Vertragsverwaltung Reference
Vertragsverwaltung
CollapseAll image

Generated by VBdocman .NET


Vertragsverwaltung Namespace

Vertragsverwaltung Namespace
collapseAll image DropDown image

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Classes

 | Name | Description
Supported by the .NET Compact Framework. | MyGenericEventHandler |
Supported by the .NET Compact Framework. | clsResizeControl |
Internal (Friend) class Supported by the .NET Compact Framework. | Crypto |
Internal (Friend) class Supported by the .NET Compact Framework. | Globals |
Top

Expand image Forms

 | Name | Description
Supported by the .NET Compact Framework. | form1 |
Supported by the .NET Compact Framework. | frmDatenbankauswahl | Form für die Datenbankauswahl
Supported by the .NET Compact Framework. | frmDokument |
Supported by the .NET Compact Framework. | frmDomainEditor | Form mit generalisiertem Domain-Table-Editor.
Supported by the .NET Compact Framework. | frmFormSelector |
Supported by the .NET Compact Framework. | frmKuendigungsfrist | Person
Supported by the .NET Compact Framework. | frmLogin | Form für den Login. Wird nur angezeigt, sofern in der Tabelle Application Show-Login = true
Supported by the .NET Compact Framework. | frmMain | Hauptformular der Vertragsverwaltung als MDI-Container
Supported by the .NET Compact Framework. | frmPerson | Person
Supported by the .NET Compact Framework. | frmSLAKatalog | SLAKatalog-Verwaltung
Supported by the .NET Compact Framework. | frmServicekatalog | Servicekatalog-Verwaltung
Supported by the .NET Compact Framework. | frmSpaltenDarstellung |
Supported by the .NET Compact Framework. | frmSysadminMenu |
Supported by the .NET Compact Framework. | frmSysadminTableSelector |
Supported by the .NET Compact Framework. | frmVerbindungEditor | Verbindungseditor: Verbindet 2 Domain-Tables in einer dritten Tabelle.
Supported by the .NET Compact Framework. | frmVertragselement |
Supported by the .NET Compact Framework. | frmVertragselementSuche | Vertragselementsuche
Supported by the .NET Compact Framework. | frmVertragskontakt |
Supported by the .NET Compact Framework. | frmVertragspartner | Vertragsaprtner
Supported by the .NET Compact Framework. | frmVertragspartnerSuche | Vertragspartnersuche
Supported by the .NET Compact Framework. | frmVertragsuebersicht |
Top

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0


MyGenericEventHandler Class

MyGenericEventHandler Class
Members
collapseAll image DropDown image

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class MyGenericEventHandler
C#
public class MyGenericEventHandler
C++

public ref class MyGenericEventHandler
JScript
public class MyGenericEventHandler

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.MyGenericEventHandler

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyGenericEventHandler Members


MyGenericEventHandler Members

MyGenericEventHandler Members
See Also Events Methods
CollapseAll image DropDown image

The following tables list the members exposed by the MyGenericEventHandler type.

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Vertragselement_Closed |
Supported by the .NET Compact Framework. | Vertragspartner_Closed |
Top

Expand image Public Events

 | Name | Description
Supported by the .NET Compact Framework. | FormularVertragelement_Closed |
Supported by the .NET Compact Framework. | FormularVertragspartner_Closed |
Top

Expand image See Also

Reference

MyGenericEventHandler Class


MyGenericEventHandler Methods

MyGenericEventHandler Methods
See Also
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Vertragselement_Closed |
Supported by the .NET Compact Framework. | Vertragspartner_Closed |
Top

Expand image See Also

Reference

MyGenericEventHandler Class


MyGenericEventHandler.Vertragselement_Closed Method

MyGenericEventHandler.Vertragselement_Closed Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Vertragselement_Closed( _
   ByVal Vertragspartnernr As Integer, _
   ByVal Vertragselementnr As Integer _
) As Object
C#
public object Vertragselement_Closed(
   int Vertragspartnernr,
   int Vertragselementnr
);
C++

public:
object^ Vertragselement_Closed(
   int Vertragspartnernr,
   int Vertragselementnr
)
JScript
public function Vertragselement_Closed(
    Vertragspartnernr : int,
    Vertragselementnr : int
) : object;

Parameters

Vertragspartnernr

Vertragselementnr

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Function Vertragselement_Closed(ByVal Vertragspartnernr As Integer, ByVal Vertragselementnr As Integer)
        RaiseEvent FormularVertragelement_Closed(Vertragspartnernr, Vertragselementnr)
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyGenericEventHandler Class
MyGenericEventHandler Members


MyGenericEventHandler.Vertragspartner_Closed Method

MyGenericEventHandler.Vertragspartner_Closed Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Vertragspartner_Closed( _
   ByVal Vertragspartnernr As Integer _
) As Object
C#
public object Vertragspartner_Closed(
   int Vertragspartnernr
);
C++

public:
object^ Vertragspartner_Closed(
   int Vertragspartnernr
)
JScript
public function Vertragspartner_Closed(
    Vertragspartnernr : int
) : object;

Parameters

Vertragspartnernr

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Function Vertragspartner_Closed(ByVal Vertragspartnernr As Integer)
        RaiseEvent FormularVertragspartner_Closed(Vertragspartnernr)
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyGenericEventHandler Class
MyGenericEventHandler Members


MyGenericEventHandler Events

MyGenericEventHandler Events
CollapseAll image DropDown image

Expand image Public Events

 | Name | Description
Supported by the .NET Compact Framework. | FormularVertragelement_Closed |
Supported by the .NET Compact Framework. | FormularVertragspartner_Closed |
Top

Expand image See Also

Reference

MyGenericEventHandler Class


FormularVertragelement_Closed Event

FormularVertragelement_Closed Event

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Event FormularVertragelement_Closed( _
   ByVal Vertragspartnernr As Integer, _
   ByVal Vertragselementnr As Integer _
)
C#
public event FormularVertragelement_ClosedEventHandler FormularVertragelement_Closed;
delegate void FormularVertragelement_ClosedEventHandler(
   int Vertragspartnernr,
   int Vertragselementnr
)
C++
public:
event FormularVertragelement_ClosedEventHandler^ FormularVertragelement_Closed {
   void add (FormularVertragelement_ClosedEventHandler^ value);
   void remove (FormularVertragelement_ClosedEventHandler^ value);
}
delegate void FormularVertragelement_ClosedEventHandler(
   int Vertragspartnernr,
   int Vertragselementnr
)
JScript
In JScript, you can handle the events defined by a class,
but you cannot define your own.

Parameters

Vertragspartnernr

Vertragselementnr

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Event FormularVertragelement_Closed(ByVal Vertragspartnernr As Integer, ByVal Vertragselementnr As Integer)

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyGenericEventHandler Class
MyGenericEventHandler Members


FormularVertragspartner_Closed Event

FormularVertragspartner_Closed Event

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Event FormularVertragspartner_Closed( _
   ByVal Vertragspartnernr As Integer _
)
C#
public event FormularVertragspartner_ClosedEventHandler FormularVertragspartner_Closed;
delegate void FormularVertragspartner_ClosedEventHandler(
   int Vertragspartnernr
)
C++
public:
event FormularVertragspartner_ClosedEventHandler^ FormularVertragspartner_Closed {
   void add (FormularVertragspartner_ClosedEventHandler^ value);
   void remove (FormularVertragspartner_ClosedEventHandler^ value);
}
delegate void FormularVertragspartner_ClosedEventHandler(
   int Vertragspartnernr
)
JScript
In JScript, you can handle the events defined by a class,
but you cannot define your own.

Parameters

Vertragspartnernr

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Event FormularVertragspartner_Closed(ByVal Vertragspartnernr As Integer)

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyGenericEventHandler Class
MyGenericEventHandler Members


clsResizeControl Class

clsResizeControl Class
Members
collapseAll image DropDown image

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsResizeControl
C#
public class clsResizeControl
C++

public ref class clsResizeControl
JScript
public class clsResizeControl

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.clsResizeControl

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsResizeControl Members


clsResizeControl Members

clsResizeControl Members
See Also Constructors Methods
CollapseAll image DropDown image

The following tables list the members exposed by the clsResizeControl type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsResizeControl Constructor |
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Finish | Diese Routine muss aufgerufen werden wenn man die Resize-Funktionalität vom Control entfernen möchte.
Supported by the .NET Compact Framework. | Paint |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | ControlMouseDown |
Supported by the .NET Compact Framework. | ControlMouseMove |
Supported by the .NET Compact Framework. | ControlMouseUp |
Supported by the .NET Compact Framework. | GetCurrIndex |
Supported by the .NET Compact Framework. | GrabRectMouseClick |
Supported by the .NET Compact Framework. | GrabRectMouseDown |
Supported by the .NET Compact Framework. | GrabRectMouseMove |
Supported by the .NET Compact Framework. | GrabRectMouseUp |
Supported by the .NET Compact Framework. | GrabRectMove |
Supported by the .NET Compact Framework. | GrabRectPaint |
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | GRS |
Supported by the .NET Compact Framework. | GrabRectColor |
Supported by the .NET Compact Framework. | GrabRects |
Supported by the .NET Compact Framework. | InResizeMode |
Supported by the .NET Compact Framework. | LastMousePos |
Supported by the .NET Compact Framework. | MoveControl |
Supported by the .NET Compact Framework. | mMinHeigth |
Supported by the .NET Compact Framework. | mMinWidth |
Top

Expand image See Also

Reference

clsResizeControl Class


clsResizeControl Constructor

clsResizeControl Constructor

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal NewControl As Control, _
   ByVal OwnerForm As Form _
)
C#
public System.Void clsResizeControl(
   Control NewControl,
   Form OwnerForm
);
C++

public:
System::Void clsResizeControl(
   Control^ NewControl,
   Form^ OwnerForm
)
JScript
public function clsResizeControl(
    NewControl : Control,
    OwnerForm : Form
);

Parameters

NewControl

OwnerForm

Expand image Source code

Visual Basic CopyCode image Copy Code
    Sub New(ByVal NewControl As Control, ByVal OwnerForm As Form)
        mControl = NewControl
        mOwnerForm = OwnerForm

        AddHandler mOwnerForm.Paint, AddressOf Paint

        AddHandler mControl.MouseDown, AddressOf ControlMouseDown
        AddHandler mControl.MouseMove, AddressOf ControlMouseMove
        AddHandler mControl.MouseUp, AddressOf ControlMouseUp

        mControl.Cursor = Cursors.SizeAll

        For i As Integer = 0 To GrabRects.Length - 1
            AddHandler GrabRects(i).Paint, AddressOf GrabRectPaint
            AddHandler GrabRects(i).MouseClick, AddressOf GrabRectMouseClick
            AddHandler GrabRects(i).MouseMove, AddressOf GrabRectMouseMove
            AddHandler GrabRects(i).MouseDown, AddressOf GrabRectMouseDown
            AddHandler GrabRects(i).MouseUp, AddressOf GrabRectMouseUp
            AddHandler GrabRects(i).Move, AddressOf GrabRectMove
        Next

        mOwnerForm.Refresh()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsResizeControl Class
clsResizeControl Members


clsResizeControl Methods

clsResizeControl Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Finish | Diese Routine muss aufgerufen werden wenn man die Resize-Funktionalität vom Control entfernen möchte.
Supported by the .NET Compact Framework. | Paint |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | ControlMouseDown |
Supported by the .NET Compact Framework. | ControlMouseMove |
Supported by the .NET Compact Framework. | ControlMouseUp |
Supported by the .NET Compact Framework. | GetCurrIndex |
Supported by the .NET Compact Framework. | GrabRectMouseClick |
Supported by the .NET Compact Framework. | GrabRectMouseDown |
Supported by the .NET Compact Framework. | GrabRectMouseMove |
Supported by the .NET Compact Framework. | GrabRectMouseUp |
Supported by the .NET Compact Framework. | GrabRectMove |
Supported by the .NET Compact Framework. | GrabRectPaint |
Top

Expand image See Also

Reference

clsResizeControl Class


clsResizeControl.ControlMouseDown Method

clsResizeControl.ControlMouseDown Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub ControlMouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)
C#
private System.Void ControlMouseDown(
   object sender,
   MouseEventArgs e
);
C++

private:
System::Void ControlMouseDown(
   object^ sender,
   MouseEventArgs^ e
)
JScript
private function ControlMouseDown(
    sender : object,
    e : MouseEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub ControlMouseDown(ByVal sender As Object, ByVal e As MouseEventArgs)
        MoveControl = True
        LastMousePos = New Point(e.X, e.Y)

        For i As Integer = 0 To GrabRects.Length - 1
            GrabRects(i).Visible = False
        Next
        mOwnerForm.Refresh()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsResizeControl Class
clsResizeControl Members


clsResizeControl.ControlMouseMove Method

clsResizeControl.ControlMouseMove Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub ControlMouseMove( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)
C#
private System.Void ControlMouseMove(
   object sender,
   MouseEventArgs e
);
C++

private:
System::Void ControlMouseMove(
   object^ sender,
   MouseEventArgs^ e
)
JScript
private function ControlMouseMove(
    sender : object,
    e : MouseEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub ControlMouseMove(ByVal sender As Object, ByVal e As MouseEventArgs)
        If MoveControl = True Then
            mControl.Left = mControl.Left + e.X - LastMousePos.X
            mControl.Top = mControl.Top + e.Y - LastMousePos.Y
            mOwnerForm.Refresh()
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsResizeControl Class
clsResizeControl Members


clsResizeControl.ControlMouseUp Method

clsResizeControl.ControlMouseUp Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub ControlMouseUp( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)
C#
private System.Void ControlMouseUp(
   object sender,
   MouseEventArgs e
);
C++

private:
System::Void ControlMouseUp(
   object^ sender,
   MouseEventArgs^ e
)
JScript
private function ControlMouseUp(
    sender : object,
    e : MouseEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub ControlMouseUp(ByVal sender As Object, ByVal e As MouseEventArgs)
        MoveControl = False

        For i As Integer = 0 To GrabRects.Length - 1
            GrabRects(i).Visible = True
        Next
        mOwnerForm.Refresh()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsResizeControl Class
clsResizeControl Members


clsResizeControl.Finish Method

clsResizeControl.Finish Method

Diese Routine muss aufgerufen werden wenn man die Resize-Funktionalität vom Control entfernen möchte.
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Finish()
C#
public System.Void Finish();
C++

public:
System::Void Finish()
JScript
public function Finish();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Sub Finish()
        RemoveHandler mOwnerForm.Paint, AddressOf Paint

        RemoveHandler mControl.MouseDown, AddressOf ControlMouseDown
        RemoveHandler mControl.MouseMove, AddressOf ControlMouseMove
        RemoveHandler mControl.MouseUp, AddressOf ControlMouseUp

        For i As Integer = 0 To GrabRects.Length - 1
            RemoveHandler GrabRects(i).Paint, AddressOf GrabRectPaint
            RemoveHandler GrabRects(i).MouseClick, AddressOf GrabRectMouseClick
            RemoveHandler GrabRects(i).MouseMove, AddressOf GrabRectMouseMove
            RemoveHandler GrabRects(i).MouseDown, AddressOf GrabRectMouseDown
            RemoveHandler GrabRects(i).MouseUp, AddressOf GrabRectMouseUp
            RemoveHandler GrabRects(i).Move, AddressOf GrabRectMove

            GrabRects(i).Dispose()
        Next

        GrabRects = Nothing

        mOwnerForm.Refresh()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsResizeControl Class
clsResizeControl Members


clsResizeControl.GetCurrIndex Method

clsResizeControl.GetCurrIndex Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function GetCurrIndex( _
   ByVal sender As Object _
) As Integer
C#
private int GetCurrIndex(
   object sender
);
C++

private:
int GetCurrIndex(
   object^ sender
)
JScript
private function GetCurrIndex(
    sender : object
) : int;

Parameters

sender

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Function GetCurrIndex(ByVal sender As Object) As Integer
        Dim CurrControl As Control = CType(sender, Control)
        For i As Integer = 0 To GrabRects.Length
            If GrabRects(i) Is CurrControl Then
                Return i
            End If
        Next
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsResizeControl Class
clsResizeControl Members


clsResizeControl.GrabRectMouseClick Method

clsResizeControl.GrabRectMouseClick Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub GrabRectMouseClick( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)
C#
private System.Void GrabRectMouseClick(
   object sender,
   MouseEventArgs e
);
C++

private:
System::Void GrabRectMouseClick(
   object^ sender,
   MouseEventArgs^ e
)
JScript
private function GrabRectMouseClick(
    sender : object,
    e : MouseEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub GrabRectMouseClick(ByVal sender As Object, ByVal e As MouseEventArgs)
        Dim CurrControl As Control = CType(sender, Control)
        Dim Index As Integer = GetCurrIndex(sender)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsResizeControl Class
clsResizeControl Members


clsResizeControl.GrabRectMouseDown Method

clsResizeControl.GrabRectMouseDown Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub GrabRectMouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)
C#
private System.Void GrabRectMouseDown(
   object sender,
   MouseEventArgs e
);
C++

private:
System::Void GrabRectMouseDown(
   object^ sender,
   MouseEventArgs^ e
)
JScript
private function GrabRectMouseDown(
    sender : object,
    e : MouseEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub GrabRectMouseDown(ByVal sender As Object, ByVal e As MouseEventArgs)
        InResizeMode = True
        For i As Integer = 0 To GrabRects.Length - 1
            GrabRects(i).Visible = False
        Next
        mOwnerForm.Refresh()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsResizeControl Class
clsResizeControl Members


clsResizeControl.GrabRectMouseMove Method

clsResizeControl.GrabRectMouseMove Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub GrabRectMouseMove( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)
C#
private System.Void GrabRectMouseMove(
   object sender,
   MouseEventArgs e
);
C++

private:
System::Void GrabRectMouseMove(
   object^ sender,
   MouseEventArgs^ e
)
JScript
private function GrabRectMouseMove(
    sender : object,
    e : MouseEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub GrabRectMouseMove(ByVal sender As Object, ByVal e As MouseEventArgs)
        Dim CurrControl As Control = CType(sender, Control)
        Dim Index As Integer = GetCurrIndex(sender)
        Dim MousePos As Point
        Static Right As Integer
        Static Bottom As Integer

        Select Case Index
            Case 0 : CurrControl.Cursor = Cursors.SizeNWSE
            Case 1 : CurrControl.Cursor = Cursors.SizeNS
            Case 2 : CurrControl.Cursor = Cursors.SizeNESW

            Case 3 : CurrControl.Cursor = Cursors.SizeWE
            Case 4 : CurrControl.Cursor = Cursors.SizeWE

            Case 5 : CurrControl.Cursor = Cursors.SizeNESW
            Case 6 : CurrControl.Cursor = Cursors.SizeNS
            Case 7 : CurrControl.Cursor = Cursors.SizeNWSE
        End Select

        If InResizeMode = True Then
            MousePos = mOwnerForm.PointToClient(Cursor.Position)
            CurrControl.Left = mOwnerForm.PointToClient(Cursor.Position).X 'CurrControl.Left + e.X
            CurrControl.Top = mOwnerForm.PointToClient(Cursor.Position).Y 'CurrControl.Top + e.Y

            Dim TmpHeigth As Integer
            Dim TmpWidth As Integer

            Select Case Index
                Case 0 'TopLeft GrabButton

                Case 1 'TopMiddle GrabButton

                Case 2 'TopRight GrabButton

                Case 3 'MiddleLeft GrabButton

                Case 4 'MiddleRight GrabButton
                    TmpWidth = GrabRects(4).Left - mControl.Left
                    If TmpWidth < mMinWidth Then TmpWidth = mMinWidth
                    mControl.Width = TmpWidth

                Case 5 'BottomLeft GrabButton

                Case 6 'BottomMiddle GrabButton
                    TmpHeigth = CurrControl.Top - mControl.Top
                    If TmpHeigth < mMinHeigth Then TmpHeigth = mMinHeigth
                    mControl.Height = TmpHeigth

                Case 7 'BottomRight GrabButton
                    TmpHeigth = CurrControl.Top - mControl.Top
                    TmpWidth = CurrControl.Left - mControl.Left

                    If TmpHeigth < mMinHeigth Then TmpHeigth = mMinHeigth
                    If TmpWidth < mMinWidth Then TmpWidth = mMinWidth

                    mControl.Size = New Size(TmpWidth, TmpHeigth)
            End Select
            mOwnerForm.Refresh()
        Else
            Right = mControl.Right
            Bottom = mControl.Bottom
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsResizeControl Class
clsResizeControl Members


clsResizeControl.GrabRectMouseUp Method

clsResizeControl.GrabRectMouseUp Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub GrabRectMouseUp( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)
C#
private System.Void GrabRectMouseUp(
   object sender,
   MouseEventArgs e
);
C++

private:
System::Void GrabRectMouseUp(
   object^ sender,
   MouseEventArgs^ e
)
JScript
private function GrabRectMouseUp(
    sender : object,
    e : MouseEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub GrabRectMouseUp(ByVal sender As Object, ByVal e As MouseEventArgs)
        InResizeMode = False
        For i As Integer = 0 To GrabRects.Length - 1
            GrabRects(i).Visible = True
        Next
        mOwnerForm.Refresh()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsResizeControl Class
clsResizeControl Members


clsResizeControl.GrabRectMove Method

clsResizeControl.GrabRectMove Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub GrabRectMove( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
private System.Void GrabRectMove(
   object sender,
   EventArgs e
);
C++

private:
System::Void GrabRectMove(
   object^ sender,
   EventArgs^ e
)
JScript
private function GrabRectMove(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub GrabRectMove(ByVal sender As Object, ByVal e As System.EventArgs)
        Dim CurrControl As Control = CType(sender, Control)
        Dim Index As Integer = GetCurrIndex(sender)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsResizeControl Class
clsResizeControl Members


clsResizeControl.GrabRectPaint Method

clsResizeControl.GrabRectPaint Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub GrabRectPaint( _
   ByVal sender As Object, _
   ByVal e As PaintEventArgs _
)
C#
private System.Void GrabRectPaint(
   object sender,
   PaintEventArgs e
);
C++

private:
System::Void GrabRectPaint(
   object^ sender,
   PaintEventArgs^ e
)
JScript
private function GrabRectPaint(
    sender : object,
    e : PaintEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub GrabRectPaint(ByVal sender As Object, ByVal e As PaintEventArgs)
        e.Graphics.DrawRectangle(Pens.Black, New Rectangle(0, 0, GRS - 1, GRS - 1))
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsResizeControl Class
clsResizeControl Members


clsResizeControl.Paint Method

clsResizeControl.Paint Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Paint( _
   ByVal sender As Object, _
   ByVal e As PaintEventArgs _
)
C#
public System.Void Paint(
   object sender,
   PaintEventArgs e
);
C++

public:
System::Void Paint(
   object^ sender,
   PaintEventArgs^ e
)
JScript
public function Paint(
    sender : object,
    e : PaintEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Sub Paint(ByVal sender As Object, ByVal e As PaintEventArgs)
        If InResizeMode = True Or MoveControl = True Then Exit Sub
        With e.Graphics
            'Rahmen
            .DrawRectangle(Pens.Gray, New Rectangle( _
            mControl.Location.X - (GRS / 2), _
            mControl.Location.Y - (GRS / 2), _
            mControl.Width + GRS, _
            mControl.Height + GRS))

            'Positionen für die GrabRects in der Reihenfolge:
            'TopLeft, TopMiddle, TopRight, MiddleLeft, MiddleRight, BottomLeft,BottomMiddle,BottomRight
            Dim GrabRectPos() As Point = { _
            New Point(mControl.Location.X - GRS, mControl.Location.Y - GRS), _
            New Point(mControl.Location.X + (mControl.Width / 2) - (GRS / 2), mControl.Location.Y - GRS), _
            New Point(mControl.Location.X + mControl.Width, mControl.Location.Y - GRS), _
            New Point(mControl.Location.X - GRS, mControl.Location.Y + (mControl.Height / 2) - (GRS / 2)), _
            New Point(mControl.Location.X + (mControl.Width), mControl.Location.Y + (mControl.Height / 2) - (GRS / 2)), _
            New Point(mControl.Location.X - GRS, mControl.Location.Y + (mControl.Height)), _
            New Point(mControl.Location.X + (mControl.Width / 2) - (GRS / 2), mControl.Location.Y + (mControl.Height)), _
            New Point(mControl.Location.X + mControl.Width, mControl.Location.Y + (mControl.Height))}

            For i As Integer = 0 To GrabRects.Length - 1
                GrabRects(i).Location = GrabRectPos(i)
                GrabRects(i).Size = New Size(GRS, GRS)
                GrabRects(i).BackColor = Color.White
                GrabRects(i).Parent = mOwnerForm
            Next

            GrabRects(4).BackColor = GrabRectColor
            GrabRects(6).BackColor = GrabRectColor
            GrabRects(7).BackColor = GrabRectColor
        End With
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsResizeControl Class
clsResizeControl Members


clsResizeControl Fields

clsResizeControl Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | GRS |
Supported by the .NET Compact Framework. | GrabRectColor |
Supported by the .NET Compact Framework. | GrabRects |
Supported by the .NET Compact Framework. | InResizeMode |
Supported by the .NET Compact Framework. | LastMousePos |
Supported by the .NET Compact Framework. | MoveControl |
Supported by the .NET Compact Framework. | mMinHeigth |
Supported by the .NET Compact Framework. | mMinWidth |
Top

Expand image See Also

Reference

clsResizeControl Class


GRS Variable

GRS Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private GRS As Integer
C#
private int GRS;
C++
private:
int GRS;
JScript
private GRS : int

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private GRS As Integer = 6

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsResizeControl Class
clsResizeControl Members


GrabRectColor Variable

GrabRectColor Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public GrabRectColor As Color
C#
public Color GrabRectColor;
C++
public:
Color GrabRectColor;
JScript
public GrabRectColor : Color

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public GrabRectColor As Color = Color.Yellow

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsResizeControl Class
clsResizeControl Members


GrabRects Variable

GrabRects Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private GrabRects As Control()
C#
private Control[] GrabRects;
C++
private:
array< Control^ >^ GrabRects;
JScript
private GrabRects : Control[]

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private GrabRects() As Control = { _
        New Control, _
        New Control, _
        New Control, _
        New Control, _
        New Control, _
        New Control, _
        New Control, _
        New Control}

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsResizeControl Class
clsResizeControl Members


InResizeMode Variable

InResizeMode Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private InResizeMode As Boolean
C#
private bool InResizeMode;
C++
private:
bool InResizeMode;
JScript
private InResizeMode : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private InResizeMode As Boolean = False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsResizeControl Class
clsResizeControl Members


LastMousePos Variable

LastMousePos Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private LastMousePos As Point
C#
private Point LastMousePos;
C++
private:
Point LastMousePos;
JScript
private LastMousePos : Point

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private LastMousePos As Point

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsResizeControl Class
clsResizeControl Members


MoveControl Variable

MoveControl Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private MoveControl As Boolean
C#
private bool MoveControl;
C++
private:
bool MoveControl;
JScript
private MoveControl : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private MoveControl As Boolean = False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsResizeControl Class
clsResizeControl Members


mMinHeigth Variable

mMinHeigth Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private mMinHeigth As Integer
C#
private int mMinHeigth;
C++
private:
int mMinHeigth;
JScript
private mMinHeigth : int

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private mMinHeigth As Integer = 20

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsResizeControl Class
clsResizeControl Members


mMinWidth Variable

mMinWidth Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private mMinWidth As Integer
C#
private int mMinWidth;
C++
private:
int mMinWidth;
JScript
private mMinWidth : int

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private mMinWidth As Integer = 20

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsResizeControl Class
clsResizeControl Members


form1 Class

form1 Class
Members
collapseAll image DropDown image

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class form1
    Inherits Form
C#
public class form1 : Form
C++

public ref class form1 : public Form^
JScript
public class form1
   extends Form

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.form1

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

form1 Members


form1 Members

form1 Members
See Also Methods
CollapseAll image DropDown image

The following tables list the members exposed by the form1 type.

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | saveasbitmap |
Top

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | BitBlt |
Supported by the .NET Compact Framework. | GetFormImage |
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | TSBtnDelete_Click |
Supported by the .NET Compact Framework. | TSBtnSave_Click |
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | p |
Supported by the .NET Compact Framework. | p2 |
Supported by the .NET Compact Framework. | r |
Supported by the .NET Compact Framework. | t |
Top

Expand image See Also

Reference

form1 Class


form1 Methods

form1 Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | saveasbitmap |
Top

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | BitBlt |
Supported by the .NET Compact Framework. | GetFormImage |
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | TSBtnDelete_Click |
Supported by the .NET Compact Framework. | TSBtnSave_Click |
Top

Expand image See Also

Reference

form1 Class


form1.BitBlt Method

form1.BitBlt Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Declare Auto Function BitBlt Lib "gdi32.dll" ( _
   ByVal hdcDest As IntPtr, _
   ByVal nXDest As Integer, _
   ByVal nYDest As Integer, _
   ByVal nWidth As Integer, _
   ByVal nHeight As Integer, _
   ByVal hdcSrc As IntPtr, _
   ByVal nXSrc As Integer, _
   ByVal nYSrc As Integer, _
   ByVal dwRop As Integer _
) As Boolean
C#
[DllImport("gdi32.dll")]
private static extern bool BitBlt(
   IntPtr hdcDest,
   int nXDest,
   int nYDest,
   int nWidth,
   int nHeight,
   IntPtr hdcSrc,
   int nXSrc,
   int nYSrc,
   int dwRop
);
C++
[DllImport("gdi32.dll")]
private:
extern bool BitBlt(
   IntPtr hdcDest,
   int nXDest,
   int nYDest,
   int nWidth,
   int nHeight,
   IntPtr hdcSrc,
   int nXSrc,
   int nYSrc,
   int dwRop
) static
JScript
In JScript, you cannot define your own external method with DllImport.

Parameters

hdcDest

nXDest

nYDest

nWidth

nHeight

hdcSrc

nXSrc

nYSrc

dwRop

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Declare Auto Function BitBlt Lib "gdi32.dll" (ByVal _
        hdcDest As IntPtr, ByVal nXDest As Integer, ByVal _
        nYDest As Integer, ByVal nWidth As Integer, ByVal _
        nHeight As Integer, ByVal hdcSrc As IntPtr, ByVal nXSrc _
        As Integer, ByVal nYSrc As Integer, ByVal dwRop As _
        System.Int32) As Boolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

form1 Class
form1 Members


form1.Dispose Method

form1.Dispose Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
C#
[System.Diagnostics.DebuggerNonUserCode()]
protected override System.Void Dispose(
   bool disposing
);
C++
[System.Diagnostics.DebuggerNonUserCode()]

protected:
System::Void Dispose(
   bool disposing
)
JScript
protected
   System.Diagnostics.DebuggerNonUserCode()
function Dispose(
    disposing : boolean
);

Parameters

disposing

Expand image Source code

Visual Basic CopyCode image Copy Code
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

form1 Class
form1 Members


form1.GetFormImage Method

form1.GetFormImage Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function GetFormImage() As Bitmap
C#
private Bitmap GetFormImage();
C++

private:
Bitmap^ GetFormImage()
JScript
private function GetFormImage() : Bitmap;

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Function GetFormImage() As Bitmap
        ' Get this form's Graphics object.
        Dim me_gr As Graphics = Me.CreateGraphics

        ' Make a Bitmap to hold the image.
        Dim bm As New Bitmap(Me.Width, _
            Me.Height, me_gr)
        Dim bm_gr As Graphics = me_gr.FromImage(bm)
        Dim bm_hdc As IntPtr = bm_gr.GetHdc

        ' Get the form's hDC. We must do this after
        ' creating the new Bitmap, which uses me_gr.
        Dim me_hdc As IntPtr = me_gr.GetHdc

        ' BitBlt the form's image onto the Bitmap.
        BitBlt(bm_hdc, 0, 0, Me.Width, _
            Me.Height, _
            me_hdc, 0, 0, SRCCOPY)
        me_gr.ReleaseHdc(me_hdc)
        bm_gr.ReleaseHdc(bm_hdc)

        ' Return the result.
        Return bm
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

form1 Class
form1 Members


form1.InitializeComponent Method

form1.InitializeComponent Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()
C#
[System.Diagnostics.DebuggerStepThrough()]
private System.Void InitializeComponent();
C++
[System.Diagnostics.DebuggerStepThrough()]

private:
System::Void InitializeComponent()
JScript
private
   System.Diagnostics.DebuggerStepThrough()
function InitializeComponent();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(form1))
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnCopy = New System.Windows.Forms.ToolStripButton
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.C1Kontakte = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        CType(Me.C1Kontakte, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "ToolStripButton1"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 25)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(711, 24)
        Me.MenuStrip1.TabIndex = 5
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(127, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnCopy
        '
        Me.TSBtnCopy.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnCopy.Image = CType(resources.GetObject("TSBtnCopy.Image"), System.Drawing.Image)
        Me.TSBtnCopy.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnCopy.Name = "TSBtnCopy"
        Me.TSBtnCopy.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnCopy.Text = "ToolStripButton2"
        Me.TSBtnCopy.ToolTipText = "Datensatz kopieren"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnCopy, Me.TSBtnNew, Me.TSBtnDelete})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 0)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(711, 25)
        Me.ToolStrip1.TabIndex = 4
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "ToolStripButton3"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "ToolStripButton3"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'C1Kontakte
        '
        Me.C1Kontakte.AlternatingRows = True
        Me.C1Kontakte.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Kontakte.FilterBar = True
        Me.C1Kontakte.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Kontakte.Images.Add(CType(resources.GetObject("C1Kontakte.Images"), System.Drawing.Image))
        Me.C1Kontakte.Location = New System.Drawing.Point(0, 49)
        Me.C1Kontakte.Name = "C1Kontakte"
        Me.C1Kontakte.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Kontakte.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Kontakte.PreviewInfo.ZoomFactor = 75
        Me.C1Kontakte.PrintInfo.PageSettings = CType(resources.GetObject("C1Kontakte.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Kontakte.Size = New System.Drawing.Size(711, 509)
        Me.C1Kontakte.TabIndex = 6
        Me.C1Kontakte.Text = "C1TrueDBGrid1"
        Me.C1Kontakte.PropBag = resources.GetString("C1Kontakte.PropBag")
        '
        'Form1
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(711, 558)
        Me.Controls.Add(Me.C1Kontakte)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Name = "Form1"
        Me.Text = "Form1"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        CType(Me.C1Kontakte, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

form1 Class
form1 Members


form1.TSBtnDelete_Click Method

form1.TSBtnDelete_Click Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click
C#
private System.Void TSBtnDelete_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnDelete_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnDelete_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
        saveasbitmap(Me.C1Kontakte)
        t.Y = Me.MenuStrip1.Top
        t.X = Me.MenuStrip1.Left
        t.Width = Me.MenuStrip1.Width
        t.Height = Me.MenuStrip1.Height

        Dim b As New Bitmap(t.Width, t.Height)
        Me.DrawToBitmap(b, t)
        b.Save("c:\temp\menustrip1.bmp")

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

form1 Class
form1 Members


form1.TSBtnSave_Click Method

form1.TSBtnSave_Click Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click
C#
private System.Void TSBtnSave_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnSave_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnSave_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Dim bm As Bitmap = GetFormImage()
        bm.Save("c:\temp\test.bmp", System.Drawing.Imaging.ImageFormat.Bmp)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

form1 Class
form1 Members


form1.saveasbitmap Method

form1.saveasbitmap Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function saveasbitmap( _
   ByRef ctl As Control _
) As Object
C#
public object saveasbitmap(
   ref Control ctl
);
C++

public:
object^ saveasbitmap(
   Control^& ctl
)
JScript
public function saveasbitmap(
    ctl : Control
) : object;

Parameters

ctl

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Function saveasbitmap(ByRef ctl As Control)
        Dim g As Graphics = ctl.CreateGraphics
        Dim b As New Bitmap(ctl.Width, ctl.Height)
        ctl.DrawToBitmap(b, New Rectangle(0, 0, ctl.Width, ctl.Height))
        b.Save("c:\temp\test.bmp", System.Drawing.Imaging.ImageFormat.Bmp)
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

form1 Class
form1 Members


form1 Fields

form1 Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | p |
Supported by the .NET Compact Framework. | p2 |
Supported by the .NET Compact Framework. | r |
Supported by the .NET Compact Framework. | t |
Top

Expand image See Also

Reference

form1 Class


components Variable

components Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private components As IContainer
C#
private IContainer components;
C++
private:
IContainer^ components;
JScript
private components : IContainer

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private components As System.ComponentModel.IContainer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

form1 Class
form1 Members


p Variable

p Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private p As Point
C#
private Point p;
C++
private:
Point p;
JScript
private p : Point

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim p As New Point

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

form1 Class
form1 Members


p2 Variable

p2 Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private p2 As Point
C#
private Point p2;
C++
private:
Point p2;
JScript
private p2 : Point

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim p2 As New Point

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

form1 Class
form1 Members


r Variable

r Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private r As Rectangle
C#
private Rectangle r;
C++
private:
Rectangle r;
JScript
private r : Rectangle

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim r As New System.Drawing.Rectangle

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

form1 Class
form1 Members


t Variable

t Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private t As Rectangle
C#
private Rectangle t;
C++
private:
Rectangle t;
JScript
private t : Rectangle

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim t As Rectangle

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

form1 Class
form1 Members


frmDatenbankauswahl Class

frmDatenbankauswahl Class
Members
collapseAll image DropDown image

Form für die Datenbankauswahl
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class frmDatenbankauswahl
    Inherits Form
C#
public class frmDatenbankauswahl : Form
C++

public ref class frmDatenbankauswahl : public Form^
JScript
public class frmDatenbankauswahl
   extends Form

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmDatenbankauswahl

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDatenbankauswahl Members


frmDatenbankauswahl Members

frmDatenbankauswahl Members
See Also Constructors Methods
CollapseAll image DropDown image

Form für die Datenbankauswahl

The following tables list the members exposed by the frmDatenbankauswahl type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | frmDatenbankauswahl Constructor |
Top

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | Button1_Click |
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | ListBox1_DoubleClick |
Supported by the .NET Compact Framework. | ListBox1_KeyDown |
Supported by the .NET Compact Framework. | frmDatenbankauswahl_Load |
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | components |
Top

Expand image See Also

Reference

frmDatenbankauswahl Class


frmDatenbankauswahl Constructor

frmDatenbankauswahl Constructor

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void frmDatenbankauswahl();
C++

public:
System::Void frmDatenbankauswahl()
JScript
public function frmDatenbankauswahl();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDatenbankauswahl Class
frmDatenbankauswahl Members


frmDatenbankauswahl Methods

frmDatenbankauswahl Methods
CollapseAll image DropDown image

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | Button1_Click |
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | ListBox1_DoubleClick |
Supported by the .NET Compact Framework. | ListBox1_KeyDown |
Supported by the .NET Compact Framework. | frmDatenbankauswahl_Load |
Top

Expand image See Also

Reference

frmDatenbankauswahl Class


frmDatenbankauswahl.Button1_Click Method

frmDatenbankauswahl.Button1_Click Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Button1_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   Button1.Click
C#
private System.Void Button1_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void Button1_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function Button1_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDatenbankauswahl Class
frmDatenbankauswahl Members


frmDatenbankauswahl.Dispose Method

frmDatenbankauswahl.Dispose Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
C#
protected override System.Void Dispose(
   bool disposing
);
C++

protected:
System::Void Dispose(
   bool disposing
)
JScript
protected function Dispose(
    disposing : boolean
);

Parameters

disposing

Expand image Source code

Visual Basic CopyCode image Copy Code
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDatenbankauswahl Class
frmDatenbankauswahl Members


frmDatenbankauswahl.InitializeComponent Method

frmDatenbankauswahl.InitializeComponent Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()
C#
[System.Diagnostics.DebuggerStepThrough()]
private System.Void InitializeComponent();
C++
[System.Diagnostics.DebuggerStepThrough()]

private:
System::Void InitializeComponent()
JScript
private
   System.Diagnostics.DebuggerStepThrough()
function InitializeComponent();

Expand image Source code

Visual Basic CopyCode image Copy Code
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmDatenbankauswahl))
        Me.ListBox1 = New System.Windows.Forms.ListBox
        Me.Button1 = New System.Windows.Forms.Button
        Me.SuspendLayout()
        '
        'ListBox1
        '
        Me.ListBox1.Location = New System.Drawing.Point(16, 16)
        Me.ListBox1.Name = "ListBox1"
        Me.ListBox1.Size = New System.Drawing.Size(232, 95)
        Me.ListBox1.TabIndex = 0
        '
        'Button1
        '
        Me.Button1.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.Button1.Location = New System.Drawing.Point(88, 128)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(75, 23)
        Me.Button1.TabIndex = 1
        Me.Button1.Text = "&OK"
        '
        'frmDatenbankauswahl
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(258, 165)
        Me.Controls.Add(Me.Button1)
        Me.Controls.Add(Me.ListBox1)
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedDialog
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.MaximizeBox = False
        Me.MinimizeBox = False
        Me.Name = "frmDatenbankauswahl"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Vertragsverwaltung: Datebbankauswahl"
        Me.ResumeLayout(False)

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDatenbankauswahl Class
frmDatenbankauswahl Members


frmDatenbankauswahl.ListBox1_DoubleClick Method

frmDatenbankauswahl.ListBox1_DoubleClick Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub ListBox1_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ListBox1.DoubleClick
C#
private System.Void ListBox1_DoubleClick(
   object sender,
   EventArgs e
);
C++

private:
System::Void ListBox1_DoubleClick(
   object^ sender,
   EventArgs^ e
)
JScript
private function ListBox1_DoubleClick(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub ListBox1_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles ListBox1.DoubleClick
        Me.Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDatenbankauswahl Class
frmDatenbankauswahl Members


frmDatenbankauswahl.ListBox1_KeyDown Method

frmDatenbankauswahl.ListBox1_KeyDown Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub ListBox1_KeyDown( _
   ByVal sender As Object, _
   ByVal e As KeyEventArgs _
) Handles  _
   ListBox1.KeyDown
C#
private System.Void ListBox1_KeyDown(
   object sender,
   KeyEventArgs e
);
C++

private:
System::Void ListBox1_KeyDown(
   object^ sender,
   KeyEventArgs^ e
)
JScript
private function ListBox1_KeyDown(
    sender : object,
    e : KeyEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub ListBox1_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles ListBox1.KeyDown
        If e.KeyCode = Keys.Enter Then Me.Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDatenbankauswahl Class
frmDatenbankauswahl Members


frmDatenbankauswahl.frmDatenbankauswahl_Load Method

frmDatenbankauswahl.frmDatenbankauswahl_Load Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub frmDatenbankauswahl_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load
C#
private System.Void frmDatenbankauswahl_Load(
   object sender,
   EventArgs e
);
C++

private:
System::Void frmDatenbankauswahl_Load(
   object^ sender,
   EventArgs^ e
)
JScript
private function frmDatenbankauswahl_Load(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub frmDatenbankauswahl_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDatenbankauswahl Class
frmDatenbankauswahl Members


frmDatenbankauswahl Fields

frmDatenbankauswahl Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | components |
Top

Expand image See Also

Reference

frmDatenbankauswahl Class


components Variable

components Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private components As IContainer
C#
private IContainer components;
C++
private:
IContainer^ components;
JScript
private components : IContainer

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private components As System.ComponentModel.IContainer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDatenbankauswahl Class
frmDatenbankauswahl Members


frmDokument Class

frmDokument Class
Members
collapseAll image DropDown image

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class frmDokument
    Inherits Form
C#
public class frmDokument : Form
C++

public ref class frmDokument : public Form^
JScript
public class frmDokument
   extends Form

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmDokument

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Members


frmDokument Members

frmDokument Members
See Also Constructors Methods
CollapseAll image DropDown image

The following tables list the members exposed by the frmDokument type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | frmDokument Constructor |
Top

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | AddChanges | Allg Eventhandler für Chanage-Ereignise festlegen
Supported by the .NET Compact Framework. | BeendenToolStripMenuItem_Click | Menu Beenden
Supported by the .NET Compact Framework. | ChangesMade | Envent-Handler für Change-Ereignisse
Supported by the .NET Compact Framework. | Check_Changes | Prüfung, ob Datenänderungen vorgenommen wurden.
Supported by the .NET Compact Framework. | FormularClosing | Schliessen des Formulars
Supported by the .NET Compact Framework. | GetControl | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
Supported by the .NET Compact Framework. | Get_Data | Daten ab DB laden uns ins Form befüllen
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | Load_Securitylevel | Laden der Securitylevel-Daten in die Combobox
Supported by the .NET Compact Framework. | Save_data | Daten ab Form speichern
Supported by the .NET Compact Framework. | TSBtnCopy_Click | Datensatz kopieren
Supported by the .NET Compact Framework. | TSBtnDelete_Click | Aktueller Datensatz inaktivieren
Supported by the .NET Compact Framework. | TSBtnNew_Click | Neuer Datensatz erstellen
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Formular schliessen
Supported by the .NET Compact Framework. | TSBtnSave_Click | Sicherungs-Button betätigt
Supported by the .NET Compact Framework. | TSBtnSuche_Click | Vertragspartner suchen
Supported by the .NET Compact Framework. | brnFileOpen_Click | Auswahl des zu speichernden Dokumentes
Supported by the .NET Compact Framework. | frmDokument_Load | Formular-Load
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | Aktuelle_Vertragselementnr |
Supported by the .NET Compact Framework. | Aktuelles_Dokument |
Supported by the .NET Compact Framework. | Anzeige |
Supported by the .NET Compact Framework. | Dokument |
Supported by the .NET Compact Framework. | FormDataChanged |
Supported by the .NET Compact Framework. | FormReadonly |
Supported by the .NET Compact Framework. | SpaltenTitel |
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | msg |
Supported by the .NET Compact Framework. | sec |
Top

Expand image See Also

Reference

frmDokument Class


frmDokument Constructor

frmDokument Constructor

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal Vertragselementnr As Integer, _
   Optional ByVal DokumentNr As Integer = -1, _
   Optional ByVal Anzeige As Boolean = False _
)
C#
public System.Void frmDokument(
   int Vertragselementnr,
   int DokumentNr,
   bool Anzeige
);
C++

public:
System::Void frmDokument(
   int Vertragselementnr,
   int DokumentNr,
   bool Anzeige
)
JScript
public function frmDokument(
    Vertragselementnr : int,
    DokumentNr : int,
    Anzeige : boolean
);

Parameters

Vertragselementnr

Required.

DokumentNr

Optionaler Parameter Dokumentnummer des aktuellen Dokuments

Anzeige

Optional. The default value is False.

Expand image Source code

Visual Basic CopyCode image Copy Code
    Sub New(ByVal Vertragselementnr As Integer, Optional ByVal DokumentNr As Integer = -1, Optional ByVal Anzeige As Boolean = False)
        Me.Aktuelles_Dokument = DokumentNr
        Me.Anzeige = Anzeige
        Me.Aktuelle_Vertragselementnr = Vertragselementnr
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


frmDokument Methods

frmDokument Methods
CollapseAll image DropDown image

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | AddChanges | Allg Eventhandler für Chanage-Ereignise festlegen
Supported by the .NET Compact Framework. | BeendenToolStripMenuItem_Click | Menu Beenden
Supported by the .NET Compact Framework. | ChangesMade | Envent-Handler für Change-Ereignisse
Supported by the .NET Compact Framework. | Check_Changes | Prüfung, ob Datenänderungen vorgenommen wurden.
Supported by the .NET Compact Framework. | FormularClosing | Schliessen des Formulars
Supported by the .NET Compact Framework. | GetControl | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
Supported by the .NET Compact Framework. | Get_Data | Daten ab DB laden uns ins Form befüllen
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | Load_Securitylevel | Laden der Securitylevel-Daten in die Combobox
Supported by the .NET Compact Framework. | Save_data | Daten ab Form speichern
Supported by the .NET Compact Framework. | TSBtnCopy_Click | Datensatz kopieren
Supported by the .NET Compact Framework. | TSBtnDelete_Click | Aktueller Datensatz inaktivieren
Supported by the .NET Compact Framework. | TSBtnNew_Click | Neuer Datensatz erstellen
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Formular schliessen
Supported by the .NET Compact Framework. | TSBtnSave_Click | Sicherungs-Button betätigt
Supported by the .NET Compact Framework. | TSBtnSuche_Click | Vertragspartner suchen
Supported by the .NET Compact Framework. | brnFileOpen_Click | Auswahl des zu speichernden Dokumentes
Supported by the .NET Compact Framework. | frmDokument_Load | Formular-Load
Top

Expand image See Also

Reference

frmDokument Class


frmDokument.AddChanges Method

frmDokument.AddChanges Method

Allg Eventhandler für Chanage-Ereignise festlegen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub AddChanges( _
   ByVal Container As Control _
)
C#
private System.Void AddChanges(
   Control Container
);
C++

private:
System::Void AddChanges(
   Control^ Container
)
JScript
private function AddChanges(
    Container : Control
);

Parameters

Container

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub AddChanges(ByVal Container As Control)
        Dim l As New List(Of Control)
        Me.GetControl(Me, "*", l)
        Dim evh As EventHandler = AddressOf ChangesMade
        For Each c As Control In l
            If TypeOf c Is TextBox Then
                Dim ctl As TextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is MaskedTextBox Then
                Dim ctl As MaskedTextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is ComboBox Then
                Dim ctl As ComboBox = c
                AddHandler ctl.SelectedValueChanged, evh
            End If
            If TypeOf c Is CheckBox Then
                Dim ctl As CheckBox = c
                AddHandler ctl.CheckedChanged, evh
            End If
        Next
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


frmDokument.BeendenToolStripMenuItem_Click Method

frmDokument.BeendenToolStripMenuItem_Click Method

Menu Beenden
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click
C#
private System.Void BeendenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void BeendenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function BeendenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.TSBtnQuit_Click(sender, e)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


frmDokument.ChangesMade Method

frmDokument.ChangesMade Method

Envent-Handler für Change-Ereignisse
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub ChangesMade( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
private System.Void ChangesMade(
   object sender,
   EventArgs e
);
C++

private:
System::Void ChangesMade(
   object^ sender,
   EventArgs^ e
)
JScript
private function ChangesMade(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub ChangesMade(ByVal sender As Object, ByVal e As System.EventArgs)
        Me.FormDataChanged = True
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


frmDokument.Check_Changes Method

frmDokument.Check_Changes Method

Prüfung, ob Datenänderungen vorgenommen wurden.
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Check_Changes() As Boolean
C#
private bool Check_Changes();
C++

private:
bool Check_Changes()
JScript
private function Check_Changes() : boolean;

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Function Check_Changes() As Boolean
        If Me.FormReadonly Then Exit Function
        Dim msgres As MsgBoxResult
        If Me.FormDataChanged Then
            msgres = msg.Show_MessageYesNoCancel(3)
            Select Case msgres
                Case MsgBoxResult.Yes
                    Save_data()
                    Return True
                Case MsgBoxResult.Cancel
                    Return False
                Case MsgBoxResult.No
                    Return True
            End Select
        End If
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


frmDokument.Dispose Method

frmDokument.Dispose Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
C#
[System.Diagnostics.DebuggerNonUserCode()]
protected override System.Void Dispose(
   bool disposing
);
C++
[System.Diagnostics.DebuggerNonUserCode()]

protected:
System::Void Dispose(
   bool disposing
)
JScript
protected
   System.Diagnostics.DebuggerNonUserCode()
function Dispose(
    disposing : boolean
);

Parameters

disposing

Expand image Source code

Visual Basic CopyCode image Copy Code
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


frmDokument.FormularClosing Method

frmDokument.FormularClosing Method

Schliessen des Formulars
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub FormularClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing
C#
private System.Void FormularClosing(
   object sender,
   FormClosingEventArgs e
);
C++

private:
System::Void FormularClosing(
   object^ sender,
   FormClosingEventArgs^ e
)
JScript
private function FormularClosing(
    sender : object,
    e : FormClosingEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub FormularClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.FormReadonly = True Then Exit Sub
        If Check_Changes() = False Then
            e.Cancel = True
        Else
            Me.Dispose()
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


frmDokument.GetControl Method

frmDokument.GetControl Method

Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function GetControl( _
   ByVal BaseControl As Control, _
   ByVal Key As String, _
   ByRef L As List(Of Control), _
   Optional ByVal ReturnAtFirstElement As Boolean = False _
) As Boolean
C#
private bool GetControl(
   Control BaseControl,
   string Key,
   ref List<Control> L,
   bool ReturnAtFirstElement
);
C++

private:
bool GetControl(
   Control^ BaseControl,
   String^ Key,
   List<Control^>^& L,
   bool ReturnAtFirstElement
)
JScript
JScript does not support generic types and methods.

Parameters

BaseControl

Base-Contrlo (z.B. aktuelles Formular

Key

Schlüssel welcher gesucht werden soll

L

Liste der gefundenen Objekte

ReturnAtFirstElement

Optional. The default value is False.

Return Value

True wenn eines oder mehr Controls gefunden wurden, false wenn kein Control gefunden wurde.

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Function GetControl(ByVal BaseControl As Control, ByVal Key As String, ByRef L As List(Of Control), Optional ByVal ReturnAtFirstElement As Boolean = False) As Boolean
        If L Is Nothing Then L = New List(Of Control)
        Dim Gut As Boolean
        Dim ReturnFlag As Boolean = False
        If Key IsNot Nothing Then Key = Key.ToLower

        If BaseControl.HasChildren = True Then
            For Each ctl As Control In BaseControl.Controls
                Gut = False
                If Key Is Nothing Then
                    Gut = True
                Else
                    If ctl.Name.Length >= Key.Length Then
                        Key = Key.ToLower
                        If Key.StartsWith("*") Then
                            If Key.Substring(1) = ctl.Name.ToLower.Substring(ctl.Name.Length - (Key.Length - 1), Key.Length - 1) Then Gut = True
                        ElseIf Key.EndsWith("*") Then
                            If Key.Substring(0, Key.Length - 1) = ctl.Name.ToLower.Substring(0, Key.Length - 1) Then Gut = True
                        Else
                            If Key = ctl.Name.ToLower Then Gut = True
                        End If
                    End If
                End If

                If Gut = True Then
                    L.Add(ctl)
                    If ReturnAtFirstElement = True Then ReturnFlag = True
                End If
                If ReturnFlag = False Then
                    Call GetControl(ctl, Key, L)
                End If
            Next
        End If

        If L.Count - 1 > -1 Then
            Return True
        Else
            Return False
        End If
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


frmDokument.Get_Data Method

frmDokument.Get_Data Method

Daten ab DB laden uns ins Form befüllen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Get_Data( _
   ByVal Vertragselementnr As Integer _
)
C#
private System.Void Get_Data(
   int Vertragselementnr
);
C++

private:
System::Void Get_Data(
   int Vertragselementnr
)
JScript
private function Get_Data(
    Vertragselementnr : int
);

Parameters

Vertragselementnr

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Get_Data(ByVal Vertragselementnr As Integer)
        Try
            Dokument.Get_Dokumenttypen()
            Me.txtBezeichnung.Text = Dokument.sBezeichnung.Value
            Me.cboxDokumenttyp.SelectedValue = Dokument.iDokumenttypNr.Value
            Me.txtBeschreibung.Text = Dokument.sBeschreibung.Value
            Me.txtVersion.Text = Dokument.sVersion.ToString
            Me.txtVersionsdatum.Text = Dokument.daVersionsdatum.ToString
            Me.txtDateiname.Text = Dokument.sFilename.Value
            Me.txtOriginalFilename_incl_path.Text = Dokument.sOriginalFilename_incl_Path.Value
            Me.txtErstellt_am.Text = Dokument.daErstellt_am.ToString
            Me.txtMutiert_am.Text = Dokument.daMutiert_am.ToString
            Me.txtMutierer.Text = Dokument.iMutierer.Value
            Try
                Me.cbaktiv.Checked = Dokument.bAktiv.Value = True

            Catch ex As Exception
                Me.cbaktiv.Checked = True
            End Try
            If Not Anzeige Then
                For Each ctl As ToolStripButton In Me.ToolStrip1.Items
                    ctl.Enabled = True
                Next
            End If
            sec.Set_Form_Security(Me)
            Me.FormDataChanged = False
        Catch ex As Exception
            For Each ctl As ToolStripButton In Me.ToolStrip1.Items
                ctl.Enabled = False
            Next
            Me.TSBtnQuit.Enabled = True
            Me.TSBtnSuche.Enabled = True
        End Try
        Me.FormDataChanged = False

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


frmDokument.InitializeComponent Method

frmDokument.InitializeComponent Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()
C#
[System.Diagnostics.DebuggerStepThrough()]
private System.Void InitializeComponent();
C++
[System.Diagnostics.DebuggerStepThrough()]

private:
System::Void InitializeComponent()
JScript
private
   System.Diagnostics.DebuggerStepThrough()
function InitializeComponent();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmDokument))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.lblBeschreibung = New System.Windows.Forms.Label
        Me.txtBeschreibung = New System.Windows.Forms.TextBox
        Me.txtMutierer = New System.Windows.Forms.TextBox
        Me.txtMutiert_am = New System.Windows.Forms.TextBox
        Me.txtErstellt_am = New System.Windows.Forms.TextBox
        Me.lblMutierer = New System.Windows.Forms.Label
        Me.lblMutiert_am = New System.Windows.Forms.Label
        Me.lblErstelltam = New System.Windows.Forms.Label
        Me.cboxSecurityLevel = New System.Windows.Forms.ComboBox
        Me.lblSecurityLebel = New System.Windows.Forms.Label
        Me.lblAktiv = New System.Windows.Forms.Label
        Me.cbaktiv = New System.Windows.Forms.CheckBox
        Me.dtPickerVersionsdatum = New System.Windows.Forms.DateTimePicker
        Me.txtVersionsdatum = New System.Windows.Forms.MaskedTextBox
        Me.lblVersionsdatum = New System.Windows.Forms.Label
        Me.txtBezeichnung = New System.Windows.Forms.TextBox
        Me.txtVersion = New System.Windows.Forms.TextBox
        Me.lblVersion = New System.Windows.Forms.Label
        Me.lblBezeichnung = New System.Windows.Forms.Label
        Me.lblDokumenttyp = New System.Windows.Forms.Label
        Me.cboxDokumenttyp = New System.Windows.Forms.ComboBox
        Me.txtFilename = New System.Windows.Forms.TextBox
        Me.lbldatei = New System.Windows.Forms.Label
        Me.OpenFileDialog1 = New System.Windows.Forms.OpenFileDialog
        Me.txtDateiname = New System.Windows.Forms.TextBox
        Me.txtOriginalFilename_incl_path = New System.Windows.Forms.TextBox
        Me.brnFileOpen = New System.Windows.Forms.Button
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.TSBtnCopy = New System.Windows.Forms.ToolStripButton
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSuche = New System.Windows.Forms.ToolStripButton
        Me.Button1 = New System.Windows.Forms.Button
        Me.lblEx = New System.Windows.Forms.Label
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(578, 24)
        Me.MenuStrip1.TabIndex = 5
        Me.MenuStrip1.Tag = ""
        Me.MenuStrip1.Text = "Hauptmenu"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Tag = ""
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(116, 22)
        Me.BeendenToolStripMenuItem.Tag = ""
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnCopy, Me.TSBtnNew, Me.TSBtnDelete, Me.TSBtnSuche})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(578, 25)
        Me.ToolStrip1.TabIndex = 6
        Me.ToolStrip1.Text = "Toolstrip Vertragspartner"
        '
        'lblBeschreibung
        '
        Me.lblBeschreibung.AccessibleDescription = "Name"
        Me.lblBeschreibung.AutoSize = True
        Me.lblBeschreibung.Location = New System.Drawing.Point(7, 118)
        Me.lblBeschreibung.Name = "lblBeschreibung"
        Me.lblBeschreibung.Size = New System.Drawing.Size(72, 13)
        Me.lblBeschreibung.TabIndex = 155
        Me.lblBeschreibung.Text = "Beschreibung"
        '
        'txtBeschreibung
        '
        Me.txtBeschreibung.Location = New System.Drawing.Point(96, 115)
        Me.txtBeschreibung.Multiline = True
        Me.txtBeschreibung.Name = "txtBeschreibung"
        Me.txtBeschreibung.Size = New System.Drawing.Size(268, 45)
        Me.txtBeschreibung.TabIndex = 154
        '
        'txtMutierer
        '
        Me.txtMutierer.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutierer.Location = New System.Drawing.Point(461, 111)
        Me.txtMutierer.Name = "txtMutierer"
        Me.txtMutierer.Size = New System.Drawing.Size(97, 20)
        Me.txtMutierer.TabIndex = 153
        '
        'txtMutiert_am
        '
        Me.txtMutiert_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutiert_am.Location = New System.Drawing.Point(461, 87)
        Me.txtMutiert_am.Name = "txtMutiert_am"
        Me.txtMutiert_am.Size = New System.Drawing.Size(97, 20)
        Me.txtMutiert_am.TabIndex = 152
        '
        'txtErstellt_am
        '
        Me.txtErstellt_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtErstellt_am.Location = New System.Drawing.Point(461, 61)
        Me.txtErstellt_am.Name = "txtErstellt_am"
        Me.txtErstellt_am.Size = New System.Drawing.Size(97, 20)
        Me.txtErstellt_am.TabIndex = 151
        '
        'lblMutierer
        '
        Me.lblMutierer.AccessibleDescription = "Name"
        Me.lblMutierer.AutoSize = True
        Me.lblMutierer.Location = New System.Drawing.Point(390, 114)
        Me.lblMutierer.Name = "lblMutierer"
        Me.lblMutierer.Size = New System.Drawing.Size(72, 13)
        Me.lblMutierer.TabIndex = 150
        Me.lblMutierer.Text = "Mutiert durch:"
        '
        'lblMutiert_am
        '
        Me.lblMutiert_am.AccessibleDescription = "Name"
        Me.lblMutiert_am.AutoSize = True
        Me.lblMutiert_am.Location = New System.Drawing.Point(391, 90)
        Me.lblMutiert_am.Name = "lblMutiert_am"
        Me.lblMutiert_am.Size = New System.Drawing.Size(59, 13)
        Me.lblMutiert_am.TabIndex = 149
        Me.lblMutiert_am.Text = "Mutiert am:"
        '
        'lblErstelltam
        '
        Me.lblErstelltam.AccessibleDescription = "Name"
        Me.lblErstelltam.AutoSize = True
        Me.lblErstelltam.Location = New System.Drawing.Point(390, 64)
        Me.lblErstelltam.Name = "lblErstelltam"
        Me.lblErstelltam.Size = New System.Drawing.Size(58, 13)
        Me.lblErstelltam.TabIndex = 148
        Me.lblErstelltam.Text = "Erstellt am:"
        '
        'cboxSecurityLevel
        '
        Me.cboxSecurityLevel.FormattingEnabled = True
        Me.cboxSecurityLevel.Location = New System.Drawing.Point(461, 165)
        Me.cboxSecurityLevel.Name = "cboxSecurityLevel"
        Me.cboxSecurityLevel.Size = New System.Drawing.Size(97, 21)
        Me.cboxSecurityLevel.TabIndex = 145
        '
        'lblSecurityLebel
        '
        Me.lblSecurityLebel.AutoSize = True
        Me.lblSecurityLebel.Location = New System.Drawing.Point(391, 168)
        Me.lblSecurityLebel.Name = "lblSecurityLebel"
        Me.lblSecurityLebel.Size = New System.Drawing.Size(71, 13)
        Me.lblSecurityLebel.TabIndex = 147
        Me.lblSecurityLebel.Text = "SecurityLevel"
        '
        'lblAktiv
        '
        Me.lblAktiv.AccessibleDescription = "Name"
        Me.lblAktiv.AutoSize = True
        Me.lblAktiv.Location = New System.Drawing.Point(391, 142)
        Me.lblAktiv.Name = "lblAktiv"
        Me.lblAktiv.Size = New System.Drawing.Size(31, 13)
        Me.lblAktiv.TabIndex = 146
        Me.lblAktiv.Text = "Aktiv"
        '
        'cbaktiv
        '
        Me.cbaktiv.AutoSize = True
        Me.cbaktiv.Location = New System.Drawing.Point(461, 142)
        Me.cbaktiv.Name = "cbaktiv"
        Me.cbaktiv.Size = New System.Drawing.Size(15, 14)
        Me.cbaktiv.TabIndex = 144
        Me.cbaktiv.UseVisualStyleBackColor = True
        '
        'dtPickerVersionsdatum
        '
        Me.dtPickerVersionsdatum.Location = New System.Drawing.Point(341, 165)
        Me.dtPickerVersionsdatum.Name = "dtPickerVersionsdatum"
        Me.dtPickerVersionsdatum.Size = New System.Drawing.Size(21, 20)
        Me.dtPickerVersionsdatum.TabIndex = 164
        '
        'txtVersionsdatum
        '
        Me.txtVersionsdatum.Location = New System.Drawing.Point(278, 165)
        Me.txtVersionsdatum.Mask = "00/00/0000"
        Me.txtVersionsdatum.Name = "txtVersionsdatum"
        Me.txtVersionsdatum.Size = New System.Drawing.Size(66, 20)
        Me.txtVersionsdatum.TabIndex = 160
        Me.txtVersionsdatum.ValidatingType = GetType(Date)
        '
        'lblVersionsdatum
        '
        Me.lblVersionsdatum.AutoSize = True
        Me.lblVersionsdatum.Location = New System.Drawing.Point(187, 168)
        Me.lblVersionsdatum.Name = "lblVersionsdatum"
        Me.lblVersionsdatum.Size = New System.Drawing.Size(76, 13)
        Me.lblVersionsdatum.TabIndex = 159
        Me.lblVersionsdatum.Text = "Versionsdatum"
        '
        'txtBezeichnung
        '
        Me.txtBezeichnung.Location = New System.Drawing.Point(96, 62)
        Me.txtBezeichnung.Name = "txtBezeichnung"
        Me.txtBezeichnung.Size = New System.Drawing.Size(268, 20)
        Me.txtBezeichnung.TabIndex = 156
        '
        'txtVersion
        '
        Me.txtVersion.Location = New System.Drawing.Point(96, 165)
        Me.txtVersion.Name = "txtVersion"
        Me.txtVersion.Size = New System.Drawing.Size(84, 20)
        Me.txtVersion.TabIndex = 158
        '
        'lblVersion
        '
        Me.lblVersion.AutoSize = True
        Me.lblVersion.Location = New System.Drawing.Point(7, 168)
        Me.lblVersion.Name = "lblVersion"
        Me.lblVersion.Size = New System.Drawing.Size(42, 13)
        Me.lblVersion.TabIndex = 162
        Me.lblVersion.Text = "Version"
        '
        'lblBezeichnung
        '
        Me.lblBezeichnung.AutoSize = True
        Me.lblBezeichnung.Location = New System.Drawing.Point(7, 65)
        Me.lblBezeichnung.Name = "lblBezeichnung"
        Me.lblBezeichnung.Size = New System.Drawing.Size(69, 13)
        Me.lblBezeichnung.TabIndex = 161
        Me.lblBezeichnung.Text = "Bezeichnung"
        '
        'lblDokumenttyp
        '
        Me.lblDokumenttyp.AutoSize = True
        Me.lblDokumenttyp.Location = New System.Drawing.Point(7, 91)
        Me.lblDokumenttyp.Name = "lblDokumenttyp"
        Me.lblDokumenttyp.Size = New System.Drawing.Size(70, 13)
        Me.lblDokumenttyp.TabIndex = 166
        Me.lblDokumenttyp.Text = "Dokumenttyp"
        '
        'cboxDokumenttyp
        '
        Me.cboxDokumenttyp.FormattingEnabled = True
        Me.cboxDokumenttyp.Location = New System.Drawing.Point(96, 88)
        Me.cboxDokumenttyp.Name = "cboxDokumenttyp"
        Me.cboxDokumenttyp.Size = New System.Drawing.Size(268, 21)
        Me.cboxDokumenttyp.TabIndex = 165
        '
        'txtFilename
        '
        Me.txtFilename.Location = New System.Drawing.Point(96, 218)
        Me.txtFilename.Name = "txtFilename"
        Me.txtFilename.Size = New System.Drawing.Size(268, 20)
        Me.txtFilename.TabIndex = 167
        '
        'lbldatei
        '
        Me.lbldatei.AutoSize = True
        Me.lbldatei.Location = New System.Drawing.Point(7, 220)
        Me.lbldatei.Name = "lbldatei"
        Me.lbldatei.Size = New System.Drawing.Size(32, 13)
        Me.lbldatei.TabIndex = 168
        Me.lbldatei.Text = "Datei"
        '
        'OpenFileDialog1
        '
        Me.OpenFileDialog1.FileName = "OpenFileDialog1"
        '
        'txtDateiname
        '
        Me.txtDateiname.Location = New System.Drawing.Point(96, 191)
        Me.txtDateiname.Name = "txtDateiname"
        Me.txtDateiname.Size = New System.Drawing.Size(268, 20)
        Me.txtDateiname.TabIndex = 170
        '
        'txtOriginalFilename_incl_path
        '
        Me.txtOriginalFilename_incl_path.Location = New System.Drawing.Point(394, 241)
        Me.txtOriginalFilename_incl_path.Name = "txtOriginalFilename_incl_path"
        Me.txtOriginalFilename_incl_path.Size = New System.Drawing.Size(169, 20)
        Me.txtOriginalFilename_incl_path.TabIndex = 171
        '
        'brnFileOpen
        '
        Me.brnFileOpen.Image = CType(resources.GetObject("brnFileOpen.Image"), System.Drawing.Image)
        Me.brnFileOpen.Location = New System.Drawing.Point(361, 217)
        Me.brnFileOpen.Name = "brnFileOpen"
        Me.brnFileOpen.Size = New System.Drawing.Size(24, 24)
        Me.brnFileOpen.TabIndex = 169
        Me.brnFileOpen.UseVisualStyleBackColor = True
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "Daten speichern"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'TSBtnCopy
        '
        Me.TSBtnCopy.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnCopy.Image = CType(resources.GetObject("TSBtnCopy.Image"), System.Drawing.Image)
        Me.TSBtnCopy.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnCopy.Name = "TSBtnCopy"
        Me.TSBtnCopy.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnCopy.Text = "Datensatz kopieren"
        Me.TSBtnCopy.ToolTipText = "Datensatz kopieren"
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "Neuer Datensatz"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "Datensatz inaktivieren"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'TSBtnSuche
        '
        Me.TSBtnSuche.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSuche.Image = CType(resources.GetObject("TSBtnSuche.Image"), System.Drawing.Image)
        Me.TSBtnSuche.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSuche.Name = "TSBtnSuche"
        Me.TSBtnSuche.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSuche.Text = "ToolStripButton1"
        '
        'Button1
        '
        Me.Button1.Image = CType(resources.GetObject("Button1.Image"), System.Drawing.Image)
        Me.Button1.Location = New System.Drawing.Point(361, 188)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(24, 24)
        Me.Button1.TabIndex = 172
        Me.Button1.UseVisualStyleBackColor = True
        '
        'lblEx
        '
        Me.lblEx.AutoSize = True
        Me.lblEx.Location = New System.Drawing.Point(7, 194)
        Me.lblEx.Name = "lblEx"
        Me.lblEx.Size = New System.Drawing.Size(59, 13)
        Me.lblEx.TabIndex = 173
        Me.lblEx.Text = "Best. Datei"
        '
        'frmDokument
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(578, 400)
        Me.Controls.Add(Me.lblEx)
        Me.Controls.Add(Me.Button1)
        Me.Controls.Add(Me.txtOriginalFilename_incl_path)
        Me.Controls.Add(Me.txtDateiname)
        Me.Controls.Add(Me.brnFileOpen)
        Me.Controls.Add(Me.txtFilename)
        Me.Controls.Add(Me.lbldatei)
        Me.Controls.Add(Me.lblDokumenttyp)
        Me.Controls.Add(Me.cboxDokumenttyp)
        Me.Controls.Add(Me.dtPickerVersionsdatum)
        Me.Controls.Add(Me.txtVersionsdatum)
        Me.Controls.Add(Me.lblVersionsdatum)
        Me.Controls.Add(Me.txtBezeichnung)
        Me.Controls.Add(Me.txtVersion)
        Me.Controls.Add(Me.lblVersion)
        Me.Controls.Add(Me.lblBezeichnung)
        Me.Controls.Add(Me.lblBeschreibung)
        Me.Controls.Add(Me.txtBeschreibung)
        Me.Controls.Add(Me.txtMutierer)
        Me.Controls.Add(Me.txtMutiert_am)
        Me.Controls.Add(Me.txtErstellt_am)
        Me.Controls.Add(Me.lblMutierer)
        Me.Controls.Add(Me.lblMutiert_am)
        Me.Controls.Add(Me.lblErstelltam)
        Me.Controls.Add(Me.cboxSecurityLevel)
        Me.Controls.Add(Me.lblSecurityLebel)
        Me.Controls.Add(Me.lblAktiv)
        Me.Controls.Add(Me.cbaktiv)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmDokument"
        Me.Text = "Dokument"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


frmDokument.Load_Securitylevel Method

frmDokument.Load_Securitylevel Method

Laden der Securitylevel-Daten in die Combobox
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Load_Securitylevel()
C#
private System.Void Load_Securitylevel();
C++

private:
System::Void Load_Securitylevel()
JScript
private function Load_Securitylevel();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Load_Securitylevel()
        Dim seclevel As New TKB.VV.DB.clsSecurityLevel
        Dim secleveldata As New DataTable

        seclevel.cpMainConnectionProvider = Globals.conn
        Globals.conn.OpenConnection()
        secleveldata = seclevel.SelectAll
        Globals.conn.CloseConnection(True)

        Me.cboxSecurityLevel.DataSource = secleveldata
        Me.cboxSecurityLevel.DisplayMember = "Bezeichnung"
        Me.cboxSecurityLevel.ValueMember = "SecurityLevelNr"

        seclevel.Dispose()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


frmDokument.Save_data Method

frmDokument.Save_data Method

Daten ab Form speichern
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Save_data()
C#
private System.Void Save_data();
C++

private:
System::Void Save_data()
JScript
private function Save_data();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Save_data()
        'Prüfung, ob das Ausgewählte File zur Speicherung vorhanden ist
        If Me.txtFilename.Text <> "" Then
            If Not IO.File.Exists(Me.txtFilename.Text) Then
                msg.show_standardmessage(271, MsgBoxStyle.Exclamation)
                msg.show_standardmessage(273, MsgBoxStyle.Information)
                Exit Sub
            End If
        End If
        If Me.txtFilename.Text <> "" And Me.txtDateiname.Text <> "" Then
            If msg.Show_MessageYesNo(272) = MsgBoxResult.No Then
                msg.show_standardmessage(273, MsgBoxStyle.Information)
                Exit Sub
            End If
        End If
        Dokument.iVertragselementNr = New SqlInt32(CType(Me.Aktuelle_Vertragselementnr, Int32))
        Dokument.iDokumenttypNr = New SqlInt32(CType(Me.cboxDokumenttyp.SelectedValue, Int32))
        Dokument.sBezeichnung = New SqlString(CType(Me.txtBezeichnung.Text, String))
        Dokument.sBeschreibung = New SqlString(CType(Me.txtBeschreibung.Text, String))
        Dokument.sVersion = New SqlString(CType(Me.txtVersion.Text, String))
        If IsDate(Me.txtVersionsdatum.Text) Then
            Dokument.daVersionsdatum = New SqlDateTime(CType(Me.txtVersionsdatum.Text, DateTime))
        Else
            Dokument.daVersionsdatum = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
        End If
        Dokument.sFilename = New SqlString(CType(Me.txtDateiname.Text, String))
        Dokument.sOriginalFilename_incl_Path = New SqlString(CType(Me.txtOriginalFilename_incl_path.Text, String))
        Dokument.bAktiv = New SqlBoolean(CType(Me.cbaktiv.Checked = True, Boolean))
        Dokument.Save_Data()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


frmDokument.TSBtnCopy_Click Method

frmDokument.TSBtnCopy_Click Method

Datensatz kopieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnCopy_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnCopy.Click
C#
private System.Void TSBtnCopy_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnCopy_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnCopy_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnCopy_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnCopy.Click
        If Me.Check_Changes = False Then Exit Sub
        Me.Get_Data(Dokument.Create_Copy(Me.Dokument.iDokumentNr.Value))
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


frmDokument.TSBtnDelete_Click Method

frmDokument.TSBtnDelete_Click Method

Aktueller Datensatz inaktivieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnDelete_Click( _
   ByVal senderBeendenToolStripMenuItem As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click
C#
private System.Void TSBtnDelete_Click(
   object senderBeendenToolStripMenuItem,
   EventArgs e
);
C++

private:
System::Void TSBtnDelete_Click(
   object^ senderBeendenToolStripMenuItem,
   EventArgs^ e
)
JScript
private function TSBtnDelete_Click(
    senderBeendenToolStripMenuItem : object,
    e : EventArgs
);

Parameters

senderBeendenToolStripMenuItem

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnDelete_Click(ByVal senderBeendenToolStripMenuItem As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
        If msg.Show_MessageYesNo(270) = MsgBoxResult.Yes Then
            Me.Dokument.Delete_Dokument(Me.Dokument.iDokumentNr.Value)
            Me.Close()
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


frmDokument.TSBtnNew_Click Method

frmDokument.TSBtnNew_Click Method

Neuer Datensatz erstellen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnNew_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnNew.Click
C#
private System.Void TSBtnNew_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnNew_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnNew_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnNew.Click
        If Me.Check_Changes = False Then Exit Sub
        Me.Get_Data(Me.Dokument.Add_New(Me.Aktuelle_Vertragselementnr))
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


frmDokument.TSBtnQuit_Click Method

frmDokument.TSBtnQuit_Click Method

Formular schliessen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click
C#
private System.Void TSBtnQuit_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnQuit_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnQuit_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


frmDokument.TSBtnSave_Click Method

frmDokument.TSBtnSave_Click Method

Sicherungs-Button betätigt
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click
C#
private System.Void TSBtnSave_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnSave_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnSave_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Me.Save_data()
        Me.txtMutiert_am.Text = Me.Dokument.daMutiert_am.ToString
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


frmDokument.TSBtnSuche_Click Method

frmDokument.TSBtnSuche_Click Method

Vertragspartner suchen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnSuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSuche.Click
C#
private System.Void TSBtnSuche_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnSuche_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnSuche_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSuche.Click
        If Not Me.FormReadonly Then Check_Changes()
        'Dim i As Integer
        'If Me.Vertragspartnerdata.Vertragspartner_Suchen(i) = True Then
        '    Me.Get_Data(i)
        'End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


frmDokument.brnFileOpen_Click Method

frmDokument.brnFileOpen_Click Method

Auswahl des zu speichernden Dokumentes
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub brnFileOpen_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   brnFileOpen.Click
C#
private System.Void brnFileOpen_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void brnFileOpen_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function brnFileOpen_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub brnFileOpen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles brnFileOpen.Click
        Me.OpenFileDialog1.ShowDialog()
        If Me.OpenFileDialog1.FileName <> "" Then Me.txtFilename.Text = Me.OpenFileDialog1.FileName
        Me.txtOriginalFilename_incl_path = Me.txtFilename
        Me.txtDateiname.Text = System.IO.Path.GetFileName(Me.txtFilename.Text)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


frmDokument.frmDokument_Load Method

frmDokument.frmDokument_Load Method

Formular-Load
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub frmDokument_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load
C#
private System.Void frmDokument_Load(
   object sender,
   EventArgs e
);
C++

private:
System::Void frmDokument_Load(
   object^ sender,
   EventArgs^ e
)
JScript
private function frmDokument_Load(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub frmDokument_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        If Anzeige = True Then
            Me.TSBtnSuche.Enabled = False
            Me.TSBtnSave.Enabled = False
        Else
            Me.TSBtnSuche.Enabled = True
        End If
        If Me.TSBtnSave.Enabled = False Or Me.TSBtnSave.Visible = False Then
            Me.FormReadonly = True
            Me.TSBtnCopy.Enabled = False
            Me.TSBtnNew.Enabled = False
            Me.TSBtnDelete.Enabled = False
        Else
            Me.FormReadonly = False
        End If

        Load_Securitylevel()

        'Dokumenttypen-Laden
        Me.Dokument.Get_Dokumenttypen()
        Me.cboxDokumenttyp.DataSource = Me.Dokument.Dokumenttypdaten
        Me.cboxDokumenttyp.DisplayMember = "Bezeichnung"
        Me.cboxDokumenttyp.ValueMember = "Dokumenttypnr"

        Get_Data(Me.Aktuelles_Dokument)
        AddChanges(Me)

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


frmDokument Fields

frmDokument Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | Aktuelle_Vertragselementnr |
Supported by the .NET Compact Framework. | Aktuelles_Dokument |
Supported by the .NET Compact Framework. | Anzeige |
Supported by the .NET Compact Framework. | Dokument |
Supported by the .NET Compact Framework. | FormDataChanged |
Supported by the .NET Compact Framework. | FormReadonly |
Supported by the .NET Compact Framework. | SpaltenTitel |
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | msg |
Supported by the .NET Compact Framework. | sec |
Top

Expand image See Also

Reference

frmDokument Class


Aktuelle_Vertragselementnr Variable

Aktuelle_Vertragselementnr Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Aktuelle_Vertragselementnr As Integer
C#
private int Aktuelle_Vertragselementnr;
C++
private:
int Aktuelle_Vertragselementnr;
JScript
private Aktuelle_Vertragselementnr : int

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Aktuelle_Vertragselementnr As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


Aktuelles_Dokument Variable

Aktuelles_Dokument Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Aktuelles_Dokument As Integer
C#
private int Aktuelles_Dokument;
C++
private:
int Aktuelles_Dokument;
JScript
private Aktuelles_Dokument : int

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Aktuelles_Dokument As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


Anzeige Variable

Anzeige Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Anzeige As Boolean
C#
private bool Anzeige;
C++
private:
bool Anzeige;
JScript
private Anzeige : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Anzeige As Boolean = False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


Dokument Variable

Dokument Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Dokument As clsDok
C#
private clsDok Dokument;
C++
private:
clsDok^ Dokument;
JScript
private Dokument : clsDok

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Dokument As New TKB.VV.Vertrag.clsDok

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


FormDataChanged Variable

FormDataChanged Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private FormDataChanged As Boolean
C#
private bool FormDataChanged;
C++
private:
bool FormDataChanged;
JScript
private FormDataChanged : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim FormDataChanged As Boolean = False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


FormReadonly Variable

FormReadonly Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private FormReadonly As Boolean
C#
private bool FormReadonly;
C++
private:
bool FormReadonly;
JScript
private FormReadonly : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim FormReadonly As Boolean = False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


SpaltenTitel Variable

SpaltenTitel Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private SpaltenTitel As Tabellenspalte
C#
private Tabellenspalte SpaltenTitel;
C++
private:
Tabellenspalte^ SpaltenTitel;
JScript
private SpaltenTitel : Tabellenspalte

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


components Variable

components Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private components As IContainer
C#
private IContainer components;
C++
private:
IContainer^ components;
JScript
private components : IContainer

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private components As System.ComponentModel.IContainer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


msg Variable

msg Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private msg As MyMessage
C#
private MyMessage msg;
C++
private:
MyMessage^ msg;
JScript
private msg : MyMessage

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim msg As New TKB.VV.Utils.MyMessage

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


sec Variable

sec Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private sec As MySecurity
C#
private MySecurity sec;
C++
private:
MySecurity^ sec;
JScript
private sec : MySecurity

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim sec As New TKB.VV.Utils.MySecurity

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDokument Class
frmDokument Members


frmDomainEditor Class

frmDomainEditor Class
See Also Members
collapseAll image DropDown image

Form mit generalisiertem Domain-Table-Editor.
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class frmDomainEditor
    Inherits Form
C#
public class frmDomainEditor : Form
C++

public ref class frmDomainEditor : public Form^
JScript
public class frmDomainEditor
   extends Form

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmDomainEditor

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDomainEditor Members
DomainTable


frmDomainEditor Members

frmDomainEditor Members
See Also Constructors Methods
CollapseAll image DropDown image

Form mit generalisiertem Domain-Table-Editor.

The following tables list the members exposed by the frmDomainEditor type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | frmDomainEditor Constructor | Tabellenname übernehmen und Objekt DomainTable initialisieren Initialisierung der Komponenten
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | SpaltenTitel_Aktualisieren | Aktualisiert die Spaltentitel der aktuellen Tabelle
Top

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | BeendenToolStripMenuItem_Click | Schliessen des Formulars
Supported by the .NET Compact Framework. | C1Daten_AfterColUpdate | Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.
Supported by the .NET Compact Framework. | C1Daten_AfterInsert | Aktualisierung der Default-Werte
Supported by the .NET Compact Framework. | C1Daten_FetchCellTips | Anzeige allfälliger Cellen-Tips
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Ruft BeendetnToolStipMenuItem_Click auf
Supported by the .NET Compact Framework. | TSBtnSave_Click | Sichern der Daten
Supported by the .NET Compact Framework. | frmDomainEditor_FormClosing | Prüfung auf allfällige Daten-Changes. Wurden Daten verändert, kann der User entscheiden, ob gespeichert, nichtgespeichert oder das Formular nicht gespeichert werden soll.
Supported by the .NET Compact Framework. | frmDomainEditor_Load | Zuordnung der Daten aus Domaintable und Spaltentitel des Grids setzen
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | Domaintable |
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | tablename |
Top

Expand image See Also

Reference

frmDomainEditor Class
DomainTable


frmDomainEditor Constructor

frmDomainEditor Constructor

Tabellenname übernehmen und Objekt DomainTable initialisieren Initialisierung der Komponenten
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal tblname As String _
)
C#
public System.Void frmDomainEditor(
   string tblname
);
C++

public:
System::Void frmDomainEditor(
   String^ tblname
)
JScript
public function frmDomainEditor(
    tblname : String
);

Parameters

tblname

Tabellenname der Tabelle, welche über den Domaineditor editiert werden soll

Expand image Remarks

Benötigt werden entsprechende Stored_Procedures, welche mit LBLLGEN_2 generiert wurden pr_"Tablename"_SelectAll pr_"Tablename"_Update

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Sub New(ByVal tblname As String)
        Domaintable = New TKB.VV.Sysadmin.DomainTable(tblname)
        Me.InitializeComponent()
        Me.Text = "Domaineditor: " & tblname
        Me.tablename = tblname
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDomainEditor Class
frmDomainEditor Members


frmDomainEditor Methods

frmDomainEditor Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | SpaltenTitel_Aktualisieren | Aktualisiert die Spaltentitel der aktuellen Tabelle
Top

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | BeendenToolStripMenuItem_Click | Schliessen des Formulars
Supported by the .NET Compact Framework. | C1Daten_AfterColUpdate | Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.
Supported by the .NET Compact Framework. | C1Daten_AfterInsert | Aktualisierung der Default-Werte
Supported by the .NET Compact Framework. | C1Daten_FetchCellTips | Anzeige allfälliger Cellen-Tips
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Ruft BeendetnToolStipMenuItem_Click auf
Supported by the .NET Compact Framework. | TSBtnSave_Click | Sichern der Daten
Supported by the .NET Compact Framework. | frmDomainEditor_FormClosing | Prüfung auf allfällige Daten-Changes. Wurden Daten verändert, kann der User entscheiden, ob gespeichert, nichtgespeichert oder das Formular nicht gespeichert werden soll.
Supported by the .NET Compact Framework. | frmDomainEditor_Load | Zuordnung der Daten aus Domaintable und Spaltentitel des Grids setzen
Top

Expand image See Also

Reference

frmDomainEditor Class
DomainTable


frmDomainEditor.BeendenToolStripMenuItem_Click Method

frmDomainEditor.BeendenToolStripMenuItem_Click Method

Schliessen des Formulars
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click
C#
private System.Void BeendenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void BeendenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function BeendenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDomainEditor Class
frmDomainEditor Members


frmDomainEditor.C1Daten_AfterColUpdate Method

frmDomainEditor.C1Daten_AfterColUpdate Method

Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub C1Daten_AfterColUpdate( _
   ByVal sender As Object, _
   ByVal e As ColEventArgs _
) Handles  _
   C1Daten.AfterColUpdate
C#
private System.Void C1Daten_AfterColUpdate(
   object sender,
   ColEventArgs e
);
C++

private:
System::Void C1Daten_AfterColUpdate(
   object^ sender,
   ColEventArgs^ e
)
JScript
private function C1Daten_AfterColUpdate(
    sender : object,
    e : ColEventArgs
);

Parameters

sender

e

Expand image Remarks

Je Domaintable ist ein Eintrag in der Key-Tabelle notwendig

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub C1Daten_AfterColUpdate(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles C1Daten.AfterColUpdate
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        Try
            For i = 0 To Me.C1Daten.Columns.Count - 1
                If LCase(Me.C1Daten.Columns(i).DataField) = "mutiert_am" Then Me.C1Daten.Columns(i).Value = Now
                If LCase(Me.C1Daten.Columns(i).DataField) = "mutierer" Then Me.C1Daten.Columns(i).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value
            Next

            'neuer DB-Key auslösen, sofern kein Key vorhanden ist
            If Me.C1Daten.Columns(0).Value Is DBNull.Value Then
                Dim dbkey As New TKB.VV.DB.clsMyKey_Tabelle()
                Dim key As Long
                dbkey.cpMainConnectionProvider = conn
                key = dbkey.get_dbkey(tablename)
                Me.C1Daten.Columns(0).Value = key
                For i = 0 To Me.C1Daten.Columns.Count - 1
                    If LCase(Me.C1Daten.Columns(i).DataField) = "mandantnr" Then
                        Me.C1Daten.Columns(i).Value = Globals.clsmitarbeiter.iMandantnr.Value
                    End If
                    If LCase(Me.C1Daten.Columns(i).DataField) = "erstellt_am" Then
                        Me.C1Daten.Columns(i).Value = Now
                    End If
                    If LCase(Me.C1Daten.Columns(i).DataField) = "aktiv" Then
                        Me.C1Daten.Columns(i).Value = 1
                    End If
                Next
                dbkey.Dispose()
            End If
        Catch
        End Try

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDomainEditor Class
frmDomainEditor Members


frmDomainEditor.C1Daten_AfterInsert Method

frmDomainEditor.C1Daten_AfterInsert Method

Aktualisierung der Default-Werte
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub C1Daten_AfterInsert( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Daten.AfterInsert
C#
private System.Void C1Daten_AfterInsert(
   object sender,
   EventArgs e
);
C++

private:
System::Void C1Daten_AfterInsert(
   object^ sender,
   EventArgs^ e
)
JScript
private function C1Daten_AfterInsert(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub C1Daten_AfterInsert(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Daten.AfterInsert
        Dim i As Integer
        'Defaulwerte erstellt_am, mutiert_am, mutierer und aktiv setzen
        Try
            For i = 0 To C1Daten.Columns.Count - 1
                If LCase(Me.C1Daten.Columns(i).DataField) = "aktiv" Then
                    Me.C1Daten.Columns(i).Value = 1
                End If
                If LCase(Me.C1Daten.Columns(i).DataField) = "mutiert_am" Then
                    Me.C1Daten.Columns(i).Value = Now
                End If
                If LCase(Me.C1Daten.Columns(i).DataField) = "mutierer" Then
                    Me.C1Daten.Columns(i).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value
                End If
                If LCase(Me.C1Daten.Columns(i).DataField) = "mandantnr" Then
                    Me.C1Daten.Columns(i).Value = Globals.clsmitarbeiter.iMandantnr.Value
                End If
                If LCase(Me.C1Daten.Columns(i).DataField) = "mandnat" Then
                    Me.C1Daten.Columns(i).Value = Globals.clsmitarbeiter.iMandantnr.Value
                End If
            Next
        Catch
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDomainEditor Class
frmDomainEditor Members


frmDomainEditor.C1Daten_FetchCellTips Method

frmDomainEditor.C1Daten_FetchCellTips Method

Anzeige allfälliger Cellen-Tips
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub C1Daten_FetchCellTips( _
   ByVal sender As Object, _
   ByVal e As FetchCellTipsEventArgs _
) Handles  _
   C1Daten.FetchCellTips
C#
private System.Void C1Daten_FetchCellTips(
   object sender,
   FetchCellTipsEventArgs e
);
C++

private:
System::Void C1Daten_FetchCellTips(
   object^ sender,
   FetchCellTipsEventArgs^ e
)
JScript
private function C1Daten_FetchCellTips(
    sender : object,
    e : FetchCellTipsEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub C1Daten_FetchCellTips(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs) Handles C1Daten.FetchCellTips
        Dim ts As New TKB.VV.Utils.Tabellenspalte
        ts.Tabelle = Me.tablename
        Try
            ts.Feld = Me.C1Daten.Columns(e.ColIndex).DataField
            ts.getspalte()
            e.CellTip = ts.TipText
        Catch
        End Try
        ts = Nothing

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDomainEditor Class
frmDomainEditor Members


frmDomainEditor.Dispose Method

frmDomainEditor.Dispose Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
C#
[System.Diagnostics.DebuggerNonUserCode()]
protected override System.Void Dispose(
   bool disposing
);
C++
[System.Diagnostics.DebuggerNonUserCode()]

protected:
System::Void Dispose(
   bool disposing
)
JScript
protected
   System.Diagnostics.DebuggerNonUserCode()
function Dispose(
    disposing : boolean
);

Parameters

disposing

Expand image Source code

Visual Basic CopyCode image Copy Code
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDomainEditor Class
frmDomainEditor Members


frmDomainEditor.InitializeComponent Method

frmDomainEditor.InitializeComponent Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()
C#
[System.Diagnostics.DebuggerStepThrough()]
private System.Void InitializeComponent();
C++
[System.Diagnostics.DebuggerStepThrough()]

private:
System::Void InitializeComponent()
JScript
private
   System.Diagnostics.DebuggerStepThrough()
function InitializeComponent();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmDomainEditor))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.C1Daten = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        CType(Me.C1Daten, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(556, 24)
        Me.MenuStrip1.TabIndex = 0
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(127, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(556, 25)
        Me.ToolStrip1.TabIndex = 1
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "ToolStripButton1"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'C1Daten
        '
        Me.C1Daten.AllowAddNew = True
        Me.C1Daten.AlternatingRows = True
        Me.C1Daten.DirectionAfterEnter = C1.Win.C1TrueDBGrid.DirectionAfterEnterEnum.MoveDown
        Me.C1Daten.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Daten.FilterBar = True
        Me.C1Daten.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Daten.Images.Add(CType(resources.GetObject("C1Daten.Images"), System.Drawing.Image))
        Me.C1Daten.Location = New System.Drawing.Point(0, 49)
        Me.C1Daten.Name = "C1Daten"
        Me.C1Daten.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Daten.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Daten.PreviewInfo.ZoomFactor = 75
        Me.C1Daten.PrintInfo.PageSettings = CType(resources.GetObject("C1Daten.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Daten.Size = New System.Drawing.Size(556, 270)
        Me.C1Daten.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Daten.TabIndex = 3
        Me.C1Daten.Text = "C1TrueDBGrid1"
        Me.C1Daten.PropBag = resources.GetString("C1Daten.PropBag")
        '
        'frmDomainEditor
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(556, 319)
        Me.Controls.Add(Me.C1Daten)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.MainMenuStrip = Me.MenuStrip1
        Me.Name = "frmDomainEditor"
        Me.Text = "frmDomainEditor"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        CType(Me.C1Daten, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDomainEditor Class
frmDomainEditor Members


frmDomainEditor.SpaltenTitel_Aktualisieren Method

frmDomainEditor.SpaltenTitel_Aktualisieren Method

Aktualisiert die Spaltentitel der aktuellen Tabelle
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub SpaltenTitel_Aktualisieren( _
   ByVal ds As DataSet _
)
C#
public System.Void SpaltenTitel_Aktualisieren(
   DataSet ds
);
C++

public:
System::Void SpaltenTitel_Aktualisieren(
   DataSet^ ds
)
JScript
public function SpaltenTitel_Aktualisieren(
    ds : DataSet
);

Parameters

ds

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Sub SpaltenTitel_Aktualisieren(ByVal ds As DataSet)
        Dim titel As New TKB.VV.Utils.MySpaltenTitel
        Dim anzcols As Integer
        Dim cols(Me.C1Daten.Splits(0).DisplayColumns.Count) As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim ts As New TKB.VV.Utils.Tabellenspalte

        Dim i As Integer
        Dim t As New DataTable()
        Dim s As String
        anzcols = Me.C1Daten.Splits(0).DisplayColumns.Count
        t = ds.Tables(0)
        ts.Tabelle = Me.tablename
        For i = 0 To Me.C1Daten.Columns.Count - 1
            s = Me.C1Daten.Columns(i).DataField
            ts.Feld = s
            ts.getspalte()
            Me.C1Daten.Columns(i).Caption = ts.spaltenname

            If ts.ColWith = 0 Then
                Me.C1Daten.Splits(0).DisplayColumns(i).Width = 0
                Me.C1Daten.Splits(0).DisplayColumns(i).Visible = False
            Else
                Me.C1Daten.Splits(0).DisplayColumns(i).Width = ts.ColWith
            End If

            If ts.locked Then
                Me.C1Daten.Splits(0).DisplayColumns(i).Locked = True
            End If

            If ts.AlsHacken Then
                Me.C1Daten.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
            End If

            'Präsentation von aktiv
            If Me.C1Daten.Columns(i).DataField = "aktiv" Then
                Me.C1Daten.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                Me.C1Daten.Columns(i).ValueItems.DefaultItem = True
                Me.C1Daten.Columns(i).DefaultValue = True
                Me.C1Daten.Columns(i).FilterText = True
            End If
            If Me.C1Daten.Columns(i).DataField = "erstellt_am" Then
                Me.C1Daten.Columns(i).DefaultValue = Now
            End If
        Next
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDomainEditor Class
frmDomainEditor Members


frmDomainEditor.TSBtnQuit_Click Method

frmDomainEditor.TSBtnQuit_Click Method

Ruft BeendetnToolStipMenuItem_Click auf
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click
C#
private System.Void TSBtnQuit_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnQuit_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnQuit_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        BeendenToolStripMenuItem_Click(sender, e)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDomainEditor Class
frmDomainEditor Members


frmDomainEditor.TSBtnSave_Click Method

frmDomainEditor.TSBtnSave_Click Method

Sichern der Daten
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click
C#
private System.Void TSBtnSave_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnSave_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnSave_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Try
            Domaintable.Save_Data()
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDomainEditor Class
frmDomainEditor Members


frmDomainEditor.frmDomainEditor_FormClosing Method

frmDomainEditor.frmDomainEditor_FormClosing Method

Prüfung auf allfällige Daten-Changes. Wurden Daten verändert, kann der User entscheiden, ob gespeichert, nichtgespeichert oder das Formular nicht gespeichert werden soll.
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub frmDomainEditor_FormClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing
C#
private System.Void frmDomainEditor_FormClosing(
   object sender,
   FormClosingEventArgs e
);
C++

private:
System::Void frmDomainEditor_FormClosing(
   object^ sender,
   FormClosingEventArgs^ e
)
JScript
private function frmDomainEditor_FormClosing(
    sender : object,
    e : FormClosingEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub frmDomainEditor_FormClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.Domaintable.Tabledata.HasChanges Then
            Dim msg As New TKB.VV.Utils.MyMessage
            Dim msgboxres As MsgBoxResult
            msgboxres = msg.Show_MessageYesNoCancel(3)
            If msgboxres = MsgBoxResult.Cancel Then
                e.Cancel = True
                Exit Sub
            End If
            If msgboxres = MsgBoxResult.Yes Then
                Domaintable.Save_Data()
            End If
        End If
        Domaintable.dispose()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDomainEditor Class
frmDomainEditor Members


frmDomainEditor.frmDomainEditor_Load Method

frmDomainEditor.frmDomainEditor_Load Method

Zuordnung der Daten aus Domaintable und Spaltentitel des Grids setzen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub frmDomainEditor_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load
C#
private System.Void frmDomainEditor_Load(
   object sender,
   EventArgs e
);
C++

private:
System::Void frmDomainEditor_Load(
   object^ sender,
   EventArgs^ e
)
JScript
private function frmDomainEditor_Load(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub frmDomainEditor_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.C1Daten.DataSource = Domaintable.Tabledata
        Me.C1Daten.DataMember = Domaintable.Tabledata.Tables(0).TableName
        SpaltenTitel_Aktualisieren(Domaintable.Tabledata)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDomainEditor Class
frmDomainEditor Members


frmDomainEditor Fields

frmDomainEditor Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | Domaintable |
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | tablename |
Top

Expand image See Also

Reference

frmDomainEditor Class
DomainTable


Domaintable Variable

Domaintable Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Domaintable As DomainTable
C#
private DomainTable Domaintable;
C++
private:
DomainTable^ Domaintable;
JScript
private Domaintable : DomainTable

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Domaintable As TKB.VV.Sysadmin.DomainTable

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDomainEditor Class
frmDomainEditor Members


components Variable

components Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private components As IContainer
C#
private IContainer components;
C++
private:
IContainer^ components;
JScript
private components : IContainer

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private components As System.ComponentModel.IContainer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDomainEditor Class
frmDomainEditor Members


tablename Variable

tablename Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private tablename As String
C#
private string tablename;
C++
private:
String^ tablename;
JScript
private tablename : String

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim tablename As String

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmDomainEditor Class
frmDomainEditor Members


frmFormSelector Class

frmFormSelector Class
Members
collapseAll image DropDown image

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class frmFormSelector
    Inherits Form
C#
public class frmFormSelector : Form
C++

public ref class frmFormSelector : public Form^
JScript
public class frmFormSelector
   extends Form

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmFormSelector

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmFormSelector Members


frmFormSelector Members

frmFormSelector Members
See Also Methods
CollapseAll image DropDown image

The following tables list the members exposed by the frmFormSelector type.

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | ListForms_SelectedIndexChanged |
Supported by the .NET Compact Framework. | frmFormSelector_Load |
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | components |
Top

Expand image See Also

Reference

frmFormSelector Class


frmFormSelector Methods

frmFormSelector Methods
CollapseAll image DropDown image

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | ListForms_SelectedIndexChanged |
Supported by the .NET Compact Framework. | frmFormSelector_Load |
Top

Expand image See Also

Reference

frmFormSelector Class


frmFormSelector.Dispose Method

frmFormSelector.Dispose Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
C#
[System.Diagnostics.DebuggerNonUserCode()]
protected override System.Void Dispose(
   bool disposing
);
C++
[System.Diagnostics.DebuggerNonUserCode()]

protected:
System::Void Dispose(
   bool disposing
)
JScript
protected
   System.Diagnostics.DebuggerNonUserCode()
function Dispose(
    disposing : boolean
);

Parameters

disposing

Expand image Source code

Visual Basic CopyCode image Copy Code
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmFormSelector Class
frmFormSelector Members


frmFormSelector.InitializeComponent Method

frmFormSelector.InitializeComponent Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()
C#
[System.Diagnostics.DebuggerStepThrough()]
private System.Void InitializeComponent();
C++
[System.Diagnostics.DebuggerStepThrough()]

private:
System::Void InitializeComponent()
JScript
private
   System.Diagnostics.DebuggerStepThrough()
function InitializeComponent();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmFormSelector))
        Me.ListForms = New System.Windows.Forms.ListBox
        Me.SuspendLayout()
        '
        'ListForms
        '
        Me.ListForms.FormattingEnabled = True
        Me.ListForms.Location = New System.Drawing.Point(28, 36)
        Me.ListForms.Name = "ListForms"
        Me.ListForms.Size = New System.Drawing.Size(259, 199)
        Me.ListForms.TabIndex = 0
        '
        'frmFormSelector
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(315, 322)
        Me.Controls.Add(Me.ListForms)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmFormSelector"
        Me.Text = "Form-Selector"
        Me.ResumeLayout(False)

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmFormSelector Class
frmFormSelector Members


frmFormSelector.ListForms_SelectedIndexChanged Method

frmFormSelector.ListForms_SelectedIndexChanged Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub ListForms_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ListForms.DoubleClick
C#
private System.Void ListForms_SelectedIndexChanged(
   object sender,
   EventArgs e
);
C++

private:
System::Void ListForms_SelectedIndexChanged(
   object^ sender,
   EventArgs^ e
)
JScript
private function ListForms_SelectedIndexChanged(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub ListForms_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ListForms.DoubleClick
        Me.DialogResult = Windows.Forms.DialogResult.OK
        Me.Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmFormSelector Class
frmFormSelector Members


frmFormSelector.frmFormSelector_Load Method

frmFormSelector.frmFormSelector_Load Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub frmFormSelector_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load
C#
private System.Void frmFormSelector_Load(
   object sender,
   EventArgs e
);
C++

private:
System::Void frmFormSelector_Load(
   object^ sender,
   EventArgs^ e
)
JScript
private function frmFormSelector_Load(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub frmFormSelector_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmFormSelector Class
frmFormSelector Members


frmFormSelector Fields

frmFormSelector Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | components |
Top

Expand image See Also

Reference

frmFormSelector Class


components Variable

components Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private components As IContainer
C#
private IContainer components;
C++
private:
IContainer^ components;
JScript
private components : IContainer

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private components As System.ComponentModel.IContainer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmFormSelector Class
frmFormSelector Members


frmKuendigungsfrist Class

frmKuendigungsfrist Class
See Also Members
collapseAll image DropDown image

Person
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class frmKuendigungsfrist
    Inherits Form
C#
public class frmKuendigungsfrist : Form
C++

public ref class frmKuendigungsfrist : public Form^
JScript
public class frmKuendigungsfrist
   extends Form

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmKuendigungsfrist

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Members
TKB.VV.Utils
TKB.VV.Utils.MyMessage
TKB.VV.Utils.MySecurity


frmKuendigungsfrist Members

frmKuendigungsfrist Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Person

The following tables list the members exposed by the frmKuendigungsfrist type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | frmKuendigungsfrist Constructor | Formular-Initialisierung
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Vertragselementnr |
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose | (Overloaded) Destructor Dispose
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | AddChanges | Allg Eventhandler für Chanage-Ereignise festlegen
Supported by the .NET Compact Framework. | ChangesMade | Envent-Handler für Change-Ereignisse
Supported by the .NET Compact Framework. | Check_Changes | Prüfung, ob Datenänderungen vorgenommen wurden.
Supported by the .NET Compact Framework. | DateTimePicker_ValueChanged | Handelt das Change-Ereignis eines Datetimepckers und stellt das ausgewählte Datum in das entsprechende Textfeld
Supported by the .NET Compact Framework. | FormularClosing | Schliessen des Formulars
Supported by the .NET Compact Framework. | GetControl | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
Supported by the .NET Compact Framework. | Get_Data | Person laden und präsentieren
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | Load_Securitylevel | Laden der Securitylevel-Daten in die Combobox
Supported by the .NET Compact Framework. | Save_Data | Daten sichern, sofern Änderungen vorgenommen worden sind
Supported by the .NET Compact Framework. | TSBtnCopy_Click | kopieren
Supported by the .NET Compact Framework. | TSBtnDelete_Click | löschen
Supported by the .NET Compact Framework. | TSBtnNew_Click | Neu
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Schliessen-Button betätigt
Supported by the .NET Compact Framework. | TSBtnSave_Click | Save-Button geklickt
Supported by the .NET Compact Framework. | frmKuendigungsfrist_Load | Laden des Formulars
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | FormDataChanged |
Supported by the .NET Compact Framework. | FormReadonly |
Supported by the .NET Compact Framework. | Kuendigungsfrist |
Supported by the .NET Compact Framework. | Kuendigungsfristnr |
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | m_vertragselementnr |
Supported by the .NET Compact Framework. | msg |
Supported by the .NET Compact Framework. | sec |
Top

Expand image See Also

Reference

frmKuendigungsfrist Class
TKB.VV.Utils
TKB.VV.Utils.MyMessage
TKB.VV.Utils.MySecurity


frmKuendigungsfrist Constructor

frmKuendigungsfrist Constructor

Formular-Initialisierung
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal Nr As Integer, _
   ByVal Vertragselementnr As Integer, _
   Optional ByVal iReadOnly As Boolean = False _
)
C#
public System.Void frmKuendigungsfrist(
   int Nr,
   int Vertragselementnr,
   bool iReadOnly
);
C++

public:
System::Void frmKuendigungsfrist(
   int Nr,
   int Vertragselementnr,
   bool iReadOnly
)
JScript
public function frmKuendigungsfrist(
    Nr : int,
    Vertragselementnr : int,
    iReadOnly : boolean
);

Parameters

Nr

PersonenNr

Vertragselementnr

Required.

iReadOnly

Optional. The default value is False.

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Sub New(ByVal Nr As Integer, ByVal Vertragselementnr As Integer, Optional ByVal iReadOnly As Boolean = False)
        MyBase.New()
        Me.InitializeComponent()
        Kuendigungsfristnr = Nr
        Me.Vertragselementnr = Vertragselementnr
        Me.FormReadonly = iReadOnly
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


frmKuendigungsfrist Properties

frmKuendigungsfrist Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Vertragselementnr |
Top

Expand image See Also

Reference

frmKuendigungsfrist Class
TKB.VV.Utils
TKB.VV.Utils.MyMessage
TKB.VV.Utils.MySecurity


frmKuendigungsfrist.Vertragselementnr Property

frmKuendigungsfrist.Vertragselementnr Property

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property Vertragselementnr() As Integer
C#
public int Vertragselementnr {get; set;}
C++
public:
property int Vertragselementnr {
 int get( );
 void set(
   int value
 );
}
JScript
public function get Vertragselementnr() : int;
public function set Vertragselementnr(value : int);

Expand image Source code

Visual Basic CopyCode image Copy Code
    Property Vertragselementnr() As Integer
        Get
            Return m_vertragselementnr
        End Get
        Set(ByVal value As Integer)
            m_vertragselementnr = value
        End Set
    End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


frmKuendigungsfrist Methods

frmKuendigungsfrist Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose | (Overloaded) Destructor Dispose
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | AddChanges | Allg Eventhandler für Chanage-Ereignise festlegen
Supported by the .NET Compact Framework. | ChangesMade | Envent-Handler für Change-Ereignisse
Supported by the .NET Compact Framework. | Check_Changes | Prüfung, ob Datenänderungen vorgenommen wurden.
Supported by the .NET Compact Framework. | DateTimePicker_ValueChanged | Handelt das Change-Ereignis eines Datetimepckers und stellt das ausgewählte Datum in das entsprechende Textfeld
Supported by the .NET Compact Framework. | FormularClosing | Schliessen des Formulars
Supported by the .NET Compact Framework. | GetControl | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
Supported by the .NET Compact Framework. | Get_Data | Person laden und präsentieren
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | Load_Securitylevel | Laden der Securitylevel-Daten in die Combobox
Supported by the .NET Compact Framework. | Save_Data | Daten sichern, sofern Änderungen vorgenommen worden sind
Supported by the .NET Compact Framework. | TSBtnCopy_Click | kopieren
Supported by the .NET Compact Framework. | TSBtnDelete_Click | löschen
Supported by the .NET Compact Framework. | TSBtnNew_Click | Neu
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Schliessen-Button betätigt
Supported by the .NET Compact Framework. | TSBtnSave_Click | Save-Button geklickt
Supported by the .NET Compact Framework. | frmKuendigungsfrist_Load | Laden des Formulars
Top

Expand image See Also

Reference

frmKuendigungsfrist Class
TKB.VV.Utils
TKB.VV.Utils.MyMessage
TKB.VV.Utils.MySecurity


frmKuendigungsfrist.AddChanges Method

frmKuendigungsfrist.AddChanges Method

Allg Eventhandler für Chanage-Ereignise festlegen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub AddChanges( _
   ByVal Container As Control _
)
C#
private System.Void AddChanges(
   Control Container
);
C++

private:
System::Void AddChanges(
   Control^ Container
)
JScript
private function AddChanges(
    Container : Control
);

Parameters

Container

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub AddChanges(ByVal Container As Control)
        Dim l As New List(Of Control)
        Me.GetControl(Me, "*", l)
        Dim evh As EventHandler = AddressOf ChangesMade
        For Each c As Control In l
            If TypeOf c Is TextBox Then
                Dim ctl As TextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is MaskedTextBox Then
                Dim ctl As MaskedTextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is ComboBox Then
                Dim ctl As ComboBox = c
                AddHandler ctl.SelectedValueChanged, evh
            End If
            If TypeOf c Is CheckBox Then
                Dim ctl As CheckBox = c
                AddHandler ctl.CheckedChanged, evh
            End If
        Next
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


frmKuendigungsfrist.ChangesMade Method

frmKuendigungsfrist.ChangesMade Method

Envent-Handler für Change-Ereignisse
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub ChangesMade( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
private System.Void ChangesMade(
   object sender,
   EventArgs e
);
C++

private:
System::Void ChangesMade(
   object^ sender,
   EventArgs^ e
)
JScript
private function ChangesMade(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub ChangesMade(ByVal sender As Object, ByVal e As System.EventArgs)
        Me.FormDataChanged = True
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


frmKuendigungsfrist.Check_Changes Method

frmKuendigungsfrist.Check_Changes Method

Prüfung, ob Datenänderungen vorgenommen wurden.
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Check_Changes() As Boolean
C#
private bool Check_Changes();
C++

private:
bool Check_Changes()
JScript
private function Check_Changes() : boolean;

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Function Check_Changes() As Boolean
        If Me.FormReadonly Then Exit Function
        Dim msgres As MsgBoxResult
        If Me.FormDataChanged Then
            msgres = msg.Show_MessageYesNoCancel(3)
            Select Case msgres
                Case MsgBoxResult.Yes
                    Save_data()
                    Return True
                Case MsgBoxResult.Cancel
                    Return False
                Case MsgBoxResult.No
                    Return True
            End Select
        Else
            Return True
        End If
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


frmKuendigungsfrist.DateTimePicker_ValueChanged Method

frmKuendigungsfrist.DateTimePicker_ValueChanged Method

Handelt das Change-Ereignis eines Datetimepckers und stellt das ausgewählte Datum in das entsprechende Textfeld
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub DateTimePicker_ValueChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   dtPickerKuendigungstermin.ValueChanged
C#
private System.Void DateTimePicker_ValueChanged(
   object sender,
   EventArgs e
);
C++

private:
System::Void DateTimePicker_ValueChanged(
   object^ sender,
   EventArgs^ e
)
JScript
private function DateTimePicker_ValueChanged(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub DateTimePicker_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles dtPickerKuendigungstermin.ValueChanged
        Dim s As String
        Dim obj As DateTimePicker = sender
        s = obj.Name
        s = "txt" + s.Substring(8, s.Length - 8)
        Dim l As New List(Of Control)
        Dim txtb As MaskedTextBox
        GetControl(Me, s, l)
        For Each ctl As Control In l
            txtb = CType(ctl, MaskedTextBox)
            txtb.Text = obj.Value
        Next
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


frmKuendigungsfrist.Dispose Method

frmKuendigungsfrist.Dispose Method

Destructor Dispose

Expand image Overload List

Name | Description
protected override System.Void Dispose(bool); |
public System.Void Dispose(); | Destructor Dispose

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


frmKuendigungsfrist.FormularClosing Method

frmKuendigungsfrist.FormularClosing Method

Schliessen des Formulars
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub FormularClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing
C#
private System.Void FormularClosing(
   object sender,
   FormClosingEventArgs e
);
C++

private:
System::Void FormularClosing(
   object^ sender,
   FormClosingEventArgs^ e
)
JScript
private function FormularClosing(
    sender : object,
    e : FormClosingEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub FormularClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.FormReadonly = True Then Exit Sub
        If check_changes() = False Then
            e.Cancel = True
        Else
            Me.dispose()
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


frmKuendigungsfrist.GetControl Method

frmKuendigungsfrist.GetControl Method

Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function GetControl( _
   ByVal BaseControl As Control, _
   ByVal Key As String, _
   ByRef L As List(Of Control), _
   Optional ByVal ReturnAtFirstElement As Boolean = False _
) As Boolean
C#
private bool GetControl(
   Control BaseControl,
   string Key,
   ref List<Control> L,
   bool ReturnAtFirstElement
);
C++

private:
bool GetControl(
   Control^ BaseControl,
   String^ Key,
   List<Control^>^& L,
   bool ReturnAtFirstElement
)
JScript
JScript does not support generic types and methods.

Parameters

BaseControl

Base-Contrlo (z.B. aktuelles Formular

Key

Schlüssel welcher gesucht werden soll

L

Liste der gefundenen Objekte

ReturnAtFirstElement

Optional. The default value is False.

Return Value

True wenn eines oder mehr Controls gefunden wurden, false wenn kein Control gefunden wurde.

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Function GetControl(ByVal BaseControl As Control, ByVal Key As String, ByRef L As List(Of Control), Optional ByVal ReturnAtFirstElement As Boolean = False) As Boolean
        If L Is Nothing Then L = New List(Of Control)
        Dim Gut As Boolean
        Dim ReturnFlag As Boolean = False
        If Key IsNot Nothing Then Key = Key.ToLower

        If BaseControl.HasChildren = True Then
            For Each ctl As Control In BaseControl.Controls
                Gut = False
                If Key Is Nothing Then
                    Gut = True
                Else
                    If ctl.Name.Length >= Key.Length Then
                        Key = Key.ToLower
                        If Key.StartsWith("*") Then
                            If Key.Substring(1) = ctl.Name.ToLower.Substring(ctl.Name.Length - (Key.Length - 1), Key.Length - 1) Then Gut = True
                        ElseIf Key.EndsWith("*") Then
                            If Key.Substring(0, Key.Length - 1) = ctl.Name.ToLower.Substring(0, Key.Length - 1) Then Gut = True
                        Else
                            If Key = ctl.Name.ToLower Then Gut = True
                        End If
                    End If
                End If

                If Gut = True Then
                    L.Add(ctl)
                    If ReturnAtFirstElement = True Then ReturnFlag = True
                End If
                If ReturnFlag = False Then
                    Call GetControl(ctl, Key, L)
                End If
            Next
        End If

        If L.Count - 1 > -1 Then
            Return True
        Else
            Return False
        End If
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


frmKuendigungsfrist.Get_Data Method

frmKuendigungsfrist.Get_Data Method

Person laden und präsentieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Get_Data( _
   ByVal Nr As Integer _
)
C#
private System.Void Get_Data(
   int Nr
);
C++

private:
System::Void Get_Data(
   int Nr
)
JScript
private function Get_Data(
    Nr : int
);

Parameters

Nr

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Get_Data(ByVal Nr As Integer)
        Me.Kuendigungsfrist.Get_Kuendigungsfrist(Nr)
        Me.txtZeitspanne.Text = Me.Kuendigungsfrist.sVarZeitspanne.ToString
        Me.txtKuendigungsfrist.Text = Me.Kuendigungsfrist.sKuendigungsfirst.ToString
        Me.txtKuendigungstermin.Text = Me.Kuendigungsfrist.daKuendigungstermin.ToString
        Me.txtBemerkung.Text = Me.Kuendigungsfrist.sBemerkung.Value
        Me.txtErstellt_am.Text = Me.Kuendigungsfrist.daErstellt_am.ToString
        Me.txtMutiert_am.Text = Me.Kuendigungsfrist.daMutiert_am.ToString
        Me.txtMutierer.Text = Me.Kuendigungsfrist.iMutierer.Value
        Me.cbAktiv.Checked = Me.Kuendigungsfrist.bAktiv.Value = True
        Me.cboxSecurityLevel.SelectedValue = Me.Kuendigungsfrist.iSecurityLevelNr.Value
        Me.FormDataChanged = False

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


frmKuendigungsfrist.InitializeComponent Method

frmKuendigungsfrist.InitializeComponent Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()
C#
[System.Diagnostics.DebuggerStepThrough()]
private System.Void InitializeComponent();
C++
[System.Diagnostics.DebuggerStepThrough()]

private:
System::Void InitializeComponent()
JScript
private
   System.Diagnostics.DebuggerStepThrough()
function InitializeComponent();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmKuendigungsfrist))
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.TSBtnCopy = New System.Windows.Forms.ToolStripButton
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.cboxSecurityLevel = New System.Windows.Forms.ComboBox
        Me.lblSecurityLebel = New System.Windows.Forms.Label
        Me.txtMutierer = New System.Windows.Forms.TextBox
        Me.txtMutiert_am = New System.Windows.Forms.TextBox
        Me.txtErstellt_am = New System.Windows.Forms.TextBox
        Me.lblMutierer = New System.Windows.Forms.Label
        Me.lblMutiert_am = New System.Windows.Forms.Label
        Me.lblErstelltam = New System.Windows.Forms.Label
        Me.txtBemerkung = New System.Windows.Forms.TextBox
        Me.lblBemerkung = New System.Windows.Forms.Label
        Me.lblZeitspanne = New System.Windows.Forms.Label
        Me.txtZeitspanne = New System.Windows.Forms.TextBox
        Me.txtKuendigungsfrist = New System.Windows.Forms.TextBox
        Me.lblKuendigungsfrist = New System.Windows.Forms.Label
        Me.cbAktiv = New System.Windows.Forms.CheckBox
        Me.lblAktiv = New System.Windows.Forms.Label
        Me.dtPickerKuendigungstermin = New System.Windows.Forms.DateTimePicker
        Me.txtKuendigungstermin = New System.Windows.Forms.MaskedTextBox
        Me.lblKuendigungstermin = New System.Windows.Forms.Label
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.SuspendLayout()
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(127, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(647, 24)
        Me.MenuStrip1.TabIndex = 15
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnCopy, Me.TSBtnNew, Me.TSBtnDelete})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(647, 25)
        Me.ToolStrip1.TabIndex = 16
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "ToolStripButton1"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'TSBtnCopy
        '
        Me.TSBtnCopy.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnCopy.Image = CType(resources.GetObject("TSBtnCopy.Image"), System.Drawing.Image)
        Me.TSBtnCopy.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnCopy.Name = "TSBtnCopy"
        Me.TSBtnCopy.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnCopy.Text = "ToolStripButton2"
        Me.TSBtnCopy.ToolTipText = "Datensatz kopieren"
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "ToolStripButton3"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "ToolStripButton3"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'cboxSecurityLevel
        '
        Me.cboxSecurityLevel.FormattingEnabled = True
        Me.cboxSecurityLevel.Location = New System.Drawing.Point(88, 264)
        Me.cboxSecurityLevel.Name = "cboxSecurityLevel"
        Me.cboxSecurityLevel.Size = New System.Drawing.Size(101, 21)
        Me.cboxSecurityLevel.TabIndex = 122
        '
        'lblSecurityLebel
        '
        Me.lblSecurityLebel.AutoSize = True
        Me.lblSecurityLebel.Location = New System.Drawing.Point(11, 268)
        Me.lblSecurityLebel.Name = "lblSecurityLebel"
        Me.lblSecurityLebel.Size = New System.Drawing.Size(71, 13)
        Me.lblSecurityLebel.TabIndex = 130
        Me.lblSecurityLebel.Text = "SecurityLevel"
        '
        'txtMutierer
        '
        Me.txtMutierer.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutierer.Location = New System.Drawing.Point(567, 265)
        Me.txtMutierer.Name = "txtMutierer"
        Me.txtMutierer.Size = New System.Drawing.Size(71, 20)
        Me.txtMutierer.TabIndex = 129
        '
        'txtMutiert_am
        '
        Me.txtMutiert_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutiert_am.Location = New System.Drawing.Point(405, 265)
        Me.txtMutiert_am.Name = "txtMutiert_am"
        Me.txtMutiert_am.Size = New System.Drawing.Size(79, 20)
        Me.txtMutiert_am.TabIndex = 128
        '
        'txtErstellt_am
        '
        Me.txtErstellt_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtErstellt_am.Location = New System.Drawing.Point(261, 265)
        Me.txtErstellt_am.Name = "txtErstellt_am"
        Me.txtErstellt_am.Size = New System.Drawing.Size(79, 20)
        Me.txtErstellt_am.TabIndex = 127
        '
        'lblMutierer
        '
        Me.lblMutierer.AccessibleDescription = "Name"
        Me.lblMutierer.AutoSize = True
        Me.lblMutierer.Location = New System.Drawing.Point(496, 268)
        Me.lblMutierer.Name = "lblMutierer"
        Me.lblMutierer.Size = New System.Drawing.Size(72, 13)
        Me.lblMutierer.TabIndex = 126
        Me.lblMutierer.Text = "Mutiert durch:"
        '
        'lblMutiert_am
        '
        Me.lblMutiert_am.AccessibleDescription = "Name"
        Me.lblMutiert_am.AutoSize = True
        Me.lblMutiert_am.Location = New System.Drawing.Point(346, 268)
        Me.lblMutiert_am.Name = "lblMutiert_am"
        Me.lblMutiert_am.Size = New System.Drawing.Size(59, 13)
        Me.lblMutiert_am.TabIndex = 125
        Me.lblMutiert_am.Text = "Mutiert am:"
        '
        'lblErstelltam
        '
        Me.lblErstelltam.AccessibleDescription = "Name"
        Me.lblErstelltam.AutoSize = True
        Me.lblErstelltam.Location = New System.Drawing.Point(203, 268)
        Me.lblErstelltam.Name = "lblErstelltam"
        Me.lblErstelltam.Size = New System.Drawing.Size(58, 13)
        Me.lblErstelltam.TabIndex = 124
        Me.lblErstelltam.Text = "Erstellt am:"
        '
        'txtBemerkung
        '
        Me.txtBemerkung.Location = New System.Drawing.Point(14, 182)
        Me.txtBemerkung.Multiline = True
        Me.txtBemerkung.Name = "txtBemerkung"
        Me.txtBemerkung.Size = New System.Drawing.Size(626, 72)
        Me.txtBemerkung.TabIndex = 121
        '
        'lblBemerkung
        '
        Me.lblBemerkung.AccessibleDescription = "Name"
        Me.lblBemerkung.AutoSize = True
        Me.lblBemerkung.Location = New System.Drawing.Point(11, 166)
        Me.lblBemerkung.Name = "lblBemerkung"
        Me.lblBemerkung.Size = New System.Drawing.Size(61, 13)
        Me.lblBemerkung.TabIndex = 123
        Me.lblBemerkung.Text = "Bemerkung"
        '
        'lblZeitspanne
        '
        Me.lblZeitspanne.AutoSize = True
        Me.lblZeitspanne.Location = New System.Drawing.Point(12, 65)
        Me.lblZeitspanne.Name = "lblZeitspanne"
        Me.lblZeitspanne.Size = New System.Drawing.Size(60, 13)
        Me.lblZeitspanne.TabIndex = 131
        Me.lblZeitspanne.Text = "Zeitspanne"
        '
        'txtZeitspanne
        '
        Me.txtZeitspanne.Location = New System.Drawing.Point(109, 62)
        Me.txtZeitspanne.Name = "txtZeitspanne"
        Me.txtZeitspanne.Size = New System.Drawing.Size(200, 20)
        Me.txtZeitspanne.TabIndex = 132
        '
        'txtKuendigungsfrist
        '
        Me.txtKuendigungsfrist.Location = New System.Drawing.Point(109, 88)
        Me.txtKuendigungsfrist.Name = "txtKuendigungsfrist"
        Me.txtKuendigungsfrist.Size = New System.Drawing.Size(200, 20)
        Me.txtKuendigungsfrist.TabIndex = 134
        '
        'lblKuendigungsfrist
        '
        Me.lblKuendigungsfrist.AutoSize = True
        Me.lblKuendigungsfrist.Location = New System.Drawing.Point(12, 91)
        Me.lblKuendigungsfrist.Name = "lblKuendigungsfrist"
        Me.lblKuendigungsfrist.Size = New System.Drawing.Size(79, 13)
        Me.lblKuendigungsfrist.TabIndex = 133
        Me.lblKuendigungsfrist.Text = "Kündigungsfrist"
        '
        'cbAktiv
        '
        Me.cbAktiv.AutoSize = True
        Me.cbAktiv.Location = New System.Drawing.Point(109, 140)
        Me.cbAktiv.Name = "cbAktiv"
        Me.cbAktiv.Size = New System.Drawing.Size(15, 14)
        Me.cbAktiv.TabIndex = 135
        Me.cbAktiv.UseVisualStyleBackColor = True
        '
        'lblAktiv
        '
        Me.lblAktiv.AccessibleDescription = "Name"
        Me.lblAktiv.AutoSize = True
        Me.lblAktiv.Location = New System.Drawing.Point(12, 141)
        Me.lblAktiv.Name = "lblAktiv"
        Me.lblAktiv.Size = New System.Drawing.Size(31, 13)
        Me.lblAktiv.TabIndex = 136
        Me.lblAktiv.Text = "Aktiv"
        '
        'dtPickerKuendigungstermin
        '
        Me.dtPickerKuendigungstermin.Location = New System.Drawing.Point(172, 114)
        Me.dtPickerKuendigungstermin.Name = "dtPickerKuendigungstermin"
        Me.dtPickerKuendigungstermin.Size = New System.Drawing.Size(21, 20)
        Me.dtPickerKuendigungstermin.TabIndex = 138
        '
        'txtKuendigungstermin
        '
        Me.txtKuendigungstermin.Location = New System.Drawing.Point(109, 114)
        Me.txtKuendigungstermin.Mask = "00/00/0000"
        Me.txtKuendigungstermin.Name = "txtKuendigungstermin"
        Me.txtKuendigungstermin.Size = New System.Drawing.Size(66, 20)
        Me.txtKuendigungstermin.TabIndex = 137
        Me.txtKuendigungstermin.ValidatingType = GetType(Date)
        '
        'lblKuendigungstermin
        '
        Me.lblKuendigungstermin.AutoSize = True
        Me.lblKuendigungstermin.Location = New System.Drawing.Point(12, 117)
        Me.lblKuendigungstermin.Name = "lblKuendigungstermin"
        Me.lblKuendigungstermin.Size = New System.Drawing.Size(91, 13)
        Me.lblKuendigungstermin.TabIndex = 139
        Me.lblKuendigungstermin.Text = "Kündigungstermin"
        '
        'frmKuendigungsfrist
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(647, 291)
        Me.Controls.Add(Me.lblKuendigungstermin)
        Me.Controls.Add(Me.dtPickerKuendigungstermin)
        Me.Controls.Add(Me.txtKuendigungstermin)
        Me.Controls.Add(Me.cbAktiv)
        Me.Controls.Add(Me.lblAktiv)
        Me.Controls.Add(Me.txtKuendigungsfrist)
        Me.Controls.Add(Me.lblKuendigungsfrist)
        Me.Controls.Add(Me.txtZeitspanne)
        Me.Controls.Add(Me.lblZeitspanne)
        Me.Controls.Add(Me.cboxSecurityLevel)
        Me.Controls.Add(Me.lblSecurityLebel)
        Me.Controls.Add(Me.txtMutierer)
        Me.Controls.Add(Me.txtMutiert_am)
        Me.Controls.Add(Me.txtErstellt_am)
        Me.Controls.Add(Me.lblMutierer)
        Me.Controls.Add(Me.lblMutiert_am)
        Me.Controls.Add(Me.lblErstelltam)
        Me.Controls.Add(Me.txtBemerkung)
        Me.Controls.Add(Me.lblBemerkung)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Name = "frmKuendigungsfrist"
        Me.Text = "Kündigungsfrist"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


frmKuendigungsfrist.Load_Securitylevel Method

frmKuendigungsfrist.Load_Securitylevel Method

Laden der Securitylevel-Daten in die Combobox
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Load_Securitylevel()
C#
private System.Void Load_Securitylevel();
C++

private:
System::Void Load_Securitylevel()
JScript
private function Load_Securitylevel();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Load_Securitylevel()
        Dim seclevel As New TKB.VV.DB.clsSecurityLevel
        Dim secleveldata As New DataTable

        seclevel.cpMainConnectionProvider = Globals.conn
        Globals.conn.OpenConnection()
        secleveldata = seclevel.SelectAll
        Globals.conn.CloseConnection(True)

        Me.cboxSecurityLevel.DataSource = secleveldata
        Me.cboxSecurityLevel.DisplayMember = "Bezeichnung"
        Me.cboxSecurityLevel.ValueMember = "SecurityLevelNr"

        seclevel.Dispose()

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


frmKuendigungsfrist.Save_Data Method

frmKuendigungsfrist.Save_Data Method

Daten sichern, sofern Änderungen vorgenommen worden sind
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Save_Data()
C#
private System.Void Save_Data();
C++

private:
System::Void Save_Data()
JScript
private function Save_Data();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Save_Data()

        If Me.FormDataChanged Then
            Me.Kuendigungsfrist.sVarZeitspanne = New SqlString(CType(Me.txtZeitspanne.Text, String))
            Me.Kuendigungsfrist.sKuendigungsfirst = New SqlString(CType(Me.txtKuendigungsfrist.Text, String))
            If IsDate(Me.txtKuendigungstermin.Text) Then Me.Kuendigungsfrist.daKuendigungstermin = New SqlDateTime(CType(Me.txtKuendigungstermin.Text, DateTime))
            Me.Kuendigungsfrist.sBemerkung = New SqlString(CType(Me.txtBemerkung.Text, String))
            Me.Kuendigungsfrist.bAktiv = New SqlBoolean(CType(Me.cbAktiv.Checked, Boolean))
            Me.Kuendigungsfrist.iSecurityLevelNr = New SqlInt32(CType(Me.cboxSecurityLevel.SelectedValue, Int32))
            Get_Data(Me.Kuendigungsfrist.Save_Data)
            Me.FormDataChanged = False
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


frmKuendigungsfrist.TSBtnCopy_Click Method

frmKuendigungsfrist.TSBtnCopy_Click Method

kopieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnCopy_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnCopy.Click
C#
private System.Void TSBtnCopy_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnCopy_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnCopy_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnCopy_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnCopy.Click
        Try
            Check_Changes()
            Me.Get_Data(Kuendigungsfrist.Create_Copy(Me.Kuendigungsfrist.iKuendigungsfristNr.Value))
        Catch
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


frmKuendigungsfrist.TSBtnDelete_Click Method

frmKuendigungsfrist.TSBtnDelete_Click Method

löschen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click
C#
private System.Void TSBtnDelete_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnDelete_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnDelete_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
        If msg.Show_MessageYesNo(260) = MsgBoxResult.Yes Then
            Me.Kuendigungsfrist.Delete_Kuendigungsfrist(Me.Kuendigungsfrist.iKuendigungsfristNr.Value)
            Me.Close()
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


frmKuendigungsfrist.TSBtnNew_Click Method

frmKuendigungsfrist.TSBtnNew_Click Method

Neu
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnNew_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnNew.Click
C#
private System.Void TSBtnNew_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnNew_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnNew_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnNew.Click
        Try
            Me.Get_Data(Me.Kuendigungsfrist.Add_New(Me.Vertragselementnr))
        Catch
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


frmKuendigungsfrist.TSBtnQuit_Click Method

frmKuendigungsfrist.TSBtnQuit_Click Method

Schliessen-Button betätigt
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click
C#
private System.Void TSBtnQuit_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnQuit_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnQuit_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


frmKuendigungsfrist.TSBtnSave_Click Method

frmKuendigungsfrist.TSBtnSave_Click Method

Save-Button geklickt
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click
C#
private System.Void TSBtnSave_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnSave_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnSave_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Me.Save_Data()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


frmKuendigungsfrist.frmKuendigungsfrist_Load Method

frmKuendigungsfrist.frmKuendigungsfrist_Load Method

Laden des Formulars
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub frmKuendigungsfrist_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load
C#
private System.Void frmKuendigungsfrist_Load(
   object sender,
   EventArgs e
);
C++

private:
System::Void frmKuendigungsfrist_Load(
   object^ sender,
   EventArgs^ e
)
JScript
private function frmKuendigungsfrist_Load(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub frmKuendigungsfrist_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        sec.Set_Form_Security(Me)

        If Me.FormReadonly = True Then Me.TSBtnSave.Enabled = False

        If Me.TSBtnSave.Enabled = False Or Me.TSBtnSave.Visible = False Then
            Me.FormReadonly = True
            Me.TSBtnCopy.Enabled = False
            Me.TSBtnNew.Enabled = False
            Me.TSBtnDelete.Enabled = False
        Else
            Me.FormReadonly = False
        End If

        Load_Securitylevel()
        Get_Data(Kuendigungsfristnr)
        Me.AddChanges(Me)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


frmKuendigungsfrist Fields

frmKuendigungsfrist Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | FormDataChanged |
Supported by the .NET Compact Framework. | FormReadonly |
Supported by the .NET Compact Framework. | Kuendigungsfrist |
Supported by the .NET Compact Framework. | Kuendigungsfristnr |
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | m_vertragselementnr |
Supported by the .NET Compact Framework. | msg |
Supported by the .NET Compact Framework. | sec |
Top

Expand image See Also

Reference

frmKuendigungsfrist Class
TKB.VV.Utils
TKB.VV.Utils.MyMessage
TKB.VV.Utils.MySecurity


FormDataChanged Variable

FormDataChanged Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private FormDataChanged As Boolean
C#
private bool FormDataChanged;
C++
private:
bool FormDataChanged;
JScript
private FormDataChanged : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim FormDataChanged As Boolean = False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


FormReadonly Variable

FormReadonly Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private FormReadonly As Boolean
C#
private bool FormReadonly;
C++
private:
bool FormReadonly;
JScript
private FormReadonly : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim FormReadonly As Boolean = False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


Kuendigungsfrist Variable

Kuendigungsfrist Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Kuendigungsfrist As clsKuendigungsfrist
C#
private clsKuendigungsfrist Kuendigungsfrist;
C++
private:
clsKuendigungsfrist^ Kuendigungsfrist;
JScript
private Kuendigungsfrist : clsKuendigungsfrist

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Kuendigungsfrist As New TKB.VV.Vertrag.clsKuendigungsfrist

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


Kuendigungsfristnr Variable

Kuendigungsfristnr Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Kuendigungsfristnr As Integer
C#
private int Kuendigungsfristnr;
C++
private:
int Kuendigungsfristnr;
JScript
private Kuendigungsfristnr : int

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Kuendigungsfristnr As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


components Variable

components Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private components As IContainer
C#
private IContainer components;
C++
private:
IContainer^ components;
JScript
private components : IContainer

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private components As System.ComponentModel.IContainer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


m_vertragselementnr Variable

m_vertragselementnr Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_vertragselementnr As Integer
C#
private int m_vertragselementnr;
C++
private:
int m_vertragselementnr;
JScript
private m_vertragselementnr : int

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim m_vertragselementnr As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


msg Variable

msg Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private msg As MyMessage
C#
private MyMessage msg;
C++
private:
MyMessage^ msg;
JScript
private msg : MyMessage

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim msg As New TKB.VV.Utils.MyMessage

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


sec Variable

sec Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private sec As MySecurity
C#
private MySecurity sec;
C++
private:
MySecurity^ sec;
JScript
private sec : MySecurity

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim sec As New TKB.VV.Utils.MySecurity

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


frmLogin Class

frmLogin Class
Members
collapseAll image DropDown image

Form für den Login. Wird nur angezeigt, sofern in der Tabelle Application Show-Login = true
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class frmLogin
    Inherits Form
C#
public class frmLogin : Form
C++

public ref class frmLogin : public Form^
JScript
public class frmLogin
   extends Form

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmLogin

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmLogin Members


frmLogin Members

frmLogin Members
See Also Methods Properties
CollapseAll image DropDown image

Form für den Login. Wird nur angezeigt, sofern in der Tabelle Application Show-Login = true

The following tables list the members exposed by the frmLogin type.

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Mitarbeiternr |
Top

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | btnAbbruch_Click |
Supported by the .NET Compact Framework. | btnAnmelden_Click |
Supported by the .NET Compact Framework. | frmLogin_Load |
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | conn |
Supported by the .NET Compact Framework. | m_mitarbeiternr |
Supported by the .NET Compact Framework. | tmp_clsmitarbeiter |
Supported by the .NET Compact Framework. | tmp_madaten |
Top

Expand image See Also

Reference

frmLogin Class


frmLogin Properties

frmLogin Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Mitarbeiternr |
Top

Expand image See Also

Reference

frmLogin Class


frmLogin.Mitarbeiternr Property

frmLogin.Mitarbeiternr Property

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property Mitarbeiternr() As Integer
C#
public int Mitarbeiternr {get; set;}
C++
public:
property int Mitarbeiternr {
 int get( );
 void set(
   int value
 );
}
JScript
public function get Mitarbeiternr() : int;
public function set Mitarbeiternr(value : int);

Expand image Source code

Visual Basic CopyCode image Copy Code
    Property Mitarbeiternr() As Integer
        Get
            Return m_mitarbeiternr
        End Get
        Set(ByVal value As Integer)
            m_mitarbeiternr = value
        End Set
    End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmLogin Class
frmLogin Members


frmLogin Methods

frmLogin Methods
CollapseAll image DropDown image

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | btnAbbruch_Click |
Supported by the .NET Compact Framework. | btnAnmelden_Click |
Supported by the .NET Compact Framework. | frmLogin_Load |
Top

Expand image See Also

Reference

frmLogin Class


frmLogin.Dispose Method

frmLogin.Dispose Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
C#
[System.Diagnostics.DebuggerNonUserCode()]
protected override System.Void Dispose(
   bool disposing
);
C++
[System.Diagnostics.DebuggerNonUserCode()]

protected:
System::Void Dispose(
   bool disposing
)
JScript
protected
   System.Diagnostics.DebuggerNonUserCode()
function Dispose(
    disposing : boolean
);

Parameters

disposing

Expand image Source code

Visual Basic CopyCode image Copy Code
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmLogin Class
frmLogin Members


frmLogin.InitializeComponent Method

frmLogin.InitializeComponent Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()
C#
[System.Diagnostics.DebuggerStepThrough()]
private System.Void InitializeComponent();
C++
[System.Diagnostics.DebuggerStepThrough()]

private:
System::Void InitializeComponent()
JScript
private
   System.Diagnostics.DebuggerStepThrough()
function InitializeComponent();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmLogin))
        Me.lblBitteAnmelden = New System.Windows.Forms.Label
        Me.cbMitarbeiter = New System.Windows.Forms.ComboBox
        Me.btnAbbruch = New System.Windows.Forms.Button
        Me.btnAnmelden = New System.Windows.Forms.Button
        Me.SuspendLayout()
        '
        'lblBitteAnmelden
        '
        Me.lblBitteAnmelden.Location = New System.Drawing.Point(12, 9)
        Me.lblBitteAnmelden.Name = "lblBitteAnmelden"
        Me.lblBitteAnmelden.Size = New System.Drawing.Size(136, 23)
        Me.lblBitteAnmelden.TabIndex = 3
        Me.lblBitteAnmelden.Text = "Bitte melden Sie sich an"
        '
        'cbMitarbeiter
        '
        Me.cbMitarbeiter.AutoCompleteMode = System.Windows.Forms.AutoCompleteMode.Append
        Me.cbMitarbeiter.AutoCompleteSource = System.Windows.Forms.AutoCompleteSource.ListItems
        Me.cbMitarbeiter.FormattingEnabled = True
        Me.cbMitarbeiter.Location = New System.Drawing.Point(15, 35)
        Me.cbMitarbeiter.Name = "cbMitarbeiter"
        Me.cbMitarbeiter.Size = New System.Drawing.Size(257, 21)
        Me.cbMitarbeiter.TabIndex = 4
        '
        'btnAbbruch
        '
        Me.btnAbbruch.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.btnAbbruch.Location = New System.Drawing.Point(158, 76)
        Me.btnAbbruch.Name = "btnAbbruch"
        Me.btnAbbruch.Size = New System.Drawing.Size(104, 24)
        Me.btnAbbruch.TabIndex = 6
        Me.btnAbbruch.Text = "&Abbruch"
        '
        'btnAnmelden
        '
        Me.btnAnmelden.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.btnAnmelden.Location = New System.Drawing.Point(14, 76)
        Me.btnAnmelden.Name = "btnAnmelden"
        Me.btnAnmelden.Size = New System.Drawing.Size(104, 24)
        Me.btnAnmelden.TabIndex = 5
        Me.btnAnmelden.Text = "&Anmelden"
        '
        'frmLogin
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(308, 129)
        Me.Controls.Add(Me.btnAbbruch)
        Me.Controls.Add(Me.btnAnmelden)
        Me.Controls.Add(Me.cbMitarbeiter)
        Me.Controls.Add(Me.lblBitteAnmelden)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmLogin"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Benutzerauswahl TKB-Vertragsverwaltung"
        Me.ResumeLayout(False)

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmLogin Class
frmLogin Members


frmLogin.btnAbbruch_Click Method

frmLogin.btnAbbruch_Click Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub btnAbbruch_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnAbbruch.Click
C#
private System.Void btnAbbruch_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void btnAbbruch_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function btnAbbruch_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub btnAbbruch_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnAbbruch.Click
        Me.Mitarbeiternr = -1
        Me.DialogResult = Windows.Forms.DialogResult.Cancel
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmLogin Class
frmLogin Members


frmLogin.btnAnmelden_Click Method

frmLogin.btnAnmelden_Click Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub btnAnmelden_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnAnmelden.Click
C#
private System.Void btnAnmelden_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void btnAnmelden_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function btnAnmelden_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub btnAnmelden_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnAnmelden.Click
        Me.Mitarbeiternr = Me.cbMitarbeiter.SelectedValue
        Me.DialogResult = Windows.Forms.DialogResult.OK
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmLogin Class
frmLogin Members


frmLogin.frmLogin_Load Method

frmLogin.frmLogin_Load Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub frmLogin_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load
C#
private System.Void frmLogin_Load(
   object sender,
   EventArgs e
);
C++

private:
System::Void frmLogin_Load(
   object^ sender,
   EventArgs^ e
)
JScript
private function frmLogin_Load(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub frmLogin_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        conn = Globals.conn
        tmp_clsmitarbeiter.cpMainConnectionProvider = conn
        conn.OpenConnection()
        tmp_madaten = tmp_clsmitarbeiter.SelectAllwithFullname
        Me.cbMitarbeiter.DataSource = tmp_madaten
        Me.cbMitarbeiter.DisplayMember = "Fullname"
        Me.cbMitarbeiter.ValueMember = "Mitarbeiternr"
        conn.CloseConnection(True)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmLogin Class
frmLogin Members


frmLogin Fields

frmLogin Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | conn |
Supported by the .NET Compact Framework. | m_mitarbeiternr |
Supported by the .NET Compact Framework. | tmp_clsmitarbeiter |
Supported by the .NET Compact Framework. | tmp_madaten |
Top

Expand image See Also

Reference

frmLogin Class


components Variable

components Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private components As IContainer
C#
private IContainer components;
C++
private:
IContainer^ components;
JScript
private components : IContainer

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private components As System.ComponentModel.IContainer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmLogin Class
frmLogin Members


conn Variable

conn Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private conn As clsConnectionProvider
C#
private clsConnectionProvider conn;
C++
private:
clsConnectionProvider^ conn;
JScript
private conn : clsConnectionProvider

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim conn As New TKB.VV.DB.clsConnectionProvider

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmLogin Class
frmLogin Members


m_mitarbeiternr Variable

m_mitarbeiternr Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_mitarbeiternr As Integer
C#
private int m_mitarbeiternr;
C++
private:
int m_mitarbeiternr;
JScript
private m_mitarbeiternr : int

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim m_mitarbeiternr As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmLogin Class
frmLogin Members


tmp_clsmitarbeiter Variable

tmp_clsmitarbeiter Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private tmp_clsmitarbeiter As MyMitarbeiter
C#
private MyMitarbeiter tmp_clsmitarbeiter;
C++
private:
MyMitarbeiter^ tmp_clsmitarbeiter;
JScript
private tmp_clsmitarbeiter : MyMitarbeiter

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim tmp_clsmitarbeiter As New TKB.VV.DB.MyMitarbeiter

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmLogin Class
frmLogin Members


tmp_madaten Variable

tmp_madaten Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private tmp_madaten As DataTable
C#
private DataTable tmp_madaten;
C++
private:
DataTable^ tmp_madaten;
JScript
private tmp_madaten : DataTable

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim tmp_madaten As New DataTable

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmLogin Class
frmLogin Members


frmMain Class

frmMain Class
Members
collapseAll image DropDown image

Hauptformular der Vertragsverwaltung als MDI-Container
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmMain
    Inherits Form
C#
[Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()]
public class frmMain : Form
C++
[Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()]

public ref class frmMain : public Form^
JScript
public
   Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()
class frmMain
   extends Form

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmMain

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmMain Members


frmMain Members

frmMain Members
See Also Methods
CollapseAll image DropDown image

Hauptformular der Vertragsverwaltung als MDI-Container

The following tables list the members exposed by the frmMain type.

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | BeendenToolStripMenuItem_Click | Menu Beenden betätigt
Supported by the .NET Compact Framework. | ImageViewerToolStripMenuItem_Click |
Supported by the .NET Compact Framework. | Init_System | System-Initialosierung - Applikationsdaten auslesen - Aktueller Mitarbeiter auslesen bzw. Login-Dialog anzeigen
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | Login | Login-Fenster anzeigen und neuen User anmelden
Supported by the .NET Compact Framework. | NeuAnmeldenToolStripMenuItem_Click |
Supported by the .NET Compact Framework. | ObjectListerToolStripMenuItem_Click | Zeigt eine Liste sämtlicher offener MDI-Formulare an. Nach Auswahl wird für das selektierte Formular die Security-Objekt-Tabelle generier
Supported by the .NET Compact Framework. | SLAKatalogVerwaltenToolStripMenuItem_Click |
Supported by the .NET Compact Framework. | SLAToolStripMenuItem_Click | Aufruf der Funktion für die Verwaltung der SLA-Typen
Supported by the .NET Compact Framework. | SLAZeiteinheitenVerwaltenToolStripMenuItem_Click | Aufrunf der Funktion für die Verwaltung der Zeiteinheittypen
Supported by the .NET Compact Framework. | ServicekatalogVerwaltenToolStripMenuItem_Click |
Supported by the .NET Compact Framework. | SystemadministrationToolStripMenuItem_Click | Aufruf System-Administration
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Quit-Button
Supported by the .NET Compact Framework. | VertragselementeToolStripMenuItem_Click | Vertragselement anzeigen
Supported by the .NET Compact Framework. | VertragspartnerToolStripMenuItem_Click | Vertragspartner anzeigen
Supported by the .NET Compact Framework. | VertragsübersichtToolStripMenuItem_Click | Vertragsübersicht anzeigen
Supported by the .NET Compact Framework. | frmMain_FormClosing | Beim schliessen des Formulars wird der User gefragt, ob die Applikation geschlossen werden soll.
Supported by the .NET Compact Framework. | frmMain_Load | Laden des Formulars
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | ForceQuit |
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | sec |
Supported by the .NET Compact Framework. | txt |
Top

Expand image See Also

Reference

frmMain Class


frmMain Methods

frmMain Methods
CollapseAll image DropDown image

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | BeendenToolStripMenuItem_Click | Menu Beenden betätigt
Supported by the .NET Compact Framework. | ImageViewerToolStripMenuItem_Click |
Supported by the .NET Compact Framework. | Init_System | System-Initialosierung - Applikationsdaten auslesen - Aktueller Mitarbeiter auslesen bzw. Login-Dialog anzeigen
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | Login | Login-Fenster anzeigen und neuen User anmelden
Supported by the .NET Compact Framework. | NeuAnmeldenToolStripMenuItem_Click |
Supported by the .NET Compact Framework. | ObjectListerToolStripMenuItem_Click | Zeigt eine Liste sämtlicher offener MDI-Formulare an. Nach Auswahl wird für das selektierte Formular die Security-Objekt-Tabelle generier
Supported by the .NET Compact Framework. | SLAKatalogVerwaltenToolStripMenuItem_Click |
Supported by the .NET Compact Framework. | SLAToolStripMenuItem_Click | Aufruf der Funktion für die Verwaltung der SLA-Typen
Supported by the .NET Compact Framework. | SLAZeiteinheitenVerwaltenToolStripMenuItem_Click | Aufrunf der Funktion für die Verwaltung der Zeiteinheittypen
Supported by the .NET Compact Framework. | ServicekatalogVerwaltenToolStripMenuItem_Click |
Supported by the .NET Compact Framework. | SystemadministrationToolStripMenuItem_Click | Aufruf System-Administration
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Quit-Button
Supported by the .NET Compact Framework. | VertragselementeToolStripMenuItem_Click | Vertragselement anzeigen
Supported by the .NET Compact Framework. | VertragspartnerToolStripMenuItem_Click | Vertragspartner anzeigen
Supported by the .NET Compact Framework. | VertragsübersichtToolStripMenuItem_Click | Vertragsübersicht anzeigen
Supported by the .NET Compact Framework. | frmMain_FormClosing | Beim schliessen des Formulars wird der User gefragt, ob die Applikation geschlossen werden soll.
Supported by the .NET Compact Framework. | frmMain_Load | Laden des Formulars
Top

Expand image See Also

Reference

frmMain Class


frmMain.BeendenToolStripMenuItem_Click Method

frmMain.BeendenToolStripMenuItem_Click Method

Menu Beenden betätigt
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click
C#
private System.Void BeendenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void BeendenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function BeendenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        TSBtnQuit_Click(sender, e)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmMain Class
frmMain Members


frmMain.Dispose Method

frmMain.Dispose Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
C#
[System.Diagnostics.DebuggerNonUserCode()]
protected override System.Void Dispose(
   bool disposing
);
C++
[System.Diagnostics.DebuggerNonUserCode()]

protected:
System::Void Dispose(
   bool disposing
)
JScript
protected
   System.Diagnostics.DebuggerNonUserCode()
function Dispose(
    disposing : boolean
);

Parameters

disposing

Expand image Source code

Visual Basic CopyCode image Copy Code
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmMain Class
frmMain Members


frmMain.ImageViewerToolStripMenuItem_Click Method

frmMain.ImageViewerToolStripMenuItem_Click Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub ImageViewerToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ImageViewerToolStripMenuItem.Click
C#
private System.Void ImageViewerToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void ImageViewerToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function ImageViewerToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub ImageViewerToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ImageViewerToolStripMenuItem.Click
        Dim f As New Form1
        f.MdiParent = Me
        f.Show()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmMain Class
frmMain Members


frmMain.Init_System Method

frmMain.Init_System Method

System-Initialosierung - Applikationsdaten auslesen - Aktueller Mitarbeiter auslesen bzw. Login-Dialog anzeigen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Init_System()
C#
private System.Void Init_System();
C++

private:
System::Void Init_System()
JScript
private function Init_System();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Init_System()
        '       Dim dbconn As New TKB.VV.DB.DB_Connection
        '      dbconn = Nothing

        Globals.clsapplication.iApplikationsnr = 1
        Globals.clsapplication.cpMainConnectionProvider = Globals.conn
        conn.OpenConnection()
        Globals.clsapplication.SelectOne()
        conn.CloseConnection(True)

        'Show Login, sofern der Applikationsparameter gesetzt ist
        If Globals.clsapplication.bShowlogin.Value = True Then
            login()

            Me.WindowState = FormWindowState.Maximized
        Else
            'Prüfung mittels TG-Nummer, ob der User berechtigt ist
            Dim tmp_mitarbeiter As New TKB.VV.DB.MyMitarbeiter
            Dim tmp_mitarbeiterdata As New DataTable
            tmp_mitarbeiter.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            tmp_mitarbeiterdata = tmp_mitarbeiter.SelectWithTGNummer()
            Globals.conn.CloseConnection(True)
            If tmp_mitarbeiterdata.Rows.Count < 1 Then
                txt.show_standardmessage(2, MsgBoxStyle.Exclamation)
                Me.ForceQuit = True
                Me.Close()
                Exit Sub
            End If
            Globals.clsmitarbeiter.iMitarbeiternr = New SqlInt32(CType(tmp_mitarbeiterdata.Rows(0).Item("Mitarbeiternr"), Int32))
            Globals.clsmitarbeiter.cpMainConnectionProvider = Globals.conn
            conn.OpenConnection()
            Globals.clsmitarbeiter.SelectOne()
            Globals.conn.CloseConnection(True)
            tmp_mitarbeiter.Dispose()
            tmp_mitarbeiterdata.Dispose()
            Me.WindowState = FormWindowState.Maximized
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmMain Class
frmMain Members


frmMain.InitializeComponent Method

frmMain.InitializeComponent Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()
C#
[System.Diagnostics.DebuggerStepThrough()]
private System.Void InitializeComponent();
C++
[System.Diagnostics.DebuggerStepThrough()]

private:
System::Void InitializeComponent()
JScript
private
   System.Diagnostics.DebuggerStepThrough()
function InitializeComponent();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmMain))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.NeuAnmeldenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.VertragsmanagementToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.VertragspartnerToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.VertragselementeToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.MonitoringToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ServiceKatalogToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.SLATypenverwaltenStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.SLAZeiteinheitenVerwaltenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStripMenuItem2 = New System.Windows.Forms.ToolStripSeparator
        Me.SLAKatalogVerwaltenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ServicekatalogVerwaltenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ApplikationsverwaltungToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ReportingToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ExtrasToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.SystemadministrationToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ObjectListerToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ImageViewerToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.FensterToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.KaskadierenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.VertikalTeilenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.HorizontalTeilenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStripMenuItem1 = New System.Windows.Forms.ToolStripSeparator
        Me.HilfeToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.ToolStripButton2 = New System.Windows.Forms.ToolStripButton
        Me.ToolStripButton3 = New System.Windows.Forms.ToolStripButton
        Me.ToolStripButton4 = New System.Windows.Forms.ToolStripButton
        Me.StatusStrip1 = New System.Windows.Forms.StatusStrip
        Me.ToolStripUser = New System.Windows.Forms.ToolStripStatusLabel
        Me.ToolStripDatabase = New System.Windows.Forms.ToolStripStatusLabel
        Me.VertragsübersichtToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStripMenuItem3 = New System.Windows.Forms.ToolStripSeparator
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.StatusStrip1.SuspendLayout()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem, Me.VertragsmanagementToolStripMenuItem, Me.MonitoringToolStripMenuItem, Me.ServiceKatalogToolStripMenuItem, Me.ApplikationsverwaltungToolStripMenuItem, Me.ReportingToolStripMenuItem, Me.ExtrasToolStripMenuItem, Me.FensterToolStripMenuItem, Me.HilfeToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.MdiWindowListItem = Me.FensterToolStripMenuItem
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(830, 24)
        Me.MenuStrip1.TabIndex = 1
        Me.MenuStrip1.Tag = ""
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem, Me.NeuAnmeldenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Tag = ""
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(153, 22)
        Me.BeendenToolStripMenuItem.Tag = "Beenden"
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'NeuAnmeldenToolStripMenuItem
        '
        Me.NeuAnmeldenToolStripMenuItem.Name = "NeuAnmeldenToolStripMenuItem"
        Me.NeuAnmeldenToolStripMenuItem.Size = New System.Drawing.Size(153, 22)
        Me.NeuAnmeldenToolStripMenuItem.Tag = ""
        Me.NeuAnmeldenToolStripMenuItem.Text = "&Neu anmelden"
        '
        'VertragsmanagementToolStripMenuItem
        '
        Me.VertragsmanagementToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.VertragsübersichtToolStripMenuItem, Me.ToolStripMenuItem3, Me.VertragspartnerToolStripMenuItem, Me.VertragselementeToolStripMenuItem})
        Me.VertragsmanagementToolStripMenuItem.Name = "VertragsmanagementToolStripMenuItem"
        Me.VertragsmanagementToolStripMenuItem.Size = New System.Drawing.Size(122, 20)
        Me.VertragsmanagementToolStripMenuItem.Tag = ""
        Me.VertragsmanagementToolStripMenuItem.Text = "&Vertragsmanagement"
        '
        'VertragspartnerToolStripMenuItem
        '
        Me.VertragspartnerToolStripMenuItem.Name = "VertragspartnerToolStripMenuItem"
        Me.VertragspartnerToolStripMenuItem.Size = New System.Drawing.Size(170, 22)
        Me.VertragspartnerToolStripMenuItem.Tag = ""
        Me.VertragspartnerToolStripMenuItem.Text = "&Vertragspartner"
        '
        'VertragselementeToolStripMenuItem
        '
        Me.VertragselementeToolStripMenuItem.Name = "VertragselementeToolStripMenuItem"
        Me.VertragselementeToolStripMenuItem.Size = New System.Drawing.Size(170, 22)
        Me.VertragselementeToolStripMenuItem.Text = "&Vertragselemente"
        '
        'MonitoringToolStripMenuItem
        '
        Me.MonitoringToolStripMenuItem.Name = "MonitoringToolStripMenuItem"
        Me.MonitoringToolStripMenuItem.Size = New System.Drawing.Size(69, 20)
        Me.MonitoringToolStripMenuItem.Tag = ""
        Me.MonitoringToolStripMenuItem.Text = "&Monitoring"
        '
        'ServiceKatalogToolStripMenuItem
        '
        Me.ServiceKatalogToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.SLATypenverwaltenStripMenuItem, Me.SLAZeiteinheitenVerwaltenToolStripMenuItem, Me.ToolStripMenuItem2, Me.SLAKatalogVerwaltenToolStripMenuItem, Me.ServicekatalogVerwaltenToolStripMenuItem})
        Me.ServiceKatalogToolStripMenuItem.Name = "ServiceKatalogToolStripMenuItem"
        Me.ServiceKatalogToolStripMenuItem.Size = New System.Drawing.Size(94, 20)
        Me.ServiceKatalogToolStripMenuItem.Tag = ""
        Me.ServiceKatalogToolStripMenuItem.Text = "&Service-Katalog"
        '
        'SLATypenverwaltenStripMenuItem
        '
        Me.SLATypenverwaltenStripMenuItem.Name = "SLATypenverwaltenStripMenuItem"
        Me.SLATypenverwaltenStripMenuItem.Size = New System.Drawing.Size(220, 22)
        Me.SLATypenverwaltenStripMenuItem.Tag = ""
        Me.SLATypenverwaltenStripMenuItem.Text = "SLA-&Typen verwalten"
        '
        'SLAZeiteinheitenVerwaltenToolStripMenuItem
        '
        Me.SLAZeiteinheitenVerwaltenToolStripMenuItem.Name = "SLAZeiteinheitenVerwaltenToolStripMenuItem"
        Me.SLAZeiteinheitenVerwaltenToolStripMenuItem.Size = New System.Drawing.Size(220, 22)
        Me.SLAZeiteinheitenVerwaltenToolStripMenuItem.Tag = ""
        Me.SLAZeiteinheitenVerwaltenToolStripMenuItem.Text = "SLA-&Zeiteinheiten verwalten"
        '
        'ToolStripMenuItem2
        '
        Me.ToolStripMenuItem2.Name = "ToolStripMenuItem2"
        Me.ToolStripMenuItem2.Size = New System.Drawing.Size(217, 6)
        '
        'SLAKatalogVerwaltenToolStripMenuItem
        '
        Me.SLAKatalogVerwaltenToolStripMenuItem.Name = "SLAKatalogVerwaltenToolStripMenuItem"
        Me.SLAKatalogVerwaltenToolStripMenuItem.Size = New System.Drawing.Size(220, 22)
        Me.SLAKatalogVerwaltenToolStripMenuItem.Tag = ""
        Me.SLAKatalogVerwaltenToolStripMenuItem.Text = "SLA-&Katalog verwalten"
        '
        'ServicekatalogVerwaltenToolStripMenuItem
        '
        Me.ServicekatalogVerwaltenToolStripMenuItem.Name = "ServicekatalogVerwaltenToolStripMenuItem"
        Me.ServicekatalogVerwaltenToolStripMenuItem.Size = New System.Drawing.Size(220, 22)
        Me.ServicekatalogVerwaltenToolStripMenuItem.Tag = ""
        Me.ServicekatalogVerwaltenToolStripMenuItem.Text = "&Servicekatalog verwalten"
        '
        'ApplikationsverwaltungToolStripMenuItem
        '
        Me.ApplikationsverwaltungToolStripMenuItem.Name = "ApplikationsverwaltungToolStripMenuItem"
        Me.ApplikationsverwaltungToolStripMenuItem.Size = New System.Drawing.Size(130, 20)
        Me.ApplikationsverwaltungToolStripMenuItem.Tag = ""
        Me.ApplikationsverwaltungToolStripMenuItem.Text = "Applikationsverwaltung"
        '
        'ReportingToolStripMenuItem
        '
        Me.ReportingToolStripMenuItem.Name = "ReportingToolStripMenuItem"
        Me.ReportingToolStripMenuItem.Size = New System.Drawing.Size(66, 20)
        Me.ReportingToolStripMenuItem.Tag = ""
        Me.ReportingToolStripMenuItem.Text = "&Reporting"
        '
        'ExtrasToolStripMenuItem
        '
        Me.ExtrasToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.SystemadministrationToolStripMenuItem, Me.ObjectListerToolStripMenuItem, Me.ImageViewerToolStripMenuItem})
        Me.ExtrasToolStripMenuItem.Name = "ExtrasToolStripMenuItem"
        Me.ExtrasToolStripMenuItem.Size = New System.Drawing.Size(50, 20)
        Me.ExtrasToolStripMenuItem.Tag = ""
        Me.ExtrasToolStripMenuItem.Text = "&Extras"
        '
        'SystemadministrationToolStripMenuItem
        '
        Me.SystemadministrationToolStripMenuItem.Name = "SystemadministrationToolStripMenuItem"
        Me.SystemadministrationToolStripMenuItem.Size = New System.Drawing.Size(187, 22)
        Me.SystemadministrationToolStripMenuItem.Tag = ""
        Me.SystemadministrationToolStripMenuItem.Text = "&Systemadministration"
        '
        'ObjectListerToolStripMenuItem
        '
        Me.ObjectListerToolStripMenuItem.Name = "ObjectListerToolStripMenuItem"
        Me.ObjectListerToolStripMenuItem.Size = New System.Drawing.Size(187, 22)
        Me.ObjectListerToolStripMenuItem.Text = "&Objektlister"
        '
        'ImageViewerToolStripMenuItem
        '
        Me.ImageViewerToolStripMenuItem.Name = "ImageViewerToolStripMenuItem"
        Me.ImageViewerToolStripMenuItem.Size = New System.Drawing.Size(187, 22)
        Me.ImageViewerToolStripMenuItem.Text = "ImageViewer"
        '
        'FensterToolStripMenuItem
        '
        Me.FensterToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.KaskadierenToolStripMenuItem, Me.VertikalTeilenToolStripMenuItem, Me.HorizontalTeilenToolStripMenuItem, Me.ToolStripMenuItem1})
        Me.FensterToolStripMenuItem.Name = "FensterToolStripMenuItem"
        Me.FensterToolStripMenuItem.Size = New System.Drawing.Size(56, 20)
        Me.FensterToolStripMenuItem.Tag = ""
        Me.FensterToolStripMenuItem.Text = "&Fenster"
        '
        'KaskadierenToolStripMenuItem
        '
        Me.KaskadierenToolStripMenuItem.Name = "KaskadierenToolStripMenuItem"
        Me.KaskadierenToolStripMenuItem.Size = New System.Drawing.Size(162, 22)
        Me.KaskadierenToolStripMenuItem.Tag = ""
        Me.KaskadierenToolStripMenuItem.Text = "&Kaskadieren"
        '
        'VertikalTeilenToolStripMenuItem
        '
        Me.VertikalTeilenToolStripMenuItem.Name = "VertikalTeilenToolStripMenuItem"
        Me.VertikalTeilenToolStripMenuItem.Size = New System.Drawing.Size(162, 22)
        Me.VertikalTeilenToolStripMenuItem.Tag = ""
        Me.VertikalTeilenToolStripMenuItem.Text = "&Vertikal teilen"
        '
        'HorizontalTeilenToolStripMenuItem
        '
        Me.HorizontalTeilenToolStripMenuItem.Name = "HorizontalTeilenToolStripMenuItem"
        Me.HorizontalTeilenToolStripMenuItem.Size = New System.Drawing.Size(162, 22)
        Me.HorizontalTeilenToolStripMenuItem.Tag = ""
        Me.HorizontalTeilenToolStripMenuItem.Text = "&Horizontal teilen"
        '
        'ToolStripMenuItem1
        '
        Me.ToolStripMenuItem1.Name = "ToolStripMenuItem1"
        Me.ToolStripMenuItem1.Size = New System.Drawing.Size(159, 6)
        '
        'HilfeToolStripMenuItem
        '
        Me.HilfeToolStripMenuItem.Name = "HilfeToolStripMenuItem"
        Me.HilfeToolStripMenuItem.Size = New System.Drawing.Size(40, 20)
        Me.HilfeToolStripMenuItem.Tag = ""
        Me.HilfeToolStripMenuItem.Text = "&Hilfe"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.ToolStripButton2, Me.ToolStripButton3, Me.ToolStripButton4})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(830, 25)
        Me.ToolStrip1.TabIndex = 3
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Anwendung beenden"
        '
        'ToolStripButton2
        '
        Me.ToolStripButton2.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.ToolStripButton2.Image = CType(resources.GetObject("ToolStripButton2.Image"), System.Drawing.Image)
        Me.ToolStripButton2.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.ToolStripButton2.Name = "ToolStripButton2"
        Me.ToolStripButton2.Size = New System.Drawing.Size(23, 22)
        Me.ToolStripButton2.Text = "ToolStripButton2"
        '
        'ToolStripButton3
        '
        Me.ToolStripButton3.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.ToolStripButton3.Image = CType(resources.GetObject("ToolStripButton3.Image"), System.Drawing.Image)
        Me.ToolStripButton3.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.ToolStripButton3.Name = "ToolStripButton3"
        Me.ToolStripButton3.Size = New System.Drawing.Size(23, 22)
        Me.ToolStripButton3.Text = "ToolStripButton3"
        '
        'ToolStripButton4
        '
        Me.ToolStripButton4.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.ToolStripButton4.Image = CType(resources.GetObject("ToolStripButton4.Image"), System.Drawing.Image)
        Me.ToolStripButton4.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.ToolStripButton4.Name = "ToolStripButton4"
        Me.ToolStripButton4.Size = New System.Drawing.Size(23, 22)
        Me.ToolStripButton4.Text = "ToolStripButton4"
        '
        'StatusStrip1
        '
        Me.StatusStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.ToolStripUser, Me.ToolStripDatabase})
        Me.StatusStrip1.Location = New System.Drawing.Point(0, 466)
        Me.StatusStrip1.Name = "StatusStrip1"
        Me.StatusStrip1.Size = New System.Drawing.Size(830, 22)
        Me.StatusStrip1.TabIndex = 5
        Me.StatusStrip1.Text = "StatusStrip1"
        '
        'ToolStripUser
        '
        Me.ToolStripUser.Name = "ToolStripUser"
        Me.ToolStripUser.Size = New System.Drawing.Size(0, 17)
        '
        'ToolStripDatabase
        '
        Me.ToolStripDatabase.Name = "ToolStripDatabase"
        Me.ToolStripDatabase.Size = New System.Drawing.Size(0, 17)
        '
        'VertragsübersichtToolStripMenuItem
        '
        Me.VertragsübersichtToolStripMenuItem.Name = "VertragsübersichtToolStripMenuItem"
        Me.VertragsübersichtToolStripMenuItem.Size = New System.Drawing.Size(170, 22)
        Me.VertragsübersichtToolStripMenuItem.Text = "&Vertragsübersicht"
        '
        'ToolStripMenuItem3
        '
        Me.ToolStripMenuItem3.Name = "ToolStripMenuItem3"
        Me.ToolStripMenuItem3.Size = New System.Drawing.Size(167, 6)
        '
        'frmMain
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(830, 488)
        Me.Controls.Add(Me.StatusStrip1)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.IsMdiContainer = True
        Me.Name = "frmMain"
        Me.Tag = "Hauptfenster Vertragsverwaltung"
        Me.Text = "TKB Vertragsverwaltung"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.StatusStrip1.ResumeLayout(False)
        Me.StatusStrip1.PerformLayout()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmMain Class
frmMain Members


frmMain.Login Method

frmMain.Login Method

Login-Fenster anzeigen und neuen User anmelden
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Login()
C#
private System.Void Login();
C++

private:
System::Void Login()
JScript
private function Login();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Login()
        Dim f As New frmLogin
        f.ShowDialog()
        If f.DialogResult = Windows.Forms.DialogResult.OK Then
            Globals.clsmitarbeiter.iMitarbeiternr = f.Mitarbeiternr
            Globals.clsmitarbeiter.cpMainConnectionProvider = Globals.conn
            conn.OpenConnection()
            Globals.clsmitarbeiter.SelectOne()
            Globals.conn.CloseConnection(True)
        Else
            Me.ForceQuit = True
            Me.Close()
        End If
        Me.ToolStripUser.Text = "U:" & Globals.clsmitarbeiter.sTgnummer.Value
        Me.ToolStripDatabase.Text = "DB:" & Globals.conn.scoDBConnection.DataSource.ToString + "." + Globals.conn.scoDBConnection.Database.ToString

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmMain Class
frmMain Members


frmMain.NeuAnmeldenToolStripMenuItem_Click Method

frmMain.NeuAnmeldenToolStripMenuItem_Click Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub NeuAnmeldenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   NeuAnmeldenToolStripMenuItem.Click
C#
private System.Void NeuAnmeldenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void NeuAnmeldenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function NeuAnmeldenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub NeuAnmeldenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles NeuAnmeldenToolStripMenuItem.Click
        Login()
        sec.Set_Form_Security(Me)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmMain Class
frmMain Members


frmMain.ObjectListerToolStripMenuItem_Click Method

frmMain.ObjectListerToolStripMenuItem_Click Method

Zeigt eine Liste sämtlicher offener MDI-Formulare an. Nach Auswahl wird für das selektierte Formular die Security-Objekt-Tabelle generier
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub ObjectListerToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ObjectListerToolStripMenuItem.Click
C#
private System.Void ObjectListerToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void ObjectListerToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function ObjectListerToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub ObjectListerToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ObjectListerToolStripMenuItem.Click
        Dim formselector As New frmFormSelector
        formselector.ListForms.Items.Clear()
        formselector.ListForms.Items.Add(Me.Name)
        For Each x As Form In Me.MdiChildren
            formselector.ListForms.Items.Add(x.Name)
        Next
        formselector.ShowDialog()
        If formselector.DialogResult = Windows.Forms.DialogResult.OK Then
            If formselector.ListForms.SelectedItem = Me.Name Then
                sec.List_Form_Controls(Me)
                sec.print_screen(Me)
                Exit Sub
            End If
            For Each x As Form In Me.MdiChildren
                If x.Name = formselector.ListForms.SelectedItem Then
                    sec.List_Form_Controls(x)
                    sec.Print_Screen(x)
                End If
            Next

        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmMain Class
frmMain Members
MySecurity


frmMain.SLAKatalogVerwaltenToolStripMenuItem_Click Method

frmMain.SLAKatalogVerwaltenToolStripMenuItem_Click Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub SLAKatalogVerwaltenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   SLAKatalogVerwaltenToolStripMenuItem.Click
C#
private System.Void SLAKatalogVerwaltenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void SLAKatalogVerwaltenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function SLAKatalogVerwaltenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub SLAKatalogVerwaltenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles SLAKatalogVerwaltenToolStripMenuItem.Click
        Dim f As New frmSLAKatalog
        f.MdiParent = Me
        f.Show()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmMain Class
frmMain Members


frmMain.SLAToolStripMenuItem_Click Method

frmMain.SLAToolStripMenuItem_Click Method

Aufruf der Funktion für die Verwaltung der SLA-Typen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub SLAToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   SLATypenverwaltenStripMenuItem.Click
C#
private System.Void SLAToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void SLAToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function SLAToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub SLAToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles SLATypenverwaltenStripMenuItem.Click
        Dim f As New frmDomainEditor("SLATyp")
        f.MdiParent = Me
        f.Show()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmMain Class
frmMain Members


frmMain.SLAZeiteinheitenVerwaltenToolStripMenuItem_Click Method

frmMain.SLAZeiteinheitenVerwaltenToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

Aufrunf der Funktion für die Verwaltung der Zeiteinheittypen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub SLAZeiteinheitenVerwaltenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   SLAZeiteinheitenVerwaltenToolStripMenuItem.Click
C#
private System.Void SLAZeiteinheitenVerwaltenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void SLAZeiteinheitenVerwaltenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function SLAZeiteinheitenVerwaltenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub SLAZeiteinheitenVerwaltenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles SLAZeiteinheitenVerwaltenToolStripMenuItem.Click
        Dim f As New frmDomainEditor("Zeiteinheittyp")
        f.MdiParent = Me
        f.Show()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmMain Class
frmMain Members


frmMain.ServicekatalogVerwaltenToolStripMenuItem_Click Method

frmMain.ServicekatalogVerwaltenToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub ServicekatalogVerwaltenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ServicekatalogVerwaltenToolStripMenuItem.Click
C#
private System.Void ServicekatalogVerwaltenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void ServicekatalogVerwaltenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function ServicekatalogVerwaltenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub ServicekatalogVerwaltenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ServicekatalogVerwaltenToolStripMenuItem.Click
        Dim f As New frmServicekatalog
        f.MdiParent = Me
        f.Show()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmMain Class
frmMain Members


frmMain.SystemadministrationToolStripMenuItem_Click Method

frmMain.SystemadministrationToolStripMenuItem_Click Method

Aufruf System-Administration
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub SystemadministrationToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   SystemadministrationToolStripMenuItem.Click
C#
private System.Void SystemadministrationToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void SystemadministrationToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function SystemadministrationToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub SystemadministrationToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles SystemadministrationToolStripMenuItem.Click
        Dim f As New FrmSysadminMenu
        f.MdiParent = Me
        f.Show()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmMain Class
frmMain Members


frmMain.TSBtnQuit_Click Method

frmMain.TSBtnQuit_Click Method

Quit-Button
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click
C#
private System.Void TSBtnQuit_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnQuit_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnQuit_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmMain Class
frmMain Members


frmMain.VertragselementeToolStripMenuItem_Click Method

frmMain.VertragselementeToolStripMenuItem_Click Method

Vertragselement anzeigen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub VertragselementeToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   VertragselementeToolStripMenuItem.Click
C#
private System.Void VertragselementeToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void VertragselementeToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function VertragselementeToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub VertragselementeToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles VertragselementeToolStripMenuItem.Click
        Dim f As New frmVertragselement
        f.MdiParent = Me
        f.Show()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmMain Class
frmMain Members


frmMain.VertragspartnerToolStripMenuItem_Click Method

frmMain.VertragspartnerToolStripMenuItem_Click Method

Vertragspartner anzeigen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub VertragspartnerToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   VertragspartnerToolStripMenuItem.Click
C#
private System.Void VertragspartnerToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void VertragspartnerToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function VertragspartnerToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub VertragspartnerToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles VertragspartnerToolStripMenuItem.Click
        Dim f As New frmVertragspartner
        f.MdiParent = Me
        f.Show()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmMain Class
frmMain Members


frmMain.VertragsübersichtToolStripMenuItem_Click Method

frmMain.VertragsübersichtToolStripMenuItem_Click Method

Vertragsübersicht anzeigen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub VertragsübersichtToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   VertragsübersichtToolStripMenuItem.Click
C#
private System.Void VertragsübersichtToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void VertragsübersichtToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function VertragsübersichtToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub VertragsübersichtToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles VertragsübersichtToolStripMenuItem.Click
        Dim f As New frmVertragsuebersicht
        f.MdiParent = Me
        f.Show()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmMain Class
frmMain Members


frmMain.frmMain_FormClosing Method

frmMain.frmMain_FormClosing Method

Beim schliessen des Formulars wird der User gefragt, ob die Applikation geschlossen werden soll.
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub frmMain_FormClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing
C#
private System.Void frmMain_FormClosing(
   object sender,
   FormClosingEventArgs e
);
C++

private:
System::Void frmMain_FormClosing(
   object^ sender,
   FormClosingEventArgs^ e
)
JScript
private function frmMain_FormClosing(
    sender : object,
    e : FormClosingEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub frmMain_FormClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.ForceQuit Then Exit Sub

        If txt.Show_MessageYesNo(1) <> MsgBoxResult.Yes Then e.Cancel = True
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmMain Class
frmMain Members


frmMain.frmMain_Load Method

frmMain.frmMain_Load Method

Laden des Formulars
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub frmMain_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load
C#
private System.Void frmMain_Load(
   object sender,
   EventArgs e
);
C++

private:
System::Void frmMain_Load(
   object^ sender,
   EventArgs^ e
)
JScript
private function frmMain_Load(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub frmMain_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Init_System()
        sec.Set_Form_Security(Me)
        VertragsübersichtToolStripMenuItem_Click(sender, e)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmMain Class
frmMain Members


frmMain Fields

frmMain Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | ForceQuit |
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | sec |
Supported by the .NET Compact Framework. | txt |
Top

Expand image See Also

Reference

frmMain Class


ForceQuit Variable

ForceQuit Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private ForceQuit As Boolean
C#
private bool ForceQuit;
C++
private:
bool ForceQuit;
JScript
private ForceQuit : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim ForceQuit As Boolean = False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmMain Class
frmMain Members


components Variable

components Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private components As IContainer
C#
private IContainer components;
C++
private:
IContainer^ components;
JScript
private components : IContainer

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private components As System.ComponentModel.IContainer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmMain Class
frmMain Members


sec Variable

sec Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private sec As MySecurity
C#
private MySecurity sec;
C++
private:
MySecurity^ sec;
JScript
private sec : MySecurity

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim sec As New TKB.VV.Utils.MySecurity

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmMain Class
frmMain Members


txt Variable

txt Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private txt As MyMessage
C#
private MyMessage txt;
C++
private:
MyMessage^ txt;
JScript
private txt : MyMessage

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim txt As New TKB.VV.Utils.MyMessage

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmMain Class
frmMain Members


frmPerson Class

frmPerson Class
See Also Members
collapseAll image DropDown image

Person
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class frmPerson
    Inherits Form
C#
public class frmPerson : Form
C++

public ref class frmPerson : public Form^
JScript
public class frmPerson
   extends Form

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmPerson

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Members
TKB.VV.Utils
TKB.VV.Utils.MyMessage
TKB.VV.Utils.MySecurity


frmPerson Members

frmPerson Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Person

The following tables list the members exposed by the frmPerson type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | frmPerson Constructor | Formular-Initialisierung
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Vertragspartnernr |
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose | (Overloaded) Destructor Dispose
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | AddChanges | Allg Eventhandler für Chanage-Ereignise festlegen
Supported by the .NET Compact Framework. | ChangesMade | Envent-Handler für Change-Ereignisse
Supported by the .NET Compact Framework. | Check_Changes | Prüfung, ob Datenänderungen vorgenommen wurden.
Supported by the .NET Compact Framework. | FormularClosing | Schliessen des Formulars
Supported by the .NET Compact Framework. | GetControl | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
Supported by the .NET Compact Framework. | Get_Data | Person laden und präsentieren
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | Load_Securitylevel | Laden der Securitylevel-Daten in die Combobox
Supported by the .NET Compact Framework. | Save_Data | Daten sichern, sofern Änderungen vorgenommen worden sind
Supported by the .NET Compact Framework. | TSBtnCopy_Click | Kontaktperson kopieren
Supported by the .NET Compact Framework. | TSBtnDelete_Click | Kontakperson löschen
Supported by the .NET Compact Framework. | TSBtnNew_Click | Neue Kontakperson
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Schliessen-Button betätigt
Supported by the .NET Compact Framework. | TSBtnSave_Click | Save-Button geklickt
Supported by the .NET Compact Framework. | frmPerson_Load | Laden des Formulars
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | FormDataChanged |
Supported by the .NET Compact Framework. | FormReadonly |
Supported by the .NET Compact Framework. | Kontaktperson |
Supported by the .NET Compact Framework. | PersonNr |
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | m_vertragspartnernr |
Supported by the .NET Compact Framework. | msg |
Supported by the .NET Compact Framework. | sec |
Top

Expand image See Also

Reference

frmPerson Class
TKB.VV.Utils
TKB.VV.Utils.MyMessage
TKB.VV.Utils.MySecurity


frmPerson Constructor

frmPerson Constructor

Formular-Initialisierung
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal Nr As Integer, _
   ByVal Vertragspartnernr As Integer, _
   Optional ByVal iReadOnly As Boolean = False _
)
C#
public System.Void frmPerson(
   int Nr,
   int Vertragspartnernr,
   bool iReadOnly
);
C++

public:
System::Void frmPerson(
   int Nr,
   int Vertragspartnernr,
   bool iReadOnly
)
JScript
public function frmPerson(
    Nr : int,
    Vertragspartnernr : int,
    iReadOnly : boolean
);

Parameters

Nr

PersonenNr

Vertragspartnernr

VertragspartnerNr

iReadOnly

Optional. The default value is False.

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Sub New(ByVal Nr As Integer, ByVal Vertragspartnernr As Integer, Optional ByVal iReadOnly As Boolean = False)
        MyBase.New()
        Me.InitializeComponent()
        PersonNr = Nr
        Me.Vertragspartnernr = Vertragspartnernr
        Me.FormReadonly = iReadOnly
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


frmPerson Properties

frmPerson Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Vertragspartnernr |
Top

Expand image See Also

Reference

frmPerson Class
TKB.VV.Utils
TKB.VV.Utils.MyMessage
TKB.VV.Utils.MySecurity


frmPerson.Vertragspartnernr Property

frmPerson.Vertragspartnernr Property

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property Vertragspartnernr() As Integer
C#
public int Vertragspartnernr {get; set;}
C++
public:
property int Vertragspartnernr {
 int get( );
 void set(
   int value
 );
}
JScript
public function get Vertragspartnernr() : int;
public function set Vertragspartnernr(value : int);

Expand image Source code

Visual Basic CopyCode image Copy Code
    Property Vertragspartnernr() As Integer
        Get
            Return m_vertragspartnernr
        End Get
        Set(ByVal value As Integer)
            m_vertragspartnernr = value
        End Set
    End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


frmPerson Methods

frmPerson Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose | (Overloaded) Destructor Dispose
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | AddChanges | Allg Eventhandler für Chanage-Ereignise festlegen
Supported by the .NET Compact Framework. | ChangesMade | Envent-Handler für Change-Ereignisse
Supported by the .NET Compact Framework. | Check_Changes | Prüfung, ob Datenänderungen vorgenommen wurden.
Supported by the .NET Compact Framework. | FormularClosing | Schliessen des Formulars
Supported by the .NET Compact Framework. | GetControl | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
Supported by the .NET Compact Framework. | Get_Data | Person laden und präsentieren
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | Load_Securitylevel | Laden der Securitylevel-Daten in die Combobox
Supported by the .NET Compact Framework. | Save_Data | Daten sichern, sofern Änderungen vorgenommen worden sind
Supported by the .NET Compact Framework. | TSBtnCopy_Click | Kontaktperson kopieren
Supported by the .NET Compact Framework. | TSBtnDelete_Click | Kontakperson löschen
Supported by the .NET Compact Framework. | TSBtnNew_Click | Neue Kontakperson
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Schliessen-Button betätigt
Supported by the .NET Compact Framework. | TSBtnSave_Click | Save-Button geklickt
Supported by the .NET Compact Framework. | frmPerson_Load | Laden des Formulars
Top

Expand image See Also

Reference

frmPerson Class
TKB.VV.Utils
TKB.VV.Utils.MyMessage
TKB.VV.Utils.MySecurity


frmPerson.AddChanges Method

frmPerson.AddChanges Method

Allg Eventhandler für Chanage-Ereignise festlegen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub AddChanges( _
   ByVal Container As Control _
)
C#
private System.Void AddChanges(
   Control Container
);
C++

private:
System::Void AddChanges(
   Control^ Container
)
JScript
private function AddChanges(
    Container : Control
);

Parameters

Container

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub AddChanges(ByVal Container As Control)
        Dim l As New List(Of Control)
        Me.GetControl(Me, "*", l)
        Dim evh As EventHandler = AddressOf ChangesMade
        For Each c As Control In l
            If TypeOf c Is TextBox Then
                Dim ctl As TextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is MaskedTextBox Then
                Dim ctl As MaskedTextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is ComboBox Then
                Dim ctl As ComboBox = c
                AddHandler ctl.SelectedValueChanged, evh
            End If
            If TypeOf c Is CheckBox Then
                Dim ctl As CheckBox = c
                AddHandler ctl.CheckedChanged, evh
            End If
        Next
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


frmPerson.ChangesMade Method

frmPerson.ChangesMade Method

Envent-Handler für Change-Ereignisse
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub ChangesMade( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
private System.Void ChangesMade(
   object sender,
   EventArgs e
);
C++

private:
System::Void ChangesMade(
   object^ sender,
   EventArgs^ e
)
JScript
private function ChangesMade(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub ChangesMade(ByVal sender As Object, ByVal e As System.EventArgs)
        Me.FormDataChanged = True
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


frmPerson.Check_Changes Method

frmPerson.Check_Changes Method

Prüfung, ob Datenänderungen vorgenommen wurden.
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Check_Changes() As Boolean
C#
private bool Check_Changes();
C++

private:
bool Check_Changes()
JScript
private function Check_Changes() : boolean;

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Function Check_Changes() As Boolean
        If Me.FormReadonly = True Then Exit Function
        Dim msgres As MsgBoxResult
        If Me.FormDataChanged Then
            msgres = msg.Show_MessageYesNoCancel(3)
            Select Case msgres
                Case MsgBoxResult.Yes
                    Save_data()
                    Return True
                Case MsgBoxResult.Cancel
                    Return False
                Case MsgBoxResult.No
                    Return True
            End Select
        Else
            Return True
        End If
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


frmPerson.Dispose Method

frmPerson.Dispose Method

Destructor Dispose

Expand image Overload List

Name | Description
protected override System.Void Dispose(bool); |
public System.Void Dispose(); | Destructor Dispose

Expand image See Also

Reference

frmPerson Class
frmPerson Members


frmPerson.FormularClosing Method

frmPerson.FormularClosing Method

Schliessen des Formulars
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub FormularClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing
C#
private System.Void FormularClosing(
   object sender,
   FormClosingEventArgs e
);
C++

private:
System::Void FormularClosing(
   object^ sender,
   FormClosingEventArgs^ e
)
JScript
private function FormularClosing(
    sender : object,
    e : FormClosingEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub FormularClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.FormReadonly = True Then Exit Sub
        If check_changes() = False Then
            e.Cancel = True
        Else
            Me.dispose()
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


frmPerson.GetControl Method

frmPerson.GetControl Method

Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function GetControl( _
   ByVal BaseControl As Control, _
   ByVal Key As String, _
   ByRef L As List(Of Control), _
   Optional ByVal ReturnAtFirstElement As Boolean = False _
) As Boolean
C#
private bool GetControl(
   Control BaseControl,
   string Key,
   ref List<Control> L,
   bool ReturnAtFirstElement
);
C++

private:
bool GetControl(
   Control^ BaseControl,
   String^ Key,
   List<Control^>^& L,
   bool ReturnAtFirstElement
)
JScript
JScript does not support generic types and methods.

Parameters

BaseControl

Base-Contrlo (z.B. aktuelles Formular

Key

Schlüssel welcher gesucht werden soll

L

Liste der gefundenen Objekte

ReturnAtFirstElement

Optional. The default value is False.

Return Value

True wenn eines oder mehr Controls gefunden wurden, false wenn kein Control gefunden wurde.

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Function GetControl(ByVal BaseControl As Control, ByVal Key As String, ByRef L As List(Of Control), Optional ByVal ReturnAtFirstElement As Boolean = False) As Boolean
        If L Is Nothing Then L = New List(Of Control)
        Dim Gut As Boolean
        Dim ReturnFlag As Boolean = False
        If Key IsNot Nothing Then Key = Key.ToLower

        If BaseControl.HasChildren = True Then
            For Each ctl As Control In BaseControl.Controls
                Gut = False
                If Key Is Nothing Then
                    Gut = True
                Else
                    If ctl.Name.Length >= Key.Length Then
                        Key = Key.ToLower
                        If Key.StartsWith("*") Then
                            If Key.Substring(1) = ctl.Name.ToLower.Substring(ctl.Name.Length - (Key.Length - 1), Key.Length - 1) Then Gut = True
                        ElseIf Key.EndsWith("*") Then
                            If Key.Substring(0, Key.Length - 1) = ctl.Name.ToLower.Substring(0, Key.Length - 1) Then Gut = True
                        Else
                            If Key = ctl.Name.ToLower Then Gut = True
                        End If
                    End If
                End If

                If Gut = True Then
                    L.Add(ctl)
                    If ReturnAtFirstElement = True Then ReturnFlag = True
                End If
                If ReturnFlag = False Then
                    Call GetControl(ctl, Key, L)
                End If
            Next
        End If

        If L.Count - 1 > -1 Then
            Return True
        Else
            Return False
        End If
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


frmPerson.Get_Data Method

frmPerson.Get_Data Method

Person laden und präsentieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Get_Data( _
   ByVal Nr As Integer _
)
C#
private System.Void Get_Data(
   int Nr
);
C++

private:
System::Void Get_Data(
   int Nr
)
JScript
private function Get_Data(
    Nr : int
);

Parameters

Nr

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Get_Data(ByVal Nr As Integer)
        Me.Kontaktperson.Get_Person(Nr)
        Me.txtName_Firma1.Text = Me.Kontaktperson.sName.Value
        Me.txtVorname_Firma2.Text = Me.Kontaktperson.sVorname.Value
        Me.txtStrasse.Text = Me.Kontaktperson.sStrasse.Value
        Me.txtPostfach.Text = Me.Kontaktperson.sPostfach.Value
        Me.txtPlz.Text = Me.Kontaktperson.sPlz.Value
        Me.txtOrt.Text = Me.Kontaktperson.sOrt.Value
        Me.txtTelefon.Text = Me.Kontaktperson.sTelefon.Value
        Me.txtTelefax.Text = Me.Kontaktperson.sTelefax.Value
        Me.txtEmail.Text = Me.Kontaktperson.sEMail.Value
        Me.txtInternet.Text = Me.Kontaktperson.sInternet.Value
        Me.txtBemerkung.Text = Me.Kontaktperson.sBemerkung.Value
        Me.txtErstellt_am.Text = Me.Kontaktperson.daErstellt_am.ToString
        Me.txtMutiert_am.Text = Me.Kontaktperson.daMutiert_am.ToString
        Me.txtMutierer.Text = Me.Kontaktperson.iMutierer.Value
        Me.cbAktiv.Checked = Me.Kontaktperson.bAktiv.Value = True
        Me.cboxSecurityLevel.SelectedValue = Me.Kontaktperson.iSecurityLevelNr.Value
        Me.FormDataChanged = False

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


frmPerson.InitializeComponent Method

frmPerson.InitializeComponent Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()
C#
[System.Diagnostics.DebuggerStepThrough()]
private System.Void InitializeComponent();
C++
[System.Diagnostics.DebuggerStepThrough()]

private:
System::Void InitializeComponent()
JScript
private
   System.Diagnostics.DebuggerStepThrough()
function InitializeComponent();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmPerson))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.TSBtnCopy = New System.Windows.Forms.ToolStripButton
        Me.cboxSecurityLevel = New System.Windows.Forms.ComboBox
        Me.lblSecurityLebel = New System.Windows.Forms.Label
        Me.cbAktiv = New System.Windows.Forms.CheckBox
        Me.lblAktiv = New System.Windows.Forms.Label
        Me.txtMutierer = New System.Windows.Forms.TextBox
        Me.txtMutiert_am = New System.Windows.Forms.TextBox
        Me.txtErstellt_am = New System.Windows.Forms.TextBox
        Me.lblMutierer = New System.Windows.Forms.Label
        Me.lblMutiert_am = New System.Windows.Forms.Label
        Me.lblErstelltam = New System.Windows.Forms.Label
        Me.txtBemerkung = New System.Windows.Forms.TextBox
        Me.lblBemerkung = New System.Windows.Forms.Label
        Me.txtInternet = New System.Windows.Forms.TextBox
        Me.lblInternet = New System.Windows.Forms.Label
        Me.txtEmail = New System.Windows.Forms.TextBox
        Me.lblEmail = New System.Windows.Forms.Label
        Me.txtTelefon = New System.Windows.Forms.TextBox
        Me.txtTelefax = New System.Windows.Forms.TextBox
        Me.lblTelefax = New System.Windows.Forms.Label
        Me.lblTelefon = New System.Windows.Forms.Label
        Me.txtOrt = New System.Windows.Forms.TextBox
        Me.txtPlz = New System.Windows.Forms.TextBox
        Me.lblPlzOrt = New System.Windows.Forms.Label
        Me.txtPostfach = New System.Windows.Forms.TextBox
        Me.lblPostfach = New System.Windows.Forms.Label
        Me.txtStrasse = New System.Windows.Forms.TextBox
        Me.lblStrasse = New System.Windows.Forms.Label
        Me.txtVorname_Firma2 = New System.Windows.Forms.TextBox
        Me.lblVorname = New System.Windows.Forms.Label
        Me.txtName_Firma1 = New System.Windows.Forms.TextBox
        Me.lblName = New System.Windows.Forms.Label
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(663, 24)
        Me.MenuStrip1.TabIndex = 14
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(127, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "ToolStripButton3"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "ToolStripButton3"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnCopy, Me.TSBtnNew, Me.TSBtnDelete})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(663, 25)
        Me.ToolStrip1.TabIndex = 13
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "ToolStripButton1"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'TSBtnCopy
        '
        Me.TSBtnCopy.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnCopy.Image = CType(resources.GetObject("TSBtnCopy.Image"), System.Drawing.Image)
        Me.TSBtnCopy.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnCopy.Name = "TSBtnCopy"
        Me.TSBtnCopy.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnCopy.Text = "ToolStripButton2"
        Me.TSBtnCopy.ToolTipText = "Datensatz kopieren"
        '
        'cboxSecurityLevel
        '
        Me.cboxSecurityLevel.FormattingEnabled = True
        Me.cboxSecurityLevel.Location = New System.Drawing.Point(85, 283)
        Me.cboxSecurityLevel.Name = "cboxSecurityLevel"
        Me.cboxSecurityLevel.Size = New System.Drawing.Size(101, 21)
        Me.cboxSecurityLevel.TabIndex = 12
        '
        'lblSecurityLebel
        '
        Me.lblSecurityLebel.AutoSize = True
        Me.lblSecurityLebel.Location = New System.Drawing.Point(8, 287)
        Me.lblSecurityLebel.Name = "lblSecurityLebel"
        Me.lblSecurityLebel.Size = New System.Drawing.Size(71, 13)
        Me.lblSecurityLebel.TabIndex = 120
        Me.lblSecurityLebel.Text = "SecurityLevel"
        '
        'cbAktiv
        '
        Me.cbAktiv.AutoSize = True
        Me.cbAktiv.Location = New System.Drawing.Point(462, 162)
        Me.cbAktiv.Name = "cbAktiv"
        Me.cbAktiv.Size = New System.Drawing.Size(15, 14)
        Me.cbAktiv.TabIndex = 10
        Me.cbAktiv.UseVisualStyleBackColor = True
        '
        'lblAktiv
        '
        Me.lblAktiv.AccessibleDescription = "Name"
        Me.lblAktiv.AutoSize = True
        Me.lblAktiv.Location = New System.Drawing.Point(400, 162)
        Me.lblAktiv.Name = "lblAktiv"
        Me.lblAktiv.Size = New System.Drawing.Size(31, 13)
        Me.lblAktiv.TabIndex = 118
        Me.lblAktiv.Text = "Aktiv"
        '
        'txtMutierer
        '
        Me.txtMutierer.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutierer.Location = New System.Drawing.Point(564, 284)
        Me.txtMutierer.Name = "txtMutierer"
        Me.txtMutierer.Size = New System.Drawing.Size(71, 20)
        Me.txtMutierer.TabIndex = 117
        '
        'txtMutiert_am
        '
        Me.txtMutiert_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutiert_am.Location = New System.Drawing.Point(402, 284)
        Me.txtMutiert_am.Name = "txtMutiert_am"
        Me.txtMutiert_am.Size = New System.Drawing.Size(79, 20)
        Me.txtMutiert_am.TabIndex = 116
        '
        'txtErstellt_am
        '
        Me.txtErstellt_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtErstellt_am.Location = New System.Drawing.Point(258, 284)
        Me.txtErstellt_am.Name = "txtErstellt_am"
        Me.txtErstellt_am.Size = New System.Drawing.Size(79, 20)
        Me.txtErstellt_am.TabIndex = 115
        '
        'lblMutierer
        '
        Me.lblMutierer.AccessibleDescription = "Name"
        Me.lblMutierer.AutoSize = True
        Me.lblMutierer.Location = New System.Drawing.Point(493, 287)
        Me.lblMutierer.Name = "lblMutierer"
        Me.lblMutierer.Size = New System.Drawing.Size(72, 13)
        Me.lblMutierer.TabIndex = 114
        Me.lblMutierer.Text = "Mutiert durch:"
        '
        'lblMutiert_am
        '
        Me.lblMutiert_am.AccessibleDescription = "Name"
        Me.lblMutiert_am.AutoSize = True
        Me.lblMutiert_am.Location = New System.Drawing.Point(343, 287)
        Me.lblMutiert_am.Name = "lblMutiert_am"
        Me.lblMutiert_am.Size = New System.Drawing.Size(59, 13)
        Me.lblMutiert_am.TabIndex = 113
        Me.lblMutiert_am.Text = "Mutiert am:"
        '
        'lblErstelltam
        '
        Me.lblErstelltam.AccessibleDescription = "Name"
        Me.lblErstelltam.AutoSize = True
        Me.lblErstelltam.Location = New System.Drawing.Point(200, 287)
        Me.lblErstelltam.Name = "lblErstelltam"
        Me.lblErstelltam.Size = New System.Drawing.Size(58, 13)
        Me.lblErstelltam.TabIndex = 112
        Me.lblErstelltam.Text = "Erstellt am:"
        '
        'txtBemerkung
        '
        Me.txtBemerkung.Location = New System.Drawing.Point(11, 201)
        Me.txtBemerkung.Multiline = True
        Me.txtBemerkung.Name = "txtBemerkung"
        Me.txtBemerkung.Size = New System.Drawing.Size(626, 72)
        Me.txtBemerkung.TabIndex = 11
        '
        'lblBemerkung
        '
        Me.lblBemerkung.AccessibleDescription = "Name"
        Me.lblBemerkung.AutoSize = True
        Me.lblBemerkung.Location = New System.Drawing.Point(8, 185)
        Me.lblBemerkung.Name = "lblBemerkung"
        Me.lblBemerkung.Size = New System.Drawing.Size(61, 13)
        Me.lblBemerkung.TabIndex = 110
        Me.lblBemerkung.Text = "Bemerkung"
        '
        'txtInternet
        '
        Me.txtInternet.Location = New System.Drawing.Point(462, 133)
        Me.txtInternet.Name = "txtInternet"
        Me.txtInternet.Size = New System.Drawing.Size(177, 20)
        Me.txtInternet.TabIndex = 9
        '
        'lblInternet
        '
        Me.lblInternet.AccessibleDescription = "Name"
        Me.lblInternet.AutoSize = True
        Me.lblInternet.Location = New System.Drawing.Point(400, 136)
        Me.lblInternet.Name = "lblInternet"
        Me.lblInternet.Size = New System.Drawing.Size(43, 13)
        Me.lblInternet.TabIndex = 108
        Me.lblInternet.Text = "Internet"
        '
        'txtEmail
        '
        Me.txtEmail.Location = New System.Drawing.Point(462, 107)
        Me.txtEmail.Name = "txtEmail"
        Me.txtEmail.Size = New System.Drawing.Size(177, 20)
        Me.txtEmail.TabIndex = 8
        '
        'lblEmail
        '
        Me.lblEmail.AccessibleDescription = "Name"
        Me.lblEmail.AutoSize = True
        Me.lblEmail.Location = New System.Drawing.Point(400, 110)
        Me.lblEmail.Name = "lblEmail"
        Me.lblEmail.Size = New System.Drawing.Size(36, 13)
        Me.lblEmail.TabIndex = 106
        Me.lblEmail.Text = "E-Mail"
        '
        'txtTelefon
        '
        Me.txtTelefon.Location = New System.Drawing.Point(462, 55)
        Me.txtTelefon.Name = "txtTelefon"
        Me.txtTelefon.Size = New System.Drawing.Size(177, 20)
        Me.txtTelefon.TabIndex = 6
        '
        'txtTelefax
        '
        Me.txtTelefax.Location = New System.Drawing.Point(462, 81)
        Me.txtTelefax.Name = "txtTelefax"
        Me.txtTelefax.Size = New System.Drawing.Size(177, 20)
        Me.txtTelefax.TabIndex = 7
        '
        'lblTelefax
        '
        Me.lblTelefax.AccessibleDescription = "Name"
        Me.lblTelefax.AutoSize = True
        Me.lblTelefax.Location = New System.Drawing.Point(400, 84)
        Me.lblTelefax.Name = "lblTelefax"
        Me.lblTelefax.Size = New System.Drawing.Size(42, 13)
        Me.lblTelefax.TabIndex = 103
        Me.lblTelefax.Text = "Telefax"
        '
        'lblTelefon
        '
        Me.lblTelefon.AccessibleDescription = "Name"
        Me.lblTelefon.AutoSize = True
        Me.lblTelefon.Location = New System.Drawing.Point(399, 58)
        Me.lblTelefon.Name = "lblTelefon"
        Me.lblTelefon.Size = New System.Drawing.Size(43, 13)
        Me.lblTelefon.TabIndex = 102
        Me.lblTelefon.Text = "Telefon"
        '
        'txtOrt
        '
        Me.txtOrt.Location = New System.Drawing.Point(205, 159)
        Me.txtOrt.Name = "txtOrt"
        Me.txtOrt.Size = New System.Drawing.Size(166, 20)
        Me.txtOrt.TabIndex = 5
        '
        'txtPlz
        '
        Me.txtPlz.Location = New System.Drawing.Point(137, 159)
        Me.txtPlz.Name = "txtPlz"
        Me.txtPlz.Size = New System.Drawing.Size(62, 20)
        Me.txtPlz.TabIndex = 4
        '
        'lblPlzOrt
        '
        Me.lblPlzOrt.AccessibleDescription = "Name"
        Me.lblPlzOrt.AutoSize = True
        Me.lblPlzOrt.Location = New System.Drawing.Point(10, 162)
        Me.lblPlzOrt.Name = "lblPlzOrt"
        Me.lblPlzOrt.Size = New System.Drawing.Size(52, 13)
        Me.lblPlzOrt.TabIndex = 99
        Me.lblPlzOrt.Text = "PLZ / Ort"
        '
        'txtPostfach
        '
        Me.txtPostfach.Location = New System.Drawing.Point(137, 133)
        Me.txtPostfach.Name = "txtPostfach"
        Me.txtPostfach.Size = New System.Drawing.Size(234, 20)
        Me.txtPostfach.TabIndex = 3
        '
        'lblPostfach
        '
        Me.lblPostfach.AccessibleDescription = "Name"
        Me.lblPostfach.AutoSize = True
        Me.lblPostfach.Location = New System.Drawing.Point(10, 136)
        Me.lblPostfach.Name = "lblPostfach"
        Me.lblPostfach.Size = New System.Drawing.Size(49, 13)
        Me.lblPostfach.TabIndex = 97
        Me.lblPostfach.Text = "Postfach"
        '
        'txtStrasse
        '
        Me.txtStrasse.Location = New System.Drawing.Point(137, 107)
        Me.txtStrasse.Name = "txtStrasse"
        Me.txtStrasse.Size = New System.Drawing.Size(234, 20)
        Me.txtStrasse.TabIndex = 2
        '
        'lblStrasse
        '
        Me.lblStrasse.AccessibleDescription = "Name"
        Me.lblStrasse.AutoSize = True
        Me.lblStrasse.Location = New System.Drawing.Point(10, 110)
        Me.lblStrasse.Name = "lblStrasse"
        Me.lblStrasse.Size = New System.Drawing.Size(42, 13)
        Me.lblStrasse.TabIndex = 95
        Me.lblStrasse.Text = "Strasse"
        '
        'txtVorname_Firma2
        '
        Me.txtVorname_Firma2.Location = New System.Drawing.Point(137, 81)
        Me.txtVorname_Firma2.Name = "txtVorname_Firma2"
        Me.txtVorname_Firma2.Size = New System.Drawing.Size(234, 20)
        Me.txtVorname_Firma2.TabIndex = 1
        '
        'lblVorname
        '
        Me.lblVorname.AccessibleDescription = "Name"
        Me.lblVorname.AutoSize = True
        Me.lblVorname.Location = New System.Drawing.Point(10, 84)
        Me.lblVorname.Name = "lblVorname"
        Me.lblVorname.Size = New System.Drawing.Size(49, 13)
        Me.lblVorname.TabIndex = 93
        Me.lblVorname.Text = "Vorname"
        '
        'txtName_Firma1
        '
        Me.txtName_Firma1.Location = New System.Drawing.Point(137, 55)
        Me.txtName_Firma1.Name = "txtName_Firma1"
        Me.txtName_Firma1.Size = New System.Drawing.Size(234, 20)
        Me.txtName_Firma1.TabIndex = 0
        '
        'lblName
        '
        Me.lblName.AccessibleDescription = "Name"
        Me.lblName.AutoSize = True
        Me.lblName.Location = New System.Drawing.Point(10, 58)
        Me.lblName.Name = "lblName"
        Me.lblName.Size = New System.Drawing.Size(35, 13)
        Me.lblName.TabIndex = 91
        Me.lblName.Text = "Name"
        '
        'frmPerson
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(663, 309)
        Me.Controls.Add(Me.cboxSecurityLevel)
        Me.Controls.Add(Me.lblSecurityLebel)
        Me.Controls.Add(Me.cbAktiv)
        Me.Controls.Add(Me.lblAktiv)
        Me.Controls.Add(Me.txtMutierer)
        Me.Controls.Add(Me.txtMutiert_am)
        Me.Controls.Add(Me.txtErstellt_am)
        Me.Controls.Add(Me.lblMutierer)
        Me.Controls.Add(Me.lblMutiert_am)
        Me.Controls.Add(Me.lblErstelltam)
        Me.Controls.Add(Me.txtBemerkung)
        Me.Controls.Add(Me.lblBemerkung)
        Me.Controls.Add(Me.txtInternet)
        Me.Controls.Add(Me.lblInternet)
        Me.Controls.Add(Me.txtEmail)
        Me.Controls.Add(Me.lblEmail)
        Me.Controls.Add(Me.txtTelefon)
        Me.Controls.Add(Me.txtTelefax)
        Me.Controls.Add(Me.lblTelefax)
        Me.Controls.Add(Me.lblTelefon)
        Me.Controls.Add(Me.txtOrt)
        Me.Controls.Add(Me.txtPlz)
        Me.Controls.Add(Me.lblPlzOrt)
        Me.Controls.Add(Me.txtPostfach)
        Me.Controls.Add(Me.lblPostfach)
        Me.Controls.Add(Me.txtStrasse)
        Me.Controls.Add(Me.lblStrasse)
        Me.Controls.Add(Me.txtVorname_Firma2)
        Me.Controls.Add(Me.lblVorname)
        Me.Controls.Add(Me.txtName_Firma1)
        Me.Controls.Add(Me.lblName)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmPerson"
        Me.Text = "Person"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


frmPerson.Load_Securitylevel Method

frmPerson.Load_Securitylevel Method

Laden der Securitylevel-Daten in die Combobox
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Load_Securitylevel()
C#
private System.Void Load_Securitylevel();
C++

private:
System::Void Load_Securitylevel()
JScript
private function Load_Securitylevel();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Load_Securitylevel()
        Dim seclevel As New TKB.VV.DB.clsSecurityLevel
        Dim secleveldata As New DataTable

        seclevel.cpMainConnectionProvider = Globals.conn
        Globals.conn.OpenConnection()
        secleveldata = seclevel.SelectAll
        Globals.conn.CloseConnection(True)

        Me.cboxSecurityLevel.DataSource = secleveldata
        Me.cboxSecurityLevel.DisplayMember = "Bezeichnung"
        Me.cboxSecurityLevel.ValueMember = "SecurityLevelNr"

        seclevel.Dispose()

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


frmPerson.Save_Data Method

frmPerson.Save_Data Method

Daten sichern, sofern Änderungen vorgenommen worden sind
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Save_Data()
C#
private System.Void Save_Data();
C++

private:
System::Void Save_Data()
JScript
private function Save_Data();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Save_Data()

        If Me.FormDataChanged Then
            Me.Kontaktperson.sName = New SqlString(CType(Me.txtName_Firma1.Text, String))
            Me.Kontaktperson.sVorname = New SqlString(CType(Me.txtVorname_Firma2.Text, String))
            Me.Kontaktperson.sStrasse = New SqlString(CType(Me.txtStrasse.Text, String))
            Me.Kontaktperson.sPostfach = New SqlString(CType(Me.txtPostfach.Text, String))
            Me.Kontaktperson.sPlz = New SqlString(CType(Me.txtPlz.Text, String))
            Me.Kontaktperson.sOrt = New SqlString(CType(Me.txtOrt.Text, String))
            Me.Kontaktperson.sTelefon = New SqlString(CType(Me.txtTelefon.Text, String))
            Me.Kontaktperson.sTelefax = New SqlString(CType(Me.txtTelefax.Text, String))
            Me.Kontaktperson.sEMail = New SqlString(CType(Me.txtEmail.Text, String))
            Me.Kontaktperson.sInternet = New SqlString(CType(Me.txtInternet.Text, String))
            Me.Kontaktperson.sBemerkung = New SqlString(CType(Me.txtBemerkung.Text, String))
            Me.Kontaktperson.bAktiv = New SqlBoolean(CType(Me.cbAktiv.Checked, Boolean))
            Me.Kontaktperson.iSecurityLevelNr = New SqlInt32(CType(Me.cboxSecurityLevel.SelectedValue, Int32))
            Get_Data(Me.Kontaktperson.Save_Data)
            Me.FormDataChanged = False
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


frmPerson.TSBtnCopy_Click Method

frmPerson.TSBtnCopy_Click Method

Kontaktperson kopieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnCopy_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnCopy.Click
C#
private System.Void TSBtnCopy_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnCopy_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnCopy_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnCopy_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnCopy.Click
        Check_Changes()
        Me.Get_Data(Kontaktperson.Create_Copy(Me.Kontaktperson.iPersonNr.Value))
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


frmPerson.TSBtnDelete_Click Method

frmPerson.TSBtnDelete_Click Method

Kontakperson löschen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click
C#
private System.Void TSBtnDelete_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnDelete_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnDelete_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
        If msg.Show_MessageYesNo(200) = MsgBoxResult.Yes Then
            Me.Kontaktperson.Delete_Kontakt(Me.Kontaktperson.iPersonNr.Value)
            Me.Close()
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


frmPerson.TSBtnNew_Click Method

frmPerson.TSBtnNew_Click Method

Neue Kontakperson
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnNew_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnNew.Click
C#
private System.Void TSBtnNew_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnNew_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnNew_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnNew.Click
        Me.Get_Data(Me.Kontaktperson.Add_New(Me.Vertragspartnernr))
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


frmPerson.TSBtnQuit_Click Method

frmPerson.TSBtnQuit_Click Method

Schliessen-Button betätigt
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click
C#
private System.Void TSBtnQuit_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnQuit_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnQuit_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


frmPerson.TSBtnSave_Click Method

frmPerson.TSBtnSave_Click Method

Save-Button geklickt
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click
C#
private System.Void TSBtnSave_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnSave_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnSave_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Me.Save_Data()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


frmPerson.frmPerson_Load Method

frmPerson.frmPerson_Load Method

Laden des Formulars
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub frmPerson_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load
C#
private System.Void frmPerson_Load(
   object sender,
   EventArgs e
);
C++

private:
System::Void frmPerson_Load(
   object^ sender,
   EventArgs^ e
)
JScript
private function frmPerson_Load(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub frmPerson_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        sec.Set_Form_Security(Me)

        If Me.FormReadonly = True Then Me.TSBtnSave.Enabled = False

        If Me.TSBtnSave.Enabled = False Or Me.TSBtnSave.Visible = False Then
            Me.FormReadonly = True
            Me.TSBtnCopy.Enabled = False
            Me.TSBtnNew.Enabled = False
            Me.TSBtnDelete.Enabled = False
        Else
            Me.FormReadonly = False
        End If

        Load_Securitylevel()
        Get_Data(PersonNr)
        Me.AddChanges(Me)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


frmPerson Fields

frmPerson Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | FormDataChanged |
Supported by the .NET Compact Framework. | FormReadonly |
Supported by the .NET Compact Framework. | Kontaktperson |
Supported by the .NET Compact Framework. | PersonNr |
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | m_vertragspartnernr |
Supported by the .NET Compact Framework. | msg |
Supported by the .NET Compact Framework. | sec |
Top

Expand image See Also

Reference

frmPerson Class
TKB.VV.Utils
TKB.VV.Utils.MyMessage
TKB.VV.Utils.MySecurity


FormDataChanged Variable

FormDataChanged Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private FormDataChanged As Boolean
C#
private bool FormDataChanged;
C++
private:
bool FormDataChanged;
JScript
private FormDataChanged : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim FormDataChanged As Boolean = False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


FormReadonly Variable

FormReadonly Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private FormReadonly As Boolean
C#
private bool FormReadonly;
C++
private:
bool FormReadonly;
JScript
private FormReadonly : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim FormReadonly As Boolean = False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


Kontaktperson Variable

Kontaktperson Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Kontaktperson As clsPersonen
C#
private clsPersonen Kontaktperson;
C++
private:
clsPersonen^ Kontaktperson;
JScript
private Kontaktperson : clsPersonen

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Kontaktperson As New TKB.VV.Vertrag.clsPersonen

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


PersonNr Variable

PersonNr Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private PersonNr As Integer
C#
private int PersonNr;
C++
private:
int PersonNr;
JScript
private PersonNr : int

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim PersonNr As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


components Variable

components Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private components As IContainer
C#
private IContainer components;
C++
private:
IContainer^ components;
JScript
private components : IContainer

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private components As System.ComponentModel.IContainer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


m_vertragspartnernr Variable

m_vertragspartnernr Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_vertragspartnernr As Integer
C#
private int m_vertragspartnernr;
C++
private:
int m_vertragspartnernr;
JScript
private m_vertragspartnernr : int

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim m_vertragspartnernr As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


msg Variable

msg Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private msg As MyMessage
C#
private MyMessage msg;
C++
private:
MyMessage^ msg;
JScript
private msg : MyMessage

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim msg As New TKB.VV.Utils.MyMessage

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


sec Variable

sec Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private sec As MySecurity
C#
private MySecurity sec;
C++
private:
MySecurity^ sec;
JScript
private sec : MySecurity

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim sec As New TKB.VV.Utils.MySecurity

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


frmSLAKatalog Class

frmSLAKatalog Class
Members
collapseAll image DropDown image

SLAKatalog-Verwaltung
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmSLAKatalog
    Inherits Form
C#
[Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()]
public class frmSLAKatalog : Form
C++
[Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()]

public ref class frmSLAKatalog : public Form^
JScript
public
   Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()
class frmSLAKatalog
   extends Form

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmSLAKatalog

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSLAKatalog Members


frmSLAKatalog Members

frmSLAKatalog Members
See Also Constructors Methods
CollapseAll image DropDown image

SLAKatalog-Verwaltung

The following tables list the members exposed by the frmSLAKatalog type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | frmSLAKatalog Constructor | Tabellenname übernehmen und Objekt DomainTable initialisieren Initialisierung der Komponenten
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | SpaltenTitel_Aktualisieren | Aktualisiert die Spaltentitel der aktuellen Tabelle
Top

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | BeendenToolStripMenuItem_Click | Schliessen des Formulars
Supported by the .NET Compact Framework. | C1Daten_AfterColUpdate | Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.
Supported by the .NET Compact Framework. | C1Daten_AfterInsert | Aktualisierung der Default-Werte
Supported by the .NET Compact Framework. | C1Daten_FetchCellTips | Anzeige allfälliger Cellen-Tips
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Ruft BeendetnToolStipMenuItem_Click auf
Supported by the .NET Compact Framework. | TSBtnSave_Click | Sichern der Daten
Supported by the .NET Compact Framework. | frmDomainEditor_FormClosing | Prüfung auf allfällige Daten-Changes. Wurden Daten verändert, kann der User entscheiden, ob gespeichert, nichtgespeichert oder das Formular nicht gespeichert werden soll.
Supported by the .NET Compact Framework. | frmDomainEditor_Load | Zuordnung der Daten aus Domaintable und Spaltentitel des Grids setzen
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | Domaintable |
Supported by the .NET Compact Framework. | SLATyp |
Supported by the .NET Compact Framework. | SLATypData |
Supported by the .NET Compact Framework. | Zeiteinheittyp |
Supported by the .NET Compact Framework. | Zeiteinheittypdata |
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | sec |
Supported by the .NET Compact Framework. | tablename |
Top

Expand image See Also

Reference

frmSLAKatalog Class


frmSLAKatalog Constructor

frmSLAKatalog Constructor

Tabellenname übernehmen und Objekt DomainTable initialisieren Initialisierung der Komponenten
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void frmSLAKatalog();
C++

public:
System::Void frmSLAKatalog()
JScript
public function frmSLAKatalog();

Expand image Remarks

Benötigt werden entsprechende Stored_Procedures, welche mit LBLLGEN_2 generiert wurden pr_"Tablename"_SelectAll pr_"Tablename"_Update

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Sub New()
        Dim tblname As String = "SLAKatalog"
        Domaintable = New TKB.VV.SLA.clsSLAKatalogdaten(tblname)
        Me.InitializeComponent()
        Me.tablename = tblname
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSLAKatalog Class
frmSLAKatalog Members


frmSLAKatalog Methods

frmSLAKatalog Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | SpaltenTitel_Aktualisieren | Aktualisiert die Spaltentitel der aktuellen Tabelle
Top

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | BeendenToolStripMenuItem_Click | Schliessen des Formulars
Supported by the .NET Compact Framework. | C1Daten_AfterColUpdate | Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.
Supported by the .NET Compact Framework. | C1Daten_AfterInsert | Aktualisierung der Default-Werte
Supported by the .NET Compact Framework. | C1Daten_FetchCellTips | Anzeige allfälliger Cellen-Tips
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Ruft BeendetnToolStipMenuItem_Click auf
Supported by the .NET Compact Framework. | TSBtnSave_Click | Sichern der Daten
Supported by the .NET Compact Framework. | frmDomainEditor_FormClosing | Prüfung auf allfällige Daten-Changes. Wurden Daten verändert, kann der User entscheiden, ob gespeichert, nichtgespeichert oder das Formular nicht gespeichert werden soll.
Supported by the .NET Compact Framework. | frmDomainEditor_Load | Zuordnung der Daten aus Domaintable und Spaltentitel des Grids setzen
Top

Expand image See Also

Reference

frmSLAKatalog Class


frmSLAKatalog.BeendenToolStripMenuItem_Click Method

frmSLAKatalog.BeendenToolStripMenuItem_Click Method

Schliessen des Formulars
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click
C#
private System.Void BeendenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void BeendenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function BeendenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSLAKatalog Class
frmSLAKatalog Members


frmSLAKatalog.C1Daten_AfterColUpdate Method

frmSLAKatalog.C1Daten_AfterColUpdate Method

Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub C1Daten_AfterColUpdate( _
   ByVal sender As Object, _
   ByVal e As ColEventArgs _
) Handles  _
   C1Daten.AfterColUpdate
C#
private System.Void C1Daten_AfterColUpdate(
   object sender,
   ColEventArgs e
);
C++

private:
System::Void C1Daten_AfterColUpdate(
   object^ sender,
   ColEventArgs^ e
)
JScript
private function C1Daten_AfterColUpdate(
    sender : object,
    e : ColEventArgs
);

Parameters

sender

e

Expand image Remarks

Je Domaintable ist ein Eintrag in der Key-Tabelle notwendig

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub C1Daten_AfterColUpdate(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles C1Daten.AfterColUpdate
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        Try
            For i = 0 To Me.C1Daten.Columns.Count - 1
                If LCase(Me.C1Daten.Columns(i).DataField) = "mutiert_am" Then Me.C1Daten.Columns(i).Value = Now
                If LCase(Me.C1Daten.Columns(i).DataField) = "mutierer" Then Me.C1Daten.Columns(i).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value
            Next

            'neuer DB-Key auslösen, sofern kein Key vorhanden ist
            If Me.C1Daten.Columns(0).Value Is DBNull.Value Then
                Dim dbkey As New TKB.VV.DB.clsMyKey_Tabelle()
                Dim key As Long
                dbkey.cpMainConnectionProvider = conn
                key = dbkey.get_dbkey(tablename)
                Me.C1Daten.Columns(0).Value = key
                For i = 0 To Me.C1Daten.Columns.Count - 1
                    If LCase(Me.C1Daten.Columns(i).DataField) = "mandantnr" Then
                        Me.C1Daten.Columns(i).Value = Globals.clsmitarbeiter.iMandantnr.Value
                    End If
                    If LCase(Me.C1Daten.Columns(i).DataField) = "erstellt_am" Then
                        Me.C1Daten.Columns(i).Value = Now
                    End If
                    If LCase(Me.C1Daten.Columns(i).DataField) = "securitylevel" Then
                        Me.C1Daten.Columns(i).Value = 0
                    End If
                    If LCase(Me.C1Daten.Columns(i).DataField) = "aktiv" Then
                        Me.C1Daten.Columns(i).Value = 1
                    End If
                    If LCase(Me.C1Daten.Columns(i).DataField) = "extern" Then
                        Me.C1Daten.Columns(i).Value = 0
                    End If
                Next
                dbkey.Dispose()
            End If
        Catch
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSLAKatalog Class
frmSLAKatalog Members


frmSLAKatalog.C1Daten_AfterInsert Method

frmSLAKatalog.C1Daten_AfterInsert Method

Aktualisierung der Default-Werte
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub C1Daten_AfterInsert( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Daten.AfterInsert
C#
private System.Void C1Daten_AfterInsert(
   object sender,
   EventArgs e
);
C++

private:
System::Void C1Daten_AfterInsert(
   object^ sender,
   EventArgs^ e
)
JScript
private function C1Daten_AfterInsert(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub C1Daten_AfterInsert(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Daten.AfterInsert
        Dim i As Integer
        'Defaulwerte erstellt_am, mutiert_am, mutierer und aktiv setzen
        Try
            For i = 0 To C1Daten.Columns.Count - 1
                If LCase(Me.C1Daten.Columns(i).DataField) = "aktiv" Then
                    Me.C1Daten.Columns(i).Value = 1
                End If
                If LCase(Me.C1Daten.Columns(i).DataField) = "mutiert_am" Then
                    Me.C1Daten.Columns(i).Value = Now
                End If
                If LCase(Me.C1Daten.Columns(i).DataField) = "mutierer" Then
                    Me.C1Daten.Columns(i).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value
                End If
                If LCase(Me.C1Daten.Columns(i).DataField) = "mandantnr" Then
                    Me.C1Daten.Columns(i).Value = Globals.clsmitarbeiter.iMandantnr.Value
                End If
                If LCase(Me.C1Daten.Columns(i).DataField) = "mandnat" Then
                    Me.C1Daten.Columns(i).Value = Globals.clsmitarbeiter.iMandantnr.Value
                End If
            Next
        Catch
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSLAKatalog Class
frmSLAKatalog Members


frmSLAKatalog.C1Daten_FetchCellTips Method

frmSLAKatalog.C1Daten_FetchCellTips Method

Anzeige allfälliger Cellen-Tips
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub C1Daten_FetchCellTips( _
   ByVal sender As Object, _
   ByVal e As FetchCellTipsEventArgs _
) Handles  _
   C1Daten.FetchCellTips
C#
private System.Void C1Daten_FetchCellTips(
   object sender,
   FetchCellTipsEventArgs e
);
C++

private:
System::Void C1Daten_FetchCellTips(
   object^ sender,
   FetchCellTipsEventArgs^ e
)
JScript
private function C1Daten_FetchCellTips(
    sender : object,
    e : FetchCellTipsEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub C1Daten_FetchCellTips(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs) Handles C1Daten.FetchCellTips
        Dim ts As New TKB.VV.Utils.Tabellenspalte
        ts.Tabelle = Me.tablename
        Try
            ts.Feld = Me.C1Daten.Columns(e.ColIndex).DataField
            ts.getspalte()
            e.CellTip = ts.TipText
        Catch
        End Try
        ts = Nothing

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSLAKatalog Class
frmSLAKatalog Members


frmSLAKatalog.Dispose Method

frmSLAKatalog.Dispose Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
C#
[System.Diagnostics.DebuggerNonUserCode()]
protected override System.Void Dispose(
   bool disposing
);
C++
[System.Diagnostics.DebuggerNonUserCode()]

protected:
System::Void Dispose(
   bool disposing
)
JScript
protected
   System.Diagnostics.DebuggerNonUserCode()
function Dispose(
    disposing : boolean
);

Parameters

disposing

Expand image Source code

Visual Basic CopyCode image Copy Code
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSLAKatalog Class
frmSLAKatalog Members


frmSLAKatalog.InitializeComponent Method

frmSLAKatalog.InitializeComponent Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()
C#
[System.Diagnostics.DebuggerStepThrough()]
private System.Void InitializeComponent();
C++
[System.Diagnostics.DebuggerStepThrough()]

private:
System::Void InitializeComponent()
JScript
private
   System.Diagnostics.DebuggerStepThrough()
function InitializeComponent();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmSLAKatalog))
        Dim Style1 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style2 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style3 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style4 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style5 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style6 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style7 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style8 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style9 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style10 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style11 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style12 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style13 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style14 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style15 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style16 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.C1DropDownSLATyp = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown
        Me.C1DropdownZeitheinheittyp = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown
        Me.C1Daten = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        CType(Me.C1DropDownSLATyp, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1DropdownZeitheinheittyp, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1Daten, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(127, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(780, 24)
        Me.MenuStrip1.TabIndex = 1
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "ToolStripButton1"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(780, 25)
        Me.ToolStrip1.TabIndex = 4
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'C1DropDownSLATyp
        '
        Me.C1DropDownSLATyp.AllowColMove = True
        Me.C1DropDownSLATyp.AllowColSelect = True
        Me.C1DropDownSLATyp.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1DropDownSLATyp.AlternatingRows = False
        Me.C1DropDownSLATyp.CaptionStyle = Style1
        Me.C1DropDownSLATyp.ColumnCaptionHeight = 17
        Me.C1DropDownSLATyp.ColumnFooterHeight = 17
        Me.C1DropDownSLATyp.EvenRowStyle = Style2
        Me.C1DropDownSLATyp.FetchRowStyles = False
        Me.C1DropDownSLATyp.FooterStyle = Style3
        Me.C1DropDownSLATyp.HeadingStyle = Style4
        Me.C1DropDownSLATyp.HighLightRowStyle = Style5
        Me.C1DropDownSLATyp.Images.Add(CType(resources.GetObject("C1DropDownSLATyp.Images"), System.Drawing.Image))
        Me.C1DropDownSLATyp.Location = New System.Drawing.Point(226, 165)
        Me.C1DropDownSLATyp.Name = "C1DropDownSLATyp"
        Me.C1DropDownSLATyp.OddRowStyle = Style6
        Me.C1DropDownSLATyp.RecordSelectorStyle = Style7
        Me.C1DropDownSLATyp.RowDivider.Color = System.Drawing.Color.DarkGray
        Me.C1DropDownSLATyp.RowDivider.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.[Single]
        Me.C1DropDownSLATyp.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1DropDownSLATyp.ScrollTips = False
        Me.C1DropDownSLATyp.Size = New System.Drawing.Size(231, 150)
        Me.C1DropDownSLATyp.Style = Style8
        Me.C1DropDownSLATyp.TabIndex = 6
        Me.C1DropDownSLATyp.Text = "C1TrueDBDropdown1"
        Me.C1DropDownSLATyp.Visible = False
        Me.C1DropDownSLATyp.PropBag = resources.GetString("C1DropDownSLATyp.PropBag")
        '
        'C1DropdownZeitheinheittyp
        '
        Me.C1DropdownZeitheinheittyp.AllowColMove = True
        Me.C1DropdownZeitheinheittyp.AllowColSelect = True
        Me.C1DropdownZeitheinheittyp.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1DropdownZeitheinheittyp.AlternatingRows = False
        Me.C1DropdownZeitheinheittyp.CaptionStyle = Style9
        Me.C1DropdownZeitheinheittyp.ColumnCaptionHeight = 17
        Me.C1DropdownZeitheinheittyp.ColumnFooterHeight = 17
        Me.C1DropdownZeitheinheittyp.EvenRowStyle = Style10
        Me.C1DropdownZeitheinheittyp.FetchRowStyles = False
        Me.C1DropdownZeitheinheittyp.FooterStyle = Style11
        Me.C1DropdownZeitheinheittyp.HeadingStyle = Style12
        Me.C1DropdownZeitheinheittyp.HighLightRowStyle = Style13
        Me.C1DropdownZeitheinheittyp.Images.Add(CType(resources.GetObject("C1DropdownZeitheinheittyp.Images"), System.Drawing.Image))
        Me.C1DropdownZeitheinheittyp.Location = New System.Drawing.Point(258, 165)
        Me.C1DropdownZeitheinheittyp.Name = "C1DropdownZeitheinheittyp"
        Me.C1DropdownZeitheinheittyp.OddRowStyle = Style14
        Me.C1DropdownZeitheinheittyp.RecordSelectorStyle = Style15
        Me.C1DropdownZeitheinheittyp.RowDivider.Color = System.Drawing.Color.DarkGray
        Me.C1DropdownZeitheinheittyp.RowDivider.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.[Single]
        Me.C1DropdownZeitheinheittyp.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1DropdownZeitheinheittyp.ScrollTips = False
        Me.C1DropdownZeitheinheittyp.Size = New System.Drawing.Size(235, 150)
        Me.C1DropdownZeitheinheittyp.Style = Style16
        Me.C1DropdownZeitheinheittyp.TabIndex = 7
        Me.C1DropdownZeitheinheittyp.Text = "C1TrueDBDropdown1"
        Me.C1DropdownZeitheinheittyp.Visible = False
        Me.C1DropdownZeitheinheittyp.PropBag = resources.GetString("C1DropdownZeitheinheittyp.PropBag")
        '
        'C1Daten
        '
        Me.C1Daten.AllowAddNew = True
        Me.C1Daten.AlternatingRows = True
        Me.C1Daten.DirectionAfterEnter = C1.Win.C1TrueDBGrid.DirectionAfterEnterEnum.MoveDown
        Me.C1Daten.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Daten.FilterBar = True
        Me.C1Daten.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Daten.Images.Add(CType(resources.GetObject("C1Daten.Images"), System.Drawing.Image))
        Me.C1Daten.Location = New System.Drawing.Point(0, 49)
        Me.C1Daten.Name = "C1Daten"
        Me.C1Daten.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Daten.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Daten.PreviewInfo.ZoomFactor = 75
        Me.C1Daten.PrintInfo.PageSettings = CType(resources.GetObject("C1Daten.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Daten.Size = New System.Drawing.Size(780, 297)
        Me.C1Daten.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Daten.TabIndex = 8
        Me.C1Daten.Text = "C1TrueDBGrid1"
        Me.C1Daten.PropBag = resources.GetString("C1Daten.PropBag")
        '
        'frmSLAKatalog
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(780, 346)
        Me.Controls.Add(Me.C1Daten)
        Me.Controls.Add(Me.C1DropdownZeitheinheittyp)
        Me.Controls.Add(Me.C1DropDownSLATyp)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Name = "frmSLAKatalog"
        Me.Text = "SLAKatalog"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        CType(Me.C1DropDownSLATyp, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1DropdownZeitheinheittyp, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1Daten, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSLAKatalog Class
frmSLAKatalog Members


frmSLAKatalog.SpaltenTitel_Aktualisieren Method

frmSLAKatalog.SpaltenTitel_Aktualisieren Method

Aktualisiert die Spaltentitel der aktuellen Tabelle
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub SpaltenTitel_Aktualisieren( _
   ByVal ds As DataSet _
)
C#
public System.Void SpaltenTitel_Aktualisieren(
   DataSet ds
);
C++

public:
System::Void SpaltenTitel_Aktualisieren(
   DataSet^ ds
)
JScript
public function SpaltenTitel_Aktualisieren(
    ds : DataSet
);

Parameters

ds

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Sub SpaltenTitel_Aktualisieren(ByVal ds As DataSet)
        Dim titel As New TKB.VV.Utils.MySpaltenTitel
        Dim anzcols As Integer
        Dim cols(Me.C1Daten.Splits(0).DisplayColumns.Count) As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim ts As New TKB.VV.Utils.Tabellenspalte

        Dim i As Integer
        Dim t As New DataTable()
        Dim s As String
        anzcols = Me.C1Daten.Splits(0).DisplayColumns.Count
        t = ds.Tables(0)
        ts.Tabelle = Me.tablename
        For i = 0 To Me.C1Daten.Columns.Count - 1
            s = Me.C1Daten.Columns(i).DataField
            ts.Feld = s
            ts.getspalte()
            Me.C1Daten.Columns(i).Caption = ts.spaltenname

            If ts.ColWith = 0 Then
                Me.C1Daten.Splits(0).DisplayColumns(i).Width = 0
                Me.C1Daten.Splits(0).DisplayColumns(i).Visible = False
            Else
                Me.C1Daten.Splits(0).DisplayColumns(i).Width = ts.ColWith
            End If

            If ts.locked Then
                Me.C1Daten.Splits(0).DisplayColumns(i).Locked = True
            End If

            If ts.AlsHacken Then
                Me.C1Daten.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
            End If

            'Präsentation von aktiv
            If Me.C1Daten.Columns(i).DataField = "aktiv" Then
                Me.C1Daten.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                Me.C1Daten.Columns(i).ValueItems.DefaultItem = True
                Me.C1Daten.Columns(i).DefaultValue = True
                Me.C1Daten.Columns(i).FilterText = True
            End If
            If Me.C1Daten.Columns(i).DataField = "erstellt_am" Then
                Me.C1Daten.Columns(i).DefaultValue = Now
            End If
        Next
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSLAKatalog Class
frmSLAKatalog Members


frmSLAKatalog.TSBtnQuit_Click Method

frmSLAKatalog.TSBtnQuit_Click Method

Ruft BeendetnToolStipMenuItem_Click auf
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click
C#
private System.Void TSBtnQuit_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnQuit_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnQuit_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        BeendenToolStripMenuItem_Click(sender, e)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSLAKatalog Class
frmSLAKatalog Members


frmSLAKatalog.TSBtnSave_Click Method

frmSLAKatalog.TSBtnSave_Click Method

Sichern der Daten
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click
C#
private System.Void TSBtnSave_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnSave_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnSave_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Try
            Domaintable.Save_Data()
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSLAKatalog Class
frmSLAKatalog Members


frmSLAKatalog.frmDomainEditor_FormClosing Method

frmSLAKatalog.frmDomainEditor_FormClosing Method

Prüfung auf allfällige Daten-Changes. Wurden Daten verändert, kann der User entscheiden, ob gespeichert, nichtgespeichert oder das Formular nicht gespeichert werden soll.
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub frmDomainEditor_FormClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing
C#
private System.Void frmDomainEditor_FormClosing(
   object sender,
   FormClosingEventArgs e
);
C++

private:
System::Void frmDomainEditor_FormClosing(
   object^ sender,
   FormClosingEventArgs^ e
)
JScript
private function frmDomainEditor_FormClosing(
    sender : object,
    e : FormClosingEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub frmDomainEditor_FormClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.Domaintable.Tabledata.HasChanges Then
            Dim msg As New TKB.VV.Utils.MyMessage
            Dim msgboxres As MsgBoxResult
            msgboxres = msg.Show_MessageYesNoCancel(3)
            If msgboxres = MsgBoxResult.Cancel Then
                e.Cancel = True
                Exit Sub
            End If
            If msgboxres = MsgBoxResult.Yes Then
                Domaintable.Save_Data()
            End If
        End If
        Domaintable.dispose()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSLAKatalog Class
frmSLAKatalog Members


frmSLAKatalog.frmDomainEditor_Load Method

frmSLAKatalog.frmDomainEditor_Load Method

Zuordnung der Daten aus Domaintable und Spaltentitel des Grids setzen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub frmDomainEditor_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load
C#
private System.Void frmDomainEditor_Load(
   object sender,
   EventArgs e
);
C++

private:
System::Void frmDomainEditor_Load(
   object^ sender,
   EventArgs^ e
)
JScript
private function frmDomainEditor_Load(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub frmDomainEditor_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.C1Daten.DataSource = Domaintable.Tabledata
        Me.C1Daten.DataMember = Domaintable.Tabledata.Tables(0).TableName
        SpaltenTitel_Aktualisieren(Domaintable.Tabledata)

        Me.SLATypData.cpMainConnectionProvider = Globals.conn
        Me.Zeiteinheittypdata.cpMainConnectionProvider = Globals.conn

        Globals.conn.OpenConnection()
        Me.SLATyp = SLATypData.SelectAll_Aktive
        Me.Zeiteinheittyp = Me.Zeiteinheittypdata.SelectAll_aktive
        Globals.conn.CloseConnection(True)

        Me.C1DropDownSLATyp.DataSource = Me.SLATyp
        Me.C1DropDownSLATyp.DataField = "SLATypNr"
        Me.C1DropDownSLATyp.ListField = "Bezeichnung"

        Me.C1DropdownZeitheinheittyp.DataSource = Me.Zeiteinheittyp
        Me.C1DropdownZeitheinheittyp.DataField = "Zeiteinheittypnr"
        Me.C1DropdownZeitheinheittyp.ListField = "Bezeichnung"

        Me.C1Daten.Columns("SLATypNr").DropDown = Me.C1DropDownSLATyp
        Me.C1Daten.Columns("Zeiteinheittypnr").DropDown = Me.C1DropdownZeitheinheittyp

        Me.C1Daten.Columns("SLATypNr").ValueItems.Translate = True
        Me.C1Daten.Columns("Zeiteinheittypnr").ValueItems.Translate = True

        Me.C1DropDownSLATyp.ValueTranslate = True
        Me.C1DropdownZeitheinheittyp.ValueTranslate = True

        Me.C1DropDownSLATyp.DisplayColumns(0).Width = 0
        Me.C1DropDownSLATyp.DisplayColumns(1).Width = Me.C1DropDownSLATyp.Width
        Me.C1DropdownZeitheinheittyp.DisplayColumns(0).Width = 0
        Me.C1DropdownZeitheinheittyp.DisplayColumns(1).Width = Me.C1DropdownZeitheinheittyp.Width

        sec.Set_Form_Security(Me)
        If Me.TSBtnSave.Visible = False Or Me.TSBtnSave.Enabled = False Then
            Me.C1Daten.AllowAddNew = False
            Me.C1Daten.AllowUpdate = False
        End If

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSLAKatalog Class
frmSLAKatalog Members


frmSLAKatalog Fields

frmSLAKatalog Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | Domaintable |
Supported by the .NET Compact Framework. | SLATyp |
Supported by the .NET Compact Framework. | SLATypData |
Supported by the .NET Compact Framework. | Zeiteinheittyp |
Supported by the .NET Compact Framework. | Zeiteinheittypdata |
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | sec |
Supported by the .NET Compact Framework. | tablename |
Top

Expand image See Also

Reference

frmSLAKatalog Class


Domaintable Variable

Domaintable Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Domaintable As clsSLAKatalogdaten
C#
private clsSLAKatalogdaten Domaintable;
C++
private:
clsSLAKatalogdaten^ Domaintable;
JScript
private Domaintable : clsSLAKatalogdaten

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Domaintable As TKB.VV.SLA.clsSLAKatalogdaten

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSLAKatalog Class
frmSLAKatalog Members


SLATyp Variable

SLATyp Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private SLATyp As DataTable
C#
private DataTable SLATyp;
C++
private:
DataTable^ SLATyp;
JScript
private SLATyp : DataTable

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim SLATyp As DataTable

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSLAKatalog Class
frmSLAKatalog Members


SLATypData Variable

SLATypData Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private SLATypData As mySLATyp
C#
private mySLATyp SLATypData;
C++
private:
mySLATyp^ SLATypData;
JScript
private SLATypData : mySLATyp

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim SLATypData As New TKB.VV.DB.mySLATyp

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSLAKatalog Class
frmSLAKatalog Members


Zeiteinheittyp Variable

Zeiteinheittyp Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Zeiteinheittyp As DataTable
C#
private DataTable Zeiteinheittyp;
C++
private:
DataTable^ Zeiteinheittyp;
JScript
private Zeiteinheittyp : DataTable

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Zeiteinheittyp As DataTable

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSLAKatalog Class
frmSLAKatalog Members


Zeiteinheittypdata Variable

Zeiteinheittypdata Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Zeiteinheittypdata As myZeiteinheittyp
C#
private myZeiteinheittyp Zeiteinheittypdata;
C++
private:
myZeiteinheittyp^ Zeiteinheittypdata;
JScript
private Zeiteinheittypdata : myZeiteinheittyp

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Zeiteinheittypdata As New TKB.VV.DB.myZeiteinheittyp

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSLAKatalog Class
frmSLAKatalog Members


components Variable

components Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private components As IContainer
C#
private IContainer components;
C++
private:
IContainer^ components;
JScript
private components : IContainer

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private components As System.ComponentModel.IContainer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSLAKatalog Class
frmSLAKatalog Members


sec Variable

sec Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private sec As MySecurity
C#
private MySecurity sec;
C++
private:
MySecurity^ sec;
JScript
private sec : MySecurity

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim sec As New TKB.VV.Utils.MySecurity

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSLAKatalog Class
frmSLAKatalog Members


tablename Variable

tablename Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private tablename As String
C#
private string tablename;
C++
private:
String^ tablename;
JScript
private tablename : String

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim tablename As String

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSLAKatalog Class
frmSLAKatalog Members


frmServicekatalog Class

frmServicekatalog Class
See Also Members
collapseAll image DropDown image

Servicekatalog-Verwaltung
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmServicekatalog
    Inherits Form
C#
[Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()]
public class frmServicekatalog : Form
C++
[Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()]

public ref class frmServicekatalog : public Form^
JScript
public
   Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()
class frmServicekatalog
   extends Form

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmServicekatalog

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Members
TKB.VV.SLA
TKB.VV.SLA.clsServiceKatalogDaten
TKB.VV.SLA.clsServiceKatalogSLATree
TKB.VV.SLA.clsServiceKatalogTree
TKB.VV.Sysadmin
TKB.VV.Sysadmin.DomainTable
TKB.VV.Utils
TKB.VV.Utils.MyMessage
TKB.VV.Utils.MySecurity
TKB.VV.Utils.Tabellenspalte


frmServicekatalog Members

frmServicekatalog Members
See Also Methods
CollapseAll image DropDown image

Servicekatalog-Verwaltung

The following tables list the members exposed by the frmServicekatalog type.

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | BeendenToolStripMenuItem_Click |
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | Load_Securitylevel | Laden der Securitylevel-Daten in die Combobox
Supported by the .NET Compact Framework. | NeueLeistungToolStripMenuItem_Click |
Supported by the .NET Compact Framework. | NeuerKatalogToolStripMenuItem_Click |
Supported by the .NET Compact Framework. | Refresh_SLATable |
Supported by the .NET Compact Framework. | Show_Data |
Supported by the .NET Compact Framework. | TSBtnQuit_Click |
Supported by the .NET Compact Framework. | TSBtnSave_Click |
Supported by the .NET Compact Framework. | TreeSLA_DoubleClick |
Supported by the .NET Compact Framework. | check_changes | Prüfung, ob Verbindungstabelle geändert wurde.
Supported by the .NET Compact Framework. | frmServicekatalog_FormClosing | Schliessen des Formulares
Supported by the .NET Compact Framework. | frmServicekatalog_Load | Formular aufbauen
Supported by the .NET Compact Framework. | save_katalogdata |
Supported by the .NET Compact Framework. | treeServiceKatalog_AfterSelect |
Supported by the .NET Compact Framework. | treeServiceKatalog_MouseDown |
Supported by the .NET Compact Framework. | txtBezeichnung_intern_TextChanged |
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | FormDataChanged |
Supported by the .NET Compact Framework. | FormReadonly |
Supported by the .NET Compact Framework. | SLATreeviewdata |
Supported by the .NET Compact Framework. | ServiceKatalogSLAKatalog |
Supported by the .NET Compact Framework. | Servicekatalogdaten |
Supported by the .NET Compact Framework. | SpaltenTitel |
Supported by the .NET Compact Framework. | Treeviewdata |
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | msg |
Supported by the .NET Compact Framework. | sec |
Top

Expand image See Also

Reference

frmServicekatalog Class
TKB.VV.SLA
TKB.VV.SLA.clsServiceKatalogDaten
TKB.VV.SLA.clsServiceKatalogSLATree
TKB.VV.SLA.clsServiceKatalogTree
TKB.VV.Sysadmin
TKB.VV.Sysadmin.DomainTable
TKB.VV.Utils
TKB.VV.Utils.MyMessage
TKB.VV.Utils.MySecurity
TKB.VV.Utils.Tabellenspalte


frmServicekatalog Methods

frmServicekatalog Methods
CollapseAll image DropDown image

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | BeendenToolStripMenuItem_Click |
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | Load_Securitylevel | Laden der Securitylevel-Daten in die Combobox
Supported by the .NET Compact Framework. | NeueLeistungToolStripMenuItem_Click |
Supported by the .NET Compact Framework. | NeuerKatalogToolStripMenuItem_Click |
Supported by the .NET Compact Framework. | Refresh_SLATable |
Supported by the .NET Compact Framework. | Show_Data |
Supported by the .NET Compact Framework. | TSBtnQuit_Click |
Supported by the .NET Compact Framework. | TSBtnSave_Click |
Supported by the .NET Compact Framework. | TreeSLA_DoubleClick |
Supported by the .NET Compact Framework. | check_changes | Prüfung, ob Verbindungstabelle geändert wurde.
Supported by the .NET Compact Framework. | frmServicekatalog_FormClosing | Schliessen des Formulares
Supported by the .NET Compact Framework. | frmServicekatalog_Load | Formular aufbauen
Supported by the .NET Compact Framework. | save_katalogdata |
Supported by the .NET Compact Framework. | treeServiceKatalog_AfterSelect |
Supported by the .NET Compact Framework. | treeServiceKatalog_MouseDown |
Supported by the .NET Compact Framework. | txtBezeichnung_intern_TextChanged |
Top

Expand image See Also

Reference

frmServicekatalog Class
TKB.VV.SLA
TKB.VV.SLA.clsServiceKatalogDaten
TKB.VV.SLA.clsServiceKatalogSLATree
TKB.VV.SLA.clsServiceKatalogTree
TKB.VV.Sysadmin
TKB.VV.Sysadmin.DomainTable
TKB.VV.Utils
TKB.VV.Utils.MyMessage
TKB.VV.Utils.MySecurity
TKB.VV.Utils.Tabellenspalte


frmServicekatalog.BeendenToolStripMenuItem_Click Method

frmServicekatalog.BeendenToolStripMenuItem_Click Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click
C#
private System.Void BeendenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void BeendenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function BeendenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


frmServicekatalog.Dispose Method

frmServicekatalog.Dispose Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
C#
[System.Diagnostics.DebuggerNonUserCode()]
protected override System.Void Dispose(
   bool disposing
);
C++
[System.Diagnostics.DebuggerNonUserCode()]

protected:
System::Void Dispose(
   bool disposing
)
JScript
protected
   System.Diagnostics.DebuggerNonUserCode()
function Dispose(
    disposing : boolean
);

Parameters

disposing

Expand image Source code

Visual Basic CopyCode image Copy Code
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


frmServicekatalog.InitializeComponent Method

frmServicekatalog.InitializeComponent Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()
C#
[System.Diagnostics.DebuggerStepThrough()]
private System.Void InitializeComponent();
C++
[System.Diagnostics.DebuggerStepThrough()]

private:
System::Void InitializeComponent()
JScript
private
   System.Diagnostics.DebuggerStepThrough()
function InitializeComponent();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmServicekatalog))
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.TestToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TestAToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TestAaToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TestAbToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TestBToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.pnlServicekatalog = New System.Windows.Forms.Panel
        Me.treeServiceKatalog = New System.Windows.Forms.TreeView
        Me.ctxMenuTreeServiceKatalog = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.NeuerKatalogToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.NeueLeistungToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ImgListTreeServiceKatalog = New System.Windows.Forms.ImageList(Me.components)
        Me.pnlServicekataloglabel = New System.Windows.Forms.Panel
        Me.lblServiceKatalog = New System.Windows.Forms.Label
        Me.SplitContainer1 = New System.Windows.Forms.SplitContainer
        Me.cbaktiv = New System.Windows.Forms.CheckBox
        Me.lblAktiv = New System.Windows.Forms.Label
        Me.txtMutierer = New System.Windows.Forms.TextBox
        Me.lblMutierer = New System.Windows.Forms.Label
        Me.txtmutiert_am = New System.Windows.Forms.TextBox
        Me.lblMutiert_am = New System.Windows.Forms.Label
        Me.txterstellt_am = New System.Windows.Forms.TextBox
        Me.lblErstellt_am = New System.Windows.Forms.Label
        Me.cboxSecurityLevel = New System.Windows.Forms.ComboBox
        Me.lblSecurityLebel = New System.Windows.Forms.Label
        Me.txtBemerkung = New System.Windows.Forms.TextBox
        Me.lblBemerkung = New System.Windows.Forms.Label
        Me.cbextern = New System.Windows.Forms.CheckBox
        Me.lblextern = New System.Windows.Forms.Label
        Me.txtBezeichnung_extern = New System.Windows.Forms.TextBox
        Me.txtBezeichnung_intern = New System.Windows.Forms.TextBox
        Me.lblBezeichnungExtern = New System.Windows.Forms.Label
        Me.lblBezeichnung_intern = New System.Windows.Forms.Label
        Me.tabctrlDetails = New System.Windows.Forms.TabControl
        Me.TabSLA = New System.Windows.Forms.TabPage
        Me.C1DatenSLA = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.TreeSLA = New System.Windows.Forms.TreeView
        Me.TabVertragsbeziehungen = New System.Windows.Forms.TabPage
        Me.C1DatenVertragsbeziehungen = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.pnlServicekatalog.SuspendLayout()
        Me.ctxMenuTreeServiceKatalog.SuspendLayout()
        Me.pnlServicekataloglabel.SuspendLayout()
        Me.SplitContainer1.Panel1.SuspendLayout()
        Me.SplitContainer1.Panel2.SuspendLayout()
        Me.SplitContainer1.SuspendLayout()
        Me.tabctrlDetails.SuspendLayout()
        Me.TabSLA.SuspendLayout()
        CType(Me.C1DatenSLA, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabVertragsbeziehungen.SuspendLayout()
        CType(Me.C1DatenVertragsbeziehungen, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(127, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem, Me.TestToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(876, 24)
        Me.MenuStrip1.TabIndex = 2
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'TestToolStripMenuItem
        '
        Me.TestToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TestAToolStripMenuItem, Me.TestBToolStripMenuItem})
        Me.TestToolStripMenuItem.Name = "TestToolStripMenuItem"
        Me.TestToolStripMenuItem.Size = New System.Drawing.Size(40, 20)
        Me.TestToolStripMenuItem.Text = "Test"
        '
        'TestAToolStripMenuItem
        '
        Me.TestAToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TestAaToolStripMenuItem, Me.TestAbToolStripMenuItem})
        Me.TestAToolStripMenuItem.Name = "TestAToolStripMenuItem"
        Me.TestAToolStripMenuItem.Size = New System.Drawing.Size(115, 22)
        Me.TestAToolStripMenuItem.Text = "Test a"
        '
        'TestAaToolStripMenuItem
        '
        Me.TestAaToolStripMenuItem.Name = "TestAaToolStripMenuItem"
        Me.TestAaToolStripMenuItem.Size = New System.Drawing.Size(121, 22)
        Me.TestAaToolStripMenuItem.Text = "Test aa"
        '
        'TestAbToolStripMenuItem
        '
        Me.TestAbToolStripMenuItem.Name = "TestAbToolStripMenuItem"
        Me.TestAbToolStripMenuItem.Size = New System.Drawing.Size(121, 22)
        Me.TestAbToolStripMenuItem.Text = "test ab"
        '
        'TestBToolStripMenuItem
        '
        Me.TestBToolStripMenuItem.Name = "TestBToolStripMenuItem"
        Me.TestBToolStripMenuItem.Size = New System.Drawing.Size(115, 22)
        Me.TestBToolStripMenuItem.Text = "Test b"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(876, 25)
        Me.ToolStrip1.TabIndex = 5
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "ToolStripButton1"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'pnlServicekatalog
        '
        Me.pnlServicekatalog.Controls.Add(Me.treeServiceKatalog)
        Me.pnlServicekatalog.Controls.Add(Me.pnlServicekataloglabel)
        Me.pnlServicekatalog.Dock = System.Windows.Forms.DockStyle.Left
        Me.pnlServicekatalog.Location = New System.Drawing.Point(0, 49)
        Me.pnlServicekatalog.Name = "pnlServicekatalog"
        Me.pnlServicekatalog.Size = New System.Drawing.Size(196, 515)
        Me.pnlServicekatalog.TabIndex = 6
        '
        'treeServiceKatalog
        '
        Me.treeServiceKatalog.ContextMenuStrip = Me.ctxMenuTreeServiceKatalog
        Me.treeServiceKatalog.Dock = System.Windows.Forms.DockStyle.Fill
        Me.treeServiceKatalog.FullRowSelect = True
        Me.treeServiceKatalog.HideSelection = False
        Me.treeServiceKatalog.HotTracking = True
        Me.treeServiceKatalog.ImageIndex = 0
        Me.treeServiceKatalog.ImageList = Me.ImgListTreeServiceKatalog
        Me.treeServiceKatalog.Location = New System.Drawing.Point(0, 29)
        Me.treeServiceKatalog.Name = "treeServiceKatalog"
        Me.treeServiceKatalog.SelectedImageIndex = 0
        Me.treeServiceKatalog.Size = New System.Drawing.Size(196, 486)
        Me.treeServiceKatalog.TabIndex = 1
        '
        'ctxMenuTreeServiceKatalog
        '
        Me.ctxMenuTreeServiceKatalog.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.NeuerKatalogToolStripMenuItem, Me.NeueLeistungToolStripMenuItem})
        Me.ctxMenuTreeServiceKatalog.Name = "ctxMenuTreeServiceKatalog"
        Me.ctxMenuTreeServiceKatalog.Size = New System.Drawing.Size(154, 48)
        '
        'NeuerKatalogToolStripMenuItem
        '
        Me.NeuerKatalogToolStripMenuItem.Name = "NeuerKatalogToolStripMenuItem"
        Me.NeuerKatalogToolStripMenuItem.Size = New System.Drawing.Size(153, 22)
        Me.NeuerKatalogToolStripMenuItem.Text = "Neuer &Katalog"
        '
        'NeueLeistungToolStripMenuItem
        '
        Me.NeueLeistungToolStripMenuItem.Name = "NeueLeistungToolStripMenuItem"
        Me.NeueLeistungToolStripMenuItem.Size = New System.Drawing.Size(153, 22)
        Me.NeueLeistungToolStripMenuItem.Text = "Neue &Leistung"
        '
        'ImgListTreeServiceKatalog
        '
        Me.ImgListTreeServiceKatalog.ImageStream = CType(resources.GetObject("ImgListTreeServiceKatalog.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImgListTreeServiceKatalog.TransparentColor = System.Drawing.Color.Transparent
        Me.ImgListTreeServiceKatalog.Images.SetKeyName(0, "BOOK10.GIF")
        Me.ImgListTreeServiceKatalog.Images.SetKeyName(1, "BOOKS10.GIF")
        '
        'pnlServicekataloglabel
        '
        Me.pnlServicekataloglabel.Controls.Add(Me.lblServiceKatalog)
        Me.pnlServicekataloglabel.Dock = System.Windows.Forms.DockStyle.Top
        Me.pnlServicekataloglabel.Location = New System.Drawing.Point(0, 0)
        Me.pnlServicekataloglabel.Name = "pnlServicekataloglabel"
        Me.pnlServicekataloglabel.Size = New System.Drawing.Size(196, 29)
        Me.pnlServicekataloglabel.TabIndex = 2
        '
        'lblServiceKatalog
        '
        Me.lblServiceKatalog.AutoSize = True
        Me.lblServiceKatalog.Location = New System.Drawing.Point(3, 9)
        Me.lblServiceKatalog.Name = "lblServiceKatalog"
        Me.lblServiceKatalog.Size = New System.Drawing.Size(78, 13)
        Me.lblServiceKatalog.TabIndex = 0
        Me.lblServiceKatalog.Text = "Servicekatalog"
        '
        'SplitContainer1
        '
        Me.SplitContainer1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.SplitContainer1.Location = New System.Drawing.Point(196, 49)
        Me.SplitContainer1.Name = "SplitContainer1"
        Me.SplitContainer1.Orientation = System.Windows.Forms.Orientation.Horizontal
        '
        'SplitContainer1.Panel1
        '
        Me.SplitContainer1.Panel1.Controls.Add(Me.cbaktiv)
        Me.SplitContainer1.Panel1.Controls.Add(Me.lblAktiv)
        Me.SplitContainer1.Panel1.Controls.Add(Me.txtMutierer)
        Me.SplitContainer1.Panel1.Controls.Add(Me.lblMutierer)
        Me.SplitContainer1.Panel1.Controls.Add(Me.txtmutiert_am)
        Me.SplitContainer1.Panel1.Controls.Add(Me.lblMutiert_am)
        Me.SplitContainer1.Panel1.Controls.Add(Me.txterstellt_am)
        Me.SplitContainer1.Panel1.Controls.Add(Me.lblErstellt_am)
        Me.SplitContainer1.Panel1.Controls.Add(Me.cboxSecurityLevel)
        Me.SplitContainer1.Panel1.Controls.Add(Me.lblSecurityLebel)
        Me.SplitContainer1.Panel1.Controls.Add(Me.txtBemerkung)
        Me.SplitContainer1.Panel1.Controls.Add(Me.lblBemerkung)
        Me.SplitContainer1.Panel1.Controls.Add(Me.cbextern)
        Me.SplitContainer1.Panel1.Controls.Add(Me.lblextern)
        Me.SplitContainer1.Panel1.Controls.Add(Me.txtBezeichnung_extern)
        Me.SplitContainer1.Panel1.Controls.Add(Me.txtBezeichnung_intern)
        Me.SplitContainer1.Panel1.Controls.Add(Me.lblBezeichnungExtern)
        Me.SplitContainer1.Panel1.Controls.Add(Me.lblBezeichnung_intern)
        '
        'SplitContainer1.Panel2
        '
        Me.SplitContainer1.Panel2.Controls.Add(Me.tabctrlDetails)
        Me.SplitContainer1.Size = New System.Drawing.Size(680, 515)
        Me.SplitContainer1.SplitterDistance = 237
        Me.SplitContainer1.TabIndex = 7
        '
        'cbaktiv
        '
        Me.cbaktiv.AutoSize = True
        Me.cbaktiv.Location = New System.Drawing.Point(517, 91)
        Me.cbaktiv.Name = "cbaktiv"
        Me.cbaktiv.Size = New System.Drawing.Size(15, 14)
        Me.cbaktiv.TabIndex = 17
        Me.cbaktiv.UseVisualStyleBackColor = True
        '
        'lblAktiv
        '
        Me.lblAktiv.AutoSize = True
        Me.lblAktiv.Location = New System.Drawing.Point(436, 91)
        Me.lblAktiv.Name = "lblAktiv"
        Me.lblAktiv.Size = New System.Drawing.Size(31, 13)
        Me.lblAktiv.TabIndex = 16
        Me.lblAktiv.Text = "Aktiv"
        '
        'txtMutierer
        '
        Me.txtMutierer.Location = New System.Drawing.Point(517, 60)
        Me.txtMutierer.Name = "txtMutierer"
        Me.txtMutierer.ReadOnly = True
        Me.txtMutierer.Size = New System.Drawing.Size(132, 20)
        Me.txtMutierer.TabIndex = 15
        '
        'lblMutierer
        '
        Me.lblMutierer.AutoSize = True
        Me.lblMutierer.Location = New System.Drawing.Point(436, 64)
        Me.lblMutierer.Name = "lblMutierer"
        Me.lblMutierer.Size = New System.Drawing.Size(69, 13)
        Me.lblMutierer.TabIndex = 14
        Me.lblMutierer.Text = "Mutiert durch"
        '
        'txtmutiert_am
        '
        Me.txtmutiert_am.Location = New System.Drawing.Point(517, 34)
        Me.txtmutiert_am.Name = "txtmutiert_am"
        Me.txtmutiert_am.ReadOnly = True
        Me.txtmutiert_am.Size = New System.Drawing.Size(132, 20)
        Me.txtmutiert_am.TabIndex = 13
        '
        'lblMutiert_am
        '
        Me.lblMutiert_am.AutoSize = True
        Me.lblMutiert_am.Location = New System.Drawing.Point(436, 37)
        Me.lblMutiert_am.Name = "lblMutiert_am"
        Me.lblMutiert_am.Size = New System.Drawing.Size(55, 13)
        Me.lblMutiert_am.TabIndex = 12
        Me.lblMutiert_am.Text = "Erstellt am"
        '
        'txterstellt_am
        '
        Me.txterstellt_am.Location = New System.Drawing.Point(517, 9)
        Me.txterstellt_am.Name = "txterstellt_am"
        Me.txterstellt_am.ReadOnly = True
        Me.txterstellt_am.Size = New System.Drawing.Size(132, 20)
        Me.txterstellt_am.TabIndex = 11
        '
        'lblErstellt_am
        '
        Me.lblErstellt_am.AutoSize = True
        Me.lblErstellt_am.Location = New System.Drawing.Point(436, 12)
        Me.lblErstellt_am.Name = "lblErstellt_am"
        Me.lblErstellt_am.Size = New System.Drawing.Size(55, 13)
        Me.lblErstellt_am.TabIndex = 10
        Me.lblErstellt_am.Text = "Erstellt am"
        '
        'cboxSecurityLevel
        '
        Me.cboxSecurityLevel.FormattingEnabled = True
        Me.cboxSecurityLevel.Location = New System.Drawing.Point(132, 196)
        Me.cboxSecurityLevel.Name = "cboxSecurityLevel"
        Me.cboxSecurityLevel.Size = New System.Drawing.Size(121, 21)
        Me.cboxSecurityLevel.TabIndex = 9
        '
        'lblSecurityLebel
        '
        Me.lblSecurityLebel.AutoSize = True
        Me.lblSecurityLebel.Location = New System.Drawing.Point(17, 199)
        Me.lblSecurityLebel.Name = "lblSecurityLebel"
        Me.lblSecurityLebel.Size = New System.Drawing.Size(71, 13)
        Me.lblSecurityLebel.TabIndex = 8
        Me.lblSecurityLebel.Text = "SecurityLevel"
        '
        'txtBemerkung
        '
        Me.txtBemerkung.Location = New System.Drawing.Point(132, 88)
        Me.txtBemerkung.Multiline = True
        Me.txtBemerkung.Name = "txtBemerkung"
        Me.txtBemerkung.Size = New System.Drawing.Size(236, 95)
        Me.txtBemerkung.TabIndex = 7
        '
        'lblBemerkung
        '
        Me.lblBemerkung.AutoSize = True
        Me.lblBemerkung.Location = New System.Drawing.Point(17, 91)
        Me.lblBemerkung.Name = "lblBemerkung"
        Me.lblBemerkung.Size = New System.Drawing.Size(61, 13)
        Me.lblBemerkung.TabIndex = 6
        Me.lblBemerkung.Text = "Bemerkung"
        '
        'cbextern
        '
        Me.cbextern.AutoSize = True
        Me.cbextern.Location = New System.Drawing.Point(132, 63)
        Me.cbextern.Name = "cbextern"
        Me.cbextern.Size = New System.Drawing.Size(15, 14)
        Me.cbextern.TabIndex = 5
        Me.cbextern.UseVisualStyleBackColor = True
        '
        'lblextern
        '
        Me.lblextern.AutoSize = True
        Me.lblextern.Location = New System.Drawing.Point(17, 63)
        Me.lblextern.Name = "lblextern"
        Me.lblextern.Size = New System.Drawing.Size(37, 13)
        Me.lblextern.TabIndex = 4
        Me.lblextern.Text = "Extern"
        '
        'txtBezeichnung_extern
        '
        Me.txtBezeichnung_extern.Location = New System.Drawing.Point(132, 34)
        Me.txtBezeichnung_extern.Name = "txtBezeichnung_extern"
        Me.txtBezeichnung_extern.Size = New System.Drawing.Size(236, 20)
        Me.txtBezeichnung_extern.TabIndex = 3
        '
        'txtBezeichnung_intern
        '
        Me.txtBezeichnung_intern.Location = New System.Drawing.Point(132, 9)
        Me.txtBezeichnung_intern.Name = "txtBezeichnung_intern"
        Me.txtBezeichnung_intern.Size = New System.Drawing.Size(236, 20)
        Me.txtBezeichnung_intern.TabIndex = 2
        '
        'lblBezeichnungExtern
        '
        Me.lblBezeichnungExtern.AutoSize = True
        Me.lblBezeichnungExtern.Location = New System.Drawing.Point(17, 37)
        Me.lblBezeichnungExtern.Name = "lblBezeichnungExtern"
        Me.lblBezeichnungExtern.Size = New System.Drawing.Size(101, 13)
        Me.lblBezeichnungExtern.TabIndex = 1
        Me.lblBezeichnungExtern.Text = "Bezeichnung extern"
        '
        'lblBezeichnung_intern
        '
        Me.lblBezeichnung_intern.AutoSize = True
        Me.lblBezeichnung_intern.Location = New System.Drawing.Point(17, 12)
        Me.lblBezeichnung_intern.Name = "lblBezeichnung_intern"
        Me.lblBezeichnung_intern.Size = New System.Drawing.Size(98, 13)
        Me.lblBezeichnung_intern.TabIndex = 0
        Me.lblBezeichnung_intern.Text = "Bezeichnung intern"
        '
        'tabctrlDetails
        '
        Me.tabctrlDetails.Controls.Add(Me.TabSLA)
        Me.tabctrlDetails.Controls.Add(Me.TabVertragsbeziehungen)
        Me.tabctrlDetails.Dock = System.Windows.Forms.DockStyle.Fill
        Me.tabctrlDetails.Location = New System.Drawing.Point(0, 0)
        Me.tabctrlDetails.Name = "tabctrlDetails"
        Me.tabctrlDetails.SelectedIndex = 0
        Me.tabctrlDetails.Size = New System.Drawing.Size(680, 274)
        Me.tabctrlDetails.TabIndex = 0
        '
        'TabSLA
        '
        Me.TabSLA.Controls.Add(Me.C1DatenSLA)
        Me.TabSLA.Controls.Add(Me.TreeSLA)
        Me.TabSLA.Location = New System.Drawing.Point(4, 22)
        Me.TabSLA.Name = "TabSLA"
        Me.TabSLA.Padding = New System.Windows.Forms.Padding(3)
        Me.TabSLA.Size = New System.Drawing.Size(672, 248)
        Me.TabSLA.TabIndex = 0
        Me.TabSLA.Text = "SLA"
        Me.TabSLA.UseVisualStyleBackColor = True
        '
        'C1DatenSLA
        '
        Me.C1DatenSLA.AlternatingRows = True
        Me.C1DatenSLA.DirectionAfterEnter = C1.Win.C1TrueDBGrid.DirectionAfterEnterEnum.MoveDown
        Me.C1DatenSLA.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1DatenSLA.FilterBar = True
        Me.C1DatenSLA.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1DatenSLA.Images.Add(CType(resources.GetObject("C1DatenSLA.Images"), System.Drawing.Image))
        Me.C1DatenSLA.Location = New System.Drawing.Point(161, 3)
        Me.C1DatenSLA.Name = "C1DatenSLA"
        Me.C1DatenSLA.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1DatenSLA.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1DatenSLA.PreviewInfo.ZoomFactor = 75
        Me.C1DatenSLA.PrintInfo.PageSettings = CType(resources.GetObject("C1DatenSLA.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1DatenSLA.Size = New System.Drawing.Size(508, 242)
        Me.C1DatenSLA.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1DatenSLA.TabIndex = 4
        Me.C1DatenSLA.Text = "C1TrueDBGrid1"
        Me.C1DatenSLA.PropBag = resources.GetString("C1DatenSLA.PropBag")
        '
        'TreeSLA
        '
        Me.TreeSLA.Dock = System.Windows.Forms.DockStyle.Left
        Me.TreeSLA.Location = New System.Drawing.Point(3, 3)
        Me.TreeSLA.Name = "TreeSLA"
        Me.TreeSLA.Size = New System.Drawing.Size(158, 242)
        Me.TreeSLA.TabIndex = 0
        '
        'TabVertragsbeziehungen
        '
        Me.TabVertragsbeziehungen.Controls.Add(Me.C1DatenVertragsbeziehungen)
        Me.TabVertragsbeziehungen.Location = New System.Drawing.Point(4, 22)
        Me.TabVertragsbeziehungen.Name = "TabVertragsbeziehungen"
        Me.TabVertragsbeziehungen.Padding = New System.Windows.Forms.Padding(3)
        Me.TabVertragsbeziehungen.Size = New System.Drawing.Size(672, 248)
        Me.TabVertragsbeziehungen.TabIndex = 1
        Me.TabVertragsbeziehungen.Text = "Vertragsbeziehungen"
        Me.TabVertragsbeziehungen.UseVisualStyleBackColor = True
        '
        'C1DatenVertragsbeziehungen
        '
        Me.C1DatenVertragsbeziehungen.AllowAddNew = True
        Me.C1DatenVertragsbeziehungen.AlternatingRows = True
        Me.C1DatenVertragsbeziehungen.DirectionAfterEnter = C1.Win.C1TrueDBGrid.DirectionAfterEnterEnum.MoveDown
        Me.C1DatenVertragsbeziehungen.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1DatenVertragsbeziehungen.FilterBar = True
        Me.C1DatenVertragsbeziehungen.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1DatenVertragsbeziehungen.Images.Add(CType(resources.GetObject("C1DatenVertragsbeziehungen.Images"), System.Drawing.Image))
        Me.C1DatenVertragsbeziehungen.Location = New System.Drawing.Point(3, 3)
        Me.C1DatenVertragsbeziehungen.Name = "C1DatenVertragsbeziehungen"
        Me.C1DatenVertragsbeziehungen.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1DatenVertragsbeziehungen.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1DatenVertragsbeziehungen.PreviewInfo.ZoomFactor = 75
        Me.C1DatenVertragsbeziehungen.PrintInfo.PageSettings = CType(resources.GetObject("C1DatenVertragsbeziehungen.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1DatenVertragsbeziehungen.Size = New System.Drawing.Size(666, 242)
        Me.C1DatenVertragsbeziehungen.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1DatenVertragsbeziehungen.TabIndex = 4
        Me.C1DatenVertragsbeziehungen.Text = "C1TrueDBGrid1"
        Me.C1DatenVertragsbeziehungen.PropBag = resources.GetString("C1DatenVertragsbeziehungen.PropBag")
        '
        'frmServicekatalog
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(876, 564)
        Me.Controls.Add(Me.SplitContainer1)
        Me.Controls.Add(Me.pnlServicekatalog)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmServicekatalog"
        Me.Text = "Service-Katalog"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.pnlServicekatalog.ResumeLayout(False)
        Me.ctxMenuTreeServiceKatalog.ResumeLayout(False)
        Me.pnlServicekataloglabel.ResumeLayout(False)
        Me.pnlServicekataloglabel.PerformLayout()
        Me.SplitContainer1.Panel1.ResumeLayout(False)
        Me.SplitContainer1.Panel1.PerformLayout()
        Me.SplitContainer1.Panel2.ResumeLayout(False)
        Me.SplitContainer1.ResumeLayout(False)
        Me.tabctrlDetails.ResumeLayout(False)
        Me.TabSLA.ResumeLayout(False)
        CType(Me.C1DatenSLA, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabVertragsbeziehungen.ResumeLayout(False)
        CType(Me.C1DatenVertragsbeziehungen, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


frmServicekatalog.Load_Securitylevel Method

frmServicekatalog.Load_Securitylevel Method

Laden der Securitylevel-Daten in die Combobox
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Load_Securitylevel()
C#
private System.Void Load_Securitylevel();
C++

private:
System::Void Load_Securitylevel()
JScript
private function Load_Securitylevel();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Load_Securitylevel()
        Dim seclevel As New TKB.VV.DB.clsSecurityLevel
        Dim secleveldata As New DataTable

        seclevel.cpMainConnectionProvider = Globals.conn
        Globals.conn.OpenConnection()
        secleveldata = seclevel.SelectAll
        Globals.conn.CloseConnection(True)

        Me.cboxSecurityLevel.DataSource = secleveldata
        Me.cboxSecurityLevel.DisplayMember = "Bezeichnung"
        Me.cboxSecurityLevel.ValueMember = "SecurityLevelNr"

        seclevel.Dispose()

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


frmServicekatalog.NeueLeistungToolStripMenuItem_Click Method

frmServicekatalog.NeueLeistungToolStripMenuItem_Click Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub NeueLeistungToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   NeueLeistungToolStripMenuItem.Click
C#
private System.Void NeueLeistungToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void NeueLeistungToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function NeueLeistungToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub NeueLeistungToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles NeueLeistungToolStripMenuItem.Click
        Dim Katalogname As String = InputBox("Katalogname", "Neuer Katalog")
        If Katalogname <> "" Then
            Dim key As Integer = Me.Servicekatalogdaten.Insert_Katalogelement(Katalogname, Me.treeServiceKatalog.SelectedNode.Tag)
            Treeviewdata.Load_Tree(Me.treeServiceKatalog)
            Treeviewdata.Set_Images(Me.treeServiceKatalog)
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


frmServicekatalog.NeuerKatalogToolStripMenuItem_Click Method

frmServicekatalog.NeuerKatalogToolStripMenuItem_Click Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub NeuerKatalogToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   NeuerKatalogToolStripMenuItem.Click
C#
private System.Void NeuerKatalogToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void NeuerKatalogToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function NeuerKatalogToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub NeuerKatalogToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles NeuerKatalogToolStripMenuItem.Click
        Dim Katalogname As String = InputBox("Katalogname", "Neuer Katalog")
        If Katalogname <> "" Then
            Dim key As Integer = Me.Servicekatalogdaten.Insert_Katalogelement(Katalogname, 0)
            Treeviewdata.Load_Tree(Me.treeServiceKatalog)
            Treeviewdata.Set_Images(Me.treeServiceKatalog)
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


frmServicekatalog.Refresh_SLATable Method

frmServicekatalog.Refresh_SLATable Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Refresh_SLATable()
C#
private System.Void Refresh_SLATable();
C++

private:
System::Void Refresh_SLATable()
JScript
private function Refresh_SLATable();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Refresh_SLATable()
        Try
            check_changes()
            Me.ServiceKatalogSLAKatalog.dispose()
        Catch
        End Try

        Dim keyvalue As String = ""
        keyvalue = Me.treeServiceKatalog.SelectedNode.Tag
        Me.C1DatenSLA.Enabled = False
        Me.ServiceKatalogSLAKatalog = New TKB.VV.Sysadmin.DomainTable("servicekatalog_slakatalog", keyvalue, Globals.clsmitarbeiter.iMitarbeiternr.Value)
        Me.C1DatenSLA.DataSource = ServiceKatalogSLAKatalog.Tabledata
        Me.C1DatenSLA.DataMember = ServiceKatalogSLAKatalog.Tabledata.Tables(0).TableName
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1DatenSLA, "servicekatalog_slakatalog", Me.ServiceKatalogSLAKatalog.Tabledata)
        Me.C1DatenSLA.Enabled = True

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


frmServicekatalog.Show_Data Method

frmServicekatalog.Show_Data Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Show_Data( _
   ByVal Servicekatalognr As Integer _
)
C#
private System.Void Show_Data(
   int Servicekatalognr
);
C++

private:
System::Void Show_Data(
   int Servicekatalognr
)
JScript
private function Show_Data(
    Servicekatalognr : int
);

Parameters

Servicekatalognr

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Show_Data(ByVal Servicekatalognr As Integer)
        Me.Servicekatalogdaten.Get_Data(Servicekatalognr)
        Me.txtBezeichnung_intern.Text = Me.Servicekatalogdaten.sBezeichnung_intern.Value
        Me.txtBezeichnung_extern.Text = Me.Servicekatalogdaten.sBezeichnung_extern.Value
        Me.txtBemerkung.Text = Me.Servicekatalogdaten.sBemerkung.Value
        Me.txtmutiert_am.Text = Me.Servicekatalogdaten.daMutiert_am.ToString
        Me.txterstellt_am.Text = Me.Servicekatalogdaten.daErstellt_am.ToString
        Me.txtMutierer.Text = Me.Servicekatalogdaten.iMutierer.Value
        Me.cbaktiv.Checked = Me.Servicekatalogdaten.bAktiv.Value = True
        Me.cbextern.Checked = Me.Servicekatalogdaten.bExtern.Value = True
        Me.cboxSecurityLevel.SelectedValue = Me.Servicekatalogdaten.iSecurityLevelNr.Value
        Me.FormDataChanged = False
        If Me.Servicekatalogdaten.iParentID > 0 Then Me.cboxSecurityLevel.Enabled = False Else Me.cboxSecurityLevel.Enabled = True
        Refresh_SLATable()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


frmServicekatalog.TSBtnQuit_Click Method

frmServicekatalog.TSBtnQuit_Click Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click
C#
private System.Void TSBtnQuit_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnQuit_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnQuit_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


frmServicekatalog.TSBtnSave_Click Method

frmServicekatalog.TSBtnSave_Click Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click
C#
private System.Void TSBtnSave_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnSave_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnSave_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        If Me.FormDataChanged Then
            save_katalogdata()
            Me.FormDataChanged = False
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


frmServicekatalog.TreeSLA_DoubleClick Method

frmServicekatalog.TreeSLA_DoubleClick Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TreeSLA_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TreeSLA.DoubleClick
C#
private System.Void TreeSLA_DoubleClick(
   object sender,
   EventArgs e
);
C++

private:
System::Void TreeSLA_DoubleClick(
   object^ sender,
   EventArgs^ e
)
JScript
private function TreeSLA_DoubleClick(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TreeSLA_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles TreeSLA.DoubleClick
        If TreeSLA.SelectedNode.Tag <> 0 And Not Me.FormReadonly Then
            Me.ServiceKatalogSLAKatalog.Insert_Bottom_Table("ServiceKatalognr", Me.treeServiceKatalog.SelectedNode.Tag, "slakatalognr", Me.TreeSLA.SelectedNode.Tag)
            Me.ServiceKatalogSLAKatalog.Save_Data()
            Refresh_SLATable()
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


frmServicekatalog.check_changes Method

frmServicekatalog.check_changes Method

Prüfung, ob Verbindungstabelle geändert wurde.
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub check_changes()
C#
private System.Void check_changes();
C++

private:
System::Void check_changes()
JScript
private function check_changes();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub check_changes()
        If Me.FormReadonly Then Exit Sub
        Dim msgres As MsgBoxResult
        If Me.ServiceKatalogSLAKatalog.Tabledata.HasChanges Then
            msgres = msg.Show_MessageYesNo(5)
            If msgres = MsgBoxResult.Yes Then
                Me.ServiceKatalogSLAKatalog.Save_Data()
            End If
        End If
        If Me.FormDataChanged Then
            msgres = msg.Show_MessageYesNo(3)
            If msgres = MsgBoxResult.Yes Then
                save_katalogdata()
            End If
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


frmServicekatalog.frmServicekatalog_FormClosing Method

frmServicekatalog.frmServicekatalog_FormClosing Method

Schliessen des Formulares
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub frmServicekatalog_FormClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing
C#
private System.Void frmServicekatalog_FormClosing(
   object sender,
   FormClosingEventArgs e
);
C++

private:
System::Void frmServicekatalog_FormClosing(
   object^ sender,
   FormClosingEventArgs^ e
)
JScript
private function frmServicekatalog_FormClosing(
    sender : object,
    e : FormClosingEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub frmServicekatalog_FormClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.FormReadonly = True Then Exit Sub
        check_changes()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


frmServicekatalog.frmServicekatalog_Load Method

frmServicekatalog.frmServicekatalog_Load Method

Formular aufbauen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub frmServicekatalog_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load
C#
private System.Void frmServicekatalog_Load(
   object sender,
   EventArgs e
);
C++

private:
System::Void frmServicekatalog_Load(
   object^ sender,
   EventArgs^ e
)
JScript
private function frmServicekatalog_Load(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub frmServicekatalog_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Treeviewdata.Load_Tree(Me.treeServiceKatalog)
        Treeviewdata.Set_Images(Me.treeServiceKatalog)
        SLATreeviewdata.Load_Tree(Me.TreeSLA)
        Load_Securitylevel()

        sec.Set_Form_Security(Me)
        If Me.TSBtnSave.Enabled = False Or Me.TSBtnSave.Visible = False Then
            Me.FormReadonly = True
            Me.ctxMenuTreeServiceKatalog.Enabled = False
        Else
            Me.FormReadonly = False
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


frmServicekatalog.save_katalogdata Method

frmServicekatalog.save_katalogdata Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub save_katalogdata()
C#
private System.Void save_katalogdata();
C++

private:
System::Void save_katalogdata()
JScript
private function save_katalogdata();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub save_katalogdata()
        Me.Servicekatalogdaten.sBezeichnung_intern = New SqlString(CType(Me.txtBezeichnung_intern.Text, String))
        Me.Servicekatalogdaten.sBezeichnung_extern = New SqlString(CType(Me.txtBezeichnung_extern.Text, String))
        Me.Servicekatalogdaten.sBemerkung = New SqlString(CType(Me.txtBemerkung.Text, String))
        Me.Servicekatalogdaten.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        Me.Servicekatalogdaten.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
        Me.Servicekatalogdaten.bAktiv = New SqlBoolean(CType(Me.cbaktiv.Checked, Boolean))
        Me.Servicekatalogdaten.bExtern = New SqlBoolean(CType(Me.cbextern.Checked, Boolean))
        Me.Servicekatalogdaten.iSecurityLevelNr = New SqlInt32(CType(Me.cboxSecurityLevel.SelectedValue, Int32))
        Me.Servicekatalogdaten.Save_Data()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


frmServicekatalog.treeServiceKatalog_AfterSelect Method

frmServicekatalog.treeServiceKatalog_AfterSelect Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub treeServiceKatalog_AfterSelect( _
   ByVal sender As Object, _
   ByVal e As TreeViewEventArgs _
) Handles  _
   treeServiceKatalog.AfterSelect
C#
private System.Void treeServiceKatalog_AfterSelect(
   object sender,
   TreeViewEventArgs e
);
C++

private:
System::Void treeServiceKatalog_AfterSelect(
   object^ sender,
   TreeViewEventArgs^ e
)
JScript
private function treeServiceKatalog_AfterSelect(
    sender : object,
    e : TreeViewEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub treeServiceKatalog_AfterSelect(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles treeServiceKatalog.AfterSelect
        Show_Data(Me.treeServiceKatalog.SelectedNode.Tag)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


frmServicekatalog.treeServiceKatalog_MouseDown Method

frmServicekatalog.treeServiceKatalog_MouseDown Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub treeServiceKatalog_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   treeServiceKatalog.MouseDown
C#
private System.Void treeServiceKatalog_MouseDown(
   object sender,
   MouseEventArgs e
);
C++

private:
System::Void treeServiceKatalog_MouseDown(
   object^ sender,
   MouseEventArgs^ e
)
JScript
private function treeServiceKatalog_MouseDown(
    sender : object,
    e : MouseEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub treeServiceKatalog_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles treeServiceKatalog.MouseDown
        Try
            check_changes()
            Dim selectPoint As New System.Drawing.Point()

            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            Me.treeServiceKatalog.SelectedNode = Me.treeServiceKatalog.GetNodeAt(selectPoint)
            If IsNothing(Me.treeServiceKatalog.SelectedNode) Then
                Me.NeueLeistungToolStripMenuItem.Enabled = False
            Else
                If Me.TSBtnSave.Enabled = True Then Me.NeueLeistungToolStripMenuItem.Enabled = True
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


frmServicekatalog.txtBezeichnung_intern_TextChanged Method

frmServicekatalog.txtBezeichnung_intern_TextChanged Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub txtBezeichnung_intern_TextChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   txtBezeichnung_intern.TextChanged, _
   txtBezeichnung_extern.TextChanged, _
   txtBemerkung.TextChanged, _
   cbaktiv.CheckedChanged, _
   cboxSecurityLevel.TextChanged, _
   cbextern.CheckedChanged, _
   cboxSecurityLevel.TextUpdate
C#
private System.Void txtBezeichnung_intern_TextChanged(
   object sender,
   EventArgs e
);
C++

private:
System::Void txtBezeichnung_intern_TextChanged(
   object^ sender,
   EventArgs^ e
)
JScript
private function txtBezeichnung_intern_TextChanged(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub txtBezeichnung_intern_TextChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles txtBezeichnung_intern.TextChanged, txtBezeichnung_extern.TextChanged, txtBemerkung.TextChanged, cbaktiv.CheckedChanged, cboxSecurityLevel.TextChanged, cbextern.CheckedChanged, cboxSecurityLevel.TextUpdate
        Me.FormDataChanged = True
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


frmServicekatalog Fields

frmServicekatalog Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | FormDataChanged |
Supported by the .NET Compact Framework. | FormReadonly |
Supported by the .NET Compact Framework. | SLATreeviewdata |
Supported by the .NET Compact Framework. | ServiceKatalogSLAKatalog |
Supported by the .NET Compact Framework. | Servicekatalogdaten |
Supported by the .NET Compact Framework. | SpaltenTitel |
Supported by the .NET Compact Framework. | Treeviewdata |
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | msg |
Supported by the .NET Compact Framework. | sec |
Top

Expand image See Also

Reference

frmServicekatalog Class
TKB.VV.SLA
TKB.VV.SLA.clsServiceKatalogDaten
TKB.VV.SLA.clsServiceKatalogSLATree
TKB.VV.SLA.clsServiceKatalogTree
TKB.VV.Sysadmin
TKB.VV.Sysadmin.DomainTable
TKB.VV.Utils
TKB.VV.Utils.MyMessage
TKB.VV.Utils.MySecurity
TKB.VV.Utils.Tabellenspalte


FormDataChanged Variable

FormDataChanged Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private FormDataChanged As Boolean
C#
private bool FormDataChanged;
C++
private:
bool FormDataChanged;
JScript
private FormDataChanged : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim FormDataChanged As Boolean = False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


FormReadonly Variable

FormReadonly Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private FormReadonly As Boolean
C#
private bool FormReadonly;
C++
private:
bool FormReadonly;
JScript
private FormReadonly : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim FormReadonly As Boolean = False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


SLATreeviewdata Variable

SLATreeviewdata Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private SLATreeviewdata As clsServiceKatalogSLATree
C#
private clsServiceKatalogSLATree SLATreeviewdata;
C++
private:
clsServiceKatalogSLATree^ SLATreeviewdata;
JScript
private SLATreeviewdata : clsServiceKatalogSLATree

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim SLATreeviewdata As New TKB.VV.SLA.clsServiceKatalogSLATree

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


ServiceKatalogSLAKatalog Variable

ServiceKatalogSLAKatalog Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private ServiceKatalogSLAKatalog As DomainTable
C#
private DomainTable ServiceKatalogSLAKatalog;
C++
private:
DomainTable^ ServiceKatalogSLAKatalog;
JScript
private ServiceKatalogSLAKatalog : DomainTable

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim ServiceKatalogSLAKatalog As TKB.VV.Sysadmin.DomainTable

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


Servicekatalogdaten Variable

Servicekatalogdaten Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Servicekatalogdaten As clsServiceKatalogDaten
C#
private clsServiceKatalogDaten Servicekatalogdaten;
C++
private:
clsServiceKatalogDaten^ Servicekatalogdaten;
JScript
private Servicekatalogdaten : clsServiceKatalogDaten

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Servicekatalogdaten As New TKB.VV.SLA.clsServiceKatalogDaten

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


SpaltenTitel Variable

SpaltenTitel Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private SpaltenTitel As Tabellenspalte
C#
private Tabellenspalte SpaltenTitel;
C++
private:
Tabellenspalte^ SpaltenTitel;
JScript
private SpaltenTitel : Tabellenspalte

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


Treeviewdata Variable

Treeviewdata Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Treeviewdata As clsServiceKatalogTree
C#
private clsServiceKatalogTree Treeviewdata;
C++
private:
clsServiceKatalogTree^ Treeviewdata;
JScript
private Treeviewdata : clsServiceKatalogTree

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Treeviewdata As New TKB.VV.SLA.clsServiceKatalogTree

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


components Variable

components Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private components As IContainer
C#
private IContainer components;
C++
private:
IContainer^ components;
JScript
private components : IContainer

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private components As System.ComponentModel.IContainer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


msg Variable

msg Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private msg As MyMessage
C#
private MyMessage msg;
C++
private:
MyMessage^ msg;
JScript
private msg : MyMessage

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim msg As New TKB.VV.Utils.MyMessage

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


sec Variable

sec Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private sec As MySecurity
C#
private MySecurity sec;
C++
private:
MySecurity^ sec;
JScript
private sec : MySecurity

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim sec As New TKB.VV.Utils.MySecurity

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmServicekatalog Class
frmServicekatalog Members


frmSpaltenDarstellung Class

frmSpaltenDarstellung Class
Members
collapseAll image DropDown image

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class frmSpaltenDarstellung
    Inherits Form
C#
public class frmSpaltenDarstellung : Form
C++

public ref class frmSpaltenDarstellung : public Form^
JScript
public class frmSpaltenDarstellung
   extends Form

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmSpaltenDarstellung

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSpaltenDarstellung Members


frmSpaltenDarstellung Members

frmSpaltenDarstellung Members
See Also Constructors Methods
CollapseAll image DropDown image

The following tables list the members exposed by the frmSpaltenDarstellung type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | frmSpaltenDarstellung Constructor |
Top

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | Button1_Click |
Supported by the .NET Compact Framework. | Button2_Click |
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | ListBox1_DoubleClick |
Supported by the .NET Compact Framework. | ListBox2_DoubleClick |
Supported by the .NET Compact Framework. | ToolBar1_ButtonClick |
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | components |
Top

Expand image See Also

Reference

frmSpaltenDarstellung Class


frmSpaltenDarstellung Constructor

frmSpaltenDarstellung Constructor

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void frmSpaltenDarstellung();
C++

public:
System::Void frmSpaltenDarstellung()
JScript
public function frmSpaltenDarstellung();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSpaltenDarstellung Class
frmSpaltenDarstellung Members


frmSpaltenDarstellung Methods

frmSpaltenDarstellung Methods
CollapseAll image DropDown image

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | Button1_Click |
Supported by the .NET Compact Framework. | Button2_Click |
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | ListBox1_DoubleClick |
Supported by the .NET Compact Framework. | ListBox2_DoubleClick |
Supported by the .NET Compact Framework. | ToolBar1_ButtonClick |
Top

Expand image See Also

Reference

frmSpaltenDarstellung Class


frmSpaltenDarstellung.Button1_Click Method

frmSpaltenDarstellung.Button1_Click Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Button1_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   Button1.Click
C#
private System.Void Button1_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void Button1_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function Button1_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        ListBox1_DoubleClick(sender, e)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSpaltenDarstellung Class
frmSpaltenDarstellung Members


frmSpaltenDarstellung.Button2_Click Method

frmSpaltenDarstellung.Button2_Click Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Button2_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   Button2.Click
C#
private System.Void Button2_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void Button2_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function Button2_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        ListBox2_DoubleClick(sender, e)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSpaltenDarstellung Class
frmSpaltenDarstellung Members


frmSpaltenDarstellung.Dispose Method

frmSpaltenDarstellung.Dispose Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
C#
protected override System.Void Dispose(
   bool disposing
);
C++

protected:
System::Void Dispose(
   bool disposing
)
JScript
protected function Dispose(
    disposing : boolean
);

Parameters

disposing

Expand image Source code

Visual Basic CopyCode image Copy Code
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSpaltenDarstellung Class
frmSpaltenDarstellung Members


frmSpaltenDarstellung.InitializeComponent Method

frmSpaltenDarstellung.InitializeComponent Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()
C#
[System.Diagnostics.DebuggerStepThrough()]
private System.Void InitializeComponent();
C++
[System.Diagnostics.DebuggerStepThrough()]

private:
System::Void InitializeComponent()
JScript
private
   System.Diagnostics.DebuggerStepThrough()
function InitializeComponent();

Expand image Source code

Visual Basic CopyCode image Copy Code
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmSpaltenDarstellung))
        Me.ListBox1 = New System.Windows.Forms.ListBox()
        Me.ListBox2 = New System.Windows.Forms.ListBox()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.SuspendLayout()
        '
        'ListBox1
        '
        Me.ListBox1.Location = New System.Drawing.Point(16, 56)
        Me.ListBox1.Name = "ListBox1"
        Me.ListBox1.SelectionMode = System.Windows.Forms.SelectionMode.MultiExtended
        Me.ListBox1.Size = New System.Drawing.Size(184, 329)
        Me.ListBox1.Sorted = True
        Me.ListBox1.TabIndex = 0
        '
        'ListBox2
        '
        Me.ListBox2.Location = New System.Drawing.Point(232, 56)
        Me.ListBox2.Name = "ListBox2"
        Me.ListBox2.SelectionMode = System.Windows.Forms.SelectionMode.MultiExtended
        Me.ListBox2.Size = New System.Drawing.Size(184, 329)
        Me.ListBox2.Sorted = True
        Me.ListBox2.TabIndex = 1
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(432, 25)
        Me.ToolBar1.TabIndex = 2
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(16, 40)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(144, 16)
        Me.Label1.TabIndex = 3
        Me.Label1.Text = "Vorhandene Spalten"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(232, 40)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(144, 16)
        Me.Label2.TabIndex = 4
        Me.Label2.Text = "Anzuzeigende Spalten"
        '
        'Button1
        '
        Me.Button1.Image = CType(resources.GetObject("Button1.Image"), System.Drawing.Bitmap)
        Me.Button1.ImageIndex = 4
        Me.Button1.ImageList = Me.ImageList1
        Me.Button1.Location = New System.Drawing.Point(200, 176)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(32, 32)
        Me.Button1.TabIndex = 5
        '
        'Button2
        '
        Me.Button2.Image = CType(resources.GetObject("Button2.Image"), System.Drawing.Bitmap)
        Me.Button2.ImageIndex = 3
        Me.Button2.ImageList = Me.ImageList1
        Me.Button2.Location = New System.Drawing.Point(200, 216)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(32, 32)
        Me.Button2.TabIndex = 6
        '
        'frmSpaltenDarstellung
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(432, 397)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button2, Me.Button1, Me.Label2, Me.Label1, Me.ToolBar1, Me.ListBox2, Me.ListBox1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmSpaltenDarstellung"
        Me.Text = "Spalten-Selektion"
        Me.ResumeLayout(False)

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSpaltenDarstellung Class
frmSpaltenDarstellung Members


frmSpaltenDarstellung.ListBox1_DoubleClick Method

frmSpaltenDarstellung.ListBox1_DoubleClick Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub ListBox1_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ListBox1.DoubleClick
C#
private System.Void ListBox1_DoubleClick(
   object sender,
   EventArgs e
);
C++

private:
System::Void ListBox1_DoubleClick(
   object^ sender,
   EventArgs^ e
)
JScript
private function ListBox1_DoubleClick(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub ListBox1_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles ListBox1.DoubleClick
        Dim i As Integer
        For i = 0 To Me.ListBox1.SelectedItems.Count - 1
            Me.ListBox2.Items.Add(Me.ListBox1.SelectedItems(i))
        Next
        For i = 0 To Me.ListBox1.SelectedItems.Count - 1
            Me.ListBox1.Items.Remove(Me.ListBox1.SelectedItems(0))
        Next
        'Me.ListBox2.Items.Add(Me.ListBox1.SelectedI
        'Me.ListBox1.Items.Remove(Me.ListBox1.SelectedItem)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSpaltenDarstellung Class
frmSpaltenDarstellung Members


frmSpaltenDarstellung.ListBox2_DoubleClick Method

frmSpaltenDarstellung.ListBox2_DoubleClick Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub ListBox2_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ListBox2.DoubleClick
C#
private System.Void ListBox2_DoubleClick(
   object sender,
   EventArgs e
);
C++

private:
System::Void ListBox2_DoubleClick(
   object^ sender,
   EventArgs^ e
)
JScript
private function ListBox2_DoubleClick(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub ListBox2_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles ListBox2.DoubleClick
        Dim i As Integer
        For i = 0 To Me.ListBox2.SelectedItems.Count - 1
            Me.ListBox1.Items.Add(Me.ListBox2.SelectedItems(i))
        Next
        For i = 0 To Me.ListBox2.SelectedItems.Count - 1
            Me.ListBox2.Items.Remove(Me.ListBox2.SelectedItems(0))
        Next
        'Me.ListBox1.Items.Add(Me.ListBox2.SelectedItem)
        'Me.ListBox2.Items.Remove(Me.ListBox2.SelectedItem)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSpaltenDarstellung Class
frmSpaltenDarstellung Members


frmSpaltenDarstellung.ToolBar1_ButtonClick Method

frmSpaltenDarstellung.ToolBar1_ButtonClick Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub ToolBar1_ButtonClick( _
   ByVal sender As Object, _
   ByVal e As ToolBarButtonClickEventArgs _
) Handles  _
   ToolBar1.ButtonClick
C#
private System.Void ToolBar1_ButtonClick(
   object sender,
   ToolBarButtonClickEventArgs e
);
C++

private:
System::Void ToolBar1_ButtonClick(
   object^ sender,
   ToolBarButtonClickEventArgs^ e
)
JScript
private function ToolBar1_ButtonClick(
    sender : object,
    e : ToolBarButtonClickEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Dim i As Integer
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case Else
        End Select

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSpaltenDarstellung Class
frmSpaltenDarstellung Members


frmSpaltenDarstellung Fields

frmSpaltenDarstellung Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | components |
Top

Expand image See Also

Reference

frmSpaltenDarstellung Class


components Variable

components Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private components As IContainer
C#
private IContainer components;
C++
private:
IContainer^ components;
JScript
private components : IContainer

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private components As System.ComponentModel.IContainer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSpaltenDarstellung Class
frmSpaltenDarstellung Members


frmSysadminMenu Class

frmSysadminMenu Class
Members
collapseAll image DropDown image

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmSysadminMenu
    Inherits Form
C#
[Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()]
public class frmSysadminMenu : Form
C++
[Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()]

public ref class frmSysadminMenu : public Form^
JScript
public
   Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()
class frmSysadminMenu
   extends Form

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmSysadminMenu

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminMenu Members


frmSysadminMenu Members

frmSysadminMenu Members
See Also Methods
CollapseAll image DropDown image

The following tables list the members exposed by the frmSysadminMenu type.

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | BeendenToolStripMenuItem_Click | Schliessen des Formulares
Supported by the .NET Compact Framework. | FrmSysadminMenu_Load | Load des Formulars
Supported by the .NET Compact Framework. | FrmSysadminMenu_Resize |
Supported by the .NET Compact Framework. | Generate_Data | Ruft die SP zur Spalten-Generierung auf
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | ListNodeCollectionRecursive | Knoten rekursiv auslesen
Supported by the .NET Compact Framework. | ListNodeSave | einzelner Knoten sichern
Supported by the .NET Compact Framework. | MenuKnotenRename_Click | Umbenennen des aktuellen Menu-Eintrages
Supported by the .NET Compact Framework. | MnuKnotenLoeschen_Click | Eintrag im Menu löschen
Supported by the .NET Compact Framework. | MnuNeuerKnoten_Click | Neuer Eintrag im Menu einfügen
Supported by the .NET Compact Framework. | MnuSave_Click | Menu Sichern
Supported by the .NET Compact Framework. | SpaltentitelGenerierenToolStripMenuItem_Click | Generiert die Spaltentitel in der Tabelle Spalten aufgrund der im Formular frmSysadminTableSelector gewählten Tabelle
Supported by the .NET Compact Framework. | SysMenuTree_DoubleClick | Doppelklick auf einen Eintrag: Es wird geprüft, ob in der Tabelle SysadminFunktion im Attribut DomainTable einen Wert vorhanden ist. Sofern dies der Fall ist, wird der generelle Domain-Table-Editor aufgerufen
Supported by the .NET Compact Framework. | SysMenuTree_DragDrop |
Supported by the .NET Compact Framework. | SysMenuTree_ItemDrag |
Supported by the .NET Compact Framework. | SysMenutree_DragEnter |
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Fenster schliessen
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | itodelete |
Supported by the .NET Compact Framework. | msg |
Supported by the .NET Compact Framework. | ssort |
Supported by the .NET Compact Framework. | todelete |
Top

Expand image See Also

Reference

frmSysadminMenu Class


frmSysadminMenu Methods

frmSysadminMenu Methods
CollapseAll image DropDown image

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | BeendenToolStripMenuItem_Click | Schliessen des Formulares
Supported by the .NET Compact Framework. | FrmSysadminMenu_Load | Load des Formulars
Supported by the .NET Compact Framework. | FrmSysadminMenu_Resize |
Supported by the .NET Compact Framework. | Generate_Data | Ruft die SP zur Spalten-Generierung auf
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | ListNodeCollectionRecursive | Knoten rekursiv auslesen
Supported by the .NET Compact Framework. | ListNodeSave | einzelner Knoten sichern
Supported by the .NET Compact Framework. | MenuKnotenRename_Click | Umbenennen des aktuellen Menu-Eintrages
Supported by the .NET Compact Framework. | MnuKnotenLoeschen_Click | Eintrag im Menu löschen
Supported by the .NET Compact Framework. | MnuNeuerKnoten_Click | Neuer Eintrag im Menu einfügen
Supported by the .NET Compact Framework. | MnuSave_Click | Menu Sichern
Supported by the .NET Compact Framework. | SpaltentitelGenerierenToolStripMenuItem_Click | Generiert die Spaltentitel in der Tabelle Spalten aufgrund der im Formular frmSysadminTableSelector gewählten Tabelle
Supported by the .NET Compact Framework. | SysMenuTree_DoubleClick | Doppelklick auf einen Eintrag: Es wird geprüft, ob in der Tabelle SysadminFunktion im Attribut DomainTable einen Wert vorhanden ist. Sofern dies der Fall ist, wird der generelle Domain-Table-Editor aufgerufen
Supported by the .NET Compact Framework. | SysMenuTree_DragDrop |
Supported by the .NET Compact Framework. | SysMenuTree_ItemDrag |
Supported by the .NET Compact Framework. | SysMenutree_DragEnter |
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Fenster schliessen
Top

Expand image See Also

Reference

frmSysadminMenu Class


frmSysadminMenu.BeendenToolStripMenuItem_Click Method

frmSysadminMenu.BeendenToolStripMenuItem_Click Method

Schliessen des Formulares
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click
C#
private System.Void BeendenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void BeendenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function BeendenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminMenu Class
frmSysadminMenu Members


frmSysadminMenu.Dispose Method

frmSysadminMenu.Dispose Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
C#
[System.Diagnostics.DebuggerNonUserCode()]
protected override System.Void Dispose(
   bool disposing
);
C++
[System.Diagnostics.DebuggerNonUserCode()]

protected:
System::Void Dispose(
   bool disposing
)
JScript
protected
   System.Diagnostics.DebuggerNonUserCode()
function Dispose(
    disposing : boolean
);

Parameters

disposing

Expand image Source code

Visual Basic CopyCode image Copy Code
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminMenu Class
frmSysadminMenu Members


frmSysadminMenu.FrmSysadminMenu_Load Method

frmSysadminMenu.FrmSysadminMenu_Load Method

Load des Formulars
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub FrmSysadminMenu_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load
C#
private System.Void FrmSysadminMenu_Load(
   object sender,
   EventArgs e
);
C++

private:
System::Void FrmSysadminMenu_Load(
   object^ sender,
   EventArgs^ e
)
JScript
private function FrmSysadminMenu_Load(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub FrmSysadminMenu_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim menu As New TKB.VV.Sysadmin.clsMySysadminfunkion()
        menu.LoadTreeMenu(SysMenuTree)
        SysMenuTree.ExpandAll()
        itodelete = 0
        Me.SysMenuTree.ContextMenu = Me.ContextMenu1
        Me.Height = Me.Parent.ClientSize.Height
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminMenu Class
frmSysadminMenu Members


frmSysadminMenu.FrmSysadminMenu_Resize Method

frmSysadminMenu.FrmSysadminMenu_Resize Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub FrmSysadminMenu_Resize( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   Me.Resize
C#
private System.Void FrmSysadminMenu_Resize(
   object sender,
   EventArgs e
);
C++

private:
System::Void FrmSysadminMenu_Resize(
   object^ sender,
   EventArgs^ e
)
JScript
private function FrmSysadminMenu_Resize(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub FrmSysadminMenu_Resize(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Resize
        If Me.Width > 300 Then Me.Width = 300
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminMenu Class
frmSysadminMenu Members


frmSysadminMenu.Generate_Data Method

frmSysadminMenu.Generate_Data Method

Ruft die SP zur Spalten-Generierung auf
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Generate_Data( _
   ByVal tablename As String _
)
C#
private System.Void Generate_Data(
   string tablename
);
C++

private:
System::Void Generate_Data(
   String^ tablename
)
JScript
private function Generate_Data(
    tablename : String
);

Parameters

tablename

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Generate_Data(ByVal tablename As String)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dttable As New DataTable(tablename)
        scmCmdToExecute.CommandText = "dbo.[sp_update_spalten]"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@Tablename", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, tablename))
            scmCmdToExecute.Connection.Open()
            scmCmdToExecute.ExecuteNonQuery()
            Return
        Catch ex As Exception
            Throw New Exception(msg.Get_Meldungstext(103), ex)
        Finally
            scmCmdToExecute.Connection.Close()
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminMenu Class
frmSysadminMenu Members


frmSysadminMenu.InitializeComponent Method

frmSysadminMenu.InitializeComponent Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()
C#
[System.Diagnostics.DebuggerStepThrough()]
private System.Void InitializeComponent();
C++
[System.Diagnostics.DebuggerStepThrough()]

private:
System::Void InitializeComponent()
JScript
private
   System.Diagnostics.DebuggerStepThrough()
function InitializeComponent();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmSysadminMenu))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.SpaltentitelGenerierenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.SysMenuTree = New System.Windows.Forms.TreeView
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu
        Me.MnuNeuerKnoten = New System.Windows.Forms.MenuItem
        Me.MnuKnotenLoeschen = New System.Windows.Forms.MenuItem
        Me.MenuKnotenRename = New System.Windows.Forms.MenuItem
        Me.MenuItem4 = New System.Windows.Forms.MenuItem
        Me.MnuSave = New System.Windows.Forms.MenuItem
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem, Me.SpaltentitelGenerierenToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(299, 24)
        Me.MenuStrip1.TabIndex = 0
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(127, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'SpaltentitelGenerierenToolStripMenuItem
        '
        Me.SpaltentitelGenerierenToolStripMenuItem.Name = "SpaltentitelGenerierenToolStripMenuItem"
        Me.SpaltentitelGenerierenToolStripMenuItem.Size = New System.Drawing.Size(128, 20)
        Me.SpaltentitelGenerierenToolStripMenuItem.Text = "&Spaltentitel generieren"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(299, 25)
        Me.ToolStrip1.TabIndex = 1
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'SysMenuTree
        '
        Me.SysMenuTree.AllowDrop = True
        Me.SysMenuTree.Dock = System.Windows.Forms.DockStyle.Fill
        Me.SysMenuTree.ImageIndex = 0
        Me.SysMenuTree.ImageList = Me.ImageList1
        Me.SysMenuTree.Indent = 19
        Me.SysMenuTree.ItemHeight = 16
        Me.SysMenuTree.Location = New System.Drawing.Point(0, 49)
        Me.SysMenuTree.Name = "SysMenuTree"
        Me.SysMenuTree.SelectedImageIndex = 0
        Me.SysMenuTree.Size = New System.Drawing.Size(299, 521)
        Me.SysMenuTree.TabIndex = 2
        '
        'ImageList1
        '
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        Me.ImageList1.Images.SetKeyName(0, "")
        Me.ImageList1.Images.SetKeyName(1, "")
        Me.ImageList1.Images.SetKeyName(2, "")
        Me.ImageList1.Images.SetKeyName(3, "")
        Me.ImageList1.Images.SetKeyName(4, "")
        Me.ImageList1.Images.SetKeyName(5, "Kette3.ico")
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuNeuerKnoten, Me.MnuKnotenLoeschen, Me.MenuKnotenRename, Me.MenuItem4, Me.MnuSave})
        '
        'MnuNeuerKnoten
        '
        Me.MnuNeuerKnoten.Index = 0
        Me.MnuNeuerKnoten.Text = "Neuer Eintrag "
        '
        'MnuKnotenLoeschen
        '
        Me.MnuKnotenLoeschen.Index = 1
        Me.MnuKnotenLoeschen.Text = "Eintrag löschen"
        '
        'MenuKnotenRename
        '
        Me.MenuKnotenRename.Index = 2
        Me.MenuKnotenRename.Text = "Eintrag umbenennen"
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 3
        Me.MenuItem4.Text = "-"
        '
        'MnuSave
        '
        Me.MnuSave.Index = 4
        Me.MnuSave.Text = "Menu Speichern"
        '
        'FrmSysadminMenu
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(299, 570)
        Me.Controls.Add(Me.SysMenuTree)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.MainMenuStrip = Me.MenuStrip1
        Me.MaximizeBox = False
        Me.MinimizeBox = False
        Me.Name = "FrmSysadminMenu"
        Me.Text = "FrmSysadminMenu"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminMenu Class
frmSysadminMenu Members


frmSysadminMenu.ListNodeCollectionRecursive Method

frmSysadminMenu.ListNodeCollectionRecursive Method

Knoten rekursiv auslesen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub ListNodeCollectionRecursive( _
   ByVal tnParent As TreeNode, _
   ByRef iSort As Integer _
)
C#
private System.Void ListNodeCollectionRecursive(
   TreeNode tnParent,
   ref int iSort
);
C++

private:
System::Void ListNodeCollectionRecursive(
   TreeNode^ tnParent,
   int& iSort
)
JScript
private function ListNodeCollectionRecursive(
    tnParent : TreeNode,
    iSort : int
);

Parameters

tnParent

iSort

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub ListNodeCollectionRecursive(ByVal tnParent As TreeNode, ByRef iSort As Integer)
        Dim tn As TreeNode
        If tnParent.GetNodeCount(False) > 0 Then
            tn = tnParent.Nodes(0)
        Else
            tn = Nothing
        End If
        ssort = 0
        Do Until tn Is Nothing
            iSort = iSort + 1
            ListNodeSave(tn, iSort)
            If tn.GetNodeCount(False) > 0 Then
                Call ListNodeCollectionRecursive(tn, iSort)
            End If
            tn = tn.NextNode
        Loop
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminMenu Class
frmSysadminMenu Members


frmSysadminMenu.ListNodeSave Method

frmSysadminMenu.ListNodeSave Method

einzelner Knoten sichern
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub ListNodeSave( _
   ByVal tn As TreeNode, _
   ByRef isort As Integer _
)
C#
private System.Void ListNodeSave(
   TreeNode tn,
   ref int isort
);
C++

private:
System::Void ListNodeSave(
   TreeNode^ tn,
   int& isort
)
JScript
private function ListNodeSave(
    tn : TreeNode,
    isort : int
);

Parameters

tn

isort

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub ListNodeSave(ByVal tn As TreeNode, ByRef isort As Integer)
        Dim dbkey As New TKB.VV.DB.clsMyKey_Tabelle()
        Dim t As DataTable
        Dim key As Long
        Dim i As Integer
        Dim ftop, fleft, fheight, fwidth As Integer
        Dim sDomaintable As String = ""
        Dim sKeyfields As String = ""
        Dim sysadmfnkt As New TKB.VV.DB.clsSysadminfunktion
        dbkey.cpMainConnectionProvider = conn
        sysadmfnkt.cpMainConnectionProvider = conn
        If tn.Tag <> 0 Then
            sysadmfnkt.iSysadminfnktnr = New SqlInt32(CType(tn.Tag, Int32))
            sysadmfnkt.SelectOne()
            ftop = sysadmfnkt.iFtop.Value
            fleft = sysadmfnkt.iFleft.Value
            fwidth = sysadmfnkt.iFwidth.Value
            fheight = sysadmfnkt.iFheight.Value
            sDomaintable = sysadmfnkt.sDomaintable.Value
            sKeyfields = sysadmfnkt.sKeyFields.Value
        End If
        sysadmfnkt.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        sysadmfnkt.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
        sysadmfnkt.sBezeichnung = New SqlString(CType(tn.Text, String))
        sysadmfnkt.sBeschreibung = New SqlString(CType("", String))
        sysadmfnkt.iParentID = New SqlInt32(CType(tn.Parent.Tag, Int32))
        sysadmfnkt.iImageIndex = New SqlInt32(CType(tn.ImageIndex, Int32))
        sysadmfnkt.iImageIndexOpen = New SqlInt32(CType(tn.SelectedImageIndex, Int32))
        sysadmfnkt.iSort = New SqlInt32(CType(isort, Int32))
        sysadmfnkt.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
        sysadmfnkt.bAktiv = New SqlBoolean(CType(True, Boolean))
        sysadmfnkt.iSprache = New SqlInt32(CType(Globals.clsmitarbeiter.iSprache.Value, Int32))
        sysadmfnkt.iMandantnr = New SqlInt32(CType(Globals.clsmitarbeiter.iMandantnr.Value, Int32))
        sysadmfnkt.iFtop = New SqlInt32(CType(ftop, Int32))
        sysadmfnkt.iFleft = New SqlInt32(CType(fleft, Int32))
        sysadmfnkt.iFwidth = New SqlInt32(CType(fwidth, Int32))
        sysadmfnkt.iFheight = New SqlInt32(CType(fheight, Int32))
        sysadmfnkt.sDomaintable = New SqlString(CType(sDomaintable, String))
        sysadmfnkt.sKeyFields = New SqlString(CType(sKeyfields, String))

        If tn.Tag <> 0 Then
            sysadmfnkt.iSysadminfnktnr = New SqlInt32(CType(tn.Tag, Int32))
            sysadmfnkt.Update()
        Else
            key = dbkey.get_dbkey("sysadminfunktion")
            conn.OpenConnection()
            sysadmfnkt.iSysadminfnktnr = New SqlInt32(CType(key, Int32))
            sysadmfnkt.Insert()
            tn.Tag = key
        End If

        For i = 1 To itodelete
            sysadmfnkt.iSysadminfnktnr = New SqlInt32(CType(todelete(i), Int32))
            t = sysadmfnkt.SelectOne
            If t.Rows.Count > 0 Then
                sysadmfnkt.Delete()
            End If
        Next
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminMenu Class
frmSysadminMenu Members


frmSysadminMenu.MenuKnotenRename_Click Method

frmSysadminMenu.MenuKnotenRename_Click Method

Umbenennen des aktuellen Menu-Eintrages
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub MenuKnotenRename_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MenuKnotenRename.Click
C#
private System.Void MenuKnotenRename_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void MenuKnotenRename_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function MenuKnotenRename_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub MenuKnotenRename_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuKnotenRename.Click
        Dim a As String
        a = InputBox("Neuer Name:")
        If a = "" Then Exit Sub
        Me.SysMenuTree.SelectedNode.Text = a
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminMenu Class
frmSysadminMenu Members


frmSysadminMenu.MnuKnotenLoeschen_Click Method

frmSysadminMenu.MnuKnotenLoeschen_Click Method

Eintrag im Menu löschen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub MnuKnotenLoeschen_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MnuKnotenLoeschen.Click
C#
private System.Void MnuKnotenLoeschen_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void MnuKnotenLoeschen_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function MnuKnotenLoeschen_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub MnuKnotenLoeschen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuKnotenLoeschen.Click
        Dim tn As New TreeNode()
        Dim tnp As New TreeNode()
        Dim i As Integer
        tn = Me.SysMenuTree.SelectedNode
        tnp = tn.Parent
        If Not (Me.SysMenuTree.SelectedNode Is Nothing) Then
            itodelete = itodelete + 1
            todelete(itodelete) = tn.Tag
            If msg.Show_MessageYesNo(101) = MsgBoxResult.Yes Then
                tn.Remove()
            End If
            If tnp.GetNodeCount(True) = 0 Then
                tnp.ImageIndex = 3
                tnp.SelectedImageIndex = 3
            End If
            Me.SysMenuTree.Refresh()
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminMenu Class
frmSysadminMenu Members


frmSysadminMenu.MnuNeuerKnoten_Click Method

frmSysadminMenu.MnuNeuerKnoten_Click Method

Neuer Eintrag im Menu einfügen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub MnuNeuerKnoten_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MnuNeuerKnoten.Click
C#
private System.Void MnuNeuerKnoten_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void MnuNeuerKnoten_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function MnuNeuerKnoten_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub MnuNeuerKnoten_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuNeuerKnoten.Click
        Dim a As String
        Dim tn As New TreeNode()
        Dim tnnew As New TreeNode()
        a = InputBox(msg.Get_Meldungstext(100))
        If a = "" Then Exit Sub
        tn = Me.SysMenuTree.SelectedNode
        tnnew = tn.Nodes.Add(a)
        With tnnew
            .Tag() = 0
            .ImageIndex() = 3
            .SelectedImageIndex() = 3
        End With
        tn.ImageIndex = 1
        tn.SelectedImageIndex = 2
        If tn.GetNodeCount(True) > 0 Then
            tn.ImageIndex = 1
            tn.SelectedImageIndex = 2
        End If
        Me.SysMenuTree.Refresh()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminMenu Class
frmSysadminMenu Members


frmSysadminMenu.MnuSave_Click Method

frmSysadminMenu.MnuSave_Click Method

Menu Sichern
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub MnuSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MnuSave.Click
C#
private System.Void MnuSave_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void MnuSave_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function MnuSave_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub MnuSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuSave.Click
        Dim i As Integer
        conn.OpenConnection()
        ListNodeCollectionRecursive(Me.SysMenuTree.Nodes(0), 0)
        i = conn.CloseConnection(True)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminMenu Class
frmSysadminMenu Members


frmSysadminMenu.SpaltentitelGenerierenToolStripMenuItem_Click Method

frmSysadminMenu.SpaltentitelGenerierenToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

Generiert die Spaltentitel in der Tabelle Spalten aufgrund der im Formular frmSysadminTableSelector gewählten Tabelle
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub SpaltentitelGenerierenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   SpaltentitelGenerierenToolStripMenuItem.Click
C#
private System.Void SpaltentitelGenerierenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void SpaltentitelGenerierenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function SpaltentitelGenerierenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub SpaltentitelGenerierenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles SpaltentitelGenerierenToolStripMenuItem.Click
        Dim f As New frmSysadminTableSelector()
        Dim tablename As String
        tablename = (f.get_tablename())
        If tablename = "" Then Exit Sub
        Generate_Data(tablename)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminMenu Class
frmSysadminMenu Members


frmSysadminMenu.SysMenuTree_DoubleClick Method

frmSysadminMenu.SysMenuTree_DoubleClick Method

Doppelklick auf einen Eintrag: Es wird geprüft, ob in der Tabelle SysadminFunktion im Attribut DomainTable einen Wert vorhanden ist. Sofern dies der Fall ist, wird der generelle Domain-Table-Editor aufgerufen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub SysMenuTree_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   SysMenuTree.DoubleClick
C#
private System.Void SysMenuTree_DoubleClick(
   object sender,
   EventArgs e
);
C++

private:
System::Void SysMenuTree_DoubleClick(
   object^ sender,
   EventArgs^ e
)
JScript
private function SysMenuTree_DoubleClick(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub SysMenuTree_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles SysMenuTree.DoubleClick
        Dim sysadmfnkt As New TKB.VV.DB.clsSysadminfunktion
        Dim wert As String
        wert = Me.SysMenuTree.SelectedNode.Tag
        If IsNumeric(wert) Then
            sysadmfnkt.iSysadminfnktnr = New SqlInt32(CType(wert, Int32))
            sysadmfnkt.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            sysadmfnkt.SelectOne()
            Globals.conn.CloseConnection(True)
            If sysadmfnkt.sDomaintable.Value.IndexOf(";") > -1 Then
                'Verbindungseditor
                Dim s As String = sysadmfnkt.sDomaintable.Value
                Dim sArray() As String = s.Split(";")
                Dim f As New FrmVerbindungEditor(sArray(0), sArray(1), sArray(2), sysadmfnkt.iSysadminfnktnr.Value)
                f.Width = sysadmfnkt.iFwidth.Value
                f.Height = sysadmfnkt.iFheight.Value
                f.Top = sysadmfnkt.iFtop.Value
                f.Left = sysadmfnkt.iFleft.Value
                f.MdiParent = Me.MdiParent
                f.Show()
            Else
                'Einzelne Domaintable
                If sysadmfnkt.sDomaintable.Value <> "" Then
                    Dim f As New frmDomainEditor(sysadmfnkt.sDomaintable.Value)
                    f.MdiParent = Me.MdiParent
                    f.Width = sysadmfnkt.iFwidth.Value
                    f.Height = sysadmfnkt.iFheight.Value
                    f.Top = sysadmfnkt.iFtop.Value
                    f.Left = sysadmfnkt.iFleft.Value
                    f.Show()
                End If
            End If
            sysadmfnkt.Dispose()
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminMenu Class
frmSysadminMenu Members


frmSysadminMenu.SysMenuTree_DragDrop Method

frmSysadminMenu.SysMenuTree_DragDrop Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub SysMenuTree_DragDrop( _
   ByVal sender As Object, _
   ByVal e As DragEventArgs _
) Handles  _
   SysMenuTree.DragDrop
C#
private System.Void SysMenuTree_DragDrop(
   object sender,
   DragEventArgs e
);
C++

private:
System::Void SysMenuTree_DragDrop(
   object^ sender,
   DragEventArgs^ e
)
JScript
private function SysMenuTree_DragDrop(
    sender : object,
    e : DragEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub SysMenuTree_DragDrop(ByVal sender As System.Object, ByVal e As System.Windows.Forms.DragEventArgs) Handles SysMenuTree.DragDrop
        Dim OriginationNode As TreeNode = CType(e.Data.GetData("System.Windows.Forms.TreeNode"), TreeNode)

        If e.Data.GetDataPresent("System.Windows.Forms.TreeNode", False) Then
            Dim pt As Point
            Dim DestinationNode As TreeNode
            pt = CType(sender, TreeView).PointToClient(New Point(e.X, e.Y))
            DestinationNode = CType(sender, TreeView).GetNodeAt(pt)
            DestinationNode.Nodes.Add(CType(OriginationNode.Clone, TreeNode))
            DestinationNode.Expand()
            If (e.KeyState And CtrlMask) <> CtrlMask Then
                OriginationNode.Remove()
            End If
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminMenu Class
frmSysadminMenu Members


frmSysadminMenu.SysMenuTree_ItemDrag Method

frmSysadminMenu.SysMenuTree_ItemDrag Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub SysMenuTree_ItemDrag( _
   ByVal sender As Object, _
   ByVal e As ItemDragEventArgs _
) Handles  _
   SysMenuTree.ItemDrag
C#
private System.Void SysMenuTree_ItemDrag(
   object sender,
   ItemDragEventArgs e
);
C++

private:
System::Void SysMenuTree_ItemDrag(
   object^ sender,
   ItemDragEventArgs^ e
)
JScript
private function SysMenuTree_ItemDrag(
    sender : object,
    e : ItemDragEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub SysMenuTree_ItemDrag(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ItemDragEventArgs) Handles SysMenuTree.ItemDrag
        If e.Button = MouseButtons.Left Then
            DoDragDrop(e.Item, DragDropEffects.Move Or DragDropEffects.Copy)
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminMenu Class
frmSysadminMenu Members


frmSysadminMenu.SysMenutree_DragEnter Method

frmSysadminMenu.SysMenutree_DragEnter Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub SysMenutree_DragEnter( _
   ByVal sender As Object, _
   ByVal e As DragEventArgs _
) Handles  _
   SysMenuTree.DragEnter
C#
private System.Void SysMenutree_DragEnter(
   object sender,
   DragEventArgs e
);
C++

private:
System::Void SysMenutree_DragEnter(
   object^ sender,
   DragEventArgs^ e
)
JScript
private function SysMenutree_DragEnter(
    sender : object,
    e : DragEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub SysMenutree_DragEnter(ByVal sender As System.Object, ByVal e As System.Windows.Forms.DragEventArgs) Handles SysMenuTree.DragEnter
        If (e.Data.GetDataPresent("System.Windows.Forms.TreeNode")) Then
            If (e.KeyState And CtrlMask) = CtrlMask Then
                e.Effect = DragDropEffects.Copy
            Else
                e.Effect = DragDropEffects.Move
            End If
        Else
            e.Effect = DragDropEffects.None
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminMenu Class
frmSysadminMenu Members


frmSysadminMenu.TSBtnQuit_Click Method

frmSysadminMenu.TSBtnQuit_Click Method

Fenster schliessen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click
C#
private System.Void TSBtnQuit_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnQuit_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnQuit_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminMenu Class
frmSysadminMenu Members


frmSysadminMenu Fields

frmSysadminMenu Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | itodelete |
Supported by the .NET Compact Framework. | msg |
Supported by the .NET Compact Framework. | ssort |
Supported by the .NET Compact Framework. | todelete |
Top

Expand image See Also

Reference

frmSysadminMenu Class


components Variable

components Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private components As IContainer
C#
private IContainer components;
C++
private:
IContainer^ components;
JScript
private components : IContainer

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private components As System.ComponentModel.IContainer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminMenu Class
frmSysadminMenu Members


itodelete Variable

itodelete Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private itodelete As Integer
C#
private int itodelete;
C++
private:
int itodelete;
JScript
private itodelete : int

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim itodelete As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminMenu Class
frmSysadminMenu Members


msg Variable

msg Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private msg As MyMessage
C#
private MyMessage msg;
C++
private:
MyMessage^ msg;
JScript
private msg : MyMessage

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim msg As New TKB.VV.Utils.MyMessage

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminMenu Class
frmSysadminMenu Members


ssort Variable

ssort Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private ssort As Integer
C#
private int ssort;
C++
private:
int ssort;
JScript
private ssort : int

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim ssort As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminMenu Class
frmSysadminMenu Members


todelete Variable

todelete Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private todelete As Integer()
C#
private int[] todelete;
C++
private:
array< int >^ todelete;
JScript
private todelete : int[]

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim todelete(50) As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminMenu Class
frmSysadminMenu Members


frmSysadminTableSelector Class

frmSysadminTableSelector Class
Members
collapseAll image DropDown image

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class frmSysadminTableSelector
    Inherits Form
C#
public class frmSysadminTableSelector : Form
C++

public ref class frmSysadminTableSelector : public Form^
JScript
public class frmSysadminTableSelector
   extends Form

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmSysadminTableSelector

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminTableSelector Members


frmSysadminTableSelector Members

frmSysadminTableSelector Members
See Also Constructors Methods
CollapseAll image DropDown image

The following tables list the members exposed by the frmSysadminTableSelector type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | frmSysadminTableSelector Constructor |
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | get_tablename |
Top

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | frmSysadminTableSelector_Load |
Supported by the .NET Compact Framework. | listbox1_dblclick |
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | components |
Top

Expand image See Also

Reference

frmSysadminTableSelector Class


frmSysadminTableSelector Constructor

frmSysadminTableSelector Constructor

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void frmSysadminTableSelector();
C++

public:
System::Void frmSysadminTableSelector()
JScript
public function frmSysadminTableSelector();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminTableSelector Class
frmSysadminTableSelector Members


frmSysadminTableSelector Methods

frmSysadminTableSelector Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | get_tablename |
Top

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | frmSysadminTableSelector_Load |
Supported by the .NET Compact Framework. | listbox1_dblclick |
Top

Expand image See Also

Reference

frmSysadminTableSelector Class


frmSysadminTableSelector.Dispose Method

frmSysadminTableSelector.Dispose Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
C#
protected override System.Void Dispose(
   bool disposing
);
C++

protected:
System::Void Dispose(
   bool disposing
)
JScript
protected function Dispose(
    disposing : boolean
);

Parameters

disposing

Expand image Source code

Visual Basic CopyCode image Copy Code
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminTableSelector Class
frmSysadminTableSelector Members


frmSysadminTableSelector.InitializeComponent Method

frmSysadminTableSelector.InitializeComponent Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()
C#
[System.Diagnostics.DebuggerStepThrough()]
private System.Void InitializeComponent();
C++
[System.Diagnostics.DebuggerStepThrough()]

private:
System::Void InitializeComponent()
JScript
private
   System.Diagnostics.DebuggerStepThrough()
function InitializeComponent();

Expand image Source code

Visual Basic CopyCode image Copy Code
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmSysadminTableSelector))
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand
        Me.DataSet1 = New System.Data.DataSet
        Me.ListBox1 = New System.Windows.Forms.ListBox
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "sysobjects", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("name", "name"), New System.Data.Common.DataColumnMapping("id", "id"), New System.Data.Common.DataColumnMapping("xtype", "xtype"), New System.Data.Common.DataColumnMapping("uid", "uid"), New System.Data.Common.DataColumnMapping("info", "info"), New System.Data.Common.DataColumnMapping("status", "status"), New System.Data.Common.DataColumnMapping("base_schema_ver", "base_schema_ver"), New System.Data.Common.DataColumnMapping("replinfo", "replinfo"), New System.Data.Common.DataColumnMapping("parent_obj", "parent_obj"), New System.Data.Common.DataColumnMapping("crdate", "crdate"), New System.Data.Common.DataColumnMapping("ftcatid", "ftcatid"), New System.Data.Common.DataColumnMapping("schema_ver", "schema_ver"), New System.Data.Common.DataColumnMapping("stats_schema_ver", "stats_schema_ver"), New System.Data.Common.DataColumnMapping("type", "type"), New System.Data.Common.DataColumnMapping("userstat", "userstat"), New System.Data.Common.DataColumnMapping("sysstat", "sysstat"), New System.Data.Common.DataColumnMapping("indexdel", "indexdel"), New System.Data.Common.DataColumnMapping("refdate", "refdate"), New System.Data.Common.DataColumnMapping("version", "version"), New System.Data.Common.DataColumnMapping("deltrig", "deltrig"), New System.Data.Common.DataColumnMapping("instrig", "instrig"), New System.Data.Common.DataColumnMapping("updtrig", "updtrig"), New System.Data.Common.DataColumnMapping("seltrig", "seltrig"), New System.Data.Common.DataColumnMapping("category", "category"), New System.Data.Common.DataColumnMapping("cache", "cache")})})
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_sysobjects_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.AddRange(New System.Data.SqlClient.SqlParameter() {New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing), New System.Data.SqlClient.SqlParameter("@name", System.Data.SqlDbType.NVarChar, 128, "name"), New System.Data.SqlClient.SqlParameter("@id", System.Data.SqlDbType.Int, 4, "id"), New System.Data.SqlClient.SqlParameter("@xtype", System.Data.SqlDbType.VarChar, 2, "xtype"), New System.Data.SqlClient.SqlParameter("@uid", System.Data.SqlDbType.Int, 2, "uid"), New System.Data.SqlClient.SqlParameter("@info", System.Data.SqlDbType.Int, 2, "info"), New System.Data.SqlClient.SqlParameter("@status", System.Data.SqlDbType.Int, 4, "status"), New System.Data.SqlClient.SqlParameter("@base_schema_ver", System.Data.SqlDbType.Int, 4, "base_schema_ver"), New System.Data.SqlClient.SqlParameter("@replinfo", System.Data.SqlDbType.Int, 4, "replinfo"), New System.Data.SqlClient.SqlParameter("@parent_obj", System.Data.SqlDbType.Int, 4, "parent_obj"), New System.Data.SqlClient.SqlParameter("@crdate", System.Data.SqlDbType.DateTime, 8, "crdate"), New System.Data.SqlClient.SqlParameter("@ftcatid", System.Data.SqlDbType.Int, 2, "ftcatid")})
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
            "station id=SHU;packet size=4096"
        Me.SqlConnection1.FireInfoMessageEventOnUserErrors = False
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_sysobjects_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.AddRange(New System.Data.SqlClient.SqlParameter() {New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing)})
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'ListBox1
        '
        Me.ListBox1.Location = New System.Drawing.Point(8, 16)
        Me.ListBox1.Name = "ListBox1"
        Me.ListBox1.Size = New System.Drawing.Size(240, 316)
        Me.ListBox1.TabIndex = 0
        '
        'frmSysadminTableSelector
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(256, 349)
        Me.Controls.Add(Me.ListBox1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmSysadminTableSelector"
        Me.Text = "Tabelle auswählen"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminTableSelector Class
frmSysadminTableSelector Members


frmSysadminTableSelector.frmSysadminTableSelector_Load Method

frmSysadminTableSelector.frmSysadminTableSelector_Load Method
See Also
collapseAll image DropDown image

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub frmSysadminTableSelector_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load
C#
private System.Void frmSysadminTableSelector_Load(
   object sender,
   EventArgs e
);
C++

private:
System::Void frmSysadminTableSelector_Load(
   object^ sender,
   EventArgs^ e
)
JScript
private function frmSysadminTableSelector_Load(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub frmSysadminTableSelector_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim ds As New DataSet
        Dim connection As New SqlConnection()
        Dim da As New SqlDataAdapter("", connection)
        Dim sqlcmd As New SqlCommand

        sqlcmd.CommandText = "dbo.sp_sysobjects_select"
        sqlcmd.CommandType = CommandType.StoredProcedure
        sqlcmd.Connection = connection
        Try
            connection.ConnectionString = Globals.sConnectionString
            connection.Open()
            da.SelectCommand = sqlcmd
            da.Fill(ds, "Datatable1")
        Catch ex As Exception
        Finally
            connection.Close()
            da.Dispose()
            sqlcmd.Dispose()
        End Try

        Dim i As Integer
        For i = 0 To ds.Tables(0).Rows.Count - 1
            Me.ListBox1.Items.Add(ds.Tables(0).Rows(i)(0))
        Next
        Me.SqlConnection1.Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminTableSelector Class
frmSysadminTableSelector Members


frmSysadminTableSelector.get_tablename Method

frmSysadminTableSelector.get_tablename Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function get_tablename() As String
C#
public string get_tablename();
C++

public:
String^ get_tablename()
JScript
public function get_tablename() : String;

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Function get_tablename() As String
        get_tablename = ""
        Me.ShowDialog()
        Return Me.ListBox1.SelectedItem
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminTableSelector Class
frmSysadminTableSelector Members


frmSysadminTableSelector.listbox1_dblclick Method

frmSysadminTableSelector.listbox1_dblclick Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub listbox1_dblclick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ListBox1.DoubleClick
C#
private System.Void listbox1_dblclick(
   object sender,
   EventArgs e
);
C++

private:
System::Void listbox1_dblclick(
   object^ sender,
   EventArgs^ e
)
JScript
private function listbox1_dblclick(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub listbox1_dblclick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ListBox1.DoubleClick
        Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminTableSelector Class
frmSysadminTableSelector Members


frmSysadminTableSelector Fields

frmSysadminTableSelector Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | components |
Top

Expand image See Also

Reference

frmSysadminTableSelector Class


components Variable

components Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private components As IContainer
C#
private IContainer components;
C++
private:
IContainer^ components;
JScript
private components : IContainer

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private components As System.ComponentModel.IContainer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmSysadminTableSelector Class
frmSysadminTableSelector Members


frmVerbindungEditor Class

frmVerbindungEditor Class
See Also Members
collapseAll image DropDown image

Verbindungseditor: Verbindet 2 Domain-Tables in einer dritten Tabelle.
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmVerbindungEditor
    Inherits Form
C#
[Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()]
public class frmVerbindungEditor : Form
C++
[Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()]

public ref class frmVerbindungEditor : public Form^
JScript
public
   Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()
class frmVerbindungEditor
   extends Form

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmVerbindungEditor

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Members
DomainTable


frmVerbindungEditor Members

frmVerbindungEditor Members
See Also Constructors Methods
CollapseAll image DropDown image

Verbindungseditor: Verbindet 2 Domain-Tables in einer dritten Tabelle.

The following tables list the members exposed by the frmVerbindungEditor type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | frmVerbindungEditor Constructor | Laden der linken und rechten Tabelle
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | SpaltenTitel_Aktualisieren | Aktualisiert die Spaltentitel der aktuellen Tabelle
Top

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | BeendenToolStripMenuItem_Click | Formular schliessen
Supported by the .NET Compact Framework. | BtnFocusLeft_Click | Linker Fokus-Knopf betätigt
Supported by the .NET Compact Framework. | BtnFocusRight_Click | Rechter Fokus-Knopf betätigt
Supported by the .NET Compact Framework. | BtnVerbinden_Click | Die linke und rechte Domain-Table in der unteren Tabelle verbinden. Daten sichern und erneut laden
Supported by the .NET Compact Framework. | C1DatenBottom_AfterColUpdate | Nach Datenmutation der unteren Tabelle mutiert_am und mutierer nachführen
Supported by the .NET Compact Framework. | FrmVerbindungEditor_Load | Laden sämlticher Tabellen
Supported by the .NET Compact Framework. | FrmVerbindungEditor_Resize | Formular-Resize: Button Verbinden und Button Focus-Rechts neu positionieren
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | Refresh_Bottomtable | Aktualiserung der Verbindungstabelle
Supported by the .NET Compact Framework. | TBLeft_Click | Linke Tabelle angeklickt
Supported by the .NET Compact Framework. | TBRight_Click | Rechte Tabelle angeklickt
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Formular schliessen
Supported by the .NET Compact Framework. | TSBtnSave_Click | Verbindungstabelle sichern
Supported by the .NET Compact Framework. | check_changes | Prüfung, ob Verbindungstabelle geändert wurde.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | Domaintableleft |
Supported by the .NET Compact Framework. | Domaintableright |
Supported by the .NET Compact Framework. | Fokus |
Supported by the .NET Compact Framework. | SysadminfunktionNr |
Supported by the .NET Compact Framework. | TablenameBottom |
Supported by the .NET Compact Framework. | TablenameLeft |
Supported by the .NET Compact Framework. | TablenameRight |
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | domaintablebottom |
Supported by the .NET Compact Framework. | msg |
Top

Expand image See Also

Reference

frmVerbindungEditor Class
DomainTable


frmVerbindungEditor Constructor

frmVerbindungEditor Constructor

Laden der linken und rechten Tabelle
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal TableLeft As String, _
   ByVal TableRight As String, _
   ByVal TableBottom As String, _
   ByVal SysadminfnktNr As Integer _
)
C#
public System.Void frmVerbindungEditor(
   string TableLeft,
   string TableRight,
   string TableBottom,
   int SysadminfnktNr
);
C++

public:
System::Void frmVerbindungEditor(
   String^ TableLeft,
   String^ TableRight,
   String^ TableBottom,
   int SysadminfnktNr
)
JScript
public function frmVerbindungEditor(
    TableLeft : String,
    TableRight : String,
    TableBottom : String,
    SysadminfnktNr : int
);

Parameters

TableLeft

TableRight

TableBottom

SysadminfnktNr

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Sub New(ByVal TableLeft As String, ByVal TableRight As String, ByVal TableBottom As String, ByVal SysadminfnktNr As Integer)
        InitializeComponent()
        Me.Domaintableleft = New TKB.VV.Sysadmin.DomainTable(TableLeft)
        Me.Domaintableright = New TKB.VV.Sysadmin.DomainTable(TableRight)
        Me.TablenameLeft = TableLeft
        Me.TablenameRight = TableRight
        Me.TablenameBottom = TableBottom
        Me.SysadminfunktionNr = SysadminfnktNr
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


frmVerbindungEditor Methods

frmVerbindungEditor Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | SpaltenTitel_Aktualisieren | Aktualisiert die Spaltentitel der aktuellen Tabelle
Top

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | BeendenToolStripMenuItem_Click | Formular schliessen
Supported by the .NET Compact Framework. | BtnFocusLeft_Click | Linker Fokus-Knopf betätigt
Supported by the .NET Compact Framework. | BtnFocusRight_Click | Rechter Fokus-Knopf betätigt
Supported by the .NET Compact Framework. | BtnVerbinden_Click | Die linke und rechte Domain-Table in der unteren Tabelle verbinden. Daten sichern und erneut laden
Supported by the .NET Compact Framework. | C1DatenBottom_AfterColUpdate | Nach Datenmutation der unteren Tabelle mutiert_am und mutierer nachführen
Supported by the .NET Compact Framework. | FrmVerbindungEditor_Load | Laden sämlticher Tabellen
Supported by the .NET Compact Framework. | FrmVerbindungEditor_Resize | Formular-Resize: Button Verbinden und Button Focus-Rechts neu positionieren
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | Refresh_Bottomtable | Aktualiserung der Verbindungstabelle
Supported by the .NET Compact Framework. | TBLeft_Click | Linke Tabelle angeklickt
Supported by the .NET Compact Framework. | TBRight_Click | Rechte Tabelle angeklickt
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Formular schliessen
Supported by the .NET Compact Framework. | TSBtnSave_Click | Verbindungstabelle sichern
Supported by the .NET Compact Framework. | check_changes | Prüfung, ob Verbindungstabelle geändert wurde.
Top

Expand image See Also

Reference

frmVerbindungEditor Class
DomainTable


frmVerbindungEditor.BeendenToolStripMenuItem_Click Method

frmVerbindungEditor.BeendenToolStripMenuItem_Click Method

Formular schliessen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click
C#
private System.Void BeendenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void BeendenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function BeendenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        check_changes()
        Me.Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


frmVerbindungEditor.BtnFocusLeft_Click Method

frmVerbindungEditor.BtnFocusLeft_Click Method

Linker Fokus-Knopf betätigt
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub BtnFocusLeft_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BtnFocusLeft.Click
C#
private System.Void BtnFocusLeft_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void BtnFocusLeft_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function BtnFocusLeft_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub BtnFocusLeft_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnFocusLeft.Click
        Fokus = 1
        Me.BtnFocusLeft.ImageIndex = 1
        Me.BtnFocusRight.ImageIndex = 2
        Refresh_Bottomtable()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


frmVerbindungEditor.BtnFocusRight_Click Method

frmVerbindungEditor.BtnFocusRight_Click Method

Rechter Fokus-Knopf betätigt
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub BtnFocusRight_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BtnFocusRight.Click
C#
private System.Void BtnFocusRight_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void BtnFocusRight_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function BtnFocusRight_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub BtnFocusRight_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnFocusRight.Click
        Me.Fokus = 2
        Me.BtnFocusRight.ImageIndex = 1
        Me.BtnFocusLeft.ImageIndex = 2
        Refresh_Bottomtable()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


frmVerbindungEditor.BtnVerbinden_Click Method

frmVerbindungEditor.BtnVerbinden_Click Method

Die linke und rechte Domain-Table in der unteren Tabelle verbinden. Daten sichern und erneut laden
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub BtnVerbinden_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BtnVerbinden.Click
C#
private System.Void BtnVerbinden_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void BtnVerbinden_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function BtnVerbinden_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub BtnVerbinden_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnVerbinden.Click
        check_changes()
        Dim ileft As Integer = Me.C1DatenLeft.SelectedRows.Count
        Dim iright As Integer = Me.C1DatenRight.SelectedRows.Count
        Dim ic As Integer = 0
        Dim Currentsel As Boolean
        Dim colrows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim keyvalueleft As Integer = 0
        Dim Keyvalueright As Integer = 0
        If (Me.Fokus = 1 And ileft > 1) Or (Me.Fokus = 2 And iright > 1) Then
            Me.msg.show_standardmessage(4, MsgBoxStyle.Exclamation)
            Exit Sub
        End If
        If Me.Fokus = 1 Then
            ic = iright
            colrows = Me.C1DatenRight.SelectedRows
        End If
        If Me.Fokus = 2 Then
            ic = ileft
            colrows = Me.C1DatenLeft.SelectedRows
        End If
        If ic = 0 Then
            ic = ic + 1
            Currentsel = True
        End If
        Dim i As Integer
        For i = 0 To ic - 1
            If Me.Fokus = 1 Then
                keyvalueleft = Me.C1DatenLeft.Columns(0).Value
                If Currentsel = True Then
                    Keyvalueright = Me.C1DatenRight.Columns(0).Value
                Else
                    Keyvalueright = Me.C1DatenRight.Columns(0).CellValue(colrows(i))
                End If
            Else
                Keyvalueright = Me.C1DatenRight.Columns(0).Value
                If Currentsel = True Then
                    keyvalueleft = Me.C1DatenLeft.Columns(0).Value
                Else
                    keyvalueleft = Me.C1DatenLeft.Columns(0).CellValue(colrows(i))
                End If
            End If
        Next
        Me.domaintablebottom.Insert_Bottom_Table(Me.Domaintableleft.Tabledata.Tables(0).Columns(0).ColumnName, keyvalueleft, Me.Domaintableright.Tabledata.Tables(0).Columns(0).ColumnName, Keyvalueright)
        Me.domaintablebottom.Save_Data()
        Me.Refresh_Bottomtable()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


frmVerbindungEditor.C1DatenBottom_AfterColUpdate Method

frmVerbindungEditor.C1DatenBottom_AfterColUpdate Method

Nach Datenmutation der unteren Tabelle mutiert_am und mutierer nachführen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub C1DatenBottom_AfterColUpdate( _
   ByVal sender As Object, _
   ByVal e As ColEventArgs _
) Handles  _
   C1DatenBottom.AfterColUpdate
C#
private System.Void C1DatenBottom_AfterColUpdate(
   object sender,
   ColEventArgs e
);
C++

private:
System::Void C1DatenBottom_AfterColUpdate(
   object^ sender,
   ColEventArgs^ e
)
JScript
private function C1DatenBottom_AfterColUpdate(
    sender : object,
    e : ColEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub C1DatenBottom_AfterColUpdate(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles C1DatenBottom.AfterColUpdate
        Dim i As Integer
        For i = 0 To Me.C1DatenBottom.Columns.Count - 1
            If LCase(Me.C1DatenBottom.Columns(i).DataField) = "mutiert_am" Then Me.C1DatenBottom.Columns(i).Value = Now
            If LCase(Me.C1DatenBottom.Columns(i).DataField) = "mutierer" Then Me.C1DatenBottom.Columns(i).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value
        Next
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


frmVerbindungEditor.Dispose Method

frmVerbindungEditor.Dispose Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
C#
[System.Diagnostics.DebuggerNonUserCode()]
protected override System.Void Dispose(
   bool disposing
);
C++
[System.Diagnostics.DebuggerNonUserCode()]

protected:
System::Void Dispose(
   bool disposing
)
JScript
protected
   System.Diagnostics.DebuggerNonUserCode()
function Dispose(
    disposing : boolean
);

Parameters

disposing

Expand image Source code

Visual Basic CopyCode image Copy Code
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


frmVerbindungEditor.FrmVerbindungEditor_Load Method

frmVerbindungEditor.FrmVerbindungEditor_Load Method

Laden sämlticher Tabellen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub FrmVerbindungEditor_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load
C#
private System.Void FrmVerbindungEditor_Load(
   object sender,
   EventArgs e
);
C++

private:
System::Void FrmVerbindungEditor_Load(
   object^ sender,
   EventArgs^ e
)
JScript
private function FrmVerbindungEditor_Load(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub FrmVerbindungEditor_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.C1DatenLeft.DataSource = Domaintableleft.Tabledata
        Me.C1DatenLeft.DataMember = Domaintableleft.Tabledata.Tables(0).TableName

        Me.C1DatenRight.DataSource = Domaintableright.Tabledata
        Me.C1DatenRight.DataMember = Domaintableright.Tabledata.Tables(0).TableName

        SpaltenTitel_Aktualisieren(Me.C1DatenLeft, TablenameLeft, Me.Domaintableleft.Tabledata)
        SpaltenTitel_Aktualisieren(Me.C1DatenRight, TablenameRight, Me.Domaintableright.Tabledata)

        Refresh_Bottomtable()

        Me.C1DatenLeft.AllowAddNew = False
        Me.C1DatenLeft.AllowDelete = False
        Me.C1DatenLeft.AllowUpdate = False

        Me.C1DatenRight.AllowAddNew = False
        Me.C1DatenRight.AllowDelete = False
        Me.C1DatenRight.AllowUpdate = False

        Me.C1DatenBottom.AllowAddNew = False
        Me.C1DatenBottom.AllowDelete = False

        Me.GrpBoxLeft.Text = Me.TablenameLeft
        Me.GrpBoxRight.Text = Me.TablenameRight
        Me.GrpBoxBottom.Text = Me.TablenameBottom
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


frmVerbindungEditor.FrmVerbindungEditor_Resize Method

frmVerbindungEditor.FrmVerbindungEditor_Resize Method

Formular-Resize: Button Verbinden und Button Focus-Rechts neu positionieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub FrmVerbindungEditor_Resize( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   Me.Resize
C#
private System.Void FrmVerbindungEditor_Resize(
   object sender,
   EventArgs e
);
C++

private:
System::Void FrmVerbindungEditor_Resize(
   object^ sender,
   EventArgs^ e
)
JScript
private function FrmVerbindungEditor_Resize(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub FrmVerbindungEditor_Resize(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Resize
        Me.BtnFocusRight.Left = Me.Width - (Me.BtnFocusRight.Width + 10)
        Me.BtnVerbinden.Left = Me.SplitContainer2.Panel1.Width - (Me.BtnVerbinden.Width / 2)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


frmVerbindungEditor.InitializeComponent Method

frmVerbindungEditor.InitializeComponent Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()
C#
[System.Diagnostics.DebuggerStepThrough()]
private System.Void InitializeComponent();
C++
[System.Diagnostics.DebuggerStepThrough()]

private:
System::Void InitializeComponent()
JScript
private
   System.Diagnostics.DebuggerStepThrough()
function InitializeComponent();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmVerbindungEditor))
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.SplitContainer1 = New System.Windows.Forms.SplitContainer
        Me.SplitContainer2 = New System.Windows.Forms.SplitContainer
        Me.GrpBoxLeft = New System.Windows.Forms.GroupBox
        Me.C1DatenLeft = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.GrpBoxRight = New System.Windows.Forms.GroupBox
        Me.C1DatenRight = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.Panel1 = New System.Windows.Forms.Panel
        Me.BtnFocusRight = New System.Windows.Forms.Button
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.BtnFocusLeft = New System.Windows.Forms.Button
        Me.BtnVerbinden = New System.Windows.Forms.Button
        Me.GrpBoxBottom = New System.Windows.Forms.GroupBox
        Me.C1DatenBottom = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.ToolStrip1.SuspendLayout()
        Me.MenuStrip1.SuspendLayout()
        Me.SplitContainer1.Panel1.SuspendLayout()
        Me.SplitContainer1.Panel2.SuspendLayout()
        Me.SplitContainer1.SuspendLayout()
        Me.SplitContainer2.Panel1.SuspendLayout()
        Me.SplitContainer2.Panel2.SuspendLayout()
        Me.SplitContainer2.SuspendLayout()
        Me.GrpBoxLeft.SuspendLayout()
        CType(Me.C1DatenLeft, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GrpBoxRight.SuspendLayout()
        CType(Me.C1DatenRight, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel1.SuspendLayout()
        Me.GrpBoxBottom.SuspendLayout()
        CType(Me.C1DatenBottom, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(953, 25)
        Me.ToolStrip1.TabIndex = 3
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "ToolStripButton1"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(953, 24)
        Me.MenuStrip1.TabIndex = 2
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(127, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'SplitContainer1
        '
        Me.SplitContainer1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.SplitContainer1.Location = New System.Drawing.Point(0, 49)
        Me.SplitContainer1.Name = "SplitContainer1"
        Me.SplitContainer1.Orientation = System.Windows.Forms.Orientation.Horizontal
        '
        'SplitContainer1.Panel1
        '
        Me.SplitContainer1.Panel1.Controls.Add(Me.SplitContainer2)
        Me.SplitContainer1.Panel1.Controls.Add(Me.Panel1)
        '
        'SplitContainer1.Panel2
        '
        Me.SplitContainer1.Panel2.Controls.Add(Me.GrpBoxBottom)
        Me.SplitContainer1.Size = New System.Drawing.Size(953, 466)
        Me.SplitContainer1.SplitterDistance = 276
        Me.SplitContainer1.TabIndex = 4
        '
        'SplitContainer2
        '
        Me.SplitContainer2.Dock = System.Windows.Forms.DockStyle.Fill
        Me.SplitContainer2.Location = New System.Drawing.Point(0, 0)
        Me.SplitContainer2.Name = "SplitContainer2"
        '
        'SplitContainer2.Panel1
        '
        Me.SplitContainer2.Panel1.Controls.Add(Me.GrpBoxLeft)
        '
        'SplitContainer2.Panel2
        '
        Me.SplitContainer2.Panel2.Controls.Add(Me.GrpBoxRight)
        Me.SplitContainer2.Size = New System.Drawing.Size(953, 243)
        Me.SplitContainer2.SplitterDistance = 467
        Me.SplitContainer2.TabIndex = 1
        '
        'GrpBoxLeft
        '
        Me.GrpBoxLeft.Controls.Add(Me.C1DatenLeft)
        Me.GrpBoxLeft.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GrpBoxLeft.Location = New System.Drawing.Point(0, 0)
        Me.GrpBoxLeft.Name = "GrpBoxLeft"
        Me.GrpBoxLeft.Size = New System.Drawing.Size(467, 243)
        Me.GrpBoxLeft.TabIndex = 0
        Me.GrpBoxLeft.TabStop = False
        Me.GrpBoxLeft.Text = "GroupBox1"
        '
        'C1DatenLeft
        '
        Me.C1DatenLeft.AllowAddNew = True
        Me.C1DatenLeft.AlternatingRows = True
        Me.C1DatenLeft.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1DatenLeft.FilterBar = True
        Me.C1DatenLeft.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1DatenLeft.Images.Add(CType(resources.GetObject("C1DatenLeft.Images"), System.Drawing.Image))
        Me.C1DatenLeft.Location = New System.Drawing.Point(3, 16)
        Me.C1DatenLeft.Name = "C1DatenLeft"
        Me.C1DatenLeft.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1DatenLeft.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1DatenLeft.PreviewInfo.ZoomFactor = 75
        Me.C1DatenLeft.PrintInfo.PageSettings = CType(resources.GetObject("C1DatenLeft.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1DatenLeft.Size = New System.Drawing.Size(461, 224)
        Me.C1DatenLeft.TabIndex = 4
        Me.C1DatenLeft.Text = "C1TrueDBGrid1"
        Me.C1DatenLeft.PropBag = resources.GetString("C1DatenLeft.PropBag")
        '
        'GrpBoxRight
        '
        Me.GrpBoxRight.Controls.Add(Me.C1DatenRight)
        Me.GrpBoxRight.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GrpBoxRight.Location = New System.Drawing.Point(0, 0)
        Me.GrpBoxRight.Name = "GrpBoxRight"
        Me.GrpBoxRight.Size = New System.Drawing.Size(482, 243)
        Me.GrpBoxRight.TabIndex = 1
        Me.GrpBoxRight.TabStop = False
        Me.GrpBoxRight.Text = "GroupBox1"
        '
        'C1DatenRight
        '
        Me.C1DatenRight.AllowAddNew = True
        Me.C1DatenRight.AlternatingRows = True
        Me.C1DatenRight.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1DatenRight.FilterBar = True
        Me.C1DatenRight.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1DatenRight.Images.Add(CType(resources.GetObject("C1DatenRight.Images"), System.Drawing.Image))
        Me.C1DatenRight.Location = New System.Drawing.Point(3, 16)
        Me.C1DatenRight.Name = "C1DatenRight"
        Me.C1DatenRight.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1DatenRight.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1DatenRight.PreviewInfo.ZoomFactor = 75
        Me.C1DatenRight.PrintInfo.PageSettings = CType(resources.GetObject("C1DatenRight.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1DatenRight.Size = New System.Drawing.Size(476, 224)
        Me.C1DatenRight.TabIndex = 4
        Me.C1DatenRight.Text = "C1TrueDBGrid1"
        Me.C1DatenRight.PropBag = resources.GetString("C1DatenRight.PropBag")
        '
        'Panel1
        '
        Me.Panel1.Controls.Add(Me.BtnFocusRight)
        Me.Panel1.Controls.Add(Me.BtnFocusLeft)
        Me.Panel1.Controls.Add(Me.BtnVerbinden)
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Bottom
        Me.Panel1.Location = New System.Drawing.Point(0, 243)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(953, 33)
        Me.Panel1.TabIndex = 0
        '
        'BtnFocusRight
        '
        Me.BtnFocusRight.ImageIndex = 2
        Me.BtnFocusRight.ImageList = Me.ImageList1
        Me.BtnFocusRight.Location = New System.Drawing.Point(920, 3)
        Me.BtnFocusRight.Name = "BtnFocusRight"
        Me.BtnFocusRight.Size = New System.Drawing.Size(30, 23)
        Me.BtnFocusRight.TabIndex = 2
        Me.BtnFocusRight.UseVisualStyleBackColor = True
        '
        'ImageList1
        '
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        Me.ImageList1.Images.SetKeyName(0, "Kette3.ico")
        Me.ImageList1.Images.SetKeyName(1, "Haken1.ico")
        Me.ImageList1.Images.SetKeyName(2, "Haken2.ico")
        '
        'BtnFocusLeft
        '
        Me.BtnFocusLeft.ImageIndex = 1
        Me.BtnFocusLeft.ImageList = Me.ImageList1
        Me.BtnFocusLeft.Location = New System.Drawing.Point(6, 4)
        Me.BtnFocusLeft.Name = "BtnFocusLeft"
        Me.BtnFocusLeft.Size = New System.Drawing.Size(30, 23)
        Me.BtnFocusLeft.TabIndex = 1
        Me.BtnFocusLeft.UseVisualStyleBackColor = True
        '
        'BtnVerbinden
        '
        Me.BtnVerbinden.ImageAlign = System.Drawing.ContentAlignment.MiddleLeft
        Me.BtnVerbinden.ImageIndex = 0
        Me.BtnVerbinden.ImageList = Me.ImageList1
        Me.BtnVerbinden.Location = New System.Drawing.Point(430, 4)
        Me.BtnVerbinden.Name = "BtnVerbinden"
        Me.BtnVerbinden.Size = New System.Drawing.Size(84, 23)
        Me.BtnVerbinden.TabIndex = 0
        Me.BtnVerbinden.Text = "Verbinden"
        Me.BtnVerbinden.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        Me.BtnVerbinden.UseVisualStyleBackColor = True
        '
        'GrpBoxBottom
        '
        Me.GrpBoxBottom.Controls.Add(Me.C1DatenBottom)
        Me.GrpBoxBottom.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GrpBoxBottom.Location = New System.Drawing.Point(0, 0)
        Me.GrpBoxBottom.Name = "GrpBoxBottom"
        Me.GrpBoxBottom.Size = New System.Drawing.Size(953, 186)
        Me.GrpBoxBottom.TabIndex = 2
        Me.GrpBoxBottom.TabStop = False
        Me.GrpBoxBottom.Text = "GroupBox1"
        '
        'C1DatenBottom
        '
        Me.C1DatenBottom.AllowAddNew = True
        Me.C1DatenBottom.AlternatingRows = True
        Me.C1DatenBottom.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1DatenBottom.FilterBar = True
        Me.C1DatenBottom.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1DatenBottom.Images.Add(CType(resources.GetObject("C1DatenBottom.Images"), System.Drawing.Image))
        Me.C1DatenBottom.Location = New System.Drawing.Point(3, 16)
        Me.C1DatenBottom.Name = "C1DatenBottom"
        Me.C1DatenBottom.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1DatenBottom.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1DatenBottom.PreviewInfo.ZoomFactor = 75
        Me.C1DatenBottom.PrintInfo.PageSettings = CType(resources.GetObject("C1DatenBottom.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1DatenBottom.Size = New System.Drawing.Size(947, 167)
        Me.C1DatenBottom.TabIndex = 4
        Me.C1DatenBottom.Text = "C1TrueDBGrid1"
        Me.C1DatenBottom.PropBag = resources.GetString("C1DatenBottom.PropBag")
        '
        'FrmVerbindungEditor
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(953, 515)
        Me.Controls.Add(Me.SplitContainer1)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "FrmVerbindungEditor"
        Me.Text = "VerbindungEditor"
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.SplitContainer1.Panel1.ResumeLayout(False)
        Me.SplitContainer1.Panel2.ResumeLayout(False)
        Me.SplitContainer1.ResumeLayout(False)
        Me.SplitContainer2.Panel1.ResumeLayout(False)
        Me.SplitContainer2.Panel2.ResumeLayout(False)
        Me.SplitContainer2.ResumeLayout(False)
        Me.GrpBoxLeft.ResumeLayout(False)
        CType(Me.C1DatenLeft, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GrpBoxRight.ResumeLayout(False)
        CType(Me.C1DatenRight, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel1.ResumeLayout(False)
        Me.GrpBoxBottom.ResumeLayout(False)
        CType(Me.C1DatenBottom, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


frmVerbindungEditor.Refresh_Bottomtable Method

frmVerbindungEditor.Refresh_Bottomtable Method

Aktualiserung der Verbindungstabelle
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Refresh_Bottomtable()
C#
private System.Void Refresh_Bottomtable();
C++

private:
System::Void Refresh_Bottomtable()
JScript
private function Refresh_Bottomtable();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Refresh_Bottomtable()
        Try
            check_changes()
            Me.domaintablebottom.dispose()
        Catch
        End Try

        Dim keyvalue As String = ""

        If Fokus = 1 Then
            keyvalue = Me.C1DatenLeft.Columns(0).Value
        Else
            keyvalue = Me.C1DatenRight.Columns(0).Value
        End If
        Me.domaintablebottom = New TKB.VV.Sysadmin.DomainTable(Me.TablenameBottom, Fokus, keyvalue)
        Me.C1DatenBottom.DataSource = domaintablebottom.Tabledata
        Me.C1DatenBottom.DataMember = domaintablebottom.Tabledata.Tables(0).TableName
        SpaltenTitel_Aktualisieren(Me.C1DatenBottom, TablenameBottom, Me.domaintablebottom.Tabledata)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


frmVerbindungEditor.SpaltenTitel_Aktualisieren Method

frmVerbindungEditor.SpaltenTitel_Aktualisieren Method

Aktualisiert die Spaltentitel der aktuellen Tabelle
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub SpaltenTitel_Aktualisieren( _
   ByRef daten As Object, _
   ByVal tablename As String, _
   ByVal ds As DataSet _
)
C#
public System.Void SpaltenTitel_Aktualisieren(
   ref object daten,
   string tablename,
   DataSet ds
);
C++

public:
System::Void SpaltenTitel_Aktualisieren(
   object^& daten,
   String^ tablename,
   DataSet^ ds
)
JScript
public function SpaltenTitel_Aktualisieren(
    daten : object,
    tablename : String,
    ds : DataSet
);

Parameters

daten

tablename

ds

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Sub SpaltenTitel_Aktualisieren(ByRef daten As Object, ByVal tablename As String, ByVal ds As DataSet)
        Dim titel As New TKB.VV.Utils.MySpaltenTitel
        Dim anzcols As Integer
        Dim cols(daten.Splits(0).DisplayColumns.Count) As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim ts As New TKB.VV.Utils.Tabellenspalte

        Dim i As Integer
        Dim t As New DataTable()
        Dim s As String
        anzcols = daten.Splits(0).DisplayColumns.Count
        t = ds.Tables(0)
        ts.Tabelle = tablename
        For i = 0 To daten.Columns.Count - 1
            s = daten.Columns(i).DataField
            ts.Feld = s
            ts.getspalte()
            daten.Columns(i).Caption = ts.spaltenname

            If ts.ColWith = 0 Then
                daten.Splits(0).DisplayColumns(i).Width = 0
                daten.Splits(0).DisplayColumns(i).Visible = False
            Else
                daten.Splits(0).DisplayColumns(i).Width = ts.ColWith
            End If

            If ts.locked Then
                daten.Splits(0).DisplayColumns(i).Locked = True
            End If

            If ts.AlsHacken Then
                daten.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
            End If

            'Präsentation von aktiv
            If daten.Columns(i).DataField = "aktiv" Then
                daten.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                daten.Columns(i).ValueItems.DefaultItem = True
                daten.Columns(i).DefaultValue = True
                daten.Columns(i).FilterText = True
            End If
            If daten.Columns(i).DataField = "erstellt_am" Then
                daten.Columns(i).DefaultValue = Now
            End If
        Next
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


frmVerbindungEditor.TBLeft_Click Method

frmVerbindungEditor.TBLeft_Click Method

Linke Tabelle angeklickt
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TBLeft_Click( _
   ByVal sender As Object, _
   ByVal e As RowColChangeEventArgs _
) Handles  _
   C1DatenLeft.RowColChange
C#
private System.Void TBLeft_Click(
   object sender,
   RowColChangeEventArgs e
);
C++

private:
System::Void TBLeft_Click(
   object^ sender,
   RowColChangeEventArgs^ e
)
JScript
private function TBLeft_Click(
    sender : object,
    e : RowColChangeEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TBLeft_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles C1DatenLeft.RowColChange
        check_changes()
        Refresh_Bottomtable()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


frmVerbindungEditor.TBRight_Click Method

frmVerbindungEditor.TBRight_Click Method

Rechte Tabelle angeklickt
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TBRight_Click( _
   ByVal sender As Object, _
   ByVal e As RowColChangeEventArgs _
) Handles  _
   C1DatenRight.RowColChange
C#
private System.Void TBRight_Click(
   object sender,
   RowColChangeEventArgs e
);
C++

private:
System::Void TBRight_Click(
   object^ sender,
   RowColChangeEventArgs^ e
)
JScript
private function TBRight_Click(
    sender : object,
    e : RowColChangeEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TBRight_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles C1DatenRight.RowColChange
        check_changes()
        Refresh_Bottomtable()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


frmVerbindungEditor.TSBtnQuit_Click Method

frmVerbindungEditor.TSBtnQuit_Click Method

Formular schliessen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click
C#
private System.Void TSBtnQuit_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnQuit_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnQuit_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        check_changes()
        Me.Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


frmVerbindungEditor.TSBtnSave_Click Method

frmVerbindungEditor.TSBtnSave_Click Method

Verbindungstabelle sichern
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click
C#
private System.Void TSBtnSave_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnSave_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnSave_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Me.domaintablebottom.Save_Data()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


frmVerbindungEditor.check_changes Method

frmVerbindungEditor.check_changes Method

Prüfung, ob Verbindungstabelle geändert wurde.
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub check_changes()
C#
private System.Void check_changes();
C++

private:
System::Void check_changes()
JScript
private function check_changes();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub check_changes()
        Dim msgres As MsgBoxResult
        If Me.domaintablebottom.Tabledata.HasChanges Then
            msgres = msg.Show_MessageYesNo(3)
            If msgres = MsgBoxResult.Yes Then
                Me.domaintablebottom.Save_Data()
            End If
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


frmVerbindungEditor Fields

frmVerbindungEditor Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | Domaintableleft |
Supported by the .NET Compact Framework. | Domaintableright |
Supported by the .NET Compact Framework. | Fokus |
Supported by the .NET Compact Framework. | SysadminfunktionNr |
Supported by the .NET Compact Framework. | TablenameBottom |
Supported by the .NET Compact Framework. | TablenameLeft |
Supported by the .NET Compact Framework. | TablenameRight |
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | domaintablebottom |
Supported by the .NET Compact Framework. | msg |
Top

Expand image See Also

Reference

frmVerbindungEditor Class
DomainTable


Domaintableleft Variable

Domaintableleft Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Domaintableleft As DomainTable
C#
private DomainTable Domaintableleft;
C++
private:
DomainTable^ Domaintableleft;
JScript
private Domaintableleft : DomainTable

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Domaintableleft As TKB.VV.Sysadmin.DomainTable

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


Domaintableright Variable

Domaintableright Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Domaintableright As DomainTable
C#
private DomainTable Domaintableright;
C++
private:
DomainTable^ Domaintableright;
JScript
private Domaintableright : DomainTable

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Domaintableright As TKB.VV.Sysadmin.DomainTable

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


Fokus Variable

Fokus Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Fokus As Integer
C#
private int Fokus;
C++
private:
int Fokus;
JScript
private Fokus : int

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Fokus As Integer = 1

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


SysadminfunktionNr Variable

SysadminfunktionNr Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private SysadminfunktionNr As Integer
C#
private int SysadminfunktionNr;
C++
private:
int SysadminfunktionNr;
JScript
private SysadminfunktionNr : int

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim SysadminfunktionNr As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


TablenameBottom Variable

TablenameBottom Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private TablenameBottom As String
C#
private string TablenameBottom;
C++
private:
String^ TablenameBottom;
JScript
private TablenameBottom : String

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim TablenameBottom As String

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


TablenameLeft Variable

TablenameLeft Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private TablenameLeft As String
C#
private string TablenameLeft;
C++
private:
String^ TablenameLeft;
JScript
private TablenameLeft : String

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim TablenameLeft As String

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


TablenameRight Variable

TablenameRight Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private TablenameRight As String
C#
private string TablenameRight;
C++
private:
String^ TablenameRight;
JScript
private TablenameRight : String

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim TablenameRight As String

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


components Variable

components Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private components As IContainer
C#
private IContainer components;
C++
private:
IContainer^ components;
JScript
private components : IContainer

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private components As System.ComponentModel.IContainer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


domaintablebottom Variable

domaintablebottom Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private domaintablebottom As DomainTable
C#
private DomainTable domaintablebottom;
C++
private:
DomainTable^ domaintablebottom;
JScript
private domaintablebottom : DomainTable

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim domaintablebottom As TKB.VV.Sysadmin.DomainTable

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


msg Variable

msg Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private msg As MyMessage
C#
private MyMessage msg;
C++
private:
MyMessage^ msg;
JScript
private msg : MyMessage

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim msg As New TKB.VV.Utils.MyMessage

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVerbindungEditor Class
frmVerbindungEditor Members


frmVertragselement Class

frmVertragselement Class
Members
collapseAll image DropDown image

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmVertragselement
    Inherits Form
C#
[Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()]
public class frmVertragselement : Form
C++
[Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()]

public ref class frmVertragselement : public Form^
JScript
public
   Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()
class frmVertragselement
   extends Form

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmVertragselement

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Members


frmVertragselement Members

frmVertragselement Members
See Also Constructors Methods
CollapseAll image DropDown image

The following tables list the members exposed by the frmVertragselement type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | frmVertragselement Constructor | (Overloaded) Standard Constructore New
Top

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose | (Overloaded)
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | AddChanges | Allg Eventhandler für Chanage-Ereignise festlegen
Supported by the .NET Compact Framework. | BeendenToolStripMenuItem_Click | Menu Beenden
Supported by the .NET Compact Framework. | C1Kontakte_DoubleClick | Doppelklick auf einem Kontakt
Supported by the .NET Compact Framework. | C1Kontakte_MouseDown | Mousedown Kontakte
Supported by the .NET Compact Framework. | C1Kuendigungsfristen_DoubleClick | Kuendigungsfrist bearbeiten / anzeigen
Supported by the .NET Compact Framework. | C1Kuendigungsfristen_MouseDown | Mousedown Kündigungsfristen
Supported by the .NET Compact Framework. | ChangesMade | Envent-Handler für Change-Ereignisse
Supported by the .NET Compact Framework. | Check_Changes | Prüfung, ob Datenänderungen vorgenommen wurden.
Supported by the .NET Compact Framework. | ClosingForm | Schliessen des Formulars
Supported by the .NET Compact Framework. | DateTimePicker_ValueChanged | Handelt das Change-Ereignis eines Datetimepckers und stellt das ausgewählte Datum in das entsprechende Textfeld
Supported by the .NET Compact Framework. | GetControl | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
Supported by the .NET Compact Framework. | Get_Data | Daten ab DB laden uns ins Form befüllen
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | KontaktAnzeigenToolStripMenuItem_Click | Anzeigen bzw. bearbeitnen eines Kontaktes
Supported by the .NET Compact Framework. | KontaktLöschenToolStripMenuItem_Click | Vertragskontakt inaktivieren
Supported by the .NET Compact Framework. | KontaktNeuToolStripMenuItem_Click | Neuer Vertragskontakt erstellen
Supported by the .NET Compact Framework. | KuendigungsfristBearbeitenToolStripMenuItem_Click | Kuendigungsfrist bearbeiten / anzeigen
Supported by the .NET Compact Framework. | KuendigungsfristLöschenToolStripMenuItem_Click | Kuendigungsfrist inaktivieren
Supported by the .NET Compact Framework. | KuendigungsfristNeuToolStripMenuItem_Click | Neue Kuendigungsfrist erstellen
Supported by the .NET Compact Framework. | Load_Securitylevel | Laden der Securitylevel-Daten in die Combobox
Supported by the .NET Compact Framework. | Refresh_Kontakte | Kündigungsfristen aktualisieren
Supported by the .NET Compact Framework. | Refresh_Kuendigungsfrist | Kündigungsfristen aktualisieren
Supported by the .NET Compact Framework. | Save_data | Daten ab Form speichern
Supported by the .NET Compact Framework. | TSBtnCopy_Click | Datensatz kopieren
Supported by the .NET Compact Framework. | TSBtnDelete_Click | Aktueller Datensatz inaktivieren
Supported by the .NET Compact Framework. | TSBtnNew_Click | Neuer Datensatz erstellen
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Formular schliessen
Supported by the .NET Compact Framework. | TSBtnSave_Click | Sicherungs-Button betätigt
Supported by the .NET Compact Framework. | TSBtnSuche_Click | Vertragspartner suchen
Supported by the .NET Compact Framework. | TabControlDiverse_SelectedIndexChanged | Index-Wechsel auf TabControlDiverse
Supported by the .NET Compact Framework. | btnVertragspartnersuche_Click | Vertragspartner suchen
Supported by the .NET Compact Framework. | frmVertragselement_Load | Load-Methode
Supported by the .NET Compact Framework. | frmVertragselement_Shown | Shown-Ereigns
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | Aktueller_Vertragspartner |
Supported by the .NET Compact Framework. | Aktuelles_Vertragselement |
Supported by the .NET Compact Framework. | Anzeige |
Supported by the .NET Compact Framework. | FormDataChanged |
Supported by the .NET Compact Framework. | FormReadonly |
Supported by the .NET Compact Framework. | SpaltenTitel |
Supported by the .NET Compact Framework. | Vertragselement |
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | msg |
Supported by the .NET Compact Framework. | sec |
Top

Expand image See Also

Reference

frmVertragselement Class


frmVertragselement Constructor

frmVertragselement Constructor

Standard Constructore New

Expand image Overload List

Name | Description
public System.Void frmVertragselement(); | Standard Constructore New
public System.Void frmVertragselement(int, bool, bool, int); | Formualr mit Vertragselementnr und Anzeigestatus öffnen

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement Methods

frmVertragselement Methods
CollapseAll image DropDown image

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose | (Overloaded)
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | AddChanges | Allg Eventhandler für Chanage-Ereignise festlegen
Supported by the .NET Compact Framework. | BeendenToolStripMenuItem_Click | Menu Beenden
Supported by the .NET Compact Framework. | C1Kontakte_DoubleClick | Doppelklick auf einem Kontakt
Supported by the .NET Compact Framework. | C1Kontakte_MouseDown | Mousedown Kontakte
Supported by the .NET Compact Framework. | C1Kuendigungsfristen_DoubleClick | Kuendigungsfrist bearbeiten / anzeigen
Supported by the .NET Compact Framework. | C1Kuendigungsfristen_MouseDown | Mousedown Kündigungsfristen
Supported by the .NET Compact Framework. | ChangesMade | Envent-Handler für Change-Ereignisse
Supported by the .NET Compact Framework. | Check_Changes | Prüfung, ob Datenänderungen vorgenommen wurden.
Supported by the .NET Compact Framework. | ClosingForm | Schliessen des Formulars
Supported by the .NET Compact Framework. | DateTimePicker_ValueChanged | Handelt das Change-Ereignis eines Datetimepckers und stellt das ausgewählte Datum in das entsprechende Textfeld
Supported by the .NET Compact Framework. | GetControl | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
Supported by the .NET Compact Framework. | Get_Data | Daten ab DB laden uns ins Form befüllen
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | KontaktAnzeigenToolStripMenuItem_Click | Anzeigen bzw. bearbeitnen eines Kontaktes
Supported by the .NET Compact Framework. | KontaktLöschenToolStripMenuItem_Click | Vertragskontakt inaktivieren
Supported by the .NET Compact Framework. | KontaktNeuToolStripMenuItem_Click | Neuer Vertragskontakt erstellen
Supported by the .NET Compact Framework. | KuendigungsfristBearbeitenToolStripMenuItem_Click | Kuendigungsfrist bearbeiten / anzeigen
Supported by the .NET Compact Framework. | KuendigungsfristLöschenToolStripMenuItem_Click | Kuendigungsfrist inaktivieren
Supported by the .NET Compact Framework. | KuendigungsfristNeuToolStripMenuItem_Click | Neue Kuendigungsfrist erstellen
Supported by the .NET Compact Framework. | Load_Securitylevel | Laden der Securitylevel-Daten in die Combobox
Supported by the .NET Compact Framework. | Refresh_Kontakte | Kündigungsfristen aktualisieren
Supported by the .NET Compact Framework. | Refresh_Kuendigungsfrist | Kündigungsfristen aktualisieren
Supported by the .NET Compact Framework. | Save_data | Daten ab Form speichern
Supported by the .NET Compact Framework. | TSBtnCopy_Click | Datensatz kopieren
Supported by the .NET Compact Framework. | TSBtnDelete_Click | Aktueller Datensatz inaktivieren
Supported by the .NET Compact Framework. | TSBtnNew_Click | Neuer Datensatz erstellen
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Formular schliessen
Supported by the .NET Compact Framework. | TSBtnSave_Click | Sicherungs-Button betätigt
Supported by the .NET Compact Framework. | TSBtnSuche_Click | Vertragspartner suchen
Supported by the .NET Compact Framework. | TabControlDiverse_SelectedIndexChanged | Index-Wechsel auf TabControlDiverse
Supported by the .NET Compact Framework. | btnVertragspartnersuche_Click | Vertragspartner suchen
Supported by the .NET Compact Framework. | frmVertragselement_Load | Load-Methode
Supported by the .NET Compact Framework. | frmVertragselement_Shown | Shown-Ereigns
Top

Expand image See Also

Reference

frmVertragselement Class


frmVertragselement.AddChanges Method

frmVertragselement.AddChanges Method

Allg Eventhandler für Chanage-Ereignise festlegen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub AddChanges( _
   ByVal Container As Control _
)
C#
private System.Void AddChanges(
   Control Container
);
C++

private:
System::Void AddChanges(
   Control^ Container
)
JScript
private function AddChanges(
    Container : Control
);

Parameters

Container

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub AddChanges(ByVal Container As Control)
        Dim l As New List(Of Control)
        Me.GetControl(Me, "*", l)
        Dim evh As EventHandler = AddressOf ChangesMade
        For Each c As Control In l
            If TypeOf c Is TextBox Then
                Dim ctl As TextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is MaskedTextBox Then
                Dim ctl As MaskedTextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is ComboBox Then
                Dim ctl As ComboBox = c
                AddHandler ctl.SelectedValueChanged, evh
            End If
            If TypeOf c Is CheckBox Then
                Dim ctl As CheckBox = c
                AddHandler ctl.CheckedChanged, evh
            End If
        Next
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.BeendenToolStripMenuItem_Click Method

frmVertragselement.BeendenToolStripMenuItem_Click Method

Menu Beenden
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click
C#
private System.Void BeendenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void BeendenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function BeendenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.TSBtnQuit_Click(sender, e)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.C1Kontakte_DoubleClick Method

frmVertragselement.C1Kontakte_DoubleClick Method

Doppelklick auf einem Kontakt
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub C1Kontakte_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Kontakte.DoubleClick
C#
private System.Void C1Kontakte_DoubleClick(
   object sender,
   EventArgs e
);
C++

private:
System::Void C1Kontakte_DoubleClick(
   object^ sender,
   EventArgs^ e
)
JScript
private function C1Kontakte_DoubleClick(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub C1Kontakte_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Kontakte.DoubleClick
        Me.KontaktAnzeigenToolStripMenuItem_Click(sender, e)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.C1Kontakte_MouseDown Method

frmVertragselement.C1Kontakte_MouseDown Method

Mousedown Kontakte
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub C1Kontakte_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Kontakte.MouseDown
C#
private System.Void C1Kontakte_MouseDown(
   object sender,
   MouseEventArgs e
);
C++

private:
System::Void C1Kontakte_MouseDown(
   object^ sender,
   MouseEventArgs^ e
)
JScript
private function C1Kontakte_MouseDown(
    sender : object,
    e : MouseEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub C1Kontakte_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Kontakte.MouseDown
        Me.C1Kontakte.Bookmark = Me.C1Kontakte.RowContaining(e.Y)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.C1Kuendigungsfristen_DoubleClick Method

frmVertragselement.C1Kuendigungsfristen_DoubleClick Method

Kuendigungsfrist bearbeiten / anzeigen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub C1Kuendigungsfristen_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Kuendigungsfristen.DoubleClick
C#
private System.Void C1Kuendigungsfristen_DoubleClick(
   object sender,
   EventArgs e
);
C++

private:
System::Void C1Kuendigungsfristen_DoubleClick(
   object^ sender,
   EventArgs^ e
)
JScript
private function C1Kuendigungsfristen_DoubleClick(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub C1Kuendigungsfristen_DoubleClick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles C1Kuendigungsfristen.DoubleClick
        Try
            Dim f As New frmKuendigungsfrist(Me.C1Kuendigungsfristen.Columns("Kuendigungsfristnr").Value, Me.Vertragselement.iVertragselementnr.Value, Me.FormReadonly)
            f.ShowDialog()
            Me.Refresh_Kuendigungsfrist()
        Catch
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.C1Kuendigungsfristen_MouseDown Method

frmVertragselement.C1Kuendigungsfristen_MouseDown Method

Mousedown Kündigungsfristen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub C1Kuendigungsfristen_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Kuendigungsfristen.MouseDown
C#
private System.Void C1Kuendigungsfristen_MouseDown(
   object sender,
   MouseEventArgs e
);
C++

private:
System::Void C1Kuendigungsfristen_MouseDown(
   object^ sender,
   MouseEventArgs^ e
)
JScript
private function C1Kuendigungsfristen_MouseDown(
    sender : object,
    e : MouseEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub C1Kuendigungsfristen_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Kuendigungsfristen.MouseDown
        Me.C1Kuendigungsfristen.Bookmark = Me.C1Kuendigungsfristen.RowContaining(e.Y)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.ChangesMade Method

frmVertragselement.ChangesMade Method

Envent-Handler für Change-Ereignisse
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub ChangesMade( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
private System.Void ChangesMade(
   object sender,
   EventArgs e
);
C++

private:
System::Void ChangesMade(
   object^ sender,
   EventArgs^ e
)
JScript
private function ChangesMade(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub ChangesMade(ByVal sender As Object, ByVal e As System.EventArgs)
        Me.FormDataChanged = True
        Dim objtype As System.Type = sender.GetType
        If objtype.Name = "MaskedTextBox" Then
            Dim o As MaskedTextBox = sender
            If o.Text = "01.01.1900" Then o.Text = "  .  .    "
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.Check_Changes Method

frmVertragselement.Check_Changes Method

Prüfung, ob Datenänderungen vorgenommen wurden.
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Check_Changes() As Boolean
C#
private bool Check_Changes();
C++

private:
bool Check_Changes()
JScript
private function Check_Changes() : boolean;

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Function Check_Changes() As Boolean
        If Me.FormReadonly Then Exit Function
        Dim msgres As MsgBoxResult
        If Me.FormDataChanged Then
            msgres = msg.Show_MessageYesNoCancel(3)
            Select Case msgres
                Case MsgBoxResult.Yes
                    Save_data()
                    Return True
                Case MsgBoxResult.Cancel
                    Return False
                Case MsgBoxResult.No
                    Return True
            End Select
        Else
            Return True
        End If
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.ClosingForm Method

frmVertragselement.ClosingForm Method

Schliessen des Formulars
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub ClosingForm( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing
C#
private System.Void ClosingForm(
   object sender,
   FormClosingEventArgs e
);
C++

private:
System::Void ClosingForm(
   object^ sender,
   FormClosingEventArgs^ e
)
JScript
private function ClosingForm(
    sender : object,
    e : FormClosingEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub ClosingForm(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.FormReadonly = True Then Exit Sub
        If check_changes() = False Then
            e.Cancel = True
        Else
            Me.dispose()
            Globals.MyEventHanlder.Vertragselement_Closed(Me.Aktueller_Vertragspartner, Me.Aktuelles_Vertragselement)
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.DateTimePicker_ValueChanged Method

frmVertragselement.DateTimePicker_ValueChanged Method

Handelt das Change-Ereignis eines Datetimepckers und stellt das ausgewählte Datum in das entsprechende Textfeld
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub DateTimePicker_ValueChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   dtPickerVertragsbegin.ValueChanged, _
   dtPickerVertragsende.ValueChanged, _
   dtPickerMindestvertragsdauerbis.ValueChanged, _
   dtPickerUnterzeichnetam.ValueChanged, _
   dtPickerVersionsdatum.ValueChanged, _
   dtPickerGekuendigtam.ValueChanged, _
   dtPickerGekuendigtper.ValueChanged
C#
private System.Void DateTimePicker_ValueChanged(
   object sender,
   EventArgs e
);
C++

private:
System::Void DateTimePicker_ValueChanged(
   object^ sender,
   EventArgs^ e
)
JScript
private function DateTimePicker_ValueChanged(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub DateTimePicker_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles _
        dtPickerVertragsbegin.ValueChanged, dtPickerVertragsende.ValueChanged, dtPickerMindestvertragsdauerbis.ValueChanged, _
        dtPickerUnterzeichnetam.ValueChanged, dtPickerVersionsdatum.ValueChanged, dtPickerGekuendigtam.ValueChanged, dtPickerGekuendigtper.ValueChanged
        Dim s As String
        Dim obj As DateTimePicker = sender
        s = obj.Name
        s = "txt" + s.Substring(8, s.Length - 8)
        Dim l As New List(Of Control)
        Dim txtb As MaskedTextBox
        GetControl(Me, s, l)
        For Each ctl As Control In l
            txtb = CType(ctl, MaskedTextBox)
            txtb.Text = obj.Value
        Next

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.Dispose Method

frmVertragselement.Dispose Method

Expand image Overload List

Name | Description
protected override System.Void Dispose(bool); |
public System.Void dispose(); |

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.GetControl Method

frmVertragselement.GetControl Method

Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function GetControl( _
   ByVal BaseControl As Control, _
   ByVal Key As String, _
   ByRef L As List(Of Control), _
   Optional ByVal ReturnAtFirstElement As Boolean = False _
) As Boolean
C#
private bool GetControl(
   Control BaseControl,
   string Key,
   ref List<Control> L,
   bool ReturnAtFirstElement
);
C++

private:
bool GetControl(
   Control^ BaseControl,
   String^ Key,
   List<Control^>^& L,
   bool ReturnAtFirstElement
)
JScript
JScript does not support generic types and methods.

Parameters

BaseControl

Base-Contrlo (z.B. aktuelles Formular

Key

Schlüssel welcher gesucht werden soll

L

Liste der gefundenen Objekte

ReturnAtFirstElement

Optional. The default value is False.

Return Value

True wenn eines oder mehr Controls gefunden wurden, false wenn kein Control gefunden wurde.

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Function GetControl(ByVal BaseControl As Control, ByVal Key As String, ByRef L As List(Of Control), Optional ByVal ReturnAtFirstElement As Boolean = False) As Boolean
        If L Is Nothing Then L = New List(Of Control)
        Dim Gut As Boolean
        Dim ReturnFlag As Boolean = False
        If Key IsNot Nothing Then Key = Key.ToLower

        If BaseControl.HasChildren = True Then
            For Each ctl As Control In BaseControl.Controls
                Gut = False
                If Key Is Nothing Then
                    Gut = True
                Else
                    If ctl.Name.Length >= Key.Length Then
                        Key = Key.ToLower
                        If Key.StartsWith("*") Then
                            If Key.Substring(1) = ctl.Name.ToLower.Substring(ctl.Name.Length - (Key.Length - 1), Key.Length - 1) Then Gut = True
                        ElseIf Key.EndsWith("*") Then
                            If Key.Substring(0, Key.Length - 1) = ctl.Name.ToLower.Substring(0, Key.Length - 1) Then Gut = True
                        Else
                            If Key = ctl.Name.ToLower Then Gut = True
                        End If
                    End If
                End If

                If Gut = True Then
                    L.Add(ctl)
                    If ReturnAtFirstElement = True Then ReturnFlag = True
                End If
                If ReturnFlag = False Then
                    Call GetControl(ctl, Key, L)
                End If
            Next
        End If

        If L.Count - 1 > -1 Then
            Return True
        Else
            Return False
        End If
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.Get_Data Method

frmVertragselement.Get_Data Method

Daten ab DB laden uns ins Form befüllen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Get_Data( _
   ByVal Vertragselementnr As Integer _
)
C#
private System.Void Get_Data(
   int Vertragselementnr
);
C++

private:
System::Void Get_Data(
   int Vertragselementnr
)
JScript
private function Get_Data(
    Vertragselementnr : int
);

Parameters

Vertragselementnr

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Get_Data(ByVal Vertragselementnr As Integer)
        Try
            Vertragselement.Get_Vertragselement(Vertragselementnr)
            Me.cbboxParentElement.Items.Clear()
            Me.cbboxParentElement.DataSource = Me.Vertragselement.Parentelemente.Load_Treedata(Me.Vertragselement.iVertragspartnerNr.Value)
            Me.cbboxParentElement.DisplayMember = "Bezeichnung"
            Me.cbboxParentElement.ValueMember = "Vertragselementnr"

            Me.txtVertragspartner.Text = Vertragselement.Vertragspartnername
            Me.Aktueller_Vertragspartner = Vertragselement.iVertragspartnerNr.Value
            Me.Aktuelles_Vertragselement = Vertragselement.iVertragselementnr.Value
            Me.cboxVertragstyp.SelectedValue = Vertragselement.iVertragstypNr.Value
            Me.cbboxParentElement.SelectedValue = Vertragselement.iParentID.Value
            Me.txtBezeichnung.Text = Vertragselement.sBezeichnung.ToString
            Me.txtVersion.Text = Vertragselement.sVersion.ToString
            Me.txtVertragsnummer.Text = Vertragselement.sNummer.ToString
            Me.txtVersion.Text = Vertragselement.sVersion.ToString
            Me.txtVersionsdatum.Text = Vertragselement.daVersionsdatum.ToString
            Me.txtVertragsbegin.Text = Vertragselement.daVertragsbeginn.ToString
            Me.txtVertragsende.Text = Vertragselement.daVertragsablauf.ToString
            Me.txtMindestvertragsdauerbis.Text = Vertragselement.daMindestvertragsdauer_bis.ToString
            Me.txtUnterzeichnetam.Text = Vertragselement.daUnterzeichnet_am.ToString
            Me.txtGekuendigtam.Text = Vertragselement.daGekuendigt_am.ToString
            Me.txtGekuendigtper.Text = Vertragselement.daGekuendigt_per.ToString
            Try
                Me.rbbefristet.Checked = Vertragselement.bBefristet_Unbefristet.Value = True
                If Me.rbbefristet.Checked = False Then Me.rbUnbefristet.Checked = True
            Catch
                Me.rbbefristet.Checked = False
                Me.rbUnbefristet.Checked = True
            End Try
            Me.txtErstelltam.Text = Vertragselement.daErstellt_am.ToString
            Me.txtMutiertam.Text = Vertragselement.daMutiert_am.ToString
            Me.txtMutierer.Text = Vertragselement.iMutierer.ToString
            Try
                Me.cbaktiv.Checked = Vertragselement.bAktiv.Value = True

            Catch ex As Exception
                Me.cbaktiv.Checked = True
            End Try
            Me.txtBeschreibung.Text = Vertragselement.sBeschreibung.ToString
            Me.txtSuchbegriffe.Text = Vertragselement.sSuchbegriffe.ToString
            Me.pnlStammdaten.Enabled = True
            Me.TabControlDiverse.Enabled = True
            If Not Anzeige Then
                For Each ctl As ToolStripButton In Me.ToolStrip1.Items
                    ctl.Enabled = True
                Next
            End If
            sec.Set_Form_Security(Me)
            Me.FormDataChanged = False
            Me.TabControlDiverse_SelectedIndexChanged(Nothing, Nothing)
        Catch ex As Exception
            Me.pnlStammdaten.Enabled = False
            Me.TabControlDiverse.Enabled = False
            For Each ctl As ToolStripButton In Me.ToolStrip1.Items
                ctl.Enabled = False
            Next
            Me.TSBtnQuit.Enabled = True
            Me.TSBtnSuche.Enabled = True
        End Try
        Me.FormDataChanged = False

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.InitializeComponent Method

frmVertragselement.InitializeComponent Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()
C#
[System.Diagnostics.DebuggerStepThrough()]
private System.Void InitializeComponent();
C++
[System.Diagnostics.DebuggerStepThrough()]

private:
System::Void InitializeComponent()
JScript
private
   System.Diagnostics.DebuggerStepThrough()
function InitializeComponent();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmVertragselement))
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStripMenuItem1 = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.TSBtnCopy = New System.Windows.Forms.ToolStripButton
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSuche = New System.Windows.Forms.ToolStripButton
        Me.pnlStammdaten = New System.Windows.Forms.Panel
        Me.dtPickerGekuendigtper = New System.Windows.Forms.DateTimePicker
        Me.dtPickerGekuendigtam = New System.Windows.Forms.DateTimePicker
        Me.dtPickerUnterzeichnetam = New System.Windows.Forms.DateTimePicker
        Me.dtPickerMindestvertragsdauerbis = New System.Windows.Forms.DateTimePicker
        Me.dtPickerVertragsende = New System.Windows.Forms.DateTimePicker
        Me.dtPickerVertragsbegin = New System.Windows.Forms.DateTimePicker
        Me.dtPickerVersionsdatum = New System.Windows.Forms.DateTimePicker
        Me.btnVertragspartnersuche = New System.Windows.Forms.Button
        Me.txtUnterzeichnetam = New System.Windows.Forms.MaskedTextBox
        Me.txtMindestvertragsdauerbis = New System.Windows.Forms.MaskedTextBox
        Me.txtVertragsende = New System.Windows.Forms.MaskedTextBox
        Me.txtVertragsbegin = New System.Windows.Forms.MaskedTextBox
        Me.txtGekuendigtper = New System.Windows.Forms.MaskedTextBox
        Me.txtGekuendigtam = New System.Windows.Forms.MaskedTextBox
        Me.txtVersionsdatum = New System.Windows.Forms.MaskedTextBox
        Me.lblVersionsdatum = New System.Windows.Forms.Label
        Me.cboxSecurityLevel = New System.Windows.Forms.ComboBox
        Me.lblSecurityLebel = New System.Windows.Forms.Label
        Me.rbUnbefristet = New System.Windows.Forms.RadioButton
        Me.rbbefristet = New System.Windows.Forms.RadioButton
        Me.lblAktiv = New System.Windows.Forms.Label
        Me.txtMutierer = New System.Windows.Forms.TextBox
        Me.txtMutiertam = New System.Windows.Forms.TextBox
        Me.txtErstelltam = New System.Windows.Forms.TextBox
        Me.lblMutierer = New System.Windows.Forms.Label
        Me.lblMutiertam = New System.Windows.Forms.Label
        Me.lblErstelltam = New System.Windows.Forms.Label
        Me.lblUnterzeichnetam = New System.Windows.Forms.Label
        Me.lblMindesvertragsdauer = New System.Windows.Forms.Label
        Me.lblGekuendigtper = New System.Windows.Forms.Label
        Me.lblGekuendigtam = New System.Windows.Forms.Label
        Me.txtBezeichnung = New System.Windows.Forms.TextBox
        Me.cbaktiv = New System.Windows.Forms.CheckBox
        Me.txtVertragsnummer = New System.Windows.Forms.TextBox
        Me.lblVertragsnummer = New System.Windows.Forms.Label
        Me.txtVersion = New System.Windows.Forms.TextBox
        Me.lblVersion = New System.Windows.Forms.Label
        Me.lblVertragsende = New System.Windows.Forms.Label
        Me.lblBezeichnung = New System.Windows.Forms.Label
        Me.lblVertragsbegin = New System.Windows.Forms.Label
        Me.lblParentElement = New System.Windows.Forms.Label
        Me.cbboxParentElement = New System.Windows.Forms.ComboBox
        Me.lblVertragstyp = New System.Windows.Forms.Label
        Me.cboxVertragstyp = New System.Windows.Forms.ComboBox
        Me.txtVertragspartner = New System.Windows.Forms.TextBox
        Me.lblVertragspartner = New System.Windows.Forms.Label
        Me.TabControlDiverse = New System.Windows.Forms.TabControl
        Me.TabVertragsinhalt = New System.Windows.Forms.TabPage
        Me.txtBeschreibung = New System.Windows.Forms.RichTextBox
        Me.TabSuchbegriffe = New System.Windows.Forms.TabPage
        Me.txtSuchbegriffe = New System.Windows.Forms.RichTextBox
        Me.TabKuendigungsfristen = New System.Windows.Forms.TabPage
        Me.C1Kuendigungsfristen = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.KuendigungsfristMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.KuendigungsfristBearbeitenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.KuendigungsfristNeuToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.KuendigungsfristLöschenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TabKontakte = New System.Windows.Forms.TabPage
        Me.C1Kontakte = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.KontakteMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.KontaktAnzeigenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.KontaktNeuToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.KontaktLöschenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.Kontaktlist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.TabServices = New System.Windows.Forms.TabPage
        Me.TabEreignisse = New System.Windows.Forms.TabPage
        Me.TabAktivitäten = New System.Windows.Forms.TabPage
        Me.TabPendenzen = New System.Windows.Forms.TabPage
        Me.TabAblageorte = New System.Windows.Forms.TabPage
        Me.TabReferenzvertraege = New System.Windows.Forms.TabPage
        Me.TabHistory = New System.Windows.Forms.TabPage
        Me.C1Services = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.pnlStammdaten.SuspendLayout()
        Me.TabControlDiverse.SuspendLayout()
        Me.TabVertragsinhalt.SuspendLayout()
        Me.TabSuchbegriffe.SuspendLayout()
        Me.TabKuendigungsfristen.SuspendLayout()
        CType(Me.C1Kuendigungsfristen, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.KuendigungsfristMenuStrip.SuspendLayout()
        Me.TabKontakte.SuspendLayout()
        CType(Me.C1Kontakte, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.KontakteMenuStrip.SuspendLayout()
        CType(Me.Kontaktlist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabServices.SuspendLayout()
        CType(Me.C1Services, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(127, 22)
        Me.BeendenToolStripMenuItem.Tag = ""
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(675, 24)
        Me.MenuStrip1.TabIndex = 4
        Me.MenuStrip1.Tag = ""
        Me.MenuStrip1.Text = "Hauptmenu"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.ToolStripMenuItem1})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Tag = ""
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'ToolStripMenuItem1
        '
        Me.ToolStripMenuItem1.Name = "ToolStripMenuItem1"
        Me.ToolStripMenuItem1.Size = New System.Drawing.Size(116, 22)
        Me.ToolStripMenuItem1.Tag = ""
        Me.ToolStripMenuItem1.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnCopy, Me.TSBtnNew, Me.TSBtnDelete, Me.TSBtnSuche})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(675, 25)
        Me.ToolStrip1.TabIndex = 5
        Me.ToolStrip1.Text = "Toolstrip Vertragspartner"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "Daten speichern"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'TSBtnCopy
        '
        Me.TSBtnCopy.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnCopy.Image = CType(resources.GetObject("TSBtnCopy.Image"), System.Drawing.Image)
        Me.TSBtnCopy.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnCopy.Name = "TSBtnCopy"
        Me.TSBtnCopy.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnCopy.Text = "Datensatz kopieren"
        Me.TSBtnCopy.ToolTipText = "Datensatz kopieren"
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "Neuer Datensatz"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "Datensatz inaktivieren"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'TSBtnSuche
        '
        Me.TSBtnSuche.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSuche.Image = CType(resources.GetObject("TSBtnSuche.Image"), System.Drawing.Image)
        Me.TSBtnSuche.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSuche.Name = "TSBtnSuche"
        Me.TSBtnSuche.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSuche.Text = "ToolStripButton1"
        '
        'pnlStammdaten
        '
        Me.pnlStammdaten.Controls.Add(Me.dtPickerGekuendigtper)
        Me.pnlStammdaten.Controls.Add(Me.dtPickerGekuendigtam)
        Me.pnlStammdaten.Controls.Add(Me.dtPickerUnterzeichnetam)
        Me.pnlStammdaten.Controls.Add(Me.dtPickerMindestvertragsdauerbis)
        Me.pnlStammdaten.Controls.Add(Me.dtPickerVertragsende)
        Me.pnlStammdaten.Controls.Add(Me.dtPickerVertragsbegin)
        Me.pnlStammdaten.Controls.Add(Me.dtPickerVersionsdatum)
        Me.pnlStammdaten.Controls.Add(Me.btnVertragspartnersuche)
        Me.pnlStammdaten.Controls.Add(Me.txtUnterzeichnetam)
        Me.pnlStammdaten.Controls.Add(Me.txtMindestvertragsdauerbis)
        Me.pnlStammdaten.Controls.Add(Me.txtVertragsende)
        Me.pnlStammdaten.Controls.Add(Me.txtVertragsbegin)
        Me.pnlStammdaten.Controls.Add(Me.txtGekuendigtper)
        Me.pnlStammdaten.Controls.Add(Me.txtGekuendigtam)
        Me.pnlStammdaten.Controls.Add(Me.txtVersionsdatum)
        Me.pnlStammdaten.Controls.Add(Me.lblVersionsdatum)
        Me.pnlStammdaten.Controls.Add(Me.cboxSecurityLevel)
        Me.pnlStammdaten.Controls.Add(Me.lblSecurityLebel)
        Me.pnlStammdaten.Controls.Add(Me.rbUnbefristet)
        Me.pnlStammdaten.Controls.Add(Me.rbbefristet)
        Me.pnlStammdaten.Controls.Add(Me.lblAktiv)
        Me.pnlStammdaten.Controls.Add(Me.txtMutierer)
        Me.pnlStammdaten.Controls.Add(Me.txtMutiertam)
        Me.pnlStammdaten.Controls.Add(Me.txtErstelltam)
        Me.pnlStammdaten.Controls.Add(Me.lblMutierer)
        Me.pnlStammdaten.Controls.Add(Me.lblMutiertam)
        Me.pnlStammdaten.Controls.Add(Me.lblErstelltam)
        Me.pnlStammdaten.Controls.Add(Me.lblUnterzeichnetam)
        Me.pnlStammdaten.Controls.Add(Me.lblMindesvertragsdauer)
        Me.pnlStammdaten.Controls.Add(Me.lblGekuendigtper)
        Me.pnlStammdaten.Controls.Add(Me.lblGekuendigtam)
        Me.pnlStammdaten.Controls.Add(Me.txtBezeichnung)
        Me.pnlStammdaten.Controls.Add(Me.cbaktiv)
        Me.pnlStammdaten.Controls.Add(Me.txtVertragsnummer)
        Me.pnlStammdaten.Controls.Add(Me.lblVertragsnummer)
        Me.pnlStammdaten.Controls.Add(Me.txtVersion)
        Me.pnlStammdaten.Controls.Add(Me.lblVersion)
        Me.pnlStammdaten.Controls.Add(Me.lblVertragsende)
        Me.pnlStammdaten.Controls.Add(Me.lblBezeichnung)
        Me.pnlStammdaten.Controls.Add(Me.lblVertragsbegin)
        Me.pnlStammdaten.Controls.Add(Me.lblParentElement)
        Me.pnlStammdaten.Controls.Add(Me.cbboxParentElement)
        Me.pnlStammdaten.Controls.Add(Me.lblVertragstyp)
        Me.pnlStammdaten.Controls.Add(Me.cboxVertragstyp)
        Me.pnlStammdaten.Controls.Add(Me.txtVertragspartner)
        Me.pnlStammdaten.Controls.Add(Me.lblVertragspartner)
        Me.pnlStammdaten.Dock = System.Windows.Forms.DockStyle.Top
        Me.pnlStammdaten.Location = New System.Drawing.Point(0, 49)
        Me.pnlStammdaten.Name = "pnlStammdaten"
        Me.pnlStammdaten.Size = New System.Drawing.Size(675, 284)
        Me.pnlStammdaten.TabIndex = 6
        '
        'dtPickerGekuendigtper
        '
        Me.dtPickerGekuendigtper.Location = New System.Drawing.Point(393, 200)
        Me.dtPickerGekuendigtper.Name = "dtPickerGekuendigtper"
        Me.dtPickerGekuendigtper.Size = New System.Drawing.Size(21, 20)
        Me.dtPickerGekuendigtper.TabIndex = 112
        '
        'dtPickerGekuendigtam
        '
        Me.dtPickerGekuendigtam.Location = New System.Drawing.Point(393, 177)
        Me.dtPickerGekuendigtam.Name = "dtPickerGekuendigtam"
        Me.dtPickerGekuendigtam.Size = New System.Drawing.Size(21, 20)
        Me.dtPickerGekuendigtam.TabIndex = 111
        '
        'dtPickerUnterzeichnetam
        '
        Me.dtPickerUnterzeichnetam.Location = New System.Drawing.Point(209, 247)
        Me.dtPickerUnterzeichnetam.Name = "dtPickerUnterzeichnetam"
        Me.dtPickerUnterzeichnetam.Size = New System.Drawing.Size(21, 20)
        Me.dtPickerUnterzeichnetam.TabIndex = 110
        '
        'dtPickerMindestvertragsdauerbis
        '
        Me.dtPickerMindestvertragsdauerbis.Location = New System.Drawing.Point(209, 226)
        Me.dtPickerMindestvertragsdauerbis.Name = "dtPickerMindestvertragsdauerbis"
        Me.dtPickerMindestvertragsdauerbis.Size = New System.Drawing.Size(21, 20)
        Me.dtPickerMindestvertragsdauerbis.TabIndex = 109
        '
        'dtPickerVertragsende
        '
        Me.dtPickerVertragsende.Location = New System.Drawing.Point(209, 200)
        Me.dtPickerVertragsende.Name = "dtPickerVertragsende"
        Me.dtPickerVertragsende.Size = New System.Drawing.Size(21, 20)
        Me.dtPickerVertragsende.TabIndex = 108
        '
        'dtPickerVertragsbegin
        '
        Me.dtPickerVertragsbegin.Location = New System.Drawing.Point(209, 174)
        Me.dtPickerVertragsbegin.Name = "dtPickerVertragsbegin"
        Me.dtPickerVertragsbegin.Size = New System.Drawing.Size(21, 20)
        Me.dtPickerVertragsbegin.TabIndex = 107
        '
        'dtPickerVersionsdatum
        '
        Me.dtPickerVersionsdatum.Location = New System.Drawing.Point(393, 146)
        Me.dtPickerVersionsdatum.Name = "dtPickerVersionsdatum"
        Me.dtPickerVersionsdatum.Size = New System.Drawing.Size(21, 20)
        Me.dtPickerVersionsdatum.TabIndex = 106
        '
        'btnVertragspartnersuche
        '
        Me.btnVertragspartnersuche.Image = CType(resources.GetObject("btnVertragspartnersuche.Image"), System.Drawing.Image)
        Me.btnVertragspartnersuche.Location = New System.Drawing.Point(411, 15)
        Me.btnVertragspartnersuche.Name = "btnVertragspartnersuche"
        Me.btnVertragspartnersuche.Size = New System.Drawing.Size(20, 20)
        Me.btnVertragspartnersuche.TabIndex = 105
        Me.btnVertragspartnersuche.Text = "Button1"
        Me.btnVertragspartnersuche.UseVisualStyleBackColor = True
        '
        'txtUnterzeichnetam
        '
        Me.txtUnterzeichnetam.Location = New System.Drawing.Point(146, 248)
        Me.txtUnterzeichnetam.Mask = "00/00/0000"
        Me.txtUnterzeichnetam.Name = "txtUnterzeichnetam"
        Me.txtUnterzeichnetam.Size = New System.Drawing.Size(66, 20)
        Me.txtUnterzeichnetam.TabIndex = 12
        Me.txtUnterzeichnetam.ValidatingType = GetType(Date)
        '
        'txtMindestvertragsdauerbis
        '
        Me.txtMindestvertragsdauerbis.Location = New System.Drawing.Point(146, 226)
        Me.txtMindestvertragsdauerbis.Mask = "00/00/0000"
        Me.txtMindestvertragsdauerbis.Name = "txtMindestvertragsdauerbis"
        Me.txtMindestvertragsdauerbis.Size = New System.Drawing.Size(66, 20)
        Me.txtMindestvertragsdauerbis.TabIndex = 11
        Me.txtMindestvertragsdauerbis.ValidatingType = GetType(Date)
        '
        'txtVertragsende
        '
        Me.txtVertragsende.Location = New System.Drawing.Point(146, 200)
        Me.txtVertragsende.Mask = "00/00/0000"
        Me.txtVertragsende.Name = "txtVertragsende"
        Me.txtVertragsende.Size = New System.Drawing.Size(66, 20)
        Me.txtVertragsende.TabIndex = 8
        Me.txtVertragsende.ValidatingType = GetType(Date)
        '
        'txtVertragsbegin
        '
        Me.txtVertragsbegin.Location = New System.Drawing.Point(146, 174)
        Me.txtVertragsbegin.Mask = "00/00/0000"
        Me.txtVertragsbegin.Name = "txtVertragsbegin"
        Me.txtVertragsbegin.Size = New System.Drawing.Size(66, 20)
        Me.txtVertragsbegin.TabIndex = 7
        Me.txtVertragsbegin.ValidatingType = GetType(Date)
        '
        'txtGekuendigtper
        '
        Me.txtGekuendigtper.Location = New System.Drawing.Point(330, 200)
        Me.txtGekuendigtper.Mask = "00/00/0000"
        Me.txtGekuendigtper.Name = "txtGekuendigtper"
        Me.txtGekuendigtper.Size = New System.Drawing.Size(66, 20)
        Me.txtGekuendigtper.TabIndex = 10
        Me.txtGekuendigtper.ValidatingType = GetType(Date)
        '
        'txtGekuendigtam
        '
        Me.txtGekuendigtam.Location = New System.Drawing.Point(330, 177)
        Me.txtGekuendigtam.Mask = "00/00/0000"
        Me.txtGekuendigtam.Name = "txtGekuendigtam"
        Me.txtGekuendigtam.Size = New System.Drawing.Size(66, 20)
        Me.txtGekuendigtam.TabIndex = 9
        Me.txtGekuendigtam.ValidatingType = GetType(Date)
        '
        'txtVersionsdatum
        '
        Me.txtVersionsdatum.Location = New System.Drawing.Point(330, 146)
        Me.txtVersionsdatum.Mask = "00/00/0000"
        Me.txtVersionsdatum.Name = "txtVersionsdatum"
        Me.txtVersionsdatum.Size = New System.Drawing.Size(66, 20)
        Me.txtVersionsdatum.TabIndex = 6
        Me.txtVersionsdatum.ValidatingType = GetType(Date)
        '
        'lblVersionsdatum
        '
        Me.lblVersionsdatum.AutoSize = True
        Me.lblVersionsdatum.Location = New System.Drawing.Point(247, 150)
        Me.lblVersionsdatum.Name = "lblVersionsdatum"
        Me.lblVersionsdatum.Size = New System.Drawing.Size(76, 13)
        Me.lblVersionsdatum.TabIndex = 6
        Me.lblVersionsdatum.Text = "Versionsdatum"
        '
        'cboxSecurityLevel
        '
        Me.cboxSecurityLevel.FormattingEnabled = True
        Me.cboxSecurityLevel.Location = New System.Drawing.Point(566, 121)
        Me.cboxSecurityLevel.Name = "cboxSecurityLevel"
        Me.cboxSecurityLevel.Size = New System.Drawing.Size(101, 21)
        Me.cboxSecurityLevel.TabIndex = 16
        '
        'lblSecurityLebel
        '
        Me.lblSecurityLebel.AutoSize = True
        Me.lblSecurityLebel.Location = New System.Drawing.Point(489, 124)
        Me.lblSecurityLebel.Name = "lblSecurityLebel"
        Me.lblSecurityLebel.Size = New System.Drawing.Size(71, 13)
        Me.lblSecurityLebel.TabIndex = 104
        Me.lblSecurityLebel.Text = "SecurityLevel"
        '
        'rbUnbefristet
        '
        Me.rbUnbefristet.AutoSize = True
        Me.rbUnbefristet.Location = New System.Drawing.Point(249, 255)
        Me.rbUnbefristet.Name = "rbUnbefristet"
        Me.rbUnbefristet.Size = New System.Drawing.Size(76, 17)
        Me.rbUnbefristet.TabIndex = 14
        Me.rbUnbefristet.TabStop = True
        Me.rbUnbefristet.Text = "Unbefristet"
        Me.rbUnbefristet.UseVisualStyleBackColor = True
        '
        'rbbefristet
        '
        Me.rbbefristet.AutoSize = True
        Me.rbbefristet.Location = New System.Drawing.Point(249, 229)
        Me.rbbefristet.Name = "rbbefristet"
        Me.rbbefristet.Size = New System.Drawing.Size(63, 17)
        Me.rbbefristet.TabIndex = 13
        Me.rbbefristet.TabStop = True
        Me.rbbefristet.Text = "Befristet"
        Me.rbbefristet.UseVisualStyleBackColor = True
        '
        'lblAktiv
        '
        Me.lblAktiv.AccessibleDescription = "Name"
        Me.lblAktiv.AutoSize = True
        Me.lblAktiv.Location = New System.Drawing.Point(489, 95)
        Me.lblAktiv.Name = "lblAktiv"
        Me.lblAktiv.Size = New System.Drawing.Size(31, 13)
        Me.lblAktiv.TabIndex = 100
        Me.lblAktiv.Text = "Aktiv"
        '
        'txtMutierer
        '
        Me.txtMutierer.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutierer.Location = New System.Drawing.Point(567, 64)
        Me.txtMutierer.Name = "txtMutierer"
        Me.txtMutierer.Size = New System.Drawing.Size(78, 20)
        Me.txtMutierer.TabIndex = 99
        '
        'txtMutiertam
        '
        Me.txtMutiertam.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutiertam.Location = New System.Drawing.Point(566, 41)
        Me.txtMutiertam.Name = "txtMutiertam"
        Me.txtMutiertam.Size = New System.Drawing.Size(79, 20)
        Me.txtMutiertam.TabIndex = 98
        '
        'txtErstelltam
        '
        Me.txtErstelltam.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtErstelltam.Location = New System.Drawing.Point(566, 17)
        Me.txtErstelltam.Name = "txtErstelltam"
        Me.txtErstelltam.Size = New System.Drawing.Size(79, 20)
        Me.txtErstelltam.TabIndex = 97
        '
        'lblMutierer
        '
        Me.lblMutierer.AccessibleDescription = "Name"
        Me.lblMutierer.AutoSize = True
        Me.lblMutierer.Location = New System.Drawing.Point(488, 68)
        Me.lblMutierer.Name = "lblMutierer"
        Me.lblMutierer.Size = New System.Drawing.Size(69, 13)
        Me.lblMutierer.TabIndex = 96
        Me.lblMutierer.Text = "Mutiert durch"
        '
        'lblMutiertam
        '
        Me.lblMutiertam.AccessibleDescription = "Name"
        Me.lblMutiertam.AutoSize = True
        Me.lblMutiertam.Location = New System.Drawing.Point(488, 45)
        Me.lblMutiertam.Name = "lblMutiertam"
        Me.lblMutiertam.Size = New System.Drawing.Size(56, 13)
        Me.lblMutiertam.TabIndex = 95
        Me.lblMutiertam.Text = "Mutiert am"
        '
        'lblErstelltam
        '
        Me.lblErstelltam.AccessibleDescription = "Name"
        Me.lblErstelltam.AutoSize = True
        Me.lblErstelltam.Location = New System.Drawing.Point(489, 20)
        Me.lblErstelltam.Name = "lblErstelltam"
        Me.lblErstelltam.Size = New System.Drawing.Size(55, 13)
        Me.lblErstelltam.TabIndex = 94
        Me.lblErstelltam.Text = "Erstellt am"
        '
        'lblUnterzeichnetam
        '
        Me.lblUnterzeichnetam.AutoSize = True
        Me.lblUnterzeichnetam.Location = New System.Drawing.Point(15, 251)
        Me.lblUnterzeichnetam.Name = "lblUnterzeichnetam"
        Me.lblUnterzeichnetam.Size = New System.Drawing.Size(90, 13)
        Me.lblUnterzeichnetam.TabIndex = 93
        Me.lblUnterzeichnetam.Text = "Unterzeichnet am"
        '
        'lblMindesvertragsdauer
        '
        Me.lblMindesvertragsdauer.AutoSize = True
        Me.lblMindesvertragsdauer.Location = New System.Drawing.Point(15, 229)
        Me.lblMindesvertragsdauer.Name = "lblMindesvertragsdauer"
        Me.lblMindesvertragsdauer.Size = New System.Drawing.Size(125, 13)
        Me.lblMindesvertragsdauer.TabIndex = 91
        Me.lblMindesvertragsdauer.Text = "Mindestvertragsdauer bis"
        '
        'lblGekuendigtper
        '
        Me.lblGekuendigtper.AutoSize = True
        Me.lblGekuendigtper.Location = New System.Drawing.Point(246, 203)
        Me.lblGekuendigtper.Name = "lblGekuendigtper"
        Me.lblGekuendigtper.Size = New System.Drawing.Size(74, 13)
        Me.lblGekuendigtper.TabIndex = 89
        Me.lblGekuendigtper.Text = "Gekündigt per"
        '
        'lblGekuendigtam
        '
        Me.lblGekuendigtam.AutoSize = True
        Me.lblGekuendigtam.Location = New System.Drawing.Point(246, 177)
        Me.lblGekuendigtam.Name = "lblGekuendigtam"
        Me.lblGekuendigtam.Size = New System.Drawing.Size(73, 13)
        Me.lblGekuendigtam.TabIndex = 87
        Me.lblGekuendigtam.Text = "Gekündigt am"
        '
        'txtBezeichnung
        '
        Me.txtBezeichnung.Location = New System.Drawing.Point(146, 94)
        Me.txtBezeichnung.Name = "txtBezeichnung"
        Me.txtBezeichnung.Size = New System.Drawing.Size(268, 20)
        Me.txtBezeichnung.TabIndex = 3
        '
        'cbaktiv
        '
        Me.cbaktiv.AutoSize = True
        Me.cbaktiv.Location = New System.Drawing.Point(566, 95)
        Me.cbaktiv.Name = "cbaktiv"
        Me.cbaktiv.Size = New System.Drawing.Size(15, 14)
        Me.cbaktiv.TabIndex = 15
        Me.cbaktiv.UseVisualStyleBackColor = True
        '
        'txtVertragsnummer
        '
        Me.txtVertragsnummer.Location = New System.Drawing.Point(146, 121)
        Me.txtVertragsnummer.Name = "txtVertragsnummer"
        Me.txtVertragsnummer.Size = New System.Drawing.Size(268, 20)
        Me.txtVertragsnummer.TabIndex = 4
        '
        'lblVertragsnummer
        '
        Me.lblVertragsnummer.AutoSize = True
        Me.lblVertragsnummer.Location = New System.Drawing.Point(15, 121)
        Me.lblVertragsnummer.Name = "lblVertragsnummer"
        Me.lblVertragsnummer.Size = New System.Drawing.Size(83, 13)
        Me.lblVertragsnummer.TabIndex = 82
        Me.lblVertragsnummer.Text = "Vertragsnummer"
        '
        'txtVersion
        '
        Me.txtVersion.Location = New System.Drawing.Point(146, 147)
        Me.txtVersion.Name = "txtVersion"
        Me.txtVersion.Size = New System.Drawing.Size(84, 20)
        Me.txtVersion.TabIndex = 5
        '
        'lblVersion
        '
        Me.lblVersion.AutoSize = True
        Me.lblVersion.Location = New System.Drawing.Point(15, 147)
        Me.lblVersion.Name = "lblVersion"
        Me.lblVersion.Size = New System.Drawing.Size(42, 13)
        Me.lblVersion.TabIndex = 80
        Me.lblVersion.Text = "Version"
        '
        'lblVertragsende
        '
        Me.lblVertragsende.AutoSize = True
        Me.lblVertragsende.Location = New System.Drawing.Point(15, 203)
        Me.lblVertragsende.Name = "lblVertragsende"
        Me.lblVertragsende.Size = New System.Drawing.Size(70, 13)
        Me.lblVertragsende.TabIndex = 79
        Me.lblVertragsende.Text = "Vertragsende"
        '
        'lblBezeichnung
        '
        Me.lblBezeichnung.AutoSize = True
        Me.lblBezeichnung.Location = New System.Drawing.Point(15, 94)
        Me.lblBezeichnung.Name = "lblBezeichnung"
        Me.lblBezeichnung.Size = New System.Drawing.Size(69, 13)
        Me.lblBezeichnung.TabIndex = 77
        Me.lblBezeichnung.Text = "Bezeichnung"
        '
        'lblVertragsbegin
        '
        Me.lblVertragsbegin.AutoSize = True
        Me.lblVertragsbegin.Location = New System.Drawing.Point(15, 177)
        Me.lblVertragsbegin.Name = "lblVertragsbegin"
        Me.lblVertragsbegin.Size = New System.Drawing.Size(72, 13)
        Me.lblVertragsbegin.TabIndex = 76
        Me.lblVertragsbegin.Text = "Vertragsbegin"
        '
        'lblParentElement
        '
        Me.lblParentElement.AutoSize = True
        Me.lblParentElement.Location = New System.Drawing.Point(15, 70)
        Me.lblParentElement.Name = "lblParentElement"
        Me.lblParentElement.Size = New System.Drawing.Size(122, 13)
        Me.lblParentElement.TabIndex = 74
        Me.lblParentElement.Text = "übergeordnetes Element"
        '
        'cbboxParentElement
        '
        Me.cbboxParentElement.FormattingEnabled = True
        Me.cbboxParentElement.Location = New System.Drawing.Point(146, 67)
        Me.cbboxParentElement.Name = "cbboxParentElement"
        Me.cbboxParentElement.Size = New System.Drawing.Size(268, 21)
        Me.cbboxParentElement.TabIndex = 2
        '
        'lblVertragstyp
        '
        Me.lblVertragstyp.AutoSize = True
        Me.lblVertragstyp.Location = New System.Drawing.Point(15, 40)
        Me.lblVertragstyp.Name = "lblVertragstyp"
        Me.lblVertragstyp.Size = New System.Drawing.Size(60, 13)
        Me.lblVertragstyp.TabIndex = 72
        Me.lblVertragstyp.Text = "Vertragstyp"
        '
        'cboxVertragstyp
        '
        Me.cboxVertragstyp.FormattingEnabled = True
        Me.cboxVertragstyp.Location = New System.Drawing.Point(146, 40)
        Me.cboxVertragstyp.Name = "cboxVertragstyp"
        Me.cboxVertragstyp.Size = New System.Drawing.Size(268, 21)
        Me.cboxVertragstyp.TabIndex = 1
        '
        'txtVertragspartner
        '
        Me.txtVertragspartner.Location = New System.Drawing.Point(146, 14)
        Me.txtVertragspartner.Name = "txtVertragspartner"
        Me.txtVertragspartner.Size = New System.Drawing.Size(268, 20)
        Me.txtVertragspartner.TabIndex = 0
        '
        'lblVertragspartner
        '
        Me.lblVertragspartner.AutoSize = True
        Me.lblVertragspartner.Location = New System.Drawing.Point(15, 14)
        Me.lblVertragspartner.Name = "lblVertragspartner"
        Me.lblVertragspartner.Size = New System.Drawing.Size(79, 13)
        Me.lblVertragspartner.TabIndex = 67
        Me.lblVertragspartner.Text = "Vertragspartner"
        '
        'TabControlDiverse
        '
        Me.TabControlDiverse.Controls.Add(Me.TabVertragsinhalt)
        Me.TabControlDiverse.Controls.Add(Me.TabSuchbegriffe)
        Me.TabControlDiverse.Controls.Add(Me.TabKuendigungsfristen)
        Me.TabControlDiverse.Controls.Add(Me.TabKontakte)
        Me.TabControlDiverse.Controls.Add(Me.TabServices)
        Me.TabControlDiverse.Controls.Add(Me.TabEreignisse)
        Me.TabControlDiverse.Controls.Add(Me.TabAktivitäten)
        Me.TabControlDiverse.Controls.Add(Me.TabPendenzen)
        Me.TabControlDiverse.Controls.Add(Me.TabAblageorte)
        Me.TabControlDiverse.Controls.Add(Me.TabReferenzvertraege)
        Me.TabControlDiverse.Controls.Add(Me.TabHistory)
        Me.TabControlDiverse.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TabControlDiverse.Location = New System.Drawing.Point(0, 333)
        Me.TabControlDiverse.Name = "TabControlDiverse"
        Me.TabControlDiverse.SelectedIndex = 0
        Me.TabControlDiverse.Size = New System.Drawing.Size(675, 182)
        Me.TabControlDiverse.TabIndex = 24
        '
        'TabVertragsinhalt
        '
        Me.TabVertragsinhalt.Controls.Add(Me.txtBeschreibung)
        Me.TabVertragsinhalt.Location = New System.Drawing.Point(4, 22)
        Me.TabVertragsinhalt.Name = "TabVertragsinhalt"
        Me.TabVertragsinhalt.Size = New System.Drawing.Size(667, 156)
        Me.TabVertragsinhalt.TabIndex = 6
        Me.TabVertragsinhalt.Text = "Vertragsinhalt"
        Me.TabVertragsinhalt.UseVisualStyleBackColor = True
        '
        'txtBeschreibung
        '
        Me.txtBeschreibung.Dock = System.Windows.Forms.DockStyle.Fill
        Me.txtBeschreibung.Location = New System.Drawing.Point(0, 0)
        Me.txtBeschreibung.Name = "txtBeschreibung"
        Me.txtBeschreibung.Size = New System.Drawing.Size(667, 156)
        Me.txtBeschreibung.TabIndex = 29
        Me.txtBeschreibung.Text = ""
        '
        'TabSuchbegriffe
        '
        Me.TabSuchbegriffe.Controls.Add(Me.txtSuchbegriffe)
        Me.TabSuchbegriffe.Location = New System.Drawing.Point(4, 22)
        Me.TabSuchbegriffe.Name = "TabSuchbegriffe"
        Me.TabSuchbegriffe.Size = New System.Drawing.Size(667, 156)
        Me.TabSuchbegriffe.TabIndex = 7
        Me.TabSuchbegriffe.Text = "Suchbegriffe"
        Me.TabSuchbegriffe.UseVisualStyleBackColor = True
        '
        'txtSuchbegriffe
        '
        Me.txtSuchbegriffe.Dock = System.Windows.Forms.DockStyle.Fill
        Me.txtSuchbegriffe.Location = New System.Drawing.Point(0, 0)
        Me.txtSuchbegriffe.Name = "txtSuchbegriffe"
        Me.txtSuchbegriffe.Size = New System.Drawing.Size(667, 156)
        Me.txtSuchbegriffe.TabIndex = 30
        Me.txtSuchbegriffe.Text = ""
        '
        'TabKuendigungsfristen
        '
        Me.TabKuendigungsfristen.Controls.Add(Me.C1Kuendigungsfristen)
        Me.TabKuendigungsfristen.Location = New System.Drawing.Point(4, 22)
        Me.TabKuendigungsfristen.Name = "TabKuendigungsfristen"
        Me.TabKuendigungsfristen.Size = New System.Drawing.Size(667, 156)
        Me.TabKuendigungsfristen.TabIndex = 10
        Me.TabKuendigungsfristen.Text = "Kündigungsfristen"
        Me.TabKuendigungsfristen.UseVisualStyleBackColor = True
        '
        'C1Kuendigungsfristen
        '
        Me.C1Kuendigungsfristen.AlternatingRows = True
        Me.C1Kuendigungsfristen.ContextMenuStrip = Me.KuendigungsfristMenuStrip
        Me.C1Kuendigungsfristen.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Kuendigungsfristen.FilterBar = True
        Me.C1Kuendigungsfristen.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Kuendigungsfristen.Images.Add(CType(resources.GetObject("C1Kuendigungsfristen.Images"), System.Drawing.Image))
        Me.C1Kuendigungsfristen.Location = New System.Drawing.Point(0, 0)
        Me.C1Kuendigungsfristen.Name = "C1Kuendigungsfristen"
        Me.C1Kuendigungsfristen.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Kuendigungsfristen.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Kuendigungsfristen.PreviewInfo.ZoomFactor = 75
        Me.C1Kuendigungsfristen.PrintInfo.PageSettings = CType(resources.GetObject("C1Kuendigungsfristen.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Kuendigungsfristen.Size = New System.Drawing.Size(667, 156)
        Me.C1Kuendigungsfristen.TabIndex = 3
        Me.C1Kuendigungsfristen.Text = "C1Kuendigungsfristen"
        Me.C1Kuendigungsfristen.PropBag = resources.GetString("C1Kuendigungsfristen.PropBag")
        '
        'KuendigungsfristMenuStrip
        '
        Me.KuendigungsfristMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.KuendigungsfristBearbeitenToolStripMenuItem, Me.KuendigungsfristNeuToolStripMenuItem, Me.KuendigungsfristLöschenToolStripMenuItem})
        Me.KuendigungsfristMenuStrip.Name = "KuendigungsfristMenuStrip"
        Me.KuendigungsfristMenuStrip.Size = New System.Drawing.Size(132, 70)
        '
        'KuendigungsfristBearbeitenToolStripMenuItem
        '
        Me.KuendigungsfristBearbeitenToolStripMenuItem.Name = "KuendigungsfristBearbeitenToolStripMenuItem"
        Me.KuendigungsfristBearbeitenToolStripMenuItem.Size = New System.Drawing.Size(131, 22)
        Me.KuendigungsfristBearbeitenToolStripMenuItem.Text = "&Anzeigen"
        '
        'KuendigungsfristNeuToolStripMenuItem
        '
        Me.KuendigungsfristNeuToolStripMenuItem.Name = "KuendigungsfristNeuToolStripMenuItem"
        Me.KuendigungsfristNeuToolStripMenuItem.Size = New System.Drawing.Size(131, 22)
        Me.KuendigungsfristNeuToolStripMenuItem.Text = "&Neu"
        '
        'KuendigungsfristLöschenToolStripMenuItem
        '
        Me.KuendigungsfristLöschenToolStripMenuItem.Name = "KuendigungsfristLöschenToolStripMenuItem"
        Me.KuendigungsfristLöschenToolStripMenuItem.Size = New System.Drawing.Size(131, 22)
        Me.KuendigungsfristLöschenToolStripMenuItem.Text = "&Inaktivieren"
        '
        'TabKontakte
        '
        Me.TabKontakte.Controls.Add(Me.C1Kontakte)
        Me.TabKontakte.Controls.Add(Me.Kontaktlist)
        Me.TabKontakte.Location = New System.Drawing.Point(4, 22)
        Me.TabKontakte.Name = "TabKontakte"
        Me.TabKontakte.Padding = New System.Windows.Forms.Padding(3)
        Me.TabKontakte.Size = New System.Drawing.Size(667, 156)
        Me.TabKontakte.TabIndex = 0
        Me.TabKontakte.Text = "Kontakte"
        Me.TabKontakte.UseVisualStyleBackColor = True
        '
        'C1Kontakte
        '
        Me.C1Kontakte.AlternatingRows = True
        Me.C1Kontakte.ContextMenuStrip = Me.KontakteMenuStrip
        Me.C1Kontakte.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Kontakte.FilterBar = True
        Me.C1Kontakte.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Kontakte.Images.Add(CType(resources.GetObject("C1Kontakte.Images"), System.Drawing.Image))
        Me.C1Kontakte.Location = New System.Drawing.Point(3, 3)
        Me.C1Kontakte.Name = "C1Kontakte"
        Me.C1Kontakte.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Kontakte.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Kontakte.PreviewInfo.ZoomFactor = 75
        Me.C1Kontakte.PrintInfo.PageSettings = CType(resources.GetObject("C1Kontakte.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Kontakte.Size = New System.Drawing.Size(661, 150)
        Me.C1Kontakte.TabIndex = 4
        Me.C1Kontakte.Text = "C1TrueDBGrid1"
        Me.C1Kontakte.PropBag = resources.GetString("C1Kontakte.PropBag")
        '
        'KontakteMenuStrip
        '
        Me.KontakteMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.KontaktAnzeigenToolStripMenuItem, Me.KontaktNeuToolStripMenuItem, Me.KontaktLöschenToolStripMenuItem})
        Me.KontakteMenuStrip.Name = "KuendigungsfristMenuStrip"
        Me.KontakteMenuStrip.Size = New System.Drawing.Size(132, 70)
        '
        'KontaktAnzeigenToolStripMenuItem
        '
        Me.KontaktAnzeigenToolStripMenuItem.Name = "KontaktAnzeigenToolStripMenuItem"
        Me.KontaktAnzeigenToolStripMenuItem.Size = New System.Drawing.Size(131, 22)
        Me.KontaktAnzeigenToolStripMenuItem.Text = "&Anzeigen"
        '
        'KontaktNeuToolStripMenuItem
        '
        Me.KontaktNeuToolStripMenuItem.Name = "KontaktNeuToolStripMenuItem"
        Me.KontaktNeuToolStripMenuItem.Size = New System.Drawing.Size(131, 22)
        Me.KontaktNeuToolStripMenuItem.Text = "&Neu"
        '
        'KontaktLöschenToolStripMenuItem
        '
        Me.KontaktLöschenToolStripMenuItem.Name = "KontaktLöschenToolStripMenuItem"
        Me.KontaktLöschenToolStripMenuItem.Size = New System.Drawing.Size(131, 22)
        Me.KontaktLöschenToolStripMenuItem.Text = "&Inaktivieren"
        '
        'Kontaktlist
        '
        Me.Kontaktlist.AlternatingRows = True
        Me.Kontaktlist.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Kontaktlist.FilterBar = True
        Me.Kontaktlist.GroupByCaption = "Drag a column header here to group by that column"
        Me.Kontaktlist.Images.Add(CType(resources.GetObject("Kontaktlist.Images"), System.Drawing.Image))
        Me.Kontaktlist.Location = New System.Drawing.Point(3, 3)
        Me.Kontaktlist.Name = "Kontaktlist"
        Me.Kontaktlist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.Kontaktlist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.Kontaktlist.PreviewInfo.ZoomFactor = 75
        Me.Kontaktlist.PrintInfo.PageSettings = CType(resources.GetObject("Kontaktlist.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.Kontaktlist.Size = New System.Drawing.Size(661, 150)
        Me.Kontaktlist.TabIndex = 2
        Me.Kontaktlist.Text = "C1TrueDBGrid1"
        Me.Kontaktlist.PropBag = resources.GetString("Kontaktlist.PropBag")
        '
        'TabServices
        '
        Me.TabServices.Controls.Add(Me.C1Services)
        Me.TabServices.Location = New System.Drawing.Point(4, 22)
        Me.TabServices.Name = "TabServices"
        Me.TabServices.Padding = New System.Windows.Forms.Padding(3)
        Me.TabServices.Size = New System.Drawing.Size(667, 156)
        Me.TabServices.TabIndex = 1
        Me.TabServices.Text = "Services"
        Me.TabServices.UseVisualStyleBackColor = True
        '
        'TabEreignisse
        '
        Me.TabEreignisse.Location = New System.Drawing.Point(4, 22)
        Me.TabEreignisse.Name = "TabEreignisse"
        Me.TabEreignisse.Size = New System.Drawing.Size(667, 156)
        Me.TabEreignisse.TabIndex = 2
        Me.TabEreignisse.Text = "Ereignisse"
        Me.TabEreignisse.UseVisualStyleBackColor = True
        '
        'TabAktivitäten
        '
        Me.TabAktivitäten.Location = New System.Drawing.Point(4, 22)
        Me.TabAktivitäten.Name = "TabAktivitäten"
        Me.TabAktivitäten.Size = New System.Drawing.Size(667, 156)
        Me.TabAktivitäten.TabIndex = 9
        Me.TabAktivitäten.Text = "Aktivitäten"
        Me.TabAktivitäten.UseVisualStyleBackColor = True
        '
        'TabPendenzen
        '
        Me.TabPendenzen.Location = New System.Drawing.Point(4, 22)
        Me.TabPendenzen.Name = "TabPendenzen"
        Me.TabPendenzen.Size = New System.Drawing.Size(667, 156)
        Me.TabPendenzen.TabIndex = 3
        Me.TabPendenzen.Text = "Pendenzen"
        Me.TabPendenzen.UseVisualStyleBackColor = True
        '
        'TabAblageorte
        '
        Me.TabAblageorte.Location = New System.Drawing.Point(4, 22)
        Me.TabAblageorte.Name = "TabAblageorte"
        Me.TabAblageorte.Size = New System.Drawing.Size(667, 156)
        Me.TabAblageorte.TabIndex = 4
        Me.TabAblageorte.Text = "Ablageorte"
        Me.TabAblageorte.UseVisualStyleBackColor = True
        '
        'TabReferenzvertraege
        '
        Me.TabReferenzvertraege.Location = New System.Drawing.Point(4, 22)
        Me.TabReferenzvertraege.Name = "TabReferenzvertraege"
        Me.TabReferenzvertraege.Size = New System.Drawing.Size(667, 156)
        Me.TabReferenzvertraege.TabIndex = 5
        Me.TabReferenzvertraege.Text = "Referenzverträge"
        Me.TabReferenzvertraege.UseVisualStyleBackColor = True
        '
        'TabHistory
        '
        Me.TabHistory.Location = New System.Drawing.Point(4, 22)
        Me.TabHistory.Name = "TabHistory"
        Me.TabHistory.Size = New System.Drawing.Size(667, 156)
        Me.TabHistory.TabIndex = 8
        Me.TabHistory.Text = "Historie"
        Me.TabHistory.UseVisualStyleBackColor = True
        '
        'C1Services
        '
        Me.C1Services.AlternatingRows = True
        Me.C1Services.ContextMenuStrip = Me.KontakteMenuStrip
        Me.C1Services.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Services.FilterBar = True
        Me.C1Services.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Services.Images.Add(CType(resources.GetObject("C1Services.Images"), System.Drawing.Image))
        Me.C1Services.Location = New System.Drawing.Point(3, 3)
        Me.C1Services.Name = "C1Services"
        Me.C1Services.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Services.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Services.PreviewInfo.ZoomFactor = 75
        Me.C1Services.PrintInfo.PageSettings = CType(resources.GetObject("C1TrueDBGrid1.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Services.Size = New System.Drawing.Size(661, 150)
        Me.C1Services.TabIndex = 5
        Me.C1Services.Text = "C1TrueDBGrid1"
        Me.C1Services.PropBag = resources.GetString("C1Services.PropBag")
        '
        'frmVertragselement
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(675, 515)
        Me.Controls.Add(Me.TabControlDiverse)
        Me.Controls.Add(Me.pnlStammdaten)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmVertragselement"
        Me.Text = "Vertragselement"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.pnlStammdaten.ResumeLayout(False)
        Me.pnlStammdaten.PerformLayout()
        Me.TabControlDiverse.ResumeLayout(False)
        Me.TabVertragsinhalt.ResumeLayout(False)
        Me.TabSuchbegriffe.ResumeLayout(False)
        Me.TabKuendigungsfristen.ResumeLayout(False)
        CType(Me.C1Kuendigungsfristen, System.ComponentModel.ISupportInitialize).EndInit()
        Me.KuendigungsfristMenuStrip.ResumeLayout(False)
        Me.TabKontakte.ResumeLayout(False)
        CType(Me.C1Kontakte, System.ComponentModel.ISupportInitialize).EndInit()
        Me.KontakteMenuStrip.ResumeLayout(False)
        CType(Me.Kontaktlist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabServices.ResumeLayout(False)
        CType(Me.C1Services, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.KontaktAnzeigenToolStripMenuItem_Click Method

frmVertragselement.KontaktAnzeigenToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

Anzeigen bzw. bearbeitnen eines Kontaktes
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub KontaktAnzeigenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   KontaktAnzeigenToolStripMenuItem.Click
C#
private System.Void KontaktAnzeigenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void KontaktAnzeigenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function KontaktAnzeigenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub KontaktAnzeigenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles KontaktAnzeigenToolStripMenuItem.Click
        Dim bm As Integer = 0
        Try
            bm = Me.C1Kontakte.Bookmark
            Dim f As New frmVertragskontakt(Me.C1Kontakte.Columns("Vertragskontaktnr").Value, Me.Aktueller_Vertragspartner, Me.Aktuelles_Vertragselement)
            f.ShowDialog()
            Refresh_Kontakte()
            Try
                Me.C1Kontakte.Bookmark = bm
            Catch ex As Exception
            End Try
        Catch ex As Exception
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.KontaktLöschenToolStripMenuItem_Click Method

frmVertragselement.KontaktLöschenToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

Vertragskontakt inaktivieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub KontaktLöschenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   KontaktLöschenToolStripMenuItem.Click
C#
private System.Void KontaktLöschenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void KontaktLöschenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function KontaktLöschenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub KontaktLöschenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles KontaktLöschenToolStripMenuItem.Click
        Try
            If msg.Show_MessageYesNo(265) = MsgBoxResult.Yes Then
                Me.Vertragselement.Vertragskontakt.Delete_Vertragskontakt(Me.C1Kontakte.Columns("Vertragskontaktnr").Value)
                Me.Refresh_Kontakte()
            End If
        Catch
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.KontaktNeuToolStripMenuItem_Click Method

frmVertragselement.KontaktNeuToolStripMenuItem_Click Method

Neuer Vertragskontakt erstellen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub KontaktNeuToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   KontaktNeuToolStripMenuItem.Click
C#
private System.Void KontaktNeuToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void KontaktNeuToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function KontaktNeuToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub KontaktNeuToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles KontaktNeuToolStripMenuItem.Click
        Try
            Dim i As Integer = Me.Vertragselement.Vertragskontakt.Add_New(Me.Vertragselement.iVertragselementnr.Value)
            Dim f As New frmVertragskontakt(i, Me.Aktueller_Vertragspartner, Me.Aktuelles_Vertragselement)
            f.ShowDialog()
            Refresh_Kontakte()
        Catch
        End Try

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.KuendigungsfristBearbeitenToolStripMenuItem_Click Method

frmVertragselement.KuendigungsfristBearbeitenToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

Kuendigungsfrist bearbeiten / anzeigen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub KuendigungsfristBearbeitenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   KuendigungsfristBearbeitenToolStripMenuItem.Click
C#
private System.Void KuendigungsfristBearbeitenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void KuendigungsfristBearbeitenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function KuendigungsfristBearbeitenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub KuendigungsfristBearbeitenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles KuendigungsfristBearbeitenToolStripMenuItem.Click
        C1Kuendigungsfristen_DoubleClick(sender, e)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.KuendigungsfristLöschenToolStripMenuItem_Click Method

frmVertragselement.KuendigungsfristLöschenToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

Kuendigungsfrist inaktivieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub KuendigungsfristLöschenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   KuendigungsfristLöschenToolStripMenuItem.Click
C#
private System.Void KuendigungsfristLöschenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void KuendigungsfristLöschenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function KuendigungsfristLöschenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub KuendigungsfristLöschenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles KuendigungsfristLöschenToolStripMenuItem.Click
        Try
            If msg.Show_MessageYesNo(260) = MsgBoxResult.Yes Then
                Me.Vertragselement.Kuendigungsfrist.Delete_Kuendigungsfrist(Me.C1Kuendigungsfristen.Columns("Kuendigungsfristnr").Value)
                Me.Refresh_Kuendigungsfrist()
            End If
        Catch
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.KuendigungsfristNeuToolStripMenuItem_Click Method

frmVertragselement.KuendigungsfristNeuToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

Neue Kuendigungsfrist erstellen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub KuendigungsfristNeuToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   KuendigungsfristNeuToolStripMenuItem.Click
C#
private System.Void KuendigungsfristNeuToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void KuendigungsfristNeuToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function KuendigungsfristNeuToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub KuendigungsfristNeuToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles KuendigungsfristNeuToolStripMenuItem.Click
        Try
            Dim i As Integer = Me.Vertragselement.Kuendigungsfrist.Add_New(Me.Vertragselement.iVertragselementnr.Value)
            Dim f As New frmKuendigungsfrist(i, Me.Vertragselement.iVertragselementnr.Value)
            f.ShowDialog()
            Me.Refresh_Kuendigungsfrist()
        Catch
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.Load_Securitylevel Method

frmVertragselement.Load_Securitylevel Method

Laden der Securitylevel-Daten in die Combobox
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Load_Securitylevel()
C#
private System.Void Load_Securitylevel();
C++

private:
System::Void Load_Securitylevel()
JScript
private function Load_Securitylevel();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Load_Securitylevel()
        Dim seclevel As New TKB.VV.DB.clsSecurityLevel
        Dim secleveldata As New DataTable

        seclevel.cpMainConnectionProvider = Globals.conn
        Globals.conn.OpenConnection()
        secleveldata = seclevel.SelectAll
        Globals.conn.CloseConnection(True)

        Me.cboxSecurityLevel.DataSource = secleveldata
        Me.cboxSecurityLevel.DisplayMember = "Bezeichnung"
        Me.cboxSecurityLevel.ValueMember = "SecurityLevelNr"

        seclevel.Dispose()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.Refresh_Kontakte Method

frmVertragselement.Refresh_Kontakte Method

Kündigungsfristen aktualisieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Refresh_Kontakte()
C#
private System.Void Refresh_Kontakte();
C++

private:
System::Void Refresh_Kontakte()
JScript
private function Refresh_Kontakte();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Refresh_Kontakte()
        Try
            If Check_Changes() = False Then Exit Sub
        Catch ex As Exception

        End Try
        Me.C1Kontakte.Enabled = False
        Me.Vertragselement.Get_Vertragskontakte(Me.C1Kontakte)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Kontakte, "Vertragskontakt", Me.Vertragselement.Vertragskontakte.Tabledata)
        sec.Set_Form_Security(Me)
        Me.C1Kontakte.Enabled = True
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.Refresh_Kuendigungsfrist Method

frmVertragselement.Refresh_Kuendigungsfrist Method

Kündigungsfristen aktualisieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Refresh_Kuendigungsfrist()
C#
private System.Void Refresh_Kuendigungsfrist();
C++

private:
System::Void Refresh_Kuendigungsfrist()
JScript
private function Refresh_Kuendigungsfrist();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Refresh_Kuendigungsfrist()
        Try
            If Check_Changes() = False Then Exit Sub
        Catch ex As Exception

        End Try
        Me.C1Kuendigungsfristen.Enabled = False
        Me.Vertragselement.Get_Kuendigungsfristen(Me.C1Kuendigungsfristen)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Kuendigungsfristen, "Kuendigungsfrist", Me.Vertragselement.Kuendigungsfristen.Tabledata)
        sec.Set_Form_Security(Me)
        Me.C1Kuendigungsfristen.Enabled = True
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.Save_data Method

frmVertragselement.Save_data Method

Daten ab Form speichern
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Save_data()
C#
private System.Void Save_data();
C++

private:
System::Void Save_data()
JScript
private function Save_data();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Save_data()
        Vertragselement.iVertragspartnerNr = New SqlInt32(CType(Me.Aktueller_Vertragspartner, Int32))
        Vertragselement.iVertragstypNr = New SqlInt32(CType(Me.cboxVertragstyp.SelectedValue, Int32))
        Vertragselement.iParentID = New SqlInt32(CType(Me.cbboxParentElement.SelectedValue, Int32))

        Vertragselement.sBezeichnung = New SqlString(CType(Me.txtBezeichnung.Text, String))
        Vertragselement.sVersion = New SqlString(CType(Me.txtVersion.Text, String))
        Vertragselement.sNummer = New SqlString(CType(Me.txtVertragsnummer.Text, String))

        If IsDate(Me.txtVersionsdatum.Text) Then
            Vertragselement.daVersionsdatum = New SqlDateTime(CType(Me.txtVersionsdatum.Text, DateTime))
        Else
            Vertragselement.daVersionsdatum = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
        End If
        If IsDate(Me.txtVertragsbegin.Text) Then
            Vertragselement.daVertragsbeginn = New SqlDateTime(CType(Me.txtVertragsbegin.Text, DateTime))
        Else
            Vertragselement.daVertragsbeginn = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
        End If
        If IsDate(Me.txtVertragsende.Text) Then
            Vertragselement.daVertragsablauf = New SqlDateTime(CType(Me.txtVertragsende.Text, DateTime))
        Else
            Vertragselement.daVertragsablauf = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
        End If
        If IsDate(Me.txtMindestvertragsdauerbis.Text) Then
            Vertragselement.daMindestvertragsdauer_bis = New SqlDateTime(CType(Me.txtMindestvertragsdauerbis.Text, DateTime))
        Else
            Vertragselement.daMindestvertragsdauer_bis = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
        End If
        If IsDate(Me.txtUnterzeichnetam.Text) Then
            Vertragselement.daUnterzeichnet_am = New SqlDateTime(CType(Me.txtUnterzeichnetam.Text, DateTime))
        Else
            Vertragselement.daUnterzeichnet_am = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
        End If
        If IsDate(Me.txtGekuendigtam.Text) Then
            Vertragselement.daGekuendigt_am = New SqlDateTime(CType(Me.txtGekuendigtam.Text, DateTime))
        Else
            Vertragselement.daGekuendigt_am = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
        End If
        If IsDate(Me.txtGekuendigtper.Text) Then
            Vertragselement.daGekuendigt_per = New SqlDateTime(CType(Me.txtGekuendigtper.Text, DateTime))
        Else
            Vertragselement.daGekuendigt_per = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
        End If
        Vertragselement.bBefristet_Unbefristet = New SqlBoolean(CType(Me.rbbefristet.Checked = True, Boolean))
        Vertragselement.bAktiv = New SqlBoolean(CType(Me.cbaktiv.Checked = True, Boolean))
        Vertragselement.sBeschreibung = New SqlString(CType(Me.txtBeschreibung.Text, String))
        Vertragselement.sSuchbegriffe = New SqlString(CType(Me.txtSuchbegriffe.Text, String))
        Vertragselement.Save_Data()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.TSBtnCopy_Click Method

frmVertragselement.TSBtnCopy_Click Method

Datensatz kopieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnCopy_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnCopy.Click
C#
private System.Void TSBtnCopy_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnCopy_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnCopy_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnCopy_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnCopy.Click
        If Me.Check_Changes = False Then Exit Sub
        Me.Get_Data(Vertragselement.Create_Copy(Me.Vertragselement.iVertragselementnr.Value))
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.TSBtnDelete_Click Method

frmVertragselement.TSBtnDelete_Click Method

Aktueller Datensatz inaktivieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click
C#
private System.Void TSBtnDelete_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnDelete_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnDelete_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
        If msg.Show_MessageYesNo(250) = MsgBoxResult.Yes Then
            Me.Vertragselement.Delete_Vertragselement(Me.Vertragselement.iVertragselementnr.Value)
            Me.Close()
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.TSBtnNew_Click Method

frmVertragselement.TSBtnNew_Click Method

Neuer Datensatz erstellen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnNew_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnNew.Click
C#
private System.Void TSBtnNew_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnNew_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnNew_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnNew.Click
        If Me.Check_Changes = False Then Exit Sub
        Me.Get_Data(Me.Vertragselement.Add_New(Me.Vertragselement.iVertragspartnerNr.Value))
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.TSBtnQuit_Click Method

frmVertragselement.TSBtnQuit_Click Method

Formular schliessen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click
C#
private System.Void TSBtnQuit_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnQuit_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnQuit_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.TSBtnSave_Click Method

frmVertragselement.TSBtnSave_Click Method

Sicherungs-Button betätigt
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click
C#
private System.Void TSBtnSave_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnSave_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnSave_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Me.Save_data()
        Me.txtMutiertam.Text = Me.Vertragselement.daMutiert_am.ToString
        Me.FormDataChanged = False
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.TSBtnSuche_Click Method

frmVertragselement.TSBtnSuche_Click Method

Vertragspartner suchen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnSuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSuche.Click
C#
private System.Void TSBtnSuche_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnSuche_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnSuche_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSuche.Click
        If Not Me.FormReadonly Then Check_Changes()
        Dim i As Integer
        If Me.Vertragselement.Suchen(i) = True Then
            Me.Get_Data(i)
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.TabControlDiverse_SelectedIndexChanged Method

frmVertragselement.TabControlDiverse_SelectedIndexChanged Method
See Also
collapseAll image DropDown image

Index-Wechsel auf TabControlDiverse
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TabControlDiverse_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TabControlDiverse.SelectedIndexChanged
C#
private System.Void TabControlDiverse_SelectedIndexChanged(
   object sender,
   EventArgs e
);
C++

private:
System::Void TabControlDiverse_SelectedIndexChanged(
   object^ sender,
   EventArgs^ e
)
JScript
private function TabControlDiverse_SelectedIndexChanged(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TabControlDiverse_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles TabControlDiverse.SelectedIndexChanged
        Select Case Me.TabControlDiverse.SelectedTab.Text
            Case "Vertragsinhalt", "Suchbegriffe"
            Case "Kündigungsfristen"
                Refresh_Kuendigungsfrist()
            Case "Kontakte"
                Refresh_Kontakte()
            Case "Services"
            Case "Ereignisse"
            Case "Aktivitäten"
            Case "Pendenzen"
            Case "Ablageorte"
            Case "Referenzverträge"
            Case "Historie"

        End Select
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.btnVertragspartnersuche_Click Method

frmVertragselement.btnVertragspartnersuche_Click Method

Vertragspartner suchen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub btnVertragspartnersuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnVertragspartnersuche.Click
C#
private System.Void btnVertragspartnersuche_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void btnVertragspartnersuche_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function btnVertragspartnersuche_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub btnVertragspartnersuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnVertragspartnersuche.Click
        If Not Me.FormReadonly Then
            Vertragselement.Vertragspartner_suchen(Me.Aktueller_Vertragspartner, Me.txtVertragspartner)
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.frmVertragselement_Load Method

frmVertragselement.frmVertragselement_Load Method

Load-Methode
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub frmVertragselement_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load
C#
private System.Void frmVertragselement_Load(
   object sender,
   EventArgs e
);
C++

private:
System::Void frmVertragselement_Load(
   object^ sender,
   EventArgs^ e
)
JScript
private function frmVertragselement_Load(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub frmVertragselement_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        If Anzeige = True Then
            Me.TSBtnSuche.Enabled = False
            Me.TSBtnSave.Enabled = False
        Else
            Me.TSBtnSuche.Enabled = True
        End If
        If Me.TSBtnSave.Enabled = False Or Me.TSBtnSave.Visible = False Then
            Me.FormReadonly = True
            Me.TSBtnCopy.Enabled = False
            Me.TSBtnNew.Enabled = False
            Me.TSBtnDelete.Enabled = False
        Else
            Me.FormReadonly = False
        End If

        Load_Securitylevel()

        'Vertragstypen laden
        Me.cboxVertragstyp.DataSource = Me.Vertragselement.Vertragstypen
        Me.cboxVertragstyp.DisplayMember = "Vertragstyp"
        Me.cboxVertragstyp.ValueMember = "VertragstypNr"

        Get_Data(Me.Aktuelles_Vertragselement)
        AddChanges(Me)

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.frmVertragselement_Shown Method

frmVertragselement.frmVertragselement_Shown Method

Shown-Ereigns
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub frmVertragselement_Shown( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   Me.Shown
C#
private System.Void frmVertragselement_Shown(
   object sender,
   EventArgs e
);
C++

private:
System::Void frmVertragselement_Shown(
   object^ sender,
   EventArgs^ e
)
JScript
private function frmVertragselement_Shown(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub frmVertragselement_Shown(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Shown
        If Me.Aktuelles_Vertragselement = -1 Then
            TSBtnSuche_Click(sender, e)
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement Fields

frmVertragselement Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | Aktueller_Vertragspartner |
Supported by the .NET Compact Framework. | Aktuelles_Vertragselement |
Supported by the .NET Compact Framework. | Anzeige |
Supported by the .NET Compact Framework. | FormDataChanged |
Supported by the .NET Compact Framework. | FormReadonly |
Supported by the .NET Compact Framework. | SpaltenTitel |
Supported by the .NET Compact Framework. | Vertragselement |
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | msg |
Supported by the .NET Compact Framework. | sec |
Top

Expand image See Also

Reference

frmVertragselement Class


Aktueller_Vertragspartner Variable

Aktueller_Vertragspartner Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Aktueller_Vertragspartner As Integer
C#
private int Aktueller_Vertragspartner;
C++
private:
int Aktueller_Vertragspartner;
JScript
private Aktueller_Vertragspartner : int

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Aktueller_Vertragspartner As Integer = 0

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


Aktuelles_Vertragselement Variable

Aktuelles_Vertragselement Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Aktuelles_Vertragselement As Integer
C#
private int Aktuelles_Vertragselement;
C++
private:
int Aktuelles_Vertragselement;
JScript
private Aktuelles_Vertragselement : int

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Aktuelles_Vertragselement As Integer = 0

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


Anzeige Variable

Anzeige Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Anzeige As Boolean
C#
private bool Anzeige;
C++
private:
bool Anzeige;
JScript
private Anzeige : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Anzeige As Boolean = False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


FormDataChanged Variable

FormDataChanged Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private FormDataChanged As Boolean
C#
private bool FormDataChanged;
C++
private:
bool FormDataChanged;
JScript
private FormDataChanged : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim FormDataChanged As Boolean = False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


FormReadonly Variable

FormReadonly Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private FormReadonly As Boolean
C#
private bool FormReadonly;
C++
private:
bool FormReadonly;
JScript
private FormReadonly : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim FormReadonly As Boolean = False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


SpaltenTitel Variable

SpaltenTitel Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private SpaltenTitel As Tabellenspalte
C#
private Tabellenspalte SpaltenTitel;
C++
private:
Tabellenspalte^ SpaltenTitel;
JScript
private SpaltenTitel : Tabellenspalte

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


Vertragselement Variable

Vertragselement Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Vertragselement As clsVertragselement
C#
private clsVertragselement Vertragselement;
C++
private:
clsVertragselement^ Vertragselement;
JScript
private Vertragselement : clsVertragselement

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Vertragselement As New TKB.VV.Vertrag.clsVertragselement

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


components Variable

components Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private components As IContainer
C#
private IContainer components;
C++
private:
IContainer^ components;
JScript
private components : IContainer

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private components As System.ComponentModel.IContainer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


msg Variable

msg Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private msg As MyMessage
C#
private MyMessage msg;
C++
private:
MyMessage^ msg;
JScript
private msg : MyMessage

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim msg As New TKB.VV.Utils.MyMessage

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


sec Variable

sec Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private sec As MySecurity
C#
private MySecurity sec;
C++
private:
MySecurity^ sec;
JScript
private sec : MySecurity

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim sec As New TKB.VV.Utils.MySecurity

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselementSuche Class

frmVertragselementSuche Class
Members
collapseAll image DropDown image

Vertragselementsuche
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class frmVertragselementSuche
    Inherits Form
C#
public class frmVertragselementSuche : Form
C++

public ref class frmVertragselementSuche : public Form^
JScript
public class frmVertragselementSuche
   extends Form

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmVertragselementSuche

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselementSuche Members


frmVertragselementSuche Members

frmVertragselementSuche Members
See Also Methods Properties
CollapseAll image DropDown image

Vertragselementsuche

The following tables list the members exposed by the frmVertragselementSuche type.

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Vertragselementnr |
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | dispose | (Overloaded) Destructor Dispose
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | BeendenToolStripMenuItem_Click | Menu Beenden
Supported by the .NET Compact Framework. | BtnSchliessen_Click | Schliessen des Fensters
Supported by the .NET Compact Framework. | BtnSelect_Click | BtnSelect gewählt
Supported by the .NET Compact Framework. | BtnSuche_Click | Suche ausführen
Supported by the .NET Compact Framework. | C1Vertragselementliste_DoubleClick | Doubleklick in C1Partnerliste
Supported by the .NET Compact Framework. | C1Vertragselementliste_MouseDown | Mousedown-Ereignis handeln, damit auch bei rechter Maustaste der Fokus auf den richtigen Datensatz gesetzt wird
Supported by the .NET Compact Framework. | DetailsAnzeigenToolStripMenuItem_Click | Kontextmenu Details anzeigen gewählt
Supported by the .NET Compact Framework. | FrmVertragspartnerSuche_Load | Load des Dialogs
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | Serach_data | Vertragspartner aus DB auslesen
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Schliessen des Fensters
Supported by the .NET Compact Framework. | Vertragselement_Suchen | Vertragselement suchen
Supported by the .NET Compact Framework. | txt_KeyDown | Textfelder KeyDown
Supported by the .NET Compact Framework. | ÜberrnehmenToolStripMenuItem_Click | Kontextmenu Übernehmen gewählt
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | d |
Supported by the .NET Compact Framework. | m_Vertragselementnr |
Top

Expand image See Also

Reference

frmVertragselementSuche Class


frmVertragselementSuche Properties

frmVertragselementSuche Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Vertragselementnr |
Top

Expand image See Also

Reference

frmVertragselementSuche Class


frmVertragselementSuche.Vertragselementnr Property

frmVertragselementSuche.Vertragselementnr Property

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property Vertragselementnr() As Integer
C#
public int Vertragselementnr {get; set;}
C++
public:
property int Vertragselementnr {
 int get( );
 void set(
   int value
 );
}
JScript
public function get Vertragselementnr() : int;
public function set Vertragselementnr(value : int);

Expand image Source code

Visual Basic CopyCode image Copy Code
    Property Vertragselementnr() As Integer
        Get
            Return m_Vertragselementnr
        End Get
        Set(ByVal value As Integer)
            m_Vertragselementnr = value
        End Set
    End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselementSuche Class
frmVertragselementSuche Members


frmVertragselementSuche Methods

frmVertragselementSuche Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | dispose | (Overloaded) Destructor Dispose
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | BeendenToolStripMenuItem_Click | Menu Beenden
Supported by the .NET Compact Framework. | BtnSchliessen_Click | Schliessen des Fensters
Supported by the .NET Compact Framework. | BtnSelect_Click | BtnSelect gewählt
Supported by the .NET Compact Framework. | BtnSuche_Click | Suche ausführen
Supported by the .NET Compact Framework. | C1Vertragselementliste_DoubleClick | Doubleklick in C1Partnerliste
Supported by the .NET Compact Framework. | C1Vertragselementliste_MouseDown | Mousedown-Ereignis handeln, damit auch bei rechter Maustaste der Fokus auf den richtigen Datensatz gesetzt wird
Supported by the .NET Compact Framework. | DetailsAnzeigenToolStripMenuItem_Click | Kontextmenu Details anzeigen gewählt
Supported by the .NET Compact Framework. | FrmVertragspartnerSuche_Load | Load des Dialogs
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | Serach_data | Vertragspartner aus DB auslesen
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Schliessen des Fensters
Supported by the .NET Compact Framework. | Vertragselement_Suchen | Vertragselement suchen
Supported by the .NET Compact Framework. | txt_KeyDown | Textfelder KeyDown
Supported by the .NET Compact Framework. | ÜberrnehmenToolStripMenuItem_Click | Kontextmenu Übernehmen gewählt
Top

Expand image See Also

Reference

frmVertragselementSuche Class


frmVertragselementSuche.BeendenToolStripMenuItem_Click Method

frmVertragselementSuche.BeendenToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

Menu Beenden
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click
C#
private System.Void BeendenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void BeendenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function BeendenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        TSBtnQuit_Click(sender, e)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselementSuche Class
frmVertragselementSuche Members


frmVertragselementSuche.BtnSchliessen_Click Method

frmVertragselementSuche.BtnSchliessen_Click Method

Schliessen des Fensters
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub BtnSchliessen_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BtnSchliessen.Click
C#
private System.Void BtnSchliessen_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void BtnSchliessen_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function BtnSchliessen_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub BtnSchliessen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnSchliessen.Click
        Me.TSBtnQuit_Click(sender, e)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselementSuche Class
frmVertragselementSuche Members


frmVertragselementSuche.BtnSelect_Click Method

frmVertragselementSuche.BtnSelect_Click Method

BtnSelect gewählt
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub BtnSelect_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BtnSelect.Click
C#
private System.Void BtnSelect_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void BtnSelect_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function BtnSelect_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub BtnSelect_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnSelect.Click
        Me.Vertragselementnr = Me.C1Vertragselementliste.Columns("Vertragselementnr").Value
        Me.DialogResult = Windows.Forms.DialogResult.OK
        Me.Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselementSuche Class
frmVertragselementSuche Members


frmVertragselementSuche.BtnSuche_Click Method

frmVertragselementSuche.BtnSuche_Click Method

Suche ausführen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub BtnSuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BtnSuche.Click
C#
private System.Void BtnSuche_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void BtnSuche_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function BtnSuche_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub BtnSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnSuche.Click
        Vertragselement_suchen()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselementSuche Class
frmVertragselementSuche Members


frmVertragselementSuche.C1Vertragselementliste_DoubleClick Method

frmVertragselementSuche.C1Vertragselementliste_DoubleClick Method
See Also
collapseAll image DropDown image

Doubleklick in C1Partnerliste
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub C1Vertragselementliste_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Vertragselementliste.DoubleClick
C#
private System.Void C1Vertragselementliste_DoubleClick(
   object sender,
   EventArgs e
);
C++

private:
System::Void C1Vertragselementliste_DoubleClick(
   object^ sender,
   EventArgs^ e
)
JScript
private function C1Vertragselementliste_DoubleClick(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub C1Vertragselementliste_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Vertragselementliste.DoubleClick
        If Me.C1Vertragselementliste.Splits(0).Rows.Count > 0 Then
            Me.BtnSelect_Click(sender, e)
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselementSuche Class
frmVertragselementSuche Members


frmVertragselementSuche.C1Vertragselementliste_MouseDown Method

frmVertragselementSuche.C1Vertragselementliste_MouseDown Method
See Also
collapseAll image DropDown image

Mousedown-Ereignis handeln, damit auch bei rechter Maustaste der Fokus auf den richtigen Datensatz gesetzt wird
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub C1Vertragselementliste_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Vertragselementliste.MouseDown
C#
private System.Void C1Vertragselementliste_MouseDown(
   object sender,
   MouseEventArgs e
);
C++

private:
System::Void C1Vertragselementliste_MouseDown(
   object^ sender,
   MouseEventArgs^ e
)
JScript
private function C1Vertragselementliste_MouseDown(
    sender : object,
    e : MouseEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub C1Vertragselementliste_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Vertragselementliste.MouseDown
        Me.C1Vertragselementliste.Bookmark = Me.C1Vertragselementliste.RowContaining(e.Y)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselementSuche Class
frmVertragselementSuche Members


frmVertragselementSuche.DetailsAnzeigenToolStripMenuItem_Click Method

frmVertragselementSuche.DetailsAnzeigenToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

Kontextmenu Details anzeigen gewählt
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub DetailsAnzeigenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   DetailsAnzeigenToolStripMenuItem.Click
C#
private System.Void DetailsAnzeigenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void DetailsAnzeigenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function DetailsAnzeigenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub DetailsAnzeigenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DetailsAnzeigenToolStripMenuItem.Click
        Dim f As New frmVertragselement(Me.C1Vertragselementliste.Columns("Vertragselementnr").Value, True)
        f.ShowDialog()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselementSuche Class
frmVertragselementSuche Members


frmVertragselementSuche.FrmVertragspartnerSuche_Load Method

frmVertragselementSuche.FrmVertragspartnerSuche_Load Method

Load des Dialogs
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub FrmVertragspartnerSuche_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load
C#
private System.Void FrmVertragspartnerSuche_Load(
   object sender,
   EventArgs e
);
C++

private:
System::Void FrmVertragspartnerSuche_Load(
   object^ sender,
   EventArgs^ e
)
JScript
private function FrmVertragspartnerSuche_Load(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub FrmVertragspartnerSuche_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.Vertragselementnr = -1
        Me.BtnSelect.Enabled = False
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselementSuche Class
frmVertragselementSuche Members


frmVertragselementSuche.InitializeComponent Method

frmVertragselementSuche.InitializeComponent Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()
C#
[System.Diagnostics.DebuggerStepThrough()]
private System.Void InitializeComponent();
C++
[System.Diagnostics.DebuggerStepThrough()]

private:
System::Void InitializeComponent()
JScript
private
   System.Diagnostics.DebuggerStepThrough()
function InitializeComponent();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmVertragselementSuche))
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.txtBezeichnung = New System.Windows.Forms.TextBox
        Me.lblOrt = New System.Windows.Forms.Label
        Me.txtName_Firma1 = New System.Windows.Forms.TextBox
        Me.lblName_Firma1 = New System.Windows.Forms.Label
        Me.BtnSuche = New System.Windows.Forms.Button
        Me.C1Vertragselementliste = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.VertragspartnerMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.ÜberrnehmenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.DetailsAnzeigenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.txtSuchbegriffe = New System.Windows.Forms.TextBox
        Me.lblFreitext = New System.Windows.Forms.Label
        Me.BtnSchliessen = New System.Windows.Forms.Button
        Me.BtnSelect = New System.Windows.Forms.Button
        Me.txtInhalt = New System.Windows.Forms.TextBox
        Me.lblInhalt = New System.Windows.Forms.Label
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        CType(Me.C1Vertragselementliste, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.VertragspartnerMenuStrip.SuspendLayout()
        Me.SuspendLayout()
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(127, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(571, 24)
        Me.MenuStrip1.TabIndex = 15
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(571, 25)
        Me.ToolStrip1.TabIndex = 16
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'txtBezeichnung
        '
        Me.txtBezeichnung.Location = New System.Drawing.Point(93, 78)
        Me.txtBezeichnung.Name = "txtBezeichnung"
        Me.txtBezeichnung.Size = New System.Drawing.Size(166, 20)
        Me.txtBezeichnung.TabIndex = 1
        '
        'lblOrt
        '
        Me.lblOrt.AccessibleDescription = "Name"
        Me.lblOrt.AutoSize = True
        Me.lblOrt.Location = New System.Drawing.Point(9, 81)
        Me.lblOrt.Name = "lblOrt"
        Me.lblOrt.Size = New System.Drawing.Size(69, 13)
        Me.lblOrt.TabIndex = 72
        Me.lblOrt.Text = "Bezeichnung"
        '
        'txtName_Firma1
        '
        Me.txtName_Firma1.Location = New System.Drawing.Point(93, 52)
        Me.txtName_Firma1.Name = "txtName_Firma1"
        Me.txtName_Firma1.Size = New System.Drawing.Size(166, 20)
        Me.txtName_Firma1.TabIndex = 0
        Me.txtName_Firma1.Tag = ""
        '
        'lblName_Firma1
        '
        Me.lblName_Firma1.AccessibleDescription = "Name"
        Me.lblName_Firma1.AutoSize = True
        Me.lblName_Firma1.Location = New System.Drawing.Point(9, 55)
        Me.lblName_Firma1.Name = "lblName_Firma1"
        Me.lblName_Firma1.Size = New System.Drawing.Size(71, 13)
        Me.lblName_Firma1.TabIndex = 71
        Me.lblName_Firma1.Text = "Name / Firma"
        '
        'BtnSuche
        '
        Me.BtnSuche.Location = New System.Drawing.Point(12, 111)
        Me.BtnSuche.Name = "BtnSuche"
        Me.BtnSuche.Size = New System.Drawing.Size(75, 23)
        Me.BtnSuche.TabIndex = 4
        Me.BtnSuche.Text = "Suchen"
        Me.BtnSuche.UseVisualStyleBackColor = True
        '
        'C1Vertragselementliste
        '
        Me.C1Vertragselementliste.AlternatingRows = True
        Me.C1Vertragselementliste.ContextMenuStrip = Me.VertragspartnerMenuStrip
        Me.C1Vertragselementliste.FilterBar = True
        Me.C1Vertragselementliste.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Vertragselementliste.Images.Add(CType(resources.GetObject("C1Vertragselementliste.Images"), System.Drawing.Image))
        Me.C1Vertragselementliste.Location = New System.Drawing.Point(12, 140)
        Me.C1Vertragselementliste.Name = "C1Vertragselementliste"
        Me.C1Vertragselementliste.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Vertragselementliste.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Vertragselementliste.PreviewInfo.ZoomFactor = 75
        Me.C1Vertragselementliste.PrintInfo.PageSettings = CType(resources.GetObject("C1Vertragselementliste.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Vertragselementliste.Size = New System.Drawing.Size(551, 201)
        Me.C1Vertragselementliste.TabIndex = 5
        Me.C1Vertragselementliste.Text = "C1Kontakte"
        Me.C1Vertragselementliste.PropBag = resources.GetString("C1Vertragselementliste.PropBag")
        '
        'VertragspartnerMenuStrip
        '
        Me.VertragspartnerMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.ÜberrnehmenToolStripMenuItem, Me.DetailsAnzeigenToolStripMenuItem})
        Me.VertragspartnerMenuStrip.Name = "VertragspartnerMenuStrip"
        Me.VertragspartnerMenuStrip.Size = New System.Drawing.Size(164, 48)
        '
        'ÜberrnehmenToolStripMenuItem
        '
        Me.ÜberrnehmenToolStripMenuItem.Name = "ÜberrnehmenToolStripMenuItem"
        Me.ÜberrnehmenToolStripMenuItem.Size = New System.Drawing.Size(163, 22)
        Me.ÜberrnehmenToolStripMenuItem.Text = "Übe&rnehmen"
        '
        'DetailsAnzeigenToolStripMenuItem
        '
        Me.DetailsAnzeigenToolStripMenuItem.Name = "DetailsAnzeigenToolStripMenuItem"
        Me.DetailsAnzeigenToolStripMenuItem.Size = New System.Drawing.Size(163, 22)
        Me.DetailsAnzeigenToolStripMenuItem.Text = "&Details anzeigen"
        '
        'txtSuchbegriffe
        '
        Me.txtSuchbegriffe.Location = New System.Drawing.Point(393, 74)
        Me.txtSuchbegriffe.Name = "txtSuchbegriffe"
        Me.txtSuchbegriffe.Size = New System.Drawing.Size(166, 20)
        Me.txtSuchbegriffe.TabIndex = 3
        '
        'lblFreitext
        '
        Me.lblFreitext.AccessibleDescription = "Name"
        Me.lblFreitext.AutoSize = True
        Me.lblFreitext.Location = New System.Drawing.Point(309, 77)
        Me.lblFreitext.Name = "lblFreitext"
        Me.lblFreitext.Size = New System.Drawing.Size(67, 13)
        Me.lblFreitext.TabIndex = 76
        Me.lblFreitext.Text = "Suchbegriffe"
        '
        'BtnSchliessen
        '
        Me.BtnSchliessen.Location = New System.Drawing.Point(12, 347)
        Me.BtnSchliessen.Name = "BtnSchliessen"
        Me.BtnSchliessen.Size = New System.Drawing.Size(80, 24)
        Me.BtnSchliessen.TabIndex = 6
        Me.BtnSchliessen.Text = "Schliessen"
        '
        'BtnSelect
        '
        Me.BtnSelect.Enabled = False
        Me.BtnSelect.Location = New System.Drawing.Point(475, 347)
        Me.BtnSelect.Name = "BtnSelect"
        Me.BtnSelect.Size = New System.Drawing.Size(88, 23)
        Me.BtnSelect.TabIndex = 7
        Me.BtnSelect.Text = "Übernehmen"
        '
        'txtInhalt
        '
        Me.txtInhalt.Location = New System.Drawing.Point(393, 48)
        Me.txtInhalt.Name = "txtInhalt"
        Me.txtInhalt.Size = New System.Drawing.Size(166, 20)
        Me.txtInhalt.TabIndex = 2
        '
        'lblInhalt
        '
        Me.lblInhalt.AccessibleDescription = "Name"
        Me.lblInhalt.AutoSize = True
        Me.lblInhalt.Location = New System.Drawing.Point(309, 51)
        Me.lblInhalt.Name = "lblInhalt"
        Me.lblInhalt.Size = New System.Drawing.Size(33, 13)
        Me.lblInhalt.TabIndex = 80
        Me.lblInhalt.Text = "Inhalt"
        '
        'frmVertragselementSuche
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(571, 376)
        Me.Controls.Add(Me.txtInhalt)
        Me.Controls.Add(Me.lblInhalt)
        Me.Controls.Add(Me.BtnSchliessen)
        Me.Controls.Add(Me.BtnSelect)
        Me.Controls.Add(Me.C1Vertragselementliste)
        Me.Controls.Add(Me.txtSuchbegriffe)
        Me.Controls.Add(Me.txtBezeichnung)
        Me.Controls.Add(Me.lblFreitext)
        Me.Controls.Add(Me.BtnSuche)
        Me.Controls.Add(Me.lblOrt)
        Me.Controls.Add(Me.txtName_Firma1)
        Me.Controls.Add(Me.lblName_Firma1)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmVertragselementSuche"
        Me.Text = "Vertragseleent suchen"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        CType(Me.C1Vertragselementliste, System.ComponentModel.ISupportInitialize).EndInit()
        Me.VertragspartnerMenuStrip.ResumeLayout(False)
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselementSuche Class
frmVertragselementSuche Members


frmVertragselementSuche.Serach_data Method

frmVertragselementSuche.Serach_data Method

Vertragspartner aus DB auslesen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Serach_data( _
   ByVal query As String, _
   ByVal fnkt As Integer _
) As DataTable
C#
private DataTable Serach_data(
   string query,
   int fnkt
);
C++

private:
DataTable^ Serach_data(
   String^ query,
   int fnkt
)
JScript
private function Serach_data(
    query : String,
    fnkt : int
) : DataTable;

Parameters

query

fnkt

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Function Serach_data(ByVal query As String, ByVal fnkt As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_vertragselement_search"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@query", SqlDbType.VarChar, 1000, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, query))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, fnkt))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
            sdaAdapter.Fill(dtToReturn)
            Return dttoreturn
        Catch ex As Exception
            Throw New Exception("clsVertragselement::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselementSuche Class
frmVertragselementSuche Members


frmVertragselementSuche.TSBtnQuit_Click Method

frmVertragselementSuche.TSBtnQuit_Click Method

Schliessen des Fensters
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click
C#
private System.Void TSBtnQuit_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnQuit_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnQuit_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselementSuche Class
frmVertragselementSuche Members


frmVertragselementSuche.Vertragselement_Suchen Method

frmVertragselementSuche.Vertragselement_Suchen Method

Vertragselement suchen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Vertragselement_Suchen() As Object
C#
private object Vertragselement_Suchen();
C++

private:
object^ Vertragselement_Suchen()
JScript
private function Vertragselement_Suchen() : object;

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Function Vertragselement_Suchen()
        If Me.txtName_Firma1.Text <> "" Then
            d = Serach_data(Me.txtName_Firma1.Text, 0)
        Else
            If Me.txtBezeichnung.Text <> "" Then
                d = Serach_data(Me.txtBezeichnung.Text, 1)
            Else
                If Me.txtInhalt.Text <> "" Then
                    d = Serach_data(Me.txtInhalt.Text, 2)
                Else
                    d = Serach_data(Me.txtSuchbegriffe.Text, 3)
                End If
            End If
        End If
        Me.C1Vertragselementliste.DataSource = d
        Me.C1Vertragselementliste.DataMember = d.TableName

        Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte
        SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Vertragselementliste, "Vertragselement", d)
        SpaltenTitel = Nothing
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselementSuche Class
frmVertragselementSuche Members


frmVertragselementSuche.dispose Method

frmVertragselementSuche.dispose Method

Destructor Dispose

Expand image Overload List

Name | Description
protected override System.Void Dispose(bool); |
public System.Void dispose(); | Destructor Dispose

Expand image See Also

Reference

frmVertragselementSuche Class
frmVertragselementSuche Members


frmVertragselementSuche.txt_KeyDown Method

frmVertragselementSuche.txt_KeyDown Method

Textfelder KeyDown
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub txt_KeyDown( _
   ByVal sender As Object, _
   ByVal e As KeyEventArgs _
) Handles  _
   txtName_Firma1.KeyDown, _
   txtBezeichnung.KeyDown, _
   txtInhalt.KeyDown, _
   txtSuchbegriffe.KeyDown
C#
private System.Void txt_KeyDown(
   object sender,
   KeyEventArgs e
);
C++

private:
System::Void txt_KeyDown(
   object^ sender,
   KeyEventArgs^ e
)
JScript
private function txt_KeyDown(
    sender : object,
    e : KeyEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub txt_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtName_Firma1.KeyDown, txtBezeichnung.KeyDown, txtInhalt.KeyDown, txtSuchbegriffe.KeyDown
        If e.KeyCode = Keys.Enter Then
            Me.BtnSuche_Click(sender, e)
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselementSuche Class
frmVertragselementSuche Members


frmVertragselementSuche.ÜberrnehmenToolStripMenuItem_Click Method

frmVertragselementSuche.ÜberrnehmenToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

Kontextmenu Übernehmen gewählt
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub ÜberrnehmenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ÜberrnehmenToolStripMenuItem.Click
C#
private System.Void ÜberrnehmenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void ÜberrnehmenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function ÜberrnehmenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub ÜberrnehmenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ÜberrnehmenToolStripMenuItem.Click
        Me.BtnSelect_Click(sender, e)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselementSuche Class
frmVertragselementSuche Members


frmVertragselementSuche Fields

frmVertragselementSuche Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | d |
Supported by the .NET Compact Framework. | m_Vertragselementnr |
Top

Expand image See Also

Reference

frmVertragselementSuche Class


components Variable

components Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private components As IContainer
C#
private IContainer components;
C++
private:
IContainer^ components;
JScript
private components : IContainer

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private components As System.ComponentModel.IContainer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselementSuche Class
frmVertragselementSuche Members


d Variable

d Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private d As DataTable
C#
private DataTable d;
C++
private:
DataTable^ d;
JScript
private d : DataTable

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim d As New DataTable

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselementSuche Class
frmVertragselementSuche Members


m_Vertragselementnr Variable

m_Vertragselementnr Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_Vertragselementnr As Integer
C#
private int m_Vertragselementnr;
C++
private:
int m_Vertragselementnr;
JScript
private m_Vertragselementnr : int

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim m_Vertragselementnr As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselementSuche Class
frmVertragselementSuche Members


frmVertragskontakt Class

frmVertragskontakt Class
Members
collapseAll image DropDown image

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmVertragskontakt
    Inherits Form
C#
[Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()]
public class frmVertragskontakt : Form
C++
[Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()]

public ref class frmVertragskontakt : public Form^
JScript
public
   Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()
class frmVertragskontakt
   extends Form

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmVertragskontakt

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Members


frmVertragskontakt Members

frmVertragskontakt Members
See Also Constructors Methods
CollapseAll image DropDown image

The following tables list the members exposed by the frmVertragskontakt type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | frmVertragskontakt Constructor | (Overloaded)
Top

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | AddChanges | Allg Eventhandler für Chanage-Ereignise festlegen
Supported by the .NET Compact Framework. | BeendenToolStripMenuItem_Click | Menu Beenden
Supported by the .NET Compact Framework. | C1Kontaktpersonen_MouseDown | C1Kontaktperson Mousedown
Supported by the .NET Compact Framework. | ChangesMade | Envent-Handler für Change-Ereignisse
Supported by the .NET Compact Framework. | Check_Changes | Prüfung, ob Datenänderungen vorgenommen wurden.
Supported by the .NET Compact Framework. | DetailsKontaktpersonToolStripMenuItem_Click | C1Kontaktperson Details anzeigen
Supported by the .NET Compact Framework. | DetailsVertragspartnerToolStripMenuItem_Click | Vertragspartner anzeigen
Supported by the .NET Compact Framework. | FormularClosing | Schliessen des Formulars
Supported by the .NET Compact Framework. | GetControl | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
Supported by the .NET Compact Framework. | Get_Data | Person laden und präsentieren
Supported by the .NET Compact Framework. | Get_Vertragspartner |
Supported by the .NET Compact Framework. | Get_Vertragspartner_Kontakte |
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | Load_Rollen |
Supported by the .NET Compact Framework. | Load_Securitylevel | Laden der Securitylevel-Daten in die Combobox
Supported by the .NET Compact Framework. | NeuKontaktpersonToolStripMenuItem_Click | C1Kontaktperson neue Person erfassen
Supported by the .NET Compact Framework. | NeuVertragspartnerToolStripMenuItem_Click | Neuer Vertragspartner eröffnen
Supported by the .NET Compact Framework. | Save_Data | Daten sichern, sofern Änderungen vorgenommen worden sind
Supported by the .NET Compact Framework. | SuchenVertragspartnerToolStripMenuItem_Click | Vertragspartner suchen
Supported by the .NET Compact Framework. | TSBtnCopy_Click | Datensatz kopieren
Supported by the .NET Compact Framework. | TSBtnDelete_Click | Aktueller Datensatz inaktivieren
Supported by the .NET Compact Framework. | TSBtnNew_Click | Neuer Datensatz erstellen
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Formular schliessen
Supported by the .NET Compact Framework. | TSBtnSave_Click | Sicherungs-Button betätigt
Supported by the .NET Compact Framework. | btnVertragspartnersuche_Click | Vertragspartner suchen
Supported by the .NET Compact Framework. | frmVertragskontakt_Load |
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | FormDataChanged |
Supported by the .NET Compact Framework. | FormReadonly |
Supported by the .NET Compact Framework. | KontaktNr |
Supported by the .NET Compact Framework. | Kontaktperson |
Supported by the .NET Compact Framework. | Person |
Supported by the .NET Compact Framework. | SpaltenTitel |
Supported by the .NET Compact Framework. | Vertragselementnr |
Supported by the .NET Compact Framework. | Vertragskontaktnr |
Supported by the .NET Compact Framework. | Vertragspartner |
Supported by the .NET Compact Framework. | VertragspartnerNr |
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | msg |
Supported by the .NET Compact Framework. | sec |
Top

Expand image See Also

Reference

frmVertragskontakt Class


frmVertragskontakt Constructor

frmVertragskontakt Constructor

Expand image Overload List

Name | Description
public System.Void frmVertragskontakt(); |
public System.Void frmVertragskontakt(int, int, int); |

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt Methods

frmVertragskontakt Methods
CollapseAll image DropDown image

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | AddChanges | Allg Eventhandler für Chanage-Ereignise festlegen
Supported by the .NET Compact Framework. | BeendenToolStripMenuItem_Click | Menu Beenden
Supported by the .NET Compact Framework. | C1Kontaktpersonen_MouseDown | C1Kontaktperson Mousedown
Supported by the .NET Compact Framework. | ChangesMade | Envent-Handler für Change-Ereignisse
Supported by the .NET Compact Framework. | Check_Changes | Prüfung, ob Datenänderungen vorgenommen wurden.
Supported by the .NET Compact Framework. | DetailsKontaktpersonToolStripMenuItem_Click | C1Kontaktperson Details anzeigen
Supported by the .NET Compact Framework. | DetailsVertragspartnerToolStripMenuItem_Click | Vertragspartner anzeigen
Supported by the .NET Compact Framework. | FormularClosing | Schliessen des Formulars
Supported by the .NET Compact Framework. | GetControl | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
Supported by the .NET Compact Framework. | Get_Data | Person laden und präsentieren
Supported by the .NET Compact Framework. | Get_Vertragspartner |
Supported by the .NET Compact Framework. | Get_Vertragspartner_Kontakte |
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | Load_Rollen |
Supported by the .NET Compact Framework. | Load_Securitylevel | Laden der Securitylevel-Daten in die Combobox
Supported by the .NET Compact Framework. | NeuKontaktpersonToolStripMenuItem_Click | C1Kontaktperson neue Person erfassen
Supported by the .NET Compact Framework. | NeuVertragspartnerToolStripMenuItem_Click | Neuer Vertragspartner eröffnen
Supported by the .NET Compact Framework. | Save_Data | Daten sichern, sofern Änderungen vorgenommen worden sind
Supported by the .NET Compact Framework. | SuchenVertragspartnerToolStripMenuItem_Click | Vertragspartner suchen
Supported by the .NET Compact Framework. | TSBtnCopy_Click | Datensatz kopieren
Supported by the .NET Compact Framework. | TSBtnDelete_Click | Aktueller Datensatz inaktivieren
Supported by the .NET Compact Framework. | TSBtnNew_Click | Neuer Datensatz erstellen
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Formular schliessen
Supported by the .NET Compact Framework. | TSBtnSave_Click | Sicherungs-Button betätigt
Supported by the .NET Compact Framework. | btnVertragspartnersuche_Click | Vertragspartner suchen
Supported by the .NET Compact Framework. | frmVertragskontakt_Load |
Top

Expand image See Also

Reference

frmVertragskontakt Class


frmVertragskontakt.AddChanges Method

frmVertragskontakt.AddChanges Method

Allg Eventhandler für Chanage-Ereignise festlegen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub AddChanges( _
   ByVal Container As Control _
)
C#
private System.Void AddChanges(
   Control Container
);
C++

private:
System::Void AddChanges(
   Control^ Container
)
JScript
private function AddChanges(
    Container : Control
);

Parameters

Container

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub AddChanges(ByVal Container As Control)
        Dim l As New List(Of Control)
        Me.GetControl(Me, "*", l)
        Dim evh As EventHandler = AddressOf ChangesMade
        For Each c As Control In l
            If TypeOf c Is TextBox Then
                Dim ctl As TextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is MaskedTextBox Then
                Dim ctl As MaskedTextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is ComboBox Then
                Dim ctl As ComboBox = c
                AddHandler ctl.SelectedValueChanged, evh
            End If
            If TypeOf c Is CheckBox Then
                Dim ctl As CheckBox = c
                AddHandler ctl.CheckedChanged, evh
            End If
            If TypeOf c Is ListBox Then
                Dim ctl As ListBox = c
                AddHandler ctl.SelectedValueChanged, evh
            End If
        Next
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.BeendenToolStripMenuItem_Click Method

frmVertragskontakt.BeendenToolStripMenuItem_Click Method

Menu Beenden
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click
C#
private System.Void BeendenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void BeendenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function BeendenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.TSBtnQuit_Click(sender, e)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.C1Kontaktpersonen_MouseDown Method

frmVertragskontakt.C1Kontaktpersonen_MouseDown Method

C1Kontaktperson Mousedown
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub C1Kontaktpersonen_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Kontaktpersonen.MouseDown
C#
private System.Void C1Kontaktpersonen_MouseDown(
   object sender,
   MouseEventArgs e
);
C++

private:
System::Void C1Kontaktpersonen_MouseDown(
   object^ sender,
   MouseEventArgs^ e
)
JScript
private function C1Kontaktpersonen_MouseDown(
    sender : object,
    e : MouseEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub C1Kontaktpersonen_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Kontaktpersonen.MouseDown
        Me.C1Kontaktpersonen.Bookmark = Me.C1Kontaktpersonen.RowContaining(e.Y)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.ChangesMade Method

frmVertragskontakt.ChangesMade Method

Envent-Handler für Change-Ereignisse
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub ChangesMade( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
private System.Void ChangesMade(
   object sender,
   EventArgs e
);
C++

private:
System::Void ChangesMade(
   object^ sender,
   EventArgs^ e
)
JScript
private function ChangesMade(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub ChangesMade(ByVal sender As Object, ByVal e As System.EventArgs)
        Me.FormDataChanged = True
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.Check_Changes Method

frmVertragskontakt.Check_Changes Method

Prüfung, ob Datenänderungen vorgenommen wurden.
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Check_Changes() As Boolean
C#
private bool Check_Changes();
C++

private:
bool Check_Changes()
JScript
private function Check_Changes() : boolean;

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Function Check_Changes() As Boolean
        If Me.FormReadonly Then Exit Function
        Dim msgres As MsgBoxResult
        If Me.FormDataChanged Then
            msgres = msg.Show_MessageYesNoCancel(3)
            Select Case msgres
                Case MsgBoxResult.Yes
                    Save_Data()
                    Return True
                Case MsgBoxResult.Cancel
                    Return False
                Case MsgBoxResult.No
                    Return True
            End Select
        Else
            Return True
        End If
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.DetailsKontaktpersonToolStripMenuItem_Click Method

frmVertragskontakt.DetailsKontaktpersonToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

C1Kontaktperson Details anzeigen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub DetailsKontaktpersonToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   DetailsKontaktpersonToolStripMenuItem.Click
C#
private System.Void DetailsKontaktpersonToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void DetailsKontaktpersonToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function DetailsKontaktpersonToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub DetailsKontaktpersonToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DetailsKontaktpersonToolStripMenuItem.Click
        Try
            Dim f As New frmPerson(Me.C1Kontaktpersonen.Columns("PersonNr").Value, Me.VertragspartnerNr, Me.FormReadonly)
            f.ShowDialog()
            f.Dispose()
        Catch
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.DetailsVertragspartnerToolStripMenuItem_Click Method

frmVertragskontakt.DetailsVertragspartnerToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

Vertragspartner anzeigen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub DetailsVertragspartnerToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   DetailsVertragspartnerToolStripMenuItem.Click
C#
private System.Void DetailsVertragspartnerToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void DetailsVertragspartnerToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function DetailsVertragspartnerToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub DetailsVertragspartnerToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DetailsVertragspartnerToolStripMenuItem.Click
        Dim f As New frmVertragspartner(Me.VertragspartnerNr, Me.FormReadonly)
        f.ShowDialog()
        f.dispose()
        Me.Get_Vertragspartner()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.Dispose Method

frmVertragskontakt.Dispose Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
C#
[System.Diagnostics.DebuggerNonUserCode()]
protected override System.Void Dispose(
   bool disposing
);
C++
[System.Diagnostics.DebuggerNonUserCode()]

protected:
System::Void Dispose(
   bool disposing
)
JScript
protected
   System.Diagnostics.DebuggerNonUserCode()
function Dispose(
    disposing : boolean
);

Parameters

disposing

Expand image Source code

Visual Basic CopyCode image Copy Code
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.FormularClosing Method

frmVertragskontakt.FormularClosing Method

Schliessen des Formulars
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub FormularClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing
C#
private System.Void FormularClosing(
   object sender,
   FormClosingEventArgs e
);
C++

private:
System::Void FormularClosing(
   object^ sender,
   FormClosingEventArgs^ e
)
JScript
private function FormularClosing(
    sender : object,
    e : FormClosingEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub FormularClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.FormReadonly = True Then Exit Sub
        If Check_Changes() = False Then
            e.Cancel = True
        Else
            Me.Dispose()
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.GetControl Method

frmVertragskontakt.GetControl Method

Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function GetControl( _
   ByVal BaseControl As Control, _
   ByVal Key As String, _
   ByRef L As List(Of Control), _
   Optional ByVal ReturnAtFirstElement As Boolean = False _
) As Boolean
C#
private bool GetControl(
   Control BaseControl,
   string Key,
   ref List<Control> L,
   bool ReturnAtFirstElement
);
C++

private:
bool GetControl(
   Control^ BaseControl,
   String^ Key,
   List<Control^>^& L,
   bool ReturnAtFirstElement
)
JScript
JScript does not support generic types and methods.

Parameters

BaseControl

Base-Contrlo (z.B. aktuelles Formular

Key

Schlüssel welcher gesucht werden soll

L

Liste der gefundenen Objekte

ReturnAtFirstElement

Optional. The default value is False.

Return Value

True wenn eines oder mehr Controls gefunden wurden, false wenn kein Control gefunden wurde.

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Function GetControl(ByVal BaseControl As Control, ByVal Key As String, ByRef L As List(Of Control), Optional ByVal ReturnAtFirstElement As Boolean = False) As Boolean
        If L Is Nothing Then L = New List(Of Control)
        Dim Gut As Boolean
        Dim ReturnFlag As Boolean = False
        If Key IsNot Nothing Then Key = Key.ToLower

        If BaseControl.HasChildren = True Then
            For Each ctl As Control In BaseControl.Controls
                Gut = False
                If Key Is Nothing Then
                    Gut = True
                Else
                    If ctl.Name.Length >= Key.Length Then
                        Key = Key.ToLower
                        If Key.StartsWith("*") Then
                            If Key.Substring(1) = ctl.Name.ToLower.Substring(ctl.Name.Length - (Key.Length - 1), Key.Length - 1) Then Gut = True
                        ElseIf Key.EndsWith("*") Then
                            If Key.Substring(0, Key.Length - 1) = ctl.Name.ToLower.Substring(0, Key.Length - 1) Then Gut = True
                        Else
                            If Key = ctl.Name.ToLower Then Gut = True
                        End If
                    End If
                End If

                If Gut = True Then
                    L.Add(ctl)
                    If ReturnAtFirstElement = True Then ReturnFlag = True
                End If
                If ReturnFlag = False Then
                    Call GetControl(ctl, Key, L)
                End If
            Next
        End If

        If L.Count - 1 > -1 Then
            Return True
        Else
            Return False
        End If
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.Get_Data Method

frmVertragskontakt.Get_Data Method

Person laden und präsentieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Get_Data( _
   ByVal Nr As Integer _
)
C#
private System.Void Get_Data(
   int Nr
);
C++

private:
System::Void Get_Data(
   int Nr
)
JScript
private function Get_Data(
    Nr : int
);

Parameters

Nr

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Get_Data(ByVal Nr As Integer)
        Me.Kontaktperson.Get_Vertragskontakt(Nr)
        Me.lbRolle.SelectedValue = Me.Kontaktperson.iKontakttypNr.Value
        Me.cbIntern.Checked = Me.Kontaktperson.bIntern.Value = True
        Me.txtErstellt_am.Text = Me.Kontaktperson.daErstellt_am.ToString
        Me.txtMutiert_am.Text = Me.Kontaktperson.daMutiert_am.ToString
        Me.txtBemerkung.Text = Me.Kontaktperson.sBemerkung.ToString
        Me.txtMutierer.Text = Me.Kontaktperson.iMutierer.Value
        Me.cbaktiv.Checked = Me.Kontaktperson.bAktiv.Value = True
        Me.cboxSecurityLevel.SelectedValue = Me.Kontaktperson.iSecurityLevelNr.Value

        If Me.Kontaktperson.iPersonNr.Value <> 0 Then
            Try
                Person.cpMainConnectionProvider = Globals.conn
                Person.iPersonNr = New SqlInt32(CType(Me.Kontaktperson.iPersonNr.Value, Int32))
                Person.SelectOne()
                Me.VertragspartnerNr = Person.iVertragspartnernr.Value
            Catch
            End Try
        End If

        Me.Get_Vertragspartner()

        Dim i As Integer = 0
        For i = 0 To Me.C1Kontaktpersonen.Splits(0).Rows.Count - 1
            Me.C1Kontaktpersonen.Bookmark = i
            If Me.C1Kontaktpersonen.Columns("PersonNr").CellText(i) = Me.Kontaktperson.iPersonNr.Value Then Exit For
        Next
        Me.FormDataChanged = False
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.Get_Vertragspartner Method

frmVertragskontakt.Get_Vertragspartner Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Get_Vertragspartner() As Object
C#
private object Get_Vertragspartner();
C++

private:
object^ Get_Vertragspartner()
JScript
private function Get_Vertragspartner() : object;

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Function Get_Vertragspartner()
        Me.txtVertragspartner.Text = Me.Vertragspartner.Get_Vertragspartnername(Me.VertragspartnerNr)
        Get_Vertragspartner_Kontakte()
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.Get_Vertragspartner_Kontakte Method

frmVertragskontakt.Get_Vertragspartner_Kontakte Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Get_Vertragspartner_Kontakte() As Object
C#
private object Get_Vertragspartner_Kontakte();
C++

private:
object^ Get_Vertragspartner_Kontakte()
JScript
private function Get_Vertragspartner_Kontakte() : object;

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Function Get_Vertragspartner_Kontakte()
        Try
            'If Check_Changes() = False Then Exit Function
        Catch ex As Exception

        End Try
        Me.C1Kontaktpersonen.Enabled = False
        Me.Vertragspartner.Get_Kontaktpersonen(Me.C1Kontaktpersonen)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Kontaktpersonen, "Person", Me.Vertragspartner.Kontaktpersonen.Tabledata)
        sec.Set_Form_Security(Me)
        Me.C1Kontaktpersonen.Enabled = True
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.InitializeComponent Method

frmVertragskontakt.InitializeComponent Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()
C#
[System.Diagnostics.DebuggerStepThrough()]
private System.Void InitializeComponent();
C++
[System.Diagnostics.DebuggerStepThrough()]

private:
System::Void InitializeComponent()
JScript
private
   System.Diagnostics.DebuggerStepThrough()
function InitializeComponent();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmVertragskontakt))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.TSBtnCopy = New System.Windows.Forms.ToolStripButton
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.btnVertragspartnersuche = New System.Windows.Forms.Button
        Me.txtVertragspartner = New System.Windows.Forms.TextBox
        Me.VertragspartnerContextMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.DetailsVertragspartnerToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.NeuVertragspartnerToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStripMenuItem1 = New System.Windows.Forms.ToolStripSeparator
        Me.SuchenVertragspartnerToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.lblVertragspartner = New System.Windows.Forms.Label
        Me.KontaktpersonMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.DetailsKontaktpersonToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.NeuKontaktpersonToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.lblKontaktperson = New System.Windows.Forms.Label
        Me.lblRolle = New System.Windows.Forms.Label
        Me.lblAktiv = New System.Windows.Forms.Label
        Me.cbaktiv = New System.Windows.Forms.CheckBox
        Me.lblIntern = New System.Windows.Forms.Label
        Me.cbIntern = New System.Windows.Forms.CheckBox
        Me.cboxSecurityLevel = New System.Windows.Forms.ComboBox
        Me.lblSecurityLebel = New System.Windows.Forms.Label
        Me.txtMutierer = New System.Windows.Forms.TextBox
        Me.txtMutiert_am = New System.Windows.Forms.TextBox
        Me.txtErstellt_am = New System.Windows.Forms.TextBox
        Me.lblMutierer = New System.Windows.Forms.Label
        Me.lblMutiert_am = New System.Windows.Forms.Label
        Me.lblErstelltam = New System.Windows.Forms.Label
        Me.lbRolle = New System.Windows.Forms.ListBox
        Me.C1Kontaktpersonen = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.txtBemerkung = New System.Windows.Forms.TextBox
        Me.lblBemerkung = New System.Windows.Forms.Label
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.VertragspartnerContextMenuStrip.SuspendLayout()
        Me.KontaktpersonMenuStrip.SuspendLayout()
        CType(Me.C1Kontaktpersonen, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(594, 24)
        Me.MenuStrip1.TabIndex = 16
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(116, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnCopy, Me.TSBtnNew, Me.TSBtnDelete})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(594, 25)
        Me.ToolStrip1.TabIndex = 17
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "ToolStripButton1"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'TSBtnCopy
        '
        Me.TSBtnCopy.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnCopy.Image = CType(resources.GetObject("TSBtnCopy.Image"), System.Drawing.Image)
        Me.TSBtnCopy.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnCopy.Name = "TSBtnCopy"
        Me.TSBtnCopy.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnCopy.Text = "ToolStripButton2"
        Me.TSBtnCopy.ToolTipText = "Datensatz kopieren"
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "ToolStripButton3"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "ToolStripButton3"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'btnVertragspartnersuche
        '
        Me.btnVertragspartnersuche.Image = CType(resources.GetObject("btnVertragspartnersuche.Image"), System.Drawing.Image)
        Me.btnVertragspartnersuche.Location = New System.Drawing.Point(368, 63)
        Me.btnVertragspartnersuche.Name = "btnVertragspartnersuche"
        Me.btnVertragspartnersuche.Size = New System.Drawing.Size(20, 20)
        Me.btnVertragspartnersuche.TabIndex = 108
        Me.btnVertragspartnersuche.Text = "Button1"
        Me.btnVertragspartnersuche.UseVisualStyleBackColor = True
        '
        'txtVertragspartner
        '
        Me.txtVertragspartner.ContextMenuStrip = Me.VertragspartnerContextMenuStrip
        Me.txtVertragspartner.Location = New System.Drawing.Point(103, 62)
        Me.txtVertragspartner.Name = "txtVertragspartner"
        Me.txtVertragspartner.Size = New System.Drawing.Size(268, 20)
        Me.txtVertragspartner.TabIndex = 0
        '
        'VertragspartnerContextMenuStrip
        '
        Me.VertragspartnerContextMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DetailsVertragspartnerToolStripMenuItem, Me.NeuVertragspartnerToolStripMenuItem, Me.ToolStripMenuItem1, Me.SuchenVertragspartnerToolStripMenuItem})
        Me.VertragspartnerContextMenuStrip.Name = "VertragspartnerContextMenuStrip"
        Me.VertragspartnerContextMenuStrip.Size = New System.Drawing.Size(110, 76)
        '
        'DetailsVertragspartnerToolStripMenuItem
        '
        Me.DetailsVertragspartnerToolStripMenuItem.Name = "DetailsVertragspartnerToolStripMenuItem"
        Me.DetailsVertragspartnerToolStripMenuItem.Size = New System.Drawing.Size(109, 22)
        Me.DetailsVertragspartnerToolStripMenuItem.Text = "&Details"
        '
        'NeuVertragspartnerToolStripMenuItem
        '
        Me.NeuVertragspartnerToolStripMenuItem.Name = "NeuVertragspartnerToolStripMenuItem"
        Me.NeuVertragspartnerToolStripMenuItem.Size = New System.Drawing.Size(109, 22)
        Me.NeuVertragspartnerToolStripMenuItem.Text = "&Neu"
        '
        'ToolStripMenuItem1
        '
        Me.ToolStripMenuItem1.Name = "ToolStripMenuItem1"
        Me.ToolStripMenuItem1.Size = New System.Drawing.Size(106, 6)
        '
        'SuchenVertragspartnerToolStripMenuItem
        '
        Me.SuchenVertragspartnerToolStripMenuItem.Name = "SuchenVertragspartnerToolStripMenuItem"
        Me.SuchenVertragspartnerToolStripMenuItem.Size = New System.Drawing.Size(109, 22)
        Me.SuchenVertragspartnerToolStripMenuItem.Text = "&Suchen"
        '
        'lblVertragspartner
        '
        Me.lblVertragspartner.AutoSize = True
        Me.lblVertragspartner.Location = New System.Drawing.Point(12, 67)
        Me.lblVertragspartner.Name = "lblVertragspartner"
        Me.lblVertragspartner.Size = New System.Drawing.Size(79, 13)
        Me.lblVertragspartner.TabIndex = 107
        Me.lblVertragspartner.Text = "Vertragspartner"
        '
        'KontaktpersonMenuStrip
        '
        Me.KontaktpersonMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DetailsKontaktpersonToolStripMenuItem, Me.NeuKontaktpersonToolStripMenuItem})
        Me.KontaktpersonMenuStrip.Name = "KontaktpersonMenuStrip"
        Me.KontaktpersonMenuStrip.Size = New System.Drawing.Size(107, 48)
        '
        'DetailsKontaktpersonToolStripMenuItem
        '
        Me.DetailsKontaktpersonToolStripMenuItem.Name = "DetailsKontaktpersonToolStripMenuItem"
        Me.DetailsKontaktpersonToolStripMenuItem.Size = New System.Drawing.Size(106, 22)
        Me.DetailsKontaktpersonToolStripMenuItem.Text = "&Details"
        '
        'NeuKontaktpersonToolStripMenuItem
        '
        Me.NeuKontaktpersonToolStripMenuItem.Name = "NeuKontaktpersonToolStripMenuItem"
        Me.NeuKontaktpersonToolStripMenuItem.Size = New System.Drawing.Size(106, 22)
        Me.NeuKontaktpersonToolStripMenuItem.Text = "&Neu"
        '
        'lblKontaktperson
        '
        Me.lblKontaktperson.AutoSize = True
        Me.lblKontaktperson.Location = New System.Drawing.Point(12, 88)
        Me.lblKontaktperson.Name = "lblKontaktperson"
        Me.lblKontaktperson.Size = New System.Drawing.Size(76, 13)
        Me.lblKontaktperson.TabIndex = 110
        Me.lblKontaktperson.Text = "Kontaktperson"
        '
        'lblRolle
        '
        Me.lblRolle.AutoSize = True
        Me.lblRolle.Location = New System.Drawing.Point(12, 240)
        Me.lblRolle.Name = "lblRolle"
        Me.lblRolle.Size = New System.Drawing.Size(31, 13)
        Me.lblRolle.TabIndex = 112
        Me.lblRolle.Text = "Rolle"
        '
        'lblAktiv
        '
        Me.lblAktiv.AccessibleDescription = "Name"
        Me.lblAktiv.AutoSize = True
        Me.lblAktiv.Location = New System.Drawing.Point(12, 415)
        Me.lblAktiv.Name = "lblAktiv"
        Me.lblAktiv.Size = New System.Drawing.Size(31, 13)
        Me.lblAktiv.TabIndex = 114
        Me.lblAktiv.Text = "Aktiv"
        '
        'cbaktiv
        '
        Me.cbaktiv.AutoSize = True
        Me.cbaktiv.Location = New System.Drawing.Point(103, 414)
        Me.cbaktiv.Name = "cbaktiv"
        Me.cbaktiv.Size = New System.Drawing.Size(15, 14)
        Me.cbaktiv.TabIndex = 4
        Me.cbaktiv.UseVisualStyleBackColor = True
        '
        'lblIntern
        '
        Me.lblIntern.AccessibleDescription = "Name"
        Me.lblIntern.AutoSize = True
        Me.lblIntern.Location = New System.Drawing.Point(12, 344)
        Me.lblIntern.Name = "lblIntern"
        Me.lblIntern.Size = New System.Drawing.Size(34, 13)
        Me.lblIntern.TabIndex = 116
        Me.lblIntern.Text = "Intern"
        '
        'cbIntern
        '
        Me.cbIntern.AutoSize = True
        Me.cbIntern.Location = New System.Drawing.Point(103, 343)
        Me.cbIntern.Name = "cbIntern"
        Me.cbIntern.Size = New System.Drawing.Size(15, 14)
        Me.cbIntern.TabIndex = 3
        Me.cbIntern.UseVisualStyleBackColor = True
        '
        'cboxSecurityLevel
        '
        Me.cboxSecurityLevel.FormattingEnabled = True
        Me.cboxSecurityLevel.Location = New System.Drawing.Point(103, 434)
        Me.cboxSecurityLevel.Name = "cboxSecurityLevel"
        Me.cboxSecurityLevel.Size = New System.Drawing.Size(101, 21)
        Me.cboxSecurityLevel.TabIndex = 5
        '
        'lblSecurityLebel
        '
        Me.lblSecurityLebel.AutoSize = True
        Me.lblSecurityLebel.Location = New System.Drawing.Point(12, 437)
        Me.lblSecurityLebel.Name = "lblSecurityLebel"
        Me.lblSecurityLebel.Size = New System.Drawing.Size(71, 13)
        Me.lblSecurityLebel.TabIndex = 132
        Me.lblSecurityLebel.Text = "SecurityLevel"
        '
        'txtMutierer
        '
        Me.txtMutierer.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutierer.Location = New System.Drawing.Point(379, 465)
        Me.txtMutierer.Name = "txtMutierer"
        Me.txtMutierer.Size = New System.Drawing.Size(71, 20)
        Me.txtMutierer.TabIndex = 138
        '
        'txtMutiert_am
        '
        Me.txtMutiert_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutiert_am.Location = New System.Drawing.Point(217, 465)
        Me.txtMutiert_am.Name = "txtMutiert_am"
        Me.txtMutiert_am.Size = New System.Drawing.Size(79, 20)
        Me.txtMutiert_am.TabIndex = 137
        '
        'txtErstellt_am
        '
        Me.txtErstellt_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtErstellt_am.Location = New System.Drawing.Point(73, 465)
        Me.txtErstellt_am.Name = "txtErstellt_am"
        Me.txtErstellt_am.Size = New System.Drawing.Size(79, 20)
        Me.txtErstellt_am.TabIndex = 136
        '
        'lblMutierer
        '
        Me.lblMutierer.AccessibleDescription = "Name"
        Me.lblMutierer.AutoSize = True
        Me.lblMutierer.Location = New System.Drawing.Point(308, 468)
        Me.lblMutierer.Name = "lblMutierer"
        Me.lblMutierer.Size = New System.Drawing.Size(72, 13)
        Me.lblMutierer.TabIndex = 135
        Me.lblMutierer.Text = "Mutiert durch:"
        '
        'lblMutiert_am
        '
        Me.lblMutiert_am.AccessibleDescription = "Name"
        Me.lblMutiert_am.AutoSize = True
        Me.lblMutiert_am.Location = New System.Drawing.Point(158, 468)
        Me.lblMutiert_am.Name = "lblMutiert_am"
        Me.lblMutiert_am.Size = New System.Drawing.Size(59, 13)
        Me.lblMutiert_am.TabIndex = 134
        Me.lblMutiert_am.Text = "Mutiert am:"
        '
        'lblErstelltam
        '
        Me.lblErstelltam.AccessibleDescription = "Name"
        Me.lblErstelltam.AutoSize = True
        Me.lblErstelltam.Location = New System.Drawing.Point(12, 468)
        Me.lblErstelltam.Name = "lblErstelltam"
        Me.lblErstelltam.Size = New System.Drawing.Size(58, 13)
        Me.lblErstelltam.TabIndex = 133
        Me.lblErstelltam.Text = "Erstellt am:"
        '
        'lbRolle
        '
        Me.lbRolle.FormattingEnabled = True
        Me.lbRolle.Location = New System.Drawing.Point(103, 240)
        Me.lbRolle.Name = "lbRolle"
        Me.lbRolle.Size = New System.Drawing.Size(268, 95)
        Me.lbRolle.TabIndex = 140
        '
        'C1Kontaktpersonen
        '
        Me.C1Kontaktpersonen.AlternatingRows = True
        Me.C1Kontaktpersonen.ContextMenuStrip = Me.KontaktpersonMenuStrip
        Me.C1Kontaktpersonen.FilterBar = True
        Me.C1Kontaktpersonen.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Kontaktpersonen.Images.Add(CType(resources.GetObject("C1Kontaktpersonen.Images"), System.Drawing.Image))
        Me.C1Kontaktpersonen.Location = New System.Drawing.Point(103, 92)
        Me.C1Kontaktpersonen.Name = "C1Kontaktpersonen"
        Me.C1Kontaktpersonen.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Kontaktpersonen.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Kontaktpersonen.PreviewInfo.ZoomFactor = 75
        Me.C1Kontaktpersonen.PrintInfo.PageSettings = CType(resources.GetObject("C1Kontaktpersonen.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Kontaktpersonen.Size = New System.Drawing.Size(479, 142)
        Me.C1Kontaktpersonen.TabIndex = 141
        Me.C1Kontaktpersonen.Text = "C1TrueDBGrid1"
        Me.C1Kontaktpersonen.PropBag = resources.GetString("C1Kontaktpersonen.PropBag")
        '
        'txtBemerkung
        '
        Me.txtBemerkung.Location = New System.Drawing.Point(103, 363)
        Me.txtBemerkung.Multiline = True
        Me.txtBemerkung.Name = "txtBemerkung"
        Me.txtBemerkung.Size = New System.Drawing.Size(479, 45)
        Me.txtBemerkung.TabIndex = 142
        '
        'lblBemerkung
        '
        Me.lblBemerkung.AccessibleDescription = "Name"
        Me.lblBemerkung.AutoSize = True
        Me.lblBemerkung.Location = New System.Drawing.Point(12, 366)
        Me.lblBemerkung.Name = "lblBemerkung"
        Me.lblBemerkung.Size = New System.Drawing.Size(61, 13)
        Me.lblBemerkung.TabIndex = 143
        Me.lblBemerkung.Text = "Bemerkung"
        '
        'frmVertragskontakt
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(594, 493)
        Me.Controls.Add(Me.lblBemerkung)
        Me.Controls.Add(Me.txtBemerkung)
        Me.Controls.Add(Me.C1Kontaktpersonen)
        Me.Controls.Add(Me.lbRolle)
        Me.Controls.Add(Me.txtMutierer)
        Me.Controls.Add(Me.txtMutiert_am)
        Me.Controls.Add(Me.txtErstellt_am)
        Me.Controls.Add(Me.lblMutierer)
        Me.Controls.Add(Me.lblMutiert_am)
        Me.Controls.Add(Me.lblErstelltam)
        Me.Controls.Add(Me.cboxSecurityLevel)
        Me.Controls.Add(Me.lblSecurityLebel)
        Me.Controls.Add(Me.lblIntern)
        Me.Controls.Add(Me.cbIntern)
        Me.Controls.Add(Me.lblAktiv)
        Me.Controls.Add(Me.cbaktiv)
        Me.Controls.Add(Me.lblRolle)
        Me.Controls.Add(Me.lblKontaktperson)
        Me.Controls.Add(Me.btnVertragspartnersuche)
        Me.Controls.Add(Me.txtVertragspartner)
        Me.Controls.Add(Me.lblVertragspartner)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmVertragskontakt"
        Me.Text = "Vertragskontakt"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.VertragspartnerContextMenuStrip.ResumeLayout(False)
        Me.KontaktpersonMenuStrip.ResumeLayout(False)
        CType(Me.C1Kontaktpersonen, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.Load_Rollen Method

frmVertragskontakt.Load_Rollen Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Load_Rollen() As Object
C#
private object Load_Rollen();
C++

private:
object^ Load_Rollen()
JScript
private function Load_Rollen() : object;

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Function Load_Rollen()
        Dim rollen As New TKB.VV.DB.clsKontakttyp
        Dim rollendata As New DataTable
        rollen.cpMainConnectionProvider = Globals.conn
        rollendata = rollen.SelectAll()
        Me.lbRolle.DataSource = rollendata
        Me.lbRolle.ValueMember = "KontakttypNr"
        Me.lbRolle.DisplayMember = "Bezeichnung"
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.Load_Securitylevel Method

frmVertragskontakt.Load_Securitylevel Method

Laden der Securitylevel-Daten in die Combobox
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Load_Securitylevel()
C#
private System.Void Load_Securitylevel();
C++

private:
System::Void Load_Securitylevel()
JScript
private function Load_Securitylevel();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Load_Securitylevel()
        Dim seclevel As New TKB.VV.DB.clsSecurityLevel
        Dim secleveldata As New DataTable

        seclevel.cpMainConnectionProvider = Globals.conn
        Globals.conn.OpenConnection()
        secleveldata = seclevel.SelectAll
        Globals.conn.CloseConnection(True)

        Me.cboxSecurityLevel.DataSource = secleveldata
        Me.cboxSecurityLevel.DisplayMember = "Bezeichnung"
        Me.cboxSecurityLevel.ValueMember = "SecurityLevelNr"

        seclevel.Dispose()

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.NeuKontaktpersonToolStripMenuItem_Click Method

frmVertragskontakt.NeuKontaktpersonToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

C1Kontaktperson neue Person erfassen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub NeuKontaktpersonToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   NeuKontaktpersonToolStripMenuItem.Click
C#
private System.Void NeuKontaktpersonToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void NeuKontaktpersonToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function NeuKontaktpersonToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub NeuKontaktpersonToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles NeuKontaktpersonToolStripMenuItem.Click
        Dim i As Integer = Me.Vertragspartner.Kontaktperson.Add_New(Me.VertragspartnerNr)
        Dim f As New frmPerson(i, Me.VertragspartnerNr, Me.FormReadonly)
        f.ShowDialog()
        f.Dispose()
        Me.Get_Vertragspartner_Kontakte()
        Dim r As Integer = 0
        For r = 0 To Me.C1Kontaktpersonen.Splits(0).Rows.Count - 1
            Me.C1Kontaktpersonen.Bookmark = r
            If Me.C1Kontaktpersonen.Columns("PersonNr").CellText(r) = i Then Exit For
        Next
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.NeuVertragspartnerToolStripMenuItem_Click Method

frmVertragskontakt.NeuVertragspartnerToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

Neuer Vertragspartner eröffnen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub NeuVertragspartnerToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   NeuVertragspartnerToolStripMenuItem.Click
C#
private System.Void NeuVertragspartnerToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void NeuVertragspartnerToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function NeuVertragspartnerToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub NeuVertragspartnerToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles NeuVertragspartnerToolStripMenuItem.Click
        Dim i As Integer = Me.Vertragspartner.Add_New
        Dim f As New frmVertragspartner(i, Me.FormReadonly)
        f.ShowDialog()
        f.dispose()
        Me.VertragspartnerNr = i
        Me.Get_Vertragspartner()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.Save_Data Method

frmVertragskontakt.Save_Data Method

Daten sichern, sofern Änderungen vorgenommen worden sind
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Save_Data()
C#
private System.Void Save_Data();
C++

private:
System::Void Save_Data()
JScript
private function Save_Data();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Save_Data()

        If Me.FormDataChanged Then
            Me.Kontaktperson.iKontakttypNr = New SqlInt32(CType(Me.lbRolle.SelectedValue, Int32))
            Me.Kontaktperson.iPersonNr = New SqlInt32(CType(Me.C1Kontaktpersonen.Columns("PersonNr").Value, Int32))
            Me.Kontaktperson.bIntern = New SqlBoolean(CType(Me.cbIntern.Checked, Boolean))
            Me.Kontaktperson.bAktiv = New SqlBoolean(CType(Me.cbaktiv.Checked, Boolean))
            Me.Kontaktperson.sBemerkung = New SqlString(CType(Me.txtBemerkung.Text, String))
            Me.Kontaktperson.iSecurityLevelNr = New SqlInt32(CType(Me.cboxSecurityLevel.SelectedValue, Int32))
            Get_Data(Me.Kontaktperson.Save_Data)
            Me.FormDataChanged = False
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.SuchenVertragspartnerToolStripMenuItem_Click Method

frmVertragskontakt.SuchenVertragspartnerToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

Vertragspartner suchen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub SuchenVertragspartnerToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   SuchenVertragspartnerToolStripMenuItem.Click
C#
private System.Void SuchenVertragspartnerToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void SuchenVertragspartnerToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function SuchenVertragspartnerToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub SuchenVertragspartnerToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles SuchenVertragspartnerToolStripMenuItem.Click
        Me.btnVertragspartnersuche_Click(sender, e)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.TSBtnCopy_Click Method

frmVertragskontakt.TSBtnCopy_Click Method

Datensatz kopieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnCopy_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnCopy.Click
C#
private System.Void TSBtnCopy_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnCopy_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnCopy_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnCopy_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnCopy.Click
        If Me.Check_Changes = False Then Exit Sub
        Me.Get_Data(Kontaktperson.Create_Copy(Me.Kontaktperson.iVertragsKontaktNr.Value))
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.TSBtnDelete_Click Method

frmVertragskontakt.TSBtnDelete_Click Method

Aktueller Datensatz inaktivieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click
C#
private System.Void TSBtnDelete_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnDelete_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnDelete_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
        If msg.Show_MessageYesNo(250) = MsgBoxResult.Yes Then
            Me.Kontaktperson.Delete_Vertragskontakt(Me.Kontaktperson.iVertragsKontaktNr.Value)
            Me.Close()
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.TSBtnNew_Click Method

frmVertragskontakt.TSBtnNew_Click Method

Neuer Datensatz erstellen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnNew_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnNew.Click
C#
private System.Void TSBtnNew_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnNew_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnNew_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnNew.Click
        If Me.Check_Changes = False Then Exit Sub
        Me.Get_Data(Me.Kontaktperson.Add_New(Me.Vertragselementnr))
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.TSBtnQuit_Click Method

frmVertragskontakt.TSBtnQuit_Click Method

Formular schliessen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click
C#
private System.Void TSBtnQuit_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnQuit_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnQuit_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.TSBtnSave_Click Method

frmVertragskontakt.TSBtnSave_Click Method

Sicherungs-Button betätigt
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click
C#
private System.Void TSBtnSave_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnSave_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnSave_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Me.Save_Data()
        Me.txtMutiert_am.Text = Me.Kontaktperson.daMutiert_am.ToString
        Me.FormDataChanged = False
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.btnVertragspartnersuche_Click Method

frmVertragskontakt.btnVertragspartnersuche_Click Method

Vertragspartner suchen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub btnVertragspartnersuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnVertragspartnersuche.Click
C#
private System.Void btnVertragspartnersuche_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void btnVertragspartnersuche_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function btnVertragspartnersuche_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub btnVertragspartnersuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnVertragspartnersuche.Click
        Dim f As New frmVertragspartnerSuche
        f.ShowDialog()
        If f.Vertragspartnernr <> -1 Then
            Me.VertragspartnerNr = f.Vertragspartnernr
            f.Dispose()
            Me.Get_Vertragspartner()
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt.frmVertragskontakt_Load Method

frmVertragskontakt.frmVertragskontakt_Load Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub frmVertragskontakt_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load
C#
private System.Void frmVertragskontakt_Load(
   object sender,
   EventArgs e
);
C++

private:
System::Void frmVertragskontakt_Load(
   object^ sender,
   EventArgs^ e
)
JScript
private function frmVertragskontakt_Load(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub frmVertragskontakt_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        sec.Set_Form_Security(Me)

        If Me.FormReadonly = True Then Me.TSBtnSave.Enabled = False

        If Me.TSBtnSave.Enabled = False Or Me.TSBtnSave.Visible = False Then
            Me.FormReadonly = True
            Me.TSBtnCopy.Enabled = False
            Me.TSBtnNew.Enabled = False
            Me.TSBtnDelete.Enabled = False
        Else
            Me.FormReadonly = False
        End If

        Load_Securitylevel()
        Load_Rollen()
        Get_Data(Me.Vertragskontaktnr)
        Me.AddChanges(Me)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt Fields

frmVertragskontakt Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | FormDataChanged |
Supported by the .NET Compact Framework. | FormReadonly |
Supported by the .NET Compact Framework. | KontaktNr |
Supported by the .NET Compact Framework. | Kontaktperson |
Supported by the .NET Compact Framework. | Person |
Supported by the .NET Compact Framework. | SpaltenTitel |
Supported by the .NET Compact Framework. | Vertragselementnr |
Supported by the .NET Compact Framework. | Vertragskontaktnr |
Supported by the .NET Compact Framework. | Vertragspartner |
Supported by the .NET Compact Framework. | VertragspartnerNr |
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | msg |
Supported by the .NET Compact Framework. | sec |
Top

Expand image See Also

Reference

frmVertragskontakt Class


FormDataChanged Variable

FormDataChanged Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private FormDataChanged As Boolean
C#
private bool FormDataChanged;
C++
private:
bool FormDataChanged;
JScript
private FormDataChanged : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim FormDataChanged As Boolean = False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


FormReadonly Variable

FormReadonly Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private FormReadonly As Boolean
C#
private bool FormReadonly;
C++
private:
bool FormReadonly;
JScript
private FormReadonly : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim FormReadonly As Boolean = False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


KontaktNr Variable

KontaktNr Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private KontaktNr As Integer
C#
private int KontaktNr;
C++
private:
int KontaktNr;
JScript
private KontaktNr : int

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private KontaktNr As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


Kontaktperson Variable

Kontaktperson Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Kontaktperson As clsKontakt
C#
private clsKontakt Kontaktperson;
C++
private:
clsKontakt^ Kontaktperson;
JScript
private Kontaktperson : clsKontakt

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Kontaktperson As New TKB.VV.Vertrag.clsKontakt

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


Person Variable

Person Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Person As clsPerson
C#
private clsPerson Person;
C++
private:
clsPerson^ Person;
JScript
private Person : clsPerson

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Person As New TKB.VV.DB.clsPerson

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


SpaltenTitel Variable

SpaltenTitel Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private SpaltenTitel As Tabellenspalte
C#
private Tabellenspalte SpaltenTitel;
C++
private:
Tabellenspalte^ SpaltenTitel;
JScript
private SpaltenTitel : Tabellenspalte

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


Vertragselementnr Variable

Vertragselementnr Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Vertragselementnr As Integer
C#
private int Vertragselementnr;
C++
private:
int Vertragselementnr;
JScript
private Vertragselementnr : int

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Vertragselementnr As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


Vertragskontaktnr Variable

Vertragskontaktnr Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Vertragskontaktnr As Integer
C#
private int Vertragskontaktnr;
C++
private:
int Vertragskontaktnr;
JScript
private Vertragskontaktnr : int

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Vertragskontaktnr As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


Vertragspartner Variable

Vertragspartner Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Vertragspartner As clsVertragspartner
C#
private clsVertragspartner Vertragspartner;
C++
private:
clsVertragspartner^ Vertragspartner;
JScript
private Vertragspartner : clsVertragspartner

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Vertragspartner As New TKB.VV.Vertrag.clsVertragspartner

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


VertragspartnerNr Variable

VertragspartnerNr Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private VertragspartnerNr As Integer
C#
private int VertragspartnerNr;
C++
private:
int VertragspartnerNr;
JScript
private VertragspartnerNr : int

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private VertragspartnerNr As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


components Variable

components Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private components As IContainer
C#
private IContainer components;
C++
private:
IContainer^ components;
JScript
private components : IContainer

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private components As System.ComponentModel.IContainer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


msg Variable

msg Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private msg As MyMessage
C#
private MyMessage msg;
C++
private:
MyMessage^ msg;
JScript
private msg : MyMessage

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim msg As New TKB.VV.Utils.MyMessage

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


sec Variable

sec Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private sec As MySecurity
C#
private MySecurity sec;
C++
private:
MySecurity^ sec;
JScript
private sec : MySecurity

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim sec As New TKB.VV.Utils.MySecurity

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragspartner Class

frmVertragspartner Class
See Also Members
collapseAll image DropDown image

Vertragsaprtner
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class frmVertragspartner
    Inherits Form
C#
public class frmVertragspartner : Form
C++

public ref class frmVertragspartner : public Form^
JScript
public class frmVertragspartner
   extends Form

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmVertragspartner

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Members
TKB.VV.SLA
TKB.VV.SLA.clsServiceKatalogTree
TKB.VV.Sysadmin
TKB.VV.Sysadmin.DomainTable
TKB.VV.Utils
TKB.VV.Utils.MyMessage
TKB.VV.Utils.MySecurity
TKB.VV.Utils.Tabellenspalte


frmVertragspartner Members

frmVertragspartner Members
See Also Constructors Methods
CollapseAll image DropDown image

Vertragsaprtner

The following tables list the members exposed by the frmVertragspartner type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | frmVertragspartner Constructor | (Overloaded) Constructor New
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | dispose | (Overloaded) destruction Dispose
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | AddChanges | Allg Eventhandler für Chanage-Ereignise festlegen
Supported by the .NET Compact Framework. | AnzeigenToolStripMenuItem_Click | KontextMenu anzeigen
Supported by the .NET Compact Framework. | BeendenToolStripMenuItem_Click | Menu Beenden
Supported by the .NET Compact Framework. | C1Kontakte_DoubleClick | Doubleclick in der Kontaktliste
Supported by the .NET Compact Framework. | C1Kontakte_MouseDown | Mousedown Kontakte
Supported by the .NET Compact Framework. | ChangesMade | Envent-Handler für Change-Ereignisse
Supported by the .NET Compact Framework. | Check_Changes | Prüfung, ob Datenänderungen vorgenommen wurden.
Supported by the .NET Compact Framework. | FormularClosing | Schliessen des Formulars
Supported by the .NET Compact Framework. | GetControl | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
Supported by the .NET Compact Framework. | Get_Data | Vertragspartner laden
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | KontaktInaktivierenToolStripMenuItem_Click | Kontextmenu Delete
Supported by the .NET Compact Framework. | KontaktKopierenToolStripMenuItem_Click | Kontextmenu Kopieren
Supported by the .NET Compact Framework. | KontaktNeuToolStripMenuItem_Click | Kontextmenu Neu
Supported by the .NET Compact Framework. | Load_Securitylevel | Laden der Securitylevel-Daten in die Combobox
Supported by the .NET Compact Framework. | Refresh_Personen | Personenliste aktualisieren
Supported by the .NET Compact Framework. | Save_Data | Vertragspartner sichern, sofern Änderungen vorgenommen wurden, anschliessend erneut laden
Supported by the .NET Compact Framework. | TS2BtnCopy_Click | Kopie eines Datensatzen erstellen
Supported by the .NET Compact Framework. | TS2BtnDelete_Click | Kontakt löschen (inaktivieren)
Supported by the .NET Compact Framework. | TS2BtnNew_Click | Neuer Kontakt hinzufügen
Supported by the .NET Compact Framework. | TS2BtnView_Click | Personendetails anzeigen bzw. bearbeiten
Supported by the .NET Compact Framework. | TSBtnCopy_Click | Datensatz kopieren
Supported by the .NET Compact Framework. | TSBtnDelete_Click | Aktueller Datensatz inaktivieren
Supported by the .NET Compact Framework. | TSBtnNew_Click | Neuer Datensatz erstellen
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Formular schliessen
Supported by the .NET Compact Framework. | TSBtnSave_Click | Sicherungs-Button betätigt
Supported by the .NET Compact Framework. | TSBtnSuche_Click | Vertragspartner suchen
Supported by the .NET Compact Framework. | frmVertragspartner_Load | Formular laden
Supported by the .NET Compact Framework. | frmVertragspartner_Shown | Anzeige des Suchformulars, wenn keine Vertragspartnernummer vorhanden ist
Supported by the .NET Compact Framework. | txtBemerkung_TextChanged | Änderungsvermerk sofern Änderungen vorgenommen wurden
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | Anzeige |
Supported by the .NET Compact Framework. | FormDataChanged |
Supported by the .NET Compact Framework. | FormReadonly |
Supported by the .NET Compact Framework. | Kontaktperson |
Supported by the .NET Compact Framework. | SpaltenTitel |
Supported by the .NET Compact Framework. | Vertragspartnerdata |
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | msg |
Supported by the .NET Compact Framework. | sec |
Supported by the .NET Compact Framework. | vpnr |
Top

Expand image See Also

Reference

frmVertragspartner Class
TKB.VV.SLA
TKB.VV.SLA.clsServiceKatalogTree
TKB.VV.Sysadmin
TKB.VV.Sysadmin.DomainTable
TKB.VV.Utils
TKB.VV.Utils.MyMessage
TKB.VV.Utils.MySecurity
TKB.VV.Utils.Tabellenspalte


frmVertragspartner Constructor

frmVertragspartner Constructor

Constructor New

Expand image Overload List

Name | Description
public System.Void frmVertragspartner(); | Constructor New
public System.Void frmVertragspartner(int, bool, bool); | Formualr mit Vertragspartnernr und Anzeigestatus öffnen

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner Methods

frmVertragspartner Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | dispose | (Overloaded) destruction Dispose
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | AddChanges | Allg Eventhandler für Chanage-Ereignise festlegen
Supported by the .NET Compact Framework. | AnzeigenToolStripMenuItem_Click | KontextMenu anzeigen
Supported by the .NET Compact Framework. | BeendenToolStripMenuItem_Click | Menu Beenden
Supported by the .NET Compact Framework. | C1Kontakte_DoubleClick | Doubleclick in der Kontaktliste
Supported by the .NET Compact Framework. | C1Kontakte_MouseDown | Mousedown Kontakte
Supported by the .NET Compact Framework. | ChangesMade | Envent-Handler für Change-Ereignisse
Supported by the .NET Compact Framework. | Check_Changes | Prüfung, ob Datenänderungen vorgenommen wurden.
Supported by the .NET Compact Framework. | FormularClosing | Schliessen des Formulars
Supported by the .NET Compact Framework. | GetControl | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
Supported by the .NET Compact Framework. | Get_Data | Vertragspartner laden
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | KontaktInaktivierenToolStripMenuItem_Click | Kontextmenu Delete
Supported by the .NET Compact Framework. | KontaktKopierenToolStripMenuItem_Click | Kontextmenu Kopieren
Supported by the .NET Compact Framework. | KontaktNeuToolStripMenuItem_Click | Kontextmenu Neu
Supported by the .NET Compact Framework. | Load_Securitylevel | Laden der Securitylevel-Daten in die Combobox
Supported by the .NET Compact Framework. | Refresh_Personen | Personenliste aktualisieren
Supported by the .NET Compact Framework. | Save_Data | Vertragspartner sichern, sofern Änderungen vorgenommen wurden, anschliessend erneut laden
Supported by the .NET Compact Framework. | TS2BtnCopy_Click | Kopie eines Datensatzen erstellen
Supported by the .NET Compact Framework. | TS2BtnDelete_Click | Kontakt löschen (inaktivieren)
Supported by the .NET Compact Framework. | TS2BtnNew_Click | Neuer Kontakt hinzufügen
Supported by the .NET Compact Framework. | TS2BtnView_Click | Personendetails anzeigen bzw. bearbeiten
Supported by the .NET Compact Framework. | TSBtnCopy_Click | Datensatz kopieren
Supported by the .NET Compact Framework. | TSBtnDelete_Click | Aktueller Datensatz inaktivieren
Supported by the .NET Compact Framework. | TSBtnNew_Click | Neuer Datensatz erstellen
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Formular schliessen
Supported by the .NET Compact Framework. | TSBtnSave_Click | Sicherungs-Button betätigt
Supported by the .NET Compact Framework. | TSBtnSuche_Click | Vertragspartner suchen
Supported by the .NET Compact Framework. | frmVertragspartner_Load | Formular laden
Supported by the .NET Compact Framework. | frmVertragspartner_Shown | Anzeige des Suchformulars, wenn keine Vertragspartnernummer vorhanden ist
Supported by the .NET Compact Framework. | txtBemerkung_TextChanged | Änderungsvermerk sofern Änderungen vorgenommen wurden
Top

Expand image See Also

Reference

frmVertragspartner Class
TKB.VV.SLA
TKB.VV.SLA.clsServiceKatalogTree
TKB.VV.Sysadmin
TKB.VV.Sysadmin.DomainTable
TKB.VV.Utils
TKB.VV.Utils.MyMessage
TKB.VV.Utils.MySecurity
TKB.VV.Utils.Tabellenspalte


frmVertragspartner.AddChanges Method

frmVertragspartner.AddChanges Method

Allg Eventhandler für Chanage-Ereignise festlegen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub AddChanges( _
   ByVal Container As Control _
)
C#
private System.Void AddChanges(
   Control Container
);
C++

private:
System::Void AddChanges(
   Control^ Container
)
JScript
private function AddChanges(
    Container : Control
);

Parameters

Container

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub AddChanges(ByVal Container As Control)
        Dim l As New List(Of Control)
        Me.GetControl(Me, "*", l)
        Dim evh As EventHandler = AddressOf ChangesMade
        For Each c As Control In l
            If TypeOf c Is TextBox Then
                Dim ctl As TextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is MaskedTextBox Then
                Dim ctl As MaskedTextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is ComboBox Then
                Dim ctl As ComboBox = c
                AddHandler ctl.SelectedValueChanged, evh
            End If
            If TypeOf c Is CheckBox Then
                Dim ctl As CheckBox = c
                AddHandler ctl.CheckedChanged, evh
            End If
        Next
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.AnzeigenToolStripMenuItem_Click Method

frmVertragspartner.AnzeigenToolStripMenuItem_Click Method

KontextMenu anzeigen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub AnzeigenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   KontaktAnzeigenToolStripMenuItem.Click
C#
private System.Void AnzeigenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void AnzeigenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function AnzeigenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub AnzeigenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles KontaktAnzeigenToolStripMenuItem.Click
        Try
            Me.TS2BtnView_Click(sender, e)
        Catch
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.BeendenToolStripMenuItem_Click Method

frmVertragspartner.BeendenToolStripMenuItem_Click Method

Menu Beenden
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click
C#
private System.Void BeendenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void BeendenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function BeendenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.TSBtnQuit_Click(sender, e)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.C1Kontakte_DoubleClick Method

frmVertragspartner.C1Kontakte_DoubleClick Method

Doubleclick in der Kontaktliste
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub C1Kontakte_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Kontakte.DoubleClick
C#
private System.Void C1Kontakte_DoubleClick(
   object sender,
   EventArgs e
);
C++

private:
System::Void C1Kontakte_DoubleClick(
   object^ sender,
   EventArgs^ e
)
JScript
private function C1Kontakte_DoubleClick(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub C1Kontakte_DoubleClick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles C1Kontakte.DoubleClick
        Try
            Dim f As New frmPerson(Me.C1Kontakte.Columns("Personnr").Value, Me.Vertragspartnerdata.iVertragspartnerNr.Value, Me.FormReadonly)
            f.ShowDialog()
            Me.Refresh_Personen()
        Catch
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.C1Kontakte_MouseDown Method

frmVertragspartner.C1Kontakte_MouseDown Method

Mousedown Kontakte
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub C1Kontakte_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Kontakte.MouseDown
C#
private System.Void C1Kontakte_MouseDown(
   object sender,
   MouseEventArgs e
);
C++

private:
System::Void C1Kontakte_MouseDown(
   object^ sender,
   MouseEventArgs^ e
)
JScript
private function C1Kontakte_MouseDown(
    sender : object,
    e : MouseEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub C1Kontakte_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Kontakte.MouseDown
        Me.C1Kontakte.Bookmark = Me.C1Kontakte.RowContaining(e.Y)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.ChangesMade Method

frmVertragspartner.ChangesMade Method

Envent-Handler für Change-Ereignisse
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub ChangesMade( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
private System.Void ChangesMade(
   object sender,
   EventArgs e
);
C++

private:
System::Void ChangesMade(
   object^ sender,
   EventArgs^ e
)
JScript
private function ChangesMade(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub ChangesMade(ByVal sender As Object, ByVal e As System.EventArgs)
        Me.FormDataChanged = True
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.Check_Changes Method

frmVertragspartner.Check_Changes Method

Prüfung, ob Datenänderungen vorgenommen wurden.
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Check_Changes() As Boolean
C#
private bool Check_Changes();
C++

private:
bool Check_Changes()
JScript
private function Check_Changes() : boolean;

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Function Check_Changes() As Boolean
        If Me.FormReadonly Then Exit Function
        Dim msgres As MsgBoxResult
        If Me.FormDataChanged Then
            msgres = msg.Show_MessageYesNoCancel(3)
            Select Case msgres
                Case MsgBoxResult.Yes
                    Save_data()
                    Return True
                Case MsgBoxResult.Cancel
                    Return False
                Case MsgBoxResult.No
                    Return True
            End Select
        Else
            Return True
        End If
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.FormularClosing Method

frmVertragspartner.FormularClosing Method

Schliessen des Formulars
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub FormularClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing
C#
private System.Void FormularClosing(
   object sender,
   FormClosingEventArgs e
);
C++

private:
System::Void FormularClosing(
   object^ sender,
   FormClosingEventArgs^ e
)
JScript
private function FormularClosing(
    sender : object,
    e : FormClosingEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub FormularClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.FormReadonly = True Then Exit Sub
        If check_changes() = False Then
            e.Cancel = True
        Else
            Me.dispose()
            Globals.MyEventHanlder.Vertragspartner_Closed(Me.Vertragspartnerdata.iVertragspartnerNr.Value)
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.GetControl Method

frmVertragspartner.GetControl Method

Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function GetControl( _
   ByVal BaseControl As Control, _
   ByVal Key As String, _
   ByRef L As List(Of Control), _
   Optional ByVal ReturnAtFirstElement As Boolean = False _
) As Boolean
C#
private bool GetControl(
   Control BaseControl,
   string Key,
   ref List<Control> L,
   bool ReturnAtFirstElement
);
C++

private:
bool GetControl(
   Control^ BaseControl,
   String^ Key,
   List<Control^>^& L,
   bool ReturnAtFirstElement
)
JScript
JScript does not support generic types and methods.

Parameters

BaseControl

Base-Contrlo (z.B. aktuelles Formular

Key

Schlüssel welcher gesucht werden soll

L

Liste der gefundenen Objekte

ReturnAtFirstElement

Optional. The default value is False.

Return Value

True wenn eines oder mehr Controls gefunden wurden, false wenn kein Control gefunden wurde.

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Function GetControl(ByVal BaseControl As Control, ByVal Key As String, ByRef L As List(Of Control), Optional ByVal ReturnAtFirstElement As Boolean = False) As Boolean
        If L Is Nothing Then L = New List(Of Control)
        Dim Gut As Boolean
        Dim ReturnFlag As Boolean = False
        If Key IsNot Nothing Then Key = Key.ToLower

        If BaseControl.HasChildren = True Then
            For Each ctl As Control In BaseControl.Controls
                Gut = False
                If Key Is Nothing Then
                    Gut = True
                Else
                    If ctl.Name.Length >= Key.Length Then
                        Key = Key.ToLower
                        If Key.StartsWith("*") Then
                            If Key.Substring(1) = ctl.Name.ToLower.Substring(ctl.Name.Length - (Key.Length - 1), Key.Length - 1) Then Gut = True
                        ElseIf Key.EndsWith("*") Then
                            If Key.Substring(0, Key.Length - 1) = ctl.Name.ToLower.Substring(0, Key.Length - 1) Then Gut = True
                        Else
                            If Key = ctl.Name.ToLower Then Gut = True
                        End If
                    End If
                End If

                If Gut = True Then
                    L.Add(ctl)
                    If ReturnAtFirstElement = True Then ReturnFlag = True
                End If
                If ReturnFlag = False Then
                    Call GetControl(ctl, Key, L)
                End If
            Next
        End If

        If L.Count - 1 > -1 Then
            Return True
        Else
            Return False
        End If
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.Get_Data Method

frmVertragspartner.Get_Data Method

Vertragspartner laden
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Get_Data( _
   ByVal Nr As Integer _
)
C#
private System.Void Get_Data(
   int Nr
);
C++

private:
System::Void Get_Data(
   int Nr
)
JScript
private function Get_Data(
    Nr : int
);

Parameters

Nr

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Get_Data(ByVal Nr As Integer)
        Try
            Me.Vertragspartnerdata.Get_Partner(Nr)
            Me.txtName_Firma1.Text = Me.Vertragspartnerdata.sNameZ1.Value
            Me.txtVorname_Firma2.Text = Me.Vertragspartnerdata.sNameZ2.Value
            Me.txtStrasse.Text = Me.Vertragspartnerdata.sStrasse.Value
            Me.txtPostfach.Text = Me.Vertragspartnerdata.sPostfach.Value
            Me.txtPlz.Text = Me.Vertragspartnerdata.sPLZ.Value
            Me.txtOrt.Text = Me.Vertragspartnerdata.sOrt.Value
            Me.txtTelefon.Text = Me.Vertragspartnerdata.sTelefon.Value
            Me.txtTelefax.Text = Me.Vertragspartnerdata.sTelefax.Value
            Me.txtEmail.Text = Me.Vertragspartnerdata.sEMail.Value
            Me.txtInternet.Text = Me.Vertragspartnerdata.sInternet.Value
            Me.txtBemerkung.Text = Me.Vertragspartnerdata.sBemerkung.Value
            Me.txtErstellt_am.Text = Me.Vertragspartnerdata.daErstellt_am.ToString
            Me.txtMutiert_am.Text = Me.Vertragspartnerdata.daMutiert_am.ToString
            Me.txtMutierer.Text = Me.Vertragspartnerdata.iMutierer.Value
            Me.cbAktiv.Checked = Me.Vertragspartnerdata.bAktiv.Value = True
            Me.cboxSecurityLevel.SelectedValue = Me.Vertragspartnerdata.iSecurityLevelNr.Value
            Me.FormDataChanged = False
            Refresh_Personen()
            If Not Anzeige Then
                Me.PnlDetails.Enabled = True
                Me.GrpKontakte.Enabled = True
                Me.TSBtnSave.Enabled = True
                Me.TSBtnCopy.Enabled = True
                Me.TSBtnNew.Enabled = True
                Me.TSBtnDelete.Enabled = True
            End If
            sec.Set_Form_Security(Me)
        Catch ex As Exception
            FormDataChanged = False
            Me.PnlDetails.Enabled = False
            Me.GrpKontakte.Enabled = False
            Me.TSBtnSave.Enabled = False
            Me.TSBtnCopy.Enabled = False
            Me.TSBtnNew.Enabled = False
            Me.TSBtnDelete.Enabled = False
        End Try

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.InitializeComponent Method

frmVertragspartner.InitializeComponent Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()
C#
[System.Diagnostics.DebuggerStepThrough()]
private System.Void InitializeComponent();
C++
[System.Diagnostics.DebuggerStepThrough()]

private:
System::Void InitializeComponent()
JScript
private
   System.Diagnostics.DebuggerStepThrough()
function InitializeComponent();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmVertragspartner))
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnCopy = New System.Windows.Forms.ToolStripButton
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSuche = New System.Windows.Forms.ToolStripButton
        Me.PnlDetails = New System.Windows.Forms.Panel
        Me.cboxSecurityLevel = New System.Windows.Forms.ComboBox
        Me.lblSecurityLebel = New System.Windows.Forms.Label
        Me.cbAktiv = New System.Windows.Forms.CheckBox
        Me.lblAktiv = New System.Windows.Forms.Label
        Me.txtMutierer = New System.Windows.Forms.TextBox
        Me.txtMutiert_am = New System.Windows.Forms.TextBox
        Me.txtErstellt_am = New System.Windows.Forms.TextBox
        Me.lblMutierer = New System.Windows.Forms.Label
        Me.lblMutiert_am = New System.Windows.Forms.Label
        Me.lblErstelltam = New System.Windows.Forms.Label
        Me.txtBemerkung = New System.Windows.Forms.TextBox
        Me.lblBemerkung = New System.Windows.Forms.Label
        Me.txtInternet = New System.Windows.Forms.TextBox
        Me.lblInternet = New System.Windows.Forms.Label
        Me.txtEmail = New System.Windows.Forms.TextBox
        Me.lblEmail = New System.Windows.Forms.Label
        Me.txtTelefon = New System.Windows.Forms.TextBox
        Me.txtTelefax = New System.Windows.Forms.TextBox
        Me.lblTelefax = New System.Windows.Forms.Label
        Me.lblTelefon = New System.Windows.Forms.Label
        Me.txtOrt = New System.Windows.Forms.TextBox
        Me.txtPlz = New System.Windows.Forms.TextBox
        Me.lblPlzOrt = New System.Windows.Forms.Label
        Me.txtPostfach = New System.Windows.Forms.TextBox
        Me.lblPostfach = New System.Windows.Forms.Label
        Me.txtStrasse = New System.Windows.Forms.TextBox
        Me.lblStrasse = New System.Windows.Forms.Label
        Me.txtVorname_Firma2 = New System.Windows.Forms.TextBox
        Me.lblVorname_Firma2 = New System.Windows.Forms.Label
        Me.txtName_Firma1 = New System.Windows.Forms.TextBox
        Me.lblName_Firma1 = New System.Windows.Forms.Label
        Me.GrpKontakte = New System.Windows.Forms.GroupBox
        Me.C1Kontakte = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.KontaktMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.KontaktAnzeigenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.KontaktKopierenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.KontaktNeuToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.KontaktInaktivierenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip2 = New System.Windows.Forms.ToolStrip
        Me.TS2BtnView = New System.Windows.Forms.ToolStripButton
        Me.TS2BtnCopy = New System.Windows.Forms.ToolStripButton
        Me.TS2BtnNew = New System.Windows.Forms.ToolStripButton
        Me.TS2BtnDelete = New System.Windows.Forms.ToolStripButton
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.PnlDetails.SuspendLayout()
        Me.GrpKontakte.SuspendLayout()
        CType(Me.C1Kontakte, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.KontaktMenuStrip.SuspendLayout()
        Me.ToolStrip2.SuspendLayout()
        Me.SuspendLayout()
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Tag = ""
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(116, 22)
        Me.BeendenToolStripMenuItem.Tag = ""
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(647, 24)
        Me.MenuStrip1.TabIndex = 3
        Me.MenuStrip1.Tag = ""
        Me.MenuStrip1.Text = "Hauptmenu"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "Daten speichern"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnCopy, Me.TSBtnNew, Me.TSBtnDelete, Me.TSBtnSuche})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(647, 25)
        Me.ToolStrip1.TabIndex = 2
        Me.ToolStrip1.Text = "Toolstrip Vertragspartner"
        '
        'TSBtnCopy
        '
        Me.TSBtnCopy.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnCopy.Image = CType(resources.GetObject("TSBtnCopy.Image"), System.Drawing.Image)
        Me.TSBtnCopy.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnCopy.Name = "TSBtnCopy"
        Me.TSBtnCopy.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnCopy.Text = "Datensatz kopieren"
        Me.TSBtnCopy.ToolTipText = "Datensatz kopieren"
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "Neuer Datensatz"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "Datensatz inaktivieren"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'TSBtnSuche
        '
        Me.TSBtnSuche.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSuche.Image = CType(resources.GetObject("TSBtnSuche.Image"), System.Drawing.Image)
        Me.TSBtnSuche.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSuche.Name = "TSBtnSuche"
        Me.TSBtnSuche.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSuche.Text = "ToolStripButton1"
        '
        'PnlDetails
        '
        Me.PnlDetails.Controls.Add(Me.cboxSecurityLevel)
        Me.PnlDetails.Controls.Add(Me.lblSecurityLebel)
        Me.PnlDetails.Controls.Add(Me.cbAktiv)
        Me.PnlDetails.Controls.Add(Me.lblAktiv)
        Me.PnlDetails.Controls.Add(Me.txtMutierer)
        Me.PnlDetails.Controls.Add(Me.txtMutiert_am)
        Me.PnlDetails.Controls.Add(Me.txtErstellt_am)
        Me.PnlDetails.Controls.Add(Me.lblMutierer)
        Me.PnlDetails.Controls.Add(Me.lblMutiert_am)
        Me.PnlDetails.Controls.Add(Me.lblErstelltam)
        Me.PnlDetails.Controls.Add(Me.txtBemerkung)
        Me.PnlDetails.Controls.Add(Me.lblBemerkung)
        Me.PnlDetails.Controls.Add(Me.txtInternet)
        Me.PnlDetails.Controls.Add(Me.lblInternet)
        Me.PnlDetails.Controls.Add(Me.txtEmail)
        Me.PnlDetails.Controls.Add(Me.lblEmail)
        Me.PnlDetails.Controls.Add(Me.txtTelefon)
        Me.PnlDetails.Controls.Add(Me.txtTelefax)
        Me.PnlDetails.Controls.Add(Me.lblTelefax)
        Me.PnlDetails.Controls.Add(Me.lblTelefon)
        Me.PnlDetails.Controls.Add(Me.txtOrt)
        Me.PnlDetails.Controls.Add(Me.txtPlz)
        Me.PnlDetails.Controls.Add(Me.lblPlzOrt)
        Me.PnlDetails.Controls.Add(Me.txtPostfach)
        Me.PnlDetails.Controls.Add(Me.lblPostfach)
        Me.PnlDetails.Controls.Add(Me.txtStrasse)
        Me.PnlDetails.Controls.Add(Me.lblStrasse)
        Me.PnlDetails.Controls.Add(Me.txtVorname_Firma2)
        Me.PnlDetails.Controls.Add(Me.lblVorname_Firma2)
        Me.PnlDetails.Controls.Add(Me.txtName_Firma1)
        Me.PnlDetails.Controls.Add(Me.lblName_Firma1)
        Me.PnlDetails.Dock = System.Windows.Forms.DockStyle.Top
        Me.PnlDetails.Location = New System.Drawing.Point(0, 49)
        Me.PnlDetails.Name = "PnlDetails"
        Me.PnlDetails.Size = New System.Drawing.Size(647, 275)
        Me.PnlDetails.TabIndex = 0
        '
        'cboxSecurityLevel
        '
        Me.cboxSecurityLevel.FormattingEnabled = True
        Me.cboxSecurityLevel.Location = New System.Drawing.Point(85, 235)
        Me.cboxSecurityLevel.Name = "cboxSecurityLevel"
        Me.cboxSecurityLevel.Size = New System.Drawing.Size(101, 21)
        Me.cboxSecurityLevel.TabIndex = 12
        '
        'lblSecurityLebel
        '
        Me.lblSecurityLebel.AutoSize = True
        Me.lblSecurityLebel.Location = New System.Drawing.Point(8, 239)
        Me.lblSecurityLebel.Name = "lblSecurityLebel"
        Me.lblSecurityLebel.Size = New System.Drawing.Size(71, 13)
        Me.lblSecurityLebel.TabIndex = 89
        Me.lblSecurityLebel.Text = "SecurityLevel"
        '
        'cbAktiv
        '
        Me.cbAktiv.AutoSize = True
        Me.cbAktiv.Location = New System.Drawing.Point(462, 114)
        Me.cbAktiv.Name = "cbAktiv"
        Me.cbAktiv.Size = New System.Drawing.Size(15, 14)
        Me.cbAktiv.TabIndex = 10
        Me.cbAktiv.Tag = ""
        Me.cbAktiv.UseVisualStyleBackColor = True
        '
        'lblAktiv
        '
        Me.lblAktiv.AccessibleDescription = "Name"
        Me.lblAktiv.AutoSize = True
        Me.lblAktiv.Location = New System.Drawing.Point(400, 114)
        Me.lblAktiv.Name = "lblAktiv"
        Me.lblAktiv.Size = New System.Drawing.Size(31, 13)
        Me.lblAktiv.TabIndex = 87
        Me.lblAktiv.Text = "Aktiv"
        '
        'txtMutierer
        '
        Me.txtMutierer.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutierer.Location = New System.Drawing.Point(564, 236)
        Me.txtMutierer.Name = "txtMutierer"
        Me.txtMutierer.Size = New System.Drawing.Size(71, 20)
        Me.txtMutierer.TabIndex = 86
        '
        'txtMutiert_am
        '
        Me.txtMutiert_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutiert_am.Location = New System.Drawing.Point(402, 236)
        Me.txtMutiert_am.Name = "txtMutiert_am"
        Me.txtMutiert_am.Size = New System.Drawing.Size(79, 20)
        Me.txtMutiert_am.TabIndex = 85
        '
        'txtErstellt_am
        '
        Me.txtErstellt_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtErstellt_am.Location = New System.Drawing.Point(258, 236)
        Me.txtErstellt_am.Name = "txtErstellt_am"
        Me.txtErstellt_am.Size = New System.Drawing.Size(79, 20)
        Me.txtErstellt_am.TabIndex = 84
        '
        'lblMutierer
        '
        Me.lblMutierer.AccessibleDescription = "Name"
        Me.lblMutierer.AutoSize = True
        Me.lblMutierer.Location = New System.Drawing.Point(493, 239)
        Me.lblMutierer.Name = "lblMutierer"
        Me.lblMutierer.Size = New System.Drawing.Size(72, 13)
        Me.lblMutierer.TabIndex = 83
        Me.lblMutierer.Text = "Mutiert durch:"
        '
        'lblMutiert_am
        '
        Me.lblMutiert_am.AccessibleDescription = "Name"
        Me.lblMutiert_am.AutoSize = True
        Me.lblMutiert_am.Location = New System.Drawing.Point(343, 239)
        Me.lblMutiert_am.Name = "lblMutiert_am"
        Me.lblMutiert_am.Size = New System.Drawing.Size(59, 13)
        Me.lblMutiert_am.TabIndex = 82
        Me.lblMutiert_am.Text = "Mutiert am:"
        '
        'lblErstelltam
        '
        Me.lblErstelltam.AccessibleDescription = "Name"
        Me.lblErstelltam.AutoSize = True
        Me.lblErstelltam.Location = New System.Drawing.Point(200, 239)
        Me.lblErstelltam.Name = "lblErstelltam"
        Me.lblErstelltam.Size = New System.Drawing.Size(58, 13)
        Me.lblErstelltam.TabIndex = 81
        Me.lblErstelltam.Text = "Erstellt am:"
        '
        'txtBemerkung
        '
        Me.txtBemerkung.Location = New System.Drawing.Point(11, 153)
        Me.txtBemerkung.Multiline = True
        Me.txtBemerkung.Name = "txtBemerkung"
        Me.txtBemerkung.Size = New System.Drawing.Size(626, 72)
        Me.txtBemerkung.TabIndex = 11
        '
        'lblBemerkung
        '
        Me.lblBemerkung.AccessibleDescription = "Name"
        Me.lblBemerkung.AutoSize = True
        Me.lblBemerkung.Location = New System.Drawing.Point(8, 137)
        Me.lblBemerkung.Name = "lblBemerkung"
        Me.lblBemerkung.Size = New System.Drawing.Size(61, 13)
        Me.lblBemerkung.TabIndex = 79
        Me.lblBemerkung.Text = "Bemerkung"
        '
        'txtInternet
        '
        Me.txtInternet.Location = New System.Drawing.Point(462, 85)
        Me.txtInternet.Name = "txtInternet"
        Me.txtInternet.Size = New System.Drawing.Size(177, 20)
        Me.txtInternet.TabIndex = 9
        '
        'lblInternet
        '
        Me.lblInternet.AccessibleDescription = "Name"
        Me.lblInternet.AutoSize = True
        Me.lblInternet.Location = New System.Drawing.Point(400, 88)
        Me.lblInternet.Name = "lblInternet"
        Me.lblInternet.Size = New System.Drawing.Size(43, 13)
        Me.lblInternet.TabIndex = 77
        Me.lblInternet.Text = "Internet"
        '
        'txtEmail
        '
        Me.txtEmail.Location = New System.Drawing.Point(462, 59)
        Me.txtEmail.Name = "txtEmail"
        Me.txtEmail.Size = New System.Drawing.Size(177, 20)
        Me.txtEmail.TabIndex = 8
        '
        'lblEmail
        '
        Me.lblEmail.AccessibleDescription = "Name"
        Me.lblEmail.AutoSize = True
        Me.lblEmail.Location = New System.Drawing.Point(400, 62)
        Me.lblEmail.Name = "lblEmail"
        Me.lblEmail.Size = New System.Drawing.Size(36, 13)
        Me.lblEmail.TabIndex = 75
        Me.lblEmail.Text = "E-Mail"
        '
        'txtTelefon
        '
        Me.txtTelefon.Location = New System.Drawing.Point(462, 7)
        Me.txtTelefon.Name = "txtTelefon"
        Me.txtTelefon.Size = New System.Drawing.Size(177, 20)
        Me.txtTelefon.TabIndex = 6
        '
        'txtTelefax
        '
        Me.txtTelefax.Location = New System.Drawing.Point(462, 33)
        Me.txtTelefax.Name = "txtTelefax"
        Me.txtTelefax.Size = New System.Drawing.Size(177, 20)
        Me.txtTelefax.TabIndex = 7
        '
        'lblTelefax
        '
        Me.lblTelefax.AccessibleDescription = "Name"
        Me.lblTelefax.AutoSize = True
        Me.lblTelefax.Location = New System.Drawing.Point(400, 36)
        Me.lblTelefax.Name = "lblTelefax"
        Me.lblTelefax.Size = New System.Drawing.Size(42, 13)
        Me.lblTelefax.TabIndex = 72
        Me.lblTelefax.Text = "Telefax"
        '
        'lblTelefon
        '
        Me.lblTelefon.AccessibleDescription = "Name"
        Me.lblTelefon.AutoSize = True
        Me.lblTelefon.Location = New System.Drawing.Point(399, 10)
        Me.lblTelefon.Name = "lblTelefon"
        Me.lblTelefon.Size = New System.Drawing.Size(43, 13)
        Me.lblTelefon.TabIndex = 71
        Me.lblTelefon.Text = "Telefon"
        '
        'txtOrt
        '
        Me.txtOrt.Location = New System.Drawing.Point(205, 111)
        Me.txtOrt.Name = "txtOrt"
        Me.txtOrt.Size = New System.Drawing.Size(166, 20)
        Me.txtOrt.TabIndex = 5
        '
        'txtPlz
        '
        Me.txtPlz.Location = New System.Drawing.Point(137, 111)
        Me.txtPlz.Name = "txtPlz"
        Me.txtPlz.Size = New System.Drawing.Size(62, 20)
        Me.txtPlz.TabIndex = 4
        '
        'lblPlzOrt
        '
        Me.lblPlzOrt.AccessibleDescription = "Name"
        Me.lblPlzOrt.AutoSize = True
        Me.lblPlzOrt.Location = New System.Drawing.Point(10, 114)
        Me.lblPlzOrt.Name = "lblPlzOrt"
        Me.lblPlzOrt.Size = New System.Drawing.Size(52, 13)
        Me.lblPlzOrt.TabIndex = 68
        Me.lblPlzOrt.Text = "PLZ / Ort"
        '
        'txtPostfach
        '
        Me.txtPostfach.Location = New System.Drawing.Point(137, 85)
        Me.txtPostfach.Name = "txtPostfach"
        Me.txtPostfach.Size = New System.Drawing.Size(234, 20)
        Me.txtPostfach.TabIndex = 3
        '
        'lblPostfach
        '
        Me.lblPostfach.AccessibleDescription = "Name"
        Me.lblPostfach.AutoSize = True
        Me.lblPostfach.Location = New System.Drawing.Point(10, 88)
        Me.lblPostfach.Name = "lblPostfach"
        Me.lblPostfach.Size = New System.Drawing.Size(49, 13)
        Me.lblPostfach.TabIndex = 66
        Me.lblPostfach.Text = "Postfach"
        '
        'txtStrasse
        '
        Me.txtStrasse.Location = New System.Drawing.Point(137, 59)
        Me.txtStrasse.Name = "txtStrasse"
        Me.txtStrasse.Size = New System.Drawing.Size(234, 20)
        Me.txtStrasse.TabIndex = 2
        '
        'lblStrasse
        '
        Me.lblStrasse.AccessibleDescription = "Name"
        Me.lblStrasse.AutoSize = True
        Me.lblStrasse.Location = New System.Drawing.Point(10, 62)
        Me.lblStrasse.Name = "lblStrasse"
        Me.lblStrasse.Size = New System.Drawing.Size(42, 13)
        Me.lblStrasse.TabIndex = 64
        Me.lblStrasse.Text = "Strasse"
        '
        'txtVorname_Firma2
        '
        Me.txtVorname_Firma2.Location = New System.Drawing.Point(137, 33)
        Me.txtVorname_Firma2.Name = "txtVorname_Firma2"
        Me.txtVorname_Firma2.Size = New System.Drawing.Size(234, 20)
        Me.txtVorname_Firma2.TabIndex = 1
        '
        'lblVorname_Firma2
        '
        Me.lblVorname_Firma2.AccessibleDescription = "Name"
        Me.lblVorname_Firma2.AutoSize = True
        Me.lblVorname_Firma2.Location = New System.Drawing.Point(10, 36)
        Me.lblVorname_Firma2.Name = "lblVorname_Firma2"
        Me.lblVorname_Firma2.Size = New System.Drawing.Size(120, 13)
        Me.lblVorname_Firma2.TabIndex = 62
        Me.lblVorname_Firma2.Text = "Vorname / Firma Zeile 2"
        '
        'txtName_Firma1
        '
        Me.txtName_Firma1.Location = New System.Drawing.Point(137, 7)
        Me.txtName_Firma1.Name = "txtName_Firma1"
        Me.txtName_Firma1.Size = New System.Drawing.Size(234, 20)
        Me.txtName_Firma1.TabIndex = 0
        Me.txtName_Firma1.Tag = ""
        '
        'lblName_Firma1
        '
        Me.lblName_Firma1.AccessibleDescription = "Name"
        Me.lblName_Firma1.AutoSize = True
        Me.lblName_Firma1.Location = New System.Drawing.Point(10, 10)
        Me.lblName_Firma1.Name = "lblName_Firma1"
        Me.lblName_Firma1.Size = New System.Drawing.Size(71, 13)
        Me.lblName_Firma1.TabIndex = 60
        Me.lblName_Firma1.Text = "Name / Firma"
        '
        'GrpKontakte
        '
        Me.GrpKontakte.Controls.Add(Me.C1Kontakte)
        Me.GrpKontakte.Controls.Add(Me.ToolStrip2)
        Me.GrpKontakte.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GrpKontakte.Location = New System.Drawing.Point(0, 324)
        Me.GrpKontakte.Name = "GrpKontakte"
        Me.GrpKontakte.Size = New System.Drawing.Size(647, 289)
        Me.GrpKontakte.TabIndex = 1
        Me.GrpKontakte.TabStop = False
        Me.GrpKontakte.Text = "Kontakte"
        '
        'C1Kontakte
        '
        Me.C1Kontakte.AlternatingRows = True
        Me.C1Kontakte.ContextMenuStrip = Me.KontaktMenuStrip
        Me.C1Kontakte.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Kontakte.FilterBar = True
        Me.C1Kontakte.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Kontakte.Images.Add(CType(resources.GetObject("C1Kontakte.Images"), System.Drawing.Image))
        Me.C1Kontakte.Location = New System.Drawing.Point(3, 41)
        Me.C1Kontakte.Name = "C1Kontakte"
        Me.C1Kontakte.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Kontakte.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Kontakte.PreviewInfo.ZoomFactor = 75
        Me.C1Kontakte.PrintInfo.PageSettings = CType(resources.GetObject("C1Kontakte.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Kontakte.Size = New System.Drawing.Size(641, 245)
        Me.C1Kontakte.TabIndex = 0
        Me.C1Kontakte.Text = "C1Kontakte"
        Me.C1Kontakte.PropBag = resources.GetString("C1Kontakte.PropBag")
        '
        'KontaktMenuStrip
        '
        Me.KontaktMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.KontaktAnzeigenToolStripMenuItem, Me.KontaktKopierenToolStripMenuItem, Me.KontaktNeuToolStripMenuItem, Me.KontaktInaktivierenToolStripMenuItem})
        Me.KontaktMenuStrip.Name = "ContextMenuStripKontakte"
        Me.KontaktMenuStrip.Size = New System.Drawing.Size(132, 92)
        '
        'KontaktAnzeigenToolStripMenuItem
        '
        Me.KontaktAnzeigenToolStripMenuItem.Name = "KontaktAnzeigenToolStripMenuItem"
        Me.KontaktAnzeigenToolStripMenuItem.Size = New System.Drawing.Size(131, 22)
        Me.KontaktAnzeigenToolStripMenuItem.Text = "&Anzeigen"
        '
        'KontaktKopierenToolStripMenuItem
        '
        Me.KontaktKopierenToolStripMenuItem.Name = "KontaktKopierenToolStripMenuItem"
        Me.KontaktKopierenToolStripMenuItem.Size = New System.Drawing.Size(131, 22)
        Me.KontaktKopierenToolStripMenuItem.Text = "&Kopieren"
        '
        'KontaktNeuToolStripMenuItem
        '
        Me.KontaktNeuToolStripMenuItem.Name = "KontaktNeuToolStripMenuItem"
        Me.KontaktNeuToolStripMenuItem.Size = New System.Drawing.Size(131, 22)
        Me.KontaktNeuToolStripMenuItem.Text = "&Neu"
        '
        'KontaktInaktivierenToolStripMenuItem
        '
        Me.KontaktInaktivierenToolStripMenuItem.Name = "KontaktInaktivierenToolStripMenuItem"
        Me.KontaktInaktivierenToolStripMenuItem.Size = New System.Drawing.Size(131, 22)
        Me.KontaktInaktivierenToolStripMenuItem.Text = "&Inaktivieren"
        '
        'ToolStrip2
        '
        Me.ToolStrip2.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TS2BtnView, Me.TS2BtnCopy, Me.TS2BtnNew, Me.TS2BtnDelete})
        Me.ToolStrip2.Location = New System.Drawing.Point(3, 16)
        Me.ToolStrip2.Name = "ToolStrip2"
        Me.ToolStrip2.Size = New System.Drawing.Size(641, 25)
        Me.ToolStrip2.TabIndex = 1
        Me.ToolStrip2.Text = "Toolstrip Kontakte"
        '
        'TS2BtnView
        '
        Me.TS2BtnView.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TS2BtnView.Image = CType(resources.GetObject("TS2BtnView.Image"), System.Drawing.Image)
        Me.TS2BtnView.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TS2BtnView.Name = "TS2BtnView"
        Me.TS2BtnView.Size = New System.Drawing.Size(23, 22)
        Me.TS2BtnView.Text = "Datensatz anzeigen"
        Me.TS2BtnView.ToolTipText = "Datensatz anzeigen"
        '
        'TS2BtnCopy
        '
        Me.TS2BtnCopy.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TS2BtnCopy.Image = CType(resources.GetObject("TS2BtnCopy.Image"), System.Drawing.Image)
        Me.TS2BtnCopy.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TS2BtnCopy.Name = "TS2BtnCopy"
        Me.TS2BtnCopy.Size = New System.Drawing.Size(23, 22)
        Me.TS2BtnCopy.Text = "Datensatz kopieren"
        Me.TS2BtnCopy.ToolTipText = "Datensatz kopieren"
        '
        'TS2BtnNew
        '
        Me.TS2BtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TS2BtnNew.Image = CType(resources.GetObject("TS2BtnNew.Image"), System.Drawing.Image)
        Me.TS2BtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TS2BtnNew.Name = "TS2BtnNew"
        Me.TS2BtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TS2BtnNew.Text = "Neuer Datensatz"
        Me.TS2BtnNew.ToolTipText = "Neuer Datensatz"
        '
        'TS2BtnDelete
        '
        Me.TS2BtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TS2BtnDelete.Image = CType(resources.GetObject("TS2BtnDelete.Image"), System.Drawing.Image)
        Me.TS2BtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TS2BtnDelete.Name = "TS2BtnDelete"
        Me.TS2BtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TS2BtnDelete.Text = "Datensatz inaktivieren"
        Me.TS2BtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'frmVertragspartner
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(647, 613)
        Me.Controls.Add(Me.GrpKontakte)
        Me.Controls.Add(Me.PnlDetails)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmVertragspartner"
        Me.Text = "Vertragspartner"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.PnlDetails.ResumeLayout(False)
        Me.PnlDetails.PerformLayout()
        Me.GrpKontakte.ResumeLayout(False)
        Me.GrpKontakte.PerformLayout()
        CType(Me.C1Kontakte, System.ComponentModel.ISupportInitialize).EndInit()
        Me.KontaktMenuStrip.ResumeLayout(False)
        Me.ToolStrip2.ResumeLayout(False)
        Me.ToolStrip2.PerformLayout()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.KontaktInaktivierenToolStripMenuItem_Click Method

frmVertragspartner.KontaktInaktivierenToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

Kontextmenu Delete
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub KontaktInaktivierenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   KontaktInaktivierenToolStripMenuItem.Click
C#
private System.Void KontaktInaktivierenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void KontaktInaktivierenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function KontaktInaktivierenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub KontaktInaktivierenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles KontaktInaktivierenToolStripMenuItem.Click
        Try
            Me.TS2BtnDelete_Click(sender, e)
        Catch
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.KontaktKopierenToolStripMenuItem_Click Method

frmVertragspartner.KontaktKopierenToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

Kontextmenu Kopieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub KontaktKopierenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   KontaktKopierenToolStripMenuItem.Click
C#
private System.Void KontaktKopierenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void KontaktKopierenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function KontaktKopierenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub KontaktKopierenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles KontaktKopierenToolStripMenuItem.Click
        Try
            Me.TS2BtnCopy_Click(sender, e)
        Catch
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.KontaktNeuToolStripMenuItem_Click Method

frmVertragspartner.KontaktNeuToolStripMenuItem_Click Method

Kontextmenu Neu
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub KontaktNeuToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   KontaktNeuToolStripMenuItem.Click
C#
private System.Void KontaktNeuToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void KontaktNeuToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function KontaktNeuToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub KontaktNeuToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles KontaktNeuToolStripMenuItem.Click
        Try
            Me.TS2BtnNew_Click(sender, e)
        Catch
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.Load_Securitylevel Method

frmVertragspartner.Load_Securitylevel Method

Laden der Securitylevel-Daten in die Combobox
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Load_Securitylevel()
C#
private System.Void Load_Securitylevel();
C++

private:
System::Void Load_Securitylevel()
JScript
private function Load_Securitylevel();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Load_Securitylevel()
        Dim seclevel As New TKB.VV.DB.clsSecurityLevel
        Dim secleveldata As New DataTable

        seclevel.cpMainConnectionProvider = Globals.conn
        Globals.conn.OpenConnection()
        secleveldata = seclevel.SelectAll
        Globals.conn.CloseConnection(True)

        Me.cboxSecurityLevel.DataSource = secleveldata
        Me.cboxSecurityLevel.DisplayMember = "Bezeichnung"
        Me.cboxSecurityLevel.ValueMember = "SecurityLevelNr"

        seclevel.Dispose()

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.Refresh_Personen Method

frmVertragspartner.Refresh_Personen Method

Personenliste aktualisieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Refresh_Personen()
C#
private System.Void Refresh_Personen();
C++

private:
System::Void Refresh_Personen()
JScript
private function Refresh_Personen();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Refresh_Personen()
        Try
            If check_changes = False Then Exit Sub
        Catch ex As Exception

        End Try
        Me.C1Kontakte.Enabled = True
        Me.Vertragspartnerdata.Get_Kontaktpersonen(Me.C1Kontakte)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Kontakte, "Person", Me.Vertragspartnerdata.Kontaktpersonen.Tabledata)
        sec.Set_Form_Security(Me)
        Me.C1Kontakte.Enabled = True
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.Save_Data Method

frmVertragspartner.Save_Data Method

Vertragspartner sichern, sofern Änderungen vorgenommen wurden, anschliessend erneut laden
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Save_Data()
C#
private System.Void Save_Data();
C++

private:
System::Void Save_Data()
JScript
private function Save_Data();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Save_Data()
        If Me.FormDataChanged Then
            Me.Vertragspartnerdata.sNameZ1 = New SqlString(CType(Me.txtName_Firma1.Text, String))
            Me.Vertragspartnerdata.sNameZ2 = New SqlString(CType(Me.txtVorname_Firma2.Text, String))
            Me.Vertragspartnerdata.sStrasse = New SqlString(CType(Me.txtStrasse.Text, String))
            Me.Vertragspartnerdata.sPostfach = New SqlString(CType(Me.txtPostfach.Text, String))
            Me.Vertragspartnerdata.sPLZ = New SqlString(CType(Me.txtPlz.Text, String))
            Me.Vertragspartnerdata.sOrt = New SqlString(CType(Me.txtOrt.Text, String))
            Me.Vertragspartnerdata.sTelefon = New SqlString(CType(Me.txtTelefon.Text, String))
            Me.Vertragspartnerdata.sTelefax = New SqlString(CType(Me.txtTelefax.Text, String))
            Me.Vertragspartnerdata.sEMail = New SqlString(CType(Me.txtEmail.Text, String))
            Me.Vertragspartnerdata.sInternet = New SqlString(CType(Me.txtInternet.Text, String))
            Me.Vertragspartnerdata.sBemerkung = New SqlString(CType(Me.txtBemerkung.Text, String))
            Me.Vertragspartnerdata.bAktiv = New SqlBoolean(CType(Me.cbAktiv.Checked, Boolean))
            Me.Vertragspartnerdata.iSecurityLevelNr = New SqlInt32(CType(Me.cboxSecurityLevel.SelectedValue, Int32))
            Get_Data(Me.Vertragspartnerdata.Save_Data)
            Me.FormDataChanged = False
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.TS2BtnCopy_Click Method

frmVertragspartner.TS2BtnCopy_Click Method

Kopie eines Datensatzen erstellen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TS2BtnCopy_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TS2BtnCopy.Click
C#
private System.Void TS2BtnCopy_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TS2BtnCopy_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TS2BtnCopy_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TS2BtnCopy_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TS2BtnCopy.Click
        Me.Vertragspartnerdata.Kontaktperson.Create_Copy(Me.C1Kontakte.Columns("Personnr").Value)
        Me.Refresh_Personen()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.TS2BtnDelete_Click Method

frmVertragspartner.TS2BtnDelete_Click Method

Kontakt löschen (inaktivieren)
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TS2BtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TS2BtnDelete.Click
C#
private System.Void TS2BtnDelete_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TS2BtnDelete_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TS2BtnDelete_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TS2BtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TS2BtnDelete.Click
        If msg.Show_MessageYesNo(200) = MsgBoxResult.Yes Then
            Me.Vertragspartnerdata.Kontaktperson.Delete_Kontakt(Me.C1Kontakte.Columns("Personnr").Value)
            Me.Refresh_Personen()
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.TS2BtnNew_Click Method

frmVertragspartner.TS2BtnNew_Click Method

Neuer Kontakt hinzufügen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TS2BtnNew_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TS2BtnNew.Click
C#
private System.Void TS2BtnNew_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TS2BtnNew_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TS2BtnNew_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TS2BtnNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TS2BtnNew.Click
        Dim i As Integer = Me.Vertragspartnerdata.Kontaktperson.Add_New(Me.Vertragspartnerdata.iVertragspartnerNr.Value)
        Dim f As New frmPerson(i, Me.Vertragspartnerdata.iVertragspartnerNr.Value)
        f.ShowDialog()
        Me.Refresh_Personen()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.TS2BtnView_Click Method

frmVertragspartner.TS2BtnView_Click Method

Personendetails anzeigen bzw. bearbeiten
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TS2BtnView_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TS2BtnView.Click
C#
private System.Void TS2BtnView_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TS2BtnView_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TS2BtnView_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TS2BtnView_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TS2BtnView.Click
        Dim f As New frmPerson(Me.C1Kontakte.Columns("Personnr").Value, Me.Vertragspartnerdata.iVertragspartnerNr.Value)
        f.ShowDialog()
        Me.Refresh_Personen()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.TSBtnCopy_Click Method

frmVertragspartner.TSBtnCopy_Click Method

Datensatz kopieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnCopy_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnCopy.Click
C#
private System.Void TSBtnCopy_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnCopy_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnCopy_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnCopy_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnCopy.Click
        If Me.Check_Changes = False Then Exit Sub
        Me.Get_Data(Vertragspartnerdata.Create_Copy(Me.Vertragspartnerdata.iVertragspartnerNr.Value))
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.TSBtnDelete_Click Method

frmVertragspartner.TSBtnDelete_Click Method

Aktueller Datensatz inaktivieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click
C#
private System.Void TSBtnDelete_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnDelete_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnDelete_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
        If msg.Show_MessageYesNo(250) = MsgBoxResult.Yes Then
            Me.Vertragspartnerdata.Delete_Partner(Me.Vertragspartnerdata.iVertragspartnerNr.Value)
            Me.Close()
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.TSBtnNew_Click Method

frmVertragspartner.TSBtnNew_Click Method

Neuer Datensatz erstellen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnNew_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnNew.Click
C#
private System.Void TSBtnNew_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnNew_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnNew_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnNew.Click
        If Me.Check_Changes = False Then Exit Sub
        Me.Get_Data(Me.Vertragspartnerdata.Add_New)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.TSBtnQuit_Click Method

frmVertragspartner.TSBtnQuit_Click Method

Formular schliessen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click
C#
private System.Void TSBtnQuit_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnQuit_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnQuit_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.TSBtnSave_Click Method

frmVertragspartner.TSBtnSave_Click Method

Sicherungs-Button betätigt
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click
C#
private System.Void TSBtnSave_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnSave_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnSave_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Me.Save_Data()
        Me.txtMutiert_am.Text = Me.Vertragspartnerdata.daMutiert_am.ToString
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.TSBtnSuche_Click Method

frmVertragspartner.TSBtnSuche_Click Method

Vertragspartner suchen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnSuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSuche.Click
C#
private System.Void TSBtnSuche_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnSuche_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnSuche_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSuche.Click
        If Not Me.FormReadonly Then Check_Changes()
        Dim i As Integer
        If Me.Vertragspartnerdata.Vertragspartner_Suchen(i) = True Then
            Me.Get_Data(i)
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.dispose Method

frmVertragspartner.dispose Method

destruction Dispose

Expand image Overload List

Name | Description
protected override System.Void Dispose(bool); |
public System.Void dispose(); | destruction Dispose

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.frmVertragspartner_Load Method

frmVertragspartner.frmVertragspartner_Load Method

Formular laden
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub frmVertragspartner_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load
C#
private System.Void frmVertragspartner_Load(
   object sender,
   EventArgs e
);
C++

private:
System::Void frmVertragspartner_Load(
   object^ sender,
   EventArgs^ e
)
JScript
private function frmVertragspartner_Load(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub frmVertragspartner_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

        If Anzeige = True Then
            Me.TSBtnSuche.Enabled = False
            Me.TSBtnSave.Enabled = False
        Else
            Me.TSBtnSuche.Enabled = True
        End If

        If Me.TSBtnSave.Enabled = False Or Me.TSBtnSave.Visible = False Then
            Me.FormReadonly = True
            Me.TSBtnCopy.Enabled = False
            Me.TSBtnNew.Enabled = False
            Me.TSBtnDelete.Enabled = False

            Me.TS2BtnNew.Enabled = False
            Me.TS2BtnCopy.Enabled = False
            Me.TS2BtnDelete.Enabled = False

            Me.KontaktAnzeigenToolStripMenuItem.Enabled = False
            Me.KontaktKopierenToolStripMenuItem.Enabled = False
            Me.KontaktNeuToolStripMenuItem.Enabled = False
            Me.KontaktInaktivierenToolStripMenuItem.Enabled = False

        Else
            Me.FormReadonly = False
        End If

        Load_Securitylevel()
        Get_Data(Me.vpnr)
        Me.AddChanges(Me)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.frmVertragspartner_Shown Method

frmVertragspartner.frmVertragspartner_Shown Method

Anzeige des Suchformulars, wenn keine Vertragspartnernummer vorhanden ist
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub frmVertragspartner_Shown( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   Me.Shown
C#
private System.Void frmVertragspartner_Shown(
   object sender,
   EventArgs e
);
C++

private:
System::Void frmVertragspartner_Shown(
   object^ sender,
   EventArgs^ e
)
JScript
private function frmVertragspartner_Shown(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub frmVertragspartner_Shown(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Shown
        If Me.vpnr = -1 Then Me.TSBtnSuche_Click(sender, e)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.txtBemerkung_TextChanged Method

frmVertragspartner.txtBemerkung_TextChanged Method

Änderungsvermerk sofern Änderungen vorgenommen wurden
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub txtBemerkung_TextChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   txtBemerkung.TextChanged, _
   cboxSecurityLevel.SelectedIndexChanged, _
   txtTelefon.TextChanged, _
   txtTelefax.TextChanged, _
   txtEmail.TextChanged, _
   txtInternet.TextChanged, _
   cbAktiv.CheckedChanged, _
   txtOrt.TextChanged, _
   txtPlz.TextChanged, _
   txtPostfach.TextChanged, _
   txtStrasse.TextChanged, _
   txtVorname_Firma2.TextChanged, _
   txtName_Firma1.TextChanged
C#
private System.Void txtBemerkung_TextChanged(
   object sender,
   EventArgs e
);
C++

private:
System::Void txtBemerkung_TextChanged(
   object^ sender,
   EventArgs^ e
)
JScript
private function txtBemerkung_TextChanged(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub txtBemerkung_TextChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles txtBemerkung.TextChanged, cboxSecurityLevel.SelectedIndexChanged, txtTelefon.TextChanged, _
        txtTelefax.TextChanged, txtEmail.TextChanged, txtInternet.TextChanged, cbAktiv.CheckedChanged, txtOrt.TextChanged, txtPlz.TextChanged, txtPostfach.TextChanged, _
        txtStrasse.TextChanged, txtVorname_Firma2.TextChanged, txtName_Firma1.TextChanged
        Me.FormDataChanged = True
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner Fields

frmVertragspartner Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | Anzeige |
Supported by the .NET Compact Framework. | FormDataChanged |
Supported by the .NET Compact Framework. | FormReadonly |
Supported by the .NET Compact Framework. | Kontaktperson |
Supported by the .NET Compact Framework. | SpaltenTitel |
Supported by the .NET Compact Framework. | Vertragspartnerdata |
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | msg |
Supported by the .NET Compact Framework. | sec |
Supported by the .NET Compact Framework. | vpnr |
Top

Expand image See Also

Reference

frmVertragspartner Class
TKB.VV.SLA
TKB.VV.SLA.clsServiceKatalogTree
TKB.VV.Sysadmin
TKB.VV.Sysadmin.DomainTable
TKB.VV.Utils
TKB.VV.Utils.MyMessage
TKB.VV.Utils.MySecurity
TKB.VV.Utils.Tabellenspalte


Anzeige Variable

Anzeige Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Anzeige As Boolean
C#
private bool Anzeige;
C++
private:
bool Anzeige;
JScript
private Anzeige : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Anzeige As Boolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


FormDataChanged Variable

FormDataChanged Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private FormDataChanged As Boolean
C#
private bool FormDataChanged;
C++
private:
bool FormDataChanged;
JScript
private FormDataChanged : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim FormDataChanged As Boolean = False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


FormReadonly Variable

FormReadonly Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private FormReadonly As Boolean
C#
private bool FormReadonly;
C++
private:
bool FormReadonly;
JScript
private FormReadonly : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim FormReadonly As Boolean = False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


Kontaktperson Variable

Kontaktperson Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Kontaktperson As clsPersonen
C#
private clsPersonen Kontaktperson;
C++
private:
clsPersonen^ Kontaktperson;
JScript
private Kontaktperson : clsPersonen

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Kontaktperson As New TKB.VV.Vertrag.clsPersonen

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


SpaltenTitel Variable

SpaltenTitel Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private SpaltenTitel As Tabellenspalte
C#
private Tabellenspalte SpaltenTitel;
C++
private:
Tabellenspalte^ SpaltenTitel;
JScript
private SpaltenTitel : Tabellenspalte

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


Vertragspartnerdata Variable

Vertragspartnerdata Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Vertragspartnerdata As clsVertragspartner
C#
private clsVertragspartner Vertragspartnerdata;
C++
private:
clsVertragspartner^ Vertragspartnerdata;
JScript
private Vertragspartnerdata : clsVertragspartner

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Vertragspartnerdata As New TKB.VV.Vertrag.clsVertragspartner

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


components Variable

components Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private components As IContainer
C#
private IContainer components;
C++
private:
IContainer^ components;
JScript
private components : IContainer

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private components As System.ComponentModel.IContainer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


msg Variable

msg Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private msg As MyMessage
C#
private MyMessage msg;
C++
private:
MyMessage^ msg;
JScript
private msg : MyMessage

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim msg As New TKB.VV.Utils.MyMessage

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


sec Variable

sec Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private sec As MySecurity
C#
private MySecurity sec;
C++
private:
MySecurity^ sec;
JScript
private sec : MySecurity

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim sec As New TKB.VV.Utils.MySecurity

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


vpnr Variable

vpnr Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private vpnr As Integer
C#
private int vpnr;
C++
private:
int vpnr;
JScript
private vpnr : int

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private vpnr As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartnerSuche Class

frmVertragspartnerSuche Class
Members
collapseAll image DropDown image

Vertragspartnersuche
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmVertragspartnerSuche
    Inherits Form
C#
[Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()]
public class frmVertragspartnerSuche : Form
C++
[Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()]

public ref class frmVertragspartnerSuche : public Form^
JScript
public
   Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()
class frmVertragspartnerSuche
   extends Form

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmVertragspartnerSuche

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartnerSuche Members


frmVertragspartnerSuche Members

frmVertragspartnerSuche Members
See Also Methods Properties
CollapseAll image DropDown image

Vertragspartnersuche

The following tables list the members exposed by the frmVertragspartnerSuche type.

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Vertragspartnernr |
Top

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | BeendenToolStripMenuItem_Click | Menu Beenden
Supported by the .NET Compact Framework. | BtnSchliessen_Click | Schliessen des Fensters
Supported by the .NET Compact Framework. | BtnSelect_Click | BtnSelect gewählt
Supported by the .NET Compact Framework. | BtnSuche_Click | Suche ausführen
Supported by the .NET Compact Framework. | C1Partnerliste_DoubleClick | Doubleklick in C1Partnerliste
Supported by the .NET Compact Framework. | C1Partnerliste_MouseDown | Mousedown-Ereignis handeln, damit auch bei rechter Maustaste der Fokus auf den richtigen Datensatz gesetzt wird
Supported by the .NET Compact Framework. | DetailsAnzeigenToolStripMenuItem_Click | Kontextmenu Details anzeigen gewählt
Supported by the .NET Compact Framework. | FrmVertragspartnerSuche_Load | Load des Dialogs
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | Partner_Suchen | Vertragspartner suchen
Supported by the .NET Compact Framework. | Serach_data | Vertragspartner aus DB auslesen
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Schliessen des Fensters
Supported by the .NET Compact Framework. | frmVertragspartnerSuche_Disposed |
Supported by the .NET Compact Framework. | txtName_Firma1_KeyDown | txtName_FirmaZ1 KeyDown
Supported by the .NET Compact Framework. | txtOrt_KeyDown | txtOrt Keydown
Supported by the .NET Compact Framework. | ÜberrnehmenToolStripMenuItem_Click | Kontextmenu Übernehmen gewählt
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | d |
Supported by the .NET Compact Framework. | m_Vertragspartnernr |
Top

Expand image See Also

Reference

frmVertragspartnerSuche Class


frmVertragspartnerSuche Properties

frmVertragspartnerSuche Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Vertragspartnernr |
Top

Expand image See Also

Reference

frmVertragspartnerSuche Class


frmVertragspartnerSuche.Vertragspartnernr Property

frmVertragspartnerSuche.Vertragspartnernr Property

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property Vertragspartnernr() As Integer
C#
public int Vertragspartnernr {get; set;}
C++
public:
property int Vertragspartnernr {
 int get( );
 void set(
   int value
 );
}
JScript
public function get Vertragspartnernr() : int;
public function set Vertragspartnernr(value : int);

Expand image Source code

Visual Basic CopyCode image Copy Code
    Property Vertragspartnernr() As Integer
        Get
            Return m_Vertragspartnernr
        End Get
        Set(ByVal value As Integer)
            m_Vertragspartnernr = value
        End Set
    End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartnerSuche Class
frmVertragspartnerSuche Members


frmVertragspartnerSuche Methods

frmVertragspartnerSuche Methods
CollapseAll image DropDown image

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | BeendenToolStripMenuItem_Click | Menu Beenden
Supported by the .NET Compact Framework. | BtnSchliessen_Click | Schliessen des Fensters
Supported by the .NET Compact Framework. | BtnSelect_Click | BtnSelect gewählt
Supported by the .NET Compact Framework. | BtnSuche_Click | Suche ausführen
Supported by the .NET Compact Framework. | C1Partnerliste_DoubleClick | Doubleklick in C1Partnerliste
Supported by the .NET Compact Framework. | C1Partnerliste_MouseDown | Mousedown-Ereignis handeln, damit auch bei rechter Maustaste der Fokus auf den richtigen Datensatz gesetzt wird
Supported by the .NET Compact Framework. | DetailsAnzeigenToolStripMenuItem_Click | Kontextmenu Details anzeigen gewählt
Supported by the .NET Compact Framework. | FrmVertragspartnerSuche_Load | Load des Dialogs
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | Partner_Suchen | Vertragspartner suchen
Supported by the .NET Compact Framework. | Serach_data | Vertragspartner aus DB auslesen
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Schliessen des Fensters
Supported by the .NET Compact Framework. | frmVertragspartnerSuche_Disposed |
Supported by the .NET Compact Framework. | txtName_Firma1_KeyDown | txtName_FirmaZ1 KeyDown
Supported by the .NET Compact Framework. | txtOrt_KeyDown | txtOrt Keydown
Supported by the .NET Compact Framework. | ÜberrnehmenToolStripMenuItem_Click | Kontextmenu Übernehmen gewählt
Top

Expand image See Also

Reference

frmVertragspartnerSuche Class


frmVertragspartnerSuche.BeendenToolStripMenuItem_Click Method

frmVertragspartnerSuche.BeendenToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

Menu Beenden
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click
C#
private System.Void BeendenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void BeendenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function BeendenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        TSBtnQuit_Click(sender, e)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartnerSuche Class
frmVertragspartnerSuche Members


frmVertragspartnerSuche.BtnSchliessen_Click Method

frmVertragspartnerSuche.BtnSchliessen_Click Method

Schliessen des Fensters
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub BtnSchliessen_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BtnSchliessen.Click
C#
private System.Void BtnSchliessen_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void BtnSchliessen_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function BtnSchliessen_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub BtnSchliessen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnSchliessen.Click
        Me.TSBtnQuit_Click(sender, e)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartnerSuche Class
frmVertragspartnerSuche Members


frmVertragspartnerSuche.BtnSelect_Click Method

frmVertragspartnerSuche.BtnSelect_Click Method

BtnSelect gewählt
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub BtnSelect_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BtnSelect.Click
C#
private System.Void BtnSelect_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void BtnSelect_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function BtnSelect_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub BtnSelect_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnSelect.Click
        Me.Vertragspartnernr = Me.C1Partnerliste.Columns("Vertragspartnernr").Value
        Me.DialogResult = Windows.Forms.DialogResult.OK
        Me.Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartnerSuche Class
frmVertragspartnerSuche Members


frmVertragspartnerSuche.BtnSuche_Click Method

frmVertragspartnerSuche.BtnSuche_Click Method

Suche ausführen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub BtnSuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BtnSuche.Click
C#
private System.Void BtnSuche_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void BtnSuche_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function BtnSuche_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub BtnSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnSuche.Click
        Me.Partner_Suchen()
        If Me.C1Partnerliste.Splits(0).Rows.Count > 0 Then
            Me.C1Partnerliste.Bookmark = 0
            Me.BtnSelect.Enabled = True
            Me.VertragspartnerMenuStrip.Enabled = True
        Else
            Me.BtnSelect.Enabled = False
            Me.VertragspartnerMenuStrip.Enabled = False
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartnerSuche Class
frmVertragspartnerSuche Members


frmVertragspartnerSuche.C1Partnerliste_DoubleClick Method

frmVertragspartnerSuche.C1Partnerliste_DoubleClick Method

Doubleklick in C1Partnerliste
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub C1Partnerliste_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Partnerliste.DoubleClick
C#
private System.Void C1Partnerliste_DoubleClick(
   object sender,
   EventArgs e
);
C++

private:
System::Void C1Partnerliste_DoubleClick(
   object^ sender,
   EventArgs^ e
)
JScript
private function C1Partnerliste_DoubleClick(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub C1Partnerliste_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Partnerliste.DoubleClick
        If Me.C1Partnerliste.Splits(0).Rows.Count > 0 Then
            Me.BtnSelect_Click(sender, e)
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartnerSuche Class
frmVertragspartnerSuche Members


frmVertragspartnerSuche.C1Partnerliste_MouseDown Method

frmVertragspartnerSuche.C1Partnerliste_MouseDown Method

Mousedown-Ereignis handeln, damit auch bei rechter Maustaste der Fokus auf den richtigen Datensatz gesetzt wird
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub C1Partnerliste_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Partnerliste.MouseDown
C#
private System.Void C1Partnerliste_MouseDown(
   object sender,
   MouseEventArgs e
);
C++

private:
System::Void C1Partnerliste_MouseDown(
   object^ sender,
   MouseEventArgs^ e
)
JScript
private function C1Partnerliste_MouseDown(
    sender : object,
    e : MouseEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub C1Partnerliste_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Partnerliste.MouseDown
        Me.C1Partnerliste.Bookmark = Me.C1Partnerliste.RowContaining(e.Y)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartnerSuche Class
frmVertragspartnerSuche Members


frmVertragspartnerSuche.DetailsAnzeigenToolStripMenuItem_Click Method

frmVertragspartnerSuche.DetailsAnzeigenToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

Kontextmenu Details anzeigen gewählt
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub DetailsAnzeigenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   DetailsAnzeigenToolStripMenuItem.Click
C#
private System.Void DetailsAnzeigenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void DetailsAnzeigenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function DetailsAnzeigenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub DetailsAnzeigenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DetailsAnzeigenToolStripMenuItem.Click
        Dim f As New frmVertragspartner(Me.C1Partnerliste.Columns("Vertragspartnernr").Value, True)
        f.ShowDialog()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartnerSuche Class
frmVertragspartnerSuche Members


frmVertragspartnerSuche.Dispose Method

frmVertragspartnerSuche.Dispose Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
C#
[System.Diagnostics.DebuggerNonUserCode()]
protected override System.Void Dispose(
   bool disposing
);
C++
[System.Diagnostics.DebuggerNonUserCode()]

protected:
System::Void Dispose(
   bool disposing
)
JScript
protected
   System.Diagnostics.DebuggerNonUserCode()
function Dispose(
    disposing : boolean
);

Parameters

disposing

Expand image Source code

Visual Basic CopyCode image Copy Code
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartnerSuche Class
frmVertragspartnerSuche Members


frmVertragspartnerSuche.FrmVertragspartnerSuche_Load Method

frmVertragspartnerSuche.FrmVertragspartnerSuche_Load Method

Load des Dialogs
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub FrmVertragspartnerSuche_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load
C#
private System.Void FrmVertragspartnerSuche_Load(
   object sender,
   EventArgs e
);
C++

private:
System::Void FrmVertragspartnerSuche_Load(
   object^ sender,
   EventArgs^ e
)
JScript
private function FrmVertragspartnerSuche_Load(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub FrmVertragspartnerSuche_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.Vertragspartnernr = -1
        Me.BtnSelect.Enabled = False
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartnerSuche Class
frmVertragspartnerSuche Members


frmVertragspartnerSuche.InitializeComponent Method

frmVertragspartnerSuche.InitializeComponent Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()
C#
[System.Diagnostics.DebuggerStepThrough()]
private System.Void InitializeComponent();
C++
[System.Diagnostics.DebuggerStepThrough()]

private:
System::Void InitializeComponent()
JScript
private
   System.Diagnostics.DebuggerStepThrough()
function InitializeComponent();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmVertragspartnerSuche))
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.txtOrt = New System.Windows.Forms.TextBox
        Me.lblOrt = New System.Windows.Forms.Label
        Me.txtName_Firma1 = New System.Windows.Forms.TextBox
        Me.lblName_Firma1 = New System.Windows.Forms.Label
        Me.BtnSuche = New System.Windows.Forms.Button
        Me.C1Partnerliste = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.VertragspartnerMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.ÜberrnehmenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.DetailsAnzeigenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.txtFreitext = New System.Windows.Forms.TextBox
        Me.lblFreitext = New System.Windows.Forms.Label
        Me.BtnSchliessen = New System.Windows.Forms.Button
        Me.BtnSelect = New System.Windows.Forms.Button
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        CType(Me.C1Partnerliste, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.VertragspartnerMenuStrip.SuspendLayout()
        Me.SuspendLayout()
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(127, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(571, 24)
        Me.MenuStrip1.TabIndex = 15
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(571, 25)
        Me.ToolStrip1.TabIndex = 16
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'txtOrt
        '
        Me.txtOrt.Location = New System.Drawing.Point(93, 78)
        Me.txtOrt.Name = "txtOrt"
        Me.txtOrt.Size = New System.Drawing.Size(166, 20)
        Me.txtOrt.TabIndex = 1
        '
        'lblOrt
        '
        Me.lblOrt.AccessibleDescription = "Name"
        Me.lblOrt.AutoSize = True
        Me.lblOrt.Location = New System.Drawing.Point(9, 81)
        Me.lblOrt.Name = "lblOrt"
        Me.lblOrt.Size = New System.Drawing.Size(21, 13)
        Me.lblOrt.TabIndex = 72
        Me.lblOrt.Text = "Ort"
        '
        'txtName_Firma1
        '
        Me.txtName_Firma1.Location = New System.Drawing.Point(93, 52)
        Me.txtName_Firma1.Name = "txtName_Firma1"
        Me.txtName_Firma1.Size = New System.Drawing.Size(166, 20)
        Me.txtName_Firma1.TabIndex = 0
        Me.txtName_Firma1.Tag = ""
        '
        'lblName_Firma1
        '
        Me.lblName_Firma1.AccessibleDescription = "Name"
        Me.lblName_Firma1.AutoSize = True
        Me.lblName_Firma1.Location = New System.Drawing.Point(9, 55)
        Me.lblName_Firma1.Name = "lblName_Firma1"
        Me.lblName_Firma1.Size = New System.Drawing.Size(71, 13)
        Me.lblName_Firma1.TabIndex = 71
        Me.lblName_Firma1.Text = "Name / Firma"
        '
        'BtnSuche
        '
        Me.BtnSuche.Location = New System.Drawing.Point(12, 111)
        Me.BtnSuche.Name = "BtnSuche"
        Me.BtnSuche.Size = New System.Drawing.Size(75, 23)
        Me.BtnSuche.TabIndex = 73
        Me.BtnSuche.Text = "Suchen"
        Me.BtnSuche.UseVisualStyleBackColor = True
        '
        'C1Partnerliste
        '
        Me.C1Partnerliste.AlternatingRows = True
        Me.C1Partnerliste.ContextMenuStrip = Me.VertragspartnerMenuStrip
        Me.C1Partnerliste.FilterBar = True
        Me.C1Partnerliste.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Partnerliste.Images.Add(CType(resources.GetObject("C1Partnerliste.Images"), System.Drawing.Image))
        Me.C1Partnerliste.Location = New System.Drawing.Point(12, 140)
        Me.C1Partnerliste.Name = "C1Partnerliste"
        Me.C1Partnerliste.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Partnerliste.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Partnerliste.PreviewInfo.ZoomFactor = 75
        Me.C1Partnerliste.PrintInfo.PageSettings = CType(resources.GetObject("C1Partnerliste.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Partnerliste.Size = New System.Drawing.Size(551, 201)
        Me.C1Partnerliste.TabIndex = 3
        Me.C1Partnerliste.Text = "C1Kontakte"
        Me.C1Partnerliste.PropBag = resources.GetString("C1Partnerliste.PropBag")
        '
        'VertragspartnerMenuStrip
        '
        Me.VertragspartnerMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.ÜberrnehmenToolStripMenuItem, Me.DetailsAnzeigenToolStripMenuItem})
        Me.VertragspartnerMenuStrip.Name = "VertragspartnerMenuStrip"
        Me.VertragspartnerMenuStrip.Size = New System.Drawing.Size(164, 48)
        '
        'ÜberrnehmenToolStripMenuItem
        '
        Me.ÜberrnehmenToolStripMenuItem.Name = "ÜberrnehmenToolStripMenuItem"
        Me.ÜberrnehmenToolStripMenuItem.Size = New System.Drawing.Size(163, 22)
        Me.ÜberrnehmenToolStripMenuItem.Text = "Übe&rnehmen"
        '
        'DetailsAnzeigenToolStripMenuItem
        '
        Me.DetailsAnzeigenToolStripMenuItem.Name = "DetailsAnzeigenToolStripMenuItem"
        Me.DetailsAnzeigenToolStripMenuItem.Size = New System.Drawing.Size(163, 22)
        Me.DetailsAnzeigenToolStripMenuItem.Text = "&Details anzeigen"
        '
        'txtFreitext
        '
        Me.txtFreitext.Location = New System.Drawing.Point(393, 52)
        Me.txtFreitext.Name = "txtFreitext"
        Me.txtFreitext.Size = New System.Drawing.Size(166, 20)
        Me.txtFreitext.TabIndex = 2
        Me.txtFreitext.Visible = False
        '
        'lblFreitext
        '
        Me.lblFreitext.AccessibleDescription = "Name"
        Me.lblFreitext.AutoSize = True
        Me.lblFreitext.Location = New System.Drawing.Point(309, 55)
        Me.lblFreitext.Name = "lblFreitext"
        Me.lblFreitext.Size = New System.Drawing.Size(41, 13)
        Me.lblFreitext.TabIndex = 76
        Me.lblFreitext.Text = "Freitext"
        Me.lblFreitext.Visible = False
        '
        'BtnSchliessen
        '
        Me.BtnSchliessen.Location = New System.Drawing.Point(12, 347)
        Me.BtnSchliessen.Name = "BtnSchliessen"
        Me.BtnSchliessen.Size = New System.Drawing.Size(80, 24)
        Me.BtnSchliessen.TabIndex = 4
        Me.BtnSchliessen.Text = "Schliessen"
        '
        'BtnSelect
        '
        Me.BtnSelect.Enabled = False
        Me.BtnSelect.Location = New System.Drawing.Point(475, 347)
        Me.BtnSelect.Name = "BtnSelect"
        Me.BtnSelect.Size = New System.Drawing.Size(88, 23)
        Me.BtnSelect.TabIndex = 5
        Me.BtnSelect.Text = "Übernehmen"
        '
        'frmVertragspartnerSuche
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(571, 376)
        Me.Controls.Add(Me.BtnSchliessen)
        Me.Controls.Add(Me.BtnSelect)
        Me.Controls.Add(Me.txtFreitext)
        Me.Controls.Add(Me.C1Partnerliste)
        Me.Controls.Add(Me.lblFreitext)
        Me.Controls.Add(Me.txtOrt)
        Me.Controls.Add(Me.lblOrt)
        Me.Controls.Add(Me.BtnSuche)
        Me.Controls.Add(Me.txtName_Firma1)
        Me.Controls.Add(Me.lblName_Firma1)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmVertragspartnerSuche"
        Me.Text = "Vertragspartner suchen"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        CType(Me.C1Partnerliste, System.ComponentModel.ISupportInitialize).EndInit()
        Me.VertragspartnerMenuStrip.ResumeLayout(False)
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartnerSuche Class
frmVertragspartnerSuche Members


frmVertragspartnerSuche.Partner_Suchen Method

frmVertragspartnerSuche.Partner_Suchen Method

Vertragspartner suchen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Partner_Suchen() As Object
C#
private object Partner_Suchen();
C++

private:
object^ Partner_Suchen()
JScript
private function Partner_Suchen() : object;

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Function Partner_Suchen()
        If Me.txtName_Firma1.Text <> "" Then
            d = Serach_data(Me.txtName_Firma1.Text, 0)
        Else
            If Me.txtOrt.Text <> "" Then
                d = Serach_data(Me.txtOrt.Text, 1)
            End If
        End If
        Me.C1Partnerliste.DataSource = d
        Me.C1Partnerliste.DataMember = d.TableName

        Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte
        SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Partnerliste, "Vertragspartner", d)
        SpaltenTitel = Nothing
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartnerSuche Class
frmVertragspartnerSuche Members


frmVertragspartnerSuche.Serach_data Method

frmVertragspartnerSuche.Serach_data Method

Vertragspartner aus DB auslesen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Serach_data( _
   ByVal query As String, _
   ByVal fnkt As Integer _
) As DataTable
C#
private DataTable Serach_data(
   string query,
   int fnkt
);
C++

private:
DataTable^ Serach_data(
   String^ query,
   int fnkt
)
JScript
private function Serach_data(
    query : String,
    fnkt : int
) : DataTable;

Parameters

query

fnkt

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Function Serach_data(ByVal query As String, ByVal fnkt As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_vertragspartner_search"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@query", SqlDbType.VarChar, 1000, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, query))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, fnkt))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
            sdaAdapter.Fill(dtToReturn)
            Return dttoreturn
        Catch ex As Exception
            Throw New Exception("clsVertragspartner::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartnerSuche Class
frmVertragspartnerSuche Members


frmVertragspartnerSuche.TSBtnQuit_Click Method

frmVertragspartnerSuche.TSBtnQuit_Click Method

Schliessen des Fensters
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click
C#
private System.Void TSBtnQuit_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnQuit_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnQuit_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartnerSuche Class
frmVertragspartnerSuche Members


frmVertragspartnerSuche.frmVertragspartnerSuche_Disposed Method

frmVertragspartnerSuche.frmVertragspartnerSuche_Disposed Method
See Also
collapseAll image DropDown image

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub frmVertragspartnerSuche_Disposed( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   Me.Disposed
C#
private System.Void frmVertragspartnerSuche_Disposed(
   object sender,
   EventArgs e
);
C++

private:
System::Void frmVertragspartnerSuche_Disposed(
   object^ sender,
   EventArgs^ e
)
JScript
private function frmVertragspartnerSuche_Disposed(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub frmVertragspartnerSuche_Disposed(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Disposed
        d.Dispose()
        components.Dispose()
        MyBase.Dispose()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartnerSuche Class
frmVertragspartnerSuche Members


frmVertragspartnerSuche.txtName_Firma1_KeyDown Method

frmVertragspartnerSuche.txtName_Firma1_KeyDown Method

txtName_FirmaZ1 KeyDown
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub txtName_Firma1_KeyDown( _
   ByVal sender As Object, _
   ByVal e As KeyEventArgs _
) Handles  _
   txtName_Firma1.KeyDown
C#
private System.Void txtName_Firma1_KeyDown(
   object sender,
   KeyEventArgs e
);
C++

private:
System::Void txtName_Firma1_KeyDown(
   object^ sender,
   KeyEventArgs^ e
)
JScript
private function txtName_Firma1_KeyDown(
    sender : object,
    e : KeyEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub txtName_Firma1_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtName_Firma1.KeyDown
        If e.KeyCode = Keys.Enter Then
            Me.BtnSuche_Click(sender, e)
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartnerSuche Class
frmVertragspartnerSuche Members


frmVertragspartnerSuche.txtOrt_KeyDown Method

frmVertragspartnerSuche.txtOrt_KeyDown Method

txtOrt Keydown
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub txtOrt_KeyDown( _
   ByVal sender As Object, _
   ByVal e As KeyEventArgs _
) Handles  _
   txtOrt.KeyDown
C#
private System.Void txtOrt_KeyDown(
   object sender,
   KeyEventArgs e
);
C++

private:
System::Void txtOrt_KeyDown(
   object^ sender,
   KeyEventArgs^ e
)
JScript
private function txtOrt_KeyDown(
    sender : object,
    e : KeyEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub txtOrt_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtOrt.KeyDown
        If e.KeyCode = Keys.Enter Then
            Me.BtnSuche_Click(sender, e)
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartnerSuche Class
frmVertragspartnerSuche Members


frmVertragspartnerSuche.ÜberrnehmenToolStripMenuItem_Click Method

frmVertragspartnerSuche.ÜberrnehmenToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

Kontextmenu Übernehmen gewählt
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub ÜberrnehmenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ÜberrnehmenToolStripMenuItem.Click
C#
private System.Void ÜberrnehmenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void ÜberrnehmenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function ÜberrnehmenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub ÜberrnehmenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ÜberrnehmenToolStripMenuItem.Click
        Me.BtnSelect_Click(sender, e)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartnerSuche Class
frmVertragspartnerSuche Members


frmVertragspartnerSuche Fields

frmVertragspartnerSuche Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | d |
Supported by the .NET Compact Framework. | m_Vertragspartnernr |
Top

Expand image See Also

Reference

frmVertragspartnerSuche Class


components Variable

components Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private components As IContainer
C#
private IContainer components;
C++
private:
IContainer^ components;
JScript
private components : IContainer

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private components As System.ComponentModel.IContainer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartnerSuche Class
frmVertragspartnerSuche Members


d Variable

d Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private d As DataTable
C#
private DataTable d;
C++
private:
DataTable^ d;
JScript
private d : DataTable

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim d As New DataTable

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartnerSuche Class
frmVertragspartnerSuche Members


m_Vertragspartnernr Variable

m_Vertragspartnernr Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_Vertragspartnernr As Integer
C#
private int m_Vertragspartnernr;
C++
private:
int m_Vertragspartnernr;
JScript
private m_Vertragspartnernr : int

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim m_Vertragspartnernr As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartnerSuche Class
frmVertragspartnerSuche Members


frmVertragsuebersicht Class

frmVertragsuebersicht Class
Members
collapseAll image DropDown image

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmVertragsuebersicht
    Inherits Form
C#
[Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()]
public class frmVertragsuebersicht : Form
C++
[Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()]

public ref class frmVertragsuebersicht : public Form^
JScript
public
   Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()
class frmVertragsuebersicht
   extends Form

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmVertragsuebersicht

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Members


frmVertragsuebersicht Members

frmVertragsuebersicht Members
See Also Methods
CollapseAll image DropDown image

The following tables list the members exposed by the frmVertragsuebersicht type.

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | FindNode | Suchen eines Knoten Treeview
Top

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | BeendenToolStipMenuItem_Click | Menu Beenden
Supported by the .NET Compact Framework. | C1Vertragselemente_DoubleClick | Doubleklick auf C1Vertragselemente
Supported by the .NET Compact Framework. | C1Vertragselemente_FetchRowStyle | Bei inaktiven Einträge Schrift "grua" setzen und durchstreichen
Supported by the .NET Compact Framework. | C1Vertragselemente_MouseDown | Mousedown-Ereignis auf C1Certragselemente, damit die Details aktualisiert werden können
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | Load_Struktur | Laden der Treestruktur
Supported by the .NET Compact Framework. | NeuerVertragspartnerToolStripMenuItem_Click | Neuer Vertragspartner eröffnen
Supported by the .NET Compact Framework. | NeuesVertragselementErstellenToolStripMenuItem_Click | Neues Vertragselement laden
Supported by the .NET Compact Framework. | RB_CheckedChanged | Handling RB_Changed für den Aufbau der Struktur
Supported by the .NET Compact Framework. | Refresh_All | Treeview Struktur aktualisieren
Supported by the .NET Compact Framework. | Refresh_Details | Details aktualisieren
Supported by the .NET Compact Framework. | Refresh_Kontakte | Kontakte aktualisieren
Supported by the .NET Compact Framework. | Refresh_Kuendigungsfrist | Kündigungsfristen aktualisieren
Supported by the .NET Compact Framework. | RootTreeNode | Toplevel-Treenode suchen
Supported by the .NET Compact Framework. | SpaltendarstellungSichernToolStripMenuItem_Click | Spaltenlayout C1Vertragselemente speichern
Supported by the .NET Compact Framework. | TSBtnCopy_Click | Datensatz kopieren
Supported by the .NET Compact Framework. | TSBtnDelete_Click | Aktueller Datensatz inaktivieren
Supported by the .NET Compact Framework. | TSBtnNew_Click | Neuer Datensatz erstellen
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Formular schliessen
Supported by the .NET Compact Framework. | TSBtnSuche_Click | Vertragspartner suchen
Supported by the .NET Compact Framework. | TabControlDiverse_SelectedIndexChanged | Index-Wechsel auf TabControlDiverse. Abhängig der gewählten Registerlasche, werden deren Daten aktualisiert.
Supported by the .NET Compact Framework. | TreeStrukturAktualisierenToolStripMenuItem_Click | Aktualisierung des aktuellen Knotens
Supported by the .NET Compact Framework. | TreeStrukturContextMenuStrip_Opening | TreeStrukturContetmenu anzeigen und allfällige MenuItems disablen
Supported by the .NET Compact Framework. | TreeStrukturTreeAktualisierenToolStripMenuItem_Click | Vollständiger Treeview aktualisieren
Supported by the .NET Compact Framework. | TreeStrukturVertragspartnerAnzeigenToolStipMenuItem_Click | Vertragspartner anzeigen / bearbeiten
Supported by the .NET Compact Framework. | TreeStruktur_Click | Treeview-Click
Supported by the .NET Compact Framework. | TreeStruktur_MouseDown | Mousedown-Ereignis auf dem Tree
Supported by the .NET Compact Framework. | Update_DetailInformationen | Detail-Informationen der ersten 2 TabPages aktualisieren
Supported by the .NET Compact Framework. | Update_Details | Detailelemente und die allfällig ausgewählte TabPage aktualisieren
Supported by the .NET Compact Framework. | Update_Node |
Supported by the .NET Compact Framework. | VertragselementAnzeigenBearbeitenToolStripMenuItem_Click | Vertragselement anzeigen / bearbeiten
Supported by the .NET Compact Framework. | cbocInaktiv_CheckedChanged |
Supported by the .NET Compact Framework. | evh_FormularVertragelement_Closed |
Supported by the .NET Compact Framework. | evh_FormularVertragspartner_Closed |
Supported by the .NET Compact Framework. | frmVertragsuebersicht_Load | Formular-Load
Supported by the .NET Compact Framework. | treeStruktur_BeforeExpand | Aktueller Tag des gewählten Nodes auslesen und Aktualisierung aufrufen
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | Docs | Dokument-Management-Klasse
Supported by the .NET Compact Framework. | FormDataChanged |
Supported by the .NET Compact Framework. | FormReadonly |
Supported by the .NET Compact Framework. | SpaltenTitel |
Supported by the .NET Compact Framework. | Strukturen | Klasse für die Bewirtschaftung der Tree-Strukturen
Supported by the .NET Compact Framework. | Tag_Descriptor | Klasse für die Beschreibung der Tree-Tags
Supported by the .NET Compact Framework. | Vertragselement | Vertragselement
Supported by the .NET Compact Framework. | c1data |
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | msg | Message-Klasse
Supported by the .NET Compact Framework. | sec | Security-Klasse
Internal (Friend) field Supported by the .NET Compact Framework. | selectPoint |
Top

Expand image See Also

Reference

frmVertragsuebersicht Class


frmVertragsuebersicht Methods

frmVertragsuebersicht Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | FindNode | Suchen eines Knoten Treeview
Top

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | BeendenToolStipMenuItem_Click | Menu Beenden
Supported by the .NET Compact Framework. | C1Vertragselemente_DoubleClick | Doubleklick auf C1Vertragselemente
Supported by the .NET Compact Framework. | C1Vertragselemente_FetchRowStyle | Bei inaktiven Einträge Schrift "grua" setzen und durchstreichen
Supported by the .NET Compact Framework. | C1Vertragselemente_MouseDown | Mousedown-Ereignis auf C1Certragselemente, damit die Details aktualisiert werden können
Supported by the .NET Compact Framework. | InitializeComponent |
Supported by the .NET Compact Framework. | Load_Struktur | Laden der Treestruktur
Supported by the .NET Compact Framework. | NeuerVertragspartnerToolStripMenuItem_Click | Neuer Vertragspartner eröffnen
Supported by the .NET Compact Framework. | NeuesVertragselementErstellenToolStripMenuItem_Click | Neues Vertragselement laden
Supported by the .NET Compact Framework. | RB_CheckedChanged | Handling RB_Changed für den Aufbau der Struktur
Supported by the .NET Compact Framework. | Refresh_All | Treeview Struktur aktualisieren
Supported by the .NET Compact Framework. | Refresh_Details | Details aktualisieren
Supported by the .NET Compact Framework. | Refresh_Kontakte | Kontakte aktualisieren
Supported by the .NET Compact Framework. | Refresh_Kuendigungsfrist | Kündigungsfristen aktualisieren
Supported by the .NET Compact Framework. | RootTreeNode | Toplevel-Treenode suchen
Supported by the .NET Compact Framework. | SpaltendarstellungSichernToolStripMenuItem_Click | Spaltenlayout C1Vertragselemente speichern
Supported by the .NET Compact Framework. | TSBtnCopy_Click | Datensatz kopieren
Supported by the .NET Compact Framework. | TSBtnDelete_Click | Aktueller Datensatz inaktivieren
Supported by the .NET Compact Framework. | TSBtnNew_Click | Neuer Datensatz erstellen
Supported by the .NET Compact Framework. | TSBtnQuit_Click | Formular schliessen
Supported by the .NET Compact Framework. | TSBtnSuche_Click | Vertragspartner suchen
Supported by the .NET Compact Framework. | TabControlDiverse_SelectedIndexChanged | Index-Wechsel auf TabControlDiverse. Abhängig der gewählten Registerlasche, werden deren Daten aktualisiert.
Supported by the .NET Compact Framework. | TreeStrukturAktualisierenToolStripMenuItem_Click | Aktualisierung des aktuellen Knotens
Supported by the .NET Compact Framework. | TreeStrukturContextMenuStrip_Opening | TreeStrukturContetmenu anzeigen und allfällige MenuItems disablen
Supported by the .NET Compact Framework. | TreeStrukturTreeAktualisierenToolStripMenuItem_Click | Vollständiger Treeview aktualisieren
Supported by the .NET Compact Framework. | TreeStrukturVertragspartnerAnzeigenToolStipMenuItem_Click | Vertragspartner anzeigen / bearbeiten
Supported by the .NET Compact Framework. | TreeStruktur_Click | Treeview-Click
Supported by the .NET Compact Framework. | TreeStruktur_MouseDown | Mousedown-Ereignis auf dem Tree
Supported by the .NET Compact Framework. | Update_DetailInformationen | Detail-Informationen der ersten 2 TabPages aktualisieren
Supported by the .NET Compact Framework. | Update_Details | Detailelemente und die allfällig ausgewählte TabPage aktualisieren
Supported by the .NET Compact Framework. | Update_Node |
Supported by the .NET Compact Framework. | VertragselementAnzeigenBearbeitenToolStripMenuItem_Click | Vertragselement anzeigen / bearbeiten
Supported by the .NET Compact Framework. | cbocInaktiv_CheckedChanged |
Supported by the .NET Compact Framework. | evh_FormularVertragelement_Closed |
Supported by the .NET Compact Framework. | evh_FormularVertragspartner_Closed |
Supported by the .NET Compact Framework. | frmVertragsuebersicht_Load | Formular-Load
Supported by the .NET Compact Framework. | treeStruktur_BeforeExpand | Aktueller Tag des gewählten Nodes auslesen und Aktualisierung aufrufen
Top

Expand image See Also

Reference

frmVertragsuebersicht Class


frmVertragsuebersicht.BeendenToolStipMenuItem_Click Method

frmVertragsuebersicht.BeendenToolStipMenuItem_Click Method

Menu Beenden
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub BeendenToolStipMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStipMenuItem.Click
C#
private System.Void BeendenToolStipMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void BeendenToolStipMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function BeendenToolStipMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub BeendenToolStipMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStipMenuItem.Click
        Me.TSBtnQuit_Click(sender, e)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.C1Vertragselemente_DoubleClick Method

frmVertragsuebersicht.C1Vertragselemente_DoubleClick Method

Doubleklick auf C1Vertragselemente
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub C1Vertragselemente_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Vertragselemente.DoubleClick
C#
private System.Void C1Vertragselemente_DoubleClick(
   object sender,
   EventArgs e
);
C++

private:
System::Void C1Vertragselemente_DoubleClick(
   object^ sender,
   EventArgs^ e
)
JScript
private function C1Vertragselemente_DoubleClick(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub C1Vertragselemente_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Vertragselemente.DoubleClick
        Try
            Dim f As New frmVertragselement(Me.C1Vertragselemente.Columns("Vertragselementnr").Value, Me.FormReadonly, False)
            f.MdiParent = Me.MdiParent
            f.Show()
        Catch ex As Exception
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.C1Vertragselemente_FetchRowStyle Method

frmVertragsuebersicht.C1Vertragselemente_FetchRowStyle Method
See Also
collapseAll image DropDown image

Bei inaktiven Einträge Schrift "grua" setzen und durchstreichen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub C1Vertragselemente_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Vertragselemente.FetchRowStyle
C#
private System.Void C1Vertragselemente_FetchRowStyle(
   object sender,
   FetchRowStyleEventArgs e
);
C++

private:
System::Void C1Vertragselemente_FetchRowStyle(
   object^ sender,
   FetchRowStyleEventArgs^ e
)
JScript
private function C1Vertragselemente_FetchRowStyle(
    sender : object,
    e : FetchRowStyleEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub C1Vertragselemente_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Vertragselemente.FetchRowStyle
        If Me.C1Vertragselemente.Columns("aktiv").CellValue(e.Row) = False Then
            Dim FNT As Font = e.CellStyle.Font
            e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
            e.CellStyle.ForeColor = Color.Gray
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.C1Vertragselemente_MouseDown Method

frmVertragsuebersicht.C1Vertragselemente_MouseDown Method

Mousedown-Ereignis auf C1Certragselemente, damit die Details aktualisiert werden können
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub C1Vertragselemente_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Vertragselemente.MouseDown
C#
private System.Void C1Vertragselemente_MouseDown(
   object sender,
   MouseEventArgs e
);
C++

private:
System::Void C1Vertragselemente_MouseDown(
   object^ sender,
   MouseEventArgs^ e
)
JScript
private function C1Vertragselemente_MouseDown(
    sender : object,
    e : MouseEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub C1Vertragselemente_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Vertragselemente.MouseDown
        Me.C1Vertragselemente.Bookmark = Me.C1Vertragselemente.RowContaining(e.Y)
        Update_Details()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.Dispose Method

frmVertragsuebersicht.Dispose Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
C#
[System.Diagnostics.DebuggerNonUserCode()]
protected override System.Void Dispose(
   bool disposing
);
C++
[System.Diagnostics.DebuggerNonUserCode()]

protected:
System::Void Dispose(
   bool disposing
)
JScript
protected
   System.Diagnostics.DebuggerNonUserCode()
function Dispose(
    disposing : boolean
);

Parameters

disposing

Expand image Source code

Visual Basic CopyCode image Copy Code
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.FindNode Method

frmVertragsuebersicht.FindNode Method

Suchen eines Knoten Treeview
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function FindNode( _
   ByVal _nodeCollection As TreeNodeCollection, _
   ByVal SearchVal As Integer, _
   ByVal SearchString As String _
) As TreeNode
C#
public TreeNode FindNode(
   TreeNodeCollection _nodeCollection,
   int SearchVal,
   string SearchString
);
C++

public:
TreeNode^ FindNode(
   TreeNodeCollection^ _nodeCollection,
   int SearchVal,
   String^ SearchString
)
JScript
public function FindNode(
    _nodeCollection : TreeNodeCollection,
    SearchVal : int,
    SearchString : String
) : TreeNode;

Parameters

_nodeCollection

Nodes des TreeView

SearchVal

Tag.Keyvalue

SearchString

Node.Text als Suchbegriff

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Function FindNode(ByVal _nodeCollection As TreeNodeCollection, ByVal SearchVal As Integer, ByVal SearchString As String) As TreeNode
        Dim tmpNode As TreeNode
        For Each _child As TreeNode In _nodeCollection
            Dim xtag As TKB.VV.Vertrag.Treenode_Descriptor = _child.Tag
            If xtag.Keyvalue = SearchVal And SearchString = _child.Text Then Return _child
            tmpNode = FindNode(_child.Nodes, SearchVal, SearchString)
            If Not tmpNode Is Nothing Then
                Return tmpNode
            End If
        Next
        Return Nothing
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.InitializeComponent Method

frmVertragsuebersicht.InitializeComponent Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()
C#
[System.Diagnostics.DebuggerStepThrough()]
private System.Void InitializeComponent();
C++
[System.Diagnostics.DebuggerStepThrough()]

private:
System::Void InitializeComponent()
JScript
private
   System.Diagnostics.DebuggerStepThrough()
function InitializeComponent();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmVertragsuebersicht))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStipMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.TSBtnCopy = New System.Windows.Forms.ToolStripButton
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSuche = New System.Windows.Forms.ToolStripButton
        Me.SplitContainer1 = New System.Windows.Forms.SplitContainer
        Me.TreeStruktur = New System.Windows.Forms.TreeView
        Me.TreeStrukturContextMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.TreeStrukturAktualisierenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TreeStrukturTreeAktualisierenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStripMenuItem1 = New System.Windows.Forms.ToolStripSeparator
        Me.TreeStrukturVertragspartnerAnzeigenToolStipMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.NeuerVertragspartnerToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ImageListTreeImages = New System.Windows.Forms.ImageList(Me.components)
        Me.pnlSort = New System.Windows.Forms.Panel
        Me.cbInaktiv = New System.Windows.Forms.CheckBox
        Me.rbSortVertragstyp = New System.Windows.Forms.RadioButton
        Me.rbSortVertragspartner = New System.Windows.Forms.RadioButton
        Me.C1Vertragselemente = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.DetailContextMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.VertragselementAnzeigenBearbeitenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.NeuesVertragselementErstellenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStripMenuItem2 = New System.Windows.Forms.ToolStripSeparator
        Me.SpaltendarstellungSichernToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TabControlDiverse = New System.Windows.Forms.TabControl
        Me.TabElementDetails = New System.Windows.Forms.TabPage
        Me.cboxSecurityLevel = New System.Windows.Forms.ComboBox
        Me.lblSecurityLebel = New System.Windows.Forms.Label
        Me.lblAktiv = New System.Windows.Forms.Label
        Me.txtMutierer = New System.Windows.Forms.TextBox
        Me.txtMutiertam = New System.Windows.Forms.TextBox
        Me.txtErstelltam = New System.Windows.Forms.TextBox
        Me.lblMutierer = New System.Windows.Forms.Label
        Me.lblMutiertam = New System.Windows.Forms.Label
        Me.lblErstelltam = New System.Windows.Forms.Label
        Me.cbaktiv = New System.Windows.Forms.CheckBox
        Me.txtUnterzeichnetam = New System.Windows.Forms.MaskedTextBox
        Me.txtMindestvertragsdauerbis = New System.Windows.Forms.MaskedTextBox
        Me.rbUnbefristet = New System.Windows.Forms.RadioButton
        Me.rbbefristet = New System.Windows.Forms.RadioButton
        Me.lblUnterzeichnetam = New System.Windows.Forms.Label
        Me.lblMindesvertragsdauer = New System.Windows.Forms.Label
        Me.txtGekuendigtper = New System.Windows.Forms.MaskedTextBox
        Me.txtGekuendigtam = New System.Windows.Forms.MaskedTextBox
        Me.lblGekuendigtam = New System.Windows.Forms.Label
        Me.txtVertragsende = New System.Windows.Forms.MaskedTextBox
        Me.txtVertragsbegin = New System.Windows.Forms.MaskedTextBox
        Me.lblVertragsbegin = New System.Windows.Forms.Label
        Me.txtVersionsdatum = New System.Windows.Forms.MaskedTextBox
        Me.txtBezeichnung = New System.Windows.Forms.TextBox
        Me.txtVertragsnummer = New System.Windows.Forms.TextBox
        Me.lblVertragsnummer = New System.Windows.Forms.Label
        Me.txtVersion = New System.Windows.Forms.TextBox
        Me.lblVersion = New System.Windows.Forms.Label
        Me.lblBezeichnung = New System.Windows.Forms.Label
        Me.TabBeschreibung = New System.Windows.Forms.TabPage
        Me.SplitContainer2 = New System.Windows.Forms.SplitContainer
        Me.txtBeschreibung = New System.Windows.Forms.RichTextBox
        Me.pnlBeschreibung = New System.Windows.Forms.Panel
        Me.lblBeschreibung = New System.Windows.Forms.Label
        Me.txtSuchbegriffe = New System.Windows.Forms.RichTextBox
        Me.pnlSuchbegriffe = New System.Windows.Forms.Panel
        Me.lblSuchbegriffe = New System.Windows.Forms.Label
        Me.TabKuendigungsfristen = New System.Windows.Forms.TabPage
        Me.C1Kuendigungsfristen = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.TabKontakte = New System.Windows.Forms.TabPage
        Me.C1Kontakte = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.SplitContainer1.Panel1.SuspendLayout()
        Me.SplitContainer1.Panel2.SuspendLayout()
        Me.SplitContainer1.SuspendLayout()
        Me.TreeStrukturContextMenuStrip.SuspendLayout()
        Me.pnlSort.SuspendLayout()
        CType(Me.C1Vertragselemente, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.DetailContextMenuStrip.SuspendLayout()
        Me.TabControlDiverse.SuspendLayout()
        Me.TabElementDetails.SuspendLayout()
        Me.TabBeschreibung.SuspendLayout()
        Me.SplitContainer2.Panel1.SuspendLayout()
        Me.SplitContainer2.Panel2.SuspendLayout()
        Me.SplitContainer2.SuspendLayout()
        Me.pnlBeschreibung.SuspendLayout()
        Me.pnlSuchbegriffe.SuspendLayout()
        Me.TabKuendigungsfristen.SuspendLayout()
        CType(Me.C1Kuendigungsfristen, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabKontakte.SuspendLayout()
        CType(Me.C1Kontakte, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(1074, 24)
        Me.MenuStrip1.TabIndex = 5
        Me.MenuStrip1.Tag = ""
        Me.MenuStrip1.Text = "Hauptmenu"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStipMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Tag = ""
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStipMenuItem
        '
        Me.BeendenToolStipMenuItem.Name = "BeendenToolStipMenuItem"
        Me.BeendenToolStipMenuItem.Size = New System.Drawing.Size(116, 22)
        Me.BeendenToolStipMenuItem.Tag = ""
        Me.BeendenToolStipMenuItem.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnCopy, Me.TSBtnNew, Me.TSBtnDelete, Me.TSBtnSuche})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(1074, 25)
        Me.ToolStrip1.TabIndex = 6
        Me.ToolStrip1.Text = "Toolstrip Vertragspartner"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "Daten speichern"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        Me.TSBtnSave.Visible = False
        '
        'TSBtnCopy
        '
        Me.TSBtnCopy.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnCopy.Image = CType(resources.GetObject("TSBtnCopy.Image"), System.Drawing.Image)
        Me.TSBtnCopy.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnCopy.Name = "TSBtnCopy"
        Me.TSBtnCopy.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnCopy.Text = "Datensatz kopieren"
        Me.TSBtnCopy.ToolTipText = "Datensatz kopieren"
        Me.TSBtnCopy.Visible = False
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "Neuer Datensatz"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        Me.TSBtnNew.Visible = False
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "Datensatz inaktivieren"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        Me.TSBtnDelete.Visible = False
        '
        'TSBtnSuche
        '
        Me.TSBtnSuche.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSuche.Image = CType(resources.GetObject("TSBtnSuche.Image"), System.Drawing.Image)
        Me.TSBtnSuche.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSuche.Name = "TSBtnSuche"
        Me.TSBtnSuche.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSuche.Text = "ToolStripButton1"
        '
        'SplitContainer1
        '
        Me.SplitContainer1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.SplitContainer1.Location = New System.Drawing.Point(0, 49)
        Me.SplitContainer1.Name = "SplitContainer1"
        '
        'SplitContainer1.Panel1
        '
        Me.SplitContainer1.Panel1.Controls.Add(Me.TreeStruktur)
        Me.SplitContainer1.Panel1.Controls.Add(Me.pnlSort)
        '
        'SplitContainer1.Panel2
        '
        Me.SplitContainer1.Panel2.Controls.Add(Me.C1Vertragselemente)
        Me.SplitContainer1.Panel2.Controls.Add(Me.TabControlDiverse)
        Me.SplitContainer1.Size = New System.Drawing.Size(1074, 489)
        Me.SplitContainer1.SplitterDistance = 341
        Me.SplitContainer1.TabIndex = 7
        '
        'TreeStruktur
        '
        Me.TreeStruktur.ContextMenuStrip = Me.TreeStrukturContextMenuStrip
        Me.TreeStruktur.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TreeStruktur.FullRowSelect = True
        Me.TreeStruktur.HideSelection = False
        Me.TreeStruktur.HotTracking = True
        Me.TreeStruktur.ImageIndex = 0
        Me.TreeStruktur.ImageList = Me.ImageListTreeImages
        Me.TreeStruktur.Location = New System.Drawing.Point(0, 39)
        Me.TreeStruktur.Name = "TreeStruktur"
        Me.TreeStruktur.SelectedImageIndex = 0
        Me.TreeStruktur.Size = New System.Drawing.Size(341, 450)
        Me.TreeStruktur.TabIndex = 2
        '
        'TreeStrukturContextMenuStrip
        '
        Me.TreeStrukturContextMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TreeStrukturAktualisierenToolStripMenuItem, Me.TreeStrukturTreeAktualisierenToolStripMenuItem, Me.ToolStripMenuItem1, Me.TreeStrukturVertragspartnerAnzeigenToolStipMenuItem, Me.NeuerVertragspartnerToolStripMenuItem})
        Me.TreeStrukturContextMenuStrip.Name = "TreeStrukturContextMenuStrip"
        Me.TreeStrukturContextMenuStrip.Size = New System.Drawing.Size(260, 98)
        '
        'TreeStrukturAktualisierenToolStripMenuItem
        '
        Me.TreeStrukturAktualisierenToolStripMenuItem.Name = "TreeStrukturAktualisierenToolStripMenuItem"
        Me.TreeStrukturAktualisierenToolStripMenuItem.ShortcutKeys = System.Windows.Forms.Keys.F5
        Me.TreeStrukturAktualisierenToolStripMenuItem.Size = New System.Drawing.Size(259, 22)
        Me.TreeStrukturAktualisierenToolStripMenuItem.Text = "&Aktueller Kntoen Aktualisieren"
        '
        'TreeStrukturTreeAktualisierenToolStripMenuItem
        '
        Me.TreeStrukturTreeAktualisierenToolStripMenuItem.Name = "TreeStrukturTreeAktualisierenToolStripMenuItem"
        Me.TreeStrukturTreeAktualisierenToolStripMenuItem.ShortcutKeys = CType((System.Windows.Forms.Keys.Control Or System.Windows.Forms.Keys.F5), System.Windows.Forms.Keys)
        Me.TreeStrukturTreeAktualisierenToolStripMenuItem.Size = New System.Drawing.Size(259, 22)
        Me.TreeStrukturTreeAktualisierenToolStripMenuItem.Text = "Alles Aktualisieren"
        '
        'ToolStripMenuItem1
        '
        Me.ToolStripMenuItem1.Name = "ToolStripMenuItem1"
        Me.ToolStripMenuItem1.Size = New System.Drawing.Size(256, 6)
        '
        'TreeStrukturVertragspartnerAnzeigenToolStipMenuItem
        '
        Me.TreeStrukturVertragspartnerAnzeigenToolStipMenuItem.Name = "TreeStrukturVertragspartnerAnzeigenToolStipMenuItem"
        Me.TreeStrukturVertragspartnerAnzeigenToolStipMenuItem.Size = New System.Drawing.Size(259, 22)
        Me.TreeStrukturVertragspartnerAnzeigenToolStipMenuItem.Text = "Vertragspartner anzeigen / bearbeiten"
        '
        'NeuerVertragspartnerToolStripMenuItem
        '
        Me.NeuerVertragspartnerToolStripMenuItem.Name = "NeuerVertragspartnerToolStripMenuItem"
        Me.NeuerVertragspartnerToolStripMenuItem.Size = New System.Drawing.Size(259, 22)
        Me.NeuerVertragspartnerToolStripMenuItem.Text = "&Neuer Vertragspartner"
        '
        'ImageListTreeImages
        '
        Me.ImageListTreeImages.ImageStream = CType(resources.GetObject("ImageListTreeImages.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageListTreeImages.TransparentColor = System.Drawing.Color.Transparent
        Me.ImageListTreeImages.Images.SetKeyName(0, "Personen.ico")
        Me.ImageListTreeImages.Images.SetKeyName(1, "book02.gif")
        Me.ImageListTreeImages.Images.SetKeyName(2, "DOC.BMP")
        Me.ImageListTreeImages.Images.SetKeyName(3, "Folder.ico")
        '
        'pnlSort
        '
        Me.pnlSort.Controls.Add(Me.cbInaktiv)
        Me.pnlSort.Controls.Add(Me.rbSortVertragstyp)
        Me.pnlSort.Controls.Add(Me.rbSortVertragspartner)
        Me.pnlSort.Dock = System.Windows.Forms.DockStyle.Top
        Me.pnlSort.Location = New System.Drawing.Point(0, 0)
        Me.pnlSort.Name = "pnlSort"
        Me.pnlSort.Size = New System.Drawing.Size(341, 39)
        Me.pnlSort.TabIndex = 1
        '
        'cbInaktiv
        '
        Me.cbInaktiv.AutoSize = True
        Me.cbInaktiv.Checked = True
        Me.cbInaktiv.CheckState = System.Windows.Forms.CheckState.Checked
        Me.cbInaktiv.Location = New System.Drawing.Point(254, 19)
        Me.cbInaktiv.Name = "cbInaktiv"
        Me.cbInaktiv.Size = New System.Drawing.Size(74, 17)
        Me.cbInaktiv.TabIndex = 4
        Me.cbInaktiv.Text = "nur Akrive"
        Me.cbInaktiv.UseVisualStyleBackColor = True
        '
        'rbSortVertragstyp
        '
        Me.rbSortVertragstyp.AutoSize = True
        Me.rbSortVertragstyp.Location = New System.Drawing.Point(3, 17)
        Me.rbSortVertragstyp.Name = "rbSortVertragstyp"
        Me.rbSortVertragstyp.Size = New System.Drawing.Size(156, 17)
        Me.rbSortVertragstyp.TabIndex = 3
        Me.rbSortVertragstyp.Text = "Sortierung nach Vertragstyp"
        Me.rbSortVertragstyp.UseVisualStyleBackColor = True
        '
        'rbSortVertragspartner
        '
        Me.rbSortVertragspartner.AutoSize = True
        Me.rbSortVertragspartner.Checked = True
        Me.rbSortVertragspartner.Location = New System.Drawing.Point(3, 3)
        Me.rbSortVertragspartner.Name = "rbSortVertragspartner"
        Me.rbSortVertragspartner.Size = New System.Drawing.Size(175, 17)
        Me.rbSortVertragspartner.TabIndex = 2
        Me.rbSortVertragspartner.TabStop = True
        Me.rbSortVertragspartner.Text = "Sortierung nach Vertragspartner"
        Me.rbSortVertragspartner.UseVisualStyleBackColor = True
        '
        'C1Vertragselemente
        '
        Me.C1Vertragselemente.AlternatingRows = True
        Me.C1Vertragselemente.ContextMenuStrip = Me.DetailContextMenuStrip
        Me.C1Vertragselemente.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Vertragselemente.FetchRowStyles = True
        Me.C1Vertragselemente.FilterBar = True
        Me.C1Vertragselemente.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Vertragselemente.Images.Add(CType(resources.GetObject("C1Vertragselemente.Images"), System.Drawing.Image))
        Me.C1Vertragselemente.Location = New System.Drawing.Point(0, 0)
        Me.C1Vertragselemente.Name = "C1Vertragselemente"
        Me.C1Vertragselemente.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Vertragselemente.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Vertragselemente.PreviewInfo.ZoomFactor = 75
        Me.C1Vertragselemente.PrintInfo.PageSettings = CType(resources.GetObject("C1Vertragselemente.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Vertragselemente.Size = New System.Drawing.Size(729, 269)
        Me.C1Vertragselemente.TabIndex = 5
        Me.C1Vertragselemente.Text = "C1TrueDBGrid1"
        Me.C1Vertragselemente.PropBag = resources.GetString("C1Vertragselemente.PropBag")
        '
        'DetailContextMenuStrip
        '
        Me.DetailContextMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.VertragselementAnzeigenBearbeitenToolStripMenuItem, Me.NeuesVertragselementErstellenToolStripMenuItem, Me.ToolStripMenuItem2, Me.SpaltendarstellungSichernToolStripMenuItem})
        Me.DetailContextMenuStrip.Name = "DetailContextMenuStrip"
        Me.DetailContextMenuStrip.Size = New System.Drawing.Size(262, 76)
        '
        'VertragselementAnzeigenBearbeitenToolStripMenuItem
        '
        Me.VertragselementAnzeigenBearbeitenToolStripMenuItem.Name = "VertragselementAnzeigenBearbeitenToolStripMenuItem"
        Me.VertragselementAnzeigenBearbeitenToolStripMenuItem.Size = New System.Drawing.Size(261, 22)
        Me.VertragselementAnzeigenBearbeitenToolStripMenuItem.Text = "Vertragselement anzeigen / bearbeiten"
        '
        'NeuesVertragselementErstellenToolStripMenuItem
        '
        Me.NeuesVertragselementErstellenToolStripMenuItem.Name = "NeuesVertragselementErstellenToolStripMenuItem"
        Me.NeuesVertragselementErstellenToolStripMenuItem.Size = New System.Drawing.Size(261, 22)
        Me.NeuesVertragselementErstellenToolStripMenuItem.Text = "Neues Vertragselement erstellen"
        '
        'ToolStripMenuItem2
        '
        Me.ToolStripMenuItem2.Name = "ToolStripMenuItem2"
        Me.ToolStripMenuItem2.Size = New System.Drawing.Size(258, 6)
        '
        'SpaltendarstellungSichernToolStripMenuItem
        '
        Me.SpaltendarstellungSichernToolStripMenuItem.Name = "SpaltendarstellungSichernToolStripMenuItem"
        Me.SpaltendarstellungSichernToolStripMenuItem.Size = New System.Drawing.Size(261, 22)
        Me.SpaltendarstellungSichernToolStripMenuItem.Text = "Spaltendarstellung sichern"
        '
        'TabControlDiverse
        '
        Me.TabControlDiverse.Controls.Add(Me.TabElementDetails)
        Me.TabControlDiverse.Controls.Add(Me.TabBeschreibung)
        Me.TabControlDiverse.Controls.Add(Me.TabKuendigungsfristen)
        Me.TabControlDiverse.Controls.Add(Me.TabKontakte)
        Me.TabControlDiverse.Dock = System.Windows.Forms.DockStyle.Bottom
        Me.TabControlDiverse.Location = New System.Drawing.Point(0, 269)
        Me.TabControlDiverse.Name = "TabControlDiverse"
        Me.TabControlDiverse.SelectedIndex = 0
        Me.TabControlDiverse.Size = New System.Drawing.Size(729, 220)
        Me.TabControlDiverse.TabIndex = 0
        '
        'TabElementDetails
        '
        Me.TabElementDetails.Controls.Add(Me.cboxSecurityLevel)
        Me.TabElementDetails.Controls.Add(Me.lblSecurityLebel)
        Me.TabElementDetails.Controls.Add(Me.lblAktiv)
        Me.TabElementDetails.Controls.Add(Me.txtMutierer)
        Me.TabElementDetails.Controls.Add(Me.txtMutiertam)
        Me.TabElementDetails.Controls.Add(Me.txtErstelltam)
        Me.TabElementDetails.Controls.Add(Me.lblMutierer)
        Me.TabElementDetails.Controls.Add(Me.lblMutiertam)
        Me.TabElementDetails.Controls.Add(Me.lblErstelltam)
        Me.TabElementDetails.Controls.Add(Me.cbaktiv)
        Me.TabElementDetails.Controls.Add(Me.txtUnterzeichnetam)
        Me.TabElementDetails.Controls.Add(Me.txtMindestvertragsdauerbis)
        Me.TabElementDetails.Controls.Add(Me.rbUnbefristet)
        Me.TabElementDetails.Controls.Add(Me.rbbefristet)
        Me.TabElementDetails.Controls.Add(Me.lblUnterzeichnetam)
        Me.TabElementDetails.Controls.Add(Me.lblMindesvertragsdauer)
        Me.TabElementDetails.Controls.Add(Me.txtGekuendigtper)
        Me.TabElementDetails.Controls.Add(Me.txtGekuendigtam)
        Me.TabElementDetails.Controls.Add(Me.lblGekuendigtam)
        Me.TabElementDetails.Controls.Add(Me.txtVertragsende)
        Me.TabElementDetails.Controls.Add(Me.txtVertragsbegin)
        Me.TabElementDetails.Controls.Add(Me.lblVertragsbegin)
        Me.TabElementDetails.Controls.Add(Me.txtVersionsdatum)
        Me.TabElementDetails.Controls.Add(Me.txtBezeichnung)
        Me.TabElementDetails.Controls.Add(Me.txtVertragsnummer)
        Me.TabElementDetails.Controls.Add(Me.lblVertragsnummer)
        Me.TabElementDetails.Controls.Add(Me.txtVersion)
        Me.TabElementDetails.Controls.Add(Me.lblVersion)
        Me.TabElementDetails.Controls.Add(Me.lblBezeichnung)
        Me.TabElementDetails.Location = New System.Drawing.Point(4, 22)
        Me.TabElementDetails.Name = "TabElementDetails"
        Me.TabElementDetails.Padding = New System.Windows.Forms.Padding(3)
        Me.TabElementDetails.Size = New System.Drawing.Size(721, 194)
        Me.TabElementDetails.TabIndex = 0
        Me.TabElementDetails.Text = "Details"
        Me.TabElementDetails.UseVisualStyleBackColor = True
        '
        'cboxSecurityLevel
        '
        Me.cboxSecurityLevel.FormattingEnabled = True
        Me.cboxSecurityLevel.Location = New System.Drawing.Point(499, 113)
        Me.cboxSecurityLevel.Name = "cboxSecurityLevel"
        Me.cboxSecurityLevel.Size = New System.Drawing.Size(101, 21)
        Me.cboxSecurityLevel.TabIndex = 106
        '
        'lblSecurityLebel
        '
        Me.lblSecurityLebel.AutoSize = True
        Me.lblSecurityLebel.Location = New System.Drawing.Point(422, 116)
        Me.lblSecurityLebel.Name = "lblSecurityLebel"
        Me.lblSecurityLebel.Size = New System.Drawing.Size(71, 13)
        Me.lblSecurityLebel.TabIndex = 114
        Me.lblSecurityLebel.Text = "SecurityLevel"
        '
        'lblAktiv
        '
        Me.lblAktiv.AccessibleDescription = "Name"
        Me.lblAktiv.AutoSize = True
        Me.lblAktiv.Location = New System.Drawing.Point(422, 87)
        Me.lblAktiv.Name = "lblAktiv"
        Me.lblAktiv.Size = New System.Drawing.Size(31, 13)
        Me.lblAktiv.TabIndex = 113
        Me.lblAktiv.Text = "Aktiv"
        '
        'txtMutierer
        '
        Me.txtMutierer.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutierer.Location = New System.Drawing.Point(500, 56)
        Me.txtMutierer.Name = "txtMutierer"
        Me.txtMutierer.Size = New System.Drawing.Size(194, 20)
        Me.txtMutierer.TabIndex = 112
        '
        'txtMutiertam
        '
        Me.txtMutiertam.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutiertam.Location = New System.Drawing.Point(499, 33)
        Me.txtMutiertam.Name = "txtMutiertam"
        Me.txtMutiertam.Size = New System.Drawing.Size(195, 20)
        Me.txtMutiertam.TabIndex = 111
        '
        'txtErstelltam
        '
        Me.txtErstelltam.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtErstelltam.Location = New System.Drawing.Point(499, 9)
        Me.txtErstelltam.Name = "txtErstelltam"
        Me.txtErstelltam.Size = New System.Drawing.Size(195, 20)
        Me.txtErstelltam.TabIndex = 110
        '
        'lblMutierer
        '
        Me.lblMutierer.AccessibleDescription = "Name"
        Me.lblMutierer.AutoSize = True
        Me.lblMutierer.Location = New System.Drawing.Point(421, 60)
        Me.lblMutierer.Name = "lblMutierer"
        Me.lblMutierer.Size = New System.Drawing.Size(69, 13)
        Me.lblMutierer.TabIndex = 109
        Me.lblMutierer.Text = "Mutiert durch"
        '
        'lblMutiertam
        '
        Me.lblMutiertam.AccessibleDescription = "Name"
        Me.lblMutiertam.AutoSize = True
        Me.lblMutiertam.Location = New System.Drawing.Point(421, 37)
        Me.lblMutiertam.Name = "lblMutiertam"
        Me.lblMutiertam.Size = New System.Drawing.Size(56, 13)
        Me.lblMutiertam.TabIndex = 108
        Me.lblMutiertam.Text = "Mutiert am"
        '
        'lblErstelltam
        '
        Me.lblErstelltam.AccessibleDescription = "Name"
        Me.lblErstelltam.AutoSize = True
        Me.lblErstelltam.Location = New System.Drawing.Point(422, 12)
        Me.lblErstelltam.Name = "lblErstelltam"
        Me.lblErstelltam.Size = New System.Drawing.Size(55, 13)
        Me.lblErstelltam.TabIndex = 107
        Me.lblErstelltam.Text = "Erstellt am"
        '
        'cbaktiv
        '
        Me.cbaktiv.AutoSize = True
        Me.cbaktiv.Location = New System.Drawing.Point(499, 87)
        Me.cbaktiv.Name = "cbaktiv"
        Me.cbaktiv.Size = New System.Drawing.Size(15, 14)
        Me.cbaktiv.TabIndex = 105
        Me.cbaktiv.UseVisualStyleBackColor = True
        '
        'txtUnterzeichnetam
        '
        Me.txtUnterzeichnetam.Location = New System.Drawing.Point(139, 167)
        Me.txtUnterzeichnetam.Mask = "00/00/0000"
        Me.txtUnterzeichnetam.Name = "txtUnterzeichnetam"
        Me.txtUnterzeichnetam.Size = New System.Drawing.Size(66, 20)
        Me.txtUnterzeichnetam.TabIndex = 100
        Me.txtUnterzeichnetam.ValidatingType = GetType(Date)
        '
        'txtMindestvertragsdauerbis
        '
        Me.txtMindestvertragsdauerbis.Location = New System.Drawing.Point(139, 145)
        Me.txtMindestvertragsdauerbis.Mask = "00/00/0000"
        Me.txtMindestvertragsdauerbis.Name = "txtMindestvertragsdauerbis"
        Me.txtMindestvertragsdauerbis.Size = New System.Drawing.Size(66, 20)
        Me.txtMindestvertragsdauerbis.TabIndex = 99
        Me.txtMindestvertragsdauerbis.ValidatingType = GetType(Date)
        '
        'rbUnbefristet
        '
        Me.rbUnbefristet.AutoSize = True
        Me.rbUnbefristet.Location = New System.Drawing.Point(214, 172)
        Me.rbUnbefristet.Name = "rbUnbefristet"
        Me.rbUnbefristet.Size = New System.Drawing.Size(76, 17)
        Me.rbUnbefristet.TabIndex = 102
        Me.rbUnbefristet.TabStop = True
        Me.rbUnbefristet.Text = "Unbefristet"
        Me.rbUnbefristet.UseVisualStyleBackColor = True
        '
        'rbbefristet
        '
        Me.rbbefristet.AutoSize = True
        Me.rbbefristet.Location = New System.Drawing.Point(214, 146)
        Me.rbbefristet.Name = "rbbefristet"
        Me.rbbefristet.Size = New System.Drawing.Size(63, 17)
        Me.rbbefristet.TabIndex = 101
        Me.rbbefristet.TabStop = True
        Me.rbbefristet.Text = "Befristet"
        Me.rbbefristet.UseVisualStyleBackColor = True
        '
        'lblUnterzeichnetam
        '
        Me.lblUnterzeichnetam.AutoSize = True
        Me.lblUnterzeichnetam.Location = New System.Drawing.Point(8, 170)
        Me.lblUnterzeichnetam.Name = "lblUnterzeichnetam"
        Me.lblUnterzeichnetam.Size = New System.Drawing.Size(90, 13)
        Me.lblUnterzeichnetam.TabIndex = 104
        Me.lblUnterzeichnetam.Text = "Unterzeichnet am"
        '
        'lblMindesvertragsdauer
        '
        Me.lblMindesvertragsdauer.AutoSize = True
        Me.lblMindesvertragsdauer.Location = New System.Drawing.Point(8, 148)
        Me.lblMindesvertragsdauer.Name = "lblMindesvertragsdauer"
        Me.lblMindesvertragsdauer.Size = New System.Drawing.Size(125, 13)
        Me.lblMindesvertragsdauer.TabIndex = 103
        Me.lblMindesvertragsdauer.Text = "Mindestvertragsdauer bis"
        '
        'txtGekuendigtper
        '
        Me.txtGekuendigtper.Location = New System.Drawing.Point(211, 119)
        Me.txtGekuendigtper.Mask = "00/00/0000"
        Me.txtGekuendigtper.Name = "txtGekuendigtper"
        Me.txtGekuendigtper.Size = New System.Drawing.Size(66, 20)
        Me.txtGekuendigtper.TabIndex = 97
        Me.txtGekuendigtper.ValidatingType = GetType(Date)
        '
        'txtGekuendigtam
        '
        Me.txtGekuendigtam.Location = New System.Drawing.Point(139, 119)
        Me.txtGekuendigtam.Mask = "00/00/0000"
        Me.txtGekuendigtam.Name = "txtGekuendigtam"
        Me.txtGekuendigtam.Size = New System.Drawing.Size(66, 20)
        Me.txtGekuendigtam.TabIndex = 96
        Me.txtGekuendigtam.ValidatingType = GetType(Date)
        '
        'lblGekuendigtam
        '
        Me.lblGekuendigtam.AutoSize = True
        Me.lblGekuendigtam.Location = New System.Drawing.Point(8, 119)
        Me.lblGekuendigtam.Name = "lblGekuendigtam"
        Me.lblGekuendigtam.Size = New System.Drawing.Size(99, 13)
        Me.lblGekuendigtam.TabIndex = 98
        Me.lblGekuendigtam.Text = "Gekündigt am / per"
        '
        'txtVertragsende
        '
        Me.txtVertragsende.Location = New System.Drawing.Point(211, 93)
        Me.txtVertragsende.Mask = "00/00/0000"
        Me.txtVertragsende.Name = "txtVertragsende"
        Me.txtVertragsende.Size = New System.Drawing.Size(66, 20)
        Me.txtVertragsende.TabIndex = 94
        Me.txtVertragsende.ValidatingType = GetType(Date)
        '
        'txtVertragsbegin
        '
        Me.txtVertragsbegin.Location = New System.Drawing.Point(139, 93)
        Me.txtVertragsbegin.Mask = "00/00/0000"
        Me.txtVertragsbegin.Name = "txtVertragsbegin"
        Me.txtVertragsbegin.Size = New System.Drawing.Size(66, 20)
        Me.txtVertragsbegin.TabIndex = 93
        Me.txtVertragsbegin.ValidatingType = GetType(Date)
        '
        'lblVertragsbegin
        '
        Me.lblVertragsbegin.AutoSize = True
        Me.lblVertragsbegin.Location = New System.Drawing.Point(8, 96)
        Me.lblVertragsbegin.Name = "lblVertragsbegin"
        Me.lblVertragsbegin.Size = New System.Drawing.Size(104, 13)
        Me.lblVertragsbegin.TabIndex = 95
        Me.lblVertragsbegin.Text = "Vertragsbegin/-ende"
        '
        'txtVersionsdatum
        '
        Me.txtVersionsdatum.Location = New System.Drawing.Point(211, 65)
        Me.txtVersionsdatum.Mask = "00/00/0000"
        Me.txtVersionsdatum.Name = "txtVersionsdatum"
        Me.txtVersionsdatum.Size = New System.Drawing.Size(66, 20)
        Me.txtVersionsdatum.TabIndex = 87
        Me.txtVersionsdatum.ValidatingType = GetType(Date)
        '
        'txtBezeichnung
        '
        Me.txtBezeichnung.Location = New System.Drawing.Point(139, 12)
        Me.txtBezeichnung.Name = "txtBezeichnung"
        Me.txtBezeichnung.Size = New System.Drawing.Size(268, 20)
        Me.txtBezeichnung.TabIndex = 84
        '
        'txtVertragsnummer
        '
        Me.txtVertragsnummer.Location = New System.Drawing.Point(139, 39)
        Me.txtVertragsnummer.Name = "txtVertragsnummer"
        Me.txtVertragsnummer.Size = New System.Drawing.Size(268, 20)
        Me.txtVertragsnummer.TabIndex = 85
        '
        'lblVertragsnummer
        '
        Me.lblVertragsnummer.AutoSize = True
        Me.lblVertragsnummer.Location = New System.Drawing.Point(8, 39)
        Me.lblVertragsnummer.Name = "lblVertragsnummer"
        Me.lblVertragsnummer.Size = New System.Drawing.Size(83, 13)
        Me.lblVertragsnummer.TabIndex = 92
        Me.lblVertragsnummer.Text = "Vertragsnummer"
        '
        'txtVersion
        '
        Me.txtVersion.Location = New System.Drawing.Point(139, 65)
        Me.txtVersion.Name = "txtVersion"
        Me.txtVersion.Size = New System.Drawing.Size(66, 20)
        Me.txtVersion.TabIndex = 86
        '
        'lblVersion
        '
        Me.lblVersion.AutoSize = True
        Me.lblVersion.Location = New System.Drawing.Point(8, 65)
        Me.lblVersion.Name = "lblVersion"
        Me.lblVersion.Size = New System.Drawing.Size(116, 13)
        Me.lblVersion.TabIndex = 91
        Me.lblVersion.Text = "Version/Versionsdatum"
        '
        'lblBezeichnung
        '
        Me.lblBezeichnung.AutoSize = True
        Me.lblBezeichnung.Location = New System.Drawing.Point(8, 12)
        Me.lblBezeichnung.Name = "lblBezeichnung"
        Me.lblBezeichnung.Size = New System.Drawing.Size(69, 13)
        Me.lblBezeichnung.TabIndex = 90
        Me.lblBezeichnung.Text = "Bezeichnung"
        '
        'TabBeschreibung
        '
        Me.TabBeschreibung.Controls.Add(Me.SplitContainer2)
        Me.TabBeschreibung.Location = New System.Drawing.Point(4, 22)
        Me.TabBeschreibung.Name = "TabBeschreibung"
        Me.TabBeschreibung.Padding = New System.Windows.Forms.Padding(3)
        Me.TabBeschreibung.Size = New System.Drawing.Size(721, 194)
        Me.TabBeschreibung.TabIndex = 1
        Me.TabBeschreibung.Text = "Beschreibung"
        Me.TabBeschreibung.UseVisualStyleBackColor = True
        '
        'SplitContainer2
        '
        Me.SplitContainer2.Dock = System.Windows.Forms.DockStyle.Fill
        Me.SplitContainer2.Location = New System.Drawing.Point(3, 3)
        Me.SplitContainer2.Name = "SplitContainer2"
        '
        'SplitContainer2.Panel1
        '
        Me.SplitContainer2.Panel1.Controls.Add(Me.txtBeschreibung)
        Me.SplitContainer2.Panel1.Controls.Add(Me.pnlBeschreibung)
        '
        'SplitContainer2.Panel2
        '
        Me.SplitContainer2.Panel2.Controls.Add(Me.txtSuchbegriffe)
        Me.SplitContainer2.Panel2.Controls.Add(Me.pnlSuchbegriffe)
        Me.SplitContainer2.Size = New System.Drawing.Size(715, 188)
        Me.SplitContainer2.SplitterDistance = 347
        Me.SplitContainer2.TabIndex = 0
        '
        'txtBeschreibung
        '
        Me.txtBeschreibung.Dock = System.Windows.Forms.DockStyle.Fill
        Me.txtBeschreibung.Location = New System.Drawing.Point(0, 22)
        Me.txtBeschreibung.Name = "txtBeschreibung"
        Me.txtBeschreibung.ReadOnly = True
        Me.txtBeschreibung.Size = New System.Drawing.Size(347, 166)
        Me.txtBeschreibung.TabIndex = 30
        Me.txtBeschreibung.Text = ""
        '
        'pnlBeschreibung
        '
        Me.pnlBeschreibung.Controls.Add(Me.lblBeschreibung)
        Me.pnlBeschreibung.Dock = System.Windows.Forms.DockStyle.Top
        Me.pnlBeschreibung.Location = New System.Drawing.Point(0, 0)
        Me.pnlBeschreibung.Name = "pnlBeschreibung"
        Me.pnlBeschreibung.Size = New System.Drawing.Size(347, 22)
        Me.pnlBeschreibung.TabIndex = 0
        '
        'lblBeschreibung
        '
        Me.lblBeschreibung.AutoSize = True
        Me.lblBeschreibung.Location = New System.Drawing.Point(5, 4)
        Me.lblBeschreibung.Name = "lblBeschreibung"
        Me.lblBeschreibung.Size = New System.Drawing.Size(72, 13)
        Me.lblBeschreibung.TabIndex = 0
        Me.lblBeschreibung.Text = "Beschreibung"
        '
        'txtSuchbegriffe
        '
        Me.txtSuchbegriffe.Dock = System.Windows.Forms.DockStyle.Fill
        Me.txtSuchbegriffe.Location = New System.Drawing.Point(0, 22)
        Me.txtSuchbegriffe.Name = "txtSuchbegriffe"
        Me.txtSuchbegriffe.ReadOnly = True
        Me.txtSuchbegriffe.Size = New System.Drawing.Size(364, 166)
        Me.txtSuchbegriffe.TabIndex = 31
        Me.txtSuchbegriffe.Text = ""
        '
        'pnlSuchbegriffe
        '
        Me.pnlSuchbegriffe.Controls.Add(Me.lblSuchbegriffe)
        Me.pnlSuchbegriffe.Dock = System.Windows.Forms.DockStyle.Top
        Me.pnlSuchbegriffe.Location = New System.Drawing.Point(0, 0)
        Me.pnlSuchbegriffe.Name = "pnlSuchbegriffe"
        Me.pnlSuchbegriffe.Size = New System.Drawing.Size(364, 22)
        Me.pnlSuchbegriffe.TabIndex = 1
        '
        'lblSuchbegriffe
        '
        Me.lblSuchbegriffe.AutoSize = True
        Me.lblSuchbegriffe.Location = New System.Drawing.Point(4, 5)
        Me.lblSuchbegriffe.Name = "lblSuchbegriffe"
        Me.lblSuchbegriffe.Size = New System.Drawing.Size(67, 13)
        Me.lblSuchbegriffe.TabIndex = 1
        Me.lblSuchbegriffe.Text = "Suchbegriffe"
        '
        'TabKuendigungsfristen
        '
        Me.TabKuendigungsfristen.Controls.Add(Me.C1Kuendigungsfristen)
        Me.TabKuendigungsfristen.Location = New System.Drawing.Point(4, 22)
        Me.TabKuendigungsfristen.Name = "TabKuendigungsfristen"
        Me.TabKuendigungsfristen.Size = New System.Drawing.Size(721, 194)
        Me.TabKuendigungsfristen.TabIndex = 2
        Me.TabKuendigungsfristen.Text = "Kündigungsfristen"
        Me.TabKuendigungsfristen.UseVisualStyleBackColor = True
        '
        'C1Kuendigungsfristen
        '
        Me.C1Kuendigungsfristen.AlternatingRows = True
        Me.C1Kuendigungsfristen.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Kuendigungsfristen.FilterBar = True
        Me.C1Kuendigungsfristen.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Kuendigungsfristen.Images.Add(CType(resources.GetObject("C1Kuendigungsfristen.Images"), System.Drawing.Image))
        Me.C1Kuendigungsfristen.Location = New System.Drawing.Point(0, 0)
        Me.C1Kuendigungsfristen.Name = "C1Kuendigungsfristen"
        Me.C1Kuendigungsfristen.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Kuendigungsfristen.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Kuendigungsfristen.PreviewInfo.ZoomFactor = 75
        Me.C1Kuendigungsfristen.PrintInfo.PageSettings = CType(resources.GetObject("C1Kuendigungsfristen.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Kuendigungsfristen.Size = New System.Drawing.Size(721, 194)
        Me.C1Kuendigungsfristen.TabIndex = 4
        Me.C1Kuendigungsfristen.Text = "C1Kuendigungsfristen"
        Me.C1Kuendigungsfristen.PropBag = resources.GetString("C1Kuendigungsfristen.PropBag")
        '
        'TabKontakte
        '
        Me.TabKontakte.Controls.Add(Me.C1Kontakte)
        Me.TabKontakte.Location = New System.Drawing.Point(4, 22)
        Me.TabKontakte.Name = "TabKontakte"
        Me.TabKontakte.Size = New System.Drawing.Size(721, 194)
        Me.TabKontakte.TabIndex = 3
        Me.TabKontakte.Text = "Kontakte"
        Me.TabKontakte.UseVisualStyleBackColor = True
        '
        'C1Kontakte
        '
        Me.C1Kontakte.AlternatingRows = True
        Me.C1Kontakte.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Kontakte.FilterBar = True
        Me.C1Kontakte.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Kontakte.Images.Add(CType(resources.GetObject("C1Kontakte.Images"), System.Drawing.Image))
        Me.C1Kontakte.Location = New System.Drawing.Point(0, 0)
        Me.C1Kontakte.Name = "C1Kontakte"
        Me.C1Kontakte.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Kontakte.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Kontakte.PreviewInfo.ZoomFactor = 75
        Me.C1Kontakte.PrintInfo.PageSettings = CType(resources.GetObject("C1Kontakte.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Kontakte.Size = New System.Drawing.Size(721, 194)
        Me.C1Kontakte.TabIndex = 5
        Me.C1Kontakte.Text = "C1TrueDBGrid1"
        Me.C1Kontakte.PropBag = resources.GetString("C1Kontakte.PropBag")
        '
        'frmVertragsuebersicht
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(1074, 538)
        Me.Controls.Add(Me.SplitContainer1)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmVertragsuebersicht"
        Me.Text = "Vertragsübersicht"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.SplitContainer1.Panel1.ResumeLayout(False)
        Me.SplitContainer1.Panel2.ResumeLayout(False)
        Me.SplitContainer1.ResumeLayout(False)
        Me.TreeStrukturContextMenuStrip.ResumeLayout(False)
        Me.pnlSort.ResumeLayout(False)
        Me.pnlSort.PerformLayout()
        CType(Me.C1Vertragselemente, System.ComponentModel.ISupportInitialize).EndInit()
        Me.DetailContextMenuStrip.ResumeLayout(False)
        Me.TabControlDiverse.ResumeLayout(False)
        Me.TabElementDetails.ResumeLayout(False)
        Me.TabElementDetails.PerformLayout()
        Me.TabBeschreibung.ResumeLayout(False)
        Me.SplitContainer2.Panel1.ResumeLayout(False)
        Me.SplitContainer2.Panel2.ResumeLayout(False)
        Me.SplitContainer2.ResumeLayout(False)
        Me.pnlBeschreibung.ResumeLayout(False)
        Me.pnlBeschreibung.PerformLayout()
        Me.pnlSuchbegriffe.ResumeLayout(False)
        Me.pnlSuchbegriffe.PerformLayout()
        Me.TabKuendigungsfristen.ResumeLayout(False)
        CType(Me.C1Kuendigungsfristen, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabKontakte.ResumeLayout(False)
        CType(Me.C1Kontakte, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.Load_Struktur Method

frmVertragsuebersicht.Load_Struktur Method

Laden der Treestruktur
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Load_Struktur()
C#
private System.Void Load_Struktur();
C++

private:
System::Void Load_Struktur()
JScript
private function Load_Struktur();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Load_Struktur()
        If Me.rbSortVertragspartner.Checked = True Then
            Strukturen.Get_Struktur(Me.TreeStruktur, 0, Me.cbInaktiv.Checked)
        End If
        If Me.rbSortVertragstyp.Checked = True Then
            Strukturen.Get_Struktur(Me.TreeStruktur, 1, Me.cbInaktiv.Checked)
        End If
        Me.TreeStruktur.SelectedNode = Me.TreeStruktur.Nodes(0)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.NeuerVertragspartnerToolStripMenuItem_Click Method

frmVertragsuebersicht.NeuerVertragspartnerToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

Neuer Vertragspartner eröffnen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub NeuerVertragspartnerToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   NeuerVertragspartnerToolStripMenuItem.Click
C#
private System.Void NeuerVertragspartnerToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void NeuerVertragspartnerToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function NeuerVertragspartnerToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub NeuerVertragspartnerToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles NeuerVertragspartnerToolStripMenuItem.Click
        Dim f As New frmVertragspartner(0, Me.FormReadonly, True)
        f.ShowDialog()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.NeuesVertragselementErstellenToolStripMenuItem_Click Method

frmVertragsuebersicht.NeuesVertragselementErstellenToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

Neues Vertragselement laden
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub NeuesVertragselementErstellenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   NeuesVertragselementErstellenToolStripMenuItem.Click
C#
private System.Void NeuesVertragselementErstellenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void NeuesVertragselementErstellenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function NeuesVertragselementErstellenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub NeuesVertragselementErstellenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles NeuesVertragselementErstellenToolStripMenuItem.Click
        Dim f As New frmVertragselement(-1, False, True, Me.C1Vertragselemente.Columns("Vertragspartnernr").Value)
        f.MdiParent = Me.MdiParent
        f.Show()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.RB_CheckedChanged Method

frmVertragsuebersicht.RB_CheckedChanged Method

Handling RB_Changed für den Aufbau der Struktur
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub RB_CheckedChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   rbSortVertragspartner.CheckedChanged, _
   rbSortVertragstyp.CheckedChanged
C#
private System.Void RB_CheckedChanged(
   object sender,
   EventArgs e
);
C++

private:
System::Void RB_CheckedChanged(
   object^ sender,
   EventArgs^ e
)
JScript
private function RB_CheckedChanged(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub RB_CheckedChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles rbSortVertragspartner.CheckedChanged, rbSortVertragstyp.CheckedChanged
        Me.Load_Struktur()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.Refresh_All Method

frmVertragsuebersicht.Refresh_All Method

Treeview Struktur aktualisieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Refresh_All()
C#
private System.Void Refresh_All();
C++

private:
System::Void Refresh_All()
JScript
private function Refresh_All();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Refresh_All()
        Me.TreeStruktur.Enabled = False

        Dim SaveTn As TreeNode = Me.TreeStruktur.SelectedNode
        Dim tmptn As TreeNode = Me.RootTreeNode(Me.TreeStruktur.SelectedNode)
        Me.TreeStruktur.Nodes.Clear()
        Me.Load_Struktur()

        Dim keyvalue As TKB.VV.Vertrag.Treenode_Descriptor = tmptn.Tag
        Me.TreeStruktur.SelectedNode = FindNode(Me.TreeStruktur.Nodes, keyvalue.Keyvalue, tmptn.Text)
        Me.Update_Node(tmptn)
        Me.TreeStruktur.SelectedNode.ExpandAll()

        keyvalue = SaveTn.Tag
        Me.TreeStruktur.SelectedNode = FindNode(Me.TreeStruktur.Nodes, keyvalue.Keyvalue, SaveTn.Text)

        Refresh_Details()
        Me.TreeStruktur.Enabled = True
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.Refresh_Details Method

frmVertragsuebersicht.Refresh_Details Method

Details aktualisieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Refresh_Details()
C#
private System.Void Refresh_Details();
C++

private:
System::Void Refresh_Details()
JScript
private function Refresh_Details();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Refresh_Details()

        Try
            If Me.rbSortVertragstyp.Checked And Me.TreeStruktur.SelectedNode.Level = 0 Then
                c1data = Me.Strukturen.Update_Vertragsuebersicht(Me.TreeStruktur.SelectedNode.Tag, True)
            Else
                c1data = Me.Strukturen.Update_Vertragsuebersicht(Me.TreeStruktur.SelectedNode.Tag)
            End If
            Dim i As Integer
            Dim o As Integer
            For i = 0 To c1data.Rows.Count - 1
                For o = 0 To c1data.Columns.Count - 1
                    If c1data.Rows(i).Item(o).GetType.Name = "DateTime" Then
                        If c1data.Rows(i).Item(o) = #1/1/1900# Then
                            c1data.Rows(i).Item(o) = System.DBNull.Value
                        End If
                    End If
                Next
            Next
            Me.C1Vertragselemente.Enabled = False
            Me.C1Vertragselemente.DataSource = c1data
            Me.C1Vertragselemente.DataMember = c1data.TableName
            Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Vertragselemente, "Vertragsuebersicht", Me.c1data, False)
            Update_Details()
            Docs.Get_Layout(Me.C1Vertragselemente, 1)
            Me.C1Vertragselemente.FetchRowStyles = True

            Me.C1Vertragselemente.Enabled = True

        Catch ex As Exception
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.Refresh_Kontakte Method

frmVertragsuebersicht.Refresh_Kontakte Method

Kontakte aktualisieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Refresh_Kontakte()
C#
private System.Void Refresh_Kontakte();
C++

private:
System::Void Refresh_Kontakte()
JScript
private function Refresh_Kontakte();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Refresh_Kontakte()
        Me.Vertragselement = New TKB.VV.Vertrag.clsVertragselement
        Me.C1Kontakte.Enabled = False
        Me.Vertragselement.Get_Vertragskontakte(Me.C1Kontakte, Me.C1Vertragselemente.Columns("Vertragselementnr").Value)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Kontakte, "Vertragskontakt", Me.Vertragselement.Vertragskontakte.Tabledata)
        sec.Set_Form_Security(Me)
        Me.C1Kontakte.Enabled = True
        Me.Vertragselement.dispose()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.Refresh_Kuendigungsfrist Method

frmVertragsuebersicht.Refresh_Kuendigungsfrist Method

Kündigungsfristen aktualisieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Refresh_Kuendigungsfrist()
C#
private System.Void Refresh_Kuendigungsfrist();
C++

private:
System::Void Refresh_Kuendigungsfrist()
JScript
private function Refresh_Kuendigungsfrist();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Refresh_Kuendigungsfrist()
        Me.Vertragselement = New TKB.VV.Vertrag.clsVertragselement
        Me.C1Kuendigungsfristen.Enabled = False
        Me.Vertragselement.Get_Kuendigungsfristen(Me.C1Kuendigungsfristen, Me.C1Vertragselemente.Columns("Vertragselementnr").Value)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Kuendigungsfristen, "Kuendigungsfrist", Me.Vertragselement.Kuendigungsfristen.Tabledata)
        Me.C1Kuendigungsfristen.Enabled = True
        Me.Vertragselement.dispose()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.RootTreeNode Method

frmVertragsuebersicht.RootTreeNode Method

Toplevel-Treenode suchen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function RootTreeNode( _
   ByVal tn As TreeNode _
) As TreeNode
C#
private TreeNode RootTreeNode(
   TreeNode tn
);
C++

private:
TreeNode^ RootTreeNode(
   TreeNode^ tn
)
JScript
private function RootTreeNode(
    tn : TreeNode
) : TreeNode;

Parameters

tn

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Function RootTreeNode(ByVal tn As TreeNode) As TreeNode
        While Not tn.Parent Is Nothing
            tn = tn.Parent
            RootTreeNode(tn)
        End While
        Return tn
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.SpaltendarstellungSichernToolStripMenuItem_Click Method

frmVertragsuebersicht.SpaltendarstellungSichernToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

Spaltenlayout C1Vertragselemente speichern
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub SpaltendarstellungSichernToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   SpaltendarstellungSichernToolStripMenuItem.Click
C#
private System.Void SpaltendarstellungSichernToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void SpaltendarstellungSichernToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function SpaltendarstellungSichernToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub SpaltendarstellungSichernToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles SpaltendarstellungSichernToolStripMenuItem.Click
        Docs.Save_LayoutFile(Me.C1Vertragselemente, 1)

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.TSBtnCopy_Click Method

frmVertragsuebersicht.TSBtnCopy_Click Method

Datensatz kopieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnCopy_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnCopy.Click
C#
private System.Void TSBtnCopy_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnCopy_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnCopy_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnCopy_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnCopy.Click
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.TSBtnDelete_Click Method

frmVertragsuebersicht.TSBtnDelete_Click Method

Aktueller Datensatz inaktivieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click
C#
private System.Void TSBtnDelete_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnDelete_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnDelete_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.TSBtnNew_Click Method

frmVertragsuebersicht.TSBtnNew_Click Method

Neuer Datensatz erstellen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnNew_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnNew.Click
C#
private System.Void TSBtnNew_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnNew_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnNew_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnNew.Click
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.TSBtnQuit_Click Method

frmVertragsuebersicht.TSBtnQuit_Click Method

Formular schliessen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click
C#
private System.Void TSBtnQuit_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnQuit_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnQuit_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.TSBtnSuche_Click Method

frmVertragsuebersicht.TSBtnSuche_Click Method

Vertragspartner suchen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TSBtnSuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSuche.Click
C#
private System.Void TSBtnSuche_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TSBtnSuche_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TSBtnSuche_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TSBtnSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSuche.Click
        Dim i As Integer

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.TabControlDiverse_SelectedIndexChanged Method

frmVertragsuebersicht.TabControlDiverse_SelectedIndexChanged Method
See Also
collapseAll image DropDown image

Index-Wechsel auf TabControlDiverse. Abhängig der gewählten Registerlasche, werden deren Daten aktualisiert.
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TabControlDiverse_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TabControlDiverse.SelectedIndexChanged
C#
private System.Void TabControlDiverse_SelectedIndexChanged(
   object sender,
   EventArgs e
);
C++

private:
System::Void TabControlDiverse_SelectedIndexChanged(
   object^ sender,
   EventArgs^ e
)
JScript
private function TabControlDiverse_SelectedIndexChanged(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TabControlDiverse_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles TabControlDiverse.SelectedIndexChanged
        Update_Details()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.TreeStrukturAktualisierenToolStripMenuItem_Click Method

frmVertragsuebersicht.TreeStrukturAktualisierenToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

Aktualisierung des aktuellen Knotens
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TreeStrukturAktualisierenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TreeStrukturAktualisierenToolStripMenuItem.Click
C#
private System.Void TreeStrukturAktualisierenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TreeStrukturAktualisierenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TreeStrukturAktualisierenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TreeStrukturAktualisierenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TreeStrukturAktualisierenToolStripMenuItem.Click

        Dim SaveTn As TreeNode = Me.TreeStruktur.SelectedNode

        Me.TreeStruktur.Enabled = False
        Dim tmptn As TreeNode = Me.RootTreeNode(Me.TreeStruktur.SelectedNode)
        tmptn.Nodes.Clear()
        tmptn.Nodes.Add("")
        Me.Update_Node(tmptn)
        tmptn.ExpandAll()
        Dim kvalue As TKB.VV.Vertrag.Treenode_Descriptor = SaveTn.Tag

        Me.TreeStruktur.SelectedNode = FindNode(Me.TreeStruktur.Nodes, kvalue.Keyvalue, SaveTn.Text)
        TreeStruktur_Click(sender, e)
        Me.TreeStruktur.Enabled = True
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.TreeStrukturContextMenuStrip_Opening Method

frmVertragsuebersicht.TreeStrukturContextMenuStrip_Opening Method
See Also
collapseAll image DropDown image

TreeStrukturContetmenu anzeigen und allfällige MenuItems disablen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TreeStrukturContextMenuStrip_Opening( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
) Handles  _
   TreeStrukturContextMenuStrip.Opening
C#
private System.Void TreeStrukturContextMenuStrip_Opening(
   object sender,
   CancelEventArgs e
);
C++

private:
System::Void TreeStrukturContextMenuStrip_Opening(
   object^ sender,
   CancelEventArgs^ e
)
JScript
private function TreeStrukturContextMenuStrip_Opening(
    sender : object,
    e : CancelEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TreeStrukturContextMenuStrip_Opening(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles TreeStrukturContextMenuStrip.Opening
        Me.TreeStrukturVertragspartnerAnzeigenToolStipMenuItem.Enabled = False
        Tag_Descriptor = Me.TreeStruktur.SelectedNode.Tag
        Select Case Tag_Descriptor.Type
            Case "Vertragspartner"
                Me.TreeStrukturVertragspartnerAnzeigenToolStipMenuItem.Enabled = True
        End Select
        Try

        Catch ex As Exception

        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.TreeStrukturTreeAktualisierenToolStripMenuItem_Click Method

frmVertragsuebersicht.TreeStrukturTreeAktualisierenToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

Vollständiger Treeview aktualisieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TreeStrukturTreeAktualisierenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TreeStrukturTreeAktualisierenToolStripMenuItem.Click
C#
private System.Void TreeStrukturTreeAktualisierenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TreeStrukturTreeAktualisierenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TreeStrukturTreeAktualisierenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TreeStrukturTreeAktualisierenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TreeStrukturTreeAktualisierenToolStripMenuItem.Click
        Refresh_All()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.TreeStrukturVertragspartnerAnzeigenToolStipMenuItem_Click Method

frmVertragsuebersicht.TreeStrukturVertragspartnerAnzeigenToolStipMenuItem_Click Method
See Also
collapseAll image DropDown image

Vertragspartner anzeigen / bearbeiten
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TreeStrukturVertragspartnerAnzeigenToolStipMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TreeStrukturVertragspartnerAnzeigenToolStipMenuItem.Click
C#
private System.Void TreeStrukturVertragspartnerAnzeigenToolStipMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TreeStrukturVertragspartnerAnzeigenToolStipMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TreeStrukturVertragspartnerAnzeigenToolStipMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TreeStrukturVertragspartnerAnzeigenToolStipMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TreeStrukturVertragspartnerAnzeigenToolStipMenuItem.Click
        Dim tmptag As TKB.VV.Vertrag.Treenode_Descriptor = Me.TreeStruktur.SelectedNode.Tag
        If tmptag.Type = "Vertragspartner" Then
            Dim f As New frmVertragspartner(tmptag.Vertragspartnernr, Me.FormReadonly)
            f.MdiParent = Me.MdiParent
            f.Show()
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.TreeStruktur_Click Method

frmVertragsuebersicht.TreeStruktur_Click Method

Treeview-Click
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TreeStruktur_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TreeStruktur.Click
C#
private System.Void TreeStruktur_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void TreeStruktur_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function TreeStruktur_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Remarks

Ist die Sortierung nach Vertragstyp und der Click auf dem Root-Entry, wird das Datenauslesen speziell behandelt, sodass sämtliche Vertragspartner berücksichtigt werden

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TreeStruktur_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles TreeStruktur.Click
        Refresh_Details()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.TreeStruktur_MouseDown Method

frmVertragsuebersicht.TreeStruktur_MouseDown Method

Mousedown-Ereignis auf dem Tree
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub TreeStruktur_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   TreeStruktur.MouseDown
C#
private System.Void TreeStruktur_MouseDown(
   object sender,
   MouseEventArgs e
);
C++

private:
System::Void TreeStruktur_MouseDown(
   object^ sender,
   MouseEventArgs^ e
)
JScript
private function TreeStruktur_MouseDown(
    sender : object,
    e : MouseEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub TreeStruktur_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles TreeStruktur.MouseDown
        Try
            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            Me.TreeStruktur.SelectedNode = Me.TreeStruktur.GetNodeAt(selectPoint)
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.Update_DetailInformationen Method

frmVertragsuebersicht.Update_DetailInformationen Method

Detail-Informationen der ersten 2 TabPages aktualisieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Update_DetailInformationen()
C#
private System.Void Update_DetailInformationen();
C++

private:
System::Void Update_DetailInformationen()
JScript
private function Update_DetailInformationen();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Update_DetailInformationen()
        Try
            Me.txtBeschreibung.Text = Me.C1Vertragselemente.Columns("Beschreibung").Value
            Me.txtBezeichnung.Text = Me.C1Vertragselemente.Columns("Bezeichnung").Value
            Me.txtSuchbegriffe.Text = Me.C1Vertragselemente.Columns("Suchbegriffe").Value
            Me.txtVersion.Text = Me.C1Vertragselemente.Columns("Version").Value
            Me.txtVertragsnummer.Text = Me.C1Vertragselemente.Columns("Nummer").Value
            If Not Me.C1Vertragselemente.Columns("Versionsdatum").Value Is System.DBNull.Value Then
                Me.txtVersionsdatum.Text = Me.C1Vertragselemente.Columns("Versionsdatum").Value
            Else
                Me.txtVersionsdatum.Text = ""
            End If
            If Not Me.C1Vertragselemente.Columns("Vertragsbeginn").Value Is System.DBNull.Value Then
                Me.txtVertragsbegin.Text = Me.C1Vertragselemente.Columns("Vertragsbeginn").Value
            Else
                Me.txtVertragsbegin.Text = ""
            End If
            If Not Me.C1Vertragselemente.Columns("Vertragsablauf").Value Is System.DBNull.Value Then
                Me.txtVertragsende.Text = Me.C1Vertragselemente.Columns("Vertragsablauf").Value
            Else
                Me.txtVertragsende.Text = ""
            End If
            If Not Me.C1Vertragselemente.Columns("Mindestvertragsdauer_bis").Value Is System.DBNull.Value Then
                Me.txtMindestvertragsdauerbis.Text = Me.C1Vertragselemente.Columns("Mindestvertragsdauer_bis").Value
            Else
                Me.txtMindestvertragsdauerbis.Text = ""
            End If
            If Not Me.C1Vertragselemente.Columns("Unterzeichnet_am").Value Is System.DBNull.Value Then
                Me.txtUnterzeichnetam.Text = Me.C1Vertragselemente.Columns("Unterzeichnet_am").Value
            Else
                Me.txtUnterzeichnetam.Text = ""
            End If
            If Not Me.C1Vertragselemente.Columns("Gekuendigt_am").Value Is System.DBNull.Value Then
                Me.txtGekuendigtam.Text = Me.C1Vertragselemente.Columns("Gekuendigt_am").Value
            Else
                Me.txtGekuendigtam.Text = ""
            End If
            If Not Me.C1Vertragselemente.Columns("Gekuendigt_per").Value Is System.DBNull.Value Then
                Me.txtGekuendigtper.Text = Me.C1Vertragselemente.Columns("Gekuendigt_per").Value
            Else
                Me.txtGekuendigtper.Text = ""
            End If
            Try
                Me.rbbefristet.Checked = Me.C1Vertragselemente.Columns("befristet_unbefristet").Value
                If Me.rbbefristet.Checked = False Then Me.rbUnbefristet.Checked = True
            Catch
                Me.rbbefristet.Checked = False
                Me.rbUnbefristet.Checked = True
            End Try
            Me.txtErstelltam.Text = Me.C1Vertragselemente.Columns("Erstellt_am").Value
            Me.txtMutiertam.Text = Me.C1Vertragselemente.Columns("Mutiert_am").Value
            Me.txtMutierer.Text = Me.C1Vertragselemente.Columns("Mutierername").Value
            Try
                Me.cbaktiv.Checked = Me.C1Vertragselemente.Columns("aktiv").Value = True
            Catch ex As Exception
                Me.cbaktiv.Checked = True
            End Try
        Catch ex As Exception
        End Try

    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.Update_Details Method

frmVertragsuebersicht.Update_Details Method

Detailelemente und die allfällig ausgewählte TabPage aktualisieren
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Update_Details()
C#
private System.Void Update_Details();
C++

private:
System::Void Update_Details()
JScript
private function Update_Details();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Update_Details()
        If Me.C1Vertragselemente.Splits(0).Rows.Count < 1 Then
            Me.TabControlDiverse.Enabled = False
            Exit Sub
        End If
        Me.TabControlDiverse.Enabled = True
        Update_DetailInformationen()
        Select Case Me.TabControlDiverse.SelectedTab.Text
            Case "Vertragsinhalt", "Suchbegriffe"
            Case "Kündigungsfristen"
                Refresh_Kuendigungsfrist()
            Case "Kontakte"
                Refresh_Kontakte()
            Case "Services"
            Case "Ereignisse"
            Case "Aktivitäten"
            Case "Pendenzen"
            Case "Ablageorte"
            Case "Referenzverträge"
            Case "Historie"
        End Select
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.Update_Node Method

frmVertragsuebersicht.Update_Node Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Update_Node( _
   ByRef tn As TreeNode _
)
C#
private System.Void Update_Node(
   ref TreeNode tn
);
C++

private:
System::Void Update_Node(
   TreeNode^& tn
)
JScript
private function Update_Node(
    tn : TreeNode
);

Parameters

tn

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub Update_Node(ByRef tn As TreeNode)
        Dim x As TKB.VV.Vertrag.Treenode_Descriptor = tn.Tag
        Select Case x.Type
            Case "Vertragspartner"
                tn.Nodes.Clear()
                Me.Strukturen.Load_SubStruktur(tn)
                tn.ExpandAll()
            Case "Vertragstyp"
                tn.Nodes.Clear()
                Me.Strukturen.Load_SubStruktur(tn)
                tn.ExpandAll()
        End Select
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.VertragselementAnzeigenBearbeitenToolStripMenuItem_Click Method

frmVertragsuebersicht.VertragselementAnzeigenBearbeitenToolStripMenuItem_Click Method
See Also
collapseAll image DropDown image

Vertragselement anzeigen / bearbeiten
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub VertragselementAnzeigenBearbeitenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   VertragselementAnzeigenBearbeitenToolStripMenuItem.Click
C#
private System.Void VertragselementAnzeigenBearbeitenToolStripMenuItem_Click(
   object sender,
   EventArgs e
);
C++

private:
System::Void VertragselementAnzeigenBearbeitenToolStripMenuItem_Click(
   object^ sender,
   EventArgs^ e
)
JScript
private function VertragselementAnzeigenBearbeitenToolStripMenuItem_Click(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub VertragselementAnzeigenBearbeitenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles VertragselementAnzeigenBearbeitenToolStripMenuItem.Click
        Me.C1Vertragselemente_DoubleClick(sender, e)
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.cbocInaktiv_CheckedChanged Method

frmVertragsuebersicht.cbocInaktiv_CheckedChanged Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub cbocInaktiv_CheckedChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   cbInaktiv.CheckedChanged
C#
private System.Void cbocInaktiv_CheckedChanged(
   object sender,
   EventArgs e
);
C++

private:
System::Void cbocInaktiv_CheckedChanged(
   object^ sender,
   EventArgs^ e
)
JScript
private function cbocInaktiv_CheckedChanged(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub cbocInaktiv_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbInaktiv.CheckedChanged
        Try
            Me.Load_Struktur()
        Catch ex As Exception
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.evh_FormularVertragelement_Closed Method

frmVertragsuebersicht.evh_FormularVertragelement_Closed Method
See Also
collapseAll image DropDown image

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub evh_FormularVertragelement_Closed( _
   ByVal Vertragspartnernr As Integer, _
   ByVal Vertragselementnr As Integer _
) Handles  _
   evh.FormularVertragelement_Closed
C#
private System.Void evh_FormularVertragelement_Closed(
   int Vertragspartnernr,
   int Vertragselementnr
);
C++

private:
System::Void evh_FormularVertragelement_Closed(
   int Vertragspartnernr,
   int Vertragselementnr
)
JScript
private function evh_FormularVertragelement_Closed(
    Vertragspartnernr : int,
    Vertragselementnr : int
);

Parameters

Vertragspartnernr

Vertragselementnr

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub evh_FormularVertragelement_Closed(ByVal Vertragspartnernr As Integer, ByVal Vertragselementnr As Integer) Handles evh.FormularVertragelement_Closed
        Try
            Refresh_All()
        Catch ex As Exception
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.evh_FormularVertragspartner_Closed Method

frmVertragsuebersicht.evh_FormularVertragspartner_Closed Method
See Also
collapseAll image DropDown image

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub evh_FormularVertragspartner_Closed( _
   ByVal Vertragspartnernr As Integer _
) Handles  _
   evh.FormularVertragspartner_Closed
C#
private System.Void evh_FormularVertragspartner_Closed(
   int Vertragspartnernr
);
C++

private:
System::Void evh_FormularVertragspartner_Closed(
   int Vertragspartnernr
)
JScript
private function evh_FormularVertragspartner_Closed(
    Vertragspartnernr : int
);

Parameters

Vertragspartnernr

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub evh_FormularVertragspartner_Closed(ByVal Vertragspartnernr As Integer) Handles evh.FormularVertragspartner_Closed
        Try
            Refresh_All()
        Catch ex As Exception
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.frmVertragsuebersicht_Load Method

frmVertragsuebersicht.frmVertragsuebersicht_Load Method

Formular-Load
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub frmVertragsuebersicht_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load
C#
private System.Void frmVertragsuebersicht_Load(
   object sender,
   EventArgs e
);
C++

private:
System::Void frmVertragsuebersicht_Load(
   object^ sender,
   EventArgs^ e
)
JScript
private function frmVertragsuebersicht_Load(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub frmVertragsuebersicht_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        If Me.TSBtnSave.Enabled = False Then
            Me.FormReadonly = True
            Me.TSBtnCopy.Enabled = False
            Me.TSBtnNew.Enabled = False
            Me.TSBtnDelete.Enabled = False
        Else
            Me.FormReadonly = False
        End If
        Load_Struktur()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht.treeStruktur_BeforeExpand Method

frmVertragsuebersicht.treeStruktur_BeforeExpand Method

Aktueller Tag des gewählten Nodes auslesen und Aktualisierung aufrufen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub treeStruktur_BeforeExpand( _
   ByVal sender As Object, _
   ByVal e As TreeViewCancelEventArgs _
) Handles  _
   TreeStruktur.BeforeExpand
C#
private System.Void treeStruktur_BeforeExpand(
   object sender,
   TreeViewCancelEventArgs e
);
C++

private:
System::Void treeStruktur_BeforeExpand(
   object^ sender,
   TreeViewCancelEventArgs^ e
)
JScript
private function treeStruktur_BeforeExpand(
    sender : object,
    e : TreeViewCancelEventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Sub treeStruktur_BeforeExpand(ByVal sender As Object, ByVal e As System.Windows.Forms.TreeViewCancelEventArgs) Handles TreeStruktur.BeforeExpand
        If Me.TreeStruktur.SelectedNode.GetNodeCount(True) = 1 And Me.TreeStruktur.SelectedNode.Level = 0 Then
            Update_Node(Me.TreeStruktur.SelectedNode)
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


frmVertragsuebersicht Fields

frmVertragsuebersicht Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | Docs | Dokument-Management-Klasse
Supported by the .NET Compact Framework. | FormDataChanged |
Supported by the .NET Compact Framework. | FormReadonly |
Supported by the .NET Compact Framework. | SpaltenTitel |
Supported by the .NET Compact Framework. | Strukturen | Klasse für die Bewirtschaftung der Tree-Strukturen
Supported by the .NET Compact Framework. | Tag_Descriptor | Klasse für die Beschreibung der Tree-Tags
Supported by the .NET Compact Framework. | Vertragselement | Vertragselement
Supported by the .NET Compact Framework. | c1data |
Supported by the .NET Compact Framework. | components |
Supported by the .NET Compact Framework. | msg | Message-Klasse
Supported by the .NET Compact Framework. | sec | Security-Klasse
Internal (Friend) field Supported by the .NET Compact Framework. | selectPoint |
Top

Expand image See Also

Reference

frmVertragsuebersicht Class


Docs Variable

Docs Variable

Dokument-Management-Klasse
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Docs As MyDocMgmt
C#
private MyDocMgmt Docs;
C++
private:
MyDocMgmt^ Docs;
JScript
private Docs : MyDocMgmt

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Docs As New TKB.VV.Utils.MyDocMgmt

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


FormDataChanged Variable

FormDataChanged Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private FormDataChanged As Boolean
C#
private bool FormDataChanged;
C++
private:
bool FormDataChanged;
JScript
private FormDataChanged : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim FormDataChanged As Boolean = False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


FormReadonly Variable

FormReadonly Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private FormReadonly As Boolean
C#
private bool FormReadonly;
C++
private:
bool FormReadonly;
JScript
private FormReadonly : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim FormReadonly As Boolean = False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


SpaltenTitel Variable

SpaltenTitel Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private SpaltenTitel As Tabellenspalte
C#
private Tabellenspalte SpaltenTitel;
C++
private:
Tabellenspalte^ SpaltenTitel;
JScript
private SpaltenTitel : Tabellenspalte

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


Strukturen Variable

Strukturen Variable

Klasse für die Bewirtschaftung der Tree-Strukturen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Strukturen As clsVertragsuebersicht_Strukturen
C#
private clsVertragsuebersicht_Strukturen Strukturen;
C++
private:
clsVertragsuebersicht_Strukturen^ Strukturen;
JScript
private Strukturen : clsVertragsuebersicht_Strukturen

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Strukturen As New TKB.VV.Vertrag.clsVertragsuebersicht_Strukturen

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


Tag_Descriptor Variable

Tag_Descriptor Variable

Klasse für die Beschreibung der Tree-Tags
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Tag_Descriptor As Treenode_Descriptor
C#
private Treenode_Descriptor Tag_Descriptor;
C++
private:
Treenode_Descriptor^ Tag_Descriptor;
JScript
private Tag_Descriptor : Treenode_Descriptor

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Tag_Descriptor As TKB.VV.Vertrag.Treenode_Descriptor

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


Vertragselement Variable

Vertragselement Variable

Vertragselement
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Vertragselement As clsVertragselement
C#
private clsVertragselement Vertragselement;
C++
private:
clsVertragselement^ Vertragselement;
JScript
private Vertragselement : clsVertragselement

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim Vertragselement As TKB.VV.Vertrag.clsVertragselement

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


c1data Variable

c1data Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private c1data As DataTable
C#
private DataTable c1data;
C++
private:
DataTable^ c1data;
JScript
private c1data : DataTable

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim c1data As New DataTable

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


components Variable

components Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private components As IContainer
C#
private IContainer components;
C++
private:
IContainer^ components;
JScript
private components : IContainer

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private components As System.ComponentModel.IContainer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


msg Variable

msg Variable

Message-Klasse
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private msg As MyMessage
C#
private MyMessage msg;
C++
private:
MyMessage^ msg;
JScript
private msg : MyMessage

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim msg As New TKB.VV.Utils.MyMessage

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


sec Variable

sec Variable

Security-Klasse
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private sec As MySecurity
C#
private MySecurity sec;
C++
private:
MySecurity^ sec;
JScript
private sec : MySecurity

Expand image Source code

Visual Basic CopyCode image Copy Code
    Dim sec As New TKB.VV.Utils.MySecurity

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


selectPoint Variable

selectPoint Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Friend selectPoint As Point
C#
internal Point selectPoint;
C++
public private:
Point selectPoint;
JScript
internal selectPoint : Point

Expand image Source code

Visual Basic CopyCode image Copy Code
    Friend selectPoint As New System.Drawing.Point()

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragsuebersicht Class
frmVertragsuebersicht Members


Crypto Class

Crypto Class
Members
collapseAll image DropDown image

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Friend Module Crypto
C#
internal sealed class Crypto
C++
private ref class sealed Crypto
JScript
internal final class Crypto

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Crypto Members


Crypto Members

Crypto Members
See Also Methods
CollapseAll image DropDown image

The following tables list the members exposed by the Crypto type.

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | DecryptText |
Supported by the .NET Compact Framework. | EncryptText |
Top

Expand image See Also

Reference

Crypto Class


Crypto Methods

Crypto Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | DecryptText |
Supported by the .NET Compact Framework. | EncryptText |
Top

Expand image See Also

Reference

Crypto Class


Crypto.DecryptText Method

Crypto.DecryptText Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Function DecryptText( _
   ByVal strText As String, _
   ByVal strPwd As String _
) As Object
C#
public static object DecryptText(
   string strText,
   string strPwd
);
C++

public:
object^ DecryptText(
   String^ strText,
   String^ strPwd
) static
JScript
public static function DecryptText(
    strText : String,
    strPwd : String
) : object;

Parameters

strText

strPwd

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Function DecryptText(ByVal strText As String, ByVal strPwd As String)
        Dim i As Integer, c As Integer
        Dim strBuff As String
        strPwd = UCase$(strPwd)
        If Len(strPwd) Then
            For i = 1 To Len(strText)
                c = Asc(Mid$(strText, i, 1))
                c = c - Asc(Mid$(strPwd, (i Mod Len(strPwd)) + 1, 1))
                strBuff = strBuff & Chr(c And &HFF)
            Next i
        Else
            strBuff = strText
        End If
        DecryptText = strBuff
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Crypto Class
Crypto Members


Crypto.EncryptText Method

Crypto.EncryptText Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Function EncryptText( _
   ByVal strText As String, _
   ByVal strPwd As String _
) As Object
C#
public static object EncryptText(
   string strText,
   string strPwd
);
C++

public:
object^ EncryptText(
   String^ strText,
   String^ strPwd
) static
JScript
public static function EncryptText(
    strText : String,
    strPwd : String
) : object;

Parameters

strText

strPwd

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Function EncryptText(ByVal strText As String, ByVal strPwd As String)
        Dim i As Integer, c As Integer
        Dim strBuff As String

        strPwd = UCase$(strPwd)
        If Len(strPwd) Then
            For i = 1 To Len(strText)
                c = Asc(Mid$(strText, i, 1))
                c = c + Asc(Mid$(strPwd, (i Mod Len(strPwd)) + 1, 1))
                strBuff = strBuff & Chr(c And &HFF)
            Next i
        Else
            strBuff = strText
        End If
        EncryptText = strBuff
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Crypto Class
Crypto Members


Globals Class

Globals Class
Members
collapseAll image DropDown image

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Friend Module Globals
C#
internal sealed class Globals
C++
private ref class sealed Globals
JScript
internal final class Globals

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Globals Members


Globals Members

Globals Members
See Also Methods
CollapseAll image DropDown image

The following tables list the members exposed by the Globals type.

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | ApplicationPath | Aktueller Applikationspfad
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | AppldataRow |
Supported by the .NET Compact Framework. | Applikationsdaten | Applikationsdaten
Supported by the .NET Compact Framework. | ConnectionFileName |
Supported by the .NET Compact Framework. | SecurityDaten |
Supported by the .NET Compact Framework. | Spaltendaten |
Supported by the .NET Compact Framework. | Version | Applikationsversion
Supported by the .NET Compact Framework. | Versionsdatum |
Supported by the .NET Compact Framework. | clsapplication | Applikationsparameter
Supported by the .NET Compact Framework. | clsmitarbeiter | Angemelderter Mitarbeiter
Supported by the .NET Compact Framework. | conn |
Supported by the .NET Compact Framework. | dbconn |
Supported by the .NET Compact Framework. | sConnectionString | DB-Verbindungsklasse
Top

Expand image See Also

Reference

Globals Class


Globals Methods

Globals Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | ApplicationPath | Aktueller Applikationspfad
Top

Expand image See Also

Reference

Globals Class


Globals.ApplicationPath Method

Globals.ApplicationPath Method

Aktueller Applikationspfad
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Function ApplicationPath() As String
C#
public static string ApplicationPath();
C++

public:
String^ ApplicationPath() static
JScript
public static function ApplicationPath() : String;

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Function ApplicationPath() As String
        Return Path.GetDirectoryName([Assembly].GetEntryAssembly().Location) + "\"
    End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Globals Class
Globals Members


Globals Fields

Globals Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | AppldataRow |
Supported by the .NET Compact Framework. | Applikationsdaten | Applikationsdaten
Supported by the .NET Compact Framework. | ConnectionFileName |
Supported by the .NET Compact Framework. | SecurityDaten |
Supported by the .NET Compact Framework. | Spaltendaten |
Supported by the .NET Compact Framework. | Version | Applikationsversion
Supported by the .NET Compact Framework. | Versionsdatum |
Supported by the .NET Compact Framework. | clsapplication | Applikationsparameter
Supported by the .NET Compact Framework. | clsmitarbeiter | Angemelderter Mitarbeiter
Supported by the .NET Compact Framework. | conn |
Supported by the .NET Compact Framework. | dbconn |
Supported by the .NET Compact Framework. | sConnectionString | DB-Verbindungsklasse
Top

Expand image See Also

Reference

Globals Class


AppldataRow Variable

AppldataRow Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Shared AppldataRow As Integer
C#
public static int AppldataRow;
C++
public:
static int AppldataRow;
JScript
public static AppldataRow : int

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public AppldataRow As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Globals Class
Globals Members


Applikationsdaten Variable

Applikationsdaten Variable

Applikationsdaten
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Applikationsdaten As DataTable
C#
public static DataTable Applikationsdaten;
C++
public:
static DataTable^ Applikationsdaten;
JScript
public static Applikationsdaten : DataTable

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Applikationsdaten As DataTable

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Globals Class
Globals Members


ConnectionFileName Variable

ConnectionFileName Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Shared ConnectionFileName As String
C#
public static string ConnectionFileName;
C++
public:
static String^ ConnectionFileName;
JScript
public static ConnectionFileName : String

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public ConnectionFileName As String = ""

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Globals Class
Globals Members


SecurityDaten Variable

SecurityDaten Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Shared SecurityDaten As DataSet
C#
public static DataSet SecurityDaten;
C++
public:
static DataSet^ SecurityDaten;
JScript
public static SecurityDaten : DataSet

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public SecurityDaten As New DataSet

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Globals Class
Globals Members


Spaltendaten Variable

Spaltendaten Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Spaltendaten As DataTable
C#
public static DataTable Spaltendaten;
C++
public:
static DataTable^ Spaltendaten;
JScript
public static Spaltendaten : DataTable

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Spaltendaten As New DataTable

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Globals Class
Globals Members


Version Variable

Version Variable

Applikationsversion
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Version As String
C#
public static string Version;
C++
public:
static String^ Version;
JScript
public static Version : String

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Version As String = "1.00"

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Globals Class
Globals Members


Versionsdatum Variable

Versionsdatum Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Versionsdatum As String
C#
public static string Versionsdatum;
C++
public:
static String^ Versionsdatum;
JScript
public static Versionsdatum : String

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Versionsdatum As String = "01. Dezember 2008"

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Globals Class
Globals Members


clsapplication Variable

clsapplication Variable

Applikationsparameter
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Shared clsapplication As clsApplikation
C#
public static clsApplikation clsapplication;
C++
public:
static clsApplikation^ clsapplication;
JScript
public static clsapplication : clsApplikation

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public clsapplication As New TKB.VV.DB.clsApplikation

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Globals Class
Globals Members


clsmitarbeiter Variable

clsmitarbeiter Variable

Angemelderter Mitarbeiter
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Shared clsmitarbeiter As clsMitarbeiter
C#
public static clsMitarbeiter clsmitarbeiter;
C++
public:
static clsMitarbeiter^ clsmitarbeiter;
JScript
public static clsmitarbeiter : clsMitarbeiter

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public clsmitarbeiter As New TKB.VV.DB.clsMitarbeiter

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Globals Class
Globals Members


conn Variable

conn Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Shared conn As clsConnectionProvider
C#
public static clsConnectionProvider conn;
C++
public:
static clsConnectionProvider^ conn;
JScript
public static conn : clsConnectionProvider

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public conn As New TKB.VV.DB.clsConnectionProvider

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Globals Class
Globals Members


dbconn Variable

dbconn Variable

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Shared dbconn As DB_Connection
C#
public static DB_Connection dbconn;
C++
public:
static DB_Connection^ dbconn;
JScript
public static dbconn : DB_Connection

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public dbconn As New TKB.VV.DB.DB_Connection

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Globals Class
Globals Members


sConnectionString Variable

sConnectionString Variable

DB-Verbindungsklasse
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Shared sConnectionString As String
C#
public static string sConnectionString;
C++
public:
static String^ sConnectionString;
JScript
public static sConnectionString : String

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public sConnectionString As String

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Globals Class
Globals Members


Vertragsverwaltung.My Namespace

Vertragsverwaltung.My Namespace

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Classes

 | Name | Description
Internal (Friend) class Supported by the .NET Compact Framework. | MyApplication |
Internal (Friend) class Supported by the .NET Compact Framework. | MySettings |
Internal (Friend) class Supported by the .NET Compact Framework. | MySettingsProperty |
Top

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0


MyApplication Class

MyApplication Class
See Also Members
collapseAll image DropDown image

Namespace: Vertragsverwaltung.My
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Friend Class MyApplication
    Inherits WindowsFormsApplicationBase
C#
internal class MyApplication : WindowsFormsApplicationBase
C++

private ref class MyApplication : public WindowsFormsApplicationBase^
JScript
internal class MyApplication
   extends WindowsFormsApplicationBase

Expand image Inheritance Hierarchy

System.Object
Microsoft.VisualBasic.ApplicationServices.ApplicationBase
Microsoft.VisualBasic.ApplicationServices.ConsoleApplicationBase
Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase
Vertragsverwaltung.My.MyApplication

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyApplication Members
Vertragsverwaltung.My Namespace


MyApplication Members

MyApplication Members
See Also Constructors Methods
CollapseAll image DropDown image

The following tables list the members exposed by the MyApplication type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | MyApplication Constructor |
Top

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | OnCreateMainForm |
Top

Expand image See Also

Reference

MyApplication Class
Vertragsverwaltung.My Namespace


MyApplication Constructor

MyApplication Constructor

Namespace: Vertragsverwaltung.My
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<Global.System.Diagnostics.DebuggerStepThrough()> _
Public Sub New()
C#
[Global.System.Diagnostics.DebuggerStepThrough()]
public System.Void MyApplication();
C++
[Global.System.Diagnostics.DebuggerStepThrough()]

public:
System::Void MyApplication()
JScript
public
   Global.System.Diagnostics.DebuggerStepThrough()
function MyApplication();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            MyBase.New(Global.Microsoft.VisualBasic.ApplicationServices.AuthenticationMode.Windows)
            Me.IsSingleInstance = false
            Me.EnableVisualStyles = true
            Me.SaveMySettingsOnExit = true
            Me.ShutDownStyle = Global.Microsoft.VisualBasic.ApplicationServices.ShutdownMode.AfterMainFormCloses
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyApplication Class
MyApplication Members
Vertragsverwaltung.My Namespace


MyApplication Methods

MyApplication Methods
CollapseAll image DropDown image

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | OnCreateMainForm |
Top

Expand image See Also

Reference

MyApplication Class
Vertragsverwaltung.My Namespace


MyApplication.OnCreateMainForm Method

MyApplication.OnCreateMainForm Method

Namespace: Vertragsverwaltung.My
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<Global.System.Diagnostics.DebuggerStepThrough()> _
Protected Overrides Sub OnCreateMainForm()
C#
[Global.System.Diagnostics.DebuggerStepThrough()]
protected override System.Void OnCreateMainForm();
C++
[Global.System.Diagnostics.DebuggerStepThrough()]

protected:
System::Void OnCreateMainForm()
JScript
protected
   Global.System.Diagnostics.DebuggerStepThrough()
function OnCreateMainForm();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Protected Overrides Sub OnCreateMainForm()
            Me.MainForm = Global.Vertragsverwaltung.frmMain
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyApplication Class
MyApplication Members
Vertragsverwaltung.My Namespace


MySettings Class

MySettings Class
See Also Members
collapseAll image DropDown image

Namespace: Vertragsverwaltung.My
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<Global.System.Runtime.CompilerServices.CompilerGenerated()> _
<Global.System.CodeDom.Compiler.GeneratedCode("Microsoft.VisualStudio.Editors.SettingsDesigner.SettingsSingleFileGenerator", "8.0.0.0")> _
<Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)> _
Friend NotInheritable Class MySettings
    Inherits ApplicationSettingsBase
C#
[Global.System.Runtime.CompilerServices.CompilerGenerated()]
[Global.System.CodeDom.Compiler.GeneratedCode("Microsoft.VisualStudio.Editors.SettingsDesigner.SettingsSingleFileGenerator", "8.0.0.0")]
[Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)]
internal sealed class MySettings : ApplicationSettingsBase
C++
[Global.System.Runtime.CompilerServices.CompilerGenerated()]
[Global.System.CodeDom.Compiler.GeneratedCode("Microsoft.VisualStudio.Editors.SettingsDesigner.SettingsSingleFileGenerator", "8.0.0.0")]
[Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)]

private ref class MySettings sealed : public ApplicationSettingsBase^
JScript
internal
   Global.System.Runtime.CompilerServices.CompilerGenerated()
   Global.System.CodeDom.Compiler.GeneratedCode("Microsoft.VisualStudio.Editors.SettingsDesigner.SettingsSingleFileGenerator", "8.0.0.0")
   Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)
final class MySettings
   extends ApplicationSettingsBase

Expand image Inheritance Hierarchy

System.Object
System.Configuration.SettingsBase
System.Configuration.ApplicationSettingsBase
Vertragsverwaltung.My.MySettings

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySettings Members
Vertragsverwaltung.My Namespace


MySettings Members

MySettings Members
See Also Methods Properties
CollapseAll image DropDown image

The following tables list the members exposed by the MySettings type.

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Default |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | AutoSaveSettings |
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | addedHandler |
Supported by the .NET Compact Framework. | addedHandlerLockObject |
Supported by the .NET Compact Framework. | defaultInstance |
Top

Expand image See Also

Reference

MySettings Class
Vertragsverwaltung.My Namespace


MySettings Properties

MySettings Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Default |
Top

Expand image See Also

Reference

MySettings Class
Vertragsverwaltung.My Namespace


MySettings.Default Property

MySettings.Default Property

Namespace: Vertragsverwaltung.My
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Shared Property Default() As MySettings
C#
public static MySettings Default {get;}
C++
public:
static property MySettings^ Default {
 MySettings^ get( );
}
JScript
public static function get Default() : MySettings;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Shared ReadOnly Property [Default]() As MySettings
            Get

#If _MyType = "WindowsForms" Then
               If Not addedHandler Then
                    SyncLock addedHandlerLockObject
                        If Not addedHandler Then
                            AddHandler My.Application.Shutdown, AddressOf AutoSaveSettings
                            addedHandler = True
                        End If
                    End SyncLock
                End If
#End If
                Return defaultInstance
            End Get
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySettings Class
MySettings Members
Vertragsverwaltung.My Namespace


MySettings Methods

MySettings Methods
CollapseAll image DropDown image

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | AutoSaveSettings |
Top

Expand image See Also

Reference

MySettings Class
Vertragsverwaltung.My Namespace


MySettings.AutoSaveSettings Method

MySettings.AutoSaveSettings Method

Namespace: Vertragsverwaltung.My
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<Global.System.Diagnostics.DebuggerNonUserCode()> _
<Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)> _
Private Shared Sub AutoSaveSettings( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
[Global.System.Diagnostics.DebuggerNonUserCode()]
[Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)]
private static System.Void AutoSaveSettings(
   object sender,
   EventArgs e
);
C++
[Global.System.Diagnostics.DebuggerNonUserCode()]
[Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)]

private:
System::Void AutoSaveSettings(
   object^ sender,
   EventArgs^ e
) static
JScript
private
   Global.System.Diagnostics.DebuggerNonUserCode()
   Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)
static function AutoSaveSettings(
    sender : object,
    e : EventArgs
);

Parameters

sender

e

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Shared Sub AutoSaveSettings(ByVal sender As Global.System.Object, ByVal e As Global.System.EventArgs)
        If My.Application.SaveMySettingsOnExit Then
            My.Settings.Save()
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySettings Class
MySettings Members
Vertragsverwaltung.My Namespace


MySettings Fields

MySettings Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | addedHandler |
Supported by the .NET Compact Framework. | addedHandlerLockObject |
Supported by the .NET Compact Framework. | defaultInstance |
Top

Expand image See Also

Reference

MySettings Class
Vertragsverwaltung.My Namespace


addedHandler Variable

addedHandler Variable

Namespace: Vertragsverwaltung.My
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Shared addedHandler As Boolean
C#
private static bool addedHandler;
C++
private:
static bool addedHandler;
JScript
private static addedHandler : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Shared addedHandler As Boolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySettings Class
MySettings Members
Vertragsverwaltung.My Namespace


addedHandlerLockObject Variable

addedHandlerLockObject Variable

Namespace: Vertragsverwaltung.My
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Shared addedHandlerLockObject As Object
C#
private static object addedHandlerLockObject;
C++
private:
static object^ addedHandlerLockObject;
JScript
private static addedHandlerLockObject : object

Expand image Source code

Visual Basic CopyCode image Copy Code
    Private Shared addedHandlerLockObject As New Object

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySettings Class
MySettings Members
Vertragsverwaltung.My Namespace


defaultInstance Variable

defaultInstance Variable

Namespace: Vertragsverwaltung.My
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Shared defaultInstance As MySettings
C#
private static MySettings defaultInstance;
C++
private:
static MySettings^ defaultInstance;
JScript
private static defaultInstance : MySettings

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Shared defaultInstance As MySettings = CType(Global.System.Configuration.ApplicationSettingsBase.Synchronized(New MySettings),MySettings)

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySettings Class
MySettings Members
Vertragsverwaltung.My Namespace


MySettingsProperty Class

MySettingsProperty Class
See Also Members
collapseAll image DropDown image

Namespace: Vertragsverwaltung.My
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<Global.Microsoft.VisualBasic.HideModuleName()> _
<Global.System.Diagnostics.DebuggerNonUserCode()> _
<Global.System.Runtime.CompilerServices.CompilerGenerated()> _
Friend Module MySettingsProperty
C#
[Global.Microsoft.VisualBasic.HideModuleName()]
[Global.System.Diagnostics.DebuggerNonUserCode()]
[Global.System.Runtime.CompilerServices.CompilerGenerated()]
internal sealed class MySettingsProperty
C++
[Global.Microsoft.VisualBasic.HideModuleName()]
[Global.System.Diagnostics.DebuggerNonUserCode()]
[Global.System.Runtime.CompilerServices.CompilerGenerated()]
private ref class sealed MySettingsProperty
JScript
internal
   Global.Microsoft.VisualBasic.HideModuleName()
   Global.System.Diagnostics.DebuggerNonUserCode()
   Global.System.Runtime.CompilerServices.CompilerGenerated()
final class MySettingsProperty

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySettingsProperty Members
Vertragsverwaltung.My Namespace


MySettingsProperty Members

MySettingsProperty Members
See Also Properties
CollapseAll image DropDown image

The following tables list the members exposed by the MySettingsProperty type.

Expand image Private, internal (Friend) and internal protected (Protected Friend) Properties

 | Name | Description
Internal (Friend) property Supported by the .NET Compact Framework. | Settings |
Top

Expand image See Also

Reference

MySettingsProperty Class
Vertragsverwaltung.My Namespace


MySettingsProperty Properties

MySettingsProperty Properties
CollapseAll image DropDown image

Expand image Private, internal (Friend) and internal protected (Protected Friend) Properties

 | Name | Description
Internal (Friend) property Supported by the .NET Compact Framework. | Settings |
Top

Expand image See Also

Reference

MySettingsProperty Class
Vertragsverwaltung.My Namespace


MySettingsProperty.Settings Property

MySettingsProperty.Settings Property

Namespace: Vertragsverwaltung.My
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<Global.System.ComponentModel.Design.HelpKeyword("My.Settings")> _
Friend ReadOnly Shared Property Settings() As MySettings
C#
[Global.System.ComponentModel.Design.HelpKeyword("My.Settings")]
internal static MySettings Settings {get;}
C++
[Global.System.ComponentModel.Design.HelpKeyword("My.Settings")]
public private:
static property MySettings^ Settings {
 MySettings^ get( );
}
JScript
internal
   Global.System.ComponentModel.Design.HelpKeyword("My.Settings")
static function get Settings() : MySettings;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Friend ReadOnly Property Settings() As Global.Vertragsverwaltung.My.MySettings
            Get
                Return Global.Vertragsverwaltung.My.MySettings.Default
            End Get
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySettingsProperty Class
MySettingsProperty Members
Vertragsverwaltung.My Namespace


Vertragsverwaltung.My.Resources Namespace

Vertragsverwaltung.My.Resources Namespace

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Classes

 | Name | Description
Internal (Friend) class Supported by the .NET Compact Framework. | Resources | Eine stark typisierte Ressourcenklasse zum Suchen von lokalisierten Zeichenfolgen usw.
Top

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0


Resources Class

Resources Class
See Also Members
collapseAll image DropDown image

Eine stark typisierte Ressourcenklasse zum Suchen von lokalisierten Zeichenfolgen usw.

Namespace: Vertragsverwaltung.My.Resources
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<Global.System.CodeDom.Compiler.GeneratedCode("System.Resources.Tools.StronglyTypedResourceBuilder", "2.0.0.0")> _
<Global.System.Diagnostics.DebuggerNonUserCode()> _
<Global.System.Runtime.CompilerServices.CompilerGenerated()> _
<Global.Microsoft.VisualBasic.HideModuleName()> _
Friend Module Resources
C#
[Global.System.CodeDom.Compiler.GeneratedCode("System.Resources.Tools.StronglyTypedResourceBuilder", "2.0.0.0")]
[Global.System.Diagnostics.DebuggerNonUserCode()]
[Global.System.Runtime.CompilerServices.CompilerGenerated()]
[Global.Microsoft.VisualBasic.HideModuleName()]
internal sealed class Resources
C++
[Global.System.CodeDom.Compiler.GeneratedCode("System.Resources.Tools.StronglyTypedResourceBuilder", "2.0.0.0")]
[Global.System.Diagnostics.DebuggerNonUserCode()]
[Global.System.Runtime.CompilerServices.CompilerGenerated()]
[Global.Microsoft.VisualBasic.HideModuleName()]
private ref class sealed Resources
JScript
internal
   Global.System.CodeDom.Compiler.GeneratedCode("System.Resources.Tools.StronglyTypedResourceBuilder", "2.0.0.0")
   Global.System.Diagnostics.DebuggerNonUserCode()
   Global.System.Runtime.CompilerServices.CompilerGenerated()
   Global.Microsoft.VisualBasic.HideModuleName()
final class Resources

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Resources Members
Vertragsverwaltung.My.Resources Namespace


Resources Members

Resources Members
See Also Properties
CollapseAll image DropDown image

Eine stark typisierte Ressourcenklasse zum Suchen von lokalisierten Zeichenfolgen usw.

The following tables list the members exposed by the Resources type.

Expand image Private, internal (Friend) and internal protected (Protected Friend) Properties

 | Name | Description
Internal (Friend) property Supported by the .NET Compact Framework. | Culture | Überschreibt die CurrentUICulture-Eigenschaft des aktuellen Threads für alle Ressourcenzuordnungen, die diese stark typisierte Ressourcenklasse verwenden.
Internal (Friend) property Supported by the .NET Compact Framework. | FileOpen |
Internal (Friend) property Supported by the .NET Compact Framework. | FileOpen1 |
Internal (Friend) property Supported by the .NET Compact Framework. | Lupe2 |
Internal (Friend) property Supported by the .NET Compact Framework. | OpenFile2 |
Internal (Friend) property Supported by the .NET Compact Framework. | ResourceManager | Gibt die zwischengespeicherte ResourceManager-Instanz zurück, die von dieser Klasse verwendet wird.
Internal (Friend) property Supported by the .NET Compact Framework. | View |
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | resourceCulture |
Supported by the .NET Compact Framework. | resourceMan |
Top

Expand image See Also

Reference

Resources Class
Vertragsverwaltung.My.Resources Namespace


Resources Properties

Resources Properties
CollapseAll image DropDown image

Expand image Private, internal (Friend) and internal protected (Protected Friend) Properties

 | Name | Description
Internal (Friend) property Supported by the .NET Compact Framework. | Culture | Überschreibt die CurrentUICulture-Eigenschaft des aktuellen Threads für alle Ressourcenzuordnungen, die diese stark typisierte Ressourcenklasse verwenden.
Internal (Friend) property Supported by the .NET Compact Framework. | FileOpen |
Internal (Friend) property Supported by the .NET Compact Framework. | FileOpen1 |
Internal (Friend) property Supported by the .NET Compact Framework. | Lupe2 |
Internal (Friend) property Supported by the .NET Compact Framework. | OpenFile2 |
Internal (Friend) property Supported by the .NET Compact Framework. | ResourceManager | Gibt die zwischengespeicherte ResourceManager-Instanz zurück, die von dieser Klasse verwendet wird.
Internal (Friend) property Supported by the .NET Compact Framework. | View |
Top

Expand image See Also

Reference

Resources Class
Vertragsverwaltung.My.Resources Namespace


Resources.Culture Property

Resources.Culture Property

Überschreibt die CurrentUICulture-Eigenschaft des aktuellen Threads für alle Ressourcenzuordnungen, die diese stark typisierte Ressourcenklasse verwenden.

Namespace: Vertragsverwaltung.My.Resources
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)> _
Friend Shared Property Culture() As CultureInfo
C#
[Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)]
internal static CultureInfo Culture {get; set;}
C++
[Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)]
public private:
static property CultureInfo^ Culture {
 CultureInfo^ get( );
 void set(
   CultureInfo^ value
 );
}
JScript
internal
   Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)
static function get Culture() : CultureInfo;
internal
   Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)
static function set Culture(value : CultureInfo);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Friend Property Culture() As Global.System.Globalization.CultureInfo
            Get
                Return resourceCulture
            End Get
            Set
                resourceCulture = value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Resources Class
Resources Members
Vertragsverwaltung.My.Resources Namespace


Resources.FileOpen Property

Resources.FileOpen Property

Namespace: Vertragsverwaltung.My.Resources
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Friend ReadOnly Shared Property FileOpen() As Bitmap
C#
internal static Bitmap FileOpen {get;}
C++
public private:
static property Bitmap^ FileOpen {
 Bitmap^ get( );
}
JScript
internal static function get FileOpen() : Bitmap;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Friend ReadOnly Property FileOpen() As System.Drawing.Bitmap
            Get
                Dim obj As Object = ResourceManager.GetObject("FileOpen", resourceCulture)
                Return CType(obj,System.Drawing.Bitmap)
            End Get
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Resources Class
Resources Members
Vertragsverwaltung.My.Resources Namespace


Resources.FileOpen1 Property

Resources.FileOpen1 Property

Namespace: Vertragsverwaltung.My.Resources
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Friend ReadOnly Shared Property FileOpen1() As Bitmap
C#
internal static Bitmap FileOpen1 {get;}
C++
public private:
static property Bitmap^ FileOpen1 {
 Bitmap^ get( );
}
JScript
internal static function get FileOpen1() : Bitmap;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Friend ReadOnly Property FileOpen1() As System.Drawing.Bitmap
            Get
                Dim obj As Object = ResourceManager.GetObject("FileOpen1", resourceCulture)
                Return CType(obj,System.Drawing.Bitmap)
            End Get
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Resources Class
Resources Members
Vertragsverwaltung.My.Resources Namespace


Resources.Lupe2 Property

Resources.Lupe2 Property

Namespace: Vertragsverwaltung.My.Resources
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Friend ReadOnly Shared Property Lupe2() As Bitmap
C#
internal static Bitmap Lupe2 {get;}
C++
public private:
static property Bitmap^ Lupe2 {
 Bitmap^ get( );
}
JScript
internal static function get Lupe2() : Bitmap;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Friend ReadOnly Property Lupe2() As System.Drawing.Bitmap
            Get
                Dim obj As Object = ResourceManager.GetObject("Lupe2", resourceCulture)
                Return CType(obj,System.Drawing.Bitmap)
            End Get
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Resources Class
Resources Members
Vertragsverwaltung.My.Resources Namespace


Resources.OpenFile2 Property

Resources.OpenFile2 Property

Namespace: Vertragsverwaltung.My.Resources
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Friend ReadOnly Shared Property OpenFile2() As Bitmap
C#
internal static Bitmap OpenFile2 {get;}
C++
public private:
static property Bitmap^ OpenFile2 {
 Bitmap^ get( );
}
JScript
internal static function get OpenFile2() : Bitmap;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Friend ReadOnly Property OpenFile2() As System.Drawing.Bitmap
            Get
                Dim obj As Object = ResourceManager.GetObject("OpenFile2", resourceCulture)
                Return CType(obj,System.Drawing.Bitmap)
            End Get
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Resources Class
Resources Members
Vertragsverwaltung.My.Resources Namespace


Resources.ResourceManager Property

Resources.ResourceManager Property

Gibt die zwischengespeicherte ResourceManager-Instanz zurück, die von dieser Klasse verwendet wird.

Namespace: Vertragsverwaltung.My.Resources
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)> _
Friend ReadOnly Shared Property ResourceManager() As ResourceManager
C#
[Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)]
internal static ResourceManager ResourceManager {get;}
C++
[Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)]
public private:
static property ResourceManager^ ResourceManager {
 ResourceManager^ get( );
}
JScript
internal
   Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)
static function get ResourceManager() : ResourceManager;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Friend ReadOnly Property ResourceManager() As Global.System.Resources.ResourceManager
            Get
                If Object.ReferenceEquals(resourceMan, Nothing) Then
                    Dim temp As Global.System.Resources.ResourceManager = New Global.System.Resources.ResourceManager("Vertragsverwaltung.Resources", GetType(Resources).Assembly)
                    resourceMan = temp
                End If
                Return resourceMan
            End Get
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Resources Class
Resources Members
Vertragsverwaltung.My.Resources Namespace


Resources.View Property

Resources.View Property

Namespace: Vertragsverwaltung.My.Resources
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Friend ReadOnly Shared Property View() As Bitmap
C#
internal static Bitmap View {get;}
C++
public private:
static property Bitmap^ View {
 Bitmap^ get( );
}
JScript
internal static function get View() : Bitmap;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Friend ReadOnly Property View() As System.Drawing.Bitmap
            Get
                Dim obj As Object = ResourceManager.GetObject("View", resourceCulture)
                Return CType(obj,System.Drawing.Bitmap)
            End Get
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Resources Class
Resources Members
Vertragsverwaltung.My.Resources Namespace


Resources Fields

Resources Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | resourceCulture |
Supported by the .NET Compact Framework. | resourceMan |
Top

Expand image See Also

Reference

Resources Class
Vertragsverwaltung.My.Resources Namespace


resourceCulture Variable

resourceCulture Variable

Namespace: Vertragsverwaltung.My.Resources
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Shared resourceCulture As CultureInfo
C#
private static CultureInfo resourceCulture;
C++
private:
static CultureInfo^ resourceCulture;
JScript
private static resourceCulture : CultureInfo

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private resourceCulture As Global.System.Globalization.CultureInfo

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Resources Class
Resources Members
Vertragsverwaltung.My.Resources Namespace


resourceMan Variable

resourceMan Variable

Namespace: Vertragsverwaltung.My.Resources
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Shared resourceMan As ResourceManager
C#
private static ResourceManager resourceMan;
C++
private:
static ResourceManager^ resourceMan;
JScript
private static resourceMan : ResourceManager

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private resourceMan As Global.System.Resources.ResourceManager

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Resources Class
Resources Members
Vertragsverwaltung.My.Resources Namespace


Vertragsverwaltung.TKB.VV.DB Namespace

Vertragsverwaltung.TKB.VV.DB Namespace

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Classes

 | Name | Description
Supported by the .NET Compact Framework. | DB_Connection | Dynamische Datenbank-Verbindung aufbauen. Verwendet wird standardmässig Vertragsverwaltung.cfg. Sollen Datenbank-Verbindungen zur Auswahl angezeigt werden, werden sämntliche Datenbank-Verbindungsdateien mit dem Namen "Vertragsverwaltung....cfg" berücksichtigt
Supported by the .NET Compact Framework. | MyMitarbeiter |
Supported by the .NET Compact Framework. | clsApplikation | Purpose: Data Access class for the table 'applikation'.
Supported by the .NET Compact Framework. | clsConnectionProvider |
Supported by the .NET Compact Framework. | clsDBInteractionBase |
Supported by the .NET Compact Framework. | clsDokument | Purpose: Data Access class for the table 'Dokument'.
Supported by the .NET Compact Framework. | clsDokumenttyp | Purpose: Data Access class for the table 'Dokumenttyp'.
Supported by the .NET Compact Framework. | clsFunktionsgruppe | Purpose: Data Access class for the table 'funktionsgruppe'.
Supported by the .NET Compact Framework. | clsFunktionsgruppe_rolle | Purpose: Data Access class for the table 'funktionsgruppe_rolle'.
Supported by the .NET Compact Framework. | clsKey_tabelle | Purpose: Data Access class for the table 'key_tabelle'.
Supported by the .NET Compact Framework. | clsKontakttyp | Purpose: Data Access class for the table 'Kontakttyp'.
Supported by the .NET Compact Framework. | clsKuendigungsfrist | Purpose: Data Access class for the table 'Kuendigungsfrist'.
Supported by the .NET Compact Framework. | clsMandant | Purpose: Data Access class for the table 'mandant'.
Supported by the .NET Compact Framework. | clsMeldungstexte | Purpose: Data Access class for the table 'meldungstexte'.
Supported by the .NET Compact Framework. | clsMitarbeiter | Purpose: Data Access class for the table 'mitarbeiter'.
Supported by the .NET Compact Framework. | clsMitarbeiter_funktionsgruppe | Purpose: Data Access class for the table 'mitarbeiter_funktionsgruppe'.
Supported by the .NET Compact Framework. | clsMyKey_Tabelle |
Supported by the .NET Compact Framework. | clsPerson | Purpose: Data Access class for the table 'Person'.
Supported by the .NET Compact Framework. | clsRolle | Purpose: Data Access class for the table 'rolle'.
Supported by the .NET Compact Framework. | clsRolle_SecurityObject | Purpose: Data Access class for the table 'Rolle_SecurityObject'.
Supported by the .NET Compact Framework. | clsRolle_securitylevel | Purpose: Data Access class for the table 'rolle_securitylevel'.
Supported by the .NET Compact Framework. | clsRolle_sysadminfunktion | Purpose: Data Access class for the table 'rolle_sysadminfunktion'.
Supported by the .NET Compact Framework. | clsSLAKatalog | Purpose: Data Access class for the table 'SLAKatalog'.
Supported by the .NET Compact Framework. | clsSLATyp | Purpose: Data Access class for the table 'SLATyp'.
Supported by the .NET Compact Framework. | clsSecurityLevel | Purpose: Data Access class for the table 'SecurityLevel'.
Supported by the .NET Compact Framework. | clsSecurityObject | Purpose: Data Access class for the table 'SecurityObject'.
Supported by the .NET Compact Framework. | clsServiceKatalog | Purpose: Data Access class for the table 'ServiceKatalog'.
Supported by the .NET Compact Framework. | clsServiceKatalog_SLAKatalog | Purpose: Data Access class for the table 'ServiceKatalog_SLAKatalog'.
Supported by the .NET Compact Framework. | clsSpalten | Purpose: Data Access class for the table 'spalten'.
Supported by the .NET Compact Framework. | clsSysadminfunktion | Purpose: Data Access class for the table 'sysadminfunktion'.
Supported by the .NET Compact Framework. | clsVertragselement | Purpose: Data Access class for the table 'Vertragselement'.
Supported by the .NET Compact Framework. | clsVertragskontakt | Purpose: Data Access class for the table 'Vertragskontakt'.
Supported by the .NET Compact Framework. | clsVertragspartner | Purpose: Data Access class for the table 'Vertragspartner'.
Supported by the .NET Compact Framework. | clsVertragstyp | Purpose: Data Access class for the table 'Vertragstyp'.
Supported by the .NET Compact Framework. | clsZeiteinheittyp | Purpose: Data Access class for the table 'Zeiteinheittyp'.
Supported by the .NET Compact Framework. | mySLATyp |
Supported by the .NET Compact Framework. | myZeiteinheittyp |
Top

Expand image Interfaces

 | Name | Description
Supported by the .NET Compact Framework. | ICommonDBAccess |
Top

Expand image Enumerations

 | Name | Description
Supported by the .NET Compact Framework. | LLBLError |
Top

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0


DB_Connection Class

DB_Connection Class
See Also Members
collapseAll image DropDown image

Dynamische Datenbank-Verbindung aufbauen. Verwendet wird standardmässig Vertragsverwaltung.cfg. Sollen Datenbank-Verbindungen zur Auswahl angezeigt werden, werden sämntliche Datenbank-Verbindungsdateien mit dem Namen "Vertragsverwaltung....cfg" berücksichtigt

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class DB_Connection
C#
public class DB_Connection
C++

public ref class DB_Connection
JScript
public class DB_Connection

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.DB_Connection

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DB_Connection Members
Vertragsverwaltung.TKB.VV.DB Namespace


DB_Connection Members

DB_Connection Members
See Also Constructors
CollapseAll image DropDown image

Dynamische Datenbank-Verbindung aufbauen. Verwendet wird standardmässig Vertragsverwaltung.cfg. Sollen Datenbank-Verbindungen zur Auswahl angezeigt werden, werden sämntliche Datenbank-Verbindungsdateien mit dem Namen "Vertragsverwaltung....cfg" berücksichtigt

The following tables list the members exposed by the DB_Connection type.

Expand image Private, internal (Friend) and internal protected (Protected Friend) Constructors

 | Name | Description
Supported by the .NET Compact Framework. | DB_Connection Constructor | Liest sämtlcihe CFG-Dateien mit dem Namen "Vertragsverwaltung...". Sind meherere Dateien vorhanden, wird ein Auswahldialog zur Datenbank-Selektion angezeigt. Standardmässig wird Vertragsverwaltung.cfg als CFG-Datei benutzt. Die CFG-Datei ist verschlüsselt und wird über die Crypto-Funktionen entschlüsselt.
Top

Expand image See Also

Reference

DB_Connection Class


DB_Connection Constructor

DB_Connection Constructor

Liest sämtlcihe CFG-Dateien mit dem Namen "Vertragsverwaltung...". Sind meherere Dateien vorhanden, wird ein Auswahldialog zur Datenbank-Selektion angezeigt. Standardmässig wird Vertragsverwaltung.cfg als CFG-Datei benutzt. Die CFG-Datei ist verschlüsselt und wird über die Crypto-Funktionen entschlüsselt.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Shared Sub New()
C#
private static System.Void DB_Connection();
C++

private:
System::Void DB_Connection() static
JScript
private static function DB_Connection();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Shared Sub New()
            Dim fc As Integer = 0
            If Globals.ConnectionFileName.Length = 0 Then
                Dim Dir As DirectoryInfo = New DirectoryInfo(Application.StartupPath)
                Try
                    Dim f As New frmDatenbankauswahl()
                    Dim ChildFile As FileInfo
                    For Each ChildFile In Dir.GetFiles()
                        If UCase(Left(ChildFile.Name, 18)) = "VERTRAGSVERWALTUNG" And UCase(ChildFile.Extension) = ".CFG" Then
                            f.ListBox1.Items.Add(ChildFile.Name)
                            fc = fc + 1
                        End If
                    Next
                    If fc > 1 Then
                        f.ListBox1.SelectedIndex = 0
                        f.ListBox1.Select()
                        f.ShowDialog()
                        Globals.ConnectionFileName = f.ListBox1.SelectedItem
                        f.Dispose()
                    End If
                Catch except As Exception
                    fc = 0
                    Exit Sub
                End Try
            End If
            If fc < 2 Then Globals.ConnectionFileName = "Vertragsverwaltung.cfg"
            Dim ofile As System.IO.File
            Dim oread As System.IO.StreamReader
            oread = ofile.OpenText(Application.StartupPath + "\" + Globals.ConnectionFileName)
            sConnectionString = oread.ReadLine
            sConnectionString = Crypto.DecryptText(sConnectionString, "HutterundMueller")
            sConnectionString = Left(sConnectionString, Len(sConnectionString) - 1)
            Globals.sConnectionString = sConnectionString
            Globals.conn.sConnectionString = sConnectionString
            oread.Close()
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DB_Connection Class
DB_Connection Members


MyMitarbeiter Class

MyMitarbeiter Class
See Also Members
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class MyMitarbeiter
    Inherits clsMitarbeiter
C#
public class MyMitarbeiter : clsMitarbeiter
C++

public ref class MyMitarbeiter : public clsMitarbeiter^
JScript
public class MyMitarbeiter
   extends clsMitarbeiter

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter
Vertragsverwaltung.TKB.VV.DB.MyMitarbeiter

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyMitarbeiter Members


MyMitarbeiter Members

MyMitarbeiter Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

The following tables list the members exposed by the MyMitarbeiter type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | MyMitarbeiter Constructor | Purpose: Class constructor. (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | bShowtip | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iFuermandant | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | iFunktionnr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | iMandantnr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | iMitarbeiternr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | iMutierer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | iPartnernr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSprache | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | sAnrede | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sEmail | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | sFax | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | sKurzzeichen | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | sName | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | sTelefon | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | sTgnummer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | sUnterschrift_text | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | sVorname | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table. (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | SelectAllwithFullname | Alle Mitarbeiter inkl. vollständigem Name (Fullname) auslesen
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | SelectWithTGNummer | Mitarbeiter mittels TGNummer auslesen
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | Get_Username | Windows-User auslesen
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | ouser | Security-Deklaration zum Auslesen der UserID vom Windows-User
Top

Expand image See Also

Reference

MyMitarbeiter Class


clsMitarbeiter Constructor

clsMitarbeiter Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsMitarbeiter();
C++

public:
System::Void clsMitarbeiter()
JScript
public function clsMitarbeiter();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


MyMitarbeiter Properties

MyMitarbeiter Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | bShowtip | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iFuermandant | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | iFunktionnr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | iMandantnr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | iMitarbeiternr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | iMutierer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | iPartnernr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSprache | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | sAnrede | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sEmail | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | sFax | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | sKurzzeichen | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | sName | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | sTelefon | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | sTgnummer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | sUnterschrift_text | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | sVorname | (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Top

Expand image See Also

Reference

MyMitarbeiter Class


clsMitarbeiter.bAktiv Property

clsMitarbeiter.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


clsMitarbeiter.bShowtip Property

clsMitarbeiter.bShowtip Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bShowtip() As SqlBoolean
C#
public SqlBoolean bShowtip {get; set;}
C++
public:
property SqlBoolean bShowtip {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bShowtip() : SqlBoolean;
public function set bShowtip(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bShowtip]() As SqlBoolean
            Get
                Return m_bShowtip
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bShowtipTmp As SqlBoolean = Value
                If bShowtipTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bShowtip", "bShowtip can't be NULL")
                End If
                m_bShowtip = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


clsDBInteractionBase.cpMainConnectionProvider Property

clsDBInteractionBase.cpMainConnectionProvider Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public WriteOnly Property cpMainConnectionProvider() As clsConnectionProvider
C#
public clsConnectionProvider cpMainConnectionProvider {set;}
C++
public:
property clsConnectionProvider^ cpMainConnectionProvider {
 void set(
   clsConnectionProvider^ value
 );
}
JScript
public function set cpMainConnectionProvider(value : clsConnectionProvider);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public WriteOnly Property cpMainConnectionProvider() As clsConnectionProvider
            Set(ByVal Value As clsConnectionProvider)
                If Value Is Nothing Then
                    ' // Invalid value
                    Throw New ArgumentNullException("cpMainConnectionProvider", "Nothing passed as value to this property which is not allowed.")
                End If

                ' // A connection provider object is passed to this class.
                ' // Retrieve the SqlConnection object, if present and create a
                ' // reference to it. If there is already a MainConnection object
                ' // referenced by the membervar, destroy that one or simply
                ' // remove the reference, based on the flag.
                If Not (m_scoMainConnection Is Nothing) Then
                    ' // First get rid of current connection object. Caller is responsible
                    If m_bMainConnectionIsCreatedLocal Then
                        ' // Is local created object, close it and dispose it.
                        m_scoMainConnection.Close()
                        m_scoMainConnection.Dispose()
                    End If
                    ' // Remove reference.
                    m_scoMainConnection = Nothing
                End If
                m_cpMainConnectionProvider = CType(Value, clsConnectionProvider)
                m_scoMainConnection = m_cpMainConnectionProvider.scoDBConnection
                m_bMainConnectionIsCreatedLocal = False
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase Members


clsMitarbeiter.daErstellt_am Property

clsMitarbeiter.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


clsMitarbeiter.daMutiert_am Property

clsMitarbeiter.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


clsDBInteractionBase.iErrorCode Property

clsDBInteractionBase.iErrorCode Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property iErrorCode() As SqlInt32
C#
public SqlInt32 iErrorCode {get;}
C++
public:
property SqlInt32 iErrorCode {
 SqlInt32 get( );
}
JScript
public function get iErrorCode() : SqlInt32;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public ReadOnly Property iErrorCode() As SqlInt32
            Get
                Return m_iErrorCode
            End Get
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase Members


clsMitarbeiter.iFuermandant Property

clsMitarbeiter.iFuermandant Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iFuermandant() As SqlInt32
C#
public SqlInt32 iFuermandant {get; set;}
C++
public:
property SqlInt32 iFuermandant {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iFuermandant() : SqlInt32;
public function set iFuermandant(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iFuermandant]() As SqlInt32
            Get
                Return m_iFuermandant
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iFuermandantTmp As SqlInt32 = Value
                If iFuermandantTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iFuermandant", "iFuermandant can't be NULL")
                End If
                m_iFuermandant = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


clsMitarbeiter.iFunktionnr Property

clsMitarbeiter.iFunktionnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iFunktionnr() As SqlInt32
C#
public SqlInt32 iFunktionnr {get; set;}
C++
public:
property SqlInt32 iFunktionnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iFunktionnr() : SqlInt32;
public function set iFunktionnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iFunktionnr]() As SqlInt32
            Get
                Return m_iFunktionnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFunktionnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


clsMitarbeiter.iMandantnr Property

clsMitarbeiter.iMandantnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandantnr() As SqlInt32
C#
public SqlInt32 iMandantnr {get; set;}
C++
public:
property SqlInt32 iMandantnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


clsMitarbeiter.iMitarbeiternr Property

clsMitarbeiter.iMitarbeiternr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMitarbeiternr() As SqlInt32
C#
public SqlInt32 iMitarbeiternr {get; set;}
C++
public:
property SqlInt32 iMitarbeiternr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMitarbeiternr() : SqlInt32;
public function set iMitarbeiternr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMitarbeiternr]() As SqlInt32
            Get
                Return m_iMitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMitarbeiternrTmp As SqlInt32 = Value
                If iMitarbeiternrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMitarbeiternr", "iMitarbeiternr can't be NULL")
                End If
                m_iMitarbeiternr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


clsMitarbeiter.iMutierer Property

clsMitarbeiter.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


clsMitarbeiter.iPartnernr Property

clsMitarbeiter.iPartnernr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iPartnernr() As SqlInt32
C#
public SqlInt32 iPartnernr {get; set;}
C++
public:
property SqlInt32 iPartnernr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iPartnernr() : SqlInt32;
public function set iPartnernr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iPartnernr]() As SqlInt32
            Get
                Return m_iPartnernr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iPartnernrTmp As SqlInt32 = Value
                If iPartnernrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iPartnernr", "iPartnernr can't be NULL")
                End If
                m_iPartnernr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


clsDBInteractionBase.iRowsAffected Property

clsDBInteractionBase.iRowsAffected Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property iRowsAffected() As Integer
C#
public int iRowsAffected {get;}
C++
public:
property int iRowsAffected {
 int get( );
}
JScript
public function get iRowsAffected() : int;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Readonly Property iRowsAffected() As Integer
            Get
                Return m_iRowsAffected
            End Get
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase Members


clsMitarbeiter.iSprache Property

clsMitarbeiter.iSprache Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iSprache() As SqlInt32
C#
public SqlInt32 iSprache {get; set;}
C++
public:
property SqlInt32 iSprache {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iSprache() : SqlInt32;
public function set iSprache(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iSprache]() As SqlInt32
            Get
                Return m_iSprache
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSprache = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


clsMitarbeiter.sAnrede Property

clsMitarbeiter.sAnrede Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sAnrede() As SqlString
C#
public SqlString sAnrede {get; set;}
C++
public:
property SqlString sAnrede {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sAnrede() : SqlString;
public function set sAnrede(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sAnrede]() As SqlString
            Get
                Return m_sAnrede
            End Get
            Set(ByVal Value As SqlString)
                m_sAnrede = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


clsDBInteractionBase.sConnectionString Property

clsDBInteractionBase.sConnectionString Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sConnectionString() As String
C#
public string sConnectionString {get; set;}
C++
public:
property String^ sConnectionString {
 String^ get( );
 void set(
   String^ value
 );
}
JScript
public function get sConnectionString() : String;
public function set sConnectionString(value : String);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property sConnectionString() As String
            Get
                Return m_sConnectionString
            End Get
            Set (ByVal Value As String)
                m_sConnectionString = Value
                m_scoMainConnection.ConnectionString = m_sConnectionString
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase Members


clsMitarbeiter.sEmail Property

clsMitarbeiter.sEmail Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sEmail() As SqlString
C#
public SqlString sEmail {get; set;}
C++
public:
property SqlString sEmail {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sEmail() : SqlString;
public function set sEmail(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sEmail]() As SqlString
            Get
                Return m_sEmail
            End Get
            Set(ByVal Value As SqlString)
                m_sEmail = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


clsMitarbeiter.sFax Property

clsMitarbeiter.sFax Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sFax() As SqlString
C#
public SqlString sFax {get; set;}
C++
public:
property SqlString sFax {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sFax() : SqlString;
public function set sFax(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sFax]() As SqlString
            Get
                Return m_sFax
            End Get
            Set(ByVal Value As SqlString)
                m_sFax = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


clsMitarbeiter.sKurzzeichen Property

clsMitarbeiter.sKurzzeichen Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sKurzzeichen() As SqlString
C#
public SqlString sKurzzeichen {get; set;}
C++
public:
property SqlString sKurzzeichen {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sKurzzeichen() : SqlString;
public function set sKurzzeichen(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sKurzzeichen]() As SqlString
            Get
                Return m_sKurzzeichen
            End Get
            Set(ByVal Value As SqlString)
                m_sKurzzeichen = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


clsMitarbeiter.sName Property

clsMitarbeiter.sName Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sName() As SqlString
C#
public SqlString sName {get; set;}
C++
public:
property SqlString sName {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sName() : SqlString;
public function set sName(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sName]() As SqlString
            Get
                Return m_sName
            End Get
            Set(ByVal Value As SqlString)
                m_sName = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


clsMitarbeiter.sTelefon Property

clsMitarbeiter.sTelefon Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sTelefon() As SqlString
C#
public SqlString sTelefon {get; set;}
C++
public:
property SqlString sTelefon {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sTelefon() : SqlString;
public function set sTelefon(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sTelefon]() As SqlString
            Get
                Return m_sTelefon
            End Get
            Set(ByVal Value As SqlString)
                m_sTelefon = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


clsMitarbeiter.sTgnummer Property

clsMitarbeiter.sTgnummer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sTgnummer() As SqlString
C#
public SqlString sTgnummer {get; set;}
C++
public:
property SqlString sTgnummer {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sTgnummer() : SqlString;
public function set sTgnummer(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sTgnummer]() As SqlString
            Get
                Return m_sTgnummer
            End Get
            Set(ByVal Value As SqlString)
                m_sTgnummer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


clsMitarbeiter.sUnterschrift_text Property

clsMitarbeiter.sUnterschrift_text Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sUnterschrift_text() As SqlString
C#
public SqlString sUnterschrift_text {get; set;}
C++
public:
property SqlString sUnterschrift_text {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sUnterschrift_text() : SqlString;
public function set sUnterschrift_text(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sUnterschrift_text]() As SqlString
            Get
                Return m_sUnterschrift_text
            End Get
            Set(ByVal Value As SqlString)
                m_sUnterschrift_text = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


clsMitarbeiter.sVorname Property

clsMitarbeiter.sVorname Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sVorname() As SqlString
C#
public SqlString sVorname {get; set;}
C++
public:
property SqlString sVorname {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sVorname() : SqlString;
public function set sVorname(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sVorname]() As SqlString
            Get
                Return m_sVorname
            End Get
            Set(ByVal Value As SqlString)
                m_sVorname = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


MyMitarbeiter Methods

MyMitarbeiter Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table. (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | SelectAllwithFullname | Alle Mitarbeiter inkl. vollständigem Name (Fullname) auslesen
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Supported by the .NET Compact Framework. | SelectWithTGNummer | Mitarbeiter mittels TGNummer auslesen
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter).
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | Get_Username | Windows-User auslesen
Top

Expand image See Also

Reference

MyMitarbeiter Class


clsMitarbeiter.Delete Method

clsMitarbeiter.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iMitarbeiternr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


clsDBInteractionBase.Dispose Method

clsDBInteractionBase.Dispose Method

Expand image Overload List

Name | Description
public System.Void Dispose(); |
protected virtual System.Void Dispose(bool); |

Expand image See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase Members


MyMitarbeiter.Get_Username Method

MyMitarbeiter.Get_Username Method

Windows-User auslesen

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Get_Username() As String
C#
private string Get_Username();
C++

private:
String^ Get_Username()
JScript
private function Get_Username() : String;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Function Get_Username() As String
            With ouser.Identity.Name
                Return (.Substring(.IndexOf("\") + 1))
            End With
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyMitarbeiter Class
MyMitarbeiter Members


clsMitarbeiter.Insert Method

clsMitarbeiter.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iMitarbeiternr</LI> <LI>sVorname. May be SqlString.Null</LI> <LI>sName. May be SqlString.Null</LI> <LI>sKurzzeichen. May be SqlString.Null</LI> <LI>sAnrede. May be SqlString.Null</LI> <LI>sTgnummer. May be SqlString.Null</LI> <LI>sEmail. May be SqlString.Null</LI> <LI>sFax. May be SqlString.Null</LI> <LI>sTelefon. May be SqlString.Null</LI> <LI>sUnterschrift_text. May be SqlString.Null</LI> <LI>iFunktionnr. May be SqlInt32.Null</LI> <LI>iSprache. May be SqlInt32.Null</LI> <LI>iFuermandant</LI> <LI>bShowtip</LI> <LI>iPartnernr</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svorname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVorname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sName))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@skurzzeichen", SqlDbType.VarChar, 10, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sKurzzeichen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sanrede", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAnrede))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stgnummer", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTgnummer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@semail", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sEmail))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sfax", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFax))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stelefon", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTelefon))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sunterschrift_text", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUnterschrift_text))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifuermandant", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFuermandant))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bshowtip", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bShowtip))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ipartnernr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPartnernr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


clsMitarbeiter.SelectAll Method

clsMitarbeiter.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("mitarbeiter")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


MyMitarbeiter.SelectAllwithFullname Method

MyMitarbeiter.SelectAllwithFullname Method

Alle Mitarbeiter inkl. vollständigem Name (Fullname) auslesen

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function SelectAllwithFullname() As DataTable
C#
public DataTable SelectAllwithFullname();
C++

public:
DataTable^ SelectAllwithFullname()
JScript
public function SelectAllwithFullname() : DataTable;

Return Value

Datatable

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function SelectAllwithFullname() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[my_mitarbeiter_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("mitarbeiter")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyMitarbeiter Class
MyMitarbeiter Members


clsMitarbeiter.SelectOne Method

clsMitarbeiter.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iMitarbeiternr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iMitarbeiternr</LI> <LI>sVorname</LI> <LI>sName</LI> <LI>sKurzzeichen</LI> <LI>sAnrede</LI> <LI>sTgnummer</LI> <LI>sEmail</LI> <LI>sFax</LI> <LI>sTelefon</LI> <LI>sUnterschrift_text</LI> <LI>iFunktionnr</LI> <LI>iSprache</LI> <LI>iFuermandant</LI> <LI>bShowtip</LI> <LI>iPartnernr</LI> <LI>iMandantnr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("mitarbeiter")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iMitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr"), Integer))
                    If dtToReturn.Rows(0)("vorname") Is System.DBNull.Value Then
                        m_sVorname = SqlString.Null
                    Else
                        m_sVorname = New SqlString(CType(dtToReturn.Rows(0)("vorname"), String))
                    End If
                    If dtToReturn.Rows(0)("name") Is System.DBNull.Value Then
                        m_sName = SqlString.Null
                    Else
                        m_sName = New SqlString(CType(dtToReturn.Rows(0)("name"), String))
                    End If
                    If dtToReturn.Rows(0)("kurzzeichen") Is System.DBNull.Value Then
                        m_sKurzzeichen = SqlString.Null
                    Else
                        m_sKurzzeichen = New SqlString(CType(dtToReturn.Rows(0)("kurzzeichen"), String))
                    End If
                    If dtToReturn.Rows(0)("anrede") Is System.DBNull.Value Then
                        m_sAnrede = SqlString.Null
                    Else
                        m_sAnrede = New SqlString(CType(dtToReturn.Rows(0)("anrede"), String))
                    End If
                    If dtToReturn.Rows(0)("tgnummer") Is System.DBNull.Value Then
                        m_sTgnummer = SqlString.Null
                    Else
                        m_sTgnummer = New SqlString(CType(dtToReturn.Rows(0)("tgnummer"), String))
                    End If
                    If dtToReturn.Rows(0)("email") Is System.DBNull.Value Then
                        m_sEmail = SqlString.Null
                    Else
                        m_sEmail = New SqlString(CType(dtToReturn.Rows(0)("email"), String))
                    End If
                    If dtToReturn.Rows(0)("fax") Is System.DBNull.Value Then
                        m_sFax = SqlString.Null
                    Else
                        m_sFax = New SqlString(CType(dtToReturn.Rows(0)("fax"), String))
                    End If
                    If dtToReturn.Rows(0)("telefon") Is System.DBNull.Value Then
                        m_sTelefon = SqlString.Null
                    Else
                        m_sTelefon = New SqlString(CType(dtToReturn.Rows(0)("telefon"), String))
                    End If
                    If dtToReturn.Rows(0)("unterschrift_text") Is System.DBNull.Value Then
                        m_sUnterschrift_text = SqlString.Null
                    Else
                        m_sUnterschrift_text = New SqlString(CType(dtToReturn.Rows(0)("unterschrift_text"), String))
                    End If
                    If dtToReturn.Rows(0)("funktionnr") Is System.DBNull.Value Then
                        m_iFunktionnr = SqlInt32.Null
                    Else
                        m_iFunktionnr = New SqlInt32(CType(dtToReturn.Rows(0)("funktionnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("sprache") Is System.DBNull.Value Then
                        m_iSprache = SqlInt32.Null
                    Else
                        m_iSprache = New SqlInt32(CType(dtToReturn.Rows(0)("sprache"), Integer))
                    End If
                    m_iFuermandant = New SqlInt32(CType(dtToReturn.Rows(0)("fuermandant"), Integer))
                    m_bShowtip = New SqlBoolean(CType(dtToReturn.Rows(0)("showtip"), Boolean))
                    m_iPartnernr = New SqlInt32(CType(dtToReturn.Rows(0)("partnernr"), Integer))
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


MyMitarbeiter.SelectWithTGNummer Method

MyMitarbeiter.SelectWithTGNummer Method

Mitarbeiter mittels TGNummer auslesen

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function SelectWithTGNummer() As DataTable
C#
public DataTable SelectWithTGNummer();
C++

public:
DataTable^ SelectWithTGNummer()
JScript
public function SelectWithTGNummer() : DataTable;

Return Value

Datatable

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function SelectWithTGNummer() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[my_mitarbeiter_SelectWithTGNummer]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("mitarbeiter")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection
            Try

                scmCmdToExecute.Parameters.Add(New SqlParameter("@stgnummer", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Get_Username))

                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_SelectAllWithTGNummer' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If
                Return dtToReturn
            Catch ex As Exception
                MsgBox(ex.Message)
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter::SelectWithTGNummer::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyMitarbeiter Class
MyMitarbeiter Members


clsMitarbeiter.Update Method

clsMitarbeiter.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iMitarbeiternr</LI> <LI>sVorname. May be SqlString.Null</LI> <LI>sName. May be SqlString.Null</LI> <LI>sKurzzeichen. May be SqlString.Null</LI> <LI>sAnrede. May be SqlString.Null</LI> <LI>sTgnummer. May be SqlString.Null</LI> <LI>sEmail. May be SqlString.Null</LI> <LI>sFax. May be SqlString.Null</LI> <LI>sTelefon. May be SqlString.Null</LI> <LI>sUnterschrift_text. May be SqlString.Null</LI> <LI>iFunktionnr. May be SqlInt32.Null</LI> <LI>iSprache. May be SqlInt32.Null</LI> <LI>iFuermandant</LI> <LI>bShowtip</LI> <LI>iPartnernr</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svorname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVorname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sName))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@skurzzeichen", SqlDbType.VarChar, 10, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sKurzzeichen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sanrede", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAnrede))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stgnummer", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTgnummer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@semail", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sEmail))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sfax", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFax))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stelefon", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTelefon))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sunterschrift_text", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUnterschrift_text))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifuermandant", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFuermandant))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bshowtip", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bShowtip))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ipartnernr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPartnernr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


MyMitarbeiter Fields

MyMitarbeiter Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | ouser | Security-Deklaration zum Auslesen der UserID vom Windows-User
Top

Expand image See Also

Reference

MyMitarbeiter Class


m_bMainConnectionIsCreatedLocal Variable

m_bMainConnectionIsCreatedLocal Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Protected m_bMainConnectionIsCreatedLocal As Boolean
C#
protected bool m_bMainConnectionIsCreatedLocal;
C++
protected:
bool m_bMainConnectionIsCreatedLocal;
JScript
protected m_bMainConnectionIsCreatedLocal : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Protected	m_bMainConnectionIsCreatedLocal As Boolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase Members


m_cpMainConnectionProvider Variable

m_cpMainConnectionProvider Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Protected m_cpMainConnectionProvider As clsConnectionProvider
C#
protected clsConnectionProvider m_cpMainConnectionProvider;
C++
protected:
clsConnectionProvider^ m_cpMainConnectionProvider;
JScript
protected m_cpMainConnectionProvider : clsConnectionProvider

Expand image Source code

Visual Basic CopyCode image Copy Code
        Protected	m_cpMainConnectionProvider As clsConnectionProvider

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase Members


m_iErrorCode Variable

m_iErrorCode Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Protected m_iErrorCode As SqlInt32
C#
protected SqlInt32 m_iErrorCode;
C++
protected:
SqlInt32 m_iErrorCode;
JScript
protected m_iErrorCode : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Protected	m_iErrorCode As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase Members


m_iRowsAffected Variable

m_iRowsAffected Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Protected m_iRowsAffected As Integer
C#
protected int m_iRowsAffected;
C++
protected:
int m_iRowsAffected;
JScript
protected m_iRowsAffected : int

Expand image Source code

Visual Basic CopyCode image Copy Code
        Protected	m_iRowsAffected As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase Members


m_scoMainConnection Variable

m_scoMainConnection Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Protected m_scoMainConnection As SqlConnection
C#
protected SqlConnection m_scoMainConnection;
C++
protected:
SqlConnection^ m_scoMainConnection;
JScript
protected m_scoMainConnection : SqlConnection

Expand image Source code

Visual Basic CopyCode image Copy Code
        Protected	m_scoMainConnection As SqlConnection

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase Members


ouser Variable

ouser Variable

Security-Deklaration zum Auslesen der UserID vom Windows-User

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private ouser As WindowsPrincipal
C#
private WindowsPrincipal ouser;
C++
private:
WindowsPrincipal^ ouser;
JScript
private ouser : WindowsPrincipal

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim ouser As New WindowsPrincipal(WindowsIdentity.GetCurrent)

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyMitarbeiter Class
MyMitarbeiter Members


clsApplikation Class

clsApplikation Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'applikation'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsApplikation
    Inherits clsDBInteractionBase
C#
public class clsApplikation : clsDBInteractionBase
C++

public ref class clsApplikation : public clsDBInteractionBase^
JScript
public class clsApplikation
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsApplikation

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsApplikation Members


clsApplikation Members

clsApplikation Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'applikation'.

The following tables list the members exposed by the clsApplikation type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsApplikation Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bShowlogin |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iApplikationsnr |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sTmp_filepath |
Supported by the .NET Compact Framework. | sVersion |
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_bShowlogin |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iApplikationsnr |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_sTmp_filepath |
Supported by the .NET Compact Framework. | m_sVersion |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsApplikation Class


clsApplikation Constructor

clsApplikation Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsApplikation();
C++

public:
System::Void clsApplikation()
JScript
public function clsApplikation();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsApplikation Class
clsApplikation Members


clsApplikation Properties

clsApplikation Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bShowlogin |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iApplikationsnr |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sTmp_filepath |
Supported by the .NET Compact Framework. | sVersion |
Top

Expand image See Also

Reference

clsApplikation Class


clsApplikation.bAktiv Property

clsApplikation.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsApplikation Class
clsApplikation Members


clsApplikation.bShowlogin Property

clsApplikation.bShowlogin Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bShowlogin() As SqlBoolean
C#
public SqlBoolean bShowlogin {get; set;}
C++
public:
property SqlBoolean bShowlogin {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bShowlogin() : SqlBoolean;
public function set bShowlogin(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bShowlogin]() As SqlBoolean
            Get
                Return m_bShowlogin
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bShowlogin = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsApplikation Class
clsApplikation Members


clsApplikation.daErstellt_am Property

clsApplikation.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsApplikation Class
clsApplikation Members


clsApplikation.daMutiert_am Property

clsApplikation.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsApplikation Class
clsApplikation Members


clsApplikation.iApplikationsnr Property

clsApplikation.iApplikationsnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iApplikationsnr() As SqlInt32
C#
public SqlInt32 iApplikationsnr {get; set;}
C++
public:
property SqlInt32 iApplikationsnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iApplikationsnr() : SqlInt32;
public function set iApplikationsnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iApplikationsnr]() As SqlInt32
            Get
                Return m_iApplikationsnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iApplikationsnrTmp As SqlInt32 = Value
                If iApplikationsnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iApplikationsnr", "iApplikationsnr can't be NULL")
                End If
                m_iApplikationsnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsApplikation Class
clsApplikation Members


clsApplikation.iMandantnr Property

clsApplikation.iMandantnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandantnr() As SqlInt32
C#
public SqlInt32 iMandantnr {get; set;}
C++
public:
property SqlInt32 iMandantnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsApplikation Class
clsApplikation Members


clsApplikation.iMutierer Property

clsApplikation.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsApplikation Class
clsApplikation Members


clsApplikation.sTmp_filepath Property

clsApplikation.sTmp_filepath Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sTmp_filepath() As SqlString
C#
public SqlString sTmp_filepath {get; set;}
C++
public:
property SqlString sTmp_filepath {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sTmp_filepath() : SqlString;
public function set sTmp_filepath(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sTmp_filepath]() As SqlString
            Get
                Return m_sTmp_filepath
            End Get
            Set(ByVal Value As SqlString)
                m_sTmp_filepath = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsApplikation Class
clsApplikation Members


clsApplikation.sVersion Property

clsApplikation.sVersion Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sVersion() As SqlString
C#
public SqlString sVersion {get; set;}
C++
public:
property SqlString sVersion {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sVersion() : SqlString;
public function set sVersion(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sVersion]() As SqlString
            Get
                Return m_sVersion
            End Get
            Set(ByVal Value As SqlString)
                m_sVersion = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsApplikation Class
clsApplikation Members


clsApplikation Methods

clsApplikation Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsApplikation Class


clsApplikation.Delete Method

clsApplikation.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iApplikationsnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_applikation_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iapplikationsnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationsnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_applikation_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikation::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsApplikation Class
clsApplikation Members


clsApplikation.Insert Method

clsApplikation.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iApplikationsnr</LI> <LI>sVersion. May be SqlString.Null</LI> <LI>bShowlogin. May be SqlBoolean.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>sTmp_filepath. May be SqlString.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_applikation_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iapplikationsnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationsnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sversion", SqlDbType.VarChar, 4, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bshowlogin", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bShowlogin))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stmp_filepath", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTmp_filepath))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_applikation_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikation::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsApplikation Class
clsApplikation Members


clsApplikation.SelectAll Method

clsApplikation.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_applikation_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("applikation")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_applikation_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikation::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsApplikation Class
clsApplikation Members


clsApplikation.SelectOne Method

clsApplikation.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iApplikationsnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iApplikationsnr</LI> <LI>sVersion</LI> <LI>bShowlogin</LI> <LI>iMandantnr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>sTmp_filepath</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_applikation_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("applikation")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iapplikationsnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationsnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_applikation_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iApplikationsnr = New SqlInt32(CType(dtToReturn.Rows(0)("applikationsnr"), Integer))
                    If dtToReturn.Rows(0)("version") Is System.DBNull.Value Then
                        m_sVersion = SqlString.Null
                    Else
                        m_sVersion = New SqlString(CType(dtToReturn.Rows(0)("version"), String))
                    End If
                    If dtToReturn.Rows(0)("showlogin") Is System.DBNull.Value Then
                        m_bShowlogin = SqlBoolean.Null
                    Else
                        m_bShowlogin = New SqlBoolean(CType(dtToReturn.Rows(0)("showlogin"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("tmp_filepath") Is System.DBNull.Value Then
                        m_sTmp_filepath = SqlString.Null
                    Else
                        m_sTmp_filepath = New SqlString(CType(dtToReturn.Rows(0)("tmp_filepath"), String))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikation::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsApplikation Class
clsApplikation Members


clsApplikation.Update Method

clsApplikation.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iApplikationsnr</LI> <LI>sVersion. May be SqlString.Null</LI> <LI>bShowlogin. May be SqlBoolean.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>sTmp_filepath. May be SqlString.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_applikation_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iapplikationsnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationsnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sversion", SqlDbType.VarChar, 4, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bshowlogin", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bShowlogin))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stmp_filepath", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTmp_filepath))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_applikation_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikation::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsApplikation Class
clsApplikation Members


clsApplikation Fields

clsApplikation Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_bShowlogin |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iApplikationsnr |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_sTmp_filepath |
Supported by the .NET Compact Framework. | m_sVersion |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsApplikation Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bShowlogin, m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsApplikation Class
clsApplikation Members


m_bShowlogin Variable

m_bShowlogin Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bShowlogin As SqlBoolean
C#
private SqlBoolean m_bShowlogin;
C++
private:
SqlBoolean m_bShowlogin;
JScript
private m_bShowlogin : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bShowlogin, m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsApplikation Class
clsApplikation Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsApplikation Class
clsApplikation Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsApplikation Class
clsApplikation Members


m_iApplikationsnr Variable

m_iApplikationsnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iApplikationsnr As SqlInt32
C#
private SqlInt32 m_iApplikationsnr;
C++
private:
SqlInt32 m_iApplikationsnr;
JScript
private m_iApplikationsnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iApplikationsnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsApplikation Class
clsApplikation Members


m_iMandantnr Variable

m_iMandantnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandantnr As SqlInt32
C#
private SqlInt32 m_iMandantnr;
C++
private:
SqlInt32 m_iMandantnr;
JScript
private m_iMandantnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iApplikationsnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsApplikation Class
clsApplikation Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iApplikationsnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsApplikation Class
clsApplikation Members


m_sTmp_filepath Variable

m_sTmp_filepath Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sTmp_filepath As SqlString
C#
private SqlString m_sTmp_filepath;
C++
private:
SqlString m_sTmp_filepath;
JScript
private m_sTmp_filepath : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sTmp_filepath, m_sVersion As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsApplikation Class
clsApplikation Members


m_sVersion Variable

m_sVersion Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sVersion As SqlString
C#
private SqlString m_sVersion;
C++
private:
SqlString m_sVersion;
JScript
private m_sVersion : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sTmp_filepath, m_sVersion As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsApplikation Class
clsApplikation Members


clsConnectionProvider Class

clsConnectionProvider Class
See Also Members
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsConnectionProvider
C#
public class clsConnectionProvider
C++

public ref class clsConnectionProvider
JScript
public class clsConnectionProvider

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsConnectionProvider

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsConnectionProvider Members


clsConnectionProvider Members

clsConnectionProvider Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

The following tables list the members exposed by the clsConnectionProvider type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsConnectionProvider Constructor |
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bIsTransactionPending |
Supported by the .NET Compact Framework. | sConnectionString |
Supported by the .NET Compact Framework. | scoDBConnection |
Supported by the .NET Compact Framework. | stCurrentTransaction |
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | BeginTransaction |
Supported by the .NET Compact Framework. | CloseConnection |
Supported by the .NET Compact Framework. | CommitTransaction |
Supported by the .NET Compact Framework. | Dispose | (Overloaded)
Supported by the .NET Compact Framework. | OpenConnection |
Supported by the .NET Compact Framework. | RollbackTransaction |
Supported by the .NET Compact Framework. | SaveTransaction |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | InitClass |
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_alSavePoints |
Supported by the .NET Compact Framework. | m_bIsDisposed |
Supported by the .NET Compact Framework. | m_bIsTransactionPending |
Supported by the .NET Compact Framework. | m_scoDBConnection |
Supported by the .NET Compact Framework. | m_stCurrentTransaction |
Top

Expand image See Also

Reference

clsConnectionProvider Class


clsConnectionProvider Constructor

clsConnectionProvider Constructor

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsConnectionProvider();
C++

public:
System::Void clsConnectionProvider()
JScript
public function clsConnectionProvider();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Init the class
            InitClass()
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsConnectionProvider Class
clsConnectionProvider Members


clsConnectionProvider Properties

clsConnectionProvider Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bIsTransactionPending |
Supported by the .NET Compact Framework. | sConnectionString |
Supported by the .NET Compact Framework. | scoDBConnection |
Supported by the .NET Compact Framework. | stCurrentTransaction |
Top

Expand image See Also

Reference

clsConnectionProvider Class


clsConnectionProvider.bIsTransactionPending Property

clsConnectionProvider.bIsTransactionPending Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property bIsTransactionPending() As Boolean
C#
public bool bIsTransactionPending {get;}
C++
public:
property bool bIsTransactionPending {
 bool get( );
}
JScript
public function get bIsTransactionPending() : boolean;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public ReadOnly Property bIsTransactionPending() As Boolean
            Get
                Return m_bIsTransactionPending
            End Get
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsConnectionProvider Class
clsConnectionProvider Members


clsConnectionProvider.sConnectionString Property

clsConnectionProvider.sConnectionString Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public WriteOnly Property sConnectionString() As String
C#
public string sConnectionString {set;}
C++
public:
property String^ sConnectionString {
 void set(
   String^ value
 );
}
JScript
public function set sConnectionString(value : String);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public WriteOnly Property sConnectionString() As String
            Set (ByVal Value As String)
                m_scoDBConnection.ConnectionString = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsConnectionProvider Class
clsConnectionProvider Members


clsConnectionProvider.scoDBConnection Property

clsConnectionProvider.scoDBConnection Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property scoDBConnection() As SqlConnection
C#
public SqlConnection scoDBConnection {get;}
C++
public:
property SqlConnection^ scoDBConnection {
 SqlConnection^ get( );
}
JScript
public function get scoDBConnection() : SqlConnection;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public ReadOnly Property scoDBConnection() As SqlConnection
            Get
                Return m_scoDBConnection
            End Get
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsConnectionProvider Class
clsConnectionProvider Members


clsConnectionProvider.stCurrentTransaction Property

clsConnectionProvider.stCurrentTransaction Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property stCurrentTransaction() As SqlTransaction
C#
public SqlTransaction stCurrentTransaction {get;}
C++
public:
property SqlTransaction^ stCurrentTransaction {
 SqlTransaction^ get( );
}
JScript
public function get stCurrentTransaction() : SqlTransaction;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public ReadOnly Property stCurrentTransaction() As SqlTransaction
            Get
                Return m_stCurrentTransaction
            End Get
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsConnectionProvider Class
clsConnectionProvider Members


clsConnectionProvider Methods

clsConnectionProvider Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | BeginTransaction |
Supported by the .NET Compact Framework. | CloseConnection |
Supported by the .NET Compact Framework. | CommitTransaction |
Supported by the .NET Compact Framework. | Dispose | (Overloaded)
Supported by the .NET Compact Framework. | OpenConnection |
Supported by the .NET Compact Framework. | RollbackTransaction |
Supported by the .NET Compact Framework. | SaveTransaction |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | InitClass |
Top

Expand image See Also

Reference

clsConnectionProvider Class


clsConnectionProvider.BeginTransaction Method

clsConnectionProvider.BeginTransaction Method

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function BeginTransaction( _
   ByRef sTransactionName As String _
) As Boolean
C#
public bool BeginTransaction(
   ref string sTransactionName
);
C++

public:
bool BeginTransaction(
   String^& sTransactionName
)
JScript
public function BeginTransaction(
    sTransactionName : String
) : boolean;

Parameters

sTransactionName

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function BeginTransaction(sTransactionName As String) As Boolean
            Try
                If m_bIsTransactionPending Then
                    ' // no nested transactions allowed.
                    Throw New Exception("BeginTransaction::Already transaction pending. Nesting not allowed")
                End If
                If (m_scoDBConnection.State And ConnectionState.Open) = 0 Then
                    ' // no open connection
                    Throw New Exception("BeginTransaction::Connection is not open.")
                End If
                ' // begin the transaction and store the transaction object.
                m_stCurrentTransaction = m_scoDBConnection.BeginTransaction(IsolationLevel.ReadCommitted, sTransactionName)
                m_bIsTransactionPending = True
                Return True
            Catch ex As Exception
                ' // bubble exception
                Throw ex
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsConnectionProvider Class
clsConnectionProvider Members


clsConnectionProvider.CloseConnection Method

clsConnectionProvider.CloseConnection Method

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function CloseConnection( _
   ByRef bCommitPendingTransaction As Boolean _
) As Boolean
C#
public bool CloseConnection(
   ref bool bCommitPendingTransaction
);
C++

public:
bool CloseConnection(
   bool& bCommitPendingTransaction
)
JScript
public function CloseConnection(
    bCommitPendingTransaction : boolean
) : boolean;

Parameters

bCommitPendingTransaction

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function CloseConnection(bCommitPendingTransaction As Boolean) As Boolean
            Try
                If (m_scoDBConnection.State And ConnectionState.Open) = 0 Then
                    ' // No open connection
                    Return False
                End If
                If m_bIsTransactionPending Then
                    If bCommitPendingTransaction Then
                        ' // Commit the pending transaction
                        m_stCurrentTransaction.Commit()
                    Else
                        ' // Rollback the pending transaction
                        m_stCurrentTransaction.Rollback()
                    End If
                    m_bIsTransactionPending = False
                    m_stCurrentTransaction.Dispose()
                    m_stCurrentTransaction = Nothing
                    m_alSavePoints.Clear()
                End If
                ' // close the connection
                m_scoDBConnection.Close()
                Return True
            Catch ex As Exception
                ' // bubble exception
                Throw ex
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsConnectionProvider Class
clsConnectionProvider Members


clsConnectionProvider.CommitTransaction Method

clsConnectionProvider.CommitTransaction Method

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function CommitTransaction() As Boolean
C#
public bool CommitTransaction();
C++

public:
bool CommitTransaction()
JScript
public function CommitTransaction() : boolean;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function CommitTransaction() As Boolean
            Try
                If Not m_bIsTransactionPending Then
                    ' // no transaction pending
                    Throw New Exception("CommitTransaction::No transaction pending.")
                End If
                If (m_scoDBConnection.State And ConnectionState.Open) = 0 Then
                    ' // no open connection
                    Throw New Exception("CommitTransaction::Connection is not open.")
                End if
                ' // commit the transaction
                m_stCurrentTransaction.Commit()
                m_bIsTransactionPending = False
                m_stCurrentTransaction.Dispose()
                m_stCurrentTransaction = Nothing
                m_alSavePoints.Clear()
                Return True
            Catch ex As Exception
                ' // bubble exception
                Throw ex
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsConnectionProvider Class
clsConnectionProvider Members


clsConnectionProvider.Dispose Method

clsConnectionProvider.Dispose Method

Expand image Overload List

Name | Description
public System.Void Dispose(); |
protected virtual System.Void Dispose(bool); |

Expand image See Also

Reference

clsConnectionProvider Class
clsConnectionProvider Members


clsConnectionProvider.InitClass Method

clsConnectionProvider.InitClass Method

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub InitClass()
C#
private System.Void InitClass();
C++

private:
System::Void InitClass()
JScript
private function InitClass();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Sub InitClass()
            ' // Create all the objects and initialize other members.
            m_scoDBConnection = new SqlConnection()
            m_bIsDisposed = False
            m_stCurrentTransaction = Nothing
            m_bIsTransactionPending = False
            m_alSavePoints = new ArrayList()
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsConnectionProvider Class
clsConnectionProvider Members


clsConnectionProvider.OpenConnection Method

clsConnectionProvider.OpenConnection Method

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function OpenConnection() As Boolean
C#
public bool OpenConnection();
C++

public:
bool OpenConnection()
JScript
public function OpenConnection() : boolean;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function OpenConnection() As Boolean
            Try
                If (m_scoDBConnection.State And ConnectionState.Open) > 0 Then
                    ' // It's already open.
                    Throw New Exception("OpenConnection::Connection is already open.")
                End If
                m_scoDBConnection.Open()
                m_bIsTransactionPending = False
                m_alSavePoints.Clear()
                Return True
            Catch ex As Exception
                ' // bubble exception
                Throw ex
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsConnectionProvider Class
clsConnectionProvider Members


clsConnectionProvider.RollbackTransaction Method

clsConnectionProvider.RollbackTransaction Method

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function RollbackTransaction( _
   ByRef sTransactionToRollback As String _
) As Boolean
C#
public bool RollbackTransaction(
   ref string sTransactionToRollback
);
C++

public:
bool RollbackTransaction(
   String^& sTransactionToRollback
)
JScript
public function RollbackTransaction(
    sTransactionToRollback : String
) : boolean;

Parameters

sTransactionToRollback

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function RollbackTransaction(sTransactionToRollback As String) As Boolean
            Try
                If Not m_bIsTransactionPending Then
                    ' // no transaction pending
                    Throw New Exception("RollbackTransaction::No transaction pending.")
                End If
                If (m_scoDBConnection.State And ConnectionState.Open) = 0 Then
                    ' // no open connection
                    Throw New Exception("RollbackTransaction::Connection is not open.")
                End If
                ' // rollback the transaction
                m_stCurrentTransaction.Rollback(sTransactionToRollback)
                ' // if this wasn't a savepoint, we've rolled back the complete transaction, so we
                ' // can clean it up.
                If Not m_alSavePoints.Contains(sTransactionToRollback) Then
                    ' // it's not a savepoint
                    m_bIsTransactionPending = False
                    m_stCurrentTransaction.Dispose()
                    m_stCurrentTransaction = Nothing
                    m_alSavePoints.Clear()
                End If
                Return True
            Catch ex As Exception
                ' // bubble exception
                Throw ex
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsConnectionProvider Class
clsConnectionProvider Members


clsConnectionProvider.SaveTransaction Method

clsConnectionProvider.SaveTransaction Method

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function SaveTransaction( _
   ByRef sSavePointName As String _
) As Boolean
C#
public bool SaveTransaction(
   ref string sSavePointName
);
C++

public:
bool SaveTransaction(
   String^& sSavePointName
)
JScript
public function SaveTransaction(
    sSavePointName : String
) : boolean;

Parameters

sSavePointName

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function SaveTransaction(sSavePointName As String) As Boolean
            Try
                If Not m_bIsTransactionPending Then
                    ' // no transaction pending
                    Throw New Exception("SaveTransaction::No transaction pending.")
                End If
                If (m_scoDBConnection.State And ConnectionState.Open) = 0 Then
                    ' // no open connection
                    Throw New Exception("SaveTransaction::Connection is not open.")
                End If
                ' // save the transaction
                m_stCurrentTransaction.Save(sSavePointName)
                ' // Store the savepoint in the list.
                m_alSavePoints.Add(sSavePointName)
                Return True
            Catch ex As Exception
                ' // bubble exception
                Throw ex
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsConnectionProvider Class
clsConnectionProvider Members


clsConnectionProvider Fields

clsConnectionProvider Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_alSavePoints |
Supported by the .NET Compact Framework. | m_bIsDisposed |
Supported by the .NET Compact Framework. | m_bIsTransactionPending |
Supported by the .NET Compact Framework. | m_scoDBConnection |
Supported by the .NET Compact Framework. | m_stCurrentTransaction |
Top

Expand image See Also

Reference

clsConnectionProvider Class


m_alSavePoints Variable

m_alSavePoints Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_alSavePoints As ArrayList
C#
private ArrayList m_alSavePoints;
C++
private:
ArrayList^ m_alSavePoints;
JScript
private m_alSavePoints : ArrayList

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private		m_alSavePoints As ArrayList

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsConnectionProvider Class
clsConnectionProvider Members


m_bIsDisposed Variable

m_bIsDisposed Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bIsDisposed As Boolean
C#
private bool m_bIsDisposed;
C++
private:
bool m_bIsDisposed;
JScript
private m_bIsDisposed : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private		m_bIsTransactionPending, m_bIsDisposed As Boolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsConnectionProvider Class
clsConnectionProvider Members


m_bIsTransactionPending Variable

m_bIsTransactionPending Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bIsTransactionPending As Boolean
C#
private bool m_bIsTransactionPending;
C++
private:
bool m_bIsTransactionPending;
JScript
private m_bIsTransactionPending : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private		m_bIsTransactionPending, m_bIsDisposed As Boolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsConnectionProvider Class
clsConnectionProvider Members


m_scoDBConnection Variable

m_scoDBConnection Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_scoDBConnection As SqlConnection
C#
private SqlConnection m_scoDBConnection;
C++
private:
SqlConnection^ m_scoDBConnection;
JScript
private m_scoDBConnection : SqlConnection

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private		m_scoDBConnection As SqlConnection

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsConnectionProvider Class
clsConnectionProvider Members


m_stCurrentTransaction Variable

m_stCurrentTransaction Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_stCurrentTransaction As SqlTransaction
C#
private SqlTransaction m_stCurrentTransaction;
C++
private:
SqlTransaction^ m_stCurrentTransaction;
JScript
private m_stCurrentTransaction : SqlTransaction

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private		m_stCurrentTransaction As SqlTransaction

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsConnectionProvider Class
clsConnectionProvider Members


clsDBInteractionBase Class

clsDBInteractionBase Class
See Also Members
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public MustInherit Class clsDBInteractionBase
    Implements ICommonDBAccess
C#
public abstract class clsDBInteractionBase : ICommonDBAccess
C++

public ref class clsDBInteractionBase abstract  : public ICommonDBAccess^
JScript
public abstract class clsDBInteractionBase
   implements ICommonDBAccess

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsApplikation
Vertragsverwaltung.TKB.VV.DB.clsDokument
Vertragsverwaltung.TKB.VV.DB.clsDokumenttyp
Vertragsverwaltung.TKB.VV.DB.clsFunktionsgruppe
Vertragsverwaltung.TKB.VV.DB.clsFunktionsgruppe_rolle
Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle
Vertragsverwaltung.TKB.VV.DB.clsKontakttyp
Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist
Vertragsverwaltung.TKB.VV.DB.clsMandant
Vertragsverwaltung.TKB.VV.DB.clsMeldungstexte
Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter
Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter_funktionsgruppe
Vertragsverwaltung.TKB.VV.DB.clsPerson
Vertragsverwaltung.TKB.VV.DB.clsRolle
Vertragsverwaltung.TKB.VV.DB.clsRolle_SecurityObject
Vertragsverwaltung.TKB.VV.DB.clsRolle_securitylevel
Vertragsverwaltung.TKB.VV.DB.clsRolle_sysadminfunktion
Vertragsverwaltung.TKB.VV.DB.clsSLAKatalog
Vertragsverwaltung.TKB.VV.DB.clsSLATyp
Vertragsverwaltung.TKB.VV.DB.clsSecurityLevel
Vertragsverwaltung.TKB.VV.DB.clsSecurityObject
Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog
Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog_SLAKatalog
Vertragsverwaltung.TKB.VV.DB.clsSpalten
Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion
Vertragsverwaltung.TKB.VV.DB.clsVertragselement
Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt
Vertragsverwaltung.TKB.VV.DB.clsVertragspartner
Vertragsverwaltung.TKB.VV.DB.clsVertragstyp
Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDBInteractionBase Members


clsDBInteractionBase Members

clsDBInteractionBase Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

The following tables list the members exposed by the clsDBInteractionBase type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsDBInteractionBase Constructor |
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | cpMainConnectionProvider |
Supported by the .NET Compact Framework. | iErrorCode |
Supported by the .NET Compact Framework. | iRowsAffected |
Supported by the .NET Compact Framework. | sConnectionString |
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded)
Supported by the .NET Compact Framework. | Insert |
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Supported by the .NET Compact Framework. | Update |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | InitClass |
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bIsDisposed |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider |
Supported by the .NET Compact Framework. | m_iErrorCode |
Supported by the .NET Compact Framework. | m_iRowsAffected |
Supported by the .NET Compact Framework. | m_sConnectionString |
Supported by the .NET Compact Framework. | m_scoMainConnection |
Top

Expand image See Also

Reference

clsDBInteractionBase Class


clsDBInteractionBase Constructor

clsDBInteractionBase Constructor

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsDBInteractionBase();
C++

public:
System::Void clsDBInteractionBase()
JScript
public function clsDBInteractionBase();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Initialize the class' members.
            InitClass()
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase Members


clsDBInteractionBase Properties

clsDBInteractionBase Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | cpMainConnectionProvider |
Supported by the .NET Compact Framework. | iErrorCode |
Supported by the .NET Compact Framework. | iRowsAffected |
Supported by the .NET Compact Framework. | sConnectionString |
Top

Expand image See Also

Reference

clsDBInteractionBase Class


clsDBInteractionBase Methods

clsDBInteractionBase Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded)
Supported by the .NET Compact Framework. | Insert |
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Supported by the .NET Compact Framework. | Update |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | InitClass |
Top

Expand image See Also

Reference

clsDBInteractionBase Class


clsDBInteractionBase.Delete Method

clsDBInteractionBase.Delete Method

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overridable Function Delete() As Boolean Implements  _
   ICommonDBAccess.Delete
C#
public virtual bool Delete();
C++

public:
bool Delete() virtual
JScript
public function Delete() : boolean;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Overridable Function Delete() As Boolean Implements ICommonDBAccess.Delete
            ' // No implementation, throw exception
            Throw New NotImplementedException()
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase Members


clsDBInteractionBase.InitClass Method

clsDBInteractionBase.InitClass Method

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub InitClass()
C#
private System.Void InitClass();
C++

private:
System::Void InitClass()
JScript
private function InitClass();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Sub InitClass()
            ' // create all the objects and initialize other members.
            m_scoMainConnection = new SqlConnection()
            m_bMainConnectionIsCreatedLocal = True
            m_cpMainConnectionProvider = Nothing
            m_iErrorCode = New SqlInt32(LLBLError.AllOk)
            m_bIsDisposed = False
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase Members


clsDBInteractionBase.Insert Method

clsDBInteractionBase.Insert Method

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overridable Function Insert() As Boolean Implements  _
   ICommonDBAccess.Insert
C#
public virtual bool Insert();
C++

public:
bool Insert() virtual
JScript
public function Insert() : boolean;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Overridable Function Insert() As Boolean Implements ICommonDBAccess.Insert
            ' // No implementation, throw exception
            Throw New NotImplementedException()
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase Members


clsDBInteractionBase.SelectAll Method

clsDBInteractionBase.SelectAll Method

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overridable Function SelectAll() As DataTable Implements  _
   ICommonDBAccess.SelectAll
C#
public virtual DataTable SelectAll();
C++

public:
DataTable^ SelectAll() virtual
JScript
public function SelectAll() : DataTable;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Overridable Function SelectAll() As DataTable Implements ICommonDBAccess.SelectAll
            ' // No implementation, throw exception
            Throw New NotImplementedException()
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase Members


clsDBInteractionBase.SelectOne Method

clsDBInteractionBase.SelectOne Method

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overridable Function SelectOne() As DataTable Implements  _
   ICommonDBAccess.SelectOne
C#
public virtual DataTable SelectOne();
C++

public:
DataTable^ SelectOne() virtual
JScript
public function SelectOne() : DataTable;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Overridable Function SelectOne() As DataTable Implements ICommonDBAccess.SelectOne
            ' // No implementation, throw exception
            Throw New NotImplementedException()
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase Members


clsDBInteractionBase.Update Method

clsDBInteractionBase.Update Method

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overridable Function Update() As Boolean Implements  _
   ICommonDBAccess.Update
C#
public virtual bool Update();
C++

public:
bool Update() virtual
JScript
public function Update() : boolean;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Overridable Function Update() As Boolean Implements ICommonDBAccess.Update
            ' // No implementation, throw exception
            Throw New NotImplementedException()
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase Members


clsDBInteractionBase Fields

clsDBInteractionBase Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bIsDisposed |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider |
Supported by the .NET Compact Framework. | m_iErrorCode |
Supported by the .NET Compact Framework. | m_iRowsAffected |
Supported by the .NET Compact Framework. | m_sConnectionString |
Supported by the .NET Compact Framework. | m_scoMainConnection |
Top

Expand image See Also

Reference

clsDBInteractionBase Class


m_bIsDisposed Variable

m_bIsDisposed Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bIsDisposed As Boolean
C#
private bool m_bIsDisposed;
C++
private:
bool m_bIsDisposed;
JScript
private m_bIsDisposed : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private		m_bIsDisposed As Boolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase Members


m_sConnectionString Variable

m_sConnectionString Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sConnectionString As String
C#
private string m_sConnectionString;
C++
private:
String^ m_sConnectionString;
JScript
private m_sConnectionString : String

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private		m_sConnectionString As String

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase Members


clsDokument Class

clsDokument Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'Dokument'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsDokument
    Inherits clsDBInteractionBase
C#
public class clsDokument : clsDBInteractionBase
C++

public ref class clsDokument : public clsDBInteractionBase^
JScript
public class clsDokument
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsDokument
Vertragsverwaltung.TKB.VV.Vertrag.clsDok

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Members


clsDokument Members

clsDokument Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'Dokument'.

The following tables list the members exposed by the clsDokument type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsDokument Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | blobDocImage |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | daVersionsdatum |
Supported by the .NET Compact Framework. | iDokumentNr |
Supported by the .NET Compact Framework. | iDokumenttypNr |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr |
Supported by the .NET Compact Framework. | iVertragselementNr |
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sFilename |
Supported by the .NET Compact Framework. | sOriginalFilename_incl_Path |
Supported by the .NET Compact Framework. | sVersion |
Supported by the .NET Compact Framework. | sVersionsNr |
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_blobDocImage |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_daVersionsdatum |
Supported by the .NET Compact Framework. | m_iDokumentNr |
Supported by the .NET Compact Framework. | m_iDokumenttypNr |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSecurityLevelNr |
Supported by the .NET Compact Framework. | m_iVertragselementNr |
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_sFilename |
Supported by the .NET Compact Framework. | m_sOriginalFilename_incl_Path |
Supported by the .NET Compact Framework. | m_sVersion |
Supported by the .NET Compact Framework. | m_sVersionsNr |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsDokument Class


clsDokument Constructor

clsDokument Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsDokument();
C++

public:
System::Void clsDokument()
JScript
public function clsDokument();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


clsDokument Properties

clsDokument Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | blobDocImage |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | daVersionsdatum |
Supported by the .NET Compact Framework. | iDokumentNr |
Supported by the .NET Compact Framework. | iDokumenttypNr |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr |
Supported by the .NET Compact Framework. | iVertragselementNr |
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sFilename |
Supported by the .NET Compact Framework. | sOriginalFilename_incl_Path |
Supported by the .NET Compact Framework. | sVersion |
Supported by the .NET Compact Framework. | sVersionsNr |
Top

Expand image See Also

Reference

clsDokument Class


clsDokument.bAktiv Property

clsDokument.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


clsDokument.blobDocImage Property

clsDokument.blobDocImage Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property blobDocImage() As SqlBinary
C#
public SqlBinary blobDocImage {get; set;}
C++
public:
property SqlBinary blobDocImage {
 SqlBinary get( );
 void set(
   SqlBinary value
 );
}
JScript
public function get blobDocImage() : SqlBinary;
public function set blobDocImage(value : SqlBinary);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [blobDocImage]() As SqlBinary
            Get
                Return m_blobDocImage
            End Get
            Set(ByVal Value As SqlBinary)
                m_blobDocImage = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


clsDokument.daErstellt_am Property

clsDokument.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


clsDokument.daMutiert_am Property

clsDokument.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


clsDokument.daVersionsdatum Property

clsDokument.daVersionsdatum Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daVersionsdatum() As SqlDateTime
C#
public SqlDateTime daVersionsdatum {get; set;}
C++
public:
property SqlDateTime daVersionsdatum {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daVersionsdatum() : SqlDateTime;
public function set daVersionsdatum(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daVersionsdatum]() As SqlDateTime
            Get
                Return m_daVersionsdatum
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daVersionsdatum = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


clsDokument.iDokumentNr Property

clsDokument.iDokumentNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iDokumentNr() As SqlInt32
C#
public SqlInt32 iDokumentNr {get; set;}
C++
public:
property SqlInt32 iDokumentNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iDokumentNr() : SqlInt32;
public function set iDokumentNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iDokumentNr]() As SqlInt32
            Get
                Return m_iDokumentNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iDokumentNrTmp As SqlInt32 = Value
                If iDokumentNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iDokumentNr", "iDokumentNr can't be NULL")
                End If
                m_iDokumentNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


clsDokument.iDokumenttypNr Property

clsDokument.iDokumenttypNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iDokumenttypNr() As SqlInt32
C#
public SqlInt32 iDokumenttypNr {get; set;}
C++
public:
property SqlInt32 iDokumenttypNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iDokumenttypNr() : SqlInt32;
public function set iDokumenttypNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iDokumenttypNr]() As SqlInt32
            Get
                Return m_iDokumenttypNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumenttypNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


clsDokument.iMutierer Property

clsDokument.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


clsDokument.iSecurityLevelNr Property

clsDokument.iSecurityLevelNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iSecurityLevelNr() As SqlInt32
C#
public SqlInt32 iSecurityLevelNr {get; set;}
C++
public:
property SqlInt32 iSecurityLevelNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iSecurityLevelNr() : SqlInt32;
public function set iSecurityLevelNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iSecurityLevelNr]() As SqlInt32
            Get
                Return m_iSecurityLevelNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityLevelNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


clsDokument.iVertragselementNr Property

clsDokument.iVertragselementNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iVertragselementNr() As SqlInt32
C#
public SqlInt32 iVertragselementNr {get; set;}
C++
public:
property SqlInt32 iVertragselementNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iVertragselementNr() : SqlInt32;
public function set iVertragselementNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iVertragselementNr]() As SqlInt32
            Get
                Return m_iVertragselementNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVertragselementNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


clsDokument.sBeschreibung Property

clsDokument.sBeschreibung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBeschreibung() As SqlString
C#
public SqlString sBeschreibung {get; set;}
C++
public:
property SqlString sBeschreibung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBeschreibung() : SqlString;
public function set sBeschreibung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


clsDokument.sBezeichnung Property

clsDokument.sBezeichnung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBezeichnung() As SqlString
C#
public SqlString sBezeichnung {get; set;}
C++
public:
property SqlString sBezeichnung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBezeichnung() : SqlString;
public function set sBezeichnung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


clsDokument.sFilename Property

clsDokument.sFilename Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sFilename() As SqlString
C#
public SqlString sFilename {get; set;}
C++
public:
property SqlString sFilename {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sFilename() : SqlString;
public function set sFilename(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sFilename]() As SqlString
            Get
                Return m_sFilename
            End Get
            Set(ByVal Value As SqlString)
                m_sFilename = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


clsDokument.sOriginalFilename_incl_Path Property

clsDokument.sOriginalFilename_incl_Path Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sOriginalFilename_incl_Path() As SqlString
C#
public SqlString sOriginalFilename_incl_Path {get; set;}
C++
public:
property SqlString sOriginalFilename_incl_Path {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sOriginalFilename_incl_Path() : SqlString;
public function set sOriginalFilename_incl_Path(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sOriginalFilename_incl_Path]() As SqlString
            Get
                Return m_sOriginalFilename_incl_Path
            End Get
            Set(ByVal Value As SqlString)
                m_sOriginalFilename_incl_Path = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


clsDokument.sVersion Property

clsDokument.sVersion Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sVersion() As SqlString
C#
public SqlString sVersion {get; set;}
C++
public:
property SqlString sVersion {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sVersion() : SqlString;
public function set sVersion(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sVersion]() As SqlString
            Get
                Return m_sVersion
            End Get
            Set(ByVal Value As SqlString)
                m_sVersion = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


clsDokument.sVersionsNr Property

clsDokument.sVersionsNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sVersionsNr() As SqlString
C#
public SqlString sVersionsNr {get; set;}
C++
public:
property SqlString sVersionsNr {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sVersionsNr() : SqlString;
public function set sVersionsNr(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sVersionsNr]() As SqlString
            Get
                Return m_sVersionsNr
            End Get
            Set(ByVal Value As SqlString)
                m_sVersionsNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


clsDokument Methods

clsDokument Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsDokument Class


clsDokument.Delete Method

clsDokument.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iDokumentNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Dokument_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumentNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Dokument_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokument::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


clsDokument.Insert Method

clsDokument.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iDokumentNr</LI> <LI>iVertragselementNr. May be SqlInt32.Null</LI> <LI>iDokumenttypNr. May be SqlInt32.Null</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>sFilename. May be SqlString.Null</LI> <LI>sOriginalFilename_incl_Path. May be SqlString.Null</LI> <LI>sVersion. May be SqlString.Null</LI> <LI>sVersionsNr. May be SqlString.Null</LI> <LI>daVersionsdatum. May be SqlDateTime.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>blobDocImage. May be SqlBinary.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Dokument_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumentNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumenttypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sFilename", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFilename))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sOriginalFilename_incl_Path", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sOriginalFilename_incl_Path))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVersion", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVersionsNr", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersionsNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daVersionsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daVersionsdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                Dim	iLength As Integer = 0
                If Not m_blobDocImage.IsNull Then
                    iLength = m_blobDocImage.Length
                End If
                scmCmdToExecute.Parameters.Add(New SqlParameter("@blobDocImage", SqlDbType.Image, iLength, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_blobDocImage))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Dokument_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokument::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


clsDokument.SelectAll Method

clsDokument.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Dokument_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Dokument")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Dokument_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokument::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


clsDokument.SelectOne Method

clsDokument.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iDokumentNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iDokumentNr</LI> <LI>iVertragselementNr</LI> <LI>iDokumenttypNr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>sFilename</LI> <LI>sOriginalFilename_incl_Path</LI> <LI>sVersion</LI> <LI>sVersionsNr</LI> <LI>daVersionsdatum</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>bAktiv</LI> <LI>iSecurityLevelNr</LI> <LI>blobDocImage</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Dokument_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Dokument")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iDokumentNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Dokument_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iDokumentNr = New SqlInt32(CType(dtToReturn.Rows(0)("DokumentNr"), Integer))
                    If dtToReturn.Rows(0)("VertragselementNr") Is System.DBNull.Value Then
                        m_iVertragselementNr = SqlInt32.Null
                    Else
                        m_iVertragselementNr = New SqlInt32(CType(dtToReturn.Rows(0)("VertragselementNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("DokumenttypNr") Is System.DBNull.Value Then
                        m_iDokumenttypNr = SqlInt32.Null
                    Else
                        m_iDokumenttypNr = New SqlInt32(CType(dtToReturn.Rows(0)("DokumenttypNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Filename") Is System.DBNull.Value Then
                        m_sFilename = SqlString.Null
                    Else
                        m_sFilename = New SqlString(CType(dtToReturn.Rows(0)("Filename"), String))
                    End If
                    If dtToReturn.Rows(0)("OriginalFilename_incl_Path") Is System.DBNull.Value Then
                        m_sOriginalFilename_incl_Path = SqlString.Null
                    Else
                        m_sOriginalFilename_incl_Path = New SqlString(CType(dtToReturn.Rows(0)("OriginalFilename_incl_Path"), String))
                    End If
                    If dtToReturn.Rows(0)("Version") Is System.DBNull.Value Then
                        m_sVersion = SqlString.Null
                    Else
                        m_sVersion = New SqlString(CType(dtToReturn.Rows(0)("Version"), String))
                    End If
                    If dtToReturn.Rows(0)("VersionsNr") Is System.DBNull.Value Then
                        m_sVersionsNr = SqlString.Null
                    Else
                        m_sVersionsNr = New SqlString(CType(dtToReturn.Rows(0)("VersionsNr"), String))
                    End If
                    If dtToReturn.Rows(0)("Versionsdatum") Is System.DBNull.Value Then
                        m_daVersionsdatum = SqlDateTime.Null
                    Else
                        m_daVersionsdatum = New SqlDateTime(CType(dtToReturn.Rows(0)("Versionsdatum"), Date))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("SecurityLevelNr") Is System.DBNull.Value Then
                        m_iSecurityLevelNr = SqlInt32.Null
                    Else
                        m_iSecurityLevelNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevelNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("DocImage") Is System.DBNull.Value Then
                        m_blobDocImage = SqlBinary.Null
                    Else
                        m_blobDocImage = New SqlBinary(CType(dtToReturn.Rows(0)("DocImage"), Byte()))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokument::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


clsDokument.Update Method

clsDokument.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iDokumentNr</LI> <LI>iVertragselementNr. May be SqlInt32.Null</LI> <LI>iDokumenttypNr. May be SqlInt32.Null</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>sFilename. May be SqlString.Null</LI> <LI>sOriginalFilename_incl_Path. May be SqlString.Null</LI> <LI>sVersion. May be SqlString.Null</LI> <LI>sVersionsNr. May be SqlString.Null</LI> <LI>daVersionsdatum. May be SqlDateTime.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>blobDocImage. May be SqlBinary.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Dokument_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumentNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumenttypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sFilename", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFilename))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sOriginalFilename_incl_Path", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sOriginalFilename_incl_Path))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVersion", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVersionsNr", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersionsNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daVersionsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daVersionsdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                Dim	iLength As Integer = 0
                If Not m_blobDocImage.IsNull Then
                    iLength = m_blobDocImage.Length
                End If
                scmCmdToExecute.Parameters.Add(New SqlParameter("@blobDocImage", SqlDbType.Image, iLength, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_blobDocImage))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Dokument_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokument::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


clsDokument Fields

clsDokument Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_blobDocImage |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_daVersionsdatum |
Supported by the .NET Compact Framework. | m_iDokumentNr |
Supported by the .NET Compact Framework. | m_iDokumenttypNr |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSecurityLevelNr |
Supported by the .NET Compact Framework. | m_iVertragselementNr |
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_sFilename |
Supported by the .NET Compact Framework. | m_sOriginalFilename_incl_Path |
Supported by the .NET Compact Framework. | m_sVersion |
Supported by the .NET Compact Framework. | m_sVersionsNr |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsDokument Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


m_blobDocImage Variable

m_blobDocImage Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_blobDocImage As SqlBinary
C#
private SqlBinary m_blobDocImage;
C++
private:
SqlBinary m_blobDocImage;
JScript
private m_blobDocImage : SqlBinary

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_blobDocImage As SqlBinary

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daVersionsdatum, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daVersionsdatum, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


m_daVersionsdatum Variable

m_daVersionsdatum Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daVersionsdatum As SqlDateTime
C#
private SqlDateTime m_daVersionsdatum;
C++
private:
SqlDateTime m_daVersionsdatum;
JScript
private m_daVersionsdatum : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daVersionsdatum, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


m_iDokumentNr Variable

m_iDokumentNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iDokumentNr As SqlInt32
C#
private SqlInt32 m_iDokumentNr;
C++
private:
SqlInt32 m_iDokumentNr;
JScript
private m_iDokumentNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iSecurityLevelNr, m_iDokumentNr, m_iDokumenttypNr, m_iVertragselementNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


m_iDokumenttypNr Variable

m_iDokumenttypNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iDokumenttypNr As SqlInt32
C#
private SqlInt32 m_iDokumenttypNr;
C++
private:
SqlInt32 m_iDokumenttypNr;
JScript
private m_iDokumenttypNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iSecurityLevelNr, m_iDokumentNr, m_iDokumenttypNr, m_iVertragselementNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iSecurityLevelNr, m_iDokumentNr, m_iDokumenttypNr, m_iVertragselementNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


m_iSecurityLevelNr Variable

m_iSecurityLevelNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iSecurityLevelNr As SqlInt32
C#
private SqlInt32 m_iSecurityLevelNr;
C++
private:
SqlInt32 m_iSecurityLevelNr;
JScript
private m_iSecurityLevelNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iSecurityLevelNr, m_iDokumentNr, m_iDokumenttypNr, m_iVertragselementNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


m_iVertragselementNr Variable

m_iVertragselementNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iVertragselementNr As SqlInt32
C#
private SqlInt32 m_iVertragselementNr;
C++
private:
SqlInt32 m_iVertragselementNr;
JScript
private m_iVertragselementNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iSecurityLevelNr, m_iDokumentNr, m_iDokumenttypNr, m_iVertragselementNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


m_sBeschreibung Variable

m_sBeschreibung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBeschreibung As SqlString
C#
private SqlString m_sBeschreibung;
C++
private:
SqlString m_sBeschreibung;
JScript
private m_sBeschreibung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBezeichnung, m_sVersion, m_sOriginalFilename_incl_Path, m_sVersionsNr, m_sBeschreibung, m_sFilename As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


m_sBezeichnung Variable

m_sBezeichnung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBezeichnung As SqlString
C#
private SqlString m_sBezeichnung;
C++
private:
SqlString m_sBezeichnung;
JScript
private m_sBezeichnung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBezeichnung, m_sVersion, m_sOriginalFilename_incl_Path, m_sVersionsNr, m_sBeschreibung, m_sFilename As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


m_sFilename Variable

m_sFilename Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sFilename As SqlString
C#
private SqlString m_sFilename;
C++
private:
SqlString m_sFilename;
JScript
private m_sFilename : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBezeichnung, m_sVersion, m_sOriginalFilename_incl_Path, m_sVersionsNr, m_sBeschreibung, m_sFilename As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


m_sOriginalFilename_incl_Path Variable

m_sOriginalFilename_incl_Path Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sOriginalFilename_incl_Path As SqlString
C#
private SqlString m_sOriginalFilename_incl_Path;
C++
private:
SqlString m_sOriginalFilename_incl_Path;
JScript
private m_sOriginalFilename_incl_Path : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBezeichnung, m_sVersion, m_sOriginalFilename_incl_Path, m_sVersionsNr, m_sBeschreibung, m_sFilename As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


m_sVersion Variable

m_sVersion Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sVersion As SqlString
C#
private SqlString m_sVersion;
C++
private:
SqlString m_sVersion;
JScript
private m_sVersion : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBezeichnung, m_sVersion, m_sOriginalFilename_incl_Path, m_sVersionsNr, m_sBeschreibung, m_sFilename As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


m_sVersionsNr Variable

m_sVersionsNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sVersionsNr As SqlString
C#
private SqlString m_sVersionsNr;
C++
private:
SqlString m_sVersionsNr;
JScript
private m_sVersionsNr : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBezeichnung, m_sVersion, m_sOriginalFilename_incl_Path, m_sVersionsNr, m_sBeschreibung, m_sFilename As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokument Class
clsDokument Members


clsDokumenttyp Class

clsDokumenttyp Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'Dokumenttyp'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsDokumenttyp
    Inherits clsDBInteractionBase
C#
public class clsDokumenttyp : clsDBInteractionBase
C++

public ref class clsDokumenttyp : public clsDBInteractionBase^
JScript
public class clsDokumenttyp
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsDokumenttyp

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokumenttyp Members


clsDokumenttyp Members

clsDokumenttyp Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'Dokumenttyp'.

The following tables list the members exposed by the clsDokumenttyp type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsDokumenttyp Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iDokumenttypnr |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iDokumenttypnr |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsDokumenttyp Class


clsDokumenttyp Constructor

clsDokumenttyp Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsDokumenttyp();
C++

public:
System::Void clsDokumenttyp()
JScript
public function clsDokumenttyp();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokumenttyp Class
clsDokumenttyp Members


clsDokumenttyp Properties

clsDokumenttyp Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iDokumenttypnr |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsDokumenttyp Class


clsDokumenttyp.bAktiv Property

clsDokumenttyp.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokumenttyp Class
clsDokumenttyp Members


clsDokumenttyp.daErstellt_am Property

clsDokumenttyp.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokumenttyp Class
clsDokumenttyp Members


clsDokumenttyp.daMutiert_am Property

clsDokumenttyp.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokumenttyp Class
clsDokumenttyp Members


clsDokumenttyp.iDokumenttypnr Property

clsDokumenttyp.iDokumenttypnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iDokumenttypnr() As SqlInt32
C#
public SqlInt32 iDokumenttypnr {get; set;}
C++
public:
property SqlInt32 iDokumenttypnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iDokumenttypnr() : SqlInt32;
public function set iDokumenttypnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iDokumenttypnr]() As SqlInt32
            Get
                Return m_iDokumenttypnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iDokumenttypnrTmp As SqlInt32 = Value
                If iDokumenttypnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iDokumenttypnr", "iDokumenttypnr can't be NULL")
                End If
                m_iDokumenttypnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokumenttyp Class
clsDokumenttyp Members


clsDokumenttyp.iMutierer Property

clsDokumenttyp.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokumenttyp Class
clsDokumenttyp Members


clsDokumenttyp.sBezeichnung Property

clsDokumenttyp.sBezeichnung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBezeichnung() As SqlString
C#
public SqlString sBezeichnung {get; set;}
C++
public:
property SqlString sBezeichnung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBezeichnung() : SqlString;
public function set sBezeichnung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokumenttyp Class
clsDokumenttyp Members


clsDokumenttyp Methods

clsDokumenttyp Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsDokumenttyp Class


clsDokumenttyp.Delete Method

clsDokumenttyp.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iDokumenttypnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Dokumenttyp_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Dokumenttyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumenttyp::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokumenttyp Class
clsDokumenttyp Members


clsDokumenttyp.Insert Method

clsDokumenttyp.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iDokumenttypnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Dokumenttyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Dokumenttyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumenttyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokumenttyp Class
clsDokumenttyp Members


clsDokumenttyp.SelectAll Method

clsDokumenttyp.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Dokumenttyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Dokumenttyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Dokumenttyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumenttyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokumenttyp Class
clsDokumenttyp Members


clsDokumenttyp.SelectOne Method

clsDokumenttyp.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iDokumenttypnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iDokumenttypnr</LI> <LI>sBezeichnung</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>bAktiv</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Dokumenttyp_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Dokumenttyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iDokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Dokumenttyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iDokumenttypnr = New SqlInt32(CType(dtToReturn.Rows(0)("Dokumenttypnr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumenttyp::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokumenttyp Class
clsDokumenttyp Members


clsDokumenttyp.Update Method

clsDokumenttyp.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iDokumenttypnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Dokumenttyp_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Dokumenttyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumenttyp::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokumenttyp Class
clsDokumenttyp Members


clsDokumenttyp Fields

clsDokumenttyp Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iDokumenttypnr |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsDokumenttyp Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokumenttyp Class
clsDokumenttyp Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokumenttyp Class
clsDokumenttyp Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokumenttyp Class
clsDokumenttyp Members


m_iDokumenttypnr Variable

m_iDokumenttypnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iDokumenttypnr As SqlInt32
C#
private SqlInt32 m_iDokumenttypnr;
C++
private:
SqlInt32 m_iDokumenttypnr;
JScript
private m_iDokumenttypnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iDokumenttypnr, m_iMutierer As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokumenttyp Class
clsDokumenttyp Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iDokumenttypnr, m_iMutierer As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokumenttyp Class
clsDokumenttyp Members


m_sBezeichnung Variable

m_sBezeichnung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBezeichnung As SqlString
C#
private SqlString m_sBezeichnung;
C++
private:
SqlString m_sBezeichnung;
JScript
private m_sBezeichnung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBezeichnung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDokumenttyp Class
clsDokumenttyp Members


clsFunktionsgruppe Class

clsFunktionsgruppe Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'funktionsgruppe'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsFunktionsgruppe
    Inherits clsDBInteractionBase
C#
public class clsFunktionsgruppe : clsDBInteractionBase
C++

public ref class clsFunktionsgruppe : public clsDBInteractionBase^
JScript
public class clsFunktionsgruppe
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsFunktionsgruppe

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Members


clsFunktionsgruppe Members

clsFunktionsgruppe Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'funktionsgruppe'.

The following tables list the members exposed by the clsFunktionsgruppe type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsFunktionsgruppe Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bBarcodeetiketten |
Supported by the .NET Compact Framework. | bBlv |
Supported by the .NET Compact Framework. | bDokumentreaktivierung |
Supported by the .NET Compact Framework. | bEdokapartner |
Supported by the .NET Compact Framework. | bFunktionszuweisung |
Supported by the .NET Compact Framework. | bPartnerzusammenlegung |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iFunktionsgruppenr |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sZugehoerigkeit |
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bBarcodeetiketten |
Supported by the .NET Compact Framework. | m_bBlv |
Supported by the .NET Compact Framework. | m_bDokumentreaktivierung |
Supported by the .NET Compact Framework. | m_bEdokapartner |
Supported by the .NET Compact Framework. | m_bFunktionszuweisung |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_bPartnerzusammenlegung |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iFunktionsgruppenr |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_sZugehoerigkeit |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsFunktionsgruppe Class


clsFunktionsgruppe Constructor

clsFunktionsgruppe Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsFunktionsgruppe();
C++

public:
System::Void clsFunktionsgruppe()
JScript
public function clsFunktionsgruppe();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


clsFunktionsgruppe Properties

clsFunktionsgruppe Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bBarcodeetiketten |
Supported by the .NET Compact Framework. | bBlv |
Supported by the .NET Compact Framework. | bDokumentreaktivierung |
Supported by the .NET Compact Framework. | bEdokapartner |
Supported by the .NET Compact Framework. | bFunktionszuweisung |
Supported by the .NET Compact Framework. | bPartnerzusammenlegung |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iFunktionsgruppenr |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sZugehoerigkeit |
Top

Expand image See Also

Reference

clsFunktionsgruppe Class


clsFunktionsgruppe.bAktiv Property

clsFunktionsgruppe.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


clsFunktionsgruppe.bBarcodeetiketten Property

clsFunktionsgruppe.bBarcodeetiketten Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bBarcodeetiketten() As SqlBoolean
C#
public SqlBoolean bBarcodeetiketten {get; set;}
C++
public:
property SqlBoolean bBarcodeetiketten {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bBarcodeetiketten() : SqlBoolean;
public function set bBarcodeetiketten(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bBarcodeetiketten]() As SqlBoolean
            Get
                Return m_bBarcodeetiketten
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bBarcodeetiketten = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


clsFunktionsgruppe.bBlv Property

clsFunktionsgruppe.bBlv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bBlv() As SqlBoolean
C#
public SqlBoolean bBlv {get; set;}
C++
public:
property SqlBoolean bBlv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bBlv() : SqlBoolean;
public function set bBlv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bBlv]() As SqlBoolean
            Get
                Return m_bBlv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bBlv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


clsFunktionsgruppe.bDokumentreaktivierung Property

clsFunktionsgruppe.bDokumentreaktivierung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bDokumentreaktivierung() As SqlBoolean
C#
public SqlBoolean bDokumentreaktivierung {get; set;}
C++
public:
property SqlBoolean bDokumentreaktivierung {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bDokumentreaktivierung() : SqlBoolean;
public function set bDokumentreaktivierung(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bDokumentreaktivierung]() As SqlBoolean
            Get
                Return m_bDokumentreaktivierung
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bDokumentreaktivierung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


clsFunktionsgruppe.bEdokapartner Property

clsFunktionsgruppe.bEdokapartner Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bEdokapartner() As SqlBoolean
C#
public SqlBoolean bEdokapartner {get; set;}
C++
public:
property SqlBoolean bEdokapartner {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bEdokapartner() : SqlBoolean;
public function set bEdokapartner(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bEdokapartner]() As SqlBoolean
            Get
                Return m_bEdokapartner
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bEdokapartner = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


clsFunktionsgruppe.bFunktionszuweisung Property

clsFunktionsgruppe.bFunktionszuweisung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bFunktionszuweisung() As SqlBoolean
C#
public SqlBoolean bFunktionszuweisung {get; set;}
C++
public:
property SqlBoolean bFunktionszuweisung {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bFunktionszuweisung() : SqlBoolean;
public function set bFunktionszuweisung(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bFunktionszuweisung]() As SqlBoolean
            Get
                Return m_bFunktionszuweisung
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bFunktionszuweisung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


clsFunktionsgruppe.bPartnerzusammenlegung Property

clsFunktionsgruppe.bPartnerzusammenlegung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bPartnerzusammenlegung() As SqlBoolean
C#
public SqlBoolean bPartnerzusammenlegung {get; set;}
C++
public:
property SqlBoolean bPartnerzusammenlegung {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bPartnerzusammenlegung() : SqlBoolean;
public function set bPartnerzusammenlegung(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bPartnerzusammenlegung]() As SqlBoolean
            Get
                Return m_bPartnerzusammenlegung
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bPartnerzusammenlegung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


clsFunktionsgruppe.daErstellt_am Property

clsFunktionsgruppe.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


clsFunktionsgruppe.daMutiert_am Property

clsFunktionsgruppe.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


clsFunktionsgruppe.iFunktionsgruppenr Property

clsFunktionsgruppe.iFunktionsgruppenr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iFunktionsgruppenr() As SqlInt32
C#
public SqlInt32 iFunktionsgruppenr {get; set;}
C++
public:
property SqlInt32 iFunktionsgruppenr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iFunktionsgruppenr() : SqlInt32;
public function set iFunktionsgruppenr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iFunktionsgruppenr]() As SqlInt32
            Get
                Return m_iFunktionsgruppenr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iFunktionsgruppenrTmp As SqlInt32 = Value
                If iFunktionsgruppenrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iFunktionsgruppenr", "iFunktionsgruppenr can't be NULL")
                End If
                m_iFunktionsgruppenr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


clsFunktionsgruppe.iMandantnr Property

clsFunktionsgruppe.iMandantnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandantnr() As SqlInt32
C#
public SqlInt32 iMandantnr {get; set;}
C++
public:
property SqlInt32 iMandantnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


clsFunktionsgruppe.iMutierer Property

clsFunktionsgruppe.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


clsFunktionsgruppe.sBeschreibung Property

clsFunktionsgruppe.sBeschreibung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBeschreibung() As SqlString
C#
public SqlString sBeschreibung {get; set;}
C++
public:
property SqlString sBeschreibung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBeschreibung() : SqlString;
public function set sBeschreibung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


clsFunktionsgruppe.sBezeichnung Property

clsFunktionsgruppe.sBezeichnung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBezeichnung() As SqlString
C#
public SqlString sBezeichnung {get; set;}
C++
public:
property SqlString sBezeichnung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBezeichnung() : SqlString;
public function set sBezeichnung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


clsFunktionsgruppe.sZugehoerigkeit Property

clsFunktionsgruppe.sZugehoerigkeit Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sZugehoerigkeit() As SqlString
C#
public SqlString sZugehoerigkeit {get; set;}
C++
public:
property SqlString sZugehoerigkeit {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sZugehoerigkeit() : SqlString;
public function set sZugehoerigkeit(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sZugehoerigkeit]() As SqlString
            Get
                Return m_sZugehoerigkeit
            End Get
            Set(ByVal Value As SqlString)
                m_sZugehoerigkeit = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


clsFunktionsgruppe Methods

clsFunktionsgruppe Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsFunktionsgruppe Class


clsFunktionsgruppe.Delete Method

clsFunktionsgruppe.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iFunktionsgruppenr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


clsFunktionsgruppe.Insert Method

clsFunktionsgruppe.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iFunktionsgruppenr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>sZugehoerigkeit. May be SqlString.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bFunktionszuweisung. May be SqlBoolean.Null</LI> <LI>bBarcodeetiketten. May be SqlBoolean.Null</LI> <LI>bEdokapartner. May be SqlBoolean.Null</LI> <LI>bDokumentreaktivierung. May be SqlBoolean.Null</LI> <LI>bPartnerzusammenlegung. May be SqlBoolean.Null</LI> <LI>bBlv. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szugehoerigkeit", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZugehoerigkeit))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bfunktionszuweisung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFunktionszuweisung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bbarcodeetiketten", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBarcodeetiketten))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bedokapartner", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEdokapartner))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bDokumentreaktivierung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokumentreaktivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bPartnerzusammenlegung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bPartnerzusammenlegung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bblv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBlv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


clsFunktionsgruppe.SelectAll Method

clsFunktionsgruppe.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("funktionsgruppe")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


clsFunktionsgruppe.SelectOne Method

clsFunktionsgruppe.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iFunktionsgruppenr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iFunktionsgruppenr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>sZugehoerigkeit</LI> <LI>iMandantnr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>bFunktionszuweisung</LI> <LI>bBarcodeetiketten</LI> <LI>bEdokapartner</LI> <LI>bDokumentreaktivierung</LI> <LI>bPartnerzusammenlegung</LI> <LI>bBlv</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("funktionsgruppe")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ifunktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iFunktionsgruppenr = New SqlInt32(CType(dtToReturn.Rows(0)("funktionsgruppenr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("zugehoerigkeit") Is System.DBNull.Value Then
                        m_sZugehoerigkeit = SqlString.Null
                    Else
                        m_sZugehoerigkeit = New SqlString(CType(dtToReturn.Rows(0)("zugehoerigkeit"), String))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("funktionszuweisung") Is System.DBNull.Value Then
                        m_bFunktionszuweisung = SqlBoolean.Null
                    Else
                        m_bFunktionszuweisung = New SqlBoolean(CType(dtToReturn.Rows(0)("funktionszuweisung"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("barcodeetiketten") Is System.DBNull.Value Then
                        m_bBarcodeetiketten = SqlBoolean.Null
                    Else
                        m_bBarcodeetiketten = New SqlBoolean(CType(dtToReturn.Rows(0)("barcodeetiketten"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("edokapartner") Is System.DBNull.Value Then
                        m_bEdokapartner = SqlBoolean.Null
                    Else
                        m_bEdokapartner = New SqlBoolean(CType(dtToReturn.Rows(0)("edokapartner"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Dokumentreaktivierung") Is System.DBNull.Value Then
                        m_bDokumentreaktivierung = SqlBoolean.Null
                    Else
                        m_bDokumentreaktivierung = New SqlBoolean(CType(dtToReturn.Rows(0)("Dokumentreaktivierung"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Partnerzusammenlegung") Is System.DBNull.Value Then
                        m_bPartnerzusammenlegung = SqlBoolean.Null
                    Else
                        m_bPartnerzusammenlegung = New SqlBoolean(CType(dtToReturn.Rows(0)("Partnerzusammenlegung"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("blv") Is System.DBNull.Value Then
                        m_bBlv = SqlBoolean.Null
                    Else
                        m_bBlv = New SqlBoolean(CType(dtToReturn.Rows(0)("blv"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


clsFunktionsgruppe.Update Method

clsFunktionsgruppe.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iFunktionsgruppenr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>sZugehoerigkeit. May be SqlString.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bFunktionszuweisung. May be SqlBoolean.Null</LI> <LI>bBarcodeetiketten. May be SqlBoolean.Null</LI> <LI>bEdokapartner. May be SqlBoolean.Null</LI> <LI>bDokumentreaktivierung. May be SqlBoolean.Null</LI> <LI>bPartnerzusammenlegung. May be SqlBoolean.Null</LI> <LI>bBlv. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szugehoerigkeit", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZugehoerigkeit))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bfunktionszuweisung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFunktionszuweisung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bbarcodeetiketten", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBarcodeetiketten))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bedokapartner", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEdokapartner))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bDokumentreaktivierung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokumentreaktivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bPartnerzusammenlegung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bPartnerzusammenlegung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bblv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBlv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


clsFunktionsgruppe Fields

clsFunktionsgruppe Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bBarcodeetiketten |
Supported by the .NET Compact Framework. | m_bBlv |
Supported by the .NET Compact Framework. | m_bDokumentreaktivierung |
Supported by the .NET Compact Framework. | m_bEdokapartner |
Supported by the .NET Compact Framework. | m_bFunktionszuweisung |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_bPartnerzusammenlegung |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iFunktionsgruppenr |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_sZugehoerigkeit |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsFunktionsgruppe Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bBarcodeetiketten, m_bAktiv, m_bFunktionszuweisung, m_bEdokapartner, m_bBlv, m_bPartnerzusammenlegung, m_bDokumentreaktivierung As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


m_bBarcodeetiketten Variable

m_bBarcodeetiketten Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bBarcodeetiketten As SqlBoolean
C#
private SqlBoolean m_bBarcodeetiketten;
C++
private:
SqlBoolean m_bBarcodeetiketten;
JScript
private m_bBarcodeetiketten : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bBarcodeetiketten, m_bAktiv, m_bFunktionszuweisung, m_bEdokapartner, m_bBlv, m_bPartnerzusammenlegung, m_bDokumentreaktivierung As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


m_bBlv Variable

m_bBlv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bBlv As SqlBoolean
C#
private SqlBoolean m_bBlv;
C++
private:
SqlBoolean m_bBlv;
JScript
private m_bBlv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bBarcodeetiketten, m_bAktiv, m_bFunktionszuweisung, m_bEdokapartner, m_bBlv, m_bPartnerzusammenlegung, m_bDokumentreaktivierung As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


m_bDokumentreaktivierung Variable

m_bDokumentreaktivierung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bDokumentreaktivierung As SqlBoolean
C#
private SqlBoolean m_bDokumentreaktivierung;
C++
private:
SqlBoolean m_bDokumentreaktivierung;
JScript
private m_bDokumentreaktivierung : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bBarcodeetiketten, m_bAktiv, m_bFunktionszuweisung, m_bEdokapartner, m_bBlv, m_bPartnerzusammenlegung, m_bDokumentreaktivierung As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


m_bEdokapartner Variable

m_bEdokapartner Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bEdokapartner As SqlBoolean
C#
private SqlBoolean m_bEdokapartner;
C++
private:
SqlBoolean m_bEdokapartner;
JScript
private m_bEdokapartner : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bBarcodeetiketten, m_bAktiv, m_bFunktionszuweisung, m_bEdokapartner, m_bBlv, m_bPartnerzusammenlegung, m_bDokumentreaktivierung As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


m_bFunktionszuweisung Variable

m_bFunktionszuweisung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bFunktionszuweisung As SqlBoolean
C#
private SqlBoolean m_bFunktionszuweisung;
C++
private:
SqlBoolean m_bFunktionszuweisung;
JScript
private m_bFunktionszuweisung : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bBarcodeetiketten, m_bAktiv, m_bFunktionszuweisung, m_bEdokapartner, m_bBlv, m_bPartnerzusammenlegung, m_bDokumentreaktivierung As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


m_bPartnerzusammenlegung Variable

m_bPartnerzusammenlegung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bPartnerzusammenlegung As SqlBoolean
C#
private SqlBoolean m_bPartnerzusammenlegung;
C++
private:
SqlBoolean m_bPartnerzusammenlegung;
JScript
private m_bPartnerzusammenlegung : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bBarcodeetiketten, m_bAktiv, m_bFunktionszuweisung, m_bEdokapartner, m_bBlv, m_bPartnerzusammenlegung, m_bDokumentreaktivierung As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


m_iFunktionsgruppenr Variable

m_iFunktionsgruppenr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iFunktionsgruppenr As SqlInt32
C#
private SqlInt32 m_iFunktionsgruppenr;
C++
private:
SqlInt32 m_iFunktionsgruppenr;
JScript
private m_iFunktionsgruppenr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iFunktionsgruppenr, m_iMandantnr, m_iMutierer As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


m_iMandantnr Variable

m_iMandantnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandantnr As SqlInt32
C#
private SqlInt32 m_iMandantnr;
C++
private:
SqlInt32 m_iMandantnr;
JScript
private m_iMandantnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iFunktionsgruppenr, m_iMandantnr, m_iMutierer As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iFunktionsgruppenr, m_iMandantnr, m_iMutierer As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


m_sBeschreibung Variable

m_sBeschreibung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBeschreibung As SqlString
C#
private SqlString m_sBeschreibung;
C++
private:
SqlString m_sBeschreibung;
JScript
private m_sBeschreibung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sZugehoerigkeit, m_sBezeichnung, m_sBeschreibung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


m_sBezeichnung Variable

m_sBezeichnung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBezeichnung As SqlString
C#
private SqlString m_sBezeichnung;
C++
private:
SqlString m_sBezeichnung;
JScript
private m_sBezeichnung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sZugehoerigkeit, m_sBezeichnung, m_sBeschreibung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


m_sZugehoerigkeit Variable

m_sZugehoerigkeit Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sZugehoerigkeit As SqlString
C#
private SqlString m_sZugehoerigkeit;
C++
private:
SqlString m_sZugehoerigkeit;
JScript
private m_sZugehoerigkeit : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sZugehoerigkeit, m_sBezeichnung, m_sBeschreibung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe Class
clsFunktionsgruppe Members


clsFunktionsgruppe_rolle Class

clsFunktionsgruppe_rolle Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'funktionsgruppe_rolle'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsFunktionsgruppe_rolle
    Inherits clsDBInteractionBase
C#
public class clsFunktionsgruppe_rolle : clsDBInteractionBase
C++

public ref class clsFunktionsgruppe_rolle : public clsDBInteractionBase^
JScript
public class clsFunktionsgruppe_rolle
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsFunktionsgruppe_rolle

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe_rolle Members


clsFunktionsgruppe_rolle Members

clsFunktionsgruppe_rolle Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'funktionsgruppe_rolle'.

The following tables list the members exposed by the clsFunktionsgruppe_rolle type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsFunktionsgruppe_rolle Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iFunktionsgruppenr |
Supported by the .NET Compact Framework. | iFunktionsgrupperollenr |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRollenr |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iFunktionsgruppenr |
Supported by the .NET Compact Framework. | m_iFunktionsgrupperollenr |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRollenr |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class


clsFunktionsgruppe_rolle Constructor

clsFunktionsgruppe_rolle Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsFunktionsgruppe_rolle();
C++

public:
System::Void clsFunktionsgruppe_rolle()
JScript
public function clsFunktionsgruppe_rolle();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class
clsFunktionsgruppe_rolle Members


clsFunktionsgruppe_rolle Properties

clsFunktionsgruppe_rolle Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iFunktionsgruppenr |
Supported by the .NET Compact Framework. | iFunktionsgrupperollenr |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRollenr |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class


clsFunktionsgruppe_rolle.bAktiv Property

clsFunktionsgruppe_rolle.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class
clsFunktionsgruppe_rolle Members


clsFunktionsgruppe_rolle.daErstellt_am Property

clsFunktionsgruppe_rolle.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class
clsFunktionsgruppe_rolle Members


clsFunktionsgruppe_rolle.daMutiert_am Property

clsFunktionsgruppe_rolle.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class
clsFunktionsgruppe_rolle Members


clsFunktionsgruppe_rolle.iFunktionsgruppenr Property

clsFunktionsgruppe_rolle.iFunktionsgruppenr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iFunktionsgruppenr() As SqlInt32
C#
public SqlInt32 iFunktionsgruppenr {get; set;}
C++
public:
property SqlInt32 iFunktionsgruppenr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iFunktionsgruppenr() : SqlInt32;
public function set iFunktionsgruppenr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iFunktionsgruppenr]() As SqlInt32
            Get
                Return m_iFunktionsgruppenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFunktionsgruppenr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class
clsFunktionsgruppe_rolle Members


clsFunktionsgruppe_rolle.iFunktionsgrupperollenr Property

clsFunktionsgruppe_rolle.iFunktionsgrupperollenr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iFunktionsgrupperollenr() As SqlInt32
C#
public SqlInt32 iFunktionsgrupperollenr {get; set;}
C++
public:
property SqlInt32 iFunktionsgrupperollenr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iFunktionsgrupperollenr() : SqlInt32;
public function set iFunktionsgrupperollenr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iFunktionsgrupperollenr]() As SqlInt32
            Get
                Return m_iFunktionsgrupperollenr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iFunktionsgrupperollenrTmp As SqlInt32 = Value
                If iFunktionsgrupperollenrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iFunktionsgrupperollenr", "iFunktionsgrupperollenr can't be NULL")
                End If
                m_iFunktionsgrupperollenr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class
clsFunktionsgruppe_rolle Members


clsFunktionsgruppe_rolle.iMandantnr Property

clsFunktionsgruppe_rolle.iMandantnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandantnr() As SqlInt32
C#
public SqlInt32 iMandantnr {get; set;}
C++
public:
property SqlInt32 iMandantnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class
clsFunktionsgruppe_rolle Members


clsFunktionsgruppe_rolle.iMutierer Property

clsFunktionsgruppe_rolle.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class
clsFunktionsgruppe_rolle Members


clsFunktionsgruppe_rolle.iRollenr Property

clsFunktionsgruppe_rolle.iRollenr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iRollenr() As SqlInt32
C#
public SqlInt32 iRollenr {get; set;}
C++
public:
property SqlInt32 iRollenr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iRollenr() : SqlInt32;
public function set iRollenr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iRollenr]() As SqlInt32
            Get
                Return m_iRollenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iRollenr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class
clsFunktionsgruppe_rolle Members


clsFunktionsgruppe_rolle Methods

clsFunktionsgruppe_rolle Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class


clsFunktionsgruppe_rolle.Delete Method

clsFunktionsgruppe_rolle.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iFunktionsgrupperollenr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_rolle_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iFunktionsgrupperollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgrupperollenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_rolle_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe_rolle::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class
clsFunktionsgruppe_rolle Members


clsFunktionsgruppe_rolle.Insert Method

clsFunktionsgruppe_rolle.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iFunktionsgrupperollenr</LI> <LI>iFunktionsgruppenr. May be SqlInt32.Null</LI> <LI>iRollenr. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_rolle_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iFunktionsgrupperollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgrupperollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_rolle_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe_rolle::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class
clsFunktionsgruppe_rolle Members


clsFunktionsgruppe_rolle.SelectAll Method

clsFunktionsgruppe_rolle.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_rolle_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("funktionsgruppe_rolle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_rolle_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe_rolle::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class
clsFunktionsgruppe_rolle Members


clsFunktionsgruppe_rolle.SelectOne Method

clsFunktionsgruppe_rolle.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iFunktionsgrupperollenr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iFunktionsgrupperollenr</LI> <LI>iFunktionsgruppenr</LI> <LI>iRollenr</LI> <LI>iMandantnr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_rolle_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("funktionsgruppe_rolle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iFunktionsgrupperollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgrupperollenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_rolle_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iFunktionsgrupperollenr = New SqlInt32(CType(dtToReturn.Rows(0)("Funktionsgrupperollenr"), Integer))
                    If dtToReturn.Rows(0)("funktionsgruppenr") Is System.DBNull.Value Then
                        m_iFunktionsgruppenr = SqlInt32.Null
                    Else
                        m_iFunktionsgruppenr = New SqlInt32(CType(dtToReturn.Rows(0)("funktionsgruppenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("rollenr") Is System.DBNull.Value Then
                        m_iRollenr = SqlInt32.Null
                    Else
                        m_iRollenr = New SqlInt32(CType(dtToReturn.Rows(0)("rollenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe_rolle::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class
clsFunktionsgruppe_rolle Members


clsFunktionsgruppe_rolle.Update Method

clsFunktionsgruppe_rolle.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iFunktionsgrupperollenr</LI> <LI>iFunktionsgruppenr. May be SqlInt32.Null</LI> <LI>iRollenr. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_rolle_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iFunktionsgrupperollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgrupperollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_rolle_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe_rolle::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class
clsFunktionsgruppe_rolle Members


clsFunktionsgruppe_rolle Fields

clsFunktionsgruppe_rolle Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iFunktionsgruppenr |
Supported by the .NET Compact Framework. | m_iFunktionsgrupperollenr |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRollenr |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class
clsFunktionsgruppe_rolle Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class
clsFunktionsgruppe_rolle Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class
clsFunktionsgruppe_rolle Members


m_iFunktionsgruppenr Variable

m_iFunktionsgruppenr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iFunktionsgruppenr As SqlInt32
C#
private SqlInt32 m_iFunktionsgruppenr;
C++
private:
SqlInt32 m_iFunktionsgruppenr;
JScript
private m_iFunktionsgruppenr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iFunktionsgruppenr, m_iFunktionsgrupperollenr, m_iMandantnr, m_iRollenr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class
clsFunktionsgruppe_rolle Members


m_iFunktionsgrupperollenr Variable

m_iFunktionsgrupperollenr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iFunktionsgrupperollenr As SqlInt32
C#
private SqlInt32 m_iFunktionsgrupperollenr;
C++
private:
SqlInt32 m_iFunktionsgrupperollenr;
JScript
private m_iFunktionsgrupperollenr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iFunktionsgruppenr, m_iFunktionsgrupperollenr, m_iMandantnr, m_iRollenr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class
clsFunktionsgruppe_rolle Members


m_iMandantnr Variable

m_iMandantnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandantnr As SqlInt32
C#
private SqlInt32 m_iMandantnr;
C++
private:
SqlInt32 m_iMandantnr;
JScript
private m_iMandantnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iFunktionsgruppenr, m_iFunktionsgrupperollenr, m_iMandantnr, m_iRollenr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class
clsFunktionsgruppe_rolle Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iFunktionsgruppenr, m_iFunktionsgrupperollenr, m_iMandantnr, m_iRollenr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class
clsFunktionsgruppe_rolle Members


m_iRollenr Variable

m_iRollenr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iRollenr As SqlInt32
C#
private SqlInt32 m_iRollenr;
C++
private:
SqlInt32 m_iRollenr;
JScript
private m_iRollenr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iFunktionsgruppenr, m_iFunktionsgrupperollenr, m_iMandantnr, m_iRollenr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsFunktionsgruppe_rolle Class
clsFunktionsgruppe_rolle Members


clsKey_tabelle Class

clsKey_tabelle Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'key_tabelle'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsKey_tabelle
    Inherits clsDBInteractionBase
C#
public class clsKey_tabelle : clsDBInteractionBase
C++

public ref class clsKey_tabelle : public clsDBInteractionBase^
JScript
public class clsKey_tabelle
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle
Vertragsverwaltung.TKB.VV.DB.clsMyKey_Tabelle

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKey_tabelle Members


clsKey_tabelle Members

clsKey_tabelle Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'key_tabelle'.

The following tables list the members exposed by the clsKey_tabelle type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsKey_tabelle Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iKey_wert |
Supported by the .NET Compact Framework. | iKeynr |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iKey_wert |
Supported by the .NET Compact Framework. | m_iKeynr |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsKey_tabelle Class


clsKey_tabelle Constructor

clsKey_tabelle Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsKey_tabelle();
C++

public:
System::Void clsKey_tabelle()
JScript
public function clsKey_tabelle();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKey_tabelle Class
clsKey_tabelle Members


clsKey_tabelle Properties

clsKey_tabelle Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iKey_wert |
Supported by the .NET Compact Framework. | iKeynr |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsKey_tabelle Class


clsKey_tabelle.bAktiv Property

clsKey_tabelle.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKey_tabelle Class
clsKey_tabelle Members


clsKey_tabelle.daErstellt_am Property

clsKey_tabelle.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKey_tabelle Class
clsKey_tabelle Members


clsKey_tabelle.daMutiert_am Property

clsKey_tabelle.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKey_tabelle Class
clsKey_tabelle Members


clsKey_tabelle.iKey_wert Property

clsKey_tabelle.iKey_wert Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iKey_wert() As SqlInt32
C#
public SqlInt32 iKey_wert {get; set;}
C++
public:
property SqlInt32 iKey_wert {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iKey_wert() : SqlInt32;
public function set iKey_wert(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iKey_wert]() As SqlInt32
            Get
                Return m_iKey_wert
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iKey_wertTmp As SqlInt32 = Value
                If iKey_wertTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iKey_wert", "iKey_wert can't be NULL")
                End If
                m_iKey_wert = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKey_tabelle Class
clsKey_tabelle Members


clsKey_tabelle.iKeynr Property

clsKey_tabelle.iKeynr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iKeynr() As SqlInt32
C#
public SqlInt32 iKeynr {get; set;}
C++
public:
property SqlInt32 iKeynr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iKeynr() : SqlInt32;
public function set iKeynr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iKeynr]() As SqlInt32
            Get
                Return m_iKeynr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iKeynrTmp As SqlInt32 = Value
                If iKeynrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iKeynr", "iKeynr can't be NULL")
                End If
                m_iKeynr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKey_tabelle Class
clsKey_tabelle Members


clsKey_tabelle.iMandantnr Property

clsKey_tabelle.iMandantnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandantnr() As SqlInt32
C#
public SqlInt32 iMandantnr {get; set;}
C++
public:
property SqlInt32 iMandantnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKey_tabelle Class
clsKey_tabelle Members


clsKey_tabelle.iMutierer Property

clsKey_tabelle.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKey_tabelle Class
clsKey_tabelle Members


clsKey_tabelle.sBeschreibung Property

clsKey_tabelle.sBeschreibung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBeschreibung() As SqlString
C#
public SqlString sBeschreibung {get; set;}
C++
public:
property SqlString sBeschreibung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBeschreibung() : SqlString;
public function set sBeschreibung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                Dim sBeschreibungTmp As SqlString = Value
                If sBeschreibungTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sBeschreibung", "sBeschreibung can't be NULL")
                End If
                m_sBeschreibung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKey_tabelle Class
clsKey_tabelle Members


clsKey_tabelle Methods

clsKey_tabelle Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsKey_tabelle Class


clsKey_tabelle.Delete Method

clsKey_tabelle.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iKeynr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_key_tabelle_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ikeynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKeynr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_key_tabelle_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKey_tabelle::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKey_tabelle Class
clsKey_tabelle Members


clsKey_tabelle.Insert Method

clsKey_tabelle.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>sBeschreibung</LI> <LI>iKey_wert</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iKeynr</LI> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_key_tabelle_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ikey_wert", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKey_wert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ikeynr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iKeynr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iKeynr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@ikeynr").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_key_tabelle_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKey_tabelle::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKey_tabelle Class
clsKey_tabelle Members


clsKey_tabelle.SelectAll Method

clsKey_tabelle.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_key_tabelle_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("key_tabelle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_key_tabelle_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKey_tabelle::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKey_tabelle Class
clsKey_tabelle Members


clsKey_tabelle.SelectOne Method

clsKey_tabelle.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iKeynr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iKeynr</LI> <LI>sBeschreibung</LI> <LI>iKey_wert</LI> <LI>iMandantnr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_key_tabelle_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("key_tabelle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ikeynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKeynr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_key_tabelle_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iKeynr = New SqlInt32(CType(dtToReturn.Rows(0)("keynr"), Integer))
                    m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    m_iKey_wert = New SqlInt32(CType(dtToReturn.Rows(0)("key_wert"), Integer))
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKey_tabelle::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKey_tabelle Class
clsKey_tabelle Members


clsKey_tabelle.Update Method

clsKey_tabelle.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iKeynr</LI> <LI>sBeschreibung</LI> <LI>iKey_wert</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_key_tabelle_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ikeynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKeynr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ikey_wert", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKey_wert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_key_tabelle_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKey_tabelle::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKey_tabelle Class
clsKey_tabelle Members


clsKey_tabelle Fields

clsKey_tabelle Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iKey_wert |
Supported by the .NET Compact Framework. | m_iKeynr |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsKey_tabelle Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKey_tabelle Class
clsKey_tabelle Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKey_tabelle Class
clsKey_tabelle Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKey_tabelle Class
clsKey_tabelle Members


m_iKey_wert Variable

m_iKey_wert Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iKey_wert As SqlInt32
C#
private SqlInt32 m_iKey_wert;
C++
private:
SqlInt32 m_iKey_wert;
JScript
private m_iKey_wert : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iKeynr, m_iKey_wert, m_iMandantnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKey_tabelle Class
clsKey_tabelle Members


m_iKeynr Variable

m_iKeynr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iKeynr As SqlInt32
C#
private SqlInt32 m_iKeynr;
C++
private:
SqlInt32 m_iKeynr;
JScript
private m_iKeynr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iKeynr, m_iKey_wert, m_iMandantnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKey_tabelle Class
clsKey_tabelle Members


m_iMandantnr Variable

m_iMandantnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandantnr As SqlInt32
C#
private SqlInt32 m_iMandantnr;
C++
private:
SqlInt32 m_iMandantnr;
JScript
private m_iMandantnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iKeynr, m_iKey_wert, m_iMandantnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKey_tabelle Class
clsKey_tabelle Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iKeynr, m_iKey_wert, m_iMandantnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKey_tabelle Class
clsKey_tabelle Members


m_sBeschreibung Variable

m_sBeschreibung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBeschreibung As SqlString
C#
private SqlString m_sBeschreibung;
C++
private:
SqlString m_sBeschreibung;
JScript
private m_sBeschreibung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBeschreibung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKey_tabelle Class
clsKey_tabelle Members


clsKontakttyp Class

clsKontakttyp Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'Kontakttyp'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsKontakttyp
    Inherits clsDBInteractionBase
C#
public class clsKontakttyp : clsDBInteractionBase
C++

public ref class clsKontakttyp : public clsDBInteractionBase^
JScript
public class clsKontakttyp
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsKontakttyp

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakttyp Members


clsKontakttyp Members

clsKontakttyp Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'Kontakttyp'.

The following tables list the members exposed by the clsKontakttyp type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsKontakttyp Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iKontakttypNr |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iKontakttypNr |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsKontakttyp Class


clsKontakttyp Constructor

clsKontakttyp Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsKontakttyp();
C++

public:
System::Void clsKontakttyp()
JScript
public function clsKontakttyp();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakttyp Class
clsKontakttyp Members


clsKontakttyp Properties

clsKontakttyp Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iKontakttypNr |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsKontakttyp Class


clsKontakttyp.bAktiv Property

clsKontakttyp.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakttyp Class
clsKontakttyp Members


clsKontakttyp.daErstellt_am Property

clsKontakttyp.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakttyp Class
clsKontakttyp Members


clsKontakttyp.daMutiert_am Property

clsKontakttyp.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakttyp Class
clsKontakttyp Members


clsKontakttyp.iKontakttypNr Property

clsKontakttyp.iKontakttypNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iKontakttypNr() As SqlInt32
C#
public SqlInt32 iKontakttypNr {get; set;}
C++
public:
property SqlInt32 iKontakttypNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iKontakttypNr() : SqlInt32;
public function set iKontakttypNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iKontakttypNr]() As SqlInt32
            Get
                Return m_iKontakttypNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iKontakttypNrTmp As SqlInt32 = Value
                If iKontakttypNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iKontakttypNr", "iKontakttypNr can't be NULL")
                End If
                m_iKontakttypNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakttyp Class
clsKontakttyp Members


clsKontakttyp.iMandantnr Property

clsKontakttyp.iMandantnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandantnr() As SqlInt32
C#
public SqlInt32 iMandantnr {get; set;}
C++
public:
property SqlInt32 iMandantnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakttyp Class
clsKontakttyp Members


clsKontakttyp.iMutierer Property

clsKontakttyp.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakttyp Class
clsKontakttyp Members


clsKontakttyp.sBeschreibung Property

clsKontakttyp.sBeschreibung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBeschreibung() As SqlString
C#
public SqlString sBeschreibung {get; set;}
C++
public:
property SqlString sBeschreibung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBeschreibung() : SqlString;
public function set sBeschreibung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakttyp Class
clsKontakttyp Members


clsKontakttyp.sBezeichnung Property

clsKontakttyp.sBezeichnung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBezeichnung() As SqlString
C#
public SqlString sBezeichnung {get; set;}
C++
public:
property SqlString sBezeichnung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBezeichnung() : SqlString;
public function set sBezeichnung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakttyp Class
clsKontakttyp Members


clsKontakttyp Methods

clsKontakttyp Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsKontakttyp Class


clsKontakttyp.Delete Method

clsKontakttyp.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iKontakttypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kontakttyp_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKontakttypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKontakttypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kontakttyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKontakttyp::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakttyp Class
clsKontakttyp Members


clsKontakttyp.Insert Method

clsKontakttyp.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iKontakttypNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kontakttyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKontakttypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKontakttypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kontakttyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKontakttyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakttyp Class
clsKontakttyp Members


clsKontakttyp.SelectAll Method

clsKontakttyp.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kontakttyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Kontakttyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kontakttyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKontakttyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakttyp Class
clsKontakttyp Members


clsKontakttyp.SelectOne Method

clsKontakttyp.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iKontakttypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iKontakttypNr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kontakttyp_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Kontakttyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iKontakttypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKontakttypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kontakttyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iKontakttypNr = New SqlInt32(CType(dtToReturn.Rows(0)("KontakttypNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKontakttyp::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakttyp Class
clsKontakttyp Members


clsKontakttyp.Update Method

clsKontakttyp.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iKontakttypNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kontakttyp_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKontakttypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKontakttypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kontakttyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKontakttyp::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakttyp Class
clsKontakttyp Members


clsKontakttyp Fields

clsKontakttyp Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iKontakttypNr |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsKontakttyp Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakttyp Class
clsKontakttyp Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakttyp Class
clsKontakttyp Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakttyp Class
clsKontakttyp Members


m_iKontakttypNr Variable

m_iKontakttypNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iKontakttypNr As SqlInt32
C#
private SqlInt32 m_iKontakttypNr;
C++
private:
SqlInt32 m_iKontakttypNr;
JScript
private m_iKontakttypNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iKontakttypNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakttyp Class
clsKontakttyp Members


m_iMandantnr Variable

m_iMandantnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandantnr As SqlInt32
C#
private SqlInt32 m_iMandantnr;
C++
private:
SqlInt32 m_iMandantnr;
JScript
private m_iMandantnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iKontakttypNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakttyp Class
clsKontakttyp Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iKontakttypNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakttyp Class
clsKontakttyp Members


m_sBeschreibung Variable

m_sBeschreibung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBeschreibung As SqlString
C#
private SqlString m_sBeschreibung;
C++
private:
SqlString m_sBeschreibung;
JScript
private m_sBeschreibung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakttyp Class
clsKontakttyp Members


m_sBezeichnung Variable

m_sBezeichnung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBezeichnung As SqlString
C#
private SqlString m_sBezeichnung;
C++
private:
SqlString m_sBezeichnung;
JScript
private m_sBezeichnung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakttyp Class
clsKontakttyp Members


clsKuendigungsfrist Class

clsKuendigungsfrist Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'Kuendigungsfrist'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsKuendigungsfrist
    Inherits clsDBInteractionBase
C#
public class clsKuendigungsfrist : clsDBInteractionBase
C++

public ref class clsKuendigungsfrist : public clsDBInteractionBase^
JScript
public class clsKuendigungsfrist
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist
Vertragsverwaltung.TKB.VV.Vertrag.clsKuendigungsfrist

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Members


clsKuendigungsfrist Members

clsKuendigungsfrist Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'Kuendigungsfrist'.

The following tables list the members exposed by the clsKuendigungsfrist type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsKuendigungsfrist Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daKuendigungstermin |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iKuendigungsfristNr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr |
Supported by the .NET Compact Framework. | iVertragselementNr |
Supported by the .NET Compact Framework. | iVertragselementNrOld |
Supported by the .NET Compact Framework. | sBemerkung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sKuendigungsfirst |
Supported by the .NET Compact Framework. | sVarZeitspanne |
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | DeleteAllWVertragselementNrLogic | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'VertragselementNr'
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectAllWVertragselementNrLogic | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'VertragselementNr'
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Supported by the .NET Compact Framework. | UpdateAllWVertragselementNrLogic | Purpose: Update method for updating one or more rows using the Foreign Key 'VertragselementNr. This method will Update one or more existing rows in the database. It will reset the field 'VertragselementNr' in all rows which have as value for this field the value as set in property 'iVertragselementNrOld' to the value as set in property 'iVertragselementNr'.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daKuendigungstermin |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iKuendigungsfristNr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSecurityLevelNr |
Supported by the .NET Compact Framework. | m_iVertragselementNr |
Supported by the .NET Compact Framework. | m_iVertragselementNrOld |
Supported by the .NET Compact Framework. | m_sBemerkung |
Supported by the .NET Compact Framework. | m_sKuendigungsfirst |
Supported by the .NET Compact Framework. | m_sVarZeitspanne |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsKuendigungsfrist Class


clsKuendigungsfrist Constructor

clsKuendigungsfrist Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsKuendigungsfrist();
C++

public:
System::Void clsKuendigungsfrist()
JScript
public function clsKuendigungsfrist();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


clsKuendigungsfrist Properties

clsKuendigungsfrist Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daKuendigungstermin |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iKuendigungsfristNr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr |
Supported by the .NET Compact Framework. | iVertragselementNr |
Supported by the .NET Compact Framework. | iVertragselementNrOld |
Supported by the .NET Compact Framework. | sBemerkung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sKuendigungsfirst |
Supported by the .NET Compact Framework. | sVarZeitspanne |
Top

Expand image See Also

Reference

clsKuendigungsfrist Class


clsKuendigungsfrist.bAktiv Property

clsKuendigungsfrist.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


clsKuendigungsfrist.daErstellt_am Property

clsKuendigungsfrist.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


clsKuendigungsfrist.daKuendigungstermin Property

clsKuendigungsfrist.daKuendigungstermin Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daKuendigungstermin() As SqlDateTime
C#
public SqlDateTime daKuendigungstermin {get; set;}
C++
public:
property SqlDateTime daKuendigungstermin {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daKuendigungstermin() : SqlDateTime;
public function set daKuendigungstermin(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daKuendigungstermin]() As SqlDateTime
            Get
                Return m_daKuendigungstermin
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daKuendigungstermin = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


clsKuendigungsfrist.daMutiert_am Property

clsKuendigungsfrist.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


clsKuendigungsfrist.iKuendigungsfristNr Property

clsKuendigungsfrist.iKuendigungsfristNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iKuendigungsfristNr() As SqlInt32
C#
public SqlInt32 iKuendigungsfristNr {get; set;}
C++
public:
property SqlInt32 iKuendigungsfristNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iKuendigungsfristNr() : SqlInt32;
public function set iKuendigungsfristNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iKuendigungsfristNr]() As SqlInt32
            Get
                Return m_iKuendigungsfristNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iKuendigungsfristNrTmp As SqlInt32 = Value
                If iKuendigungsfristNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iKuendigungsfristNr", "iKuendigungsfristNr can't be NULL")
                End If
                m_iKuendigungsfristNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


clsKuendigungsfrist.iMutierer Property

clsKuendigungsfrist.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


clsKuendigungsfrist.iSecurityLevelNr Property

clsKuendigungsfrist.iSecurityLevelNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iSecurityLevelNr() As SqlInt32
C#
public SqlInt32 iSecurityLevelNr {get; set;}
C++
public:
property SqlInt32 iSecurityLevelNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iSecurityLevelNr() : SqlInt32;
public function set iSecurityLevelNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iSecurityLevelNr]() As SqlInt32
            Get
                Return m_iSecurityLevelNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityLevelNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


clsKuendigungsfrist.iVertragselementNr Property

clsKuendigungsfrist.iVertragselementNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iVertragselementNr() As SqlInt32
C#
public SqlInt32 iVertragselementNr {get; set;}
C++
public:
property SqlInt32 iVertragselementNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iVertragselementNr() : SqlInt32;
public function set iVertragselementNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iVertragselementNr]() As SqlInt32
            Get
                Return m_iVertragselementNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVertragselementNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


clsKuendigungsfrist.iVertragselementNrOld Property

clsKuendigungsfrist.iVertragselementNrOld Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iVertragselementNrOld() As SqlInt32
C#
public SqlInt32 iVertragselementNrOld {get; set;}
C++
public:
property SqlInt32 iVertragselementNrOld {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iVertragselementNrOld() : SqlInt32;
public function set iVertragselementNrOld(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iVertragselementNrOld]() As SqlInt32
            Get
                Return m_iVertragselementNrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVertragselementNrOld = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


clsKuendigungsfrist.sBemerkung Property

clsKuendigungsfrist.sBemerkung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBemerkung() As SqlString
C#
public SqlString sBemerkung {get; set;}
C++
public:
property SqlString sBemerkung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBemerkung() : SqlString;
public function set sBemerkung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBemerkung]() As SqlString
            Get
                Return m_sBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


clsKuendigungsfrist.sKuendigungsfirst Property

clsKuendigungsfrist.sKuendigungsfirst Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sKuendigungsfirst() As SqlString
C#
public SqlString sKuendigungsfirst {get; set;}
C++
public:
property SqlString sKuendigungsfirst {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sKuendigungsfirst() : SqlString;
public function set sKuendigungsfirst(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sKuendigungsfirst]() As SqlString
            Get
                Return m_sKuendigungsfirst
            End Get
            Set(ByVal Value As SqlString)
                m_sKuendigungsfirst = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


clsKuendigungsfrist.sVarZeitspanne Property

clsKuendigungsfrist.sVarZeitspanne Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sVarZeitspanne() As SqlString
C#
public SqlString sVarZeitspanne {get; set;}
C++
public:
property SqlString sVarZeitspanne {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sVarZeitspanne() : SqlString;
public function set sVarZeitspanne(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sVarZeitspanne]() As SqlString
            Get
                Return m_sVarZeitspanne
            End Get
            Set(ByVal Value As SqlString)
                m_sVarZeitspanne = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


clsKuendigungsfrist Methods

clsKuendigungsfrist Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | DeleteAllWVertragselementNrLogic | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'VertragselementNr'
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectAllWVertragselementNrLogic | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'VertragselementNr'
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Supported by the .NET Compact Framework. | UpdateAllWVertragselementNrLogic | Purpose: Update method for updating one or more rows using the Foreign Key 'VertragselementNr. This method will Update one or more existing rows in the database. It will reset the field 'VertragselementNr' in all rows which have as value for this field the value as set in property 'iVertragselementNrOld' to the value as set in property 'iVertragselementNr'.
Top

Expand image See Also

Reference

clsKuendigungsfrist Class


clsKuendigungsfrist.Delete Method

clsKuendigungsfrist.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iKuendigungsfristNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kuendigungsfrist_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKuendigungsfristNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKuendigungsfristNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kuendigungsfrist_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKuendigungsfrist::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


clsKuendigungsfrist.DeleteAllWVertragselementNrLogic Method

clsKuendigungsfrist.DeleteAllWVertragselementNrLogic Method

Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'VertragselementNr'

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function DeleteAllWVertragselementNrLogic() As Boolean
C#
public bool DeleteAllWVertragselementNrLogic();
C++

public:
bool DeleteAllWVertragselementNrLogic()
JScript
public function DeleteAllWVertragselementNrLogic() : boolean;

Return Value

true if succeeded, false otherwise

Expand image Remarks

Properties needed for this method: <UL> <LI>iVertragselementNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function DeleteAllWVertragselementNrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kuendigungsfrist_DeleteAllWVertragselementNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragselementNr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iVertragselementNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iVertragselementNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kuendigungsfrist_DeleteAllWVertragselementNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKuendigungsfrist::DeleteAllWVertragselementNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


clsKuendigungsfrist.Insert Method

clsKuendigungsfrist.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iKuendigungsfristNr</LI> <LI>iVertragselementNr. May be SqlInt32.Null</LI> <LI>sVarZeitspanne. May be SqlString.Null</LI> <LI>sKuendigungsfirst. May be SqlString.Null</LI> <LI>daKuendigungstermin. May be SqlDateTime.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kuendigungsfrist_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKuendigungsfristNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKuendigungsfristNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVarZeitspanne", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVarZeitspanne))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sKuendigungsfirst", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sKuendigungsfirst))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daKuendigungstermin", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daKuendigungstermin))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kuendigungsfrist_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKuendigungsfrist::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


clsKuendigungsfrist.SelectAll Method

clsKuendigungsfrist.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kuendigungsfrist_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Kuendigungsfrist")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kuendigungsfrist_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKuendigungsfrist::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


clsKuendigungsfrist.SelectAllWVertragselementNrLogic Method

clsKuendigungsfrist.SelectAllWVertragselementNrLogic Method

Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'VertragselementNr'

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function SelectAllWVertragselementNrLogic() As DataTable
C#
public DataTable SelectAllWVertragselementNrLogic();
C++

public:
DataTable^ SelectAllWVertragselementNrLogic()
JScript
public function SelectAllWVertragselementNrLogic() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iVertragselementNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function SelectAllWVertragselementNrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kuendigungsfrist_SelectAllWVertragselementNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Kuendigungsfrist")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragselementNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iVertragselementNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iVertragselementNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kuendigungsfrist_SelectAllWVertragselementNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKuendigungsfrist::SelectAllWVertragselementNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


clsKuendigungsfrist.SelectOne Method

clsKuendigungsfrist.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iKuendigungsfristNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iKuendigungsfristNr</LI> <LI>iVertragselementNr</LI> <LI>sVarZeitspanne</LI> <LI>sKuendigungsfirst</LI> <LI>daKuendigungstermin</LI> <LI>sBemerkung</LI> <LI>iSecurityLevelNr</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>bAktiv</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kuendigungsfrist_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Kuendigungsfrist")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iKuendigungsfristNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKuendigungsfristNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kuendigungsfrist_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iKuendigungsfristNr = New SqlInt32(CType(dtToReturn.Rows(0)("KuendigungsfristNr"), Integer))
                    If dtToReturn.Rows(0)("VertragselementNr") Is System.DBNull.Value Then
                        m_iVertragselementNr = SqlInt32.Null
                    Else
                        m_iVertragselementNr = New SqlInt32(CType(dtToReturn.Rows(0)("VertragselementNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("VarZeitspanne") Is System.DBNull.Value Then
                        m_sVarZeitspanne = SqlString.Null
                    Else
                        m_sVarZeitspanne = New SqlString(CType(dtToReturn.Rows(0)("VarZeitspanne"), String))
                    End If
                    If dtToReturn.Rows(0)("Kuendigungsfirst") Is System.DBNull.Value Then
                        m_sKuendigungsfirst = SqlString.Null
                    Else
                        m_sKuendigungsfirst = New SqlString(CType(dtToReturn.Rows(0)("Kuendigungsfirst"), String))
                    End If
                    If dtToReturn.Rows(0)("Kuendigungstermin") Is System.DBNull.Value Then
                        m_daKuendigungstermin = SqlDateTime.Null
                    Else
                        m_daKuendigungstermin = New SqlDateTime(CType(dtToReturn.Rows(0)("Kuendigungstermin"), Date))
                    End If
                    If dtToReturn.Rows(0)("Bemerkung") Is System.DBNull.Value Then
                        m_sBemerkung = SqlString.Null
                    Else
                        m_sBemerkung = New SqlString(CType(dtToReturn.Rows(0)("Bemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("SecurityLevelNr") Is System.DBNull.Value Then
                        m_iSecurityLevelNr = SqlInt32.Null
                    Else
                        m_iSecurityLevelNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevelNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKuendigungsfrist::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


clsKuendigungsfrist.Update Method

clsKuendigungsfrist.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iKuendigungsfristNr</LI> <LI>iVertragselementNr. May be SqlInt32.Null</LI> <LI>sVarZeitspanne. May be SqlString.Null</LI> <LI>sKuendigungsfirst. May be SqlString.Null</LI> <LI>daKuendigungstermin. May be SqlDateTime.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kuendigungsfrist_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKuendigungsfristNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKuendigungsfristNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVarZeitspanne", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVarZeitspanne))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sKuendigungsfirst", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sKuendigungsfirst))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daKuendigungstermin", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daKuendigungstermin))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kuendigungsfrist_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKuendigungsfrist::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


clsKuendigungsfrist.UpdateAllWVertragselementNrLogic Method

clsKuendigungsfrist.UpdateAllWVertragselementNrLogic Method

Purpose: Update method for updating one or more rows using the Foreign Key 'VertragselementNr. This method will Update one or more existing rows in the database. It will reset the field 'VertragselementNr' in all rows which have as value for this field the value as set in property 'iVertragselementNrOld' to the value as set in property 'iVertragselementNr'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function UpdateAllWVertragselementNrLogic() As Boolean
C#
public bool UpdateAllWVertragselementNrLogic();
C++

public:
bool UpdateAllWVertragselementNrLogic()
JScript
public function UpdateAllWVertragselementNrLogic() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iVertragselementNr. May be SqlInt32.Null</LI> <LI>iVertragselementNrOld. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function UpdateAllWVertragselementNrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kuendigungsfrist_UpdateAllWVertragselementNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragselementNr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragselementNrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementNrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iVertragselementNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iVertragselementNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kuendigungsfrist_UpdateAllWVertragselementNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKuendigungsfrist::UpdateAllWVertragselementNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


clsKuendigungsfrist Fields

clsKuendigungsfrist Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daKuendigungstermin |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iKuendigungsfristNr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSecurityLevelNr |
Supported by the .NET Compact Framework. | m_iVertragselementNr |
Supported by the .NET Compact Framework. | m_iVertragselementNrOld |
Supported by the .NET Compact Framework. | m_sBemerkung |
Supported by the .NET Compact Framework. | m_sKuendigungsfirst |
Supported by the .NET Compact Framework. | m_sVarZeitspanne |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsKuendigungsfrist Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daKuendigungstermin, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


m_daKuendigungstermin Variable

m_daKuendigungstermin Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daKuendigungstermin As SqlDateTime
C#
private SqlDateTime m_daKuendigungstermin;
C++
private:
SqlDateTime m_daKuendigungstermin;
JScript
private m_daKuendigungstermin : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daKuendigungstermin, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daKuendigungstermin, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


m_iKuendigungsfristNr Variable

m_iKuendigungsfristNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iKuendigungsfristNr As SqlInt32
C#
private SqlInt32 m_iKuendigungsfristNr;
C++
private:
SqlInt32 m_iKuendigungsfristNr;
JScript
private m_iKuendigungsfristNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iSecurityLevelNr, m_iMutierer, m_iVertragselementNr, m_iVertragselementNrOld, m_iKuendigungsfristNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iSecurityLevelNr, m_iMutierer, m_iVertragselementNr, m_iVertragselementNrOld, m_iKuendigungsfristNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


m_iSecurityLevelNr Variable

m_iSecurityLevelNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iSecurityLevelNr As SqlInt32
C#
private SqlInt32 m_iSecurityLevelNr;
C++
private:
SqlInt32 m_iSecurityLevelNr;
JScript
private m_iSecurityLevelNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iSecurityLevelNr, m_iMutierer, m_iVertragselementNr, m_iVertragselementNrOld, m_iKuendigungsfristNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


m_iVertragselementNr Variable

m_iVertragselementNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iVertragselementNr As SqlInt32
C#
private SqlInt32 m_iVertragselementNr;
C++
private:
SqlInt32 m_iVertragselementNr;
JScript
private m_iVertragselementNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iSecurityLevelNr, m_iMutierer, m_iVertragselementNr, m_iVertragselementNrOld, m_iKuendigungsfristNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


m_iVertragselementNrOld Variable

m_iVertragselementNrOld Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iVertragselementNrOld As SqlInt32
C#
private SqlInt32 m_iVertragselementNrOld;
C++
private:
SqlInt32 m_iVertragselementNrOld;
JScript
private m_iVertragselementNrOld : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iSecurityLevelNr, m_iMutierer, m_iVertragselementNr, m_iVertragselementNrOld, m_iKuendigungsfristNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


m_sBemerkung Variable

m_sBemerkung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBemerkung As SqlString
C#
private SqlString m_sBemerkung;
C++
private:
SqlString m_sBemerkung;
JScript
private m_sBemerkung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBemerkung, m_sKuendigungsfirst, m_sVarZeitspanne As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


m_sKuendigungsfirst Variable

m_sKuendigungsfirst Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sKuendigungsfirst As SqlString
C#
private SqlString m_sKuendigungsfirst;
C++
private:
SqlString m_sKuendigungsfirst;
JScript
private m_sKuendigungsfirst : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBemerkung, m_sKuendigungsfirst, m_sVarZeitspanne As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


m_sVarZeitspanne Variable

m_sVarZeitspanne Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sVarZeitspanne As SqlString
C#
private SqlString m_sVarZeitspanne;
C++
private:
SqlString m_sVarZeitspanne;
JScript
private m_sVarZeitspanne : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBemerkung, m_sKuendigungsfirst, m_sVarZeitspanne As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members


clsMandant Class

clsMandant Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'mandant'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsMandant
    Inherits clsDBInteractionBase
C#
public class clsMandant : clsDBInteractionBase
C++

public ref class clsMandant : public clsDBInteractionBase^
JScript
public class clsMandant
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsMandant

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMandant Members


clsMandant Members

clsMandant Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'mandant'.

The following tables list the members exposed by the clsMandant type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsMandant Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMandantnr1 |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMandantnr1 |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsMandant Class


clsMandant Constructor

clsMandant Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsMandant();
C++

public:
System::Void clsMandant()
JScript
public function clsMandant();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMandant Class
clsMandant Members


clsMandant Properties

clsMandant Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMandantnr1 |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsMandant Class


clsMandant.bAktiv Property

clsMandant.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMandant Class
clsMandant Members


clsMandant.daErstellt_am Property

clsMandant.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMandant Class
clsMandant Members


clsMandant.daMutiert_am Property

clsMandant.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMandant Class
clsMandant Members


clsMandant.iMandantnr Property

clsMandant.iMandantnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandantnr() As SqlInt32
C#
public SqlInt32 iMandantnr {get; set;}
C++
public:
property SqlInt32 iMandantnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMandantnrTmp As SqlInt32 = Value
                If iMandantnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMandantnr", "iMandantnr can't be NULL")
                End If
                m_iMandantnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMandant Class
clsMandant Members


clsMandant.iMandantnr1 Property

clsMandant.iMandantnr1 Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandantnr1() As SqlInt32
C#
public SqlInt32 iMandantnr1 {get; set;}
C++
public:
property SqlInt32 iMandantnr1 {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandantnr1() : SqlInt32;
public function set iMandantnr1(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandantnr1]() As SqlInt32
            Get
                Return m_iMandantnr1
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr1 = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMandant Class
clsMandant Members


clsMandant.iMutierer Property

clsMandant.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMandant Class
clsMandant Members


clsMandant.sBeschreibung Property

clsMandant.sBeschreibung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBeschreibung() As SqlString
C#
public SqlString sBeschreibung {get; set;}
C++
public:
property SqlString sBeschreibung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBeschreibung() : SqlString;
public function set sBeschreibung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMandant Class
clsMandant Members


clsMandant.sBezeichnung Property

clsMandant.sBezeichnung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBezeichnung() As SqlString
C#
public SqlString sBezeichnung {get; set;}
C++
public:
property SqlString sBezeichnung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBezeichnung() : SqlString;
public function set sBezeichnung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMandant Class
clsMandant Members


clsMandant Methods

clsMandant Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsMandant Class


clsMandant.Delete Method

clsMandant.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iMandantnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mandant_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mandant_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMandant::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMandant Class
clsMandant Members


clsMandant.Insert Method

clsMandant.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iMandantnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>iMandantnr1. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mandant_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr1", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mandant_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMandant::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMandant Class
clsMandant Members


clsMandant.SelectAll Method

clsMandant.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mandant_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("mandant")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mandant_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMandant::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMandant Class
clsMandant Members


clsMandant.SelectOne Method

clsMandant.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iMandantnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iMandantnr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>iMandantnr1</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mandant_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("mandant")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mandant_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("mandantnr1") Is System.DBNull.Value Then
                        m_iMandantnr1 = SqlInt32.Null
                    Else
                        m_iMandantnr1 = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr1"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMandant::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMandant Class
clsMandant Members


clsMandant.Update Method

clsMandant.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iMandantnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>iMandantnr1. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mandant_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr1", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mandant_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMandant::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMandant Class
clsMandant Members


clsMandant Fields

clsMandant Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMandantnr1 |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsMandant Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMandant Class
clsMandant Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMandant Class
clsMandant Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMandant Class
clsMandant Members


m_iMandantnr Variable

m_iMandantnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandantnr As SqlInt32
C#
private SqlInt32 m_iMandantnr;
C++
private:
SqlInt32 m_iMandantnr;
JScript
private m_iMandantnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iMandantnr1 As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMandant Class
clsMandant Members


m_iMandantnr1 Variable

m_iMandantnr1 Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandantnr1 As SqlInt32
C#
private SqlInt32 m_iMandantnr1;
C++
private:
SqlInt32 m_iMandantnr1;
JScript
private m_iMandantnr1 : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iMandantnr1 As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMandant Class
clsMandant Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iMandantnr1 As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMandant Class
clsMandant Members


m_sBeschreibung Variable

m_sBeschreibung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBeschreibung As SqlString
C#
private SqlString m_sBeschreibung;
C++
private:
SqlString m_sBeschreibung;
JScript
private m_sBeschreibung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBeschreibung, m_sBezeichnung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMandant Class
clsMandant Members


m_sBezeichnung Variable

m_sBezeichnung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBezeichnung As SqlString
C#
private SqlString m_sBezeichnung;
C++
private:
SqlString m_sBezeichnung;
JScript
private m_sBezeichnung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBeschreibung, m_sBezeichnung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMandant Class
clsMandant Members


clsMeldungstexte Class

clsMeldungstexte Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'meldungstexte'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsMeldungstexte
    Inherits clsDBInteractionBase
C#
public class clsMeldungstexte : clsDBInteractionBase
C++

public ref class clsMeldungstexte : public clsDBInteractionBase^
JScript
public class clsMeldungstexte
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsMeldungstexte

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMeldungstexte Members


clsMeldungstexte Members

clsMeldungstexte Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'meldungstexte'.

The following tables list the members exposed by the clsMeldungstexte type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsMeldungstexte Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMeldungstextnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSprache |
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sInhalt |
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMeldungstextnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSprache |
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sInhalt |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsMeldungstexte Class


clsMeldungstexte Constructor

clsMeldungstexte Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsMeldungstexte();
C++

public:
System::Void clsMeldungstexte()
JScript
public function clsMeldungstexte();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMeldungstexte Class
clsMeldungstexte Members


clsMeldungstexte Properties

clsMeldungstexte Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMeldungstextnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSprache |
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sInhalt |
Top

Expand image See Also

Reference

clsMeldungstexte Class


clsMeldungstexte.bAktiv Property

clsMeldungstexte.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bAktivTmp As SqlBoolean = Value
                If bAktivTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bAktiv", "bAktiv can't be NULL")
                End If
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMeldungstexte Class
clsMeldungstexte Members


clsMeldungstexte.daErstellt_am Property

clsMeldungstexte.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMeldungstexte Class
clsMeldungstexte Members


clsMeldungstexte.daMutiert_am Property

clsMeldungstexte.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMeldungstexte Class
clsMeldungstexte Members


clsMeldungstexte.iMandantnr Property

clsMeldungstexte.iMandantnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandantnr() As SqlInt32
C#
public SqlInt32 iMandantnr {get; set;}
C++
public:
property SqlInt32 iMandantnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMeldungstexte Class
clsMeldungstexte Members


clsMeldungstexte.iMeldungstextnr Property

clsMeldungstexte.iMeldungstextnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMeldungstextnr() As SqlInt32
C#
public SqlInt32 iMeldungstextnr {get; set;}
C++
public:
property SqlInt32 iMeldungstextnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMeldungstextnr() : SqlInt32;
public function set iMeldungstextnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMeldungstextnr]() As SqlInt32
            Get
                Return m_iMeldungstextnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMeldungstextnrTmp As SqlInt32 = Value
                If iMeldungstextnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMeldungstextnr", "iMeldungstextnr can't be NULL")
                End If
                m_iMeldungstextnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMeldungstexte Class
clsMeldungstexte Members


clsMeldungstexte.iMutierer Property

clsMeldungstexte.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMeldungstexte Class
clsMeldungstexte Members


clsMeldungstexte.iSprache Property

clsMeldungstexte.iSprache Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iSprache() As SqlInt32
C#
public SqlInt32 iSprache {get; set;}
C++
public:
property SqlInt32 iSprache {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iSprache() : SqlInt32;
public function set iSprache(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iSprache]() As SqlInt32
            Get
                Return m_iSprache
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSprache = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMeldungstexte Class
clsMeldungstexte Members


clsMeldungstexte.sBeschreibung Property

clsMeldungstexte.sBeschreibung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBeschreibung() As SqlString
C#
public SqlString sBeschreibung {get; set;}
C++
public:
property SqlString sBeschreibung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBeschreibung() : SqlString;
public function set sBeschreibung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMeldungstexte Class
clsMeldungstexte Members


clsMeldungstexte.sInhalt Property

clsMeldungstexte.sInhalt Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sInhalt() As SqlString
C#
public SqlString sInhalt {get; set;}
C++
public:
property SqlString sInhalt {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sInhalt() : SqlString;
public function set sInhalt(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sInhalt]() As SqlString
            Get
                Return m_sInhalt
            End Get
            Set(ByVal Value As SqlString)
                m_sInhalt = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMeldungstexte Class
clsMeldungstexte Members


clsMeldungstexte Methods

clsMeldungstexte Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsMeldungstexte Class


clsMeldungstexte.Delete Method

clsMeldungstexte.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iMeldungstextnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_meldungstexte_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imeldungstextnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMeldungstextnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_meldungstexte_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMeldungstexte::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMeldungstexte Class
clsMeldungstexte Members


clsMeldungstexte.Insert Method

clsMeldungstexte.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iMeldungstextnr</LI> <LI>iSprache. May be SqlInt32.Null</LI> <LI>sInhalt. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_meldungstexte_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imeldungstextnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMeldungstextnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sinhalt", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sInhalt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_meldungstexte_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMeldungstexte::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMeldungstexte Class
clsMeldungstexte Members


clsMeldungstexte.SelectAll Method

clsMeldungstexte.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_meldungstexte_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("meldungstexte")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_meldungstexte_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMeldungstexte::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMeldungstexte Class
clsMeldungstexte Members


clsMeldungstexte.SelectOne Method

clsMeldungstexte.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iMeldungstextnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iMeldungstextnr</LI> <LI>iSprache</LI> <LI>sInhalt</LI> <LI>sBeschreibung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_meldungstexte_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("meldungstexte")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@imeldungstextnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMeldungstextnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_meldungstexte_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iMeldungstextnr = New SqlInt32(CType(dtToReturn.Rows(0)("meldungstextnr"), Integer))
                    If dtToReturn.Rows(0)("sprache") Is System.DBNull.Value Then
                        m_iSprache = SqlInt32.Null
                    Else
                        m_iSprache = New SqlInt32(CType(dtToReturn.Rows(0)("sprache"), Integer))
                    End If
                    If dtToReturn.Rows(0)("inhalt") Is System.DBNull.Value Then
                        m_sInhalt = SqlString.Null
                    Else
                        m_sInhalt = New SqlString(CType(dtToReturn.Rows(0)("inhalt"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMeldungstexte::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMeldungstexte Class
clsMeldungstexte Members


clsMeldungstexte.Update Method

clsMeldungstexte.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iMeldungstextnr</LI> <LI>iSprache. May be SqlInt32.Null</LI> <LI>sInhalt. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_meldungstexte_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imeldungstextnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMeldungstextnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sinhalt", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sInhalt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_meldungstexte_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMeldungstexte::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMeldungstexte Class
clsMeldungstexte Members


clsMeldungstexte Fields

clsMeldungstexte Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMeldungstextnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSprache |
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sInhalt |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsMeldungstexte Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMeldungstexte Class
clsMeldungstexte Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMeldungstexte Class
clsMeldungstexte Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMeldungstexte Class
clsMeldungstexte Members


m_iMandantnr Variable

m_iMandantnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandantnr As SqlInt32
C#
private SqlInt32 m_iMandantnr;
C++
private:
SqlInt32 m_iMandantnr;
JScript
private m_iMandantnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iSprache, m_iMeldungstextnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMeldungstexte Class
clsMeldungstexte Members


m_iMeldungstextnr Variable

m_iMeldungstextnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMeldungstextnr As SqlInt32
C#
private SqlInt32 m_iMeldungstextnr;
C++
private:
SqlInt32 m_iMeldungstextnr;
JScript
private m_iMeldungstextnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iSprache, m_iMeldungstextnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMeldungstexte Class
clsMeldungstexte Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iSprache, m_iMeldungstextnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMeldungstexte Class
clsMeldungstexte Members


m_iSprache Variable

m_iSprache Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iSprache As SqlInt32
C#
private SqlInt32 m_iSprache;
C++
private:
SqlInt32 m_iSprache;
JScript
private m_iSprache : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iSprache, m_iMeldungstextnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMeldungstexte Class
clsMeldungstexte Members


m_sBeschreibung Variable

m_sBeschreibung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBeschreibung As SqlString
C#
private SqlString m_sBeschreibung;
C++
private:
SqlString m_sBeschreibung;
JScript
private m_sBeschreibung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBeschreibung, m_sInhalt As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMeldungstexte Class
clsMeldungstexte Members


m_sInhalt Variable

m_sInhalt Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sInhalt As SqlString
C#
private SqlString m_sInhalt;
C++
private:
SqlString m_sInhalt;
JScript
private m_sInhalt : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBeschreibung, m_sInhalt As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMeldungstexte Class
clsMeldungstexte Members


clsMitarbeiter Class

clsMitarbeiter Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'mitarbeiter'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsMitarbeiter
    Inherits clsDBInteractionBase
C#
public class clsMitarbeiter : clsDBInteractionBase
C++

public ref class clsMitarbeiter : public clsDBInteractionBase^
JScript
public class clsMitarbeiter
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter
Vertragsverwaltung.TKB.VV.DB.MyMitarbeiter

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Members


clsMitarbeiter Members

clsMitarbeiter Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'mitarbeiter'.

The following tables list the members exposed by the clsMitarbeiter type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsMitarbeiter Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bShowtip |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iFuermandant |
Supported by the .NET Compact Framework. | iFunktionnr |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMitarbeiternr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iPartnernr |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSprache |
Supported by the .NET Compact Framework. | sAnrede |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sEmail |
Supported by the .NET Compact Framework. | sFax |
Supported by the .NET Compact Framework. | sKurzzeichen |
Supported by the .NET Compact Framework. | sName |
Supported by the .NET Compact Framework. | sTelefon |
Supported by the .NET Compact Framework. | sTgnummer |
Supported by the .NET Compact Framework. | sUnterschrift_text |
Supported by the .NET Compact Framework. | sVorname |
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_bShowtip |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iFuermandant |
Supported by the .NET Compact Framework. | m_iFunktionnr |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMitarbeiternr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iPartnernr |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSprache |
Supported by the .NET Compact Framework. | m_sAnrede |
Supported by the .NET Compact Framework. | m_sEmail |
Supported by the .NET Compact Framework. | m_sFax |
Supported by the .NET Compact Framework. | m_sKurzzeichen |
Supported by the .NET Compact Framework. | m_sName |
Supported by the .NET Compact Framework. | m_sTelefon |
Supported by the .NET Compact Framework. | m_sTgnummer |
Supported by the .NET Compact Framework. | m_sUnterschrift_text |
Supported by the .NET Compact Framework. | m_sVorname |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsMitarbeiter Class


clsMitarbeiter Properties

clsMitarbeiter Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bShowtip |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iFuermandant |
Supported by the .NET Compact Framework. | iFunktionnr |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMitarbeiternr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iPartnernr |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSprache |
Supported by the .NET Compact Framework. | sAnrede |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sEmail |
Supported by the .NET Compact Framework. | sFax |
Supported by the .NET Compact Framework. | sKurzzeichen |
Supported by the .NET Compact Framework. | sName |
Supported by the .NET Compact Framework. | sTelefon |
Supported by the .NET Compact Framework. | sTgnummer |
Supported by the .NET Compact Framework. | sUnterschrift_text |
Supported by the .NET Compact Framework. | sVorname |
Top

Expand image See Also

Reference

clsMitarbeiter Class


clsMitarbeiter Methods

clsMitarbeiter Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsMitarbeiter Class


clsMitarbeiter Fields

clsMitarbeiter Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_bShowtip |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iFuermandant |
Supported by the .NET Compact Framework. | m_iFunktionnr |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMitarbeiternr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iPartnernr |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSprache |
Supported by the .NET Compact Framework. | m_sAnrede |
Supported by the .NET Compact Framework. | m_sEmail |
Supported by the .NET Compact Framework. | m_sFax |
Supported by the .NET Compact Framework. | m_sKurzzeichen |
Supported by the .NET Compact Framework. | m_sName |
Supported by the .NET Compact Framework. | m_sTelefon |
Supported by the .NET Compact Framework. | m_sTgnummer |
Supported by the .NET Compact Framework. | m_sUnterschrift_text |
Supported by the .NET Compact Framework. | m_sVorname |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsMitarbeiter Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bShowtip, m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


m_bShowtip Variable

m_bShowtip Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bShowtip As SqlBoolean
C#
private SqlBoolean m_bShowtip;
C++
private:
SqlBoolean m_bShowtip;
JScript
private m_bShowtip : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bShowtip, m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


m_iFuermandant Variable

m_iFuermandant Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iFuermandant As SqlInt32
C#
private SqlInt32 m_iFuermandant;
C++
private:
SqlInt32 m_iFuermandant;
JScript
private m_iFuermandant : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iFunktionnr, m_iSprache, m_iFuermandant, m_iMandantnr, m_iPartnernr, m_iMutierer, m_iMitarbeiternr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


m_iFunktionnr Variable

m_iFunktionnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iFunktionnr As SqlInt32
C#
private SqlInt32 m_iFunktionnr;
C++
private:
SqlInt32 m_iFunktionnr;
JScript
private m_iFunktionnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iFunktionnr, m_iSprache, m_iFuermandant, m_iMandantnr, m_iPartnernr, m_iMutierer, m_iMitarbeiternr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


m_iMandantnr Variable

m_iMandantnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandantnr As SqlInt32
C#
private SqlInt32 m_iMandantnr;
C++
private:
SqlInt32 m_iMandantnr;
JScript
private m_iMandantnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iFunktionnr, m_iSprache, m_iFuermandant, m_iMandantnr, m_iPartnernr, m_iMutierer, m_iMitarbeiternr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


m_iMitarbeiternr Variable

m_iMitarbeiternr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMitarbeiternr As SqlInt32
C#
private SqlInt32 m_iMitarbeiternr;
C++
private:
SqlInt32 m_iMitarbeiternr;
JScript
private m_iMitarbeiternr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iFunktionnr, m_iSprache, m_iFuermandant, m_iMandantnr, m_iPartnernr, m_iMutierer, m_iMitarbeiternr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iFunktionnr, m_iSprache, m_iFuermandant, m_iMandantnr, m_iPartnernr, m_iMutierer, m_iMitarbeiternr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


m_iPartnernr Variable

m_iPartnernr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iPartnernr As SqlInt32
C#
private SqlInt32 m_iPartnernr;
C++
private:
SqlInt32 m_iPartnernr;
JScript
private m_iPartnernr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iFunktionnr, m_iSprache, m_iFuermandant, m_iMandantnr, m_iPartnernr, m_iMutierer, m_iMitarbeiternr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


m_iSprache Variable

m_iSprache Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iSprache As SqlInt32
C#
private SqlInt32 m_iSprache;
C++
private:
SqlInt32 m_iSprache;
JScript
private m_iSprache : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iFunktionnr, m_iSprache, m_iFuermandant, m_iMandantnr, m_iPartnernr, m_iMutierer, m_iMitarbeiternr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


m_sAnrede Variable

m_sAnrede Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sAnrede As SqlString
C#
private SqlString m_sAnrede;
C++
private:
SqlString m_sAnrede;
JScript
private m_sAnrede : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sName, m_sKurzzeichen, m_sUnterschrift_text, m_sVorname, m_sFax, m_sTelefon, m_sEmail, m_sAnrede, m_sTgnummer As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


m_sEmail Variable

m_sEmail Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sEmail As SqlString
C#
private SqlString m_sEmail;
C++
private:
SqlString m_sEmail;
JScript
private m_sEmail : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sName, m_sKurzzeichen, m_sUnterschrift_text, m_sVorname, m_sFax, m_sTelefon, m_sEmail, m_sAnrede, m_sTgnummer As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


m_sFax Variable

m_sFax Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sFax As SqlString
C#
private SqlString m_sFax;
C++
private:
SqlString m_sFax;
JScript
private m_sFax : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sName, m_sKurzzeichen, m_sUnterschrift_text, m_sVorname, m_sFax, m_sTelefon, m_sEmail, m_sAnrede, m_sTgnummer As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


m_sKurzzeichen Variable

m_sKurzzeichen Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sKurzzeichen As SqlString
C#
private SqlString m_sKurzzeichen;
C++
private:
SqlString m_sKurzzeichen;
JScript
private m_sKurzzeichen : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sName, m_sKurzzeichen, m_sUnterschrift_text, m_sVorname, m_sFax, m_sTelefon, m_sEmail, m_sAnrede, m_sTgnummer As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


m_sName Variable

m_sName Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sName As SqlString
C#
private SqlString m_sName;
C++
private:
SqlString m_sName;
JScript
private m_sName : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sName, m_sKurzzeichen, m_sUnterschrift_text, m_sVorname, m_sFax, m_sTelefon, m_sEmail, m_sAnrede, m_sTgnummer As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


m_sTelefon Variable

m_sTelefon Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sTelefon As SqlString
C#
private SqlString m_sTelefon;
C++
private:
SqlString m_sTelefon;
JScript
private m_sTelefon : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sName, m_sKurzzeichen, m_sUnterschrift_text, m_sVorname, m_sFax, m_sTelefon, m_sEmail, m_sAnrede, m_sTgnummer As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


m_sTgnummer Variable

m_sTgnummer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sTgnummer As SqlString
C#
private SqlString m_sTgnummer;
C++
private:
SqlString m_sTgnummer;
JScript
private m_sTgnummer : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sName, m_sKurzzeichen, m_sUnterschrift_text, m_sVorname, m_sFax, m_sTelefon, m_sEmail, m_sAnrede, m_sTgnummer As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


m_sUnterschrift_text Variable

m_sUnterschrift_text Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sUnterschrift_text As SqlString
C#
private SqlString m_sUnterschrift_text;
C++
private:
SqlString m_sUnterschrift_text;
JScript
private m_sUnterschrift_text : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sName, m_sKurzzeichen, m_sUnterschrift_text, m_sVorname, m_sFax, m_sTelefon, m_sEmail, m_sAnrede, m_sTgnummer As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


m_sVorname Variable

m_sVorname Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sVorname As SqlString
C#
private SqlString m_sVorname;
C++
private:
SqlString m_sVorname;
JScript
private m_sVorname : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sName, m_sKurzzeichen, m_sUnterschrift_text, m_sVorname, m_sFax, m_sTelefon, m_sEmail, m_sAnrede, m_sTgnummer As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter Class
clsMitarbeiter Members


clsMitarbeiter_funktionsgruppe Class

clsMitarbeiter_funktionsgruppe Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'mitarbeiter_funktionsgruppe'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsMitarbeiter_funktionsgruppe
    Inherits clsDBInteractionBase
C#
public class clsMitarbeiter_funktionsgruppe : clsDBInteractionBase
C++

public ref class clsMitarbeiter_funktionsgruppe : public clsDBInteractionBase^
JScript
public class clsMitarbeiter_funktionsgruppe
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter_funktionsgruppe

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Members


clsMitarbeiter_funktionsgruppe Members

clsMitarbeiter_funktionsgruppe Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'mitarbeiter_funktionsgruppe'.

The following tables list the members exposed by the clsMitarbeiter_funktionsgruppe type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsMitarbeiter_funktionsgruppe Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iFunktionsgruppenr |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMitarbeiter_funktionsgruppenr |
Supported by the .NET Compact Framework. | iMitarbeiternr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iFunktionsgruppenr |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMitarbeiter_funktionsgruppenr |
Supported by the .NET Compact Framework. | m_iMitarbeiternr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class


clsMitarbeiter_funktionsgruppe Constructor

clsMitarbeiter_funktionsgruppe Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsMitarbeiter_funktionsgruppe();
C++

public:
System::Void clsMitarbeiter_funktionsgruppe()
JScript
public function clsMitarbeiter_funktionsgruppe();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class
clsMitarbeiter_funktionsgruppe Members


clsMitarbeiter_funktionsgruppe Properties

clsMitarbeiter_funktionsgruppe Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iFunktionsgruppenr |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMitarbeiter_funktionsgruppenr |
Supported by the .NET Compact Framework. | iMitarbeiternr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class


clsMitarbeiter_funktionsgruppe.bAktiv Property

clsMitarbeiter_funktionsgruppe.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class
clsMitarbeiter_funktionsgruppe Members


clsMitarbeiter_funktionsgruppe.daErstellt_am Property

clsMitarbeiter_funktionsgruppe.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class
clsMitarbeiter_funktionsgruppe Members


clsMitarbeiter_funktionsgruppe.daMutiert_am Property

clsMitarbeiter_funktionsgruppe.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class
clsMitarbeiter_funktionsgruppe Members


clsMitarbeiter_funktionsgruppe.iFunktionsgruppenr Property

clsMitarbeiter_funktionsgruppe.iFunktionsgruppenr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iFunktionsgruppenr() As SqlInt32
C#
public SqlInt32 iFunktionsgruppenr {get; set;}
C++
public:
property SqlInt32 iFunktionsgruppenr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iFunktionsgruppenr() : SqlInt32;
public function set iFunktionsgruppenr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iFunktionsgruppenr]() As SqlInt32
            Get
                Return m_iFunktionsgruppenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFunktionsgruppenr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class
clsMitarbeiter_funktionsgruppe Members


clsMitarbeiter_funktionsgruppe.iMandantnr Property

clsMitarbeiter_funktionsgruppe.iMandantnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandantnr() As SqlInt32
C#
public SqlInt32 iMandantnr {get; set;}
C++
public:
property SqlInt32 iMandantnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class
clsMitarbeiter_funktionsgruppe Members


clsMitarbeiter_funktionsgruppe.iMitarbeiter_funktionsgruppenr Property

clsMitarbeiter_funktionsgruppe.iMitarbeiter_funktionsgruppenr Property
See Also
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMitarbeiter_funktionsgruppenr() As SqlInt32
C#
public SqlInt32 iMitarbeiter_funktionsgruppenr {get; set;}
C++
public:
property SqlInt32 iMitarbeiter_funktionsgruppenr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMitarbeiter_funktionsgruppenr() : SqlInt32;
public function set iMitarbeiter_funktionsgruppenr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMitarbeiter_funktionsgruppenr]() As SqlInt32
            Get
                Return m_iMitarbeiter_funktionsgruppenr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMitarbeiter_funktionsgruppenrTmp As SqlInt32 = Value
                If iMitarbeiter_funktionsgruppenrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMitarbeiter_funktionsgruppenr", "iMitarbeiter_funktionsgruppenr can't be NULL")
                End If
                m_iMitarbeiter_funktionsgruppenr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class
clsMitarbeiter_funktionsgruppe Members


clsMitarbeiter_funktionsgruppe.iMitarbeiternr Property

clsMitarbeiter_funktionsgruppe.iMitarbeiternr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMitarbeiternr() As SqlInt32
C#
public SqlInt32 iMitarbeiternr {get; set;}
C++
public:
property SqlInt32 iMitarbeiternr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMitarbeiternr() : SqlInt32;
public function set iMitarbeiternr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMitarbeiternr]() As SqlInt32
            Get
                Return m_iMitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMitarbeiternr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class
clsMitarbeiter_funktionsgruppe Members


clsMitarbeiter_funktionsgruppe.iMutierer Property

clsMitarbeiter_funktionsgruppe.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class
clsMitarbeiter_funktionsgruppe Members


clsMitarbeiter_funktionsgruppe Methods

clsMitarbeiter_funktionsgruppe Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class


clsMitarbeiter_funktionsgruppe.Delete Method

clsMitarbeiter_funktionsgruppe.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iMitarbeiter_funktionsgruppenr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_funktionsgruppe_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiter_funktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiter_funktionsgruppenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_funktionsgruppe_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter_funktionsgruppe::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class
clsMitarbeiter_funktionsgruppe Members


clsMitarbeiter_funktionsgruppe.Insert Method

clsMitarbeiter_funktionsgruppe.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iMitarbeiter_funktionsgruppenr</LI> <LI>iMitarbeiternr. May be SqlInt32.Null</LI> <LI>iFunktionsgruppenr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_funktionsgruppe_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiter_funktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiter_funktionsgruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_funktionsgruppe_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter_funktionsgruppe::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class
clsMitarbeiter_funktionsgruppe Members


clsMitarbeiter_funktionsgruppe.SelectAll Method

clsMitarbeiter_funktionsgruppe.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_funktionsgruppe_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("mitarbeiter_funktionsgruppe")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_funktionsgruppe_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter_funktionsgruppe::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class
clsMitarbeiter_funktionsgruppe Members


clsMitarbeiter_funktionsgruppe.SelectOne Method

clsMitarbeiter_funktionsgruppe.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iMitarbeiter_funktionsgruppenr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iMitarbeiter_funktionsgruppenr</LI> <LI>iMitarbeiternr</LI> <LI>iFunktionsgruppenr</LI> <LI>bAktiv</LI> <LI>iMandantnr</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_funktionsgruppe_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("mitarbeiter_funktionsgruppe")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@imitarbeiter_funktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiter_funktionsgruppenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_funktionsgruppe_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iMitarbeiter_funktionsgruppenr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiter_funktionsgruppenr"), Integer))
                    If dtToReturn.Rows(0)("mitarbeiternr") Is System.DBNull.Value Then
                        m_iMitarbeiternr = SqlInt32.Null
                    Else
                        m_iMitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("funktionsgruppenr") Is System.DBNull.Value Then
                        m_iFunktionsgruppenr = SqlInt32.Null
                    Else
                        m_iFunktionsgruppenr = New SqlInt32(CType(dtToReturn.Rows(0)("funktionsgruppenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter_funktionsgruppe::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class
clsMitarbeiter_funktionsgruppe Members


clsMitarbeiter_funktionsgruppe.Update Method

clsMitarbeiter_funktionsgruppe.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iMitarbeiter_funktionsgruppenr</LI> <LI>iMitarbeiternr. May be SqlInt32.Null</LI> <LI>iFunktionsgruppenr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_funktionsgruppe_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiter_funktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiter_funktionsgruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_funktionsgruppe_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter_funktionsgruppe::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class
clsMitarbeiter_funktionsgruppe Members


clsMitarbeiter_funktionsgruppe Fields

clsMitarbeiter_funktionsgruppe Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iFunktionsgruppenr |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMitarbeiter_funktionsgruppenr |
Supported by the .NET Compact Framework. | m_iMitarbeiternr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class
clsMitarbeiter_funktionsgruppe Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class
clsMitarbeiter_funktionsgruppe Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class
clsMitarbeiter_funktionsgruppe Members


m_iFunktionsgruppenr Variable

m_iFunktionsgruppenr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iFunktionsgruppenr As SqlInt32
C#
private SqlInt32 m_iFunktionsgruppenr;
C++
private:
SqlInt32 m_iFunktionsgruppenr;
JScript
private m_iFunktionsgruppenr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iMitarbeiternr, m_iFunktionsgruppenr, m_iMitarbeiter_funktionsgruppenr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class
clsMitarbeiter_funktionsgruppe Members


m_iMandantnr Variable

m_iMandantnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandantnr As SqlInt32
C#
private SqlInt32 m_iMandantnr;
C++
private:
SqlInt32 m_iMandantnr;
JScript
private m_iMandantnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iMitarbeiternr, m_iFunktionsgruppenr, m_iMitarbeiter_funktionsgruppenr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class
clsMitarbeiter_funktionsgruppe Members


m_iMitarbeiter_funktionsgruppenr Variable

m_iMitarbeiter_funktionsgruppenr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMitarbeiter_funktionsgruppenr As SqlInt32
C#
private SqlInt32 m_iMitarbeiter_funktionsgruppenr;
C++
private:
SqlInt32 m_iMitarbeiter_funktionsgruppenr;
JScript
private m_iMitarbeiter_funktionsgruppenr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iMitarbeiternr, m_iFunktionsgruppenr, m_iMitarbeiter_funktionsgruppenr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class
clsMitarbeiter_funktionsgruppe Members


m_iMitarbeiternr Variable

m_iMitarbeiternr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMitarbeiternr As SqlInt32
C#
private SqlInt32 m_iMitarbeiternr;
C++
private:
SqlInt32 m_iMitarbeiternr;
JScript
private m_iMitarbeiternr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iMitarbeiternr, m_iFunktionsgruppenr, m_iMitarbeiter_funktionsgruppenr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class
clsMitarbeiter_funktionsgruppe Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iMitarbeiternr, m_iFunktionsgruppenr, m_iMitarbeiter_funktionsgruppenr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMitarbeiter_funktionsgruppe Class
clsMitarbeiter_funktionsgruppe Members


clsMyKey_Tabelle Class

clsMyKey_Tabelle Class
See Also Members
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsMyKey_Tabelle
    Inherits clsKey_tabelle
C#
public class clsMyKey_Tabelle : clsKey_tabelle
C++

public ref class clsMyKey_Tabelle : public clsKey_tabelle^
JScript
public class clsMyKey_Tabelle
   extends clsKey_tabelle

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle
Vertragsverwaltung.TKB.VV.DB.clsMyKey_Tabelle

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMyKey_Tabelle Members


clsMyKey_Tabelle Members

clsMyKey_Tabelle Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

The following tables list the members exposed by the clsMyKey_Tabelle type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsMyKey_Tabelle Constructor | Purpose: Class constructor. (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iKey_wert | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | iKeynr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | iMandantnr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | iMutierer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sBeschreibung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table. (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | get_dbkey |
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsMyKey_Tabelle Class


clsMyKey_Tabelle Properties

clsMyKey_Tabelle Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iKey_wert | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | iKeynr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | iMandantnr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | iMutierer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sBeschreibung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsMyKey_Tabelle Class


clsMyKey_Tabelle Methods

clsMyKey_Tabelle Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table. (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle).
Supported by the .NET Compact Framework. | get_dbkey |
Top

Expand image See Also

Reference

clsMyKey_Tabelle Class


clsMyKey_Tabelle.get_dbkey Method

clsMyKey_Tabelle.get_dbkey Method

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function get_dbkey( _
   ByVal Tablename As String _
) As Long
C#
public long get_dbkey(
   string Tablename
);
C++

public:
long get_dbkey(
   String^ Tablename
)
JScript
public function get_dbkey(
    Tablename : String
) : long;

Parameters

Tablename

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function get_dbkey(ByVal Tablename As String) As Long
            Dim m_dbkey As Long
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[sp_get_dbkey]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Tablename", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, Tablename))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dbkey", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_dbkey))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                Try
                    scmCmdToExecute.Connection.Open()
                Catch ex As Exception
                Finally
                End Try

                scmCmdToExecute.ExecuteNonQuery()
                m_dbkey = scmCmdToExecute.Parameters.Item("@dbkey").Value
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))
                scmCmdToExecute.Connection.Close()

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'sp_get_dbkey' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return m_dbkey
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKey_tabelle::get_dbkey::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMyKey_Tabelle Class
clsMyKey_Tabelle Members


clsMyKey_Tabelle Fields

clsMyKey_Tabelle Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsMyKey_Tabelle Class


clsPerson Class

clsPerson Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'Person'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsPerson
    Inherits clsDBInteractionBase
C#
public class clsPerson : clsDBInteractionBase
C++

public ref class clsPerson : public clsDBInteractionBase^
JScript
public class clsPerson
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsPerson
Vertragsverwaltung.TKB.VV.Vertrag.clsPersonen

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Members


clsPerson Members

clsPerson Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'Person'.

The following tables list the members exposed by the clsPerson type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsPerson Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantNr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iPersonNr |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr |
Supported by the .NET Compact Framework. | iVertragspartnernr |
Supported by the .NET Compact Framework. | sBemerkung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sEMail |
Supported by the .NET Compact Framework. | sInternet |
Supported by the .NET Compact Framework. | sName |
Supported by the .NET Compact Framework. | sOrt |
Supported by the .NET Compact Framework. | sPlz |
Supported by the .NET Compact Framework. | sPostfach |
Supported by the .NET Compact Framework. | sStrasse |
Supported by the .NET Compact Framework. | sTelefax |
Supported by the .NET Compact Framework. | sTelefon |
Supported by the .NET Compact Framework. | sVorname |
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantNr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iPersonNr |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSecurityLevelNr |
Supported by the .NET Compact Framework. | m_iVertragspartnernr |
Supported by the .NET Compact Framework. | m_sBemerkung |
Supported by the .NET Compact Framework. | m_sEMail |
Supported by the .NET Compact Framework. | m_sInternet |
Supported by the .NET Compact Framework. | m_sName |
Supported by the .NET Compact Framework. | m_sOrt |
Supported by the .NET Compact Framework. | m_sPlz |
Supported by the .NET Compact Framework. | m_sPostfach |
Supported by the .NET Compact Framework. | m_sStrasse |
Supported by the .NET Compact Framework. | m_sTelefax |
Supported by the .NET Compact Framework. | m_sTelefon |
Supported by the .NET Compact Framework. | m_sVorname |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsPerson Class


clsPerson Constructor

clsPerson Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsPerson();
C++

public:
System::Void clsPerson()
JScript
public function clsPerson();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsPerson Properties

clsPerson Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantNr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iPersonNr |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr |
Supported by the .NET Compact Framework. | iVertragspartnernr |
Supported by the .NET Compact Framework. | sBemerkung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sEMail |
Supported by the .NET Compact Framework. | sInternet |
Supported by the .NET Compact Framework. | sName |
Supported by the .NET Compact Framework. | sOrt |
Supported by the .NET Compact Framework. | sPlz |
Supported by the .NET Compact Framework. | sPostfach |
Supported by the .NET Compact Framework. | sStrasse |
Supported by the .NET Compact Framework. | sTelefax |
Supported by the .NET Compact Framework. | sTelefon |
Supported by the .NET Compact Framework. | sVorname |
Top

Expand image See Also

Reference

clsPerson Class


clsPerson.bAktiv Property

clsPerson.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsPerson.daErstellt_am Property

clsPerson.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsPerson.daMutiert_am Property

clsPerson.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsPerson.iMandantNr Property

clsPerson.iMandantNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandantNr() As SqlInt32
C#
public SqlInt32 iMandantNr {get; set;}
C++
public:
property SqlInt32 iMandantNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandantNr() : SqlInt32;
public function set iMandantNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandantNr]() As SqlInt32
            Get
                Return m_iMandantNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsPerson.iMutierer Property

clsPerson.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsPerson.iPersonNr Property

clsPerson.iPersonNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iPersonNr() As SqlInt32
C#
public SqlInt32 iPersonNr {get; set;}
C++
public:
property SqlInt32 iPersonNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iPersonNr() : SqlInt32;
public function set iPersonNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iPersonNr]() As SqlInt32
            Get
                Return m_iPersonNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iPersonNrTmp As SqlInt32 = Value
                If iPersonNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iPersonNr", "iPersonNr can't be NULL")
                End If
                m_iPersonNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsPerson.iSecurityLevelNr Property

clsPerson.iSecurityLevelNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iSecurityLevelNr() As SqlInt32
C#
public SqlInt32 iSecurityLevelNr {get; set;}
C++
public:
property SqlInt32 iSecurityLevelNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iSecurityLevelNr() : SqlInt32;
public function set iSecurityLevelNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iSecurityLevelNr]() As SqlInt32
            Get
                Return m_iSecurityLevelNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityLevelNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsPerson.iVertragspartnernr Property

clsPerson.iVertragspartnernr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iVertragspartnernr() As SqlInt32
C#
public SqlInt32 iVertragspartnernr {get; set;}
C++
public:
property SqlInt32 iVertragspartnernr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iVertragspartnernr() : SqlInt32;
public function set iVertragspartnernr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iVertragspartnernr]() As SqlInt32
            Get
                Return m_iVertragspartnernr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVertragspartnernr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsPerson.sBemerkung Property

clsPerson.sBemerkung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBemerkung() As SqlString
C#
public SqlString sBemerkung {get; set;}
C++
public:
property SqlString sBemerkung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBemerkung() : SqlString;
public function set sBemerkung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBemerkung]() As SqlString
            Get
                Return m_sBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsPerson.sEMail Property

clsPerson.sEMail Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sEMail() As SqlString
C#
public SqlString sEMail {get; set;}
C++
public:
property SqlString sEMail {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sEMail() : SqlString;
public function set sEMail(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sEMail]() As SqlString
            Get
                Return m_sEMail
            End Get
            Set(ByVal Value As SqlString)
                m_sEMail = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsPerson.sInternet Property

clsPerson.sInternet Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sInternet() As SqlString
C#
public SqlString sInternet {get; set;}
C++
public:
property SqlString sInternet {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sInternet() : SqlString;
public function set sInternet(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sInternet]() As SqlString
            Get
                Return m_sInternet
            End Get
            Set(ByVal Value As SqlString)
                m_sInternet = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsPerson.sName Property

clsPerson.sName Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sName() As SqlString
C#
public SqlString sName {get; set;}
C++
public:
property SqlString sName {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sName() : SqlString;
public function set sName(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sName]() As SqlString
            Get
                Return m_sName
            End Get
            Set(ByVal Value As SqlString)
                m_sName = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsPerson.sOrt Property

clsPerson.sOrt Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sOrt() As SqlString
C#
public SqlString sOrt {get; set;}
C++
public:
property SqlString sOrt {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sOrt() : SqlString;
public function set sOrt(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sOrt]() As SqlString
            Get
                Return m_sOrt
            End Get
            Set(ByVal Value As SqlString)
                m_sOrt = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsPerson.sPlz Property

clsPerson.sPlz Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sPlz() As SqlString
C#
public SqlString sPlz {get; set;}
C++
public:
property SqlString sPlz {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sPlz() : SqlString;
public function set sPlz(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sPlz]() As SqlString
            Get
                Return m_sPlz
            End Get
            Set(ByVal Value As SqlString)
                m_sPlz = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsPerson.sPostfach Property

clsPerson.sPostfach Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sPostfach() As SqlString
C#
public SqlString sPostfach {get; set;}
C++
public:
property SqlString sPostfach {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sPostfach() : SqlString;
public function set sPostfach(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sPostfach]() As SqlString
            Get
                Return m_sPostfach
            End Get
            Set(ByVal Value As SqlString)
                m_sPostfach = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsPerson.sStrasse Property

clsPerson.sStrasse Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sStrasse() As SqlString
C#
public SqlString sStrasse {get; set;}
C++
public:
property SqlString sStrasse {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sStrasse() : SqlString;
public function set sStrasse(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sStrasse]() As SqlString
            Get
                Return m_sStrasse
            End Get
            Set(ByVal Value As SqlString)
                m_sStrasse = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsPerson.sTelefax Property

clsPerson.sTelefax Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sTelefax() As SqlString
C#
public SqlString sTelefax {get; set;}
C++
public:
property SqlString sTelefax {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sTelefax() : SqlString;
public function set sTelefax(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sTelefax]() As SqlString
            Get
                Return m_sTelefax
            End Get
            Set(ByVal Value As SqlString)
                m_sTelefax = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsPerson.sTelefon Property

clsPerson.sTelefon Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sTelefon() As SqlString
C#
public SqlString sTelefon {get; set;}
C++
public:
property SqlString sTelefon {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sTelefon() : SqlString;
public function set sTelefon(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sTelefon]() As SqlString
            Get
                Return m_sTelefon
            End Get
            Set(ByVal Value As SqlString)
                m_sTelefon = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsPerson.sVorname Property

clsPerson.sVorname Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sVorname() As SqlString
C#
public SqlString sVorname {get; set;}
C++
public:
property SqlString sVorname {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sVorname() : SqlString;
public function set sVorname(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sVorname]() As SqlString
            Get
                Return m_sVorname
            End Get
            Set(ByVal Value As SqlString)
                m_sVorname = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsPerson Methods

clsPerson Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsPerson Class


clsPerson.Delete Method

clsPerson.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iPersonNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Person_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPersonNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPersonNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Person_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPerson::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsPerson.Insert Method

clsPerson.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iPersonNr</LI> <LI>iVertragspartnernr. May be SqlInt32.Null</LI> <LI>sName. May be SqlString.Null</LI> <LI>sVorname. May be SqlString.Null</LI> <LI>sStrasse. May be SqlString.Null</LI> <LI>sPostfach. May be SqlString.Null</LI> <LI>sPlz. May be SqlString.Null</LI> <LI>sOrt. May be SqlString.Null</LI> <LI>sTelefon. May be SqlString.Null</LI> <LI>sTelefax. May be SqlString.Null</LI> <LI>sEMail. May be SqlString.Null</LI> <LI>sInternet. May be SqlString.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantNr. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Person_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPersonNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPersonNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragspartnernr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragspartnernr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sName", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sName))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVorname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVorname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sStrasse", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sStrasse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sPostfach", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPostfach))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sPlz", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPlz))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sOrt", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sOrt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTelefon", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTelefon))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTelefax", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTelefax))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sEMail", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sEMail))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sInternet", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sInternet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Person_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPerson::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsPerson.SelectAll Method

clsPerson.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Person_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Person")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Person_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPerson::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsPerson.SelectOne Method

clsPerson.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iPersonNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iPersonNr</LI> <LI>iVertragspartnernr</LI> <LI>sName</LI> <LI>sVorname</LI> <LI>sStrasse</LI> <LI>sPostfach</LI> <LI>sPlz</LI> <LI>sOrt</LI> <LI>sTelefon</LI> <LI>sTelefax</LI> <LI>sEMail</LI> <LI>sInternet</LI> <LI>sBemerkung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantNr</LI> <LI>iSecurityLevelNr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Person_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Person")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iPersonNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPersonNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Person_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iPersonNr = New SqlInt32(CType(dtToReturn.Rows(0)("PersonNr"), Integer))
                    If dtToReturn.Rows(0)("Vertragspartnernr") Is System.DBNull.Value Then
                        m_iVertragspartnernr = SqlInt32.Null
                    Else
                        m_iVertragspartnernr = New SqlInt32(CType(dtToReturn.Rows(0)("Vertragspartnernr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Name") Is System.DBNull.Value Then
                        m_sName = SqlString.Null
                    Else
                        m_sName = New SqlString(CType(dtToReturn.Rows(0)("Name"), String))
                    End If
                    If dtToReturn.Rows(0)("Vorname") Is System.DBNull.Value Then
                        m_sVorname = SqlString.Null
                    Else
                        m_sVorname = New SqlString(CType(dtToReturn.Rows(0)("Vorname"), String))
                    End If
                    If dtToReturn.Rows(0)("Strasse") Is System.DBNull.Value Then
                        m_sStrasse = SqlString.Null
                    Else
                        m_sStrasse = New SqlString(CType(dtToReturn.Rows(0)("Strasse"), String))
                    End If
                    If dtToReturn.Rows(0)("Postfach") Is System.DBNull.Value Then
                        m_sPostfach = SqlString.Null
                    Else
                        m_sPostfach = New SqlString(CType(dtToReturn.Rows(0)("Postfach"), String))
                    End If
                    If dtToReturn.Rows(0)("Plz") Is System.DBNull.Value Then
                        m_sPlz = SqlString.Null
                    Else
                        m_sPlz = New SqlString(CType(dtToReturn.Rows(0)("Plz"), String))
                    End If
                    If dtToReturn.Rows(0)("Ort") Is System.DBNull.Value Then
                        m_sOrt = SqlString.Null
                    Else
                        m_sOrt = New SqlString(CType(dtToReturn.Rows(0)("Ort"), String))
                    End If
                    If dtToReturn.Rows(0)("Telefon") Is System.DBNull.Value Then
                        m_sTelefon = SqlString.Null
                    Else
                        m_sTelefon = New SqlString(CType(dtToReturn.Rows(0)("Telefon"), String))
                    End If
                    If dtToReturn.Rows(0)("Telefax") Is System.DBNull.Value Then
                        m_sTelefax = SqlString.Null
                    Else
                        m_sTelefax = New SqlString(CType(dtToReturn.Rows(0)("Telefax"), String))
                    End If
                    If dtToReturn.Rows(0)("EMail") Is System.DBNull.Value Then
                        m_sEMail = SqlString.Null
                    Else
                        m_sEMail = New SqlString(CType(dtToReturn.Rows(0)("EMail"), String))
                    End If
                    If dtToReturn.Rows(0)("Internet") Is System.DBNull.Value Then
                        m_sInternet = SqlString.Null
                    Else
                        m_sInternet = New SqlString(CType(dtToReturn.Rows(0)("Internet"), String))
                    End If
                    If dtToReturn.Rows(0)("Bemerkung") Is System.DBNull.Value Then
                        m_sBemerkung = SqlString.Null
                    Else
                        m_sBemerkung = New SqlString(CType(dtToReturn.Rows(0)("Bemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("MandantNr") Is System.DBNull.Value Then
                        m_iMandantNr = SqlInt32.Null
                    Else
                        m_iMandantNr = New SqlInt32(CType(dtToReturn.Rows(0)("MandantNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("SecurityLevelNr") Is System.DBNull.Value Then
                        m_iSecurityLevelNr = SqlInt32.Null
                    Else
                        m_iSecurityLevelNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevelNr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPerson::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsPerson.Update Method

clsPerson.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iPersonNr</LI> <LI>iVertragspartnernr. May be SqlInt32.Null</LI> <LI>sName. May be SqlString.Null</LI> <LI>sVorname. May be SqlString.Null</LI> <LI>sStrasse. May be SqlString.Null</LI> <LI>sPostfach. May be SqlString.Null</LI> <LI>sPlz. May be SqlString.Null</LI> <LI>sOrt. May be SqlString.Null</LI> <LI>sTelefon. May be SqlString.Null</LI> <LI>sTelefax. May be SqlString.Null</LI> <LI>sEMail. May be SqlString.Null</LI> <LI>sInternet. May be SqlString.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantNr. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Person_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPersonNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPersonNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragspartnernr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragspartnernr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sName", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sName))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVorname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVorname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sStrasse", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sStrasse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sPostfach", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPostfach))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sPlz", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPlz))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sOrt", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sOrt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTelefon", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTelefon))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTelefax", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTelefax))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sEMail", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sEMail))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sInternet", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sInternet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Person_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPerson::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsPerson Fields

clsPerson Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantNr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iPersonNr |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSecurityLevelNr |
Supported by the .NET Compact Framework. | m_iVertragspartnernr |
Supported by the .NET Compact Framework. | m_sBemerkung |
Supported by the .NET Compact Framework. | m_sEMail |
Supported by the .NET Compact Framework. | m_sInternet |
Supported by the .NET Compact Framework. | m_sName |
Supported by the .NET Compact Framework. | m_sOrt |
Supported by the .NET Compact Framework. | m_sPlz |
Supported by the .NET Compact Framework. | m_sPostfach |
Supported by the .NET Compact Framework. | m_sStrasse |
Supported by the .NET Compact Framework. | m_sTelefax |
Supported by the .NET Compact Framework. | m_sTelefon |
Supported by the .NET Compact Framework. | m_sVorname |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsPerson Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


m_iMandantNr Variable

m_iMandantNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandantNr As SqlInt32
C#
private SqlInt32 m_iMandantNr;
C++
private:
SqlInt32 m_iMandantNr;
JScript
private m_iMandantNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iSecurityLevelNr, m_iMutierer, m_iMandantNr, m_iPersonNr, m_iVertragspartnernr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iSecurityLevelNr, m_iMutierer, m_iMandantNr, m_iPersonNr, m_iVertragspartnernr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


m_iPersonNr Variable

m_iPersonNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iPersonNr As SqlInt32
C#
private SqlInt32 m_iPersonNr;
C++
private:
SqlInt32 m_iPersonNr;
JScript
private m_iPersonNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iSecurityLevelNr, m_iMutierer, m_iMandantNr, m_iPersonNr, m_iVertragspartnernr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


m_iSecurityLevelNr Variable

m_iSecurityLevelNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iSecurityLevelNr As SqlInt32
C#
private SqlInt32 m_iSecurityLevelNr;
C++
private:
SqlInt32 m_iSecurityLevelNr;
JScript
private m_iSecurityLevelNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iSecurityLevelNr, m_iMutierer, m_iMandantNr, m_iPersonNr, m_iVertragspartnernr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


m_iVertragspartnernr Variable

m_iVertragspartnernr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iVertragspartnernr As SqlInt32
C#
private SqlInt32 m_iVertragspartnernr;
C++
private:
SqlInt32 m_iVertragspartnernr;
JScript
private m_iVertragspartnernr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iSecurityLevelNr, m_iMutierer, m_iMandantNr, m_iPersonNr, m_iVertragspartnernr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


m_sBemerkung Variable

m_sBemerkung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBemerkung As SqlString
C#
private SqlString m_sBemerkung;
C++
private:
SqlString m_sBemerkung;
JScript
private m_sBemerkung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sVorname, m_sStrasse, m_sTelefax, m_sName, m_sBemerkung, m_sTelefon, m_sOrt, m_sPlz, m_sInternet, m_sEMail, m_sPostfach As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


m_sEMail Variable

m_sEMail Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sEMail As SqlString
C#
private SqlString m_sEMail;
C++
private:
SqlString m_sEMail;
JScript
private m_sEMail : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sVorname, m_sStrasse, m_sTelefax, m_sName, m_sBemerkung, m_sTelefon, m_sOrt, m_sPlz, m_sInternet, m_sEMail, m_sPostfach As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


m_sInternet Variable

m_sInternet Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sInternet As SqlString
C#
private SqlString m_sInternet;
C++
private:
SqlString m_sInternet;
JScript
private m_sInternet : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sVorname, m_sStrasse, m_sTelefax, m_sName, m_sBemerkung, m_sTelefon, m_sOrt, m_sPlz, m_sInternet, m_sEMail, m_sPostfach As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


m_sName Variable

m_sName Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sName As SqlString
C#
private SqlString m_sName;
C++
private:
SqlString m_sName;
JScript
private m_sName : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sVorname, m_sStrasse, m_sTelefax, m_sName, m_sBemerkung, m_sTelefon, m_sOrt, m_sPlz, m_sInternet, m_sEMail, m_sPostfach As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


m_sOrt Variable

m_sOrt Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sOrt As SqlString
C#
private SqlString m_sOrt;
C++
private:
SqlString m_sOrt;
JScript
private m_sOrt : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sVorname, m_sStrasse, m_sTelefax, m_sName, m_sBemerkung, m_sTelefon, m_sOrt, m_sPlz, m_sInternet, m_sEMail, m_sPostfach As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


m_sPlz Variable

m_sPlz Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sPlz As SqlString
C#
private SqlString m_sPlz;
C++
private:
SqlString m_sPlz;
JScript
private m_sPlz : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sVorname, m_sStrasse, m_sTelefax, m_sName, m_sBemerkung, m_sTelefon, m_sOrt, m_sPlz, m_sInternet, m_sEMail, m_sPostfach As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


m_sPostfach Variable

m_sPostfach Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sPostfach As SqlString
C#
private SqlString m_sPostfach;
C++
private:
SqlString m_sPostfach;
JScript
private m_sPostfach : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sVorname, m_sStrasse, m_sTelefax, m_sName, m_sBemerkung, m_sTelefon, m_sOrt, m_sPlz, m_sInternet, m_sEMail, m_sPostfach As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


m_sStrasse Variable

m_sStrasse Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sStrasse As SqlString
C#
private SqlString m_sStrasse;
C++
private:
SqlString m_sStrasse;
JScript
private m_sStrasse : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sVorname, m_sStrasse, m_sTelefax, m_sName, m_sBemerkung, m_sTelefon, m_sOrt, m_sPlz, m_sInternet, m_sEMail, m_sPostfach As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


m_sTelefax Variable

m_sTelefax Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sTelefax As SqlString
C#
private SqlString m_sTelefax;
C++
private:
SqlString m_sTelefax;
JScript
private m_sTelefax : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sVorname, m_sStrasse, m_sTelefax, m_sName, m_sBemerkung, m_sTelefon, m_sOrt, m_sPlz, m_sInternet, m_sEMail, m_sPostfach As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


m_sTelefon Variable

m_sTelefon Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sTelefon As SqlString
C#
private SqlString m_sTelefon;
C++
private:
SqlString m_sTelefon;
JScript
private m_sTelefon : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sVorname, m_sStrasse, m_sTelefax, m_sName, m_sBemerkung, m_sTelefon, m_sOrt, m_sPlz, m_sInternet, m_sEMail, m_sPostfach As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


m_sVorname Variable

m_sVorname Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sVorname As SqlString
C#
private SqlString m_sVorname;
C++
private:
SqlString m_sVorname;
JScript
private m_sVorname : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sVorname, m_sStrasse, m_sTelefax, m_sName, m_sBemerkung, m_sTelefon, m_sOrt, m_sPlz, m_sInternet, m_sEMail, m_sPostfach As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPerson Class
clsPerson Members


clsRolle Class

clsRolle Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'rolle'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsRolle
    Inherits clsDBInteractionBase
C#
public class clsRolle : clsDBInteractionBase
C++

public ref class clsRolle : public clsDBInteractionBase^
JScript
public class clsRolle
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsRolle

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle Members


clsRolle Members

clsRolle Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'rolle'.

The following tables list the members exposed by the clsRolle type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsRolle Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bSysadminrolle |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRollenr |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_bSysadminrolle |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRollenr |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsRolle Class


clsRolle Constructor

clsRolle Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsRolle();
C++

public:
System::Void clsRolle()
JScript
public function clsRolle();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle Class
clsRolle Members


clsRolle Properties

clsRolle Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bSysadminrolle |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRollenr |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsRolle Class


clsRolle.bAktiv Property

clsRolle.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle Class
clsRolle Members


clsRolle.bSysadminrolle Property

clsRolle.bSysadminrolle Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bSysadminrolle() As SqlBoolean
C#
public SqlBoolean bSysadminrolle {get; set;}
C++
public:
property SqlBoolean bSysadminrolle {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bSysadminrolle() : SqlBoolean;
public function set bSysadminrolle(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bSysadminrolle]() As SqlBoolean
            Get
                Return m_bSysadminrolle
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bSysadminrolle = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle Class
clsRolle Members


clsRolle.daErstellt_am Property

clsRolle.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle Class
clsRolle Members


clsRolle.daMutiert_am Property

clsRolle.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle Class
clsRolle Members


clsRolle.iMandantnr Property

clsRolle.iMandantnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandantnr() As SqlInt32
C#
public SqlInt32 iMandantnr {get; set;}
C++
public:
property SqlInt32 iMandantnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle Class
clsRolle Members


clsRolle.iMutierer Property

clsRolle.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle Class
clsRolle Members


clsRolle.iRollenr Property

clsRolle.iRollenr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iRollenr() As SqlInt32
C#
public SqlInt32 iRollenr {get; set;}
C++
public:
property SqlInt32 iRollenr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iRollenr() : SqlInt32;
public function set iRollenr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iRollenr]() As SqlInt32
            Get
                Return m_iRollenr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iRollenrTmp As SqlInt32 = Value
                If iRollenrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iRollenr", "iRollenr can't be NULL")
                End If
                m_iRollenr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle Class
clsRolle Members


clsRolle.sBeschreibung Property

clsRolle.sBeschreibung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBeschreibung() As SqlString
C#
public SqlString sBeschreibung {get; set;}
C++
public:
property SqlString sBeschreibung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBeschreibung() : SqlString;
public function set sBeschreibung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle Class
clsRolle Members


clsRolle.sBezeichnung Property

clsRolle.sBezeichnung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBezeichnung() As SqlString
C#
public SqlString sBezeichnung {get; set;}
C++
public:
property SqlString sBezeichnung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBezeichnung() : SqlString;
public function set sBezeichnung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle Class
clsRolle Members


clsRolle Methods

clsRolle Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsRolle Class


clsRolle.Delete Method

clsRolle.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iRollenr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle Class
clsRolle Members


clsRolle.Insert Method

clsRolle.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iRollenr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bSysadminrolle. May be SqlBoolean.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bsysadminrolle", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bSysadminrolle))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle Class
clsRolle Members


clsRolle.SelectAll Method

clsRolle.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle Class
clsRolle Members


clsRolle.SelectOne Method

clsRolle.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iRollenr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iRollenr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>bSysadminrolle</LI> <LI>iMandantnr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iRollenr = New SqlInt32(CType(dtToReturn.Rows(0)("rollenr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("sysadminrolle") Is System.DBNull.Value Then
                        m_bSysadminrolle = SqlBoolean.Null
                    Else
                        m_bSysadminrolle = New SqlBoolean(CType(dtToReturn.Rows(0)("sysadminrolle"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle Class
clsRolle Members


clsRolle.Update Method

clsRolle.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iRollenr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bSysadminrolle. May be SqlBoolean.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bsysadminrolle", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bSysadminrolle))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle Class
clsRolle Members


clsRolle Fields

clsRolle Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_bSysadminrolle |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRollenr |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsRolle Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bSysadminrolle, m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle Class
clsRolle Members


m_bSysadminrolle Variable

m_bSysadminrolle Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bSysadminrolle As SqlBoolean
C#
private SqlBoolean m_bSysadminrolle;
C++
private:
SqlBoolean m_bSysadminrolle;
JScript
private m_bSysadminrolle : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bSysadminrolle, m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle Class
clsRolle Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle Class
clsRolle Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle Class
clsRolle Members


m_iMandantnr Variable

m_iMandantnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandantnr As SqlInt32
C#
private SqlInt32 m_iMandantnr;
C++
private:
SqlInt32 m_iMandantnr;
JScript
private m_iMandantnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iRollenr, m_iMandantnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle Class
clsRolle Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iRollenr, m_iMandantnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle Class
clsRolle Members


m_iRollenr Variable

m_iRollenr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iRollenr As SqlInt32
C#
private SqlInt32 m_iRollenr;
C++
private:
SqlInt32 m_iRollenr;
JScript
private m_iRollenr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iRollenr, m_iMandantnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle Class
clsRolle Members


m_sBeschreibung Variable

m_sBeschreibung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBeschreibung As SqlString
C#
private SqlString m_sBeschreibung;
C++
private:
SqlString m_sBeschreibung;
JScript
private m_sBeschreibung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBeschreibung, m_sBezeichnung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle Class
clsRolle Members


m_sBezeichnung Variable

m_sBezeichnung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBezeichnung As SqlString
C#
private SqlString m_sBezeichnung;
C++
private:
SqlString m_sBezeichnung;
JScript
private m_sBezeichnung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBeschreibung, m_sBezeichnung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle Class
clsRolle Members


clsRolle_SecurityObject Class

clsRolle_SecurityObject Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'Rolle_SecurityObject'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsRolle_SecurityObject
    Inherits clsDBInteractionBase
C#
public class clsRolle_SecurityObject : clsDBInteractionBase
C++

public ref class clsRolle_SecurityObject : public clsDBInteractionBase^
JScript
public class clsRolle_SecurityObject
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsRolle_SecurityObject

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Members


clsRolle_SecurityObject Members

clsRolle_SecurityObject Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'Rolle_SecurityObject'.

The following tables list the members exposed by the clsRolle_SecurityObject type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsRolle_SecurityObject Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bInvisible |
Supported by the .NET Compact Framework. | bReadonly |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRolle_securityobjectnr |
Supported by the .NET Compact Framework. | iRollenr |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityobjectnr |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bInvisible |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_bReadonly |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRolle_securityobjectnr |
Supported by the .NET Compact Framework. | m_iRollenr |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSecurityobjectnr |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsRolle_SecurityObject Class


clsRolle_SecurityObject Constructor

clsRolle_SecurityObject Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsRolle_SecurityObject();
C++

public:
System::Void clsRolle_SecurityObject()
JScript
public function clsRolle_SecurityObject();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


clsRolle_SecurityObject Properties

clsRolle_SecurityObject Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bInvisible |
Supported by the .NET Compact Framework. | bReadonly |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRolle_securityobjectnr |
Supported by the .NET Compact Framework. | iRollenr |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityobjectnr |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsRolle_SecurityObject Class


clsRolle_SecurityObject.bAktiv Property

clsRolle_SecurityObject.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


clsRolle_SecurityObject.bInvisible Property

clsRolle_SecurityObject.bInvisible Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bInvisible() As SqlBoolean
C#
public SqlBoolean bInvisible {get; set;}
C++
public:
property SqlBoolean bInvisible {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bInvisible() : SqlBoolean;
public function set bInvisible(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bInvisible]() As SqlBoolean
            Get
                Return m_bInvisible
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bInvisible = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


clsRolle_SecurityObject.bReadonly Property

clsRolle_SecurityObject.bReadonly Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bReadonly() As SqlBoolean
C#
public SqlBoolean bReadonly {get; set;}
C++
public:
property SqlBoolean bReadonly {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bReadonly() : SqlBoolean;
public function set bReadonly(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bReadonly]() As SqlBoolean
            Get
                Return m_bReadonly
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bReadonly = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


clsRolle_SecurityObject.daErstellt_am Property

clsRolle_SecurityObject.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


clsRolle_SecurityObject.daMutiert_am Property

clsRolle_SecurityObject.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


clsRolle_SecurityObject.iMandantnr Property

clsRolle_SecurityObject.iMandantnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandantnr() As SqlInt32
C#
public SqlInt32 iMandantnr {get; set;}
C++
public:
property SqlInt32 iMandantnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


clsRolle_SecurityObject.iMutierer Property

clsRolle_SecurityObject.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


clsRolle_SecurityObject.iRolle_securityobjectnr Property

clsRolle_SecurityObject.iRolle_securityobjectnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iRolle_securityobjectnr() As SqlInt32
C#
public SqlInt32 iRolle_securityobjectnr {get; set;}
C++
public:
property SqlInt32 iRolle_securityobjectnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iRolle_securityobjectnr() : SqlInt32;
public function set iRolle_securityobjectnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iRolle_securityobjectnr]() As SqlInt32
            Get
                Return m_iRolle_securityobjectnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iRolle_securityobjectnrTmp As SqlInt32 = Value
                If iRolle_securityobjectnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iRolle_securityobjectnr", "iRolle_securityobjectnr can't be NULL")
                End If
                m_iRolle_securityobjectnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


clsRolle_SecurityObject.iRollenr Property

clsRolle_SecurityObject.iRollenr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iRollenr() As SqlInt32
C#
public SqlInt32 iRollenr {get; set;}
C++
public:
property SqlInt32 iRollenr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iRollenr() : SqlInt32;
public function set iRollenr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iRollenr]() As SqlInt32
            Get
                Return m_iRollenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iRollenr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


clsRolle_SecurityObject.iSecurityobjectnr Property

clsRolle_SecurityObject.iSecurityobjectnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iSecurityobjectnr() As SqlInt32
C#
public SqlInt32 iSecurityobjectnr {get; set;}
C++
public:
property SqlInt32 iSecurityobjectnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iSecurityobjectnr() : SqlInt32;
public function set iSecurityobjectnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iSecurityobjectnr]() As SqlInt32
            Get
                Return m_iSecurityobjectnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityobjectnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


clsRolle_SecurityObject Methods

clsRolle_SecurityObject Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsRolle_SecurityObject Class


clsRolle_SecurityObject.Delete Method

clsRolle_SecurityObject.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iRolle_securityobjectnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Rolle_SecurityObject_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_securityobjectnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_securityobjectnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Rolle_SecurityObject_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_SecurityObject::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


clsRolle_SecurityObject.Insert Method

clsRolle_SecurityObject.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iRolle_securityobjectnr</LI> <LI>iRollenr. May be SqlInt32.Null</LI> <LI>iSecurityobjectnr. May be SqlInt32.Null</LI> <LI>bReadonly. May be SqlBoolean.Null</LI> <LI>bInvisible. May be SqlBoolean.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Rolle_SecurityObject_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_securityobjectnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_securityobjectnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isecurityobjectnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityobjectnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@breadonly", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bReadonly))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@binvisible", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bInvisible))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Rolle_SecurityObject_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_SecurityObject::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


clsRolle_SecurityObject.SelectAll Method

clsRolle_SecurityObject.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Rolle_SecurityObject_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Rolle_SecurityObject")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Rolle_SecurityObject_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_SecurityObject::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


clsRolle_SecurityObject.SelectOne Method

clsRolle_SecurityObject.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iRolle_securityobjectnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iRolle_securityobjectnr</LI> <LI>iRollenr</LI> <LI>iSecurityobjectnr</LI> <LI>bReadonly</LI> <LI>bInvisible</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Rolle_SecurityObject_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Rolle_SecurityObject")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@irolle_securityobjectnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_securityobjectnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Rolle_SecurityObject_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iRolle_securityobjectnr = New SqlInt32(CType(dtToReturn.Rows(0)("rolle_securityobjectnr"), Integer))
                    If dtToReturn.Rows(0)("rollenr") Is System.DBNull.Value Then
                        m_iRollenr = SqlInt32.Null
                    Else
                        m_iRollenr = New SqlInt32(CType(dtToReturn.Rows(0)("rollenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("securityobjectnr") Is System.DBNull.Value Then
                        m_iSecurityobjectnr = SqlInt32.Null
                    Else
                        m_iSecurityobjectnr = New SqlInt32(CType(dtToReturn.Rows(0)("securityobjectnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("readonly") Is System.DBNull.Value Then
                        m_bReadonly = SqlBoolean.Null
                    Else
                        m_bReadonly = New SqlBoolean(CType(dtToReturn.Rows(0)("readonly"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("invisible") Is System.DBNull.Value Then
                        m_bInvisible = SqlBoolean.Null
                    Else
                        m_bInvisible = New SqlBoolean(CType(dtToReturn.Rows(0)("invisible"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_SecurityObject::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


clsRolle_SecurityObject.Update Method

clsRolle_SecurityObject.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iRolle_securityobjectnr</LI> <LI>iRollenr. May be SqlInt32.Null</LI> <LI>iSecurityobjectnr. May be SqlInt32.Null</LI> <LI>bReadonly. May be SqlBoolean.Null</LI> <LI>bInvisible. May be SqlBoolean.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Rolle_SecurityObject_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_securityobjectnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_securityobjectnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isecurityobjectnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityobjectnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@breadonly", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bReadonly))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@binvisible", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bInvisible))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Rolle_SecurityObject_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_SecurityObject::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


clsRolle_SecurityObject Fields

clsRolle_SecurityObject Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bInvisible |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_bReadonly |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRolle_securityobjectnr |
Supported by the .NET Compact Framework. | m_iRollenr |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSecurityobjectnr |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsRolle_SecurityObject Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bReadonly, m_bAktiv, m_bInvisible As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


m_bInvisible Variable

m_bInvisible Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bInvisible As SqlBoolean
C#
private SqlBoolean m_bInvisible;
C++
private:
SqlBoolean m_bInvisible;
JScript
private m_bInvisible : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bReadonly, m_bAktiv, m_bInvisible As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


m_bReadonly Variable

m_bReadonly Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bReadonly As SqlBoolean
C#
private SqlBoolean m_bReadonly;
C++
private:
SqlBoolean m_bReadonly;
JScript
private m_bReadonly : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bReadonly, m_bAktiv, m_bInvisible As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


m_iMandantnr Variable

m_iMandantnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandantnr As SqlInt32
C#
private SqlInt32 m_iMandantnr;
C++
private:
SqlInt32 m_iMandantnr;
JScript
private m_iMandantnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iRollenr, m_iSecurityobjectnr, m_iRolle_securityobjectnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iRollenr, m_iSecurityobjectnr, m_iRolle_securityobjectnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


m_iRolle_securityobjectnr Variable

m_iRolle_securityobjectnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iRolle_securityobjectnr As SqlInt32
C#
private SqlInt32 m_iRolle_securityobjectnr;
C++
private:
SqlInt32 m_iRolle_securityobjectnr;
JScript
private m_iRolle_securityobjectnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iRollenr, m_iSecurityobjectnr, m_iRolle_securityobjectnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


m_iRollenr Variable

m_iRollenr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iRollenr As SqlInt32
C#
private SqlInt32 m_iRollenr;
C++
private:
SqlInt32 m_iRollenr;
JScript
private m_iRollenr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iRollenr, m_iSecurityobjectnr, m_iRolle_securityobjectnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


m_iSecurityobjectnr Variable

m_iSecurityobjectnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iSecurityobjectnr As SqlInt32
C#
private SqlInt32 m_iSecurityobjectnr;
C++
private:
SqlInt32 m_iSecurityobjectnr;
JScript
private m_iSecurityobjectnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iRollenr, m_iSecurityobjectnr, m_iRolle_securityobjectnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_SecurityObject Class
clsRolle_SecurityObject Members


clsRolle_securitylevel Class

clsRolle_securitylevel Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'rolle_securitylevel'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsRolle_securitylevel
    Inherits clsDBInteractionBase
C#
public class clsRolle_securitylevel : clsDBInteractionBase
C++

public ref class clsRolle_securitylevel : public clsDBInteractionBase^
JScript
public class clsRolle_securitylevel
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsRolle_securitylevel

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_securitylevel Members


clsRolle_securitylevel Members

clsRolle_securitylevel Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'rolle_securitylevel'.

The following tables list the members exposed by the clsRolle_securitylevel type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsRolle_securitylevel Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRolle_securitylevelnr |
Supported by the .NET Compact Framework. | iRollenr |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRolle_securitylevelnr |
Supported by the .NET Compact Framework. | m_iRollenr |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSecurityLevelNr |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsRolle_securitylevel Class


clsRolle_securitylevel Constructor

clsRolle_securitylevel Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsRolle_securitylevel();
C++

public:
System::Void clsRolle_securitylevel()
JScript
public function clsRolle_securitylevel();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_securitylevel Class
clsRolle_securitylevel Members


clsRolle_securitylevel Properties

clsRolle_securitylevel Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRolle_securitylevelnr |
Supported by the .NET Compact Framework. | iRollenr |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsRolle_securitylevel Class


clsRolle_securitylevel.bAktiv Property

clsRolle_securitylevel.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_securitylevel Class
clsRolle_securitylevel Members


clsRolle_securitylevel.daErstellt_am Property

clsRolle_securitylevel.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_securitylevel Class
clsRolle_securitylevel Members


clsRolle_securitylevel.daMutiert_am Property

clsRolle_securitylevel.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_securitylevel Class
clsRolle_securitylevel Members


clsRolle_securitylevel.iMandantnr Property

clsRolle_securitylevel.iMandantnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandantnr() As SqlInt32
C#
public SqlInt32 iMandantnr {get; set;}
C++
public:
property SqlInt32 iMandantnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_securitylevel Class
clsRolle_securitylevel Members


clsRolle_securitylevel.iMutierer Property

clsRolle_securitylevel.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_securitylevel Class
clsRolle_securitylevel Members


clsRolle_securitylevel.iRolle_securitylevelnr Property

clsRolle_securitylevel.iRolle_securitylevelnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iRolle_securitylevelnr() As SqlInt32
C#
public SqlInt32 iRolle_securitylevelnr {get; set;}
C++
public:
property SqlInt32 iRolle_securitylevelnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iRolle_securitylevelnr() : SqlInt32;
public function set iRolle_securitylevelnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iRolle_securitylevelnr]() As SqlInt32
            Get
                Return m_iRolle_securitylevelnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iRolle_securitylevelnrTmp As SqlInt32 = Value
                If iRolle_securitylevelnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iRolle_securitylevelnr", "iRolle_securitylevelnr can't be NULL")
                End If
                m_iRolle_securitylevelnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_securitylevel Class
clsRolle_securitylevel Members


clsRolle_securitylevel.iRollenr Property

clsRolle_securitylevel.iRollenr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iRollenr() As SqlInt32
C#
public SqlInt32 iRollenr {get; set;}
C++
public:
property SqlInt32 iRollenr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iRollenr() : SqlInt32;
public function set iRollenr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iRollenr]() As SqlInt32
            Get
                Return m_iRollenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iRollenr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_securitylevel Class
clsRolle_securitylevel Members


clsRolle_securitylevel.iSecurityLevelNr Property

clsRolle_securitylevel.iSecurityLevelNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iSecurityLevelNr() As SqlInt32
C#
public SqlInt32 iSecurityLevelNr {get; set;}
C++
public:
property SqlInt32 iSecurityLevelNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iSecurityLevelNr() : SqlInt32;
public function set iSecurityLevelNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iSecurityLevelNr]() As SqlInt32
            Get
                Return m_iSecurityLevelNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityLevelNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_securitylevel Class
clsRolle_securitylevel Members


clsRolle_securitylevel Methods

clsRolle_securitylevel Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsRolle_securitylevel Class


clsRolle_securitylevel.Delete Method

clsRolle_securitylevel.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iRolle_securitylevelnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_securitylevel_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_securitylevelnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_securitylevelnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_securitylevel_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_securitylevel::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_securitylevel Class
clsRolle_securitylevel Members


clsRolle_securitylevel.Insert Method

clsRolle_securitylevel.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iRolle_securitylevelnr</LI> <LI>iRollenr. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_securitylevel_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_securitylevelnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_securitylevelnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_securitylevel_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_securitylevel::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_securitylevel Class
clsRolle_securitylevel Members


clsRolle_securitylevel.SelectAll Method

clsRolle_securitylevel.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_securitylevel_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolle_securitylevel")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_securitylevel_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_securitylevel::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_securitylevel Class
clsRolle_securitylevel Members


clsRolle_securitylevel.SelectOne Method

clsRolle_securitylevel.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iRolle_securitylevelnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iRolle_securitylevelnr</LI> <LI>iRollenr</LI> <LI>iSecurityLevelNr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_securitylevel_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolle_securitylevel")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@irolle_securitylevelnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_securitylevelnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_securitylevel_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iRolle_securitylevelnr = New SqlInt32(CType(dtToReturn.Rows(0)("rolle_securitylevelnr"), Integer))
                    If dtToReturn.Rows(0)("rollenr") Is System.DBNull.Value Then
                        m_iRollenr = SqlInt32.Null
                    Else
                        m_iRollenr = New SqlInt32(CType(dtToReturn.Rows(0)("rollenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("SecurityLevelNr") Is System.DBNull.Value Then
                        m_iSecurityLevelNr = SqlInt32.Null
                    Else
                        m_iSecurityLevelNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevelNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_securitylevel::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_securitylevel Class
clsRolle_securitylevel Members


clsRolle_securitylevel.Update Method

clsRolle_securitylevel.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iRolle_securitylevelnr</LI> <LI>iRollenr. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_securitylevel_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_securitylevelnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_securitylevelnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_securitylevel_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_securitylevel::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_securitylevel Class
clsRolle_securitylevel Members


clsRolle_securitylevel Fields

clsRolle_securitylevel Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRolle_securitylevelnr |
Supported by the .NET Compact Framework. | m_iRollenr |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSecurityLevelNr |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsRolle_securitylevel Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_securitylevel Class
clsRolle_securitylevel Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_securitylevel Class
clsRolle_securitylevel Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_securitylevel Class
clsRolle_securitylevel Members


m_iMandantnr Variable

m_iMandantnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandantnr As SqlInt32
C#
private SqlInt32 m_iMandantnr;
C++
private:
SqlInt32 m_iMandantnr;
JScript
private m_iMandantnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iRollenr, m_iSecurityLevelNr, m_iRolle_securitylevelnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_securitylevel Class
clsRolle_securitylevel Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iRollenr, m_iSecurityLevelNr, m_iRolle_securitylevelnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_securitylevel Class
clsRolle_securitylevel Members


m_iRolle_securitylevelnr Variable

m_iRolle_securitylevelnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iRolle_securitylevelnr As SqlInt32
C#
private SqlInt32 m_iRolle_securitylevelnr;
C++
private:
SqlInt32 m_iRolle_securitylevelnr;
JScript
private m_iRolle_securitylevelnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iRollenr, m_iSecurityLevelNr, m_iRolle_securitylevelnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_securitylevel Class
clsRolle_securitylevel Members


m_iRollenr Variable

m_iRollenr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iRollenr As SqlInt32
C#
private SqlInt32 m_iRollenr;
C++
private:
SqlInt32 m_iRollenr;
JScript
private m_iRollenr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iRollenr, m_iSecurityLevelNr, m_iRolle_securitylevelnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_securitylevel Class
clsRolle_securitylevel Members


m_iSecurityLevelNr Variable

m_iSecurityLevelNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iSecurityLevelNr As SqlInt32
C#
private SqlInt32 m_iSecurityLevelNr;
C++
private:
SqlInt32 m_iSecurityLevelNr;
JScript
private m_iSecurityLevelNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iRollenr, m_iSecurityLevelNr, m_iRolle_securitylevelnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_securitylevel Class
clsRolle_securitylevel Members


clsRolle_sysadminfunktion Class

clsRolle_sysadminfunktion Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'rolle_sysadminfunktion'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsRolle_sysadminfunktion
    Inherits clsDBInteractionBase
C#
public class clsRolle_sysadminfunktion : clsDBInteractionBase
C++

public ref class clsRolle_sysadminfunktion : public clsDBInteractionBase^
JScript
public class clsRolle_sysadminfunktion
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsRolle_sysadminfunktion

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_sysadminfunktion Members


clsRolle_sysadminfunktion Members

clsRolle_sysadminfunktion Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'rolle_sysadminfunktion'.

The following tables list the members exposed by the clsRolle_sysadminfunktion type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsRolle_sysadminfunktion Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandant |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRolle_sysadminfnktnr |
Supported by the .NET Compact Framework. | iRollenr |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSysadminfnktnr |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandant |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRolle_sysadminfnktnr |
Supported by the .NET Compact Framework. | m_iRollenr |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSysadminfnktnr |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsRolle_sysadminfunktion Class


clsRolle_sysadminfunktion Constructor

clsRolle_sysadminfunktion Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsRolle_sysadminfunktion();
C++

public:
System::Void clsRolle_sysadminfunktion()
JScript
public function clsRolle_sysadminfunktion();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_sysadminfunktion Class
clsRolle_sysadminfunktion Members


clsRolle_sysadminfunktion Properties

clsRolle_sysadminfunktion Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandant |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRolle_sysadminfnktnr |
Supported by the .NET Compact Framework. | iRollenr |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSysadminfnktnr |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsRolle_sysadminfunktion Class


clsRolle_sysadminfunktion.bAktiv Property

clsRolle_sysadminfunktion.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_sysadminfunktion Class
clsRolle_sysadminfunktion Members


clsRolle_sysadminfunktion.daErstellt_am Property

clsRolle_sysadminfunktion.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_sysadminfunktion Class
clsRolle_sysadminfunktion Members


clsRolle_sysadminfunktion.daMutiert_am Property

clsRolle_sysadminfunktion.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_sysadminfunktion Class
clsRolle_sysadminfunktion Members


clsRolle_sysadminfunktion.iMandant Property

clsRolle_sysadminfunktion.iMandant Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandant() As SqlInt32
C#
public SqlInt32 iMandant {get; set;}
C++
public:
property SqlInt32 iMandant {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandant() : SqlInt32;
public function set iMandant(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandant]() As SqlInt32
            Get
                Return m_iMandant
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandant = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_sysadminfunktion Class
clsRolle_sysadminfunktion Members


clsRolle_sysadminfunktion.iMutierer Property

clsRolle_sysadminfunktion.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_sysadminfunktion Class
clsRolle_sysadminfunktion Members


clsRolle_sysadminfunktion.iRolle_sysadminfnktnr Property

clsRolle_sysadminfunktion.iRolle_sysadminfnktnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iRolle_sysadminfnktnr() As SqlInt32
C#
public SqlInt32 iRolle_sysadminfnktnr {get; set;}
C++
public:
property SqlInt32 iRolle_sysadminfnktnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iRolle_sysadminfnktnr() : SqlInt32;
public function set iRolle_sysadminfnktnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iRolle_sysadminfnktnr]() As SqlInt32
            Get
                Return m_iRolle_sysadminfnktnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iRolle_sysadminfnktnrTmp As SqlInt32 = Value
                If iRolle_sysadminfnktnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iRolle_sysadminfnktnr", "iRolle_sysadminfnktnr can't be NULL")
                End If
                m_iRolle_sysadminfnktnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_sysadminfunktion Class
clsRolle_sysadminfunktion Members


clsRolle_sysadminfunktion.iRollenr Property

clsRolle_sysadminfunktion.iRollenr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iRollenr() As SqlInt32
C#
public SqlInt32 iRollenr {get; set;}
C++
public:
property SqlInt32 iRollenr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iRollenr() : SqlInt32;
public function set iRollenr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iRollenr]() As SqlInt32
            Get
                Return m_iRollenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iRollenr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_sysadminfunktion Class
clsRolle_sysadminfunktion Members


clsRolle_sysadminfunktion.iSysadminfnktnr Property

clsRolle_sysadminfunktion.iSysadminfnktnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iSysadminfnktnr() As SqlInt32
C#
public SqlInt32 iSysadminfnktnr {get; set;}
C++
public:
property SqlInt32 iSysadminfnktnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iSysadminfnktnr() : SqlInt32;
public function set iSysadminfnktnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iSysadminfnktnr]() As SqlInt32
            Get
                Return m_iSysadminfnktnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSysadminfnktnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_sysadminfunktion Class
clsRolle_sysadminfunktion Members


clsRolle_sysadminfunktion Methods

clsRolle_sysadminfunktion Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsRolle_sysadminfunktion Class


clsRolle_sysadminfunktion.Delete Method

clsRolle_sysadminfunktion.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iRolle_sysadminfnktnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_sysadminfunktion_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_sysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_sysadminfnktnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_sysadminfunktion_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_sysadminfunktion::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_sysadminfunktion Class
clsRolle_sysadminfunktion Members


clsRolle_sysadminfunktion.Insert Method

clsRolle_sysadminfunktion.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iRolle_sysadminfnktnr</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iSysadminfnktnr. May be SqlInt32.Null</LI> <LI>iRollenr. May be SqlInt32.Null</LI> <LI>iMandant. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_sysadminfunktion_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_sysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_sysadminfnktnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSysadminfnktnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandant))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_sysadminfunktion_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_sysadminfunktion::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_sysadminfunktion Class
clsRolle_sysadminfunktion Members


clsRolle_sysadminfunktion.SelectAll Method

clsRolle_sysadminfunktion.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_sysadminfunktion_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolle_sysadminfunktion")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_sysadminfunktion_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_sysadminfunktion::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_sysadminfunktion Class
clsRolle_sysadminfunktion Members


clsRolle_sysadminfunktion.SelectOne Method

clsRolle_sysadminfunktion.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iRolle_sysadminfnktnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iRolle_sysadminfnktnr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iSysadminfnktnr</LI> <LI>iRollenr</LI> <LI>iMandant</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_sysadminfunktion_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolle_sysadminfunktion")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@irolle_sysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_sysadminfnktnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_sysadminfunktion_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iRolle_sysadminfnktnr = New SqlInt32(CType(dtToReturn.Rows(0)("rolle_sysadminfnktnr"), Integer))
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("sysadminfnktnr") Is System.DBNull.Value Then
                        m_iSysadminfnktnr = SqlInt32.Null
                    Else
                        m_iSysadminfnktnr = New SqlInt32(CType(dtToReturn.Rows(0)("sysadminfnktnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("rollenr") Is System.DBNull.Value Then
                        m_iRollenr = SqlInt32.Null
                    Else
                        m_iRollenr = New SqlInt32(CType(dtToReturn.Rows(0)("rollenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mandant") Is System.DBNull.Value Then
                        m_iMandant = SqlInt32.Null
                    Else
                        m_iMandant = New SqlInt32(CType(dtToReturn.Rows(0)("mandant"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_sysadminfunktion::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_sysadminfunktion Class
clsRolle_sysadminfunktion Members


clsRolle_sysadminfunktion.Update Method

clsRolle_sysadminfunktion.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iRolle_sysadminfnktnr</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iSysadminfnktnr. May be SqlInt32.Null</LI> <LI>iRollenr. May be SqlInt32.Null</LI> <LI>iMandant. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_sysadminfunktion_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_sysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_sysadminfnktnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSysadminfnktnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandant))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_sysadminfunktion_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_sysadminfunktion::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_sysadminfunktion Class
clsRolle_sysadminfunktion Members


clsRolle_sysadminfunktion Fields

clsRolle_sysadminfunktion Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandant |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRolle_sysadminfnktnr |
Supported by the .NET Compact Framework. | m_iRollenr |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSysadminfnktnr |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsRolle_sysadminfunktion Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_sysadminfunktion Class
clsRolle_sysadminfunktion Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_sysadminfunktion Class
clsRolle_sysadminfunktion Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_sysadminfunktion Class
clsRolle_sysadminfunktion Members


m_iMandant Variable

m_iMandant Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandant As SqlInt32
C#
private SqlInt32 m_iMandant;
C++
private:
SqlInt32 m_iMandant;
JScript
private m_iMandant : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iRollenr, m_iMandant, m_iSysadminfnktnr, m_iRolle_sysadminfnktnr, m_iMutierer As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_sysadminfunktion Class
clsRolle_sysadminfunktion Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iRollenr, m_iMandant, m_iSysadminfnktnr, m_iRolle_sysadminfnktnr, m_iMutierer As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_sysadminfunktion Class
clsRolle_sysadminfunktion Members


m_iRolle_sysadminfnktnr Variable

m_iRolle_sysadminfnktnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iRolle_sysadminfnktnr As SqlInt32
C#
private SqlInt32 m_iRolle_sysadminfnktnr;
C++
private:
SqlInt32 m_iRolle_sysadminfnktnr;
JScript
private m_iRolle_sysadminfnktnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iRollenr, m_iMandant, m_iSysadminfnktnr, m_iRolle_sysadminfnktnr, m_iMutierer As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_sysadminfunktion Class
clsRolle_sysadminfunktion Members


m_iRollenr Variable

m_iRollenr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iRollenr As SqlInt32
C#
private SqlInt32 m_iRollenr;
C++
private:
SqlInt32 m_iRollenr;
JScript
private m_iRollenr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iRollenr, m_iMandant, m_iSysadminfnktnr, m_iRolle_sysadminfnktnr, m_iMutierer As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_sysadminfunktion Class
clsRolle_sysadminfunktion Members


m_iSysadminfnktnr Variable

m_iSysadminfnktnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iSysadminfnktnr As SqlInt32
C#
private SqlInt32 m_iSysadminfnktnr;
C++
private:
SqlInt32 m_iSysadminfnktnr;
JScript
private m_iSysadminfnktnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iRollenr, m_iMandant, m_iSysadminfnktnr, m_iRolle_sysadminfnktnr, m_iMutierer As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsRolle_sysadminfunktion Class
clsRolle_sysadminfunktion Members


clsSLAKatalog Class

clsSLAKatalog Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'SLAKatalog'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsSLAKatalog
    Inherits clsDBInteractionBase
C#
public class clsSLAKatalog : clsDBInteractionBase
C++

public ref class clsSLAKatalog : public clsDBInteractionBase^
JScript
public class clsSLAKatalog
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsSLAKatalog

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Members


clsSLAKatalog Members

clsSLAKatalog Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'SLAKatalog'.

The following tables list the members exposed by the clsSLAKatalog type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsSLAKatalog Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bExtern |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | fZeit |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSLAKatalogNr |
Supported by the .NET Compact Framework. | iSLATypNr |
Supported by the .NET Compact Framework. | iSecurityLevel |
Supported by the .NET Compact Framework. | iZeiteinheittypnr |
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bExtern |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_fZeit |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSLAKatalogNr |
Supported by the .NET Compact Framework. | m_iSLATypNr |
Supported by the .NET Compact Framework. | m_iSecurityLevel |
Supported by the .NET Compact Framework. | m_iZeiteinheittypnr |
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsSLAKatalog Class


clsSLAKatalog Constructor

clsSLAKatalog Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsSLAKatalog();
C++

public:
System::Void clsSLAKatalog()
JScript
public function clsSLAKatalog();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


clsSLAKatalog Properties

clsSLAKatalog Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bExtern |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | fZeit |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSLAKatalogNr |
Supported by the .NET Compact Framework. | iSLATypNr |
Supported by the .NET Compact Framework. | iSecurityLevel |
Supported by the .NET Compact Framework. | iZeiteinheittypnr |
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsSLAKatalog Class


clsSLAKatalog.bAktiv Property

clsSLAKatalog.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


clsSLAKatalog.bExtern Property

clsSLAKatalog.bExtern Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bExtern() As SqlBoolean
C#
public SqlBoolean bExtern {get; set;}
C++
public:
property SqlBoolean bExtern {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bExtern() : SqlBoolean;
public function set bExtern(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bExtern]() As SqlBoolean
            Get
                Return m_bExtern
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bExtern = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


clsSLAKatalog.daErstellt_am Property

clsSLAKatalog.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


clsSLAKatalog.daMutiert_am Property

clsSLAKatalog.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


clsSLAKatalog.fZeit Property

clsSLAKatalog.fZeit Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property fZeit() As SqlDouble
C#
public SqlDouble fZeit {get; set;}
C++
public:
property SqlDouble fZeit {
 SqlDouble get( );
 void set(
   SqlDouble value
 );
}
JScript
public function get fZeit() : SqlDouble;
public function set fZeit(value : SqlDouble);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [fZeit]() As SqlDouble
            Get
                Return m_fZeit
            End Get
            Set(ByVal Value As SqlDouble)
                m_fZeit = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


clsSLAKatalog.iMandantnr Property

clsSLAKatalog.iMandantnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandantnr() As SqlInt32
C#
public SqlInt32 iMandantnr {get; set;}
C++
public:
property SqlInt32 iMandantnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


clsSLAKatalog.iMutierer Property

clsSLAKatalog.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


clsSLAKatalog.iSLAKatalogNr Property

clsSLAKatalog.iSLAKatalogNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iSLAKatalogNr() As SqlInt32
C#
public SqlInt32 iSLAKatalogNr {get; set;}
C++
public:
property SqlInt32 iSLAKatalogNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iSLAKatalogNr() : SqlInt32;
public function set iSLAKatalogNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iSLAKatalogNr]() As SqlInt32
            Get
                Return m_iSLAKatalogNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iSLAKatalogNrTmp As SqlInt32 = Value
                If iSLAKatalogNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iSLAKatalogNr", "iSLAKatalogNr can't be NULL")
                End If
                m_iSLAKatalogNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


clsSLAKatalog.iSLATypNr Property

clsSLAKatalog.iSLATypNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iSLATypNr() As SqlInt32
C#
public SqlInt32 iSLATypNr {get; set;}
C++
public:
property SqlInt32 iSLATypNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iSLATypNr() : SqlInt32;
public function set iSLATypNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iSLATypNr]() As SqlInt32
            Get
                Return m_iSLATypNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSLATypNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


clsSLAKatalog.iSecurityLevel Property

clsSLAKatalog.iSecurityLevel Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iSecurityLevel() As SqlInt32
C#
public SqlInt32 iSecurityLevel {get; set;}
C++
public:
property SqlInt32 iSecurityLevel {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iSecurityLevel() : SqlInt32;
public function set iSecurityLevel(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iSecurityLevel]() As SqlInt32
            Get
                Return m_iSecurityLevel
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityLevel = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


clsSLAKatalog.iZeiteinheittypnr Property

clsSLAKatalog.iZeiteinheittypnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iZeiteinheittypnr() As SqlInt32
C#
public SqlInt32 iZeiteinheittypnr {get; set;}
C++
public:
property SqlInt32 iZeiteinheittypnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iZeiteinheittypnr() : SqlInt32;
public function set iZeiteinheittypnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iZeiteinheittypnr]() As SqlInt32
            Get
                Return m_iZeiteinheittypnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iZeiteinheittypnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


clsSLAKatalog.sBeschreibung Property

clsSLAKatalog.sBeschreibung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBeschreibung() As SqlString
C#
public SqlString sBeschreibung {get; set;}
C++
public:
property SqlString sBeschreibung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBeschreibung() : SqlString;
public function set sBeschreibung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


clsSLAKatalog.sBezeichnung Property

clsSLAKatalog.sBezeichnung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBezeichnung() As SqlString
C#
public SqlString sBezeichnung {get; set;}
C++
public:
property SqlString sBezeichnung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBezeichnung() : SqlString;
public function set sBezeichnung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


clsSLAKatalog Methods

clsSLAKatalog Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsSLAKatalog Class


clsSLAKatalog.Delete Method

clsSLAKatalog.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iSLAKatalogNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLAKatalog_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLAKatalogNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSLAKatalogNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLAKatalog_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLAKatalog::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


clsSLAKatalog.Insert Method

clsSLAKatalog.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iSLAKatalogNr</LI> <LI>iSLATypNr. May be SqlInt32.Null</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>fZeit. May be SqlDouble.Null</LI> <LI>iZeiteinheittypnr. May be SqlInt32.Null</LI> <LI>bExtern. May be SqlBoolean.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>iSecurityLevel. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLAKatalog_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLAKatalogNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSLAKatalogNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLATypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSLATypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fZeit", SqlDbType.Float, 8, ParameterDirection.Input, True, 38, 0, "", DataRowVersion.Proposed, m_fZeit))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iZeiteinheittypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iZeiteinheittypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bExtern", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bExtern))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevel", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevel))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLAKatalog_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLAKatalog::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


clsSLAKatalog.SelectAll Method

clsSLAKatalog.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLAKatalog_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("SLAKatalog")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLAKatalog_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLAKatalog::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


clsSLAKatalog.SelectOne Method

clsSLAKatalog.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iSLAKatalogNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iSLAKatalogNr</LI> <LI>iSLATypNr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>fZeit</LI> <LI>iZeiteinheittypnr</LI> <LI>bExtern</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> <LI>iSecurityLevel</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLAKatalog_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("SLAKatalog")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iSLAKatalogNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSLAKatalogNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLAKatalog_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iSLAKatalogNr = New SqlInt32(CType(dtToReturn.Rows(0)("SLAKatalogNr"), Integer))
                    If dtToReturn.Rows(0)("SLATypNr") Is System.DBNull.Value Then
                        m_iSLATypNr = SqlInt32.Null
                    Else
                        m_iSLATypNr = New SqlInt32(CType(dtToReturn.Rows(0)("SLATypNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Zeit") Is System.DBNull.Value Then
                        m_fZeit = SqlDouble.Null
                    Else
                        m_fZeit = New SqlDouble(CType(dtToReturn.Rows(0)("Zeit"), Double))
                    End If
                    If dtToReturn.Rows(0)("Zeiteinheittypnr") Is System.DBNull.Value Then
                        m_iZeiteinheittypnr = SqlInt32.Null
                    Else
                        m_iZeiteinheittypnr = New SqlInt32(CType(dtToReturn.Rows(0)("Zeiteinheittypnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Extern") Is System.DBNull.Value Then
                        m_bExtern = SqlBoolean.Null
                    Else
                        m_bExtern = New SqlBoolean(CType(dtToReturn.Rows(0)("Extern"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("SecurityLevel") Is System.DBNull.Value Then
                        m_iSecurityLevel = SqlInt32.Null
                    Else
                        m_iSecurityLevel = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevel"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLAKatalog::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


clsSLAKatalog.Update Method

clsSLAKatalog.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iSLAKatalogNr</LI> <LI>iSLATypNr. May be SqlInt32.Null</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>fZeit. May be SqlDouble.Null</LI> <LI>iZeiteinheittypnr. May be SqlInt32.Null</LI> <LI>bExtern. May be SqlBoolean.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>iSecurityLevel. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLAKatalog_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLAKatalogNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSLAKatalogNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLATypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSLATypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fZeit", SqlDbType.Float, 8, ParameterDirection.Input, True, 38, 0, "", DataRowVersion.Proposed, m_fZeit))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iZeiteinheittypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iZeiteinheittypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bExtern", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bExtern))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevel", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevel))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLAKatalog_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLAKatalog::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


clsSLAKatalog Fields

clsSLAKatalog Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bExtern |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_fZeit |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSLAKatalogNr |
Supported by the .NET Compact Framework. | m_iSLATypNr |
Supported by the .NET Compact Framework. | m_iSecurityLevel |
Supported by the .NET Compact Framework. | m_iZeiteinheittypnr |
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsSLAKatalog Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bAktiv, m_bExtern As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


m_bExtern Variable

m_bExtern Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bExtern As SqlBoolean
C#
private SqlBoolean m_bExtern;
C++
private:
SqlBoolean m_bExtern;
JScript
private m_bExtern : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bAktiv, m_bExtern As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


m_fZeit Variable

m_fZeit Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_fZeit As SqlDouble
C#
private SqlDouble m_fZeit;
C++
private:
SqlDouble m_fZeit;
JScript
private m_fZeit : SqlDouble

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_fZeit As SqlDouble

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


m_iMandantnr Variable

m_iMandantnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandantnr As SqlInt32
C#
private SqlInt32 m_iMandantnr;
C++
private:
SqlInt32 m_iMandantnr;
JScript
private m_iMandantnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iSecurityLevel, m_iSLATypNr, m_iZeiteinheittypnr, m_iSLAKatalogNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iSecurityLevel, m_iSLATypNr, m_iZeiteinheittypnr, m_iSLAKatalogNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


m_iSLAKatalogNr Variable

m_iSLAKatalogNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iSLAKatalogNr As SqlInt32
C#
private SqlInt32 m_iSLAKatalogNr;
C++
private:
SqlInt32 m_iSLAKatalogNr;
JScript
private m_iSLAKatalogNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iSecurityLevel, m_iSLATypNr, m_iZeiteinheittypnr, m_iSLAKatalogNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


m_iSLATypNr Variable

m_iSLATypNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iSLATypNr As SqlInt32
C#
private SqlInt32 m_iSLATypNr;
C++
private:
SqlInt32 m_iSLATypNr;
JScript
private m_iSLATypNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iSecurityLevel, m_iSLATypNr, m_iZeiteinheittypnr, m_iSLAKatalogNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


m_iSecurityLevel Variable

m_iSecurityLevel Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iSecurityLevel As SqlInt32
C#
private SqlInt32 m_iSecurityLevel;
C++
private:
SqlInt32 m_iSecurityLevel;
JScript
private m_iSecurityLevel : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iSecurityLevel, m_iSLATypNr, m_iZeiteinheittypnr, m_iSLAKatalogNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


m_iZeiteinheittypnr Variable

m_iZeiteinheittypnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iZeiteinheittypnr As SqlInt32
C#
private SqlInt32 m_iZeiteinheittypnr;
C++
private:
SqlInt32 m_iZeiteinheittypnr;
JScript
private m_iZeiteinheittypnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iSecurityLevel, m_iSLATypNr, m_iZeiteinheittypnr, m_iSLAKatalogNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


m_sBeschreibung Variable

m_sBeschreibung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBeschreibung As SqlString
C#
private SqlString m_sBeschreibung;
C++
private:
SqlString m_sBeschreibung;
JScript
private m_sBeschreibung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBeschreibung, m_sBezeichnung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


m_sBezeichnung Variable

m_sBezeichnung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBezeichnung As SqlString
C#
private SqlString m_sBezeichnung;
C++
private:
SqlString m_sBezeichnung;
JScript
private m_sBezeichnung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBeschreibung, m_sBezeichnung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalog Class
clsSLAKatalog Members


clsSLATyp Class

clsSLATyp Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'SLATyp'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsSLATyp
    Inherits clsDBInteractionBase
C#
public class clsSLATyp : clsDBInteractionBase
C++

public ref class clsSLATyp : public clsDBInteractionBase^
JScript
public class clsSLATyp
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsSLATyp
Vertragsverwaltung.TKB.VV.DB.mySLATyp

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLATyp Members


clsSLATyp Members

clsSLATyp Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'SLATyp'.

The following tables list the members exposed by the clsSLATyp type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsSLATyp Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSLATypNr |
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSLATypNr |
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsSLATyp Class


clsSLATyp Constructor

clsSLATyp Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsSLATyp();
C++

public:
System::Void clsSLATyp()
JScript
public function clsSLATyp();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLATyp Class
clsSLATyp Members


clsSLATyp Properties

clsSLATyp Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSLATypNr |
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsSLATyp Class


clsSLATyp.bAktiv Property

clsSLATyp.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLATyp Class
clsSLATyp Members


clsSLATyp.daErstellt_am Property

clsSLATyp.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLATyp Class
clsSLATyp Members


clsSLATyp.daMutiert_am Property

clsSLATyp.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLATyp Class
clsSLATyp Members


clsSLATyp.iMandantnr Property

clsSLATyp.iMandantnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandantnr() As SqlInt32
C#
public SqlInt32 iMandantnr {get; set;}
C++
public:
property SqlInt32 iMandantnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLATyp Class
clsSLATyp Members


clsSLATyp.iMutierer Property

clsSLATyp.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLATyp Class
clsSLATyp Members


clsSLATyp.iSLATypNr Property

clsSLATyp.iSLATypNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iSLATypNr() As SqlInt32
C#
public SqlInt32 iSLATypNr {get; set;}
C++
public:
property SqlInt32 iSLATypNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iSLATypNr() : SqlInt32;
public function set iSLATypNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iSLATypNr]() As SqlInt32
            Get
                Return m_iSLATypNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iSLATypNrTmp As SqlInt32 = Value
                If iSLATypNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iSLATypNr", "iSLATypNr can't be NULL")
                End If
                m_iSLATypNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLATyp Class
clsSLATyp Members


clsSLATyp.sBeschreibung Property

clsSLATyp.sBeschreibung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBeschreibung() As SqlString
C#
public SqlString sBeschreibung {get; set;}
C++
public:
property SqlString sBeschreibung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBeschreibung() : SqlString;
public function set sBeschreibung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLATyp Class
clsSLATyp Members


clsSLATyp.sBezeichnung Property

clsSLATyp.sBezeichnung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBezeichnung() As SqlString
C#
public SqlString sBezeichnung {get; set;}
C++
public:
property SqlString sBezeichnung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBezeichnung() : SqlString;
public function set sBezeichnung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLATyp Class
clsSLATyp Members


clsSLATyp Methods

clsSLATyp Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsSLATyp Class


clsSLATyp.Delete Method

clsSLATyp.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iSLATypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLATyp_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLATypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSLATypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLATyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLATyp::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLATyp Class
clsSLATyp Members


clsSLATyp.Insert Method

clsSLATyp.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iSLATypNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLATyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLATypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSLATypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLATyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLATyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLATyp Class
clsSLATyp Members


clsSLATyp.SelectAll Method

clsSLATyp.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLATyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("SLATyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLATyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLATyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLATyp Class
clsSLATyp Members


clsSLATyp.SelectOne Method

clsSLATyp.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iSLATypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iSLATypNr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLATyp_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("SLATyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iSLATypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSLATypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLATyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iSLATypNr = New SqlInt32(CType(dtToReturn.Rows(0)("SLATypNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLATyp::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLATyp Class
clsSLATyp Members


clsSLATyp.Update Method

clsSLATyp.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iSLATypNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLATyp_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLATypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSLATypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLATyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLATyp::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLATyp Class
clsSLATyp Members


clsSLATyp Fields

clsSLATyp Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSLATypNr |
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsSLATyp Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLATyp Class
clsSLATyp Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLATyp Class
clsSLATyp Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLATyp Class
clsSLATyp Members


m_iMandantnr Variable

m_iMandantnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandantnr As SqlInt32
C#
private SqlInt32 m_iMandantnr;
C++
private:
SqlInt32 m_iMandantnr;
JScript
private m_iMandantnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iSLATypNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLATyp Class
clsSLATyp Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iSLATypNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLATyp Class
clsSLATyp Members


m_iSLATypNr Variable

m_iSLATypNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iSLATypNr As SqlInt32
C#
private SqlInt32 m_iSLATypNr;
C++
private:
SqlInt32 m_iSLATypNr;
JScript
private m_iSLATypNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iSLATypNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLATyp Class
clsSLATyp Members


m_sBeschreibung Variable

m_sBeschreibung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBeschreibung As SqlString
C#
private SqlString m_sBeschreibung;
C++
private:
SqlString m_sBeschreibung;
JScript
private m_sBeschreibung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLATyp Class
clsSLATyp Members


m_sBezeichnung Variable

m_sBezeichnung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBezeichnung As SqlString
C#
private SqlString m_sBezeichnung;
C++
private:
SqlString m_sBezeichnung;
JScript
private m_sBezeichnung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLATyp Class
clsSLATyp Members


clsSecurityLevel Class

clsSecurityLevel Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'SecurityLevel'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsSecurityLevel
    Inherits clsDBInteractionBase
C#
public class clsSecurityLevel : clsDBInteractionBase
C++

public ref class clsSecurityLevel : public clsDBInteractionBase^
JScript
public class clsSecurityLevel
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsSecurityLevel

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityLevel Members


clsSecurityLevel Members

clsSecurityLevel Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'SecurityLevel'.

The following tables list the members exposed by the clsSecurityLevel type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsSecurityLevel Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr |
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSecurityLevelNr |
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsSecurityLevel Class


clsSecurityLevel Constructor

clsSecurityLevel Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsSecurityLevel();
C++

public:
System::Void clsSecurityLevel()
JScript
public function clsSecurityLevel();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityLevel Class
clsSecurityLevel Members


clsSecurityLevel Properties

clsSecurityLevel Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr |
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsSecurityLevel Class


clsSecurityLevel.bAktiv Property

clsSecurityLevel.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityLevel Class
clsSecurityLevel Members


clsSecurityLevel.daErstellt_am Property

clsSecurityLevel.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityLevel Class
clsSecurityLevel Members


clsSecurityLevel.daMutiert_am Property

clsSecurityLevel.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityLevel Class
clsSecurityLevel Members


clsSecurityLevel.iMandantnr Property

clsSecurityLevel.iMandantnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandantnr() As SqlInt32
C#
public SqlInt32 iMandantnr {get; set;}
C++
public:
property SqlInt32 iMandantnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityLevel Class
clsSecurityLevel Members


clsSecurityLevel.iMutierer Property

clsSecurityLevel.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityLevel Class
clsSecurityLevel Members


clsSecurityLevel.iSecurityLevelNr Property

clsSecurityLevel.iSecurityLevelNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iSecurityLevelNr() As SqlInt32
C#
public SqlInt32 iSecurityLevelNr {get; set;}
C++
public:
property SqlInt32 iSecurityLevelNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iSecurityLevelNr() : SqlInt32;
public function set iSecurityLevelNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iSecurityLevelNr]() As SqlInt32
            Get
                Return m_iSecurityLevelNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iSecurityLevelNrTmp As SqlInt32 = Value
                If iSecurityLevelNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iSecurityLevelNr", "iSecurityLevelNr can't be NULL")
                End If
                m_iSecurityLevelNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityLevel Class
clsSecurityLevel Members


clsSecurityLevel.sBeschreibung Property

clsSecurityLevel.sBeschreibung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBeschreibung() As SqlString
C#
public SqlString sBeschreibung {get; set;}
C++
public:
property SqlString sBeschreibung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBeschreibung() : SqlString;
public function set sBeschreibung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityLevel Class
clsSecurityLevel Members


clsSecurityLevel.sBezeichnung Property

clsSecurityLevel.sBezeichnung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBezeichnung() As SqlString
C#
public SqlString sBezeichnung {get; set;}
C++
public:
property SqlString sBezeichnung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBezeichnung() : SqlString;
public function set sBezeichnung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityLevel Class
clsSecurityLevel Members


clsSecurityLevel Methods

clsSecurityLevel Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsSecurityLevel Class


clsSecurityLevel.Delete Method

clsSecurityLevel.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iSecurityLevelNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SecurityLevel_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SecurityLevel_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSecurityLevel::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityLevel Class
clsSecurityLevel Members


clsSecurityLevel.Insert Method

clsSecurityLevel.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iSecurityLevelNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SecurityLevel_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SecurityLevel_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSecurityLevel::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityLevel Class
clsSecurityLevel Members


clsSecurityLevel.SelectAll Method

clsSecurityLevel.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SecurityLevel_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("SecurityLevel")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SecurityLevel_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSecurityLevel::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityLevel Class
clsSecurityLevel Members


clsSecurityLevel.SelectOne Method

clsSecurityLevel.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iSecurityLevelNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iSecurityLevelNr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SecurityLevel_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("SecurityLevel")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SecurityLevel_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iSecurityLevelNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevelNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSecurityLevel::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityLevel Class
clsSecurityLevel Members


clsSecurityLevel.Update Method

clsSecurityLevel.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iSecurityLevelNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SecurityLevel_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SecurityLevel_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSecurityLevel::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityLevel Class
clsSecurityLevel Members


clsSecurityLevel Fields

clsSecurityLevel Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSecurityLevelNr |
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsSecurityLevel Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityLevel Class
clsSecurityLevel Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityLevel Class
clsSecurityLevel Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityLevel Class
clsSecurityLevel Members


m_iMandantnr Variable

m_iMandantnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandantnr As SqlInt32
C#
private SqlInt32 m_iMandantnr;
C++
private:
SqlInt32 m_iMandantnr;
JScript
private m_iMandantnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iSecurityLevelNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityLevel Class
clsSecurityLevel Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iSecurityLevelNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityLevel Class
clsSecurityLevel Members


m_iSecurityLevelNr Variable

m_iSecurityLevelNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iSecurityLevelNr As SqlInt32
C#
private SqlInt32 m_iSecurityLevelNr;
C++
private:
SqlInt32 m_iSecurityLevelNr;
JScript
private m_iSecurityLevelNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iSecurityLevelNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityLevel Class
clsSecurityLevel Members


m_sBeschreibung Variable

m_sBeschreibung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBeschreibung As SqlString
C#
private SqlString m_sBeschreibung;
C++
private:
SqlString m_sBeschreibung;
JScript
private m_sBeschreibung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityLevel Class
clsSecurityLevel Members


m_sBezeichnung Variable

m_sBezeichnung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBezeichnung As SqlString
C#
private SqlString m_sBezeichnung;
C++
private:
SqlString m_sBezeichnung;
JScript
private m_sBezeichnung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityLevel Class
clsSecurityLevel Members


clsSecurityObject Class

clsSecurityObject Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'SecurityObject'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsSecurityObject
    Inherits clsDBInteractionBase
C#
public class clsSecurityObject : clsDBInteractionBase
C++

public ref class clsSecurityObject : public clsDBInteractionBase^
JScript
public class clsSecurityObject
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsSecurityObject

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Members


clsSecurityObject Members

clsSecurityObject Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'SecurityObject'.

The following tables list the members exposed by the clsSecurityObject type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsSecurityObject Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iLevel |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityObjectNr |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sSecurityForm |
Supported by the .NET Compact Framework. | sSecurityObject |
Supported by the .NET Compact Framework. | sSecurityObjectDescriotion |
Supported by the .NET Compact Framework. | sSecurityObjectItem |
Supported by the .NET Compact Framework. | sSecurityObjectType |
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iLevel |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSecurityObjectNr |
Supported by the .NET Compact Framework. | m_sSecurityForm |
Supported by the .NET Compact Framework. | m_sSecurityObject |
Supported by the .NET Compact Framework. | m_sSecurityObjectDescriotion |
Supported by the .NET Compact Framework. | m_sSecurityObjectItem |
Supported by the .NET Compact Framework. | m_sSecurityObjectType |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsSecurityObject Class


clsSecurityObject Constructor

clsSecurityObject Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsSecurityObject();
C++

public:
System::Void clsSecurityObject()
JScript
public function clsSecurityObject();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


clsSecurityObject Properties

clsSecurityObject Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iLevel |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityObjectNr |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sSecurityForm |
Supported by the .NET Compact Framework. | sSecurityObject |
Supported by the .NET Compact Framework. | sSecurityObjectDescriotion |
Supported by the .NET Compact Framework. | sSecurityObjectItem |
Supported by the .NET Compact Framework. | sSecurityObjectType |
Top

Expand image See Also

Reference

clsSecurityObject Class


clsSecurityObject.bAktiv Property

clsSecurityObject.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


clsSecurityObject.daErstellt_am Property

clsSecurityObject.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


clsSecurityObject.daMutiert_am Property

clsSecurityObject.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


clsSecurityObject.iLevel Property

clsSecurityObject.iLevel Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iLevel() As SqlInt32
C#
public SqlInt32 iLevel {get; set;}
C++
public:
property SqlInt32 iLevel {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iLevel() : SqlInt32;
public function set iLevel(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iLevel]() As SqlInt32
            Get
                Return m_iLevel
            End Get
            Set(ByVal Value As SqlInt32)
                m_iLevel = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


clsSecurityObject.iMandantnr Property

clsSecurityObject.iMandantnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandantnr() As SqlInt32
C#
public SqlInt32 iMandantnr {get; set;}
C++
public:
property SqlInt32 iMandantnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


clsSecurityObject.iMutierer Property

clsSecurityObject.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


clsSecurityObject.iSecurityObjectNr Property

clsSecurityObject.iSecurityObjectNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iSecurityObjectNr() As SqlInt32
C#
public SqlInt32 iSecurityObjectNr {get; set;}
C++
public:
property SqlInt32 iSecurityObjectNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iSecurityObjectNr() : SqlInt32;
public function set iSecurityObjectNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iSecurityObjectNr]() As SqlInt32
            Get
                Return m_iSecurityObjectNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iSecurityObjectNrTmp As SqlInt32 = Value
                If iSecurityObjectNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iSecurityObjectNr", "iSecurityObjectNr can't be NULL")
                End If
                m_iSecurityObjectNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


clsSecurityObject.sSecurityForm Property

clsSecurityObject.sSecurityForm Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sSecurityForm() As SqlString
C#
public SqlString sSecurityForm {get; set;}
C++
public:
property SqlString sSecurityForm {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sSecurityForm() : SqlString;
public function set sSecurityForm(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sSecurityForm]() As SqlString
            Get
                Return m_sSecurityForm
            End Get
            Set(ByVal Value As SqlString)
                m_sSecurityForm = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


clsSecurityObject.sSecurityObject Property

clsSecurityObject.sSecurityObject Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sSecurityObject() As SqlString
C#
public SqlString sSecurityObject {get; set;}
C++
public:
property SqlString sSecurityObject {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sSecurityObject() : SqlString;
public function set sSecurityObject(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sSecurityObject]() As SqlString
            Get
                Return m_sSecurityObject
            End Get
            Set(ByVal Value As SqlString)
                m_sSecurityObject = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


clsSecurityObject.sSecurityObjectDescriotion Property

clsSecurityObject.sSecurityObjectDescriotion Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sSecurityObjectDescriotion() As SqlString
C#
public SqlString sSecurityObjectDescriotion {get; set;}
C++
public:
property SqlString sSecurityObjectDescriotion {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sSecurityObjectDescriotion() : SqlString;
public function set sSecurityObjectDescriotion(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sSecurityObjectDescriotion]() As SqlString
            Get
                Return m_sSecurityObjectDescriotion
            End Get
            Set(ByVal Value As SqlString)
                m_sSecurityObjectDescriotion = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


clsSecurityObject.sSecurityObjectItem Property

clsSecurityObject.sSecurityObjectItem Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sSecurityObjectItem() As SqlString
C#
public SqlString sSecurityObjectItem {get; set;}
C++
public:
property SqlString sSecurityObjectItem {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sSecurityObjectItem() : SqlString;
public function set sSecurityObjectItem(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sSecurityObjectItem]() As SqlString
            Get
                Return m_sSecurityObjectItem
            End Get
            Set(ByVal Value As SqlString)
                m_sSecurityObjectItem = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


clsSecurityObject.sSecurityObjectType Property

clsSecurityObject.sSecurityObjectType Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sSecurityObjectType() As SqlString
C#
public SqlString sSecurityObjectType {get; set;}
C++
public:
property SqlString sSecurityObjectType {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sSecurityObjectType() : SqlString;
public function set sSecurityObjectType(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sSecurityObjectType]() As SqlString
            Get
                Return m_sSecurityObjectType
            End Get
            Set(ByVal Value As SqlString)
                m_sSecurityObjectType = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


clsSecurityObject Methods

clsSecurityObject Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsSecurityObject Class


clsSecurityObject.Delete Method

clsSecurityObject.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iSecurityObjectNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SecurityObject_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityObjectNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSecurityObjectNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SecurityObject_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSecurityObject::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


clsSecurityObject.Insert Method

clsSecurityObject.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iSecurityObjectNr</LI> <LI>sSecurityForm. May be SqlString.Null</LI> <LI>sSecurityObjectType. May be SqlString.Null</LI> <LI>sSecurityObject. May be SqlString.Null</LI> <LI>sSecurityObjectItem. May be SqlString.Null</LI> <LI>sSecurityObjectDescriotion. May be SqlString.Null</LI> <LI>iLevel. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SecurityObject_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityObjectNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSecurityObjectNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSecurityForm", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSecurityForm))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSecurityObjectType", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSecurityObjectType))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSecurityObject", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSecurityObject))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSecurityObjectItem", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSecurityObjectItem))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSecurityObjectDescriotion", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSecurityObjectDescriotion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iLevel", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iLevel))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SecurityObject_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSecurityObject::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


clsSecurityObject.SelectAll Method

clsSecurityObject.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SecurityObject_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("SecurityObject")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SecurityObject_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSecurityObject::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


clsSecurityObject.SelectOne Method

clsSecurityObject.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iSecurityObjectNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iSecurityObjectNr</LI> <LI>sSecurityForm</LI> <LI>sSecurityObjectType</LI> <LI>sSecurityObject</LI> <LI>sSecurityObjectItem</LI> <LI>sSecurityObjectDescriotion</LI> <LI>iLevel</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SecurityObject_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("SecurityObject")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iSecurityObjectNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSecurityObjectNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SecurityObject_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iSecurityObjectNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityObjectNr"), Integer))
                    If dtToReturn.Rows(0)("SecurityForm") Is System.DBNull.Value Then
                        m_sSecurityForm = SqlString.Null
                    Else
                        m_sSecurityForm = New SqlString(CType(dtToReturn.Rows(0)("SecurityForm"), String))
                    End If
                    If dtToReturn.Rows(0)("SecurityObjectType") Is System.DBNull.Value Then
                        m_sSecurityObjectType = SqlString.Null
                    Else
                        m_sSecurityObjectType = New SqlString(CType(dtToReturn.Rows(0)("SecurityObjectType"), String))
                    End If
                    If dtToReturn.Rows(0)("SecurityObject") Is System.DBNull.Value Then
                        m_sSecurityObject = SqlString.Null
                    Else
                        m_sSecurityObject = New SqlString(CType(dtToReturn.Rows(0)("SecurityObject"), String))
                    End If
                    If dtToReturn.Rows(0)("SecurityObjectItem") Is System.DBNull.Value Then
                        m_sSecurityObjectItem = SqlString.Null
                    Else
                        m_sSecurityObjectItem = New SqlString(CType(dtToReturn.Rows(0)("SecurityObjectItem"), String))
                    End If
                    If dtToReturn.Rows(0)("SecurityObjectDescriotion") Is System.DBNull.Value Then
                        m_sSecurityObjectDescriotion = SqlString.Null
                    Else
                        m_sSecurityObjectDescriotion = New SqlString(CType(dtToReturn.Rows(0)("SecurityObjectDescriotion"), String))
                    End If
                    If dtToReturn.Rows(0)("Level") Is System.DBNull.Value Then
                        m_iLevel = SqlInt32.Null
                    Else
                        m_iLevel = New SqlInt32(CType(dtToReturn.Rows(0)("Level"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSecurityObject::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


clsSecurityObject.Update Method

clsSecurityObject.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iSecurityObjectNr</LI> <LI>sSecurityForm. May be SqlString.Null</LI> <LI>sSecurityObjectType. May be SqlString.Null</LI> <LI>sSecurityObject. May be SqlString.Null</LI> <LI>sSecurityObjectItem. May be SqlString.Null</LI> <LI>sSecurityObjectDescriotion. May be SqlString.Null</LI> <LI>iLevel. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SecurityObject_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityObjectNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSecurityObjectNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSecurityForm", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSecurityForm))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSecurityObjectType", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSecurityObjectType))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSecurityObject", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSecurityObject))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSecurityObjectItem", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSecurityObjectItem))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSecurityObjectDescriotion", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSecurityObjectDescriotion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iLevel", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iLevel))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SecurityObject_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSecurityObject::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


clsSecurityObject Fields

clsSecurityObject Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iLevel |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSecurityObjectNr |
Supported by the .NET Compact Framework. | m_sSecurityForm |
Supported by the .NET Compact Framework. | m_sSecurityObject |
Supported by the .NET Compact Framework. | m_sSecurityObjectDescriotion |
Supported by the .NET Compact Framework. | m_sSecurityObjectItem |
Supported by the .NET Compact Framework. | m_sSecurityObjectType |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsSecurityObject Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


m_iLevel Variable

m_iLevel Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iLevel As SqlInt32
C#
private SqlInt32 m_iLevel;
C++
private:
SqlInt32 m_iLevel;
JScript
private m_iLevel : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iLevel, m_iMutierer, m_iMandantnr, m_iSecurityObjectNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


m_iMandantnr Variable

m_iMandantnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandantnr As SqlInt32
C#
private SqlInt32 m_iMandantnr;
C++
private:
SqlInt32 m_iMandantnr;
JScript
private m_iMandantnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iLevel, m_iMutierer, m_iMandantnr, m_iSecurityObjectNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iLevel, m_iMutierer, m_iMandantnr, m_iSecurityObjectNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


m_iSecurityObjectNr Variable

m_iSecurityObjectNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iSecurityObjectNr As SqlInt32
C#
private SqlInt32 m_iSecurityObjectNr;
C++
private:
SqlInt32 m_iSecurityObjectNr;
JScript
private m_iSecurityObjectNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iLevel, m_iMutierer, m_iMandantnr, m_iSecurityObjectNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


m_sSecurityForm Variable

m_sSecurityForm Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sSecurityForm As SqlString
C#
private SqlString m_sSecurityForm;
C++
private:
SqlString m_sSecurityForm;
JScript
private m_sSecurityForm : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sSecurityForm, m_sSecurityObjectDescriotion, m_sSecurityObjectItem, m_sSecurityObject, m_sSecurityObjectType As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


m_sSecurityObject Variable

m_sSecurityObject Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sSecurityObject As SqlString
C#
private SqlString m_sSecurityObject;
C++
private:
SqlString m_sSecurityObject;
JScript
private m_sSecurityObject : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sSecurityForm, m_sSecurityObjectDescriotion, m_sSecurityObjectItem, m_sSecurityObject, m_sSecurityObjectType As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


m_sSecurityObjectDescriotion Variable

m_sSecurityObjectDescriotion Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sSecurityObjectDescriotion As SqlString
C#
private SqlString m_sSecurityObjectDescriotion;
C++
private:
SqlString m_sSecurityObjectDescriotion;
JScript
private m_sSecurityObjectDescriotion : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sSecurityForm, m_sSecurityObjectDescriotion, m_sSecurityObjectItem, m_sSecurityObject, m_sSecurityObjectType As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


m_sSecurityObjectItem Variable

m_sSecurityObjectItem Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sSecurityObjectItem As SqlString
C#
private SqlString m_sSecurityObjectItem;
C++
private:
SqlString m_sSecurityObjectItem;
JScript
private m_sSecurityObjectItem : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sSecurityForm, m_sSecurityObjectDescriotion, m_sSecurityObjectItem, m_sSecurityObject, m_sSecurityObjectType As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


m_sSecurityObjectType Variable

m_sSecurityObjectType Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sSecurityObjectType As SqlString
C#
private SqlString m_sSecurityObjectType;
C++
private:
SqlString m_sSecurityObjectType;
JScript
private m_sSecurityObjectType : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sSecurityForm, m_sSecurityObjectDescriotion, m_sSecurityObjectItem, m_sSecurityObject, m_sSecurityObjectType As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSecurityObject Class
clsSecurityObject Members


clsServiceKatalog Class

clsServiceKatalog Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'ServiceKatalog'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsServiceKatalog
    Inherits clsDBInteractionBase
C#
public class clsServiceKatalog : clsDBInteractionBase
C++

public ref class clsServiceKatalog : public clsDBInteractionBase^
JScript
public class clsServiceKatalog
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog
Vertragsverwaltung.TKB.VV.SLA.clsServiceKatalogDaten

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Members


clsServiceKatalog Members

clsServiceKatalog Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'ServiceKatalog'.

The following tables list the members exposed by the clsServiceKatalog type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsServiceKatalog Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bExtern |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iParentID |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr |
Supported by the .NET Compact Framework. | iServiceKatalogNr |
Supported by the .NET Compact Framework. | sBemerkung |
Supported by the .NET Compact Framework. | sBezeichnung_extern |
Supported by the .NET Compact Framework. | sBezeichnung_intern |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bExtern |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iParentID |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSecurityLevelNr |
Supported by the .NET Compact Framework. | m_iServiceKatalogNr |
Supported by the .NET Compact Framework. | m_sBemerkung |
Supported by the .NET Compact Framework. | m_sBezeichnung_extern |
Supported by the .NET Compact Framework. | m_sBezeichnung_intern |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsServiceKatalog Class


clsServiceKatalog Constructor

clsServiceKatalog Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsServiceKatalog();
C++

public:
System::Void clsServiceKatalog()
JScript
public function clsServiceKatalog();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


clsServiceKatalog Properties

clsServiceKatalog Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bExtern |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iParentID |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr |
Supported by the .NET Compact Framework. | iServiceKatalogNr |
Supported by the .NET Compact Framework. | sBemerkung |
Supported by the .NET Compact Framework. | sBezeichnung_extern |
Supported by the .NET Compact Framework. | sBezeichnung_intern |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsServiceKatalog Class


clsServiceKatalog.bAktiv Property

clsServiceKatalog.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


clsServiceKatalog.bExtern Property

clsServiceKatalog.bExtern Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bExtern() As SqlBoolean
C#
public SqlBoolean bExtern {get; set;}
C++
public:
property SqlBoolean bExtern {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bExtern() : SqlBoolean;
public function set bExtern(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bExtern]() As SqlBoolean
            Get
                Return m_bExtern
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bExtern = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


clsServiceKatalog.daErstellt_am Property

clsServiceKatalog.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


clsServiceKatalog.daMutiert_am Property

clsServiceKatalog.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


clsServiceKatalog.iMandantnr Property

clsServiceKatalog.iMandantnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandantnr() As SqlInt32
C#
public SqlInt32 iMandantnr {get; set;}
C++
public:
property SqlInt32 iMandantnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


clsServiceKatalog.iMutierer Property

clsServiceKatalog.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


clsServiceKatalog.iParentID Property

clsServiceKatalog.iParentID Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iParentID() As SqlInt32
C#
public SqlInt32 iParentID {get; set;}
C++
public:
property SqlInt32 iParentID {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iParentID() : SqlInt32;
public function set iParentID(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iParentID]() As SqlInt32
            Get
                Return m_iParentID
            End Get
            Set(ByVal Value As SqlInt32)
                m_iParentID = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


clsServiceKatalog.iSecurityLevelNr Property

clsServiceKatalog.iSecurityLevelNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iSecurityLevelNr() As SqlInt32
C#
public SqlInt32 iSecurityLevelNr {get; set;}
C++
public:
property SqlInt32 iSecurityLevelNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iSecurityLevelNr() : SqlInt32;
public function set iSecurityLevelNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iSecurityLevelNr]() As SqlInt32
            Get
                Return m_iSecurityLevelNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityLevelNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


clsServiceKatalog.iServiceKatalogNr Property

clsServiceKatalog.iServiceKatalogNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iServiceKatalogNr() As SqlInt32
C#
public SqlInt32 iServiceKatalogNr {get; set;}
C++
public:
property SqlInt32 iServiceKatalogNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iServiceKatalogNr() : SqlInt32;
public function set iServiceKatalogNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iServiceKatalogNr]() As SqlInt32
            Get
                Return m_iServiceKatalogNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iServiceKatalogNrTmp As SqlInt32 = Value
                If iServiceKatalogNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iServiceKatalogNr", "iServiceKatalogNr can't be NULL")
                End If
                m_iServiceKatalogNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


clsServiceKatalog.sBemerkung Property

clsServiceKatalog.sBemerkung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBemerkung() As SqlString
C#
public SqlString sBemerkung {get; set;}
C++
public:
property SqlString sBemerkung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBemerkung() : SqlString;
public function set sBemerkung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBemerkung]() As SqlString
            Get
                Return m_sBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


clsServiceKatalog.sBezeichnung_extern Property

clsServiceKatalog.sBezeichnung_extern Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBezeichnung_extern() As SqlString
C#
public SqlString sBezeichnung_extern {get; set;}
C++
public:
property SqlString sBezeichnung_extern {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBezeichnung_extern() : SqlString;
public function set sBezeichnung_extern(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBezeichnung_extern]() As SqlString
            Get
                Return m_sBezeichnung_extern
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung_extern = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


clsServiceKatalog.sBezeichnung_intern Property

clsServiceKatalog.sBezeichnung_intern Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBezeichnung_intern() As SqlString
C#
public SqlString sBezeichnung_intern {get; set;}
C++
public:
property SqlString sBezeichnung_intern {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBezeichnung_intern() : SqlString;
public function set sBezeichnung_intern(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBezeichnung_intern]() As SqlString
            Get
                Return m_sBezeichnung_intern
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung_intern = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


clsServiceKatalog Methods

clsServiceKatalog Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsServiceKatalog Class


clsServiceKatalog.Delete Method

clsServiceKatalog.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iServiceKatalogNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ServiceKatalog_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iServiceKatalogNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iServiceKatalogNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ServiceKatalog_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsServiceKatalog::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


clsServiceKatalog.Insert Method

clsServiceKatalog.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iServiceKatalogNr</LI> <LI>iParentID. May be SqlInt32.Null</LI> <LI>sBezeichnung_intern. May be SqlString.Null</LI> <LI>sBezeichnung_extern. May be SqlString.Null</LI> <LI>bExtern. May be SqlBoolean.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ServiceKatalog_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iServiceKatalogNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iServiceKatalogNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iParentID", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung_intern", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung_intern))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung_extern", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung_extern))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bextern", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bExtern))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ServiceKatalog_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsServiceKatalog::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


clsServiceKatalog.SelectAll Method

clsServiceKatalog.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ServiceKatalog_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ServiceKatalog")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ServiceKatalog_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsServiceKatalog::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


clsServiceKatalog.SelectOne Method

clsServiceKatalog.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iServiceKatalogNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iServiceKatalogNr</LI> <LI>iParentID</LI> <LI>sBezeichnung_intern</LI> <LI>sBezeichnung_extern</LI> <LI>bExtern</LI> <LI>sBemerkung</LI> <LI>iSecurityLevelNr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ServiceKatalog_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ServiceKatalog")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iServiceKatalogNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iServiceKatalogNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ServiceKatalog_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iServiceKatalogNr = New SqlInt32(CType(dtToReturn.Rows(0)("ServiceKatalogNr"), Integer))
                    If dtToReturn.Rows(0)("ParentID") Is System.DBNull.Value Then
                        m_iParentID = SqlInt32.Null
                    Else
                        m_iParentID = New SqlInt32(CType(dtToReturn.Rows(0)("ParentID"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Bezeichnung_intern") Is System.DBNull.Value Then
                        m_sBezeichnung_intern = SqlString.Null
                    Else
                        m_sBezeichnung_intern = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung_intern"), String))
                    End If
                    If dtToReturn.Rows(0)("Bezeichnung_extern") Is System.DBNull.Value Then
                        m_sBezeichnung_extern = SqlString.Null
                    Else
                        m_sBezeichnung_extern = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung_extern"), String))
                    End If
                    If dtToReturn.Rows(0)("extern") Is System.DBNull.Value Then
                        m_bExtern = SqlBoolean.Null
                    Else
                        m_bExtern = New SqlBoolean(CType(dtToReturn.Rows(0)("extern"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Bemerkung") Is System.DBNull.Value Then
                        m_sBemerkung = SqlString.Null
                    Else
                        m_sBemerkung = New SqlString(CType(dtToReturn.Rows(0)("Bemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("SecurityLevelNr") Is System.DBNull.Value Then
                        m_iSecurityLevelNr = SqlInt32.Null
                    Else
                        m_iSecurityLevelNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevelNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsServiceKatalog::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


clsServiceKatalog.Update Method

clsServiceKatalog.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iServiceKatalogNr</LI> <LI>iParentID. May be SqlInt32.Null</LI> <LI>sBezeichnung_intern. May be SqlString.Null</LI> <LI>sBezeichnung_extern. May be SqlString.Null</LI> <LI>bExtern. May be SqlBoolean.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ServiceKatalog_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iServiceKatalogNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iServiceKatalogNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iParentID", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung_intern", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung_intern))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung_extern", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung_extern))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bextern", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bExtern))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ServiceKatalog_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsServiceKatalog::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


clsServiceKatalog Fields

clsServiceKatalog Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bExtern |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iParentID |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSecurityLevelNr |
Supported by the .NET Compact Framework. | m_iServiceKatalogNr |
Supported by the .NET Compact Framework. | m_sBemerkung |
Supported by the .NET Compact Framework. | m_sBezeichnung_extern |
Supported by the .NET Compact Framework. | m_sBezeichnung_intern |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsServiceKatalog Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bAktiv, m_bExtern As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


m_bExtern Variable

m_bExtern Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bExtern As SqlBoolean
C#
private SqlBoolean m_bExtern;
C++
private:
SqlBoolean m_bExtern;
JScript
private m_bExtern : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bAktiv, m_bExtern As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


m_iMandantnr Variable

m_iMandantnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandantnr As SqlInt32
C#
private SqlInt32 m_iMandantnr;
C++
private:
SqlInt32 m_iMandantnr;
JScript
private m_iMandantnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iSecurityLevelNr, m_iMutierer, m_iServiceKatalogNr, m_iParentID, m_iMandantnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iSecurityLevelNr, m_iMutierer, m_iServiceKatalogNr, m_iParentID, m_iMandantnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


m_iParentID Variable

m_iParentID Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iParentID As SqlInt32
C#
private SqlInt32 m_iParentID;
C++
private:
SqlInt32 m_iParentID;
JScript
private m_iParentID : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iSecurityLevelNr, m_iMutierer, m_iServiceKatalogNr, m_iParentID, m_iMandantnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


m_iSecurityLevelNr Variable

m_iSecurityLevelNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iSecurityLevelNr As SqlInt32
C#
private SqlInt32 m_iSecurityLevelNr;
C++
private:
SqlInt32 m_iSecurityLevelNr;
JScript
private m_iSecurityLevelNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iSecurityLevelNr, m_iMutierer, m_iServiceKatalogNr, m_iParentID, m_iMandantnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


m_iServiceKatalogNr Variable

m_iServiceKatalogNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iServiceKatalogNr As SqlInt32
C#
private SqlInt32 m_iServiceKatalogNr;
C++
private:
SqlInt32 m_iServiceKatalogNr;
JScript
private m_iServiceKatalogNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iSecurityLevelNr, m_iMutierer, m_iServiceKatalogNr, m_iParentID, m_iMandantnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


m_sBemerkung Variable

m_sBemerkung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBemerkung As SqlString
C#
private SqlString m_sBemerkung;
C++
private:
SqlString m_sBemerkung;
JScript
private m_sBemerkung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBemerkung, m_sBezeichnung_extern, m_sBezeichnung_intern As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


m_sBezeichnung_extern Variable

m_sBezeichnung_extern Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBezeichnung_extern As SqlString
C#
private SqlString m_sBezeichnung_extern;
C++
private:
SqlString m_sBezeichnung_extern;
JScript
private m_sBezeichnung_extern : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBemerkung, m_sBezeichnung_extern, m_sBezeichnung_intern As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


m_sBezeichnung_intern Variable

m_sBezeichnung_intern Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBezeichnung_intern As SqlString
C#
private SqlString m_sBezeichnung_intern;
C++
private:
SqlString m_sBezeichnung_intern;
JScript
private m_sBezeichnung_intern : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBemerkung, m_sBezeichnung_extern, m_sBezeichnung_intern As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog Class
clsServiceKatalog Members


clsServiceKatalog_SLAKatalog Class

clsServiceKatalog_SLAKatalog Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'ServiceKatalog_SLAKatalog'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsServiceKatalog_SLAKatalog
    Inherits clsDBInteractionBase
C#
public class clsServiceKatalog_SLAKatalog : clsDBInteractionBase
C++

public ref class clsServiceKatalog_SLAKatalog : public clsDBInteractionBase^
JScript
public class clsServiceKatalog_SLAKatalog
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog_SLAKatalog

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Members


clsServiceKatalog_SLAKatalog Members

clsServiceKatalog_SLAKatalog Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'ServiceKatalog_SLAKatalog'.

The following tables list the members exposed by the clsServiceKatalog_SLAKatalog type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsServiceKatalog_SLAKatalog Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSLAKatalogNr |
Supported by the .NET Compact Framework. | iServiceKatalog_SLAKatalognr |
Supported by the .NET Compact Framework. | iServiceKatalognr |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSLAKatalogNr |
Supported by the .NET Compact Framework. | m_iServiceKatalog_SLAKatalognr |
Supported by the .NET Compact Framework. | m_iServiceKatalognr |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class


clsServiceKatalog_SLAKatalog Constructor

clsServiceKatalog_SLAKatalog Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsServiceKatalog_SLAKatalog();
C++

public:
System::Void clsServiceKatalog_SLAKatalog()
JScript
public function clsServiceKatalog_SLAKatalog();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class
clsServiceKatalog_SLAKatalog Members


clsServiceKatalog_SLAKatalog Properties

clsServiceKatalog_SLAKatalog Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSLAKatalogNr |
Supported by the .NET Compact Framework. | iServiceKatalog_SLAKatalognr |
Supported by the .NET Compact Framework. | iServiceKatalognr |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class


clsServiceKatalog_SLAKatalog.bAktiv Property

clsServiceKatalog_SLAKatalog.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class
clsServiceKatalog_SLAKatalog Members


clsServiceKatalog_SLAKatalog.daErstellt_am Property

clsServiceKatalog_SLAKatalog.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class
clsServiceKatalog_SLAKatalog Members


clsServiceKatalog_SLAKatalog.daMutiert_am Property

clsServiceKatalog_SLAKatalog.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class
clsServiceKatalog_SLAKatalog Members


clsServiceKatalog_SLAKatalog.iMandantnr Property

clsServiceKatalog_SLAKatalog.iMandantnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandantnr() As SqlInt32
C#
public SqlInt32 iMandantnr {get; set;}
C++
public:
property SqlInt32 iMandantnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class
clsServiceKatalog_SLAKatalog Members


clsServiceKatalog_SLAKatalog.iMutierer Property

clsServiceKatalog_SLAKatalog.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class
clsServiceKatalog_SLAKatalog Members


clsServiceKatalog_SLAKatalog.iSLAKatalogNr Property

clsServiceKatalog_SLAKatalog.iSLAKatalogNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iSLAKatalogNr() As SqlInt32
C#
public SqlInt32 iSLAKatalogNr {get; set;}
C++
public:
property SqlInt32 iSLAKatalogNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iSLAKatalogNr() : SqlInt32;
public function set iSLAKatalogNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iSLAKatalogNr]() As SqlInt32
            Get
                Return m_iSLAKatalogNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSLAKatalogNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class
clsServiceKatalog_SLAKatalog Members


clsServiceKatalog_SLAKatalog.iServiceKatalog_SLAKatalognr Property

clsServiceKatalog_SLAKatalog.iServiceKatalog_SLAKatalognr Property
See Also
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iServiceKatalog_SLAKatalognr() As SqlInt32
C#
public SqlInt32 iServiceKatalog_SLAKatalognr {get; set;}
C++
public:
property SqlInt32 iServiceKatalog_SLAKatalognr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iServiceKatalog_SLAKatalognr() : SqlInt32;
public function set iServiceKatalog_SLAKatalognr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iServiceKatalog_SLAKatalognr]() As SqlInt32
            Get
                Return m_iServiceKatalog_SLAKatalognr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iServiceKatalog_SLAKatalognrTmp As SqlInt32 = Value
                If iServiceKatalog_SLAKatalognrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iServiceKatalog_SLAKatalognr", "iServiceKatalog_SLAKatalognr can't be NULL")
                End If
                m_iServiceKatalog_SLAKatalognr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class
clsServiceKatalog_SLAKatalog Members


clsServiceKatalog_SLAKatalog.iServiceKatalognr Property

clsServiceKatalog_SLAKatalog.iServiceKatalognr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iServiceKatalognr() As SqlInt32
C#
public SqlInt32 iServiceKatalognr {get; set;}
C++
public:
property SqlInt32 iServiceKatalognr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iServiceKatalognr() : SqlInt32;
public function set iServiceKatalognr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iServiceKatalognr]() As SqlInt32
            Get
                Return m_iServiceKatalognr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iServiceKatalognr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class
clsServiceKatalog_SLAKatalog Members


clsServiceKatalog_SLAKatalog Methods

clsServiceKatalog_SLAKatalog Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class


clsServiceKatalog_SLAKatalog.Delete Method

clsServiceKatalog_SLAKatalog.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iServiceKatalog_SLAKatalognr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ServiceKatalog_SLAKatalog_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iServiceKatalog_SLAKatalognr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iServiceKatalog_SLAKatalognr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ServiceKatalog_SLAKatalog_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsServiceKatalog_SLAKatalog::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class
clsServiceKatalog_SLAKatalog Members


clsServiceKatalog_SLAKatalog.Insert Method

clsServiceKatalog_SLAKatalog.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iServiceKatalog_SLAKatalognr</LI> <LI>iServiceKatalognr. May be SqlInt32.Null</LI> <LI>iSLAKatalogNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ServiceKatalog_SLAKatalog_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iServiceKatalog_SLAKatalognr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iServiceKatalog_SLAKatalognr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iServiceKatalognr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iServiceKatalognr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLAKatalogNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSLAKatalogNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ServiceKatalog_SLAKatalog_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsServiceKatalog_SLAKatalog::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class
clsServiceKatalog_SLAKatalog Members


clsServiceKatalog_SLAKatalog.SelectAll Method

clsServiceKatalog_SLAKatalog.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ServiceKatalog_SLAKatalog_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ServiceKatalog_SLAKatalog")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ServiceKatalog_SLAKatalog_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsServiceKatalog_SLAKatalog::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class
clsServiceKatalog_SLAKatalog Members


clsServiceKatalog_SLAKatalog.SelectOne Method

clsServiceKatalog_SLAKatalog.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iServiceKatalog_SLAKatalognr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iServiceKatalog_SLAKatalognr</LI> <LI>iServiceKatalognr</LI> <LI>iSLAKatalogNr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ServiceKatalog_SLAKatalog_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ServiceKatalog_SLAKatalog")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iServiceKatalog_SLAKatalognr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iServiceKatalog_SLAKatalognr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ServiceKatalog_SLAKatalog_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iServiceKatalog_SLAKatalognr = New SqlInt32(CType(dtToReturn.Rows(0)("ServiceKatalog_SLAKatalognr"), Integer))
                    If dtToReturn.Rows(0)("ServiceKatalognr") Is System.DBNull.Value Then
                        m_iServiceKatalognr = SqlInt32.Null
                    Else
                        m_iServiceKatalognr = New SqlInt32(CType(dtToReturn.Rows(0)("ServiceKatalognr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("SLAKatalogNr") Is System.DBNull.Value Then
                        m_iSLAKatalogNr = SqlInt32.Null
                    Else
                        m_iSLAKatalogNr = New SqlInt32(CType(dtToReturn.Rows(0)("SLAKatalogNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsServiceKatalog_SLAKatalog::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class
clsServiceKatalog_SLAKatalog Members


clsServiceKatalog_SLAKatalog.Update Method

clsServiceKatalog_SLAKatalog.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iServiceKatalog_SLAKatalognr</LI> <LI>iServiceKatalognr. May be SqlInt32.Null</LI> <LI>iSLAKatalogNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ServiceKatalog_SLAKatalog_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iServiceKatalog_SLAKatalognr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iServiceKatalog_SLAKatalognr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iServiceKatalognr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iServiceKatalognr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLAKatalogNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSLAKatalogNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ServiceKatalog_SLAKatalog_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsServiceKatalog_SLAKatalog::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class
clsServiceKatalog_SLAKatalog Members


clsServiceKatalog_SLAKatalog Fields

clsServiceKatalog_SLAKatalog Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSLAKatalogNr |
Supported by the .NET Compact Framework. | m_iServiceKatalog_SLAKatalognr |
Supported by the .NET Compact Framework. | m_iServiceKatalognr |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class
clsServiceKatalog_SLAKatalog Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class
clsServiceKatalog_SLAKatalog Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class
clsServiceKatalog_SLAKatalog Members


m_iMandantnr Variable

m_iMandantnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandantnr As SqlInt32
C#
private SqlInt32 m_iMandantnr;
C++
private:
SqlInt32 m_iMandantnr;
JScript
private m_iMandantnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iServiceKatalognr, m_iSLAKatalogNr, m_iServiceKatalog_SLAKatalognr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class
clsServiceKatalog_SLAKatalog Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iServiceKatalognr, m_iSLAKatalogNr, m_iServiceKatalog_SLAKatalognr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class
clsServiceKatalog_SLAKatalog Members


m_iSLAKatalogNr Variable

m_iSLAKatalogNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iSLAKatalogNr As SqlInt32
C#
private SqlInt32 m_iSLAKatalogNr;
C++
private:
SqlInt32 m_iSLAKatalogNr;
JScript
private m_iSLAKatalogNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iServiceKatalognr, m_iSLAKatalogNr, m_iServiceKatalog_SLAKatalognr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class
clsServiceKatalog_SLAKatalog Members


m_iServiceKatalog_SLAKatalognr Variable

m_iServiceKatalog_SLAKatalognr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iServiceKatalog_SLAKatalognr As SqlInt32
C#
private SqlInt32 m_iServiceKatalog_SLAKatalognr;
C++
private:
SqlInt32 m_iServiceKatalog_SLAKatalognr;
JScript
private m_iServiceKatalog_SLAKatalognr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iServiceKatalognr, m_iSLAKatalogNr, m_iServiceKatalog_SLAKatalognr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class
clsServiceKatalog_SLAKatalog Members


m_iServiceKatalognr Variable

m_iServiceKatalognr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iServiceKatalognr As SqlInt32
C#
private SqlInt32 m_iServiceKatalognr;
C++
private:
SqlInt32 m_iServiceKatalognr;
JScript
private m_iServiceKatalognr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iServiceKatalognr, m_iSLAKatalogNr, m_iServiceKatalog_SLAKatalognr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalog_SLAKatalog Class
clsServiceKatalog_SLAKatalog Members


clsSpalten Class

clsSpalten Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'spalten'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsSpalten
    Inherits clsDBInteractionBase
C#
public class clsSpalten : clsDBInteractionBase
C++

public ref class clsSpalten : public clsDBInteractionBase^
JScript
public class clsSpalten
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsSpalten

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Members


clsSpalten Members

clsSpalten Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'spalten'.

The following tables list the members exposed by the clsSpalten type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsSpalten Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bAlsHacken |
Supported by the .NET Compact Framework. | bReadonly |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iBreite |
Supported by the .NET Compact Framework. | iEintragnr |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iReihenfolge |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sSpalte |
Supported by the .NET Compact Framework. | sTabelle |
Supported by the .NET Compact Framework. | sTabellenspalte |
Supported by the .NET Compact Framework. | sTiptext |
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bAlsHacken |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_bReadonly |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iBreite |
Supported by the .NET Compact Framework. | m_iEintragnr |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iReihenfolge |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_sSpalte |
Supported by the .NET Compact Framework. | m_sTabelle |
Supported by the .NET Compact Framework. | m_sTabellenspalte |
Supported by the .NET Compact Framework. | m_sTiptext |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsSpalten Class


clsSpalten Constructor

clsSpalten Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsSpalten();
C++

public:
System::Void clsSpalten()
JScript
public function clsSpalten();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


clsSpalten Properties

clsSpalten Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bAlsHacken |
Supported by the .NET Compact Framework. | bReadonly |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iBreite |
Supported by the .NET Compact Framework. | iEintragnr |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iReihenfolge |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sSpalte |
Supported by the .NET Compact Framework. | sTabelle |
Supported by the .NET Compact Framework. | sTabellenspalte |
Supported by the .NET Compact Framework. | sTiptext |
Top

Expand image See Also

Reference

clsSpalten Class


clsSpalten.bAktiv Property

clsSpalten.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bAktivTmp As SqlBoolean = Value
                If bAktivTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bAktiv", "bAktiv can't be NULL")
                End If
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


clsSpalten.bAlsHacken Property

clsSpalten.bAlsHacken Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAlsHacken() As SqlBoolean
C#
public SqlBoolean bAlsHacken {get; set;}
C++
public:
property SqlBoolean bAlsHacken {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAlsHacken() : SqlBoolean;
public function set bAlsHacken(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAlsHacken]() As SqlBoolean
            Get
                Return m_bAlsHacken
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bAlsHackenTmp As SqlBoolean = Value
                If bAlsHackenTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bAlsHacken", "bAlsHacken can't be NULL")
                End If
                m_bAlsHacken = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


clsSpalten.bReadonly Property

clsSpalten.bReadonly Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bReadonly() As SqlBoolean
C#
public SqlBoolean bReadonly {get; set;}
C++
public:
property SqlBoolean bReadonly {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bReadonly() : SqlBoolean;
public function set bReadonly(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bReadonly]() As SqlBoolean
            Get
                Return m_bReadonly
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bReadonlyTmp As SqlBoolean = Value
                If bReadonlyTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bReadonly", "bReadonly can't be NULL")
                End If
                m_bReadonly = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


clsSpalten.daErstellt_am Property

clsSpalten.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


clsSpalten.daMutiert_am Property

clsSpalten.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


clsSpalten.iBreite Property

clsSpalten.iBreite Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iBreite() As SqlInt32
C#
public SqlInt32 iBreite {get; set;}
C++
public:
property SqlInt32 iBreite {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iBreite() : SqlInt32;
public function set iBreite(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iBreite]() As SqlInt32
            Get
                Return m_iBreite
            End Get
            Set(ByVal Value As SqlInt32)
                m_iBreite = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


clsSpalten.iEintragnr Property

clsSpalten.iEintragnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iEintragnr() As SqlInt32
C#
public SqlInt32 iEintragnr {get; set;}
C++
public:
property SqlInt32 iEintragnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iEintragnr() : SqlInt32;
public function set iEintragnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iEintragnr]() As SqlInt32
            Get
                Return m_iEintragnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iEintragnrTmp As SqlInt32 = Value
                If iEintragnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iEintragnr", "iEintragnr can't be NULL")
                End If
                m_iEintragnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


clsSpalten.iMandantnr Property

clsSpalten.iMandantnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandantnr() As SqlInt32
C#
public SqlInt32 iMandantnr {get; set;}
C++
public:
property SqlInt32 iMandantnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


clsSpalten.iMutierer Property

clsSpalten.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


clsSpalten.iReihenfolge Property

clsSpalten.iReihenfolge Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iReihenfolge() As SqlInt32
C#
public SqlInt32 iReihenfolge {get; set;}
C++
public:
property SqlInt32 iReihenfolge {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iReihenfolge() : SqlInt32;
public function set iReihenfolge(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iReihenfolge]() As SqlInt32
            Get
                Return m_iReihenfolge
            End Get
            Set(ByVal Value As SqlInt32)
                m_iReihenfolge = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


clsSpalten.sSpalte Property

clsSpalten.sSpalte Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sSpalte() As SqlString
C#
public SqlString sSpalte {get; set;}
C++
public:
property SqlString sSpalte {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sSpalte() : SqlString;
public function set sSpalte(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sSpalte]() As SqlString
            Get
                Return m_sSpalte
            End Get
            Set(ByVal Value As SqlString)
                m_sSpalte = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


clsSpalten.sTabelle Property

clsSpalten.sTabelle Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sTabelle() As SqlString
C#
public SqlString sTabelle {get; set;}
C++
public:
property SqlString sTabelle {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sTabelle() : SqlString;
public function set sTabelle(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sTabelle]() As SqlString
            Get
                Return m_sTabelle
            End Get
            Set(ByVal Value As SqlString)
                m_sTabelle = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


clsSpalten.sTabellenspalte Property

clsSpalten.sTabellenspalte Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sTabellenspalte() As SqlString
C#
public SqlString sTabellenspalte {get; set;}
C++
public:
property SqlString sTabellenspalte {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sTabellenspalte() : SqlString;
public function set sTabellenspalte(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sTabellenspalte]() As SqlString
            Get
                Return m_sTabellenspalte
            End Get
            Set(ByVal Value As SqlString)
                m_sTabellenspalte = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


clsSpalten.sTiptext Property

clsSpalten.sTiptext Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sTiptext() As SqlString
C#
public SqlString sTiptext {get; set;}
C++
public:
property SqlString sTiptext {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sTiptext() : SqlString;
public function set sTiptext(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sTiptext]() As SqlString
            Get
                Return m_sTiptext
            End Get
            Set(ByVal Value As SqlString)
                m_sTiptext = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


clsSpalten Methods

clsSpalten Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsSpalten Class


clsSpalten.Delete Method

clsSpalten.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iEintragnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_spalten_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ieintragnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iEintragnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_spalten_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSpalten::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


clsSpalten.Insert Method

clsSpalten.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iEintragnr</LI> <LI>sTabelle. May be SqlString.Null</LI> <LI>sTabellenspalte. May be SqlString.Null</LI> <LI>sSpalte. May be SqlString.Null</LI> <LI>bReadonly</LI> <LI>bAlsHacken</LI> <LI>iBreite. May be SqlInt32.Null</LI> <LI>iReihenfolge. May be SqlInt32.Null</LI> <LI>sTiptext. May be SqlString.Null</LI> <LI>bAktiv</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_spalten_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ieintragnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iEintragnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stabelle", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTabelle))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stabellenspalte", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTabellenspalte))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sspalte", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSpalte))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bReadonly", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bReadonly))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@balsHacken", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAlsHacken))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iBreite", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBreite))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReihenfolge", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReihenfolge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stiptext", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTiptext))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_spalten_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSpalten::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


clsSpalten.SelectAll Method

clsSpalten.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_spalten_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("spalten")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_spalten_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSpalten::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


clsSpalten.SelectOne Method

clsSpalten.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iEintragnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iEintragnr</LI> <LI>sTabelle</LI> <LI>sTabellenspalte</LI> <LI>sSpalte</LI> <LI>bReadonly</LI> <LI>bAlsHacken</LI> <LI>iBreite</LI> <LI>iReihenfolge</LI> <LI>sTiptext</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_spalten_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("spalten")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ieintragnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iEintragnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_spalten_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iEintragnr = New SqlInt32(CType(dtToReturn.Rows(0)("eintragnr"), Integer))
                    If dtToReturn.Rows(0)("tabelle") Is System.DBNull.Value Then
                        m_sTabelle = SqlString.Null
                    Else
                        m_sTabelle = New SqlString(CType(dtToReturn.Rows(0)("tabelle"), String))
                    End If
                    If dtToReturn.Rows(0)("tabellenspalte") Is System.DBNull.Value Then
                        m_sTabellenspalte = SqlString.Null
                    Else
                        m_sTabellenspalte = New SqlString(CType(dtToReturn.Rows(0)("tabellenspalte"), String))
                    End If
                    If dtToReturn.Rows(0)("spalte") Is System.DBNull.Value Then
                        m_sSpalte = SqlString.Null
                    Else
                        m_sSpalte = New SqlString(CType(dtToReturn.Rows(0)("spalte"), String))
                    End If
                    m_bReadonly = New SqlBoolean(CType(dtToReturn.Rows(0)("Readonly"), Boolean))
                    m_bAlsHacken = New SqlBoolean(CType(dtToReturn.Rows(0)("alsHacken"), Boolean))
                    If dtToReturn.Rows(0)("Breite") Is System.DBNull.Value Then
                        m_iBreite = SqlInt32.Null
                    Else
                        m_iBreite = New SqlInt32(CType(dtToReturn.Rows(0)("Breite"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Reihenfolge") Is System.DBNull.Value Then
                        m_iReihenfolge = SqlInt32.Null
                    Else
                        m_iReihenfolge = New SqlInt32(CType(dtToReturn.Rows(0)("Reihenfolge"), Integer))
                    End If
                    If dtToReturn.Rows(0)("tiptext") Is System.DBNull.Value Then
                        m_sTiptext = SqlString.Null
                    Else
                        m_sTiptext = New SqlString(CType(dtToReturn.Rows(0)("tiptext"), String))
                    End If
                    m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSpalten::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


clsSpalten.Update Method

clsSpalten.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iEintragnr</LI> <LI>sTabelle. May be SqlString.Null</LI> <LI>sTabellenspalte. May be SqlString.Null</LI> <LI>sSpalte. May be SqlString.Null</LI> <LI>bReadonly</LI> <LI>bAlsHacken</LI> <LI>iBreite. May be SqlInt32.Null</LI> <LI>iReihenfolge. May be SqlInt32.Null</LI> <LI>sTiptext. May be SqlString.Null</LI> <LI>bAktiv</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_spalten_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ieintragnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iEintragnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stabelle", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTabelle))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stabellenspalte", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTabellenspalte))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sspalte", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSpalte))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bReadonly", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bReadonly))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@balsHacken", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAlsHacken))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iBreite", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBreite))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReihenfolge", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReihenfolge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stiptext", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTiptext))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_spalten_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSpalten::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


clsSpalten Fields

clsSpalten Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bAlsHacken |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_bReadonly |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iBreite |
Supported by the .NET Compact Framework. | m_iEintragnr |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iReihenfolge |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_sSpalte |
Supported by the .NET Compact Framework. | m_sTabelle |
Supported by the .NET Compact Framework. | m_sTabellenspalte |
Supported by the .NET Compact Framework. | m_sTiptext |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsSpalten Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bReadonly, m_bAlsHacken, m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


m_bAlsHacken Variable

m_bAlsHacken Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAlsHacken As SqlBoolean
C#
private SqlBoolean m_bAlsHacken;
C++
private:
SqlBoolean m_bAlsHacken;
JScript
private m_bAlsHacken : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bReadonly, m_bAlsHacken, m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


m_bReadonly Variable

m_bReadonly Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bReadonly As SqlBoolean
C#
private SqlBoolean m_bReadonly;
C++
private:
SqlBoolean m_bReadonly;
JScript
private m_bReadonly : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bReadonly, m_bAlsHacken, m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


m_iBreite Variable

m_iBreite Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iBreite As SqlInt32
C#
private SqlInt32 m_iBreite;
C++
private:
SqlInt32 m_iBreite;
JScript
private m_iBreite : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMandantnr, m_iMutierer, m_iReihenfolge, m_iBreite, m_iEintragnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


m_iEintragnr Variable

m_iEintragnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iEintragnr As SqlInt32
C#
private SqlInt32 m_iEintragnr;
C++
private:
SqlInt32 m_iEintragnr;
JScript
private m_iEintragnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMandantnr, m_iMutierer, m_iReihenfolge, m_iBreite, m_iEintragnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


m_iMandantnr Variable

m_iMandantnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandantnr As SqlInt32
C#
private SqlInt32 m_iMandantnr;
C++
private:
SqlInt32 m_iMandantnr;
JScript
private m_iMandantnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMandantnr, m_iMutierer, m_iReihenfolge, m_iBreite, m_iEintragnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMandantnr, m_iMutierer, m_iReihenfolge, m_iBreite, m_iEintragnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


m_iReihenfolge Variable

m_iReihenfolge Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iReihenfolge As SqlInt32
C#
private SqlInt32 m_iReihenfolge;
C++
private:
SqlInt32 m_iReihenfolge;
JScript
private m_iReihenfolge : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMandantnr, m_iMutierer, m_iReihenfolge, m_iBreite, m_iEintragnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


m_sSpalte Variable

m_sSpalte Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sSpalte As SqlString
C#
private SqlString m_sSpalte;
C++
private:
SqlString m_sSpalte;
JScript
private m_sSpalte : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sTabelle, m_sTiptext, m_sSpalte, m_sTabellenspalte As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


m_sTabelle Variable

m_sTabelle Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sTabelle As SqlString
C#
private SqlString m_sTabelle;
C++
private:
SqlString m_sTabelle;
JScript
private m_sTabelle : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sTabelle, m_sTiptext, m_sSpalte, m_sTabellenspalte As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


m_sTabellenspalte Variable

m_sTabellenspalte Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sTabellenspalte As SqlString
C#
private SqlString m_sTabellenspalte;
C++
private:
SqlString m_sTabellenspalte;
JScript
private m_sTabellenspalte : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sTabelle, m_sTiptext, m_sSpalte, m_sTabellenspalte As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


m_sTiptext Variable

m_sTiptext Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sTiptext As SqlString
C#
private SqlString m_sTiptext;
C++
private:
SqlString m_sTiptext;
JScript
private m_sTiptext : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sTabelle, m_sTiptext, m_sSpalte, m_sTabellenspalte As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSpalten Class
clsSpalten Members


clsSysadminfunktion Class

clsSysadminfunktion Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'sysadminfunktion'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsSysadminfunktion
    Inherits clsDBInteractionBase
C#
public class clsSysadminfunktion : clsDBInteractionBase
C++

public ref class clsSysadminfunktion : public clsDBInteractionBase^
JScript
public class clsSysadminfunktion
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion
Vertragsverwaltung.TKB.VV.Sysadmin.clsMySysadminfunkion

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Members


clsSysadminfunktion Members

clsSysadminfunktion Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'sysadminfunktion'.

The following tables list the members exposed by the clsSysadminfunktion type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsSysadminfunktion Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iFheight |
Supported by the .NET Compact Framework. | iFleft |
Supported by the .NET Compact Framework. | iFtop |
Supported by the .NET Compact Framework. | iFwidth |
Supported by the .NET Compact Framework. | iImageIndex |
Supported by the .NET Compact Framework. | iImageIndexOpen |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iParentID |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSort |
Supported by the .NET Compact Framework. | iSprache |
Supported by the .NET Compact Framework. | iSysadminfnktnr |
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sDomaintable |
Supported by the .NET Compact Framework. | sKeyFields |
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iFheight |
Supported by the .NET Compact Framework. | m_iFleft |
Supported by the .NET Compact Framework. | m_iFtop |
Supported by the .NET Compact Framework. | m_iFwidth |
Supported by the .NET Compact Framework. | m_iImageIndex |
Supported by the .NET Compact Framework. | m_iImageIndexOpen |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iParentID |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSort |
Supported by the .NET Compact Framework. | m_iSprache |
Supported by the .NET Compact Framework. | m_iSysadminfnktnr |
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_sDomaintable |
Supported by the .NET Compact Framework. | m_sKeyFields |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsSysadminfunktion Class


clsSysadminfunktion Constructor

clsSysadminfunktion Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsSysadminfunktion();
C++

public:
System::Void clsSysadminfunktion()
JScript
public function clsSysadminfunktion();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsSysadminfunktion Properties

clsSysadminfunktion Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iFheight |
Supported by the .NET Compact Framework. | iFleft |
Supported by the .NET Compact Framework. | iFtop |
Supported by the .NET Compact Framework. | iFwidth |
Supported by the .NET Compact Framework. | iImageIndex |
Supported by the .NET Compact Framework. | iImageIndexOpen |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iParentID |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSort |
Supported by the .NET Compact Framework. | iSprache |
Supported by the .NET Compact Framework. | iSysadminfnktnr |
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sDomaintable |
Supported by the .NET Compact Framework. | sKeyFields |
Top

Expand image See Also

Reference

clsSysadminfunktion Class


clsSysadminfunktion.bAktiv Property

clsSysadminfunktion.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsSysadminfunktion.daErstellt_am Property

clsSysadminfunktion.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsSysadminfunktion.daMutiert_am Property

clsSysadminfunktion.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsSysadminfunktion.iFheight Property

clsSysadminfunktion.iFheight Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iFheight() As SqlInt32
C#
public SqlInt32 iFheight {get; set;}
C++
public:
property SqlInt32 iFheight {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iFheight() : SqlInt32;
public function set iFheight(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iFheight]() As SqlInt32
            Get
                Return m_iFheight
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFheight = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsSysadminfunktion.iFleft Property

clsSysadminfunktion.iFleft Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iFleft() As SqlInt32
C#
public SqlInt32 iFleft {get; set;}
C++
public:
property SqlInt32 iFleft {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iFleft() : SqlInt32;
public function set iFleft(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iFleft]() As SqlInt32
            Get
                Return m_iFleft
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFleft = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsSysadminfunktion.iFtop Property

clsSysadminfunktion.iFtop Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iFtop() As SqlInt32
C#
public SqlInt32 iFtop {get; set;}
C++
public:
property SqlInt32 iFtop {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iFtop() : SqlInt32;
public function set iFtop(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iFtop]() As SqlInt32
            Get
                Return m_iFtop
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFtop = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsSysadminfunktion.iFwidth Property

clsSysadminfunktion.iFwidth Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iFwidth() As SqlInt32
C#
public SqlInt32 iFwidth {get; set;}
C++
public:
property SqlInt32 iFwidth {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iFwidth() : SqlInt32;
public function set iFwidth(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iFwidth]() As SqlInt32
            Get
                Return m_iFwidth
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFwidth = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsSysadminfunktion.iImageIndex Property

clsSysadminfunktion.iImageIndex Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iImageIndex() As SqlInt32
C#
public SqlInt32 iImageIndex {get; set;}
C++
public:
property SqlInt32 iImageIndex {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iImageIndex() : SqlInt32;
public function set iImageIndex(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iImageIndex]() As SqlInt32
            Get
                Return m_iImageIndex
            End Get
            Set(ByVal Value As SqlInt32)
                m_iImageIndex = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsSysadminfunktion.iImageIndexOpen Property

clsSysadminfunktion.iImageIndexOpen Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iImageIndexOpen() As SqlInt32
C#
public SqlInt32 iImageIndexOpen {get; set;}
C++
public:
property SqlInt32 iImageIndexOpen {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iImageIndexOpen() : SqlInt32;
public function set iImageIndexOpen(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iImageIndexOpen]() As SqlInt32
            Get
                Return m_iImageIndexOpen
            End Get
            Set(ByVal Value As SqlInt32)
                m_iImageIndexOpen = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsSysadminfunktion.iMandantnr Property

clsSysadminfunktion.iMandantnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandantnr() As SqlInt32
C#
public SqlInt32 iMandantnr {get; set;}
C++
public:
property SqlInt32 iMandantnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMandantnrTmp As SqlInt32 = Value
                If iMandantnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMandantnr", "iMandantnr can't be NULL")
                End If
                m_iMandantnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsSysadminfunktion.iMutierer Property

clsSysadminfunktion.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsSysadminfunktion.iParentID Property

clsSysadminfunktion.iParentID Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iParentID() As SqlInt32
C#
public SqlInt32 iParentID {get; set;}
C++
public:
property SqlInt32 iParentID {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iParentID() : SqlInt32;
public function set iParentID(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iParentID]() As SqlInt32
            Get
                Return m_iParentID
            End Get
            Set(ByVal Value As SqlInt32)
                m_iParentID = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsSysadminfunktion.iSort Property

clsSysadminfunktion.iSort Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iSort() As SqlInt32
C#
public SqlInt32 iSort {get; set;}
C++
public:
property SqlInt32 iSort {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iSort() : SqlInt32;
public function set iSort(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iSort]() As SqlInt32
            Get
                Return m_iSort
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSort = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsSysadminfunktion.iSprache Property

clsSysadminfunktion.iSprache Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iSprache() As SqlInt32
C#
public SqlInt32 iSprache {get; set;}
C++
public:
property SqlInt32 iSprache {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iSprache() : SqlInt32;
public function set iSprache(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iSprache]() As SqlInt32
            Get
                Return m_iSprache
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iSpracheTmp As SqlInt32 = Value
                If iSpracheTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iSprache", "iSprache can't be NULL")
                End If
                m_iSprache = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsSysadminfunktion.iSysadminfnktnr Property

clsSysadminfunktion.iSysadminfnktnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iSysadminfnktnr() As SqlInt32
C#
public SqlInt32 iSysadminfnktnr {get; set;}
C++
public:
property SqlInt32 iSysadminfnktnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iSysadminfnktnr() : SqlInt32;
public function set iSysadminfnktnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iSysadminfnktnr]() As SqlInt32
            Get
                Return m_iSysadminfnktnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iSysadminfnktnrTmp As SqlInt32 = Value
                If iSysadminfnktnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iSysadminfnktnr", "iSysadminfnktnr can't be NULL")
                End If
                m_iSysadminfnktnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsSysadminfunktion.sBeschreibung Property

clsSysadminfunktion.sBeschreibung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBeschreibung() As SqlString
C#
public SqlString sBeschreibung {get; set;}
C++
public:
property SqlString sBeschreibung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBeschreibung() : SqlString;
public function set sBeschreibung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsSysadminfunktion.sBezeichnung Property

clsSysadminfunktion.sBezeichnung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBezeichnung() As SqlString
C#
public SqlString sBezeichnung {get; set;}
C++
public:
property SqlString sBezeichnung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBezeichnung() : SqlString;
public function set sBezeichnung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsSysadminfunktion.sDomaintable Property

clsSysadminfunktion.sDomaintable Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sDomaintable() As SqlString
C#
public SqlString sDomaintable {get; set;}
C++
public:
property SqlString sDomaintable {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sDomaintable() : SqlString;
public function set sDomaintable(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sDomaintable]() As SqlString
            Get
                Return m_sDomaintable
            End Get
            Set(ByVal Value As SqlString)
                m_sDomaintable = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsSysadminfunktion.sKeyFields Property

clsSysadminfunktion.sKeyFields Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sKeyFields() As SqlString
C#
public SqlString sKeyFields {get; set;}
C++
public:
property SqlString sKeyFields {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sKeyFields() : SqlString;
public function set sKeyFields(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sKeyFields]() As SqlString
            Get
                Return m_sKeyFields
            End Get
            Set(ByVal Value As SqlString)
                m_sKeyFields = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsSysadminfunktion Methods

clsSysadminfunktion Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsSysadminfunktion Class


clsSysadminfunktion.Delete Method

clsSysadminfunktion.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iSysadminfnktnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_sysadminfunktion_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSysadminfnktnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSysadminfunktion::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsSysadminfunktion.Insert Method

clsSysadminfunktion.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iSysadminfnktnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>iParentID. May be SqlInt32.Null</LI> <LI>iSort. May be SqlInt32.Null</LI> <LI>iImageIndex. May be SqlInt32.Null</LI> <LI>iImageIndexOpen. May be SqlInt32.Null</LI> <LI>iFtop. May be SqlInt32.Null</LI> <LI>iFleft. May be SqlInt32.Null</LI> <LI>iFwidth. May be SqlInt32.Null</LI> <LI>iFheight. May be SqlInt32.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>iMandantnr</LI> <LI>iSprache</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>sDomaintable. May be SqlString.Null</LI> <LI>sKeyFields. May be SqlString.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_sysadminfunktion_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSysadminfnktnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iParentID", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSort", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iImageIndex", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageIndex))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iImageIndexOpen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageIndexOpen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iftop", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFtop))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifleft", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFleft))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifwidth", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFwidth))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifheight", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFheight))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sDomaintable", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDomaintable))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sKeyFields", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sKeyFields))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSysadminfunktion::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsSysadminfunktion.SelectAll Method

clsSysadminfunktion.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_sysadminfunktion_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("sysadminfunktion")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSysadminfunktion::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsSysadminfunktion.SelectOne Method

clsSysadminfunktion.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iSysadminfnktnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iSysadminfnktnr</LI> <LI>sBezeichnung</LI> <LI>iParentID</LI> <LI>iSort</LI> <LI>iImageIndex</LI> <LI>iImageIndexOpen</LI> <LI>iFtop</LI> <LI>iFleft</LI> <LI>iFwidth</LI> <LI>iFheight</LI> <LI>sBeschreibung</LI> <LI>iMandantnr</LI> <LI>iSprache</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>sDomaintable</LI> <LI>sKeyFields</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_sysadminfunktion_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("sysadminfunktion")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@isysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSysadminfnktnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iSysadminfnktnr = New SqlInt32(CType(dtToReturn.Rows(0)("sysadminfnktnr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("ParentID") Is System.DBNull.Value Then
                        m_iParentID = SqlInt32.Null
                    Else
                        m_iParentID = New SqlInt32(CType(dtToReturn.Rows(0)("ParentID"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Sort") Is System.DBNull.Value Then
                        m_iSort = SqlInt32.Null
                    Else
                        m_iSort = New SqlInt32(CType(dtToReturn.Rows(0)("Sort"), Integer))
                    End If
                    If dtToReturn.Rows(0)("ImageIndex") Is System.DBNull.Value Then
                        m_iImageIndex = SqlInt32.Null
                    Else
                        m_iImageIndex = New SqlInt32(CType(dtToReturn.Rows(0)("ImageIndex"), Integer))
                    End If
                    If dtToReturn.Rows(0)("ImageIndexOpen") Is System.DBNull.Value Then
                        m_iImageIndexOpen = SqlInt32.Null
                    Else
                        m_iImageIndexOpen = New SqlInt32(CType(dtToReturn.Rows(0)("ImageIndexOpen"), Integer))
                    End If
                    If dtToReturn.Rows(0)("ftop") Is System.DBNull.Value Then
                        m_iFtop = SqlInt32.Null
                    Else
                        m_iFtop = New SqlInt32(CType(dtToReturn.Rows(0)("ftop"), Integer))
                    End If
                    If dtToReturn.Rows(0)("fleft") Is System.DBNull.Value Then
                        m_iFleft = SqlInt32.Null
                    Else
                        m_iFleft = New SqlInt32(CType(dtToReturn.Rows(0)("fleft"), Integer))
                    End If
                    If dtToReturn.Rows(0)("fwidth") Is System.DBNull.Value Then
                        m_iFwidth = SqlInt32.Null
                    Else
                        m_iFwidth = New SqlInt32(CType(dtToReturn.Rows(0)("fwidth"), Integer))
                    End If
                    If dtToReturn.Rows(0)("fheight") Is System.DBNull.Value Then
                        m_iFheight = SqlInt32.Null
                    Else
                        m_iFheight = New SqlInt32(CType(dtToReturn.Rows(0)("fheight"), Integer))
                    End If
                    If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    End If
                    m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    m_iSprache = New SqlInt32(CType(dtToReturn.Rows(0)("sprache"), Integer))
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Domaintable") Is System.DBNull.Value Then
                        m_sDomaintable = SqlString.Null
                    Else
                        m_sDomaintable = New SqlString(CType(dtToReturn.Rows(0)("Domaintable"), String))
                    End If
                    If dtToReturn.Rows(0)("KeyFields") Is System.DBNull.Value Then
                        m_sKeyFields = SqlString.Null
                    Else
                        m_sKeyFields = New SqlString(CType(dtToReturn.Rows(0)("KeyFields"), String))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSysadminfunktion::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsSysadminfunktion.Update Method

clsSysadminfunktion.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iSysadminfnktnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>iParentID. May be SqlInt32.Null</LI> <LI>iSort. May be SqlInt32.Null</LI> <LI>iImageIndex. May be SqlInt32.Null</LI> <LI>iImageIndexOpen. May be SqlInt32.Null</LI> <LI>iFtop. May be SqlInt32.Null</LI> <LI>iFleft. May be SqlInt32.Null</LI> <LI>iFwidth. May be SqlInt32.Null</LI> <LI>iFheight. May be SqlInt32.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>iMandantnr</LI> <LI>iSprache</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>sDomaintable. May be SqlString.Null</LI> <LI>sKeyFields. May be SqlString.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_sysadminfunktion_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSysadminfnktnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iParentID", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSort", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iImageIndex", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageIndex))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iImageIndexOpen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageIndexOpen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iftop", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFtop))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifleft", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFleft))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifwidth", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFwidth))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifheight", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFheight))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sDomaintable", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDomaintable))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sKeyFields", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sKeyFields))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSysadminfunktion::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsSysadminfunktion Fields

clsSysadminfunktion Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iFheight |
Supported by the .NET Compact Framework. | m_iFleft |
Supported by the .NET Compact Framework. | m_iFtop |
Supported by the .NET Compact Framework. | m_iFwidth |
Supported by the .NET Compact Framework. | m_iImageIndex |
Supported by the .NET Compact Framework. | m_iImageIndexOpen |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iParentID |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSort |
Supported by the .NET Compact Framework. | m_iSprache |
Supported by the .NET Compact Framework. | m_iSysadminfnktnr |
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_sDomaintable |
Supported by the .NET Compact Framework. | m_sKeyFields |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsSysadminfunktion Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


m_iFheight Variable

m_iFheight Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iFheight As SqlInt32
C#
private SqlInt32 m_iFheight;
C++
private:
SqlInt32 m_iFheight;
JScript
private m_iFheight : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


m_iFleft Variable

m_iFleft Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iFleft As SqlInt32
C#
private SqlInt32 m_iFleft;
C++
private:
SqlInt32 m_iFleft;
JScript
private m_iFleft : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


m_iFtop Variable

m_iFtop Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iFtop As SqlInt32
C#
private SqlInt32 m_iFtop;
C++
private:
SqlInt32 m_iFtop;
JScript
private m_iFtop : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


m_iFwidth Variable

m_iFwidth Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iFwidth As SqlInt32
C#
private SqlInt32 m_iFwidth;
C++
private:
SqlInt32 m_iFwidth;
JScript
private m_iFwidth : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


m_iImageIndex Variable

m_iImageIndex Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iImageIndex As SqlInt32
C#
private SqlInt32 m_iImageIndex;
C++
private:
SqlInt32 m_iImageIndex;
JScript
private m_iImageIndex : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


m_iImageIndexOpen Variable

m_iImageIndexOpen Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iImageIndexOpen As SqlInt32
C#
private SqlInt32 m_iImageIndexOpen;
C++
private:
SqlInt32 m_iImageIndexOpen;
JScript
private m_iImageIndexOpen : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


m_iMandantnr Variable

m_iMandantnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandantnr As SqlInt32
C#
private SqlInt32 m_iMandantnr;
C++
private:
SqlInt32 m_iMandantnr;
JScript
private m_iMandantnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


m_iParentID Variable

m_iParentID Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iParentID As SqlInt32
C#
private SqlInt32 m_iParentID;
C++
private:
SqlInt32 m_iParentID;
JScript
private m_iParentID : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


m_iSort Variable

m_iSort Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iSort As SqlInt32
C#
private SqlInt32 m_iSort;
C++
private:
SqlInt32 m_iSort;
JScript
private m_iSort : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


m_iSprache Variable

m_iSprache Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iSprache As SqlInt32
C#
private SqlInt32 m_iSprache;
C++
private:
SqlInt32 m_iSprache;
JScript
private m_iSprache : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


m_iSysadminfnktnr Variable

m_iSysadminfnktnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iSysadminfnktnr As SqlInt32
C#
private SqlInt32 m_iSysadminfnktnr;
C++
private:
SqlInt32 m_iSysadminfnktnr;
JScript
private m_iSysadminfnktnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


m_sBeschreibung Variable

m_sBeschreibung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBeschreibung As SqlString
C#
private SqlString m_sBeschreibung;
C++
private:
SqlString m_sBeschreibung;
JScript
private m_sBeschreibung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sKeyFields, m_sDomaintable, m_sBeschreibung, m_sBezeichnung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


m_sBezeichnung Variable

m_sBezeichnung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBezeichnung As SqlString
C#
private SqlString m_sBezeichnung;
C++
private:
SqlString m_sBezeichnung;
JScript
private m_sBezeichnung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sKeyFields, m_sDomaintable, m_sBeschreibung, m_sBezeichnung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


m_sDomaintable Variable

m_sDomaintable Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sDomaintable As SqlString
C#
private SqlString m_sDomaintable;
C++
private:
SqlString m_sDomaintable;
JScript
private m_sDomaintable : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sKeyFields, m_sDomaintable, m_sBeschreibung, m_sBezeichnung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


m_sKeyFields Variable

m_sKeyFields Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sKeyFields As SqlString
C#
private SqlString m_sKeyFields;
C++
private:
SqlString m_sKeyFields;
JScript
private m_sKeyFields : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sKeyFields, m_sDomaintable, m_sBeschreibung, m_sBezeichnung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSysadminfunktion Class
clsSysadminfunktion Members


clsVertragselement Class

clsVertragselement Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'Vertragselement'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsVertragselement
    Inherits clsDBInteractionBase
C#
public class clsVertragselement : clsDBInteractionBase
C++

public ref class clsVertragselement : public clsDBInteractionBase^
JScript
public class clsVertragselement
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsVertragselement
Vertragsverwaltung.TKB.VV.Vertrag.clsVertragselement

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Members


clsVertragselement Members

clsVertragselement Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'Vertragselement'.

The following tables list the members exposed by the clsVertragselement type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsVertragselement Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bBefristet_Unbefristet |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daGekuendigt_am |
Supported by the .NET Compact Framework. | daGekuendigt_per |
Supported by the .NET Compact Framework. | daMindestvertragsdauer_bis |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | daUnterzeichnet_am |
Supported by the .NET Compact Framework. | daVersionsdatum |
Supported by the .NET Compact Framework. | daVertragsablauf |
Supported by the .NET Compact Framework. | daVertragsbeginn |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iParentID |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr |
Supported by the .NET Compact Framework. | iVertragselementnr |
Supported by the .NET Compact Framework. | iVertragspartnerNr |
Supported by the .NET Compact Framework. | iVertragstypNr |
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sNummer |
Supported by the .NET Compact Framework. | sSuchbegriffe |
Supported by the .NET Compact Framework. | sVersion |
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bBefristet_Unbefristet |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daGekuendigt_am |
Supported by the .NET Compact Framework. | m_daGekuendigt_per |
Supported by the .NET Compact Framework. | m_daMindestvertragsdauer_bis |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_daUnterzeichnet_am |
Supported by the .NET Compact Framework. | m_daVersionsdatum |
Supported by the .NET Compact Framework. | m_daVertragsablauf |
Supported by the .NET Compact Framework. | m_daVertragsbeginn |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iParentID |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSecurityLevelNr |
Supported by the .NET Compact Framework. | m_iVertragselementnr |
Supported by the .NET Compact Framework. | m_iVertragspartnerNr |
Supported by the .NET Compact Framework. | m_iVertragstypNr |
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_sNummer |
Supported by the .NET Compact Framework. | m_sSuchbegriffe |
Supported by the .NET Compact Framework. | m_sVersion |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsVertragselement Class


clsVertragselement Constructor

clsVertragselement Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsVertragselement();
C++

public:
System::Void clsVertragselement()
JScript
public function clsVertragselement();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement Properties

clsVertragselement Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bBefristet_Unbefristet |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daGekuendigt_am |
Supported by the .NET Compact Framework. | daGekuendigt_per |
Supported by the .NET Compact Framework. | daMindestvertragsdauer_bis |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | daUnterzeichnet_am |
Supported by the .NET Compact Framework. | daVersionsdatum |
Supported by the .NET Compact Framework. | daVertragsablauf |
Supported by the .NET Compact Framework. | daVertragsbeginn |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iParentID |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr |
Supported by the .NET Compact Framework. | iVertragselementnr |
Supported by the .NET Compact Framework. | iVertragspartnerNr |
Supported by the .NET Compact Framework. | iVertragstypNr |
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sNummer |
Supported by the .NET Compact Framework. | sSuchbegriffe |
Supported by the .NET Compact Framework. | sVersion |
Top

Expand image See Also

Reference

clsVertragselement Class


clsVertragselement.bAktiv Property

clsVertragselement.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement.bBefristet_Unbefristet Property

clsVertragselement.bBefristet_Unbefristet Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bBefristet_Unbefristet() As SqlBoolean
C#
public SqlBoolean bBefristet_Unbefristet {get; set;}
C++
public:
property SqlBoolean bBefristet_Unbefristet {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bBefristet_Unbefristet() : SqlBoolean;
public function set bBefristet_Unbefristet(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bBefristet_Unbefristet]() As SqlBoolean
            Get
                Return m_bBefristet_Unbefristet
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bBefristet_Unbefristet = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement.daErstellt_am Property

clsVertragselement.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement.daGekuendigt_am Property

clsVertragselement.daGekuendigt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daGekuendigt_am() As SqlDateTime
C#
public SqlDateTime daGekuendigt_am {get; set;}
C++
public:
property SqlDateTime daGekuendigt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daGekuendigt_am() : SqlDateTime;
public function set daGekuendigt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daGekuendigt_am]() As SqlDateTime
            Get
                Return m_daGekuendigt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daGekuendigt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement.daGekuendigt_per Property

clsVertragselement.daGekuendigt_per Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daGekuendigt_per() As SqlDateTime
C#
public SqlDateTime daGekuendigt_per {get; set;}
C++
public:
property SqlDateTime daGekuendigt_per {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daGekuendigt_per() : SqlDateTime;
public function set daGekuendigt_per(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daGekuendigt_per]() As SqlDateTime
            Get
                Return m_daGekuendigt_per
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daGekuendigt_per = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement.daMindestvertragsdauer_bis Property

clsVertragselement.daMindestvertragsdauer_bis Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMindestvertragsdauer_bis() As SqlDateTime
C#
public SqlDateTime daMindestvertragsdauer_bis {get; set;}
C++
public:
property SqlDateTime daMindestvertragsdauer_bis {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMindestvertragsdauer_bis() : SqlDateTime;
public function set daMindestvertragsdauer_bis(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMindestvertragsdauer_bis]() As SqlDateTime
            Get
                Return m_daMindestvertragsdauer_bis
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMindestvertragsdauer_bis = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement.daMutiert_am Property

clsVertragselement.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement.daUnterzeichnet_am Property

clsVertragselement.daUnterzeichnet_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daUnterzeichnet_am() As SqlDateTime
C#
public SqlDateTime daUnterzeichnet_am {get; set;}
C++
public:
property SqlDateTime daUnterzeichnet_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daUnterzeichnet_am() : SqlDateTime;
public function set daUnterzeichnet_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daUnterzeichnet_am]() As SqlDateTime
            Get
                Return m_daUnterzeichnet_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daUnterzeichnet_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement.daVersionsdatum Property

clsVertragselement.daVersionsdatum Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daVersionsdatum() As SqlDateTime
C#
public SqlDateTime daVersionsdatum {get; set;}
C++
public:
property SqlDateTime daVersionsdatum {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daVersionsdatum() : SqlDateTime;
public function set daVersionsdatum(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daVersionsdatum]() As SqlDateTime
            Get
                Return m_daVersionsdatum
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daVersionsdatum = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement.daVertragsablauf Property

clsVertragselement.daVertragsablauf Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daVertragsablauf() As SqlDateTime
C#
public SqlDateTime daVertragsablauf {get; set;}
C++
public:
property SqlDateTime daVertragsablauf {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daVertragsablauf() : SqlDateTime;
public function set daVertragsablauf(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daVertragsablauf]() As SqlDateTime
            Get
                Return m_daVertragsablauf
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daVertragsablauf = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement.daVertragsbeginn Property

clsVertragselement.daVertragsbeginn Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daVertragsbeginn() As SqlDateTime
C#
public SqlDateTime daVertragsbeginn {get; set;}
C++
public:
property SqlDateTime daVertragsbeginn {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daVertragsbeginn() : SqlDateTime;
public function set daVertragsbeginn(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daVertragsbeginn]() As SqlDateTime
            Get
                Return m_daVertragsbeginn
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daVertragsbeginn = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement.iMutierer Property

clsVertragselement.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement.iParentID Property

clsVertragselement.iParentID Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iParentID() As SqlInt32
C#
public SqlInt32 iParentID {get; set;}
C++
public:
property SqlInt32 iParentID {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iParentID() : SqlInt32;
public function set iParentID(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iParentID]() As SqlInt32
            Get
                Return m_iParentID
            End Get
            Set(ByVal Value As SqlInt32)
                m_iParentID = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement.iSecurityLevelNr Property

clsVertragselement.iSecurityLevelNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iSecurityLevelNr() As SqlInt32
C#
public SqlInt32 iSecurityLevelNr {get; set;}
C++
public:
property SqlInt32 iSecurityLevelNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iSecurityLevelNr() : SqlInt32;
public function set iSecurityLevelNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iSecurityLevelNr]() As SqlInt32
            Get
                Return m_iSecurityLevelNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityLevelNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement.iVertragselementnr Property

clsVertragselement.iVertragselementnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iVertragselementnr() As SqlInt32
C#
public SqlInt32 iVertragselementnr {get; set;}
C++
public:
property SqlInt32 iVertragselementnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iVertragselementnr() : SqlInt32;
public function set iVertragselementnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iVertragselementnr]() As SqlInt32
            Get
                Return m_iVertragselementnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iVertragselementnrTmp As SqlInt32 = Value
                If iVertragselementnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iVertragselementnr", "iVertragselementnr can't be NULL")
                End If
                m_iVertragselementnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement.iVertragspartnerNr Property

clsVertragselement.iVertragspartnerNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iVertragspartnerNr() As SqlInt32
C#
public SqlInt32 iVertragspartnerNr {get; set;}
C++
public:
property SqlInt32 iVertragspartnerNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iVertragspartnerNr() : SqlInt32;
public function set iVertragspartnerNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iVertragspartnerNr]() As SqlInt32
            Get
                Return m_iVertragspartnerNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVertragspartnerNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement.iVertragstypNr Property

clsVertragselement.iVertragstypNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iVertragstypNr() As SqlInt32
C#
public SqlInt32 iVertragstypNr {get; set;}
C++
public:
property SqlInt32 iVertragstypNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iVertragstypNr() : SqlInt32;
public function set iVertragstypNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iVertragstypNr]() As SqlInt32
            Get
                Return m_iVertragstypNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVertragstypNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement.sBeschreibung Property

clsVertragselement.sBeschreibung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBeschreibung() As SqlString
C#
public SqlString sBeschreibung {get; set;}
C++
public:
property SqlString sBeschreibung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBeschreibung() : SqlString;
public function set sBeschreibung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement.sBezeichnung Property

clsVertragselement.sBezeichnung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBezeichnung() As SqlString
C#
public SqlString sBezeichnung {get; set;}
C++
public:
property SqlString sBezeichnung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBezeichnung() : SqlString;
public function set sBezeichnung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement.sNummer Property

clsVertragselement.sNummer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sNummer() As SqlString
C#
public SqlString sNummer {get; set;}
C++
public:
property SqlString sNummer {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sNummer() : SqlString;
public function set sNummer(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sNummer]() As SqlString
            Get
                Return m_sNummer
            End Get
            Set(ByVal Value As SqlString)
                m_sNummer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement.sSuchbegriffe Property

clsVertragselement.sSuchbegriffe Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sSuchbegriffe() As SqlString
C#
public SqlString sSuchbegriffe {get; set;}
C++
public:
property SqlString sSuchbegriffe {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sSuchbegriffe() : SqlString;
public function set sSuchbegriffe(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sSuchbegriffe]() As SqlString
            Get
                Return m_sSuchbegriffe
            End Get
            Set(ByVal Value As SqlString)
                m_sSuchbegriffe = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement.sVersion Property

clsVertragselement.sVersion Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sVersion() As SqlString
C#
public SqlString sVersion {get; set;}
C++
public:
property SqlString sVersion {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sVersion() : SqlString;
public function set sVersion(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sVersion]() As SqlString
            Get
                Return m_sVersion
            End Get
            Set(ByVal Value As SqlString)
                m_sVersion = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement Methods

clsVertragselement Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsVertragselement Class


clsVertragselement.Delete Method

clsVertragselement.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iVertragselementnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragselement_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragselement_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselement::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement.Insert Method

clsVertragselement.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iVertragselementnr</LI> <LI>iVertragstypNr. May be SqlInt32.Null</LI> <LI>iVertragspartnerNr. May be SqlInt32.Null</LI> <LI>iParentID. May be SqlInt32.Null</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>sVersion. May be SqlString.Null</LI> <LI>daVersionsdatum. May be SqlDateTime.Null</LI> <LI>sNummer. May be SqlString.Null</LI> <LI>daUnterzeichnet_am. May be SqlDateTime.Null</LI> <LI>daVertragsbeginn. May be SqlDateTime.Null</LI> <LI>daVertragsablauf. May be SqlDateTime.Null</LI> <LI>bBefristet_Unbefristet. May be SqlBoolean.Null</LI> <LI>daMindestvertragsdauer_bis. May be SqlDateTime.Null</LI> <LI>daGekuendigt_am. May be SqlDateTime.Null</LI> <LI>daGekuendigt_per. May be SqlDateTime.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>sSuchbegriffe. May be SqlString.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragselement_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragstypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragstypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragspartnerNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragspartnerNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iParentID", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 2048, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVersion", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daVersionsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daVersionsdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNummer", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNummer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daUnterzeichnet_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daUnterzeichnet_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daVertragsbeginn", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daVertragsbeginn))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daVertragsablauf", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daVertragsablauf))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bBefristet_Unbefristet", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBefristet_Unbefristet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMindestvertragsdauer_bis", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMindestvertragsdauer_bis))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daGekuendigt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daGekuendigt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daGekuendigt_per", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daGekuendigt_per))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSuchbegriffe", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSuchbegriffe))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragselement_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselement::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement.SelectAll Method

clsVertragselement.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragselement_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragselement")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragselement_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselement::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement.SelectOne Method

clsVertragselement.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iVertragselementnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iVertragselementnr</LI> <LI>iVertragstypNr</LI> <LI>iVertragspartnerNr</LI> <LI>iParentID</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>sVersion</LI> <LI>daVersionsdatum</LI> <LI>sNummer</LI> <LI>daUnterzeichnet_am</LI> <LI>daVertragsbeginn</LI> <LI>daVertragsablauf</LI> <LI>bBefristet_Unbefristet</LI> <LI>daMindestvertragsdauer_bis</LI> <LI>daGekuendigt_am</LI> <LI>daGekuendigt_per</LI> <LI>iSecurityLevelNr</LI> <LI>sSuchbegriffe</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>bAktiv</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragselement_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragselement")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragselementnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragselement_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iVertragselementnr = New SqlInt32(CType(dtToReturn.Rows(0)("Vertragselementnr"), Integer))
                    If dtToReturn.Rows(0)("VertragstypNr") Is System.DBNull.Value Then
                        m_iVertragstypNr = SqlInt32.Null
                    Else
                        m_iVertragstypNr = New SqlInt32(CType(dtToReturn.Rows(0)("VertragstypNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("VertragspartnerNr") Is System.DBNull.Value Then
                        m_iVertragspartnerNr = SqlInt32.Null
                    Else
                        m_iVertragspartnerNr = New SqlInt32(CType(dtToReturn.Rows(0)("VertragspartnerNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("ParentID") Is System.DBNull.Value Then
                        m_iParentID = SqlInt32.Null
                    Else
                        m_iParentID = New SqlInt32(CType(dtToReturn.Rows(0)("ParentID"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Version") Is System.DBNull.Value Then
                        m_sVersion = SqlString.Null
                    Else
                        m_sVersion = New SqlString(CType(dtToReturn.Rows(0)("Version"), String))
                    End If
                    If dtToReturn.Rows(0)("Versionsdatum") Is System.DBNull.Value Then
                        m_daVersionsdatum = SqlDateTime.Null
                    Else
                        m_daVersionsdatum = New SqlDateTime(CType(dtToReturn.Rows(0)("Versionsdatum"), Date))
                    End If
                    If dtToReturn.Rows(0)("Nummer") Is System.DBNull.Value Then
                        m_sNummer = SqlString.Null
                    Else
                        m_sNummer = New SqlString(CType(dtToReturn.Rows(0)("Nummer"), String))
                    End If
                    If dtToReturn.Rows(0)("Unterzeichnet_am") Is System.DBNull.Value Then
                        m_daUnterzeichnet_am = SqlDateTime.Null
                    Else
                        m_daUnterzeichnet_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Unterzeichnet_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Vertragsbeginn") Is System.DBNull.Value Then
                        m_daVertragsbeginn = SqlDateTime.Null
                    Else
                        m_daVertragsbeginn = New SqlDateTime(CType(dtToReturn.Rows(0)("Vertragsbeginn"), Date))
                    End If
                    If dtToReturn.Rows(0)("Vertragsablauf") Is System.DBNull.Value Then
                        m_daVertragsablauf = SqlDateTime.Null
                    Else
                        m_daVertragsablauf = New SqlDateTime(CType(dtToReturn.Rows(0)("Vertragsablauf"), Date))
                    End If
                    If dtToReturn.Rows(0)("Befristet_Unbefristet") Is System.DBNull.Value Then
                        m_bBefristet_Unbefristet = SqlBoolean.Null
                    Else
                        m_bBefristet_Unbefristet = New SqlBoolean(CType(dtToReturn.Rows(0)("Befristet_Unbefristet"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Mindestvertragsdauer_bis") Is System.DBNull.Value Then
                        m_daMindestvertragsdauer_bis = SqlDateTime.Null
                    Else
                        m_daMindestvertragsdauer_bis = New SqlDateTime(CType(dtToReturn.Rows(0)("Mindestvertragsdauer_bis"), Date))
                    End If
                    If dtToReturn.Rows(0)("Gekuendigt_am") Is System.DBNull.Value Then
                        m_daGekuendigt_am = SqlDateTime.Null
                    Else
                        m_daGekuendigt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Gekuendigt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Gekuendigt_per") Is System.DBNull.Value Then
                        m_daGekuendigt_per = SqlDateTime.Null
                    Else
                        m_daGekuendigt_per = New SqlDateTime(CType(dtToReturn.Rows(0)("Gekuendigt_per"), Date))
                    End If
                    If dtToReturn.Rows(0)("SecurityLevelNr") Is System.DBNull.Value Then
                        m_iSecurityLevelNr = SqlInt32.Null
                    Else
                        m_iSecurityLevelNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevelNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Suchbegriffe") Is System.DBNull.Value Then
                        m_sSuchbegriffe = SqlString.Null
                    Else
                        m_sSuchbegriffe = New SqlString(CType(dtToReturn.Rows(0)("Suchbegriffe"), String))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselement::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement.Update Method

clsVertragselement.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iVertragselementnr</LI> <LI>iVertragstypNr. May be SqlInt32.Null</LI> <LI>iVertragspartnerNr. May be SqlInt32.Null</LI> <LI>iParentID. May be SqlInt32.Null</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>sVersion. May be SqlString.Null</LI> <LI>daVersionsdatum. May be SqlDateTime.Null</LI> <LI>sNummer. May be SqlString.Null</LI> <LI>daUnterzeichnet_am. May be SqlDateTime.Null</LI> <LI>daVertragsbeginn. May be SqlDateTime.Null</LI> <LI>daVertragsablauf. May be SqlDateTime.Null</LI> <LI>bBefristet_Unbefristet. May be SqlBoolean.Null</LI> <LI>daMindestvertragsdauer_bis. May be SqlDateTime.Null</LI> <LI>daGekuendigt_am. May be SqlDateTime.Null</LI> <LI>daGekuendigt_per. May be SqlDateTime.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>sSuchbegriffe. May be SqlString.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragselement_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragstypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragstypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragspartnerNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragspartnerNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iParentID", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 2048, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVersion", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daVersionsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daVersionsdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNummer", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNummer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daUnterzeichnet_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daUnterzeichnet_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daVertragsbeginn", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daVertragsbeginn))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daVertragsablauf", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daVertragsablauf))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bBefristet_Unbefristet", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBefristet_Unbefristet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMindestvertragsdauer_bis", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMindestvertragsdauer_bis))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daGekuendigt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daGekuendigt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daGekuendigt_per", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daGekuendigt_per))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSuchbegriffe", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSuchbegriffe))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragselement_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselement::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragselement Fields

clsVertragselement Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bBefristet_Unbefristet |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daGekuendigt_am |
Supported by the .NET Compact Framework. | m_daGekuendigt_per |
Supported by the .NET Compact Framework. | m_daMindestvertragsdauer_bis |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_daUnterzeichnet_am |
Supported by the .NET Compact Framework. | m_daVersionsdatum |
Supported by the .NET Compact Framework. | m_daVertragsablauf |
Supported by the .NET Compact Framework. | m_daVertragsbeginn |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iParentID |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSecurityLevelNr |
Supported by the .NET Compact Framework. | m_iVertragselementnr |
Supported by the .NET Compact Framework. | m_iVertragspartnerNr |
Supported by the .NET Compact Framework. | m_iVertragstypNr |
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_sNummer |
Supported by the .NET Compact Framework. | m_sSuchbegriffe |
Supported by the .NET Compact Framework. | m_sVersion |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsVertragselement Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bBefristet_Unbefristet, m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


m_bBefristet_Unbefristet Variable

m_bBefristet_Unbefristet Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bBefristet_Unbefristet As SqlBoolean
C#
private SqlBoolean m_bBefristet_Unbefristet;
C++
private:
SqlBoolean m_bBefristet_Unbefristet;
JScript
private m_bBefristet_Unbefristet : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bBefristet_Unbefristet, m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMindestvertragsdauer_bis, m_daVertragsbeginn, m_daVertragsablauf, m_daErstellt_am, m_daMutiert_am, m_daGekuendigt_am, m_daGekuendigt_per, m_daUnterzeichnet_am, m_daVersionsdatum As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


m_daGekuendigt_am Variable

m_daGekuendigt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daGekuendigt_am As SqlDateTime
C#
private SqlDateTime m_daGekuendigt_am;
C++
private:
SqlDateTime m_daGekuendigt_am;
JScript
private m_daGekuendigt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMindestvertragsdauer_bis, m_daVertragsbeginn, m_daVertragsablauf, m_daErstellt_am, m_daMutiert_am, m_daGekuendigt_am, m_daGekuendigt_per, m_daUnterzeichnet_am, m_daVersionsdatum As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


m_daGekuendigt_per Variable

m_daGekuendigt_per Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daGekuendigt_per As SqlDateTime
C#
private SqlDateTime m_daGekuendigt_per;
C++
private:
SqlDateTime m_daGekuendigt_per;
JScript
private m_daGekuendigt_per : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMindestvertragsdauer_bis, m_daVertragsbeginn, m_daVertragsablauf, m_daErstellt_am, m_daMutiert_am, m_daGekuendigt_am, m_daGekuendigt_per, m_daUnterzeichnet_am, m_daVersionsdatum As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


m_daMindestvertragsdauer_bis Variable

m_daMindestvertragsdauer_bis Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMindestvertragsdauer_bis As SqlDateTime
C#
private SqlDateTime m_daMindestvertragsdauer_bis;
C++
private:
SqlDateTime m_daMindestvertragsdauer_bis;
JScript
private m_daMindestvertragsdauer_bis : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMindestvertragsdauer_bis, m_daVertragsbeginn, m_daVertragsablauf, m_daErstellt_am, m_daMutiert_am, m_daGekuendigt_am, m_daGekuendigt_per, m_daUnterzeichnet_am, m_daVersionsdatum As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMindestvertragsdauer_bis, m_daVertragsbeginn, m_daVertragsablauf, m_daErstellt_am, m_daMutiert_am, m_daGekuendigt_am, m_daGekuendigt_per, m_daUnterzeichnet_am, m_daVersionsdatum As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


m_daUnterzeichnet_am Variable

m_daUnterzeichnet_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daUnterzeichnet_am As SqlDateTime
C#
private SqlDateTime m_daUnterzeichnet_am;
C++
private:
SqlDateTime m_daUnterzeichnet_am;
JScript
private m_daUnterzeichnet_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMindestvertragsdauer_bis, m_daVertragsbeginn, m_daVertragsablauf, m_daErstellt_am, m_daMutiert_am, m_daGekuendigt_am, m_daGekuendigt_per, m_daUnterzeichnet_am, m_daVersionsdatum As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


m_daVersionsdatum Variable

m_daVersionsdatum Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daVersionsdatum As SqlDateTime
C#
private SqlDateTime m_daVersionsdatum;
C++
private:
SqlDateTime m_daVersionsdatum;
JScript
private m_daVersionsdatum : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMindestvertragsdauer_bis, m_daVertragsbeginn, m_daVertragsablauf, m_daErstellt_am, m_daMutiert_am, m_daGekuendigt_am, m_daGekuendigt_per, m_daUnterzeichnet_am, m_daVersionsdatum As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


m_daVertragsablauf Variable

m_daVertragsablauf Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daVertragsablauf As SqlDateTime
C#
private SqlDateTime m_daVertragsablauf;
C++
private:
SqlDateTime m_daVertragsablauf;
JScript
private m_daVertragsablauf : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMindestvertragsdauer_bis, m_daVertragsbeginn, m_daVertragsablauf, m_daErstellt_am, m_daMutiert_am, m_daGekuendigt_am, m_daGekuendigt_per, m_daUnterzeichnet_am, m_daVersionsdatum As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


m_daVertragsbeginn Variable

m_daVertragsbeginn Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daVertragsbeginn As SqlDateTime
C#
private SqlDateTime m_daVertragsbeginn;
C++
private:
SqlDateTime m_daVertragsbeginn;
JScript
private m_daVertragsbeginn : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMindestvertragsdauer_bis, m_daVertragsbeginn, m_daVertragsablauf, m_daErstellt_am, m_daMutiert_am, m_daGekuendigt_am, m_daGekuendigt_per, m_daUnterzeichnet_am, m_daVersionsdatum As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iVertragspartnerNr, m_iSecurityLevelNr, m_iMutierer, m_iVertragstypNr, m_iVertragselementnr, m_iParentID As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


m_iParentID Variable

m_iParentID Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iParentID As SqlInt32
C#
private SqlInt32 m_iParentID;
C++
private:
SqlInt32 m_iParentID;
JScript
private m_iParentID : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iVertragspartnerNr, m_iSecurityLevelNr, m_iMutierer, m_iVertragstypNr, m_iVertragselementnr, m_iParentID As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


m_iSecurityLevelNr Variable

m_iSecurityLevelNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iSecurityLevelNr As SqlInt32
C#
private SqlInt32 m_iSecurityLevelNr;
C++
private:
SqlInt32 m_iSecurityLevelNr;
JScript
private m_iSecurityLevelNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iVertragspartnerNr, m_iSecurityLevelNr, m_iMutierer, m_iVertragstypNr, m_iVertragselementnr, m_iParentID As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


m_iVertragselementnr Variable

m_iVertragselementnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iVertragselementnr As SqlInt32
C#
private SqlInt32 m_iVertragselementnr;
C++
private:
SqlInt32 m_iVertragselementnr;
JScript
private m_iVertragselementnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iVertragspartnerNr, m_iSecurityLevelNr, m_iMutierer, m_iVertragstypNr, m_iVertragselementnr, m_iParentID As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


m_iVertragspartnerNr Variable

m_iVertragspartnerNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iVertragspartnerNr As SqlInt32
C#
private SqlInt32 m_iVertragspartnerNr;
C++
private:
SqlInt32 m_iVertragspartnerNr;
JScript
private m_iVertragspartnerNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iVertragspartnerNr, m_iSecurityLevelNr, m_iMutierer, m_iVertragstypNr, m_iVertragselementnr, m_iParentID As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


m_iVertragstypNr Variable

m_iVertragstypNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iVertragstypNr As SqlInt32
C#
private SqlInt32 m_iVertragstypNr;
C++
private:
SqlInt32 m_iVertragstypNr;
JScript
private m_iVertragstypNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iVertragspartnerNr, m_iSecurityLevelNr, m_iMutierer, m_iVertragstypNr, m_iVertragselementnr, m_iParentID As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


m_sBeschreibung Variable

m_sBeschreibung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBeschreibung As SqlString
C#
private SqlString m_sBeschreibung;
C++
private:
SqlString m_sBeschreibung;
JScript
private m_sBeschreibung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sVersion, m_sNummer, m_sBezeichnung, m_sSuchbegriffe, m_sBeschreibung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


m_sBezeichnung Variable

m_sBezeichnung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBezeichnung As SqlString
C#
private SqlString m_sBezeichnung;
C++
private:
SqlString m_sBezeichnung;
JScript
private m_sBezeichnung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sVersion, m_sNummer, m_sBezeichnung, m_sSuchbegriffe, m_sBeschreibung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


m_sNummer Variable

m_sNummer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sNummer As SqlString
C#
private SqlString m_sNummer;
C++
private:
SqlString m_sNummer;
JScript
private m_sNummer : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sVersion, m_sNummer, m_sBezeichnung, m_sSuchbegriffe, m_sBeschreibung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


m_sSuchbegriffe Variable

m_sSuchbegriffe Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sSuchbegriffe As SqlString
C#
private SqlString m_sSuchbegriffe;
C++
private:
SqlString m_sSuchbegriffe;
JScript
private m_sSuchbegriffe : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sVersion, m_sNummer, m_sBezeichnung, m_sSuchbegriffe, m_sBeschreibung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


m_sVersion Variable

m_sVersion Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sVersion As SqlString
C#
private SqlString m_sVersion;
C++
private:
SqlString m_sVersion;
JScript
private m_sVersion : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sVersion, m_sNummer, m_sBezeichnung, m_sSuchbegriffe, m_sBeschreibung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members


clsVertragskontakt Class

clsVertragskontakt Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'Vertragskontakt'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsVertragskontakt
    Inherits clsDBInteractionBase
C#
public class clsVertragskontakt : clsDBInteractionBase
C++

public ref class clsVertragskontakt : public clsDBInteractionBase^
JScript
public class clsVertragskontakt
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt
Vertragsverwaltung.TKB.VV.Vertrag.clsKontakt

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Members


clsVertragskontakt Members

clsVertragskontakt Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'Vertragskontakt'.

The following tables list the members exposed by the clsVertragskontakt type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsVertragskontakt Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bIntern |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iKontakttypNr |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iPersonNr |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr |
Supported by the .NET Compact Framework. | iVertragsKontaktNr |
Supported by the .NET Compact Framework. | iVertragselementNr |
Supported by the .NET Compact Framework. | sBemerkung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bIntern |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iKontakttypNr |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iPersonNr |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSecurityLevelNr |
Supported by the .NET Compact Framework. | m_iVertragsKontaktNr |
Supported by the .NET Compact Framework. | m_iVertragselementNr |
Supported by the .NET Compact Framework. | m_sBemerkung |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsVertragskontakt Class


clsVertragskontakt Constructor

clsVertragskontakt Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsVertragskontakt();
C++

public:
System::Void clsVertragskontakt()
JScript
public function clsVertragskontakt();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


clsVertragskontakt Properties

clsVertragskontakt Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bIntern |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iKontakttypNr |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iPersonNr |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr |
Supported by the .NET Compact Framework. | iVertragsKontaktNr |
Supported by the .NET Compact Framework. | iVertragselementNr |
Supported by the .NET Compact Framework. | sBemerkung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsVertragskontakt Class


clsVertragskontakt.bAktiv Property

clsVertragskontakt.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


clsVertragskontakt.bIntern Property

clsVertragskontakt.bIntern Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bIntern() As SqlBoolean
C#
public SqlBoolean bIntern {get; set;}
C++
public:
property SqlBoolean bIntern {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bIntern() : SqlBoolean;
public function set bIntern(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bIntern]() As SqlBoolean
            Get
                Return m_bIntern
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bIntern = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


clsVertragskontakt.daErstellt_am Property

clsVertragskontakt.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


clsVertragskontakt.daMutiert_am Property

clsVertragskontakt.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


clsVertragskontakt.iKontakttypNr Property

clsVertragskontakt.iKontakttypNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iKontakttypNr() As SqlInt32
C#
public SqlInt32 iKontakttypNr {get; set;}
C++
public:
property SqlInt32 iKontakttypNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iKontakttypNr() : SqlInt32;
public function set iKontakttypNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iKontakttypNr]() As SqlInt32
            Get
                Return m_iKontakttypNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iKontakttypNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


clsVertragskontakt.iMandantnr Property

clsVertragskontakt.iMandantnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandantnr() As SqlInt32
C#
public SqlInt32 iMandantnr {get; set;}
C++
public:
property SqlInt32 iMandantnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


clsVertragskontakt.iMutierer Property

clsVertragskontakt.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


clsVertragskontakt.iPersonNr Property

clsVertragskontakt.iPersonNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iPersonNr() As SqlInt32
C#
public SqlInt32 iPersonNr {get; set;}
C++
public:
property SqlInt32 iPersonNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iPersonNr() : SqlInt32;
public function set iPersonNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iPersonNr]() As SqlInt32
            Get
                Return m_iPersonNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iPersonNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


clsVertragskontakt.iSecurityLevelNr Property

clsVertragskontakt.iSecurityLevelNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iSecurityLevelNr() As SqlInt32
C#
public SqlInt32 iSecurityLevelNr {get; set;}
C++
public:
property SqlInt32 iSecurityLevelNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iSecurityLevelNr() : SqlInt32;
public function set iSecurityLevelNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iSecurityLevelNr]() As SqlInt32
            Get
                Return m_iSecurityLevelNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityLevelNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


clsVertragskontakt.iVertragsKontaktNr Property

clsVertragskontakt.iVertragsKontaktNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iVertragsKontaktNr() As SqlInt32
C#
public SqlInt32 iVertragsKontaktNr {get; set;}
C++
public:
property SqlInt32 iVertragsKontaktNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iVertragsKontaktNr() : SqlInt32;
public function set iVertragsKontaktNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iVertragsKontaktNr]() As SqlInt32
            Get
                Return m_iVertragsKontaktNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iVertragsKontaktNrTmp As SqlInt32 = Value
                If iVertragsKontaktNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iVertragsKontaktNr", "iVertragsKontaktNr can't be NULL")
                End If
                m_iVertragsKontaktNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


clsVertragskontakt.iVertragselementNr Property

clsVertragskontakt.iVertragselementNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iVertragselementNr() As SqlInt32
C#
public SqlInt32 iVertragselementNr {get; set;}
C++
public:
property SqlInt32 iVertragselementNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iVertragselementNr() : SqlInt32;
public function set iVertragselementNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iVertragselementNr]() As SqlInt32
            Get
                Return m_iVertragselementNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVertragselementNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


clsVertragskontakt.sBemerkung Property

clsVertragskontakt.sBemerkung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBemerkung() As SqlString
C#
public SqlString sBemerkung {get; set;}
C++
public:
property SqlString sBemerkung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBemerkung() : SqlString;
public function set sBemerkung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBemerkung]() As SqlString
            Get
                Return m_sBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


clsVertragskontakt Methods

clsVertragskontakt Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsVertragskontakt Class


clsVertragskontakt.Delete Method

clsVertragskontakt.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iVertragsKontaktNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragskontakt_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragsKontaktNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragsKontaktNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragskontakt_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragskontakt::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


clsVertragskontakt.Insert Method

clsVertragskontakt.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iVertragsKontaktNr</LI> <LI>iVertragselementNr. May be SqlInt32.Null</LI> <LI>iPersonNr. May be SqlInt32.Null</LI> <LI>iKontakttypNr. May be SqlInt32.Null</LI> <LI>bIntern. May be SqlBoolean.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragskontakt_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragsKontaktNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragsKontaktNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPersonNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPersonNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKontakttypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKontakttypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bIntern", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bIntern))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragskontakt_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragskontakt::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


clsVertragskontakt.SelectAll Method

clsVertragskontakt.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragskontakt_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragskontakt")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragskontakt_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragskontakt::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


clsVertragskontakt.SelectOne Method

clsVertragskontakt.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iVertragsKontaktNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iVertragsKontaktNr</LI> <LI>iVertragselementNr</LI> <LI>iPersonNr</LI> <LI>iKontakttypNr</LI> <LI>bIntern</LI> <LI>sBemerkung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> <LI>iSecurityLevelNr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragskontakt_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragskontakt")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragsKontaktNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragsKontaktNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragskontakt_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iVertragsKontaktNr = New SqlInt32(CType(dtToReturn.Rows(0)("VertragsKontaktNr"), Integer))
                    If dtToReturn.Rows(0)("VertragselementNr") Is System.DBNull.Value Then
                        m_iVertragselementNr = SqlInt32.Null
                    Else
                        m_iVertragselementNr = New SqlInt32(CType(dtToReturn.Rows(0)("VertragselementNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("PersonNr") Is System.DBNull.Value Then
                        m_iPersonNr = SqlInt32.Null
                    Else
                        m_iPersonNr = New SqlInt32(CType(dtToReturn.Rows(0)("PersonNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("KontakttypNr") Is System.DBNull.Value Then
                        m_iKontakttypNr = SqlInt32.Null
                    Else
                        m_iKontakttypNr = New SqlInt32(CType(dtToReturn.Rows(0)("KontakttypNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Intern") Is System.DBNull.Value Then
                        m_bIntern = SqlBoolean.Null
                    Else
                        m_bIntern = New SqlBoolean(CType(dtToReturn.Rows(0)("Intern"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Bemerkung") Is System.DBNull.Value Then
                        m_sBemerkung = SqlString.Null
                    Else
                        m_sBemerkung = New SqlString(CType(dtToReturn.Rows(0)("Bemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("SecurityLevelNr") Is System.DBNull.Value Then
                        m_iSecurityLevelNr = SqlInt32.Null
                    Else
                        m_iSecurityLevelNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevelNr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragskontakt::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


clsVertragskontakt.Update Method

clsVertragskontakt.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iVertragsKontaktNr</LI> <LI>iVertragselementNr. May be SqlInt32.Null</LI> <LI>iPersonNr. May be SqlInt32.Null</LI> <LI>iKontakttypNr. May be SqlInt32.Null</LI> <LI>bIntern. May be SqlBoolean.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragskontakt_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragsKontaktNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragsKontaktNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPersonNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPersonNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKontakttypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKontakttypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bIntern", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bIntern))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragskontakt_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragskontakt::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


clsVertragskontakt Fields

clsVertragskontakt Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bIntern |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iKontakttypNr |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iPersonNr |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSecurityLevelNr |
Supported by the .NET Compact Framework. | m_iVertragsKontaktNr |
Supported by the .NET Compact Framework. | m_iVertragselementNr |
Supported by the .NET Compact Framework. | m_sBemerkung |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsVertragskontakt Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bIntern, m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


m_bIntern Variable

m_bIntern Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bIntern As SqlBoolean
C#
private SqlBoolean m_bIntern;
C++
private:
SqlBoolean m_bIntern;
JScript
private m_bIntern : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bIntern, m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


m_iKontakttypNr Variable

m_iKontakttypNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iKontakttypNr As SqlInt32
C#
private SqlInt32 m_iKontakttypNr;
C++
private:
SqlInt32 m_iKontakttypNr;
JScript
private m_iKontakttypNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMandantnr, m_iMutierer, m_iVertragselementNr, m_iVertragsKontaktNr, m_iPersonNr, m_iSecurityLevelNr, m_iKontakttypNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


m_iMandantnr Variable

m_iMandantnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandantnr As SqlInt32
C#
private SqlInt32 m_iMandantnr;
C++
private:
SqlInt32 m_iMandantnr;
JScript
private m_iMandantnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMandantnr, m_iMutierer, m_iVertragselementNr, m_iVertragsKontaktNr, m_iPersonNr, m_iSecurityLevelNr, m_iKontakttypNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMandantnr, m_iMutierer, m_iVertragselementNr, m_iVertragsKontaktNr, m_iPersonNr, m_iSecurityLevelNr, m_iKontakttypNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


m_iPersonNr Variable

m_iPersonNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iPersonNr As SqlInt32
C#
private SqlInt32 m_iPersonNr;
C++
private:
SqlInt32 m_iPersonNr;
JScript
private m_iPersonNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMandantnr, m_iMutierer, m_iVertragselementNr, m_iVertragsKontaktNr, m_iPersonNr, m_iSecurityLevelNr, m_iKontakttypNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


m_iSecurityLevelNr Variable

m_iSecurityLevelNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iSecurityLevelNr As SqlInt32
C#
private SqlInt32 m_iSecurityLevelNr;
C++
private:
SqlInt32 m_iSecurityLevelNr;
JScript
private m_iSecurityLevelNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMandantnr, m_iMutierer, m_iVertragselementNr, m_iVertragsKontaktNr, m_iPersonNr, m_iSecurityLevelNr, m_iKontakttypNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


m_iVertragsKontaktNr Variable

m_iVertragsKontaktNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iVertragsKontaktNr As SqlInt32
C#
private SqlInt32 m_iVertragsKontaktNr;
C++
private:
SqlInt32 m_iVertragsKontaktNr;
JScript
private m_iVertragsKontaktNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMandantnr, m_iMutierer, m_iVertragselementNr, m_iVertragsKontaktNr, m_iPersonNr, m_iSecurityLevelNr, m_iKontakttypNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


m_iVertragselementNr Variable

m_iVertragselementNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iVertragselementNr As SqlInt32
C#
private SqlInt32 m_iVertragselementNr;
C++
private:
SqlInt32 m_iVertragselementNr;
JScript
private m_iVertragselementNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMandantnr, m_iMutierer, m_iVertragselementNr, m_iVertragsKontaktNr, m_iPersonNr, m_iSecurityLevelNr, m_iKontakttypNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


m_sBemerkung Variable

m_sBemerkung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBemerkung As SqlString
C#
private SqlString m_sBemerkung;
C++
private:
SqlString m_sBemerkung;
JScript
private m_sBemerkung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBemerkung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragskontakt Class
clsVertragskontakt Members


clsVertragspartner Class

clsVertragspartner Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'Vertragspartner'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsVertragspartner
    Inherits clsDBInteractionBase
C#
public class clsVertragspartner : clsDBInteractionBase
C++

public ref class clsVertragspartner : public clsDBInteractionBase^
JScript
public class clsVertragspartner
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsVertragspartner
Vertragsverwaltung.TKB.VV.Vertrag.clsVertragspartner

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Members


clsVertragspartner Members

clsVertragspartner Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'Vertragspartner'.

The following tables list the members exposed by the clsVertragspartner type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsVertragspartner Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr |
Supported by the .NET Compact Framework. | iVertragspartnerNr |
Supported by the .NET Compact Framework. | sBemerkung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sEMail |
Supported by the .NET Compact Framework. | sInternet |
Supported by the .NET Compact Framework. | sNameZ1 |
Supported by the .NET Compact Framework. | sNameZ2 |
Supported by the .NET Compact Framework. | sOrt |
Supported by the .NET Compact Framework. | sPLZ |
Supported by the .NET Compact Framework. | sPostfach |
Supported by the .NET Compact Framework. | sStrasse |
Supported by the .NET Compact Framework. | sTelefax |
Supported by the .NET Compact Framework. | sTelefon |
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSecurityLevelNr |
Supported by the .NET Compact Framework. | m_iVertragspartnerNr |
Supported by the .NET Compact Framework. | m_sBemerkung |
Supported by the .NET Compact Framework. | m_sEMail |
Supported by the .NET Compact Framework. | m_sInternet |
Supported by the .NET Compact Framework. | m_sNameZ1 |
Supported by the .NET Compact Framework. | m_sNameZ2 |
Supported by the .NET Compact Framework. | m_sOrt |
Supported by the .NET Compact Framework. | m_sPLZ |
Supported by the .NET Compact Framework. | m_sPostfach |
Supported by the .NET Compact Framework. | m_sStrasse |
Supported by the .NET Compact Framework. | m_sTelefax |
Supported by the .NET Compact Framework. | m_sTelefon |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsVertragspartner Class


clsVertragspartner Constructor

clsVertragspartner Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsVertragspartner();
C++

public:
System::Void clsVertragspartner()
JScript
public function clsVertragspartner();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


clsVertragspartner Properties

clsVertragspartner Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr |
Supported by the .NET Compact Framework. | iVertragspartnerNr |
Supported by the .NET Compact Framework. | sBemerkung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sEMail |
Supported by the .NET Compact Framework. | sInternet |
Supported by the .NET Compact Framework. | sNameZ1 |
Supported by the .NET Compact Framework. | sNameZ2 |
Supported by the .NET Compact Framework. | sOrt |
Supported by the .NET Compact Framework. | sPLZ |
Supported by the .NET Compact Framework. | sPostfach |
Supported by the .NET Compact Framework. | sStrasse |
Supported by the .NET Compact Framework. | sTelefax |
Supported by the .NET Compact Framework. | sTelefon |
Top

Expand image See Also

Reference

clsVertragspartner Class


clsVertragspartner.bAktiv Property

clsVertragspartner.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


clsVertragspartner.daErstellt_am Property

clsVertragspartner.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


clsVertragspartner.daMutiert_am Property

clsVertragspartner.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


clsVertragspartner.iMandantnr Property

clsVertragspartner.iMandantnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandantnr() As SqlInt32
C#
public SqlInt32 iMandantnr {get; set;}
C++
public:
property SqlInt32 iMandantnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


clsVertragspartner.iMutierer Property

clsVertragspartner.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


clsVertragspartner.iSecurityLevelNr Property

clsVertragspartner.iSecurityLevelNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iSecurityLevelNr() As SqlInt32
C#
public SqlInt32 iSecurityLevelNr {get; set;}
C++
public:
property SqlInt32 iSecurityLevelNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iSecurityLevelNr() : SqlInt32;
public function set iSecurityLevelNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iSecurityLevelNr]() As SqlInt32
            Get
                Return m_iSecurityLevelNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityLevelNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


clsVertragspartner.iVertragspartnerNr Property

clsVertragspartner.iVertragspartnerNr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iVertragspartnerNr() As SqlInt32
C#
public SqlInt32 iVertragspartnerNr {get; set;}
C++
public:
property SqlInt32 iVertragspartnerNr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iVertragspartnerNr() : SqlInt32;
public function set iVertragspartnerNr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iVertragspartnerNr]() As SqlInt32
            Get
                Return m_iVertragspartnerNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iVertragspartnerNrTmp As SqlInt32 = Value
                If iVertragspartnerNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iVertragspartnerNr", "iVertragspartnerNr can't be NULL")
                End If
                m_iVertragspartnerNr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


clsVertragspartner.sBemerkung Property

clsVertragspartner.sBemerkung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBemerkung() As SqlString
C#
public SqlString sBemerkung {get; set;}
C++
public:
property SqlString sBemerkung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBemerkung() : SqlString;
public function set sBemerkung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBemerkung]() As SqlString
            Get
                Return m_sBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


clsVertragspartner.sEMail Property

clsVertragspartner.sEMail Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sEMail() As SqlString
C#
public SqlString sEMail {get; set;}
C++
public:
property SqlString sEMail {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sEMail() : SqlString;
public function set sEMail(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sEMail]() As SqlString
            Get
                Return m_sEMail
            End Get
            Set(ByVal Value As SqlString)
                m_sEMail = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


clsVertragspartner.sInternet Property

clsVertragspartner.sInternet Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sInternet() As SqlString
C#
public SqlString sInternet {get; set;}
C++
public:
property SqlString sInternet {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sInternet() : SqlString;
public function set sInternet(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sInternet]() As SqlString
            Get
                Return m_sInternet
            End Get
            Set(ByVal Value As SqlString)
                m_sInternet = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


clsVertragspartner.sNameZ1 Property

clsVertragspartner.sNameZ1 Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sNameZ1() As SqlString
C#
public SqlString sNameZ1 {get; set;}
C++
public:
property SqlString sNameZ1 {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sNameZ1() : SqlString;
public function set sNameZ1(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sNameZ1]() As SqlString
            Get
                Return m_sNameZ1
            End Get
            Set(ByVal Value As SqlString)
                m_sNameZ1 = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


clsVertragspartner.sNameZ2 Property

clsVertragspartner.sNameZ2 Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sNameZ2() As SqlString
C#
public SqlString sNameZ2 {get; set;}
C++
public:
property SqlString sNameZ2 {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sNameZ2() : SqlString;
public function set sNameZ2(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sNameZ2]() As SqlString
            Get
                Return m_sNameZ2
            End Get
            Set(ByVal Value As SqlString)
                m_sNameZ2 = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


clsVertragspartner.sOrt Property

clsVertragspartner.sOrt Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sOrt() As SqlString
C#
public SqlString sOrt {get; set;}
C++
public:
property SqlString sOrt {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sOrt() : SqlString;
public function set sOrt(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sOrt]() As SqlString
            Get
                Return m_sOrt
            End Get
            Set(ByVal Value As SqlString)
                m_sOrt = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


clsVertragspartner.sPLZ Property

clsVertragspartner.sPLZ Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sPLZ() As SqlString
C#
public SqlString sPLZ {get; set;}
C++
public:
property SqlString sPLZ {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sPLZ() : SqlString;
public function set sPLZ(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sPLZ]() As SqlString
            Get
                Return m_sPLZ
            End Get
            Set(ByVal Value As SqlString)
                m_sPLZ = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


clsVertragspartner.sPostfach Property

clsVertragspartner.sPostfach Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sPostfach() As SqlString
C#
public SqlString sPostfach {get; set;}
C++
public:
property SqlString sPostfach {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sPostfach() : SqlString;
public function set sPostfach(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sPostfach]() As SqlString
            Get
                Return m_sPostfach
            End Get
            Set(ByVal Value As SqlString)
                m_sPostfach = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


clsVertragspartner.sStrasse Property

clsVertragspartner.sStrasse Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sStrasse() As SqlString
C#
public SqlString sStrasse {get; set;}
C++
public:
property SqlString sStrasse {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sStrasse() : SqlString;
public function set sStrasse(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sStrasse]() As SqlString
            Get
                Return m_sStrasse
            End Get
            Set(ByVal Value As SqlString)
                m_sStrasse = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


clsVertragspartner.sTelefax Property

clsVertragspartner.sTelefax Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sTelefax() As SqlString
C#
public SqlString sTelefax {get; set;}
C++
public:
property SqlString sTelefax {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sTelefax() : SqlString;
public function set sTelefax(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sTelefax]() As SqlString
            Get
                Return m_sTelefax
            End Get
            Set(ByVal Value As SqlString)
                m_sTelefax = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


clsVertragspartner.sTelefon Property

clsVertragspartner.sTelefon Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sTelefon() As SqlString
C#
public SqlString sTelefon {get; set;}
C++
public:
property SqlString sTelefon {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sTelefon() : SqlString;
public function set sTelefon(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sTelefon]() As SqlString
            Get
                Return m_sTelefon
            End Get
            Set(ByVal Value As SqlString)
                m_sTelefon = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


clsVertragspartner Methods

clsVertragspartner Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsVertragspartner Class


clsVertragspartner.Delete Method

clsVertragspartner.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iVertragspartnerNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragspartner_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragspartnerNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragspartnerNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragspartner_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragspartner::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


clsVertragspartner.Insert Method

clsVertragspartner.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iVertragspartnerNr</LI> <LI>sNameZ1. May be SqlString.Null</LI> <LI>sNameZ2. May be SqlString.Null</LI> <LI>sStrasse. May be SqlString.Null</LI> <LI>sPostfach. May be SqlString.Null</LI> <LI>sPLZ. May be SqlString.Null</LI> <LI>sOrt. May be SqlString.Null</LI> <LI>sTelefon. May be SqlString.Null</LI> <LI>sTelefax. May be SqlString.Null</LI> <LI>sEMail. May be SqlString.Null</LI> <LI>sInternet. May be SqlString.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragspartner_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragspartnerNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragspartnerNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNameZ1", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNameZ1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNameZ2", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNameZ2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sStrasse", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sStrasse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sPostfach", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPostfach))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sPLZ", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPLZ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sOrt", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sOrt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTelefon", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTelefon))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTelefax", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTelefax))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sEMail", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sEMail))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sInternet", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sInternet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragspartner_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragspartner::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


clsVertragspartner.SelectAll Method

clsVertragspartner.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragspartner_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragspartner")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragspartner_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragspartner::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


clsVertragspartner.SelectOne Method

clsVertragspartner.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iVertragspartnerNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iVertragspartnerNr</LI> <LI>sNameZ1</LI> <LI>sNameZ2</LI> <LI>sStrasse</LI> <LI>sPostfach</LI> <LI>sPLZ</LI> <LI>sOrt</LI> <LI>sTelefon</LI> <LI>sTelefax</LI> <LI>sEMail</LI> <LI>sInternet</LI> <LI>sBemerkung</LI> <LI>iSecurityLevelNr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragspartner_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragspartner")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragspartnerNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragspartnerNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragspartner_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iVertragspartnerNr = New SqlInt32(CType(dtToReturn.Rows(0)("VertragspartnerNr"), Integer))
                    If dtToReturn.Rows(0)("NameZ1") Is System.DBNull.Value Then
                        m_sNameZ1 = SqlString.Null
                    Else
                        m_sNameZ1 = New SqlString(CType(dtToReturn.Rows(0)("NameZ1"), String))
                    End If
                    If dtToReturn.Rows(0)("NameZ2") Is System.DBNull.Value Then
                        m_sNameZ2 = SqlString.Null
                    Else
                        m_sNameZ2 = New SqlString(CType(dtToReturn.Rows(0)("NameZ2"), String))
                    End If
                    If dtToReturn.Rows(0)("Strasse") Is System.DBNull.Value Then
                        m_sStrasse = SqlString.Null
                    Else
                        m_sStrasse = New SqlString(CType(dtToReturn.Rows(0)("Strasse"), String))
                    End If
                    If dtToReturn.Rows(0)("Postfach") Is System.DBNull.Value Then
                        m_sPostfach = SqlString.Null
                    Else
                        m_sPostfach = New SqlString(CType(dtToReturn.Rows(0)("Postfach"), String))
                    End If
                    If dtToReturn.Rows(0)("PLZ") Is System.DBNull.Value Then
                        m_sPLZ = SqlString.Null
                    Else
                        m_sPLZ = New SqlString(CType(dtToReturn.Rows(0)("PLZ"), String))
                    End If
                    If dtToReturn.Rows(0)("Ort") Is System.DBNull.Value Then
                        m_sOrt = SqlString.Null
                    Else
                        m_sOrt = New SqlString(CType(dtToReturn.Rows(0)("Ort"), String))
                    End If
                    If dtToReturn.Rows(0)("Telefon") Is System.DBNull.Value Then
                        m_sTelefon = SqlString.Null
                    Else
                        m_sTelefon = New SqlString(CType(dtToReturn.Rows(0)("Telefon"), String))
                    End If
                    If dtToReturn.Rows(0)("Telefax") Is System.DBNull.Value Then
                        m_sTelefax = SqlString.Null
                    Else
                        m_sTelefax = New SqlString(CType(dtToReturn.Rows(0)("Telefax"), String))
                    End If
                    If dtToReturn.Rows(0)("EMail") Is System.DBNull.Value Then
                        m_sEMail = SqlString.Null
                    Else
                        m_sEMail = New SqlString(CType(dtToReturn.Rows(0)("EMail"), String))
                    End If
                    If dtToReturn.Rows(0)("Internet") Is System.DBNull.Value Then
                        m_sInternet = SqlString.Null
                    Else
                        m_sInternet = New SqlString(CType(dtToReturn.Rows(0)("Internet"), String))
                    End If
                    If dtToReturn.Rows(0)("Bemerkung") Is System.DBNull.Value Then
                        m_sBemerkung = SqlString.Null
                    Else
                        m_sBemerkung = New SqlString(CType(dtToReturn.Rows(0)("Bemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("SecurityLevelNr") Is System.DBNull.Value Then
                        m_iSecurityLevelNr = SqlInt32.Null
                    Else
                        m_iSecurityLevelNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevelNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragspartner::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


clsVertragspartner.Update Method

clsVertragspartner.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iVertragspartnerNr</LI> <LI>sNameZ1. May be SqlString.Null</LI> <LI>sNameZ2. May be SqlString.Null</LI> <LI>sStrasse. May be SqlString.Null</LI> <LI>sPostfach. May be SqlString.Null</LI> <LI>sPLZ. May be SqlString.Null</LI> <LI>sOrt. May be SqlString.Null</LI> <LI>sTelefon. May be SqlString.Null</LI> <LI>sTelefax. May be SqlString.Null</LI> <LI>sEMail. May be SqlString.Null</LI> <LI>sInternet. May be SqlString.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragspartner_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragspartnerNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragspartnerNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNameZ1", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNameZ1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNameZ2", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNameZ2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sStrasse", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sStrasse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sPostfach", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPostfach))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sPLZ", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPLZ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sOrt", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sOrt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTelefon", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTelefon))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTelefax", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTelefax))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sEMail", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sEMail))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sInternet", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sInternet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragspartner_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragspartner::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


clsVertragspartner Fields

clsVertragspartner Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iSecurityLevelNr |
Supported by the .NET Compact Framework. | m_iVertragspartnerNr |
Supported by the .NET Compact Framework. | m_sBemerkung |
Supported by the .NET Compact Framework. | m_sEMail |
Supported by the .NET Compact Framework. | m_sInternet |
Supported by the .NET Compact Framework. | m_sNameZ1 |
Supported by the .NET Compact Framework. | m_sNameZ2 |
Supported by the .NET Compact Framework. | m_sOrt |
Supported by the .NET Compact Framework. | m_sPLZ |
Supported by the .NET Compact Framework. | m_sPostfach |
Supported by the .NET Compact Framework. | m_sStrasse |
Supported by the .NET Compact Framework. | m_sTelefax |
Supported by the .NET Compact Framework. | m_sTelefon |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsVertragspartner Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


m_iMandantnr Variable

m_iMandantnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandantnr As SqlInt32
C#
private SqlInt32 m_iMandantnr;
C++
private:
SqlInt32 m_iMandantnr;
JScript
private m_iMandantnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMandantnr, m_iSecurityLevelNr, m_iMutierer, m_iVertragspartnerNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMandantnr, m_iSecurityLevelNr, m_iMutierer, m_iVertragspartnerNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


m_iSecurityLevelNr Variable

m_iSecurityLevelNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iSecurityLevelNr As SqlInt32
C#
private SqlInt32 m_iSecurityLevelNr;
C++
private:
SqlInt32 m_iSecurityLevelNr;
JScript
private m_iSecurityLevelNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMandantnr, m_iSecurityLevelNr, m_iMutierer, m_iVertragspartnerNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


m_iVertragspartnerNr Variable

m_iVertragspartnerNr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iVertragspartnerNr As SqlInt32
C#
private SqlInt32 m_iVertragspartnerNr;
C++
private:
SqlInt32 m_iVertragspartnerNr;
JScript
private m_iVertragspartnerNr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMandantnr, m_iSecurityLevelNr, m_iMutierer, m_iVertragspartnerNr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


m_sBemerkung Variable

m_sBemerkung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBemerkung As SqlString
C#
private SqlString m_sBemerkung;
C++
private:
SqlString m_sBemerkung;
JScript
private m_sBemerkung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sStrasse, m_sPostfach, m_sNameZ2, m_sTelefax, m_sNameZ1, m_sPLZ, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


m_sEMail Variable

m_sEMail Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sEMail As SqlString
C#
private SqlString m_sEMail;
C++
private:
SqlString m_sEMail;
JScript
private m_sEMail : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sStrasse, m_sPostfach, m_sNameZ2, m_sTelefax, m_sNameZ1, m_sPLZ, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


m_sInternet Variable

m_sInternet Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sInternet As SqlString
C#
private SqlString m_sInternet;
C++
private:
SqlString m_sInternet;
JScript
private m_sInternet : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sStrasse, m_sPostfach, m_sNameZ2, m_sTelefax, m_sNameZ1, m_sPLZ, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


m_sNameZ1 Variable

m_sNameZ1 Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sNameZ1 As SqlString
C#
private SqlString m_sNameZ1;
C++
private:
SqlString m_sNameZ1;
JScript
private m_sNameZ1 : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sStrasse, m_sPostfach, m_sNameZ2, m_sTelefax, m_sNameZ1, m_sPLZ, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


m_sNameZ2 Variable

m_sNameZ2 Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sNameZ2 As SqlString
C#
private SqlString m_sNameZ2;
C++
private:
SqlString m_sNameZ2;
JScript
private m_sNameZ2 : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sStrasse, m_sPostfach, m_sNameZ2, m_sTelefax, m_sNameZ1, m_sPLZ, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


m_sOrt Variable

m_sOrt Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sOrt As SqlString
C#
private SqlString m_sOrt;
C++
private:
SqlString m_sOrt;
JScript
private m_sOrt : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sStrasse, m_sPostfach, m_sNameZ2, m_sTelefax, m_sNameZ1, m_sPLZ, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


m_sPLZ Variable

m_sPLZ Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sPLZ As SqlString
C#
private SqlString m_sPLZ;
C++
private:
SqlString m_sPLZ;
JScript
private m_sPLZ : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sStrasse, m_sPostfach, m_sNameZ2, m_sTelefax, m_sNameZ1, m_sPLZ, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


m_sPostfach Variable

m_sPostfach Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sPostfach As SqlString
C#
private SqlString m_sPostfach;
C++
private:
SqlString m_sPostfach;
JScript
private m_sPostfach : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sStrasse, m_sPostfach, m_sNameZ2, m_sTelefax, m_sNameZ1, m_sPLZ, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


m_sStrasse Variable

m_sStrasse Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sStrasse As SqlString
C#
private SqlString m_sStrasse;
C++
private:
SqlString m_sStrasse;
JScript
private m_sStrasse : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sStrasse, m_sPostfach, m_sNameZ2, m_sTelefax, m_sNameZ1, m_sPLZ, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


m_sTelefax Variable

m_sTelefax Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sTelefax As SqlString
C#
private SqlString m_sTelefax;
C++
private:
SqlString m_sTelefax;
JScript
private m_sTelefax : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sStrasse, m_sPostfach, m_sNameZ2, m_sTelefax, m_sNameZ1, m_sPLZ, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


m_sTelefon Variable

m_sTelefon Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sTelefon As SqlString
C#
private SqlString m_sTelefon;
C++
private:
SqlString m_sTelefon;
JScript
private m_sTelefon : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sStrasse, m_sPostfach, m_sNameZ2, m_sTelefax, m_sNameZ1, m_sPLZ, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members


clsVertragstyp Class

clsVertragstyp Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'Vertragstyp'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsVertragstyp
    Inherits clsDBInteractionBase
C#
public class clsVertragstyp : clsDBInteractionBase
C++

public ref class clsVertragstyp : public clsDBInteractionBase^
JScript
public class clsVertragstyp
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsVertragstyp

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragstyp Members


clsVertragstyp Members

clsVertragstyp Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'Vertragstyp'.

The following tables list the members exposed by the clsVertragstyp type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsVertragstyp Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iVertragstypnr |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sMutiert_durch |
Supported by the .NET Compact Framework. | sVertragstyp |
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | SelectOneWVertragstypnrLogic | Purpose: Select method for a unique field. This method will Select one row from the database, based on the unique field 'Vertragstypnr'
Supported by the .NET Compact Framework. | Update | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iVertragstypnr |
Supported by the .NET Compact Framework. | m_sMutiert_durch |
Supported by the .NET Compact Framework. | m_sVertragstyp |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsVertragstyp Class


clsVertragstyp Constructor

clsVertragstyp Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsVertragstyp();
C++

public:
System::Void clsVertragstyp()
JScript
public function clsVertragstyp();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragstyp Class
clsVertragstyp Members


clsVertragstyp Properties

clsVertragstyp Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iVertragstypnr |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sMutiert_durch |
Supported by the .NET Compact Framework. | sVertragstyp |
Top

Expand image See Also

Reference

clsVertragstyp Class


clsVertragstyp.bAktiv Property

clsVertragstyp.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragstyp Class
clsVertragstyp Members


clsVertragstyp.daErstellt_am Property

clsVertragstyp.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragstyp Class
clsVertragstyp Members


clsVertragstyp.daMutiert_am Property

clsVertragstyp.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragstyp Class
clsVertragstyp Members


clsVertragstyp.iVertragstypnr Property

clsVertragstyp.iVertragstypnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iVertragstypnr() As SqlInt32
C#
public SqlInt32 iVertragstypnr {get; set;}
C++
public:
property SqlInt32 iVertragstypnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iVertragstypnr() : SqlInt32;
public function set iVertragstypnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iVertragstypnr]() As SqlInt32
            Get
                Return m_iVertragstypnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iVertragstypnrTmp As SqlInt32 = Value
                If iVertragstypnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iVertragstypnr", "iVertragstypnr can't be NULL")
                End If
                m_iVertragstypnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragstyp Class
clsVertragstyp Members


clsVertragstyp.sMutiert_durch Property

clsVertragstyp.sMutiert_durch Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sMutiert_durch() As SqlString
C#
public SqlString sMutiert_durch {get; set;}
C++
public:
property SqlString sMutiert_durch {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sMutiert_durch() : SqlString;
public function set sMutiert_durch(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sMutiert_durch]() As SqlString
            Get
                Return m_sMutiert_durch
            End Get
            Set(ByVal Value As SqlString)
                m_sMutiert_durch = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragstyp Class
clsVertragstyp Members


clsVertragstyp.sVertragstyp Property

clsVertragstyp.sVertragstyp Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sVertragstyp() As SqlString
C#
public SqlString sVertragstyp {get; set;}
C++
public:
property SqlString sVertragstyp {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sVertragstyp() : SqlString;
public function set sVertragstyp(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sVertragstyp]() As SqlString
            Get
                Return m_sVertragstyp
            End Get
            Set(ByVal Value As SqlString)
                m_sVertragstyp = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragstyp Class
clsVertragstyp Members


clsVertragstyp Methods

clsVertragstyp Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | SelectOneWVertragstypnrLogic | Purpose: Select method for a unique field. This method will Select one row from the database, based on the unique field 'Vertragstypnr'
Supported by the .NET Compact Framework. | Update | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsVertragstyp Class


clsVertragstyp.Insert Method

clsVertragstyp.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>sVertragstyp. May be SqlString.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>sMutiert_durch. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iVertragstypnr</LI> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragstyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVertragstyp", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVertragstyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sMutiert_durch", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sMutiert_durch))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragstypnr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragstypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iVertragstypnr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iVertragstypnr").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragstyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragstyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragstyp Class
clsVertragstyp Members


clsVertragstyp.SelectAll Method

clsVertragstyp.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragstyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragstyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragstyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragstyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragstyp Class
clsVertragstyp Members


clsVertragstyp.SelectOneWVertragstypnrLogic Method

clsVertragstyp.SelectOneWVertragstypnrLogic Method

Purpose: Select method for a unique field. This method will Select one row from the database, based on the unique field 'Vertragstypnr'

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function SelectOneWVertragstypnrLogic() As DataTable
C#
public DataTable SelectOneWVertragstypnrLogic();
C++

public:
DataTable^ SelectOneWVertragstypnrLogic()
JScript
public function SelectOneWVertragstypnrLogic() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iVertragstypnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iVertragstypnr</LI> <LI>sVertragstyp</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>sMutiert_durch</LI> <LI>bAktiv</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function SelectOneWVertragstypnrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragstyp_SelectOneWVertragstypnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragstyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragstypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragstypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iVertragstypnr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iVertragstypnr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragstyp_SelectOneWVertragstypnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iVertragstypnr = New SqlInt32(CType(dtToReturn.Rows(0)("Vertragstypnr"), Integer))
                    If dtToReturn.Rows(0)("Vertragstyp") Is System.DBNull.Value Then
                        m_sVertragstyp = SqlString.Null
                    Else
                        m_sVertragstyp = New SqlString(CType(dtToReturn.Rows(0)("Vertragstyp"), String))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_durch") Is System.DBNull.Value Then
                        m_sMutiert_durch = SqlString.Null
                    Else
                        m_sMutiert_durch = New SqlString(CType(dtToReturn.Rows(0)("Mutiert_durch"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragstyp::SelectOneWVertragstypnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragstyp Class
clsVertragstyp Members


clsVertragstyp Fields

clsVertragstyp Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iVertragstypnr |
Supported by the .NET Compact Framework. | m_sMutiert_durch |
Supported by the .NET Compact Framework. | m_sVertragstyp |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsVertragstyp Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragstyp Class
clsVertragstyp Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragstyp Class
clsVertragstyp Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragstyp Class
clsVertragstyp Members


m_iVertragstypnr Variable

m_iVertragstypnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iVertragstypnr As SqlInt32
C#
private SqlInt32 m_iVertragstypnr;
C++
private:
SqlInt32 m_iVertragstypnr;
JScript
private m_iVertragstypnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iVertragstypnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragstyp Class
clsVertragstyp Members


m_sMutiert_durch Variable

m_sMutiert_durch Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sMutiert_durch As SqlString
C#
private SqlString m_sMutiert_durch;
C++
private:
SqlString m_sMutiert_durch;
JScript
private m_sMutiert_durch : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sVertragstyp, m_sMutiert_durch As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragstyp Class
clsVertragstyp Members


m_sVertragstyp Variable

m_sVertragstyp Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sVertragstyp As SqlString
C#
private SqlString m_sVertragstyp;
C++
private:
SqlString m_sVertragstyp;
JScript
private m_sVertragstyp : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sVertragstyp, m_sMutiert_durch As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragstyp Class
clsVertragstyp Members


clsZeiteinheittyp Class

clsZeiteinheittyp Class
See Also Members
collapseAll image DropDown image

Purpose: Data Access class for the table 'Zeiteinheittyp'.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsZeiteinheittyp
    Inherits clsDBInteractionBase
C#
public class clsZeiteinheittyp : clsDBInteractionBase
C++

public ref class clsZeiteinheittyp : public clsDBInteractionBase^
JScript
public class clsZeiteinheittyp
   extends clsDBInteractionBase

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp
Vertragsverwaltung.TKB.VV.DB.myZeiteinheittyp

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsZeiteinheittyp Members


clsZeiteinheittyp Members

clsZeiteinheittyp Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Purpose: Data Access class for the table 'Zeiteinheittyp'.

The following tables list the members exposed by the clsZeiteinheittyp type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsZeiteinheittyp Constructor | Purpose: Class constructor.
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iZeiteinheittypnr |
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iZeiteinheittypnr |
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsZeiteinheittyp Class


clsZeiteinheittyp Constructor

clsZeiteinheittyp Constructor

Purpose: Class constructor.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsZeiteinheittyp();
C++

public:
System::Void clsZeiteinheittyp()
JScript
public function clsZeiteinheittyp();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()
            ' // Nothing for now.
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsZeiteinheittyp Class
clsZeiteinheittyp Members


clsZeiteinheittyp Properties

clsZeiteinheittyp Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iZeiteinheittypnr |
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsZeiteinheittyp Class


clsZeiteinheittyp.bAktiv Property

clsZeiteinheittyp.bAktiv Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property bAktiv() As SqlBoolean
C#
public SqlBoolean bAktiv {get; set;}
C++
public:
property SqlBoolean bAktiv {
 SqlBoolean get( );
 void set(
   SqlBoolean value
 );
}
JScript
public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsZeiteinheittyp Class
clsZeiteinheittyp Members


clsZeiteinheittyp.daErstellt_am Property

clsZeiteinheittyp.daErstellt_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daErstellt_am() As SqlDateTime
C#
public SqlDateTime daErstellt_am {get; set;}
C++
public:
property SqlDateTime daErstellt_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsZeiteinheittyp Class
clsZeiteinheittyp Members


clsZeiteinheittyp.daMutiert_am Property

clsZeiteinheittyp.daMutiert_am Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property daMutiert_am() As SqlDateTime
C#
public SqlDateTime daMutiert_am {get; set;}
C++
public:
property SqlDateTime daMutiert_am {
 SqlDateTime get( );
 void set(
   SqlDateTime value
 );
}
JScript
public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsZeiteinheittyp Class
clsZeiteinheittyp Members


clsZeiteinheittyp.iMandantnr Property

clsZeiteinheittyp.iMandantnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMandantnr() As SqlInt32
C#
public SqlInt32 iMandantnr {get; set;}
C++
public:
property SqlInt32 iMandantnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsZeiteinheittyp Class
clsZeiteinheittyp Members


clsZeiteinheittyp.iMutierer Property

clsZeiteinheittyp.iMutierer Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iMutierer() As SqlInt32
C#
public SqlInt32 iMutierer {get; set;}
C++
public:
property SqlInt32 iMutierer {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsZeiteinheittyp Class
clsZeiteinheittyp Members


clsZeiteinheittyp.iZeiteinheittypnr Property

clsZeiteinheittyp.iZeiteinheittypnr Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property iZeiteinheittypnr() As SqlInt32
C#
public SqlInt32 iZeiteinheittypnr {get; set;}
C++
public:
property SqlInt32 iZeiteinheittypnr {
 SqlInt32 get( );
 void set(
   SqlInt32 value
 );
}
JScript
public function get iZeiteinheittypnr() : SqlInt32;
public function set iZeiteinheittypnr(value : SqlInt32);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [iZeiteinheittypnr]() As SqlInt32
            Get
                Return m_iZeiteinheittypnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iZeiteinheittypnrTmp As SqlInt32 = Value
                If iZeiteinheittypnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iZeiteinheittypnr", "iZeiteinheittypnr can't be NULL")
                End If
                m_iZeiteinheittypnr = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsZeiteinheittyp Class
clsZeiteinheittyp Members


clsZeiteinheittyp.sBeschreibung Property

clsZeiteinheittyp.sBeschreibung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBeschreibung() As SqlString
C#
public SqlString sBeschreibung {get; set;}
C++
public:
property SqlString sBeschreibung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBeschreibung() : SqlString;
public function set sBeschreibung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsZeiteinheittyp Class
clsZeiteinheittyp Members


clsZeiteinheittyp.sBezeichnung Property

clsZeiteinheittyp.sBezeichnung Property

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property sBezeichnung() As SqlString
C#
public SqlString sBezeichnung {get; set;}
C++
public:
property SqlString sBezeichnung {
 SqlString get( );
 void set(
   SqlString value
 );
}
JScript
public function get sBezeichnung() : SqlString;
public function set sBezeichnung(value : SqlString);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsZeiteinheittyp Class
clsZeiteinheittyp Members


clsZeiteinheittyp Methods

clsZeiteinheittyp Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database.
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database.
Top

Expand image See Also

Reference

clsZeiteinheittyp Class


clsZeiteinheittyp.Delete Method

clsZeiteinheittyp.Delete Method

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Delete() As Boolean
C#
public override bool Delete();
C++

public:
bool Delete()
JScript
public function Delete() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iZeiteinheittypnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Zeiteinheittyp_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iZeiteinheittypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iZeiteinheittypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Zeiteinheittyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsZeiteinheittyp::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsZeiteinheittyp Class
clsZeiteinheittyp Members


clsZeiteinheittyp.Insert Method

clsZeiteinheittyp.Insert Method

Purpose: Insert method. This method will insert one new row into the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Insert() As Boolean
C#
public override bool Insert();
C++

public:
bool Insert()
JScript
public function Insert() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iZeiteinheittypnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Zeiteinheittyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iZeiteinheittypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iZeiteinheittypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Zeiteinheittyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsZeiteinheittyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsZeiteinheittyp Class
clsZeiteinheittyp Members


clsZeiteinheittyp.SelectAll Method

clsZeiteinheittyp.SelectAll Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectAll() As DataTable
C#
public override DataTable SelectAll();
C++

public:
DataTable^ SelectAll()
JScript
public function SelectAll() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Zeiteinheittyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Zeiteinheittyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Zeiteinheittyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsZeiteinheittyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsZeiteinheittyp Class
clsZeiteinheittyp Members


clsZeiteinheittyp.SelectOne Method

clsZeiteinheittyp.SelectOne Method

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function SelectOne() As DataTable
C#
public override DataTable SelectOne();
C++

public:
DataTable^ SelectOne()
JScript
public function SelectOne() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iZeiteinheittypnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iZeiteinheittypnr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Zeiteinheittyp_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Zeiteinheittyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iZeiteinheittypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iZeiteinheittypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Zeiteinheittyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iZeiteinheittypnr = New SqlInt32(CType(dtToReturn.Rows(0)("Zeiteinheittypnr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsZeiteinheittyp::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsZeiteinheittyp Class
clsZeiteinheittyp Members


clsZeiteinheittyp.Update Method

clsZeiteinheittyp.Update Method

Purpose: Update method. This method will Update one existing row in the database.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Boolean
C#
public override bool Update();
C++

public:
bool Update()
JScript
public function Update() : boolean;

Return Value

True if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties needed for this method: <UL> <LI>iZeiteinheittypnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Zeiteinheittyp_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iZeiteinheittypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iZeiteinheittypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Zeiteinheittyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsZeiteinheittyp::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsZeiteinheittyp Class
clsZeiteinheittyp Members


clsZeiteinheittyp Fields

clsZeiteinheittyp Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iZeiteinheittypnr |
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsZeiteinheittyp Class


m_bAktiv Variable

m_bAktiv Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_bAktiv As SqlBoolean
C#
private SqlBoolean m_bAktiv;
C++
private:
SqlBoolean m_bAktiv;
JScript
private m_bAktiv : SqlBoolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_bAktiv As SqlBoolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsZeiteinheittyp Class
clsZeiteinheittyp Members


m_daErstellt_am Variable

m_daErstellt_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daErstellt_am As SqlDateTime
C#
private SqlDateTime m_daErstellt_am;
C++
private:
SqlDateTime m_daErstellt_am;
JScript
private m_daErstellt_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsZeiteinheittyp Class
clsZeiteinheittyp Members


m_daMutiert_am Variable

m_daMutiert_am Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_daMutiert_am As SqlDateTime
C#
private SqlDateTime m_daMutiert_am;
C++
private:
SqlDateTime m_daMutiert_am;
JScript
private m_daMutiert_am : SqlDateTime

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsZeiteinheittyp Class
clsZeiteinheittyp Members


m_iMandantnr Variable

m_iMandantnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMandantnr As SqlInt32
C#
private SqlInt32 m_iMandantnr;
C++
private:
SqlInt32 m_iMandantnr;
JScript
private m_iMandantnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iZeiteinheittypnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsZeiteinheittyp Class
clsZeiteinheittyp Members


m_iMutierer Variable

m_iMutierer Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iMutierer As SqlInt32
C#
private SqlInt32 m_iMutierer;
C++
private:
SqlInt32 m_iMutierer;
JScript
private m_iMutierer : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iZeiteinheittypnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsZeiteinheittyp Class
clsZeiteinheittyp Members


m_iZeiteinheittypnr Variable

m_iZeiteinheittypnr Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_iZeiteinheittypnr As SqlInt32
C#
private SqlInt32 m_iZeiteinheittypnr;
C++
private:
SqlInt32 m_iZeiteinheittypnr;
JScript
private m_iZeiteinheittypnr : SqlInt32

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_iMutierer, m_iMandantnr, m_iZeiteinheittypnr As SqlInt32

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsZeiteinheittyp Class
clsZeiteinheittyp Members


m_sBeschreibung Variable

m_sBeschreibung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBeschreibung As SqlString
C#
private SqlString m_sBeschreibung;
C++
private:
SqlString m_sBeschreibung;
JScript
private m_sBeschreibung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsZeiteinheittyp Class
clsZeiteinheittyp Members


m_sBezeichnung Variable

m_sBezeichnung Variable

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_sBezeichnung As SqlString
C#
private SqlString m_sBezeichnung;
C++
private:
SqlString m_sBezeichnung;
JScript
private m_sBezeichnung : SqlString

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsZeiteinheittyp Class
clsZeiteinheittyp Members


mySLATyp Class

mySLATyp Class
See Also Members
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class mySLATyp
    Inherits clsSLATyp
C#
public class mySLATyp : clsSLATyp
C++

public ref class mySLATyp : public clsSLATyp^
JScript
public class mySLATyp
   extends clsSLATyp

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsSLATyp
Vertragsverwaltung.TKB.VV.DB.mySLATyp

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

mySLATyp Members


mySLATyp Members

mySLATyp Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

The following tables list the members exposed by the mySLATyp type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | mySLATyp Constructor | Purpose: Class constructor. (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Supported by the .NET Compact Framework. | iMutierer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSLATypNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Supported by the .NET Compact Framework. | sBeschreibung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Supported by the .NET Compact Framework. | sBezeichnung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table. (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Supported by the .NET Compact Framework. | SelectAll_Aktive | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

mySLATyp Class


mySLATyp Properties

mySLATyp Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Supported by the .NET Compact Framework. | iMutierer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSLATypNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Supported by the .NET Compact Framework. | sBeschreibung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Supported by the .NET Compact Framework. | sBezeichnung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

mySLATyp Class


mySLATyp Methods

mySLATyp Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table. (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Supported by the .NET Compact Framework. | SelectAll_Aktive | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsSLATyp).
Top

Expand image See Also

Reference

mySLATyp Class


mySLATyp.SelectAll_Aktive Method

mySLATyp.SelectAll_Aktive Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function SelectAll_Aktive() As DataTable
C#
public DataTable SelectAll_Aktive();
C++

public:
DataTable^ SelectAll_Aktive()
JScript
public function SelectAll_Aktive() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function SelectAll_Aktive() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLATyp_SelectAll_Aktive]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("SLATyp")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(TKB.VV.DB.LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLATyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLATyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

mySLATyp Class
mySLATyp Members


mySLATyp Fields

mySLATyp Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

mySLATyp Class


myZeiteinheittyp Class

myZeiteinheittyp Class
See Also Members
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class myZeiteinheittyp
    Inherits clsZeiteinheittyp
C#
public class myZeiteinheittyp : clsZeiteinheittyp
C++

public ref class myZeiteinheittyp : public clsZeiteinheittyp^
JScript
public class myZeiteinheittyp
   extends clsZeiteinheittyp

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp
Vertragsverwaltung.TKB.VV.DB.myZeiteinheittyp

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

myZeiteinheittyp Members


myZeiteinheittyp Members

myZeiteinheittyp Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

The following tables list the members exposed by the myZeiteinheittyp type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | myZeiteinheittyp Constructor | Purpose: Class constructor. (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Supported by the .NET Compact Framework. | iMutierer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iZeiteinheittypnr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Supported by the .NET Compact Framework. | sBeschreibung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Supported by the .NET Compact Framework. | sBezeichnung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table. (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Supported by the .NET Compact Framework. | SelectAll_aktive | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

myZeiteinheittyp Class


myZeiteinheittyp Properties

myZeiteinheittyp Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Supported by the .NET Compact Framework. | iMutierer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iZeiteinheittypnr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Supported by the .NET Compact Framework. | sBeschreibung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Supported by the .NET Compact Framework. | sBezeichnung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

myZeiteinheittyp Class


myZeiteinheittyp Methods

myZeiteinheittyp Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table. (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Supported by the .NET Compact Framework. | SelectAll_aktive | Purpose: SelectAll method. This method will Select all rows from the table.
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp).
Top

Expand image See Also

Reference

myZeiteinheittyp Class


myZeiteinheittyp.SelectAll_aktive Method

myZeiteinheittyp.SelectAll_aktive Method

Purpose: SelectAll method. This method will Select all rows from the table.

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function SelectAll_aktive() As DataTable
C#
public DataTable SelectAll_aktive();
C++

public:
DataTable^ SelectAll_aktive()
JScript
public function SelectAll_aktive() : DataTable;

Return Value

DataTable object if succeeded, otherwise an Exception is thrown.

Expand image Remarks

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function SelectAll_aktive() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Zeiteinheittyp_SelectAll_aktive]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("Zeiteinheittyp")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(TKB.VV.DB.LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Zeiteinheittyp_SelectAll_Aktive' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsZeiteinheittyp::SelectAll_Aktive::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

myZeiteinheittyp Class
myZeiteinheittyp Members


myZeiteinheittyp Fields

myZeiteinheittyp Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

myZeiteinheittyp Class


ICommonDBAccess Interface

ICommonDBAccess Interface
See Also Members
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Interface ICommonDBAccess
C#
public interface ICommonDBAccess
C++

public interface class ICommonDBAccess
JScript
public interface ICommonDBAccess

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

ICommonDBAccess Members


ICommonDBAccess Members

ICommonDBAccess Members
See Also Methods
CollapseAll image DropDown image

The following tables list the members exposed by the ICommonDBAccess type.

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Insert |
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Supported by the .NET Compact Framework. | Update |
Top

Expand image See Also

Reference

ICommonDBAccess Interface


ICommonDBAccess Methods

ICommonDBAccess Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Insert |
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Supported by the .NET Compact Framework. | Update |
Top

Expand image See Also

Reference

ICommonDBAccess Interface


ICommonDBAccess.Delete Method

ICommonDBAccess.Delete Method

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Function Delete() As Boolean
C#
bool Delete();
C++

bool Delete()
JScript
function Delete() : boolean;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Function	Delete() As Boolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

ICommonDBAccess Interface
ICommonDBAccess Members


ICommonDBAccess.Insert Method

ICommonDBAccess.Insert Method

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Function Insert() As Boolean
C#
bool Insert();
C++

bool Insert()
JScript
function Insert() : boolean;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Function	Insert() As Boolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

ICommonDBAccess Interface
ICommonDBAccess Members


ICommonDBAccess.SelectAll Method

ICommonDBAccess.SelectAll Method

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Function SelectAll() As DataTable
C#
DataTable SelectAll();
C++

DataTable^ SelectAll()
JScript
function SelectAll() : DataTable;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Function	SelectAll() As DataTable

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

ICommonDBAccess Interface
ICommonDBAccess Members


ICommonDBAccess.SelectOne Method

ICommonDBAccess.SelectOne Method

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Function SelectOne() As DataTable
C#
DataTable SelectOne();
C++

DataTable^ SelectOne()
JScript
function SelectOne() : DataTable;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Function	SelectOne() As DataTable

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

ICommonDBAccess Interface
ICommonDBAccess Members


ICommonDBAccess.Update Method

ICommonDBAccess.Update Method

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Function Update() As Boolean
C#
bool Update();
C++

bool Update()
JScript
function Update() : boolean;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Function	Update() As Boolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

ICommonDBAccess Interface
ICommonDBAccess Members


LLBLError Enumeration

LLBLError Enumeration

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Enum LLBLError
        AllOk
        ' // Add more here (check the comma's!)
    End Enum

Expand image See Also

Reference


Vertragsverwaltung.TKB.VV.SLA Namespace

Vertragsverwaltung.TKB.VV.SLA Namespace

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Classes

 | Name | Description
Supported by the .NET Compact Framework. | clsSLAKatalogdaten | Laden der Daten für die SLA-Katalogverwaltung
Supported by the .NET Compact Framework. | clsServiceKatalogDaten |
Supported by the .NET Compact Framework. | clsServiceKatalogSLATree | TreeDatenklasse für den Servicekatalog-Tree
Supported by the .NET Compact Framework. | clsServiceKatalogTree | TreeDatenklasse für den Servicekatalog-Tree
Top

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0


clsSLAKatalogdaten Class

clsSLAKatalogdaten Class
See Also Members
collapseAll image DropDown image

Laden der Daten für die SLA-Katalogverwaltung

Namespace: Vertragsverwaltung.TKB.VV.SLA
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsSLAKatalogdaten
    Inherits DomainTable
C#
public class clsSLAKatalogdaten : DomainTable
C++

public ref class clsSLAKatalogdaten : public DomainTable^
JScript
public class clsSLAKatalogdaten
   extends DomainTable

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable
Vertragsverwaltung.TKB.VV.SLA.clsSLAKatalogdaten

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalogdaten Members
Vertragsverwaltung.TKB.VV.SLA Namespace


clsSLAKatalogdaten Members

clsSLAKatalogdaten Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Laden der Daten für die SLA-Katalogverwaltung

The following tables list the members exposed by the clsSLAKatalogdaten type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsSLAKatalogdaten Constructor | (Overloaded)
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Insert_Proc | (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Supported by the .NET Compact Framework. | Insert_Proc_Bottomtable | (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Supported by the .NET Compact Framework. | Select_Proc | (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Supported by the .NET Compact Framework. | Select_Proc_Bottomtable | (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Supported by the .NET Compact Framework. | Tabledata | (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Supported by the .NET Compact Framework. | Tablename | (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Supported by the .NET Compact Framework. | Update_Proc | (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Supported by the .NET Compact Framework. | Update_Proc_Bottomtable | (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Insert_Bottom_Table | Neuer Eintrag in der Tabelle eintragen. Sind neben den Defaultwerten weitere Attribute vorhanden, werde diese abhängig vom Datentype mit Defaultwerten befüllt. (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Supported by the .NET Compact Framework. | Load_Bootom_Table | Load der Verbindungstabelle (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Supported by the .NET Compact Framework. | Load_Data | Daten ab Datenbank laden
Supported by the .NET Compact Framework. | Load_Data_MA | (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Supported by the .NET Compact Framework. | Save_Data | Datesichern. Dabei wird das Update- sowie das Insert-Statement dynamisch generiert (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Supported by the .NET Compact Framework. | dispose | Dispose von Tabledata (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Top

Expand image See Also

Reference

clsSLAKatalogdaten Class
Vertragsverwaltung.TKB.VV.SLA Namespace


clsSLAKatalogdaten Constructor

clsSLAKatalogdaten Constructor

Expand image Overload List

Name | Description
public System.Void DomainTable(string, string, int); | (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
public System.Void DomainTable(string, int, string); | Tabellenname übernehmen und Daten ab DB laden (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
public System.Void clsSLAKatalogdaten(string); |

Expand image See Also

Reference

clsSLAKatalogdaten Class
clsSLAKatalogdaten Members
Vertragsverwaltung.TKB.VV.SLA Namespace


clsSLAKatalogdaten Properties

clsSLAKatalogdaten Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Insert_Proc | (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Supported by the .NET Compact Framework. | Insert_Proc_Bottomtable | (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Supported by the .NET Compact Framework. | Select_Proc | (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Supported by the .NET Compact Framework. | Select_Proc_Bottomtable | (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Supported by the .NET Compact Framework. | Tabledata | (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Supported by the .NET Compact Framework. | Tablename | (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Supported by the .NET Compact Framework. | Update_Proc | (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Supported by the .NET Compact Framework. | Update_Proc_Bottomtable | (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Top

Expand image See Also

Reference

clsSLAKatalogdaten Class
Vertragsverwaltung.TKB.VV.SLA Namespace


DomainTable.Insert_Proc Property

DomainTable.Insert_Proc Property

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property Insert_Proc() As String
C#
public string Insert_Proc {get; set;}
C++
public:
property String^ Insert_Proc {
 String^ get( );
 void set(
   String^ value
 );
}
JScript
public function get Insert_Proc() : String;
public function set Insert_Proc(value : String);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Property Insert_Proc() As String
            Get
                Return "pr_" & Tablename & "_Insert"
            End Get
            Set(ByVal value As String)
                m_selectproc = "pr_" & Tablename & "_Update"
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


DomainTable.Insert_Proc_Bottomtable Property

DomainTable.Insert_Proc_Bottomtable Property

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property Insert_Proc_Bottomtable() As String
C#
public string Insert_Proc_Bottomtable {get; set;}
C++
public:
property String^ Insert_Proc_Bottomtable {
 String^ get( );
 void set(
   String^ value
 );
}
JScript
public function get Insert_Proc_Bottomtable() : String;
public function set Insert_Proc_Bottomtable(value : String);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Property Insert_Proc_Bottomtable() As String
            Get
                Return "pr_" & Tablename & "_Insert_bottomtable"
            End Get
            Set(ByVal value As String)
                m_selectproc = "pr_" & Tablename & "_Update_bottomtable"
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


DomainTable.Select_Proc Property

DomainTable.Select_Proc Property

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property Select_Proc() As String
C#
public string Select_Proc {get; set;}
C++
public:
property String^ Select_Proc {
 String^ get( );
 void set(
   String^ value
 );
}
JScript
public function get Select_Proc() : String;
public function set Select_Proc(value : String);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Property Select_Proc() As String
            Get
                Return "pr_" & Tablename & "_selectall"
            End Get
            Set(ByVal value As String)
                m_selectproc = "pr_" & Tablename & "_selectall"
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


DomainTable.Select_Proc_Bottomtable Property

DomainTable.Select_Proc_Bottomtable Property

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property Select_Proc_Bottomtable() As String
C#
public string Select_Proc_Bottomtable {get; set;}
C++
public:
property String^ Select_Proc_Bottomtable {
 String^ get( );
 void set(
   String^ value
 );
}
JScript
public function get Select_Proc_Bottomtable() : String;
public function set Select_Proc_Bottomtable(value : String);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Property Select_Proc_Bottomtable() As String
            Get
                Return "pr_" & Tablename & "_selectall_bottomtable"
            End Get
            Set(ByVal value As String)
                m_selectproc = "pr_" & Tablename & "_selectall_bottomtable"
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


DomainTable.Tabledata Property

DomainTable.Tabledata Property

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property Tabledata() As DataSet
C#
public DataSet Tabledata {get; set;}
C++
public:
property DataSet^ Tabledata {
 DataSet^ get( );
 void set(
   DataSet^ value
 );
}
JScript
public function get Tabledata() : DataSet;
public function set Tabledata(value : DataSet);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Property Tabledata() As DataSet
            Get
                Return m_Tabledata
            End Get
            Set(ByVal value As DataSet)
                m_Tabledata = value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


DomainTable.Tablename Property

DomainTable.Tablename Property

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property Tablename() As String
C#
public string Tablename {get; set;}
C++
public:
property String^ Tablename {
 String^ get( );
 void set(
   String^ value
 );
}
JScript
public function get Tablename() : String;
public function set Tablename(value : String);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Property Tablename() As String
            Get
                Return m_tablename
            End Get
            Set(ByVal value As String)
                m_tablename = value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


DomainTable.Update_Proc Property

DomainTable.Update_Proc Property

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property Update_Proc() As String
C#
public string Update_Proc {get; set;}
C++
public:
property String^ Update_Proc {
 String^ get( );
 void set(
   String^ value
 );
}
JScript
public function get Update_Proc() : String;
public function set Update_Proc(value : String);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Property Update_Proc() As String
            Get
                Return "pr_" & Tablename & "_Update"
            End Get
            Set(ByVal value As String)
                m_selectproc = "pr_" & Tablename & "_Update"
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


DomainTable.Update_Proc_Bottomtable Property

DomainTable.Update_Proc_Bottomtable Property

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property Update_Proc_Bottomtable() As String
C#
public string Update_Proc_Bottomtable {get; set;}
C++
public:
property String^ Update_Proc_Bottomtable {
 String^ get( );
 void set(
   String^ value
 );
}
JScript
public function get Update_Proc_Bottomtable() : String;
public function set Update_Proc_Bottomtable(value : String);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Property Update_Proc_Bottomtable() As String
            Get
                Return "pr_" & Tablename & "_Update_bottomtable"
            End Get
            Set(ByVal value As String)
                m_selectproc = "pr_" & Tablename & "_Update_bottomtable"
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


clsSLAKatalogdaten Methods

clsSLAKatalogdaten Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Insert_Bottom_Table | Neuer Eintrag in der Tabelle eintragen. Sind neben den Defaultwerten weitere Attribute vorhanden, werde diese abhängig vom Datentype mit Defaultwerten befüllt. (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Supported by the .NET Compact Framework. | Load_Bootom_Table | Load der Verbindungstabelle (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Supported by the .NET Compact Framework. | Load_Data | Daten ab Datenbank laden
Supported by the .NET Compact Framework. | Load_Data_MA | (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Supported by the .NET Compact Framework. | Save_Data | Datesichern. Dabei wird das Update- sowie das Insert-Statement dynamisch generiert (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Supported by the .NET Compact Framework. | dispose | Dispose von Tabledata (inherited from Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable).
Top

Expand image See Also

Reference

clsSLAKatalogdaten Class
Vertragsverwaltung.TKB.VV.SLA Namespace


DomainTable.Insert_Bottom_Table Method

DomainTable.Insert_Bottom_Table Method

Neuer Eintrag in der Tabelle eintragen. Sind neben den Defaultwerten weitere Attribute vorhanden, werde diese abhängig vom Datentype mit Defaultwerten befüllt.

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Insert_Bottom_Table( _
   ByVal key1 As String, _
   ByVal keyvalue1 As Integer, _
   ByVal key2 As String, _
   ByVal keyvalue2 As String _
)
C#
public System.Void Insert_Bottom_Table(
   string key1,
   int keyvalue1,
   string key2,
   string keyvalue2
);
C++

public:
System::Void Insert_Bottom_Table(
   String^ key1,
   int keyvalue1,
   String^ key2,
   String^ keyvalue2
)
JScript
public function Insert_Bottom_Table(
    key1 : String,
    keyvalue1 : int,
    key2 : String,
    keyvalue2 : String
);

Parameters

key1

keyvalue1

key2

keyvalue2

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub Insert_Bottom_Table(ByVal key1 As String, ByVal keyvalue1 As Integer, ByVal key2 As String, ByVal keyvalue2 As String)
            Dim dbkey As New TKB.VV.DB.clsMyKey_Tabelle
            dbkey.cpMainConnectionProvider = Globals.conn
            conn.OpenConnection()
            Dim newkey As Integer = dbkey.get_dbkey(Me.Tablename)
            conn.CloseConnection(True)
            dbkey.Dispose()
            Dim dr As DataRow
            dr = Me.Tabledata.Tables(0).NewRow
            dr.Item(0) = newkey
            Dim i As Integer
            For i = 1 To Me.Tabledata.Tables(0).Columns.Count - 1
                Select Case UCase(Me.Tabledata.Tables(0).Columns(i).ColumnName)
                    Case "AKTIV"
                        dr.Item(i) = 1
                    Case "ERSTELLT_AM"
                        dr.Item(i) = Now
                    Case "MUTIERT_AM"
                        dr.Item(i) = Now
                    Case "MUTIERER"
                        dr.Item(i) = Globals.clsmitarbeiter.iMitarbeiternr.Value
                    Case "MANDANTNR"
                        dr.Item(i) = Globals.clsmitarbeiter.iMandantnr.Value
                    Case "MANDANT"
                        dr.Item(i) = Globals.clsmitarbeiter.iMandantnr.Value
                    Case UCase(key1)
                        dr.Item(i) = keyvalue1
                    Case UCase(key2)
                        dr.Item(i) = keyvalue2
                    Case Else
                        Select Case Type.GetTypeCode(Me.Tabledata.Tables(0).Columns(i).DataType)
                            Case TypeCode.DateTime
                                dr.Item(i) = Now
                            Case TypeCode.Double
                                dr.Item(i) = 0
                            Case TypeCode.String
                                dr.Item(i) = ""
                            Case TypeCode.Int32
                                dr.Item(i) = 0
                            Case TypeCode.Boolean
                                dr.Item(i) = True
                            Case TypeCode.Int16
                                dr.Item(i) = 0
                            Case TypeCode.Int32
                                dr.Item(i) = 0
                            Case TypeCode.Int64
                                dr.Item(i) = 0
                        End Select
                End Select
            Next
            Me.Tabledata.Tables(0).Rows.Add(dr)
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


DomainTable.Load_Bootom_Table Method

DomainTable.Load_Bootom_Table Method

Load der Verbindungstabelle

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Load_Bootom_Table( _
   ByVal tablename As String, _
   ByVal Fokus As Integer, _
   ByVal KeyValue As String _
)
C#
public System.Void Load_Bootom_Table(
   string tablename,
   int Fokus,
   string KeyValue
);
C++

public:
System::Void Load_Bootom_Table(
   String^ tablename,
   int Fokus,
   String^ KeyValue
)
JScript
public function Load_Bootom_Table(
    tablename : String,
    Fokus : int,
    KeyValue : String
);

Parameters

tablename

Fokus

KeyValue

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub Load_Bootom_Table(ByVal tablename As String, ByVal Fokus As Integer, ByVal KeyValue As String)
            Tabledata.Tables.Clear()
            Dim sqlcmd As New SqlCommand
            sqlcmd.CommandText = Me.Select_Proc_bottomtable
            sqlcmd.Parameters.Add("@iErrorCode", SqlDbType.Int, 4)
            sqlcmd.Parameters.Add("@Fokus", SqlDbType.Int, 4)
            sqlcmd.Parameters.Add("@KeyValue", SqlDbType.VarChar, 255)
            sqlcmd.Parameters(0).Value = 0
            sqlcmd.Parameters(1).Value = Fokus
            sqlcmd.Parameters(2).Value = KeyValue

            sqlcmd.CommandType = CommandType.StoredProcedure
            sqlcmd.Connection = connection
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.SelectCommand = sqlcmd
                da.Fill(Tabledata, "Domaintable")
            Catch ex As Exception
            Finally
                connection.Close()
                da.Dispose()
                sqlcmd.Dispose()
            End Try
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


clsSLAKatalogdaten.Load_Data Method

clsSLAKatalogdaten.Load_Data Method

Daten ab Datenbank laden

Namespace: Vertragsverwaltung.TKB.VV.SLA
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Sub Load_Data()
C#
public override System.Void Load_Data();
C++

public:
System::Void Load_Data()
JScript
public function Load_Data();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Overrides Sub Load_Data()
            Tabledata.Tables.Clear()
            Dim selectcommand As New SqlCommand
            Dim connection As New SqlConnection()
            Dim da As New SqlDataAdapter("", connection)

            selectcommand.CommandText = Me.Select_Proc & "_Level"
            selectcommand.Parameters.Add("@Mitarbeiternr", SqlDbType.Int, 4)
            selectcommand.Parameters.Add("@iErrorCode", SqlDbType.Int, 4)
            selectcommand.Parameters(0).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value
            selectcommand.Parameters(1).Value = 0

            selectcommand.CommandType = CommandType.StoredProcedure
            selectcommand.Connection = connection
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.SelectCommand = selectcommand
                da.Fill(Tabledata, "Domaintable")
            Catch ex As Exception
            Finally
                connection.Close()
                da.Dispose()
                selectcommand.Dispose()
            End Try
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalogdaten Class
clsSLAKatalogdaten Members
Vertragsverwaltung.TKB.VV.SLA Namespace


DomainTable.Load_Data_MA Method

DomainTable.Load_Data_MA Method

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Load_Data_MA( _
   ByVal tablename As String, _
   ByVal KeyValue As String, _
   ByVal mitarbeiternr As Integer _
)
C#
public System.Void Load_Data_MA(
   string tablename,
   string KeyValue,
   int mitarbeiternr
);
C++

public:
System::Void Load_Data_MA(
   String^ tablename,
   String^ KeyValue,
   int mitarbeiternr
)
JScript
public function Load_Data_MA(
    tablename : String,
    KeyValue : String,
    mitarbeiternr : int
);

Parameters

tablename

KeyValue

mitarbeiternr

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub Load_Data_MA(ByVal tablename As String, ByVal KeyValue As String, ByVal mitarbeiternr As Integer)
            Tabledata.Tables.Clear()
            Dim sqlcmd As New SqlCommand
            sqlcmd.CommandText = Me.Select_Proc_Bottomtable
            sqlcmd.Parameters.Add("@iErrorCode", SqlDbType.Int, 4)
            sqlcmd.Parameters.Add("@Fokus", SqlDbType.Int, 4)
            sqlcmd.Parameters.Add("@KeyValue", SqlDbType.VarChar, 255)
            sqlcmd.Parameters.Add("@mitarbeiternr", SqlDbType.VarChar, 255)
            sqlcmd.Parameters(0).Value = 0
            sqlcmd.Parameters(1).Value = 0
            sqlcmd.Parameters(2).Value = KeyValue
            sqlcmd.Parameters(3).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value

            sqlcmd.CommandType = CommandType.StoredProcedure
            sqlcmd.Connection = connection
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.SelectCommand = sqlcmd
                da.Fill(Tabledata, "Domaintable")
            Catch ex As Exception
            Finally
                connection.Close()
                da.Dispose()
                sqlcmd.Dispose()
            End Try
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


DomainTable.Save_Data Method

DomainTable.Save_Data Method

Datesichern. Dabei wird das Update- sowie das Insert-Statement dynamisch generiert

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Save_Data()
C#
public System.Void Save_Data();
C++

public:
System::Void Save_Data()
JScript
public function Save_Data();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub Save_Data()
            Load_BaseData()
            Generate_Update_Statement()
            Generate_Insert_Statement()
            Try
                da.Update(Me.Tabledata, Me.Tabledata.Tables(0).TableName)
            Catch ex As Exception
                MsgBox(ex.Message)
            End Try
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


DomainTable.dispose Method

DomainTable.dispose Method

Dispose von Tabledata

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub dispose()
C#
public System.Void dispose();
C++

public:
System::Void dispose()
JScript
public function dispose();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub dispose()
            Me.Tabledata.Dispose()
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


clsServiceKatalogDaten Class

clsServiceKatalogDaten Class
See Also Members
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.SLA
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsServiceKatalogDaten
    Inherits clsServiceKatalog
C#
public class clsServiceKatalogDaten : clsServiceKatalog
C++

public ref class clsServiceKatalogDaten : public clsServiceKatalog^
JScript
public class clsServiceKatalogDaten
   extends clsServiceKatalog

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog
Vertragsverwaltung.TKB.VV.SLA.clsServiceKatalogDaten

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalogDaten Members
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogDaten Members

clsServiceKatalogDaten Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

The following tables list the members exposed by the clsServiceKatalogDaten type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsServiceKatalogDaten Constructor | Purpose: Class constructor. (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | bExtern | (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | iMutierer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | iParentID | (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | iServiceKatalogNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | sBemerkung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | sBezeichnung_extern | (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | sBezeichnung_intern | (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Get_Data |
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | Insert_Katalogelement |
Supported by the .NET Compact Framework. | Insert_Katalogelementsik | Neuer Service-Katalog-Eintrag einfügen
Supported by the .NET Compact Framework. | Save_Data |
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table. (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsServiceKatalogDaten Class
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogDaten Properties

clsServiceKatalogDaten Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | bExtern | (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | iMutierer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | iParentID | (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | iServiceKatalogNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | sBemerkung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | sBezeichnung_extern | (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | sBezeichnung_intern | (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsServiceKatalogDaten Class
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogDaten Methods

clsServiceKatalogDaten Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Get_Data |
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | Insert_Katalogelement |
Supported by the .NET Compact Framework. | Insert_Katalogelementsik | Neuer Service-Katalog-Eintrag einfügen
Supported by the .NET Compact Framework. | Save_Data |
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table. (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog).
Top

Expand image See Also

Reference

clsServiceKatalogDaten Class
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogDaten.Get_Data Method

clsServiceKatalogDaten.Get_Data Method

Namespace: Vertragsverwaltung.TKB.VV.SLA
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Get_Data( _
   ByVal Servicekatalognr As Integer _
) As Object
C#
public object Get_Data(
   int Servicekatalognr
);
C++

public:
object^ Get_Data(
   int Servicekatalognr
)
JScript
public function Get_Data(
    Servicekatalognr : int
) : object;

Parameters

Servicekatalognr

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Get_Data(ByVal Servicekatalognr As Integer)
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            Me.iServiceKatalogNr = New SqlInt32(CType(Servicekatalognr, Int32))
            Me.SelectOne()
            Globals.conn.CloseConnection(True)
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalogDaten Class
clsServiceKatalogDaten Members
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogDaten.Insert_Katalogelement Method

clsServiceKatalogDaten.Insert_Katalogelement Method

Namespace: Vertragsverwaltung.TKB.VV.SLA
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Insert_Katalogelement( _
   ByVal Katalogname As String, _
   ByVal parentid As String _
) As Object
C#
public object Insert_Katalogelement(
   string Katalogname,
   string parentid
);
C++

public:
object^ Insert_Katalogelement(
   String^ Katalogname,
   String^ parentid
)
JScript
public function Insert_Katalogelement(
    Katalogname : String,
    parentid : String
) : object;

Parameters

Katalogname

parentid

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Insert_Katalogelement(ByVal Katalogname As String, ByVal parentid As String)
            Dim dbkey As New TKB.VV.DB.clsMyKey_Tabelle
            dbkey.cpMainConnectionProvider = Globals.conn
            Dim newkey = dbkey.get_dbkey("Servicekatalog")

            Me.iServiceKatalogNr = New SqlInt32(CType(newkey, Int32))
            Me.iMandantnr = New SqlInt32(CType(Globals.clsmitarbeiter.iMandantnr.Value, Int32))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.bExtern = New SqlBoolean(CType(False, Boolean))
            Me.sBemerkung = New SqlString(CType("", String))
            Me.sBezeichnung_intern = New SqlString(CType(Katalogname, String))
            Me.sBezeichnung_extern = New SqlString(CType(Katalogname, String))
            Me.iParentID = New SqlInt32(CType(parentid, Int32))
            Me.iSecurityLevelNr = New SqlInt32(CType(0, Int32))
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalogDaten Class
clsServiceKatalogDaten Members
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogDaten.Insert_Katalogelementsik Method

clsServiceKatalogDaten.Insert_Katalogelementsik Method

Neuer Service-Katalog-Eintrag einfügen

Namespace: Vertragsverwaltung.TKB.VV.SLA
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Insert_Katalogelementsik( _
   ByVal Katalogname As String, _
   ByVal parentid As String _
) As Integer
C#
public int Insert_Katalogelementsik(
   string Katalogname,
   string parentid
);
C++

public:
int Insert_Katalogelementsik(
   String^ Katalogname,
   String^ parentid
)
JScript
public function Insert_Katalogelementsik(
    Katalogname : String,
    parentid : String
) : int;

Parameters

Katalogname

parentid

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Insert_Katalogelementsik(ByVal Katalogname As String, ByVal parentid As String) As Integer
            Dim katalogdaten As New TKB.VV.DB.clsServiceKatalog
            Dim dbkey As New TKB.VV.DB.clsMyKey_Tabelle
            dbkey.cpMainConnectionProvider = Globals.conn
            Dim newkey = dbkey.get_dbkey("Servicekatalog")
            katalogdaten.iServiceKatalogNr = New SqlInt32(CType(newkey, Int32))
            katalogdaten.iMandantnr = New SqlInt32(CType(Globals.clsmitarbeiter.iMandantnr.Value, Int32))
            katalogdaten.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            katalogdaten.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            katalogdaten.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            katalogdaten.bAktiv = New SqlBoolean(CType(True, Boolean))
            katalogdaten.bExtern = New SqlBoolean(CType(False, Boolean))
            katalogdaten.sBemerkung = New SqlString(CType("", String))
            katalogdaten.sBezeichnung_intern = New SqlString(CType(Katalogname, String))
            katalogdaten.sBezeichnung_extern = New SqlString(CType(Katalogname, String))
            katalogdaten.iParentID = New SqlInt32(CType(parentid, Int32))
            katalogdaten.iSecurityLevelNr = New SqlInt32(CType(0, Int32))
            katalogdaten.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            katalogdaten.Insert()
            Globals.conn.CloseConnection(True)
            Return newkey
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalogDaten Class
clsServiceKatalogDaten Members
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogDaten.Save_Data Method

clsServiceKatalogDaten.Save_Data Method

Namespace: Vertragsverwaltung.TKB.VV.SLA
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Save_Data() As Object
C#
public object Save_Data();
C++

public:
object^ Save_Data()
JScript
public function Save_Data() : object;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Save_Data()
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalogDaten Class
clsServiceKatalogDaten Members
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogDaten Fields

clsServiceKatalogDaten Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsServiceKatalogDaten Class
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogSLATree Class

clsServiceKatalogSLATree Class
See Also Members
collapseAll image DropDown image

TreeDatenklasse für den Servicekatalog-Tree

Namespace: Vertragsverwaltung.TKB.VV.SLA
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsServiceKatalogSLATree
C#
public class clsServiceKatalogSLATree
C++

public ref class clsServiceKatalogSLATree
JScript
public class clsServiceKatalogSLATree

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.SLA.clsServiceKatalogSLATree

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalogSLATree Members
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogSLATree Members

clsServiceKatalogSLATree Members
See Also Methods
CollapseAll image DropDown image

TreeDatenklasse für den Servicekatalog-Tree

The following tables list the members exposed by the clsServiceKatalogSLATree type.

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Load_Tree | Laden der Treedaten und Tree aufbauen
Supported by the .NET Compact Framework. | Set_Images |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | LoadTreeView |
Supported by the .NET Compact Framework. | Load_Treedata | Treedaten ab Datenbank laden
Supported by the .NET Compact Framework. | RecurseNodes |
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | Treedata |
Top

Expand image See Also

Reference

clsServiceKatalogSLATree Class
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogSLATree Methods

clsServiceKatalogSLATree Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Load_Tree | Laden der Treedaten und Tree aufbauen
Supported by the .NET Compact Framework. | Set_Images |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | LoadTreeView |
Supported by the .NET Compact Framework. | Load_Treedata | Treedaten ab Datenbank laden
Supported by the .NET Compact Framework. | RecurseNodes |
Top

Expand image See Also

Reference

clsServiceKatalogSLATree Class
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogSLATree.LoadTreeView Method

clsServiceKatalogSLATree.LoadTreeView Method

Namespace: Vertragsverwaltung.TKB.VV.SLA
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function LoadTreeView( _
   ByVal ds As DataSet, _
   ByRef tree As TreeView _
) As Object
C#
private object LoadTreeView(
   DataSet ds,
   ref TreeView tree
);
C++

private:
object^ LoadTreeView(
   DataSet^ ds,
   TreeView^& tree
)
JScript
private function LoadTreeView(
    ds : DataSet,
    tree : TreeView
) : object;

Parameters

ds

tree

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Function LoadTreeView(ByVal ds As DataSet, ByRef tree As TreeView)
            Dim sroot As String = ""
            Dim tchild As New TreeNode
            Dim tchild1 As New TreeNode
            Dim i As Integer
            For i = 0 To ds.Tables(0).Rows.Count - 1
                If sroot <> ds.Tables(0).Rows(i).Item(1) Then
                    tchild = tree.Nodes.Add(ds.Tables(0).Rows(i).Item(1))
                    tchild.Tag = 0
                    sroot = ds.Tables(0).Rows(i).Item(1)
                End If
                tchild1 = tchild.Nodes.Add(ds.Tables(0).Rows(i).Item(2))
                tchild1.Tag = ds.Tables(0).Rows(i).Item(0)
            Next
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalogSLATree Class
clsServiceKatalogSLATree Members
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogSLATree.Load_Tree Method

clsServiceKatalogSLATree.Load_Tree Method

Laden der Treedaten und Tree aufbauen

Namespace: Vertragsverwaltung.TKB.VV.SLA
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Load_Tree( _
   ByRef tree As TreeView _
) As Object
C#
public object Load_Tree(
   ref TreeView tree
);
C++

public:
object^ Load_Tree(
   TreeView^& tree
)
JScript
public function Load_Tree(
    tree : TreeView
) : object;

Parameters

tree

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Load_Tree(ByRef tree As TreeView)
            Load_Treedata()
            tree.Nodes.Clear()
            LoadTreeView(Treedata, tree)
            tree.ExpandAll()
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalogSLATree Class
clsServiceKatalogSLATree Members
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogSLATree.Load_Treedata Method

clsServiceKatalogSLATree.Load_Treedata Method

Treedaten ab Datenbank laden

Namespace: Vertragsverwaltung.TKB.VV.SLA
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Load_Treedata() As DataTable
C#
private DataTable Load_Treedata();
C++

private:
DataTable^ Load_Treedata()
JScript
private function Load_Treedata() : DataTable;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Function Load_Treedata() As DataTable
            Dim selectcommand As New SqlCommand
            Dim connection As New SqlConnection()
            Dim da As New SqlDataAdapter("", connection)

            selectcommand.CommandText = "my_servicekatalog_sla_struktur"
            selectcommand.Parameters.Add("@Mitarbeiternr", SqlDbType.Int, 4)
            selectcommand.Parameters(0).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value

            selectcommand.CommandType = CommandType.StoredProcedure
            selectcommand.Connection = connection
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.SelectCommand = selectcommand
                da.Fill(Treedata, "Tree")
            Catch ex As Exception
            Finally
                connection.Close()
                da.Dispose()
                selectcommand.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalogSLATree Class
clsServiceKatalogSLATree Members
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogSLATree.RecurseNodes Method

clsServiceKatalogSLATree.RecurseNodes Method

Namespace: Vertragsverwaltung.TKB.VV.SLA
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function RecurseNodes( _
   ByVal Node As TreeNodeCollection _
) As Object
C#
private object RecurseNodes(
   TreeNodeCollection Node
);
C++

private:
object^ RecurseNodes(
   TreeNodeCollection^ Node
)
JScript
private function RecurseNodes(
    Node : TreeNodeCollection
) : object;

Parameters

Node

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Function RecurseNodes(ByVal Node As TreeNodeCollection)
            For Each tn As TreeNode In Node
                If tn.Nodes.Count > 0 Then
                    tn.ImageIndex = 1
                    tn.SelectedImageIndex = 2
                Else
                    tn.ImageIndex = 3
                End If
                RecurseNodes(tn.Nodes)
            Next
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalogSLATree Class
clsServiceKatalogSLATree Members
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogSLATree.Set_Images Method

clsServiceKatalogSLATree.Set_Images Method

Namespace: Vertragsverwaltung.TKB.VV.SLA
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Set_Images( _
   ByRef tree As TreeView _
) As Object
C#
public object Set_Images(
   ref TreeView tree
);
C++

public:
object^ Set_Images(
   TreeView^& tree
)
JScript
public function Set_Images(
    tree : TreeView
) : object;

Parameters

tree

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Set_Images(ByRef tree As TreeView)
            Dim tn As TreeNode
            For Each tn In tree.Nodes
                If tn.Nodes.Count > 0 Then
                    tn.ImageIndex = 1
                    tn.SelectedImageIndex = 2
                Else
                    tn.ImageIndex = 3
                End If
                RecurseNodes(tn.Nodes)
            Next
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalogSLATree Class
clsServiceKatalogSLATree Members
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogSLATree Fields

clsServiceKatalogSLATree Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | Treedata |
Top

Expand image See Also

Reference

clsServiceKatalogSLATree Class
Vertragsverwaltung.TKB.VV.SLA Namespace


Treedata Variable

Treedata Variable

Namespace: Vertragsverwaltung.TKB.VV.SLA
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Treedata As DataSet
C#
private DataSet Treedata;
C++
private:
DataSet^ Treedata;
JScript
private Treedata : DataSet

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim Treedata As New DataSet

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalogSLATree Class
clsServiceKatalogSLATree Members
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogTree Class

clsServiceKatalogTree Class
See Also Members
collapseAll image DropDown image

TreeDatenklasse für den Servicekatalog-Tree

Namespace: Vertragsverwaltung.TKB.VV.SLA
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsServiceKatalogTree
C#
public class clsServiceKatalogTree
C++

public ref class clsServiceKatalogTree
JScript
public class clsServiceKatalogTree

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.SLA.clsServiceKatalogTree

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalogTree Members
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogTree Members

clsServiceKatalogTree Members
See Also Methods
CollapseAll image DropDown image

TreeDatenklasse für den Servicekatalog-Tree

The following tables list the members exposed by the clsServiceKatalogTree type.

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Load_Tree | Laden der Treedaten und Tree aufbauen
Supported by the .NET Compact Framework. | Set_Images | Images auf den Nodes des TreeVies setzen
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | LoadTreeView | Tree aufbauen
Supported by the .NET Compact Framework. | Load_Treedata | Treedaten ab Datenbank laden
Supported by the .NET Compact Framework. | Load_Treeview | Interne Relation aufbauen und Tree aufbauen
Supported by the .NET Compact Framework. | RecurseNodes | Nodes rekursiv lesen
Supported by the .NET Compact Framework. | RecursivelyLoadTree | Child-Nodes hinzufügen
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | Treedata |
Top

Expand image See Also

Reference

clsServiceKatalogTree Class
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogTree Methods

clsServiceKatalogTree Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Load_Tree | Laden der Treedaten und Tree aufbauen
Supported by the .NET Compact Framework. | Set_Images | Images auf den Nodes des TreeVies setzen
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | LoadTreeView | Tree aufbauen
Supported by the .NET Compact Framework. | Load_Treedata | Treedaten ab Datenbank laden
Supported by the .NET Compact Framework. | Load_Treeview | Interne Relation aufbauen und Tree aufbauen
Supported by the .NET Compact Framework. | RecurseNodes | Nodes rekursiv lesen
Supported by the .NET Compact Framework. | RecursivelyLoadTree | Child-Nodes hinzufügen
Top

Expand image See Also

Reference

clsServiceKatalogTree Class
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogTree.LoadTreeView Method

clsServiceKatalogTree.LoadTreeView Method

Tree aufbauen

Namespace: Vertragsverwaltung.TKB.VV.SLA
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub LoadTreeView( _
   ByVal oDS As DataSet, _
   ByRef oTreeview As TreeView _
)
C#
private System.Void LoadTreeView(
   DataSet oDS,
   ref TreeView oTreeview
);
C++

private:
System::Void LoadTreeView(
   DataSet^ oDS,
   TreeView^& oTreeview
)
JScript
private function LoadTreeView(
    oDS : DataSet,
    oTreeview : TreeView
);

Parameters

oDS

oTreeview

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Sub LoadTreeView(ByVal oDS As DataSet, ByRef oTreeview As TreeView)
            'Dim oTreeView As TreeView = New TreeView()
            Dim oDataRow As DataRow
            For Each oDataRow In oDS.Tables(0).Rows
                If Not oDataRow.IsNull("Parentid") Then
                    If oDataRow.Item("Parentid") = 0 Then
                        'If oDataRow.IsNull("Parentid") Then
                        Dim oNode As New TreeNode()
                        oNode.Text = oDataRow("Bezeichnung").ToString()
                        oNode.Tag = oDataRow("Servicekatalognr").ToString
                        oTreeview.Nodes.Add(oNode)
                        RecursivelyLoadTree(oDataRow, oNode)
                    End If
                End If
            Next oDataRow
            oDS.Dispose()
            oDS = Nothing
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalogTree Class
clsServiceKatalogTree Members
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogTree.Load_Tree Method

clsServiceKatalogTree.Load_Tree Method

Laden der Treedaten und Tree aufbauen

Namespace: Vertragsverwaltung.TKB.VV.SLA
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Load_Tree( _
   ByRef tree As TreeView _
) As Object
C#
public object Load_Tree(
   ref TreeView tree
);
C++

public:
object^ Load_Tree(
   TreeView^& tree
)
JScript
public function Load_Tree(
    tree : TreeView
) : object;

Parameters

tree

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Load_Tree(ByRef tree As TreeView)
            Load_Treedata()
            tree.Nodes.Clear()
            Load_Treeview(Treedata, tree)

            tree.ExpandAll()
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalogTree Class
clsServiceKatalogTree Members
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogTree.Load_Treedata Method

clsServiceKatalogTree.Load_Treedata Method

Treedaten ab Datenbank laden

Namespace: Vertragsverwaltung.TKB.VV.SLA
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Load_Treedata() As DataTable
C#
private DataTable Load_Treedata();
C++

private:
DataTable^ Load_Treedata()
JScript
private function Load_Treedata() : DataTable;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Function Load_Treedata() As DataTable
            Treedata.Tables.Clear()
            Dim selectcommand As New SqlCommand
            Dim connection As New SqlConnection()
            Dim da As New SqlDataAdapter("", connection)

            selectcommand.CommandText = "my_servicekatalog_struktur"
            selectcommand.Parameters.Add("@Mitarbeiternr", SqlDbType.Int, 4)
            selectcommand.Parameters(0).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value

            selectcommand.CommandType = CommandType.StoredProcedure
            selectcommand.Connection = connection
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.SelectCommand = selectcommand
                da.Fill(Treedata, "Tree")
            Catch ex As Exception
            Finally
                connection.Close()
                da.Dispose()
                selectcommand.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalogTree Class
clsServiceKatalogTree Members
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogTree.Load_Treeview Method

clsServiceKatalogTree.Load_Treeview Method

Interne Relation aufbauen und Tree aufbauen

Namespace: Vertragsverwaltung.TKB.VV.SLA
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Load_Treeview( _
   ByVal oSourceData As DataSet, _
   ByRef tree As TreeView _
)
C#
private System.Void Load_Treeview(
   DataSet oSourceData,
   ref TreeView tree
);
C++

private:
System::Void Load_Treeview(
   DataSet^ oSourceData,
   TreeView^& tree
)
JScript
private function Load_Treeview(
    oSourceData : DataSet,
    tree : TreeView
);

Parameters

oSourceData

tree

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Sub Load_Treeview(ByVal oSourceData As DataSet, ByRef tree As TreeView)
            If Not (oSourceData Is Nothing) Then
                Dim oView As DataView = oSourceData.Tables(0).DefaultView
                Dim oTable As DataTable = oView.Table
                Dim oDS As DataSet = New DataSet()
                oDS.Tables.Add(oTable.Copy())

                If oDS.Relations.Contains("SelfRefenceRelation") = False Then
                    oDS.Relations.Add("SelfRefenceRelation", _
                        oDS.Tables(0).Columns("Servicekatalognr"), _
                        oDS.Tables(0).Columns("Parentid"))
                End If
                oTable.Dispose()
                oTable = Nothing
                LoadTreeView(oDS, tree)
                oDS.Dispose()
                oDS = Nothing
            End If
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalogTree Class
clsServiceKatalogTree Members
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogTree.RecurseNodes Method

clsServiceKatalogTree.RecurseNodes Method

Nodes rekursiv lesen

Namespace: Vertragsverwaltung.TKB.VV.SLA
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function RecurseNodes( _
   ByVal Node As TreeNodeCollection _
) As Object
C#
private object RecurseNodes(
   TreeNodeCollection Node
);
C++

private:
object^ RecurseNodes(
   TreeNodeCollection^ Node
)
JScript
private function RecurseNodes(
    Node : TreeNodeCollection
) : object;

Parameters

Node

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Function RecurseNodes(ByVal Node As TreeNodeCollection)
            For Each tn As TreeNode In Node
                If tn.Nodes.Count > 0 Then
                    tn.ImageIndex = 0
                    tn.StateImageIndex = 0
                    tn.SelectedImageIndex = 0
                Else
                    tn.ImageIndex = 1
                    tn.StateImageIndex = 1
                    tn.SelectedImageIndex = 1
                End If
                RecurseNodes(tn.Nodes)
            Next
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalogTree Class
clsServiceKatalogTree Members
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogTree.RecursivelyLoadTree Method

clsServiceKatalogTree.RecursivelyLoadTree Method

Child-Nodes hinzufügen

Namespace: Vertragsverwaltung.TKB.VV.SLA
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub RecursivelyLoadTree( _
   ByVal oDataRow As DataRow, _
   ByRef oNode As TreeNode _
)
C#
private System.Void RecursivelyLoadTree(
   DataRow oDataRow,
   ref TreeNode oNode
);
C++

private:
System::Void RecursivelyLoadTree(
   DataRow^ oDataRow,
   TreeNode^& oNode
)
JScript
private function RecursivelyLoadTree(
    oDataRow : DataRow,
    oNode : TreeNode
);

Parameters

oDataRow

oNode

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Sub RecursivelyLoadTree(ByVal oDataRow As DataRow, ByRef oNode As TreeNode)
            Dim oChildRow As DataRow
            For Each oChildRow In oDataRow.GetChildRows("SelfRefenceRelation")
                Dim oChildNode As New TreeNode()
                oChildNode.Text = oChildRow("Bezeichnung").ToString()
                oChildNode.Tag = oChildRow("Servicekatalognr").ToString()
                oNode.Nodes.Add(oChildNode)
                RecursivelyLoadTree(oChildRow, oChildNode)
            Next oChildRow
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalogTree Class
clsServiceKatalogTree Members
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogTree.Set_Images Method

clsServiceKatalogTree.Set_Images Method

Images auf den Nodes des TreeVies setzen

Namespace: Vertragsverwaltung.TKB.VV.SLA
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Set_Images( _
   ByRef tree As TreeView _
) As Object
C#
public object Set_Images(
   ref TreeView tree
);
C++

public:
object^ Set_Images(
   TreeView^& tree
)
JScript
public function Set_Images(
    tree : TreeView
) : object;

Parameters

tree

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Set_Images(ByRef tree As TreeView)
            Dim tn As TreeNode
            For Each tn In tree.Nodes
                If tn.Nodes.Count > 0 Then
                    tn.ImageIndex = 0
                    tn.StateImageIndex = 0
                    tn.SelectedImageIndex = 0
                Else
                    tn.ImageIndex = 1
                    tn.StateImageIndex = 1
                    tn.SelectedImageIndex = 1
                End If
                RecurseNodes(tn.Nodes)
            Next
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalogTree Class
clsServiceKatalogTree Members
Vertragsverwaltung.TKB.VV.SLA Namespace


clsServiceKatalogTree Fields

clsServiceKatalogTree Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | Treedata |
Top

Expand image See Also

Reference

clsServiceKatalogTree Class
Vertragsverwaltung.TKB.VV.SLA Namespace


Treedata Variable

Treedata Variable

Namespace: Vertragsverwaltung.TKB.VV.SLA
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Treedata As DataSet
C#
private DataSet Treedata;
C++
private:
DataSet^ Treedata;
JScript
private Treedata : DataSet

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim Treedata As New DataSet

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsServiceKatalogTree Class
clsServiceKatalogTree Members
Vertragsverwaltung.TKB.VV.SLA Namespace


Vertragsverwaltung.TKB.VV.Sysadmin Namespace

Vertragsverwaltung.TKB.VV.Sysadmin Namespace

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Classes

 | Name | Description
Supported by the .NET Compact Framework. | DomainTable |
Supported by the .NET Compact Framework. | clsMySysadminfunkion |
Top

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0


DomainTable Class

DomainTable Class
See Also Members
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class DomainTable
C#
public class DomainTable
C++

public ref class DomainTable
JScript
public class DomainTable

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable
Vertragsverwaltung.TKB.VV.SLA.clsSLAKatalogdaten

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


DomainTable Members

DomainTable Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

The following tables list the members exposed by the DomainTable type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | DomainTable Constructor | (Overloaded) Tabellenname übernehmen und Daten ab DB laden
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Insert_Proc |
Supported by the .NET Compact Framework. | Insert_Proc_Bottomtable |
Supported by the .NET Compact Framework. | Select_Proc |
Supported by the .NET Compact Framework. | Select_Proc_Bottomtable |
Supported by the .NET Compact Framework. | Tabledata |
Supported by the .NET Compact Framework. | Tablename |
Supported by the .NET Compact Framework. | Update_Proc |
Supported by the .NET Compact Framework. | Update_Proc_Bottomtable |
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Insert_Bottom_Table | Neuer Eintrag in der Tabelle eintragen. Sind neben den Defaultwerten weitere Attribute vorhanden, werde diese abhängig vom Datentype mit Defaultwerten befüllt.
Supported by the .NET Compact Framework. | Load_Bootom_Table | Load der Verbindungstabelle
Supported by the .NET Compact Framework. | Load_Data | Daten ab Datenbank laden
Supported by the .NET Compact Framework. | Load_Data_MA |
Supported by the .NET Compact Framework. | Save_Data | Datesichern. Dabei wird das Update- sowie das Insert-Statement dynamisch generiert
Supported by the .NET Compact Framework. | dispose | Dispose von Tabledata
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | Generate_Insert_Statement | Insert-Statement dynamisch für das InsertCommand generieren
Supported by the .NET Compact Framework. | Generate_Update_Statement | Update-Statement dynamisch für das UpdateCommand generieren
Supported by the .NET Compact Framework. | Get_Data_Fieldlen | Feldlänge für den SP-Übergabeparemter festlegen
Supported by the .NET Compact Framework. | Get_Prefix | Prefixt für den SP-Übergabeparameter generieren
Supported by the .NET Compact Framework. | Get_SqlDBType | SQL-DB-Type für den SP-Übergabeparameter festlegen
Supported by the .NET Compact Framework. | Load_BaseData | Basis-Datentabelle laden. Diese wird für die dynamische Generierung der Insert- und Update-Statements benötigt
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | BaseData |
Supported by the .NET Compact Framework. | InsertCommand |
Supported by the .NET Compact Framework. | UpdateCommand |
Supported by the .NET Compact Framework. | connection |
Supported by the .NET Compact Framework. | da |
Supported by the .NET Compact Framework. | m_Tabledata |
Supported by the .NET Compact Framework. | m_selectproc |
Supported by the .NET Compact Framework. | m_tablename |
Supported by the .NET Compact Framework. | selectcommand |
Top

Expand image See Also

Reference

DomainTable Class
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


DomainTable Constructor (System.String, System.Int32, System.String)

DomainTable Constructor (System.String, System.Int32, System.String)
See Also
collapseAll image DropDown image

Tabellenname übernehmen und Daten ab DB laden

Expand image Overload List

Name | Description
public System.Void DomainTable(string, string, int); |
public System.Void DomainTable(string, int, string); | Tabellenname übernehmen und Daten ab DB laden

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


DomainTable Properties

DomainTable Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Insert_Proc |
Supported by the .NET Compact Framework. | Insert_Proc_Bottomtable |
Supported by the .NET Compact Framework. | Select_Proc |
Supported by the .NET Compact Framework. | Select_Proc_Bottomtable |
Supported by the .NET Compact Framework. | Tabledata |
Supported by the .NET Compact Framework. | Tablename |
Supported by the .NET Compact Framework. | Update_Proc |
Supported by the .NET Compact Framework. | Update_Proc_Bottomtable |
Top

Expand image See Also

Reference

DomainTable Class
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


DomainTable Methods

DomainTable Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Insert_Bottom_Table | Neuer Eintrag in der Tabelle eintragen. Sind neben den Defaultwerten weitere Attribute vorhanden, werde diese abhängig vom Datentype mit Defaultwerten befüllt.
Supported by the .NET Compact Framework. | Load_Bootom_Table | Load der Verbindungstabelle
Supported by the .NET Compact Framework. | Load_Data | Daten ab Datenbank laden
Supported by the .NET Compact Framework. | Load_Data_MA |
Supported by the .NET Compact Framework. | Save_Data | Datesichern. Dabei wird das Update- sowie das Insert-Statement dynamisch generiert
Supported by the .NET Compact Framework. | dispose | Dispose von Tabledata
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | Generate_Insert_Statement | Insert-Statement dynamisch für das InsertCommand generieren
Supported by the .NET Compact Framework. | Generate_Update_Statement | Update-Statement dynamisch für das UpdateCommand generieren
Supported by the .NET Compact Framework. | Get_Data_Fieldlen | Feldlänge für den SP-Übergabeparemter festlegen
Supported by the .NET Compact Framework. | Get_Prefix | Prefixt für den SP-Übergabeparameter generieren
Supported by the .NET Compact Framework. | Get_SqlDBType | SQL-DB-Type für den SP-Übergabeparameter festlegen
Supported by the .NET Compact Framework. | Load_BaseData | Basis-Datentabelle laden. Diese wird für die dynamische Generierung der Insert- und Update-Statements benötigt
Top

Expand image See Also

Reference

DomainTable Class
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


DomainTable.Generate_Insert_Statement Method

DomainTable.Generate_Insert_Statement Method

Insert-Statement dynamisch für das InsertCommand generieren

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Generate_Insert_Statement()
C#
private System.Void Generate_Insert_Statement();
C++

private:
System::Void Generate_Insert_Statement()
JScript
private function Generate_Insert_Statement();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Sub Generate_Insert_Statement()
            Dim col As DataColumn
            Dim col1 As DataColumn
            Dim UseCol As Boolean = False

            InsertCommand.CommandText = Me.Insert_Proc
            InsertCommand.CommandType = System.Data.CommandType.StoredProcedure
            InsertCommand.Connection = connection

            InsertCommand.Parameters.Clear()
            For Each col In Me.Tabledata.Tables(0).Columns
                UseCol = False
                For Each col1 In Me.BaseData.Tables(0).Columns
                    If col.ColumnName = col1.ColumnName Then
                        UseCol = True
                        Exit For
                    End If
                Next
                If UseCol Then InsertCommand.Parameters.Add(New System.Data.SqlClient.SqlParameter(Get_Prefix(col) & col.ColumnName, Get_SqlDBType(col), Get_Data_Fieldlen(col), col.ColumnName))
            Next
            InsertCommand.Parameters.Add(New System.Data.SqlClient.SqlParameter("@iErrorcode", SqlDbType.Int, 4))
            InsertCommand.Parameters("@iErrorcode").Value = 0
            da.InsertCommand = InsertCommand
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


DomainTable.Generate_Update_Statement Method

DomainTable.Generate_Update_Statement Method

Update-Statement dynamisch für das UpdateCommand generieren

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Generate_Update_Statement()
C#
private System.Void Generate_Update_Statement();
C++

private:
System::Void Generate_Update_Statement()
JScript
private function Generate_Update_Statement();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Sub Generate_Update_Statement()
            Dim col As DataColumn
            Dim col1 As DataColumn
            Dim UseCol As Boolean = False

            UpdateCommand.CommandText = Me.Update_Proc
            UpdateCommand.CommandType = System.Data.CommandType.StoredProcedure
            UpdateCommand.Connection = connection

            UpdateCommand.Parameters.Clear()
            For Each col In Me.Tabledata.Tables(0).Columns
                UseCol = False
                For Each col1 In Me.BaseData.Tables(0).Columns
                    If col.ColumnName = col1.ColumnName Then
                        UseCol = True
                        Exit For
                    End If
                Next
                If UseCol Then UpdateCommand.Parameters.Add(New System.Data.SqlClient.SqlParameter(Get_Prefix(col) & col.ColumnName, Get_SqlDBType(col), Get_Data_Fieldlen(col), col.ColumnName))
            Next
            UpdateCommand.Parameters.Add(New System.Data.SqlClient.SqlParameter("@iErrorcode", SqlDbType.Int, 4))
            UpdateCommand.Parameters("@iErrorcode").Value = 0
            da.UpdateCommand = UpdateCommand
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


DomainTable.Get_Data_Fieldlen Method

DomainTable.Get_Data_Fieldlen Method

Feldlänge für den SP-Übergabeparemter festlegen

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Get_Data_Fieldlen( _
   ByVal col As DataColumn _
) As Integer
C#
private int Get_Data_Fieldlen(
   DataColumn col
);
C++

private:
int Get_Data_Fieldlen(
   DataColumn^ col
)
JScript
private function Get_Data_Fieldlen(
    col : DataColumn
) : int;

Parameters

col

Aktulle Column

Return Value

Feldlänge

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Function Get_Data_Fieldlen(ByVal col As DataColumn) As Integer
            Return col.MaxLength
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


DomainTable.Get_Prefix Method

DomainTable.Get_Prefix Method

Prefixt für den SP-Übergabeparameter generieren

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Get_Prefix( _
   ByVal col As DataColumn _
) As String
C#
private string Get_Prefix(
   DataColumn col
);
C++

private:
String^ Get_Prefix(
   DataColumn^ col
)
JScript
private function Get_Prefix(
    col : DataColumn
) : String;

Parameters

col

Aktuelle Columnt

Return Value

Prefis für SP-Übergabeparameter

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Function Get_Prefix(ByVal col As DataColumn) As String
            If col.DataType.Name = "DateTime" Then Return "@da"
            If col.DataType.Name = "Double" Then Return "@f"
            Return "@" & col.DataType.Name.Substring(0, 1)
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


DomainTable.Get_SqlDBType Method

DomainTable.Get_SqlDBType Method

SQL-DB-Type für den SP-Übergabeparameter festlegen

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Get_SqlDBType( _
   ByVal col As DataColumn _
) As SqlDbType
C#
private SqlDbType Get_SqlDBType(
   DataColumn col
);
C++

private:
SqlDbType Get_SqlDBType(
   DataColumn^ col
)
JScript
private function Get_SqlDBType(
    col : DataColumn
) : SqlDbType;

Parameters

col

Aktuelle Column

Return Value

SQLDBType

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Function Get_SqlDBType(ByVal col As DataColumn) As SqlDbType
            If col.DataType.Name = "Integer" Then Return SqlDbType.Int
            If col.DataType.Name = "Int32" Then Return SqlDbType.Int
            If col.DataType.Name = "String" Then Return SqlDbType.VarChar
            If col.DataType.Name = "Boolean" Then Return SqlDbType.Bit
            If col.DataType.Name = "DateTime" Then Return SqlDbType.DateTime
            If col.DataType.Name = "Double" Then Return SqlDbType.Float
            MsgBox(col.DataType.Name)
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


DomainTable.Load_BaseData Method

DomainTable.Load_BaseData Method

Basis-Datentabelle laden. Diese wird für die dynamische Generierung der Insert- und Update-Statements benötigt

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Load_BaseData()
C#
private System.Void Load_BaseData();
C++

private:
System::Void Load_BaseData()
JScript
private function Load_BaseData();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Sub Load_BaseData()
            BaseData.Tables.Clear()
            Dim sqlcmd As New SqlCommand

            sqlcmd.CommandText = Me.Select_Proc
            sqlcmd.Parameters.Add("@iErrorCode", SqlDbType.Int, 4)
            sqlcmd.Parameters(0).Value = 0

            sqlcmd.CommandType = CommandType.StoredProcedure
            sqlcmd.Connection = connection
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.SelectCommand = sqlcmd
                da.Fill(BaseData, "Basedata")
            Catch ex As Exception
            Finally
                connection.Close()
                da.Dispose()
                sqlcmd.Dispose()
            End Try
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


DomainTable.Load_Data Method

DomainTable.Load_Data Method

Daten ab Datenbank laden

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overridable Sub Load_Data()
C#
public virtual System.Void Load_Data();
C++

public:
System::Void Load_Data() virtual
JScript
public function Load_Data();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Overridable Sub Load_Data()
            Tabledata.Tables.Clear()

            selectcommand.CommandText = Me.Select_Proc
            selectcommand.Parameters.Add("@iErrorCode", SqlDbType.Int, 4)
            selectcommand.Parameters(0).Value = 0

            selectcommand.CommandType = CommandType.StoredProcedure
            selectcommand.Connection = connection
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.SelectCommand = selectcommand
                da.Fill(Tabledata, "Domaintable")
            Catch ex As Exception
            Finally
                connection.Close()
                da.Dispose()
                selectcommand.Dispose()
            End Try
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


DomainTable Fields

DomainTable Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | BaseData |
Supported by the .NET Compact Framework. | InsertCommand |
Supported by the .NET Compact Framework. | UpdateCommand |
Supported by the .NET Compact Framework. | connection |
Supported by the .NET Compact Framework. | da |
Supported by the .NET Compact Framework. | m_Tabledata |
Supported by the .NET Compact Framework. | m_selectproc |
Supported by the .NET Compact Framework. | m_tablename |
Supported by the .NET Compact Framework. | selectcommand |
Top

Expand image See Also

Reference

DomainTable Class
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


BaseData Variable

BaseData Variable

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private BaseData As DataSet
C#
private DataSet BaseData;
C++
private:
DataSet^ BaseData;
JScript
private BaseData : DataSet

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim BaseData As New DataSet

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


InsertCommand Variable

InsertCommand Variable

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private InsertCommand As SqlCommand
C#
private SqlCommand InsertCommand;
C++
private:
SqlCommand^ InsertCommand;
JScript
private InsertCommand : SqlCommand

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim InsertCommand As New SqlCommand

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


UpdateCommand Variable

UpdateCommand Variable

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private UpdateCommand As SqlCommand
C#
private SqlCommand UpdateCommand;
C++
private:
SqlCommand^ UpdateCommand;
JScript
private UpdateCommand : SqlCommand

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim UpdateCommand As New SqlCommand

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


connection Variable

connection Variable

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private connection As SqlConnection
C#
private SqlConnection connection;
C++
private:
SqlConnection^ connection;
JScript
private connection : SqlConnection

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim connection As New SqlConnection()

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


da Variable

da Variable

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private da As SqlDataAdapter
C#
private SqlDataAdapter da;
C++
private:
SqlDataAdapter^ da;
JScript
private da : SqlDataAdapter

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim da As New SqlDataAdapter("", connection)

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


m_Tabledata Variable

m_Tabledata Variable

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_Tabledata As DataSet
C#
private DataSet m_Tabledata;
C++
private:
DataSet^ m_Tabledata;
JScript
private m_Tabledata : DataSet

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim m_Tabledata As New DataSet

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


m_selectproc Variable

m_selectproc Variable

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_selectproc As String
C#
private string m_selectproc;
C++
private:
String^ m_selectproc;
JScript
private m_selectproc : String

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim m_selectproc As String

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


m_tablename Variable

m_tablename Variable

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_tablename As String
C#
private string m_tablename;
C++
private:
String^ m_tablename;
JScript
private m_tablename : String

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim m_tablename As String

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


selectcommand Variable

selectcommand Variable

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private selectcommand As SqlCommand
C#
private SqlCommand selectcommand;
C++
private:
SqlCommand^ selectcommand;
JScript
private selectcommand : SqlCommand

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim selectcommand As New SqlCommand

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


clsMySysadminfunkion Class

clsMySysadminfunkion Class
See Also Members
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsMySysadminfunkion
    Inherits clsSysadminfunktion
C#
public class clsMySysadminfunkion : clsSysadminfunktion
C++

public ref class clsMySysadminfunkion : public clsSysadminfunktion^
JScript
public class clsMySysadminfunkion
   extends clsSysadminfunktion

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion
Vertragsverwaltung.TKB.VV.Sysadmin.clsMySysadminfunkion

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMySysadminfunkion Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


clsMySysadminfunkion Members

clsMySysadminfunkion Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

The following tables list the members exposed by the clsMySysadminfunkion type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsMySysadminfunkion Constructor | Purpose: Class constructor. (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iFheight | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | iFleft | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | iFtop | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | iFwidth | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | iImageIndex | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | iImageIndexOpen | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | iMandantnr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | iMutierer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | iParentID | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSort | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | iSprache | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | iSysadminfnktnr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | sBeschreibung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | sBezeichnung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sDomaintable | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | sKeyFields | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | LoadTreeMenu |
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table. (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | SelectHierarchy |
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsMySysadminfunkion Class
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


clsMySysadminfunkion Properties

clsMySysadminfunkion Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iFheight | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | iFleft | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | iFtop | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | iFwidth | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | iImageIndex | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | iImageIndexOpen | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | iMandantnr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | iMutierer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | iParentID | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSort | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | iSprache | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | iSysadminfnktnr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | sBeschreibung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | sBezeichnung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sDomaintable | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | sKeyFields | (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Top

Expand image See Also

Reference

clsMySysadminfunkion Class
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


clsMySysadminfunkion Methods

clsMySysadminfunkion Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | LoadTreeMenu |
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table. (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | SelectHierarchy |
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion).
Top

Expand image See Also

Reference

clsMySysadminfunkion Class
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


clsMySysadminfunkion.LoadTreeMenu Method

clsMySysadminfunkion.LoadTreeMenu Method

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub LoadTreeMenu( _
   ByVal otv As TreeView _
)
C#
public System.Void LoadTreeMenu(
   TreeView otv
);
C++

public:
System::Void LoadTreeMenu(
   TreeView^ otv
)
JScript
public function LoadTreeMenu(
    otv : TreeView
);

Parameters

otv

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub LoadTreeMenu(ByVal otv As TreeView)
            Dim menueintraege As New clsMySysadminfunkion()
            Dim menudata As DataTable
            Dim i As Integer
            Dim m_collDeletedNodes As Collection
            Dim collNodeKeys As New Collection()
            Dim tnNew As TreeNode
            Dim tnParent As TreeNode

            m_collDeletedNodes = Nothing
            m_collDeletedNodes = New Collection()

            menueintraege.cpMainConnectionProvider = conn
            menudata = menueintraege.SelectHierarchy

            For i = 0 To menudata.Rows.Count - 1
                If menudata.Rows(i).Item("ParentID") = 0 Then
                    tnNew = otv.Nodes.Add(menudata.Rows(i).Item("bezeichnung"))
                    With tnNew
                        .Tag() = menudata.Rows(i).Item("sysadminfnktnr")
                        .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                        .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen")
                    End With
                    Try
                        collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("sysadminfnktnr"), String))
                    Catch ex As Exception
                        MsgBox(ex.Message, MsgBoxStyle.Critical)
                    End Try
                Else
                    Try
                        tnParent = CType(collNodeKeys.Item(CType(menudata.Rows(i).Item("ParentID"), String)), TreeNode)
                        tnNew = tnParent.Nodes.Add(CType(menudata.Rows(i).Item("bezeichnung"), String))
                        With tnNew
                            .Tag() = CType(menudata.Rows(i).Item("sysadminfnktnr"), String)
                            .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                            .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen")
                        End With
                        collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("sysadminfnktnr"), String))
                    Catch ex As Exception
                        MsgBox(ex.Message, MsgBoxStyle.Critical)
                    End Try
                End If
            Next
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMySysadminfunkion Class
clsMySysadminfunkion Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


clsMySysadminfunkion.SelectHierarchy Method

clsMySysadminfunkion.SelectHierarchy Method

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function SelectHierarchy() As DataTable
C#
public DataTable SelectHierarchy();
C++

public:
DataTable^ SelectHierarchy()
JScript
public function SelectHierarchy() : DataTable;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function SelectHierarchy() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            'scmCmdToExecute.CommandText = "dbo.[sp_sysadminfunktion_hierarchie]"
            scmCmdToExecute.CommandText = "dbo.[sp_get_sysadmin_tree]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("sysadminfunktion")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iroot", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iSprache.Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMandantnr.Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(TKB.VV.DB.LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSysadminfunktion::SelectAll::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsMySysadminfunkion Class
clsMySysadminfunkion Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


clsMySysadminfunkion Fields

clsMySysadminfunkion Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsMySysadminfunkion Class
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


Vertragsverwaltung.TKB.VV.Utils Namespace

Vertragsverwaltung.TKB.VV.Utils Namespace

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Classes

 | Name | Description
Supported by the .NET Compact Framework. | MyDocMgmt |
Supported by the .NET Compact Framework. | MyFormControls | Klasse für ein Control-Objekt
Supported by the .NET Compact Framework. | MyMessage | Standard-Messages in div. Formatenm
Supported by the .NET Compact Framework. | MySecurity | Formular-Security-Objekte auslesen und auf DB schreiben bzw. Formular-Security zur Laufzeit setzen
Supported by the .NET Compact Framework. | MySpaltenTitel |
Supported by the .NET Compact Framework. | Tabellenspalte |
Top

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0


MyDocMgmt Class

MyDocMgmt Class
See Also Members
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class MyDocMgmt
C#
public class MyDocMgmt
C++

public ref class MyDocMgmt
JScript
public class MyDocMgmt

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.Utils.MyDocMgmt

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyDocMgmt Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MyDocMgmt Members

MyDocMgmt Members
See Also Methods
CollapseAll image DropDown image

The following tables list the members exposed by the MyDocMgmt type.

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Get_Layout |
Supported by the .NET Compact Framework. | Save_Document | Dokument in der Tabelle Dokument speichern
Supported by the .NET Compact Framework. | Save_LayoutFile | Grid-Layoutfile speichern
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | Get_Dokument |
Supported by the .NET Compact Framework. | Get_Layoutfile_from_db |
Top

Expand image See Also

Reference

MyDocMgmt Class
Vertragsverwaltung.TKB.VV.Utils Namespace


MyDocMgmt Methods

MyDocMgmt Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Get_Layout |
Supported by the .NET Compact Framework. | Save_Document | Dokument in der Tabelle Dokument speichern
Supported by the .NET Compact Framework. | Save_LayoutFile | Grid-Layoutfile speichern
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | Get_Dokument |
Supported by the .NET Compact Framework. | Get_Layoutfile_from_db |
Top

Expand image See Also

Reference

MyDocMgmt Class
Vertragsverwaltung.TKB.VV.Utils Namespace


MyDocMgmt.Get_Dokument Method

MyDocMgmt.Get_Dokument Method

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Get_Dokument( _
   ByVal DokumentNr As Integer _
) As Boolean
C#
private bool Get_Dokument(
   int DokumentNr
);
C++

private:
bool Get_Dokument(
   int DokumentNr
)
JScript
private function Get_Dokument(
    DokumentNr : int
) : boolean;

Parameters

DokumentNr

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Function Get_Dokument(ByVal DokumentNr As Integer) As Boolean
            Dim Filename As String = Globals.clsapplication.sTmp_filepath
            If Right(Filename, 1) <> "\" Then Filename = Filename + "\"

            Dim connection As New SqlConnection()
            Dim da As New SqlDataAdapter("Select * From Dokument where DokumentNr=" + Str(DokumentNr), connection)
            Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
            Dim ds As New DataSet()
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.Fill(ds, "Dokument")
                Dim myRow As DataRow
                myRow = ds.Tables(0).Rows(0)
                Dim MyData() As Byte
                MyData = myRow.Item(15)

                Dim K As Long
                K = UBound(MyData)
                Filename = Filename + myRow.Item(5)
                Dim fs As New FileStream(filename, FileMode.OpenOrCreate, FileAccess.Write)
                fs.Write(MyData, 0, K)
                fs.Close()
                fs = Nothing
                Return True
            Catch ex As Exception
                Return False
            End Try
            CB = Nothing
            ds = Nothing
            da = Nothing
            connection.Close()
            connection = Nothing
            Return True
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyDocMgmt Class
MyDocMgmt Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MyDocMgmt.Get_Layout Method

MyDocMgmt.Get_Layout Method

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Get_Layout( _
   ByRef c1data As C1TrueDBGrid, _
   ByVal GridNo As Integer _
) As Boolean
C#
public bool Get_Layout(
   ref C1TrueDBGrid c1data,
   int GridNo
);
C++

public:
bool Get_Layout(
   C1TrueDBGrid^& c1data,
   int GridNo
)
JScript
public function Get_Layout(
    c1data : C1TrueDBGrid,
    GridNo : int
) : boolean;

Parameters

c1data

GridNo

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Get_Layout(ByRef c1data As C1TrueDBGrid, ByVal GridNo As Integer) As Boolean
            Dim filename As String = Globals.clsapplication.sTmp_filepath + Trim(Str(Globals.clsmitarbeiter.iMitarbeiternr.Value)) + Trim(Str(GridNo)) + ".lyt"
            If File.Exists(filename) Then
                c1data.LoadLayout(filename)
                Return True
            End If
            If Get_Layoutfile_from_db(filename, GridNo) Then
                c1data.LoadLayout(filename)
                Return True
            End If
            Return False
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyDocMgmt Class
MyDocMgmt Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MyDocMgmt.Get_Layoutfile_from_db Method

MyDocMgmt.Get_Layoutfile_from_db Method

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Get_Layoutfile_from_db( _
   ByVal filename As String, _
   ByVal GridNo As Integer _
) As Boolean
C#
private bool Get_Layoutfile_from_db(
   string filename,
   int GridNo
);
C++

private:
bool Get_Layoutfile_from_db(
   String^ filename,
   int GridNo
)
JScript
private function Get_Layoutfile_from_db(
    filename : String,
    GridNo : int
) : boolean;

Parameters

filename

GridNo

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Function Get_Layoutfile_from_db(ByVal filename As String, ByVal GridNo As Integer) As Boolean
            Dim connection As New SqlConnection()
            Dim da As New SqlDataAdapter("Select * From profil where mitarbeiternr=" + Str(Globals.clsmitarbeiter.iMitarbeiternr.Value), connection)
            Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
            Dim ds As New DataSet()
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.Fill(ds, "docs")
                Dim myRow As DataRow
                myRow = ds.Tables(0).Rows(0)
                Dim MyData() As Byte
                Select Case GridNo
                    Case 1
                        MyData = myRow.Item(3)

                End Select

                Dim K As Long
                K = UBound(MyData)
                Dim fs As New FileStream(filename, FileMode.OpenOrCreate, FileAccess.Write)
                fs.Write(MyData, 0, K)
                fs.Close()
                fs = Nothing
                Return True
            Catch ex As Exception
                Return False
            End Try
            CB = Nothing
            ds = Nothing
            da = Nothing
            connection.Close()
            connection = Nothing
            Return True
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyDocMgmt Class
MyDocMgmt Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MyDocMgmt.Save_Document Method

MyDocMgmt.Save_Document Method

Dokument in der Tabelle Dokument speichern

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Save_Document( _
   ByVal Dokumentnr As Integer, _
   ByVal Filename As String _
) As Boolean
C#
public bool Save_Document(
   int Dokumentnr,
   string Filename
);
C++

public:
bool Save_Document(
   int Dokumentnr,
   String^ Filename
)
JScript
public function Save_Document(
    Dokumentnr : int,
    Filename : String
) : boolean;

Parameters

Dokumentnr

Nummer des Dokument-Datensatzes

Filename

Zu speichender Dateiname

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Save_Document(ByVal Dokumentnr As Integer, ByVal Filename As String) As Boolean
            Dim Connection As New SqlConnection()
            Dim DA As New SqlDataAdapter("select * from dokument where dokumentnr =" + Str(dokumentnr), Connection)
            Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
            Dim ds As New DataSet()
            Dim fs As New FileStream(filename, FileMode.OpenOrCreate, FileAccess.Read)
            Dim mydata(fs.Length) As Byte
            fs.Read(mydata, 0, fs.Length)
            fs.Close()
            Try
                Connection.ConnectionString = Globals.sConnectionString
                Connection.Open()
                DA.Fill(ds, "Dokument")
                Dim myRow As DataRow
                If ds.Tables(0).Rows.Count = 0 Then
                    Return False
                Else
                    myRow = ds.Tables(0).Rows(0)
                    myRow.Item(15) = mydata
                    DA.Update(ds, "Dokument")
                End If
            Catch ex As Exception
                MsgBox(ex.Message)
                Return False
            End Try
            fs = Nothing
            cb = Nothing
            ds = Nothing
            DA = Nothing
            Connection.Close()
            Connection = Nothing
            Return True
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyDocMgmt Class
MyDocMgmt Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MyDocMgmt.Save_LayoutFile Method

MyDocMgmt.Save_LayoutFile Method

Grid-Layoutfile speichern

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Save_LayoutFile( _
   ByRef c1data As C1TrueDBGrid, _
   ByVal GridNo As Integer _
) As Boolean
C#
public bool Save_LayoutFile(
   ref C1TrueDBGrid c1data,
   int GridNo
);
C++

public:
bool Save_LayoutFile(
   C1TrueDBGrid^& c1data,
   int GridNo
)
JScript
public function Save_LayoutFile(
    c1data : C1TrueDBGrid,
    GridNo : int
) : boolean;

Parameters

c1data

C1Truedbgrind, von welchem das Layout gespeichert werden soll

GridNo

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Save_LayoutFile(ByRef c1data As C1TrueDBGrid, ByVal GridNo As Integer) As Boolean
            Dim filename As String = Globals.clsapplication.sTmp_filepath + Trim(Str(Globals.clsmitarbeiter.iMitarbeiternr.Value)) + Trim(Str(GridNo)) + ".lyt"
            c1data.SaveLayout(filename)

            Dim Connection As New SqlConnection()
            Dim DA As New SqlDataAdapter("select * from profil where mitarbeiternr=" + Str(Globals.clsmitarbeiter.iMitarbeiternr.Value), Connection)
            Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
            Dim ds As New DataSet()
            Dim fs As New FileStream(filename, FileMode.OpenOrCreate, FileAccess.Read)
            Dim mydata(fs.Length) As Byte
            fs.Read(mydata, 0, fs.Length)
            fs.Close()
            Try
                Connection.ConnectionString = Globals.sConnectionString
                Connection.Open()
                DA.Fill(ds, "profil")
                Dim myRow As DataRow
                If ds.Tables(0).Rows.Count = 0 Then
                    ' Neues Profil sepeichern
                    myRow = ds.Tables(0).NewRow
                    myRow.Item(1) = Globals.clsmitarbeiter.iMitarbeiternr.Value
                    myRow.Item(2) = ""
                    Select Case GridNo
                        Case 1
                            myRow.Item(3) = mydata
                    End Select
                    ds.Tables(0).Rows.Add(myRow)
                    DA.Update(ds, "profil")
                Else
                    myRow = ds.Tables(0).Rows(0)
                    Select Case GridNo
                        Case 1
                            myRow.Item(3) = mydata
                    End Select
                    DA.Update(ds, "profil")
                End If
            Catch ex As Exception
                MsgBox(ex.Message)
                Return False
            End Try
            fs = Nothing
            cb = Nothing
            ds = Nothing
            DA = Nothing
            Connection.Close()
            Connection = Nothing
            Return True

        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyDocMgmt Class
MyDocMgmt Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MyFormControls Class

MyFormControls Class
See Also Members
collapseAll image DropDown image

Klasse für ein Control-Objekt

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class MyFormControls
C#
public class MyFormControls
C++

public ref class MyFormControls
JScript
public class MyFormControls

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.Utils.MyFormControls

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyFormControls Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MyFormControls Members

MyFormControls Members
See Also Constructors Methods
CollapseAll image DropDown image

Klasse für ein Control-Objekt

The following tables list the members exposed by the MyFormControls type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | MyFormControls Constructor | Neue Instanz erstellen
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Write_Object_to_DB | Schreibt einen Datnsatz in die Tabelle SecurityObjects
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | Get_Description |
Supported by the .NET Compact Framework. | Objexists | Prüft, ob das Security-Objekt bereits auf der DB vorhanden ist
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | MyControl |
Supported by the .NET Compact Framework. | MyDescription |
Supported by the .NET Compact Framework. | MyFormname |
Supported by the .NET Compact Framework. | MyLevel |
Supported by the .NET Compact Framework. | MySecurityObject |
Supported by the .NET Compact Framework. | MySecurityObjectItem |
Supported by the .NET Compact Framework. | MySecurityObjecttype |
Top

Expand image See Also

Reference

MyFormControls Class
Vertragsverwaltung.TKB.VV.Utils Namespace


MyFormControls Constructor

MyFormControls Constructor

Neue Instanz erstellen

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal ctl As Object, _
   ByVal Formname As String, _
   ByVal securityobjecttype As String, _
   ByVal Securityobject As String, _
   ByVal SecurityObjectItem As String, _
   Optional ByVal level As Integer = 0, _
   Optional ByVal desc As String = "" _
)
C#
public System.Void MyFormControls(
   object ctl,
   string Formname,
   string securityobjecttype,
   string Securityobject,
   string SecurityObjectItem,
   int level,
   string desc
);
C++

public:
System::Void MyFormControls(
   object^ ctl,
   String^ Formname,
   String^ securityobjecttype,
   String^ Securityobject,
   String^ SecurityObjectItem,
   int level,
   String^ desc
)
JScript
public function MyFormControls(
    ctl : object,
    Formname : String,
    securityobjecttype : String,
    Securityobject : String,
    SecurityObjectItem : String,
    level : int,
    desc : String
);

Parameters

ctl

Control-Objekt

Formname

Betroffenes Formular

securityobjecttype

Objekttyp

Securityobject

Objektname

SecurityObjectItem

Unterobjekt (z.B. bei Menus, Spalten von C1TrueDBGrids)

level

Optional. The default value is 0.

desc

Optional. The default value is "".

Expand image Source code

Visual Basic CopyCode image Copy Code
        Sub New(ByVal ctl As Object, ByVal Formname As String, ByVal securityobjecttype As String, ByVal Securityobject As String, ByVal SecurityObjectItem As String, Optional ByVal level As Integer = 0, Optional ByVal desc As String = "")
            MyControl = ctl
            MySecurityObjecttype = securityobjecttype
            MyFormname = Formname
            MySecurityObject = Securityobject
            MySecurityObjectItem = SecurityObjectItem
            If desc = "" Then
                MyDescription = Get_Description(ctl)
            Else
                MyDescription = desc
            End If
            Try
                MyDescription = MyDescription.Replace("&", "")
            Catch ex As Exception
            End Try
            MyLevel = level
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyFormControls Class
MyFormControls Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MyFormControls Methods

MyFormControls Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Write_Object_to_DB | Schreibt einen Datnsatz in die Tabelle SecurityObjects
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | Get_Description |
Supported by the .NET Compact Framework. | Objexists | Prüft, ob das Security-Objekt bereits auf der DB vorhanden ist
Top

Expand image See Also

Reference

MyFormControls Class
Vertragsverwaltung.TKB.VV.Utils Namespace


MyFormControls.Get_Description Method

MyFormControls.Get_Description Method

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Get_Description( _
   ByRef ctl As Object _
) As String
C#
private string Get_Description(
   ref object ctl
);
C++

private:
String^ Get_Description(
   object^& ctl
)
JScript
private function Get_Description(
    ctl : object
) : String;

Parameters

ctl

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Function Get_Description(ByRef ctl As Object) As String
            Dim typ As System.Type = ctl.GetType
            Select Case LCase(typ.Name)
                Case "menustrip", "toolstripmenuitem", "toolstrip", "toolstripbutton", "contextmenustrip", "tabpage", "c1truedbgrid", "label"
                    Return ctl.Text
                Case Else
                    Return ctl.Name
            End Select

        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyFormControls Class
MyFormControls Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MyFormControls.Objexists Method

MyFormControls.Objexists Method

Prüft, ob das Security-Objekt bereits auf der DB vorhanden ist

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Objexists() As Boolean
C#
private bool Objexists();
C++

private:
bool Objexists()
JScript
private function Objexists() : boolean;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Function Objexists() As Boolean
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[my_security_check_entry]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@form", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, Me.MyFormname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@objecttype", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, Me.MySecurityObjecttype))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@object", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, Me.MySecurityObject))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@objectitem", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, Me.MySecurityObjectItem))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@objexists", SqlDbType.Int, 4, ParameterDirection.Output, True, 0, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Connection.Open()
                scmCmdToExecute.ExecuteNonQuery()
                If scmCmdToExecute.Parameters("@objexists").Value > 0 Then
                    Return True
                Else
                    Return False
                End If
            Catch ex As Exception
            Finally
                scmCmdToExecute.Connection.Close()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyFormControls Class
MyFormControls Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MyFormControls.Write_Object_to_DB Method

MyFormControls.Write_Object_to_DB Method

Schreibt einen Datnsatz in die Tabelle SecurityObjects

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Write_Object_to_DB() As Object
C#
public object Write_Object_to_DB();
C++

public:
object^ Write_Object_to_DB()
JScript
public function Write_Object_to_DB() : object;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Write_Object_to_DB()
            If Objexists() Then Exit Function
            Dim sectbl As New TKB.VV.DB.clsSecurityObject
            Dim dbkey As New TKB.VV.DB.clsMyKey_Tabelle
            dbkey.cpMainConnectionProvider = Globals.conn
            Dim newkey As Integer = dbkey.get_dbkey("SecurityObject")

            sectbl.cpMainConnectionProvider = Globals.conn
            conn.OpenConnection()
            sectbl.iSecurityObjectNr = New SqlInt32(CType(newkey, Int32))
            sectbl.sSecurityForm = New SqlString(CType(MyFormname, String))
            sectbl.sSecurityObjectType = New SqlString(CType(Me.MySecurityObjecttype, String))
            sectbl.sSecurityObject = New SqlString(CType(Me.MySecurityObject, String))
            sectbl.sSecurityObjectItem = New SqlString(CType(Me.MySecurityObjectItem, String))
            sectbl.bAktiv = New SqlBoolean(CType(True, Boolean))
            sectbl.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            sectbl.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            sectbl.sSecurityObjectDescriotion = New SqlString(CType(Me.MyDescription, String))
            sectbl.iLevel = New SqlInt32(CType(Me.MyLevel, Int32))
            sectbl.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            sectbl.iMandantnr = New SqlInt32(CType(Globals.clsmitarbeiter.iMandantnr.Value, Int32))
            sectbl.Insert()
            conn.CloseConnection(True)
            sectbl.Dispose()
            dbkey.Dispose()
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyFormControls Class
MyFormControls Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MyFormControls Fields

MyFormControls Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | MyControl |
Supported by the .NET Compact Framework. | MyDescription |
Supported by the .NET Compact Framework. | MyFormname |
Supported by the .NET Compact Framework. | MyLevel |
Supported by the .NET Compact Framework. | MySecurityObject |
Supported by the .NET Compact Framework. | MySecurityObjectItem |
Supported by the .NET Compact Framework. | MySecurityObjecttype |
Top

Expand image See Also

Reference

MyFormControls Class
Vertragsverwaltung.TKB.VV.Utils Namespace


MyControl Variable

MyControl Variable

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public MyControl As Object
C#
public object MyControl;
C++
public:
object^ MyControl;
JScript
public MyControl : object

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public MyControl As Object

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyFormControls Class
MyFormControls Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MyDescription Variable

MyDescription Variable

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public MyDescription As String
C#
public string MyDescription;
C++
public:
String^ MyDescription;
JScript
public MyDescription : String

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public MyDescription As String

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyFormControls Class
MyFormControls Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MyFormname Variable

MyFormname Variable

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public MyFormname As String
C#
public string MyFormname;
C++
public:
String^ MyFormname;
JScript
public MyFormname : String

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public MyFormname As String

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyFormControls Class
MyFormControls Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MyLevel Variable

MyLevel Variable

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public MyLevel As Integer
C#
public int MyLevel;
C++
public:
int MyLevel;
JScript
public MyLevel : int

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public MyLevel As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyFormControls Class
MyFormControls Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MySecurityObject Variable

MySecurityObject Variable

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public MySecurityObject As String
C#
public string MySecurityObject;
C++
public:
String^ MySecurityObject;
JScript
public MySecurityObject : String

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public MySecurityObject As String

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyFormControls Class
MyFormControls Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MySecurityObjectItem Variable

MySecurityObjectItem Variable

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public MySecurityObjectItem As String
C#
public string MySecurityObjectItem;
C++
public:
String^ MySecurityObjectItem;
JScript
public MySecurityObjectItem : String

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public MySecurityObjectItem As String

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyFormControls Class
MyFormControls Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MySecurityObjecttype Variable

MySecurityObjecttype Variable

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public MySecurityObjecttype As String
C#
public string MySecurityObjecttype;
C++
public:
String^ MySecurityObjecttype;
JScript
public MySecurityObjecttype : String

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public MySecurityObjecttype As String

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyFormControls Class
MyFormControls Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MyMessage Class

MyMessage Class
See Also Members
collapseAll image DropDown image

Standard-Messages in div. Formatenm

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class MyMessage
C#
public class MyMessage
C++

public ref class MyMessage
JScript
public class MyMessage

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.Utils.MyMessage

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyMessage Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MyMessage Members

MyMessage Members
See Also Methods
CollapseAll image DropDown image

Standard-Messages in div. Formatenm

The following tables list the members exposed by the MyMessage type.

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Get_Meldungstext | Meldungen aus der Datenbanklesen, sofern diese noch nicht ausgelesen worden sind. Nach dem ersten Lesen werden die Daten aus der Tabelle Meldungstexte ohne erneutem DB-Zugriff verwendet
Supported by the .NET Compact Framework. | ReplaceTextinMSG | Ausgabe der Meldung, welche übergeben wird. Als Option können 2 Texte zum Ersetzen übergeben werden. Parameter im Meldungstext #1 oder #2
Supported by the .NET Compact Framework. | Show_MessageYesNo | Yes-No-Meldung
Supported by the .NET Compact Framework. | Show_MessageYesNoCancel | Meldung Yes-No-Cancel
Supported by the .NET Compact Framework. | show_MessageYesNo_ReplaceText | Yes-No-Meldung, welcher 2 Strings als Parameter übergeben werden, damit diese im Meldungstext ersetzt werden können. Parameter im Meldungstext #1 oder #2
Supported by the .NET Compact Framework. | show_standardmessage | Standardmessage
Supported by the .NET Compact Framework. | show_standardmessage_ReplaceText | Standard-Meldung, welcher 2 Strings als Parameter übergeben werden, damit diese im Meldungstext ersetzt werden können. Parameter im Meldungstext #1 oder #2
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | meldungstexte | Dataview Meldungstexte um Textelemente für die Ausgabe zu suchen
Top

Expand image See Also

Reference

MyMessage Class
Vertragsverwaltung.TKB.VV.Utils Namespace


MyMessage Methods

MyMessage Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Get_Meldungstext | Meldungen aus der Datenbanklesen, sofern diese noch nicht ausgelesen worden sind. Nach dem ersten Lesen werden die Daten aus der Tabelle Meldungstexte ohne erneutem DB-Zugriff verwendet
Supported by the .NET Compact Framework. | ReplaceTextinMSG | Ausgabe der Meldung, welche übergeben wird. Als Option können 2 Texte zum Ersetzen übergeben werden. Parameter im Meldungstext #1 oder #2
Supported by the .NET Compact Framework. | Show_MessageYesNo | Yes-No-Meldung
Supported by the .NET Compact Framework. | Show_MessageYesNoCancel | Meldung Yes-No-Cancel
Supported by the .NET Compact Framework. | show_MessageYesNo_ReplaceText | Yes-No-Meldung, welcher 2 Strings als Parameter übergeben werden, damit diese im Meldungstext ersetzt werden können. Parameter im Meldungstext #1 oder #2
Supported by the .NET Compact Framework. | show_standardmessage | Standardmessage
Supported by the .NET Compact Framework. | show_standardmessage_ReplaceText | Standard-Meldung, welcher 2 Strings als Parameter übergeben werden, damit diese im Meldungstext ersetzt werden können. Parameter im Meldungstext #1 oder #2
Top

Expand image See Also

Reference

MyMessage Class
Vertragsverwaltung.TKB.VV.Utils Namespace


MyMessage.Get_Meldungstext Method

MyMessage.Get_Meldungstext Method

Meldungen aus der Datenbanklesen, sofern diese noch nicht ausgelesen worden sind. Nach dem ersten Lesen werden die Daten aus der Tabelle Meldungstexte ohne erneutem DB-Zugriff verwendet

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Get_Meldungstext( _
   ByVal i As Integer _
) As String
C#
public string Get_Meldungstext(
   int i
);
C++

public:
String^ Get_Meldungstext(
   int i
)
JScript
public function Get_Meldungstext(
    i : int
) : String;

Parameters

i

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Get_Meldungstext(ByVal i As Integer) As String
            Dim meldungen As New TKB.VV.DB.clsMeldungstexte
            Dim res As Integer
            meldungen.cpMainConnectionProvider = conn
            If Me.meldungstexte.Count = 0 Then
                Me.meldungstexte.Table = meldungen.SelectAll
            End If
            meldungstexte.Sort = "meldungstextnr"
            res = meldungstexte.Find(i)
            Try
                Get_Meldungstext = Me.meldungstexte(res).Item(2)
            Catch
                Get_Meldungstext = ""
            End Try
            meldungen.Dispose()
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyMessage Class
MyMessage Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MyMessage.ReplaceTextinMSG Method

MyMessage.ReplaceTextinMSG Method

Ausgabe der Meldung, welche übergeben wird. Als Option können 2 Texte zum Ersetzen übergeben werden. Parameter im Meldungstext #1 oder #2

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function ReplaceTextinMSG( _
   ByVal OrgText As String, _
   ByVal Text1 As String, _
   ByVal Text2 As String _
) As String
C#
public string ReplaceTextinMSG(
   string OrgText,
   string Text1,
   string Text2
);
C++

public:
String^ ReplaceTextinMSG(
   String^ OrgText,
   String^ Text1,
   String^ Text2
)
JScript
public function ReplaceTextinMSG(
    OrgText : String,
    Text1 : String,
    Text2 : String
) : String;

Parameters

OrgText

Meldungstext

Text1

erster Text zum ersetzen

Text2

zweiter Text zum ersetzen

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function ReplaceTextinMSG(ByVal OrgText As String, ByVal Text1 As String, ByVal Text2 As String) As String
            OrgText = OrgText.Replace("#1", Text1)
            OrgText = OrgText.Replace("#2", Text2)
            ReplaceTextinMSG = OrgText
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyMessage Class
MyMessage Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MyMessage.Show_MessageYesNo Method

MyMessage.Show_MessageYesNo Method

Yes-No-Meldung

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Show_MessageYesNo( _
   ByVal i As Integer _
) As MsgBoxResult
C#
public MsgBoxResult Show_MessageYesNo(
   int i
);
C++

public:
MsgBoxResult Show_MessageYesNo(
   int i
)
JScript
public function Show_MessageYesNo(
    i : int
) : MsgBoxResult;

Parameters

i

Meldungsnr

Return Value

MsgboxResult

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Show_MessageYesNo(ByVal i As Integer) As MsgBoxResult
            Show_MessageYesNo = MsgBox(Get_Meldungstext(i), MsgBoxStyle.YesNo + MsgBoxStyle.Question)
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyMessage Class
MyMessage Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MyMessage.Show_MessageYesNoCancel Method

MyMessage.Show_MessageYesNoCancel Method

Meldung Yes-No-Cancel

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Show_MessageYesNoCancel( _
   ByVal i As Integer _
) As MsgBoxResult
C#
public MsgBoxResult Show_MessageYesNoCancel(
   int i
);
C++

public:
MsgBoxResult Show_MessageYesNoCancel(
   int i
)
JScript
public function Show_MessageYesNoCancel(
    i : int
) : MsgBoxResult;

Parameters

i

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Show_MessageYesNoCancel(ByVal i As Integer) As MsgBoxResult
            Show_MessageYesNoCancel = MsgBox(Get_Meldungstext(i), MsgBoxStyle.YesNoCancel + MsgBoxStyle.Question)
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyMessage Class
MyMessage Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MyMessage.show_MessageYesNo_ReplaceText Method

MyMessage.show_MessageYesNo_ReplaceText Method

Yes-No-Meldung, welcher 2 Strings als Parameter übergeben werden, damit diese im Meldungstext ersetzt werden können. Parameter im Meldungstext #1 oder #2

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function show_MessageYesNo_ReplaceText( _
   ByVal i As Integer, _
   ByVal Text1 As String, _
   ByVal Text2 As String _
) As MsgBoxResult
C#
public MsgBoxResult show_MessageYesNo_ReplaceText(
   int i,
   string Text1,
   string Text2
);
C++

public:
MsgBoxResult show_MessageYesNo_ReplaceText(
   int i,
   String^ Text1,
   String^ Text2
)
JScript
public function show_MessageYesNo_ReplaceText(
    i : int,
    Text1 : String,
    Text2 : String
) : MsgBoxResult;

Parameters

i

MeldungsNr

Text1

erster Text zum ersetzen

Text2

zweiter Text zum ersetzen

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function show_MessageYesNo_ReplaceText(ByVal i As Integer, ByVal Text1 As String, ByVal Text2 As String) As MsgBoxResult
            Dim s As String
            s = Get_Meldungstext(i)
            s = s.Replace("#1", Text1)
            s = s.Replace("#2", Text2)
            show_MessageYesNo_ReplaceText = MsgBox(s, MsgBoxStyle.YesNo + MsgBoxStyle.Question)
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyMessage Class
MyMessage Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MyMessage.show_standardmessage Method

MyMessage.show_standardmessage Method

Standardmessage

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function show_standardmessage( _
   ByVal i As Integer, _
   ByVal typ As MsgBoxStyle _
) As Integer
C#
public int show_standardmessage(
   int i,
   MsgBoxStyle typ
);
C++

public:
int show_standardmessage(
   int i,
   MsgBoxStyle typ
)
JScript
public function show_standardmessage(
    i : int,
    typ : MsgBoxStyle
) : int;

Parameters

i

Messagenr

typ

Messagetyp

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function show_standardmessage(ByVal i As Integer, ByVal typ As MsgBoxStyle) As Integer
            MsgBox(Get_Meldungstext(i), typ)
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyMessage Class
MyMessage Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MyMessage.show_standardmessage_ReplaceText Method

MyMessage.show_standardmessage_ReplaceText Method

Standard-Meldung, welcher 2 Strings als Parameter übergeben werden, damit diese im Meldungstext ersetzt werden können. Parameter im Meldungstext #1 oder #2

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function show_standardmessage_ReplaceText( _
   ByVal i As Integer, _
   ByVal typ As MsgBoxStyle, _
   ByVal Text1 As String, _
   ByVal Text2 As String _
) As Integer
C#
public int show_standardmessage_ReplaceText(
   int i,
   MsgBoxStyle typ,
   string Text1,
   string Text2
);
C++

public:
int show_standardmessage_ReplaceText(
   int i,
   MsgBoxStyle typ,
   String^ Text1,
   String^ Text2
)
JScript
public function show_standardmessage_ReplaceText(
    i : int,
    typ : MsgBoxStyle,
    Text1 : String,
    Text2 : String
) : int;

Parameters

i

typ

Text1

Text2

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function show_standardmessage_ReplaceText(ByVal i As Integer, ByVal typ As MsgBoxStyle, ByVal Text1 As String, ByVal Text2 As String) As Integer
            Dim s As String
            s = Get_Meldungstext(i)
            s = s.Replace("#1", Text1)
            s = s.Replace("#2", Text2)
            MsgBox(s, typ)
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyMessage Class
MyMessage Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MyMessage Fields

MyMessage Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | meldungstexte | Dataview Meldungstexte um Textelemente für die Ausgabe zu suchen
Top

Expand image See Also

Reference

MyMessage Class
Vertragsverwaltung.TKB.VV.Utils Namespace


meldungstexte Variable

meldungstexte Variable

Dataview Meldungstexte um Textelemente für die Ausgabe zu suchen

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private meldungstexte As DataView
C#
private DataView meldungstexte;
C++
private:
DataView^ meldungstexte;
JScript
private meldungstexte : DataView

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private meldungstexte As New DataView()

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MyMessage Class
MyMessage Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MySecurity Class

MySecurity Class
See Also Members
collapseAll image DropDown image

Formular-Security-Objekte auslesen und auf DB schreiben bzw. Formular-Security zur Laufzeit setzen

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class MySecurity
C#
public class MySecurity
C++

public ref class MySecurity
JScript
public class MySecurity

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.Utils.MySecurity

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySecurity Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MySecurity Members

MySecurity Members
See Also Methods
CollapseAll image DropDown image

Formular-Security-Objekte auslesen und auf DB schreiben bzw. Formular-Security zur Laufzeit setzen

The following tables list the members exposed by the MySecurity type.

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Generate_HTML |
Supported by the .NET Compact Framework. | List_Form_Controls | Alle Controls des Formulars zusammensuchen und auf der DB speichern
Supported by the .NET Compact Framework. | Print_Screen |
Supported by the .NET Compact Framework. | Set_Form_Security | Formularsecurity setzen
Supported by the .NET Compact Framework. | saveasbitmap |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | Load_Data | Daten ab Datenbank laden
Supported by the .NET Compact Framework. | Objectanalysis | Sämtliche Controls vom Formular auslesen
Supported by the .NET Compact Framework. | Objexists | Prüft, ob das Security-Objekt bereits auf der DB vorhanden ist
Supported by the .NET Compact Framework. | ReadMenu |
Supported by the .NET Compact Framework. | Set_Preferences | Security-Einstellungen setzen
Supported by the .NET Compact Framework. | Set_Security | Prüft die DB-Einträge mit den Formcontrols und bei Übereinstimmung werden die Security-Einstellungen gesetzt
Supported by the .NET Compact Framework. | get_all_menus | Auslesen von Menu-Subitems
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | IntForm |
Supported by the .NET Compact Framework. | SecurityData |
Supported by the .NET Compact Framework. | connection |
Supported by the .NET Compact Framework. | ctlcol |
Supported by the .NET Compact Framework. | da |
Supported by the .NET Compact Framework. | formname |
Supported by the .NET Compact Framework. | level | Auslesen von MenuItems
Supported by the .NET Compact Framework. | tmpmenuname |
Top

Expand image See Also

Reference

MySecurity Class
Vertragsverwaltung.TKB.VV.Utils Namespace


MySecurity Methods

MySecurity Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Generate_HTML |
Supported by the .NET Compact Framework. | List_Form_Controls | Alle Controls des Formulars zusammensuchen und auf der DB speichern
Supported by the .NET Compact Framework. | Print_Screen |
Supported by the .NET Compact Framework. | Set_Form_Security | Formularsecurity setzen
Supported by the .NET Compact Framework. | saveasbitmap |
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | Load_Data | Daten ab Datenbank laden
Supported by the .NET Compact Framework. | Objectanalysis | Sämtliche Controls vom Formular auslesen
Supported by the .NET Compact Framework. | Objexists | Prüft, ob das Security-Objekt bereits auf der DB vorhanden ist
Supported by the .NET Compact Framework. | ReadMenu |
Supported by the .NET Compact Framework. | Set_Preferences | Security-Einstellungen setzen
Supported by the .NET Compact Framework. | Set_Security | Prüft die DB-Einträge mit den Formcontrols und bei Übereinstimmung werden die Security-Einstellungen gesetzt
Supported by the .NET Compact Framework. | get_all_menus | Auslesen von Menu-Subitems
Top

Expand image See Also

Reference

MySecurity Class
Vertragsverwaltung.TKB.VV.Utils Namespace


MySecurity.Generate_HTML Method

MySecurity.Generate_HTML Method

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Generate_HTML() As Object
C#
public object Generate_HTML();
C++

public:
object^ Generate_HTML()
JScript
public function Generate_HTML() : object;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Generate_HTML()
            saveasbitmap(Me.IntForm, "testform")
            'Exit Function
            'Dim x As MyFormControls
            'For Each x In ctlcol
            '    Try
            '        saveasbitmap(x.MyControl, x.MyFormname & "_" & x.MySecurityObject & "_" & x.MySecurityObjectItem)
            '        If x.MySecurityObjecttype = "ToolStrip" And x.MySecurityObjectItem = "" Then
            '            Dim gaga As ToolStrip = x.MyControl
            '            For Each c As ToolStripButton In gaga.Items
            '                Dim xxx As Control = CType(c, Control)

            '                xxx = CType(c, Control)
            '                saveasbitmap(xxx, "xxx")
            '            Next
            '        End If
            '    Catch ex As Exception
            '        MsgBox(ex.Message)
            '    End Try
            'Next
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySecurity Class
MySecurity Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MySecurity.List_Form_Controls Method

MySecurity.List_Form_Controls Method

Alle Controls des Formulars zusammensuchen und auf der DB speichern

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function List_Form_Controls( _
   ByRef f As Form _
) As Object
C#
public object List_Form_Controls(
   ref Form f
);
C++

public:
object^ List_Form_Controls(
   Form^& f
)
JScript
public function List_Form_Controls(
    f : Form
) : object;

Parameters

f

Betroffenes Formular

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function List_Form_Controls(ByRef f As Form)
            Me.ctlcol.Clear()
            formname = f.Name
            For Each ctl As Control In f.Controls
                Objectanalysis(ctl)
            Next
            Dim i As Integer
            For i = 1 To ctlcol.Count
                Dim secobj As MyFormControls = ctlcol(i)
                secobj.Write_Object_to_DB()
            Next
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySecurity Class
MySecurity Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MySecurity.Load_Data Method

MySecurity.Load_Data Method

Daten ab Datenbank laden

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Load_Data( _
   ByVal Formname As String _
)
C#
private System.Void Load_Data(
   string Formname
);
C++

private:
System::Void Load_Data(
   String^ Formname
)
JScript
private function Load_Data(
    Formname : String
);

Parameters

Formname

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Sub Load_Data(ByVal Formname As String)
            Try
                If SecurityData.Tables.Count > 0 Then Exit Sub
            Catch ex As Exception
            End Try
            SecurityData.Tables.Clear()
            Dim sqlcmd As New SqlCommand

            sqlcmd.CommandText = "dbo.my_security_get_data"
            sqlcmd.Parameters.Add("@FormName", SqlDbType.VarChar, 255)
            sqlcmd.Parameters.Add("@Mitarbeiternr", SqlDbType.Int, 4)
            sqlcmd.Parameters(0).Value = Formname
            sqlcmd.Parameters(1).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value

            sqlcmd.CommandType = CommandType.StoredProcedure
            sqlcmd.Connection = connection
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.SelectCommand = sqlcmd
                da.Fill(SecurityData, "SecurityTable")
            Catch ex As Exception
            Finally
                connection.Close()
                da.Dispose()
                sqlcmd.Dispose()
            End Try
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySecurity Class
MySecurity Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MySecurity.Objectanalysis Method

MySecurity.Objectanalysis Method

Sämtliche Controls vom Formular auslesen

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Objectanalysis( _
   ByRef ctl As Object _
) As String
C#
private string Objectanalysis(
   ref object ctl
);
C++

private:
String^ Objectanalysis(
   object^& ctl
)
JScript
private function Objectanalysis(
    ctl : object
) : String;

Parameters

ctl

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Function Objectanalysis(ByRef ctl As Object) As String
            Dim typ As System.Type = ctl.GetType
            Select Case LCase(typ.Name)
                Case "menustrip", "contextmenustrip"
                    ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, ""))
                    tmpmenuname = ctl.name
                    ReadMenu(ctl)
                Case "toolstrip"
                    ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, ""))
                    Dim tmptoolstrop As ToolStrip = ctl
                    For Each subobj As ToolStripButton In tmptoolstrop.Items
                        ctlcol.Add(New MyFormControls(subobj, formname, typ.Name, ctl.Name, subobj.Name, 1))
                    Next
                Case "splitcontainer"
                    ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, ""))
                    Dim tmpsplit As SplitContainer = ctl
                    For Each ctrl As Object In tmpsplit.Panel1.Controls
                        Objectanalysis(ctrl)
                    Next
                    For Each ctrl As Object In tmpsplit.Panel2.Controls
                        Objectanalysis(ctrl)
                    Next
                Case "tabcontrol"
                    ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, ""))
                    Dim tmptabcontrol As TabControl = ctl
                    For Each ctl In tmptabcontrol.TabPages
                        Objectanalysis(ctl)
                    Next
                Case "tabpage"
                    ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, "", 1))
                    Dim tmptabpage As TabPage = ctl
                    For Each ctl In tmptabpage.Controls
                        Objectanalysis(ctl)
                    Next
                Case "groupbox"
                    ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, ""))
                    Dim tmptabpage As GroupBox = ctl
                    For Each ctl In tmptabpage.Controls
                        Objectanalysis(ctl)
                    Next
                Case "panel"
                    ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, ""))
                    Dim tmppanel As Panel = ctl
                    For Each ctl In tmppanel.Controls
                        Objectanalysis(ctl)
                    Next
                Case "c1truedbgrid"
                    ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, ""))
                    Dim ctrl As C1TrueDBGrid = ctl
                    Dim i As Integer
                    For i = 0 To ctrl.Columns.Count - 1
                        ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, ctrl.Columns(i).Caption, 0, ctrl.Columns(i).Caption))
                    Next
                Case Else
                    ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, ""))
            End Select
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySecurity Class
MySecurity Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MySecurity.Objexists Method

MySecurity.Objexists Method

Prüft, ob das Security-Objekt bereits auf der DB vorhanden ist

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Objexists( _
   ByVal securityform As String, _
   ByVal securityobjecttype As String, _
   ByVal securityobject As String, _
   ByVal securityobjectitem As String _
) As Boolean
C#
private bool Objexists(
   string securityform,
   string securityobjecttype,
   string securityobject,
   string securityobjectitem
);
C++

private:
bool Objexists(
   String^ securityform,
   String^ securityobjecttype,
   String^ securityobject,
   String^ securityobjectitem
)
JScript
private function Objexists(
    securityform : String,
    securityobjecttype : String,
    securityobject : String,
    securityobjectitem : String
) : boolean;

Parameters

securityform

Formular

securityobjecttype

Objekttyp

securityobject

Objektname

securityobjectitem

Objektitem

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Function Objexists(ByVal securityform As String, ByVal securityobjecttype As String, ByVal securityobject As String, ByVal securityobjectitem As String) As Boolean
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[my_security_check_entry]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@form", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, securityform))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@objecttype", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, securityobjecttype))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@object", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, securityobject))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@objectitem", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, securityobjectitem))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@objexists", SqlDbType.Int, 4, ParameterDirection.Output, True, 0, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Connection.Open()
                scmCmdToExecute.ExecuteNonQuery()
                If scmCmdToExecute.Parameters("@objexists").Value > 0 Then
                    Return True
                Else
                    Return False
                End If
            Catch ex As Exception
            Finally
                scmCmdToExecute.Connection.Close()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySecurity Class
MySecurity Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MySecurity.Print_Screen Method

MySecurity.Print_Screen Method

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Print_Screen( _
   ByRef ctl As Control _
) As Object
C#
public object Print_Screen(
   ref Control ctl
);
C++

public:
object^ Print_Screen(
   Control^& ctl
)
JScript
public function Print_Screen(
    ctl : Control
) : object;

Parameters

ctl

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Print_Screen(ByRef ctl As Control)
            saveasbitmap(ctl, ctl.Name)
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySecurity Class
MySecurity Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MySecurity.ReadMenu Method

MySecurity.ReadMenu Method

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function ReadMenu( _
   ByRef x As Object _
) As Object
C#
private object ReadMenu(
   ref object x
);
C++

private:
object^ ReadMenu(
   object^& x
)
JScript
private function ReadMenu(
    x : object
) : object;

Parameters

x

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Function ReadMenu(ByRef x As Object)
            Dim tmpmnu As MenuStrip = x
            level = 0
            For Each xx As ToolStripMenuItem In tmpmnu.Items
                ctlcol.Add(New MyFormControls(xx, formname, "menustrip", tmpmenuname, xx.Name, level))
                get_all_menus(xx)
            Next
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySecurity Class
MySecurity Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MySecurity.Set_Form_Security Method

MySecurity.Set_Form_Security Method

Formularsecurity setzen

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Set_Form_Security( _
   ByRef f As Form _
) As Object
C#
public object Set_Form_Security(
   ref Form f
);
C++

public:
object^ Set_Form_Security(
   Form^& f
)
JScript
public function Set_Form_Security(
    f : Form
) : object;

Parameters

f

Aktuelles Formular

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Set_Form_Security(ByRef f As Form)
            IntForm = f
            formname = f.Name
            'Load form DB
            Load_Data(f.Name)
            'Load FormObjects
            Me.ctlcol.Clear()
            formname = f.Name
            For Each ctl As Control In f.Controls
                Objectanalysis(ctl)
            Next
            Set_Security()
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySecurity Class
MySecurity Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MySecurity.Set_Preferences Method

MySecurity.Set_Preferences Method

Security-Einstellungen setzen

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Set_Preferences( _
   ByRef obj As Object, _
   ByVal read_only As Boolean, _
   ByVal invisible As Boolean, _
   ByVal SecurityObjectItem As String _
)
C#
private System.Void Set_Preferences(
   ref object obj,
   bool read_only,
   bool invisible,
   string SecurityObjectItem
);
C++

private:
System::Void Set_Preferences(
   object^& obj,
   bool read_only,
   bool invisible,
   String^ SecurityObjectItem
)
JScript
private function Set_Preferences(
    obj : object,
    read_only : boolean,
    invisible : boolean,
    SecurityObjectItem : String
);

Parameters

obj

Betroffenes Objeckt (Menuitem, Conrol usw.)

read_only

Readonly ja/nein

invisible

Sichtbar ja/nein

SecurityObjectItem

Name des Unterobjektes - wird für die Spalteneinstellungen von C1TruedbGrids verwendet

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Sub Set_Preferences(ByRef obj As Object, ByVal read_only As Boolean, ByVal invisible As Boolean, ByVal SecurityObjectItem As String)
            Dim objtype As System.Type = obj.GetType
            Select Case LCase(objtype.Name)
                Case "toolstripmenuitem"
                    Dim ctl As ToolStripMenuItem = obj
                    If read_only Then ctl.Enabled = False
                    If invisible Then ctl.Visible = False
                Case "textbox", "label", "combobox", "checkbox", "toolstripbutton", "panel"
                    If read_only Then obj.Enabled = False
                    If invisible Then obj.Visible = False
                Case "c1truedbgrid"
                    Dim ctl As C1TrueDBGrid = obj
                    If SecurityObjectItem = "" Then
                        If read_only Then ctl.Enabled = False
                        If invisible Then obj.Visible = False
                    Else
                        If read_only Then ctl.Splits(0).DisplayColumns(SecurityObjectItem).Locked = True
                        If invisible Then ctl.Splits(0).DisplayColumns(SecurityObjectItem).Visible = False
                    End If

            End Select
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySecurity Class
MySecurity Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MySecurity.Set_Security Method

MySecurity.Set_Security Method

Prüft die DB-Einträge mit den Formcontrols und bei Übereinstimmung werden die Security-Einstellungen gesetzt

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Set_Security()
C#
private System.Void Set_Security();
C++

private:
System::Void Set_Security()
JScript
private function Set_Security();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Sub Set_Security()
            Dim i As Integer
            For i = 0 To Me.SecurityData.Tables(0).Rows.Count - 1
                Dim SecurityObject As String = Me.SecurityData.Tables(0).Rows(i).Item("SecurityObject")
                Dim SecurityObjectitem As String = Me.SecurityData.Tables(0).Rows(i).Item("SecurityObjectItem")
                Dim read_only As Boolean = Me.SecurityData.Tables(0).Rows(i).Item("readonly")
                Dim invisible As Boolean = Me.SecurityData.Tables(0).Rows(i).Item("invisible")
                Dim ii As Integer
                For ii = 1 To ctlcol.Count
                    Dim secobj As MyFormControls = ctlcol(ii)

                    If secobj.MySecurityObject = SecurityObject And secobj.MySecurityObjectItem = SecurityObjectitem Then
                        Set_Preferences(secobj.MyControl, read_only, invisible, SecurityObjectitem)
                    End If
                Next
            Next
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySecurity Class
MySecurity Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MySecurity.get_all_menus Method

MySecurity.get_all_menus Method

Auslesen von Menu-Subitems

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function get_all_menus( _
   ByRef xx As ToolStripMenuItem _
) As Object
C#
private object get_all_menus(
   ref ToolStripMenuItem xx
);
C++

private:
object^ get_all_menus(
   ToolStripMenuItem^& xx
)
JScript
private function get_all_menus(
    xx : ToolStripMenuItem
) : object;

Parameters

xx

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Function get_all_menus(ByRef xx As ToolStripMenuItem)
            level = level + 1
            For Each subobj As Object In xx.DropDownItems
                If LCase(subobj.GetType.Name) = "toolstripmenuitem" Then
                    ctlcol.Add(New MyFormControls(subobj, formname, "menustrip", tmpmenuname, subobj.Name, level))
                    get_all_menus(subobj)
                End If
            Next
            level = level - 1
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySecurity Class
MySecurity Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MySecurity.saveasbitmap Method

MySecurity.saveasbitmap Method

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function saveasbitmap( _
   ByRef ctl As Control, _
   ByVal filename As String _
) As Object
C#
public object saveasbitmap(
   ref Control ctl,
   string filename
);
C++

public:
object^ saveasbitmap(
   Control^& ctl,
   String^ filename
)
JScript
public function saveasbitmap(
    ctl : Control,
    filename : String
) : object;

Parameters

ctl

filename

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function saveasbitmap(ByRef ctl As Control, ByVal filename As String)
            Dim g As Graphics = ctl.CreateGraphics
            Dim b As New Bitmap(ctl.Width, ctl.Height)
            ctl.DrawToBitmap(b, New Rectangle(0, 0, ctl.Width, ctl.Height))
            b.Save("E:\Software-Projekte\Vertragsverwaltung\Screens\" & filename & ".jpg", System.Drawing.Imaging.ImageFormat.Jpeg)
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySecurity Class
MySecurity Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MySecurity Fields

MySecurity Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | IntForm |
Supported by the .NET Compact Framework. | SecurityData |
Supported by the .NET Compact Framework. | connection |
Supported by the .NET Compact Framework. | ctlcol |
Supported by the .NET Compact Framework. | da |
Supported by the .NET Compact Framework. | formname |
Supported by the .NET Compact Framework. | level | Auslesen von MenuItems
Supported by the .NET Compact Framework. | tmpmenuname |
Top

Expand image See Also

Reference

MySecurity Class
Vertragsverwaltung.TKB.VV.Utils Namespace


IntForm Variable

IntForm Variable

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private IntForm As Form
C#
private Form IntForm;
C++
private:
Form^ IntForm;
JScript
private IntForm : Form

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim IntForm As Form

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySecurity Class
MySecurity Members
Vertragsverwaltung.TKB.VV.Utils Namespace


SecurityData Variable

SecurityData Variable

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private SecurityData As DataSet
C#
private DataSet SecurityData;
C++
private:
DataSet^ SecurityData;
JScript
private SecurityData : DataSet

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim SecurityData As DataSet = Globals.SecurityDaten

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySecurity Class
MySecurity Members
Vertragsverwaltung.TKB.VV.Utils Namespace


connection Variable

connection Variable

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private connection As SqlConnection
C#
private SqlConnection connection;
C++
private:
SqlConnection^ connection;
JScript
private connection : SqlConnection

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim connection As New SqlConnection()

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySecurity Class
MySecurity Members
Vertragsverwaltung.TKB.VV.Utils Namespace


ctlcol Variable

ctlcol Variable

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private ctlcol As Collection
C#
private Collection ctlcol;
C++
private:
Collection^ ctlcol;
JScript
private ctlcol : Collection

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim ctlcol As New Collection

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySecurity Class
MySecurity Members
Vertragsverwaltung.TKB.VV.Utils Namespace


da Variable

da Variable

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private da As SqlDataAdapter
C#
private SqlDataAdapter da;
C++
private:
SqlDataAdapter^ da;
JScript
private da : SqlDataAdapter

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim da As New SqlDataAdapter("", connection)

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySecurity Class
MySecurity Members
Vertragsverwaltung.TKB.VV.Utils Namespace


formname Variable

formname Variable

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private formname As String
C#
private string formname;
C++
private:
String^ formname;
JScript
private formname : String

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim formname As String = ""

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySecurity Class
MySecurity Members
Vertragsverwaltung.TKB.VV.Utils Namespace


level Variable

level Variable

Auslesen von MenuItems

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private level As Integer
C#
private int level;
C++
private:
int level;
JScript
private level : int

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim level As Integer = 0

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySecurity Class
MySecurity Members
Vertragsverwaltung.TKB.VV.Utils Namespace


tmpmenuname Variable

tmpmenuname Variable

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private tmpmenuname As String
C#
private string tmpmenuname;
C++
private:
String^ tmpmenuname;
JScript
private tmpmenuname : String

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim tmpmenuname As String

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySecurity Class
MySecurity Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MySpaltenTitel Class

MySpaltenTitel Class
See Also Members
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class MySpaltenTitel
C#
public class MySpaltenTitel
C++

public ref class MySpaltenTitel
JScript
public class MySpaltenTitel

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.Utils.MySpaltenTitel

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySpaltenTitel Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MySpaltenTitel Members

MySpaltenTitel Members
See Also Constructors Methods
CollapseAll image DropDown image

The following tables list the members exposed by the MySpaltenTitel type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | MySpaltenTitel Constructor |
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | dispose |
Supported by the .NET Compact Framework. | getspalte |
Supported by the .NET Compact Framework. | load_data |
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | spaltendata |
Top

Expand image See Also

Reference

MySpaltenTitel Class
Vertragsverwaltung.TKB.VV.Utils Namespace


MySpaltenTitel Constructor

MySpaltenTitel Constructor

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void MySpaltenTitel();
C++

public:
System::Void MySpaltenTitel()
JScript
public function MySpaltenTitel();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Sub New()
            load_data()
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySpaltenTitel Class
MySpaltenTitel Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MySpaltenTitel Methods

MySpaltenTitel Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | dispose |
Supported by the .NET Compact Framework. | getspalte |
Supported by the .NET Compact Framework. | load_data |
Top

Expand image See Also

Reference

MySpaltenTitel Class
Vertragsverwaltung.TKB.VV.Utils Namespace


MySpaltenTitel.dispose Method

MySpaltenTitel.dispose Method

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub dispose()
C#
public System.Void dispose();
C++

public:
System::Void dispose()
JScript
public function dispose();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Sub dispose()
            spaltendata.Dispose()
            Me.dispose()
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySpaltenTitel Class
MySpaltenTitel Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MySpaltenTitel.getspalte Method

MySpaltenTitel.getspalte Method

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function getspalte( _
   ByVal tabelle As String, _
   ByVal feld As String, _
   ByRef spaltenname As String, _
   ByRef locked As Boolean, _
   ByRef colwidth As Integer, _
   ByRef order As Integer, _
   ByRef alshacken As Boolean, _
   ByRef tiptext As String _
) As Object
C#
public object getspalte(
   string tabelle,
   string feld,
   ref string spaltenname,
   ref bool locked,
   ref int colwidth,
   ref int order,
   ref bool alshacken,
   ref string tiptext
);
C++

public:
object^ getspalte(
   String^ tabelle,
   String^ feld,
   String^& spaltenname,
   bool& locked,
   int& colwidth,
   int& order,
   bool& alshacken,
   String^& tiptext
)
JScript
public function getspalte(
    tabelle : String,
    feld : String,
    spaltenname : String,
    locked : boolean,
    colwidth : int,
    order : int,
    alshacken : boolean,
    tiptext : String
) : object;

Parameters

tabelle

feld

spaltenname

locked

colwidth

order

alshacken

tiptext

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function getspalte(ByVal tabelle As String, ByVal feld As String, ByRef spaltenname As String, ByRef locked As Boolean, _
        ByRef colwidth As Integer, ByRef order As Integer, ByRef alshacken As Boolean, ByRef tiptext As String)
            If spaltendata.Rows.Count = 0 Then load_data()
            Dim dv() As DataRow
            Dim dr As DataRow
            dv = spaltendata.Select("Tabelle='" & tabelle & "' and tabellenspalte='" & feld & "'")
            For Each dr In dv
                spaltenname = dr.Item(3)
                locked = dr.Item(4)
                colwidth = dr.Item(6)
                order = dr.Item(7)
                alshacken = dr.Item(5)
                tiptext = dr.Item(8)
            Next
            'Dim i As Integer
            'For i = 0 To spaltendata.Rows.Count - 1

            '    If UCase(spaltendata.Rows(i).Item(1)) = UCase(tabelle) And UCase(spaltendata.Rows(i).Item(2)) = UCase(feld) Then
            '        spaltenname = spaltendata.Rows(i).Item(3)
            '        locked = spaltendata.Rows(i).Item(4)
            '        colwidth = spaltendata.Rows(i).Item(6)
            '        order = spaltendata.Rows(i).Item(7)
            '        alshacken = spaltendata.Rows(i).Item(5)
            '        tiptext = spaltendata.Rows(i).Item(8)
            '        Exit Function
            '    End If
            'Next
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySpaltenTitel Class
MySpaltenTitel Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MySpaltenTitel.load_data Method

MySpaltenTitel.load_data Method

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub load_data()
C#
public System.Void load_data();
C++

public:
System::Void load_data()
JScript
public function load_data();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub load_data()
            If Me.spaltendata.Rows.Count > 0 Then Exit Sub
            Dim spalten As New TKB.VV.DB.clsSpalten()
            spaltendata.Rows.Clear()
            spalten.cpMainConnectionProvider = conn
            spaltendata = spalten.SelectAll
            Globals.Spaltendaten = spaltendata
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySpaltenTitel Class
MySpaltenTitel Members
Vertragsverwaltung.TKB.VV.Utils Namespace


MySpaltenTitel Fields

MySpaltenTitel Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | spaltendata |
Top

Expand image See Also

Reference

MySpaltenTitel Class
Vertragsverwaltung.TKB.VV.Utils Namespace


spaltendata Variable

spaltendata Variable

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private spaltendata As DataTable
C#
private DataTable spaltendata;
C++
private:
DataTable^ spaltendata;
JScript
private spaltendata : DataTable

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private spaltendata As DataTable = Globals.Spaltendaten

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

MySpaltenTitel Class
MySpaltenTitel Members
Vertragsverwaltung.TKB.VV.Utils Namespace


Tabellenspalte Class

Tabellenspalte Class
See Also Members
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class Tabellenspalte
C#
public class Tabellenspalte
C++

public ref class Tabellenspalte
JScript
public class Tabellenspalte

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.Utils.Tabellenspalte

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Tabellenspalte Members
Vertragsverwaltung.TKB.VV.Utils Namespace


Tabellenspalte Members

Tabellenspalte Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

The following tables list the members exposed by the Tabellenspalte type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | Tabellenspalte Constructor | (Overloaded)
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | AlsHacken |
Supported by the .NET Compact Framework. | ColWith |
Supported by the .NET Compact Framework. | Feld |
Supported by the .NET Compact Framework. | Order |
Supported by the .NET Compact Framework. | Tabelle |
Supported by the .NET Compact Framework. | TipText |
Supported by the .NET Compact Framework. | locked |
Supported by the .NET Compact Framework. | spaltenname |
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Spaltentitel_aktualisieren | (Overloaded)
Supported by the .NET Compact Framework. | getspalte |
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_Order |
Supported by the .NET Compact Framework. | m_Width |
Supported by the .NET Compact Framework. | m_alsHacken |
Supported by the .NET Compact Framework. | m_field |
Supported by the .NET Compact Framework. | m_locked |
Supported by the .NET Compact Framework. | m_spaltenname |
Supported by the .NET Compact Framework. | m_table |
Supported by the .NET Compact Framework. | m_tiptext |
Top

Expand image See Also

Reference

Tabellenspalte Class
Vertragsverwaltung.TKB.VV.Utils Namespace


Tabellenspalte Constructor

Tabellenspalte Constructor

Expand image Overload List

Name | Description
public System.Void Tabellenspalte(); |
public System.Void Tabellenspalte(ref object, ref string, ref DataSet); |

Expand image See Also

Reference

Tabellenspalte Class
Tabellenspalte Members
Vertragsverwaltung.TKB.VV.Utils Namespace


Tabellenspalte Properties

Tabellenspalte Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | AlsHacken |
Supported by the .NET Compact Framework. | ColWith |
Supported by the .NET Compact Framework. | Feld |
Supported by the .NET Compact Framework. | Order |
Supported by the .NET Compact Framework. | Tabelle |
Supported by the .NET Compact Framework. | TipText |
Supported by the .NET Compact Framework. | locked |
Supported by the .NET Compact Framework. | spaltenname |
Top

Expand image See Also

Reference

Tabellenspalte Class
Vertragsverwaltung.TKB.VV.Utils Namespace


Tabellenspalte.AlsHacken Property

Tabellenspalte.AlsHacken Property

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property AlsHacken() As Boolean
C#
public bool AlsHacken {get; set;}
C++
public:
property bool AlsHacken {
 bool get( );
 void set(
   bool value
 );
}
JScript
public function get AlsHacken() : boolean;
public function set AlsHacken(value : boolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Property AlsHacken() As Boolean
            Get
                Return m_alsHacken
            End Get
            Set(ByVal Value As Boolean)
                m_alsHacken = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Tabellenspalte Class
Tabellenspalte Members
Vertragsverwaltung.TKB.VV.Utils Namespace


Tabellenspalte.ColWith Property

Tabellenspalte.ColWith Property

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property ColWith() As Integer
C#
public int ColWith {get; set;}
C++
public:
property int ColWith {
 int get( );
 void set(
   int value
 );
}
JScript
public function get ColWith() : int;
public function set ColWith(value : int);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Property ColWith() As Integer
            Get
                Return m_Width
            End Get
            Set(ByVal Value As Integer)
                m_Width = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Tabellenspalte Class
Tabellenspalte Members
Vertragsverwaltung.TKB.VV.Utils Namespace


Tabellenspalte.Feld Property

Tabellenspalte.Feld Property

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property Feld() As String
C#
public string Feld {get; set;}
C++
public:
property String^ Feld {
 String^ get( );
 void set(
   String^ value
 );
}
JScript
public function get Feld() : String;
public function set Feld(value : String);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Property Feld() As String
            Get
                Return m_field
            End Get
            Set(ByVal Value As String)
                m_field = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Tabellenspalte Class
Tabellenspalte Members
Vertragsverwaltung.TKB.VV.Utils Namespace


Tabellenspalte.Order Property

Tabellenspalte.Order Property

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property Order() As Integer
C#
public int Order {get; set;}
C++
public:
property int Order {
 int get( );
 void set(
   int value
 );
}
JScript
public function get Order() : int;
public function set Order(value : int);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Property Order() As Integer
            Get
                Return m_Order
            End Get
            Set(ByVal Value As Integer)
                m_Order = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Tabellenspalte Class
Tabellenspalte Members
Vertragsverwaltung.TKB.VV.Utils Namespace


Tabellenspalte.Tabelle Property

Tabellenspalte.Tabelle Property

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property Tabelle() As String
C#
public string Tabelle {get; set;}
C++
public:
property String^ Tabelle {
 String^ get( );
 void set(
   String^ value
 );
}
JScript
public function get Tabelle() : String;
public function set Tabelle(value : String);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Property Tabelle() As String
            Get
                Return m_table
            End Get
            Set(ByVal Value As String)
                m_table = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Tabellenspalte Class
Tabellenspalte Members
Vertragsverwaltung.TKB.VV.Utils Namespace


Tabellenspalte.TipText Property

Tabellenspalte.TipText Property

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property TipText() As String
C#
public string TipText {get; set;}
C++
public:
property String^ TipText {
 String^ get( );
 void set(
   String^ value
 );
}
JScript
public function get TipText() : String;
public function set TipText(value : String);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Property TipText() As String
            Get
                Return m_tiptext
            End Get
            Set(ByVal Value As String)
                m_tiptext = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Tabellenspalte Class
Tabellenspalte Members
Vertragsverwaltung.TKB.VV.Utils Namespace


Tabellenspalte.locked Property

Tabellenspalte.locked Property

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property locked() As Boolean
C#
public bool locked {get; set;}
C++
public:
property bool locked {
 bool get( );
 void set(
   bool value
 );
}
JScript
public function get locked() : boolean;
public function set locked(value : boolean);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Property locked() As Boolean
            Get
                Return m_locked
            End Get
            Set(ByVal Value As Boolean)
                m_locked = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Tabellenspalte Class
Tabellenspalte Members
Vertragsverwaltung.TKB.VV.Utils Namespace


Tabellenspalte.spaltenname Property

Tabellenspalte.spaltenname Property

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property spaltenname() As String
C#
public string spaltenname {get; set;}
C++
public:
property String^ spaltenname {
 String^ get( );
 void set(
   String^ value
 );
}
JScript
public function get spaltenname() : String;
public function set spaltenname(value : String);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Property spaltenname() As String
            Get
                Return m_spaltenname
            End Get
            Set(ByVal Value As String)
                m_spaltenname = Value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Tabellenspalte Class
Tabellenspalte Members
Vertragsverwaltung.TKB.VV.Utils Namespace


Tabellenspalte Methods

Tabellenspalte Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Spaltentitel_aktualisieren | (Overloaded)
Supported by the .NET Compact Framework. | getspalte |
Top

Expand image See Also

Reference

Tabellenspalte Class
Vertragsverwaltung.TKB.VV.Utils Namespace


Tabellenspalte.Spaltentitel_aktualisieren (System.Object, System.String, System.Data.DataSet) Method

Tabellenspalte.Spaltentitel_aktualisieren (System.Object, System.String, System.Data.DataSet) Method
See Also
collapseAll image DropDown image

Expand image Overload List

Name | Description
public object Spaltentitel_aktualisieren(ref object, ref string, ref DataSet); |
public object Spaltentitel_aktualisieren(ref object, ref string, ref DataTable, bool); |

Expand image See Also

Reference

Tabellenspalte Class
Tabellenspalte Members
Vertragsverwaltung.TKB.VV.Utils Namespace


Tabellenspalte.getspalte Method

Tabellenspalte.getspalte Method

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function getspalte() As Object
C#
public object getspalte();
C++

public:
object^ getspalte()
JScript
public function getspalte() : object;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function getspalte()
            Try
                Dim myspalten As New MySpaltenTitel()
                myspalten.getspalte(Me.Tabelle, Me.Feld, Me.spaltenname, Me.locked, Me.ColWith, Me.Order, Me.AlsHacken, Me.TipText)
            Catch ex As Exception

            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Tabellenspalte Class
Tabellenspalte Members
Vertragsverwaltung.TKB.VV.Utils Namespace


Tabellenspalte Fields

Tabellenspalte Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_Order |
Supported by the .NET Compact Framework. | m_Width |
Supported by the .NET Compact Framework. | m_alsHacken |
Supported by the .NET Compact Framework. | m_field |
Supported by the .NET Compact Framework. | m_locked |
Supported by the .NET Compact Framework. | m_spaltenname |
Supported by the .NET Compact Framework. | m_table |
Supported by the .NET Compact Framework. | m_tiptext |
Top

Expand image See Also

Reference

Tabellenspalte Class
Vertragsverwaltung.TKB.VV.Utils Namespace


m_Order Variable

m_Order Variable

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_Order As Integer
C#
private int m_Order;
C++
private:
int m_Order;
JScript
private m_Order : int

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private m_Order As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Tabellenspalte Class
Tabellenspalte Members
Vertragsverwaltung.TKB.VV.Utils Namespace


m_Width Variable

m_Width Variable

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_Width As Integer
C#
private int m_Width;
C++
private:
int m_Width;
JScript
private m_Width : int

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private m_Width As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Tabellenspalte Class
Tabellenspalte Members
Vertragsverwaltung.TKB.VV.Utils Namespace


m_alsHacken Variable

m_alsHacken Variable

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_alsHacken As Boolean
C#
private bool m_alsHacken;
C++
private:
bool m_alsHacken;
JScript
private m_alsHacken : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private m_alsHacken As Boolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Tabellenspalte Class
Tabellenspalte Members
Vertragsverwaltung.TKB.VV.Utils Namespace


m_field Variable

m_field Variable

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_field As String
C#
private string m_field;
C++
private:
String^ m_field;
JScript
private m_field : String

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private m_field As String

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Tabellenspalte Class
Tabellenspalte Members
Vertragsverwaltung.TKB.VV.Utils Namespace


m_locked Variable

m_locked Variable

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_locked As Boolean
C#
private bool m_locked;
C++
private:
bool m_locked;
JScript
private m_locked : boolean

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private m_locked As Boolean

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Tabellenspalte Class
Tabellenspalte Members
Vertragsverwaltung.TKB.VV.Utils Namespace


m_spaltenname Variable

m_spaltenname Variable

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_spaltenname As String
C#
private string m_spaltenname;
C++
private:
String^ m_spaltenname;
JScript
private m_spaltenname : String

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private m_spaltenname As String

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Tabellenspalte Class
Tabellenspalte Members
Vertragsverwaltung.TKB.VV.Utils Namespace


m_table Variable

m_table Variable

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_table As String
C#
private string m_table;
C++
private:
String^ m_table;
JScript
private m_table : String

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private m_table As String

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Tabellenspalte Class
Tabellenspalte Members
Vertragsverwaltung.TKB.VV.Utils Namespace


m_tiptext Variable

m_tiptext Variable

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_tiptext As String
C#
private string m_tiptext;
C++
private:
String^ m_tiptext;
JScript
private m_tiptext : String

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private m_tiptext As String

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Tabellenspalte Class
Tabellenspalte Members
Vertragsverwaltung.TKB.VV.Utils Namespace


Vertragsverwaltung.TKB.VV.Vertrag Namespace

Vertragsverwaltung.TKB.VV.Vertrag Namespace

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Classes

 | Name | Description
Supported by the .NET Compact Framework. | Treenode_Descriptor | Treenode-Descriptor zur Befüllung des Tree-Node-Tags
Supported by the .NET Compact Framework. | clsDok |
Supported by the .NET Compact Framework. | clsKontakt |
Supported by the .NET Compact Framework. | clsKuendigungsfrist |
Supported by the .NET Compact Framework. | clsParentelemente |
Supported by the .NET Compact Framework. | clsPersonen |
Supported by the .NET Compact Framework. | clsVertragselement |
Supported by the .NET Compact Framework. | clsVertragspartner |
Supported by the .NET Compact Framework. | clsVertragsuebersicht_Strukturen |
Top

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0


Treenode_Descriptor Class

Treenode_Descriptor Class
See Also Members
collapseAll image DropDown image

Treenode-Descriptor zur Befüllung des Tree-Node-Tags

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class Treenode_Descriptor
C#
public class Treenode_Descriptor
C++

public ref class Treenode_Descriptor
JScript
public class Treenode_Descriptor

Expand image Remarks

Treenode-Tags werden mit den 2 Elementen (Type und Keyvalue) befüllt: Type: Vertragspartner, Vertragstyp Keyvalue: Primary-Key des Elementes

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.Vertrag.Treenode_Descriptor

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Treenode_Descriptor Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


Treenode_Descriptor Members

Treenode_Descriptor Members
See Also Constructors Properties
CollapseAll image DropDown image

Treenode-Descriptor zur Befüllung des Tree-Node-Tags

The following tables list the members exposed by the Treenode_Descriptor type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | Treenode_Descriptor Constructor |
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Keyvalue |
Supported by the .NET Compact Framework. | Type |
Supported by the .NET Compact Framework. | Vertragspartnernr |
Supported by the .NET Compact Framework. | Vertragstypnr |
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_keyvalue |
Supported by the .NET Compact Framework. | m_type |
Supported by the .NET Compact Framework. | m_vertragspartnernr |
Supported by the .NET Compact Framework. | m_vertragstypnr |
Top

Expand image See Also

Reference

Treenode_Descriptor Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


Treenode_Descriptor Constructor

Treenode_Descriptor Constructor

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal Type As String, _
   ByVal Keyvalue As Integer, _
   ByVal Vertragspartnernr As Integer, _
   ByVal vertragstypnr As Integer _
)
C#
public System.Void Treenode_Descriptor(
   string Type,
   int Keyvalue,
   int Vertragspartnernr,
   int vertragstypnr
);
C++

public:
System::Void Treenode_Descriptor(
   String^ Type,
   int Keyvalue,
   int Vertragspartnernr,
   int vertragstypnr
)
JScript
public function Treenode_Descriptor(
    Type : String,
    Keyvalue : int,
    Vertragspartnernr : int,
    vertragstypnr : int
);

Parameters

Type

Keyvalue

Vertragspartnernr

vertragstypnr

Expand image Source code

Visual Basic CopyCode image Copy Code
        Sub New(ByVal Type As String, ByVal Keyvalue As Integer, ByVal Vertragspartnernr As Integer, ByVal vertragstypnr As Integer)
            Me.Type = Type
            Me.Keyvalue = Keyvalue
            Me.Vertragspartnernr = Vertragspartnernr
            Me.Vertragstypnr = vertragstypnr
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Treenode_Descriptor Class
Treenode_Descriptor Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


Treenode_Descriptor Properties

Treenode_Descriptor Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Keyvalue |
Supported by the .NET Compact Framework. | Type |
Supported by the .NET Compact Framework. | Vertragspartnernr |
Supported by the .NET Compact Framework. | Vertragstypnr |
Top

Expand image See Also

Reference

Treenode_Descriptor Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


Treenode_Descriptor.Keyvalue Property

Treenode_Descriptor.Keyvalue Property

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property Keyvalue() As Integer
C#
public int Keyvalue {get; set;}
C++
public:
property int Keyvalue {
 int get( );
 void set(
   int value
 );
}
JScript
public function get Keyvalue() : int;
public function set Keyvalue(value : int);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Property Keyvalue() As Integer
            Get
                Return m_keyvalue
            End Get
            Set(ByVal value As Integer)
                m_keyvalue = value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Treenode_Descriptor Class
Treenode_Descriptor Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


Treenode_Descriptor.Type Property

Treenode_Descriptor.Type Property

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property Type() As String
C#
public string Type {get; set;}
C++
public:
property String^ Type {
 String^ get( );
 void set(
   String^ value
 );
}
JScript
public function get Type() : String;
public function set Type(value : String);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Property Type() As String
            Get
                Return m_type
            End Get
            Set(ByVal value As String)
                m_type = value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Treenode_Descriptor Class
Treenode_Descriptor Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


Treenode_Descriptor.Vertragspartnernr Property

Treenode_Descriptor.Vertragspartnernr Property

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property Vertragspartnernr() As Integer
C#
public int Vertragspartnernr {get; set;}
C++
public:
property int Vertragspartnernr {
 int get( );
 void set(
   int value
 );
}
JScript
public function get Vertragspartnernr() : int;
public function set Vertragspartnernr(value : int);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Property Vertragspartnernr() As Integer
            Get
                Return m_vertragspartnernr
            End Get
            Set(ByVal value As Integer)
                m_vertragspartnernr = value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Treenode_Descriptor Class
Treenode_Descriptor Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


Treenode_Descriptor.Vertragstypnr Property

Treenode_Descriptor.Vertragstypnr Property

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Property Vertragstypnr() As Integer
C#
public int Vertragstypnr {get; set;}
C++
public:
property int Vertragstypnr {
 int get( );
 void set(
   int value
 );
}
JScript
public function get Vertragstypnr() : int;
public function set Vertragstypnr(value : int);

Expand image Source code

Visual Basic CopyCode image Copy Code
        Property Vertragstypnr() As Integer
            Get
                Return m_vertragstypnr
            End Get
            Set(ByVal value As Integer)
                m_vertragstypnr = value
            End Set
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Treenode_Descriptor Class
Treenode_Descriptor Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


Treenode_Descriptor Fields

Treenode_Descriptor Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_keyvalue |
Supported by the .NET Compact Framework. | m_type |
Supported by the .NET Compact Framework. | m_vertragspartnernr |
Supported by the .NET Compact Framework. | m_vertragstypnr |
Top

Expand image See Also

Reference

Treenode_Descriptor Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


m_keyvalue Variable

m_keyvalue Variable

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_keyvalue As Integer
C#
private int m_keyvalue;
C++
private:
int m_keyvalue;
JScript
private m_keyvalue : int

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim m_keyvalue As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Treenode_Descriptor Class
Treenode_Descriptor Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


m_type Variable

m_type Variable

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_type As String
C#
private string m_type;
C++
private:
String^ m_type;
JScript
private m_type : String

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim m_type As String

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Treenode_Descriptor Class
Treenode_Descriptor Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


m_vertragspartnernr Variable

m_vertragspartnernr Variable

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_vertragspartnernr As Integer
C#
private int m_vertragspartnernr;
C++
private:
int m_vertragspartnernr;
JScript
private m_vertragspartnernr : int

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim m_vertragspartnernr As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Treenode_Descriptor Class
Treenode_Descriptor Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


m_vertragstypnr Variable

m_vertragstypnr Variable

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private m_vertragstypnr As Integer
C#
private int m_vertragstypnr;
C++
private:
int m_vertragstypnr;
JScript
private m_vertragstypnr : int

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim m_vertragstypnr As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Treenode_Descriptor Class
Treenode_Descriptor Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsDok Class

clsDok Class
See Also Members
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsDok
    Inherits clsDokument
C#
public class clsDok : clsDokument
C++

public ref class clsDok : public clsDokument^
JScript
public class clsDok
   extends clsDokument

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsDokument
Vertragsverwaltung.TKB.VV.Vertrag.clsDok

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDok Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsDok Members

clsDok Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

The following tables list the members exposed by the clsDok type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsDok Constructor | Purpose: Class constructor. (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | blobDocImage | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | daVersionsdatum | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | iDokumentNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | iDokumenttypNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMutierer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | iVertragselementNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | sBeschreibung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | sBezeichnung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sFilename | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | sOriginalFilename_incl_Path | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | sVersion | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | sVersionsNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Add_New | Neue Person einfügen
Supported by the .NET Compact Framework. | Create_Copy | Kopie eines Datensatzes erstellen.
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | Delete_Dokument | Kopie eines Datensatzes erstellen.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Get_Dokument | Dokument laden
Supported by the .NET Compact Framework. | Get_Dokumenttypen | Dokumenttypen laden und in der Datatable Dokumenttypdaten bereit stellen
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | Save_Data | Person sichern
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table. (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | DocMgmt |
Supported by the .NET Compact Framework. | Dokumenttyp |
Supported by the .NET Compact Framework. | Dokumenttypdaten |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsDok Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsDok Properties

clsDok Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | blobDocImage | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | daVersionsdatum | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | iDokumentNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | iDokumenttypNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMutierer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | iVertragselementNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | sBeschreibung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | sBezeichnung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sFilename | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | sOriginalFilename_incl_Path | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | sVersion | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | sVersionsNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Top

Expand image See Also

Reference

clsDok Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsDok Methods

clsDok Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Add_New | Neue Person einfügen
Supported by the .NET Compact Framework. | Create_Copy | Kopie eines Datensatzes erstellen.
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | Delete_Dokument | Kopie eines Datensatzes erstellen.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Get_Dokument | Dokument laden
Supported by the .NET Compact Framework. | Get_Dokumenttypen | Dokumenttypen laden und in der Datatable Dokumenttypdaten bereit stellen
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | Save_Data | Person sichern
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table. (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsDokument).
Top

Expand image See Also

Reference

clsDok Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsDok.Add_New Method

clsDok.Add_New Method

Neue Person einfügen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Add_New( _
   ByVal Vertragselementnr As Integer _
) As Integer
C#
public int Add_New(
   int Vertragselementnr
);
C++

public:
int Add_New(
   int Vertragselementnr
)
JScript
public function Add_New(
    Vertragselementnr : int
) : int;

Parameters

Vertragselementnr

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Add_New(ByVal Vertragselementnr As Integer) As Integer
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Dokument")
            db.Dispose()
            Me.iDokumentNr = New SqlInt32(CType(newkey, Int32))
            Me.iVertragselementNr = New SqlInt32(CType(Vertragselementnr, Int32))
            Me.iDokumenttypNr = New SqlInt32(CType(1, Int32))
            Me.sBezeichnung = New SqlString(CType("", String))
            Me.sBeschreibung = New SqlString(CType("", String))
            Me.sFilename = New SqlString(CType("", String))
            Me.sOriginalFilename_incl_Path = New SqlString(CType("", String))
            Me.sVersion = New SqlString(CType("", String))
            Me.daVersionsdatum = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
            Me.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.iSecurityLevelNr = New SqlInt32(CType(0, Int32))
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Return newkey
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDok Class
clsDok Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsDok.Create_Copy Method

clsDok.Create_Copy Method

Kopie eines Datensatzes erstellen.

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Create_Copy( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer
C#
public int Create_Copy(
   int Basenr
);
C++

public:
int Create_Copy(
   int Basenr
)
JScript
public function Create_Copy(
    Basenr : int
) : int;

Parameters

Basenr

Ursprungs-Person: Ist dieser Wert nicht 0, werden die Daten mit BaseNr zuerst gelesen

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Create_Copy(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Get_Dokument(Basenr)
            End If
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Dokument")
            db.Dispose()

            Me.cpMainConnectionProvider = Globals.conn
            Me.iDokumentNr = New SqlInt32(CType(newkey, Int32))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Return newkey
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDok Class
clsDok Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsDok.Delete_Dokument Method

clsDok.Delete_Dokument Method

Kopie eines Datensatzes erstellen.

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Delete_Dokument( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer
C#
public int Delete_Dokument(
   int Basenr
);
C++

public:
int Delete_Dokument(
   int Basenr
)
JScript
public function Delete_Dokument(
    Basenr : int
) : int;

Parameters

Basenr

Ursprungs-Person: Ist dieser Wert nicht 0, werden die Daten mit BaseNr zuerst gelesen

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Delete_Dokument(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Get_Dokument(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Me.bAktiv = New SqlBoolean(CType(False, Boolean))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDok Class
clsDok Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsDok.Get_Dokument Method

clsDok.Get_Dokument Method

Dokument laden

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Get_Dokument( _
   ByVal Nr As Integer _
) As Object
C#
public object Get_Dokument(
   int Nr
);
C++

public:
object^ Get_Dokument(
   int Nr
)
JScript
public function Get_Dokument(
    Nr : int
) : object;

Parameters

Nr

PersonNr

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Get_Dokument(ByVal Nr As Integer)
            Me.cpMainConnectionProvider = Globals.conn
            Me.iDokumentNr = New SqlInt32(CType(Nr, Int32))
            Globals.conn.OpenConnection()
            Me.SelectOne()
            Globals.conn.CloseConnection(True)
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDok Class
clsDok Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsDok.Get_Dokumenttypen Method

clsDok.Get_Dokumenttypen Method

Dokumenttypen laden und in der Datatable Dokumenttypdaten bereit stellen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Get_Dokumenttypen() As DataTable
C#
public DataTable Get_Dokumenttypen();
C++

public:
DataTable^ Get_Dokumenttypen()
JScript
public function Get_Dokumenttypen() : DataTable;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Get_Dokumenttypen() As DataTable
            Me.Dokumenttyp.cpMainConnectionProvider = Globals.conn
            Me.Dokumenttypdaten = Me.Dokumenttyp.SelectAll
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDok Class
clsDok Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsDok.Save_Data Method

clsDok.Save_Data Method

Person sichern

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Save_Data() As Integer
C#
public int Save_Data();
C++

public:
int Save_Data()
JScript
public function Save_Data() : int;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Save_Data() As Integer
            Me.cpMainConnectionProvider = Globals.conn
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Return Me.iDokumentNr.Value
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDok Class
clsDok Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsDok Fields

clsDok Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | DocMgmt |
Supported by the .NET Compact Framework. | Dokumenttyp |
Supported by the .NET Compact Framework. | Dokumenttypdaten |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsDok Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


DocMgmt Variable

DocMgmt Variable

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private DocMgmt As MyDocMgmt
C#
private MyDocMgmt DocMgmt;
C++
private:
MyDocMgmt^ DocMgmt;
JScript
private DocMgmt : MyDocMgmt

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private DocMgmt As New TKB.VV.Utils.MyDocMgmt

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDok Class
clsDok Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


Dokumenttyp Variable

Dokumenttyp Variable

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Dokumenttyp As clsDokumenttyp
C#
private clsDokumenttyp Dokumenttyp;
C++
private:
clsDokumenttyp^ Dokumenttyp;
JScript
private Dokumenttyp : clsDokumenttyp

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Dokumenttyp As New TKB.VV.DB.clsDokumenttyp

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDok Class
clsDok Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


Dokumenttypdaten Variable

Dokumenttypdaten Variable

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Dokumenttypdaten As DataTable
C#
public DataTable Dokumenttypdaten;
C++
public:
DataTable^ Dokumenttypdaten;
JScript
public Dokumenttypdaten : DataTable

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Dokumenttypdaten As DataTable

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDok Class
clsDok Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsKontakt Class

clsKontakt Class
See Also Members
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsKontakt
    Inherits clsVertragskontakt
C#
public class clsKontakt : clsVertragskontakt
C++

public ref class clsKontakt : public clsVertragskontakt^
JScript
public class clsKontakt
   extends clsVertragskontakt

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt
Vertragsverwaltung.TKB.VV.Vertrag.clsKontakt

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakt Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsKontakt Members

clsKontakt Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

The following tables list the members exposed by the clsKontakt type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsKontakt Constructor | Purpose: Class constructor. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | bIntern | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iKontakttypNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | iMandantnr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | iMutierer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | iPersonNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | iVertragsKontaktNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | iVertragselementNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | sBemerkung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Add_New | Neue Kuendigungsfrist einfügen
Supported by the .NET Compact Framework. | Create_Copy | Kopie eines Datensatzes erstellen.
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | Delete_Vertragskontakt | Kopie eines Datensatzes erstellen.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Get_Vertragskontakt | Kuendigungsfrist lesen
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | Save_Data | Daten sichern
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsKontakt Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsKontakt Properties

clsKontakt Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | bIntern | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iKontakttypNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | iMandantnr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | iMutierer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | iPersonNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | iVertragsKontaktNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | iVertragselementNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | sBemerkung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsKontakt Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsKontakt Methods

clsKontakt Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Add_New | Neue Kuendigungsfrist einfügen
Supported by the .NET Compact Framework. | Create_Copy | Kopie eines Datensatzes erstellen.
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | Delete_Vertragskontakt | Kopie eines Datensatzes erstellen.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Get_Vertragskontakt | Kuendigungsfrist lesen
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | Save_Data | Daten sichern
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt).
Top

Expand image See Also

Reference

clsKontakt Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsKontakt.Add_New Method

clsKontakt.Add_New Method

Neue Kuendigungsfrist einfügen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Add_New( _
   ByVal Vertragselementnr As Integer _
) As Integer
C#
public int Add_New(
   int Vertragselementnr
);
C++

public:
int Add_New(
   int Vertragselementnr
)
JScript
public function Add_New(
    Vertragselementnr : int
) : int;

Parameters

Vertragselementnr

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Add_New(ByVal Vertragselementnr As Integer) As Integer
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Vertragskontakt")
            db.Dispose()
            Me.iVertragsKontaktNr = New SqlInt32(CType(newkey, Int32))
            Me.iVertragselementNr = New SqlInt32(CType(Vertragselementnr, Int32))
            Me.iKontakttypNr = New SqlInt32(CType(0, Int32))
            Me.iPersonNr = New SqlInt32(CType(0, Int32))
            Me.bIntern = New SqlBoolean(CType(False, Boolean))
            Me.sBemerkung = New SqlString(CType("", String))
            Me.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.iSecurityLevelNr = New SqlInt32(CType(0, Int32))
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Return newkey
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakt Class
clsKontakt Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsKontakt.Create_Copy Method

clsKontakt.Create_Copy Method

Kopie eines Datensatzes erstellen.

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Create_Copy( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer
C#
public int Create_Copy(
   int Basenr
);
C++

public:
int Create_Copy(
   int Basenr
)
JScript
public function Create_Copy(
    Basenr : int
) : int;

Parameters

Basenr

Ursprungs-Person: Ist dieser Wert nicht 0, werden die Daten mit BaseNr zuerst gelesen

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Create_Copy(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Me.Get_Vertragskontakt(Basenr)
            End If
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Vertragskontakt")
            db.Dispose()

            Me.cpMainConnectionProvider = Globals.conn
            Me.iVertragsKontaktNr = New SqlInt32(CType(newkey, Int32))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Return newkey
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakt Class
clsKontakt Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsKontakt.Delete_Vertragskontakt Method

clsKontakt.Delete_Vertragskontakt Method

Kopie eines Datensatzes erstellen.

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Delete_Vertragskontakt( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer
C#
public int Delete_Vertragskontakt(
   int Basenr
);
C++

public:
int Delete_Vertragskontakt(
   int Basenr
)
JScript
public function Delete_Vertragskontakt(
    Basenr : int
) : int;

Parameters

Basenr

Optional. The default value is 0.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Delete_Vertragskontakt(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Me.Get_Vertragskontakt(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Me.bAktiv = New SqlBoolean(CType(False, Boolean))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakt Class
clsKontakt Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsKontakt.Get_Vertragskontakt Method

clsKontakt.Get_Vertragskontakt Method

Kuendigungsfrist lesen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Get_Vertragskontakt( _
   ByVal Nr As Integer _
) As Object
C#
public object Get_Vertragskontakt(
   int Nr
);
C++

public:
object^ Get_Vertragskontakt(
   int Nr
)
JScript
public function Get_Vertragskontakt(
    Nr : int
) : object;

Parameters

Nr

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Get_Vertragskontakt(ByVal Nr As Integer)
            Me.cpMainConnectionProvider = Globals.conn
            Me.iVertragsKontaktNr = New SqlInt32(CType(Nr, Int32))
            Globals.conn.OpenConnection()
            Me.SelectOne()
            Globals.conn.CloseConnection(True)
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakt Class
clsKontakt Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsKontakt.Save_Data Method

clsKontakt.Save_Data Method

Daten sichern

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Save_Data() As Integer
C#
public int Save_Data();
C++

public:
int Save_Data()
JScript
public function Save_Data() : int;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Save_Data() As Integer
            Me.cpMainConnectionProvider = Globals.conn
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Return Me.iVertragsKontaktNr.Value
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKontakt Class
clsKontakt Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsKontakt Fields

clsKontakt Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsKontakt Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsKuendigungsfrist Class

clsKuendigungsfrist Class
See Also Members
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsKuendigungsfrist
    Inherits clsKuendigungsfrist
C#
public class clsKuendigungsfrist : clsKuendigungsfrist
C++

public ref class clsKuendigungsfrist : public clsKuendigungsfrist^
JScript
public class clsKuendigungsfrist
   extends clsKuendigungsfrist

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist
Vertragsverwaltung.TKB.VV.Vertrag.clsKuendigungsfrist

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsKuendigungsfrist Members

clsKuendigungsfrist Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

The following tables list the members exposed by the clsKuendigungsfrist type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsKuendigungsfrist Constructor | Purpose: Class constructor. (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | daKuendigungstermin | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iKuendigungsfristNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | iMutierer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | iVertragselementNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | iVertragselementNrOld | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | sBemerkung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sKuendigungsfirst | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | sVarZeitspanne | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Add_New | Neue Kuendigungsfrist einfügen
Supported by the .NET Compact Framework. | Create_Copy | Kopie eines Datensatzes erstellen.
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | DeleteAllWVertragselementNrLogic | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'VertragselementNr' (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | Delete_Kuendigungsfrist | Kopie eines Datensatzes erstellen.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Get_Kuendigungsfrist | Kuendigungsfrist lesen
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | Save_Data | Daten sichern
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table. (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | SelectAllWVertragselementNrLogic | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'VertragselementNr' (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | UpdateAllWVertragselementNrLogic | Purpose: Update method for updating one or more rows using the Foreign Key 'VertragselementNr. This method will Update one or more existing rows in the database. It will reset the field 'VertragselementNr' in all rows which have as value for this field the value as set in property 'iVertragselementNrOld' to the value as set in property 'iVertragselementNr'. (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsKuendigungsfrist Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsKuendigungsfrist Properties

clsKuendigungsfrist Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | daKuendigungstermin | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iKuendigungsfristNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | iMutierer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | iVertragselementNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | iVertragselementNrOld | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | sBemerkung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sKuendigungsfirst | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | sVarZeitspanne | (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Top

Expand image See Also

Reference

clsKuendigungsfrist Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsKuendigungsfrist Methods

clsKuendigungsfrist Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Add_New | Neue Kuendigungsfrist einfügen
Supported by the .NET Compact Framework. | Create_Copy | Kopie eines Datensatzes erstellen.
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | DeleteAllWVertragselementNrLogic | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'VertragselementNr' (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | Delete_Kuendigungsfrist | Kopie eines Datensatzes erstellen.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Get_Kuendigungsfrist | Kuendigungsfrist lesen
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | Save_Data | Daten sichern
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table. (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | SelectAllWVertragselementNrLogic | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'VertragselementNr' (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Supported by the .NET Compact Framework. | UpdateAllWVertragselementNrLogic | Purpose: Update method for updating one or more rows using the Foreign Key 'VertragselementNr. This method will Update one or more existing rows in the database. It will reset the field 'VertragselementNr' in all rows which have as value for this field the value as set in property 'iVertragselementNrOld' to the value as set in property 'iVertragselementNr'. (inherited from Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist).
Top

Expand image See Also

Reference

clsKuendigungsfrist Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsKuendigungsfrist.Add_New Method

clsKuendigungsfrist.Add_New Method

Neue Kuendigungsfrist einfügen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Add_New( _
   ByVal Vertragselementnr As Integer _
) As Integer
C#
public int Add_New(
   int Vertragselementnr
);
C++

public:
int Add_New(
   int Vertragselementnr
)
JScript
public function Add_New(
    Vertragselementnr : int
) : int;

Parameters

Vertragselementnr

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Add_New(ByVal Vertragselementnr As Integer) As Integer
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Kuendigungsfrist")
            db.Dispose()
            Me.iKuendigungsfristNr = New SqlInt32(CType(newkey, Int32))
            Me.iVertragselementNr = New SqlInt32(CType(Vertragselementnr, Int32))
            Me.sVarZeitspanne = New SqlString(CType("", String))
            Me.sKuendigungsfirst = New SqlString(CType("", String))
            Me.sBemerkung = New SqlString(CType("", String))
            Me.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.iSecurityLevelNr = New SqlInt32(CType(0, Int32))
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Return newkey
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsKuendigungsfrist.Create_Copy Method

clsKuendigungsfrist.Create_Copy Method

Kopie eines Datensatzes erstellen.

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Create_Copy( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer
C#
public int Create_Copy(
   int Basenr
);
C++

public:
int Create_Copy(
   int Basenr
)
JScript
public function Create_Copy(
    Basenr : int
) : int;

Parameters

Basenr

Ursprungs-Person: Ist dieser Wert nicht 0, werden die Daten mit BaseNr zuerst gelesen

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Create_Copy(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Me.Get_Kuendigungsfrist(Basenr)
            End If
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Kuendigungsfrist")
            db.Dispose()

            Me.cpMainConnectionProvider = Globals.conn
            Me.iKuendigungsfristNr = New SqlInt32(CType(newkey, Int32))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Return newkey
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsKuendigungsfrist.Delete_Kuendigungsfrist Method

clsKuendigungsfrist.Delete_Kuendigungsfrist Method

Kopie eines Datensatzes erstellen.

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Delete_Kuendigungsfrist( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer
C#
public int Delete_Kuendigungsfrist(
   int Basenr
);
C++

public:
int Delete_Kuendigungsfrist(
   int Basenr
)
JScript
public function Delete_Kuendigungsfrist(
    Basenr : int
) : int;

Parameters

Basenr

Optional. The default value is 0.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Delete_Kuendigungsfrist(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Get_Kuendigungsfrist(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Me.bAktiv = New SqlBoolean(CType(False, Boolean))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsKuendigungsfrist.Get_Kuendigungsfrist Method

clsKuendigungsfrist.Get_Kuendigungsfrist Method

Kuendigungsfrist lesen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Get_Kuendigungsfrist( _
   ByVal Nr As Integer _
) As Object
C#
public object Get_Kuendigungsfrist(
   int Nr
);
C++

public:
object^ Get_Kuendigungsfrist(
   int Nr
)
JScript
public function Get_Kuendigungsfrist(
    Nr : int
) : object;

Parameters

Nr

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Get_Kuendigungsfrist(ByVal Nr As Integer)
            Me.cpMainConnectionProvider = Globals.conn
            Me.iKuendigungsfristNr = New SqlInt32(CType(nr, Int32))
            Globals.conn.OpenConnection()
            Me.SelectOne()
            Globals.conn.CloseConnection(True)
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsKuendigungsfrist.Save_Data Method

clsKuendigungsfrist.Save_Data Method

Daten sichern

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Save_Data() As Integer
C#
public int Save_Data();
C++

public:
int Save_Data()
JScript
public function Save_Data() : int;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Save_Data() As Integer
            Me.cpMainConnectionProvider = Globals.conn
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Return Me.iKuendigungsfristNr.Value
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsKuendigungsfrist Class
clsKuendigungsfrist Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsKuendigungsfrist Fields

clsKuendigungsfrist Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsKuendigungsfrist Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsParentelemente Class

clsParentelemente Class
See Also Members
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsParentelemente
C#
public class clsParentelemente
C++

public ref class clsParentelemente
JScript
public class clsParentelemente

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.Vertrag.clsParentelemente

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsParentelemente Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsParentelemente Members

clsParentelemente Members
See Also Methods
CollapseAll image DropDown image

The following tables list the members exposed by the clsParentelemente type.

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Load_Treedata | Laden der Treedaten und Tree aufbauen
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | Treedata |
Top

Expand image See Also

Reference

clsParentelemente Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsParentelemente Methods

clsParentelemente Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Load_Treedata | Laden der Treedaten und Tree aufbauen
Top

Expand image See Also

Reference

clsParentelemente Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsParentelemente.Load_Treedata Method

clsParentelemente.Load_Treedata Method

Laden der Treedaten und Tree aufbauen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Load_Treedata( _
   ByVal vertragspartnernr As Object _
) As DataTable
C#
public DataTable Load_Treedata(
   object vertragspartnernr
);
C++

public:
DataTable^ Load_Treedata(
   object^ vertragspartnernr
)
JScript
public function Load_Treedata(
    vertragspartnernr : object
) : DataTable;

Parameters

vertragspartnernr

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Load_Treedata(ByVal vertragspartnernr) As DataTable
            Dim selectcommand As New SqlCommand
            Dim connection As New SqlConnection()
            Dim da As New SqlDataAdapter("", connection)

            selectcommand.CommandText = "my_vertragselement_parentelemente"
            selectcommand.Parameters.Add("@vertragspartnernr", SqlDbType.Int, 4)
            selectcommand.Parameters.Add("@Mitarbeiternr", SqlDbType.Int, 4)
            selectcommand.Parameters(0).Value = vertragspartnernr
            selectcommand.Parameters(1).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value

            selectcommand.CommandType = CommandType.StoredProcedure
            selectcommand.Connection = connection
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.SelectCommand = selectcommand
                da.Fill(Treedata, "Tree")
                Return Treedata.Tables(0)
            Catch ex As Exception
            Finally
                connection.Close()
                da.Dispose()
                selectcommand.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsParentelemente Class
clsParentelemente Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsParentelemente Fields

clsParentelemente Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | Treedata |
Top

Expand image See Also

Reference

clsParentelemente Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


Treedata Variable

Treedata Variable

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Treedata As DataSet
C#
private DataSet Treedata;
C++
private:
DataSet^ Treedata;
JScript
private Treedata : DataSet

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim Treedata As New DataSet

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsParentelemente Class
clsParentelemente Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsPersonen Class

clsPersonen Class
See Also Members
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsPersonen
    Inherits clsPerson
C#
public class clsPersonen : clsPerson
C++

public ref class clsPersonen : public clsPerson^
JScript
public class clsPersonen
   extends clsPerson

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsPerson
Vertragsverwaltung.TKB.VV.Vertrag.clsPersonen

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPersonen Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsPersonen Members

clsPersonen Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

The following tables list the members exposed by the clsPersonen type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsPersonen Constructor | Purpose: Class constructor. (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | iMutierer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | iPersonNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | iVertragspartnernr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | sBemerkung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sEMail | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | sInternet | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | sName | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | sOrt | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | sPlz | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | sPostfach | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | sStrasse | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | sTelefax | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | sTelefon | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | sVorname | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Add_New | Neue Person einfügen
Supported by the .NET Compact Framework. | Create_Copy | Kopie eines Datensatzes erstellen.
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | Delete_Kontakt | Kopie eines Datensatzes erstellen.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Get_Person | Person lesen
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | Save_Data | Person sichern
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table. (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsPersonen Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsPersonen Properties

clsPersonen Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | iMutierer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | iPersonNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | iVertragspartnernr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | sBemerkung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sEMail | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | sInternet | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | sName | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | sOrt | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | sPlz | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | sPostfach | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | sStrasse | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | sTelefax | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | sTelefon | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | sVorname | (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Top

Expand image See Also

Reference

clsPersonen Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsPersonen Methods

clsPersonen Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Add_New | Neue Person einfügen
Supported by the .NET Compact Framework. | Create_Copy | Kopie eines Datensatzes erstellen.
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | Delete_Kontakt | Kopie eines Datensatzes erstellen.
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | Get_Person | Person lesen
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | Save_Data | Person sichern
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table. (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsPerson).
Top

Expand image See Also

Reference

clsPersonen Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsPersonen.Add_New Method

clsPersonen.Add_New Method

Neue Person einfügen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Add_New( _
   ByVal Vertragspartnernr As Integer _
) As Integer
C#
public int Add_New(
   int Vertragspartnernr
);
C++

public:
int Add_New(
   int Vertragspartnernr
)
JScript
public function Add_New(
    Vertragspartnernr : int
) : int;

Parameters

Vertragspartnernr

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Add_New(ByVal Vertragspartnernr As Integer) As Integer
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Person")
            db.Dispose()
            Me.iPersonNr = New SqlInt32(CType(newkey, Int32))
            Me.iVertragspartnernr = New SqlInt32(CType(Vertragspartnernr, Int32))
            Me.sName = New SqlString(CType("", String))
            Me.sVorname = New SqlString(CType("", String))
            Me.sStrasse = New SqlString(CType("", String))
            Me.sPostfach = New SqlString(CType("", String))
            Me.sPlz = New SqlString(CType("", String))
            Me.sOrt = New SqlString(CType("", String))
            Me.sTelefon = New SqlString(CType("", String))
            Me.sTelefax = New SqlString(CType("", String))
            Me.sEMail = New SqlString(CType("", String))
            Me.sInternet = New SqlString(CType("", String))
            Me.sBemerkung = New SqlString(CType("", String))
            Me.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.iSecurityLevelNr = New SqlInt32(CType(0, Int32))
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Return newkey
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPersonen Class
clsPersonen Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsPersonen.Create_Copy Method

clsPersonen.Create_Copy Method

Kopie eines Datensatzes erstellen.

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Create_Copy( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer
C#
public int Create_Copy(
   int Basenr
);
C++

public:
int Create_Copy(
   int Basenr
)
JScript
public function Create_Copy(
    Basenr : int
) : int;

Parameters

Basenr

Ursprungs-Person: Ist dieser Wert nicht 0, werden die Daten mit BaseNr zuerst gelesen

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Create_Copy(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Get_Person(Basenr)
            End If
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Person")
            db.Dispose()

            Me.cpMainConnectionProvider = Globals.conn
            Me.iPersonNr = New SqlInt32(CType(newkey, Int32))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Return newkey
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPersonen Class
clsPersonen Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsPersonen.Delete_Kontakt Method

clsPersonen.Delete_Kontakt Method

Kopie eines Datensatzes erstellen.

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Delete_Kontakt( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer
C#
public int Delete_Kontakt(
   int Basenr
);
C++

public:
int Delete_Kontakt(
   int Basenr
)
JScript
public function Delete_Kontakt(
    Basenr : int
) : int;

Parameters

Basenr

Ursprungs-Person: Ist dieser Wert nicht 0, werden die Daten mit BaseNr zuerst gelesen

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Delete_Kontakt(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Get_Person(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Me.bAktiv = New SqlBoolean(CType(False, Boolean))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPersonen Class
clsPersonen Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsPersonen.Get_Person Method

clsPersonen.Get_Person Method

Person lesen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Get_Person( _
   ByVal Nr As Integer _
) As Object
C#
public object Get_Person(
   int Nr
);
C++

public:
object^ Get_Person(
   int Nr
)
JScript
public function Get_Person(
    Nr : int
) : object;

Parameters

Nr

PersonNr

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Get_Person(ByVal Nr As Integer)
            Me.cpMainConnectionProvider = Globals.conn
            Me.iPersonNr = New SqlInt32(CType(Nr, Int32))
            Globals.conn.OpenConnection()
            Me.SelectOne()
            Globals.conn.CloseConnection(True)
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPersonen Class
clsPersonen Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsPersonen.Save_Data Method

clsPersonen.Save_Data Method

Person sichern

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Save_Data() As Integer
C#
public int Save_Data();
C++

public:
int Save_Data()
JScript
public function Save_Data() : int;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Save_Data() As Integer
            Me.cpMainConnectionProvider = Globals.conn
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Return Me.iPersonNr.Value
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsPersonen Class
clsPersonen Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsPersonen Fields

clsPersonen Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsPersonen Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragselement Class

clsVertragselement Class
See Also Members
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsVertragselement
    Inherits clsVertragselement
C#
public class clsVertragselement : clsVertragselement
C++

public ref class clsVertragselement : public clsVertragselement^
JScript
public class clsVertragselement
   extends clsVertragselement

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsVertragselement
Vertragsverwaltung.TKB.VV.Vertrag.clsVertragselement

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragselement Members

clsVertragselement Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

The following tables list the members exposed by the clsVertragselement type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsVertragselement Constructor |
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Vertragspartnername |
Supported by the .NET Compact Framework. | bAktiv | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | bBefristet_Unbefristet | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | daGekuendigt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | daGekuendigt_per | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | daMindestvertragsdauer_bis | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | daUnterzeichnet_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | daVersionsdatum | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | daVertragsablauf | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | daVertragsbeginn | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMutierer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | iParentID | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | iVertragselementnr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | iVertragspartnerNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | iVertragstypNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | sBeschreibung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | sBezeichnung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sNummer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | sSuchbegriffe | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | sVersion | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Add_New | Neue Person einfügen
Supported by the .NET Compact Framework. | Create_Copy | Kopie eines Datensatzes erstellen.
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | Delete_Vertragselement | Kopie eines Datensatzes erstellen.
Supported by the .NET Compact Framework. | Get_Kuendigungsfristen | (Overloaded) Kündiguntsfristen lasen und dem Grid übergeben
Supported by the .NET Compact Framework. | Get_Vertragselement |
Supported by the .NET Compact Framework. | Get_Vertragskontakte | (Overloaded) Kontakte auslesen und dem TrueDBGrid übergeben
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | Save_Data | Vertragselement sichern
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | Suchen | Suchen eines Vertragselementes
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | Vertragspartner_suchen | Vertragspartner für das Vertragselement suchen
Supported by the .NET Compact Framework. | dispose | (Overloaded)
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | Kuendigungsfrist |
Supported by the .NET Compact Framework. | Kuendigungsfristen |
Supported by the .NET Compact Framework. | Parentelemente |
Supported by the .NET Compact Framework. | Vertragselement |
Supported by the .NET Compact Framework. | Vertragskontakt |
Supported by the .NET Compact Framework. | Vertragskontakte |
Supported by the .NET Compact Framework. | Vertragspartner |
Supported by the .NET Compact Framework. | Vertragstypen |
Supported by the .NET Compact Framework. | daten | Vertragselement lesen
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | vertragstyp |
Top

Expand image See Also

Reference

clsVertragselement Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragselement Constructor

clsVertragselement Constructor

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void clsVertragselement();
C++

public:
System::Void clsVertragselement()
JScript
public function clsVertragselement();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Sub New()
            vertragstyp.cpMainConnectionProvider = Globals.conn
            Vertragstypen = vertragstyp.SelectAll

        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragselement Properties

clsVertragselement Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Vertragspartnername |
Supported by the .NET Compact Framework. | bAktiv | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | bBefristet_Unbefristet | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | daGekuendigt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | daGekuendigt_per | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | daMindestvertragsdauer_bis | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | daUnterzeichnet_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | daVersionsdatum | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | daVertragsablauf | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | daVertragsbeginn | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMutierer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | iParentID | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | iVertragselementnr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | iVertragspartnerNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | iVertragstypNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | sBeschreibung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | sBezeichnung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sNummer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | sSuchbegriffe | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | sVersion | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Top

Expand image See Also

Reference

clsVertragselement Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragselement.Vertragspartnername Property

clsVertragselement.Vertragspartnername Property

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Vertragspartnername() As String
C#
public string Vertragspartnername {get;}
C++
public:
property String^ Vertragspartnername {
 String^ get( );
}
JScript
public function get Vertragspartnername() : String;

Expand image Source code

Visual Basic CopyCode image Copy Code
        ReadOnly Property Vertragspartnername() As String
            Get
                Try
                    Return Vertragspartner.Get_Vertragspartnername(Me.iVertragspartnerNr.Value)
                Catch ex As Exception
                    Return ""
                End Try
            End Get
        End Property

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragselement Methods

clsVertragselement Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Add_New | Neue Person einfügen
Supported by the .NET Compact Framework. | Create_Copy | Kopie eines Datensatzes erstellen.
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | Delete_Vertragselement | Kopie eines Datensatzes erstellen.
Supported by the .NET Compact Framework. | Get_Kuendigungsfristen | (Overloaded) Kündiguntsfristen lasen und dem Grid übergeben
Supported by the .NET Compact Framework. | Get_Vertragselement |
Supported by the .NET Compact Framework. | Get_Vertragskontakte | (Overloaded) Kontakte auslesen und dem TrueDBGrid übergeben
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | Save_Data | Vertragselement sichern
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | Suchen | Suchen eines Vertragselementes
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragselement).
Supported by the .NET Compact Framework. | Vertragspartner_suchen | Vertragspartner für das Vertragselement suchen
Supported by the .NET Compact Framework. | dispose | (Overloaded)
Top

Expand image See Also

Reference

clsVertragselement Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragselement.Add_New Method

clsVertragselement.Add_New Method

Neue Person einfügen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Add_New( _
   ByVal Vertragspartnernr As Integer _
) As Integer
C#
public int Add_New(
   int Vertragspartnernr
);
C++

public:
int Add_New(
   int Vertragspartnernr
)
JScript
public function Add_New(
    Vertragspartnernr : int
) : int;

Parameters

Vertragspartnernr

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Add_New(ByVal Vertragspartnernr As Integer) As Integer
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Vertragselement")
            db.Dispose()
            Me.iVertragselementnr = New SqlInt32(CType(newkey, Int32))
            Me.iVertragstypNr = New SqlInt32(CType(1, Int32))
            Me.iVertragspartnerNr = New SqlInt32(CType(Vertragspartnernr, Int32))
            Me.iParentID = New SqlInt32(CType(0, Int32))
            Me.sBezeichnung = New SqlString(CType("", String))
            Me.sBeschreibung = New SqlString(CType("", String))
            Me.sVersion = New SqlString(CType("", String))
            Me.daVersionsdatum = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
            Me.daVertragsbeginn = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
            Me.daVertragsablauf = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
            Me.daMindestvertragsdauer_bis = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
            Me.daUnterzeichnet_am = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
            Me.daGekuendigt_am = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
            Me.daGekuendigt_per = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
            Me.sNummer = New SqlString(CType("", String))
            Me.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.iSecurityLevelNr = New SqlInt32(CType(0, Int32))
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Return newkey
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragselement.Create_Copy Method

clsVertragselement.Create_Copy Method

Kopie eines Datensatzes erstellen.

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Create_Copy( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer
C#
public int Create_Copy(
   int Basenr
);
C++

public:
int Create_Copy(
   int Basenr
)
JScript
public function Create_Copy(
    Basenr : int
) : int;

Parameters

Basenr

Ursprungs-Person: Ist dieser Wert nicht 0, werden die Daten mit BaseNr zuerst gelesen

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Create_Copy(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Get_Vertragselement(Basenr)
            End If
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Vertragselement")
            db.Dispose()

            Me.cpMainConnectionProvider = Globals.conn
            Me.iVertragselementnr = New SqlInt32(CType(newkey, Int32))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Return newkey
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragselement.Delete_Vertragselement Method

clsVertragselement.Delete_Vertragselement Method

Kopie eines Datensatzes erstellen.

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Delete_Vertragselement( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer
C#
public int Delete_Vertragselement(
   int Basenr
);
C++

public:
int Delete_Vertragselement(
   int Basenr
)
JScript
public function Delete_Vertragselement(
    Basenr : int
) : int;

Parameters

Basenr

Ursprungs-Person: Ist dieser Wert nicht 0, werden die Daten mit BaseNr zuerst gelesen

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Delete_Vertragselement(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Get_Vertragselement(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Me.bAktiv = New SqlBoolean(CType(False, Boolean))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragselement.Get_Kuendigungsfristen (C1.Win.C1TrueDBGrid.C1TrueDBGrid) Method

clsVertragselement.Get_Kuendigungsfristen (C1.Win.C1TrueDBGrid.C1TrueDBGrid) Method
See Also
collapseAll image DropDown image

Kündiguntsfristen lasen und dem Grid übergeben

Expand image Overload List

Name | Description
public object Get_Kuendigungsfristen(ref C1TrueDBGrid); | Kündiguntsfristen lasen und dem Grid übergeben
public object Get_Kuendigungsfristen(ref C1TrueDBGrid, int); | Kündiguntsfristen lasen und dem Grid übergeben

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragselement.Get_Vertragselement Method

clsVertragselement.Get_Vertragselement Method

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Get_Vertragselement( _
   ByVal Nr As Integer _
) As Object
C#
public object Get_Vertragselement(
   int Nr
);
C++

public:
object^ Get_Vertragselement(
   int Nr
)
JScript
public function Get_Vertragselement(
    Nr : int
) : object;

Parameters

Nr

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Get_Vertragselement(ByVal Nr As Integer)
            Me.cpMainConnectionProvider = Globals.conn
            Me.iVertragselementnr = New SqlInt32(CType(Nr, Int32))
            Globals.conn.OpenConnection()
            Me.daten = Me.SelectOne()
            Globals.conn.CloseConnection(True)
            Try
                Vertragspartner.Get_Partner(Me.iVertragspartnerNr.Value)
            Catch ex As Exception
            End Try

        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragselement.Get_Vertragskontakte (C1.Win.C1TrueDBGrid.C1TrueDBGrid) Method

clsVertragselement.Get_Vertragskontakte (C1.Win.C1TrueDBGrid.C1TrueDBGrid) Method
See Also
collapseAll image DropDown image

Kontakte auslesen und dem TrueDBGrid übergeben

Expand image Overload List

Name | Description
public object Get_Vertragskontakte(ref C1TrueDBGrid); | Kontakte auslesen und dem TrueDBGrid übergeben
public object Get_Vertragskontakte(ref C1TrueDBGrid, int); | Kontakte auslesen und dem TrueDBGrid übergeben

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragselement.Save_Data Method

clsVertragselement.Save_Data Method

Vertragselement sichern

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Save_Data() As Integer
C#
public int Save_Data();
C++

public:
int Save_Data()
JScript
public function Save_Data() : int;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Save_Data() As Integer
            Me.cpMainConnectionProvider = Globals.conn
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragselement.Suchen Method

clsVertragselement.Suchen Method

Suchen eines Vertragselementes

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Suchen( _
   ByRef Vertragselementnr As Integer _
) As Object
C#
public object Suchen(
   ref int Vertragselementnr
);
C++

public:
object^ Suchen(
   int& Vertragselementnr
)
JScript
public function Suchen(
    Vertragselementnr : int
) : object;

Parameters

Vertragselementnr

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Suchen(ByRef Vertragselementnr As Integer)
            Dim vesuche As New frmVertragselementSuche
            vesuche.ShowDialog()
            Try
                If vesuche.DialogResult = DialogResult.OK Then
                    Vertragselementnr = vesuche.Vertragselementnr
                    Return True
                Else
                    Vertragselementnr = -1
                    Return False
                End If
            Catch ex As Exception
                Return False
            Finally
                vesuche.Dispose()
            End Try

        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragselement.Vertragspartner_suchen Method

clsVertragselement.Vertragspartner_suchen Method

Vertragspartner für das Vertragselement suchen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Vertragspartner_suchen( _
   ByRef Vertragspartnernummer As Integer, _
   ByRef Partnername As TextBox _
) As Boolean
C#
public bool Vertragspartner_suchen(
   ref int Vertragspartnernummer,
   ref TextBox Partnername
);
C++

public:
bool Vertragspartner_suchen(
   int& Vertragspartnernummer,
   TextBox^& Partnername
)
JScript
public function Vertragspartner_suchen(
    Vertragspartnernummer : int,
    Partnername : TextBox
) : boolean;

Parameters

Vertragspartnernummer

Partnername

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Vertragspartner_suchen(ByRef Vertragspartnernummer As Integer, ByRef Partnername As TextBox) As Boolean
            If Me.Vertragspartner.Vertragspartner_Suchen(Vertragspartnernummer) = True Then
                Me.iVertragspartnerNr = New SqlInt32(CType(Vertragspartnernummer, Int32))
                Partnername.Text = Me.Vertragspartnername
            End If
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragselement.dispose Method

clsVertragselement.dispose Method

Expand image Overload List

Name | Description
protected virtual System.Void Dispose(bool); | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
public System.Void dispose(); |

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragselement Fields

clsVertragselement Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | Kuendigungsfrist |
Supported by the .NET Compact Framework. | Kuendigungsfristen |
Supported by the .NET Compact Framework. | Parentelemente |
Supported by the .NET Compact Framework. | Vertragselement |
Supported by the .NET Compact Framework. | Vertragskontakt |
Supported by the .NET Compact Framework. | Vertragskontakte |
Supported by the .NET Compact Framework. | Vertragspartner |
Supported by the .NET Compact Framework. | Vertragstypen |
Supported by the .NET Compact Framework. | daten | Vertragselement lesen
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | vertragstyp |
Top

Expand image See Also

Reference

clsVertragselement Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


Kuendigungsfrist Variable

Kuendigungsfrist Variable

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Kuendigungsfrist As clsKuendigungsfrist
C#
public clsKuendigungsfrist Kuendigungsfrist;
C++
public:
clsKuendigungsfrist^ Kuendigungsfrist;
JScript
public Kuendigungsfrist : clsKuendigungsfrist

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Kuendigungsfrist As New TKB.VV.Vertrag.clsKuendigungsfrist

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


Kuendigungsfristen Variable

Kuendigungsfristen Variable

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Kuendigungsfristen As DomainTable
C#
public DomainTable Kuendigungsfristen;
C++
public:
DomainTable^ Kuendigungsfristen;
JScript
public Kuendigungsfristen : DomainTable

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Kuendigungsfristen As TKB.VV.Sysadmin.DomainTable

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


Parentelemente Variable

Parentelemente Variable

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Parentelemente As clsParentelemente
C#
public clsParentelemente Parentelemente;
C++
public:
clsParentelemente^ Parentelemente;
JScript
public Parentelemente : clsParentelemente

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Parentelemente As New TKB.VV.Vertrag.clsParentelemente

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


Vertragselement Variable

Vertragselement Variable

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Vertragselement As clsVertragselement
C#
public clsVertragselement Vertragselement;
C++
public:
clsVertragselement^ Vertragselement;
JScript
public Vertragselement : clsVertragselement

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Vertragselement As TKB.VV.DB.clsVertragselement

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


Vertragskontakt Variable

Vertragskontakt Variable

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Vertragskontakt As clsKontakt
C#
public clsKontakt Vertragskontakt;
C++
public:
clsKontakt^ Vertragskontakt;
JScript
public Vertragskontakt : clsKontakt

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Vertragskontakt As New TKB.VV.Vertrag.clsKontakt

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


Vertragskontakte Variable

Vertragskontakte Variable

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Vertragskontakte As DomainTable
C#
public DomainTable Vertragskontakte;
C++
public:
DomainTable^ Vertragskontakte;
JScript
public Vertragskontakte : DomainTable

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Vertragskontakte As TKB.VV.Sysadmin.DomainTable

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


Vertragspartner Variable

Vertragspartner Variable

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Vertragspartner As clsVertragspartner
C#
private clsVertragspartner Vertragspartner;
C++
private:
clsVertragspartner^ Vertragspartner;
JScript
private Vertragspartner : clsVertragspartner

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Vertragspartner As New TKB.VV.Vertrag.clsVertragspartner

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


Vertragstypen Variable

Vertragstypen Variable

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Vertragstypen As DataTable
C#
public DataTable Vertragstypen;
C++
public:
DataTable^ Vertragstypen;
JScript
public Vertragstypen : DataTable

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Vertragstypen As New DataTable

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


daten Variable

daten Variable

Vertragselement lesen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public daten As DataTable
C#
public DataTable daten;
C++
public:
DataTable^ daten;
JScript
public daten : DataTable

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public daten As New DataTable

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


vertragstyp Variable

vertragstyp Variable

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private vertragstyp As clsVertragstyp
C#
private clsVertragstyp vertragstyp;
C++
private:
clsVertragstyp^ vertragstyp;
JScript
private vertragstyp : clsVertragstyp

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private vertragstyp As New TKB.VV.DB.clsVertragstyp

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragspartner Class

clsVertragspartner Class
See Also Members
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsVertragspartner
    Inherits clsVertragspartner
C#
public class clsVertragspartner : clsVertragspartner
C++

public ref class clsVertragspartner : public clsVertragspartner^
JScript
public class clsVertragspartner
   extends clsVertragspartner

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsVertragspartner
Vertragsverwaltung.TKB.VV.Vertrag.clsVertragspartner

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragspartner Members

clsVertragspartner Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

The following tables list the members exposed by the clsVertragspartner type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsVertragspartner Constructor | Purpose: Class constructor. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Top

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | iMutierer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | iVertragspartnerNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | sBemerkung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sEMail | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | sInternet | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | sNameZ1 | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | sNameZ2 | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | sOrt | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | sPLZ | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | sPostfach | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | sStrasse | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | sTelefax | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | sTelefon | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Add_New | Neuer Vertragspartner
Supported by the .NET Compact Framework. | Create_Copy | Kopie eines Vertragspartners erstellen
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | Delete_Partner | Vertragspartner inaktivieren
Supported by the .NET Compact Framework. | Get_Kontaktpersonen | (Overloaded) Kontaktpersonen zu einem Vertragspartner auslesen
Supported by the .NET Compact Framework. | Get_Partner | Vertragspartener auslesen
Supported by the .NET Compact Framework. | Get_Vertragspartnername | Standard-Vertragspartnername auslesen
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | Save_Data | Vertragspartner speichern
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | Vertragspartner_Suchen | Vertragspartner suchen
Supported by the .NET Compact Framework. | dispose | (Overloaded) Destructor Dispose
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete_Kontaktpersonen | Inaktivieren aller aktiven Kontaktpersonen zu einem Vertragspartner
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | Kontaktperson |
Supported by the .NET Compact Framework. | Kontaktpersonen |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsVertragspartner Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragspartner Properties

clsVertragspartner Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iMandantnr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | iMutierer | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | iSecurityLevelNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | iVertragspartnerNr | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | sBemerkung | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | sEMail | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | sInternet | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | sNameZ1 | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | sNameZ2 | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | sOrt | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | sPLZ | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | sPostfach | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | sStrasse | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | sTelefax | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | sTelefon | (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Top

Expand image See Also

Reference

clsVertragspartner Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragspartner Methods

clsVertragspartner Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Add_New | Neuer Vertragspartner
Supported by the .NET Compact Framework. | Create_Copy | Kopie eines Vertragspartners erstellen
Supported by the .NET Compact Framework. | Delete | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | Delete_Partner | Vertragspartner inaktivieren
Supported by the .NET Compact Framework. | Get_Kontaktpersonen | (Overloaded) Kontaktpersonen zu einem Vertragspartner auslesen
Supported by the .NET Compact Framework. | Get_Partner | Vertragspartener auslesen
Supported by the .NET Compact Framework. | Get_Vertragspartnername | Standard-Vertragspartnername auslesen
Supported by the .NET Compact Framework. | Insert | Purpose: Insert method. This method will insert one new row into the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | Save_Data | Vertragspartner speichern
Supported by the .NET Compact Framework. | SelectAll | Purpose: SelectAll method. This method will Select all rows from the table. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | SelectOne | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | Update | Purpose: Update method. This method will Update one existing row in the database. (inherited from Vertragsverwaltung.TKB.VV.DB.clsVertragspartner).
Supported by the .NET Compact Framework. | Vertragspartner_Suchen | Vertragspartner suchen
Supported by the .NET Compact Framework. | dispose | (Overloaded) Destructor Dispose
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete_Kontaktpersonen | Inaktivieren aller aktiven Kontaktpersonen zu einem Vertragspartner
Top

Expand image See Also

Reference

clsVertragspartner Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragspartner.Add_New Method

clsVertragspartner.Add_New Method

Neuer Vertragspartner

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Add_New() As Integer
C#
public int Add_New();
C++

public:
int Add_New()
JScript
public function Add_New() : int;

Return Value

Key des neuen Vertragspartners

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Add_New() As Integer
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Vertragspartner")
            db.Dispose()
            Me.iVertragspartnerNr = New SqlInt32(CType(newkey, Int32))
            Me.sNameZ1 = New SqlString(CType("", String))
            Me.sNameZ2 = New SqlString(CType("", String))
            Me.sStrasse = New SqlString(CType("", String))
            Me.sPostfach = New SqlString(CType("", String))
            Me.sPLZ = New SqlString(CType("", String))
            Me.sOrt = New SqlString(CType("", String))
            Me.sTelefon = New SqlString(CType("", String))
            Me.sTelefax = New SqlString(CType("", String))
            Me.sEMail = New SqlString(CType("", String))
            Me.sInternet = New SqlString(CType("", String))
            Me.sBemerkung = New SqlString(CType("", String))
            Me.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.iSecurityLevelNr = New SqlInt32(CType(0, Int32))
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Return newkey
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragspartner.Create_Copy Method

clsVertragspartner.Create_Copy Method

Kopie eines Vertragspartners erstellen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Create_Copy( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer
C#
public int Create_Copy(
   int Basenr
);
C++

public:
int Create_Copy(
   int Basenr
)
JScript
public function Create_Copy(
    Basenr : int
) : int;

Parameters

Basenr

Optional. The default value is 0.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Create_Copy(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Get_Partner(Basenr)
            End If
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Vertragspartner")
            db.Dispose()

            Me.cpMainConnectionProvider = Globals.conn
            Me.iVertragspartnerNr = New SqlInt32(CType(newkey, Int32))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Return newkey
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragspartner.Delete_Kontaktpersonen Method

clsVertragspartner.Delete_Kontaktpersonen Method

Inaktivieren aller aktiven Kontaktpersonen zu einem Vertragspartner

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Delete_Kontaktpersonen()
C#
private System.Void Delete_Kontaktpersonen();
C++

private:
System::Void Delete_Kontaktpersonen()
JScript
private function Delete_Kontaktpersonen();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Sub Delete_Kontaktpersonen()
            Dim i As Integer
            For i = 0 To Me.Kontaktpersonen.Tabledata.Tables(0).Rows.Count - 1
                If Me.Kontaktpersonen.Tabledata.Tables(0).Rows(i).Item("Aktiv") = True Then
                    Me.Kontaktperson.Delete_Kontakt(Me.Kontaktpersonen.Tabledata.Tables(0).Rows(i).Item("PersonNr"))
                End If
            Next
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragspartner.Delete_Partner Method

clsVertragspartner.Delete_Partner Method

Vertragspartner inaktivieren

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Delete_Partner( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer
C#
public int Delete_Partner(
   int Basenr
);
C++

public:
int Delete_Partner(
   int Basenr
)
JScript
public function Delete_Partner(
    Basenr : int
) : int;

Parameters

Basenr

Optional. The default value is 0.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Delete_Partner(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Me.Get_Partner(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Me.bAktiv = New SqlBoolean(CType(False, Boolean))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Delete_Kontaktpersonen()
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragspartner.Get_Kontaktpersonen (C1.Win.C1TrueDBGrid.C1TrueDBGrid) Method

clsVertragspartner.Get_Kontaktpersonen (C1.Win.C1TrueDBGrid.C1TrueDBGrid) Method
See Also
collapseAll image DropDown image

Kontaktpersonen zu einem Vertragspartner auslesen

Expand image Overload List

Name | Description
public DataSet Get_Kontaktpersonen(); | Kontaktpersonen zu einem Vertragspartner auslesen
public object Get_Kontaktpersonen(ref C1TrueDBGrid); | Kontaktpersonen zu einem Vertragspartner auslesen

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragspartner.Get_Partner Method

clsVertragspartner.Get_Partner Method

Vertragspartener auslesen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Get_Partner( _
   ByVal Nr As Integer _
) As Object
C#
public object Get_Partner(
   int Nr
);
C++

public:
object^ Get_Partner(
   int Nr
)
JScript
public function Get_Partner(
    Nr : int
) : object;

Parameters

Nr

Nr des Vertragspartners

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Get_Partner(ByVal Nr As Integer)
            Me.cpMainConnectionProvider = Globals.conn
            Me.iVertragspartnerNr = New SqlInt32(CType(Nr, Int32))
            Globals.conn.OpenConnection()
            Me.SelectOne()
            Globals.conn.CloseConnection(True)
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragspartner.Get_Vertragspartnername Method

clsVertragspartner.Get_Vertragspartnername Method

Standard-Vertragspartnername auslesen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Get_Vertragspartnername( _
   ByVal Vertragspartnernr As Integer _
) As String
C#
public string Get_Vertragspartnername(
   int Vertragspartnernr
);
C++

public:
String^ Get_Vertragspartnername(
   int Vertragspartnernr
)
JScript
public function Get_Vertragspartnername(
    Vertragspartnernr : int
) : String;

Parameters

Vertragspartnernr

Nummer des Vertragspartners

Return Value

Name des Vertragspartners

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Get_Vertragspartnername(ByVal Vertragspartnernr As Integer) As String
            Get_Partner(Vertragspartnernr)
            Return Me.sNameZ1 + " " + Me.sNameZ2 + ", " + Me.sOrt
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragspartner.Save_Data Method

clsVertragspartner.Save_Data Method

Vertragspartner speichern

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Save_Data() As Integer
C#
public int Save_Data();
C++

public:
int Save_Data()
JScript
public function Save_Data() : int;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Save_Data() As Integer
            Me.cpMainConnectionProvider = Globals.conn
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Return Me.iVertragspartnerNr.Value
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragspartner.Vertragspartner_Suchen Method

clsVertragspartner.Vertragspartner_Suchen Method

Vertragspartner suchen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Vertragspartner_Suchen( _
   ByRef Vertragspartnernr As Integer _
) As Boolean
C#
public bool Vertragspartner_Suchen(
   ref int Vertragspartnernr
);
C++

public:
bool Vertragspartner_Suchen(
   int& Vertragspartnernr
)
JScript
public function Vertragspartner_Suchen(
    Vertragspartnernr : int
) : boolean;

Parameters

Vertragspartnernr

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Vertragspartner_Suchen(ByRef Vertragspartnernr As Integer) As Boolean
            Dim vpsuche As New frmVertragspartnerSuche
            vpsuche.ShowDialog()
            Try
                If vpsuche.DialogResult = DialogResult.OK Then
                    Vertragspartnernr = vpsuche.Vertragspartnernr
                    Return True
                Else
                    Vertragspartnernr = -1
                    Return False
                End If
            Catch ex As Exception
                Return False
            Finally
                vpsuche.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragspartner.dispose Method

clsVertragspartner.dispose Method

Destructor Dispose

Expand image Overload List

Name | Description
public System.Void dispose(); | Destructor Dispose
protected virtual System.Void Dispose(bool); | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragspartner Fields

clsVertragspartner Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | Kontaktperson |
Supported by the .NET Compact Framework. | Kontaktpersonen |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_iRowsAffected | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase).
Top

Expand image See Also

Reference

clsVertragspartner Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


Kontaktperson Variable

Kontaktperson Variable

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Kontaktperson As clsPersonen
C#
public clsPersonen Kontaktperson;
C++
public:
clsPersonen^ Kontaktperson;
JScript
public Kontaktperson : clsPersonen

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Kontaktperson As New TKB.VV.Vertrag.clsPersonen

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


Kontaktpersonen Variable

Kontaktpersonen Variable

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Kontaktpersonen As DomainTable
C#
public DomainTable Kontaktpersonen;
C++
public:
DomainTable^ Kontaktpersonen;
JScript
public Kontaktpersonen : DomainTable

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Kontaktpersonen As TKB.VV.Sysadmin.DomainTable

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragsuebersicht_Strukturen Class

clsVertragsuebersicht_Strukturen Class
See Also Members
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsVertragsuebersicht_Strukturen
C#
public class clsVertragsuebersicht_Strukturen
C++

public ref class clsVertragsuebersicht_Strukturen
JScript
public class clsVertragsuebersicht_Strukturen

Expand image Inheritance Hierarchy

System.Object
Vertragsverwaltung.TKB.VV.Vertrag.clsVertragsuebersicht_Strukturen

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragsuebersicht_Strukturen Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragsuebersicht_Strukturen Members

clsVertragsuebersicht_Strukturen Members
See Also Methods
CollapseAll image DropDown image

The following tables list the members exposed by the clsVertragsuebersicht_Strukturen type.

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Get_Struktur | Tree-Struktur auslesen und Tree abfüllen
Supported by the .NET Compact Framework. | Load_SubStruktur | Datenstruktur für den Tree lasen
Supported by the .NET Compact Framework. | Update_Vertragsuebersicht | Vertrasgdetail abhängig des gewählten Nodes auslesen
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | Get_SubStruktur | Laden der Substruktur
Supported by the .NET Compact Framework. | Get_Treedata | Auslesen der Partner für die Vertragsuebersicht
Supported by the .NET Compact Framework. | Get_Vertragsdetails | Laden der Substruktur
Supported by the .NET Compact Framework. | LoadNode | Tree aufbauen
Supported by the .NET Compact Framework. | Load_Tree | Treeview laden und je eintrag einen "Dummy-Eintrag" erstellen
Supported by the .NET Compact Framework. | RecursivelyLoadNode | Child-Nodes hinzufügen
Supported by the .NET Compact Framework. | Update_Node | Parent-Beziehung herstellen und Struktur abfüllen
Top

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | SelectionType |
Supported by the .NET Compact Framework. | TreeData |
Supported by the .NET Compact Framework. | xVertragspartnernr |
Top

Expand image See Also

Reference

clsVertragsuebersicht_Strukturen Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragsuebersicht_Strukturen Methods

clsVertragsuebersicht_Strukturen Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Get_Struktur | Tree-Struktur auslesen und Tree abfüllen
Supported by the .NET Compact Framework. | Load_SubStruktur | Datenstruktur für den Tree lasen
Supported by the .NET Compact Framework. | Update_Vertragsuebersicht | Vertrasgdetail abhängig des gewählten Nodes auslesen
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | Get_SubStruktur | Laden der Substruktur
Supported by the .NET Compact Framework. | Get_Treedata | Auslesen der Partner für die Vertragsuebersicht
Supported by the .NET Compact Framework. | Get_Vertragsdetails | Laden der Substruktur
Supported by the .NET Compact Framework. | LoadNode | Tree aufbauen
Supported by the .NET Compact Framework. | Load_Tree | Treeview laden und je eintrag einen "Dummy-Eintrag" erstellen
Supported by the .NET Compact Framework. | RecursivelyLoadNode | Child-Nodes hinzufügen
Supported by the .NET Compact Framework. | Update_Node | Parent-Beziehung herstellen und Struktur abfüllen
Top

Expand image See Also

Reference

clsVertragsuebersicht_Strukturen Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragsuebersicht_Strukturen.Get_Struktur Method

clsVertragsuebersicht_Strukturen.Get_Struktur Method

Tree-Struktur auslesen und Tree abfüllen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Get_Struktur( _
   ByRef tree As TreeView, _
   Optional ByVal SelectionType As Integer = 0, _
   Optional ByVal Aktiv As Boolean = True _
) As Object
C#
public object Get_Struktur(
   ref TreeView tree,
   int SelectionType,
   bool Aktiv
);
C++

public:
object^ Get_Struktur(
   TreeView^& tree,
   int SelectionType,
   bool Aktiv
)
JScript
public function Get_Struktur(
    tree : TreeView,
    SelectionType : int,
    Aktiv : boolean
) : object;

Parameters

tree

abzufüllender Treeview

SelectionType

1=Vertragspartner, 2=Vertragstyp

Aktiv

0=Alle Elemente, 1=nur aktive Elemente

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Get_Struktur(ByRef tree As TreeView, Optional ByVal SelectionType As Integer = 0, Optional ByVal Aktiv As Boolean = True)
            Me.TreeData = Get_Treedata(SelectionType, Aktiv)
            Select Case SelectionType
                Case 0
                    Me.SelectionType = "Vertragspartner"
                Case 1
                    Me.SelectionType = "Vertragstyp"
                Case Else
                    Me.SelectionType = "Unknown"
            End Select
            Load_Tree(tree)
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragsuebersicht_Strukturen Class
clsVertragsuebersicht_Strukturen Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragsuebersicht_Strukturen.Get_SubStruktur Method

clsVertragsuebersicht_Strukturen.Get_SubStruktur Method

Laden der Substruktur

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Get_SubStruktur( _
   ByVal vertragstypnr As Integer, _
   ByVal Vertragspartnernr As Integer _
) As DataTable
C#
private DataTable Get_SubStruktur(
   int vertragstypnr,
   int Vertragspartnernr
);
C++

private:
DataTable^ Get_SubStruktur(
   int vertragstypnr,
   int Vertragspartnernr
)
JScript
private function Get_SubStruktur(
    vertragstypnr : int,
    Vertragspartnernr : int
) : DataTable;

Parameters

vertragstypnr

Vertragspartnernr

Nummer des aktuellen Vertragspartners

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Function Get_SubStruktur(ByVal vertragstypnr As Integer, ByVal Vertragspartnernr As Integer) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_vertragsuebersicht_get_struktur"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@vertragstypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, vertragstypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@vertragspartnernr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Vertragspartnernr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
                sdaAdapter.Fill(dtToReturn)
                Return dtToReturn
            Catch ex As Exception
                Throw New Exception("clsVertragsuebersicht::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragsuebersicht_Strukturen Class
clsVertragsuebersicht_Strukturen Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragsuebersicht_Strukturen.Get_Treedata Method

clsVertragsuebersicht_Strukturen.Get_Treedata Method

Auslesen der Partner für die Vertragsuebersicht

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Get_Treedata( _
   ByVal Selectiontype As Integer, _
   ByVal aktiv As Boolean _
) As DataTable
C#
private DataTable Get_Treedata(
   int Selectiontype,
   bool aktiv
);
C++

private:
DataTable^ Get_Treedata(
   int Selectiontype,
   bool aktiv
)
JScript
private function Get_Treedata(
    Selectiontype : int,
    aktiv : boolean
) : DataTable;

Parameters

Selectiontype

Vertragspartner oder Vertragstyp

aktiv

Aktiv=0

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Function Get_Treedata(ByVal Selectiontype As Integer, ByVal aktiv As Boolean) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_vertragsuebersicht_get_TreeRoot"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@SelectionType", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Selectiontype))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, aktiv))
                sdaAdapter.Fill(dtToReturn)
                Return dtToReturn
            Catch ex As Exception
                Throw New Exception("clsVertragsuebersicht::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragsuebersicht_Strukturen Class
clsVertragsuebersicht_Strukturen Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragsuebersicht_Strukturen.Get_Vertragsdetails Method

clsVertragsuebersicht_Strukturen.Get_Vertragsdetails Method

Laden der Substruktur

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Get_Vertragsdetails( _
   ByVal Elementtyp As String, _
   ByVal EntryRoot As Integer, _
   ByVal Vertragspartnernr As Integer _
) As Object
C#
private object Get_Vertragsdetails(
   string Elementtyp,
   int EntryRoot,
   int Vertragspartnernr
);
C++

private:
object^ Get_Vertragsdetails(
   String^ Elementtyp,
   int EntryRoot,
   int Vertragspartnernr
)
JScript
private function Get_Vertragsdetails(
    Elementtyp : String,
    EntryRoot : int,
    Vertragspartnernr : int
) : object;

Parameters

Elementtyp

EntryRoot

Vertragspartnernr

Nummer des aktuellen Vertragspartners

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Function Get_Vertragsdetails(ByVal Elementtyp As String, ByVal EntryRoot As Integer, ByVal Vertragspartnernr As Integer)
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_vertragsuebersicht_get_Details"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Elementtyp", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Elementtyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@EntryRoot", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, EntryRoot))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@vertragspartnernr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Vertragspartnernr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
                sdaAdapter.Fill(dtToReturn)
                Return dtToReturn
            Catch ex As Exception
                Throw New Exception("clsVertragsuebersicht::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragsuebersicht_Strukturen Class
clsVertragsuebersicht_Strukturen Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragsuebersicht_Strukturen.LoadNode Method

clsVertragsuebersicht_Strukturen.LoadNode Method

Tree aufbauen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub LoadNode( _
   ByVal oDS As DataSet, _
   ByRef oNode As TreeNode, _
   ByVal type As String _
)
C#
private System.Void LoadNode(
   DataSet oDS,
   ref TreeNode oNode,
   string type
);
C++

private:
System::Void LoadNode(
   DataSet^ oDS,
   TreeNode^& oNode,
   String^ type
)
JScript
private function LoadNode(
    oDS : DataSet,
    oNode : TreeNode,
    type : String
);

Parameters

oDS

Input-Dataset

oNode

Aktueller Node

type

Type Vertragspartner oder Vertragstyp

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Sub LoadNode(ByVal oDS As DataSet, ByRef oNode As TreeNode, ByVal type As String)
            'Dim oTreeView As TreeView = New TreeView()
            Dim oDataRow As DataRow
            For Each oDataRow In oDS.Tables(0).Rows
                If Not oDataRow.IsNull("Parentid") Then
                    If oDataRow.Item("Parentid") = 0 Then
                        'If oDataRow.IsNull("Parentid") Then
                        Dim oNode1 As New TreeNode()
                        oNode1.Text = oDataRow("Bezeichnung").ToString()
                        Select Case type
                            Case "Vertragspartner"
                                oNode1.Tag = New Treenode_Descriptor("Vertragstyp", oDataRow("vertragselementnr").ToString, xVertragspartnernr, oDataRow("vertragstypnr").ToString)
                                oNode1.ImageIndex = 1
                                oNode1.SelectedImageIndex = 1
                                oNode1.StateImageIndex = 1
                            Case "Vertragstyp"
                                oNode1.Tag = New Treenode_Descriptor("Vertragspartner", oDataRow("vertragselementnr").ToString, xVertragspartnernr, oDataRow("vertragstypnr").ToString)
                                oNode1.ImageIndex = 0
                                oNode1.SelectedImageIndex = 0
                                oNode1.StateImageIndex = 0
                        End Select
                        oNode.Nodes.Add(oNode1)
                        RecursivelyLoadNode(oDataRow, oNode1, type)
                    End If
                End If
            Next oDataRow
            oDS.Dispose()
            oDS = Nothing
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragsuebersicht_Strukturen Class
clsVertragsuebersicht_Strukturen Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragsuebersicht_Strukturen.Load_SubStruktur Method

clsVertragsuebersicht_Strukturen.Load_SubStruktur Method

Datenstruktur für den Tree lasen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Load_SubStruktur( _
   ByRef Node As TreeNode _
) As Object
C#
public object Load_SubStruktur(
   ref TreeNode Node
);
C++

public:
object^ Load_SubStruktur(
   TreeNode^& Node
)
JScript
public function Load_SubStruktur(
    Node : TreeNode
) : object;

Parameters

Node

Parent-Node

Expand image Remarks

Abhängig vom Type wird die Struktur nach Vertragspartner oder Vertragstyp aufgebaut

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Load_SubStruktur(ByRef Node As TreeNode)
            Dim x As Treenode_Descriptor = Node.Tag
            Dim substrukturdata As New DataTable
            Select Case x.Type
                Case "Vertragspartner"
                    Me.xVertragspartnernr = x.Vertragspartnernr
                    substrukturdata = Get_SubStruktur(0, x.Vertragspartnernr)
                Case "Vertragstyp"
                    substrukturdata = Get_SubStruktur(x.Vertragstypnr, 0)
            End Select
            Update_Node(substrukturdata, Node, x.Type)
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragsuebersicht_Strukturen Class
clsVertragsuebersicht_Strukturen Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragsuebersicht_Strukturen.Load_Tree Method

clsVertragsuebersicht_Strukturen.Load_Tree Method

Treeview laden und je eintrag einen "Dummy-Eintrag" erstellen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Function Load_Tree( _
   ByRef Tree As TreeView _
) As Object
C#
private object Load_Tree(
   ref TreeView Tree
);
C++

private:
object^ Load_Tree(
   TreeView^& Tree
)
JScript
private function Load_Tree(
    Tree : TreeView
) : object;

Parameters

Tree

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Function Load_Tree(ByRef Tree As TreeView)
            Tree.Enabled = False
            Tree.Nodes.Clear()
            For Each dr As DataRow In Me.TreeData.Rows
                Dim tn As New TreeNode
                tn.Text = dr.Item("Description")
                tn.Tag = New Treenode_Descriptor(Me.SelectionType, dr.Item("KeyValue"), dr.Item("KeyValue"), dr.Item("KeyValue"))
                Select Case Me.SelectionType
                    Case "Vertragspartner"
                        tn.ImageIndex = 0
                        tn.SelectedImageIndex = 0
                        tn.StateImageIndex = 0
                    Case "Vertragstyp"
                        tn.ImageIndex = 1
                        tn.SelectedImageIndex = 1
                        tn.StateImageIndex = 1
                End Select
                Tree.Nodes.Add(tn)
                Dim subtn As New TreeNode
                subtn.Tag = New TKB.VV.Vertrag.Treenode_Descriptor("", -99, 0, 0)
                tn.Nodes.Add(subtn)
            Next
            Tree.Enabled = True
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragsuebersicht_Strukturen Class
clsVertragsuebersicht_Strukturen Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragsuebersicht_Strukturen.RecursivelyLoadNode Method

clsVertragsuebersicht_Strukturen.RecursivelyLoadNode Method

Child-Nodes hinzufügen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub RecursivelyLoadNode( _
   ByVal oDataRow As DataRow, _
   ByRef oNode As TreeNode, _
   ByVal type As String _
)
C#
private System.Void RecursivelyLoadNode(
   DataRow oDataRow,
   ref TreeNode oNode,
   string type
);
C++

private:
System::Void RecursivelyLoadNode(
   DataRow^ oDataRow,
   TreeNode^& oNode,
   String^ type
)
JScript
private function RecursivelyLoadNode(
    oDataRow : DataRow,
    oNode : TreeNode,
    type : String
);

Parameters

oDataRow

oNode

type

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Sub RecursivelyLoadNode(ByVal oDataRow As DataRow, ByRef oNode As TreeNode, ByVal type As String)
            Dim oChildRow As DataRow
            For Each oChildRow In oDataRow.GetChildRows("SelfRefenceRelation")
                Dim oChildNode As New TreeNode()
                oChildNode.Text = oChildRow("Bezeichnung").ToString()
                oChildNode.Tag = New Treenode_Descriptor("Vertragselement", oChildRow("Vertragselementnr").ToString(), xVertragspartnernr, oDataRow("vertragstypnr").ToString)
                oChildNode.ImageIndex = 2
                oChildNode.SelectedImageIndex = 2
                oChildNode.StateImageIndex = 2
                oNode.Nodes.Add(oChildNode)
                RecursivelyLoadNode(oChildRow, oChildNode, type)
            Next oChildRow
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragsuebersicht_Strukturen Class
clsVertragsuebersicht_Strukturen Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragsuebersicht_Strukturen.Update_Node Method

clsVertragsuebersicht_Strukturen.Update_Node Method

Parent-Beziehung herstellen und Struktur abfüllen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private Sub Update_Node( _
   ByVal oSourceData As DataTable, _
   ByRef node As TreeNode, _
   ByVal type As String _
)
C#
private System.Void Update_Node(
   DataTable oSourceData,
   ref TreeNode node,
   string type
);
C++

private:
System::Void Update_Node(
   DataTable^ oSourceData,
   TreeNode^& node,
   String^ type
)
JScript
private function Update_Node(
    oSourceData : DataTable,
    node : TreeNode,
    type : String
);

Parameters

oSourceData

node

type

Expand image Source code

Visual Basic CopyCode image Copy Code
        Private Sub Update_Node(ByVal oSourceData As DataTable, ByRef node As TreeNode, ByVal type As String)
            If Not (oSourceData Is Nothing) Then
                Dim oView As DataView = oSourceData.DefaultView
                Dim oTable As DataTable = oView.Table
                Dim oDS As DataSet = New DataSet()
                oDS.Tables.Add(oTable.Copy())

                If oDS.Relations.Contains("SelfRefenceRelation") = False Then
                    oDS.Relations.Add("SelfRefenceRelation", _
                        oDS.Tables(0).Columns("Vertragselementnr"), _
                        oDS.Tables(0).Columns("Parentid"))
                End If
                oTable.Dispose()
                oTable = Nothing
                LoadNode(oDS, node, type)
                oDS.Dispose()
                oDS = Nothing
            End If
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragsuebersicht_Strukturen Class
clsVertragsuebersicht_Strukturen Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragsuebersicht_Strukturen.Update_Vertragsuebersicht Method

clsVertragsuebersicht_Strukturen.Update_Vertragsuebersicht Method
See Also
collapseAll image DropDown image

Vertrasgdetail abhängig des gewählten Nodes auslesen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Update_Vertragsuebersicht( _
   ByVal SelectedTag As Object, _
   Optional ByVal SelNachVertragstyp As Boolean = False _
) As DataTable
C#
public DataTable Update_Vertragsuebersicht(
   object SelectedTag,
   bool SelNachVertragstyp
);
C++

public:
DataTable^ Update_Vertragsuebersicht(
   object^ SelectedTag,
   bool SelNachVertragstyp
)
JScript
public function Update_Vertragsuebersicht(
    SelectedTag : object,
    SelNachVertragstyp : boolean
) : DataTable;

Parameters

SelectedTag

Required.

SelNachVertragstyp

Optional. The default value is False.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Update_Vertragsuebersicht(ByVal SelectedTag As Object, Optional ByVal SelNachVertragstyp As Boolean = False) As DataTable
            Dim x As Treenode_Descriptor = SelectedTag
            Select Case x.Type
                Case "Vertragspartner"
                    Return Get_Vertragsdetails(x.Type, 0, x.Vertragspartnernr)
                Case "Vertragstyp"
                    If SelNachVertragstyp = True Then
                        Return Get_Vertragsdetails(x.Type, x.Vertragstypnr, 0)
                    Else
                        Return Get_Vertragsdetails(x.Type, x.Vertragstypnr, x.Vertragspartnernr)
                    End If
                Case "Vertragselement"
                    Return Get_Vertragsdetails(x.Type, x.Keyvalue, x.Vertragspartnernr)
            End Select

        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragsuebersicht_Strukturen Class
clsVertragsuebersicht_Strukturen Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragsuebersicht_Strukturen Fields

clsVertragsuebersicht_Strukturen Fields
CollapseAll image DropDown image

Expand image Fields

 | Name | Description
Supported by the .NET Compact Framework. | SelectionType |
Supported by the .NET Compact Framework. | TreeData |
Supported by the .NET Compact Framework. | xVertragspartnernr |
Top

Expand image See Also

Reference

clsVertragsuebersicht_Strukturen Class
Vertragsverwaltung.TKB.VV.Vertrag Namespace


SelectionType Variable

SelectionType Variable

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private SelectionType As String
C#
private string SelectionType;
C++
private:
String^ SelectionType;
JScript
private SelectionType : String

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim SelectionType As String

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragsuebersicht_Strukturen Class
clsVertragsuebersicht_Strukturen Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


TreeData Variable

TreeData Variable

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private TreeData As DataTable
C#
private DataTable TreeData;
C++
private:
DataTable^ TreeData;
JScript
private TreeData : DataTable

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim TreeData As New DataTable

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragsuebersicht_Strukturen Class
clsVertragsuebersicht_Strukturen Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


xVertragspartnernr Variable

xVertragspartnernr Variable

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Private xVertragspartnernr As Integer
C#
private int xVertragspartnernr;
C++
private:
int xVertragspartnernr;
JScript
private xVertragspartnernr : int

Expand image Source code

Visual Basic CopyCode image Copy Code
        Dim xVertragspartnernr As Integer

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragsuebersicht_Strukturen Class
clsVertragsuebersicht_Strukturen Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


frmVertragselement.Dispose Method

frmVertragselement.Dispose Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
C#
[System.Diagnostics.DebuggerNonUserCode()]
protected override System.Void Dispose(
   bool disposing
);
C++
[System.Diagnostics.DebuggerNonUserCode()]

protected:
System::Void Dispose(
   bool disposing
)
JScript
protected
   System.Diagnostics.DebuggerNonUserCode()
function Dispose(
    disposing : boolean
);

Parameters

disposing

Expand image Source code

Visual Basic CopyCode image Copy Code
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


clsSLAKatalogdaten Constructor

clsSLAKatalogdaten Constructor

Namespace: Vertragsverwaltung.TKB.VV.SLA
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal tblname As String _
)
C#
public System.Void clsSLAKatalogdaten(
   string tblname
);
C++

public:
System::Void clsSLAKatalogdaten(
   String^ tblname
)
JScript
public function clsSLAKatalogdaten(
    tblname : String
);

Parameters

tblname

Expand image Source code

Visual Basic CopyCode image Copy Code
        Sub New(ByVal tblname As String)
            MyBase.New(tblname)
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsSLAKatalogdaten Class
clsSLAKatalogdaten Members
Vertragsverwaltung.TKB.VV.SLA Namespace


frmVertragselement Constructor

frmVertragselement Constructor

Standard Constructore New
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void frmVertragselement();
C++

public:
System::Void frmVertragselement()
JScript
public function frmVertragselement();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Sub New()
        InitializeComponent()
        Me.Aktuelles_Vertragselement = -1
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement Constructor (System.Int32, System.Boolean, System.Boolean, System.Int32)

frmVertragselement Constructor (System.Int32, System.Boolean, System.Boolean, System.Int32)
See Also
collapseAll image DropDown image

Formualr mit Vertragselementnr und Anzeigestatus öffnen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal Vertragselementnr As Integer, _
   ByVal Anzeige As Boolean, _
   Optional ByVal CreateNew As Boolean = False, _
   Optional ByVal Vertragspartnernr As Integer = 0 _
)
C#
public System.Void frmVertragselement(
   int Vertragselementnr,
   bool Anzeige,
   bool CreateNew,
   int Vertragspartnernr
);
C++

public:
System::Void frmVertragselement(
   int Vertragselementnr,
   bool Anzeige,
   bool CreateNew,
   int Vertragspartnernr
)
JScript
public function frmVertragselement(
    Vertragselementnr : int,
    Anzeige : boolean,
    CreateNew : boolean,
    Vertragspartnernr : int
);

Parameters

Vertragselementnr

Nr des Vertragspartners

Anzeige

True=Readonly, False=normal

CreateNew

Optional. The default value is False.

Vertragspartnernr

Optional. The default value is 0.

Expand image Source code

Visual Basic CopyCode image Copy Code
    Sub New(ByVal Vertragselementnr As Integer, ByVal Anzeige As Boolean, Optional ByVal CreateNew As Boolean = False, Optional ByVal Vertragspartnernr As Integer = 0)
        MyBase.New()
        InitializeComponent()
        Me.Aktuelles_Vertragselement = Vertragselementnr
        Me.Anzeige = Anzeige
        If CreateNew Then
            Me.Get_Data(Me.Vertragselement.Add_New(Vertragspartnernr))
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselement.dispose Method

frmVertragselement.dispose Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overloads Sub dispose()
C#
public System.Void dispose();
C++

public:
System::Void dispose()
JScript
public function dispose();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Public Overloads Sub dispose()
        Me.Vertragselement.dispose()
        sec = Nothing
        msg = Nothing
        MyBase.Dispose()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselement Class
frmVertragselement Members


frmVertragselementSuche.Dispose Method

frmVertragselementSuche.Dispose Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
C#
[System.Diagnostics.DebuggerNonUserCode()]
protected override System.Void Dispose(
   bool disposing
);
C++
[System.Diagnostics.DebuggerNonUserCode()]

protected:
System::Void Dispose(
   bool disposing
)
JScript
protected
   System.Diagnostics.DebuggerNonUserCode()
function Dispose(
    disposing : boolean
);

Parameters

disposing

Expand image Source code

Visual Basic CopyCode image Copy Code
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselementSuche Class
frmVertragselementSuche Members


frmKuendigungsfrist.Dispose (System.Boolean) Method

frmKuendigungsfrist.Dispose (System.Boolean) Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
C#
[System.Diagnostics.DebuggerNonUserCode()]
protected override System.Void Dispose(
   bool disposing
);
C++
[System.Diagnostics.DebuggerNonUserCode()]

protected:
System::Void Dispose(
   bool disposing
)
JScript
protected
   System.Diagnostics.DebuggerNonUserCode()
function Dispose(
    disposing : boolean
);

Parameters

disposing

Expand image Source code

Visual Basic CopyCode image Copy Code
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


clsConnectionProvider.Dispose Method

clsConnectionProvider.Dispose Method

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

C#
public System.Void Dispose();
C++

public:
System::Void Dispose()
JScript
public function Dispose();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overloads Public Sub Dispose() Implements IDisposable.Dispose
            Dispose(True)
            GC.SuppressFinalize(Me)
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsConnectionProvider Class
clsConnectionProvider Members


clsConnectionProvider.Dispose (System.Boolean) Method

clsConnectionProvider.Dispose (System.Boolean) Method

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal bIsDisposing As Boolean _
)
C#
protected virtual System.Void Dispose(
   bool bIsDisposing
);
C++

protected:
System::Void Dispose(
   bool bIsDisposing
) virtual
JScript
protected function Dispose(
    bIsDisposing : boolean
);

Parameters

bIsDisposing

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overridable Overloads Protected Sub Dispose(ByVal bIsDisposing As Boolean)
            ' // Check to see if Dispose has already been called.
            If Not m_bIsDisposed Then
                If bIsDisposing Then
                    ' // Dispose managed resources.
                    If Not (m_stCurrentTransaction Is Nothing) Then
                        m_stCurrentTransaction.Dispose()
                        m_stCurrentTransaction = Nothing
                    End If
                    If Not (m_scoDBConnection Is Nothing) Then
                        ' // closing the connection will abort (rollback) any pending transactions
                        m_scoDBConnection.Close()
                        m_scoDBConnection.Dispose()
                        m_scoDBConnection = Nothing
                    End If
                End If
            End If
            m_bIsDisposed = True
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsConnectionProvider Class
clsConnectionProvider Members


frmPerson.Dispose Method

frmPerson.Dispose Method

Destructor Dispose
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overloads Sub Dispose()
C#
public System.Void Dispose();
C++

public:
System::Void Dispose()
JScript
public function Dispose();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Overloads Sub Dispose()
        Kontaktperson.Dispose()
        sec = Nothing
        msg = Nothing
        MyBase.Dispose()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


clsVertragspartner.Get_Kontaktpersonen (C1.Win.C1TrueDBGrid.C1TrueDBGrid) Method

clsVertragspartner.Get_Kontaktpersonen (C1.Win.C1TrueDBGrid.C1TrueDBGrid) Method
See Also
collapseAll image DropDown image

Kontaktpersonen zu einem Vertragspartner auslesen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Get_Kontaktpersonen( _
   ByRef c1data As C1TrueDBGrid _
) As Object
C#
public object Get_Kontaktpersonen(
   ref C1TrueDBGrid c1data
);
C++

public:
object^ Get_Kontaktpersonen(
   C1TrueDBGrid^& c1data
)
JScript
public function Get_Kontaktpersonen(
    c1data : C1TrueDBGrid
) : object;

Parameters

c1data

Datagrid, welches die Kontaktpersonen anzeigt

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Get_Kontaktpersonen(ByRef c1data As C1TrueDBGrid)
            Try
                Kontaktpersonen.dispose()
                Kontaktpersonen = Nothing
            Catch ex As Exception
            End Try
            Kontaktpersonen = New TKB.VV.Sysadmin.DomainTable("Person", Me.iVertragspartnerNr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = Kontaktpersonen.Tabledata
            c1data.DataMember = Kontaktpersonen.Tabledata.Tables(0).TableName
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragspartner.Get_Kontaktpersonen Method

clsVertragspartner.Get_Kontaktpersonen Method

Kontaktpersonen zu einem Vertragspartner auslesen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Get_Kontaktpersonen() As DataSet
C#
public DataSet Get_Kontaktpersonen();
C++

public:
DataSet^ Get_Kontaktpersonen()
JScript
public function Get_Kontaktpersonen() : DataSet;

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Get_Kontaktpersonen() As DataSet
            Try
                Kontaktpersonen.dispose()
                Kontaktpersonen = Nothing
            Catch ex As Exception
            End Try
            Kontaktpersonen = New TKB.VV.Sysadmin.DomainTable("Person", Me.iVertragspartnerNr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            Return Kontaktpersonen.Tabledata
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsDBInteractionBase.Dispose Method

clsDBInteractionBase.Dispose Method

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

C#
public System.Void Dispose();
C++

public:
System::Void Dispose()
JScript
public function Dispose();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overloads Public Sub Dispose() Implements IDisposable.Dispose
            Dispose(True)
            GC.SuppressFinalize(Me)
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase Members


clsDBInteractionBase.Dispose (System.Boolean) Method

clsDBInteractionBase.Dispose (System.Boolean) Method

Namespace: Vertragsverwaltung.TKB.VV.DB
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal bIsDisposing As Boolean _
)
C#
protected virtual System.Void Dispose(
   bool bIsDisposing
);
C++

protected:
System::Void Dispose(
   bool bIsDisposing
) virtual
JScript
protected function Dispose(
    bIsDisposing : boolean
);

Parameters

bIsDisposing

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overridable  Overloads Protected Sub Dispose(ByVal bIsDisposing As Boolean)
            ' // Check to see if Dispose has already been called.
            If Not m_bIsDisposed Then
                If bIsDisposing Then
                    ' // Dispose managed resources.
                    If m_bMainConnectionIsCreatedLocal Then
                        ' // Object is created in this class, so destroy it here.
                        m_scoMainConnection.Close()
                        m_scoMainConnection.Dispose()
                        m_bMainConnectionIsCreatedLocal = True
                    End If
                    m_cpMainConnectionProvider = Nothing
                    m_scoMainConnection = Nothing
                End If
            End If
            m_bIsDisposed = True
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase Members


Tabellenspalte Constructor

Tabellenspalte Constructor

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void Tabellenspalte();
C++

public:
System::Void Tabellenspalte()
JScript
public function Tabellenspalte();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New()

        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Tabellenspalte Class
Tabellenspalte Members
Vertragsverwaltung.TKB.VV.Utils Namespace


Tabellenspalte Constructor (System.Object, System.String, System.Data.DataSet)

Tabellenspalte Constructor (System.Object, System.String, System.Data.DataSet)
See Also
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByRef daten As Object, _
   ByRef tablename As String, _
   ByRef ds As DataSet _
)
C#
public System.Void Tabellenspalte(
   ref object daten,
   ref string tablename,
   ref DataSet ds
);
C++

public:
System::Void Tabellenspalte(
   object^& daten,
   String^& tablename,
   DataSet^& ds
)
JScript
public function Tabellenspalte(
    daten : object,
    tablename : String,
    ds : DataSet
);

Parameters

daten

tablename

ds

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Sub New(ByRef daten As Object, ByRef tablename As String, ByRef ds As DataSet)
            Spaltentitel_aktualisieren(daten, tablename, ds)
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Tabellenspalte Class
Tabellenspalte Members
Vertragsverwaltung.TKB.VV.Utils Namespace


Tabellenspalte.Spaltentitel_aktualisieren (System.Object, System.String, System.Data.DataSet) Method

Tabellenspalte.Spaltentitel_aktualisieren (System.Object, System.String, System.Data.DataSet) Method
See Also
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Spaltentitel_aktualisieren( _
   ByRef daten As Object, _
   ByRef tablename As String, _
   ByRef ds As DataSet _
) As Object
C#
public object Spaltentitel_aktualisieren(
   ref object daten,
   ref string tablename,
   ref DataSet ds
);
C++

public:
object^ Spaltentitel_aktualisieren(
   object^& daten,
   String^& tablename,
   DataSet^& ds
)
JScript
public function Spaltentitel_aktualisieren(
    daten : object,
    tablename : String,
    ds : DataSet
) : object;

Parameters

daten

tablename

ds

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Spaltentitel_aktualisieren(ByRef daten As Object, ByRef tablename As String, ByRef ds As DataSet)
            Dim anzcols As Integer
            Dim i As Integer
            Dim s As String
            anzcols = daten.Splits(0).DisplayColumns.Count
            Me.Tabelle = tablename
            For i = 0 To daten.Columns.Count - 1
                s = daten.Columns(i).DataField
                Me.Feld = s
                Me.getspalte()
                daten.Columns(i).Caption = Me.spaltenname

                If Me.ColWith = 0 Then
                    daten.Splits(0).DisplayColumns(i).Width = 0
                    daten.Splits(0).DisplayColumns(i).Visible = False
                Else
                    daten.Splits(0).DisplayColumns(i).Width = Me.ColWith
                End If

                If Me.locked Then
                    daten.Splits(0).DisplayColumns(i).Locked = True
                End If

                If Me.AlsHacken Then
                    daten.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                End If

                'Präsentation von aktiv
                If LCase(daten.Columns(i).DataField) = "aktiv" Then
                    daten.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                    daten.Columns(i).ValueItems.DefaultItem = True
                    daten.Columns(i).DefaultValue = True
                    daten.Columns(i).FilterText = True
                End If
                If LCase(daten.Columns(i).DataField) = "erstellt_am" Then
                    daten.Columns(i).DefaultValue = Now
                End If
            Next

        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Tabellenspalte Class
Tabellenspalte Members
Vertragsverwaltung.TKB.VV.Utils Namespace


frmKuendigungsfrist.Dispose Method

frmKuendigungsfrist.Dispose Method

Destructor Dispose
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overloads Sub Dispose()
C#
public System.Void Dispose();
C++

public:
System::Void Dispose()
JScript
public function Dispose();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Overloads Sub Dispose()
        Me.Kuendigungsfrist.Dispose()
        sec = Nothing
        msg = Nothing
        MyBase.Dispose()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmKuendigungsfrist Class
frmKuendigungsfrist Members


frmVertragspartner.Dispose Method

frmVertragspartner.Dispose Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
C#
[System.Diagnostics.DebuggerNonUserCode()]
protected override System.Void Dispose(
   bool disposing
);
C++
[System.Diagnostics.DebuggerNonUserCode()]

protected:
System::Void Dispose(
   bool disposing
)
JScript
protected
   System.Diagnostics.DebuggerNonUserCode()
function Dispose(
    disposing : boolean
);

Parameters

disposing

Expand image Source code

Visual Basic CopyCode image Copy Code
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


clsVertragspartner.dispose Method

clsVertragspartner.dispose Method

Destructor Dispose

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overloads Sub dispose()
C#
public System.Void dispose();
C++

public:
System::Void dispose()
JScript
public function dispose();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Overloads Sub dispose()
            Kontaktpersonen = Nothing
            Kontaktperson.Dispose()
            MyBase.Dispose()
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragspartner Class
clsVertragspartner Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


DomainTable Constructor (System.String, System.Int32, System.String)

DomainTable Constructor (System.String, System.Int32, System.String)
See Also
collapseAll image DropDown image

Tabellenname übernehmen und Daten ab DB laden

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal tablename As String, _
   Optional ByVal Fokus As Integer = 0, _
   Optional ByVal Keyvalue As String = "" _
)
C#
public System.Void DomainTable(
   string tablename,
   int Fokus,
   string Keyvalue
);
C++

public:
System::Void DomainTable(
   String^ tablename,
   int Fokus,
   String^ Keyvalue
)
JScript
public function DomainTable(
    tablename : String,
    Fokus : int,
    Keyvalue : String
);

Parameters

tablename

Required.

Fokus

Optional. The default value is 0.

Keyvalue

Optional. The default value is "".

Expand image Source code

Visual Basic CopyCode image Copy Code
        Sub New(ByVal tablename As String, Optional ByVal Fokus As Integer = 0, Optional ByVal Keyvalue As String = "")
            Me.Tablename = tablename
            If Keyvalue = "" Then
                Load_Data()
            Else
                Load_Bootom_Table(tablename, Fokus, Keyvalue)
            End If
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


DomainTable Constructor (System.String, System.String, System.Int32)

DomainTable Constructor (System.String, System.String, System.Int32)
See Also
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal tablename As String, _
   ByVal keyvalue As String, _
   ByVal mitarbeiternr As Integer _
)
C#
public System.Void DomainTable(
   string tablename,
   string keyvalue,
   int mitarbeiternr
);
C++

public:
System::Void DomainTable(
   String^ tablename,
   String^ keyvalue,
   int mitarbeiternr
)
JScript
public function DomainTable(
    tablename : String,
    keyvalue : String,
    mitarbeiternr : int
);

Parameters

tablename

keyvalue

mitarbeiternr

Expand image Source code

Visual Basic CopyCode image Copy Code
        Sub New(ByVal tablename As String, ByVal keyvalue As String, ByVal mitarbeiternr As Integer)
            Me.Tablename = tablename
            Load_Data_ma(tablename, keyvalue, mitarbeiternr)
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

DomainTable Class
DomainTable Members
Vertragsverwaltung.TKB.VV.Sysadmin Namespace


clsVertragselement.Get_Kuendigungsfristen (C1.Win.C1TrueDBGrid.C1TrueDBGrid) Method

clsVertragselement.Get_Kuendigungsfristen (C1.Win.C1TrueDBGrid.C1TrueDBGrid) Method
See Also
collapseAll image DropDown image

Kündiguntsfristen lasen und dem Grid übergeben

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Get_Kuendigungsfristen( _
   ByRef c1data As C1TrueDBGrid _
) As Object
C#
public object Get_Kuendigungsfristen(
   ref C1TrueDBGrid c1data
);
C++

public:
object^ Get_Kuendigungsfristen(
   C1TrueDBGrid^& c1data
)
JScript
public function Get_Kuendigungsfristen(
    c1data : C1TrueDBGrid
) : object;

Parameters

c1data

C1TrueDBGrid mit Kündigungsfristen

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Get_Kuendigungsfristen(ByRef c1data As C1TrueDBGrid)
            Try
                Kuendigungsfristen.dispose()
                Kuendigungsfristen = Nothing
            Catch ex As Exception

            End Try
            Kuendigungsfristen = New TKB.VV.Sysadmin.DomainTable("Kuendigungsfrist", Me.iVertragselementnr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = Kuendigungsfristen.Tabledata
            c1data.DataMember = Kuendigungsfristen.Tabledata.Tables(0).TableName

        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragselement.Get_Kuendigungsfristen (C1.Win.C1TrueDBGrid.C1TrueDBGrid, System.Int32) Method

clsVertragselement.Get_Kuendigungsfristen (C1.Win.C1TrueDBGrid.C1TrueDBGrid, System.Int32) Method
See Also
collapseAll image DropDown image

Kündiguntsfristen lasen und dem Grid übergeben

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Get_Kuendigungsfristen( _
   ByRef c1data As C1TrueDBGrid, _
   ByVal Vertragselementnr As Integer _
) As Object
C#
public object Get_Kuendigungsfristen(
   ref C1TrueDBGrid c1data,
   int Vertragselementnr
);
C++

public:
object^ Get_Kuendigungsfristen(
   C1TrueDBGrid^& c1data,
   int Vertragselementnr
)
JScript
public function Get_Kuendigungsfristen(
    c1data : C1TrueDBGrid,
    Vertragselementnr : int
) : object;

Parameters

c1data

C1TrueDBGrid mit Kündigungsfristen

Vertragselementnr

Vertragselement, für welches die Kündigungsfristen geladen werden sollen

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Get_Kuendigungsfristen(ByRef c1data As C1TrueDBGrid, ByVal Vertragselementnr As Integer)
            If Vertragselementnr <> -1 Then Me.Get_Vertragselement(Vertragselementnr)

            Try
                Kuendigungsfristen.dispose()
                Kuendigungsfristen = Nothing
            Catch ex As Exception

            End Try
            If Vertragselementnr <> -1 Then
                Me.Get_Vertragselement(Vertragselementnr)
            End If
            Kuendigungsfristen = New TKB.VV.Sysadmin.DomainTable("Kuendigungsfrist", Me.iVertragselementnr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = Kuendigungsfristen.Tabledata
            c1data.DataMember = Kuendigungsfristen.Tabledata.Tables(0).TableName

        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


frmVertragselementSuche.dispose Method

frmVertragselementSuche.dispose Method

Destructor Dispose
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overloads Sub dispose()
C#
public System.Void dispose();
C++

public:
System::Void dispose()
JScript
public function dispose();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Overloads Sub dispose()
        d.Dispose()
        MyBase.Dispose()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragselementSuche Class
frmVertragselementSuche Members


Tabellenspalte.Spaltentitel_aktualisieren (System.Object, System.String, System.Data.DataTable, System.Boolean) Method

Tabellenspalte.Spaltentitel_aktualisieren (System.Object, System.String, System.Data.DataTable, System.Boolean) Method
See Also
collapseAll image DropDown image

Namespace: Vertragsverwaltung.TKB.VV.Utils
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Spaltentitel_aktualisieren( _
   ByRef daten As Object, _
   ByRef tablename As String, _
   ByRef dt As DataTable, _
   Optional ByVal Aktiv_Spalte_True_Setzen As Boolean = True _
) As Object
C#
public object Spaltentitel_aktualisieren(
   ref object daten,
   ref string tablename,
   ref DataTable dt,
   bool Aktiv_Spalte_True_Setzen
);
C++

public:
object^ Spaltentitel_aktualisieren(
   object^& daten,
   String^& tablename,
   DataTable^& dt,
   bool Aktiv_Spalte_True_Setzen
)
JScript
public function Spaltentitel_aktualisieren(
    daten : object,
    tablename : String,
    dt : DataTable,
    Aktiv_Spalte_True_Setzen : boolean
) : object;

Parameters

daten

Required.

tablename

Required.

dt

Required.

Aktiv_Spalte_True_Setzen

Optional. The default value is True.

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Spaltentitel_aktualisieren(ByRef daten As Object, ByRef tablename As String, ByRef dt As DataTable, Optional ByVal Aktiv_Spalte_True_Setzen As Boolean = True)
            Dim anzcols As Integer
            Dim i As Integer
            Dim t As New DataTable()
            Dim s As String
            anzcols = daten.Splits(0).DisplayColumns.Count
            t = dt
            Me.Tabelle = tablename
            For i = 0 To daten.Columns.Count - 1
                s = daten.Columns(i).DataField
                Me.Feld = s
                Me.getspalte()
                daten.Columns(i).Caption = Me.spaltenname

                If Me.ColWith = 0 Then
                    daten.Splits(0).DisplayColumns(i).Width = 0
                    daten.Splits(0).DisplayColumns(i).Visible = False
                Else
                    daten.Splits(0).DisplayColumns(i).Width = Me.ColWith
                End If

                If Me.locked Then
                    daten.Splits(0).DisplayColumns(i).Locked = True
                End If

                If Me.AlsHacken Then
                    daten.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                End If

                'Präsentation von aktiv
                If LCase(daten.Columns(i).DataField) = "aktiv" And Aktiv_Spalte_True_Setzen = True Then
                    daten.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                    daten.Columns(i).ValueItems.DefaultItem = True
                    daten.Columns(i).DefaultValue = True
                    daten.Columns(i).FilterText = True
                End If
                If LCase(daten.Columns(i).DataField) = "erstellt_am" Then
                    daten.Columns(i).DefaultValue = Now
                End If
            Next

        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Tabellenspalte Class
Tabellenspalte Members
Vertragsverwaltung.TKB.VV.Utils Namespace


frmVertragspartner Constructor

frmVertragspartner Constructor

Constructor New
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void frmVertragspartner();
C++

public:
System::Void frmVertragspartner()
JScript
public function frmVertragspartner();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Sub New()
        MyBase.New()
        Me.InitializeComponent()
        Me.vpnr = -1
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner Constructor (System.Int32, System.Boolean, System.Boolean)

frmVertragspartner Constructor (System.Int32, System.Boolean, System.Boolean)
See Also
collapseAll image DropDown image

Formualr mit Vertragspartnernr und Anzeigestatus öffnen
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal vertragspartnernr As Integer, _
   ByVal Anzeige As Boolean, _
   Optional ByVal CreateNew As Boolean = False _
)
C#
public System.Void frmVertragspartner(
   int vertragspartnernr,
   bool Anzeige,
   bool CreateNew
);
C++

public:
System::Void frmVertragspartner(
   int vertragspartnernr,
   bool Anzeige,
   bool CreateNew
)
JScript
public function frmVertragspartner(
    vertragspartnernr : int,
    Anzeige : boolean,
    CreateNew : boolean
);

Parameters

vertragspartnernr

Nr des Vertragspartners

Anzeige

True=Readonly, False=normal

CreateNew

Optional. The default value is False.

Expand image Source code

Visual Basic CopyCode image Copy Code
    Sub New(ByVal vertragspartnernr As Integer, ByVal Anzeige As Boolean, Optional ByVal CreateNew As Boolean = False)
        MyBase.New()
        Me.InitializeComponent()
        Me.vpnr = vertragspartnernr
        Me.Anzeige = Anzeige
        If CreateNew Then
            Me.Get_Data(Me.Vertragspartnerdata.Add_New)
            Me.txtName_Firma1.Text = "*** Neuer Vertragspartner ***"
            Me.txtName_Firma1.SelectAll()
        End If
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragspartner.dispose Method

frmVertragspartner.dispose Method

destruction Dispose
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overloads Sub dispose()
C#
public System.Void dispose();
C++

public:
System::Void dispose()
JScript
public function dispose();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Overloads Sub dispose()
        Vertragspartnerdata.dispose()
        Kontaktperson.Dispose()
        sec = Nothing
        msg = Nothing
        SpaltenTitel = Nothing
        MyBase.Dispose()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragspartner Class
frmVertragspartner Members


frmVertragskontakt Constructor

frmVertragskontakt Constructor

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public System.Void frmVertragskontakt();
C++

public:
System::Void frmVertragskontakt()
JScript
public function frmVertragskontakt();

Expand image Source code

Visual Basic CopyCode image Copy Code
    Sub New()
        InitializeComponent()
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmVertragskontakt Constructor (System.Int32, System.Int32, System.Int32)

frmVertragskontakt Constructor (System.Int32, System.Int32, System.Int32)
See Also
collapseAll image DropDown image

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal Vertragskontaktnr As Integer, _
   ByVal Vertragspartnernr As Integer, _
   ByVal Vertragselementnr As Integer _
)
C#
public System.Void frmVertragskontakt(
   int Vertragskontaktnr,
   int Vertragspartnernr,
   int Vertragselementnr
);
C++

public:
System::Void frmVertragskontakt(
   int Vertragskontaktnr,
   int Vertragspartnernr,
   int Vertragselementnr
)
JScript
public function frmVertragskontakt(
    Vertragskontaktnr : int,
    Vertragspartnernr : int,
    Vertragselementnr : int
);

Parameters

Vertragskontaktnr

Vertragspartnernr

Vertragselementnr

Expand image Source code

Visual Basic CopyCode image Copy Code
    Sub New(ByVal Vertragskontaktnr As Integer, ByVal Vertragspartnernr As Integer, ByVal Vertragselementnr As Integer)
        InitializeComponent()
        Me.Vertragskontaktnr = Vertragskontaktnr
        Me.VertragspartnerNr = Vertragspartnernr
        Me.Vertragselementnr = Vertragselementnr
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmVertragskontakt Class
frmVertragskontakt Members


frmPerson.Dispose (System.Boolean) Method

frmPerson.Dispose (System.Boolean) Method

Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
C#
[System.Diagnostics.DebuggerNonUserCode()]
protected override System.Void Dispose(
   bool disposing
);
C++
[System.Diagnostics.DebuggerNonUserCode()]

protected:
System::Void Dispose(
   bool disposing
)
JScript
protected
   System.Diagnostics.DebuggerNonUserCode()
function Dispose(
    disposing : boolean
);

Parameters

disposing

Expand image Source code

Visual Basic CopyCode image Copy Code
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPerson Class
frmPerson Members


clsVertragselement.dispose Method

clsVertragselement.dispose Method

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Overloads Sub dispose()
C#
public System.Void dispose();
C++

public:
System::Void dispose()
JScript
public function dispose();

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Overloads Sub dispose()
            MyBase.Dispose()

            vertragstyp.Dispose()
            vertragstyp = Nothing
            Try
                Vertragspartner.Dispose()
                Vertragspartner = Nothing
            Catch
            End Try
        End Sub

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragselement.Get_Vertragskontakte (C1.Win.C1TrueDBGrid.C1TrueDBGrid) Method

clsVertragselement.Get_Vertragskontakte (C1.Win.C1TrueDBGrid.C1TrueDBGrid) Method
See Also
collapseAll image DropDown image

Kontakte auslesen und dem TrueDBGrid übergeben

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Get_Vertragskontakte( _
   ByRef c1data As C1TrueDBGrid _
) As Object
C#
public object Get_Vertragskontakte(
   ref C1TrueDBGrid c1data
);
C++

public:
object^ Get_Vertragskontakte(
   C1TrueDBGrid^& c1data
)
JScript
public function Get_Vertragskontakte(
    c1data : C1TrueDBGrid
) : object;

Parameters

c1data

C1TrueDBGrid

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Get_Vertragskontakte(ByRef c1data As C1TrueDBGrid)
            Try
                Vertragskontakte.dispose()
                Vertragskontakte = Nothing
            Catch ex As Exception

            End Try
            Vertragskontakte = New TKB.VV.Sysadmin.DomainTable("Vertragskontakt", Me.iVertragselementnr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = Vertragskontakte.Tabledata
            c1data.DataMember = Vertragskontakte.Tabledata.Tables(0).TableName
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace


clsVertragselement.Get_Vertragskontakte (C1.Win.C1TrueDBGrid.C1TrueDBGrid, System.Int32) Method

clsVertragselement.Get_Vertragskontakte (C1.Win.C1TrueDBGrid.C1TrueDBGrid, System.Int32) Method
See Also
collapseAll image DropDown image

Kontakte auslesen und dem TrueDBGrid übergeben

Namespace: Vertragsverwaltung.TKB.VV.Vertrag
Assembly: Vertragsverwaltung (in Vertragsverwaltung.exe)

Expand image Syntax

Visual Basic (Declaration)
Public Function Get_Vertragskontakte( _
   ByRef c1data As C1TrueDBGrid, _
   ByVal Vertragselementnr As Integer _
) As Object
C#
public object Get_Vertragskontakte(
   ref C1TrueDBGrid c1data,
   int Vertragselementnr
);
C++

public:
object^ Get_Vertragskontakte(
   C1TrueDBGrid^& c1data,
   int Vertragselementnr
)
JScript
public function Get_Vertragskontakte(
    c1data : C1TrueDBGrid,
    Vertragselementnr : int
) : object;

Parameters

c1data

C1TrueDBGrid

Vertragselementnr

Vertragselement, für welches die Kontakte ausgelesen werden

Expand image Source code

Visual Basic CopyCode image Copy Code
        Public Function Get_Vertragskontakte(ByRef c1data As C1TrueDBGrid, ByVal Vertragselementnr As Integer)
            Me.Get_Vertragselement(Vertragselementnr)
            Vertragskontakte = New TKB.VV.Sysadmin.DomainTable("Vertragskontakt", Me.iVertragselementnr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = Vertragskontakte.Tabledata
            c1data.DataMember = Vertragskontakte.Tabledata.Tables(0).TableName
        End Function

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsVertragselement Class
clsVertragselement Members
Vertragsverwaltung.TKB.VV.Vertrag Namespace