AllgFnkt_Plugin Reference

[image] [image] [image]

Generated by VSdocman


AllgFnkt_Plugin Namespace

[image] [image] [image]

AllgFnkt_Plugin Reference
AllgFnkt_Plugin Namespace

Assembly: AllgFnkt_Plugin (in AllgFnkt_Plugin.dll)

Expand image Classes

 | Name | Description
Supported by the .NET Compact Framework. | Plugin |
Supported by the .NET Compact Framework. | clsAllgFnkt |
Supported by the .NET Compact Framework. | frmPrinterSettings |
Supported by the .NET Compact Framework. | frmPrinterSettings_sik |
Top

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0


Plugin Class

[image] [image] [image]

AllgFnkt_Plugin Reference
Plugin Class
Members

Assembly: AllgFnkt_Plugin (in AllgFnkt_Plugin.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Class Plugin
    Implements IPlugin
C#
public class Plugin : IPlugin
C++
public ref class Plugin  : public IPlugin^
JScript
public class Plugin
   implements IPlugin

Expand image Inheritance Hierarchy

System.Object
AllgFnkt_Plugin.Plugin

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Plugin Members


Plugin Members

[image] [image] [image]

AllgFnkt_Plugin Reference
Plugin Members
Plugin Class Methods Properties See Also

The following tables list the members exposed by the Plugin type.

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | ErrorCode | Liefer Fehlercode Code ungleich 0 - Detaillierte Meldung in Error-Message
Supported by the .NET Compact Framework. | ErrorMessage | Fehlermeldung bei iError-Code ungleich 0
Supported by the .NET Compact Framework. | IAppdomain | Gets or sets .
Supported by the .NET Compact Framework. | PluginName | Liefert Plugin-Name und Version
Supported by the .NET Compact Framework. | Returnwert | Liefert ein allfälliges Resultat aus einer Funktion zurück
Top

Expand image Public Methods

 | Name | Description
Public method | Equals | (Overloaded) Bestimmt, ob das angegebene Object und das aktuelle Object gleich sind. (inherited from Object).
Public method | GetHashCode | Fungiert als Hashfunktion für einen bestimmten Typ. (inherited from Object).
Public method | GetType | Ruft den Type der aktuellen Instanz ab. (inherited from Object).
 | ReferenceEquals | Stellt fest, ob die angegebenen Object-Instanzen dieselbe Instanz sind. (inherited from Object).
Supported by the .NET Compact Framework. | Start | Startet eine implementierte Funktion: - Formularaktualisierung - Printersettings
Public method | ToString | Gibt einen String zurück, der das aktuelle Object darstellt. (inherited from Object).
Top

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Finalize | Gibt einem Object Gelegenheit zu dem Versuch, Ressourcen freizugeben und andere Bereinigungen durchzuführen, bevor das Object von der Garbage Collection freigegeben wird.
Protected method | MemberwiseClone | Erstellt eine flache Kopie des aktuellen Object. (inherited from Object).
Top

Expand image See Also

Reference

Plugin Class


Plugin Properties

[image] [image] [image]

AllgFnkt_Plugin Reference
Plugin Properties
Plugin Class See Also

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | ErrorCode | Liefer Fehlercode Code ungleich 0 - Detaillierte Meldung in Error-Message
Supported by the .NET Compact Framework. | ErrorMessage | Fehlermeldung bei iError-Code ungleich 0
Supported by the .NET Compact Framework. | IAppdomain | Gets or sets .
Supported by the .NET Compact Framework. | PluginName | Liefert Plugin-Name und Version
Supported by the .NET Compact Framework. | Returnwert | Liefert ein allfälliges Resultat aus einer Funktion zurück
Top

Expand image See Also

Reference

Plugin Class


Plugin.ErrorCode Property

[image] [image] [image]

AllgFnkt_Plugin Reference
Plugin.ErrorCode Property
See Also

Liefer Fehlercode Code ungleich 0 - Detaillierte Meldung in Error-Message
Assembly: AllgFnkt_Plugin (in AllgFnkt_Plugin.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property ErrorCode() As Integer Implements  _
   IPlugin.ErrorCode
C#
public int ErrorCode {get; set;}
C++
public:
property int ErrorCode {
 int get( );
 void set(
   int value
 );
}
JScript
public function get ErrorCode() : int;
public function set ErrorCode(value : int);

Implements

IPlugin.ErrorCode

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Plugin Class
Plugin Members


Plugin.ErrorMessage Property

[image] [image] [image]

AllgFnkt_Plugin Reference
Plugin.ErrorMessage Property
See Also

Fehlermeldung bei iError-Code ungleich 0
Assembly: AllgFnkt_Plugin (in AllgFnkt_Plugin.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property ErrorMessage() As String Implements  _
   IPlugin.Error_Message
C#
public string ErrorMessage {get; set;}
C++
public:
property String^ ErrorMessage {
 String^ get( );
 void set(
   String^ value
 );
}
JScript
public function get ErrorMessage() : String;
public function set ErrorMessage(value : String);

Implements

IPlugin.Error_Message

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Plugin Class
Plugin Members


Plugin.IAppdomain Property

[image] [image] [image]

AllgFnkt_Plugin Reference
Plugin.IAppdomain Property
See Also

Gets or sets .
Assembly: AllgFnkt_Plugin (in AllgFnkt_Plugin.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property IAppdomain() As AppDomain Implements  _
   IPlugin.IAppdomain
C#
public AppDomain IAppdomain {get; set;}
C++
public:
property AppDomain^ IAppdomain {
 AppDomain^ get( );
 void set(
   AppDomain^ value
 );
}
JScript
public function get IAppdomain() : AppDomain;
public function set IAppdomain(value : AppDomain);

Implements

IPlugin.IAppdomain

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Plugin Class
Plugin Members


Plugin.PluginName Property

[image] [image] [image]

AllgFnkt_Plugin Reference
Plugin.PluginName Property
See Also

Liefert Plugin-Name und Version
Assembly: AllgFnkt_Plugin (in AllgFnkt_Plugin.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property PluginName() As String Implements  _
   IPlugin.PluginName
C#
public string PluginName {get;}
C++
public:
property String^ PluginName {
 String^ get( );
}
JScript
public function get PluginName() : String;

Implements

IPlugin.PluginName

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Plugin Class
Plugin Members


Plugin.Returnwert Property

[image] [image] [image]

AllgFnkt_Plugin Reference
Plugin.Returnwert Property
See Also

Liefert ein allfälliges Resultat aus einer Funktion zurück
Assembly: AllgFnkt_Plugin (in AllgFnkt_Plugin.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Returnwert() As Object Implements  _
   IPlugin.Returnwert
C#
public object Returnwert {get; set;}
C++
public:
property object^ Returnwert {
 object^ get( );
 void set(
   object^ value
 );
}
JScript
public function get Returnwert() : object;
public function set Returnwert(value : object);

Implements

IPlugin.Returnwert

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Plugin Class
Plugin Members


Plugin Methods

[image] [image] [image]

AllgFnkt_Plugin Reference
Plugin Methods
Plugin Class See Also

Expand image Public Methods

 | Name | Description
Public method | Equals | (Overloaded) Bestimmt, ob das angegebene Object und das aktuelle Object gleich sind. (inherited from Object).
Public method | GetHashCode | Fungiert als Hashfunktion für einen bestimmten Typ. (inherited from Object).
Public method | GetType | Ruft den Type der aktuellen Instanz ab. (inherited from Object).
 | ReferenceEquals | Stellt fest, ob die angegebenen Object-Instanzen dieselbe Instanz sind. (inherited from Object).
Supported by the .NET Compact Framework. | Start | Startet eine implementierte Funktion: - Formularaktualisierung - Printersettings
Public method | ToString | Gibt einen String zurück, der das aktuelle Object darstellt. (inherited from Object).
Top

Expand image Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Finalize | Gibt einem Object Gelegenheit zu dem Versuch, Ressourcen freizugeben und andere Bereinigungen durchzuführen, bevor das Object von der Garbage Collection freigegeben wird.
Protected method | MemberwiseClone | Erstellt eine flache Kopie des aktuellen Object. (inherited from Object).
Top

Expand image See Also

Reference

Plugin Class


Plugin.Finalize Method

[image] [image] [image]

AllgFnkt_Plugin Reference
Plugin.Finalize Method
See Also

Gibt einem Object Gelegenheit zu dem Versuch, Ressourcen freizugeben und andere Bereinigungen durchzuführen, bevor das Object von der Garbage Collection freigegeben wird.
Assembly: AllgFnkt_Plugin (in AllgFnkt_Plugin.dll)

Expand image Syntax

Visual Basic (Declaration)
Protected Overrides Sub Finalize()
C#
protected override System.Void Finalize()
C++
protected:
System::Void Finalize()
JScript
protected function Finalize();

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Plugin Class
Plugin Members


Plugin.Start Method

[image] [image] [image]

AllgFnkt_Plugin Reference
Plugin.Start Method
See Also

Startet eine implementierte Funktion: - Formularaktualisierung - Printersettings
Assembly: AllgFnkt_Plugin (in AllgFnkt_Plugin.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Start( _
   ByVal App As Object, _
   ByRef Fnkt As String, _
   ByRef Parameters As Object _
) As Object Implements  _
   IPlugin.Start
C#
public object Start(
   object App,
   ref string Fnkt,
   ref object Parameters
)
C++
public:
object^ Start(
   object^ App,
   String^& Fnkt,
   object^& Parameters
)
JScript
public function Start(
    App : object,
    Fnkt : String,
    Parameters : object
) : object;

Parameters

App

Type: object

Applikationsobjekt (z.B. Word)

Fnkt

Type: string

Aufzurufende Funktion

Parameters

Type: object

Parameter sofern von der Funktion unterstütz

Return Value

Returnwert aus der Funktion, sofern von der Funktion unterstützt

Implements

IPlugin.Start

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

Plugin Class
Plugin Members


clsAllgFnkt Class

[image] [image] [image]

AllgFnkt_Plugin Reference
clsAllgFnkt Class
Members

Assembly: AllgFnkt_Plugin (in AllgFnkt_Plugin.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Class clsAllgFnkt
C#
public class clsAllgFnkt
C++
public ref class clsAllgFnkt
JScript
public class clsAllgFnkt

Expand image Inheritance Hierarchy

System.Object
AllgFnkt_Plugin.clsAllgFnkt

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsAllgFnkt Members


clsAllgFnkt Members

[image] [image] [image]

AllgFnkt_Plugin Reference
clsAllgFnkt Members
clsAllgFnkt Class Methods See Also

The following tables list the members exposed by the clsAllgFnkt type.

Expand image Public Methods

 | Name | Description
Public method | Equals | (Overloaded) Bestimmt, ob das angegebene Object und das aktuelle Object gleich sind. (inherited from Object).
Supported by the .NET Compact Framework. | FormularAktualisieren |
Public method | GetHashCode | Fungiert als Hashfunktion für einen bestimmten Typ. (inherited from Object).
Public method | GetType | Ruft den Type der aktuellen Instanz ab. (inherited from Object).
 | ReferenceEquals | Stellt fest, ob die angegebenen Object-Instanzen dieselbe Instanz sind. (inherited from Object).
Public method | ToString | Gibt einen String zurück, der das aktuelle Object darstellt. (inherited from Object).
Top

Expand image Protected Methods

 | Name | Description
Protected method | Finalize | Gibt einem Object Gelegenheit zu dem Versuch, Ressourcen freizugeben und andere Bereinigungen durchzuführen, bevor das Object von der Garbage Collection freigegeben wird. (inherited from Object).
Protected method | MemberwiseClone | Erstellt eine flache Kopie des aktuellen Object. (inherited from Object).
Top

Expand image See Also

Reference

clsAllgFnkt Class


clsAllgFnkt Methods

[image] [image] [image]

AllgFnkt_Plugin Reference
clsAllgFnkt Methods
clsAllgFnkt Class See Also

Expand image Public Methods

 | Name | Description
Public method | Equals | (Overloaded) Bestimmt, ob das angegebene Object und das aktuelle Object gleich sind. (inherited from Object).
Supported by the .NET Compact Framework. | FormularAktualisieren |
Public method | GetHashCode | Fungiert als Hashfunktion für einen bestimmten Typ. (inherited from Object).
Public method | GetType | Ruft den Type der aktuellen Instanz ab. (inherited from Object).
 | ReferenceEquals | Stellt fest, ob die angegebenen Object-Instanzen dieselbe Instanz sind. (inherited from Object).
Public method | ToString | Gibt einen String zurück, der das aktuelle Object darstellt. (inherited from Object).
Top

Expand image Protected Methods

 | Name | Description
Protected method | Finalize | Gibt einem Object Gelegenheit zu dem Versuch, Ressourcen freizugeben und andere Bereinigungen durchzuführen, bevor das Object von der Garbage Collection freigegeben wird. (inherited from Object).
Protected method | MemberwiseClone | Erstellt eine flache Kopie des aktuellen Object. (inherited from Object).
Top

Expand image See Also

Reference

clsAllgFnkt Class


clsAllgFnkt.FormularAktualisieren Method

[image] [image] [image]

AllgFnkt_Plugin Reference
clsAllgFnkt.FormularAktualisieren Method
See Also

Assembly: AllgFnkt_Plugin (in AllgFnkt_Plugin.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FormularAktualisieren( _
   ByRef app As Object _
) As Object
C#
public object FormularAktualisieren(
   ref object app
)
C++
public:
object^ FormularAktualisieren(
   object^& app
)
JScript
public function FormularAktualisieren(
    app : object
) : object;

Parameters

app

Type: object

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

clsAllgFnkt Class
clsAllgFnkt Members


frmPrinterSettings Class

[image] [image] [image]

AllgFnkt_Plugin Reference
frmPrinterSettings Class
Members

Assembly: AllgFnkt_Plugin (in AllgFnkt_Plugin.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Class frmPrinterSettings
    Inherits Form
C#
public class frmPrinterSettings : Form
C++
public ref class frmPrinterSettings : public Form^
JScript
public class frmPrinterSettings
   extends Form

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
AllgFnkt_Plugin.frmPrinterSettings

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPrinterSettings Members


frmPrinterSettings Members

[image] [image] [image]

AllgFnkt_Plugin Reference
frmPrinterSettings Members
frmPrinterSettings Class Constructors Events Methods Properties See Also

The following tables list the members exposed by the frmPrinterSettings type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | frmPrinterSettings Constructor | Initializes a new instance of the frmPrinterSettings class.
Top

Expand image Public Properties

 | Name | Description
Public property | AcceptButton | Ruft die Schaltfläche im Formular ab, die beim Drücken der EINGABETASTE betätigt wird, oder legt diese fest. (inherited from Form).
Public property | AccessibilityObject | Ruft das dem Steuerelement zugewiesene AccessibleObject ab. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Ruft die Beschreibung der Standardaktion des Steuerelements für die Verwendung durch Clientanwendungen für die Barrierefreiheit ab oder legt diese fest. (inherited from Control).
Public property | AccessibleDescription | Ruft die Beschreibung des von Clientanwendungen für die Barrierefreiheit verwendeten Steuerelements ab oder legt diese fest. (inherited from Control).
Public property | AccessibleName | Ruft den Namen des von Clientanwendungen für die Barrierefreiheit verwendeten Steuerelements ab oder legt diesen fest. (inherited from Control).
Public property | AccessibleRole | Ruft die barrierefreie Rolle des Steuerelements ab oder legt diese fest. (inherited from Control).
Public property | ActiveControl | Ruft das aktive Steuerelement im Containersteuerelement ab oder legt dieses fest. (inherited from ContainerControl).
 | ActiveForm | Ruft das momentan aktive Formular für diese Anwendung ab. (inherited from Form).
Public property | ActiveMdiChild | Ruft das momentan aktive untergeordnete MDI (Multiple Document Interface)-Fenster ab. (inherited from Form).
Public property | AllowDrop | Ruft einen Wert ab, der angibt, ob das Steuerelement Daten annehmen kann, die vom Benutzer darauf gezogen wurden, oder legt diesen fest. (inherited from Control).
Public property | AllowTransparency | Ruft einen Wert ab, der angibt, ob die Durchlässigkeit des Formulars angepasst werden kann, oder legt diesen Wert fest. (inherited from Form).
Public property | Anchor | Ruft die Ränder des Containers ab, an die ein Steuerelement gebunden ist, oder legt diese fest und bestimmt, wie die Größe des Steuerelements mit dessen übergeordnetem Element geändert wird. (inherited from Control).
Public property | AutoScale | Obsolete. Ruft einen Wert ab, der angibt, ob die Größe des Formulars der Höhe der im Formular verwendeten Schriftart angepasst wird und die Steuerelemente des Formulars skaliert werden, oder legt diesen fest. (inherited from Form).
Public property | AutoScaleBaseSize | Ruft die Grundgröße ab, die für die automatische Skalierung des Formulars verwendet wird, oder legt diese fest. (inherited from Form).
Public property | AutoScaleDimensions | Ruft die Dimensionen ab, für die das Steuerelement entworfen wurde, oder ruft diese ab. (inherited from ContainerControl).
Public property | AutoScaleMode | Ruft den automatischen Skalierungsmodus des Steuerelements ab oder legt diesen fest. (inherited from ContainerControl).
Public property | AutoScroll | Ruft einen Wert ab, der angibt, ob das Formular den automatischen Bildlauf ermöglicht, oder legt diesen fest. (inherited from Form).
Public property | AutoScrollMargin | Ruft die Größe des AutoBildlaufrandes ab oder legt diese fest. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Ruft die minimale Größe des AutoBildlaufs ab oder legt diese fest. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Ruft in Control) ab oder legt anhand dessen fest, in welcher Richtung der Bildlauf dieses Steuerelements durchgeführt wird. (inherited from Control).
Public property | AutoScrollPosition | Ruft die Position des AutoBildlaufs ab oder legt diese fest. (inherited from ScrollableControl).
Public property | AutoSize | Ändern Sie die Größe des Formulars entsprechend der Einstellung von AutoSizeMode. (inherited from Form).
Public property | AutoSizeMode | Ruft den Modus ab, in dem das Formular seine Größe automatisch selbst ändert, oder legt diesen Modus fest. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Ruft das im Steuerelement angezeigte Hintergrundbild ab oder legt dieses fest. (inherited from Control).
Public property | BackgroundImageLayout | Ruft das Layout für das Hintergrundbild wie in der ImageLayout-Enumeration definiert ab oder legt dieses fest. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Ruft den Abstand zwischen dem unteren Rand des Steuerelements und dem oberen Rand des Clientbereichs des zugehörigen Containers in Pixel ab. (inherited from Control).
Public property | Bounds | Ruft die Größe und die Position des Steuerelements, einschließlich seiner Nicht-Clientelemente, in Pixel relativ zum übergeordneten Steuerelement ab oder legt diese fest. (inherited from Control).
Public property | CanFocus | Ruft einen Wert ab, der angibt, ob das Steuerelement den Fokus erhalten kann. (inherited from Control).
Public property | CanSelect | Ruft einen Wert ab, der angibt, ob das Steuerelement ausgewählt werden kann. (inherited from Control).
Public property | CancelButton | Ruft das Button-Steuerelement ab, das beim Drücken von ESC betätigt wird, oder legt dieses fest. (inherited from Form).
Public property | Capture | Ruft einen Wert ab, der angibt, ob die Maus vom Steuerelement erfasst wurde, oder legt diesen fest. (inherited from Control).
Public property | CausesValidation | Ruft einen Wert ab, der angibt, ob das Steuerelement bei Erhalt des Fokus eine Validierung für alle eine Validierung erfordernden Steuerelemente veranlasst, oder legt diesen fest. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Ruft einen Wert ab, mit dem angegeben wird, ob Aufrufe an den falschen Thread, der auf die Handle-Eigenschaft eines Steuerelements zugreift, abgefangen werden sollen, wenn eine Anwendung gedebuggt wird, oder legt diesen Wert fest. (inherited from Control).
Public property | ClientRectangle | Ruft das Rechteck ab, das den Clientbereich des Steuerelements darstellt. (inherited from Control).
Public property | ClientSize | Ruft die Größe des Clientbereichs des Formulars ab oder legt diese fest. (inherited from Form).
Public property | CompanyName | Ruft den Namen des Unternehmens oder des Entwicklers der Anwendung ab, die das Steuerelement enthält. (inherited from Control).
Public property | Container | Ruft den IContainer ab, der die Component enthält. (inherited from Component).
Public property | ContainsFocus | Ruft einen Wert ab, der angibt, ob das Steuerelement oder eines der untergeordneten Steuerelemente den Eingabefokus besitzt. (inherited from Control).
Public property | ContextMenu | Ruft das dem Steuerelement zugeordnete Kontextmenü ab oder legt dieses fest. (inherited from Control).
Public property | ContextMenuStrip | Ruft die diesem Steuerelement zugeordnete ContextMenuStrip-Klasse ab oder legt diese fest. (inherited from Control).
Public property | ControlBox | Ruft einen Wert ab, der angibt, ob auf der Titelleiste des Formulars ein Systemmenüfeld angezeigt wird, oder legt diesen fest. (inherited from Form).
Public property | Controls | Ruft die im Steuerelement enthaltene Auflistung von Steuerelementen ab. (inherited from Control).
Public property | Created | Ruft einen Wert ab, der angibt, ob das Steuerelement erstellt wurde. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Ruft die aktuellen Laufzeitdimensionen des Bildschirms ab. (inherited from ContainerControl).
Public property | Cursor | Ruft den Cursor ab, der angezeigt wird, wenn sich der Mauszeiger über dem Steuerelement befindet, oder legt diesen fest. (inherited from Control).
Public property | DataBindings | Ruft die Datenbindungen für das Steuerelement ab. (inherited from Control).
 | DefaultBackColor | Ruft die Standardhintergrundfarbe des Steuerelements ab. (inherited from Control).
 | DefaultFont | Ruft die Standardschriftart des Steuerelements ab. (inherited from Control).
 | DefaultForeColor | Ruft die Standardvordergrundfarbe des Steuerelements ab. (inherited from Control).
Public property | DesktopBounds | Ruft Größe und Position des Formulars auf dem Windows-Desktop ab oder legt diese fest. (inherited from Form).
Public property | DesktopLocation | Ruft die Position des Formulars auf dem Windows-Desktop ab oder legt diese fest. (inherited from Form).
Public property | DialogResult | Ruft das Dialogergebnis für das Formular ab oder legt dieses fest. (inherited from Form).
Public property | DisplayRectangle | Ruft das Rechteck ab, das den virtuellen Anzeigebereich des Steuerelements darstellt. (inherited from ScrollableControl).
Public property | Disposing | Ruft einen Wert ab, der angibt, ob die Control-Basisklasse gerade freigegeben wird. (inherited from Control).
Public property | Dock | Ruft ab oder legt fest, welche Steuerelementrahmen am übergeordneten Steuerelement angedockt sind, und bestimmt, wie die Größe eines Steuerelements mit dem übergeordneten Steuerelement geändert wird. (inherited from Control).
Public property | DockPadding | Ruft die Einstellungen für den Andockleerraum für alle Ränder des Steuerelements ab. (inherited from ScrollableControl).
Public property | Enabled | Ruft einen Wert ab, der angibt, ob das Steuerelement auf Benutzerinteraktionen reagieren kann, oder legt diesen fest. (inherited from Control).
Public property | Focused | Ruft einen Wert ab, der angibt, ob das Steuerelement den Eingabefokus besitzt. (inherited from Control).
Public property | Font | Ruft die Schriftart für die Anzeige von Text im Steuerelement ab oder legt diese fest. (inherited from Control).
Public property | ForeColor | Ruft die Vordergrundfarbe des Steuerelements ab oder legt diese fest. (inherited from Control).
Public property | FormBorderStyle | Ruft die Rahmenart des Formulars ab oder legt diese fest. (inherited from Form).
Public property | Handle | Ruft das Fensterhandle ab, an das das Steuerelement gebunden ist. (inherited from Control).
Public property | HasChildren | Ruft einen Wert ab, der angibt, ob das Steuerelement ein oder mehrere untergeordnete Steuerelemente enthält. (inherited from Control).
Public property | Height | Ruft die Höhe des Steuerelements ab oder legt diese fest. (inherited from Control).
Public property | HelpButton | Ruft einen Wert ab, der angibt, ob auf der Titelleiste des Formulars die Hilfeschaltfläche angezeigt werden soll, oder legt diesen fest. (inherited from Form).
Public property | HorizontalScroll | Ruft die der horizontalen Schiebeleiste zugeordneten Merkmale ab. (inherited from ScrollableControl).
Public property | Icon | Ruft das Symbol für das Formular ab oder legt dieses fest. (inherited from Form).
Public property | ImeMode | Ruft den IME-Modus (Eingabemethoden-Editor) des Steuerelements ab oder legt diesen fest. (inherited from Control).
Public property | InvokeRequired | Ruft einen Wert ab, der angibt ob der Aufrufer beim Aufruf von Methoden des Steuerelements eine Aufrufmethode aufrufen muss, da sich der Aufrufer in einem anderen Thread als dem befindet, in dem das Steuerelement erstellt wurde. (inherited from Control).
Public property | IsAccessible | Ruft einen Wert ab, der angibt, ob das Steuerelement für barrierefreie Anwendungen sichtbar ist, oder legt diesen fest. (inherited from Control).
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Steuerelement freigegeben wurde. (inherited from Control).
Public property | IsHandleCreated | Ruft einen Wert ab, der angibt, ob dem Steuerelement ein Handle zugeordnet ist. (inherited from Control).
Public property | IsMdiChild | Ruft einen Wert ab, der angibt, ob das Formular ein untergeordnetes MDI (Multiple Document Interface)-Formular ist. (inherited from Form).
Public property | IsMdiContainer | Ruft einen Wert ab, der angibt, ob das Formular ein Container für untergeordnete MDI (Multiple Document Interface)-Formulare ist, oder legt diesen fest. (inherited from Form).
Public property | IsMirrored | Ruft einen Wert ab, der angibt, ob das Steuerelement gespiegelt wird. (inherited from Control).
Public property | IsRestrictedWindow | Ruft einen Wert ab, der angibt, ob für das Formular alle Fenster und Benutzereingabeereignisse uneingeschränkt verwendet werden können. (inherited from Form).
Public property | KeyPreview | Ruft einen Wert ab, der angibt, ob das Formular Tastaturereignisse empfängt, bevor das Ereignis an das Steuerelement übergeben wird, das den Fokus besitzt, oder legt diesen fest. (inherited from Form).
Public property | LayoutEngine | Ruft eine zwischengespeicherte Instanz des Layoutmoduls des Steuerelements ab. (inherited from Control).
Public property | Left | Ruft den Abstand zwischen dem linken Rand des Steuerelements und dem linken Rand des Clientbereichs des zugehörigen Containers in Pixel ab oder legt diesen fest. (inherited from Control).
Public property | Location | Ruft den Point ab, der die linke obere Ecke des Form in Bildschirmkoordinaten darstellt, oder legt diesen fest. (inherited from Form).
Public property | MainMenuStrip | Ruft den primären Menücontainer für das Formular ab oder legt diesen fest. (inherited from Form).
Public property | Margin | Ruft den Zwischenraum zwischen Steuerelementen ab oder legt diesen fest. (inherited from Form).
Public property | MaximizeBox | Ruft einen Wert ab, der angibt, ob auf der Titelleiste des Formulars die Schaltfläche Maximieren angezeigt wird, oder legt diesen fest. (inherited from Form).
Public property | MaximumSize | Ruft die maximale Größe für die Vergrößerung des Formulars ab. (inherited from Form).
Public property | MdiChildren | Ruft ein Array von Formularen ab, das die untergeordneten MDI (Multiple Document Interface)-Formulare darstellt, deren übergeordnetes Formular dieses Formular ist. (inherited from Form).
Public property | MdiParent | Ruft das aktuelle übergeordnete MDI (Multiple Document Interface)-Formular für dieses Formular ab oder legt dieses fest. (inherited from Form).
Public property | Menu | Ruft das MainMenu ab, das im Formular angezeigt wird, oder legt dieses fest. (inherited from Form).
Public property | MergedMenu | Ruft das zusammengeführte Menü für das Formular ab. (inherited from Form).
Public property | MinimizeBox | Ruft einen Wert ab, der angibt, ob auf der Titelleiste des Formulars die Schaltfläche Minimieren angezeigt wird, oder legt diesen fest. (inherited from Form).
Public property | MinimumSize | Ruft die Mindestgröße des Formulars ab oder legt diese fest. (inherited from Form).
Public property | Modal | Ruft einen Wert ab, der angibt, ob dieses Formular modal angezeigt wird. (inherited from Form).
 | ModifierKeys | Ruft einen Wert ab, der angibt, welche der Modifizierertasten (UMSCHALT, STRG und/oder ALT) gerade gedrückt wird. (inherited from Control).
 | MouseButtons | Ruft einen Wert ab, der angibt, welche Maustaste gerade gedrückt wird. (inherited from Control).
 | MousePosition | Ruft die Position des Mauszeigers in Bildschirmkoordinaten ab. (inherited from Control).
Public property | Name | Ruft den Namen des Steuerelements ab oder legt diesen fest. (inherited from Control).
Public property | Opacity | Ruft die Durchlässigkeit des Formulars ab oder legt diese fest. (inherited from Form).
Public property | OwnedForms | Ruft ein Array von Form-Objekten ab, die alle Formulare darstellen, die dieses Formular besitzt. (inherited from Form).
Public property | Owner | Ruft das Formular ab, das Besitzer dieses Formulars ist, oder legt dieses fest. (inherited from Form).
Public property | Padding | Ruft den Abstand im Steuerelement ab oder legt diesen fest. (inherited from Control).
Public property | Parent | Ruft den übergeordneten Container des Steuerelements ab oder legt diesen fest. (inherited from Control).
Public property | ParentForm | Ruft das Formular ab, dem das Containersteuerelement zugewiesen ist. (inherited from ContainerControl).
Public property | PreferredSize | Ruft die Größe eines rechteckigen Bereichs ab, in den das Steuerelement eingepasst werden kann. (inherited from Control).
Public property | ProductName | Ruft den Produktnamen der Assembly ab, die das Steuerelement enthält. (inherited from Control).
Public property | ProductVersion | Ruft die Version der Assembly ab, die das Steuerelement enthält. (inherited from Control).
Public property | RecreatingHandle | Ruft einen Wert ab, der angibt, ob das Steuerelement gerade das zugehörige Handle neu erstellt. (inherited from Control).
Public property | Region | Ruft den dem Steuerelement zugeordneten Fensterbereich ab oder legt diesen fest. (inherited from Control).
Public property | RestoreBounds | Ruft die Position und die Größe des Formulars im normalen Fensterzustand ab. (inherited from Form).
Public property | Right | Ruft den Abstand zwischen dem rechten Rand des Steuerelements und dem linken Rand des Clientbereichs des zugehörigen Containers in Pixel ab. (inherited from Control).
Public property | RightToLeft | Ruft einen Wert ab, der angibt, ob Elemente des Steuerelements für die Unterstützung von Gebietsschemas ausgerichtet sind, die von rechts nach links geschriebene Schriftarten verwenden, oder legt diesen fest. (inherited from Control).
Public property | RightToLeftLayout | Ruft einen Wert ab, der angibt, ob die Anordnung der Spiegelung von rechts nach links aktiviert ist, oder legt diesen Wert fest. (inherited from Form).
Public property | ShowIcon | Ruft einen Wert ab, der angibt, ob ein Symbol auf der Titelleiste des Formulars angezeigt wird, oder legt diesen Wert fest. (inherited from Form).
Public property | ShowInTaskbar | Ruft einen Wert ab, der angibt, ob das Formular auf der Windows-Taskleiste angezeigt wird, oder legt diesen fest. (inherited from Form).
Public property | Site | Ruft die Site des Steuerelements ab oder legt diese fest. (inherited from Control).
Public property | Size | Ruft die Größe des Formulars ab oder legt diese fest. (inherited from Form).
Public property | SizeGripStyle | Ruft die Art des Größenziehpunkts in der linken unteren Ecke des Formulars ab oder legt diesen fest. (inherited from Form).
Public property | StartPosition | Ruft die Anfangsposition des Formulars zur Laufzeit ab oder legt diese fest. (inherited from Form).
Public property | TabIndex | Ruft die Aktivierreihenfolge des Steuerelements in dessen Container ab oder legt diese fest. (inherited from Form).
Public property | TabStop | Ruft einen Wert ab, der angibt, ob Benutzer den Fokus mit der TAB-TASTE auf dieses Steuerelement setzen können, oder legt diesen fest. (inherited from Form).
Public property | Tag | Ruft das Objekt ab, das Daten über das Steuerelement enthält, oder legt dieses fest. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Ruft den Abstand zwischen dem oberen Rand des Steuerelements und dem oberen Rand des Clientbereichs des zugehörigen Containers in Pixel ab oder legt diesen fest. (inherited from Control).
Public property | TopLevel | Ruft einen Wert ab, der angibt, ob das Formular als Fenster der obersten Ebene angezeigt wird, oder legt diesen fest. (inherited from Form).
Public property | TopLevelControl | Ruft das übergeordnete Steuerelement ab, dem kein anderes Windows Forms-Steuerelement übergeordnet ist.Dies ist i. d. R. das äußerste Form, in dem das Steuerelement enthalten ist. (inherited from Control).
Public property | TopMost | Ruft einen Wert ab, der angibt, ob das Formular als oberstes Formular angezeigt werden soll, oder legt diesen fest. (inherited from Form).
Public property | TransparencyKey | Ruft die Farbe ab, in der transparente Bereiche des Formulars darstellt werden, oder legt diese fest. (inherited from Form).
Public property | UseWaitCursor | Ruft einen Wert ab, der angibt, ob der Wartecursor für das aktuelle Steuerelement und alle untergeordneten Steuerelemente verwendet werden soll. (inherited from Control).
Public property | VerticalScroll | Ruft die der vertikalen Schiebeleiste zugeordneten Merkmale ab. (inherited from ScrollableControl).
Public property | Visible | Ruft einen Wert ab, mit dem angegeben wird, ob das Steuerelement und alle untergeordneten Steuerelemente angezeigt werden, oder legt diesen Wert fest. (inherited from Control).
Public property | Width | Ruft die Breite des Steuerelements ab oder legt diese fest. (inherited from Control).
Public property | WindowState | Ruft den Fensterzustand des Formulars ab oder legt diesen fest. (inherited from Form).
Public property | WindowTarget | Diese Eigenschaft ist für diese Klasse nicht relevant. (inherited from Control).
Top

Expand image Public Methods

 | Name | Description
Public method | Activate | Aktiviert das Formular und übergibt diesem den Fokus. (inherited from Form).
Public method | AddOwnedForm | Fügt diesem Formular als Besitzer ein Formular hinzu. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Führt den angegebenen Delegaten asynchron für den Thread aus, in dem das dem Steuerelement zugrunde liegende Handle erstellt wurde. (inherited from Control).
Public method | BringToFront | Zeigt dieses Steuerelement am Anfang der z-Reihenfolge an. (inherited from Control).
Public method | Close | Schließt das Formular. (inherited from Form).
Public method | Contains | Ruft einen Wert ab, der angibt, ob das angegebene Steuerelement dem Steuerelement untergeordnet ist. (inherited from Control).
Public method | CreateControl | Erzwingt das Erstellen des Steuerelements, einschließlich des Handles und aller untergeordneten Steuerelemente. (inherited from Control).
Public method | CreateGraphics | Erstellt die Graphics für das Steuerelement. (inherited from Control).
Public method | CreateObjRef | Erstellt ein Objekt mit allen relevanten Informationen, die zum Generieren eines Proxys für die Kommunikation mit einem Remoteobjekt erforderlich sind. (inherited from MarshalByRefObject).
Supported by the .NET Compact Framework. | DefaultPrinterName |
Public method | DoDragDrop | Beginnt einen Drag & Drop-Vorgang. (inherited from Control).
Public method | DrawToBitmap | Unterstützt das Rendering für die angegebene Bitmap. (inherited from Control).
Public method | EndInvoke | Ruft den Rückgabewert des asynchronen Vorgangs ab, der durch das übergebene IAsyncResult dargestellt wird. (inherited from Control).
Public method | Equals | (Overloaded) Bestimmt, ob das angegebene Object und das aktuelle Object gleich sind. (inherited from Object).
Public method | FindForm | Ruft das Formular ab, in dem sich das Steuerelement befindet. (inherited from Control).
Public method | Focus | Setzt den Eingabefokus auf das Steuerelement. (inherited from Control).
 | FromChildHandle | Ruft das Steuerelement ab, das das angegebene Handle enthält. (inherited from Control).
 | FromHandle | Gibt das Steuerelement zurück, das gerade dem angegebenen Handle zugeordnet ist. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Ruft die Größe des Formulars bei automatischer Skalierung entsprechend einer angegebenen Schriftart ab. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Ruft das untergeordnete Steuerelement ab, das sich an den angegebenen Koordinaten befindet, und gibt an, ob untergeordnete Steuerelemente eines bestimmten Typs ignoriert werden sollen. (inherited from Control).
Public method | GetContainerControl | Gibt das nächste ContainerControl aufwärts in der Kette übergeordneter Steuerelemente des Steuerelements zurück. (inherited from Control).
Public method | GetLifetimeService | Ruft das aktuelle Lebensdauerdienstobjekt ab, das die Lebensdauerrichtlinien für diese Instanz steuert. (inherited from MarshalByRefObject).
Public method | GetNextControl | Ruft das nächste oder vorherige Steuerelement in der Aktivierreihenfolge untergeordneter Steuerelemente ab. (inherited from Control).
Public method | GetPreferredSize | Ruft die Größe eines rechteckigen Bereichs ab, in den ein Steuerelement eingefügt werden kann. (inherited from Control).
Public method | Hide | Verbirgt das Steuerelement vor dem Benutzer. (inherited from Control).
Public method | InitializeLifetimeService | Ruft ein Lebensdauerdienstobjekt ab, mit dem die Lebensdauerrichtlinien für diese Instanz gesteuert werden können. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Erklärt den angegebenen Bereich des Steuerelements für ungültig, indem es diesen dem Aktualisierungsbereich des Steuerelements hinzufügt. Dies ist der Bereich, der beim nächsten Zeichnenvorgang neu gezeichnet wird. Außerdem wird veranlasst, dass eine Zeichnenmeldung an das Steuerelement gesendet wird. (inherited from Control).
Public method | Invoke | (Overloaded) Führt den angegebenen Delegaten für den Thread aus, der das dem Steuerelement zugrunde liegende Fensterhandle besitzt. (inherited from Control).
 | IsKeyLocked | Bestimmt, ob die FESTSTELLTASTE, NUM oder ROLLEN aktiviert ist. (inherited from Control).
 | IsMnemonic | Bestimmt, ob das angegebene Zeichen das mnemonische Zeichen ist, das dem Steuerelement in der angegebenen Zeichenfolge zugewiesen wurde. (inherited from Control).
Public method | LayoutMdi | Ordnet die untergeordneten MDI (Multiple Document Interface)-Formulare im übergeordneten MDI-Formular an. (inherited from Form).
Public method | PerformAutoScale | Führt eine Skalierung für das Containersteuerelement und die dazugehörigen untergeordneten Elemente aus. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Erzwingt die Anwendung von Layoutlogik durch das Steuerelement auf sämtliche diesem untergeordneten Steuerelemente. (inherited from Control).
Public method | PointToClient | Rechnet die Position des angegebenen Bildschirmpunkts in Clientkoordinaten um. (inherited from Control).
Public method | PointToScreen | Rechnet die Position des angegebenen Clientpunkts in Bildschirmkoordinaten um. (inherited from Control).
Public method | PreProcessControlMessage | Führt eine Vorverarbeitung der Tastatur- oder Eingabemeldungen in der Nachrichtenschleife aus, bevor sie gesendet werden. (inherited from Control).
Public method | PreProcessMessage | Führt eine Vorverarbeitung der Tastatur- oder Eingabemeldungen in der Nachrichtenschleife aus, bevor sie gesendet werden. (inherited from Control).
Public method | RectangleToClient | Berechnet die Größe und die Position des angegebenen Bildschirmrechtecks in Clientkoordinaten. (inherited from Control).
Public method | RectangleToScreen | Berechnet die Größe und die Position des angegebenen Clientrechtecks in Bildschirmkoordinaten. (inherited from Control).
Public method | Refresh | Erzwingt, dass das Steuerelement seinen Clientbereich für ungültig erklärt und sich sowie alle untergeordneten Steuerelemente sofort selbst neu zeichnet. (inherited from Control).
Public method | RemoveOwnedForm | Entfernt ein Formular aus dem Besitzerformular. (inherited from Form).
Public method | ResetBackColor | Setzt die BackColor-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResetBindings | Führt dazu, dass in ein an BindingSource gebundenes Steuerelement alle Elemente in der Liste erneut eingelesen und ihre angezeigten Werte aktualisiert werden. (inherited from Control).
Public method | ResetCursor | Setzt die Cursor-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResetFont | Setzt die Font-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResetForeColor | Setzt die ForeColor-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResetImeMode | Setzt die ImeMode-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResetRightToLeft | Setzt die RightToLeft-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResetText | Setzt die Text-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Nimmt die übliche Layoutlogik wieder auf. (inherited from Control).
Public method | Scale | (Overloaded) Skaliert das Steuerelement und alle untergeordneten Steuerelemente. (inherited from Control).
Public method | ScrollControlIntoView | Führt einen Bildlauf durch, um das angegebene untergeordnete Steuerelement in einem Steuerelement anzuzeigen, für das der automatische Bildlauf aktiviert ist. (inherited from ScrollableControl).
Public method | SelectNextControl | Aktiviert das nächste Steuerelement. (inherited from Control).
Public method | SendToBack | Sendet das Steuerelement ans Ende der z-Reihenfolge. (inherited from Control).
Public method | SetAutoScrollMargin | Legt die Größe der AutoBildlaufränder fest. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Legt die Begrenzungen des Steuerelements auf die angegebene Position und Größe fest. (inherited from Control).
Public method | SetDesktopBounds | Legt die Begrenzungen des Formulars in Desktopkoordinaten fest. (inherited from Form).
Public method | SetDesktopLocation | Legt die Position des Formulars in Desktopkoordinaten fest. (inherited from Form).
Public method | Show | (Overloaded) Zeigt dem Benutzer das Formular mit dem angegebenen Besitzer an. (inherited from Form).
Public method | ShowDialog | (Overloaded) Zeigt das Formular als modales Dialogfeld an, wobei das derzeit aktive Fenster als Besitzer festgelegt ist. (inherited from Form).
Supported by the .NET Compact Framework. | SortNodes |
Public method | SuspendLayout | Unterbricht vorübergehend die Layoutlogik für das Steuerelement. (inherited from Control).
Public method | ToString | Ruft eine Zeichenfolge ab, die die aktuelle Instanz des Formulars darstellt. (inherited from Form).
Public method | Update | Bewirkt, dass das Steuerelement die für ungültig erklärten Bereiche im Clientbereich neu zeichnet. (inherited from Control).
Public method | Validate | (Overloaded) Überprüft den Wert des Steuerelements, das den Fokus verliert, indem das Validating-Ereignis und das Validated-Ereignis in dieser Reihenfolge ausgelöst werden. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top

Expand image Protected Methods

 | Name | Description
Protected method | ActivateMdiChild | Aktiviert das untergeordnete MDI-Element eines Formulars. (inherited from Form).
Protected method | AdjustFormScrollbars | Passt die Schiebeleisten im Container anhand der aktuellen Positionen der Steuerelemente und des aktuell ausgewählten Steuerelements an. (inherited from Form).
Protected method | ApplyAutoScaling | Obsolete. Ändert die Größe des Formulars entsprechend dem aktuellen Wert der AutoScaleBaseSize-Eigenschaft und der Größe der aktuellen Schriftart. (inherited from Form).
Protected method | CenterToParent | Zentriert die Position des Formulars innerhalb der Begrenzungen des übergeordneten Formulars. (inherited from Form).
Protected method | CenterToScreen | Zentriert das Formular für den aktuellen Bildschirm. (inherited from Form).
Protected method | CreateAccessibilityInstance | Erstellt ein neues Objekt für die Barrierefreiheit für das Steuerelement. (inherited from Control).
Protected method | CreateControlsInstance | (inherited from Form).
Protected method | CreateHandle | Erstellt das Handle für das Formular.Wenn eine abgeleitete Klasse diese Funktion überschreibt, muss sie die Basisimplementierung aufrufen. (inherited from Form).
Protected method | DefWndProc | (inherited from Form).
Protected method | DestroyHandle | Löscht das mit dem Steuerelement verknüpfte Handle. (inherited from Control).
Supported by the .NET Compact Framework. | Dispose | (Overloaded) Gibt die von Form verwendeten Ressourcen (mit Ausnahme des Speichers) frei.
Protected method | Finalize | Gibt nicht verwaltete Ressourcen frei und führt andere Bereinigungsvorgänge durch, bevor die Component durch die Garbage Collection wieder zugänglich gemacht wird. (inherited from Component).
Protected method | GetAccessibilityObjectById | Ruft das angegebene AccessibleObject ab. (inherited from Control).
Protected method | GetAutoSizeMode | Ruft einen Wert ab, der angibt, wie sich ein Steuerelement verhält, wenn seine AutoSize-Eigenschaft aktiviert wird. (inherited from Control).
Protected method | GetScaledBounds | (inherited from Form).
Protected method | GetScrollState | Bestimmt, ob das angegebene Flag festgelegt wurde. (inherited from ScrollableControl).
Protected method | GetService | Gibt ein Objekt zurück, das einen von der Component oder von deren Container bereitgestellten Dienst darstellt. (inherited from Component).
Protected method | GetStyle | Ruft den Wert für das angegebene Steuerelement-Formatbit für das Steuerelement ab. (inherited from Control).
Protected method | GetTopLevel | Bestimmt, ob es sich bei dem Steuerelement um ein Steuerelement der obersten Ebene handelt. (inherited from Control).
Protected method | InitLayout | Wird nach dem Hinzufügen des Steuerelements zu einem anderen Container aufgerufen. (inherited from Control).
Protected method | InvokeGotFocus | Löst das GotFocus-Ereignis für das angegebene Steuerelement aus. (inherited from Control).
Protected method | InvokeLostFocus | Löst das LostFocus-Ereignis für das angegebene Steuerelement aus. (inherited from Control).
Protected method | InvokeOnClick | Löst das Click-Ereignis für das angegebene Steuerelement aus. (inherited from Control).
Protected method | InvokePaint | Löst das Paint-Ereignis für das angegebene Steuerelement aus. (inherited from Control).
Protected method | InvokePaintBackground | Löst das PaintBackground-Ereignis für das angegebene Steuerelement aus. (inherited from Control).
Protected method | IsInputChar | Bestimmt, ob ein Zeichen ein vom Steuerelement erkanntes Eingabezeichen ist. (inherited from Control).
Protected method | IsInputKey | Bestimmt, ob es sich bei der angegebenen Taste um eine normale oder um eine besondere Taste handelt, für die eine Vorverarbeitung erforderlich ist. (inherited from Control).
Protected method | MemberwiseClone | Erstellt eine flache Kopie des aktuellen MarshalByRefObject-Objekts. (inherited from MarshalByRefObject).
Protected method | NotifyInvalidate | Löst das Invalidated-Ereignis aus, wobei ein angegebener Bereich des Steuerelements für ungültig erklärt wird. (inherited from Control).
Protected method | OnActivated | Löst das Activated-Ereignis aus. (inherited from Form).
Protected method | OnAutoSizeChanged | Löst das AutoSizeChanged-Ereignis aus. (inherited from Control).
Protected method | OnAutoValidateChanged | Löst das AutoValidateChanged-Ereignis aus. (inherited from ContainerControl).
Protected method | OnBackColorChanged | Löst das BackColorChanged-Ereignis aus. (inherited from Control).
Protected method | OnBackgroundImageChanged | Löst das BackgroundImageChanged-Ereignis aus. (inherited from Form).
Protected method | OnBackgroundImageLayoutChanged | Löst das BackgroundImageLayoutChanged-Ereignis aus. (inherited from Form).
Protected method | OnBindingContextChanged | Löst das BindingContextChanged-Ereignis aus. (inherited from Control).
Protected method | OnCausesValidationChanged | Löst das CausesValidationChanged-Ereignis aus. (inherited from Control).
Protected method | OnChangeUICues | Löst das ChangeUICues-Ereignis aus. (inherited from Control).
Protected method | OnClick | Löst das Click-Ereignis aus. (inherited from Control).
Protected method | OnClientSizeChanged | Löst das ClientSizeChanged-Ereignis aus. (inherited from Control).
Protected method | OnClosed | Löst das Closed-Ereignis aus. (inherited from Form).
Protected method | OnClosing | Löst das Closing-Ereignis aus. (inherited from Form).
Protected method | OnContextMenuChanged | Löst das ContextMenuChanged-Ereignis aus. (inherited from Control).
Protected method | OnContextMenuStripChanged | Löst das ContextMenuStripChanged-Ereignis aus. (inherited from Control).
Protected method | OnControlAdded | Löst das ControlAdded-Ereignis aus. (inherited from Control).
Protected method | OnControlRemoved | Löst das ControlRemoved-Ereignis aus. (inherited from Control).
Protected method | OnCreateControl | Löst das CreateControl-Ereignis aus. (inherited from Form).
Protected method | OnCursorChanged | Löst das CursorChanged-Ereignis aus. (inherited from Control).
Protected method | OnDeactivate | Löst das Deactivate-Ereignis aus. (inherited from Form).
Protected method | OnDockChanged | Löst das DockChanged-Ereignis aus. (inherited from Control).
Protected method | OnDoubleClick | Löst das DoubleClick-Ereignis aus. (inherited from Control).
Protected method | OnDragDrop | Löst das DragDrop-Ereignis aus. (inherited from Control).
Protected method | OnDragEnter | Löst das DragEnter-Ereignis aus. (inherited from Control).
Protected method | OnDragLeave | Löst das DragLeave-Ereignis aus. (inherited from Control).
Protected method | OnDragOver | Löst das DragOver-Ereignis aus. (inherited from Control).
Protected method | OnEnabledChanged | (inherited from Form).
Protected method | OnEnter | Löst das Enter-Ereignis aus. (inherited from Form).
Protected method | OnFontChanged | (inherited from Form).
Protected method | OnForeColorChanged | Löst das ForeColorChanged-Ereignis aus. (inherited from Control).
Protected method | OnFormClosed | Löst das FormClosed-Ereignis aus. (inherited from Form).
Protected method | OnFormClosing | Löst das FormClosing-Ereignis aus. (inherited from Form).
Protected method | OnGiveFeedback | Löst das GiveFeedback-Ereignis aus. (inherited from Control).
Protected method | OnGotFocus | Löst das GotFocus-Ereignis aus. (inherited from Control).
Protected method | OnHandleCreated | (inherited from Form).
Protected method | OnHandleDestroyed | (inherited from Form).
Protected method | OnHelpButtonClicked | Löst das HelpButtonClicked-Ereignis aus. (inherited from Form).
Protected method | OnHelpRequested | Löst das HelpRequested-Ereignis aus. (inherited from Control).
Protected method | OnImeModeChanged | Löst das ImeModeChanged-Ereignis aus. (inherited from Control).
Protected method | OnInputLanguageChanged | Löst das InputLanguageChanged-Ereignis aus. (inherited from Form).
Protected method | OnInputLanguageChanging | Löst das InputLanguageChanging-Ereignis aus. (inherited from Form).
Protected method | OnInvalidated | Löst das Invalidated-Ereignis aus. (inherited from Control).
Protected method | OnKeyDown | Löst das KeyDown-Ereignis aus. (inherited from Control).
Protected method | OnKeyPress | Löst das KeyPress-Ereignis aus. (inherited from Control).
Protected method | OnKeyUp | Löst das KeyUp-Ereignis aus. (inherited from Control).
Protected method | OnLayout | Löst das Layout-Ereignis aus. (inherited from Form).
Protected method | OnLeave | Löst das Leave-Ereignis aus. (inherited from Control).
Protected method | OnLoad | Löst das Load-Ereignis aus. (inherited from Form).
Protected method | OnLocationChanged | Löst das LocationChanged-Ereignis aus. (inherited from Control).
Protected method | OnLostFocus | Löst das LostFocus-Ereignis aus. (inherited from Control).
Protected method | OnMarginChanged | Löst das MarginChanged-Ereignis aus. (inherited from Control).
Protected method | OnMaximizedBoundsChanged | Löst das MaximizedBoundsChanged-Ereignis aus. (inherited from Form).
Protected method | OnMaximumSizeChanged | Löst das MaximumSizeChanged-Ereignis aus. (inherited from Form).
Protected method | OnMdiChildActivate | Löst das MdiChildActivate-Ereignis aus. (inherited from Form).
Protected method | OnMenuComplete | Löst das MenuComplete-Ereignis aus. (inherited from Form).
Protected method | OnMenuStart | Löst das MenuStart-Ereignis aus. (inherited from Form).
Protected method | OnMinimumSizeChanged | Löst das MinimumSizeChanged-Ereignis aus. (inherited from Form).
Protected method | OnMouseCaptureChanged | Löst das MouseCaptureChanged-Ereignis aus. (inherited from Control).
Protected method | OnMouseClick | Löst das MouseClick-Ereignis aus. (inherited from Control).
Protected method | OnMouseDoubleClick | Löst das MouseDoubleClick-Ereignis aus. (inherited from Control).
Protected method | OnMouseDown | Löst das MouseDown-Ereignis aus. (inherited from Control).
Protected method | OnMouseEnter | Löst das MouseEnter-Ereignis aus. (inherited from Control).
Protected method | OnMouseHover | Löst das MouseHover-Ereignis aus. (inherited from Control).
Protected method | OnMouseLeave | Löst das MouseLeave-Ereignis aus. (inherited from Control).
Protected method | OnMouseMove | Löst das MouseMove-Ereignis aus. (inherited from Control).
Protected method | OnMouseUp | Löst das MouseUp-Ereignis aus. (inherited from Control).
Protected method | OnMouseWheel | Löst das MouseWheel-Ereignis aus. (inherited from ScrollableControl).
Protected method | OnMove | Löst das Move-Ereignis aus. (inherited from Control).
Protected method | OnNotifyMessage | Benachrichtigt das Steuerelement über Windows-Meldungen. (inherited from Control).
Protected method | OnPaddingChanged | Löst das PaddingChanged-Ereignis aus. (inherited from ScrollableControl).
Protected method | OnPaint | (inherited from Form).
Protected method | OnPaintBackground | Zeichnet den Hintergrund des Steuerelements. (inherited from ScrollableControl).
Protected method | OnParentBackColorChanged | Löst das BackColorChanged-Ereignis aus, wenn sich der BackColor-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentBackgroundImageChanged | Löst das BackgroundImageChanged-Ereignis aus, wenn sich der BackgroundImage-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentBindingContextChanged | Löst das BindingContextChanged-Ereignis aus, wenn sich der BindingContext-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentChanged | (inherited from ContainerControl).
Protected method | OnParentCursorChanged | Löst das CursorChanged-Ereignis aus. (inherited from Control).
Protected method | OnParentEnabledChanged | Löst das EnabledChanged-Ereignis aus, wenn sich der Enabled-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentFontChanged | Löst das FontChanged-Ereignis aus, wenn sich der Font-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentForeColorChanged | Löst das ForeColorChanged-Ereignis aus, wenn sich der ForeColor-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentRightToLeftChanged | Löst das RightToLeftChanged-Ereignis aus, wenn sich der RightToLeft-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentVisibleChanged | Löst das VisibleChanged-Ereignis aus, wenn sich der Visible-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnPreviewKeyDown | Löst das PreviewKeyDown-Ereignis aus. (inherited from Control).
Protected method | OnPrint | Löst das Paint-Ereignis aus. (inherited from Control).
Protected method | OnQueryContinueDrag | Löst das QueryContinueDrag-Ereignis aus. (inherited from Control).
Protected method | OnRegionChanged | Löst das RegionChanged-Ereignis aus. (inherited from Control).
Protected method | OnResize | (inherited from Form).
Protected method | OnResizeBegin | Löst das ResizeBegin-Ereignis aus. (inherited from Form).
Protected method | OnResizeEnd | Löst das ResizeEnd-Ereignis aus. (inherited from Form).
Protected method | OnRightToLeftChanged | (inherited from ScrollableControl).
Protected method | OnRightToLeftLayoutChanged | Löst das RightToLeftLayoutChanged-Ereignis aus. (inherited from Form).
Protected method | OnScroll | Löst das Scroll-Ereignis aus. (inherited from ScrollableControl).
Protected method | OnShown | Löst das Shown-Ereignis aus. (inherited from Form).
Protected method | OnSizeChanged | Löst das SizeChanged-Ereignis aus. (inherited from Control).
Protected method | OnStyleChanged | (inherited from Form).
Protected method | OnSystemColorsChanged | Löst das SystemColorsChanged-Ereignis aus. (inherited from Control).
Protected method | OnTabIndexChanged | Löst das TabIndexChanged-Ereignis aus. (inherited from Control).
Protected method | OnTabStopChanged | Löst das TabStopChanged-Ereignis aus. (inherited from Control).
Protected method | OnTextChanged | (inherited from Form).
Protected method | OnValidated | Löst das Validated-Ereignis aus. (inherited from Control).
Protected method | OnValidating | Löst das Validating-Ereignis aus. (inherited from Control).
Protected method | OnVisibleChanged | Löst das VisibleChanged-Ereignis aus. (inherited from Form).
Protected method | ProcessCmdKey | Verarbeitet eine Befehlstaste. (inherited from Form).
Protected method | ProcessDialogChar | Verarbeitet ein Dialogfeldzeichen. (inherited from Form).
Protected method | ProcessDialogKey | Verarbeitet eine Tastatureingabe im Dialogfeld. (inherited from Form).
Protected method | ProcessKeyEventArgs | Verarbeitet eine Tastenmeldung und generiert die entsprechenden Steuerelementereignisse. (inherited from Control).
Protected method | ProcessKeyPreview | (inherited from Form).
Protected method | ProcessTabKey | (inherited from Form).
Protected method | RaiseDragEvent | Löst das entsprechende Ziehereignis aus. (inherited from Control).
Protected method | RaiseKeyEvent | Löst das entsprechende Tastenereignis aus. (inherited from Control).
Protected method | RaiseMouseEvent | Löst das entsprechende Mausereignis aus. (inherited from Control).
Protected method | RaisePaintEvent | Löst das entsprechende Paint-Ereignis aus. (inherited from Control).
Protected method | RecreateHandle | Erzwingt ein erneutes Erstellen des Handles für das Steuerelement. (inherited from Control).
 | ReflectMessage | Reflektiert die angegebene Meldung an das Steuerelement, das an das angegebene Handle gebunden ist. (inherited from Control).
Protected method | ResetMouseEventArgs | Setzt das Steuerelement zurück, um das MouseLeave-Ereignis zu behandeln. (inherited from Control).
Protected method | RtlTranslateAlignment | (Overloaded) Konvertiert das angegebene HorizontalAlignment in das entsprechende HorizontalAlignment für die Unterstützung der Schriftrichtung von rechts nach links. (inherited from Control).
Protected method | RtlTranslateHorizontal | Konvertiert das angegebene HorizontalAlignment in das entsprechende HorizontalAlignment für die Unterstützung der Schriftrichtung von rechts nach links. (inherited from Control).
Protected method | RtlTranslateLeftRight | Konvertiert das angegebene LeftRightAlignment in das entsprechende LeftRightAlignment für die Unterstützung der Schriftrichtung von rechts nach links. (inherited from Control).
Protected method | ScaleControl | Skaliert Speicherort, Größe, Textabstand und Rand eines Steuerelements. (inherited from Form).
Protected method | ScaleCore | Führt die Skalierung des Formulars aus. (inherited from Form).
Protected method | ScrollToControl | Berechnet den Bildlauf-Offset zum angegebenen untergeordneten Steuerelement. (inherited from ScrollableControl).
Protected method | Select | (Overloaded) Aktiviert dieses Formular und wählt optional das nächste oder vorherige Steuerelement aus. (inherited from Form).
Protected method | SetAutoSizeMode | Legt einen Wert fest, der angibt, wie sich ein Steuerelement verhält, wenn seine AutoSize-Eigenschaft aktiviert wird. (inherited from Control).
Protected method | SetBoundsCore | (inherited from Form).
Protected method | SetClientSizeCore | Legt die Clientgröße des Formulars fest.Hiermit werden die Begrenzungen des Formulars so angepasst, dass die Clientgröße der angeforderten Größe entspricht. (inherited from Form).
Protected method | SetDisplayRectLocation | Positioniert das Anzeigefenster anhand des angegebenen Werts. (inherited from ScrollableControl).
Protected method | SetScrollState | Legt das angegebene Flag für den Bildlaufzustand fest. (inherited from ScrollableControl).
Protected method | SetStyle | Legt ein angegebenes ControlStyles-Flag auf true oder false fest. (inherited from Control).
Protected method | SetTopLevel | Legt das Steuerelement als Steuerelement der obersten Ebene fest. (inherited from Control).
Protected method | SetVisibleCore | (inherited from Form).
Protected method | SizeFromClientSize | Bestimmt die Größe des gesamten Steuerelements anhand der Höhe und Breite seines Clientbereichs. (inherited from Control).
Protected method | UpdateDefaultButton | Aktualisiert, welche Schaltfläche die Standardschaltfläche ist. (inherited from Form).
Protected method | UpdateStyles | Erzwingt ein erneutes Anwenden der zugewiesenen Formate auf das Steuerelement. (inherited from Control).
Protected method | UpdateZOrder | Aktualisiert das Steuerelement in der z-Reihenfolge des übergeordneten Elements. (inherited from Control).
Protected method | WndProc | (inherited from Form).
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Internal protected (Protected Friend) method | AccessibilityNotifyClients | (Overloaded) Benachrichtigt die Clientanwendungen für die Barrierefreiheit über die angegebenen AccessibleEvents für das angegebene untergeordnete Steuerelement. (inherited from Control).
Internal protected (Protected Friend) method | ProcessKeyMessage | Verarbeitet eine Tastaturmeldung. (inherited from Control).
Internal protected (Protected Friend) method | ProcessMnemonic | Verarbeitet ein mnemonisches Zeichen. (inherited from Form).
Internal protected (Protected Friend) method | RtlTranslateContent | Konvertiert das angegebene ContentAlignment in das entsprechende ContentAlignment für die Unterstützung der Schriftrichtung von rechts nach links. (inherited from Control).
Internal protected (Protected Friend) method | UpdateBounds | (Overloaded) Aktualisiert die Begrenzungen des Steuerelements mit der aktuellen Größe und Position. (inherited from Control).
Top

Expand image Public Events

 | Name | Description
Public event | Activated | Tritt ein, wenn das Formular im Code oder vom Benutzer aktiviert wird. (inherited from Form).
Public event | AutoSizeChanged | Tritt ein, wenn sich die AutoSize-Eigenschaft ändert. (inherited from Form).
Public event | AutoValidateChanged | Tritt ein, wenn sich die AutoValidate-Eigenschaft ändert. (inherited from Form).
Public event | BackColorChanged | Tritt ein, wenn sich der Wert der BackColor-Eigenschaft ändert. (inherited from Control).
Public event | BackgroundImageChanged | Tritt ein, wenn sich der Wert der BackgroundImage-Eigenschaft ändert. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Tritt ein, wenn sich die BackgroundImageLayout-Eigenschaft ändert. (inherited from Control).
Public event | BindingContextChanged | Tritt ein, wenn sich der Wert der BindingContext-Eigenschaft ändert. (inherited from Control).
Public event | CausesValidationChanged | Tritt auf, wenn der Wert der CausesValidation-Eigenschaft geändert wird. (inherited from Control).
Public event | ChangeUICues | Tritt ein, wenn sich der Fokus-Cue oder der Tastatur-Cue der Benutzeroberfläche ändert. (inherited from Control).
Public event | Click | Tritt beim Klicken auf das Steuerelement ein. (inherited from Control).
Public event | ClientSizeChanged | Tritt ein, wenn sich der Wert der ClientSize-Eigenschaft ändert. (inherited from Control).
Public event | Closed | Tritt ein, wenn das Formular geschlossen ist. (inherited from Form).
Public event | Closing | Tritt beim Schließen des Formulars ein. (inherited from Form).
Public event | ContextMenuChanged | Tritt ein, wenn sich der Wert der ContextMenu-Eigenschaft ändert. (inherited from Control).
Public event | ContextMenuStripChanged | Tritt ein, wenn sich der Wert der ContextMenuStrip-Eigenschaft ändert. (inherited from Control).
Public event | ControlAdded | Tritt ein, wenn der ControlCollection ein neues Steuerelement hinzugefügt wird. (inherited from Control).
Public event | ControlRemoved | Tritt beim Entfernen des Steuerelements aus der ControlCollection ein. (inherited from Control).
Public event | CursorChanged | Tritt ein, wenn sich der Wert der Cursor-Eigenschaft ändert. (inherited from Control).
Public event | Deactivate | Tritt ein, wenn das Formular den Fokus verliert und nicht mehr das aktive Formular ist. (inherited from Form).
Public event | Disposed | Tritt ein, wenn die Komponente durch einen Aufruf der Dispose-Methode freigegeben wird. (inherited from Component).
Public event | DockChanged | Tritt ein, wenn sich der Wert der Dock-Eigenschaft ändert. (inherited from Control).
Public event | DoubleClick | Tritt beim Doppelklicken auf das Steuerelement ein. (inherited from Control).
Public event | DragDrop | Tritt ein, wenn eine Drag & Drop-Operation beendet wurde. (inherited from Control).
Public event | DragEnter | Tritt ein, wenn ein Objekt in den Bereich des Steuerelements gezogen wird. (inherited from Control).
Public event | DragLeave | Tritt ein, wenn ein Objekt aus dem Bereich des Steuerelements gezogen wird. (inherited from Control).
Public event | DragOver | Tritt ein, wenn ein Objekt über die Begrenzungen des Steuerelements gezogen wird. (inherited from Control).
Public event | EnabledChanged | Tritt ein, wenn sich der Enabled-Eigenschaftswert geändert hat. (inherited from Control).
Public event | Enter | Tritt beim Eintreten in den Bereich des Steuerelements ein. (inherited from Control).
Public event | FontChanged | Tritt ein, wenn sich der Font-Eigenschaftswert ändert. (inherited from Control).
Public event | ForeColorChanged | Tritt ein, wenn sich der ForeColor-Eigenschaftswert ändert. (inherited from Control).
Public event | FormClosed | Tritt ein, nachdem das Formular geschlossen wurde. (inherited from Form).
Public event | FormClosing | Tritt ein, bevor das Formular geschlossen wird. (inherited from Form).
Public event | GiveFeedback | Tritt während eines Ziehvorgangs ein. (inherited from Control).
Public event | GotFocus | Tritt ein, wenn das Steuerelement den Fokus erhält. (inherited from Control).
Public event | HandleCreated | Tritt ein, wenn ein Handle für das Steuerelement erstellt wird. (inherited from Control).
Public event | HandleDestroyed | Tritt ein, wenn das Handle des Steuerelements gerade gelöscht wird. (inherited from Control).
Public event | HelpButtonClicked | Tritt beim Klicken auf die Schaltfläche Hilfe ein. (inherited from Form).
Public event | HelpRequested | Tritt ein, wenn der Benutzer die Hilfe für ein Steuerelement anfordert. (inherited from Control).
Public event | ImeModeChanged | Tritt ein, wenn die ImeMode-Eigenschaft geändert wurde. (inherited from Control).
Public event | InputLanguageChanged | Tritt ein, nachdem die Eingabesprache des Formulars geändert wurde. (inherited from Form).
Public event | InputLanguageChanging | Tritt ein, wenn der Benutzer versucht, die Eingabesprache für das Formular zu ändern. (inherited from Form).
Public event | Invalidated | Tritt ein, wenn die Anzeige eines Steuerelements neu gezeichnet werden muss. (inherited from Control).
Public event | KeyDown | Tritt ein, wenn eine Taste gedrückt wird, während das Steuerelement den Fokus hat. (inherited from Control).
Public event | KeyPress | Tritt ein, wenn eine Taste gedrückt wird, während das Steuerelement den Fokus hat. (inherited from Control).
Public event | KeyUp | Tritt ein, wenn eine Taste losgelassen wird, während das Steuerelement den Fokus hat. (inherited from Control).
Public event | Layout | Tritt ein, wenn ein Steuerelement seine untergeordneten Steuerelemente neu positionieren muss. (inherited from Control).
Public event | Leave | Tritt ein, wenn der Eingabefokus das Steuerelement verlässt. (inherited from Control).
Public event | Load | Tritt ein, bevor ein Formular erstmals angezeigt wird. (inherited from Form).
Public event | LocationChanged | Tritt ein, wenn sich der Location-Eigenschaftswert geändert hat. (inherited from Control).
Public event | LostFocus | Tritt ein, wenn das Steuerelement den Fokus verliert. (inherited from Control).
Public event | MarginChanged | Tritt ein, wenn sich die Margin-Eigenschaft ändert. (inherited from Form).
Public event | MaximizedBoundsChanged | Tritt ein, wenn sich der Wert der MaximizedBounds-Eigenschaft geändert hat. (inherited from Form).
Public event | MaximumSizeChanged | Tritt ein, wenn sich der Wert der MaximumSize-Eigenschaft geändert hat. (inherited from Form).
Public event | MdiChildActivate | Tritt ein, wenn ein untergeordnetes MDI (Multiple Document Interface)-Formular in einer MDI-Anwendung aktiviert oder geschlossen wird. (inherited from Form).
Public event | MenuComplete | Tritt ein, wenn das Menü eines Formulars den Fokus verliert. (inherited from Form).
Public event | MenuStart | Tritt ein, wenn das Menü eines Formulars den Fokus erhält. (inherited from Form).
Public event | MinimumSizeChanged | Tritt ein, wenn sich der Wert der MinimumSize-Eigenschaft geändert hat. (inherited from Form).
Public event | MouseCaptureChanged | Tritt ein, wenn das Steuerelement beginnt oder aufhört, Mauseingaben aufzufangen. (inherited from Control).
Public event | MouseClick | Tritt ein, wenn mit der Maus auf das Steuerelement geklickt wird. (inherited from Control).
Public event | MouseDoubleClick | Tritt ein, wenn mit der Maus ein Doppelklick auf das Steuerelement ausgeführt wird. (inherited from Control).
Public event | MouseDown | Tritt ein, wenn sich der Mauszeiger über dem Steuerelement befindet und eine Maustaste gedrückt wird. (inherited from Control).
Public event | MouseEnter | Tritt ein, wenn der Mauszeiger in den Bereich des Steuerelements eintritt. (inherited from Control).
Public event | MouseHover | Tritt ein, wenn der Mauszeiger auf dem Steuerelement verbleibt. (inherited from Control).
Public event | MouseLeave | Tritt ein, wenn der Mauszeiger den Bereich des Steuerelements verlässt. (inherited from Control).
Public event | MouseMove | Tritt ein, wenn der Mauszeiger über dem Steuerelement bewegt wird. (inherited from Control).
Public event | MouseUp | Tritt ein, wenn sich der Mauszeiger über dem Steuerelement befindet und eine Maustaste losgelassen wird. (inherited from Control).
Public event | MouseWheel | Tritt ein, wenn das Mausrad bewegt wird, während das Steuerelement den Fokus besitzt. (inherited from Control).
Public event | Move | Tritt beim Verschieben des Steuerelements ein. (inherited from Control).
Public event | PaddingChanged | Tritt ein, wenn der Abstand des Steuerelements geändert wird. (inherited from Control).
Public event | Paint | Tritt ein, wenn das Steuerelement neu gezeichnet wird. (inherited from Control).
Public event | ParentChanged | Tritt ein, wenn sich der Parent-Eigenschaftswert ändert. (inherited from Control).
Public event | PreviewKeyDown | Tritt vor dem KeyDown-Ereignis ein, wenn eine Taste gedrückt wird, während dieses Steuerelement den Fokus besitzt. (inherited from Control).
Public event | QueryAccessibilityHelp | Tritt ein, wenn AccessibleObject Hilfe für barrierefreie Anwendungen bereitstellt. (inherited from Control).
Public event | QueryContinueDrag | Tritt während eines Drag & Drop-Vorgangs ein. Dadurch kann die Quelle des Ziehvorgangs bestimmen, ob der Drag & Drop-Vorgang abgebrochen werden soll. (inherited from Control).
Public event | RegionChanged | Tritt ein, wenn sich der Wert der Region-Eigenschaft ändert. (inherited from Control).
Public event | Resize | Tritt beim Ändern der Größe des Steuerelements ein. (inherited from Control).
Public event | ResizeBegin | Tritt ein, wenn ein Formular in den Größenänderungsmodus wechselt. (inherited from Form).
Public event | ResizeEnd | Tritt ein, wenn ein Formular den Größenänderungsmodus verlässt. (inherited from Form).
Public event | RightToLeftChanged | Tritt ein, wenn sich der RightToLeft-Eigenschaftswert ändert. (inherited from Control).
Public event | RightToLeftLayoutChanged | Tritt ein, nachdem sich der Wert der RightToLeftLayout-Eigenschaft geändert hat. (inherited from Form).
Public event | Scroll | Tritt ein, wenn vom Benutzer oder von Code ein Bildlauf durch den Clientbereich durchgeführt wird. (inherited from ScrollableControl).
Public event | Shown | Tritt immer dann ein, wenn das Formular erstmalig angezeigt wird. (inherited from Form).
Public event | SizeChanged | Tritt ein, wenn sich der Size-Eigenschaftswert ändert. (inherited from Control).
Public event | StyleChanged | Tritt ein, wenn sich das Format des Steuerelements ändert. (inherited from Control).
Public event | SystemColorsChanged | Tritt ein, wenn sich die Systemfarben ändern. (inherited from Control).
Public event | TabIndexChanged | Tritt ein, wenn sich der Wert der TabIndex-Eigenschaft ändert. (inherited from Form).
Public event | TabStopChanged | Tritt ein, wenn sich die TabStop-Eigenschaft ändert. (inherited from Form).
Public event | TextChanged | Tritt ein, wenn sich der Text-Eigenschaftswert ändert. (inherited from Control).
Public event | Validated | Tritt ein, wenn das Steuerelement die Überprüfung abgeschlossen hat. (inherited from Control).
Public event | Validating | Tritt ein, während das Steuerelement eine Überprüfung durchführt. (inherited from Control).
Public event | VisibleChanged | Tritt ein, wenn sich der Visible-Eigenschaftswert ändert. (inherited from Control).
Top

Expand image See Also

Reference

frmPrinterSettings Class


frmPrinterSettings Constructor

[image] [image] [image]

AllgFnkt_Plugin Reference
frmPrinterSettings Constructor
See Also

Initializes a new instance of the frmPrinterSettings class.
Assembly: AllgFnkt_Plugin (in AllgFnkt_Plugin.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByRef a_wdapp As Object _
)
C#
public frmPrinterSettings(
   ref object a_wdapp
)
C++
public:
frmPrinterSettings(
   object^& a_wdapp
)
JScript
public function frmPrinterSettings(
    a_wdapp : object
);

Parameters

a_wdapp

Type: object

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPrinterSettings Class
frmPrinterSettings Members


frmPrinterSettings Properties

[image] [image] [image]

AllgFnkt_Plugin Reference
frmPrinterSettings Properties
frmPrinterSettings Class See Also

Expand image Public Properties

 | Name | Description
Public property | AcceptButton | Ruft die Schaltfläche im Formular ab, die beim Drücken der EINGABETASTE betätigt wird, oder legt diese fest. (inherited from Form).
Public property | AccessibilityObject | Ruft das dem Steuerelement zugewiesene AccessibleObject ab. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Ruft die Beschreibung der Standardaktion des Steuerelements für die Verwendung durch Clientanwendungen für die Barrierefreiheit ab oder legt diese fest. (inherited from Control).
Public property | AccessibleDescription | Ruft die Beschreibung des von Clientanwendungen für die Barrierefreiheit verwendeten Steuerelements ab oder legt diese fest. (inherited from Control).
Public property | AccessibleName | Ruft den Namen des von Clientanwendungen für die Barrierefreiheit verwendeten Steuerelements ab oder legt diesen fest. (inherited from Control).
Public property | AccessibleRole | Ruft die barrierefreie Rolle des Steuerelements ab oder legt diese fest. (inherited from Control).
Public property | ActiveControl | Ruft das aktive Steuerelement im Containersteuerelement ab oder legt dieses fest. (inherited from ContainerControl).
 | ActiveForm | Ruft das momentan aktive Formular für diese Anwendung ab. (inherited from Form).
Public property | ActiveMdiChild | Ruft das momentan aktive untergeordnete MDI (Multiple Document Interface)-Fenster ab. (inherited from Form).
Public property | AllowDrop | Ruft einen Wert ab, der angibt, ob das Steuerelement Daten annehmen kann, die vom Benutzer darauf gezogen wurden, oder legt diesen fest. (inherited from Control).
Public property | AllowTransparency | Ruft einen Wert ab, der angibt, ob die Durchlässigkeit des Formulars angepasst werden kann, oder legt diesen Wert fest. (inherited from Form).
Public property | Anchor | Ruft die Ränder des Containers ab, an die ein Steuerelement gebunden ist, oder legt diese fest und bestimmt, wie die Größe des Steuerelements mit dessen übergeordnetem Element geändert wird. (inherited from Control).
Public property | AutoScale | Obsolete. Ruft einen Wert ab, der angibt, ob die Größe des Formulars der Höhe der im Formular verwendeten Schriftart angepasst wird und die Steuerelemente des Formulars skaliert werden, oder legt diesen fest. (inherited from Form).
Public property | AutoScaleBaseSize | Ruft die Grundgröße ab, die für die automatische Skalierung des Formulars verwendet wird, oder legt diese fest. (inherited from Form).
Public property | AutoScaleDimensions | Ruft die Dimensionen ab, für die das Steuerelement entworfen wurde, oder ruft diese ab. (inherited from ContainerControl).
Public property | AutoScaleMode | Ruft den automatischen Skalierungsmodus des Steuerelements ab oder legt diesen fest. (inherited from ContainerControl).
Public property | AutoScroll | Ruft einen Wert ab, der angibt, ob das Formular den automatischen Bildlauf ermöglicht, oder legt diesen fest. (inherited from Form).
Public property | AutoScrollMargin | Ruft die Größe des AutoBildlaufrandes ab oder legt diese fest. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Ruft die minimale Größe des AutoBildlaufs ab oder legt diese fest. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Ruft in Control) ab oder legt anhand dessen fest, in welcher Richtung der Bildlauf dieses Steuerelements durchgeführt wird. (inherited from Control).
Public property | AutoScrollPosition | Ruft die Position des AutoBildlaufs ab oder legt diese fest. (inherited from ScrollableControl).
Public property | AutoSize | Ändern Sie die Größe des Formulars entsprechend der Einstellung von AutoSizeMode. (inherited from Form).
Public property | AutoSizeMode | Ruft den Modus ab, in dem das Formular seine Größe automatisch selbst ändert, oder legt diesen Modus fest. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Ruft das im Steuerelement angezeigte Hintergrundbild ab oder legt dieses fest. (inherited from Control).
Public property | BackgroundImageLayout | Ruft das Layout für das Hintergrundbild wie in der ImageLayout-Enumeration definiert ab oder legt dieses fest. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Ruft den Abstand zwischen dem unteren Rand des Steuerelements und dem oberen Rand des Clientbereichs des zugehörigen Containers in Pixel ab. (inherited from Control).
Public property | Bounds | Ruft die Größe und die Position des Steuerelements, einschließlich seiner Nicht-Clientelemente, in Pixel relativ zum übergeordneten Steuerelement ab oder legt diese fest. (inherited from Control).
Public property | CanFocus | Ruft einen Wert ab, der angibt, ob das Steuerelement den Fokus erhalten kann. (inherited from Control).
Public property | CanSelect | Ruft einen Wert ab, der angibt, ob das Steuerelement ausgewählt werden kann. (inherited from Control).
Public property | CancelButton | Ruft das Button-Steuerelement ab, das beim Drücken von ESC betätigt wird, oder legt dieses fest. (inherited from Form).
Public property | Capture | Ruft einen Wert ab, der angibt, ob die Maus vom Steuerelement erfasst wurde, oder legt diesen fest. (inherited from Control).
Public property | CausesValidation | Ruft einen Wert ab, der angibt, ob das Steuerelement bei Erhalt des Fokus eine Validierung für alle eine Validierung erfordernden Steuerelemente veranlasst, oder legt diesen fest. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Ruft einen Wert ab, mit dem angegeben wird, ob Aufrufe an den falschen Thread, der auf die Handle-Eigenschaft eines Steuerelements zugreift, abgefangen werden sollen, wenn eine Anwendung gedebuggt wird, oder legt diesen Wert fest. (inherited from Control).
Public property | ClientRectangle | Ruft das Rechteck ab, das den Clientbereich des Steuerelements darstellt. (inherited from Control).
Public property | ClientSize | Ruft die Größe des Clientbereichs des Formulars ab oder legt diese fest. (inherited from Form).
Public property | CompanyName | Ruft den Namen des Unternehmens oder des Entwicklers der Anwendung ab, die das Steuerelement enthält. (inherited from Control).
Public property | Container | Ruft den IContainer ab, der die Component enthält. (inherited from Component).
Public property | ContainsFocus | Ruft einen Wert ab, der angibt, ob das Steuerelement oder eines der untergeordneten Steuerelemente den Eingabefokus besitzt. (inherited from Control).
Public property | ContextMenu | Ruft das dem Steuerelement zugeordnete Kontextmenü ab oder legt dieses fest. (inherited from Control).
Public property | ContextMenuStrip | Ruft die diesem Steuerelement zugeordnete ContextMenuStrip-Klasse ab oder legt diese fest. (inherited from Control).
Public property | ControlBox | Ruft einen Wert ab, der angibt, ob auf der Titelleiste des Formulars ein Systemmenüfeld angezeigt wird, oder legt diesen fest. (inherited from Form).
Public property | Controls | Ruft die im Steuerelement enthaltene Auflistung von Steuerelementen ab. (inherited from Control).
Public property | Created | Ruft einen Wert ab, der angibt, ob das Steuerelement erstellt wurde. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Ruft die aktuellen Laufzeitdimensionen des Bildschirms ab. (inherited from ContainerControl).
Public property | Cursor | Ruft den Cursor ab, der angezeigt wird, wenn sich der Mauszeiger über dem Steuerelement befindet, oder legt diesen fest. (inherited from Control).
Public property | DataBindings | Ruft die Datenbindungen für das Steuerelement ab. (inherited from Control).
 | DefaultBackColor | Ruft die Standardhintergrundfarbe des Steuerelements ab. (inherited from Control).
 | DefaultFont | Ruft die Standardschriftart des Steuerelements ab. (inherited from Control).
 | DefaultForeColor | Ruft die Standardvordergrundfarbe des Steuerelements ab. (inherited from Control).
Public property | DesktopBounds | Ruft Größe und Position des Formulars auf dem Windows-Desktop ab oder legt diese fest. (inherited from Form).
Public property | DesktopLocation | Ruft die Position des Formulars auf dem Windows-Desktop ab oder legt diese fest. (inherited from Form).
Public property | DialogResult | Ruft das Dialogergebnis für das Formular ab oder legt dieses fest. (inherited from Form).
Public property | DisplayRectangle | Ruft das Rechteck ab, das den virtuellen Anzeigebereich des Steuerelements darstellt. (inherited from ScrollableControl).
Public property | Disposing | Ruft einen Wert ab, der angibt, ob die Control-Basisklasse gerade freigegeben wird. (inherited from Control).
Public property | Dock | Ruft ab oder legt fest, welche Steuerelementrahmen am übergeordneten Steuerelement angedockt sind, und bestimmt, wie die Größe eines Steuerelements mit dem übergeordneten Steuerelement geändert wird. (inherited from Control).
Public property | DockPadding | Ruft die Einstellungen für den Andockleerraum für alle Ränder des Steuerelements ab. (inherited from ScrollableControl).
Public property | Enabled | Ruft einen Wert ab, der angibt, ob das Steuerelement auf Benutzerinteraktionen reagieren kann, oder legt diesen fest. (inherited from Control).
Public property | Focused | Ruft einen Wert ab, der angibt, ob das Steuerelement den Eingabefokus besitzt. (inherited from Control).
Public property | Font | Ruft die Schriftart für die Anzeige von Text im Steuerelement ab oder legt diese fest. (inherited from Control).
Public property | ForeColor | Ruft die Vordergrundfarbe des Steuerelements ab oder legt diese fest. (inherited from Control).
Public property | FormBorderStyle | Ruft die Rahmenart des Formulars ab oder legt diese fest. (inherited from Form).
Public property | Handle | Ruft das Fensterhandle ab, an das das Steuerelement gebunden ist. (inherited from Control).
Public property | HasChildren | Ruft einen Wert ab, der angibt, ob das Steuerelement ein oder mehrere untergeordnete Steuerelemente enthält. (inherited from Control).
Public property | Height | Ruft die Höhe des Steuerelements ab oder legt diese fest. (inherited from Control).
Public property | HelpButton | Ruft einen Wert ab, der angibt, ob auf der Titelleiste des Formulars die Hilfeschaltfläche angezeigt werden soll, oder legt diesen fest. (inherited from Form).
Public property | HorizontalScroll | Ruft die der horizontalen Schiebeleiste zugeordneten Merkmale ab. (inherited from ScrollableControl).
Public property | Icon | Ruft das Symbol für das Formular ab oder legt dieses fest. (inherited from Form).
Public property | ImeMode | Ruft den IME-Modus (Eingabemethoden-Editor) des Steuerelements ab oder legt diesen fest. (inherited from Control).
Public property | InvokeRequired | Ruft einen Wert ab, der angibt ob der Aufrufer beim Aufruf von Methoden des Steuerelements eine Aufrufmethode aufrufen muss, da sich der Aufrufer in einem anderen Thread als dem befindet, in dem das Steuerelement erstellt wurde. (inherited from Control).
Public property | IsAccessible | Ruft einen Wert ab, der angibt, ob das Steuerelement für barrierefreie Anwendungen sichtbar ist, oder legt diesen fest. (inherited from Control).
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Steuerelement freigegeben wurde. (inherited from Control).
Public property | IsHandleCreated | Ruft einen Wert ab, der angibt, ob dem Steuerelement ein Handle zugeordnet ist. (inherited from Control).
Public property | IsMdiChild | Ruft einen Wert ab, der angibt, ob das Formular ein untergeordnetes MDI (Multiple Document Interface)-Formular ist. (inherited from Form).
Public property | IsMdiContainer | Ruft einen Wert ab, der angibt, ob das Formular ein Container für untergeordnete MDI (Multiple Document Interface)-Formulare ist, oder legt diesen fest. (inherited from Form).
Public property | IsMirrored | Ruft einen Wert ab, der angibt, ob das Steuerelement gespiegelt wird. (inherited from Control).
Public property | IsRestrictedWindow | Ruft einen Wert ab, der angibt, ob für das Formular alle Fenster und Benutzereingabeereignisse uneingeschränkt verwendet werden können. (inherited from Form).
Public property | KeyPreview | Ruft einen Wert ab, der angibt, ob das Formular Tastaturereignisse empfängt, bevor das Ereignis an das Steuerelement übergeben wird, das den Fokus besitzt, oder legt diesen fest. (inherited from Form).
Public property | LayoutEngine | Ruft eine zwischengespeicherte Instanz des Layoutmoduls des Steuerelements ab. (inherited from Control).
Public property | Left | Ruft den Abstand zwischen dem linken Rand des Steuerelements und dem linken Rand des Clientbereichs des zugehörigen Containers in Pixel ab oder legt diesen fest. (inherited from Control).
Public property | Location | Ruft den Point ab, der die linke obere Ecke des Form in Bildschirmkoordinaten darstellt, oder legt diesen fest. (inherited from Form).
Public property | MainMenuStrip | Ruft den primären Menücontainer für das Formular ab oder legt diesen fest. (inherited from Form).
Public property | Margin | Ruft den Zwischenraum zwischen Steuerelementen ab oder legt diesen fest. (inherited from Form).
Public property | MaximizeBox | Ruft einen Wert ab, der angibt, ob auf der Titelleiste des Formulars die Schaltfläche Maximieren angezeigt wird, oder legt diesen fest. (inherited from Form).
Public property | MaximumSize | Ruft die maximale Größe für die Vergrößerung des Formulars ab. (inherited from Form).
Public property | MdiChildren | Ruft ein Array von Formularen ab, das die untergeordneten MDI (Multiple Document Interface)-Formulare darstellt, deren übergeordnetes Formular dieses Formular ist. (inherited from Form).
Public property | MdiParent | Ruft das aktuelle übergeordnete MDI (Multiple Document Interface)-Formular für dieses Formular ab oder legt dieses fest. (inherited from Form).
Public property | Menu | Ruft das MainMenu ab, das im Formular angezeigt wird, oder legt dieses fest. (inherited from Form).
Public property | MergedMenu | Ruft das zusammengeführte Menü für das Formular ab. (inherited from Form).
Public property | MinimizeBox | Ruft einen Wert ab, der angibt, ob auf der Titelleiste des Formulars die Schaltfläche Minimieren angezeigt wird, oder legt diesen fest. (inherited from Form).
Public property | MinimumSize | Ruft die Mindestgröße des Formulars ab oder legt diese fest. (inherited from Form).
Public property | Modal | Ruft einen Wert ab, der angibt, ob dieses Formular modal angezeigt wird. (inherited from Form).
 | ModifierKeys | Ruft einen Wert ab, der angibt, welche der Modifizierertasten (UMSCHALT, STRG und/oder ALT) gerade gedrückt wird. (inherited from Control).
 | MouseButtons | Ruft einen Wert ab, der angibt, welche Maustaste gerade gedrückt wird. (inherited from Control).
 | MousePosition | Ruft die Position des Mauszeigers in Bildschirmkoordinaten ab. (inherited from Control).
Public property | Name | Ruft den Namen des Steuerelements ab oder legt diesen fest. (inherited from Control).
Public property | Opacity | Ruft die Durchlässigkeit des Formulars ab oder legt diese fest. (inherited from Form).
Public property | OwnedForms | Ruft ein Array von Form-Objekten ab, die alle Formulare darstellen, die dieses Formular besitzt. (inherited from Form).
Public property | Owner | Ruft das Formular ab, das Besitzer dieses Formulars ist, oder legt dieses fest. (inherited from Form).
Public property | Padding | Ruft den Abstand im Steuerelement ab oder legt diesen fest. (inherited from Control).
Public property | Parent | Ruft den übergeordneten Container des Steuerelements ab oder legt diesen fest. (inherited from Control).
Public property | ParentForm | Ruft das Formular ab, dem das Containersteuerelement zugewiesen ist. (inherited from ContainerControl).
Public property | PreferredSize | Ruft die Größe eines rechteckigen Bereichs ab, in den das Steuerelement eingepasst werden kann. (inherited from Control).
Public property | ProductName | Ruft den Produktnamen der Assembly ab, die das Steuerelement enthält. (inherited from Control).
Public property | ProductVersion | Ruft die Version der Assembly ab, die das Steuerelement enthält. (inherited from Control).
Public property | RecreatingHandle | Ruft einen Wert ab, der angibt, ob das Steuerelement gerade das zugehörige Handle neu erstellt. (inherited from Control).
Public property | Region | Ruft den dem Steuerelement zugeordneten Fensterbereich ab oder legt diesen fest. (inherited from Control).
Public property | RestoreBounds | Ruft die Position und die Größe des Formulars im normalen Fensterzustand ab. (inherited from Form).
Public property | Right | Ruft den Abstand zwischen dem rechten Rand des Steuerelements und dem linken Rand des Clientbereichs des zugehörigen Containers in Pixel ab. (inherited from Control).
Public property | RightToLeft | Ruft einen Wert ab, der angibt, ob Elemente des Steuerelements für die Unterstützung von Gebietsschemas ausgerichtet sind, die von rechts nach links geschriebene Schriftarten verwenden, oder legt diesen fest. (inherited from Control).
Public property | RightToLeftLayout | Ruft einen Wert ab, der angibt, ob die Anordnung der Spiegelung von rechts nach links aktiviert ist, oder legt diesen Wert fest. (inherited from Form).
Public property | ShowIcon | Ruft einen Wert ab, der angibt, ob ein Symbol auf der Titelleiste des Formulars angezeigt wird, oder legt diesen Wert fest. (inherited from Form).
Public property | ShowInTaskbar | Ruft einen Wert ab, der angibt, ob das Formular auf der Windows-Taskleiste angezeigt wird, oder legt diesen fest. (inherited from Form).
Public property | Site | Ruft die Site des Steuerelements ab oder legt diese fest. (inherited from Control).
Public property | Size | Ruft die Größe des Formulars ab oder legt diese fest. (inherited from Form).
Public property | SizeGripStyle | Ruft die Art des Größenziehpunkts in der linken unteren Ecke des Formulars ab oder legt diesen fest. (inherited from Form).
Public property | StartPosition | Ruft die Anfangsposition des Formulars zur Laufzeit ab oder legt diese fest. (inherited from Form).
Public property | TabIndex | Ruft die Aktivierreihenfolge des Steuerelements in dessen Container ab oder legt diese fest. (inherited from Form).
Public property | TabStop | Ruft einen Wert ab, der angibt, ob Benutzer den Fokus mit der TAB-TASTE auf dieses Steuerelement setzen können, oder legt diesen fest. (inherited from Form).
Public property | Tag | Ruft das Objekt ab, das Daten über das Steuerelement enthält, oder legt dieses fest. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Ruft den Abstand zwischen dem oberen Rand des Steuerelements und dem oberen Rand des Clientbereichs des zugehörigen Containers in Pixel ab oder legt diesen fest. (inherited from Control).
Public property | TopLevel | Ruft einen Wert ab, der angibt, ob das Formular als Fenster der obersten Ebene angezeigt wird, oder legt diesen fest. (inherited from Form).
Public property | TopLevelControl | Ruft das übergeordnete Steuerelement ab, dem kein anderes Windows Forms-Steuerelement übergeordnet ist.Dies ist i. d. R. das äußerste Form, in dem das Steuerelement enthalten ist. (inherited from Control).
Public property | TopMost | Ruft einen Wert ab, der angibt, ob das Formular als oberstes Formular angezeigt werden soll, oder legt diesen fest. (inherited from Form).
Public property | TransparencyKey | Ruft die Farbe ab, in der transparente Bereiche des Formulars darstellt werden, oder legt diese fest. (inherited from Form).
Public property | UseWaitCursor | Ruft einen Wert ab, der angibt, ob der Wartecursor für das aktuelle Steuerelement und alle untergeordneten Steuerelemente verwendet werden soll. (inherited from Control).
Public property | VerticalScroll | Ruft die der vertikalen Schiebeleiste zugeordneten Merkmale ab. (inherited from ScrollableControl).
Public property | Visible | Ruft einen Wert ab, mit dem angegeben wird, ob das Steuerelement und alle untergeordneten Steuerelemente angezeigt werden, oder legt diesen Wert fest. (inherited from Control).
Public property | Width | Ruft die Breite des Steuerelements ab oder legt diese fest. (inherited from Control).
Public property | WindowState | Ruft den Fensterzustand des Formulars ab oder legt diesen fest. (inherited from Form).
Public property | WindowTarget | Diese Eigenschaft ist für diese Klasse nicht relevant. (inherited from Control).
Top

Expand image See Also

Reference

frmPrinterSettings Class


frmPrinterSettings Methods

[image] [image] [image]

AllgFnkt_Plugin Reference
frmPrinterSettings Methods
frmPrinterSettings Class See Also

Expand image Public Methods

 | Name | Description
Public method | Activate | Aktiviert das Formular und übergibt diesem den Fokus. (inherited from Form).
Public method | AddOwnedForm | Fügt diesem Formular als Besitzer ein Formular hinzu. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Führt den angegebenen Delegaten asynchron für den Thread aus, in dem das dem Steuerelement zugrunde liegende Handle erstellt wurde. (inherited from Control).
Public method | BringToFront | Zeigt dieses Steuerelement am Anfang der z-Reihenfolge an. (inherited from Control).
Public method | Close | Schließt das Formular. (inherited from Form).
Public method | Contains | Ruft einen Wert ab, der angibt, ob das angegebene Steuerelement dem Steuerelement untergeordnet ist. (inherited from Control).
Public method | CreateControl | Erzwingt das Erstellen des Steuerelements, einschließlich des Handles und aller untergeordneten Steuerelemente. (inherited from Control).
Public method | CreateGraphics | Erstellt die Graphics für das Steuerelement. (inherited from Control).
Public method | CreateObjRef | Erstellt ein Objekt mit allen relevanten Informationen, die zum Generieren eines Proxys für die Kommunikation mit einem Remoteobjekt erforderlich sind. (inherited from MarshalByRefObject).
Supported by the .NET Compact Framework. | DefaultPrinterName |
Public method | DoDragDrop | Beginnt einen Drag & Drop-Vorgang. (inherited from Control).
Public method | DrawToBitmap | Unterstützt das Rendering für die angegebene Bitmap. (inherited from Control).
Public method | EndInvoke | Ruft den Rückgabewert des asynchronen Vorgangs ab, der durch das übergebene IAsyncResult dargestellt wird. (inherited from Control).
Public method | Equals | (Overloaded) Bestimmt, ob das angegebene Object und das aktuelle Object gleich sind. (inherited from Object).
Public method | FindForm | Ruft das Formular ab, in dem sich das Steuerelement befindet. (inherited from Control).
Public method | Focus | Setzt den Eingabefokus auf das Steuerelement. (inherited from Control).
 | FromChildHandle | Ruft das Steuerelement ab, das das angegebene Handle enthält. (inherited from Control).
 | FromHandle | Gibt das Steuerelement zurück, das gerade dem angegebenen Handle zugeordnet ist. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Ruft die Größe des Formulars bei automatischer Skalierung entsprechend einer angegebenen Schriftart ab. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Ruft das untergeordnete Steuerelement ab, das sich an den angegebenen Koordinaten befindet, und gibt an, ob untergeordnete Steuerelemente eines bestimmten Typs ignoriert werden sollen. (inherited from Control).
Public method | GetContainerControl | Gibt das nächste ContainerControl aufwärts in der Kette übergeordneter Steuerelemente des Steuerelements zurück. (inherited from Control).
Public method | GetLifetimeService | Ruft das aktuelle Lebensdauerdienstobjekt ab, das die Lebensdauerrichtlinien für diese Instanz steuert. (inherited from MarshalByRefObject).
Public method | GetNextControl | Ruft das nächste oder vorherige Steuerelement in der Aktivierreihenfolge untergeordneter Steuerelemente ab. (inherited from Control).
Public method | GetPreferredSize | Ruft die Größe eines rechteckigen Bereichs ab, in den ein Steuerelement eingefügt werden kann. (inherited from Control).
Public method | Hide | Verbirgt das Steuerelement vor dem Benutzer. (inherited from Control).
Public method | InitializeLifetimeService | Ruft ein Lebensdauerdienstobjekt ab, mit dem die Lebensdauerrichtlinien für diese Instanz gesteuert werden können. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Erklärt den angegebenen Bereich des Steuerelements für ungültig, indem es diesen dem Aktualisierungsbereich des Steuerelements hinzufügt. Dies ist der Bereich, der beim nächsten Zeichnenvorgang neu gezeichnet wird. Außerdem wird veranlasst, dass eine Zeichnenmeldung an das Steuerelement gesendet wird. (inherited from Control).
Public method | Invoke | (Overloaded) Führt den angegebenen Delegaten für den Thread aus, der das dem Steuerelement zugrunde liegende Fensterhandle besitzt. (inherited from Control).
 | IsKeyLocked | Bestimmt, ob die FESTSTELLTASTE, NUM oder ROLLEN aktiviert ist. (inherited from Control).
 | IsMnemonic | Bestimmt, ob das angegebene Zeichen das mnemonische Zeichen ist, das dem Steuerelement in der angegebenen Zeichenfolge zugewiesen wurde. (inherited from Control).
Public method | LayoutMdi | Ordnet die untergeordneten MDI (Multiple Document Interface)-Formulare im übergeordneten MDI-Formular an. (inherited from Form).
Public method | PerformAutoScale | Führt eine Skalierung für das Containersteuerelement und die dazugehörigen untergeordneten Elemente aus. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Erzwingt die Anwendung von Layoutlogik durch das Steuerelement auf sämtliche diesem untergeordneten Steuerelemente. (inherited from Control).
Public method | PointToClient | Rechnet die Position des angegebenen Bildschirmpunkts in Clientkoordinaten um. (inherited from Control).
Public method | PointToScreen | Rechnet die Position des angegebenen Clientpunkts in Bildschirmkoordinaten um. (inherited from Control).
Public method | PreProcessControlMessage | Führt eine Vorverarbeitung der Tastatur- oder Eingabemeldungen in der Nachrichtenschleife aus, bevor sie gesendet werden. (inherited from Control).
Public method | PreProcessMessage | Führt eine Vorverarbeitung der Tastatur- oder Eingabemeldungen in der Nachrichtenschleife aus, bevor sie gesendet werden. (inherited from Control).
Public method | RectangleToClient | Berechnet die Größe und die Position des angegebenen Bildschirmrechtecks in Clientkoordinaten. (inherited from Control).
Public method | RectangleToScreen | Berechnet die Größe und die Position des angegebenen Clientrechtecks in Bildschirmkoordinaten. (inherited from Control).
Public method | Refresh | Erzwingt, dass das Steuerelement seinen Clientbereich für ungültig erklärt und sich sowie alle untergeordneten Steuerelemente sofort selbst neu zeichnet. (inherited from Control).
Public method | RemoveOwnedForm | Entfernt ein Formular aus dem Besitzerformular. (inherited from Form).
Public method | ResetBackColor | Setzt die BackColor-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResetBindings | Führt dazu, dass in ein an BindingSource gebundenes Steuerelement alle Elemente in der Liste erneut eingelesen und ihre angezeigten Werte aktualisiert werden. (inherited from Control).
Public method | ResetCursor | Setzt die Cursor-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResetFont | Setzt die Font-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResetForeColor | Setzt die ForeColor-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResetImeMode | Setzt die ImeMode-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResetRightToLeft | Setzt die RightToLeft-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResetText | Setzt die Text-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Nimmt die übliche Layoutlogik wieder auf. (inherited from Control).
Public method | Scale | (Overloaded) Skaliert das Steuerelement und alle untergeordneten Steuerelemente. (inherited from Control).
Public method | ScrollControlIntoView | Führt einen Bildlauf durch, um das angegebene untergeordnete Steuerelement in einem Steuerelement anzuzeigen, für das der automatische Bildlauf aktiviert ist. (inherited from ScrollableControl).
Public method | SelectNextControl | Aktiviert das nächste Steuerelement. (inherited from Control).
Public method | SendToBack | Sendet das Steuerelement ans Ende der z-Reihenfolge. (inherited from Control).
Public method | SetAutoScrollMargin | Legt die Größe der AutoBildlaufränder fest. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Legt die Begrenzungen des Steuerelements auf die angegebene Position und Größe fest. (inherited from Control).
Public method | SetDesktopBounds | Legt die Begrenzungen des Formulars in Desktopkoordinaten fest. (inherited from Form).
Public method | SetDesktopLocation | Legt die Position des Formulars in Desktopkoordinaten fest. (inherited from Form).
Public method | Show | (Overloaded) Zeigt dem Benutzer das Formular mit dem angegebenen Besitzer an. (inherited from Form).
Public method | ShowDialog | (Overloaded) Zeigt das Formular als modales Dialogfeld an, wobei das derzeit aktive Fenster als Besitzer festgelegt ist. (inherited from Form).
Supported by the .NET Compact Framework. | SortNodes |
Public method | SuspendLayout | Unterbricht vorübergehend die Layoutlogik für das Steuerelement. (inherited from Control).
Public method | ToString | Ruft eine Zeichenfolge ab, die die aktuelle Instanz des Formulars darstellt. (inherited from Form).
Public method | Update | Bewirkt, dass das Steuerelement die für ungültig erklärten Bereiche im Clientbereich neu zeichnet. (inherited from Control).
Public method | Validate | (Overloaded) Überprüft den Wert des Steuerelements, das den Fokus verliert, indem das Validating-Ereignis und das Validated-Ereignis in dieser Reihenfolge ausgelöst werden. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top

Expand image Protected Methods

 | Name | Description
Protected method | ActivateMdiChild | Aktiviert das untergeordnete MDI-Element eines Formulars. (inherited from Form).
Protected method | AdjustFormScrollbars | Passt die Schiebeleisten im Container anhand der aktuellen Positionen der Steuerelemente und des aktuell ausgewählten Steuerelements an. (inherited from Form).
Protected method | ApplyAutoScaling | Obsolete. Ändert die Größe des Formulars entsprechend dem aktuellen Wert der AutoScaleBaseSize-Eigenschaft und der Größe der aktuellen Schriftart. (inherited from Form).
Protected method | CenterToParent | Zentriert die Position des Formulars innerhalb der Begrenzungen des übergeordneten Formulars. (inherited from Form).
Protected method | CenterToScreen | Zentriert das Formular für den aktuellen Bildschirm. (inherited from Form).
Protected method | CreateAccessibilityInstance | Erstellt ein neues Objekt für die Barrierefreiheit für das Steuerelement. (inherited from Control).
Protected method | CreateControlsInstance | (inherited from Form).
Protected method | CreateHandle | Erstellt das Handle für das Formular.Wenn eine abgeleitete Klasse diese Funktion überschreibt, muss sie die Basisimplementierung aufrufen. (inherited from Form).
Protected method | DefWndProc | (inherited from Form).
Protected method | DestroyHandle | Löscht das mit dem Steuerelement verknüpfte Handle. (inherited from Control).
Supported by the .NET Compact Framework. | Dispose | (Overloaded) Gibt die von Form verwendeten Ressourcen (mit Ausnahme des Speichers) frei.
Protected method | Finalize | Gibt nicht verwaltete Ressourcen frei und führt andere Bereinigungsvorgänge durch, bevor die Component durch die Garbage Collection wieder zugänglich gemacht wird. (inherited from Component).
Protected method | GetAccessibilityObjectById | Ruft das angegebene AccessibleObject ab. (inherited from Control).
Protected method | GetAutoSizeMode | Ruft einen Wert ab, der angibt, wie sich ein Steuerelement verhält, wenn seine AutoSize-Eigenschaft aktiviert wird. (inherited from Control).
Protected method | GetScaledBounds | (inherited from Form).
Protected method | GetScrollState | Bestimmt, ob das angegebene Flag festgelegt wurde. (inherited from ScrollableControl).
Protected method | GetService | Gibt ein Objekt zurück, das einen von der Component oder von deren Container bereitgestellten Dienst darstellt. (inherited from Component).
Protected method | GetStyle | Ruft den Wert für das angegebene Steuerelement-Formatbit für das Steuerelement ab. (inherited from Control).
Protected method | GetTopLevel | Bestimmt, ob es sich bei dem Steuerelement um ein Steuerelement der obersten Ebene handelt. (inherited from Control).
Protected method | InitLayout | Wird nach dem Hinzufügen des Steuerelements zu einem anderen Container aufgerufen. (inherited from Control).
Protected method | InvokeGotFocus | Löst das GotFocus-Ereignis für das angegebene Steuerelement aus. (inherited from Control).
Protected method | InvokeLostFocus | Löst das LostFocus-Ereignis für das angegebene Steuerelement aus. (inherited from Control).
Protected method | InvokeOnClick | Löst das Click-Ereignis für das angegebene Steuerelement aus. (inherited from Control).
Protected method | InvokePaint | Löst das Paint-Ereignis für das angegebene Steuerelement aus. (inherited from Control).
Protected method | InvokePaintBackground | Löst das PaintBackground-Ereignis für das angegebene Steuerelement aus. (inherited from Control).
Protected method | IsInputChar | Bestimmt, ob ein Zeichen ein vom Steuerelement erkanntes Eingabezeichen ist. (inherited from Control).
Protected method | IsInputKey | Bestimmt, ob es sich bei der angegebenen Taste um eine normale oder um eine besondere Taste handelt, für die eine Vorverarbeitung erforderlich ist. (inherited from Control).
Protected method | MemberwiseClone | Erstellt eine flache Kopie des aktuellen MarshalByRefObject-Objekts. (inherited from MarshalByRefObject).
Protected method | NotifyInvalidate | Löst das Invalidated-Ereignis aus, wobei ein angegebener Bereich des Steuerelements für ungültig erklärt wird. (inherited from Control).
Protected method | OnActivated | Löst das Activated-Ereignis aus. (inherited from Form).
Protected method | OnAutoSizeChanged | Löst das AutoSizeChanged-Ereignis aus. (inherited from Control).
Protected method | OnAutoValidateChanged | Löst das AutoValidateChanged-Ereignis aus. (inherited from ContainerControl).
Protected method | OnBackColorChanged | Löst das BackColorChanged-Ereignis aus. (inherited from Control).
Protected method | OnBackgroundImageChanged | Löst das BackgroundImageChanged-Ereignis aus. (inherited from Form).
Protected method | OnBackgroundImageLayoutChanged | Löst das BackgroundImageLayoutChanged-Ereignis aus. (inherited from Form).
Protected method | OnBindingContextChanged | Löst das BindingContextChanged-Ereignis aus. (inherited from Control).
Protected method | OnCausesValidationChanged | Löst das CausesValidationChanged-Ereignis aus. (inherited from Control).
Protected method | OnChangeUICues | Löst das ChangeUICues-Ereignis aus. (inherited from Control).
Protected method | OnClick | Löst das Click-Ereignis aus. (inherited from Control).
Protected method | OnClientSizeChanged | Löst das ClientSizeChanged-Ereignis aus. (inherited from Control).
Protected method | OnClosed | Löst das Closed-Ereignis aus. (inherited from Form).
Protected method | OnClosing | Löst das Closing-Ereignis aus. (inherited from Form).
Protected method | OnContextMenuChanged | Löst das ContextMenuChanged-Ereignis aus. (inherited from Control).
Protected method | OnContextMenuStripChanged | Löst das ContextMenuStripChanged-Ereignis aus. (inherited from Control).
Protected method | OnControlAdded | Löst das ControlAdded-Ereignis aus. (inherited from Control).
Protected method | OnControlRemoved | Löst das ControlRemoved-Ereignis aus. (inherited from Control).
Protected method | OnCreateControl | Löst das CreateControl-Ereignis aus. (inherited from Form).
Protected method | OnCursorChanged | Löst das CursorChanged-Ereignis aus. (inherited from Control).
Protected method | OnDeactivate | Löst das Deactivate-Ereignis aus. (inherited from Form).
Protected method | OnDockChanged | Löst das DockChanged-Ereignis aus. (inherited from Control).
Protected method | OnDoubleClick | Löst das DoubleClick-Ereignis aus. (inherited from Control).
Protected method | OnDragDrop | Löst das DragDrop-Ereignis aus. (inherited from Control).
Protected method | OnDragEnter | Löst das DragEnter-Ereignis aus. (inherited from Control).
Protected method | OnDragLeave | Löst das DragLeave-Ereignis aus. (inherited from Control).
Protected method | OnDragOver | Löst das DragOver-Ereignis aus. (inherited from Control).
Protected method | OnEnabledChanged | (inherited from Form).
Protected method | OnEnter | Löst das Enter-Ereignis aus. (inherited from Form).
Protected method | OnFontChanged | (inherited from Form).
Protected method | OnForeColorChanged | Löst das ForeColorChanged-Ereignis aus. (inherited from Control).
Protected method | OnFormClosed | Löst das FormClosed-Ereignis aus. (inherited from Form).
Protected method | OnFormClosing | Löst das FormClosing-Ereignis aus. (inherited from Form).
Protected method | OnGiveFeedback | Löst das GiveFeedback-Ereignis aus. (inherited from Control).
Protected method | OnGotFocus | Löst das GotFocus-Ereignis aus. (inherited from Control).
Protected method | OnHandleCreated | (inherited from Form).
Protected method | OnHandleDestroyed | (inherited from Form).
Protected method | OnHelpButtonClicked | Löst das HelpButtonClicked-Ereignis aus. (inherited from Form).
Protected method | OnHelpRequested | Löst das HelpRequested-Ereignis aus. (inherited from Control).
Protected method | OnImeModeChanged | Löst das ImeModeChanged-Ereignis aus. (inherited from Control).
Protected method | OnInputLanguageChanged | Löst das InputLanguageChanged-Ereignis aus. (inherited from Form).
Protected method | OnInputLanguageChanging | Löst das InputLanguageChanging-Ereignis aus. (inherited from Form).
Protected method | OnInvalidated | Löst das Invalidated-Ereignis aus. (inherited from Control).
Protected method | OnKeyDown | Löst das KeyDown-Ereignis aus. (inherited from Control).
Protected method | OnKeyPress | Löst das KeyPress-Ereignis aus. (inherited from Control).
Protected method | OnKeyUp | Löst das KeyUp-Ereignis aus. (inherited from Control).
Protected method | OnLayout | Löst das Layout-Ereignis aus. (inherited from Form).
Protected method | OnLeave | Löst das Leave-Ereignis aus. (inherited from Control).
Protected method | OnLoad | Löst das Load-Ereignis aus. (inherited from Form).
Protected method | OnLocationChanged | Löst das LocationChanged-Ereignis aus. (inherited from Control).
Protected method | OnLostFocus | Löst das LostFocus-Ereignis aus. (inherited from Control).
Protected method | OnMarginChanged | Löst das MarginChanged-Ereignis aus. (inherited from Control).
Protected method | OnMaximizedBoundsChanged | Löst das MaximizedBoundsChanged-Ereignis aus. (inherited from Form).
Protected method | OnMaximumSizeChanged | Löst das MaximumSizeChanged-Ereignis aus. (inherited from Form).
Protected method | OnMdiChildActivate | Löst das MdiChildActivate-Ereignis aus. (inherited from Form).
Protected method | OnMenuComplete | Löst das MenuComplete-Ereignis aus. (inherited from Form).
Protected method | OnMenuStart | Löst das MenuStart-Ereignis aus. (inherited from Form).
Protected method | OnMinimumSizeChanged | Löst das MinimumSizeChanged-Ereignis aus. (inherited from Form).
Protected method | OnMouseCaptureChanged | Löst das MouseCaptureChanged-Ereignis aus. (inherited from Control).
Protected method | OnMouseClick | Löst das MouseClick-Ereignis aus. (inherited from Control).
Protected method | OnMouseDoubleClick | Löst das MouseDoubleClick-Ereignis aus. (inherited from Control).
Protected method | OnMouseDown | Löst das MouseDown-Ereignis aus. (inherited from Control).
Protected method | OnMouseEnter | Löst das MouseEnter-Ereignis aus. (inherited from Control).
Protected method | OnMouseHover | Löst das MouseHover-Ereignis aus. (inherited from Control).
Protected method | OnMouseLeave | Löst das MouseLeave-Ereignis aus. (inherited from Control).
Protected method | OnMouseMove | Löst das MouseMove-Ereignis aus. (inherited from Control).
Protected method | OnMouseUp | Löst das MouseUp-Ereignis aus. (inherited from Control).
Protected method | OnMouseWheel | Löst das MouseWheel-Ereignis aus. (inherited from ScrollableControl).
Protected method | OnMove | Löst das Move-Ereignis aus. (inherited from Control).
Protected method | OnNotifyMessage | Benachrichtigt das Steuerelement über Windows-Meldungen. (inherited from Control).
Protected method | OnPaddingChanged | Löst das PaddingChanged-Ereignis aus. (inherited from ScrollableControl).
Protected method | OnPaint | (inherited from Form).
Protected method | OnPaintBackground | Zeichnet den Hintergrund des Steuerelements. (inherited from ScrollableControl).
Protected method | OnParentBackColorChanged | Löst das BackColorChanged-Ereignis aus, wenn sich der BackColor-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentBackgroundImageChanged | Löst das BackgroundImageChanged-Ereignis aus, wenn sich der BackgroundImage-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentBindingContextChanged | Löst das BindingContextChanged-Ereignis aus, wenn sich der BindingContext-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentChanged | (inherited from ContainerControl).
Protected method | OnParentCursorChanged | Löst das CursorChanged-Ereignis aus. (inherited from Control).
Protected method | OnParentEnabledChanged | Löst das EnabledChanged-Ereignis aus, wenn sich der Enabled-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentFontChanged | Löst das FontChanged-Ereignis aus, wenn sich der Font-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentForeColorChanged | Löst das ForeColorChanged-Ereignis aus, wenn sich der ForeColor-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentRightToLeftChanged | Löst das RightToLeftChanged-Ereignis aus, wenn sich der RightToLeft-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentVisibleChanged | Löst das VisibleChanged-Ereignis aus, wenn sich der Visible-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnPreviewKeyDown | Löst das PreviewKeyDown-Ereignis aus. (inherited from Control).
Protected method | OnPrint | Löst das Paint-Ereignis aus. (inherited from Control).
Protected method | OnQueryContinueDrag | Löst das QueryContinueDrag-Ereignis aus. (inherited from Control).
Protected method | OnRegionChanged | Löst das RegionChanged-Ereignis aus. (inherited from Control).
Protected method | OnResize | (inherited from Form).
Protected method | OnResizeBegin | Löst das ResizeBegin-Ereignis aus. (inherited from Form).
Protected method | OnResizeEnd | Löst das ResizeEnd-Ereignis aus. (inherited from Form).
Protected method | OnRightToLeftChanged | (inherited from ScrollableControl).
Protected method | OnRightToLeftLayoutChanged | Löst das RightToLeftLayoutChanged-Ereignis aus. (inherited from Form).
Protected method | OnScroll | Löst das Scroll-Ereignis aus. (inherited from ScrollableControl).
Protected method | OnShown | Löst das Shown-Ereignis aus. (inherited from Form).
Protected method | OnSizeChanged | Löst das SizeChanged-Ereignis aus. (inherited from Control).
Protected method | OnStyleChanged | (inherited from Form).
Protected method | OnSystemColorsChanged | Löst das SystemColorsChanged-Ereignis aus. (inherited from Control).
Protected method | OnTabIndexChanged | Löst das TabIndexChanged-Ereignis aus. (inherited from Control).
Protected method | OnTabStopChanged | Löst das TabStopChanged-Ereignis aus. (inherited from Control).
Protected method | OnTextChanged | (inherited from Form).
Protected method | OnValidated | Löst das Validated-Ereignis aus. (inherited from Control).
Protected method | OnValidating | Löst das Validating-Ereignis aus. (inherited from Control).
Protected method | OnVisibleChanged | Löst das VisibleChanged-Ereignis aus. (inherited from Form).
Protected method | ProcessCmdKey | Verarbeitet eine Befehlstaste. (inherited from Form).
Protected method | ProcessDialogChar | Verarbeitet ein Dialogfeldzeichen. (inherited from Form).
Protected method | ProcessDialogKey | Verarbeitet eine Tastatureingabe im Dialogfeld. (inherited from Form).
Protected method | ProcessKeyEventArgs | Verarbeitet eine Tastenmeldung und generiert die entsprechenden Steuerelementereignisse. (inherited from Control).
Protected method | ProcessKeyPreview | (inherited from Form).
Protected method | ProcessTabKey | (inherited from Form).
Protected method | RaiseDragEvent | Löst das entsprechende Ziehereignis aus. (inherited from Control).
Protected method | RaiseKeyEvent | Löst das entsprechende Tastenereignis aus. (inherited from Control).
Protected method | RaiseMouseEvent | Löst das entsprechende Mausereignis aus. (inherited from Control).
Protected method | RaisePaintEvent | Löst das entsprechende Paint-Ereignis aus. (inherited from Control).
Protected method | RecreateHandle | Erzwingt ein erneutes Erstellen des Handles für das Steuerelement. (inherited from Control).
 | ReflectMessage | Reflektiert die angegebene Meldung an das Steuerelement, das an das angegebene Handle gebunden ist. (inherited from Control).
Protected method | ResetMouseEventArgs | Setzt das Steuerelement zurück, um das MouseLeave-Ereignis zu behandeln. (inherited from Control).
Protected method | RtlTranslateAlignment | (Overloaded) Konvertiert das angegebene HorizontalAlignment in das entsprechende HorizontalAlignment für die Unterstützung der Schriftrichtung von rechts nach links. (inherited from Control).
Protected method | RtlTranslateHorizontal | Konvertiert das angegebene HorizontalAlignment in das entsprechende HorizontalAlignment für die Unterstützung der Schriftrichtung von rechts nach links. (inherited from Control).
Protected method | RtlTranslateLeftRight | Konvertiert das angegebene LeftRightAlignment in das entsprechende LeftRightAlignment für die Unterstützung der Schriftrichtung von rechts nach links. (inherited from Control).
Protected method | ScaleControl | Skaliert Speicherort, Größe, Textabstand und Rand eines Steuerelements. (inherited from Form).
Protected method | ScaleCore | Führt die Skalierung des Formulars aus. (inherited from Form).
Protected method | ScrollToControl | Berechnet den Bildlauf-Offset zum angegebenen untergeordneten Steuerelement. (inherited from ScrollableControl).
Protected method | Select | (Overloaded) Aktiviert dieses Formular und wählt optional das nächste oder vorherige Steuerelement aus. (inherited from Form).
Protected method | SetAutoSizeMode | Legt einen Wert fest, der angibt, wie sich ein Steuerelement verhält, wenn seine AutoSize-Eigenschaft aktiviert wird. (inherited from Control).
Protected method | SetBoundsCore | (inherited from Form).
Protected method | SetClientSizeCore | Legt die Clientgröße des Formulars fest.Hiermit werden die Begrenzungen des Formulars so angepasst, dass die Clientgröße der angeforderten Größe entspricht. (inherited from Form).
Protected method | SetDisplayRectLocation | Positioniert das Anzeigefenster anhand des angegebenen Werts. (inherited from ScrollableControl).
Protected method | SetScrollState | Legt das angegebene Flag für den Bildlaufzustand fest. (inherited from ScrollableControl).
Protected method | SetStyle | Legt ein angegebenes ControlStyles-Flag auf true oder false fest. (inherited from Control).
Protected method | SetTopLevel | Legt das Steuerelement als Steuerelement der obersten Ebene fest. (inherited from Control).
Protected method | SetVisibleCore | (inherited from Form).
Protected method | SizeFromClientSize | Bestimmt die Größe des gesamten Steuerelements anhand der Höhe und Breite seines Clientbereichs. (inherited from Control).
Protected method | UpdateDefaultButton | Aktualisiert, welche Schaltfläche die Standardschaltfläche ist. (inherited from Form).
Protected method | UpdateStyles | Erzwingt ein erneutes Anwenden der zugewiesenen Formate auf das Steuerelement. (inherited from Control).
Protected method | UpdateZOrder | Aktualisiert das Steuerelement in der z-Reihenfolge des übergeordneten Elements. (inherited from Control).
Protected method | WndProc | (inherited from Form).
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Internal protected (Protected Friend) method | AccessibilityNotifyClients | (Overloaded) Benachrichtigt die Clientanwendungen für die Barrierefreiheit über die angegebenen AccessibleEvents für das angegebene untergeordnete Steuerelement. (inherited from Control).
Internal protected (Protected Friend) method | ProcessKeyMessage | Verarbeitet eine Tastaturmeldung. (inherited from Control).
Internal protected (Protected Friend) method | ProcessMnemonic | Verarbeitet ein mnemonisches Zeichen. (inherited from Form).
Internal protected (Protected Friend) method | RtlTranslateContent | Konvertiert das angegebene ContentAlignment in das entsprechende ContentAlignment für die Unterstützung der Schriftrichtung von rechts nach links. (inherited from Control).
Internal protected (Protected Friend) method | UpdateBounds | (Overloaded) Aktualisiert die Begrenzungen des Steuerelements mit der aktuellen Größe und Position. (inherited from Control).
Top

Expand image See Also

Reference

frmPrinterSettings Class


frmPrinterSettings.DefaultPrinterName Method

[image] [image] [image]

AllgFnkt_Plugin Reference
frmPrinterSettings.DefaultPrinterName Method
See Also

Assembly: AllgFnkt_Plugin (in AllgFnkt_Plugin.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Function DefaultPrinterName() As String
C#
public static string DefaultPrinterName()
C++
public:
static String^ DefaultPrinterName()
JScript
public static function DefaultPrinterName() : String;

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPrinterSettings Class
frmPrinterSettings Members


frmPrinterSettings.Dispose Method

[image] [image] [image]

AllgFnkt_Plugin Reference
frmPrinterSettings.Dispose Method
frmPrinterSettings Class See Also

Gibt die von Form verwendeten Ressourcen (mit Ausnahme des Speichers) frei.

Expand image Overload List

Name | Description
Dispose(bool) | Gibt die von Form verwendeten Ressourcen (mit Ausnahme des Speichers) frei.
Dispose | Gibt sämtliche von der Component verwendeten Ressourcen frei. (System.ComponentModel.Component).

Expand image See Also

Reference

frmPrinterSettings Class
frmPrinterSettings Members


frmPrinterSettings.SortNodes Method

[image] [image] [image]

AllgFnkt_Plugin Reference
frmPrinterSettings.SortNodes Method
See Also

Assembly: AllgFnkt_Plugin (in AllgFnkt_Plugin.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub SortNodes( _
   ByVal NodesCollection As TreeNodeCollection, _
   Optional ByVal Ascending As Boolean = True _
)
C#
public System.Void SortNodes(
   TreeNodeCollection NodesCollection,
   bool Ascending
)
C++
public:
System::Void SortNodes(
   TreeNodeCollection^ NodesCollection,
   bool Ascending
)
JScript
public function SortNodes(
    NodesCollection : TreeNodeCollection,
    Ascending : boolean
);

Parameters

NodesCollection

Type: TreeNodeCollection

Required.

Ascending

Type: bool

If set to true, then ; otherwise, .

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPrinterSettings Class
frmPrinterSettings Members


frmPrinterSettings Events

[image] [image] [image]

AllgFnkt_Plugin Reference
frmPrinterSettings Events
frmPrinterSettings Class See Also

Expand image Public Events

 | Name | Description
Public event | Activated | Tritt ein, wenn das Formular im Code oder vom Benutzer aktiviert wird. (inherited from Form).
Public event | AutoSizeChanged | Tritt ein, wenn sich die AutoSize-Eigenschaft ändert. (inherited from Form).
Public event | AutoValidateChanged | Tritt ein, wenn sich die AutoValidate-Eigenschaft ändert. (inherited from Form).
Public event | BackColorChanged | Tritt ein, wenn sich der Wert der BackColor-Eigenschaft ändert. (inherited from Control).
Public event | BackgroundImageChanged | Tritt ein, wenn sich der Wert der BackgroundImage-Eigenschaft ändert. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Tritt ein, wenn sich die BackgroundImageLayout-Eigenschaft ändert. (inherited from Control).
Public event | BindingContextChanged | Tritt ein, wenn sich der Wert der BindingContext-Eigenschaft ändert. (inherited from Control).
Public event | CausesValidationChanged | Tritt auf, wenn der Wert der CausesValidation-Eigenschaft geändert wird. (inherited from Control).
Public event | ChangeUICues | Tritt ein, wenn sich der Fokus-Cue oder der Tastatur-Cue der Benutzeroberfläche ändert. (inherited from Control).
Public event | Click | Tritt beim Klicken auf das Steuerelement ein. (inherited from Control).
Public event | ClientSizeChanged | Tritt ein, wenn sich der Wert der ClientSize-Eigenschaft ändert. (inherited from Control).
Public event | Closed | Tritt ein, wenn das Formular geschlossen ist. (inherited from Form).
Public event | Closing | Tritt beim Schließen des Formulars ein. (inherited from Form).
Public event | ContextMenuChanged | Tritt ein, wenn sich der Wert der ContextMenu-Eigenschaft ändert. (inherited from Control).
Public event | ContextMenuStripChanged | Tritt ein, wenn sich der Wert der ContextMenuStrip-Eigenschaft ändert. (inherited from Control).
Public event | ControlAdded | Tritt ein, wenn der ControlCollection ein neues Steuerelement hinzugefügt wird. (inherited from Control).
Public event | ControlRemoved | Tritt beim Entfernen des Steuerelements aus der ControlCollection ein. (inherited from Control).
Public event | CursorChanged | Tritt ein, wenn sich der Wert der Cursor-Eigenschaft ändert. (inherited from Control).
Public event | Deactivate | Tritt ein, wenn das Formular den Fokus verliert und nicht mehr das aktive Formular ist. (inherited from Form).
Public event | Disposed | Tritt ein, wenn die Komponente durch einen Aufruf der Dispose-Methode freigegeben wird. (inherited from Component).
Public event | DockChanged | Tritt ein, wenn sich der Wert der Dock-Eigenschaft ändert. (inherited from Control).
Public event | DoubleClick | Tritt beim Doppelklicken auf das Steuerelement ein. (inherited from Control).
Public event | DragDrop | Tritt ein, wenn eine Drag & Drop-Operation beendet wurde. (inherited from Control).
Public event | DragEnter | Tritt ein, wenn ein Objekt in den Bereich des Steuerelements gezogen wird. (inherited from Control).
Public event | DragLeave | Tritt ein, wenn ein Objekt aus dem Bereich des Steuerelements gezogen wird. (inherited from Control).
Public event | DragOver | Tritt ein, wenn ein Objekt über die Begrenzungen des Steuerelements gezogen wird. (inherited from Control).
Public event | EnabledChanged | Tritt ein, wenn sich der Enabled-Eigenschaftswert geändert hat. (inherited from Control).
Public event | Enter | Tritt beim Eintreten in den Bereich des Steuerelements ein. (inherited from Control).
Public event | FontChanged | Tritt ein, wenn sich der Font-Eigenschaftswert ändert. (inherited from Control).
Public event | ForeColorChanged | Tritt ein, wenn sich der ForeColor-Eigenschaftswert ändert. (inherited from Control).
Public event | FormClosed | Tritt ein, nachdem das Formular geschlossen wurde. (inherited from Form).
Public event | FormClosing | Tritt ein, bevor das Formular geschlossen wird. (inherited from Form).
Public event | GiveFeedback | Tritt während eines Ziehvorgangs ein. (inherited from Control).
Public event | GotFocus | Tritt ein, wenn das Steuerelement den Fokus erhält. (inherited from Control).
Public event | HandleCreated | Tritt ein, wenn ein Handle für das Steuerelement erstellt wird. (inherited from Control).
Public event | HandleDestroyed | Tritt ein, wenn das Handle des Steuerelements gerade gelöscht wird. (inherited from Control).
Public event | HelpButtonClicked | Tritt beim Klicken auf die Schaltfläche Hilfe ein. (inherited from Form).
Public event | HelpRequested | Tritt ein, wenn der Benutzer die Hilfe für ein Steuerelement anfordert. (inherited from Control).
Public event | ImeModeChanged | Tritt ein, wenn die ImeMode-Eigenschaft geändert wurde. (inherited from Control).
Public event | InputLanguageChanged | Tritt ein, nachdem die Eingabesprache des Formulars geändert wurde. (inherited from Form).
Public event | InputLanguageChanging | Tritt ein, wenn der Benutzer versucht, die Eingabesprache für das Formular zu ändern. (inherited from Form).
Public event | Invalidated | Tritt ein, wenn die Anzeige eines Steuerelements neu gezeichnet werden muss. (inherited from Control).
Public event | KeyDown | Tritt ein, wenn eine Taste gedrückt wird, während das Steuerelement den Fokus hat. (inherited from Control).
Public event | KeyPress | Tritt ein, wenn eine Taste gedrückt wird, während das Steuerelement den Fokus hat. (inherited from Control).
Public event | KeyUp | Tritt ein, wenn eine Taste losgelassen wird, während das Steuerelement den Fokus hat. (inherited from Control).
Public event | Layout | Tritt ein, wenn ein Steuerelement seine untergeordneten Steuerelemente neu positionieren muss. (inherited from Control).
Public event | Leave | Tritt ein, wenn der Eingabefokus das Steuerelement verlässt. (inherited from Control).
Public event | Load | Tritt ein, bevor ein Formular erstmals angezeigt wird. (inherited from Form).
Public event | LocationChanged | Tritt ein, wenn sich der Location-Eigenschaftswert geändert hat. (inherited from Control).
Public event | LostFocus | Tritt ein, wenn das Steuerelement den Fokus verliert. (inherited from Control).
Public event | MarginChanged | Tritt ein, wenn sich die Margin-Eigenschaft ändert. (inherited from Form).
Public event | MaximizedBoundsChanged | Tritt ein, wenn sich der Wert der MaximizedBounds-Eigenschaft geändert hat. (inherited from Form).
Public event | MaximumSizeChanged | Tritt ein, wenn sich der Wert der MaximumSize-Eigenschaft geändert hat. (inherited from Form).
Public event | MdiChildActivate | Tritt ein, wenn ein untergeordnetes MDI (Multiple Document Interface)-Formular in einer MDI-Anwendung aktiviert oder geschlossen wird. (inherited from Form).
Public event | MenuComplete | Tritt ein, wenn das Menü eines Formulars den Fokus verliert. (inherited from Form).
Public event | MenuStart | Tritt ein, wenn das Menü eines Formulars den Fokus erhält. (inherited from Form).
Public event | MinimumSizeChanged | Tritt ein, wenn sich der Wert der MinimumSize-Eigenschaft geändert hat. (inherited from Form).
Public event | MouseCaptureChanged | Tritt ein, wenn das Steuerelement beginnt oder aufhört, Mauseingaben aufzufangen. (inherited from Control).
Public event | MouseClick | Tritt ein, wenn mit der Maus auf das Steuerelement geklickt wird. (inherited from Control).
Public event | MouseDoubleClick | Tritt ein, wenn mit der Maus ein Doppelklick auf das Steuerelement ausgeführt wird. (inherited from Control).
Public event | MouseDown | Tritt ein, wenn sich der Mauszeiger über dem Steuerelement befindet und eine Maustaste gedrückt wird. (inherited from Control).
Public event | MouseEnter | Tritt ein, wenn der Mauszeiger in den Bereich des Steuerelements eintritt. (inherited from Control).
Public event | MouseHover | Tritt ein, wenn der Mauszeiger auf dem Steuerelement verbleibt. (inherited from Control).
Public event | MouseLeave | Tritt ein, wenn der Mauszeiger den Bereich des Steuerelements verlässt. (inherited from Control).
Public event | MouseMove | Tritt ein, wenn der Mauszeiger über dem Steuerelement bewegt wird. (inherited from Control).
Public event | MouseUp | Tritt ein, wenn sich der Mauszeiger über dem Steuerelement befindet und eine Maustaste losgelassen wird. (inherited from Control).
Public event | MouseWheel | Tritt ein, wenn das Mausrad bewegt wird, während das Steuerelement den Fokus besitzt. (inherited from Control).
Public event | Move | Tritt beim Verschieben des Steuerelements ein. (inherited from Control).
Public event | PaddingChanged | Tritt ein, wenn der Abstand des Steuerelements geändert wird. (inherited from Control).
Public event | Paint | Tritt ein, wenn das Steuerelement neu gezeichnet wird. (inherited from Control).
Public event | ParentChanged | Tritt ein, wenn sich der Parent-Eigenschaftswert ändert. (inherited from Control).
Public event | PreviewKeyDown | Tritt vor dem KeyDown-Ereignis ein, wenn eine Taste gedrückt wird, während dieses Steuerelement den Fokus besitzt. (inherited from Control).
Public event | QueryAccessibilityHelp | Tritt ein, wenn AccessibleObject Hilfe für barrierefreie Anwendungen bereitstellt. (inherited from Control).
Public event | QueryContinueDrag | Tritt während eines Drag & Drop-Vorgangs ein. Dadurch kann die Quelle des Ziehvorgangs bestimmen, ob der Drag & Drop-Vorgang abgebrochen werden soll. (inherited from Control).
Public event | RegionChanged | Tritt ein, wenn sich der Wert der Region-Eigenschaft ändert. (inherited from Control).
Public event | Resize | Tritt beim Ändern der Größe des Steuerelements ein. (inherited from Control).
Public event | ResizeBegin | Tritt ein, wenn ein Formular in den Größenänderungsmodus wechselt. (inherited from Form).
Public event | ResizeEnd | Tritt ein, wenn ein Formular den Größenänderungsmodus verlässt. (inherited from Form).
Public event | RightToLeftChanged | Tritt ein, wenn sich der RightToLeft-Eigenschaftswert ändert. (inherited from Control).
Public event | RightToLeftLayoutChanged | Tritt ein, nachdem sich der Wert der RightToLeftLayout-Eigenschaft geändert hat. (inherited from Form).
Public event | Scroll | Tritt ein, wenn vom Benutzer oder von Code ein Bildlauf durch den Clientbereich durchgeführt wird. (inherited from ScrollableControl).
Public event | Shown | Tritt immer dann ein, wenn das Formular erstmalig angezeigt wird. (inherited from Form).
Public event | SizeChanged | Tritt ein, wenn sich der Size-Eigenschaftswert ändert. (inherited from Control).
Public event | StyleChanged | Tritt ein, wenn sich das Format des Steuerelements ändert. (inherited from Control).
Public event | SystemColorsChanged | Tritt ein, wenn sich die Systemfarben ändern. (inherited from Control).
Public event | TabIndexChanged | Tritt ein, wenn sich der Wert der TabIndex-Eigenschaft ändert. (inherited from Form).
Public event | TabStopChanged | Tritt ein, wenn sich die TabStop-Eigenschaft ändert. (inherited from Form).
Public event | TextChanged | Tritt ein, wenn sich der Text-Eigenschaftswert ändert. (inherited from Control).
Public event | Validated | Tritt ein, wenn das Steuerelement die Überprüfung abgeschlossen hat. (inherited from Control).
Public event | Validating | Tritt ein, während das Steuerelement eine Überprüfung durchführt. (inherited from Control).
Public event | VisibleChanged | Tritt ein, wenn sich der Visible-Eigenschaftswert ändert. (inherited from Control).
Top

Expand image See Also

Reference

frmPrinterSettings Class


frmPrinterSettings_sik Class

[image] [image] [image]

AllgFnkt_Plugin Reference
frmPrinterSettings_sik Class
Members

Assembly: AllgFnkt_Plugin (in AllgFnkt_Plugin.dll)

Expand image Syntax

Visual Basic (Declaration)
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmPrinterSettings_sik
    Inherits Form
C#
[Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()]
public class frmPrinterSettings_sik : Form
C++
[Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()]
public ref class frmPrinterSettings_sik : public Form^
JScript
public
   Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()
class frmPrinterSettings_sik
   extends Form

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
AllgFnkt_Plugin.frmPrinterSettings_sik

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPrinterSettings_sik Members


frmPrinterSettings_sik Members

[image] [image] [image]

AllgFnkt_Plugin Reference
frmPrinterSettings_sik Members
frmPrinterSettings_sik Class Constructors Events Methods Properties See Also

The following tables list the members exposed by the frmPrinterSettings_sik type.

Expand image Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | frmPrinterSettings_sik Constructor | Initializes a new instance of the frmPrinterSettings_sik class.
Top

Expand image Public Properties

 | Name | Description
Public property | AcceptButton | Ruft die Schaltfläche im Formular ab, die beim Drücken der EINGABETASTE betätigt wird, oder legt diese fest. (inherited from Form).
Public property | AccessibilityObject | Ruft das dem Steuerelement zugewiesene AccessibleObject ab. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Ruft die Beschreibung der Standardaktion des Steuerelements für die Verwendung durch Clientanwendungen für die Barrierefreiheit ab oder legt diese fest. (inherited from Control).
Public property | AccessibleDescription | Ruft die Beschreibung des von Clientanwendungen für die Barrierefreiheit verwendeten Steuerelements ab oder legt diese fest. (inherited from Control).
Public property | AccessibleName | Ruft den Namen des von Clientanwendungen für die Barrierefreiheit verwendeten Steuerelements ab oder legt diesen fest. (inherited from Control).
Public property | AccessibleRole | Ruft die barrierefreie Rolle des Steuerelements ab oder legt diese fest. (inherited from Control).
Public property | ActiveControl | Ruft das aktive Steuerelement im Containersteuerelement ab oder legt dieses fest. (inherited from ContainerControl).
 | ActiveForm | Ruft das momentan aktive Formular für diese Anwendung ab. (inherited from Form).
Public property | ActiveMdiChild | Ruft das momentan aktive untergeordnete MDI (Multiple Document Interface)-Fenster ab. (inherited from Form).
Public property | AllowDrop | Ruft einen Wert ab, der angibt, ob das Steuerelement Daten annehmen kann, die vom Benutzer darauf gezogen wurden, oder legt diesen fest. (inherited from Control).
Public property | AllowTransparency | Ruft einen Wert ab, der angibt, ob die Durchlässigkeit des Formulars angepasst werden kann, oder legt diesen Wert fest. (inherited from Form).
Public property | Anchor | Ruft die Ränder des Containers ab, an die ein Steuerelement gebunden ist, oder legt diese fest und bestimmt, wie die Größe des Steuerelements mit dessen übergeordnetem Element geändert wird. (inherited from Control).
Public property | AutoScale | Obsolete. Ruft einen Wert ab, der angibt, ob die Größe des Formulars der Höhe der im Formular verwendeten Schriftart angepasst wird und die Steuerelemente des Formulars skaliert werden, oder legt diesen fest. (inherited from Form).
Public property | AutoScaleBaseSize | Ruft die Grundgröße ab, die für die automatische Skalierung des Formulars verwendet wird, oder legt diese fest. (inherited from Form).
Public property | AutoScaleDimensions | Ruft die Dimensionen ab, für die das Steuerelement entworfen wurde, oder ruft diese ab. (inherited from ContainerControl).
Public property | AutoScaleMode | Ruft den automatischen Skalierungsmodus des Steuerelements ab oder legt diesen fest. (inherited from ContainerControl).
Public property | AutoScroll | Ruft einen Wert ab, der angibt, ob das Formular den automatischen Bildlauf ermöglicht, oder legt diesen fest. (inherited from Form).
Public property | AutoScrollMargin | Ruft die Größe des AutoBildlaufrandes ab oder legt diese fest. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Ruft die minimale Größe des AutoBildlaufs ab oder legt diese fest. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Ruft in Control) ab oder legt anhand dessen fest, in welcher Richtung der Bildlauf dieses Steuerelements durchgeführt wird. (inherited from Control).
Public property | AutoScrollPosition | Ruft die Position des AutoBildlaufs ab oder legt diese fest. (inherited from ScrollableControl).
Public property | AutoSize | Ändern Sie die Größe des Formulars entsprechend der Einstellung von AutoSizeMode. (inherited from Form).
Public property | AutoSizeMode | Ruft den Modus ab, in dem das Formular seine Größe automatisch selbst ändert, oder legt diesen Modus fest. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Ruft das im Steuerelement angezeigte Hintergrundbild ab oder legt dieses fest. (inherited from Control).
Public property | BackgroundImageLayout | Ruft das Layout für das Hintergrundbild wie in der ImageLayout-Enumeration definiert ab oder legt dieses fest. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Ruft den Abstand zwischen dem unteren Rand des Steuerelements und dem oberen Rand des Clientbereichs des zugehörigen Containers in Pixel ab. (inherited from Control).
Public property | Bounds | Ruft die Größe und die Position des Steuerelements, einschließlich seiner Nicht-Clientelemente, in Pixel relativ zum übergeordneten Steuerelement ab oder legt diese fest. (inherited from Control).
Public property | CanFocus | Ruft einen Wert ab, der angibt, ob das Steuerelement den Fokus erhalten kann. (inherited from Control).
Public property | CanSelect | Ruft einen Wert ab, der angibt, ob das Steuerelement ausgewählt werden kann. (inherited from Control).
Public property | CancelButton | Ruft das Button-Steuerelement ab, das beim Drücken von ESC betätigt wird, oder legt dieses fest. (inherited from Form).
Public property | Capture | Ruft einen Wert ab, der angibt, ob die Maus vom Steuerelement erfasst wurde, oder legt diesen fest. (inherited from Control).
Public property | CausesValidation | Ruft einen Wert ab, der angibt, ob das Steuerelement bei Erhalt des Fokus eine Validierung für alle eine Validierung erfordernden Steuerelemente veranlasst, oder legt diesen fest. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Ruft einen Wert ab, mit dem angegeben wird, ob Aufrufe an den falschen Thread, der auf die Handle-Eigenschaft eines Steuerelements zugreift, abgefangen werden sollen, wenn eine Anwendung gedebuggt wird, oder legt diesen Wert fest. (inherited from Control).
Public property | ClientRectangle | Ruft das Rechteck ab, das den Clientbereich des Steuerelements darstellt. (inherited from Control).
Public property | ClientSize | Ruft die Größe des Clientbereichs des Formulars ab oder legt diese fest. (inherited from Form).
Public property | CompanyName | Ruft den Namen des Unternehmens oder des Entwicklers der Anwendung ab, die das Steuerelement enthält. (inherited from Control).
Public property | Container | Ruft den IContainer ab, der die Component enthält. (inherited from Component).
Public property | ContainsFocus | Ruft einen Wert ab, der angibt, ob das Steuerelement oder eines der untergeordneten Steuerelemente den Eingabefokus besitzt. (inherited from Control).
Public property | ContextMenu | Ruft das dem Steuerelement zugeordnete Kontextmenü ab oder legt dieses fest. (inherited from Control).
Public property | ContextMenuStrip | Ruft die diesem Steuerelement zugeordnete ContextMenuStrip-Klasse ab oder legt diese fest. (inherited from Control).
Public property | ControlBox | Ruft einen Wert ab, der angibt, ob auf der Titelleiste des Formulars ein Systemmenüfeld angezeigt wird, oder legt diesen fest. (inherited from Form).
Public property | Controls | Ruft die im Steuerelement enthaltene Auflistung von Steuerelementen ab. (inherited from Control).
Public property | Created | Ruft einen Wert ab, der angibt, ob das Steuerelement erstellt wurde. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Ruft die aktuellen Laufzeitdimensionen des Bildschirms ab. (inherited from ContainerControl).
Public property | Cursor | Ruft den Cursor ab, der angezeigt wird, wenn sich der Mauszeiger über dem Steuerelement befindet, oder legt diesen fest. (inherited from Control).
Public property | DataBindings | Ruft die Datenbindungen für das Steuerelement ab. (inherited from Control).
 | DefaultBackColor | Ruft die Standardhintergrundfarbe des Steuerelements ab. (inherited from Control).
 | DefaultFont | Ruft die Standardschriftart des Steuerelements ab. (inherited from Control).
 | DefaultForeColor | Ruft die Standardvordergrundfarbe des Steuerelements ab. (inherited from Control).
Public property | DesktopBounds | Ruft Größe und Position des Formulars auf dem Windows-Desktop ab oder legt diese fest. (inherited from Form).
Public property | DesktopLocation | Ruft die Position des Formulars auf dem Windows-Desktop ab oder legt diese fest. (inherited from Form).
Public property | DialogResult | Ruft das Dialogergebnis für das Formular ab oder legt dieses fest. (inherited from Form).
Public property | DisplayRectangle | Ruft das Rechteck ab, das den virtuellen Anzeigebereich des Steuerelements darstellt. (inherited from ScrollableControl).
Public property | Disposing | Ruft einen Wert ab, der angibt, ob die Control-Basisklasse gerade freigegeben wird. (inherited from Control).
Public property | Dock | Ruft ab oder legt fest, welche Steuerelementrahmen am übergeordneten Steuerelement angedockt sind, und bestimmt, wie die Größe eines Steuerelements mit dem übergeordneten Steuerelement geändert wird. (inherited from Control).
Public property | DockPadding | Ruft die Einstellungen für den Andockleerraum für alle Ränder des Steuerelements ab. (inherited from ScrollableControl).
Public property | Enabled | Ruft einen Wert ab, der angibt, ob das Steuerelement auf Benutzerinteraktionen reagieren kann, oder legt diesen fest. (inherited from Control).
Public property | Focused | Ruft einen Wert ab, der angibt, ob das Steuerelement den Eingabefokus besitzt. (inherited from Control).
Public property | Font | Ruft die Schriftart für die Anzeige von Text im Steuerelement ab oder legt diese fest. (inherited from Control).
Public property | ForeColor | Ruft die Vordergrundfarbe des Steuerelements ab oder legt diese fest. (inherited from Control).
Public property | FormBorderStyle | Ruft die Rahmenart des Formulars ab oder legt diese fest. (inherited from Form).
Public property | Handle | Ruft das Fensterhandle ab, an das das Steuerelement gebunden ist. (inherited from Control).
Public property | HasChildren | Ruft einen Wert ab, der angibt, ob das Steuerelement ein oder mehrere untergeordnete Steuerelemente enthält. (inherited from Control).
Public property | Height | Ruft die Höhe des Steuerelements ab oder legt diese fest. (inherited from Control).
Public property | HelpButton | Ruft einen Wert ab, der angibt, ob auf der Titelleiste des Formulars die Hilfeschaltfläche angezeigt werden soll, oder legt diesen fest. (inherited from Form).
Public property | HorizontalScroll | Ruft die der horizontalen Schiebeleiste zugeordneten Merkmale ab. (inherited from ScrollableControl).
Public property | Icon | Ruft das Symbol für das Formular ab oder legt dieses fest. (inherited from Form).
Public property | ImeMode | Ruft den IME-Modus (Eingabemethoden-Editor) des Steuerelements ab oder legt diesen fest. (inherited from Control).
Public property | InvokeRequired | Ruft einen Wert ab, der angibt ob der Aufrufer beim Aufruf von Methoden des Steuerelements eine Aufrufmethode aufrufen muss, da sich der Aufrufer in einem anderen Thread als dem befindet, in dem das Steuerelement erstellt wurde. (inherited from Control).
Public property | IsAccessible | Ruft einen Wert ab, der angibt, ob das Steuerelement für barrierefreie Anwendungen sichtbar ist, oder legt diesen fest. (inherited from Control).
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Steuerelement freigegeben wurde. (inherited from Control).
Public property | IsHandleCreated | Ruft einen Wert ab, der angibt, ob dem Steuerelement ein Handle zugeordnet ist. (inherited from Control).
Public property | IsMdiChild | Ruft einen Wert ab, der angibt, ob das Formular ein untergeordnetes MDI (Multiple Document Interface)-Formular ist. (inherited from Form).
Public property | IsMdiContainer | Ruft einen Wert ab, der angibt, ob das Formular ein Container für untergeordnete MDI (Multiple Document Interface)-Formulare ist, oder legt diesen fest. (inherited from Form).
Public property | IsMirrored | Ruft einen Wert ab, der angibt, ob das Steuerelement gespiegelt wird. (inherited from Control).
Public property | IsRestrictedWindow | Ruft einen Wert ab, der angibt, ob für das Formular alle Fenster und Benutzereingabeereignisse uneingeschränkt verwendet werden können. (inherited from Form).
Public property | KeyPreview | Ruft einen Wert ab, der angibt, ob das Formular Tastaturereignisse empfängt, bevor das Ereignis an das Steuerelement übergeben wird, das den Fokus besitzt, oder legt diesen fest. (inherited from Form).
Public property | LayoutEngine | Ruft eine zwischengespeicherte Instanz des Layoutmoduls des Steuerelements ab. (inherited from Control).
Public property | Left | Ruft den Abstand zwischen dem linken Rand des Steuerelements und dem linken Rand des Clientbereichs des zugehörigen Containers in Pixel ab oder legt diesen fest. (inherited from Control).
Public property | Location | Ruft den Point ab, der die linke obere Ecke des Form in Bildschirmkoordinaten darstellt, oder legt diesen fest. (inherited from Form).
Public property | MainMenuStrip | Ruft den primären Menücontainer für das Formular ab oder legt diesen fest. (inherited from Form).
Public property | Margin | Ruft den Zwischenraum zwischen Steuerelementen ab oder legt diesen fest. (inherited from Form).
Public property | MaximizeBox | Ruft einen Wert ab, der angibt, ob auf der Titelleiste des Formulars die Schaltfläche Maximieren angezeigt wird, oder legt diesen fest. (inherited from Form).
Public property | MaximumSize | Ruft die maximale Größe für die Vergrößerung des Formulars ab. (inherited from Form).
Public property | MdiChildren | Ruft ein Array von Formularen ab, das die untergeordneten MDI (Multiple Document Interface)-Formulare darstellt, deren übergeordnetes Formular dieses Formular ist. (inherited from Form).
Public property | MdiParent | Ruft das aktuelle übergeordnete MDI (Multiple Document Interface)-Formular für dieses Formular ab oder legt dieses fest. (inherited from Form).
Public property | Menu | Ruft das MainMenu ab, das im Formular angezeigt wird, oder legt dieses fest. (inherited from Form).
Public property | MergedMenu | Ruft das zusammengeführte Menü für das Formular ab. (inherited from Form).
Public property | MinimizeBox | Ruft einen Wert ab, der angibt, ob auf der Titelleiste des Formulars die Schaltfläche Minimieren angezeigt wird, oder legt diesen fest. (inherited from Form).
Public property | MinimumSize | Ruft die Mindestgröße des Formulars ab oder legt diese fest. (inherited from Form).
Public property | Modal | Ruft einen Wert ab, der angibt, ob dieses Formular modal angezeigt wird. (inherited from Form).
 | ModifierKeys | Ruft einen Wert ab, der angibt, welche der Modifizierertasten (UMSCHALT, STRG und/oder ALT) gerade gedrückt wird. (inherited from Control).
 | MouseButtons | Ruft einen Wert ab, der angibt, welche Maustaste gerade gedrückt wird. (inherited from Control).
 | MousePosition | Ruft die Position des Mauszeigers in Bildschirmkoordinaten ab. (inherited from Control).
Public property | Name | Ruft den Namen des Steuerelements ab oder legt diesen fest. (inherited from Control).
Public property | Opacity | Ruft die Durchlässigkeit des Formulars ab oder legt diese fest. (inherited from Form).
Public property | OwnedForms | Ruft ein Array von Form-Objekten ab, die alle Formulare darstellen, die dieses Formular besitzt. (inherited from Form).
Public property | Owner | Ruft das Formular ab, das Besitzer dieses Formulars ist, oder legt dieses fest. (inherited from Form).
Public property | Padding | Ruft den Abstand im Steuerelement ab oder legt diesen fest. (inherited from Control).
Public property | Parent | Ruft den übergeordneten Container des Steuerelements ab oder legt diesen fest. (inherited from Control).
Public property | ParentForm | Ruft das Formular ab, dem das Containersteuerelement zugewiesen ist. (inherited from ContainerControl).
Public property | PreferredSize | Ruft die Größe eines rechteckigen Bereichs ab, in den das Steuerelement eingepasst werden kann. (inherited from Control).
Public property | ProductName | Ruft den Produktnamen der Assembly ab, die das Steuerelement enthält. (inherited from Control).
Public property | ProductVersion | Ruft die Version der Assembly ab, die das Steuerelement enthält. (inherited from Control).
Public property | RecreatingHandle | Ruft einen Wert ab, der angibt, ob das Steuerelement gerade das zugehörige Handle neu erstellt. (inherited from Control).
Public property | Region | Ruft den dem Steuerelement zugeordneten Fensterbereich ab oder legt diesen fest. (inherited from Control).
Public property | RestoreBounds | Ruft die Position und die Größe des Formulars im normalen Fensterzustand ab. (inherited from Form).
Public property | Right | Ruft den Abstand zwischen dem rechten Rand des Steuerelements und dem linken Rand des Clientbereichs des zugehörigen Containers in Pixel ab. (inherited from Control).
Public property | RightToLeft | Ruft einen Wert ab, der angibt, ob Elemente des Steuerelements für die Unterstützung von Gebietsschemas ausgerichtet sind, die von rechts nach links geschriebene Schriftarten verwenden, oder legt diesen fest. (inherited from Control).
Public property | RightToLeftLayout | Ruft einen Wert ab, der angibt, ob die Anordnung der Spiegelung von rechts nach links aktiviert ist, oder legt diesen Wert fest. (inherited from Form).
Public property | ShowIcon | Ruft einen Wert ab, der angibt, ob ein Symbol auf der Titelleiste des Formulars angezeigt wird, oder legt diesen Wert fest. (inherited from Form).
Public property | ShowInTaskbar | Ruft einen Wert ab, der angibt, ob das Formular auf der Windows-Taskleiste angezeigt wird, oder legt diesen fest. (inherited from Form).
Public property | Site | Ruft die Site des Steuerelements ab oder legt diese fest. (inherited from Control).
Public property | Size | Ruft die Größe des Formulars ab oder legt diese fest. (inherited from Form).
Public property | SizeGripStyle | Ruft die Art des Größenziehpunkts in der linken unteren Ecke des Formulars ab oder legt diesen fest. (inherited from Form).
Public property | StartPosition | Ruft die Anfangsposition des Formulars zur Laufzeit ab oder legt diese fest. (inherited from Form).
Public property | TabIndex | Ruft die Aktivierreihenfolge des Steuerelements in dessen Container ab oder legt diese fest. (inherited from Form).
Public property | TabStop | Ruft einen Wert ab, der angibt, ob Benutzer den Fokus mit der TAB-TASTE auf dieses Steuerelement setzen können, oder legt diesen fest. (inherited from Form).
Public property | Tag | Ruft das Objekt ab, das Daten über das Steuerelement enthält, oder legt dieses fest. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Ruft den Abstand zwischen dem oberen Rand des Steuerelements und dem oberen Rand des Clientbereichs des zugehörigen Containers in Pixel ab oder legt diesen fest. (inherited from Control).
Public property | TopLevel | Ruft einen Wert ab, der angibt, ob das Formular als Fenster der obersten Ebene angezeigt wird, oder legt diesen fest. (inherited from Form).
Public property | TopLevelControl | Ruft das übergeordnete Steuerelement ab, dem kein anderes Windows Forms-Steuerelement übergeordnet ist.Dies ist i. d. R. das äußerste Form, in dem das Steuerelement enthalten ist. (inherited from Control).
Public property | TopMost | Ruft einen Wert ab, der angibt, ob das Formular als oberstes Formular angezeigt werden soll, oder legt diesen fest. (inherited from Form).
Public property | TransparencyKey | Ruft die Farbe ab, in der transparente Bereiche des Formulars darstellt werden, oder legt diese fest. (inherited from Form).
Public property | UseWaitCursor | Ruft einen Wert ab, der angibt, ob der Wartecursor für das aktuelle Steuerelement und alle untergeordneten Steuerelemente verwendet werden soll. (inherited from Control).
Public property | VerticalScroll | Ruft die der vertikalen Schiebeleiste zugeordneten Merkmale ab. (inherited from ScrollableControl).
Public property | Visible | Ruft einen Wert ab, mit dem angegeben wird, ob das Steuerelement und alle untergeordneten Steuerelemente angezeigt werden, oder legt diesen Wert fest. (inherited from Control).
Public property | Width | Ruft die Breite des Steuerelements ab oder legt diese fest. (inherited from Control).
Public property | WindowState | Ruft den Fensterzustand des Formulars ab oder legt diesen fest. (inherited from Form).
Public property | WindowTarget | Diese Eigenschaft ist für diese Klasse nicht relevant. (inherited from Control).
Top

Expand image Public Methods

 | Name | Description
Public method | Activate | Aktiviert das Formular und übergibt diesem den Fokus. (inherited from Form).
Public method | AddOwnedForm | Fügt diesem Formular als Besitzer ein Formular hinzu. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Führt den angegebenen Delegaten asynchron für den Thread aus, in dem das dem Steuerelement zugrunde liegende Handle erstellt wurde. (inherited from Control).
Public method | BringToFront | Zeigt dieses Steuerelement am Anfang der z-Reihenfolge an. (inherited from Control).
Public method | Close | Schließt das Formular. (inherited from Form).
Public method | Contains | Ruft einen Wert ab, der angibt, ob das angegebene Steuerelement dem Steuerelement untergeordnet ist. (inherited from Control).
Public method | CreateControl | Erzwingt das Erstellen des Steuerelements, einschließlich des Handles und aller untergeordneten Steuerelemente. (inherited from Control).
Public method | CreateGraphics | Erstellt die Graphics für das Steuerelement. (inherited from Control).
Public method | CreateObjRef | Erstellt ein Objekt mit allen relevanten Informationen, die zum Generieren eines Proxys für die Kommunikation mit einem Remoteobjekt erforderlich sind. (inherited from MarshalByRefObject).
Supported by the .NET Compact Framework. | DefaultPrinterName |
Public method | DoDragDrop | Beginnt einen Drag & Drop-Vorgang. (inherited from Control).
Public method | DrawToBitmap | Unterstützt das Rendering für die angegebene Bitmap. (inherited from Control).
Public method | EndInvoke | Ruft den Rückgabewert des asynchronen Vorgangs ab, der durch das übergebene IAsyncResult dargestellt wird. (inherited from Control).
Public method | Equals | (Overloaded) Bestimmt, ob das angegebene Object und das aktuelle Object gleich sind. (inherited from Object).
Public method | FindForm | Ruft das Formular ab, in dem sich das Steuerelement befindet. (inherited from Control).
Public method | Focus | Setzt den Eingabefokus auf das Steuerelement. (inherited from Control).
 | FromChildHandle | Ruft das Steuerelement ab, das das angegebene Handle enthält. (inherited from Control).
 | FromHandle | Gibt das Steuerelement zurück, das gerade dem angegebenen Handle zugeordnet ist. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Ruft die Größe des Formulars bei automatischer Skalierung entsprechend einer angegebenen Schriftart ab. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Ruft das untergeordnete Steuerelement ab, das sich an den angegebenen Koordinaten befindet, und gibt an, ob untergeordnete Steuerelemente eines bestimmten Typs ignoriert werden sollen. (inherited from Control).
Public method | GetContainerControl | Gibt das nächste ContainerControl aufwärts in der Kette übergeordneter Steuerelemente des Steuerelements zurück. (inherited from Control).
Public method | GetLifetimeService | Ruft das aktuelle Lebensdauerdienstobjekt ab, das die Lebensdauerrichtlinien für diese Instanz steuert. (inherited from MarshalByRefObject).
Public method | GetNextControl | Ruft das nächste oder vorherige Steuerelement in der Aktivierreihenfolge untergeordneter Steuerelemente ab. (inherited from Control).
Public method | GetPreferredSize | Ruft die Größe eines rechteckigen Bereichs ab, in den ein Steuerelement eingefügt werden kann. (inherited from Control).
Public method | Hide | Verbirgt das Steuerelement vor dem Benutzer. (inherited from Control).
Public method | InitializeLifetimeService | Ruft ein Lebensdauerdienstobjekt ab, mit dem die Lebensdauerrichtlinien für diese Instanz gesteuert werden können. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Erklärt den angegebenen Bereich des Steuerelements für ungültig, indem es diesen dem Aktualisierungsbereich des Steuerelements hinzufügt. Dies ist der Bereich, der beim nächsten Zeichnenvorgang neu gezeichnet wird. Außerdem wird veranlasst, dass eine Zeichnenmeldung an das Steuerelement gesendet wird. (inherited from Control).
Public method | Invoke | (Overloaded) Führt den angegebenen Delegaten für den Thread aus, der das dem Steuerelement zugrunde liegende Fensterhandle besitzt. (inherited from Control).
 | IsKeyLocked | Bestimmt, ob die FESTSTELLTASTE, NUM oder ROLLEN aktiviert ist. (inherited from Control).
 | IsMnemonic | Bestimmt, ob das angegebene Zeichen das mnemonische Zeichen ist, das dem Steuerelement in der angegebenen Zeichenfolge zugewiesen wurde. (inherited from Control).
Public method | LayoutMdi | Ordnet die untergeordneten MDI (Multiple Document Interface)-Formulare im übergeordneten MDI-Formular an. (inherited from Form).
Public method | PerformAutoScale | Führt eine Skalierung für das Containersteuerelement und die dazugehörigen untergeordneten Elemente aus. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Erzwingt die Anwendung von Layoutlogik durch das Steuerelement auf sämtliche diesem untergeordneten Steuerelemente. (inherited from Control).
Public method | PointToClient | Rechnet die Position des angegebenen Bildschirmpunkts in Clientkoordinaten um. (inherited from Control).
Public method | PointToScreen | Rechnet die Position des angegebenen Clientpunkts in Bildschirmkoordinaten um. (inherited from Control).
Public method | PreProcessControlMessage | Führt eine Vorverarbeitung der Tastatur- oder Eingabemeldungen in der Nachrichtenschleife aus, bevor sie gesendet werden. (inherited from Control).
Public method | PreProcessMessage | Führt eine Vorverarbeitung der Tastatur- oder Eingabemeldungen in der Nachrichtenschleife aus, bevor sie gesendet werden. (inherited from Control).
Public method | RectangleToClient | Berechnet die Größe und die Position des angegebenen Bildschirmrechtecks in Clientkoordinaten. (inherited from Control).
Public method | RectangleToScreen | Berechnet die Größe und die Position des angegebenen Clientrechtecks in Bildschirmkoordinaten. (inherited from Control).
Public method | Refresh | Erzwingt, dass das Steuerelement seinen Clientbereich für ungültig erklärt und sich sowie alle untergeordneten Steuerelemente sofort selbst neu zeichnet. (inherited from Control).
Public method | RemoveOwnedForm | Entfernt ein Formular aus dem Besitzerformular. (inherited from Form).
Public method | ResetBackColor | Setzt die BackColor-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResetBindings | Führt dazu, dass in ein an BindingSource gebundenes Steuerelement alle Elemente in der Liste erneut eingelesen und ihre angezeigten Werte aktualisiert werden. (inherited from Control).
Public method | ResetCursor | Setzt die Cursor-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResetFont | Setzt die Font-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResetForeColor | Setzt die ForeColor-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResetImeMode | Setzt die ImeMode-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResetRightToLeft | Setzt die RightToLeft-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResetText | Setzt die Text-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Nimmt die übliche Layoutlogik wieder auf. (inherited from Control).
Public method | Scale | (Overloaded) Skaliert das Steuerelement und alle untergeordneten Steuerelemente. (inherited from Control).
Public method | ScrollControlIntoView | Führt einen Bildlauf durch, um das angegebene untergeordnete Steuerelement in einem Steuerelement anzuzeigen, für das der automatische Bildlauf aktiviert ist. (inherited from ScrollableControl).
Public method | SelectNextControl | Aktiviert das nächste Steuerelement. (inherited from Control).
Public method | SendToBack | Sendet das Steuerelement ans Ende der z-Reihenfolge. (inherited from Control).
Public method | SetAutoScrollMargin | Legt die Größe der AutoBildlaufränder fest. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Legt die Begrenzungen des Steuerelements auf die angegebene Position und Größe fest. (inherited from Control).
Public method | SetDesktopBounds | Legt die Begrenzungen des Formulars in Desktopkoordinaten fest. (inherited from Form).
Public method | SetDesktopLocation | Legt die Position des Formulars in Desktopkoordinaten fest. (inherited from Form).
Public method | Show | (Overloaded) Zeigt dem Benutzer das Formular mit dem angegebenen Besitzer an. (inherited from Form).
Public method | ShowDialog | (Overloaded) Zeigt das Formular als modales Dialogfeld an, wobei das derzeit aktive Fenster als Besitzer festgelegt ist. (inherited from Form).
Supported by the .NET Compact Framework. | SortNodes |
Public method | SuspendLayout | Unterbricht vorübergehend die Layoutlogik für das Steuerelement. (inherited from Control).
Public method | ToString | Ruft eine Zeichenfolge ab, die die aktuelle Instanz des Formulars darstellt. (inherited from Form).
Public method | Update | Bewirkt, dass das Steuerelement die für ungültig erklärten Bereiche im Clientbereich neu zeichnet. (inherited from Control).
Public method | Validate | (Overloaded) Überprüft den Wert des Steuerelements, das den Fokus verliert, indem das Validating-Ereignis und das Validated-Ereignis in dieser Reihenfolge ausgelöst werden. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top

Expand image Protected Methods

 | Name | Description
Protected method | ActivateMdiChild | Aktiviert das untergeordnete MDI-Element eines Formulars. (inherited from Form).
Protected method | AdjustFormScrollbars | Passt die Schiebeleisten im Container anhand der aktuellen Positionen der Steuerelemente und des aktuell ausgewählten Steuerelements an. (inherited from Form).
Protected method | ApplyAutoScaling | Obsolete. Ändert die Größe des Formulars entsprechend dem aktuellen Wert der AutoScaleBaseSize-Eigenschaft und der Größe der aktuellen Schriftart. (inherited from Form).
Protected method | CenterToParent | Zentriert die Position des Formulars innerhalb der Begrenzungen des übergeordneten Formulars. (inherited from Form).
Protected method | CenterToScreen | Zentriert das Formular für den aktuellen Bildschirm. (inherited from Form).
Protected method | CreateAccessibilityInstance | Erstellt ein neues Objekt für die Barrierefreiheit für das Steuerelement. (inherited from Control).
Protected method | CreateControlsInstance | (inherited from Form).
Protected method | CreateHandle | Erstellt das Handle für das Formular.Wenn eine abgeleitete Klasse diese Funktion überschreibt, muss sie die Basisimplementierung aufrufen. (inherited from Form).
Protected method | DefWndProc | (inherited from Form).
Protected method | DestroyHandle | Löscht das mit dem Steuerelement verknüpfte Handle. (inherited from Control).
Supported by the .NET Compact Framework. | Dispose | (Overloaded) Gibt die von Form verwendeten Ressourcen (mit Ausnahme des Speichers) frei.
Protected method | Finalize | Gibt nicht verwaltete Ressourcen frei und führt andere Bereinigungsvorgänge durch, bevor die Component durch die Garbage Collection wieder zugänglich gemacht wird. (inherited from Component).
Protected method | GetAccessibilityObjectById | Ruft das angegebene AccessibleObject ab. (inherited from Control).
Protected method | GetAutoSizeMode | Ruft einen Wert ab, der angibt, wie sich ein Steuerelement verhält, wenn seine AutoSize-Eigenschaft aktiviert wird. (inherited from Control).
Protected method | GetScaledBounds | (inherited from Form).
Protected method | GetScrollState | Bestimmt, ob das angegebene Flag festgelegt wurde. (inherited from ScrollableControl).
Protected method | GetService | Gibt ein Objekt zurück, das einen von der Component oder von deren Container bereitgestellten Dienst darstellt. (inherited from Component).
Protected method | GetStyle | Ruft den Wert für das angegebene Steuerelement-Formatbit für das Steuerelement ab. (inherited from Control).
Protected method | GetTopLevel | Bestimmt, ob es sich bei dem Steuerelement um ein Steuerelement der obersten Ebene handelt. (inherited from Control).
Protected method | InitLayout | Wird nach dem Hinzufügen des Steuerelements zu einem anderen Container aufgerufen. (inherited from Control).
Protected method | InvokeGotFocus | Löst das GotFocus-Ereignis für das angegebene Steuerelement aus. (inherited from Control).
Protected method | InvokeLostFocus | Löst das LostFocus-Ereignis für das angegebene Steuerelement aus. (inherited from Control).
Protected method | InvokeOnClick | Löst das Click-Ereignis für das angegebene Steuerelement aus. (inherited from Control).
Protected method | InvokePaint | Löst das Paint-Ereignis für das angegebene Steuerelement aus. (inherited from Control).
Protected method | InvokePaintBackground | Löst das PaintBackground-Ereignis für das angegebene Steuerelement aus. (inherited from Control).
Protected method | IsInputChar | Bestimmt, ob ein Zeichen ein vom Steuerelement erkanntes Eingabezeichen ist. (inherited from Control).
Protected method | IsInputKey | Bestimmt, ob es sich bei der angegebenen Taste um eine normale oder um eine besondere Taste handelt, für die eine Vorverarbeitung erforderlich ist. (inherited from Control).
Protected method | MemberwiseClone | Erstellt eine flache Kopie des aktuellen MarshalByRefObject-Objekts. (inherited from MarshalByRefObject).
Protected method | NotifyInvalidate | Löst das Invalidated-Ereignis aus, wobei ein angegebener Bereich des Steuerelements für ungültig erklärt wird. (inherited from Control).
Protected method | OnActivated | Löst das Activated-Ereignis aus. (inherited from Form).
Protected method | OnAutoSizeChanged | Löst das AutoSizeChanged-Ereignis aus. (inherited from Control).
Protected method | OnAutoValidateChanged | Löst das AutoValidateChanged-Ereignis aus. (inherited from ContainerControl).
Protected method | OnBackColorChanged | Löst das BackColorChanged-Ereignis aus. (inherited from Control).
Protected method | OnBackgroundImageChanged | Löst das BackgroundImageChanged-Ereignis aus. (inherited from Form).
Protected method | OnBackgroundImageLayoutChanged | Löst das BackgroundImageLayoutChanged-Ereignis aus. (inherited from Form).
Protected method | OnBindingContextChanged | Löst das BindingContextChanged-Ereignis aus. (inherited from Control).
Protected method | OnCausesValidationChanged | Löst das CausesValidationChanged-Ereignis aus. (inherited from Control).
Protected method | OnChangeUICues | Löst das ChangeUICues-Ereignis aus. (inherited from Control).
Protected method | OnClick | Löst das Click-Ereignis aus. (inherited from Control).
Protected method | OnClientSizeChanged | Löst das ClientSizeChanged-Ereignis aus. (inherited from Control).
Protected method | OnClosed | Löst das Closed-Ereignis aus. (inherited from Form).
Protected method | OnClosing | Löst das Closing-Ereignis aus. (inherited from Form).
Protected method | OnContextMenuChanged | Löst das ContextMenuChanged-Ereignis aus. (inherited from Control).
Protected method | OnContextMenuStripChanged | Löst das ContextMenuStripChanged-Ereignis aus. (inherited from Control).
Protected method | OnControlAdded | Löst das ControlAdded-Ereignis aus. (inherited from Control).
Protected method | OnControlRemoved | Löst das ControlRemoved-Ereignis aus. (inherited from Control).
Protected method | OnCreateControl | Löst das CreateControl-Ereignis aus. (inherited from Form).
Protected method | OnCursorChanged | Löst das CursorChanged-Ereignis aus. (inherited from Control).
Protected method | OnDeactivate | Löst das Deactivate-Ereignis aus. (inherited from Form).
Protected method | OnDockChanged | Löst das DockChanged-Ereignis aus. (inherited from Control).
Protected method | OnDoubleClick | Löst das DoubleClick-Ereignis aus. (inherited from Control).
Protected method | OnDragDrop | Löst das DragDrop-Ereignis aus. (inherited from Control).
Protected method | OnDragEnter | Löst das DragEnter-Ereignis aus. (inherited from Control).
Protected method | OnDragLeave | Löst das DragLeave-Ereignis aus. (inherited from Control).
Protected method | OnDragOver | Löst das DragOver-Ereignis aus. (inherited from Control).
Protected method | OnEnabledChanged | (inherited from Form).
Protected method | OnEnter | Löst das Enter-Ereignis aus. (inherited from Form).
Protected method | OnFontChanged | (inherited from Form).
Protected method | OnForeColorChanged | Löst das ForeColorChanged-Ereignis aus. (inherited from Control).
Protected method | OnFormClosed | Löst das FormClosed-Ereignis aus. (inherited from Form).
Protected method | OnFormClosing | Löst das FormClosing-Ereignis aus. (inherited from Form).
Protected method | OnGiveFeedback | Löst das GiveFeedback-Ereignis aus. (inherited from Control).
Protected method | OnGotFocus | Löst das GotFocus-Ereignis aus. (inherited from Control).
Protected method | OnHandleCreated | (inherited from Form).
Protected method | OnHandleDestroyed | (inherited from Form).
Protected method | OnHelpButtonClicked | Löst das HelpButtonClicked-Ereignis aus. (inherited from Form).
Protected method | OnHelpRequested | Löst das HelpRequested-Ereignis aus. (inherited from Control).
Protected method | OnImeModeChanged | Löst das ImeModeChanged-Ereignis aus. (inherited from Control).
Protected method | OnInputLanguageChanged | Löst das InputLanguageChanged-Ereignis aus. (inherited from Form).
Protected method | OnInputLanguageChanging | Löst das InputLanguageChanging-Ereignis aus. (inherited from Form).
Protected method | OnInvalidated | Löst das Invalidated-Ereignis aus. (inherited from Control).
Protected method | OnKeyDown | Löst das KeyDown-Ereignis aus. (inherited from Control).
Protected method | OnKeyPress | Löst das KeyPress-Ereignis aus. (inherited from Control).
Protected method | OnKeyUp | Löst das KeyUp-Ereignis aus. (inherited from Control).
Protected method | OnLayout | Löst das Layout-Ereignis aus. (inherited from Form).
Protected method | OnLeave | Löst das Leave-Ereignis aus. (inherited from Control).
Protected method | OnLoad | Löst das Load-Ereignis aus. (inherited from Form).
Protected method | OnLocationChanged | Löst das LocationChanged-Ereignis aus. (inherited from Control).
Protected method | OnLostFocus | Löst das LostFocus-Ereignis aus. (inherited from Control).
Protected method | OnMarginChanged | Löst das MarginChanged-Ereignis aus. (inherited from Control).
Protected method | OnMaximizedBoundsChanged | Löst das MaximizedBoundsChanged-Ereignis aus. (inherited from Form).
Protected method | OnMaximumSizeChanged | Löst das MaximumSizeChanged-Ereignis aus. (inherited from Form).
Protected method | OnMdiChildActivate | Löst das MdiChildActivate-Ereignis aus. (inherited from Form).
Protected method | OnMenuComplete | Löst das MenuComplete-Ereignis aus. (inherited from Form).
Protected method | OnMenuStart | Löst das MenuStart-Ereignis aus. (inherited from Form).
Protected method | OnMinimumSizeChanged | Löst das MinimumSizeChanged-Ereignis aus. (inherited from Form).
Protected method | OnMouseCaptureChanged | Löst das MouseCaptureChanged-Ereignis aus. (inherited from Control).
Protected method | OnMouseClick | Löst das MouseClick-Ereignis aus. (inherited from Control).
Protected method | OnMouseDoubleClick | Löst das MouseDoubleClick-Ereignis aus. (inherited from Control).
Protected method | OnMouseDown | Löst das MouseDown-Ereignis aus. (inherited from Control).
Protected method | OnMouseEnter | Löst das MouseEnter-Ereignis aus. (inherited from Control).
Protected method | OnMouseHover | Löst das MouseHover-Ereignis aus. (inherited from Control).
Protected method | OnMouseLeave | Löst das MouseLeave-Ereignis aus. (inherited from Control).
Protected method | OnMouseMove | Löst das MouseMove-Ereignis aus. (inherited from Control).
Protected method | OnMouseUp | Löst das MouseUp-Ereignis aus. (inherited from Control).
Protected method | OnMouseWheel | Löst das MouseWheel-Ereignis aus. (inherited from ScrollableControl).
Protected method | OnMove | Löst das Move-Ereignis aus. (inherited from Control).
Protected method | OnNotifyMessage | Benachrichtigt das Steuerelement über Windows-Meldungen. (inherited from Control).
Protected method | OnPaddingChanged | Löst das PaddingChanged-Ereignis aus. (inherited from ScrollableControl).
Protected method | OnPaint | (inherited from Form).
Protected method | OnPaintBackground | Zeichnet den Hintergrund des Steuerelements. (inherited from ScrollableControl).
Protected method | OnParentBackColorChanged | Löst das BackColorChanged-Ereignis aus, wenn sich der BackColor-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentBackgroundImageChanged | Löst das BackgroundImageChanged-Ereignis aus, wenn sich der BackgroundImage-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentBindingContextChanged | Löst das BindingContextChanged-Ereignis aus, wenn sich der BindingContext-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentChanged | (inherited from ContainerControl).
Protected method | OnParentCursorChanged | Löst das CursorChanged-Ereignis aus. (inherited from Control).
Protected method | OnParentEnabledChanged | Löst das EnabledChanged-Ereignis aus, wenn sich der Enabled-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentFontChanged | Löst das FontChanged-Ereignis aus, wenn sich der Font-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentForeColorChanged | Löst das ForeColorChanged-Ereignis aus, wenn sich der ForeColor-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentRightToLeftChanged | Löst das RightToLeftChanged-Ereignis aus, wenn sich der RightToLeft-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentVisibleChanged | Löst das VisibleChanged-Ereignis aus, wenn sich der Visible-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnPreviewKeyDown | Löst das PreviewKeyDown-Ereignis aus. (inherited from Control).
Protected method | OnPrint | Löst das Paint-Ereignis aus. (inherited from Control).
Protected method | OnQueryContinueDrag | Löst das QueryContinueDrag-Ereignis aus. (inherited from Control).
Protected method | OnRegionChanged | Löst das RegionChanged-Ereignis aus. (inherited from Control).
Protected method | OnResize | (inherited from Form).
Protected method | OnResizeBegin | Löst das ResizeBegin-Ereignis aus. (inherited from Form).
Protected method | OnResizeEnd | Löst das ResizeEnd-Ereignis aus. (inherited from Form).
Protected method | OnRightToLeftChanged | (inherited from ScrollableControl).
Protected method | OnRightToLeftLayoutChanged | Löst das RightToLeftLayoutChanged-Ereignis aus. (inherited from Form).
Protected method | OnScroll | Löst das Scroll-Ereignis aus. (inherited from ScrollableControl).
Protected method | OnShown | Löst das Shown-Ereignis aus. (inherited from Form).
Protected method | OnSizeChanged | Löst das SizeChanged-Ereignis aus. (inherited from Control).
Protected method | OnStyleChanged | (inherited from Form).
Protected method | OnSystemColorsChanged | Löst das SystemColorsChanged-Ereignis aus. (inherited from Control).
Protected method | OnTabIndexChanged | Löst das TabIndexChanged-Ereignis aus. (inherited from Control).
Protected method | OnTabStopChanged | Löst das TabStopChanged-Ereignis aus. (inherited from Control).
Protected method | OnTextChanged | (inherited from Form).
Protected method | OnValidated | Löst das Validated-Ereignis aus. (inherited from Control).
Protected method | OnValidating | Löst das Validating-Ereignis aus. (inherited from Control).
Protected method | OnVisibleChanged | Löst das VisibleChanged-Ereignis aus. (inherited from Form).
Protected method | ProcessCmdKey | Verarbeitet eine Befehlstaste. (inherited from Form).
Protected method | ProcessDialogChar | Verarbeitet ein Dialogfeldzeichen. (inherited from Form).
Protected method | ProcessDialogKey | Verarbeitet eine Tastatureingabe im Dialogfeld. (inherited from Form).
Protected method | ProcessKeyEventArgs | Verarbeitet eine Tastenmeldung und generiert die entsprechenden Steuerelementereignisse. (inherited from Control).
Protected method | ProcessKeyPreview | (inherited from Form).
Protected method | ProcessTabKey | (inherited from Form).
Protected method | RaiseDragEvent | Löst das entsprechende Ziehereignis aus. (inherited from Control).
Protected method | RaiseKeyEvent | Löst das entsprechende Tastenereignis aus. (inherited from Control).
Protected method | RaiseMouseEvent | Löst das entsprechende Mausereignis aus. (inherited from Control).
Protected method | RaisePaintEvent | Löst das entsprechende Paint-Ereignis aus. (inherited from Control).
Protected method | RecreateHandle | Erzwingt ein erneutes Erstellen des Handles für das Steuerelement. (inherited from Control).
 | ReflectMessage | Reflektiert die angegebene Meldung an das Steuerelement, das an das angegebene Handle gebunden ist. (inherited from Control).
Protected method | ResetMouseEventArgs | Setzt das Steuerelement zurück, um das MouseLeave-Ereignis zu behandeln. (inherited from Control).
Protected method | RtlTranslateAlignment | (Overloaded) Konvertiert das angegebene HorizontalAlignment in das entsprechende HorizontalAlignment für die Unterstützung der Schriftrichtung von rechts nach links. (inherited from Control).
Protected method | RtlTranslateHorizontal | Konvertiert das angegebene HorizontalAlignment in das entsprechende HorizontalAlignment für die Unterstützung der Schriftrichtung von rechts nach links. (inherited from Control).
Protected method | RtlTranslateLeftRight | Konvertiert das angegebene LeftRightAlignment in das entsprechende LeftRightAlignment für die Unterstützung der Schriftrichtung von rechts nach links. (inherited from Control).
Protected method | ScaleControl | Skaliert Speicherort, Größe, Textabstand und Rand eines Steuerelements. (inherited from Form).
Protected method | ScaleCore | Führt die Skalierung des Formulars aus. (inherited from Form).
Protected method | ScrollToControl | Berechnet den Bildlauf-Offset zum angegebenen untergeordneten Steuerelement. (inherited from ScrollableControl).
Protected method | Select | (Overloaded) Aktiviert dieses Formular und wählt optional das nächste oder vorherige Steuerelement aus. (inherited from Form).
Protected method | SetAutoSizeMode | Legt einen Wert fest, der angibt, wie sich ein Steuerelement verhält, wenn seine AutoSize-Eigenschaft aktiviert wird. (inherited from Control).
Protected method | SetBoundsCore | (inherited from Form).
Protected method | SetClientSizeCore | Legt die Clientgröße des Formulars fest.Hiermit werden die Begrenzungen des Formulars so angepasst, dass die Clientgröße der angeforderten Größe entspricht. (inherited from Form).
Protected method | SetDisplayRectLocation | Positioniert das Anzeigefenster anhand des angegebenen Werts. (inherited from ScrollableControl).
Protected method | SetScrollState | Legt das angegebene Flag für den Bildlaufzustand fest. (inherited from ScrollableControl).
Protected method | SetStyle | Legt ein angegebenes ControlStyles-Flag auf true oder false fest. (inherited from Control).
Protected method | SetTopLevel | Legt das Steuerelement als Steuerelement der obersten Ebene fest. (inherited from Control).
Protected method | SetVisibleCore | (inherited from Form).
Protected method | SizeFromClientSize | Bestimmt die Größe des gesamten Steuerelements anhand der Höhe und Breite seines Clientbereichs. (inherited from Control).
Protected method | UpdateDefaultButton | Aktualisiert, welche Schaltfläche die Standardschaltfläche ist. (inherited from Form).
Protected method | UpdateStyles | Erzwingt ein erneutes Anwenden der zugewiesenen Formate auf das Steuerelement. (inherited from Control).
Protected method | UpdateZOrder | Aktualisiert das Steuerelement in der z-Reihenfolge des übergeordneten Elements. (inherited from Control).
Protected method | WndProc | (inherited from Form).
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Internal protected (Protected Friend) method | AccessibilityNotifyClients | (Overloaded) Benachrichtigt die Clientanwendungen für die Barrierefreiheit über die angegebenen AccessibleEvents für das angegebene untergeordnete Steuerelement. (inherited from Control).
Internal protected (Protected Friend) method | ProcessKeyMessage | Verarbeitet eine Tastaturmeldung. (inherited from Control).
Internal protected (Protected Friend) method | ProcessMnemonic | Verarbeitet ein mnemonisches Zeichen. (inherited from Form).
Internal protected (Protected Friend) method | RtlTranslateContent | Konvertiert das angegebene ContentAlignment in das entsprechende ContentAlignment für die Unterstützung der Schriftrichtung von rechts nach links. (inherited from Control).
Internal protected (Protected Friend) method | UpdateBounds | (Overloaded) Aktualisiert die Begrenzungen des Steuerelements mit der aktuellen Größe und Position. (inherited from Control).
Top

Expand image Public Events

 | Name | Description
Public event | Activated | Tritt ein, wenn das Formular im Code oder vom Benutzer aktiviert wird. (inherited from Form).
Public event | AutoSizeChanged | Tritt ein, wenn sich die AutoSize-Eigenschaft ändert. (inherited from Form).
Public event | AutoValidateChanged | Tritt ein, wenn sich die AutoValidate-Eigenschaft ändert. (inherited from Form).
Public event | BackColorChanged | Tritt ein, wenn sich der Wert der BackColor-Eigenschaft ändert. (inherited from Control).
Public event | BackgroundImageChanged | Tritt ein, wenn sich der Wert der BackgroundImage-Eigenschaft ändert. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Tritt ein, wenn sich die BackgroundImageLayout-Eigenschaft ändert. (inherited from Control).
Public event | BindingContextChanged | Tritt ein, wenn sich der Wert der BindingContext-Eigenschaft ändert. (inherited from Control).
Public event | CausesValidationChanged | Tritt auf, wenn der Wert der CausesValidation-Eigenschaft geändert wird. (inherited from Control).
Public event | ChangeUICues | Tritt ein, wenn sich der Fokus-Cue oder der Tastatur-Cue der Benutzeroberfläche ändert. (inherited from Control).
Public event | Click | Tritt beim Klicken auf das Steuerelement ein. (inherited from Control).
Public event | ClientSizeChanged | Tritt ein, wenn sich der Wert der ClientSize-Eigenschaft ändert. (inherited from Control).
Public event | Closed | Tritt ein, wenn das Formular geschlossen ist. (inherited from Form).
Public event | Closing | Tritt beim Schließen des Formulars ein. (inherited from Form).
Public event | ContextMenuChanged | Tritt ein, wenn sich der Wert der ContextMenu-Eigenschaft ändert. (inherited from Control).
Public event | ContextMenuStripChanged | Tritt ein, wenn sich der Wert der ContextMenuStrip-Eigenschaft ändert. (inherited from Control).
Public event | ControlAdded | Tritt ein, wenn der ControlCollection ein neues Steuerelement hinzugefügt wird. (inherited from Control).
Public event | ControlRemoved | Tritt beim Entfernen des Steuerelements aus der ControlCollection ein. (inherited from Control).
Public event | CursorChanged | Tritt ein, wenn sich der Wert der Cursor-Eigenschaft ändert. (inherited from Control).
Public event | Deactivate | Tritt ein, wenn das Formular den Fokus verliert und nicht mehr das aktive Formular ist. (inherited from Form).
Public event | Disposed | Tritt ein, wenn die Komponente durch einen Aufruf der Dispose-Methode freigegeben wird. (inherited from Component).
Public event | DockChanged | Tritt ein, wenn sich der Wert der Dock-Eigenschaft ändert. (inherited from Control).
Public event | DoubleClick | Tritt beim Doppelklicken auf das Steuerelement ein. (inherited from Control).
Public event | DragDrop | Tritt ein, wenn eine Drag & Drop-Operation beendet wurde. (inherited from Control).
Public event | DragEnter | Tritt ein, wenn ein Objekt in den Bereich des Steuerelements gezogen wird. (inherited from Control).
Public event | DragLeave | Tritt ein, wenn ein Objekt aus dem Bereich des Steuerelements gezogen wird. (inherited from Control).
Public event | DragOver | Tritt ein, wenn ein Objekt über die Begrenzungen des Steuerelements gezogen wird. (inherited from Control).
Public event | EnabledChanged | Tritt ein, wenn sich der Enabled-Eigenschaftswert geändert hat. (inherited from Control).
Public event | Enter | Tritt beim Eintreten in den Bereich des Steuerelements ein. (inherited from Control).
Public event | FontChanged | Tritt ein, wenn sich der Font-Eigenschaftswert ändert. (inherited from Control).
Public event | ForeColorChanged | Tritt ein, wenn sich der ForeColor-Eigenschaftswert ändert. (inherited from Control).
Public event | FormClosed | Tritt ein, nachdem das Formular geschlossen wurde. (inherited from Form).
Public event | FormClosing | Tritt ein, bevor das Formular geschlossen wird. (inherited from Form).
Public event | GiveFeedback | Tritt während eines Ziehvorgangs ein. (inherited from Control).
Public event | GotFocus | Tritt ein, wenn das Steuerelement den Fokus erhält. (inherited from Control).
Public event | HandleCreated | Tritt ein, wenn ein Handle für das Steuerelement erstellt wird. (inherited from Control).
Public event | HandleDestroyed | Tritt ein, wenn das Handle des Steuerelements gerade gelöscht wird. (inherited from Control).
Public event | HelpButtonClicked | Tritt beim Klicken auf die Schaltfläche Hilfe ein. (inherited from Form).
Public event | HelpRequested | Tritt ein, wenn der Benutzer die Hilfe für ein Steuerelement anfordert. (inherited from Control).
Public event | ImeModeChanged | Tritt ein, wenn die ImeMode-Eigenschaft geändert wurde. (inherited from Control).
Public event | InputLanguageChanged | Tritt ein, nachdem die Eingabesprache des Formulars geändert wurde. (inherited from Form).
Public event | InputLanguageChanging | Tritt ein, wenn der Benutzer versucht, die Eingabesprache für das Formular zu ändern. (inherited from Form).
Public event | Invalidated | Tritt ein, wenn die Anzeige eines Steuerelements neu gezeichnet werden muss. (inherited from Control).
Public event | KeyDown | Tritt ein, wenn eine Taste gedrückt wird, während das Steuerelement den Fokus hat. (inherited from Control).
Public event | KeyPress | Tritt ein, wenn eine Taste gedrückt wird, während das Steuerelement den Fokus hat. (inherited from Control).
Public event | KeyUp | Tritt ein, wenn eine Taste losgelassen wird, während das Steuerelement den Fokus hat. (inherited from Control).
Public event | Layout | Tritt ein, wenn ein Steuerelement seine untergeordneten Steuerelemente neu positionieren muss. (inherited from Control).
Public event | Leave | Tritt ein, wenn der Eingabefokus das Steuerelement verlässt. (inherited from Control).
Public event | Load | Tritt ein, bevor ein Formular erstmals angezeigt wird. (inherited from Form).
Public event | LocationChanged | Tritt ein, wenn sich der Location-Eigenschaftswert geändert hat. (inherited from Control).
Public event | LostFocus | Tritt ein, wenn das Steuerelement den Fokus verliert. (inherited from Control).
Public event | MarginChanged | Tritt ein, wenn sich die Margin-Eigenschaft ändert. (inherited from Form).
Public event | MaximizedBoundsChanged | Tritt ein, wenn sich der Wert der MaximizedBounds-Eigenschaft geändert hat. (inherited from Form).
Public event | MaximumSizeChanged | Tritt ein, wenn sich der Wert der MaximumSize-Eigenschaft geändert hat. (inherited from Form).
Public event | MdiChildActivate | Tritt ein, wenn ein untergeordnetes MDI (Multiple Document Interface)-Formular in einer MDI-Anwendung aktiviert oder geschlossen wird. (inherited from Form).
Public event | MenuComplete | Tritt ein, wenn das Menü eines Formulars den Fokus verliert. (inherited from Form).
Public event | MenuStart | Tritt ein, wenn das Menü eines Formulars den Fokus erhält. (inherited from Form).
Public event | MinimumSizeChanged | Tritt ein, wenn sich der Wert der MinimumSize-Eigenschaft geändert hat. (inherited from Form).
Public event | MouseCaptureChanged | Tritt ein, wenn das Steuerelement beginnt oder aufhört, Mauseingaben aufzufangen. (inherited from Control).
Public event | MouseClick | Tritt ein, wenn mit der Maus auf das Steuerelement geklickt wird. (inherited from Control).
Public event | MouseDoubleClick | Tritt ein, wenn mit der Maus ein Doppelklick auf das Steuerelement ausgeführt wird. (inherited from Control).
Public event | MouseDown | Tritt ein, wenn sich der Mauszeiger über dem Steuerelement befindet und eine Maustaste gedrückt wird. (inherited from Control).
Public event | MouseEnter | Tritt ein, wenn der Mauszeiger in den Bereich des Steuerelements eintritt. (inherited from Control).
Public event | MouseHover | Tritt ein, wenn der Mauszeiger auf dem Steuerelement verbleibt. (inherited from Control).
Public event | MouseLeave | Tritt ein, wenn der Mauszeiger den Bereich des Steuerelements verlässt. (inherited from Control).
Public event | MouseMove | Tritt ein, wenn der Mauszeiger über dem Steuerelement bewegt wird. (inherited from Control).
Public event | MouseUp | Tritt ein, wenn sich der Mauszeiger über dem Steuerelement befindet und eine Maustaste losgelassen wird. (inherited from Control).
Public event | MouseWheel | Tritt ein, wenn das Mausrad bewegt wird, während das Steuerelement den Fokus besitzt. (inherited from Control).
Public event | Move | Tritt beim Verschieben des Steuerelements ein. (inherited from Control).
Public event | PaddingChanged | Tritt ein, wenn der Abstand des Steuerelements geändert wird. (inherited from Control).
Public event | Paint | Tritt ein, wenn das Steuerelement neu gezeichnet wird. (inherited from Control).
Public event | ParentChanged | Tritt ein, wenn sich der Parent-Eigenschaftswert ändert. (inherited from Control).
Public event | PreviewKeyDown | Tritt vor dem KeyDown-Ereignis ein, wenn eine Taste gedrückt wird, während dieses Steuerelement den Fokus besitzt. (inherited from Control).
Public event | QueryAccessibilityHelp | Tritt ein, wenn AccessibleObject Hilfe für barrierefreie Anwendungen bereitstellt. (inherited from Control).
Public event | QueryContinueDrag | Tritt während eines Drag & Drop-Vorgangs ein. Dadurch kann die Quelle des Ziehvorgangs bestimmen, ob der Drag & Drop-Vorgang abgebrochen werden soll. (inherited from Control).
Public event | RegionChanged | Tritt ein, wenn sich der Wert der Region-Eigenschaft ändert. (inherited from Control).
Public event | Resize | Tritt beim Ändern der Größe des Steuerelements ein. (inherited from Control).
Public event | ResizeBegin | Tritt ein, wenn ein Formular in den Größenänderungsmodus wechselt. (inherited from Form).
Public event | ResizeEnd | Tritt ein, wenn ein Formular den Größenänderungsmodus verlässt. (inherited from Form).
Public event | RightToLeftChanged | Tritt ein, wenn sich der RightToLeft-Eigenschaftswert ändert. (inherited from Control).
Public event | RightToLeftLayoutChanged | Tritt ein, nachdem sich der Wert der RightToLeftLayout-Eigenschaft geändert hat. (inherited from Form).
Public event | Scroll | Tritt ein, wenn vom Benutzer oder von Code ein Bildlauf durch den Clientbereich durchgeführt wird. (inherited from ScrollableControl).
Public event | Shown | Tritt immer dann ein, wenn das Formular erstmalig angezeigt wird. (inherited from Form).
Public event | SizeChanged | Tritt ein, wenn sich der Size-Eigenschaftswert ändert. (inherited from Control).
Public event | StyleChanged | Tritt ein, wenn sich das Format des Steuerelements ändert. (inherited from Control).
Public event | SystemColorsChanged | Tritt ein, wenn sich die Systemfarben ändern. (inherited from Control).
Public event | TabIndexChanged | Tritt ein, wenn sich der Wert der TabIndex-Eigenschaft ändert. (inherited from Form).
Public event | TabStopChanged | Tritt ein, wenn sich die TabStop-Eigenschaft ändert. (inherited from Form).
Public event | TextChanged | Tritt ein, wenn sich der Text-Eigenschaftswert ändert. (inherited from Control).
Public event | Validated | Tritt ein, wenn das Steuerelement die Überprüfung abgeschlossen hat. (inherited from Control).
Public event | Validating | Tritt ein, während das Steuerelement eine Überprüfung durchführt. (inherited from Control).
Public event | VisibleChanged | Tritt ein, wenn sich der Visible-Eigenschaftswert ändert. (inherited from Control).
Top

Expand image See Also

Reference

frmPrinterSettings_sik Class


frmPrinterSettings_sik Constructor

[image] [image] [image]

AllgFnkt_Plugin Reference
frmPrinterSettings_sik Constructor
See Also

Initializes a new instance of the frmPrinterSettings_sik class.
Assembly: AllgFnkt_Plugin (in AllgFnkt_Plugin.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByRef a_wdapp As Object _
)
C#
public frmPrinterSettings_sik(
   ref object a_wdapp
)
C++
public:
frmPrinterSettings_sik(
   object^& a_wdapp
)
JScript
public function frmPrinterSettings_sik(
    a_wdapp : object
);

Parameters

a_wdapp

Type: object

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPrinterSettings_sik Class
frmPrinterSettings_sik Members


frmPrinterSettings_sik Properties

[image] [image] [image]

AllgFnkt_Plugin Reference
frmPrinterSettings_sik Properties
frmPrinterSettings_sik Class See Also

Expand image Public Properties

 | Name | Description
Public property | AcceptButton | Ruft die Schaltfläche im Formular ab, die beim Drücken der EINGABETASTE betätigt wird, oder legt diese fest. (inherited from Form).
Public property | AccessibilityObject | Ruft das dem Steuerelement zugewiesene AccessibleObject ab. (inherited from Control).
Public property | AccessibleDefaultActionDescription | Ruft die Beschreibung der Standardaktion des Steuerelements für die Verwendung durch Clientanwendungen für die Barrierefreiheit ab oder legt diese fest. (inherited from Control).
Public property | AccessibleDescription | Ruft die Beschreibung des von Clientanwendungen für die Barrierefreiheit verwendeten Steuerelements ab oder legt diese fest. (inherited from Control).
Public property | AccessibleName | Ruft den Namen des von Clientanwendungen für die Barrierefreiheit verwendeten Steuerelements ab oder legt diesen fest. (inherited from Control).
Public property | AccessibleRole | Ruft die barrierefreie Rolle des Steuerelements ab oder legt diese fest. (inherited from Control).
Public property | ActiveControl | Ruft das aktive Steuerelement im Containersteuerelement ab oder legt dieses fest. (inherited from ContainerControl).
 | ActiveForm | Ruft das momentan aktive Formular für diese Anwendung ab. (inherited from Form).
Public property | ActiveMdiChild | Ruft das momentan aktive untergeordnete MDI (Multiple Document Interface)-Fenster ab. (inherited from Form).
Public property | AllowDrop | Ruft einen Wert ab, der angibt, ob das Steuerelement Daten annehmen kann, die vom Benutzer darauf gezogen wurden, oder legt diesen fest. (inherited from Control).
Public property | AllowTransparency | Ruft einen Wert ab, der angibt, ob die Durchlässigkeit des Formulars angepasst werden kann, oder legt diesen Wert fest. (inherited from Form).
Public property | Anchor | Ruft die Ränder des Containers ab, an die ein Steuerelement gebunden ist, oder legt diese fest und bestimmt, wie die Größe des Steuerelements mit dessen übergeordnetem Element geändert wird. (inherited from Control).
Public property | AutoScale | Obsolete. Ruft einen Wert ab, der angibt, ob die Größe des Formulars der Höhe der im Formular verwendeten Schriftart angepasst wird und die Steuerelemente des Formulars skaliert werden, oder legt diesen fest. (inherited from Form).
Public property | AutoScaleBaseSize | Ruft die Grundgröße ab, die für die automatische Skalierung des Formulars verwendet wird, oder legt diese fest. (inherited from Form).
Public property | AutoScaleDimensions | Ruft die Dimensionen ab, für die das Steuerelement entworfen wurde, oder ruft diese ab. (inherited from ContainerControl).
Public property | AutoScaleMode | Ruft den automatischen Skalierungsmodus des Steuerelements ab oder legt diesen fest. (inherited from ContainerControl).
Public property | AutoScroll | Ruft einen Wert ab, der angibt, ob das Formular den automatischen Bildlauf ermöglicht, oder legt diesen fest. (inherited from Form).
Public property | AutoScrollMargin | Ruft die Größe des AutoBildlaufrandes ab oder legt diese fest. (inherited from ScrollableControl).
Public property | AutoScrollMinSize | Ruft die minimale Größe des AutoBildlaufs ab oder legt diese fest. (inherited from ScrollableControl).
Public property | AutoScrollOffset | Ruft in Control) ab oder legt anhand dessen fest, in welcher Richtung der Bildlauf dieses Steuerelements durchgeführt wird. (inherited from Control).
Public property | AutoScrollPosition | Ruft die Position des AutoBildlaufs ab oder legt diese fest. (inherited from ScrollableControl).
Public property | AutoSize | Ändern Sie die Größe des Formulars entsprechend der Einstellung von AutoSizeMode. (inherited from Form).
Public property | AutoSizeMode | Ruft den Modus ab, in dem das Formular seine Größe automatisch selbst ändert, oder legt diesen Modus fest. (inherited from Form).
Public property | AutoValidate | (inherited from Form).
Public property | BackColor | (inherited from Form).
Public property | BackgroundImage | Ruft das im Steuerelement angezeigte Hintergrundbild ab oder legt dieses fest. (inherited from Control).
Public property | BackgroundImageLayout | Ruft das Layout für das Hintergrundbild wie in der ImageLayout-Enumeration definiert ab oder legt dieses fest. (inherited from Control).
Public property | BindingContext | (inherited from ContainerControl).
Public property | Bottom | Ruft den Abstand zwischen dem unteren Rand des Steuerelements und dem oberen Rand des Clientbereichs des zugehörigen Containers in Pixel ab. (inherited from Control).
Public property | Bounds | Ruft die Größe und die Position des Steuerelements, einschließlich seiner Nicht-Clientelemente, in Pixel relativ zum übergeordneten Steuerelement ab oder legt diese fest. (inherited from Control).
Public property | CanFocus | Ruft einen Wert ab, der angibt, ob das Steuerelement den Fokus erhalten kann. (inherited from Control).
Public property | CanSelect | Ruft einen Wert ab, der angibt, ob das Steuerelement ausgewählt werden kann. (inherited from Control).
Public property | CancelButton | Ruft das Button-Steuerelement ab, das beim Drücken von ESC betätigt wird, oder legt dieses fest. (inherited from Form).
Public property | Capture | Ruft einen Wert ab, der angibt, ob die Maus vom Steuerelement erfasst wurde, oder legt diesen fest. (inherited from Control).
Public property | CausesValidation | Ruft einen Wert ab, der angibt, ob das Steuerelement bei Erhalt des Fokus eine Validierung für alle eine Validierung erfordernden Steuerelemente veranlasst, oder legt diesen fest. (inherited from Control).
 | CheckForIllegalCrossThreadCalls | Ruft einen Wert ab, mit dem angegeben wird, ob Aufrufe an den falschen Thread, der auf die Handle-Eigenschaft eines Steuerelements zugreift, abgefangen werden sollen, wenn eine Anwendung gedebuggt wird, oder legt diesen Wert fest. (inherited from Control).
Public property | ClientRectangle | Ruft das Rechteck ab, das den Clientbereich des Steuerelements darstellt. (inherited from Control).
Public property | ClientSize | Ruft die Größe des Clientbereichs des Formulars ab oder legt diese fest. (inherited from Form).
Public property | CompanyName | Ruft den Namen des Unternehmens oder des Entwicklers der Anwendung ab, die das Steuerelement enthält. (inherited from Control).
Public property | Container | Ruft den IContainer ab, der die Component enthält. (inherited from Component).
Public property | ContainsFocus | Ruft einen Wert ab, der angibt, ob das Steuerelement oder eines der untergeordneten Steuerelemente den Eingabefokus besitzt. (inherited from Control).
Public property | ContextMenu | Ruft das dem Steuerelement zugeordnete Kontextmenü ab oder legt dieses fest. (inherited from Control).
Public property | ContextMenuStrip | Ruft die diesem Steuerelement zugeordnete ContextMenuStrip-Klasse ab oder legt diese fest. (inherited from Control).
Public property | ControlBox | Ruft einen Wert ab, der angibt, ob auf der Titelleiste des Formulars ein Systemmenüfeld angezeigt wird, oder legt diesen fest. (inherited from Form).
Public property | Controls | Ruft die im Steuerelement enthaltene Auflistung von Steuerelementen ab. (inherited from Control).
Public property | Created | Ruft einen Wert ab, der angibt, ob das Steuerelement erstellt wurde. (inherited from Control).
Public property | CurrentAutoScaleDimensions | Ruft die aktuellen Laufzeitdimensionen des Bildschirms ab. (inherited from ContainerControl).
Public property | Cursor | Ruft den Cursor ab, der angezeigt wird, wenn sich der Mauszeiger über dem Steuerelement befindet, oder legt diesen fest. (inherited from Control).
Public property | DataBindings | Ruft die Datenbindungen für das Steuerelement ab. (inherited from Control).
 | DefaultBackColor | Ruft die Standardhintergrundfarbe des Steuerelements ab. (inherited from Control).
 | DefaultFont | Ruft die Standardschriftart des Steuerelements ab. (inherited from Control).
 | DefaultForeColor | Ruft die Standardvordergrundfarbe des Steuerelements ab. (inherited from Control).
Public property | DesktopBounds | Ruft Größe und Position des Formulars auf dem Windows-Desktop ab oder legt diese fest. (inherited from Form).
Public property | DesktopLocation | Ruft die Position des Formulars auf dem Windows-Desktop ab oder legt diese fest. (inherited from Form).
Public property | DialogResult | Ruft das Dialogergebnis für das Formular ab oder legt dieses fest. (inherited from Form).
Public property | DisplayRectangle | Ruft das Rechteck ab, das den virtuellen Anzeigebereich des Steuerelements darstellt. (inherited from ScrollableControl).
Public property | Disposing | Ruft einen Wert ab, der angibt, ob die Control-Basisklasse gerade freigegeben wird. (inherited from Control).
Public property | Dock | Ruft ab oder legt fest, welche Steuerelementrahmen am übergeordneten Steuerelement angedockt sind, und bestimmt, wie die Größe eines Steuerelements mit dem übergeordneten Steuerelement geändert wird. (inherited from Control).
Public property | DockPadding | Ruft die Einstellungen für den Andockleerraum für alle Ränder des Steuerelements ab. (inherited from ScrollableControl).
Public property | Enabled | Ruft einen Wert ab, der angibt, ob das Steuerelement auf Benutzerinteraktionen reagieren kann, oder legt diesen fest. (inherited from Control).
Public property | Focused | Ruft einen Wert ab, der angibt, ob das Steuerelement den Eingabefokus besitzt. (inherited from Control).
Public property | Font | Ruft die Schriftart für die Anzeige von Text im Steuerelement ab oder legt diese fest. (inherited from Control).
Public property | ForeColor | Ruft die Vordergrundfarbe des Steuerelements ab oder legt diese fest. (inherited from Control).
Public property | FormBorderStyle | Ruft die Rahmenart des Formulars ab oder legt diese fest. (inherited from Form).
Public property | Handle | Ruft das Fensterhandle ab, an das das Steuerelement gebunden ist. (inherited from Control).
Public property | HasChildren | Ruft einen Wert ab, der angibt, ob das Steuerelement ein oder mehrere untergeordnete Steuerelemente enthält. (inherited from Control).
Public property | Height | Ruft die Höhe des Steuerelements ab oder legt diese fest. (inherited from Control).
Public property | HelpButton | Ruft einen Wert ab, der angibt, ob auf der Titelleiste des Formulars die Hilfeschaltfläche angezeigt werden soll, oder legt diesen fest. (inherited from Form).
Public property | HorizontalScroll | Ruft die der horizontalen Schiebeleiste zugeordneten Merkmale ab. (inherited from ScrollableControl).
Public property | Icon | Ruft das Symbol für das Formular ab oder legt dieses fest. (inherited from Form).
Public property | ImeMode | Ruft den IME-Modus (Eingabemethoden-Editor) des Steuerelements ab oder legt diesen fest. (inherited from Control).
Public property | InvokeRequired | Ruft einen Wert ab, der angibt ob der Aufrufer beim Aufruf von Methoden des Steuerelements eine Aufrufmethode aufrufen muss, da sich der Aufrufer in einem anderen Thread als dem befindet, in dem das Steuerelement erstellt wurde. (inherited from Control).
Public property | IsAccessible | Ruft einen Wert ab, der angibt, ob das Steuerelement für barrierefreie Anwendungen sichtbar ist, oder legt diesen fest. (inherited from Control).
Public property | IsDisposed | Ruft einen Wert ab, der angibt, ob das Steuerelement freigegeben wurde. (inherited from Control).
Public property | IsHandleCreated | Ruft einen Wert ab, der angibt, ob dem Steuerelement ein Handle zugeordnet ist. (inherited from Control).
Public property | IsMdiChild | Ruft einen Wert ab, der angibt, ob das Formular ein untergeordnetes MDI (Multiple Document Interface)-Formular ist. (inherited from Form).
Public property | IsMdiContainer | Ruft einen Wert ab, der angibt, ob das Formular ein Container für untergeordnete MDI (Multiple Document Interface)-Formulare ist, oder legt diesen fest. (inherited from Form).
Public property | IsMirrored | Ruft einen Wert ab, der angibt, ob das Steuerelement gespiegelt wird. (inherited from Control).
Public property | IsRestrictedWindow | Ruft einen Wert ab, der angibt, ob für das Formular alle Fenster und Benutzereingabeereignisse uneingeschränkt verwendet werden können. (inherited from Form).
Public property | KeyPreview | Ruft einen Wert ab, der angibt, ob das Formular Tastaturereignisse empfängt, bevor das Ereignis an das Steuerelement übergeben wird, das den Fokus besitzt, oder legt diesen fest. (inherited from Form).
Public property | LayoutEngine | Ruft eine zwischengespeicherte Instanz des Layoutmoduls des Steuerelements ab. (inherited from Control).
Public property | Left | Ruft den Abstand zwischen dem linken Rand des Steuerelements und dem linken Rand des Clientbereichs des zugehörigen Containers in Pixel ab oder legt diesen fest. (inherited from Control).
Public property | Location | Ruft den Point ab, der die linke obere Ecke des Form in Bildschirmkoordinaten darstellt, oder legt diesen fest. (inherited from Form).
Public property | MainMenuStrip | Ruft den primären Menücontainer für das Formular ab oder legt diesen fest. (inherited from Form).
Public property | Margin | Ruft den Zwischenraum zwischen Steuerelementen ab oder legt diesen fest. (inherited from Form).
Public property | MaximizeBox | Ruft einen Wert ab, der angibt, ob auf der Titelleiste des Formulars die Schaltfläche Maximieren angezeigt wird, oder legt diesen fest. (inherited from Form).
Public property | MaximumSize | Ruft die maximale Größe für die Vergrößerung des Formulars ab. (inherited from Form).
Public property | MdiChildren | Ruft ein Array von Formularen ab, das die untergeordneten MDI (Multiple Document Interface)-Formulare darstellt, deren übergeordnetes Formular dieses Formular ist. (inherited from Form).
Public property | MdiParent | Ruft das aktuelle übergeordnete MDI (Multiple Document Interface)-Formular für dieses Formular ab oder legt dieses fest. (inherited from Form).
Public property | Menu | Ruft das MainMenu ab, das im Formular angezeigt wird, oder legt dieses fest. (inherited from Form).
Public property | MergedMenu | Ruft das zusammengeführte Menü für das Formular ab. (inherited from Form).
Public property | MinimizeBox | Ruft einen Wert ab, der angibt, ob auf der Titelleiste des Formulars die Schaltfläche Minimieren angezeigt wird, oder legt diesen fest. (inherited from Form).
Public property | MinimumSize | Ruft die Mindestgröße des Formulars ab oder legt diese fest. (inherited from Form).
Public property | Modal | Ruft einen Wert ab, der angibt, ob dieses Formular modal angezeigt wird. (inherited from Form).
 | ModifierKeys | Ruft einen Wert ab, der angibt, welche der Modifizierertasten (UMSCHALT, STRG und/oder ALT) gerade gedrückt wird. (inherited from Control).
 | MouseButtons | Ruft einen Wert ab, der angibt, welche Maustaste gerade gedrückt wird. (inherited from Control).
 | MousePosition | Ruft die Position des Mauszeigers in Bildschirmkoordinaten ab. (inherited from Control).
Public property | Name | Ruft den Namen des Steuerelements ab oder legt diesen fest. (inherited from Control).
Public property | Opacity | Ruft die Durchlässigkeit des Formulars ab oder legt diese fest. (inherited from Form).
Public property | OwnedForms | Ruft ein Array von Form-Objekten ab, die alle Formulare darstellen, die dieses Formular besitzt. (inherited from Form).
Public property | Owner | Ruft das Formular ab, das Besitzer dieses Formulars ist, oder legt dieses fest. (inherited from Form).
Public property | Padding | Ruft den Abstand im Steuerelement ab oder legt diesen fest. (inherited from Control).
Public property | Parent | Ruft den übergeordneten Container des Steuerelements ab oder legt diesen fest. (inherited from Control).
Public property | ParentForm | Ruft das Formular ab, dem das Containersteuerelement zugewiesen ist. (inherited from ContainerControl).
Public property | PreferredSize | Ruft die Größe eines rechteckigen Bereichs ab, in den das Steuerelement eingepasst werden kann. (inherited from Control).
Public property | ProductName | Ruft den Produktnamen der Assembly ab, die das Steuerelement enthält. (inherited from Control).
Public property | ProductVersion | Ruft die Version der Assembly ab, die das Steuerelement enthält. (inherited from Control).
Public property | RecreatingHandle | Ruft einen Wert ab, der angibt, ob das Steuerelement gerade das zugehörige Handle neu erstellt. (inherited from Control).
Public property | Region | Ruft den dem Steuerelement zugeordneten Fensterbereich ab oder legt diesen fest. (inherited from Control).
Public property | RestoreBounds | Ruft die Position und die Größe des Formulars im normalen Fensterzustand ab. (inherited from Form).
Public property | Right | Ruft den Abstand zwischen dem rechten Rand des Steuerelements und dem linken Rand des Clientbereichs des zugehörigen Containers in Pixel ab. (inherited from Control).
Public property | RightToLeft | Ruft einen Wert ab, der angibt, ob Elemente des Steuerelements für die Unterstützung von Gebietsschemas ausgerichtet sind, die von rechts nach links geschriebene Schriftarten verwenden, oder legt diesen fest. (inherited from Control).
Public property | RightToLeftLayout | Ruft einen Wert ab, der angibt, ob die Anordnung der Spiegelung von rechts nach links aktiviert ist, oder legt diesen Wert fest. (inherited from Form).
Public property | ShowIcon | Ruft einen Wert ab, der angibt, ob ein Symbol auf der Titelleiste des Formulars angezeigt wird, oder legt diesen Wert fest. (inherited from Form).
Public property | ShowInTaskbar | Ruft einen Wert ab, der angibt, ob das Formular auf der Windows-Taskleiste angezeigt wird, oder legt diesen fest. (inherited from Form).
Public property | Site | Ruft die Site des Steuerelements ab oder legt diese fest. (inherited from Control).
Public property | Size | Ruft die Größe des Formulars ab oder legt diese fest. (inherited from Form).
Public property | SizeGripStyle | Ruft die Art des Größenziehpunkts in der linken unteren Ecke des Formulars ab oder legt diesen fest. (inherited from Form).
Public property | StartPosition | Ruft die Anfangsposition des Formulars zur Laufzeit ab oder legt diese fest. (inherited from Form).
Public property | TabIndex | Ruft die Aktivierreihenfolge des Steuerelements in dessen Container ab oder legt diese fest. (inherited from Form).
Public property | TabStop | Ruft einen Wert ab, der angibt, ob Benutzer den Fokus mit der TAB-TASTE auf dieses Steuerelement setzen können, oder legt diesen fest. (inherited from Form).
Public property | Tag | Ruft das Objekt ab, das Daten über das Steuerelement enthält, oder legt dieses fest. (inherited from Control).
Public property | Text | (inherited from Form).
Public property | Top | Ruft den Abstand zwischen dem oberen Rand des Steuerelements und dem oberen Rand des Clientbereichs des zugehörigen Containers in Pixel ab oder legt diesen fest. (inherited from Control).
Public property | TopLevel | Ruft einen Wert ab, der angibt, ob das Formular als Fenster der obersten Ebene angezeigt wird, oder legt diesen fest. (inherited from Form).
Public property | TopLevelControl | Ruft das übergeordnete Steuerelement ab, dem kein anderes Windows Forms-Steuerelement übergeordnet ist.Dies ist i. d. R. das äußerste Form, in dem das Steuerelement enthalten ist. (inherited from Control).
Public property | TopMost | Ruft einen Wert ab, der angibt, ob das Formular als oberstes Formular angezeigt werden soll, oder legt diesen fest. (inherited from Form).
Public property | TransparencyKey | Ruft die Farbe ab, in der transparente Bereiche des Formulars darstellt werden, oder legt diese fest. (inherited from Form).
Public property | UseWaitCursor | Ruft einen Wert ab, der angibt, ob der Wartecursor für das aktuelle Steuerelement und alle untergeordneten Steuerelemente verwendet werden soll. (inherited from Control).
Public property | VerticalScroll | Ruft die der vertikalen Schiebeleiste zugeordneten Merkmale ab. (inherited from ScrollableControl).
Public property | Visible | Ruft einen Wert ab, mit dem angegeben wird, ob das Steuerelement und alle untergeordneten Steuerelemente angezeigt werden, oder legt diesen Wert fest. (inherited from Control).
Public property | Width | Ruft die Breite des Steuerelements ab oder legt diese fest. (inherited from Control).
Public property | WindowState | Ruft den Fensterzustand des Formulars ab oder legt diesen fest. (inherited from Form).
Public property | WindowTarget | Diese Eigenschaft ist für diese Klasse nicht relevant. (inherited from Control).
Top

Expand image See Also

Reference

frmPrinterSettings_sik Class


frmPrinterSettings_sik Methods

[image] [image] [image]

AllgFnkt_Plugin Reference
frmPrinterSettings_sik Methods
frmPrinterSettings_sik Class See Also

Expand image Public Methods

 | Name | Description
Public method | Activate | Aktiviert das Formular und übergibt diesem den Fokus. (inherited from Form).
Public method | AddOwnedForm | Fügt diesem Formular als Besitzer ein Formular hinzu. (inherited from Form).
Public method | BeginInvoke | (Overloaded) Führt den angegebenen Delegaten asynchron für den Thread aus, in dem das dem Steuerelement zugrunde liegende Handle erstellt wurde. (inherited from Control).
Public method | BringToFront | Zeigt dieses Steuerelement am Anfang der z-Reihenfolge an. (inherited from Control).
Public method | Close | Schließt das Formular. (inherited from Form).
Public method | Contains | Ruft einen Wert ab, der angibt, ob das angegebene Steuerelement dem Steuerelement untergeordnet ist. (inherited from Control).
Public method | CreateControl | Erzwingt das Erstellen des Steuerelements, einschließlich des Handles und aller untergeordneten Steuerelemente. (inherited from Control).
Public method | CreateGraphics | Erstellt die Graphics für das Steuerelement. (inherited from Control).
Public method | CreateObjRef | Erstellt ein Objekt mit allen relevanten Informationen, die zum Generieren eines Proxys für die Kommunikation mit einem Remoteobjekt erforderlich sind. (inherited from MarshalByRefObject).
Supported by the .NET Compact Framework. | DefaultPrinterName |
Public method | DoDragDrop | Beginnt einen Drag & Drop-Vorgang. (inherited from Control).
Public method | DrawToBitmap | Unterstützt das Rendering für die angegebene Bitmap. (inherited from Control).
Public method | EndInvoke | Ruft den Rückgabewert des asynchronen Vorgangs ab, der durch das übergebene IAsyncResult dargestellt wird. (inherited from Control).
Public method | Equals | (Overloaded) Bestimmt, ob das angegebene Object und das aktuelle Object gleich sind. (inherited from Object).
Public method | FindForm | Ruft das Formular ab, in dem sich das Steuerelement befindet. (inherited from Control).
Public method | Focus | Setzt den Eingabefokus auf das Steuerelement. (inherited from Control).
 | FromChildHandle | Ruft das Steuerelement ab, das das angegebene Handle enthält. (inherited from Control).
 | FromHandle | Gibt das Steuerelement zurück, das gerade dem angegebenen Handle zugeordnet ist. (inherited from Control).
 | GetAutoScaleSize | Obsolete. Ruft die Größe des Formulars bei automatischer Skalierung entsprechend einer angegebenen Schriftart ab. (inherited from Form).
Public method | GetChildAtPoint | (Overloaded) Ruft das untergeordnete Steuerelement ab, das sich an den angegebenen Koordinaten befindet, und gibt an, ob untergeordnete Steuerelemente eines bestimmten Typs ignoriert werden sollen. (inherited from Control).
Public method | GetContainerControl | Gibt das nächste ContainerControl aufwärts in der Kette übergeordneter Steuerelemente des Steuerelements zurück. (inherited from Control).
Public method | GetLifetimeService | Ruft das aktuelle Lebensdauerdienstobjekt ab, das die Lebensdauerrichtlinien für diese Instanz steuert. (inherited from MarshalByRefObject).
Public method | GetNextControl | Ruft das nächste oder vorherige Steuerelement in der Aktivierreihenfolge untergeordneter Steuerelemente ab. (inherited from Control).
Public method | GetPreferredSize | Ruft die Größe eines rechteckigen Bereichs ab, in den ein Steuerelement eingefügt werden kann. (inherited from Control).
Public method | Hide | Verbirgt das Steuerelement vor dem Benutzer. (inherited from Control).
Public method | InitializeLifetimeService | Ruft ein Lebensdauerdienstobjekt ab, mit dem die Lebensdauerrichtlinien für diese Instanz gesteuert werden können. (inherited from MarshalByRefObject).
Public method | Invalidate | (Overloaded) Erklärt den angegebenen Bereich des Steuerelements für ungültig, indem es diesen dem Aktualisierungsbereich des Steuerelements hinzufügt. Dies ist der Bereich, der beim nächsten Zeichnenvorgang neu gezeichnet wird. Außerdem wird veranlasst, dass eine Zeichnenmeldung an das Steuerelement gesendet wird. (inherited from Control).
Public method | Invoke | (Overloaded) Führt den angegebenen Delegaten für den Thread aus, der das dem Steuerelement zugrunde liegende Fensterhandle besitzt. (inherited from Control).
 | IsKeyLocked | Bestimmt, ob die FESTSTELLTASTE, NUM oder ROLLEN aktiviert ist. (inherited from Control).
 | IsMnemonic | Bestimmt, ob das angegebene Zeichen das mnemonische Zeichen ist, das dem Steuerelement in der angegebenen Zeichenfolge zugewiesen wurde. (inherited from Control).
Public method | LayoutMdi | Ordnet die untergeordneten MDI (Multiple Document Interface)-Formulare im übergeordneten MDI-Formular an. (inherited from Form).
Public method | PerformAutoScale | Führt eine Skalierung für das Containersteuerelement und die dazugehörigen untergeordneten Elemente aus. (inherited from ContainerControl).
Public method | PerformLayout | (Overloaded) Erzwingt die Anwendung von Layoutlogik durch das Steuerelement auf sämtliche diesem untergeordneten Steuerelemente. (inherited from Control).
Public method | PointToClient | Rechnet die Position des angegebenen Bildschirmpunkts in Clientkoordinaten um. (inherited from Control).
Public method | PointToScreen | Rechnet die Position des angegebenen Clientpunkts in Bildschirmkoordinaten um. (inherited from Control).
Public method | PreProcessControlMessage | Führt eine Vorverarbeitung der Tastatur- oder Eingabemeldungen in der Nachrichtenschleife aus, bevor sie gesendet werden. (inherited from Control).
Public method | PreProcessMessage | Führt eine Vorverarbeitung der Tastatur- oder Eingabemeldungen in der Nachrichtenschleife aus, bevor sie gesendet werden. (inherited from Control).
Public method | RectangleToClient | Berechnet die Größe und die Position des angegebenen Bildschirmrechtecks in Clientkoordinaten. (inherited from Control).
Public method | RectangleToScreen | Berechnet die Größe und die Position des angegebenen Clientrechtecks in Bildschirmkoordinaten. (inherited from Control).
Public method | Refresh | Erzwingt, dass das Steuerelement seinen Clientbereich für ungültig erklärt und sich sowie alle untergeordneten Steuerelemente sofort selbst neu zeichnet. (inherited from Control).
Public method | RemoveOwnedForm | Entfernt ein Formular aus dem Besitzerformular. (inherited from Form).
Public method | ResetBackColor | Setzt die BackColor-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResetBindings | Führt dazu, dass in ein an BindingSource gebundenes Steuerelement alle Elemente in der Liste erneut eingelesen und ihre angezeigten Werte aktualisiert werden. (inherited from Control).
Public method | ResetCursor | Setzt die Cursor-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResetFont | Setzt die Font-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResetForeColor | Setzt die ForeColor-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResetImeMode | Setzt die ImeMode-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResetRightToLeft | Setzt die RightToLeft-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResetText | Setzt die Text-Eigenschaft auf den Standardwert zurück. (inherited from Control).
Public method | ResumeLayout | (Overloaded) Nimmt die übliche Layoutlogik wieder auf. (inherited from Control).
Public method | Scale | (Overloaded) Skaliert das Steuerelement und alle untergeordneten Steuerelemente. (inherited from Control).
Public method | ScrollControlIntoView | Führt einen Bildlauf durch, um das angegebene untergeordnete Steuerelement in einem Steuerelement anzuzeigen, für das der automatische Bildlauf aktiviert ist. (inherited from ScrollableControl).
Public method | SelectNextControl | Aktiviert das nächste Steuerelement. (inherited from Control).
Public method | SendToBack | Sendet das Steuerelement ans Ende der z-Reihenfolge. (inherited from Control).
Public method | SetAutoScrollMargin | Legt die Größe der AutoBildlaufränder fest. (inherited from ScrollableControl).
Public method | SetBounds | (Overloaded) Legt die Begrenzungen des Steuerelements auf die angegebene Position und Größe fest. (inherited from Control).
Public method | SetDesktopBounds | Legt die Begrenzungen des Formulars in Desktopkoordinaten fest. (inherited from Form).
Public method | SetDesktopLocation | Legt die Position des Formulars in Desktopkoordinaten fest. (inherited from Form).
Public method | Show | (Overloaded) Zeigt dem Benutzer das Formular mit dem angegebenen Besitzer an. (inherited from Form).
Public method | ShowDialog | (Overloaded) Zeigt das Formular als modales Dialogfeld an, wobei das derzeit aktive Fenster als Besitzer festgelegt ist. (inherited from Form).
Supported by the .NET Compact Framework. | SortNodes |
Public method | SuspendLayout | Unterbricht vorübergehend die Layoutlogik für das Steuerelement. (inherited from Control).
Public method | ToString | Ruft eine Zeichenfolge ab, die die aktuelle Instanz des Formulars darstellt. (inherited from Form).
Public method | Update | Bewirkt, dass das Steuerelement die für ungültig erklärten Bereiche im Clientbereich neu zeichnet. (inherited from Control).
Public method | Validate | (Overloaded) Überprüft den Wert des Steuerelements, das den Fokus verliert, indem das Validating-Ereignis und das Validated-Ereignis in dieser Reihenfolge ausgelöst werden. (inherited from ContainerControl).
Public method | ValidateChildren | (Overloaded) (inherited from Form).
Top

Expand image Protected Methods

 | Name | Description
Protected method | ActivateMdiChild | Aktiviert das untergeordnete MDI-Element eines Formulars. (inherited from Form).
Protected method | AdjustFormScrollbars | Passt die Schiebeleisten im Container anhand der aktuellen Positionen der Steuerelemente und des aktuell ausgewählten Steuerelements an. (inherited from Form).
Protected method | ApplyAutoScaling | Obsolete. Ändert die Größe des Formulars entsprechend dem aktuellen Wert der AutoScaleBaseSize-Eigenschaft und der Größe der aktuellen Schriftart. (inherited from Form).
Protected method | CenterToParent | Zentriert die Position des Formulars innerhalb der Begrenzungen des übergeordneten Formulars. (inherited from Form).
Protected method | CenterToScreen | Zentriert das Formular für den aktuellen Bildschirm. (inherited from Form).
Protected method | CreateAccessibilityInstance | Erstellt ein neues Objekt für die Barrierefreiheit für das Steuerelement. (inherited from Control).
Protected method | CreateControlsInstance | (inherited from Form).
Protected method | CreateHandle | Erstellt das Handle für das Formular.Wenn eine abgeleitete Klasse diese Funktion überschreibt, muss sie die Basisimplementierung aufrufen. (inherited from Form).
Protected method | DefWndProc | (inherited from Form).
Protected method | DestroyHandle | Löscht das mit dem Steuerelement verknüpfte Handle. (inherited from Control).
Supported by the .NET Compact Framework. | Dispose | (Overloaded) Gibt die von Form verwendeten Ressourcen (mit Ausnahme des Speichers) frei.
Protected method | Finalize | Gibt nicht verwaltete Ressourcen frei und führt andere Bereinigungsvorgänge durch, bevor die Component durch die Garbage Collection wieder zugänglich gemacht wird. (inherited from Component).
Protected method | GetAccessibilityObjectById | Ruft das angegebene AccessibleObject ab. (inherited from Control).
Protected method | GetAutoSizeMode | Ruft einen Wert ab, der angibt, wie sich ein Steuerelement verhält, wenn seine AutoSize-Eigenschaft aktiviert wird. (inherited from Control).
Protected method | GetScaledBounds | (inherited from Form).
Protected method | GetScrollState | Bestimmt, ob das angegebene Flag festgelegt wurde. (inherited from ScrollableControl).
Protected method | GetService | Gibt ein Objekt zurück, das einen von der Component oder von deren Container bereitgestellten Dienst darstellt. (inherited from Component).
Protected method | GetStyle | Ruft den Wert für das angegebene Steuerelement-Formatbit für das Steuerelement ab. (inherited from Control).
Protected method | GetTopLevel | Bestimmt, ob es sich bei dem Steuerelement um ein Steuerelement der obersten Ebene handelt. (inherited from Control).
Protected method | InitLayout | Wird nach dem Hinzufügen des Steuerelements zu einem anderen Container aufgerufen. (inherited from Control).
Protected method | InvokeGotFocus | Löst das GotFocus-Ereignis für das angegebene Steuerelement aus. (inherited from Control).
Protected method | InvokeLostFocus | Löst das LostFocus-Ereignis für das angegebene Steuerelement aus. (inherited from Control).
Protected method | InvokeOnClick | Löst das Click-Ereignis für das angegebene Steuerelement aus. (inherited from Control).
Protected method | InvokePaint | Löst das Paint-Ereignis für das angegebene Steuerelement aus. (inherited from Control).
Protected method | InvokePaintBackground | Löst das PaintBackground-Ereignis für das angegebene Steuerelement aus. (inherited from Control).
Protected method | IsInputChar | Bestimmt, ob ein Zeichen ein vom Steuerelement erkanntes Eingabezeichen ist. (inherited from Control).
Protected method | IsInputKey | Bestimmt, ob es sich bei der angegebenen Taste um eine normale oder um eine besondere Taste handelt, für die eine Vorverarbeitung erforderlich ist. (inherited from Control).
Protected method | MemberwiseClone | Erstellt eine flache Kopie des aktuellen MarshalByRefObject-Objekts. (inherited from MarshalByRefObject).
Protected method | NotifyInvalidate | Löst das Invalidated-Ereignis aus, wobei ein angegebener Bereich des Steuerelements für ungültig erklärt wird. (inherited from Control).
Protected method | OnActivated | Löst das Activated-Ereignis aus. (inherited from Form).
Protected method | OnAutoSizeChanged | Löst das AutoSizeChanged-Ereignis aus. (inherited from Control).
Protected method | OnAutoValidateChanged | Löst das AutoValidateChanged-Ereignis aus. (inherited from ContainerControl).
Protected method | OnBackColorChanged | Löst das BackColorChanged-Ereignis aus. (inherited from Control).
Protected method | OnBackgroundImageChanged | Löst das BackgroundImageChanged-Ereignis aus. (inherited from Form).
Protected method | OnBackgroundImageLayoutChanged | Löst das BackgroundImageLayoutChanged-Ereignis aus. (inherited from Form).
Protected method | OnBindingContextChanged | Löst das BindingContextChanged-Ereignis aus. (inherited from Control).
Protected method | OnCausesValidationChanged | Löst das CausesValidationChanged-Ereignis aus. (inherited from Control).
Protected method | OnChangeUICues | Löst das ChangeUICues-Ereignis aus. (inherited from Control).
Protected method | OnClick | Löst das Click-Ereignis aus. (inherited from Control).
Protected method | OnClientSizeChanged | Löst das ClientSizeChanged-Ereignis aus. (inherited from Control).
Protected method | OnClosed | Löst das Closed-Ereignis aus. (inherited from Form).
Protected method | OnClosing | Löst das Closing-Ereignis aus. (inherited from Form).
Protected method | OnContextMenuChanged | Löst das ContextMenuChanged-Ereignis aus. (inherited from Control).
Protected method | OnContextMenuStripChanged | Löst das ContextMenuStripChanged-Ereignis aus. (inherited from Control).
Protected method | OnControlAdded | Löst das ControlAdded-Ereignis aus. (inherited from Control).
Protected method | OnControlRemoved | Löst das ControlRemoved-Ereignis aus. (inherited from Control).
Protected method | OnCreateControl | Löst das CreateControl-Ereignis aus. (inherited from Form).
Protected method | OnCursorChanged | Löst das CursorChanged-Ereignis aus. (inherited from Control).
Protected method | OnDeactivate | Löst das Deactivate-Ereignis aus. (inherited from Form).
Protected method | OnDockChanged | Löst das DockChanged-Ereignis aus. (inherited from Control).
Protected method | OnDoubleClick | Löst das DoubleClick-Ereignis aus. (inherited from Control).
Protected method | OnDragDrop | Löst das DragDrop-Ereignis aus. (inherited from Control).
Protected method | OnDragEnter | Löst das DragEnter-Ereignis aus. (inherited from Control).
Protected method | OnDragLeave | Löst das DragLeave-Ereignis aus. (inherited from Control).
Protected method | OnDragOver | Löst das DragOver-Ereignis aus. (inherited from Control).
Protected method | OnEnabledChanged | (inherited from Form).
Protected method | OnEnter | Löst das Enter-Ereignis aus. (inherited from Form).
Protected method | OnFontChanged | (inherited from Form).
Protected method | OnForeColorChanged | Löst das ForeColorChanged-Ereignis aus. (inherited from Control).
Protected method | OnFormClosed | Löst das FormClosed-Ereignis aus. (inherited from Form).
Protected method | OnFormClosing | Löst das FormClosing-Ereignis aus. (inherited from Form).
Protected method | OnGiveFeedback | Löst das GiveFeedback-Ereignis aus. (inherited from Control).
Protected method | OnGotFocus | Löst das GotFocus-Ereignis aus. (inherited from Control).
Protected method | OnHandleCreated | (inherited from Form).
Protected method | OnHandleDestroyed | (inherited from Form).
Protected method | OnHelpButtonClicked | Löst das HelpButtonClicked-Ereignis aus. (inherited from Form).
Protected method | OnHelpRequested | Löst das HelpRequested-Ereignis aus. (inherited from Control).
Protected method | OnImeModeChanged | Löst das ImeModeChanged-Ereignis aus. (inherited from Control).
Protected method | OnInputLanguageChanged | Löst das InputLanguageChanged-Ereignis aus. (inherited from Form).
Protected method | OnInputLanguageChanging | Löst das InputLanguageChanging-Ereignis aus. (inherited from Form).
Protected method | OnInvalidated | Löst das Invalidated-Ereignis aus. (inherited from Control).
Protected method | OnKeyDown | Löst das KeyDown-Ereignis aus. (inherited from Control).
Protected method | OnKeyPress | Löst das KeyPress-Ereignis aus. (inherited from Control).
Protected method | OnKeyUp | Löst das KeyUp-Ereignis aus. (inherited from Control).
Protected method | OnLayout | Löst das Layout-Ereignis aus. (inherited from Form).
Protected method | OnLeave | Löst das Leave-Ereignis aus. (inherited from Control).
Protected method | OnLoad | Löst das Load-Ereignis aus. (inherited from Form).
Protected method | OnLocationChanged | Löst das LocationChanged-Ereignis aus. (inherited from Control).
Protected method | OnLostFocus | Löst das LostFocus-Ereignis aus. (inherited from Control).
Protected method | OnMarginChanged | Löst das MarginChanged-Ereignis aus. (inherited from Control).
Protected method | OnMaximizedBoundsChanged | Löst das MaximizedBoundsChanged-Ereignis aus. (inherited from Form).
Protected method | OnMaximumSizeChanged | Löst das MaximumSizeChanged-Ereignis aus. (inherited from Form).
Protected method | OnMdiChildActivate | Löst das MdiChildActivate-Ereignis aus. (inherited from Form).
Protected method | OnMenuComplete | Löst das MenuComplete-Ereignis aus. (inherited from Form).
Protected method | OnMenuStart | Löst das MenuStart-Ereignis aus. (inherited from Form).
Protected method | OnMinimumSizeChanged | Löst das MinimumSizeChanged-Ereignis aus. (inherited from Form).
Protected method | OnMouseCaptureChanged | Löst das MouseCaptureChanged-Ereignis aus. (inherited from Control).
Protected method | OnMouseClick | Löst das MouseClick-Ereignis aus. (inherited from Control).
Protected method | OnMouseDoubleClick | Löst das MouseDoubleClick-Ereignis aus. (inherited from Control).
Protected method | OnMouseDown | Löst das MouseDown-Ereignis aus. (inherited from Control).
Protected method | OnMouseEnter | Löst das MouseEnter-Ereignis aus. (inherited from Control).
Protected method | OnMouseHover | Löst das MouseHover-Ereignis aus. (inherited from Control).
Protected method | OnMouseLeave | Löst das MouseLeave-Ereignis aus. (inherited from Control).
Protected method | OnMouseMove | Löst das MouseMove-Ereignis aus. (inherited from Control).
Protected method | OnMouseUp | Löst das MouseUp-Ereignis aus. (inherited from Control).
Protected method | OnMouseWheel | Löst das MouseWheel-Ereignis aus. (inherited from ScrollableControl).
Protected method | OnMove | Löst das Move-Ereignis aus. (inherited from Control).
Protected method | OnNotifyMessage | Benachrichtigt das Steuerelement über Windows-Meldungen. (inherited from Control).
Protected method | OnPaddingChanged | Löst das PaddingChanged-Ereignis aus. (inherited from ScrollableControl).
Protected method | OnPaint | (inherited from Form).
Protected method | OnPaintBackground | Zeichnet den Hintergrund des Steuerelements. (inherited from ScrollableControl).
Protected method | OnParentBackColorChanged | Löst das BackColorChanged-Ereignis aus, wenn sich der BackColor-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentBackgroundImageChanged | Löst das BackgroundImageChanged-Ereignis aus, wenn sich der BackgroundImage-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentBindingContextChanged | Löst das BindingContextChanged-Ereignis aus, wenn sich der BindingContext-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentChanged | (inherited from ContainerControl).
Protected method | OnParentCursorChanged | Löst das CursorChanged-Ereignis aus. (inherited from Control).
Protected method | OnParentEnabledChanged | Löst das EnabledChanged-Ereignis aus, wenn sich der Enabled-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentFontChanged | Löst das FontChanged-Ereignis aus, wenn sich der Font-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentForeColorChanged | Löst das ForeColorChanged-Ereignis aus, wenn sich der ForeColor-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentRightToLeftChanged | Löst das RightToLeftChanged-Ereignis aus, wenn sich der RightToLeft-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnParentVisibleChanged | Löst das VisibleChanged-Ereignis aus, wenn sich der Visible-Eigenschaftswert des Containers ändert, zu dem das Steuerelement gehört. (inherited from Control).
Protected method | OnPreviewKeyDown | Löst das PreviewKeyDown-Ereignis aus. (inherited from Control).
Protected method | OnPrint | Löst das Paint-Ereignis aus. (inherited from Control).
Protected method | OnQueryContinueDrag | Löst das QueryContinueDrag-Ereignis aus. (inherited from Control).
Protected method | OnRegionChanged | Löst das RegionChanged-Ereignis aus. (inherited from Control).
Protected method | OnResize | (inherited from Form).
Protected method | OnResizeBegin | Löst das ResizeBegin-Ereignis aus. (inherited from Form).
Protected method | OnResizeEnd | Löst das ResizeEnd-Ereignis aus. (inherited from Form).
Protected method | OnRightToLeftChanged | (inherited from ScrollableControl).
Protected method | OnRightToLeftLayoutChanged | Löst das RightToLeftLayoutChanged-Ereignis aus. (inherited from Form).
Protected method | OnScroll | Löst das Scroll-Ereignis aus. (inherited from ScrollableControl).
Protected method | OnShown | Löst das Shown-Ereignis aus. (inherited from Form).
Protected method | OnSizeChanged | Löst das SizeChanged-Ereignis aus. (inherited from Control).
Protected method | OnStyleChanged | (inherited from Form).
Protected method | OnSystemColorsChanged | Löst das SystemColorsChanged-Ereignis aus. (inherited from Control).
Protected method | OnTabIndexChanged | Löst das TabIndexChanged-Ereignis aus. (inherited from Control).
Protected method | OnTabStopChanged | Löst das TabStopChanged-Ereignis aus. (inherited from Control).
Protected method | OnTextChanged | (inherited from Form).
Protected method | OnValidated | Löst das Validated-Ereignis aus. (inherited from Control).
Protected method | OnValidating | Löst das Validating-Ereignis aus. (inherited from Control).
Protected method | OnVisibleChanged | Löst das VisibleChanged-Ereignis aus. (inherited from Form).
Protected method | ProcessCmdKey | Verarbeitet eine Befehlstaste. (inherited from Form).
Protected method | ProcessDialogChar | Verarbeitet ein Dialogfeldzeichen. (inherited from Form).
Protected method | ProcessDialogKey | Verarbeitet eine Tastatureingabe im Dialogfeld. (inherited from Form).
Protected method | ProcessKeyEventArgs | Verarbeitet eine Tastenmeldung und generiert die entsprechenden Steuerelementereignisse. (inherited from Control).
Protected method | ProcessKeyPreview | (inherited from Form).
Protected method | ProcessTabKey | (inherited from Form).
Protected method | RaiseDragEvent | Löst das entsprechende Ziehereignis aus. (inherited from Control).
Protected method | RaiseKeyEvent | Löst das entsprechende Tastenereignis aus. (inherited from Control).
Protected method | RaiseMouseEvent | Löst das entsprechende Mausereignis aus. (inherited from Control).
Protected method | RaisePaintEvent | Löst das entsprechende Paint-Ereignis aus. (inherited from Control).
Protected method | RecreateHandle | Erzwingt ein erneutes Erstellen des Handles für das Steuerelement. (inherited from Control).
 | ReflectMessage | Reflektiert die angegebene Meldung an das Steuerelement, das an das angegebene Handle gebunden ist. (inherited from Control).
Protected method | ResetMouseEventArgs | Setzt das Steuerelement zurück, um das MouseLeave-Ereignis zu behandeln. (inherited from Control).
Protected method | RtlTranslateAlignment | (Overloaded) Konvertiert das angegebene HorizontalAlignment in das entsprechende HorizontalAlignment für die Unterstützung der Schriftrichtung von rechts nach links. (inherited from Control).
Protected method | RtlTranslateHorizontal | Konvertiert das angegebene HorizontalAlignment in das entsprechende HorizontalAlignment für die Unterstützung der Schriftrichtung von rechts nach links. (inherited from Control).
Protected method | RtlTranslateLeftRight | Konvertiert das angegebene LeftRightAlignment in das entsprechende LeftRightAlignment für die Unterstützung der Schriftrichtung von rechts nach links. (inherited from Control).
Protected method | ScaleControl | Skaliert Speicherort, Größe, Textabstand und Rand eines Steuerelements. (inherited from Form).
Protected method | ScaleCore | Führt die Skalierung des Formulars aus. (inherited from Form).
Protected method | ScrollToControl | Berechnet den Bildlauf-Offset zum angegebenen untergeordneten Steuerelement. (inherited from ScrollableControl).
Protected method | Select | (Overloaded) Aktiviert dieses Formular und wählt optional das nächste oder vorherige Steuerelement aus. (inherited from Form).
Protected method | SetAutoSizeMode | Legt einen Wert fest, der angibt, wie sich ein Steuerelement verhält, wenn seine AutoSize-Eigenschaft aktiviert wird. (inherited from Control).
Protected method | SetBoundsCore | (inherited from Form).
Protected method | SetClientSizeCore | Legt die Clientgröße des Formulars fest.Hiermit werden die Begrenzungen des Formulars so angepasst, dass die Clientgröße der angeforderten Größe entspricht. (inherited from Form).
Protected method | SetDisplayRectLocation | Positioniert das Anzeigefenster anhand des angegebenen Werts. (inherited from ScrollableControl).
Protected method | SetScrollState | Legt das angegebene Flag für den Bildlaufzustand fest. (inherited from ScrollableControl).
Protected method | SetStyle | Legt ein angegebenes ControlStyles-Flag auf true oder false fest. (inherited from Control).
Protected method | SetTopLevel | Legt das Steuerelement als Steuerelement der obersten Ebene fest. (inherited from Control).
Protected method | SetVisibleCore | (inherited from Form).
Protected method | SizeFromClientSize | Bestimmt die Größe des gesamten Steuerelements anhand der Höhe und Breite seines Clientbereichs. (inherited from Control).
Protected method | UpdateDefaultButton | Aktualisiert, welche Schaltfläche die Standardschaltfläche ist. (inherited from Form).
Protected method | UpdateStyles | Erzwingt ein erneutes Anwenden der zugewiesenen Formate auf das Steuerelement. (inherited from Control).
Protected method | UpdateZOrder | Aktualisiert das Steuerelement in der z-Reihenfolge des übergeordneten Elements. (inherited from Control).
Protected method | WndProc | (inherited from Form).
Top

Expand image Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Internal protected (Protected Friend) method | AccessibilityNotifyClients | (Overloaded) Benachrichtigt die Clientanwendungen für die Barrierefreiheit über die angegebenen AccessibleEvents für das angegebene untergeordnete Steuerelement. (inherited from Control).
Internal protected (Protected Friend) method | ProcessKeyMessage | Verarbeitet eine Tastaturmeldung. (inherited from Control).
Internal protected (Protected Friend) method | ProcessMnemonic | Verarbeitet ein mnemonisches Zeichen. (inherited from Form).
Internal protected (Protected Friend) method | RtlTranslateContent | Konvertiert das angegebene ContentAlignment in das entsprechende ContentAlignment für die Unterstützung der Schriftrichtung von rechts nach links. (inherited from Control).
Internal protected (Protected Friend) method | UpdateBounds | (Overloaded) Aktualisiert die Begrenzungen des Steuerelements mit der aktuellen Größe und Position. (inherited from Control).
Top

Expand image See Also

Reference

frmPrinterSettings_sik Class


frmPrinterSettings_sik.DefaultPrinterName Method

[image] [image] [image]

AllgFnkt_Plugin Reference
frmPrinterSettings_sik.DefaultPrinterName Method
See Also

Assembly: AllgFnkt_Plugin (in AllgFnkt_Plugin.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Function DefaultPrinterName() As String
C#
public static string DefaultPrinterName()
C++
public:
static String^ DefaultPrinterName()
JScript
public static function DefaultPrinterName() : String;

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPrinterSettings_sik Class
frmPrinterSettings_sik Members


frmPrinterSettings_sik.Dispose Method

[image] [image] [image]

AllgFnkt_Plugin Reference
frmPrinterSettings_sik.Dispose Method
frmPrinterSettings_sik Class See Also

Gibt die von Form verwendeten Ressourcen (mit Ausnahme des Speichers) frei.

Expand image Overload List

Name | Description
Dispose(bool) | Gibt die von Form verwendeten Ressourcen (mit Ausnahme des Speichers) frei.
Dispose | Gibt sämtliche von der Component verwendeten Ressourcen frei. (System.ComponentModel.Component).

Expand image See Also

Reference

frmPrinterSettings_sik Class
frmPrinterSettings_sik Members


frmPrinterSettings_sik.SortNodes Method

[image] [image] [image]

AllgFnkt_Plugin Reference
frmPrinterSettings_sik.SortNodes Method
See Also

Assembly: AllgFnkt_Plugin (in AllgFnkt_Plugin.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub SortNodes( _
   ByVal NodesCollection As TreeNodeCollection, _
   Optional ByVal Ascending As Boolean = True _
)
C#
public System.Void SortNodes(
   TreeNodeCollection NodesCollection,
   bool Ascending
)
C++
public:
System::Void SortNodes(
   TreeNodeCollection^ NodesCollection,
   bool Ascending
)
JScript
public function SortNodes(
    NodesCollection : TreeNodeCollection,
    Ascending : boolean
);

Parameters

NodesCollection

Type: TreeNodeCollection

Required.

Ascending

Type: bool

If set to true, then ; otherwise, .

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPrinterSettings_sik Class
frmPrinterSettings_sik Members


frmPrinterSettings_sik Events

[image] [image] [image]

AllgFnkt_Plugin Reference
frmPrinterSettings_sik Events
frmPrinterSettings_sik Class See Also

Expand image Public Events

 | Name | Description
Public event | Activated | Tritt ein, wenn das Formular im Code oder vom Benutzer aktiviert wird. (inherited from Form).
Public event | AutoSizeChanged | Tritt ein, wenn sich die AutoSize-Eigenschaft ändert. (inherited from Form).
Public event | AutoValidateChanged | Tritt ein, wenn sich die AutoValidate-Eigenschaft ändert. (inherited from Form).
Public event | BackColorChanged | Tritt ein, wenn sich der Wert der BackColor-Eigenschaft ändert. (inherited from Control).
Public event | BackgroundImageChanged | Tritt ein, wenn sich der Wert der BackgroundImage-Eigenschaft ändert. (inherited from Control).
Public event | BackgroundImageLayoutChanged | Tritt ein, wenn sich die BackgroundImageLayout-Eigenschaft ändert. (inherited from Control).
Public event | BindingContextChanged | Tritt ein, wenn sich der Wert der BindingContext-Eigenschaft ändert. (inherited from Control).
Public event | CausesValidationChanged | Tritt auf, wenn der Wert der CausesValidation-Eigenschaft geändert wird. (inherited from Control).
Public event | ChangeUICues | Tritt ein, wenn sich der Fokus-Cue oder der Tastatur-Cue der Benutzeroberfläche ändert. (inherited from Control).
Public event | Click | Tritt beim Klicken auf das Steuerelement ein. (inherited from Control).
Public event | ClientSizeChanged | Tritt ein, wenn sich der Wert der ClientSize-Eigenschaft ändert. (inherited from Control).
Public event | Closed | Tritt ein, wenn das Formular geschlossen ist. (inherited from Form).
Public event | Closing | Tritt beim Schließen des Formulars ein. (inherited from Form).
Public event | ContextMenuChanged | Tritt ein, wenn sich der Wert der ContextMenu-Eigenschaft ändert. (inherited from Control).
Public event | ContextMenuStripChanged | Tritt ein, wenn sich der Wert der ContextMenuStrip-Eigenschaft ändert. (inherited from Control).
Public event | ControlAdded | Tritt ein, wenn der ControlCollection ein neues Steuerelement hinzugefügt wird. (inherited from Control).
Public event | ControlRemoved | Tritt beim Entfernen des Steuerelements aus der ControlCollection ein. (inherited from Control).
Public event | CursorChanged | Tritt ein, wenn sich der Wert der Cursor-Eigenschaft ändert. (inherited from Control).
Public event | Deactivate | Tritt ein, wenn das Formular den Fokus verliert und nicht mehr das aktive Formular ist. (inherited from Form).
Public event | Disposed | Tritt ein, wenn die Komponente durch einen Aufruf der Dispose-Methode freigegeben wird. (inherited from Component).
Public event | DockChanged | Tritt ein, wenn sich der Wert der Dock-Eigenschaft ändert. (inherited from Control).
Public event | DoubleClick | Tritt beim Doppelklicken auf das Steuerelement ein. (inherited from Control).
Public event | DragDrop | Tritt ein, wenn eine Drag & Drop-Operation beendet wurde. (inherited from Control).
Public event | DragEnter | Tritt ein, wenn ein Objekt in den Bereich des Steuerelements gezogen wird. (inherited from Control).
Public event | DragLeave | Tritt ein, wenn ein Objekt aus dem Bereich des Steuerelements gezogen wird. (inherited from Control).
Public event | DragOver | Tritt ein, wenn ein Objekt über die Begrenzungen des Steuerelements gezogen wird. (inherited from Control).
Public event | EnabledChanged | Tritt ein, wenn sich der Enabled-Eigenschaftswert geändert hat. (inherited from Control).
Public event | Enter | Tritt beim Eintreten in den Bereich des Steuerelements ein. (inherited from Control).
Public event | FontChanged | Tritt ein, wenn sich der Font-Eigenschaftswert ändert. (inherited from Control).
Public event | ForeColorChanged | Tritt ein, wenn sich der ForeColor-Eigenschaftswert ändert. (inherited from Control).
Public event | FormClosed | Tritt ein, nachdem das Formular geschlossen wurde. (inherited from Form).
Public event | FormClosing | Tritt ein, bevor das Formular geschlossen wird. (inherited from Form).
Public event | GiveFeedback | Tritt während eines Ziehvorgangs ein. (inherited from Control).
Public event | GotFocus | Tritt ein, wenn das Steuerelement den Fokus erhält. (inherited from Control).
Public event | HandleCreated | Tritt ein, wenn ein Handle für das Steuerelement erstellt wird. (inherited from Control).
Public event | HandleDestroyed | Tritt ein, wenn das Handle des Steuerelements gerade gelöscht wird. (inherited from Control).
Public event | HelpButtonClicked | Tritt beim Klicken auf die Schaltfläche Hilfe ein. (inherited from Form).
Public event | HelpRequested | Tritt ein, wenn der Benutzer die Hilfe für ein Steuerelement anfordert. (inherited from Control).
Public event | ImeModeChanged | Tritt ein, wenn die ImeMode-Eigenschaft geändert wurde. (inherited from Control).
Public event | InputLanguageChanged | Tritt ein, nachdem die Eingabesprache des Formulars geändert wurde. (inherited from Form).
Public event | InputLanguageChanging | Tritt ein, wenn der Benutzer versucht, die Eingabesprache für das Formular zu ändern. (inherited from Form).
Public event | Invalidated | Tritt ein, wenn die Anzeige eines Steuerelements neu gezeichnet werden muss. (inherited from Control).
Public event | KeyDown | Tritt ein, wenn eine Taste gedrückt wird, während das Steuerelement den Fokus hat. (inherited from Control).
Public event | KeyPress | Tritt ein, wenn eine Taste gedrückt wird, während das Steuerelement den Fokus hat. (inherited from Control).
Public event | KeyUp | Tritt ein, wenn eine Taste losgelassen wird, während das Steuerelement den Fokus hat. (inherited from Control).
Public event | Layout | Tritt ein, wenn ein Steuerelement seine untergeordneten Steuerelemente neu positionieren muss. (inherited from Control).
Public event | Leave | Tritt ein, wenn der Eingabefokus das Steuerelement verlässt. (inherited from Control).
Public event | Load | Tritt ein, bevor ein Formular erstmals angezeigt wird. (inherited from Form).
Public event | LocationChanged | Tritt ein, wenn sich der Location-Eigenschaftswert geändert hat. (inherited from Control).
Public event | LostFocus | Tritt ein, wenn das Steuerelement den Fokus verliert. (inherited from Control).
Public event | MarginChanged | Tritt ein, wenn sich die Margin-Eigenschaft ändert. (inherited from Form).
Public event | MaximizedBoundsChanged | Tritt ein, wenn sich der Wert der MaximizedBounds-Eigenschaft geändert hat. (inherited from Form).
Public event | MaximumSizeChanged | Tritt ein, wenn sich der Wert der MaximumSize-Eigenschaft geändert hat. (inherited from Form).
Public event | MdiChildActivate | Tritt ein, wenn ein untergeordnetes MDI (Multiple Document Interface)-Formular in einer MDI-Anwendung aktiviert oder geschlossen wird. (inherited from Form).
Public event | MenuComplete | Tritt ein, wenn das Menü eines Formulars den Fokus verliert. (inherited from Form).
Public event | MenuStart | Tritt ein, wenn das Menü eines Formulars den Fokus erhält. (inherited from Form).
Public event | MinimumSizeChanged | Tritt ein, wenn sich der Wert der MinimumSize-Eigenschaft geändert hat. (inherited from Form).
Public event | MouseCaptureChanged | Tritt ein, wenn das Steuerelement beginnt oder aufhört, Mauseingaben aufzufangen. (inherited from Control).
Public event | MouseClick | Tritt ein, wenn mit der Maus auf das Steuerelement geklickt wird. (inherited from Control).
Public event | MouseDoubleClick | Tritt ein, wenn mit der Maus ein Doppelklick auf das Steuerelement ausgeführt wird. (inherited from Control).
Public event | MouseDown | Tritt ein, wenn sich der Mauszeiger über dem Steuerelement befindet und eine Maustaste gedrückt wird. (inherited from Control).
Public event | MouseEnter | Tritt ein, wenn der Mauszeiger in den Bereich des Steuerelements eintritt. (inherited from Control).
Public event | MouseHover | Tritt ein, wenn der Mauszeiger auf dem Steuerelement verbleibt. (inherited from Control).
Public event | MouseLeave | Tritt ein, wenn der Mauszeiger den Bereich des Steuerelements verlässt. (inherited from Control).
Public event | MouseMove | Tritt ein, wenn der Mauszeiger über dem Steuerelement bewegt wird. (inherited from Control).
Public event | MouseUp | Tritt ein, wenn sich der Mauszeiger über dem Steuerelement befindet und eine Maustaste losgelassen wird. (inherited from Control).
Public event | MouseWheel | Tritt ein, wenn das Mausrad bewegt wird, während das Steuerelement den Fokus besitzt. (inherited from Control).
Public event | Move | Tritt beim Verschieben des Steuerelements ein. (inherited from Control).
Public event | PaddingChanged | Tritt ein, wenn der Abstand des Steuerelements geändert wird. (inherited from Control).
Public event | Paint | Tritt ein, wenn das Steuerelement neu gezeichnet wird. (inherited from Control).
Public event | ParentChanged | Tritt ein, wenn sich der Parent-Eigenschaftswert ändert. (inherited from Control).
Public event | PreviewKeyDown | Tritt vor dem KeyDown-Ereignis ein, wenn eine Taste gedrückt wird, während dieses Steuerelement den Fokus besitzt. (inherited from Control).
Public event | QueryAccessibilityHelp | Tritt ein, wenn AccessibleObject Hilfe für barrierefreie Anwendungen bereitstellt. (inherited from Control).
Public event | QueryContinueDrag | Tritt während eines Drag & Drop-Vorgangs ein. Dadurch kann die Quelle des Ziehvorgangs bestimmen, ob der Drag & Drop-Vorgang abgebrochen werden soll. (inherited from Control).
Public event | RegionChanged | Tritt ein, wenn sich der Wert der Region-Eigenschaft ändert. (inherited from Control).
Public event | Resize | Tritt beim Ändern der Größe des Steuerelements ein. (inherited from Control).
Public event | ResizeBegin | Tritt ein, wenn ein Formular in den Größenänderungsmodus wechselt. (inherited from Form).
Public event | ResizeEnd | Tritt ein, wenn ein Formular den Größenänderungsmodus verlässt. (inherited from Form).
Public event | RightToLeftChanged | Tritt ein, wenn sich der RightToLeft-Eigenschaftswert ändert. (inherited from Control).
Public event | RightToLeftLayoutChanged | Tritt ein, nachdem sich der Wert der RightToLeftLayout-Eigenschaft geändert hat. (inherited from Form).
Public event | Scroll | Tritt ein, wenn vom Benutzer oder von Code ein Bildlauf durch den Clientbereich durchgeführt wird. (inherited from ScrollableControl).
Public event | Shown | Tritt immer dann ein, wenn das Formular erstmalig angezeigt wird. (inherited from Form).
Public event | SizeChanged | Tritt ein, wenn sich der Size-Eigenschaftswert ändert. (inherited from Control).
Public event | StyleChanged | Tritt ein, wenn sich das Format des Steuerelements ändert. (inherited from Control).
Public event | SystemColorsChanged | Tritt ein, wenn sich die Systemfarben ändern. (inherited from Control).
Public event | TabIndexChanged | Tritt ein, wenn sich der Wert der TabIndex-Eigenschaft ändert. (inherited from Form).
Public event | TabStopChanged | Tritt ein, wenn sich die TabStop-Eigenschaft ändert. (inherited from Form).
Public event | TextChanged | Tritt ein, wenn sich der Text-Eigenschaftswert ändert. (inherited from Control).
Public event | Validated | Tritt ein, wenn das Steuerelement die Überprüfung abgeschlossen hat. (inherited from Control).
Public event | Validating | Tritt ein, während das Steuerelement eine Überprüfung durchführt. (inherited from Control).
Public event | VisibleChanged | Tritt ein, wenn sich der Visible-Eigenschaftswert ändert. (inherited from Control).
Top

Expand image See Also

Reference

frmPrinterSettings_sik Class


frmPrinterSettings.Dispose Method

[image] [image] [image]

AllgFnkt_Plugin Reference
frmPrinterSettings.Dispose Method
See Also

Gibt die von Form verwendeten Ressourcen (mit Ausnahme des Speichers) frei.
Assembly: AllgFnkt_Plugin (in AllgFnkt_Plugin.dll)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
C#
[System.Diagnostics.DebuggerNonUserCode()]
protected override System.Void Dispose(
   bool disposing
)
C++
[System.Diagnostics.DebuggerNonUserCode()]
protected:
System::Void Dispose(
   bool disposing
)
JScript
protected
   System.Diagnostics.DebuggerNonUserCode()
function Dispose(
    disposing : boolean
);

Parameters

disposing

Type: bool

true, um sowohl verwaltete als auch nicht verwaltete Ressourcen freizugeben, false, wenn ausschließlich nicht verwaltete Ressourcen freigegeben werden sollen.

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPrinterSettings Class
frmPrinterSettings Members


frmPrinterSettings_sik.Dispose Method

[image] [image] [image]

AllgFnkt_Plugin Reference
frmPrinterSettings_sik.Dispose Method
See Also

Gibt die von Form verwendeten Ressourcen (mit Ausnahme des Speichers) frei.
Assembly: AllgFnkt_Plugin (in AllgFnkt_Plugin.dll)

Expand image Syntax

Visual Basic (Declaration)
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
C#
[System.Diagnostics.DebuggerNonUserCode()]
protected override System.Void Dispose(
   bool disposing
)
C++
[System.Diagnostics.DebuggerNonUserCode()]
protected:
System::Void Dispose(
   bool disposing
)
JScript
protected
   System.Diagnostics.DebuggerNonUserCode()
function Dispose(
    disposing : boolean
);

Parameters

disposing

Type: bool

true, um sowohl verwaltete als auch nicht verwaltete Ressourcen freizugeben, false, wenn ausschließlich nicht verwaltete Ressourcen freigegeben werden sollen.

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 2.0, 1.0

XNA Framework

Supported in: 1.0

Expand image See Also

Reference

frmPrinterSettings_sik Class
frmPrinterSettings_sik Members